Дисковые квоты

Дисковые квоты используются для наблюдения за использованием дискового пространства на томах NTFS и ограничения его использования.

  • До установки дисковых квот просмотрите раздел Контрольный список: установка дисковых квот.
  • Советы по использованию дисковых квот см. в разделе Советы и рекомендации.
  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Общие сведения см. в разделе Основные понятия.
  • Инструкции по устранению неполадок содержатся в разделе Устранение неполадок.


Контрольный список: Установка дисковых квот

Действие | Справочные сведения
Ознакомьтесь с основными понятиями. | Общие сведения о дисковых квотах
Убедитесь, что входите в группу Администраторы. | Сведения об учетных записях пользователей
Включите дисковые квоты. | Включение дисковых квот
Задайте дисковые квоты для томов NTFS. | Задание значений квоты для использования по умолчанию


Советы и рекомендации

  • Применение соответствующих предельных дисковых квот
    Применяйте предельные дисковые квоты в соответствии с реальными потребностями места на диске пользователями. Начните с классификации всех пользователей по ожидаемым потребностям места на диске (например, пользователи, работающие со сканированными фотографиями или графикой, могут использовать много дискового пространства). Затем упорядочьте тома по выделенным классам и используйте дисковые квоты для ограничения дискового пространства, доступного пользователям на каждом томе.
  • Установка пределов по умолчанию
    Установите умеренные ограничения пределов по умолчанию для всех учетных записей пользователей и потом увеличьте эти пределы для пользователей, работающих с большими файлами. Для небольшого числа пользователей лучше увеличить предельные дисковые квоты, чем заставлять некоторых пользователей работать с предельной квотой, которая меньше необходимой. Политики пользователей занимают не менее 2 МБ дискового пространства, поэтому пределы пределы по умолчанию для всех пользователей должны превышать 2 МБ.
  • Разрешение увеличения предельной квоты
    Установите предельные квоты на уровне, позволяющем увеличивать объем используемого дискового пространства. При наличии оснований для увеличения квоты, увеличьте ее в процентах от текущей величины.
  • Удаление пользовательских записей квот
    Если пользователю больше не нужно использовать определенный том (например, если он уволен), то удалите пользовательскую запись квоты для тома и удалите или переместите файлы пользователя, либо смените владельца любых файлов пользователя. Это позволит исключить использование места на диске ненужными файлами.
  • Ограничение установок для администраторов
    Если включены параметры дисковой квоты на томе, где установлены Windows и другие программы, ограничьте установки компонентов Windows и программ для членов группы Администраторы на локальном компьютере. Поскольку для членов группы администраторов нет предельной квоты, то установка ими компонентов и программ ограничит предельные квоты для пользователей.


Инструкции

  • Управление дисковыми квотами на удаленном компьютере
  • Управление дисковыми квотами
  • Управление записями дисковых квот


Управление дисковыми квотами

  • Просмотр параметров дисковой квоты
  • Включение дисковых квот
  • Отключение дисковых квот
  • Запрет выделения места на диске для пользователей, превысивших заданный предел
  • Задание значений квоты для использования по умолчанию
  • Управление дисковыми квотами на удаленном компьютере


Просмотр параметров дисковой квоты

Рисунок Microsoft Windows

Чтобы просмотреть параметры дисковой квоты

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, параметры дисковой квоты которого требуется просмотреть, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку Квота.

Примечания

  • XOX
  • XOX


Включение дисковых квот

Рисунок Microsoft Windows

Чтобы включить дисковые квоты

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, для которого требуется включить дисковые квоты, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку Квота.
  4. Установите флажок Включить управление квотами на вкладке Квота.
  5. Выберите один или несколько из следующих параметров и нажмите кнопку OK.

    6. Не выделять место на диске при превышении квоты

    Пользователи, превысившие квоту, получают сообщение об ошибке Windows "Недостаточно места на диске" и не могут записывать дополнительные данные в том без предварительного удаления или перемещения некоторых существующих файлов с диска.

    В отдельных приложениях предусмотрен особый порядок действий в данной ситуации. Ситуация воспринимается приложением как переполнение диска. Если снять данный флажок, пользователи не смогут превышать предельную квоту. Включение квот без ограничения использования дискового пространства используется в случаях, когда не требуется запрещать пользователям доступ к тому, но требуется отслеживать использование дискового пространства отдельными пользователями. Можно также включить или отключить режим регистрации событий превышения пользователями заданных для них квот или порогов предупреждения.

    Выделять на диске не более

    Укажите объем дискового пространства, выделяемого новым пользователям тома, а также порог, по достижении которого в системный журнал будет записано событие. Администраторы могут просматривать эти события в окне просмотра событий. Можно использовать десятичные числа (например, 20,5). Для дискового пространства и порога предупреждения в раскрывающемся списке выберите соответствующие наименования величин (например, Кбайт, Мбайт, Гбайт и т.п.). Для получения дополнительных сведений об окне просмотра событий щелкните ссылку «См. также».

    Регистрация превышения квоты пользователем

    Если квоты включены, при превышении пользователями заданной предельной квоты в системный журнал на локальном компьютере заносится событие. Администраторы могут просматривать эти события в окне просмотра событий, отбирая их по типу.

    По умолчанию события квоты записываются в системный журнал на локальном компьютере каждый час. Интервал записи событий квоты в системный журнал на локальном компьютере можно изменить с помощью команды fsutil behavior. Для получения дополнительных сведений о просмотре событий или команде fsutil behavior щелкните ссылку «См. также».

    Регистрация превышения порога предупреждения

    Если квоты включены, при превышении пользователями заданного порога предупреждения в системный журнал на локальном компьютере заносится событие. Администраторы могут просматривать эти события в окне просмотра событий, отбирая их по типу.

    По умолчанию события квоты записываются в системный журнал на локальном компьютере каждый час. Интервал записи событий квоты в системный журнал на локальном компьютере можно изменить с помощью команды fsutil behavior. Для получения дополнительных сведений о просмотре событий или о команде fsutil behavior щелкните ссылку «См. также».

Примечания

  • XOX
  • XOX
  • Программа просмотра событий выстраивает хронологический список сведений о том, кто из пользователей и когда превысил порог предупреждения дисковой квоты и предельную дисковую квоту. Однако эта программа не позволяет узнать, кто из пользователей в настоящий момент превышает порог предупреждения. Для поиска этих сведений нажмите кнопку Записи квот.

См. также


Отключение дисковых квот

Рисунок Microsoft Windows

Чтобы отключить дисковые квоты

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, для которого требуется отключить дисковые квоты, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку «Квота».
  4. На вкладке Квота снимите флажок Включить управление квотами и нажмите кнопку OK.

Примечания

  • XOX
  • XOX

См. также


Запрет выделения места на диске для пользователей, превысивших заданный предел

Рисунок Microsoft Windows

Чтобы запретить выделение места на диске для пользователей, превысивших заданный предел

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, для которого требуется запретить использование места на диске, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку Квота.
  4. На вкладке Квота установите флажок Включить управление квотами, установите флажок Не выделять место на диске при превышении квоты и нажмите кнопку OK.

Примечания

  • XOX
  • XOX
  • Когда система дисковых квот запрещает выделять место на диске для пользователей тома, превысивших заданную предельную квоту, пользователи не могут записывать на том дополнительные данные без предварительного удаления или перемещения с тома части существующих файлов. Ответ системы пользователю, превышающему предельную квоту, зависит от каждой отдельной программы. Программа при этом действует так же, как при переполнении диска.

См. также


Задание значений квоты для использования по умолчанию

Рисунок Microsoft Windows

Чтобы задать значения квоты для использования по умолчанию

С помощью интерфейса Windows

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, для которого требуется задать значения квоты по умолчанию, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку «Квота».
  4. Установите флажок Включить управление квотами на вкладке Квота.
  5. Выберите параметр Выделять на диске не более. Будут активизированы поля для задания предельной квоты и порога предупреждения.
  6. Введите числовые значения в эти поля, выберите нужные единицы измерения из раскрывающегося списка и нажмите кнопку OK. Можно использовать дробные значения (такие как 20,5 МБ).

Примечания

  • XOX
  • XOX
  • Хранить данные на томе, для которого включены дисковые квоты, могут любые пользователи, имеющие доступ к этому тому для записи и не превысившие заданную квоту. При первой записи данных на том, для которого включены квоты, система дисковых квот назначает пользователю предельную квоту и порог предупреждения, заданные по умолчанию.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    fsutil quota modify [буква_тома] [порог] [предел] [имя_пользователя]

Значение | Описание
буква_тома | Назначенная тому буква диска, например «C:».
порог | Предельный размер в байтах, по достижении которого выдается предупреждение.
предел | Максимальный допустимый размер занятого места на диске в байтах.
имя_пользователя | Имя пользователя, использование диска которым требуется ограничить, в следующем формате: домен\имя_пользователя.

Примечания

  • XOX
  • Для задания значений квоты по умолчанию том должен быть отформатирован в файловой системе NTFS.
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    fsutil /?

    Для получения дополнительных сведений о команде fsutil щелкните ссылку «См. также».

См. также


Управление дисковыми квотами на удаленном компьютере

Рисунок Microsoft Windows

Чтобы управлять дисковыми квотами на удаленном компьютере

  1. Щелкните правой кнопкой значок Мой компьютер и выберите команду Подключить сетевой диск.
  2. В диалоговом окне Подключение сетевого диска введите в поле Папка путь к тому на удаленном компьютере, дисковыми квотами для которого требуется управлять, и нажмите кнопку Готово.
  3. После подключения к тому на удаленном компьютере откройте папку Мой компьютер.
  4. Щелкните правой кнопкой значок тома, для которого требуется управлять дисковыми квотами, и выберите команду Свойства.
  5. В диалоговом окне Свойства откройте вкладку «Квота».
  6. Нажмите кнопку Записи квот на вкладке Квота.

    7. Откроется окно записей квот. Каждая строка в списке содержит данные по конкретному пользователю тома.

Примечания

  • XOX
  • XOX
  • Для управления дисковыми квотами на томе удаленного компьютера необходимо входить в группу Администраторы на этом компьютере, а к корневому каталогу тома должен быт предоставлен общий доступ.

См. также


Управление записями дисковых квот

  • Просмотр сведений о дисковых квотах для пользователей тома
  • Добавление новых записей квот
  • Удаление записей квот
  • Изменение предельных квот и порогов предупреждения
  • Поиск записи квоты в окне «Записи квот»
  • Сортировка записей квот
  • Изменение порядка столбцов в окне «Записи квот».
  • Создание отчета о квотах
  • Импорт параметров квоты с другого тома
  • Экспорт параметров квоты на другой том


Просмотр сведений о дисковых квотах для пользователей тома

Рисунок Microsoft Windows

Чтобы просмотреть сведения о дисковых квотах для пользователей тома

С помощью интерфейса Windows

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой мыши значок тома, сведения о квотах для которого требуется просмотреть, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку Квота.
  4. Нажмите кнопку Записи квот на вкладке Квота.

    5. Откроется окно Записи квот. Каждая строка содержит сведения о пользователе тома.

Примечания

  • XOX
  • XOX
  • При первом открытии окна Записи квот сведения о квотах тома должны быть получены с сетевого контроллера домена. Эти сведения заполняются динамически по мере их получения, а затем сохраняются для быстрого доступа при следующем открытии окна Записи квот.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    fsutil quota query [буква_тома]

Значение | Описание
буква_тома | Назначенная тому буква диска, например «C:».

Примечания

  • XOX
  • Для просмотра сведений о квотах том должен быть отформатирован в файловой системе NTFS.
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    fsutil /?

    Для получения дополнительных сведений о команде fsutil щелкните ссылку «См. также».

См. также


Добавление новых записей квот

Рисунок Microsoft Windows

Чтобы добавить новую запись квоты

С помощью интерфейса Windows

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, для которого требуется добавить новую запись квоты, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку Квота.
  4. Нажмите кнопку Записи квот на вкладке Квота.
  5. В меню Квота окна Записи квот выберите команду Создать запись квоты.
  6. В диалоговом окне Выбор: Пользователи введите в поле Имя имя домена или рабочей группы, обратную косую черту и имя пользователя, для которого требуется задать квоты. Нажмите кнопку ОК.
  7. В диалоговом окне Добавление новой квоты выберите один из следующих параметров и нажмите кнопку OK.

    8. Не ограничивать выделение места на диске. Отслеживать, но не ограничивать использование места на диске.

    Выделять на диске не более. Активизация полей для ввода значений предельной квоты и порога предупреждения. Введите числовое значение в поле и выберите из раскрывающегося списка единицы измерения места на диске. Можно использовать дробные значения (такие как 20,5 МБ). Введенное числовое значение не может превышать размер тома.

Примечания

  • XOX
  • XOX
  • С помощью команды Создать запись квоты можно задать предельную квоту и порог предупреждения до того, как пользователь начнет использование тома. Это позволяет задать для пользователя значения предельной квоты и порога предупреждения, отличные от используемых по умолчанию. Обычно значения предельной квоты и уровня предупреждения, заданные администратором тома для использования по умолчанию, подходят для новых пользователей тома.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    fsutil quota modify [буква_тома] [порог] [предел] [домен\имя_пользователя]

Значение | Описание
буква_тома | Назначенная тому буква диска, например «C:».
порог | Предельный размер в байтах, по достижении которого выдается предупреждение.
предел | Максимальный допустимый размер занятого места на диске в байтах.
домен\имя_пользователя | Имя пользователя, использование диска которым требуется ограничить, в следующем формате: домен\имя_пользователя.

Примечания

  • XOX
  • Для добавления новых записей квот том должен быть отформатирован в файловой системе NTFS.
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    fsutil /?

    Для получения дополнительных сведений о команде fsutil щелкните ссылку «См. также».

См. также


Удаление записей квот

Рисунок Microsoft Windows

Чтобы удалить записи квот

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, для которого требуется удалить записи квот, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку «Квота».
  4. Нажмите кнопку Записи квот на вкладке Квота.
  5. В диалоговом окне записей квот выберите для удаления записи нужных пользователей, а затем выберите в меню Квота команду Удалить запись квоты.
  6. При появлении диалогового окна Дисковая квота нажмите кнопку Да, выберите файлы или папки, над которыми требуется выполнить действие, нажмите одну из следующих кнопок, а затем — кнопку Закрыть.
    • Удалить. Удаление выбранных файлов из тома. Отсутствует возможность удалять папки.
    • Стать владельцем. Пользователь становится владельцем выделенных файлов ил папок на томе.
    • Переместить. Перемещение выделенных файлов на определенный том. Отсутствует возможность перемещать папки.

Примечания

  • XOX
  • XOX
  • С помощью флажков Отображать только папки и Отображать только файлы можно отфильтровать список для отображения только папок или только файлов. При работе с большим числом файлов и папок удобнее сначала удалить, переместить или стать владельцем файлов, а затем — стать владельцем папок.
  • Если пользователь является владельцем файлов или папок на томе, его записи квот не могут быть удалены. Перед удалением записи необходимо либо удалить все файлы, владельцем которых является пользователь, переместить их на другой том или сделать владельцем этих файлов и папок другого пользователя.
  • Приглашение на удаление, смену владельца или перемещение выводится только в том случае, если на момент удаления записи квоты пользователь все еще владеет файлами и папками на томе.

См. также


Изменение предельных квот и порогов предупреждения

Рисунок Microsoft Windows

Чтобы изменить предельную квоту и порог предупреждения для пользователя

С помощью интерфейса Windows

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, значения квоты для которого требуется изменить, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку Квота.
  4. Нажмите кнопку Записи квот на вкладке Квота.
  5. В окне Записи квот выделите записи для пользователей, для которых требуется изменить параметры, а затем выберите в меню Квота команду Свойства.
  6. В диалоговом окне Параметры квоты измените любые из следующих параметров и нажмите кнопку OK.

    7. Не ограничивать выделение места на диске. Выберите данный параметр для отслеживания использования места на диске без его ограничения.

    Выделять на диске не более. Включение полей для ограничения места на диске и порога выдачи предупреждений. Введите числовое значение в поле и выберите из раскрывающегося списка единицы измерения места на диске. Можно использовать дробные значения (такие как 20,5 МБ).

Примечания

  • XOX
  • XOX

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    fsutil quota modify [буква_тома] [порог] [предел] [домен\имя_пользователя]

Значение | Описание
буква_тома | Назначенная тому буква диска, например «C:».
порог | Предельный размер в байтах, по достижении которого выдается предупреждение.
предел | Максимальный допустимый размер занятого места на диске в байтах.
домен\имя_пользователя | Имя пользователя, использование диска которым требуется ограничить, в следующем формате: домен\имя_пользователя.

Примечания

  • XOX
  • Для задания ограничений на выделение дискового пространства для пользователя том должен быть отформатирован для файловой системы NTFS.
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    fsutil /?

    Для получения дополнительных сведений о команде fsutil щелкните ссылку «См. также».

См. также


Поиск записи квоты в окне «Записи квот»

Рисунок Microsoft Windows

Чтобы найти запись квоты в окне «Записи квот»

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, записи квот для которого требуется найти, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку «Квота».
  4. Нажмите кнопку Записи квот на вкладке Квота.
  5. В меню Правка окна Записи квот выберите команду Найти.
  6. В диалоговом окне Поиск записи квот введите имя пользователя, которое требуется найти, в формате имя_домена\имя_пользователя или имя_пользователя@имя_домена, и нажмите кнопку OK.

    7. Найденные записи будут выделены цветом в окне записей квот.

Примечания

  • XOX
  • XOX
  • Для поиска нескольких пользователей тома можно использовать диалоговое окно Поиск записи квот несколько раз. Каждая найденная запись остается выделенной в окне записей квот.
  • После использования диалогового окна Поиск записи квоты для поиска записей квот одного или нескольких пользователей можно изменить параметры для всех найденных записей, выбрав в меню Квота команду Свойства.


Сортировка записей квот

Рисунок Microsoft Windows

Чтобы отсортировать записи квот

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой мыши значок тома, для которого требуется отсортировать записи квот, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку Квота.
  4. Нажмите кнопку Записи квот на вкладке Квота.
  5. В меню Вид окна записей квот выберите команду Упорядочить записи, а затем — один из следующих параметров:

    6. по папке для сортировки по названию папки;

    по имени пользователя для сортировки по полному имени пользователя;

    по имени для входа в систему для сортировки по имени для входа в систему;

    по состоянию для сортировки по состоянию квоты;

    по объему использования для сортировки по объему использованного места на томе;

    по пределу квоты для сортировки по ограничению места на диске;

    по порогу предупреждений для сортировки по порогу предупреждений;

    по проценту использования для сортировки по проценту использования выделенного места на диске.

Примечания

  • XOX
  • XOX
  • Кроме того, щелкнув заголовок столбца в окне записей квот, можно выполнить сортировку по записям в этом столбце. Чтобы обратить порядок сортировки, щелкните заголовок столбца еще раз.

См. также


Изменение порядка столбцов в окне «Записи квот».

Рисунок Microsoft Windows

Чтобы изменить порядок столбцов в окне «Записи квот».

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, для которого требуется просмотреть записи квот, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку Квота.
  4. Нажмите кнопку Записи квот на вкладке Квота.
  5. В окне записей квот выберите заголовок столбца, который требуется переместить, а затем перетащите его горизонтально на новую позицию в списке.

Примечания

  • XOX
  • XOX
  • При закрытии окна записей квот порядок и размер столбцов сохраняется и автоматически воспроизводится при следующем открытии этого окна.
См. также


Создание отчета о квотах

Рисунок Microsoft Windows

Чтобы создать отчет о квотах

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, для которого требуется создать отчет, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку «Квота».
  4. Нажмите кнопку Записи квот на вкладке Квота.
  5. После открытия окна Записи квот откройте документ в программе, которая будет использоваться для создания отчета (например, электронную таблицу Microsoft Excel).
  6. В окне Записи квот выберите записи, которые требуется включить в отчет, и перетащите их в программу, используемую для создания отчета; например, в электронную таблицу Microsoft Excel или документ Microsoft Word. В перенесенных данных будет такой же порядок столбцов и записей, как и в окне Записи квот.

Примечания

  • XOX
  • XOX
  • Форматы отчетов, поддерживаемые буфером обмена: формат RTF, формат CSV, форматы CF_UNICODETEXT и CF_TEXT.

См. также


Импорт параметров квоты с другого тома

Рисунок Microsoft Windows

Чтобы импортировать параметры квоты с другого тома

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, на который требуется импортировать параметры квоты, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку Квота.
  4. Нажмите кнопку Записи квот на вкладке Квота.
  5. В меню Квота окна Записи квот выберите команду Импорт.
  6. В диалоговом окне Параметры импорта квоты выберите имя файла, содержащего параметры квоты, которые требуется импортировать, и нажмите кнопку Открыть.

    7. Если при импорте записей квот импортируемые параметры будут заменять существующие параметры для пользователя тома, будет выведено диалоговое окно. Укажите, следует ли заменять существующие параметры.

Примечания

  • XOX
  • XOX
  • Кроме того, можно открыть два окна Записей квот: первое для тома, с которого будут импортироваться записи квоты, второе для тома, на который будут импортироваться записи квоты. Затем перетащите записи квот из окна Записи квот исходного тома в окно Записи квот конечного тома.
  • Для записей, уже существующих на конечном томе, изменяются заданные для пользователей значения предельной квоты и порога предупреждения. Если записи не существуют, будут созданы новые записи.
  • Параметры дисковой квоты сохраняются в файле особого формата, используемого только системой дисковых квот и только для импорта и экспорта параметров квоты с одного тома на другой. В диалоговом окне Параметры импорта квоты расширение имени файла параметров не отображается, даже если в папке, содержащей этот файл, отображаются расширения всех файлов.

См. также


Экспорт параметров квоты на другой том

Рисунок Microsoft Windows

Чтобы экспортировать параметры квоты на другой том

  1. Откройте папку Мой компьютер.
  2. Щелкните правой кнопкой значок тома, с которого требуется экспортировать параметры квоты, и выберите команду Свойства.
  3. В диалоговом окне Свойства откройте вкладку Квота.
  4. На вкладке Квота убедитесь, что флажок Включить управление квотами установлен, и нажмите кнопку Записи квот.
  5. Выберите запись квоты пользователя, которую требуется экспортировать.
  6. В меню Квота выберите команду Экспорт.
  7. В диалоговом окне Параметры экспорта квоты выберите конечную папку, введите имя файла и нажмите кнопку Сохранить.

Примечания

  • XOX
  • XOX
  • Кроме того, можно открыть два окна записей квот: первое — для тома, с которого будут экспортироваться записи квоты, второе — для тома на который будут экспортироваться записи квоты. Затем перетащите записи квот из окна записей квот для исходного тома в окно записей квот для конечного тома.
  • Для записей, уже существующих на конечном томе, изменяются заданные для пользователей значения предельной квоты и порога предупреждения. Если записи не существуют, будут созданы новые записи.
  • Параметры дисковой квоты сохраняются в файле особого формата, используемого только системой дисковых квот и только для импорта и экспорта параметров квоты с одного тома на другой. В диалоговом окне Параметры экспорта квоты расширение имени файла параметров не отображается, даже если в папке, содержащей этот файл, отображаются расширения всех файлов.
  • Можно перетащить выбранные параметры квоты в папку, в которой файл экспорта будет создан автоматически.

См. также


Основные понятия

Данный раздел содержит общие сведения о дисковых квотах.

  • Общие сведения о дисковых квотах
  • Общее представление о дисковых квотах
  • Использование дисковых квот
  • Управление дисковыми квотами из командной строки
  • Ресурсы


Общие сведения о дисковых квотах

Дисковые квоты отслеживают и контролируют использование места на диске для томов NTFS. Администраторы могут настроить Windows таким образом, чтобы:

  • запрещать использование дискового пространства сверх указанного предела и регистрировать случаи превышения этого предела пользователями;
  • регистрировать события превышения пользователями указанного порога предупреждения, то есть отметки, при прохождении которой пользователь приближается к заданному для него пределу использования дискового пространства.

При включении дисковых квот можно задать два параметра: предельную квоту диска и порог предупреждения дисковой квоты. Например, можно задать для пользователя дисковую квоту в 500 мегабайт (МБ) и порог предупреждения дисковой квоты в 450 МБ. В этом случае пользователь сможет хранить на соответствующем томе не более 500 MБ файлов. Систему дисковых квот можно настроить таким образом, чтобы при сохранении пользователем на томе более 450 МБ файлов создавалась запись о событии системы. Для управления квотами на томе необходимо входить в состав группы «Администраторы». Инструкции по заданию значений дисковой квоты см. в разделе Установка значений дисковой квоты по умолчанию.

Можно разрешить пользователям превышать заданные квоты. Включение квот без ограничения использования дискового пространства полезно в случаях, когда не требуется запрещать пользователям доступ к тому, но требуется отслеживать использование дискового пространства отдельными пользователями. Также можно включить или отключить режим регистрации событий превышения пользователями заданных для них квот или порогов предупреждения.

Отслеживание использования тома всеми пользователями начинается автоматически с момента включения дисковых квот для тома.

Квоты можно включать на локальных томах, сетевых томах и съемных дисках с файловой системой NTFS. Кроме того, для сетевых томов должен быть предоставлен общий доступ к корневому каталогу тома, а съемные диски должны быть предоставлены для общего доступа. Тома, отформатированные с использованием версии NTFS, использовавшейся в Windows NT 4.0, автоматически обновляются программой установки Windows.

Нельзя использовать сжатие файлов для предотвращения превышения пользователями заданных квот, поскольку сжатые файлы отслеживаются по их несжатому размеру. Например, если файл размером 50 МБ сжать до 40 МБ, Windows сопоставит с квотой его исходный размер, 50 МБ.

При расчете использования тома сжатыми папками Windows, наоборот, использует размер папок после сжатия. Например, если папку размером 500 МБ сжать до 300 МБ, Windows сопоставит с квотой 300 МБ.


Общее представление о дисковых квотах

В этом разделе

  • Квоты и пользователи
  • Квоты и тома
  • Обновление записей квот
  • Квоты и тома, преобразованные в файловую систему NTSF
  • Локальное и удаленное внедрение дисковых квот


Квоты и пользователи

Поскольку дисковые квоты наблюдают за использованием тома отдельными пользователями, использование места на диске каждым из пользователей не влияет на дисковые квоты для других пользователей того же тома. Например, если для тома F задана квота в 500 мегабайт (МБ) и пользователь сохранит на нем 500 мегабайт (МБ) файлов, этот пользователь не сможет записать дополнительные данные на том F без предварительного удаления или перемещения с этого тома существующих данных. Однако другие пользователи смогут продолжать сохранять на этом томе до 500 МБ каждый при наличии свободного дискового пространства.

Дисковые квоты основаны на владении файлами и не зависят от расположения папки с файлами пользователя на томе. Например, если пользователи переместят свои файлы из одной папки тома в другую папку того же тома, объем дискового пространства, используемого этими пользователями на томе, не изменится. Однако, если пользователи скопируют свои файлы в другую папку того же тома, объем используемого дискового пространства удвоится. При смене владельца файла, имеющего размер 200 килобайт (КБ), объем дискового пространства, используемого его бывшим владельцем, уменьшится на 200 КБ, а объем дискового пространства, используемого новым владельцем файла, увеличится на 200 КБ.

Инструкции по включению дисковых квот см. в разделе Включение дисковых квот.


Квоты и тома

Дисковые квоты применяются только к томам и не зависят ни от структуры папок на томах, ни от схемы размещения томов на физических дисках.

Если том содержит несколько папок, то квоты применяются ко всем папкам этого тома одинаково. Например, если \\Production\QA и \\Production\Public — общие папки на томе F, то файлы, хранимые пользователями в этих папках, не могут занимать на диске больше места, чем предельная квота, заданная для тома F.

Если один физический диск содержит несколько томов и квоты применяются к каждому тому, то каждая квота применяется только к указанному тому. Например, если два различных тома предоставлены для общего доступа как том F и том G, то квоты для каждого из этих томов отслеживаются независимо, даже если они расположены на одном физическом диске.

Если один том занимает несколько физических дисков, то ко всему составному тому применяется одна квота. Например, если том F имеет предельную квоту в 500 мегабайт (МБ), то пользователи не смогут сохранить на томе F более 500 МБ, независимо от того, расположен ли том F на одном физическом диске или занимает целых три.

Инструкции по включению дисковых квот см. в разделе Включение дисковых квот.


Обновление записей квот

В файловой системе NTFS сведения об использовании тома сохраняются для учетного кода (SID), а не для имени учетной записи. При первом открытии окна записей квот система дисковых квот должна получить сведения об именах учетных записей пользователя с сетевого контроллера домена или из оснастки «Локальные пользователи и группы», сопоставить их с учетными кодами безопасности (SID) для текущих пользователей тома и отобразить имена пользователей в столбце Имя каждой записи. Имена отображаются в поле «Имя» так, как они были получены с контроллера домена или из оснастки «Локальные пользователи и группы». Этот процесс начинается незамедлительно при первом просмотре записей квот.

После получения имена сохраняются в файле на томе для обеспечения быстрого доступа к ним при следующем открытии окна записей квот. Однако из-за того, что Windows может не обновлять этот файл в течение нескольких дней, окно записей квот может не отражать изменения в списке учетных записей пользователей домена, произошедшие со времени просмотра записей квот.

Для получения текущего списка имен пользователей нажмите клавишу F5. Windows обновит имена всех пользователей с сетевого контроллера домена или из оснастки «Локальные пользователи и группы». В зависимости от количества пользователей тома и скорости сети это может занять несколько минут. Если в ходе этого процесса потребуется ускорить просмотр имени конкретного пользователя, выделите соответствующую запись и переместите ее в начало списка.

Инструкции см. в разделе Просмотр сведений о дисковых квотах для пользователей тома.


Квоты и тома, преобразованные в файловую систему NTSF

Дисковые квоты можно использовать для всех томов NTFS в операционных системах Windows 2000 или Windows XP. Однако файлы на томах, преобразованных из файловой системы FAT или FAT32 в NTFS, автоматически принадлежат администратору, поэтому размер этих файлов вычитается из квоты для учетной записи «Администратор». Это редко создает неудобства, поскольку администраторы используют том без ограничений. Сказанное относится только к файлам, существовавшим до преобразования в файловую систему NTFS; файлы, создаваемые после преобразования, принадлежат соответствующему пользователю.

Поскольку дисковые квоты основаны на владении файлами, то любые изменения на томе, влияющие на статус владения файлами, включая преобразования файловой системы, могут внести изменения в дисковые квоты на томе. Поэтому перед преобразованием существующих томов из одной файловой системы в другую следует просчитать, каким образом это преобразование повлияет на принадлежность файлов.

Дополнительные сведения о файловых системах см. в разделе Файловые системы Windows.


Локальное и удаленное внедрение дисковых квот

Дисковые квоты можно включать на томах с файловой системой NTFS, расположенных как на локальных, так и на удаленных компьютерах. На локальных компьютерах квоты можно использовать для ограничения объема дискового пространства, доступного для пользователей, работающих на локальном компьютере. На удаленных компьютерах с помощью квот можно ограничить использование тома удаленными пользователями.

Можно использовать квоты для того, чтобы:

  • несколько пользователей, подключеных к одному и тому же компьютеру, не могли помешать другим пользователям работать;
  • место на диске общедоступного сервера не использовалось монопольно одним или несколькими пользователями;
  • пользователи не использовали излишнего места на диске для общих папок на персональном компьютере.

Для включения квот на томе удаленного компьютера необходимо, чтобы этот том был отформатирован для файловой системы NTFS, используемой Windows 2000 или Windows XP, и чтобы общим каталогом являлся корневой каталог тома. Для включения и управления квотами на томе удаленного компьютера необходимо также входить в группу Администраторы на этом компьютере.

Системные файлы Windows включаются в использованное дисковое пространство при установке Windows на локальный компьютер. При внедрении дисковых квот на локальном томе следует учесть дисковое пространство, занимаемое файлами Windows. В зависимости от объема свободного места на томе можно задать высокий предел квоты или совсем не задавать предел для пользователя, установившего Windows. Если установка Windows была выполнена администратором, это делать не требуется, поскольку администраторы и члены группы «Администраторы» имеют неограниченную квоту.

Инструкции см. в разделе Включение дисковых квот.


Использование дисковых квот

В этом разделе

  • Включение дисковых квот
  • Удаление записей дисковых квот
  • Отслеживание использования места на диске
  • Управление дисковыми квотами из командной строки


Включение дисковых квот

Включать дисковые квоты на томах NTFS могут члены группы Администраторы. На томах, которые уже содержат файлы, Windows вычисляет дисковое пространство, используемое всеми пользователями, которые скопировали, сохранили файлы на данном томе или стали владельцами файлов. На основе этих вычислений предельная квота и порог предупреждения применяются ко всем, кто использовал или будет использовать этот том. После этого для некоторых пользователей можно установить другую дисковую квоту или отключить ее совсем. Можно установить дисковые квоты для определенных пользователей, кто еще не копировал или не сохранял файлы, либо не являлся владельцем файлов на томе.

Например, можно установить предельную квоту в 50 мегабайт (МБ) для всех пользователей папки \\Production\Public, обеспечив для двух пользователей, работающих с большими файлами, квоту в 100 МБ. Если оба этих пользователя уже хранят файлы в папке \\Production\Public, можно выделить обоих пользователей и задать для них квоту в 100 МБ. Однако, если при включении квоты один или оба этих пользователя еще не хранят файлы на сервере, их необходимо выделить в окне записей квот и задать для них предельную квоту больше, чем размер квоты по умолчанию для новых пользователей.

Инструкции по включению дисковых квот см. в разделе Чтобы включить дисковые квоты.


Удаление записей дисковых квот

Если пользователь больше не использует том, на котором включены квоты, можно удалить порог предупреждения и предельную квоту этого пользователя, удалив его запись из диалогового окна записей квот. Однако сделать это можно только после удаления или перемещения с тома всех файлов этого пользователя, либо после смены владельца этих файлов.

Поскольку дисковые квоты отслеживают файлы по владельцам, при удалении записи квоты для упрощения поиска файлов и последующего их перемещения, удаления или смены их владельца выводится диалоговое окно. Инструкции по удалению записей квот см. в разделе Удаление записей квот.

Инструкции по смене владельца файлов см. в разделе Смена владельца файла или папки.


Отслеживание использования места на диске

Можно установить предельную квоту, не запрещая пользователям превышать ее. Это позволяет не запрещать пользователям доступ к тому, но при этом отслеживать использование места на диске каждым пользователем. Также можно включить режим регистрации событий превышения пользователями заданных для них квот или порогов предупреждения. Отслеживание использования места на диске полезно в случаях, когда требуется:

  • вести журнал использования места на диске;
  • отображать потребности в дополнительном дисковом пространстве;
  • отображать распределение места на диске между пользователями;
  • уведомлять пользователей о превышении ими выделенного для них места на диске.

Инструкции по документированию использования места на диске см. в разделе Создание отчета о квотах.


Управление дисковыми квотами из командной строки

Помимо использования папки Мой компьютер для управления дисковыми квотами (щелкните значок тома правой кнопкой, выберите команду Свойства и откройте вкладку Квота), для управления дисками и томами можно использовать служебную программу командной строки fsutil.

Можно использовать следующие команды:

  • fsutil quota для создания и изменения дисковых квот для конкретных пользователей, запроса дисковых квот для конкретных томов, поиска в журнале системы записей о нарушении квот или для выполнения этих задач с помощью сценариев;
  • fsutil behavior для смены частоты записи событий квоты в системный журнал.

Программа fsutil — это мощный инструмент, предназначенный только для опытных пользователей, хорошо знающих Windows.

Сведения о других служебных программах командной строки см. в разделе Справочник по параметрам командной строки. Дополнительные сведения о возможностях управления см. в разделе Управление и администрирование.


Ресурсы

  • Домашняя страница Microsoft Windows на веб-узле корпорации Майкрософт (http://www.microsoft.com/)
  • Microsoft TechNet на веб-узле корпорации Майкрософт (http://www.microsoft.com/)
  • Компакт-диски Microsoft TechNet
  • Служба поддержки корпорации Майкрософт на веб-узле корпорации Майкрософт (http://www.microsoft.com)


Устранение неполадок

Выберите тип неполадки, которую требуется устранить.

Вкладка Квота не появляется в диалоговом окне Свойства для отформатированного в FAT тома.

Причина. Поскольку дисковые квоты могут быть установлены только для томов, отформатированных для файловой системы NTFS, то вкладка Квота не появляется для томов, отформатированных в FAT.

Решение. Отформатируйте необходимые тома в файловую систему NTFS или ограничьте место на диске для использования в файловой системе NTFS.

См. также Квоты и преобразованные в NTFS тома.

Невозможно удалить запись квоты.

Причина. Запись квоты учетной записи пользователя невозможно удалить до тех пор, пока все файлы этого пользователя не будут удалены из тома или другой пользователь не станет владельцем данных файлов.

Решение. Переместите, удалите или измените владельца файлов удаляемого пользователя на томе.

См. также Удаление записей квоты.

При попытке добавить файлы на том пользователь получил сообщение об ошибке «недостаточно места на диске».

Причина. Пользователь превысил предельную квоту.

Решение. Увеличьте предельную квоту пользователя, переместите или удалите файлы из тома или снимите флажок Не выделять место на диске при превышении квоты на вкладке Квота в окне свойств тома.

См. также Включение дисковых квот.

После запуска Windows NT 4.0 пользователи превысили свои пределы квоты.

Причина. Дисковые квоты доступны только для Windows 2000 и Windows XP. Если задать дисковые квоты на компьютере, на котором установлены Windows NT 4.0 и Windows XP, пользователи смогут превышать свои дисковые квоты, работая в Windows NT 4.0. В этом случае при следующем запуске Windows XP пользователи, которые превысили свои пределы дисковых квот, работая в Windows NT 4.0, не смогут добавить файлы на том, на котором установлены квоты.

Решение. Для того чтобы разрешить пользователям добавлять файлы на том, работающий под управлением Windows XP, см. предыдущий раздел. Для предотвращения превышения пользователями предельных квот на томе при работе в Windows NT 4.0 измените доступ на том таким образом, чтобы у пользователей не было разрешения на запись.

См. также Разрешения для папок и Установка на компьютер нескольких операционных систем.

Записи квот устарели.

Причина. На вкладке Квота не установлен флажок Включить управление квотами. Windows сохраняет все имеющиеся сведения о квотах, но не обновляет их, пока не включено использование квот.

Решение. Включите дисковые квоты. Инструкции по включению дисковых квот см. в разделе Включение дисковых квот.

Не удается включить использование квот на томе удаленного компьютера.

Решение. Установите соединение с удаленным томом и включите квоты. Инструкции по установлению подключения к удаленному тому и управлению квотами на нем см. в разделе Управление дисковыми квотами на удаленном компьютере. Инструкции по включению дисковых квот см. в разделе Включение дисковых квот.