Общие папки

Компонент «Общие папки» может быть использован для управления общими ресурсами по сети. При помощи компонента «Общие папки» можно осуществлять контроль над разрешениями учетных записей пользователей, сеансами и свойствами общих ресурсов.

  • Советы по работе с компонентом «Общие папки»использованию см. в разделе Советы и рекомендации.
  • Справочные сведения по выполнению конкретных задач см. в разделе Инструкции.
  • Общие сведения см. в разделе Основные понятия.
  • Инструкции по устранению неполадок см. в разделе Устранение неполадок.


Советы и рекомендации

  • Задание разрешений с помощью файловой системы NTFS или управления доступом.

    • Файловая система NTFS и управление доступом предоставляют более высокий уровень безопасности, чем разрешения для общих папок.

    Дополнительные сведения см. в следующих разделах.

    • Файловая система NTFS
    • Управление доступом
  • Назначение разрешений группам, а не учетным записям пользователей.

    • Назначение разрешений группам облегчает управление общими ресурсами, поскольку в этом случае отменять разрешения нужно только при необходимости переопределить уже применяемые разрешения. В большинстве случаев разрешения отменяются только при необходимости их отмены для определенного пользователя в группе. Для отмены всех видов доступа к общему ресурсу следует отменить разрешение «Полный доступ».

  • Назначение наиболее строгих разрешений, позволяющих пользователям выполнять поставленные задачи.

    • Например, если пользователю нужно только прочитывать сведения, содержащиеся в папке, и ему не придется удалять, создавать или изменять файлы, рекомендуется назначит разрешение «Чтение».

  • Упорядочение ресурсов с целью размещения объектов с одинаковыми требования по безопасности в одинаковых папках.

    • Например, если пользователям необходимо разрешение «Чтение» для нескольких папок приложения, рекомендуется хранить эти папки в одной родительской папке. В результате можно предоставить общий доступ к родительской папке вместо предоставления доступа к отдельным папкам приложения. При необходимости изменить расположение приложения нужно его переустановить.

  • Использование наглядных, недлинных подписей для общих ресурсов.

    • Это позволяет любому пользователю и при использовании любой операционной системы клиента легко распознавать и получать доступ к ресурсам.

  • Отказ от отмены разрешений для группы «Все» с целью предотвращения возникновения сложностей при получении доступа к сетевым ресурсам.

    • Группа «Все» включает всех пользователей, имеющих доступ к сетевым ресурсам, включая пользователей с учетной записью «Гость», однако не включает группу «Анонимный вход». Дополнительные сведения см. в следующих разделах.

    • Параметры безопасности по умолчанию
    • Различия между параметрами безопасности по умолчанию
  • Размещение всех общих приложений в одной папке при совместной работе с приложениями.

    • Размещение всех приложений в одной общей папке упрощает администрирование, поскольку для установки и обновления программного обеспечения используется одно расположение.

  • Ограничение участия и предоставление разрешения «Полный доступ» группе «Администраторы».

    • Это позволит администраторам управлять прикладными программами и разрешениями пользователей.

  • Ограничение разрешений для группы «Все», которая включает всех пользователей, имеющих доступ к сетевым ресурсам, включая пользователей с учетной записью «Гость».

    • Рекомендуется предоставить разрешение «Чтение» группе «Пользователи», включающей только созданные Вами учетные записи.

  • Использование централизованных папок данных.

    • Централизованные папки данных позволяют управлять ресурсами и легко выполнять архивацию.

  • Использование брандмауэра.

    • Для защиты общих ресурсов от несанкционированного доступа через Интернет на компьютерах с установленной операционной системой Windows XP Professional, не входящих в домен, а также на компьютерах с установленной операционной системой Windows XP Home Edition рекомендуется использовать брандмауэр.

  • Предоставление разрешений доступа при помощи учетных записей пользователей домена.

    • Для компьютеров с установленной операционной системой Windows XP Professional, подключенных к домену, рекомендуется предоставлять доступ к общим ресурсам при помощи учетных записей пользователей домена, а не при помощи локальных учетных записей. Это позволяет централизовать администрирование разрешений для общих ресурсов.


Инструкции

  • Предоставление доступа к папке или диску для совместной работы
  • Задание разрешений для общего ресурса
  • Просмотр сведений по общим ресурсам
  • Управление свойствами общего ресурса
  • Отключение пользователя или пользователей
  • Закрытие открытого файла или ресурса
  • Прекращение доступа к общему ресурсу
  • Ограничение числа пользователей общего ресурса
  • Установка параметров кэширования для общего ресурса


Предоставление доступа к папке или диску для совместной работы

Рисунок Microsoft Windows

Чтобы предоставить доступ к папке или диску для совместной работы

С помощью компонента «Общие папки»

  1. XOX
  2. В дереве консоли щелкните узел Ресурсы.

    3. Где?

    • Оснастка «Управление компьютером»
    • Служебные программы
    • Общие папки
    • Ресурсы
  3. В меню Действие выберите команду Новый общий файловый ресурс.
  4. Следуйте инструкциям, выводящимся в окне Создание общей папки.

    Выберите папку или диск, введите имя и описание нового общего ресурса и установите разрешения. Введя эти сведения, нажмите кнопку Готово.

Примечания

  • XOX
  • Пользоваться компонентом «Общие папки» могут только члены группы «Администраторы» или «Опытные пользователи».

С помощью проводника Windows

Откройте проводник и найдите общую папку или диск, для которых требуется добавить новое имя общего ресурса.

При наличии подключения к домену выполните следующие действия.

  1. Правой кнопкой мыши щелкните общую папку или диск, затем выберите команду Общий доступ и безопасность.
  2. Нажмите кнопку Открыть общий доступ к этой папке.
  3. Установите требуемые параметры и нажмите кнопку OK.

При входе на домен или при работе под управлением Windows XP Home Edition выполните следующие действия.

  1. Правой кнопкой мыши щелкните общую папку или диск, затем выберите команду Свойства.
  2. На вкладке Доступ установите переключатель Открыть общий доступ к этой папке.
  3. Установите требуемые параметры и нажмите кнопку OK.

Примечание

  • XOX

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    net share ресурс=диск:путь

Значение | Описание
net share | Создание и удаление совместно используемых ресурсов или вывод сведений о ресурсах.
ресурс=диск:путь | Сетевое имя общего ресурса и полный путь к папке.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    net help share

Примечания

  • Удобно использовать средство «Общие папки» для управления общими ресурсами как на локальном, так и на удаленных компьютерах. С помощью проводника Windows и командной строки можно управлять только общими ресурсами на локальном компьютере.
  • Чтобы скрыть общий ресурс при просмотре, последним знаком имени общего ресурса должен быть знак $. Пользователи могут подключить диск к этому общему ресурсу, однако при использовании проводника, объекта «Мой компьютер» или при использовании команды net view этот ресурс просмотреть будет нельзя. Дополнительные сведения об этой команде см. в разделе Net view.
  • Для завершения этой процедуры необходимо иметь соответствующее разрешение.

См. также


Задание разрешений для общего ресурса

Рисунок Microsoft Windows

Чтобы задать разрешения для общего ресурса

С помощью компонента «Общие папки»

  1. XOX
  2. В дереве консоли щелкните узел Ресурсы.

    3. Где?

    • Оснастка «Управление компьютером»
    • Служебные программы
    • Общие папки
    • Ресурсы
  3. Щелкните правой кнопкой мыши общий ресурс, для которого нужно задать разрешения, и выберите команду Свойства.
  4. На вкладке Разрешения для общего ресурса выберите нужные параметры и нажмите кнопку OK.
    • Нажмите кнопку Добавить, чтобы предоставить пользователю или группе разрешение для общего ресурса. В диалоговом окне Выбор: Пользователи или Группы найдите или введите имя пользователя, компьютера или группы и нажмите кнопку OK.
    • Нажмите кнопку Удалить, чтобы отменить доступ к общему ресурсу.
    • В диалоговом окне Разрешения для <групп и пользователей> установите соответственно флажки Разрешить или Запретить для задания индивидуальных разрешений выделенным пользователям или группам.

Примечания

  • XOX
  • Пользоваться компонентом «Общие папки» могут только члены группы «Администраторы» или «Опытные пользователи».

С помощью проводника Windows

  1. Откройте проводник и найдите общую папку или диск, для которых требуется добавить новое имя общего ресурса.
  2. Правой кнопкой мыши щелкните общую папку или диск, затем выберите команду Общий доступ и безопасность.
  3. На вкладке Доступ выполните одно из следующих действий.
    • При наличии подключения к домену нажмите кнопку Разрешения. В диалоговом окне Разрешения для <папки или диска> установите требуемые параметры и нажмите кнопку OK.
    • Если подключение к домену не выполнено, снимите флажок Разрешить другим пользователям изменять файлы.

Примечание

  • XOX

Примечания

  • Удобно использовать средство «Общие папки» для управления общими ресурсами как на локальном, так и на удаленных компьютерах. С помощью проводника Windows и командной строки можно управлять только общими ресурсами на локальном компьютере.
  • При назначении разрешений проще назначать разрешения группам, а затем добавлять пользователей в эти группы, чем назначать одинаковые разрешения нескольким отдельным пользователям.
  • Разрешения для общего ресурса применяются только к пользователям, имеющим общий доступ к ресурсу. Они не применяются к пользователям, которые получают доступ к ресурсу на компьютере, на котором сохранен ресурс.

См. также


Просмотр сведений по общим ресурсам

Рисунок Microsoft Windows

Чтобы просмотреть сведения по общим ресурсам

С помощью компонента «Общие папки»

  1. XOX
  2. В дереве консоли выберите одну из следующих папок.
    • Чтобы просмотреть сведения по общим ресурсам на этом компьютере, выберите узел Ресурсы.
    • Чтобы просмотреть сведения об открытых сеансах, выберите узел Сеансы.
    • Чтобы просмотреть сведения об открытых файлах, выберите узел Открытые файлы.

    Где?

    • Оснастка «Управление компьютером»
    • Служебные программы
    • Общие папки

Примечания

  • XOX
  • Пользоваться компонентом «Общие папки» могут только члены группы «Администраторы» или «Опытные пользователи».

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите одну из следующих команд.

    net share

    net session

    net file

Значение | Описание
net share | Ввод сведений по всем общим ресурсам на локальном компьютере.
net session | Отображение сведений по всем открытым сеансам по сети между локальным компьютером и другими компьютерами.
net file | Отображение сведений по всем открытым файлам общих ресурсов.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этих команд, введите в командной строке одну из следующих команд.

    net help share

    net help session

    net help file

Примечания

  • При удаленном администрировании другого компьютера соединение отображается как открытый именованный канал. Закрыть его нельзя.
  • Видимыми являются только файлы, открытые на конечном компьютере.

См. также


Управление свойствами общего ресурса

Рисунок Microsoft Windows

Чтобы управлять свойствами общего ресурса

С помощью компонента «Общие папки»

  1. XOX
  2. В дереве консоли щелкните узел Ресурсы.

    3. Где?

    • Оснастка «Управление компьютером»
    • Служебные программы
    • Общие папки
    • Ресурсы
  3. Щелкните правой кнопкой мыши общий ресурс, свойства которого необходимо изменить, и выберите команду Свойства.
  4. Внесите нужные изменения и нажмите кнопку OK.

Примечания

  • XOX
  • Пользоваться компонентом «Общие папки» могут только члены группы «Администраторы» или «Опытные пользователи».

С помощью проводника Windows

  1. Откройте проводник и найдите общую папку или общий диск, свойства которого необходимо изменить.
  2. Правой кнопкой мыши щелкните общую папку или диск, затем выберите команду Общий доступ и безопасность.
  3. Внесите нужные изменения и нажмите кнопку OK.

Примечание

  • XOX

Примечания

  • Удобно использовать средство «Общие папки» для управления общими ресурсами как на локальном, так и на удаленных компьютерах. С помощью проводника Windows и командной строки можно управлять только общими ресурсами на локальном компьютере.
  • Для завершения этой процедуры необходимо иметь соответствующее разрешение.

См. также


Отключение пользователя или пользователей

Рисунок Microsoft Windows

Чтобы отключить пользователя или пользователей

С помощью компонента «Общие папки»

  1. XOX
  2. В дереве консоли щелкните узел Сеансы.

    3. Где?

    • Оснастка «Управление компьютером»
    • Служебные программы
    • Общие папки
    • Сеансы
  3. Выполните одно из следующих действий.
    • Чтобы отключить всех пользователей, в меню Действие выберите команду Отключить все сеансы.
    • Чтобы отключить одного пользователя, в окне сведений щелкните правой кнопкой мыши имя пользователя, а затем выберите команду Закрыть сеанс.

Примечание

  • XOX
  • Пользоваться компонентом «Общие папки» могут только члены группы «Администраторы» или «Опытные пользователи».
  • При удаленном администрировании другого компьютера соединение отображается как открытый именованный канал. Закрыть его нельзя.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    net session \\компьютер /delete

Значение | Описание
net session | Отключение пользователей, подключенных к компьютеру, или вывод списка таких пользователей.
\\компьютер | Задает имя компьютера, для которого требуется перечислить или отключить сеансы.
/delete | Заканчивает сеанс с \\компьютером и закрывает все открытые файлы данного сеанса. Если \\компьютер не задан, закрываются все сеансы на локальном компьютере.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    net help session

Внимание!

  • Отключение пользователей, подключенных к общему ресурсу в текущий момент, может привести к потере данных. Следует оповестить отключаемых пользователей перед отключением.

Примечание

  • Для завершения этой процедуры необходимо иметь соответствующее разрешение.

См. также


Закрытие открытого файла или ресурса

Рисунок Microsoft Windows

Чтобы закрыть открытый файл или ресурс

С помощью компонента «Общие папки»

  1. XOX
  2. В дереве консоли щелкните узел Открытые папки.

    3. Где?

    • Оснастка «Управление компьютером»
    • Служебные программы
    • Общие папки
    • Поле «Открытые файлы»
  3. Выполните одно из следующих действий.
    • Чтобы отключить все открытые ресурсы, в меню Действие выберите команду Отключить все открытые файлы.
    • Чтобы отключить один открытый файл или ресурс, в окне сведений щелкните правой кнопкой мыши имя файла, а затем выберите команду Закрыть сеанс.

Примечания

  • XOX
  • Пользоваться компонентом «Общие папки» могут только члены группы «Администраторы» или «Опытные пользователи».

С помощью командной строки

  • Откройте окно Командная строка.
  • Введите:

    net file код /close

Значение | Описание
net file | Вывод имен открытых общих файлов на сервере и количества блокировок для каждого файла, если они установлены.
код | Динамически назначаемый общему ресурсу код.
/close | Закрытие общего ресурса и удаление блокировки файла. Данная команда запускается на сервере, где находятся общие файлы.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    net help file

Внимание!

  • В случае закрытия открытых файлов или ресурсов пользователи могут потерять данные. Перед закрытием открытого файла или ресурса необходимо предупредить подключенных пользователей о предстоящем отключении.

Примечания

  • Удобно использовать средство «Общие папки» для управления общими ресурсами как на локальном, так и на удаленных компьютерах. С помощью проводника Windows и командной строки можно управлять только общими ресурсами на локальном компьютере.
  • При удаленном администрировании другого компьютера соединение отображается как открытый именованный канал. Закрыть его нельзя.
  • Для завершения этой процедуры необходимо иметь соответствующее разрешение.

См. также


Прекращение доступа к общему ресурсу

Рисунок Microsoft Windows

Чтобы прекратить доступ к общему ресурсу

С помощью компонента «Общие папки»

  1. XOX
  2. В дереве консоли щелкните узел Ресурсы.

    Где?

    • Оснастка «Управление компьютером»
    • Служебные программы
    • Общие папки
    • Ресурсы
  3. В области сведений щелкните правой кнопкой папку, доступ к которой необходимо прекратить, и выберите команду Прекратить доступ.

Примечания

  • XOX
  • Пользоваться компонентом «Общие папки» могут только члены группы «Администраторы» или «Опытные пользователи».

С помощью проводника Windows

Откройте проводник и найдите общую папку или общий диск, совместный доступ к которым должен быть отменен.

В случае наличия подключения к домену выполните следующий действия.

  1. Правой кнопкой мыши щелкните общую папку или диск, затем выберите команду Общий доступ и безопасность.
  2. Чтобы прекратить доступ ко всем элементам общего ресурса, выберите команду Отменить общий доступ к этой папке. Чтобы прекратить доступ только к одному элементу папки или диска, общий доступ к которым осуществляется неоднократно, в группе Общий ресурс щелкните ресурс, который необходимо удалить, нажмите кнопку Удалить общий ресурс, а затем нажмите кнопку ОК.

При входе на домен или при работе под управлением Windows XP Home Edition выполните следующие действия.

  1. Правой кнопкой мыши щелкните общую папку или диск, затем выберите команду Свойства.
  2. На вкладке Доступ снимите флажок Открыть общий доступ к этой папке.

Примечание

  • XOX

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    net share ресурс /delete

Значение | Описание
net share | Создание и удаление совместно используемых ресурсов или вывод сведений о ресурсах.
ресурс | Указывает сетевое имя общего ресурса.
/delete | Отменяет совместное использование ресурса.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    net help share

Внимание!

  • Если прекратить общий доступ к папке в то время, когда к ней подключены пользователи, может произойти потеря данных. Перед прекращением общего доступа следует предупреждать об этом подключенных пользователей.
  • В большинстве случаев не следует прекращать общий доступ к специальным общим ресурсам, созданным системой (например A$, B$, C$, ADMIN$, IPC$, NETLOGON, SYSVOL или PRINT$).

Примечание

  • Удобно использовать средство «Общие папки» для управления общими ресурсами как на локальном, так и на удаленных компьютерах. С помощью проводника Windows и командной строки можно управлять только общими ресурсами на локальном компьютере.

См. также


Ограничение числа пользователей общего ресурса

Рисунок Microsoft Windows

Чтобы ограничить число пользователей общего ресурса

С помощью компонента «Общие папки»

  1. XOX
  2. В дереве консоли щелкните узел Ресурсы.

    3. Где?

    • Оснастка «Управление компьютером»
    • Служебные программы
    • Общие папки
    • Ресурсы
  3. В окне сведений щелкните правой кнопкой мыши общую папку или диск, для которых требуется задать предельное число пользователей, и выберите команду Свойства.
  4. В группе Предельное число пользователей выберите параметр максимально возможное, нажмите кнопку ОК или выберите параметр не более.

    При выборе параметра не более в поле Пользователи выберите или введите максимальное число одновременных подключений, а затем нажмите кнопку ОК.

Примечания

  • XOX
  • Предельное число пользователей не может превышать указанного в лицензии на программное обеспечения соответствующего предельного числа. Предельные значения параметров общих папок не могут превышать соответствующие предельные значения, указанные в лицензии на программное обеспечение.
  • Пользоваться компонентом «Общие папки» могут только члены группы «Администраторы» или «Опытные пользователи».

С помощью проводника Windows

  1. Откройте проводник и найдите общую папку или диск, для которых необходимо ограничить число пользователей.
  2. Правой кнопкой мыши щелкните общую папку или диск, затем выберите команду Общий доступ и безопасность.
  3. В группе Предельное число пользователей выберите параметр максимально возможное, нажмите кнопку ОК или выберите параметр не более.

    При выборе параметра не более в поле Пользователи выберите или введите предельное число одновременных подключений, а затем нажмите кнопку ОК.

Примечания

  • XOX
  • Предельное число пользователей не может превышать указанного в лицензии на программное обеспечения соответствующего предельного числа. Предельные значения параметров общих папок не могут превышать соответствующие предельные значения, указанные в лицензии на программное обеспечение.
  • На компьютерах, на которых установлена операционная система Windows XP Home Edition или Windows XP Professional, и которые не подключены к домену для выполнения этой задачи нельзя использовать проводник Windows.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    net share ресурс /users:число

Значение | Описание
net share | Создание и удаление совместно используемых ресурсов или вывод сведений о ресурсах.
ресурс | Сетевое имя общего ресурса и полный путь.
/users:число | Устанавливает предельное число пользователей, которым разрешен одновременный доступ к общему ресурсу.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    net help share

Примечания

  • Удобно использовать средство «Общие папки» для управления общими ресурсами как на локальном, так и на удаленных компьютерах. С помощью проводника Windows и командной строки можно управлять только общими ресурсами на локальном компьютере.
  • Предельные значения параметров общих папок не могут превышать соответствующие предельные значения, указанные в лицензии на программное обеспечение.

См. также


Установка параметров кэширования для общего ресурса

Рисунок Microsoft Windows

Чтобы установить параметры кэширования для общего ресурса

С помощью компонента «Общие папки»

  1. XOX
  2. В дереве консоли щелкните узел Ресурсы.

    3. Где?

    • Оснастка «Управление компьютером»
    • Служебные программы
    • Общие папки
    • Ресурсы
  3. Щелкните правой кнопкой мыши общий ресурс, для которой нужно установить параметры кэширования, и выберите команду Свойства.
  4. На вкладке Общие нажмите кнопку Кэширование. Если требуется отключить кэширование, снимите флажок Разрешить кэширование файлов в этой общей папке и нажмите кнопку OK. Если требуется разрешить кэширование, оставьте этот флажок установленным.
  5. Если флажок установлен, в поле Параметр выберите один из следующих параметров и нажмите кнопку ОК.
    • Выберите параметр Автоматическое кэширование для документов, чтобы сделать каждый файл, открываемый пользователем, доступным в автономном режиме.
    • Выберите параметр Автоматическое кэширование программ и документов для предоставления доступа а автономном режиме к общим ресурсам, содержащим файлы с атрибутом «только для чтения» или приложения, которые запускаются только из сети.
    • Выберите параметр Ручное кэширование для документов, чтобы потребовать от пользователей явно указывать файлы, которые требуется сделать доступными в автономном режиме.

Примечания

  • XOX
  • Пользоваться компонентом «Общие папки» могут только члены группы «Администраторы» или «Опытные пользователи».

С помощью проводника Windows

  1. Откройте проводник и найдите общую папку или диск, для которых необходимо задать параметры кэширования. (Возможно, понадобиться разрешить совместный доступ к ресурсу.)
  2. Правой кнопкой мыши щелкните общую папку или диск, затем выберите команду Общий доступ и безопасность.
  3. На вкладке Доступ выберите команду Кэширование. Если требуется отключить кэширование, снимите флажок Разрешить кэширование файлов в этой общей папке и нажмите кнопку OK. Если требуется разрешить кэширование, оставьте этот флажок установленным.
  4. Если флажок установлен, в поле Параметр выберите один из следующих параметров и нажмите кнопку ОК.
    • Выберите параметр Автоматическое кэширование для документов, чтобы сделать каждый файл, открываемый пользователем, доступным в автономном режиме.
    • Выберите параметр Автоматическое кэширование программ и документов для предоставления доступа а автономном режиме к общим ресурсам, содержащим файлы с атрибутом «только для чтения» или приложения, которые запускаются только из сети.
    • Выберите параметр Ручное кэширование для документов, чтобы потребовать от пользователей явно указывать файлы, которые требуется сделать доступными в автономном режиме.

Примечания

  • XOX
  • На компьютерах, на которых установлена операционная система Windows XP Home Edition или Windows XP Professional, и которые не подключены к домену для выполнения этой задачи нельзя использовать проводник Windows.

С помощью командной строки

  1. Откройте окно Командная строка.
  2. Введите:

    net share ресурс /cache:manual

    или

    net share ресурс /cache:documents

    или

    net share ресурс /cache:programs

    или

    net share ресурс /cache:none

Значение | Описание
net share | Управление общими ресурсами.
ресурс | Сетевое имя общего ресурса в формате диск:путь. Команда net share с именем ресурса выведет сведения об отдельном ресурсе.
/cache:manual | Включение кэширования документов и программ из определенного общего ресурса вручную.
/cache:documents | Включение автоматического кэширования документов из определенного общего ресурса.
/cache:programs | Включение автоматического кэширования документов и программ из определенного общего ресурса.
/cache:none | Отключение кэширования из определенного общего ресурса.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    net help share

Примечания

  • Для завершения этой процедуры необходимо иметь соответствующее разрешение.
  • При создании нового общего ресурса кэширование разрешается по умолчанию.

См. также


Основные понятия

В этом разделе представлены сведения общего характера о компоненте «Общие папки».

  • Общие сведения о компоненте «Общие папки»
  • Общее представление о компоненте «Общие папки»
  • Администрирование общих папок


Общие сведения о компоненте «Общие папки»

Компонент «Общие папки» позволяет просматривать сводку подключений и использования ресурсов на локальном и удаленных компьютерах. Компонент «Общие папки» замещает компоненты панели управления Windows NT Server версии 4.0, связанные с использованием ресурсов.

Используя компонент «Общие папки» можно выполнять следующие действия:

  • создавать, просматривать и задавать разрешения для общих ресурсов;
  • просматривать список всех пользователей, подключенных к данному компьютеру с помощью локальной сети, и отключать их;
  • просматривать список файлов, открытых удаленными пользователями, а также закрывать эти файлы.

Подпапки компонента «Общие папки» содержат сведения, распределенные по столбцам, обо всех общих ресурсах, сеансах и открытых файлах на локальном компьютере. Далее представлены заголовки столбцов этих папок.

Ресурсы

В узле Ресурсы представлены следующие сведения об общих ресурсах, доступных на этом компьютере.

Столбец | Описание
Общая папка | Выводит список общих ресурсов доступных на этом компьютере. В некоторых случаях подключение к принтеру отображается в списке как подключение к именованному каналу. Общий ресурс может быть общим каталогом, именованным каналом, общим принтером или ресурсом неопознанного типа.
Общий путь | Путь для общего ресурса.
Тип | Тип сетевого подключения: Windows, NetWare или Macintosh.
# Клиентские подключения | Число пользователей, подключенных к общему ресурсу.
Комментарий | Описание общего ресурса.

Сеансы

В узле Сеансы представлены следующие сведения о всех сетевых пользователях, подключенных к данному компьютеру.

Столбец | Описание
Пользователь | В этом столбце содержится список пользователей сети подключенных к компьютеру.
Компьютер | В этом столбце содержится имя, присвоенное компьютеру пользователя.
Тип | Тип сетевого подключения: Windows, NetWare или Macintosh.
# Открытые файлы | В этом столбце выводится число ресурсов открытых пользователем на этом компьютере.
Время подсоединения | Отображает часы и минуты, прошедшие с момента начала данного сеанса.
Время простоя | Отображает время простоя (в часах и минута) после последнего действия пользователя.
Гость | В этом столбце определяется, будет ли пользователь подключен к данному компьютеру как гость («Да» или «Нет»).

Открытые файлы

В узле Открытые файлы представлены следующие сведения о всех открытых файлах на данном компьютере.

Столбец | Описание
Открытый файл | Список открытых файлов. Открытый файл может быть файлом, именованным каналом, заданием печати в очереди печати или ресурсом неопознанного типа. В некоторых случаях задание печати отображается в списке как открытый именованный канал.
Пользователь | Имя пользователя, открывшего файл или получившего доступ к ресурсу.
Тип | Тип сетевого подключения: Windows, NetWare или Macintosh.
Блокир. | Выводится число блокировок на ресурсе.
Режим открытия | В этом столбце для открытого ресурса выводится предоставленное разрешение.

Примечание

  • Пользоваться компонентом «Общие папки» могут только члены группы «Администраторы» или «Опытные пользователи».


Общее представление о компоненте «Общие папки»

В этом разделе рассмотрены следующие темы:

  • Разрешения для общих ресурсов
  • Параметры кэширования общих ресурсов
  • Особые общие ресурсы


Разрешения для общих ресурсов

Общий ресурс предоставляет доступ к приложениям, данным или личным сведениям пользователя. Имеется возможность предоставить или отменить разрешения для каждого общего ресурса.

В общем, лучше всего задавать разрешения с помощью файловой системы NTFS или средств управления доступом. Всегда применяются более строгие разрешения. Для получения дополнительных сведений о работе с компонентом «Общие папки» см. раздел Советы и рекомендации.

Разрешения для общих ресурсов:

  • Эти разрешения применяются только к пользователям, доступ которых к ресурсу осуществляется по сети. Они не применяются к пользователям, которые получают доступ к ресурсу на компьютере, на котором сохранен ресурс.
  • Разрешения применяются ко всем файлам и папкам общего ресурса. По этим причинам разрешения для общих ресурсов обеспечивают меньший уровень безопасности, чем разрешения NTFS.
  • Эти разрешения являются единственным способом защиты сетевых ресурсов для томов с файловыми системами FAT и FAT32, поскольку разрешения NTFS не доступны для томов с файловыми системами FAT и FAT32.
  • Разрешениями определяются максимальные права доступа пользователя к общему ресурсу при работе в сети. Все эти свойства являются дополнением безопасности, предоставляемой файловой системой NTFS.

Имеется возможность применять следующие типы разрешений доступа к общим папкам или дискам.

    Чтение

    Разрешение «Чтение» позволяет:

    • просматривать имена файлов и подкаталогов;
    • просматривать подпапки;
    • просматривать данные в файлах;
    • выполнять программные файлы.

    Изменить

    Разрешение «Изменить» включает разрешение «Чтение», а также позволяет:

    • добавлять файлы и подпапки;
    • изменять данные в файлах;
    • удалять подпапки и файлы.

    Полный доступ

    Разрешение «Полный доступ» используется по умолчанию для всех новых общих ресурсов. При общем использовании ресурса это разрешение назначается группе «Все». Разрешение «Полный доступ» включает разрешения «Изменить» и «Чтение», а также позволяет:

    • изменять разрешения (только для файлов и папок NTFS);
    • стать владельцем (только для файлов и каталогов NTFS).


Параметры кэширования общих ресурсов

Для работы с общими ресурсами можно использовать папку автономных файлов даже при отсутствии подключения к сети. При создании общего ресурса можно задать условие и способ локального «кэширования» (хранения) файлов общего ресурса при доступе к ним других пользователей.

Для обеспечения работы в автономном режиме с общими сетевыми ресурсами в папке автономных файлов в зарезервированной части дискового пространства, называемой файловым кэшем системы, сохраняются их версии. Возможность доступа локального компьютера к кэшу не зависит от наличия подключения к сети.

Для каждого общего ресурса можно выбрать один из представленных далее параметров кэширования.

Кэширование запрещено

При выборе этого параметра пользователи не смогут сохранять локальные копии общих файлов.

Автоматическое кэширование документов

Автоматическое кэширование для документов предоставляет для автономной работы все открываемые в общей папке файлы. При автоматическом кэшировании доступными в автономном режиме становятся не все файлы в общей папке, а только открытые файлы.

Автоматическое кэширование программ и документов

Автоматическое кэширование для программ предоставляет доступ к общим папкам, файлы в которых не могут быть изменены. Использование этого параметра кэширования позволяет уменьшить сетевой трафик, поскольку доступ к программам, сохраненным в автономном режиме, может осуществляться локально.

При выборе параметра Автоматическое кэширование программ и документов файлы в общей папке следует сделать доступными только для чтения.

Ручное кэширование документов

Ручное кэширование для документов предоставляет доступ в автономном режиме только к тем файлам в общей папке, которые были вручную указаны сетевым пользователем. Данный параметр кэширования лучше всего подходит для случаев совместной работы с общей сетевой папкой, содержащей файлы, которые должны использоваться и изменяться несколькими пользователями. При настройке папки для работы в автономном режиме данный параметр используется по умолчанию.

Дополнительные сведения об автономных файлах см. в разделе Общие сведения об автономных файлах. Дополнительные сведения по заданию параметров кэширования см. в разделе Чтобы установить параметры кэширования для общего ресурса.


Особые общие ресурсы

В зависимости от конфигурации компьютера отдельные или все перечисленные ниже особые общие папки создаются для обеспечения работы системы или целей администрирования. Доступ к этим общим ресурсам не может быть осуществлен из папки «Мой компьютер», однако их можно просматривать при помощи компонента «Общие папки». В большинстве случаев они не должны удаляться и изменяться.

При помощи компонента «Общие папки» можно просматривать некоторые или все представленные далее административные общие ресурсы.

имя диска$

Представляет собой общий ресурс, который позволяет администраторам подключаться к корневому каталогу диска. Корневой каталог выводится в столбце Общая папка компонента «Общие папки» следующим образом: A$, B$, C$, D$ и т. д. Например, доступ к диску D можно получить, щелкнув D$.

ADMIN$

Это ресурс, который используется при удаленном администрировании компьютера. Путь к этому общему ресурсу всегда совпадает с путем к корневому каталогу (т.е. каталогу, в котором установлена система, например C:\Windows).

IPC$

Представляет собой ресурс совместного доступа к именованным каналам, которые обеспечивают связь между программами. Используется для удаленного администрирования компьютера и для просмотра общих ресурсов компьютера. Этот ресурс нельзя удалить.

NETLOGON

Обязательный ресурс, который используется на контроллерах домена. Удаление этого ресурса ведет к потере функциональности на всех клиентах, обслуживаемых контроллером домена.

SYSVOL

Обязательный ресурс, который используется на контроллерах домена. Удаление этого ресурса ведет к потере функциональности на всех клиентах, обслуживаемых контроллером домена.

PRINT$

Общий ресурс, используемый для удаленного администрирования принтеров.

FAX$

Общая папка на сервере, используемая клиентами службы факсов в процессе отправки факса. Данная общая папка используется для временного хранения файлов в кэше и для доступа к титульным страницам на сервере.

Примечания

  • При повторном запуске службы сервера эти особые общие ресурсы автоматически воссоздаются. Дополнительные сведения о службах содержатся в разделе Службы.
  • Если на компьютере установлена операционная система Windows XP Home Edition, некоторые из представленных выше общих ресурсов не создаются.


Администрирование общих папок

В этом разделе рассмотрены следующие темы:

  • Обеспечение безопасности общих ресурсов
  • Управление общими папками из командной строки


Обеспечение безопасности общих ресурсов

Ко всем дискам компьютера, например C или D, автоматически открыт общий доступ с именем имя_диска$, например C$ или D$. Данные диски отображаются без значка руки, который означает возможность совместного использования через папку "Мой компьютер" или с помощью проводника; кроме того, данные диски недоступны при удаленном подключении к компьютеру.

Однако если в случае отсутствия защиты с помощью брандмауэра другому лицу известно имя пользователя и пароль одного из членов групп «Администраторы», «Операторы архива» или «Операторы сервера», это лицо имеет такой же доступ к компьютеру, что и администратор.

Для обеспечения безопасности дисков следует придерживаться следующих правил.

Использование сложных паролей для всех учетных записей

Очень часто пользователи оставляют пустым пароль для учетной записи администратора, что делает компьютер практически беззащитным, так как любой пользователь может войти в систему как администратор, указав пустой пароль. Дополнительные сведения по защите паролей см. в разделе Создание надежных паролей.

На компьютерах, на которых установлена операционная система Windows XP Professional, имеется возможность изменить учетную запись администратора при помощи диспетчера локальных пользователей и групп. Дополнительные сведения по этому вопросу содержатся в разделе Локальные пользователи и группы.

Удаление службы доступа к файлам и принтерам сетей Microsoft

Параметр Служба доступа к файлам и принтерам сетей Microsoft выводится на экране при просмотре свойств любого из сетевых подключений. Нажмите кнопку Удалить, чтобы удалить данный компонент. Для удаления компонента снятия флажка Служба доступа к файлам и принтерам сетей Microsoft недостаточно. Дополнительные сведения см. в разделе Служба доступа к файлам и принтерам сетей Microsoft.


Управление общими папками из командной строки

В дополнение к общим папкам и проводнику Windows имеются программы для управления общими ресурсами, которые можно запускать из командной строки.

Имя | Описание
net file | Просмотр и управление общими сетевыми ресурсами. Для выполнения этой команды должна быть запущена служба сервера.
net config server | Обзор максимального числа пользователей, имеющих доступ к общему ресурсу, а также обзор максимального числа открытых файлов во время одного сеанса.
net use | Подключение компьютера к общему ресурсу или отключение от общего ресурса.
net share | Создание, удаление, управление общими ресурсами их отображение.

Сведения о других программах, запускаемых из командной строки, см. в разделе Справочник по параметрам командной строки. Дополнительные сведения о возможностях управления см. в разделе Управление и администрирование.


Устранение неполадок

Вид неполадки

Не удается получить доступ к общим ресурсам

Причина. Включен брандмауэр Windows.

Решение. При использовании брандмауэра Windows просмотр общих ресурсов невозможен. Если брандмауэр отключен, компьютер является уязвимым для вторжения.

См. также. Включение и отключение брандмауэра Windows

Причина. Потеря сетевого подключения.

Решение. Проверьте параметры сети.

См. также: Устранение неполадок сетевых подключений и подключений удаленного доступа

Причина. Доступ невозможен по причине отсутствия соответствующих разрешений для общих ресурсов или файловой системы.

Решение. Проверьте наличие разрешения для доступа к сетевым ресурсам для компьютера, к которому осуществляется подключение.

Не удается просмотреть сведения об общих ресурсах в компоненте «Общие папки»

Причина. При работе на компьютере, на котором установлена операционная система Windows XP Professional, отсутствует подключение к конечному компьютеру в качестве члена группы «Администраторы» или группы «Опытные пользователи». При работе на компьютере, на котором установлена операционная система Windows XP Home Edition, отсутствует подключение к конечному компьютеру в качестве члена группы «Владельцы».

Решение. Выполните подключение к конечному компьютеру, используя правильные учетные данные.