Общие сведения об оборудовании

Оборудованием называют все устройства, подключенные к компьютеру и управляемые его процессором. Сюда относится оборудование, которое было подключено к компьютеру при его изготовлении, а также периферийные устройства, добавляемые позже. Далее перечислены некоторые примеры устройств.

  • Универсальная последовательная шина (USB)
  • IEEE 1394
  • Модемы
  • Дисковые накопители
  • Устройства чтения компакт-дисков
  • Дисководы DVD (digital video disc)
  • Принтеры
  • Сетевые адаптеры
  • Клавиатуры
  • Платы видеоадаптеров
  • Мониторы
  • Игровые контроллеры

Устройства (как Plug and Play, так и не Plug and Play) могут быть подключены к компьютеру несколькими способами. Одни устройства, например сетевые адаптеры и звуковые платы, подключаются в гнезда расширений внутри компьютера. Другие, например принтеры и сканеры, подключаются к внешним портам компьютера. Некоторые (так называемые устройства PC Card) подключаются только в гнезда PC Card переносного компьютера.

Для правильной работы устройства с Windows на компьютере должно быть установлено программное обеспечение, которое называется драйвером устройства. Работа каждого устройства обеспечивается одним или несколькими уникальными драйверами, которые обычно предоставляются изготовителями устройств. Однако некоторые драйверы поставляются с Windows. Windows обнаруживает устройства Plug and Play автоматически и устанавливает для них соответствующие драйверы.

Если операционная система Windows не установила устройство автоматически, будет запущен мастер нового оборудования с приглашением вставить носитель (компакт-диск или дискету), входящий в комплект поставки устройства. Для установки устройств, не поддерживающих Plug and Play, используется мастер установки оборудования, запускаемый с панели управления. Чтобы установить драйверы устройств вручную, необходимо использовать диспетчер устройств. Перед этим следует ознакомиться с поставляемой изготовителем документацией к устройству.

Внимание!

В следующих случаях для установки и настройки устройств необходимо войти в систему с учетной записью члена группы «Администраторы».

  • Если драйвер устройства не имеет эмблемы «Designed for Windows» (предназначено для Windows) или цифровой подписи.
  • Если для установки устройств требуется выполнить дополнительные действия, требующие отображения интерфейса пользователя.
  • Если драйвер устройства еще не установлен на компьютере.
  • Для настройки устройства необходимо использовать диспетчер устройств.
  • Если компьютер подключен к сети, параметры сетевой политики могут запрещать установку оборудования.

Примечание

  • XOX

См. также


Общие сведения об установке устройств

Для упрощения установки можно условно разделить устройства на две группы: Plug and Play и non-Plug and Play. Большинство устройств, изготовленных после 1995 года, используют технологию Plug and Play. Устройства Plug and Play достаточно подключить к компьютеру, после чего их можно использовать сразу, не настраивая вручную.

Как определить, поддерживает ли устройство технологию Plug and Play? Устройства Plug and Play часто имеют разъемы, выглядящие следующим образом:

Разъем USB (тип A) Разъем USB (тип B)

Установка нового устройства, независимо от того, поддерживает ли оно технологию Plug and Play, обычно выполняется в три этапа.

  • Подключение к компьютеру.
  • Загрузка соответствующих драйверов устройства. Если устройство поддерживает технологию Plug and Play, этот шаг можно пропустить.
  • Настройка свойств и параметров устройства. Если устройство поддерживает технологию Plug and Play, этот шаг можно пропустить.

Независимо от того, поддерживает ли устройство технологию Plug and Play, для обеспечения его правильной работы необходимо при установке следовать инструкциям изготовителя, поставляемым вместе с устройством. По инструкции может потребоваться завершение работы и отключение питания компьютера перед подключением устройства к соответствующему порту или его вставкой в соответствующее гнездо.

Если устройство не начинает работать автоматически, это означает, что оно не поддерживает Plug and Play или предназначено для автозагрузки (например, жесткий диск); может потребоваться перезагрузка компьютера. Затем Windows возобновит попытки обнаружения нового устройства.

Если Windows не удалось обнаружить новое оборудование, необходимо воспользоваться мастером установки оборудования на панели управления, чтобы сообщить Windows о типе устанавливаемого устройства. Мастер установки оборудования может запросить носитель (компакт-диск или дискету), если таковой входит в комплект поставки устройства. Мастер установки оборудования используется главным образом для установки устройств, не поддерживающих технологию Plug and Play.

Когда устройство обнаружено средствами Windows или указано пользователем с помощью мастера установки оборудования, Windows выполняет попытку найти и установить подходящий драйвер для данного устройства.

  • Сначала Windows выполняет поиск драйвера на жестком диске компьютера, а также на дискете или компакт-диске изготовителя устройства, если соответствующий носитель вставлен в дисковод. При обнаружении драйвера Windows устанавливает его.
  • Если Windows не находит драйвер, а компьютер подключен к Интернету, Windows выполняет поиск драйвера на веб-узле корпорации Майкрософт. XOX При обнаружении драйвера на веб-узле Windows Update он будет скопирован и установлен на компьютере. Если компьютер не подключен к Интернету, Windows предлагает выполнить подключение к Интернету.
  • Если Windows не удалось найти драйвер на веб-узле Windows Update, будет запущен мастер нового оборудования с приглашением вставить носитель (компакт-диск или дискету), входящий в комплект поставки устройства. Если драйвер находится на этом носителе, Windows выполнит его установку.

Внимание!

  • После загрузки в систему драйверов устройств Windows настраивает свойства и параметры устройства. Хотя их можно настроить вручную, лучше доверить это Windows. После ручной настройки значения свойств и параметров устройства фиксируются и не могут быть изменены Windows при возникновении неполадок или конфликта с другим устройством.

Внимание!

В следующих случаях для установки устройств необходимо войти в систему с учетной записью члена группы «Администраторы».

  • Если драйвер устройства не имеет эмблемы «Designed for Windows» (предназначено для Windows) или цифровой подписи.
  • Если для установки устройств требуется выполнить дополнительные действия, требующие отображения интерфейса пользователя.
  • Если драйвер устройства еще не установлен на компьютере.
  • Для установки устройства необходимо использование мастера установки оборудования. Обычно он используется для установки устройств, не поддерживающих технологию Plug and Play.
  • Если компьютер подключен к сети, параметры сетевой политики могут запрещать установку оборудования.


Установка устройства

Рисунок Microsoft Windows

Чтобы установить устройство

Большинство устройств, изготовленных после 1995 года, используют технологию Plug and Play. Это означает возможность работы с устройством сразу же после его подключения к компьютеру, без необходимости его настройки или установки дополнительного программного обеспечения. Если используется старое устройство или если описанная ниже процедура не дает результата, возможно, данное устройство не поддерживает Plug and Play. XOX

  1. Подключите устройство к соответствующему порту или гнезду компьютера в соответствии с указаниями производителя.
  2. Windows или инструкции изготовителя устройства могут требовать перезагрузки компьютера.

Примечания

  • Если устройство, например звуковую плату, необходимо установить в гнездо внутри компьютера, завершите работу Windows и выключите компьютер. Снимите крышку корпуса компьютера и установите устройство в соответствующее гнездо. Закройте крышку и включите компьютер.
  • При установке устройства SCSI подключите его к SCSI-порту компьютера в соответствии с указаниями производителя. Перезагрузите или включите компьютер.

    Необходимо убедиться, что номер устройства используется только для одного SCSI-устройства. Чтобы изменить номер устройства, обратитесь к документации устройства.

  • При установке устройств USB или IEEE 1394 подключите их к любому USB- или IEEE-порту компьютера. При появлении соответствующего приглашения следуйте инструкциям на экране. Порты USB обычно выглядят следующим образом: Порт USB (тип A) Порт USB (тип B)

    При установке устройств USB или IEEE 1394 выключать или перезагружать компьютер не требуется. Хотя технологии USB и IEEE 1394 похожи, разъемы USB и IEEE 1394 не являются взаимозаменяемыми.


Установка устройств, не поддерживающих Plug and Play

Рисунок Microsoft Windows

Чтобы установить устройство, не поддерживающее технологию Plug and Play

XOX

  1. Подключите устройство не Plug and Play к компьютеру.
  2. Откройте компонент Установка оборудования на панели управления.
  3. В мастере установки оборудования нажмите кнопку Далее.
  4. Выберите пункт Добавление нового устройства и нажмите кнопку Далее.
  5. Выполните одно из следующих действий:
    • если требуется, чтобы система попыталась определить устанавливаемое новое устройство, не поддерживающее технологию Plug and Play, выберите параметр Поиск и автоматическая установка оборудования (рекомендуется);
    • если тип и модель устанавливаемого устройства известны и их можно выбрать из списка устройств, выберите параметр Установка оборудования, выбранного из списка вручную.
  6. Нажмите кнопку Далее и следуйте инструкциям, появляющимся на экране.

Примечания

  • XOX
  • Для добавления и настройки устройств Plug and Play могут потребоваться права администратора. Они необходимы, если для установки устройства требуется интерфейс пользователя или в процессе установки возникают ошибки.
  • Пользователь, не являющийся администратором или членом группы «Администраторы», может выполнять некоторые из функций администратора с помощью команды Запуск от имени. XOX
  • При установке устройств, не поддерживающих технологию Plug and Play, может требоваться перезагрузка компьютера. Перед тем как ее выполнить, рекомендуется вывести данный раздел справки на печать, поскольку в ходе загрузки справочная система будет недоступна.


Настройка устройств

При установке устройства Plug and Play Windows автоматически настраивает его, обеспечивая его правильную работу с другими установленными на компьютере устройствами. В ходе процесса настройки Windows назначает устанавливаемому устройству уникальный набор системных ресурсов. Эти ресурсы могут включать один или несколько из следующих параметров.

  • Номера строк запроса на прерывание (IRQ).
  • Каналы прямого доступа к памяти (DMA).
  • Адреса портов ввода/вывода (I/O).
  • Диапазоны адресов памяти.

Каждый ресурс, назначаемый устройству, должен быть уникальным. Это необходимо для правильной работы устройства. Для устройств Plug and Play Windows автоматически проверяет правильность настройки ресурсов.

Иногда двум устройствам требуются одинаковые ресурсы, что приводит к конфликту устройств. В этом случае необходимо вручную изменить настройку ресурсов таким образом, чтобы все параметры были уникальными. Некоторые ресурсы, например прерывания устройств PCI, могут в зависимости от драйверов и компьютера использоваться совместно.

При установке устройств не Plug and Play автоматическая настройка ресурсов не производится. Некоторые типы устройств требуется настраивать вручную. Необходимые инструкции содержатся в руководстве, поставляемом вместе с устройством.

Изменять параметры ресурсов вручную обычно не рекомендуется, поскольку при этом значения фиксируются, что снижает возможности Windows по выделению ресурсов для других устройств. Если зафиксировано слишком много значений параметров для отдельных ресурсов, Windows не сможет автоматически устанавливать новые устройства Plug and Play.

Для настройки устройств вручную используется диспетчер устройств.

Внимание!

  • Неправильное изменение параметров ресурсов может привести к отключению устройства или стать причиной неправильной работы компьютера. Их следует изменять только при полной уверенности в том, что новые параметры не будут конфликтовать с другим оборудованием, или в том случае, если изготовитель данного устройства предлагает для него конкретные параметры.


Диагностика неполадок устройства

Рисунок Microsoft Windows

Чтобы выполнить диагностику неполадок устройства

XOX

  1. Откройте компонент Установка оборудования на панели управления.
  2. Выберите команду Далее. Windows произведет попытку определения новых устройств Plug and Play.
  3. В списке Установленное оборудование выберите устройство, неполадки которого требуется найти и устранить, а затем нажмите кнопку Далее.
  4. Нажмите кнопку Готово, чтобы запустить средство диагностики и устранения неполадок, а затем следуйте появляющимся на экране инструкциям.

Примечания

  • XOX
  • Если устройство отсутствует в списке, выберите Добавление нового устройства и следуйте указаниям на экране.
  • С помощью диспетчера устройств можно также выполнять различные диагностические задачи, в том числе устранение неполадок устройства при неправильной его работе. Эти действия рекомендуется производить только пользователям, обладающим глубокими знаниями в области работы с устройствами и их настройки. XOX
  • Пользователь, не являющийся администратором или членом группы «Администраторы», может выполнять некоторые действия администратора с помощью команды Запуск от имени. XOX


Общие сведения о Plug and Play

Установить устройство Plug and Play очень просто. Достаточно только подключить его, и Windows установит необходимые драйверы, обновит систему и распределит ресурсы. Большинство устройств, изготовленных после 1995 года, используют технологию Plug and Play.

Например, можно пристыковать переносной компьютер к стыковочному узлу и подключиться к сети, не изменяя конфигурацию. Потом этот же компьютер можно отстыковать и подключиться к сети с помощью модема, снова не внося изменений в конфигурацию (Windows выполнит это самостоятельно).

При использовании технологии Plug and Play можно быть уверенным в правильной совместной работе устройств и правильном перезапуске после установки или удаления устройств.

При запуске компьютера распознается новое оборудование и загружаются все необходимые драйверы.

При установке или удалении устройств технология Plug and Play использует параметры электропитания Windows для управления требованиями к питанию аппаратного и периферийного оборудования, выключая устройства или сохраняя электроэнергию, если они не используются. Кроме того, если во время установки или удаления устройств активна другая программа, будет выведено сообщение, что конфигурация компьютера будет изменена и предлагается сохранить данные.

При возникновении неполадок сведения о них заносятся в журнал событий.

Устройства Plug and Play часто имеют разъемы, выглядящие следующим образом:

Разъем USB (тип A) Разъем USB (тип B)

Порты компьютера для устройств Plug and Play обычно выглядят следующим образом:

Порт USB (тип A) Порт USB (тип B)


Поддержка драйверов устройств Plug and Play

Windows устанавливает устройства Plug and Play и их драйверы автоматически. Однако при установке более старой версии драйвера или устройства поддержка Plug and Play может быть ограниченной или отсутствовать вообще.

Использование драйвера Plug and Play при установке устройства не Plug and Play может обеспечить поддержку некоторых функций этого стандарта. Хотя система и не может самостоятельно распознать оборудование и загрузить соответствующие драйверы, технология Plug and Play контролирует процесс установки, размещая ресурсы, взаимодействуя с параметрами электропитания на панели управления и занося записи в журнал событий.

Обычно при установке оборудования, не совместимого со стандартом Plug and Play, необходимо выполнить некоторые шаги ручной настройки. Для изменения параметров старых версий устройств предназначены мастер установки оборудования на панели управления и диспетчер устройств.

Перед удалением устройства Plug and Play необходимо уведомить об этом Windows с помощью диспетчера устройств. Тогда Windows драйверы устройства больше не будут загружаться при запуске компьютера.

Внимание!

  • Чтобы установить устройство с помощью мастера установки оборудования или диспетчера устройств, необходимо войти в систему с учетной записью администратора или члена группы «Администраторы». Если компьютер подключен к сети, установка оборудования может быть запрещена параметрами сетевой политики. Если драйверы устройства уже были загружены администратором, установить устройство можно без прав администратора.


Использование устройств Plug and Play с устройствами ACPI

Чтобы полностью использовать все возможности технологии Plug and Play, необходим компьютер, поддерживающий расширенный интерфейс управления питанием и конфигурациями (ACPI), работающий в этом режиме, и аппаратные устройства, совместимые со стандартом Plug and Play. В компьютерах ACPI настройка компьютера и наблюдение за его состоянием осуществляются операционной системой, а не аппаратным обеспечением.

Операционная система Windows определяет активные программы и управляет всеми требованиями к питанию для подсистем компьютера и периферийного оборудования. С помощью ACPI она при необходимости направляет питание к устройствам, тем самым предотвращая излишние расходы энергии в системе.

Поскольку Windows отслеживает ресурсы и конфигурацию компьютера, можно устанавливаить новые устройства Plug and Play без перезагрузки компьютера. Windows автоматически определяет новое устройство и устанавливает необходимые драйверы. При установке новых устройств на компьютерах других типов могут потребоваться ручная настройка и перезапуск компьютера.


Управление питанием при установке устройств Plug and Play

Для обеспечения эффективной работы системы при установке или удалении устройств технология Plug and Play использует параметры электропитания на панели управления. Параметры электропитания управляют подачей питания к устройствам, подключенным к компьютеру, направляя его к активным и сохраняя для неактивных устройств. Windows автоматически управляет подачей электропитания к устройствам. Тем не менее, параметры некоторых устройств можно настроить с помощью диспетчера устройств.

Для использования параметров электропитания необходимо, чтобы компьютер был снабжен ACPI, а также чтобы их поддержка была предусмотрена изготовителем компьютера. Более подробные сведения можно найти в документации, входящей в комплект поставки компьютера.


Общие сведения о типах устройств

В Windows устройства классифицируются по типам. Типы устройств включают в себя: платы видеоадаптеров, клавиатуры, устройства чтения компакт-дисков, порты и принтеры. В окнах диспетчера устройств и мастера установки оборудования отображается список типов устройств, установленных на данном компьютере.

Типы устройств в свою очередь подразделяются на категории в соответствии с конкретными устройствами. Например, тип «Модемы» включает в себя сотни различных модемов, которые можно установить и использовать с Windows.

Устройства классифицируются также по способу их подключения к компьютеру. Большинство из них постоянно подключено к компьютеру и устанавливается только один раз. Такие устройства доступны при каждом запуске компьютера, если только они не отключены или не удалены. Примерами могут служить звуковые платы, платы видеоадаптеров, модемы и жесткие диски.

Другие устройства рассчитаны на подключение к компьютеру и отключение от него по мере необходимости. Они могут подключаться к соответствующему порту или гнезду расширений, и Windows распознает и настраивает их без перезагрузки компьютера. При отключении таких устройств необходимо лишь сообщать Windows об их извлечении, удалении или отключении. Выключать или перезапускать компьютер не требуется. Устройствами этого типа являются, например, следующие.

  • Платы PC, подключаемые к переносным компьютерам.
  • Оборудование, подключаемое к шине USB или шине IEEE 1394.
  • Стыковочные узлы, поддерживающие горячую стыковку и отстыковку переносных компьютеров.
  • Оборудование, подключаемое к последовательным или параллельным портам.

XOX


Общие сведения о профилях оборудования

Профиль оборудования — это набор инструкций, используемых Windows для определения устройств, которые должны загружаться при запуске компьютера, или параметров для каждого устройства. При первой установке Windows создается профиль оборудования «Profile 1»; для переносных компьютеров профили будут называться «Docked Profile (пристыкованный)» и «Undocked Profile (отстыкованный)». По умолчанию все устройства, присутствующие на компьютере на момент установки Windows, включены в «Profile 1».

Профили оборудования особенно удобны при работе с переносными компьютерами. Обычно такие компьютеры используются в различных местах, и профили оборудования позволяют изменять перечень устройств, применяемых в конкретной ситуации. Например, один профиль, предназначенный для подключения переносного компьютера к стыковочному узлу, можно назвать Конфигурация стыковочного узла. В этот профиль могут входить такие компоненты, как устройство чтения компакт-дисков и сетевой адаптер. Можно создать второй профиль с именем Отстыкованная конфигурация для использования переносного компьютера в отеле или самолете, когда вместо названных устройств используются модем и переносной принтер.

Если в системе имеется несколько профилей оборудования, можно указать среди них тот, который будет использоваться по умолчанию при каждом запуске компьютера. Windows позволяет также отображать при запуске вопрос, какой профиль следует использовать. После создания профиля оборудования устройства, входящие в него, можно отключать и включать с помощью диспетчера устройств. При отключении устройства в профиле оборудования драйверы устройства не загружаются при запуске компьютера. XOX


Дата компиляции

Рисунок Microsoft Windows
Дата компиляции: 2003-12-03


Установка пользовательского интерфейса UPnP

Рисунок Microsoft Windows

Чтобы установить пользовательский интерфейс UPnP

  1. На панели управления откройте компонент Установка и удаление программ.
  2. Нажмите кнопку Установка компонентов Windows.
  3. В списке Компоненты выберите Сетевые службы и нажмите кнопку Состав.
  4. Убедитесь, что флажок Пользовательский интерфейс UPnP установлен.

Примечания

  • XOX
  • Если установка Windows выполнялась с компакт-диска, система предложит вставить компакт-диск в компьютер.


Использование среды UPnP для управления устройствами

Технология UPnP позволяет Windows обнаруживать устройства UPnP и управлять ими. Возможности этих устройств и другие сетевые службы можно использовать непосредственно после подключения к сети. Например, при подключении любого личного цифрового помощника или переносного компьютера можно сразу же использовать принтеры и другие ресурсы сети. В своей основе UPnP имеет очень мало общего как с Plug and Play, так и с non-Plug and Play устройствами.

Windows обнаруживает и существующие устройства UPnP, и добавляемые новые устройства. В обоих случаях при обнаружении устройств в области уведомлений появляется сообщение. Устройства UPnP также отображаются в папке «Сетевое окружение». XOX Для управления устройством UPnP дважды щелкните его значок или просмотрите его свойства, щелкнув его значок правой кнопкой мыши и выбрав Свойства.

Примечания

  • Основной модуль UPnP не устанавливается автоматически при установке Windows. XOX
  • Необходимо установить основной модуль UPnP на всех компьютерах, где требуется просматривать свойства устройств и управлять ими.