Средства администрирования

На компьютере с XOX с помощью удаленного рабочего стола можно управлять любым сервером, на котором установлена система Windows 2000 Professional.

На компьютерах с XOX не используйте средства администрирования Windows 2000 (которые имеются на компакт-диске Windows 2000 Server в виде отдельной консоли MMC) . Средства администрирования Windows 2000 должны быть удалены с компьютеров, на которых установлена система Windows 2000 Professional, перед обновлением до XOX. Если во время обновления Windows 2000 Professional до XOX средства администрирования Windows 2000 будут обнаружены на компьютере, пользователю будет рекомендовано удалить их до продолжения обновления.


Только для Windows Advanced Server

Рисунок Microsoft Windows

Cведения недоступны

Сведения, которые вы пытаетесь найти, относятся к средствам, недоступным в данной версии Windows. В документации по используемой операционной системе эти сведения отсутствуют.

Для возврата к предыдущему разделу нажмите кнопку Назад.


Выбор между NTFS, FAT и FAT32

На компьютере с XOX для разделов диска имеется возможность выбора одной из трех файловых систем: NTFS, FAT и FAT32. Для сравнения этих файловых систем используйте следующие сведения.

Далее перечислены причины, по которым для использования рекомендуется файловая система NTFS.

  • NTFS — более мощная файловая система, чем FAT и FAT32; в ее состав входят возможности, необходимые для обслуживания Active Directory, а также другие важные функции обеспечения безопасности. Только NTFS позволяет использовать таких средства, как Active Directory и система безопасности на основе доменов.
  • Разделы легко преобразуются в формат NTFS. Такое преобразование без труда выполняется с помощью команды установки, независимо от того, какая файловая система перед этим использовалась для раздела — FAT, FAT32 или более ранняя версия NTFS. При таком преобразовании все данные в разделе сохраняются (в отличие от процедуры форматирования диска). Если сохранять файлы, имеющиеся в разделе FAT или FAT32, не требуется, вместо преобразования раздела из формата FAT или FAT32 рекомендуется выполнить форматирование раздела в файловой системе NTFS. В результате форматирования все содержимое раздела уничтожается, и получается чистый диск, готовый к работе.

    Независимо от того, будет раздел отформатирован с помощью NTFS или преобразован с использованием команды convert, NTFS следует признать наилучшей файловой системой. Для получения дополнительных сведений о программе Convert.exe по окончании установки нажмите кнопку Пуск, выберите команду Выполнить, введите cmd и нажмите клавишу ВВОД. В окне программы введите команду help convert и нажмите клавишу ВВОД.

  • Если требуется управлять доступом к файлам и папкам и организовать поддержку учетных записей с ограниченными правами, необходимо использовать NTFS. В случае файловой системы FAT32 все пользователи будут иметь доступ ко всем файлам на жестком диске, независимо от типа учетной записи (администратор, ограниченные права или стандартные права).
  • NTFS лучше всего подходит для работы с большими дисками. (Ей немного уступает в этом отношении файловая система FAT32.)

При определенных обстоятельствах может потребоваться использование файловой системы FAT или FAT32. Это необходимо, если на компьютере планируется работа как в XOX, так и в Windows предыдущей версии. При этом основной (загрузочный) раздел жесткого диска должен иметь файловую систему FAT или FAT32. Более ранние версии Windows, как правило, не могут получить доступ к разделу, использующему последнюю версию NTFS. Исключение составляют операционные системы Windows 2000 и Windows NT 4.0 пакетом обновления 4 (SP4). Windows NT 4.0 пакетом обновления 4 (SP4) или более поздней версии позволяет получить доступ к разделам с NTFS последней версии, но с некоторыми ограничениями: она не имеет доступа к файлам, которые были сохранены с использованием возможностей NTFS, разработанных после выпуска Windows NT 4.0.

В остальных случаях, когда работа в нескольких операционных системах не планируется, рекомендуется выбрать файловую систему NTFS.

Важно!

  • Если диск или раздел преобразован в формат NTFS, его нельзя будет просто преобразовать обратно в формат FAT или FAT32. Необходимо будет переформатировать диск или раздел, что приведет к уничтожению всех содержащихся в нем данных, включая программы и личные файлы.

В следующей таблице приведены данные по совместимости каждой файловой системы с различными операционными системами.

NTFS | FAT | FAT32
Компьютеры под управлением XOX или Windows 2000 имеют доступ к файлам, находящимся в разделе NTFS. Компьютеры под управлением Windows NT 4.0 пакетом обновления 4 (SP4) или более поздним имеют доступ к некоторым файлам. Для других операционных систем доступ отсутствует. | Возможен доступ из MS-DOS, любых версий Windows: Windows NT, Windows 2000, XOX и OS/2. | Доступ только из Windows 95 OSR2, Windows 98, Windows Millennium Edition, Windows 2000 и XOX.

В следующей таблице приведены сравнительные данные по размерам дисков и файлов, допустимых для каждой файловой системы.

NTFS | FAT | FAT32
Рекомендуемый минимальный размер тома равен примерно 10 МБ. Допускаются размеры томов свыше 2 ТБ. Не может использоваться для гибких дисков. | Тома объемом от гибкого диска до 4 ГБ. Домены не поддерживаются. | Тома объемом от 512 МБ до 2 ТБ. XOX позволяет отформатировать в FAT32 тома объемом до 32 ГБ. Домены не поддерживаются.
Максимальный размер файла ограничен только размером тома. | Максимальный размер файла равен 2 ГБ. | Максимальный размер файла равен 4 ГБ.

Примечание

  • Некоторые старые программы не выполняются на томе NTFS, поэтому перед преобразованием необходимо изучить текущие требования для используемого программного обеспечения.

См. также


Настройка старых программ для работы под управлением Windows XP

Рисунок Microsoft Windows

Настройка старых программ для работы под управлением XOX

Большинство программ корректно выполняется в XOX. Исключение составляют некоторые старые игры и другие программы, написанные специально для какой-либо более ранней версии Windows. Чтобы запустить программу в системе XOX, выполните следующие действия.

  1. Запустите мастер совместимости программ. Можно также установить свойства совместимости вручную.
  2. Обновите программу, драйверы или оборудование.

Эти операции подробнее описываются ниже.

Мастер совместимости программ

Этот мастер предлагает протестировать программу в различных режимах (средах) с различными параметрами. Например, если программа изначально предназначена для работы под управлением Windows 95, установите режим совместимости с Windows 95 и попробуйте снова запустить программу. Если попытка окажется удачной, значит, программа будет каждый раз запускаться в этом режиме. Мастер также предоставит возможность попробовать другие параметры, например переключить экран в режим 256 цветов и установить разрешение 640 х 480.

Если проблемы совместимости не позволяют установить программу в XOX, запустите мастер совместимости программ для файла установки этой программы. Такой файл обычно имеет имя Setup.exe или похожее и находится на установочном диске программы.

Чтобы запустить мастер совместимости программ

  1. Запустите мастер совместимости программ.
  2. Следуйте указаниям мастера.

Примечание

  • Чтобы запустить мастер совместимости программ, нажмите кнопку Пуск, выберите команду Справка и поддержка, щелкните ссылку Поиск совместимого оборудования и программ для XOX, затем в группе См. также в области переходов щелкните ссылку Мастер совместимости программ.

Установка свойств совместимости вручную

Вместо того чтобы запускать мастер совместимости программ, можно установить свойства совместимости для программы вручную. Значения этих свойств совпадают с параметрами мастера совместимости программ.

Чтобы вручную установить свойства совместимости для программы

  1. Щелкните правой кнопкой мыши значок запускаемой программы на рабочем столе или ее ярлык в меню Пуск, и затем выберите команду Свойства.
  2. Перейдите на вкладку Совместимость и внесите необходимые изменения в параметры совместимости для данной программы.

Примечания

  • Вкладка Совместимость доступна только для программ, установленных на жестком диске. Несмотря на то что мастер совместимости программ можно запускать для программ или установочных файлов, расположенных на компакт-диске или дискете, эти изменения утратят силу после закрытия программы.
  • Чтобы получить более подробные сведения о каком-либо параметре вкладки Совместимость, щелкните его правой кнопкой мыши и выберите команду Что это такое.

Обновление программы и драйверов

Если программа неправильно работает после тестирования мастером совместимости программ, проверьте, нет ли для нее в Интернете обновлений или исправлений.

  • Поищите обновления на веб-узле производителя программы.
  • Посмотрите, нет ли исправлений для программы на веб-узле Windows Update. Нажмите кнопку Домой в строке меню окна Центр справки и поддержки, а затем щелкните ссылку Windows Update в правой области окна.
  • Если программа — это игра, использующая DirectX, убедитесь, что установлена последняя версия DirectX. Кроме того, проверьте веб-узел изготовителя звуковой или видеоплаты — возможно, там появились новые версии драйверов для этих плат.


Дата компиляции

Рисунок Microsoft Windows
Дата компиляции: 2003-12-03


Управление производительностью компьютера

Распределение ресурсов и управление устройствами зависят от настройки и потребностей операционной системы. Тем не менее производительность компьютера можно повысить, в частности путем изменения режима использования системой Windows времени процессора и памяти.

Управление использованием времени процессора

Обработка данных на системном уровне управляется непосредственно Windows; операционная система может распределять задачи по процессорам, а также выполнять несколько процессов на одном процессоре. Однако Windows можно настроить таким образом, чтобы текущему приложению выделялась большая часть времени процессора. В результате может улучшиться время отклика программ и приложений, используемых в ходе работы. Если же при этом должны выполняться фоновые процессы (такие, как печать или архивация диска), можно настроить Windows на равномерное распределение ресурсов процессора между программами, работающими в фоновом или оперативном режиме.

Управление памятью компьютера

Если компьютер испытывает нехватку свободной оперативной памяти (RAM), а для завершения текущей задачи требуется дополнительная память, Windows использует пространство жесткого диска для моделирования системной оперативной памяти. В Windows такая память называется виртуальной памятью, или файлом подкачки. Этот ресурс является аналогом файла подкачки из UNIX. По умолчанию размер файла подкачки виртуальной памяти (с именем Pagefile.sys), создаваемого в ходе установки, в полтора раза превышает объем оперативной памяти компьютера.

Виртуальную память можно оптимизировать, распределив ее по нескольким дискам, среди которых не должно быть медленных или интенсивно используемых дисков. Чтобы добиться наилучшей оптимизации, используйте для виртуальной памяти максимально возможное число физических жестких дисков. При выборе дисков придерживайтесь следующих правил.

  • Не размещайте файл подкачки на том же диске, где находятся системные файлы.
  • Не размещайте файл подкачки на отказоустойчивых дисках, например на зеркальном томе или томе RAID-5. Для файлов подкачки не требуется обеспечивать отказоусточивость; к тому же некоторые отказоустойчивые системы слишком медленно работают из-за того, что выполняют запись в несколько мест.
  • Не размещайте несколько файлов подкачки в разных разделах одного и того же физического диска.


Преобразование тома в формат NTFS из командной строки

Рисунок Microsoft Windows

Чтобы преобразовать том в формат NTFS из командной строки

  1. XOX
  2. Введите в командной строке:

    3. convert буква_диска: /fs:ntfs

    Например, с помощью команды convert D: /fs:ntfs можно выполнить преобразование диска D в формат NTFS.

Примечания

  • XOX
  • С помощью этой команды можно преобразовывать тома FAT и FAT32 в формат NTFS.


Настройка компьютера с использованием групповой политики

XOX поддерживает несколько способов настройки компьютера. С помощью компонентов панели управления можно изменять внешний вид рабочего стола, звуковое сопровождение конкретных событий в программе, а также форму и скорость перемещения указателя мыши.

Другой метод настройки связан с использованием групповой политики. В среде домена сети групповые политики помогают администраторам настраивать компьютеры сети. В среде, включающей один автономный компьютер или несколько компьютеров, объединенных в рабочую группу, также можно проводить настройку компьютера с использованием групповой политики.

Чтобы открыть групповую политику

  1. Нажмите кнопку Пуск и выберите команду Выполнить.
  2. Введите gpedit.msc и нажмите кнопку ОК.

В открытой оснастке «Групповая политика» имеется два параметра в узле «Политика локального компьютера»: Конфигурация компьютера и Конфигурация пользователя. С помощью параметра Конфигурация компьютера можно устанавливать политики, которые будут применяться к компьютеру независимо от того, кто использует его для входа в сеть. С помощью параметра Конфигурация пользователя можно устанавливать политики, которые будут применяться к каждому пользователю, работающему на компьютере.

Использование групповой политики на компьютере

Среду рабочего стола можно настраивать, включая или выключая те или иные параметры политики. Например, с помощью групповой политики можно удалить значки с рабочего стола, изменить содержимое меню Пуск и упростить структуру панели управления. Можно также добавлять сценарии, которые должны будут выполняться на компьютере при его запуске и завершении работы, при входе пользователей в систему и выходе из нее; допускается даже настройка обозревателя Internet Explorer.

Ниже перечислены основные компоненты, для которых можно устанавливать политики с целью настройки компьютера; в таблице указаны ссылки на разделы справки средства «Административные шаблоны», в которых приводятся сведения по установке групповых политик для каждого компонента.

Компонент | Разделы справки
Операционная система XOX | XOX
Проигрыватель Windows Media | Проигрыватель Windows Media
Internet Explorer | Internet Explorer
NetMeeting | NetMeeting

Использование групповой политики на компьютере, входящем в сетевой домен

Если компьютер входит в корпоративную сеть, у администратора сети может возникнуть необходимость настроить компьютер с использованием соответствующих параметров групповой политики. Эти параметры групповой политики, применяемые администратором сети, имеют более высокий приоритет, чем любые другие параметры групповой политики, установленные пользователем на компьютере.

Дополнительные сведения о параметрах групповой политики, которые были применены к конкретному компьютеру, можно найти в центре справки и поддержки.

Чтобы открыть окно центра справки и поддержки для просмотра сведений о политике

  1. Нажмите кнопку Пуск и выберите команду Справка и поддержка.
  2. В группе Выберите задание щелкните ссылку Использование служебных программ для просмотра информации о компьютере и диагностики неполадок.
  3. В списке Инструменты щелкните ссылку Дополнительные сведения о системе.
  4. В списке Дополнительные сведения о системе щелкните ссылку Просмотр сведений о политике.

Примечания

  • Дополнительные сведения об использовании оснастки «Групповая политика» для задания параметров политики, которые применяются для компьютеров и пользователей, см. в справке по групповой политике.
  • Дополнительные сведения об использовании оснастки «Групповая политика» для задания параметров безопасности, которые применяются для компьютеров и пользователей, см. в справке по локальной безопасности.
  • Для добавления оснастки «Групповая политика» на консоль управления MMC и использования групповой политики при настройке компьютера необходимо иметь права администратора.


Windows Server 2003, Datacenter Edition

Рисунок Microsoft Windows

Cведения недоступны

Сведения, которые вы пытаетесь найти, относятся к средствам, недоступным в данной версии Windows. В документации по используемой операционной системе эти сведения отсутствуют.

Для возврата к предыдущему разделу нажмите кнопку Назад.


Удаление ненужных файлов

Пользователь такой сложной операционной системы как Windows не всегда понимает важность каждого файла, имеющегося на компьютере. Иногда Windows использует файлы для определенных действий, а затем помещает их в папку для временных файлов. На компьютере могут находиться ранее установленные компоненты Windows , которые больше не используются. По различным причинам, например из-за недостатка свободного места на жестком диске, может потребоваться удаление некоторых файлов с диска или освобождение дискового пространства другими способами, если это можно сделать без ущерба для программ.

Воспользуйтесь мастером очистки диска Windows , чтобы выполнить все задачи по очистке пространства на диске, перечисленные ниже.

  • Удаление временных файлов Интернета.
  • Удаление всех файлов программ, загруженных из Интернета (элементов управления ActiveX и приложений Java).
  • Очистка корзины.
  • Удаление временных файлов Windows.
  • Удаление неиспользуемых компонентов Windows.
  • Удаление неиспользуемых программ.

Примечание

  • Чтобы приступить к очистке диска, нажмите кнопку Пуск, выберите команду Выполнить и введите cleanmgr.


Использование службы каталогов Active Directory

Служба каталогов Active Directory для Windows собирает сведения о всех объектах сети, включая пользователей, компьютеры и принтеры, и распространяет эти сведения в сети. Active Directory обеспечивает единую систему именования, описания, поиска, получения, администрирования и защиты сведений об этих ресурсах. В Active Directory интегрированы средства безопасности в виде проверки подлинности при подключении и управления доступом. Благодаря Active Directory можно, однократно войдя в систему, без труда найти нужные ресурсы и работать с ними, в каком бы месте сети они ни находились.

Служба каталогов Active Directory доступна пока только на контроллерах доменов Windows 2000; на клиентских компьютерах могут быть установлены системы Windows NT 4.0, Windows 95, Windows 98, Windows 2000 Professional, XOX и UNIX для рабочих станций. Клиенты могут обладать полным доступом к общим ресурсам внутри домена, но только на компьютерах с XOX, Windows 2000 Professional, Windows 95 или Windows 98 и с установленным клиентским программным обеспечением Active Directory можно использовать Active Directory для запроса сведений об этих общих ресурсах.

В Active Directory такие сетевые ресурсы, как пользователи, группы и компьютеры, представлены в виде объектов. Из этих объектов в сущности и состоит сеть; объекты — это именованные наборы атрибутов, представляющие нечто конкретное, например пользователя, принтер или программу. Например, объект «пользователь» может содержать значения таких атрибутов, как имя и фамилия пользователя и имя, предъявляемое им при входе в систему. В целях систематизации объекты помещаются в контейнеры, которые представляют те или иные организационные структуры (например, отдел маркетинга) или собрания однородных объектов (например, принтеров).

Для получения дополнительных сведений об Active Directory посетите страницу общих сведений об Active Directory (перейдите на узел http://www.microsoft.com/ и выполните поиск строки «active directory overview») на веб-узле Microsoft.


Установка нескольких операционных систем на компьютере

Можно установить несколько операционных систем на компьютере и каждый раз при его запуске выбирать нужную систему. Такие конфигурации называются конфигурациями с двумя операционными системами или с несколькими операционными системами. XOX поддерживает конфигурации, в которых также установлены MS-DOS, Windows 3.1, Windows 95, Windows 98, Windows NT 3.51, Windows NT 4.0 и Windows 2000.

Тома и форматы дисков

Каждая операционная система должна устанавливаться на отдельном томе. Необходимо также убедиться, что загрузочный том отформатирован для соответствующей файловой системы. Если имеется только один том, диск необходимо заново разбить на разделы и переформатировать, чтобы каждая установленная операционная система сохраняла свои файлы и сведения о настройке.

Если требуется установить Windows 95 или Windows 98 с Windows NT 4.0 или Windows 2000, загрузочный том должен быть отформатирован в системе FAT, а не NTFS, поскольку в конфигурациях с несколькими ОС Windows 95 и Windows 98 должны быть установлены на загрузочный том, а эти две системы поддерживают только тома FAT. Windows 95 OSR2, Windows 98, Windows 2000 и XOX поддерживают тома FAT32.

Однако, если отформатировать том с Windows NT 4.0, Windows 2000 или XOX в файловой системе, отличной от NTFS, все особые возможности NTFS будут утеряны. В том числе будут утеряны некоторые возможности XOX, такие как безопасность файловой системы, параметры шифрования файловой системы (EFS), дисковые квоты и внешние хранилища. Аналогично Windows 95 и Windows 98 не могут распознать раздел NTFS и будут определять его как неизвестный. Следовательно, если раздел Windows 98 отформатирован в FAT, а раздел XOX — в NTFS, все файлы в разделе NTFS будут недоступны и невидны при работе под управлением Windows 98.

Операционная система | Поддерживаемая файловая система
MS-DOS | FAT
Windows 3.1 | Файловая система FAT
Windows 95 | Файловая система FAT
Windows 95 OSR2 | FAT, FAT32
Windows 98 | FAT, FAT32
Windows 2000 | FAT32, NTFS
XOX | FAT32, NTFS

Установка на один компьютер MS-DOS, Windows 95 или Windows 98 и XOX

Для уменьшения вероятности возникновения трудностей с установкой операционных систем при конфигурации с несколькими операционными системами, такими как MS-DOS, Windows 95 или Windows 98 и XOX устанавливайте их в следующем порядке: MS-DOS, Windows 95 или Windows 98, а затем XOX.

Если XOX установлена на том, отформатированный как FAT, и есть свободный том, отформатированный как FAT или FAT32, то можно установить Windows 98 на свободный том, не переформатируя жесткий диск.

Убедившись, что жесткий диск отформатирован с помощью подходящей файловой системы, выполните одно из следующих действий.

  • Чтобы настроить конфигурацию с операционными системами MS-DOS, Windows 95 или Windows 98 и XOX, установите сначала MS-DOS, затем Windows 95 или Windows 98, а затем XOX.
  • Чтобы настроить конфигурацию с двумя операционными системами, одна из которых Windows 95 или Windows 98, установите Windows 95 или Windows 98, а затем XOX.

Важно!

До создания конфигурации с несколькими операционными системами, одна из которых XOX, а другая MS-DOS, Windows 95 или Windows 98, обратите внимание на следующие предупреждения.

  • Каждая операционная система должна быть установлена на отдельном томе. Microsoft не поддерживает установку нескольких операционных систем на один том.
  • Если жесткий диск компьютера содержит только один том, то для создания конфигурации с несколькими операционными системами необходимо переформатировать и заново разбить жесткий диск на разделы, кроме случая, когда необходимо просто установить другую копию XOX.
  • Невозможно установить Windows 95 и Windows 98 в конфигурации с несколькими операционными системами. Система Windows 98 разработана как обновление Windows 95 и будет пытаться использовать тот же загрузочный файл.
  • XOX следует устанавливать только после установки MS-DOS, Windows 95 или Windows 98, чтобы MS-DOS или Windows 95 не могли перезаписать загрузочный сектор или загрузочные файлы XOX.
  • Не устанавливайте XOX на диск, сжатый средствами, отличными от средства сжатия для файловой системы NTFS.
  • Если компьютер находится в безопасном домене Windows 2000 или XOX, для каждой операционной системы следует задать различные имена компьютера.

Установка на один компьютер Windows NT 4.0 и XOX

Не рекомендуется долговременное использование конфигурации, в которой установлены и Windows NT 4.0, и XOX. Обновление NTFS в пакете обновления 4 (SP4) для Windows NT 4.0 предназначено только для диагностики и обновления до XOX.

После форматирования диска с помощью необходимой файловой системы установите Windows NT 4.0, а затем установите XOX.

Важно!

До создания конфигурации с несколькими операционными системами, одна из которых XOX, а другая MS-DOS, Windows 95 или Windows 98, обратите внимание на следующие предупреждения.

  • Каждая операционная система должна быть установлена на отдельном томе. Microsoft не поддерживает установку нескольких операционных систем на один том.
  • Если жесткий диск компьютера содержит только один том, то для создания конфигурации с несколькими операционными системами необходимо переформатировать и заново разбить жесткий диск на разделы, кроме случая, когда необходимо просто установить другую копию XOX.
  • Если планируется установка конфигурации с несколькими операционными системами, в состав которой входит определенное сочетание Windows NT 4.0 и Windows 2000 или XOX, обязательно установите пакет обновления 4 для Windows NT 4.0. XOX автоматически обновит все разделы NTFS, которые будут обнаружены в системе, до версии NTFS, которая используется в Windows 2000 и XOX. Однако Windows NT 4.0 требуется пакет обновления 4 (SP4) для чтения и записи файлов на томах, отформатированных в NTFS той версии, которая используется в Windows 2000 и XOX.
  • Не устанавливайте XOX на диск, сжатый средствами, отличными от средства сжатия для файловой системы NTFS.
  • Если компьютер находится в безопасном домене Windows 2000 или XOX, для каждой операционной системы следует задать различные имена компьютера.

Установка программ в нескольких операционных системах

Каждую операционную систему следует рассматривать как существующую отдельно. Все требуемые программы и драйверы должны быть установлены в каждой операционной системе, в которой эти средства предполагается использовать. Например, чтобы использовать Microsoft Word в операционных системах Windows 98 и XOX, установленных на одном компьютере, необходимо запустить Windows 98 и установить Microsoft Word. Затем запустить XOX и снова установить Microsoft Word.

Примечания

  • Если на компьютере установлено несколько операционных систем, то можно выбрать систему, которая будет загружаться по умолчанию при запуске компьютера. XOX
  • При первом запуске Windows 95 или Windows 98 операционная система может изменить параметры оборудования. Это может вызвать проблемы настройки при запуске XOX.


Справка для сообщений об ошибках

В Windows содержатся сведения об устранении некоторых наиболее часто возникающих системных ошибках. Эти сведения помогают быстро установить причину неполадок.

После нажатия кнопки Справка в диалоговом окне сообщения об ошибке будут выведены следующие сведения:

  • подробное описание ошибки;
  • один или несколько способов устранения этой ошибки;
  • список средств и разделов справки, которые могут помочь предотвратить повторение этой ошибки в будущем.


Быстрое переключение пользователей

Если на одном компьютере работает несколько пользователей, процедуры входа в систему и выхода из нее при смене пользователей могут стать довольно утомительными.

Быстрое переключение пользователей, возможность, доступная в XOX и XOX (если компьютер не подключен к домену), позволяет быстро менять пользователя, не завершая текущий сеанс на компьютере. При этом несколько пользователей могут по очереди работать на компьютере, не закрывая свои программы.

Например, предположим, что вы занимаетесь составлением семейного бюджета и вынуждены ненадолго отлучиться. Ваш ребенок изъявляет желание сыграть в игру во время вашего отсутствия. Благодаря средству быстрого переключения пользователей вы можете оставить финансовое приложение в работающем состоянии и позволить ребенку запустить игру. Когда вы вновь войдете в систему, вы вернетесь в то же место файла бюджета, где остановились.

Для переключения нажмите кнопку Пуск, выберите команду Выход из системы, нажмите кнопку Смена пользователя, а затем выберите нового пользователя. Для получения дополнительных сведений о переключении пользователей без выхода из системы щелкните ссылку См. также.

Важно!

  • При использовании быстрого переключения средство альтернативных устройств ввода не будет работать. Это специальное средство, обеспечивающее поддержку альтернативных устройств ввода, таких как устройство с одним переключателем или пневматический манипулятор, которые могут использоваться вместо стандартной клавиатуры или мыши. XOX

Примечания

  • Средство быстрого переключения будет недоступно, если его не включить в компоненте «Учетные записи пользователей» панели управления.
  • Быстрое переключение пользователей недоступно для компьютеров, которые являются членами сетевого домена.
  • Чтобы включить (выключить) средство быстрого переключения пользователей, необходимо войти в систему с учетной записью администратора компьютера.
  • Средство быстрого переключения пользователей нельзя выключить, если на компьютере в систему вошли несколько пользователей.
  • Когда средство быстрого переключения пользователей выключено, программы при выходе из системы закрываются, поэтому после входа в нее следующего пользователя компьютер будет работать быстрее. Сведения о включении средства быстрого переключения пользователей с помощью компонента «Учетные записи пользователей» панели управления см. по ссылке См. также.


Файловые системы

Файловой системой называется общая структура, определяющая именование, сохранение и размещение файлов. Windows поддерживает три файловые системы. FAT, FAT32 и NTFS. Выбор файловой системы осуществляется при установке Windows, форматировании существующего тома и установке нового жесткого диска.

Прежде чем выбирать файловую систему, следует ознакомиться с преимуществами и ограничениями каждой из них. Замена файловой системы тома может занять много времени, поэтому нужно с самого начала выбрать файловую систему, которая лучше всего удовлетворяет текущим и будущим потребностям. Если требуется перейти к другой файловой системе, необходимо выполнить архивацию данных и затем отформатировать том с применением новой файловой системы. Однако том FAT или FAT32 может быть преобразован в том NTFS без переформатирования тома; тем не менее перед преобразованием целесообразно выполнить архивацию тома.


Список средств устранения неполадок

Ниже перечислены средства устранения неполадок, доступные в Windows. Для запуска нужного средства щелкните его имя в левом столбце таблицы.

Средство | Обслуживаемые процессы и компоненты
Установка системы | Установка и настройка Windows
Запуск/завершение | Запуск и завершение работы компьютера
Дисплей | Видеоплаты и видеоадаптеры, включая экран компьютера, устаревшие или несовместимые видеодрайверы и неправильные настройки видеооборудования
Домашняя сеть | Установка, подключение к Интернету, общий доступ к файлам и принтерам
Оборудование | Дисковые накопители (включая дисководы для компакт- и DVD-дисков), игровые устройства, устройства ввода (такие как клавиатуры, мыши, камеры, сканеры и устройства инфракрасной связи), сетевые платы, USB-устройства, модемы и звуковые платы. См. также перечисленные ниже средства устранения неполадок для конкретных устройств
Мультимедиа и игры | Игры и другие мультимедийные программы, драйверы DirectX, устройства USB, диски DVD, звуковое сопровождение, джойстики и связанные с ними вопросы
Цифровые видеодиски (DVD) | Дисководы и декодеры DVD
Устройства ввода | Клавиатуры, мыши, шаровые манипуляторы, камеры, сканеры и устройства инфракрасной связи
Диски и сетевые адаптеры | Жесткие диски, гибкие диски, компакт-диски, диски DVD, сетевые платы, накопители на магнитной ленте, программы архивации
USB | Порты и периферийные устройства USB
Звук | Звук и звуковые платы
Модем | Подключение, установка, настройка и обнаружение модема
Общий доступ к подключению Интернета | Подключение и регистрация у поставщика услуг Интернета
Internet Explorer | Просмотр веб-узлов, загрузка файлов из Интернета, сохранение ссылок на избранные места, использование панелей инструментов обозревателя, печать веб-страниц
Outlook Express (обмен сообщениями) | Outlook Express и Windows Messenger Service
Общий доступ к файлам и принтерам | Совместное использование файлов и принтеров несколькими компьютерами, подключение к другим компьютерам сети, установка сетевых адаптеров, вход в систему
Печать | Установка и подключение принтера, драйверы принтеров, качество печати, скорость работы принтера, шрифты


Использование средств устранения неполадок

Средства устранения неполадок помогают диагностировать и устранять технические неполадки, возникающие в ходе работы компьютера. После запуска средства устранения неполадок необходимо ответить на ряд вопросов об имеющейся неполадке. Эти ответы помогают Windows найти решение проблемы.

В состав системы входит несколько различных средств устранения неполадок, каждое из которых предназначено для решения проблем определенного типа. Чтобы просмотреть полный список средств устранения неполадок Windows, щелкните ссылку См. также.

Чтобы наилучшим образом применять средства устранения неполадок Windows, выполняйте следующие указания.

  • Уберите панель переходов в окне центра справки и поддержки, нажав на панели инструментов справки кнопку Смена представления. Можно также изменить размеры окна, перетащив его границы.
  • Точно следуйте указаниям средства устранения неполадок. В противном случае могут быть пропущены важные сведения, что снизит эффективность применения средства.
  • На некоторых этапах требуется перезагрузить компьютер или закрыть окно средства устранения неполадок. В этом случае запишите (или запомните) ответы на все вопросы, чтобы можно было вернуться в то же место, после которого была предпринята перезагрузка или закрыто окно.


Использование пакета ресурсов Microsoft Internet Explorer 6

Пакет ресурсов Microsoft Internet Explorer 6 содержит техническую информацию и средства, необходимые для успешной настройки, развертывания, управления и поддержки Microsoft Internet Explorer 6. Ищите этот пакет ресурсов в книжных магазинах либо посетите страницу пакета ресурсов Microsoft Internet Explorer 6 на веб-узле корпорации Майкрософт (перейдите на узел http://www.microsoft.com/ и выполните поиск строки "Internet Explorer 6 Resource Kit").

Помимо рабочих средств, на веб-странице пакета ресурсов Microsoft Internet Explorer 6 можно найти документацию на следующие темы:

  • установка и настройка обозревателя;
  • безопасность;
  • поддержка платформ;
  • специальные возможности;
  • подготовительные процедуры;
  • развертывание;
  • администрирование пакета;
  • системные политики и ограничения;
  • устранение неполадок;
  • обучение и поддержка.


Поиск дополнительных сведений на веб-узле Microsoft Personal Support Center

Рисунок Microsoft Windows

Поиск дополнительных сведений на веб-узле центра технической поддержки корпорации Майкрософт

На веб-узле центра технической поддержки корпорации Майкрософт содержатся дополнительные интерактивные ресурсы службы поддержки, мастеры устранения неполадок, элементы, которые можно загрузить, и другие полезные сведения. Статьи интерактивной службы поддержки содержат подробные сведения, помогающие глубже изучить конкретную возможность Windows.

При первом посещении веб-узла центра технической поддержки корпорации Майкрософт необходимо зарегистрировать свое имя и адрес в базе данных. При последующем использовании веб-узла будет сразу отображаться окно поиска.

При поиске на узле центра технической поддержки корпорации Майкрософт можно выбрать основной или расширенный режим. В основном режиме можно быстро, в два этапа, найти необходимые сведения. Для этого следует ввести ключевые слова, связанные с искомым продуктом или технологией. Например, введите Internet Explorer shortcut create web, и будет выдан список статей, содержащих эти слова.

В расширенном режиме можно указать более подробные данные и условия для поиска. Допускается поиск по ключевым словам, номерам статей, именам файлов драйверов, конкретным средствам устранения неполадок; можно использовать также любые сочетания этих методов.

В результатах поиска отображаются все статьи, удовлетворяющие указанным условиям. Просто щелкните нужную статью.

Получить дополнительные сведения или начать поиск можно в разделе интерактивной поддержки продуктов веб-узла корпорации Майкрософт (http://support.microsoft.com/).

Для получения дополнительных сведений о поддержке продукта посетите страницу поддержки Windows (перейдите на узел http://www.microsoft.com/ и выполните поиск строки «поддержка Windows») на веб-узле корпорации Майкрософт.


Поиск потерянных файлов

Рисунок Microsoft Windows

Чтобы найти потерянный файл

Проверьте, нет ли искомого файла в следующих местах.

Папка «Мои документы»

  • XOX

Папка, используемая по умолчанию для сохранения в программе, с помощью которой был открыт или создан файл

  1. Откройте программу.
  2. В меню Файл выберите команду Сохранить как.

    3. В результате будет открыта папка, используемая программой по умолчанию для сохранения файлов.

Выполните поиск

  • Нажмите кнопку Пуск, выберите команду Поиск и выполните одно из следующих действий:
    • для поиска документа щелкните ссылку Документы (текстовых редакторов, электронные таблицы и т.д.);
    • для поиска файла другого типа щелкните Все файлы или папки.

XOX

Папка «Documents and Settings\имя_пользователя»

  1. XOX
  2. Дважды щелкните значок жесткого диска, чтобы отобразить содержимое его корневого каталога. Например, выберите C:\ или D:\.
  3. Дважды щелкните папку Documents and Settings, а затем дважды щелкните папку, соответствующую имени пользователя.

    4. В зависимости от способа установки Windows на компьютер, папка Documents and Settings может отсутствовать.

Папка системный_корневой_каталог\Windows\system32

  1. XOX
  2. Дважды щелкните значок жесткого диска, чтобы отобразить содержимое его корневого каталога. Например, выберите C:\ или D:\.
  3. Дважды щелкните папку системный_корневой_каталог, а затем дважды щелкните папку system32.
  4. В папке «системный_корневой_каталог\system32» дважды щелкните файл или папку, которую требуется открыть.

Корневой каталог

  1. XOX
  2. Дважды щелкните значок жесткого диска, чтобы отобразить содержимое его корневого каталога. Например, выберите C:\ или D:\.

Папки программы, использовавшейся для открытия или создания файла

  1. XOX
  2. Дважды щелкните значок жесткого диска, чтобы отобразить содержимое его корневого каталога. Например, выберите C:\ или D:\.
  3. Дважды щелкните папку Program Files, а затем дважды щелкните файл или папку, которую следует открыть.

    4. Например, если документ был создан в Microsoft Word, файл мог быть сохранен в одной из папок, связанных с Microsoft Word.


NTFS

Далее перечислены возможности, предоставляемые файловой системой NTFS.

  • Домены, которые входят в состав Active Directory и позволяют настраивать средства безопасности, не усложняя задачи администрирования. Для работы контроллеров домена необходимо использовать файловую систему NTFS.
  • Шифрование файлов, значительно повышающее безопасность.
  • Разрешения, которые могут устанавливаться как для отдельных файлов, так и для папок.
  • Разреженные файлы. Это файлы очень больших размеров, но создаваемые в приложениях таким образом, что для их хранения требуется немного места на диске. В связи с этим NTFS выделяет дисковое пространство только для тех частей файла, в которые производится запись данных.
  • Служба внешнего хранилища, позволяющая расширить дисковое пространство путем организации удобного доступа к съемным носителям, таким как магнитные ленты.
  • Ведение журнала метаданных NTFS, который помогает быстро восстанавливать данные в случае сбоя электропитания или других неполадок в системе. Это позволяет получить доступ к тому сразу после перезагрузки компьютера без запуска программы chkdsk.exe.
  • Дисковые квоты, с помощью которых можно управлять объемом дискового пространства, выделяемого конкретным пользователям.
  • Улучшенные возможности масштабирования при переходе к дискам больших размеров. Максимальный размер диска для NTFS значительно превышает максимальный размер диска для FAT, причем, в отличие от FAT, при увеличении размера диска производительность не снижается.

Программа установки позволяет легко преобразовать имеющийся раздел в формат новой версии NTFS, даже если для этого раздела использовалась файловая система FAT или FAT32. При таком преобразовании все файлы в разделе сохраняются (в отличие от процедуры форматирования раздела).

Установка начинается с проверки имеющейся файловой системы. Если это система NTFS, преобразование не требуется. Если используется файловая система FAT или FAT32, программа установки позволяет инициировать преобразование в формат NTFS. Если не требуется сохранять файлы, имеющиеся в разделе FAT или FAT32, вместо преобразования раздела из формата FAT или FAT32 рекомендуется выполнить форматирование раздела в файловой системе NTFS. В результате форматирования все содержимое раздела уничтожается и получается чистый диск, готовый к работе.

Независимо от способа создания раздела NTFS (форматирование или преобразование), применение данной файловой системы является предпочтительным. Преобразование также можно выполнить после установки с помощью программы Convert.exe. Для получения дополнительных сведений о программе Convert.exe по окончании установки нажмите кнопку Пуск, выберите команду Выполнить, введите cmd и нажмите клавишу ВВОД. В окне программы введите команду help convert и нажмите клавишу ВВОД.


Только для дополнительных компонентов

Рисунок Microsoft Windows

Cведения в настоящее время недоступны

Искомые сведения отображаются только в документации дополнительно устанавливаемого компонента Windows. Чтобы эти сведения стали доступны для чтения, необходимо сначала установить соответствующий компонент.

Для установки новых компонентов Windows используйте компонент «Установка и удаление программ» на панели управления. Следуйте указаниям мастера компонентов Windows.


Общие сведения о паспорте .NET

Паспорт .NET обеспечивает персонифицированный доступ к некоторым службам и веб-узлам с помощью адреса электронной почты. Паспорт обеспечивает единую регистрацию, позволяя предъявлять лишь одно имя пользователя и один пароль.

Получив паспорт, можно с одним именем и паролем использовать все службы, поддерживающие паспорт .NET.

Можно хранить личные данные в профиле службы .NET Passport, чтобы их не нужно было повторно вводить при использовании различных служб, поддерживающих паспорт.

Защита личных сведений в паспорте осуществляется с помощью мощной технологии шифрования и сложных политик конфиденциальности. Также паспорт позволяет управлять списком служб, имеющих доступ к вашим личным сведениям, включая адреса электронной и обычной почты. Более подробные сведения об этом содержатся в заявлении о защите личных сведений службы .NET Passport. Также эта служба помогает защитить вашу конфиденциальность на компьютерах, доступ к которым имеют другие люди.

Паспорт можно получить с помощью мастера паспорта .NET в компоненте «Учетные записи пользователей».

Откройте Мастер цифрового паспорта .NET.

Дополнительные сведения о паспортах и способах их получения см. по ссылке См. также.

Примечания

  • XOX
  • Если компьютер входит в домен, перейдите на вкладку Дополнительно и нажмите кнопку Мастер цифрового паспорта .NET.
  • Если компьютер не входит в домен и используется учетная запись администратора компьютера, выберите ее имя и установите переключатель Что вы хотите изменить в своей учетной записи? в положение Настроить учетную запись на использование цифрового паспорта .NET.
  • Если компьютер не входит в домен и используется учетная запись с ограниченными правами, в списке Выберите задание выберите вариант Настроить учетную запись на использование цифрового паспорта .NET.


Связывание и внедрение

Вырезание сведений из одного документа и вставка их в другой — эффективный метод повторного использования данных. Вставленные в новый документ данные становятся его неотъемлемой частью. При внесении изменений в данные, хранящиеся в исходном документе, эти изменения не будут отражены в фрагменте, вставленном в другой документ.

Приложения Windows, поддерживающие перетаскивание мышью, допускают использование связывания и внедрения для передачи сведений из одного документа в другой, даже если документы открыты в разных программах.

Связывание — это вставка скопированных данных в документ, при которой поддерживается связь с исходным файлом. Связывание подразумевает автоматическое обновление вставленных сведений при внесении изменений в исходный документ. Для связывания выделенных данных воспользуйтесь командами Копировать и Специальная вставка в меню Правка. Для связывания файла с документом воспользуйтесь командой Объект в меню Вставка. Например, чтобы использовать в других документах текст, созданный в программе WordPad, выберите в меню Вставка команду Объект и вставьте этот текст в документ в виде связанного файла WordPad. После этого при каждом внесении изменений в содержимое файла WordPad эти изменения будут автоматически отражены во всех остальных документах, связанных с данным файлом WordPad. (Не все программы поддерживают связывание.)

Внедрение — это вставка данных (например, текста или рисунка), созданных в одной программе, в документ, открываемый в другой программе. Внедренные данные, или объекты, становятся частью нового документа. Изменения, внесенные в исходный документ, не будут отражаться в новом документе. Для редактирования внедренного объекта дважды щелкните его; будет открыта программа, в которой был создан объект. Чтобы выполнить редактирование внедренного объекта, необходимо предварительно установить на компьютере программу, в которой объект был создан (или любую другую программу, в которой объект может редактироваться). После завершения редактирования объекта и возврата в документ все сделанные изменения отобразятся в документе. Для внедрения выделенных данных воспользуйтесь командами Копировать и Вставить в меню Правка.

Связывание применяется в случае, когда требуется обеспечить динамическое обновление данных в соответствии с изменением исходного файла. Внедрение применяется в случае, если данные необходимо редактировать отдельно от исходного файла или если исходный файл в будущем может оказаться недоступным.


Защита от вирусов и троянских коней

В современном компьютеризированном мире важную роль играет защита от несанкционированного проникновения на компьютер и в сеть с помощью вирусов и троянских коней. Чтобы предотвратить заражение вирусами и атаки троянских коней, придерживайтесь следующих рекомендаций.

Пользователям

  • Старайтесь узнать как можно больше о вирусах и способах их распространения. Вирус можно случайно занести в сеть, запустив программу, полученную, например, из Интернета, с электронной доски объявлений (Bulletin Board System, BBS) или в виде вложения в сообщение электронной почты.
  • Наиболее общие признаки заражения вирусами следующие: на экране появляются необычные сообщения, снижается производительность системы, отсутствуют некоторые данные или невозможно получить доступ к жесткому диску. При возникновении подобных неполадок на компьютере немедленно запустите антивирусную программу, чтобы снизить вероятность потери данных.
  • Программы на дискетах также могут содержать вирусы. Проверяйте все дискеты на наличие вирусов, прежде чем копировать или открывать содержащиеся на них файлы или выполнять загрузку компьютера с таких дискет.
  • Необходимо приобрести хотя бы одну коммерческую антивирусную программу и регулярно пользоваться ею для проверки компьютеров. Поскольку новые вирусы создаются каждый день, старайтесь оперативно пополнять свой набор файлов сигнатур вирусов новыми сигнатурами.

Администраторам

  • Прежде чем размещать новое приложение в сети, установите его на компьютере, не подключенном к сети, и проверьте с помощью антивирусных средств. (Вообще говоря, в свою систему рекомендуется входить в качестве члена группы «Пользователи», однако установку программы для проверки следует выполнять, войдя в систему с учетной записью члена локальной группы «Администраторы», так как не все программы успешно устанавливаются членами группы «Пользователи».)
  • Не разрешайте пользователям входить на их компьютеры с учетными записями членов группы «Администраторы», поскольку вирусы становятся гораздо опаснее, если они активизируются от имени учетной записи с правами администратора. Пользователи должны входить в систему как члены группы «Пользователи»; таким образом они будут обладать лишь разрешениями, необходимыми для выполнения своих задач.
  • Требуйте от пользователей создавать надежные пароли, чтобы вирусы не могли легко подобрать пароль и получить разрешения администратора. (Требования к паролям можно установить с помощью оснастки «Групповая политика».) Сведения о создании надежных паролей см. по ссылке См. также.
  • Регулярное архивирование файлов позволит минимизировать ущерб от вирусной атаки.

Примечание

  • Для получения дополнительных сведений о вирусах обратитесь к документации антивирусной программы.


Реестр Windows

В Windows сведения о конфигурации хранятся в базе данных, которая называется реестр. (С Windows поставляется программа-редактор реестра regedit.exe.) В реестре хранятся профили всех пользователей компьютера, а также сведения об оборудовании системы, установленных программах и параметрах настройки. Windows обращается к этим сведениям во время работы.

Существуют специальные редакторы реестра, позволяющие просматривать и модифицировать реестр. Однако пользователь, вообще говоря, не должен делать это сам. Вместо этого позвольте программам Windows изменять системный реестр при необходимости. Категорически не рекомендуется изменять параметры реестра самостоятельно.

Внимание!

  • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра необходимо по крайней мере выполнить архивацию всех ценных данных, содержащихся на компьютере.

Если система все же повреждена, реестр можно исправить или восстановить в том виде, который он имел в момент последнего удачного запуска компьютера. В противном случае следует переустановить Windows. При переустановке системы внесенные в нее изменения (например, связанные с установкой пакетов обновления) могут быть утеряны, и их потребуется повторять отдельно. Сведения о восстановлении предыдущего состояния реестра см. по ссылке См. также.


Включение прослушивания по протоколу RIP

Рисунок Microsoft Windows

Чтобы включить прослушивание по протоколу RIP

XOX

  1. На панели управления откройте компонент Установка и удаление программ.
  2. Нажмите кнопку Установка компонентов Windows.
  3. В списке Компоненты выделите элемент Сетевые службы (не устанавливая и не снимая соответствующий флажок) и нажмите кнопку Состав.
  4. Установите флажок Слушатель RIP и нажмите кнопку ОК.
  5. Нажмите кнопку Далее и следуйте указаниям мастера.

Примечания

  • XOX
  • После включения прослушивания по протоколу RIP (так называемого пассивного режима RIP) компьютер может узнавать другие маршруты сети, прослушивая сообщения RIP и добавляя их IP-адреса в таблицу маршрутизации. Поэтому не нужно вручную добавлять маршруты в таблицу маршрутизации. Эта служба может быть полезной в некоторых конфигурациях удаленного доступа к сети, например если компьютер подключается в качестве клиента удаленного доступа к корпоративной сети. В данном случае Windows может прослушивать и динамически обновлять таблицу маршрутизации, используемую по умолчанию, чтобы включить дополнительные маршруты, допустимые в корпоративной сети. Дополнительные маршруты могут повысить эффективность сетевого доступа и быстродействие удаленного подключения, так как снижается количество пакетов, ошибочно отправляемых не на тот маршрутизатор.
  • Служба маршрутизации и удаленного доступа Microsoft (RRAS) может быть настроена для отправки либо пакетов RIPv1, либо RIPv2, либо пакетов обоих типов. Однако в режиме прослушивания RIP отслеживаются и обновляются только сведения о маршрутах, которые отправляются маршрутизаторами, использующими RIPv1.
  • Некоторые компоненты Windows требуют настройки до начала использования. Если один или несколько таких компонентов были установлены, но не были настроены, при нажатии кнопки Добавление компонентов Windows отображается список компонентов, требующих настройки. Чтобы запустить мастер компонентов Windows, выберите параметр Компоненты.


Удаленный доступ к справке Windows 2000 Server

В этом разделе объясняется, как работать со справочной системой Windows 2000 Server или Windows 2000 Advanced Server на удаленном компьютере.

Файлы справки Windows 2000 Server обычно находятся в каталоге C:\Winnt\Help или C:\Windows\Help. Эти файлы связаны между собой, образуя интегрированную справочную систему, в которой содержатся ссылки, используемые для открытия различных средств администрирования. Файлы справки занимают около 30 МБ дискового пространства.

Получить доступ к справке Windows 2000 Server можно различными способами. У каждого из них есть свои преимущества, поэтому следует применять тот вариант, который лучше всего подходит к конкретной ситуации или удовлетворяет политике администрирования, принятой в организации.

  • Разрешение доступа на чтение папки со справочными файлами, находящейся на сервере. Пользователи и группы, которым предоставлено разрешение на чтение этой папки, могут осуществлять доступ к справочной системе. При этом ссылки, используемые для открытия средств администрирования сервера, будут действовать при условии, если пользователь обладает необходимыми правами. Следует иметь в виду, что предоставление доступа к ресурсам сервера, даже если разрешается только чтение, может ослабить систему безопасности. Для запуска справки Windows 2000 Server из общей папки дважды щелкните файл Windows.chm или создайте его ярлык.
  • Копирование всех справочных файлов в общую папку в сети. Можно скопировать все справочные файлы на другой компьютер в сети. После этого предоставьте соответствующим пользователям или группам разрешение на чтение данной общей папки. При этом ссылки, используемые для открытия средств администрирования, не будут функционировать. Для запуска справки Windows 2000 Server из общей папки дважды щелкните файл Windows.chm или создайте его ярлык.
  • Копирование всех справочных файлов на локальный компьютер. Можно скопировать все справочные файлы на локальный компьютер. Следите за тем, чтобы не скопировать их в локальную папку Windows\Help (или winnt\Help, если система XOX была установлена в результате обновления предыдущей версии Windows), иначе они будут записаны поверх файлов локального компьютера. Если скопировать справочные файлы сервера в локальную папку Windows\Help, некоторые разделы в окне центра справки и поддержки могут стать недоступными. Следует также иметь в виду, что ссылки, используемые для открытия средств администрирования, не будут действовать в скопированных файлах. Для запуска справки из папки на локальном компьютере дважды щелкните файл Windows.chm или создайте его ярлык.
  • Печать разделов серверной справочной системы. Разделы, перечисленные в содержании справки Windows 2000 Server, можно вывести на печать. Для этого на вкладке Содержание щелкните нужный заголовок правой кнопкой мыши и выберите команду Печать. Чтобы напечатать только содержимое, появляющееся в правой части окна при открытии данного заголовка, выберите вариант Напечатать текущий раздел. Чтобы напечатать все материалы, входящие в данный раздел (книгу), выберите вариант Напечатать все содержимое текущего заголовка. Прежде чем печатать подразделы, просмотрите их, чтобы оценить размер задания печати.
  • Просмотр файлов справки на веб-узле Microsoft. Можно просматривать обновленные файлы справки для Windows 2000 Server и Windows 2000 Advanced Server на домашних страницах веб-узла Windows. Сведения о Windows 2000 Server и Windows 2000 Advanced Server см. на веб-узле Microsoft (http://www.microsoft.com/).

Примечание

  • Копируя файлы из папки справки, убедитесь, что скопированы все файлы (включая скрытые файлы), иначе справочная система не сможет правильно работать.


Защита компьютера

Для обеспечения безопасности компьютера необходимо организовать защиту отдельных файлов и папок и принять меры к физической защите самого компьютера. Если на компьютере имеются конфиденциальные сведения, они должны храниться в безопасном месте.

Другими способами защиты компьютера являются его блокировка на время отсутствия пользователя на рабочем месте и настройка экранной заставки, защищенной паролем. Нажав одновременно клавиши CTRL, ALT и DEL, а затем кнопку Блокировка, можно предотвратить доступ пользователей, не прошедших проверку, на компьютер. Разблокировать его сможет только владелец и члены группы администраторов компьютера. (Для разблокирования компьютера нужно нажать одновременно клавиши CTRL, ALT и DEL, ввести пароль, а затем нажать кнопку ОК.) Можно также настроить заставку таким образом, чтобы она открывалась и автоматически блокировала компьютер после того, как он простаивал в течение определенного времени.


Запись сведений о цифровой подписи в файл журнала

Рисунок Microsoft Windows

Чтобы записать сведения о цифровой подписи в файл журнала

  1. Откройте окно Проверка подписи файла.
  2. Нажмите кнопку Дополнительно.
  3. На вкладке Ведение журнала установите флажок Сохранять результаты проверки подписи в журнале.
  4. Выберите один из следующих режимов.
    • Добавление в существующий файл: добавление результатов нового поиска в конец имеющегося файла журнала.
    • Перезапись существующего файла: замена существующего файла журнала новым.
  5. В поле Имя файла журнала введите имя файла, в котором будет сохранен журнал.

    6. Если с помощью программы проверки подписи файла проверять наличие цифровой подписи у системных файлов, результаты поиска будут записываться в этот файл.

  6. Нажмите кнопку ОК, а затем кнопку Начать.

Примечания

  • Чтобы запустить программу проверки подписи файла, в меню Пуск выберите команду Выполнить, введите sigverif и нажмите кнопку ОК.
  • Если требуется просто перезаписать файл журнала, выберите в меню Пуск команду Выполнить, введите sigverif /defscan и нажмите кнопку ОК.


Проверка наличия цифровой подписи у системных файлов

Рисунок Microsoft Windows

Чтобы проверить наличие цифровой подписи у системных файлов

  1. Откройте окно Проверка подписи файла.
  2. Нажмите кнопку Начать.

    Программа проверки подписи файла отыскивает системные файлы и файлы драйверов устройств, имеющие цифровую подпись, и отображает результаты. Если ведется журнал, результаты поиска также записываются в файл журнала. XOX

Примечание

  • Чтобы запустить программу проверки подписи файла, выберите в меню Пуск команду Выполнить, введите sigverif и нажмите кнопку ОК.


Проверка цифровых подписей системных и прочих файлов

Рисунок Microsoft Windows

Чтобы проверить цифровые подписи системных и прочих файлов

  1. Откройте окно Проверка подписи файла.
  2. Нажмите кнопку Дополнительно.
  3. На вкладке Поиск выберите один из следующих параметров.
    • Уведомлять о неподписанных системных файлах

      • Проверяет наличие цифровой подписи только в системных файлах Windows и всех файлах драйверов устройств.

    • Искать другие файлы, не подписанные цифровой подписью

      • Позволяет указать тип и местоположение несистемных файлов для проверки на наличие цифровой подписи.

  4. Нажмите кнопку ОК, а затем кнопку Начать.

Примечание

  • Чтобы запустить программу проверки подписи файла, выберите в меню Пуск команду Выполнить, введите sigverif и нажмите кнопку ОК.


Использование программы проверки подписи файла

Иногда при установке на компьютере новых программ системные файлы и файлы драйверов устройств заменяются несовместимыми версиями или версиями, не имеющими цифровой подписи, что приводит к нестабильной работе системы. Системные файлы и файлы драйверов устройств, поставляемые с XOX, имеют цифровую подпись корпорации Майкрософт, наличие которой указывает, что это оригинальные неизмененные системные файлы либо что они были одобрены корпорацией Майкрософт для использования в Windows. С помощью программы проверки подписи файла можно находить на компьютере неподписанные файлы и получать следующие сведения о них:

  • имя файла;
  • местоположение файла;
  • дата изменения файла;
  • тип файла;
  • номер версии файла.

Откройте окно Проверка подписи файла.

Примечание

  • Чтобы запустить программу проверки подписи файла, выберите в меню Пуск команду Выполнить, введите sigverif и нажмите кнопку ОК.


Защита файлов Windows

В версиях Windows, предшествующих Windows 2000, установка дополнительного программного обеспечения операционной системы может привести к перезаписи общих системных файлов, таких как библиотеки динамической компоновки (DLL) и исполняемые файлы (EXE). Это вызывало непредсказуемые изменения системной производительности, нестабильную работу программ и сбои операционной системы.

Защита файлов в Windows 2000 и XOX предотвращает замещение защищенных системных файлов, таких как файлы SYS, DLL, OCX, TTF, FON и EXE. Защита файлов Windows выполняется в фоновом режиме и защищает все файлы, установленные программой установки Windows.

Защита файлов Windows определяет попытки других программ заменить или переместить защищенные системные файлы. Защита файлов Windows проверяет цифровую подпись файла, чтобы определить правильность версии нового файла корпорации Майкрософт. Если версия файла является неправильной, защита файлов Windows заменяет файл либо из архива, хранящегося в папке Dllcache, либо с компакт-диска Windows. Если соответствующий файл найти не удается, предлагается ввести его местоположение. Также в журнал событий заносится запись о попытке замены файла.

По умолчанию защита файлов Windows всегда включена и разрешает замену существующих файлов файлами Windows с цифровой подписью. В настоящее время подписанные файлы распространяются следующими способами:

  • в пакетах обновления Windows;
  • в пакетах исправлений;
  • в составе обновлений операционной системы;
  • в обновлениях, полученных с помощью средства Windows Update;
  • устанавливаются диспетчером устройств и установщиком классов Windows.


Использование программы regedit.exe

Редактор реестра (regedit.exe) позволяет просматривать, искать и изменять параметры в системном реестре, который содержит сведения о том, как должен работать компьютер. Несмотря на то что редактор реестра предоставляет возможности просмотра и изменения реестра, делать это не рекомендуется, поскольку внесение неправильных изменений может привести к повреждению системы.

Иногда все же возникает необходимость в применении редактора реестра для корректировки (с помощью технического специалиста) определенных системных параметров.

Программа Regedit.exe автоматически устанавливается вместе с Windows и хранится в папке, в которой установлена операционная система.

Чтобы запустить программу regedit.exe

  1. Нажмите кнопку Пуск и выберите команду Выполнить.
  2. Введите regedit и нажмите кнопку ОК.


Устранение неполадок в компонентах DirectX

Для выявления и устранения проблем, связанных с DirectX, используются средство диагностики DirectX и средство устранения неполадок игр и мультимедиа. Средство диагностики DirectX помогает тестировать работу компонентов DirectX, диагностировать неполадки и устанавливать уровень аппаратной поддержки для DirectX, что позволяет избежать многих проблем на некоторых дисках мультимедиа. Программа диагностики DirectX (Dxdiag.exe) устанавливается вместе с DirectX; для ее запуска достаточно выбрать в меню Пуск команду Выполнить и ввести dxdiag. Для получения сведений об использовании средства диагностики DirectX нажмите кнопку Справка в окне этой программы.

  • Откройте окно Средство диагностики DirectX.

Средство устранения неполадок игр и мультимедиа помогает выявлять и устранять проблемы, связанные с драйверами и играми DirectX.

  • Откройте окно Устранение неполадок в игровых и мультимедийных программах.


Удаление Windows XP

Рисунок Microsoft Windows

Удаление XOX

В редких случаях возникают обстоятельства, при которых может потребоваться удалить XOX и вернуться к исходной операционной системе.

Примечание

  • XOX
  1. На панели управления откройте компонент Установка и удаление программ.
  2. В списке программ щелкните XOX и нажмите кнопку Заменить/удалить.
  3. Нажмите кнопку Удалить XOX, а затем — кнопку Продолжить.
  4. Если после обновления предыдущей системы до XOX какие-либо программы были изменены, будет отображено предупреждение. Просмотрите его и, если процесс удаления следует продолжить, нажмите кнопку Продолжить.
  5. Для подтверждения удаления XOX нажмите кнопку Да.

    6. Произойдет автоматическая перезагрузка компьютера. Убедитесь, что в дисководах нет гибких дисков, и нажмите кнопку Да.

Важно!

  • Удаление XOX невозможно в следующих случаях:
    • была изменена конфигурация жесткого диска, например было выполнено преобразование из FAT в NTFS или созданы новые разделы;
    • была обновлена операционная система Windows NT 4.0 или Windows 2000;
  • Программы, измененные после обновления до XOX, будут неработоспособны после ее удаления. Например:
    • если была удалена какая-либо программа, а затем была удалена XOX, некоторые компоненты программы (например, ссылки в меню Пуск) будут восстановлены процессом удаления системы, а другие компоненты (например, файлы программы) восстановлены не будут;
    • если была добавлена какая-то программа, а затем была удалена XOX, некоторые компоненты программы (например, параметры реестра) будут утеряны.
    • если программы изменялись, по окончании процесса удаления системы могут появиться сообщения об ошибках.

Примечания

  • XOX
  • XOX предупредит обо всех возможных неполадках до начала процесса удаления. Чтобы исправить эти неполадки, повторно внесите изменения после удаления XOX.
  • Новые файлы, добавленные на компьютер под управлением XOX, не будут удалены. Это относится к таким файлам, как электронные таблицы, сообщения электронной почты, ярлыки рабочего стола, файлы программ и т. п. Некоторые из этих файлов могут быть созданы во время работы приложений, например документы текстового редактора.
  • Если новая версия программы была установлена под управлением XOX, некоторые документы могут стать недоступными, если в предыдущей версии операционной системы была установлена более старая версия этой программы. Например, предположим, что на компьютере имеется финансовая программа. Если в XOX была установлена новая версия этой финансовой программы, файлы документов могли быть преобразованы в новый формат. После удаления XOX необходимо будет установить ту же самую новую версию этой финансовой программы, чтобы получить доступ к документам.


Информация и поддержка в Интернете

Ниже приведен список ссылок на веб-узлы, на которых содержатся дополнительные сведения о Windows.

Домашняя страница Windows

Последние сведения о Windows.

Домашняя страница Windows (http://www.microsoft.com/windows)

Поддержка программных продуктов

Дополнительная техническая информация о Windows.

Поддержка продуктов (http://www.microsoft.com/support)

Загрузка

Обновления системы, драйверы устройств и новые возможности Windows на странице Windows Update.

Windows Update (http://windowsupdate.microsoft.com)

Совместимость продуктов

Список совместимых с Windows продуктов.

Совместимость продуктов (http://www.microsoft.com/windows)

Развертывание

Технические руководства по развертыванию Windows.

Развертывание (http://www.microsoft.com/windows)

Пакет ресурсов

Веб-узлы пакетов Windows Resource Kit.

Пакеты Resource Kit (http://windows.microsoft.com/windows2000/reskit)

Специальные возможности

Сведения о ресурсах, связанных со специальными возможностями.

Специальные возможности (http://www.microsoft.com/enable)


Что такое DirectX

Windows поддерживает программу DirectX версии 8.1, существенно расширяющую мультимедийные возможности компьютера. DirectX обеспечивает доступ к функциям дисплея и аудиоплаты, которые позволяют реализовать в программах реалистичную трехмерную графику и впечатляющие музыкальные и звуковые эффекты. DirectX представляет собой набор интерфейсов прикладного программирования (API), обеспечивающих для программ Windows поддержку высокопроизводительных технологий мультимедиа с аппаратным ускорением.

DirectX позволяет приложению определить аппаратные возможности компьютера, а затем устанавливает соответствующие параметры приложения. Это позволяет выполнять мультимедийные программы на любом компьютере под управлением операционной системы Windows с оборудованием и драйверами, совместимыми с DirectX, а также обеспечивает оптимальное использование оборудования этими программами.

API-интерфейсы DirectX обеспечивают доступ к новейшим возможностям высокопроизводительных устройств, таких как микросхемы ускорения трехмерной графики и звуковые платы. Эти интерфейсы управляют функциями нижнего уровня, в том числе ускорением двумерной графики, поддержкой устройств ввода, таких, как джойстик, клавиатура и мышь, а также микшированием и выводом звука. Данные функции нижнего уровня поддерживаются следующими компонентами DirectX.

Microsoft DirectDraw

Интерфейс программирования Microsoft DirectDraw обеспечивает очень быстрый прямой доступ к возможностям видеоадаптеров компьютера, поддерживающих ускорение графики. Этот интерфейс поддерживает стандартные методы отображения графики для всех видеоадаптеров, а также более быстрый и более непосредственный доступ при использовании драйверов ускоренной обработки. DirectDraw позволяет программам (например, играм и графическим пакетам двухмерной графики и системным компонентам Windows (например, цифровым аудиокодекам) получать, вне зависимости от устройства, доступ к возможностям конкретных устройств отображения, не запрашивая дополнительных сведений у пользователя о возможностях устройства.

Microsoft Direct3D

Интерфейс программирования Microsoft Direct3D (Direct3D) является интерфейсом функций обработки объемной графики, встроенных в большинство современных видеоадаптеров. Direct3D — это API-интерфейс трехмерной графики нижнего уровня, позволяющий приложениям эффективно взаимодействовать с аппаратными ускорителями независимым от оборудования способом. Direct3D включает поддержку специализированных наборов процессорных команд, что обеспечивает дополнительное ускорение на новых моделях компьютеров.

Microsoft DirectSound

Интерфейс программирования Microsoft DirectSound обеспечивает связь между программами и возможностями микширования, воспроизведения и захвата звука звукового адаптера. DirectSound предоставляет приложениям мультимедиа возможности микширования с небольшой задержкой, аппаратного ускорения и прямого доступа к звуковому устройству. При этом поддерживается совместимость с существующими драйверами устройств.

Microsoft DirectMusic

Интерфейс программирования Microsoft DirectMusic является интерактивным аудиокомпонентом DirectX. В отличие от интерфейса DirectSound, служащего для записи и воспроизведения цифрового звука, DirectMusic работает с цифровыми аудиоданными, а также с музыкальными данными, управляемыми при помощи сообщений и преобразуемыми в цифровой аудиоформат либо звуковой платой, либо встроенным программным синтезатором. DirectMusic поддерживает ввод в формате MIDI (Musical Instrument Digital Interface), допуская как сжатые, так и распакованные цифровые аудиоданные. С помощью DirectMusic разработчики программного обеспечения могут создавать насыщенные динамические фонограммы, способные реагировать на самые разнообразные изменения в программной среде, в том числе на ввод данных пользователем.

Microsoft DirectInput

Интерфейс программирования Microsoft DirectInput предоставляет дополнительные возможности обработки входных данных для игр и позволяет обрабатывать сигналы джойстика так же, как и сигналы таких устройств, как мышь, клавиатура и игровые устройства с обратной связью по усилию.

Microsoft DirectPlay

Интерфейс программирования Microsoft DirectPlay поддерживает игровые подключения с помощью модема, через Интернет или локальную сеть. DirectPlay облегчает доступ к средствам связи и обеспечивает взаимодействие одной игры с другой независимо от протокола или интерактивной службы. DirectPlay предоставляет услуги по проведению подготовительных действий, упрощающих инициализацию игры с несколькими участниками, и поддерживает надежные коммуникационные протоколы, исключающие потерю важных данных в сети во время игры. Среди новых возможностей DirectPlay 8.0 следует отметить поддержку голосовой связи через сеть, которая сможет существенно повысить уровень игр с участием команд игроков, а также внесет новое качество в игры социального характера, позволив их участникам разговаривать друг с другом.

Microsoft DirectShow

Интерфейс программирования Microsoft DirectShow обеспечивает высококачественный захват и воспроизведение мультимедийных файлов, расположенных на локальном компьютере и на серверах в Интернете. DirectShow поддерживает широкий набор форматов аудио и видео, включая файлы ASF, AVI, DV, MPEG, MP3, WMA/WMV и WAV. DirectShow обеспечивает запись видеоизображения, вопроизведение дисков DVD, монтаж видеоматериалов, декодирование видео с аппаратным ускорением и настройку аналоговых и цифровых сигналов телевещания.


Создание загрузочного диска MS-DOS

Рисунок Microsoft Windows

Чтобы создать загрузочную дискету MS-DOS

Создаваемая загрузочная дискета MS-DOS позволит выполнять загрузку в MS-DOS.

  1. Вставьте дискету в дисковод гибких дисков.
  2. Откройте окно Мой компьютер и выберите используемый дисковод гибких дисков.
  3. В меню Файл выберите команду Форматировать.
  4. В разделе Способы форматирования установите флажок Создание загрузочного диска MS-DOS.
  5. Нажмите кнопку Начать.

Важно!

  • Создание загрузочной дискеты MS-DOS приведет к удалению всех данных с дискеты.

Примечания

  • XOX
  • Загрузочная дискета MS-DOS позволяет выполнять загрузку только в командную строку MS-DOS. Никаких дополнительных средств на диске не содержится.


Форматирование диска

Рисунок Microsoft Windows

Чтобы отформатировать диск

  1. Если требуется отформатировать гибкий диск, вставьте его в дисковод. В противном случае перейдите к шагу 2.
  2. Откройте окно Мой компьютер и выделите диск, который требуется отформатировать.
  3. В меню Файл выберите команду Форматировать.
  4. Задайте следующие параметры:
    • Емкость
    • Файловая система
    • Размер кластера
    • Метка тома
    • Быстрое форматирование
    • Использовать сжатие (только для дисков NTFS)
    • Создание загрузочной дискеты MS-DOS
  5. Нажмите кнопку Начать.

Важно!

  • Форматирование приводит к полному уничтожению всех данных на диске.

Примечания

  • XOX
  • Режим Быстрое форматирование означает удаление файлов с диска без проверки на наличие дефектных секторов. Используйте этот параметр, только если диск ранее уже был отформатирован и наверняка исправен. Для получения дополнительных сведений о каком-либо из перечисленных параметров щелкните вопросительный знак в правом верхнем углу диалогового окна Форматирование и затем щелкните сам параметр.
  • Диск нельзя форматировать, если на нем открыты файлы, на экране отображается его содержимое или на диске находится системный или загрузочный раздел.
  • Диск можно также отформатировать с помощью оснастки «Управление дисками». XOX


Определение объема свободного пространства на диске

Рисунок Microsoft Windows

Чтобы определить объем свободного пространства на диске

  1. Откройте окно Мой компьютер.
  2. Установите указатель мыши на диск, подлежащий проверке. На экране в виде подсказки появятся значения общей емкости диска и объема свободного пространства.

Примечания

  • XOX
  • Если в окне имеется строка состояния, объем свободного пространства отображается в этой строке в нижней части экрана. Если сведения об объеме свободного пространства не видны, перетащите правую границу окна, чтобы увеличить окно. Для отображения строки состояния в меню Вид выберите команду Строка состояния.
  • Можно также просмотреть объем свободного пространства и другие свойства диска, щелкнув диск правой кнопкой мыши и затем выбрав команду Свойства.


Присвоение имени диску

Рисунок Microsoft Windows

Чтобы присвоить имя диску

  1. Откройте окно Мой компьютер и выберите диск, которому требуется присвоить имя.
  2. В меню Файл выберите команду Свойства.
  3. Введите имя для диска в поле, расположенном рядом со значком диска.

Примечания

  • XOX
  • Чтобы заменить имеющуюся метку, выделите ее и наберите новое имя.
  • Если диск отформатирован с помощью файловой системы FAT, его метка может содержать до 11 символов. Если на компьютере используется файловая система NTFS, длина имени ограничена 32 символами.


Общие сведения о проигрывателе Windows Media

С помощью проигрывателя Windows Media можно воспроизводить компакт-диски и DVD-диски, создавать собственные компакт-диски, слушать радиопередачи, отыскивать и систематизировать цифровые мультимедийные файлы, а также копировать файлы на переносное устройство.

Подробнее о проигрывателе Windows Media можно узнать, прочитав следующие разделы справки.

  • Использование общих элементов управления для воспроизведения звука. Содержит сведения о воспроизведении и прокрутке файлов, об изменении громкости, о просмотре свойств файлов и статистики, а также сведений о содержимом.
  • Использование компакт-дисков. Содержит сведения о проигрывании и копировании компакт-дисков, о просмотре сведений о компакт-дисках через Интернет, а также о создании собственных компакт-дисков.
  • Использование DVD-дисков. Содержит сведения о проигрывании DVD-дисков, об использовании субтитров, изменении языковых параметров и просмотре сведений о DVD-дисках.
  • Прослушивание радиостанций. Содержит сведения о поиске и прослушивании радиостанций через Интернет.
  • Хранение цифровых мультимедийных файлов. Содержит сведения о возможностях мультимедийной библиотеки.
  • Поиск файлов Windows Media в Интернете. Содержит сведения об использовании средства «Media Guide» для поиска мультимедийных файлов в Интернете.
  • Копирование файлов на переносное устройство. Содержит список процедур для копирования аудио- и видеофайлов на переносное устройство.
  • Использование клавиатуры. Содержит список сочетаний клавиш клавиатуры для использования с проигрывателем Windows Media.

Дополнительные сведения см. в следующих разделах.

  • Использование проигрывателя Windows Media
  • Панели и кнопки проигрывателя
  • Изменение внешнего вида проигрывателя посредством смены обложек


Выбор программы для создания документа

Выбор программы для создания документа зависит от его сложности. Какое требуется форматирование? Содержатся ли в документе рисунки или таблицы? Будет ли документ открываться и изменяться в других операционных системах? Каковы размеры документа? Является ли документ веб-страницей?

В Windows имеется две программы для обработки слов: «Блокнот» и WordPad. В каждой из них поддерживаются основные возможности редактирования текста, но какие-то задачи один из текстовых редакторов может выполнять лучше, чем другой.

Прежде чем выбрать текстовый редактор, определите, какие средства необходимы для создания документа.

Форматирование текста

Блокнот поддерживает только наиболее общее форматирование текста. В нем можно задавать шрифт и вставлять символы табуляции. Шрифт применяется ко всему документу, а не к отдельным абзацам или словам и не сохраняется вместе с файлом. При просмотре файла на другом компьютере будет использоваться шрифт, доступный на этом компьютере.

WordPad позволяет создавать более сложные документы и поддерживает большинство возможностей типичного текстового редактора. Имеется возможность изменять шрифт как для всего документа, так и для отдельного слова. Нажатием кнопки можно вставлять маркеры в текст WordPad или выравнивать абзац по правому или левому краю. Все форматирование сохраняется в документе, поэтому при последующем открытии он будет отображаться в том виде, в котором был создан.

Текстовые редакторы предоставляют такие дополнительные возможности форматирования текста, как автоматическая нумерация строк, создание столбцов и вставка рамок.

Таблицы

Если в файле предполагается использовать таблицы, для его создания, скорее всего, нужно использовать текстовый редактор. В документе блокнота или WordPad можно создать таблицу, но для этого придется считать символы или вставлять символы табуляции для выравнивания столбцов. Текстовые редакторы, как правило, сами разделяют столбцы и строки и автоматически переносят текст в пределах столбца.

Графика

Блокнот не поддерживает графику. В документ WordPad можно вставлять рисунки, используя связывание или внедрение, а затем изменять их. Практически все текстовые редакторы позволяют работать с графикой.

Настройка страницы

Настройка основных параметров страницы поддерживается и в блокноте, и в WordPad. Можно задавать поля, добавлять колонтитулы и изменять ориентацию печати документа (книжная или альбомная). В других текстовых редакторах могут предоставляться дополнительные возможности.

Большие документы

Чем сложнее документ, тем больше времени занимает его открытие и изменение. Блокнот и WordPad представляют собой достаточно простые программы, они быстро запускаются и открывают файлы, поэтому их удобнее использовать при работе с небольшими документами.

Текстовые редакторы предназначены для более крупных и более сложных документов. Текстовые редакторы предоставляют больше возможностей для работы с документами, чем блокнот и WordPad. Как правило, они позволяют добавлять сноски, делать пометки и даже автоматически создавать оглавление документов. Большинство текстовых редакторов поддерживают использование макросов и шаблонов, помогающих автоматизировать такие повторяющиеся задачи, как ввод имени автора или форматирование заголовков. Обычно в текстовых редакторах имеется возможность автоматической проверки орфографии и грамматики.

Поддержка различных операционных систем

«Блокнот» является простейшим текстовым редактором, который чаще всего используется для просмотра и редактирования текстовых файлов, таких как файлы «Readme.txt», имеющиеся в различных программах Windows. Текстовые файлы необходимы, если к документам предоставляется общий доступ для пользователей других операционных систем, таких, как Macintosh или UNIX. WordPad также позволяет сохранять файлы в формате редактора Word; таким образом можно редактировать файлы, созданные в Word, даже если эта программа на компьютере отсутствует.

Использование нескольких языков

Блокнот и WordPad позволяют сохранять файлы в различных форматах, таких как Юникод, что обеспечивает большую гибкость при работе с документами, использующими разные наборы символов или созданными в других программах.

Большинство текстовых редакторов также позволяют сохранять файлы в различных форматах. В некоторых из них поддерживается использование нескольких языков и даже нескольких словарей для проверки орфографии. При работе в WordPad документы, использующие несколько языков, должны сохраняться в формате RTF.

Веб-страницы и формат HTML

Многие создатели веб-страниц и других документов в формате HTML считают блокнот весьма удобным средством для создания файлов HTML. Блокнот предоставляет минимальные средства оформления, поэтому здесь исключена вероятность случайного сохранения специальных атрибутов форматирования в текстовых файлах. Это особенно важно иметь в виду при создании документов HTML для веб-страницы, так как присутствие специальных символов или других атрибутов форматирования на опубликованной веб-странице может оказаться нежелательным или даже вызвать ошибки.

Во многих текстовых редакторах имеются дополнительные средства или программы преобразования формата, помогающие создавать документы HTML. Но для создания простых страниц или для быстрого внесения небольших изменений лучше использовать блокнот, который очень быстро открывает файлы. Кроме того, в блокноте видны все теги HTML, так что здесь удобно устранять ошибки в коде страницы. Не все текстовые редакторы и программы преобразования позволяют работать с кодом HTML.

Если требуется создавать только простые документы, в этом случае вам лучше всего подходит блокнот. Щелкните здесь, чтобы открыть блокнот. Для более сложных задач следует использовать WordPad или другой текстовый редактор. Щелкните здесь, чтобы открыть WordPad.

Примечания

  • XOX
  • XOX
  • Сведения об использовании блокнота см. в меню Справка этой программы. Сведения об использовании WordPad см. в меню Справка этой программы.


Использование специальных символов

При создании документов может возникнуть необходимость использовать в тексте такие специальные символы, как товарный знак (™) или знак градуса (°). XOX Можно выполнять копирование и вставку необходимых символов из таблицы символов в документ.

Если в таблице символов нужный символ отсутствует, можно создать свой символ с помощью редактора личных символов (Private Character Editor, PCE). Он позволяет создавать специальные буквы, эмблемы и идеограммы и связывать их с библиотекой шрифтов для последующего использования.