Групповая политика

Оснастка Групповая политика используется для определения параметров политики, которые будут применяться к компьютерам или пользователям.

  • Перед использованием оснастки «Групповая политика» просмотрите разделы Контрольные списки
    • .
  • Описание некоторых возможностей, изменившихся в Windows ХР, см. в разделе Новые способы выполнения некоторых задач.
    • .
  • Рекомендации по использованию оснастки «Групповая политика» см. в разделе Советы и рекомендации
    • .
  • Справочные сведения по выполнению конкретных задач см. в разделе Инструкции.
  • Сведения общего характера см. в разделе Основные понятия.
  • Источники дополнительных сведений см. в разделе Ресурсы.
  • Инструкции по устранению неполадок см. в разделе Устранение неполадок.


Контрольные списки

В этом разделе рассмотрены следующие темы.

  • Контрольный список: применение групповой политики в Active Directory
  • Контрольный список: применение локальной групповой политики
  • Контрольный список: открытие оснастки «Установка программного обеспечения»


Контрольный список: применение групповой политики в Active Directory

Действие | Справочные сведения
Ознакомьтесь с общими сведениями о групповой политике и Active Directory. Общие сведенияя о групповой политике;
Active Directory — пользователи и компьютеры
Установите операционную систему Windows 2000 на компьютеры-клиенты.

Важно!

  • Клиентские компьютеры под управлением Windows NT 4.0, Windows 95, Windows 98, Windows ME и Windows XP Home Edition не могут управляться посредством групповой политики.
Для установки операционной системы с компакт-диска обратитесь к печатной документации, поставляемой с компакт-диском.
После запуска Active Directory и групповой политики службы удаленной установки позволяют выполнять удаленную установку операционной системы на множество компьютеров.
Установите контроллер домена | Чтобы установить контроллер домена
Определите используемую структуру Active Directory. Советы и рекомендации;
Планирование структуры сайтов;
Планирование структуры доменов;
Планирование структуры DNS
Ознакомьтесь с материалами о групповой политике. | Групповая политика
Откройте групповую политику. Открытие оснастки «Групповая политика»;
Способы открытия оснастки «Групповая политика»


Контрольный список: применение локальной групповой политики

Действие | Справочные сведения
Ознакомьтесь с основными понятиями о политике локальной группы. | Объекты групповой политики; Политика локальной группы
Установите Windows XP Professional на локальном компьютере. | Следуйте инструкция, поставляемым с установочным диском.
Откройте групповую политику для редактирования оснастки «Политика локальной группы». | Открытие оснастки «Групповая политика»; Способы открытия оснастки «Групповая политика»


Контрольный список: открытие оснастки «Установка программного обеспечения»

Действие | Справочные сведения
Ознакомьтесь с основными понятиями об установке программ, групповой политике и об Active Directory. Пользователи и компьютеры Active Directory;
Основные сведения о групповой политике;
Оснастка «Установка программного обеспечения»
Установите групповую политику в организации. | Контрольный список: применение групповой политики в Active Directory
Откройте групповую политику для применения ее к сайту, домену или подразделению, содержащему пользователей и компьютеры, которым следует получить программное обеспечение. Открытие оснастки «Групповая политика»;
Способы открытия оснастки «Групповая политика»
Обеспечьте наличие пакетов установщика Windows (.msi) для программного обеспечения. | Обратитесь к поставщику программного обеспечения
Откройте оснастку «Установка программного обеспечения». | Чтобы открыть оснастку «Установка программного обеспечения»


Новые способы выполнения типичных задач

В операционной системе Windows NT 4.0 имеется редактор системной политики, используемый для создания системной политики, контролирующей окружение пользователя и его действия и определяющей настройки системных параметров для всех компьютеров, работающих под управлением Windows NT 4.0. Параметры политики задают различные компоненты в рабочем окружении, включая приложения, доступные пользователю, приложения, отображаемые на рабочих столах пользователей, и команды, отображающиеся в меню Пуск.

Пользователи, которые обновляют операционную систему с Windows NT 4.0 до Windows XP, знакомы с многими инструментами групповой политики и ее расширениями. В следующей таблице приведены различия между Windows NT 4.0 и Windows XP, касающиеся создания системной политики.

Задача | Средство Windows NT 4.0 | Средство Windows XP
Установка политик для пользователей и компьютеров сайта | Не применяется | Групповая политика, доступна посредством оснастки Active Directory — сайты и службы
Установка политик для пользователей и компьютеров домена | Редактор системной политики (poledit.exe) | Групповая политика, доступная с помощью оснастки Active Directory — пользователи и компьютеры
Установка политик для пользователей и компьютеров подразделения | Не применяется | Групповая политика, доступная с помощью оснастки Active Directory — пользователи и компьютеры
Использование групп безопасности для фильтрации в области политики | Не применяется | Редактирование записи разрешений для действия Применение групповой политики на вкладке Безопасность диалогового окна свойств объекта групповой политики.
Управление программным обеспечением Для администраторов — сервер Systems Management Server. Для пользователей — компонент панели управления «Установка и удаление программ» Сервер Systems Management Server и три компонента установки и сопровождения программ:
  • Установка программного обеспечения, расширение оснастки «Групповая политика»
  • Установщик Windows
  • Компонент панели управления «Установка и удаление программ»
Создание безопасного пользовательского интерфейса для редактирования реестра Административные шаблоны в формате Windows NT 4.0 для редактора системной политики Административные шаблоны в формате Windows XP для групповой политики

Сведения об изменении роли файлов .adm в Windows ХР см. в разделе Роль административных шаблонов.
Выполнение основных административных задач Мастер администрирования, диспетчер пользователей и диспетчер серверов Оснастки консоли управления MMC, в частности,
Active Directory — пользователи и компьютеры,
Active Directory — сайты и службы
и Групповая политика, а также их расширения

При переходе с Windows 2000 на Windows XP пользователи оценят просто использования политики «Перенаправления папки», особенности которой описаны в следующей таблице.

Задача | Средство в Windows 2000 | Средство Windows XP
Перенаправление особой папки в сетевой ресурс использованием пути в формате UNC, индивидуальном для каждого пользователя | Путь UNC должен содержать %имя_пользователя%, например \\server\share\%имя_пользователя%\Мои документы | Диалоговое окно свойств специальной папки, см. раздел Чтобы перенаправить специальные папки в корневой каталог


Советы и рекомендации

В данном разделе содержатся рекомендации по решению большинства задач, связанных с групповой политикой, перенаправлением папки и установкой программного обеспечения.

Инструкции по устранению неполадок см. в разделе Устранение неполадок. Другие источники сведений, включая веб-ссылки, см. в разделе Ресурсы.

Групповая политика

Отключите неиспользуемые части объекта групповой политики.

  • Если папки объекта групповой политики Конфигурация пользователя или Конфигурация компьютера в оснасткеГрупповая политика содержат только параметры, для которых установлено состояние Не задан, имеется возможность отключить обработку этих параметров путем отключения узла «Конфигурация пользователя» или «Конфигурация компьютера». Это ускорит запуск компьютеров и вход пользователей, к которым применяется данный объект групповой политики.

    Дополнительные сведения см. в следующих разделах.

    • Чтобы отключить параметры конфигурации пользователя в объекте групповой политики
    • Чтобы отключить параметры конфигурации компьютера в объекте групповой политики
  • Чтобы прекратить воздействие объекта групповой политики на сайт, домен или подразделение, см. разделы Чтобы отключить связь объекта групповой политики с сайтом, доменом или подразделением и Чтобы отключить связь объекта групповой политики. При этом сохраняется возможность включить или повторно связать объект групповой политики позднее.
  • Если этот объект больше не понадобится, см. раздел Чтобы удалить объект групповой политики.

Используйте параметры «Блокирование политики наследования» и «Не перекрывать» в ограниченном объеме.

  • Активное применение этих параметров затрудняет устранение неполадок. Если их необходимо использовать, см. разделы Чтобы блокировать наследование политики и Чтобы запретить перекрывание объекта групповой политики.

Используйте оптимальные соглашения об именах объектов групповой политики.

  • Не рекомендуется, например, использовать одинаковые имена для различных объектов групповой политики. Использование одинаковых имен не приведет к неправильной работе групповой политики, однако, может вызвать путаницу.

Внимание!

  • Если для объекта групповой политики вводится имя длиной более 255 символов, оно без предупреждения обрезается до 255 символов.

Минимизируйте количество объектов групповой политики, применяемых к пользователям в домене или подразделении.

  • Большое количество объектов групповой политики, применяемых к пользователю, замедляет его вход в систему.

Применение фильтра к групповой политике в соответствии с членством в группе безопасности.

  • Пользователи, у которых нет записи управления доступом (ACE), указывающей на определенный объект групповой политики, применяемый к ним, могут избежать задержек при входе в систему, поскольку объект групповой политики к ним неприменим.
  • Фильтрование может быть выполнено только с использованием членства в группах безопасности. Дополнительные сведения см. в разделе Применение фильтра к групповой политике в соответствии с членством в группе безопасности.
  • Записи ACE отображаются на вкладке Безопасность диалогового окна свойств объекта групповой политики.

Перекрывайте групповую политику пользователя групповой политикой компьютера только при необходимости.

  • Используйте эту возможность только в случае необходимости настроить одинаковый вид рабочего стола, не зависящий от пользователя, вошедшего в систему. Дополнительный параметр групповой политики «Замыкание на себя» удобно использовать в некоторых закрытых управляемых средах, например в лабораториях, классах, Интернет-салонах и приемных. Параметр «Замыкание на себя» расположен в дереве консоли оснастки «Групповая политика».

    Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера
    • Административные шаблоны
    • Система
    • Групповая политика
    • Режим обработки замыкания пользовательской групповой политики

Используйте групповую политику вместо системной политики.

Системную политику следует использовать только для управления компьютерами, на которых установлена более ранняя по сравнению с Windows 2000 версия операционной системы или при необходимости управления рабочими столами для нескольких пользователей на отдельных компьютерах. Дополнительные сведения см. в разделе Сведения о миграции.

Избегайте междоменного назначения объектов групповой политики.

  • Обработка объектов групповой политики замедляет запуск и вход в систему, если групповая политика извлекается из другого домена.

Не устанавливайте политику файловой системы на диск или папку (например, «Sysvol»), реплицируемую посредством системы репликации NTFS (FRS).

  • Параметры политики файловой системы в консоли «Групповая политика» могут вызвать избыточную репликацию, переполнение диска и снижение пропускной способности сети.

    Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера
    • Конфигурация Windows
    • Параметры безопасности
    • Файловая система

Установка и управление программным обеспечением

Определите категории приложений для организации.

  • Использование категорий упростит пользователям поиск приложений в окне «Установка и удаление программ» на панели управления. Например, могут быть заданы категории «Приложения для отдела продаж», «Бухгалтерские приложения» и так далее. Дополнительные сведения см. в разделе Чтобы задать категории для управляемых приложений.

Перед назначением или публикацией убедитесь в правильном преобразовании пакетов установщика Windows.

  • Помните, что преобразователи применяются к пакетам в момент назначения или публикации. Преобразователи (файлы .mst) — настройки, применимые к пакетам установщика Windows. Преобразователь применяется во время назначения или публикации и не применяется во время установки. На практике это означает, что до нажатия клавиши OK необходимо убедиться, что на вкладке Модификации в диалоговом окне свойств пакета установлен необходимый путь. Если это не сделано и приложение было назначено или опубликовано до его полной настройки, то его можно либо удалить, либо назначить или опубликовать заново, либо обновить его полностью преобразованной версией. Дополнительные сведения о данных процедурах см. в разделах Чтобы удалить управляемое приложение и Чтобы обновить приложения. Кроме того, см. раздел Работа с модификациями пакета.

Назначайте и публикуйте программы в объекте групповой политики только один раз.

  • Не рекомендуется использовать пакет установщика Windows для назначения или публикации приложения более одного раза в одном объекте групповой политики. Например, можно назначить Microsoft Office для компьютеров, на которые воздействует объект групповой политики, а затем не назначать и не публиковать его для пользователей, на которых влияет этот объект. Дополнительные сведения см. в разделах Чтобы назначить приложение и Чтобы опубликовать приложение.

Используйте преимущества средств разработки.

  • Разработчики, знакомые с файлами, записями реестра и другими требованиями, необходимыми для правильной работы приложения, могут создать простые пакеты установщика Windows, используя доступные средства от различных поставщиков программного обеспечения.

Используйте пакеты для существующего программного обеспечения.

  • С помощью средств, поставляемых независимыми поставщиками, имеется возможность создавать пакеты установщика Windows для программного обеспечения, изначально не содержащего MSI-файлы. Они сравнивают состояние компьютера до и после установки. Для достижения наилучших результатов устанавливайте эти средства на компьютер, на котором не установлено другое программное обеспечение («чистая» установка).

Используйте сервер Systems Management Server и распределенную файловую систему DFS.

  • Сервер Microsoft Systems Management Server и распределенная файловая система DFS полезны для управления точками распространения программного обеспечения (общими ресурсами сети, из которых пользователи устанавливают управляемое программное обеспечение).

Назначайте и публикуйте приложения на высшем уровне иерархии Active Directory.

  • Поскольку параметры групповой политики по умолчанию применяются к дочерним контейнерам Active Directory, оптимальным является назначать или публиковать приложения путем связывания объекта групповой политики с родительским подразделением или доменом. Для улучшения контроля над пользователями, получившими программное обеспечение, используйте дескрипторы безопасности (ACE) в объекте групповой политики. Дополнительные сведения см. в разделе Применение фильтра к групповой политике в соответствии с членством в группе безопасности.

Используйте обязательное обновление вместо необязательного.

  • Сведения о правильной процедуре обновления (обязательного и необязательного) см. в разделе Чтобы обновить приложение.
  • На вкладке Обновления для пакета в оснастке «Установка программного обеспечения» имеется параметр Обязательное обновление для уже установленных приложений. Рекомендуется устанавливать данный флажок. Если два пользователя испольуют приложение на одном компьютере и один из них обновит приложение, а другой — нет, на компьютере будут присутствовать обе версии приложения. Некоторые приложения не поддерживают такую конфигурацию.

    Диалоговое окно совйст пакета расположено в дереве консоли оснастки «Групповая политика».

    Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения
    • Имя пакета

Примечания

  • Для пользователей, прошедших проверку, необходимо задать разрешения на «Чтение» и «Применение групповой политики», чтобы они имели возможность устанавливать приложения из точки распространения программ.
  • Для управления программным обеспечением необходимо установить «Полный доступ» для администраторов.

Используйте свойства установки программного обеспечения для расширения возможностей управления.

  • В дереве консоли щелкните правой кнопкой узел Установка программного обеспечения и выберите команду Свойства.

    Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения

    Это поможет усократить количество необходимых действий при назначении или публикации большого числа пакетов с одинаковыми свойствами в одном объекте групповой политики. Например, если нужно опубликовать все программное обеспечение пришедшее из одной точки распространения. Описание процедур см. в разделе Задание параметров для оснастки «Установка программного обеспечения».

Используйте свойства пакета установщика Windows для улучшения управления.

  • Перейдите к узлу «Установка программного обеспечения», как указано выше, щелкните правой кнопкой нужный пакет в области сведений и выберите команду Свойства. Используйте эту процедуру для назначения и публикации отдельных пакетов. Описание процедур см. в разделе Работа с приложениями.

Перенаправление папки

Позвольте создать эту папку системе.

  • Если эта папка создается вручную, на нее не будут установлены необходимые разрешения.
  • Если необходимо создать эту папку вручную или она уже создана, сведения из секции «Разрешения для перенаправления папки» в разделе Перенаправление папки могут оказаться неприменимыми.

Не перенаправляйте папку «Мои документы» в домашнюю папку, за исключением тех случаев, когда в организации уже развернуты домашние папки.

  • Перенаправление в домашнюю папку снижает уровень безопасности по сравнению со стандартным перенаправлением и используется только для обеспечения обратной совместимости. Дополнительные сведения см. в разделах Перенаправление папки и Чтобы перенаправить папку «Мои документы» в домашнюю папку.

Если папка «Мои документы» перенаправлена в домашнюю папку и пользователь входит в систему с клиента сервера терминалов, не следует указывать отдельную домашнюю папку служб терминалов.

  • В диалоговом окне свойств пользователя в Active Directory имеется вкладка Профиль, на которой задается значение параметра Домашняя папка, и вкладка Профиль служб терминалов, где может быть задано значение параметра Домашняя папка служб терминалов. Если эти сетевые папки различаются, подключение к серверу терминалов вызывает копирование домашней папки профиля в домашнюю папку служб терминалов. При отключении от сервера терминалов данные копируются в обратном направлении. Это может быть нежелательно, так как замедляются процессы входа и выхода пользователей из системы. Дополнительные сведения см. в разделе Чтобы перенаправить папку «Мои документы» в домашнюю папку.

Задействуйте кэширование на стороне клиента.

  • Это особенно важно для пользователей с портативными компьютерами. Сведения о настройке для совместной работы перенаправления папки и автономных файлов см. в разделе Перенаправлениек папки.
  • Всегда включайте параметр групповой политики «Синхронизовать перед выходом из системы».

    Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Административные шаблоны
    • Сеть
    • Автономные файлы
    Включение данного параметра обеспечивает полную синхронизацию автономных файлов и доступность всен файлов из перенаправленной папки пользователя при автономной работе. Если этот параметр не включен, в системе выполняется только быстрая синхронизация, в результате кэшируются только недавно использовавшиеся файлы.

Используйте полные пути в формате UNC, например \\server\share.

  • Хотя есть возможность использовать пути типа C:\Foldername, это не рекомендуется, поскольку такой путь может не существовать на другом компьютере.

Внимание!

  • Пути в формате UNC доиной более 260 символов обрезаются. Если путь обрезан, перенаправление не будет выполнено.

Располагайте папку «Мои рисунки» вместе с папкой «Мои документы».

  • Это рекомендуется за исключением тех случаев, когда необходимо разделять эти папки (например, для обеспечения масштабируемости совместного доступа к файлам).

Запомните конфигурацию при удалении политики.

  • Следует запомнить конфигурацию политики перенаправления папки при ее удалении, как описано в в таблице удаления политики в разделе Удаление папки. Изменения значения параметра перенаправления на Не задана не вызывает перенаправления папки в место, определяемое локальным профилем пользователя. Папка по прежнему останется перенаправленной в заданное расположение. При необходимости вернуть папку в расположение, определяемое локальным профилем пользователя, используйте параметр «Перенаправлять в место, определяемое локальным профилем», как описано в разделе Чтобы перенаправить специальные папки в расположение локального профиля.

Использйте значения параметров по умолчанию.

  • В общем случае, политики «Перенаправление папки» можно принять значения параметров по умолчанию.


Инструкции

  • Открытие оснастки «Групповая политика»
  • Работа с объектами групповой политики
  • Работа со свойствами объектов групповой политики
  • Использование административных шаблонов
  • Использование сценариев
  • Использование оснастки «Установка программного обеспечения»
  • Использование оснастки «Перенаправление папки»
  • Настройка групповой политики
  • Делегирование управления групповой политикой


Открытие оснастки «Групповая политика»

  • Открытие оснастки «Групповая политика» из окна «Active Directory - пользователи и компьютеры»
  • Открытие оснастки «Групповая политика» из окна «Active Directory - сайты и службы»
  • Открытие оснастки «Групповая политика» как автономной оснастки MMC


Открытие оснастки «Групповая политика» из оснастки «Active Directory — пользователи и компьютеры»

Рисунок Microsoft Windows

Чтобы открыть оснастку «Групповая политика» из оснастки «Active Directory — пользователи и компьютеры»

  1. Откройте оснастку Active Directory — пользователи и компьютеры.
  2. В дереве консоли щелкните правой кнопкой мыши домен или подразделение, для которых требуется задать групповую политику.

    Расположение

    • Пользователи и компьютеры Active Directory [имя_контроллера_домена.имя_домена]
    • домен
    • подразделение
    • дочернее подразделение
  3. Выберите Свойства и откройте вкладку Групповая политика.
  4. В раскрывающемся списке выберите имеющийся объект групповой политики, а затем нажмите кнопку Изменить.

    или

    Или нажмите кнопку Создать для создания нового объекта групповой политики, а затем нажмите кнопку Изменить.

Примечание

  • Для запуска оснастки «Active Directory — пользователи и компьютеры» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
См. также


Открытие оснастки «Групповая политика» из оснастки «Active Directory — сайты и службы»

Рисунок Microsoft Windows

Чтобы открыть оснастку «Групповая политика» из оснастки «Active Directory — сайты и службы»

  1. Откройте оснастку Active Directory — сайты и службы.
  2. В дереве консоли выберите сайт, для которого необходимо задать групповую политику.

    Расположение

    • Active Directory — сайты и службы [имя_контроллера_домена.имя_домена]
    • Сайты
    • имя сайта
  3. Выберите Свойства и откройте вкладку Групповая политика.
  4. В раскрывающемся списке выберите имеющийся объект групповой политики, а затем нажмите кнопку Изменить.

    или

    Или нажмите кнопку Создать для создания нового объекта групповой политики, а затем нажмите кнопку Изменить.

Примечание

  • Для запуска оснастки «Active Directory — сайты и службы» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
См. также


Открытие групповой политики как изолированной оснастки MMC

Рисунок Microsoft Windows

Чтобы открыть групповую политику как изолированную оснастку MMC

  1. Откройте Консоль управления (MMC).
  2. В меню Консоль выберите команду Добавить или удалить оснастку.
  3. На вкладке Изолированная оснастка нажмите кнопку Добавить.
  4. В диалоговом окне Добавить изолированную оснастку выберите оснастку Групповая политика и нажмите кнопку Добавить.
  5. Для редактирования локального объекта групповой политики или поиска необходимого объекта в диалоговом окне Выбор объекта групповой политики выберите Локальный компьютер или нажмите кнопку Обзор для поиска требуемого объекта групповой политики.
  6. Нажмите кнопку Готово, кнопку Закрыть, а затем — кнопку OK. Выбранный объект групповой политики будет открыт для изменения в оснастке «Групповая политика».

Примечание

  • Для открытия консоли управления MMC нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите кнопку OK.
  • Чтобы сохранить консоль групповой политики и иметь возможность выбирать, какой объект групповой политики открывается в ней при запуске из командной строки, в диалоговом окне Выбор объекта групповой политики установите флажок Разрешить изменение фокуса «Оснастки групповой политики» при запуске из командной строки. Применяется только при сохранении консоли.
  • Сведения о различных способах открытия оснастки «Групповая политика», включая открытие из командной строки, см. в разделе Способы открытия оснастки «Групповая политика».
См. также


Работа с объектами групповой политики

  • Изменение объекта групповой политики
  • Изменение объекта локальной групповой политики.
  • Создание нового объекта групповой политики
  • Удаление объекта групповой политики
  • Связывание объекта групповой политики с сайтом, доменом или подразделением
  • Блокирование наследования политики
  • Отключение связи объекта групповой политики с сайтом, доменом или подразделением
  • Отключение связи объекта групповой политики
  • Запрет перекрывания объекта групповой политики


Изменение объекта групповой политики

Рисунок Microsoft Windows

Чтобы изменить объект групповой политики

  1. Откройте объект групповой политики, который требуется изменить.
  2. В дереве консоли дважды щелкните папку для просмотра ее политик на панели сведений.
  3. На панели сведений дважды щелкните имена политик для открытия диалогового окна их свойств и изменения их параметров.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • Для открытия объекта групповой политики необходимо иметь разрешения на чтение и запись.
  • Поскольку изменения в объекте групповой политики происходят немедленно, то во время редактирования его можно отключить. Для получения сведений об отключении объекта групповой запуске групповой политики щелкните ссылку «См. также».

См. также


Изменение объекта локальной групповой политики

Рисунок Microsoft Windows

Чтобы изменить объект локальной групповой политики

  1. Откройте оснастку Групповая политика.
  2. В дереве консоли дважды щелкните папку на панели сведений для просмотра ее политик.
  3. На панели сведений дважды щелкните имена политик для открытия диалогового окна их свойств и изменения их параметров.

Примечания

  • Для открытия оснастки «Групповая политика» нажмите кнопку Пуск, выберите команду Выполнить, введите gpedit.msc и нажмите кнопку OK.
  • Изменения, внесенные в объект групповой политики, сохраняются автоматически.

См. также


Создание нового объекта групповой политики

Рисунок Microsoft Windows

Чтобы создать новый объект групповой политики

  1. Для создания объекта групповой политики, связанного с доменом или подразделением, откройте оснастку Active Directory — пользователи и компьютеры.

    Откройте оснастку Active Directory — сайты и службы для создания объекта групповой политики, связанного с сайтом.

  2. В дереве консоли щелкните правой кнопкой мыши сайт, домен или подразделение, с которым будет связан созданный объект групповой политики. (Объект групповой политики будет храниться в текущем домене, то есть домене, содержащем контроллер домена, используемый оснасткой «Active Directory — пользователи и компьютеры» или «Active Directory — сайты и службы».)
  3. Выберите Свойства и откройте вкладку Групповая политика.
  4. Нажмите кнопку Создать, введите имя объекта групповой политики и нажмите кнопку Закрыть.

Примечания

  • Для запуска оснастки «Active Directory — пользователи и компьютеры» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • Для запуска оснастки «Active Directory — сайты и службы» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • Созданный объект групповой политики связан с сайтом, доменом или подразделением, выбранном при его создании, и его параметры применяются к этому сайту, домену или подразделению. Для получения сведений об удалении связи объекта групповой политики с сайтом, доменом или подразделением щелкните ссылку «См. также».

См. также


Удаление объекта групповой политики

Рисунок Microsoft Windows

Чтобы удалить объект групповой политики

  1. Откройте оснастку Active Directory — пользователи и компьютеры.

  2. В дереве консоли щелкните правой кнопкой мыши домен или любое подразделение в домене.
  3. Выберите Свойства и откройте вкладку Групповая политика.
  4. Чтобы найти все объекты групповой политики, содержащиеся в домене, нажмите кнопку Добавить. Будет открыто диалоговое окно Добавить ссылку на объект групповой политики.
  5. На вкладке Все выберите нужный объект групповой политики и нажмите кнопку Удалить.
  6. Нажмите кнопку Да, кнопку Отмена, а затем — OK.

Примечания

  • Для запуска оснастки «Active Directory — пользователи и компьютеры» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • При удалении объекта групповой политики теряются его связи с любыми сайтами, доменами и подразделениями. Вместо удаления объекта групповой политики можно его просто отключить. Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Связывание объекта групповой политики с сайтом, доменом или подразделением

Рисунок Microsoft Windows

Чтобы связать объект групповой политики с сайтом, доменом или подразделением

  1. Откройте оснастку Active Directory - пользователи и компьютеры, чтобы связать объект групповой политики с доменом или подразделением.

    Откройте окно Active Directory - сайты и службы, чтобы связать объект групповой политики с сайтом.

  2. В дереве консоли щелкните правой кнопкой мыши сайт, домен или подразделение с которым необходимо связать объект групповой политики.
  3. Выберите команду Свойства и откройте вкладку Групповая политика.
  4. Чтобы добавить объект групповой политики в список Ссылки на объекты групповой политики, нажмите кнопку Добавить. При этом будет открыто диалоговое окноДобавить ссылку на объект групповой политики.
  5. На вкладке Все выберите нужный объект групповой политики и нажмите кнопку OK.
  6. В диалоговом окне свойств сайта, домена или подразделения нажмите кнопку OK.

Примечания

  • Для запуска оснастки «Active Directory - пользователи и компьютеры» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • Для запуска оснастки «Active Directory - сайты и службы» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • Связывание объекта групповой политики можно выполнить для применения его параметров к пользователям и компьютерам сайта, домена или подразделения и к пользователям и компьютерам контейнеров Active Directory, которые наследуют параметры политики с сайта, домена или подразделения.
См. также


Блокирование наследования политики

Рисунок Microsoft Windows

Чтобы блокировать наследование политики

  1. Чтобы блокировать наследование политики на сайте, откройте оснастку Active Directory — сайты и службы.

    Чтобы блокировать наследование политики в домене или подразделении откройте оснастку Active Directory — пользователи и компьютеры.

  2. В дереве консоли щелкните правой кнопкой узел, домен или подразделение, в котором необходимо блокировать наследование политики, и выберите команду Свойства.
  3. На вкладке Групповая политика убедитесь, что установлен флажок Блокировать наследование политики и нажмите кнопку OK.

Примечания

  • Для запуска оснастки «Active Directory — пользователи и компьютеры» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • Для запуска оснастки «Active Directory — сайты и службы» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • Параметр Блокировать наследование политики блокирует объекты групповой политики, применимые к более высокому уровню иерархии сайтов, доменов или подразделений Active Directory. Она не блокирует объекты групповой политики, если включен параметр Не перекрывать.
  • Параметр Блокировать наследование политики применим только к сайтам, доменам и подразделениям, а не к отдельным объектам групповой политики.

См. также


Отключение связи объекта групповой политики с сайтом, доменом или подразделением

Рисунок Microsoft Windows

Чтобы отключить связь объекта групповой политики с сайтом, доменом или подразделением

  1. Для отключения объекта групповой политики для домена или подразделения откройте оснастку Active Directory — пользователи и компьютеры.

    Откройте оснастку Active Directory — сайты и службы для отключения связи объекта групповой политики с сайтом.

  2. В дереве консоли щелкните правой кнопкой мыши сайт, домен или подразделение, с которым требуется разорвать связь. (Отключение связи предотвращает влияние объекта групповой политики на сайт, домен или подразделение.)
  3. Выберите Свойства и откройте вкладку Групповая политика.
  4. Выберите отключаемый объект групповой политики и нажмите кнопку Удалить.
  5. В диалоговом окне Удаление выберите вариант Изъять ссылку из списка, не удаляя объект и нажмите кнопку OK.

Важно!

  • Если в диалоговом окне Удалениевыбрать параметр Изъять ссылку и окончательно удалить объект групповой политики, то ко всем сайтам, доменам и подразделениям, с которыми был связан объект групповой политики, не будут применяться параметры этого объекта групповой политики, а сам объект будет удален.

Примечания

  • Для запуска оснастки «Active Directory — пользователи и компьютеры» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • Для запуска оснастки «Active Directory — сайты и службы» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
См. также


Отключение связи объекта групповой политики

Рисунок Microsoft Windows

Чтобы отключить связь объекта групповой политики

  1. Для отключения связи объекта групповой политики с доменом или подразделением откройте оснастку Active Directory — пользователи и компьютеры.

    Откройте оснастку Active Directory — сайты и службы для отключения связи объекта групповой политики с сайтом.

  2. В дереве консоли щелкните правой кнопкой мыши сайт, домен или подразделение, с которым связан объект групповой политики, и выберите команду Свойства.
  3. Откройте вкладку Групповая политика.
  4. Щелкните правой кнопкой мыши объект групповой политики, чью связь необходимо отключить, выберите Отключено и нажмите кнопку Да. В столбце Отключено отобразится метка.

Примечания

  • Для запуска оснастки «Active Directory — пользователи и компьютеры» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • Для запуска оснастки «Active Directory — сайты и службы» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • При отключении связи объекта групповой политики данный объект больше не применяется к пользователям и компьютерам в сайте, домене или подразделении, с которыми был связан объект; кроме того, он больше не применяется к пользователям и компьютерам в дочерних контейнерах Active Directory, наследовавших данные параметры групповой политики.

См. также


Запрещение перекрывания объекта групповой политики

Рисунок Microsoft Windows

Чтобы запретить перекрывание объекта групповой политики

  1. Откройте оснастку Active Directory — пользователи и компьютеры для доступа к объекту групповой политики, связанному с доменом или подразделением.

    Откройте оснастку Active Directory — сайты и службы для доступа к объекту групповой политики, связанному с сайтом.

  2. В дереве консоли щелкните правой кнопкой мыши сайт, домен или подразделение с которым связан объект групповой политики.
  3. Выберите команду Свойства и откройте вкладку Групповая политика.
  4. В списке Ссылки на объекты групповой политики щелкните правой кнопкой мыши ссылку объекта групповой политики, из контекстного меню выберите команду Не перекрывать, а затем нажмите кнопку ОК. В столбце Не перекрывать появится галочка.

Примечания

  • Для запуска оснастки «Active Directory — пользователи и компьютеры» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • Для запуска оснастки «Active Directory — сайты и службы» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • При выборе параметра ссылки объекта групповой политики Не перекрывать параметры групповой политики применяются для всех пользователей и компьютеров сайта, домена или подразделения и для всех пользователей и компьютеров контейнеров Active Directory, которые наследуют его политику.
  • Параметры групповой политики, для которых установлен флажок Не перекрывать, не могут быть блокированы.

См. также


Работа со свойствами объектов групповой политики

  • Применение фильтра к групповой политике в соответствии с членством в группе безопасности
  • Поиск сайтов, доменов и подразделений, с которыми связан объект групповой политики
  • Отключение параметров конфигурации пользователя в объекте групповой политики
  • Отключение параметров конфигурации компьютера в объекте групповой политики


Применение фильтра к групповой политике в соответствии с членством в группе безопасности

Рисунок Microsoft Windows

Чтобы применить фильтр к групповой политике в соответствии с членством в группе безопасности

  1. Откройте объект групповой политики, к которому будет применен фильтр.
  2. Щелкните правой кнопкой значок или имя объекта групповой политики, который выглядит следующим образом:
    Политика имя_объекта_групповой_политики [имя_котроллера_домена.имя_домена],
    и выберите команду Свойства.
  3. Перейдите на вкладку Безопасность и выберите группу безопасности, по которой необходимо отфильтровать объект групповой политики.

    Если необходимо изменить список групп безопасности, по которым фильтруется данный объект групповой политики, используйте кнопки Добавить и Удалить для добавления или удаления групп безопасности.

  4. В области Разрешения для выбранной группы безопасности установите или снимите соответствующие флажки для установки разрешений, описанных в следующей таблице, и затем нажмите кнопку OK.
Задача | Разрешения | Результат
Необходимо применить объекты групповой политики к членам этой группы безопасности. | Установите флажок Разрешить для параметра Применение групповой политики. Установите флажок Разрешить для параметра Чтение. | Этот объект групповой политики будет применен к членам группы безопасности кроме тех, кто является членами еще по крайней мере одной группы безопасности, у которой установлен флажок Запретить для параметра Применение групповой политики или параметра Чтение, либо запрещены оба параметра.
Члены этой группы безопасности освобождены от этого объекта групповой политики. | Установите флажок Запретить для параметра Применение групповой политики. Установите флажок Запретить для параметра Чтение. | Объект групповой политики никогда не применяется к членам этой группы безопасности, вне зависимости от разрешений для членов, состоящих также в других группах.
Членство в этой группе безопасности никак не связано с применением объекта групповой политики. | Не устанавливайте ни флажок Запретить, ни флажок Разрешить для параметра Применение групповой политики. Не устанавливайте ни флажок Запретить, ни флажок Разрешить для параметра Чтение. | Этот объект групповой политики применяется к членам этой группы безопасности, как к членам по крайней мере одной группы безопасности, тогда и только тогда, когда для обоих параметров Применить групповую политику и Чтение установлены флажки Разрешить. Они также не должны содержать членов по крайней мере одной группы, у которых для одного из параметров Применить групповую политику или Чтение установлен флажок Запретить.

Примечания

  • Чтобы открыть оснастку Групповая политика, щелкните ссылку «См. также».
  • Объекты групповой политики применимы только к сайтам, доменам или подразделениям. Параметры групповой политики влияют только на пользователей или компьютеры, включенные в них. В частности, объекты групповой политики не связаны с группами безопасности.
  • Расположение групп безопасности в Active Directory не связано и не оказывает влияния на процесс фильтрации, описанный в этом разделе.
  • Если пользователь или компьютер не содержит сайт, домен или подразделение, что является предметом для объекта групповой политики, или посредствам связи, или через наследование, то отсутствует необходимая комбинация разрешений для любых групп безопасности, что может стать причиной влияния параметров групповой политики на пользователя или компьютер.
  • Описанная в этом разделе фильтрация на уровне объекта групповой политики может быть причиной обработки или не обработки объекта групповой политики в целом. Расширения установки программ и перенаправления папки используют группы безопасности для усовершенствования контроля за уровнем объекта групповой политики. Группы безопасности не используются для фильтрования отдельных параметров или наборов объекта групповой политики, кроме как для установки программ и для перенаправления папки. Вместо этого, для управления отдельными параметрами создайте или отредактируйте объект групповой политики.

См. также


Поиск сайтов, доменов и подразделений, с которыми связан объект групповой политики

Рисунок Microsoft Windows

Чтобы найти сайты, домены и подразделения, с которыми связан объект групповой политики

  1. Откройте объект групповой политики.
  2. Щелкните правой кнопкой значок или имя объекта групповой политики, который выглядит следующим образом:
    Политика имя_объекта_групповой_политики [имя_котроллера_домена.имя_домена],
    и выберите команду Свойства.
  3. Выберите вкладку Связи, а затем нажмите кнопку Найти. В поле Найденные сайты, домены или подразделения будет отображен список сайтов, доменов и подразделений, связанных с объектом групповой политики.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • Если объект групповой политики связан с несколькими доменами, имеется возможность ограничить поиск подразделений одним доменом, используя раскрывающийся список Домен.

См. также


Отключение параметров конфигурации пользователя в объекте групповой политики

Рисунок Microsoft Windows

Чтобы отключить параметры конфигурации пользователя в объекте групповой политики

  1. Откройте объект групповой политики, который требуется изменить.
  2. Щелкните правой кнопкой значок или имя объекта групповой политики, который выглядит следующим образом:
    Политика имя_объекта_групповой_политики [имя_котроллера_домена.имя_домена],
    и выберите команду Свойства.
  3. На вкладке Общие установите флажок Отключить параметры конфигурации пользователя и нажмите кнопку OK.

Примечания

  • Чтобы открыть оснастку Групповая политика, щелкните ссылку «См. также».
  • После отключения параметров конфигурации пользователя в объекте групповой политики они перестают влиять на все связанные сайты, домены или подразделения.

См. также


Отключение параметров конфигурации компьютера в объекте групповой политики

Рисунок Microsoft Windows

Чтобы отключить параметры конфигурации компьютера в объекте групповой политики

  1. Откройте объект групповой политики, который требуется изменить.
  2. Щелкните правой кнопкой значок или имя объекта групповой политики, который выглядит следующим образом:
    Политика имя_объекта_групповой_политики [имя_котроллера_домена.имя_домена],
    и выберите команду Свойства.
  3. На вкладке Общие установите флажок Отключить параметры конфигурации компьютера и нажмите кнопку OK.

Примечания

  • Чтобы открыть оснастку Групповая политика, щелкните ссылку «См. также».
  • После отключения параметров конфигурации компьютера в объекте групповой политики они перестают влиять на все связанные сайты, домены или подразделения.

См. также


Использование административных шаблонов

  • Добавление или удаление файла административного шаблона (.adm)
  • Использование вида папки «Административные шаблоны»
  • Использование фильтра при просмотре папки «Административные шаблоны»


Добавление или удаление файла административного шаблона (.adm)

Рисунок Microsoft Windows

Чтобы добавить или удалить файл административного шаблона (.adm)

  1. Откройте редактируемый объект групповой политики и в дереве консоли щелкните правой кнопкой папку Административные шаблоны.

    Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Административные шаблоны
  2. Выберите команду Добавление и удаление шаблонов.
  3. Для удаления шаблона в списке Текущие шаблоны политики выберите шаблон и нажмите кнопку Удалить.

    Если необходимо добавить шаблон, нажмите кнопку Добавить. В диалоговом окне Шаблоны политики щелкните шаблоны, которую требуется добавить, и нажмите кнопку Открыть.

  4. В диалоговом окне Добавление и удаление шаблонов нажмите кнопку Закрыть.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • Поскольку в Windows ХР роль административных шаблонов изменилась по сравнению с Windows NT 4.0, для клиентов Windows ХР не рекомендуется использовать файлы .adm, созданные для Windows NT 4.0.

    Если для создания пространства имен в консоли «Групповая политика» используются старые версии файлов .adm, можно указать, следует ли отображать параметры системной политики Windows NT 4.0 в области сведений, выполнив следующие действия.

    1. В дереве консоли щелкните папку Административные шаблоны.
    2. В меню Вид выберите команду Фильтрация, а затем установите или снимите флажок Показывать только управляемые параметры политики. Если этот флажок установлен, параметры системной политики в области сведений не отображаются. Для этого можно также использовать параметр групповой политики «Вывод пункта "Показывать только политики"».

    Расположение

    • Имя объекта групповой политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Система
    • Групповая политика

См. также


Использование вида папки «Административные шаблоны»

Рисунок Microsoft Windows

Чтобы использовать вид папки «Административные шаблоны»

  1. Откройте оснастку «Групповая политика» и в дереве консоли щелкните подпапку в папке «Административные шаблоны», содержащую параметры политики, для которых необходимо задать значения.

    2. Расположение

    • Политика имя_политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Административные шаблоны
    • папка политики
  2. В нижней части панели сведений щелкните вкладку Расширенный.
  3. Для просмотра описания параметра щелкните его имя или значок в столбце Параметр.
  4. Если необходимо изменись состояние настройки по умолчанию (не задана), дважды щелкните ее имя или значок. На вкладке Параметр используйте одну из кнопок, описанных в следующей таблице.
    Кнопка | Результат
    Не задан | Реестр не изменяется.
    Включен | В реестре отражается включение параметра политики.
    Отключен | В реестре отражается отключение параметра политики.

    Установите другие требуемые параметры на вкладке Параметр и нажмите кнопку OK.

    5. Для просмотра других параметров в текущей папке и задания из значений могут быть использованы кнопки Предыдущий параметр и Следующий параметр.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • В консоли «Групповая политика» имеются две ветви «Административные шаблоны». Параметры для раздела HKEY_LOCAL_MACHINE находятся в папке «Конфигурация компьютера», а для раздела HKEY_CURRENT_USER — в папке «Конфигурация пользователя».
  • Если имеет место конфликт политики компьютера и политики пользователя, политика компьютера, как правило, имеет приоритет. Авторы программ могут не соблюдать стандарты, в таком случае эти программы не могут управляться с помощью групповой политики.
  • Вкладка Расширенный добавлена в этой версии. На ней не только приводится описание параметра политики, как в Windows 2000, но также приводятся сведения о том, какие версии Windows поддерживаются данным параметром как клиенты. Если необходимо просматривать параметры без текста пояснения, используйте вкладку Стандартный.
  • Сведения о ключевом слове Поддерживается см. в файлах .adm см. на веб-странице Реализация групповой политики с помощью реестра (http://www.microsoft.com/), расположенной на веб-узле корпорации Майкрософт.

См. также


Использование фильтра при просмотре папки «Административные шаблоны»

Рисунок Microsoft Windows

Чтобы использовать фильтр при просмотре папки «Административные шаблоны»

  1. Откройте оснастку «Групповая политика» и в дереве консоли щелкните папку Административные шаблоны или подпапку, содержащую параметры политики, для которых необходимо использовать фильтр.

    2. Расположение

    • Политика имя_политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Административные шаблоны
    • папка_политики
  2. В меню Вид выберите команду Фильтрация.
  3. Установите флажок Фильтрация по полю «Требования», а затем установите в списке флажки для категорий, которые необходимо просмотреть.
  4. Если необходимо скрыть ненастроенные параметры, установите флажок Показывать только настроенные параметры политики. Если данный флажок установлен, отображаются только параметры со значениями «Включен» и «Отключен».
  5. Если необходимо скрыть параметры системной политики в формате Windows NT 4.0, установите флажок Показывать только управляемые параметры политики. Этот параметр является рекомендуемым и включен по умолчанию.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • Процедура фильтрации применяется при большом количестве параметров административных шаблонов, отображаемых в консоли групповой политики. С помощью фильтра выбираются только отображаемые параметры. Использование фильтра не влияет на применение параметров к пользователям и компьютерам и не аналогично процедуре применения фильтра к групповой политике в соответствии с членством в группе безопасности.

См. также


Использование сценариев

  • Установка сценариев для контроллера домена
  • Назначение сценариев автозагрузки компьютера
  • Назначение сценариев завершения работы компьютера
  • Назначение сценариев входа пользователя в систему
  • Назначение сценариев выхода пользователя из системы


Установка сценариев на контроллере домена

Рисунок Microsoft Windows

Чтобы установить сценарии на контроллере домена

  • Скопируйте сценарий и все связанные с ним файлы в общую папку Netlogon или любую другую папку на контроллере домена, на котором необходимо запустить этот сценарий.


Назначение сценариев автозагрузки компьютера

Рисунок Microsoft Windows

Чтобы назначить сценарии автозагрузки компьютера

  1. Откройте оснастку «Групповая политика».
  2. В дереве консоли щелкните Сценарии (запуск/завершение).

    Расположение

    • Политика имя_политики
    • Конфигурация компьютера
    • Конфигурация Windows
    • Сценарии (запуск/завершение)
  3. В области сведений дважды щелкните Автозагрузка.
  4. В диалоговом окне Свойства: Автозагрузка нажмите кнопку Добавить.
  5. В диалоговом окне Добавление сценария введите следующие сведения и нажмите кнопку OK.

    Имя сценария. Введите путь к сценарию или нажмите кнопку Обзор для поиска файла сценария в общей папке Netlogon контроллера домена.

    Параметры сценария. Введите все необходимые параметры, так же как в командной строке. Например, если сценарий включает параметры //logo (отображать заставку) и //I (диалоговый режим), введите следующие параметры: //logo //I

  6. В диалоговом окне свойств Свойства: Автозагрузка выберите необходимые параметры и нажмите кнопку OK.

    Сценарии запуска для Объект групповой политики. Отображение списка всех сценариев, назначенных выбранному объекту групповой политики. При назначении нескольких сценариев они будут применяться в заданном порядке. Чтобы переместить сценарий в списке вверх, выберите его и нажмите кнопку Вверх. Чтобы переместить сценарий в списке вниз, выберите его и нажмите кнопку Вниз.

    Добавить. Открывает диалоговое окно Добавление сценария, в котором можно указать дополнительные сценарии.

    Изменить. Открывает диалоговое окно Изменение сценария, в котором можно изменить сведения о сценарии, такие как имя и параметры.

    Удалить. Удаляет выбранный сценарий из списка Сценарии запуска.

    Показать файлы. Отображает файлы сценариев, которые хранятся в выделенном объекте групповой политики.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • Сценарии автозагрузка выполняются как локальная система и имеют полные права, связанные с запуском в качестве локальной системы.

См. также


Назначение сценариев завершения работы компьютера

Рисунок Microsoft Windows

Чтобы назначить сценарии завершения работы компьютера

  1. Откройте оснастку «Групповая политика».
  2. В дереве консоли щелкните Сценарии (запуск/завершение).

    Расположение

    • Политика имя_политики
    • Конфигурация компьютера
    • Конфигурация Windows
    • Сценарии (запуск/завершение)
  3. В области сведений дважды щелкните элемент Завершение работы.
  4. В диалоговом окне Свойства: Завершение работы нажмите кнопку Добавить.
  5. В диалоговом окне Добавление сценария введите следующие сведения и нажмите кнопку OK.

    Имя сценария. Введите путь к сценарию или нажмите кнопку Обзор для поиска файла сценария в общей папке Netlogon контроллера домена.

    Параметры сценария. Введите все необходимые параметры, так же как в командной строке. Например, если сценарий включает параметры //logo (отображать заставку) и //I (диалоговый режим), введите следующие параметры: //logo //I

  6. В диалоговом окне свойств Свойства: Завершение работы выберите необходимые параметры и нажмите кнопку OK.

    Сценарии завершение работы для Объект групповой политики. Отображение списка всех сценариев, назначенных выбранному объекту групповой политики. При назначении нескольких сценариев они будут применяться в заданном порядке. Чтобы переместить сценарий в списке вверх, выберите его и нажмите кнопку Вверх. Чтобы переместить сценарий в списке вниз, выберите его и нажмите кнопку Вниз.

    Добавить. Открывает диалоговое окно Добавление сценария, в котором можно указать дополнительные сценарии.

    Изменить. Открывает диалоговое окно Изменение сценария, в котором можно изменить сведения о сценарии, такие как имя и параметры.

    Удалить. Удаляет выбранный сценарий из списка Сценарии завершения работы.

    Показать файлы. Отображает файлы сценариев, которые хранятся в выделенном объекте групповой политики.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • Сценарии завершения работы выполняются как локальная система и имеют полные права, связанные с запуском в качестве локальной системы.

См. также


Назначение сценариев входа пользователя в систему

Рисунок Microsoft Windows

Чтобы назначить сценарии входа пользователя в систему

  1. Откройте оснастку «Групповая политика».
  2. В дереве консоли щелкните Сценарии (вход/выход из системы).

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Конфигурация Windows
    • Сценарии (вход/выход из системы)
  3. В области сведений дважды щелкните Вход в систему.
  4. В диалоговом окне Свойства: Вход в систему нажмите кнопку Добавить.
  5. В диалоговом окне Добавление сценария введите следующие сведения и нажмите кнопку OK.

    Имя сценария. Введите путь к сценарию или нажмите кнопку Обзор для поиска файла сценария в общей папке Netlogon контроллера домена.

    Параметры сценария. Введите все необходимые параметры, так же как в командной строке. Например, если сценарий включает параметры //logo (отображать заставку) и //I (диалоговый режим), введите следующие параметры: //logo //I

  6. В диалоговом окне свойств Свойства: Вход в систему выберите необходимые параметры и нажмите кнопку OK.

    7. Сценарии входа для Объект групповой политики. Отображение списка всех сценариев, назначенных выбранному объекту групповой политики. При назначении нескольких сценариев они будут применяться в заданном порядке. Чтобы переместить сценарий в списке вверх, выберите его и нажмите кнопку Вверх. Чтобы переместить сценарий в списке вниз, выберите его и нажмите кнопку Вниз.

    Добавить. Открывает диалоговое окно Добавление сценария, в котором можно указать дополнительные сценарии.

    Изменить. Открывает диалоговое окно Изменение сценария, в котором можно изменить сведения о сценарии, такие как имя и параметры.

    Удалить. Удаляет выбранный сценарий из списка Сценарии входа.

    Показать файлы. Отображает файлы сценариев, которые хранятся в выделенном объекте групповой политики.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • Сценарии входа в систему запускаются как «Пользователь», а не как «Администратор», соответственно, их права ограничены.

См. также


Назначение сценариев выхода пользователя из системы

Рисунок Microsoft Windows

Чтобы назначить сценарии выхода пользователя из системы

  1. Откройте оснастку «Групповая политика».
  2. В дереве консоли щелкните Сценарии (вход/выход из системы).

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Конфигурация Windows
    • Сценарии (вход/выход из системы)
  3. В области сведений дважды щелкните Выход из системы.
  4. В диалоговом окне Свойства: Выход из системы нажмите кнопку Добавить.
  5. В диалоговом окне Добавление сценария введите следующие сведения и нажмите кнопку OK.

    Имя сценария. Введите путь к сценарию или нажмите кнопку Обзор для поиска файла сценария в общей папке Netlogon контроллера домена.

    Параметры сценария. Введите все необходимые параметры, так же как в командной строке. Например, если сценарий включает параметры //logo (отображать заставку) и //I (диалоговый режим), введите следующие параметры: //logo //I

  6. В диалоговом окне свойств Свойства: Выход из системы выберите необходимые параметры и нажмите кнопку OK.

    7. Сценарии выхода для Объект групповой политики. Отображение списка всех сценариев, назначенных выбранному объекту групповой политики. При назначении нескольких сценариев они будут применяться в заданном порядке. Чтобы переместить сценарий в списке вверх, выберите его и нажмите кнопку Вверх. Чтобы переместить сценарий в списке вниз, выберите его и нажмите кнопку Вниз.

    Добавить. Открывает диалоговое окно Добавление сценария, в котором можно указать дополнительные сценарии.

    Изменить. Открывает диалоговое окно Изменение сценария, в котором можно изменить сведения о сценарии, такие как имя и параметры.

    Удалить. Удаляет выбранный сценарий из списка Сценарии выхода.

    Показать файлы. Отображает файлы сценариев, которые хранятся в выделенном объекте групповой политики.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • Сценарии выхода из системы запускаются как «Пользователь», а не как «Администратор», соответственно, их права ограничены.

См. также


Использование оснастки «Установка программного обеспечения»

  • Открытие оснастки «Установка программного обеспечения»
  • Задание параметров для оснастки «Установка программного обеспечения»
  • Работа с приложениями
  • Задание свойств приложения
  • Работа с модификациями пакета


Открытие оснастки «Установка программного обеспечения»

Рисунок Microsoft Windows

Чтобы открыть оснастку «Установка программного обеспечения»

  1. Откройте оснастку «Групповая политика».
  2. Чтобы назначить приложения компьютеру, дважды щелкните папку Конфигурация компьютера в дереве консоли. Чтобы назначить или опубликовать приложения для пользователей, дважды щелкните папку Конфигурация пользователя в дереве консоли.
  3. Дважды щелкните Конфигурация программ, а затем — Установка программного обеспечения.

    Расположение

    • Политика имя_политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения

Примечание

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».

См. также


Задание параметров для оснастки «Установка программного обеспечения»

  • Задание значений параметров по умолчанию в оснастке «Установка программного обеспечения».
  • Определение параметров автоматической установки в соответствии с расширением файла
  • Задание категорий для управляемых приложений


Задание значений параметров по умолчанию в оснастке «Установка программного обеспечения».

Рисунок Microsoft Windows

Чтобы задать значения параметров по умолчанию в оснастке «Установка программного обеспечения»

  1. Откройте оснастку «Установка программного обеспечения».
  2. В дереве консоли щелкните правой кнопкой мыши папку Установка программного обеспечения.

    Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения
  3. Нажмите кнопку Свойства и на вкладке Общие выберите необходимые параметры:

    Расположение пакетов по умолчанию. Задание точки распространения программного обеспечения по умолчанию.

    Новые пакеты. По умолчанию новые пакеты могут либо назначаться, либо публиковаться(для компьютеров возможно только назначение пакетов). Если этот параметр необходимо определять для каждого пакета, выберите параметр Открывать диалоговое окно «Развертывание программ». Для дополнительного управления каждым пакетом нажмите кнопку Дополнительно.

    Пользовательский интерфейс при установке. Выберите Простой или Полный в зависимости от того, какой интерфейс необходимо отображать пользователям.

Примечание

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».

См. также


Определение параметров автоматической установки в соответствии с расширением файла

Рисунок Microsoft Windows

Чтобы определить параметры автоматической установки в соответствии с расширением файла

  1. Откройте оснастку «Установка программного обеспечения».
  2. В дереве консоли щелкните правой кнопкой мыши папку Установка программного обеспечения.

    3. Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения
  3. Выберите команду Свойства, а затем — вкладку Расширения файлов.
  4. На вкладке Расширения файлов определите необходимые параметры и нажмите кнопку OK.

    5. Выберите расширение. Отображение списка доступных расширений для управления программами. При выборе расширения все приложения с таким расширением в Active Directory отображаются в окне Порядок приложений. Например, файлы с расширением .htm могут быть связаны с большим числом приложений: Microsoft Word, Microsoft Internet Explorer, Netscape Communicator и т. д.

    Порядок приложений. Список всех приложений, связанных с выбранным расширением. По умолчанию приложения с наибольшим приоритетом отображаются в начале списка.

    Вверх. Перемещение выбранного приложения выше по списку. Если документ с выбранным расширением запускается до установки необходимого приложения, то верхнее приложение в списке будет установлено автоматически. При выборе первого приложения в списке кнопка Вверх недоступна.

    Вниз. Перемещение выбранного приложения ниже по списку. При выборе последнего приложения в списке кнопка Вниз недоступна.

Примечания

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».
  • При обновлении приложения убедитесь, что для старой версии отключен параметр автоматической установки.

См. также


Задание категорий для управляемых приложений

Рисунок Microsoft Windows

Чтобы задать категории для управляемых приложений

  1. Откройте оснастку «Установка программного обеспечения».
  2. В дереве консоли щелкните правой кнопкой мыши папку Установка программного обеспечения.

    3. Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения
  3. Нажмите кнопку Свойства и выберите вкладку Категории.
  4. Создайте или измените список категорий, в которых программы будут отображаться в окне «Установка и удаление программ» на панели управления.

    5. Добавить. Открывает диалоговое окно, где можно ввести текст, задающий новую категорию. Если отсутствуют разрешения на добавление категорий, эта кнопка недоступна.

    Изменить. Открывает диалоговое окно для изменения текста выбранной категории. Если отсутствуют разрешения на изменение категорий, эта кнопка недоступна.

    Удалить. Удаляет выбранную категорию из списка Категории. Если отсутствуют разрешения на изменение категорий, эта кнопка недоступна.

Примечания

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».
  • Изменения, внесенные в категории приложений, применяются в домене, в котором расположен объект групповой политики.
  • Для выполнения данной процедуры необходимо являться администратором домена или иметь аналогичные права.

См. также


Работа с приложениями

  • Назначение приложения
  • Публикация приложения
  • Обновление приложения
  • Удаление управляемого приложения


Назначение приложения

Рисунок Microsoft Windows

Чтобы назначить приложение

  1. Откройте оснастку «Установка программного обеспечения».
  2. В дереве консоли щелкните узел «Установка программного обеспечения».

    3. Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения
  3. Щелкните правой кнопкой мыши панель сведений и выберите команду Создать, а затем — команду Пакет.
  4. В диалоговом окне Открыть выберите пакет установщика Windows и нажмите кнопку Открыть.

    Диалоговое окно Открыть показывает пакеты, расположенные в выбранной по умолчанию точке распространения программного обеспечения. Для получения инструкций по изменению ее местоположения щелкните ссылку «См. также».

    Если пакет установщика Windows находится на другом сетевом ресурсе, перейдите с помощью диалогового окна Открыть к необходимой точке распространения программного обеспечения, выберите пакет установщика и нажмите кнопку Открыть.

  5. В диалоговом окне Развертывание программы выберите параметр Назначенный и нажмите кнопку OK.

См. также


Публикация приложения

Рисунок Microsoft Windows

Чтобы опубликовать приложение

  1. Откройте оснастку «Установка программного обеспечения».
  2. В дереве консоли щелкните узел Установка программного обеспечения.

    3. Расположение

    • Имя объекта групповой политики
    • Конфигурация пользователя
    • Конфигурация программ
    • Установка программного обеспечения
  3. Щелкните правой кнопкой панель сведений и выберите команду Создать, а затем команду Пакет.
  4. В диалоговом окне Открытьвыберите публикуемый пакет установщика Windows и нажмите кнопку Открыть.

    В диалоговом окне Открыть отображаются пакеты, расположенные в точке распространения программного обеспечения, выбранной по умолчанию. Для получения инструкций по изменению точки распространения программного обеспечения по умолчанию щелкните ссылку «См. также».

    Если пакет установщика Windows находится на другом сетевом ресурсе, с помощью диалогового окна Открыть перейдите к необходимой точке распространения программного обеспечения, выберите пакет установщика и нажмите кнопку Открыть.

  5. В диалоговом окне Развертывание программы выберите параметр Опубликовано и нажмите кнопку OK.

    Приложение станет доступным для установки пользователями либо с помощью компонента «Установка и удаление программ» на панели управления, либо путем открытия файла с расширением, связанным с этим приложением. Для получения сведений о сопоставлении расширения файла соответствующему приложению щелкните ссылку «См. также».

Примечания

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».
  • Пакеты могут быть опубликованы только для пользователей, но не для компьютеров.

См. также


Обновление приложения

Рисунок Microsoft Windows

Чтобы обновить приложение

  1. Откройте оснастку «Установка программного обеспечения».
  2. В дереве консоли щелкните узел Установка программного обеспечения.

    3. Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения
  3. В области сведений щелкните правой кнопкой мыши пакет установщика Windows, который будет выполнять роль обновления (не обновляемого пакета). Вначале необходимо назначить или опубликовать этот пакет.
  4. Выберите команду Свойства, а затем вкладку Обновления.
  5. Для создания или добавления списка пакетов, которые могут быть обновлены данным пакетом, нажмите кнопку Добавить.
  6. В диалоговом окне Добавление обновления в списке Выбор обновления выберите либо Из текущего объекта групповой политики (GPO), либо Из указанного объекта групповой политики. В последнем случае нажмите кнопку Обзор, выберите необходимый объект групповой политики и затем в диалоговом окне Поиск объекта групповой политики нажмите кнопку OK.

    В списке Обновляемое приложение перечислены все пакеты, назначенные или опубликованные в выбранном объекте групповой политики. В зависимости от объекта групповой политики этот список может либо иметь несколько записей, либо не иметь их вообще.

  7. Щелкните пакет, который необходимо обновить, и выберите либо Удалить приложение, затем установить его обновлениелибо Обновление возможно поверх имеющегося приложения, а затем нажмите кнопку OK.

    Обычно параметр удаления используется для замены существующего приложения другим (возможно даже, другого производителя программ). Параметр обновления используется для установки новой версии существующего приложения, сохраняя предпочтения пользователя, типы связанных с этим приложением документов и так далее.

  8. Если необходимо сделать обновление обязательным, на вкладке Обновления установите флажок Обязательное обновление для уже установленных приложений и нажмите кнопку OK.

    Если это обновление происходит в узле «Конфигурация компьютера» консоли «Групповая политика», то этот флажок отображается установленным и затененным, поскольку пакеты могут быть только назначены компьютеру, но не опубликованы.

Примечание

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».

См. также


Удаление управляемого приложения

Рисунок Microsoft Windows

Чтобы удалить управляемое приложение

  1. Откройте оснастку «Установка программного обеспечения».
  2. В дереве консоли щелкните узел Установка программного обеспечения.

    3. Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения
  3. В панели сведений щелкните правой кнопкой мыши удаляемое приложение.
  4. Выберите пункт Все задачи, а затем — Удалить.
  5. В диалоговом окне Удаление приложений выберите один из следующих способов удаления и нажмите кнопку OK.

    Немедленное удаление этого приложения с компьютеров всех пользователей. Выберите этот параметр, чтобы указать, что приложение будет удалено при следующем входе пользователя в систему или при перезагрузке компьютера.

    Разрешить использование уже установленного приложения, но запретить новую установку. Выберите этот способ, чтобы указать, что пользователи имеют возможность продолжать использовать приложение, если оно уже установлено. Если приложение удалено или не установлено, то пользователи больше не смогут его установить.

Примечание

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».

См. также


Задание свойств приложения

  • Просмотр свойств управляемых приложений
  • Редактирование параметров установки приложений
  • Задание категорий приложений для компонента «Установка и удаление программ» на панели управления.
  • Задание параметра автоматической установки для приложения
  • Установка разрешений для оснастки «Установка программного обеспечения»


Просмотр свойств управляемых приложений

Рисунок Microsoft Windows

Чтобы просмотреть свойства управляемых приложений

  1. Откройте оснастку «Установка программного обеспечения».
  2. В области сведений щелкните правой кнопкой приложения, свойства которого необходимо просмотреть, и выберите команду Свойства.

Примечание

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».

См. также


Редактирование параметров установки приложений

Рисунок Microsoft Windows

Чтобы отредактировать параметры установки приложений

  1. Откройте оснастку «Установка программного обеспечения».
  2. В дереве консоли щелкните узел Установка программного обеспечения.

    3. Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения
  3. В области сведений щелкните правой кнопкой мыши приложение, для которого нужно установить параметры установки, и выберите команду Свойства.
  4. В диалоговом окне свойств перейдите на вкладку Развертывание.
  5. На вкладке Развертывание в группе Тип развертывания выберите один из следующих параметров:

    Опубликовано. Пользователи выбранного узла, домена или подразделения могут устанавливать приложение, используя компонент «Установка и удаление программ» на панели управления либо запуская соответствующий файл.

    Назначено. Пользователи выбранного узла, домена или подразделения получают это приложение при следующем входе в систему (для назначенных пользователю) или при перезагрузке компьютера (для назначенных компьютеру).

  6. В группе Параметры развертывания установите необходимые флажки для следующих параметров:

    Автоматически устанавливать приложение при обращении к файлу с соответствующим расширением. Установите данный флажок, если требуется использовать приоритет приложения для расширения файла, как определено на вкладке Расширения файлов в диалоговом окне Свойства установки программ.

    Если приложение еще не установлено, выбор этого параметра означает, что оно будет установлено при попытке пользователя открыть файл с расширением, связанным с этим приложением (например, если пользователь дважды щелкнет такой файл).

    Удалять это приложение, если его использование выходит за рамки, допустимые политикой управления. Выберите этот параметр при необходимости удалять приложение при входе (для пользователей) или при загрузке (для компьютеров), если они переходят на узел, домен или подразделение, для которого это приложение не развернуто.

    Не отображать этот пакет в окне мастера установки и удаления программ панели управления. С помощью данного параметра для пользователя исключается наиболее очевидный способ удаления приложения. В некоторых случаях это может быть полезно.

    Устанавливать это приложение при входе в систему. Если выбран этот параметр, приложение не демонстрируется пользователю при помощи ярлыка. Вместо этого выполняется полная установка приложения с использованием параметров пакета по умолчанию. Следует отметить, что использование параметров пакета по умолчанию позволяет устанавливать функции программы как полностью, так и выборочно.

  7. В группе Пользовательский интерфейс при установке выберите один из следующих параметров.

    Простой. Отображаются только индикаторы выполнения и ошибки.

    Полный. Полностью отображается интерфейс, поддерживаемый пакетом.

  8. При необходимости выбора дополнительных параметров нажмите кнопку Дополнительно.

    Не использовать языковые установки при развертывании. Выберите этот параметр, если требуется устанавливать приложения с языком, отличным от языка операционной системы.

    Удаление существующих экземпляров этого продукта с компьютеров, если он был установлен не на основе групповой политики. Данный параметр может быть полезен, например, в случаях, когда политика организации не разрешает пользователям устанавливать приложения с собственных компакт-дисков.

    Сделать это 32-разрядное X86 приложение доступным для компьютеров с архитектурой IA64. Параметр определяет возможность развертывания или публикации данного 32-разрядного приложения для компьютеров с архитектурой IA64.

    Включать информацию об OLE классе и продукте. Этот параметр указывает, следует ли развертывать сведения о COM-компонентах вместе с пакетом, что позволит программному обеспечению клиента устанавливать их по мере необходимости из Active Directory аналогично активации при обращении к расширению имени файла.

Примечания

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».
  • Окно Дополнительные параметры развертывания, возникающее при нажатии кнопки Дополнительно, позволяет просмотреть дополнительные диагностические сведения, которые могут потребоваться для устранения неполадок.
    Поле | Данные
    Код продукта | Глобальный уникальный идентификатор (GUID), представляющий продукт
    Развернуто | Количество раз, которое был развернут пакет в объекте групповой политики
    Имя сценария | Полный сетевой путь, включая GUID, к сценарию назначения приложения (файл с расширением .aas)

См. также


Задание категорий для компонента «Установка и удаление программ» на панели управления.

Рисунок Microsoft Windows

Чтобы задать категории приложений для компонента «Установка и удаление программ» на панели управления

  1. Откройте оснастку «Установка программного обеспечения».
  2. В панели сведений дважды щелкните управляемое приложения, для которого необходимо задать категории.
  3. В диалоговом окне свойств перейдите на вкладку Категории.
  4. На вкладкеКатегории выберите необходимые параметры и нажмите кнопку OK:

    5. Доступные категории. Список категорий приложений, которые могут быть назначены для организации.

    Выбрать. Связывает выбранную категорию приложений с приложением. Чтобы использовать этот параметр, выберите категорию из списка Доступные категории и нажмите кнопку Выбрать.

    Удалить. Удаляет категорию из списка Выбранные категории. Чтобы использовать этот параметр, выберите категорию в списке Выбранные категории и нажмите кнопку Удалить.

    Выбранные категории. Отображает категории, которые связаны с этим приложением.

Примечания

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».
  • Категории, установленные в этом диалоговом окне, обычно применимы только к опубликованным приложениям, поскольку назначенные приложения не отображаются в окне «Установка и удаление программ» на панели управления. Приложения в выбранных категориях отображаются в окне «Установка и удаление программ» на панели управления, используемое пользователями для установке приложения.
  • Эта процедура используется только для связи приложений с существующими категориями, а не для создания или удаления категорий. Для получения сведений об управлении непосредственно категориями щелкните ссылку «См. также».

См. также


Задание параметра автоматической установки для приложения

Рисунок Microsoft Windows

Чтобы задать параметр автоматической установки для приложения

  1. Откройте оснастку «Установка программного обеспечения».
  2. В дереве консоли щелкните узел Установка программного обеспечения.

    3. Расположение

    • Имя объекта групповой политики
    • Конфигурация пользователя
    • Конфигурация программ
    • Установка программного обеспечения
  3. В панели сведений щелкните правой кнопкой мыши приложение, которое должно будет устанавливаться автоматически при попытке пользователя открыть файл со связанным расширением.
  4. Нажмите кнопку Свойства и выберите вкладку Развертывание.
  5. В группе Параметры развертывания убедитесь, что флажок Автоматически устанавливать приложение при обращении к файлу с соответствующим расширением установлен, и нажмите кнопку OK.

Примечания

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».
  • При обновлении приложения убедитесь, что для старой версии отключен параметр автоматической установки.

См. также


Установка разрешений для оснастки «Установка программного обеспечения»

Рисунок Microsoft Windows

Чтобы установить разрешения для оснастки «Установка программного обеспечения»

  1. Откройте объект групповой политики, который требуется изменить.
  2. В дереве консоли щелкните правой кнопкой значок или имя объекта групповой политики, который выглядит следующим образом:
    Политика имя_объекта_групповой_политики [имя_домена],
    и выберите команду Свойства.
  3. Перейдите на вкладку Безопасность и в области Группы или пользователи щелкните группу безопасность, для которой необходимо задать разрешения.

    Если необходимо изменить набор групп безопасности, имеющих разрешения на данный объект групповой политики, используйте кнопки Добавить и Удалить для добавления или удаления групп безопасности.

  4. Если группа безопасности представляет администраторов (лиц, управляющих программным обеспечением для пользователей и компьютеров в организации), в поле Разрешения для выбранной группы установите флажок Разрешить для полного контроля, а затем нажмите кнопку OK.

    Если группа безопасности представляет пользователей (лиц, использующих программное обеспечение, назначенное или опубликованное администратором), в поле Разрешения для выбранной группы установите флажки Разрешить для применения групповой политики и для чтения, а затем нажмите кнопку OK.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните раздел «См. также».
  • Разрешения, установленные с помощью данной процедуры, относятся только к объекту групповой политики. Кроме того, в сети должны быть общие папки (точки распространения программного обеспечения), содержащие пакеты для установки. Администраторы должны иметь полный доступ к этим точкам, а пользователи — только разрешение на чтение. Сведения о разрешениях и их установке см. в разделе Управление доступом.

См. также


Работа с модификациями пакета

  • Добавление или удаление модификаций для пакета приложения


Добавление или удаление модификаций для пакета приложения

Рисунок Microsoft Windows

Чтобы добавить или удалить модификации для пакета приложения

  1. Откройте оснастку «Установка программного обеспечения».
  2. В дереве консоли щелкните узел Установка программного обеспечения.

    3. Расположение

    • Имя объекта групповой политики
    • Конфигурация компьютера (или «Конфигурация пользователя»)
    • Конфигурация программ
    • Установка программного обеспечения
  3. Щелкните правой кнопкой мыши панель сведений и выберите команду Создать, а затем — команду Пакет. Диалоговое окно Открыть открывается в местоположении пакетов, заданном по умолчанию, которое можно изменить. Если возникла такая необходимость, см. раздел Задание параметров оснастки «Установка программного обеспечения» по умолчанию.
  4. В диалоговом окне Открыть выберите пакет установщика Windows и нажмите кнопку Открыть.
  5. В диалоговом окне Развертывание программы выберите параметр Дополнительно и нажмите кнопку OK.
  6. В диалоговом окне свойств перейдите на вкладку Модификации.
  7. Если необходимо добавить модификации, нажмите кнопку Добавить. В диалоговом окне Открыть перейдите к файлу преобразователя (.mst) и нажмите кнопку Открыть.
  8. Если требуется удалить модификации, на вкладке Модификации щелкните одну из них и нажмите кнопку Удалить. Повторите этот шаг для каждой удаляемой модификации.
  9. Убедитесь, что модификации настроены должным образом, и нажмите кнопку OK.

Внимание!

  • Не нажимайте кнопку OK до тех пор, пока не закончена настройка модификаций. При нажатии кнопки OK пакет будет назначен или опубликован немедленно. Если модификации настроены неправильно, придется удалить пакет или обновить его до правильно настроенной версии.

Примечания

  • Чтобы открыть оснастку «Установка программного обеспечения», щелкните ссылку «См. также».
  • Модификации (файлы .mst) применяются к пакетам установщика Windows (которые имеют расширение .msi) в порядке, заданном администратором. Этот порядок должен быть определен до назначения или публикации приложения.
  • Можно также добавить несколько модификаций (также называемых «преобразованиями»). Преобразования применяются в порядке, заданном в списке Модификации, сверху вниз. Если требуется изменить этот порядок, щелкните в списке нужную строку и нажмите кнопку Вверх или Вниз, чтобы переместить ее.

См. также


Использование оснастки «Перенаправление папки»

  • Перенаправление особых папок в одно расположение для всех пользователей
  • Перенаправление специальных папок в различные размещения в соответствии с членством в группе безопасности


Перенаправление особых папок в одно расположение для всех пользователей

  • Перенаправление папки «Мои документы» в основной каталог
  • Перенаправление специальных папок в корневой каталог
  • Перенаправление специальных папок по указанному пути
  • Перенаправление специальных папок в расположение локального профиля


Перенаправление папки «Мои документы» в основной каталог

Рисунок Microsoft Windows

Чтобы перенаправить папку «Мои документы» в основной каталог

  1. Откройте объект групповой политики, связанный с сайтом, доменом или подразделением, содержащим пользователей, чьи папки «Мои документы» необходимо перенаправить.
  2. В дереве консоли дважды щелкните узел Перенаправление папки, чтобы открыть папку «Мои документы».

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Конфигурация Windows
    • Перенаправление папки
    • Мои документы
  3. Щелкните правой кнопкой параметр Мои документы и выберите команду Свойства.
  4. На вкладке Размещение выберите в поле Политика значение
    Простое - перенаправлять папки всех пользователей в одно место.
  5. В области Размещение конечной папки выберите Перенаправить на домашнюю папку пользователя и нажмите кнопку OK.

Примечания

  • Эта возможность предназначена только для организаций, которые уже развернули домашние папки, и теперь требуется обеспечить совместимость с существующей средой домашних папок.
  • Если перенаправить папку «Мои документы» в домашнюю папку, администраторы домена будут иметь полный контроль над папкой пользователя «Мои документы». Это будет иметь место даже при установленном флажке Предоставить права монопольного доступа к «Мои документы» на вкладке Параметры диалогового окна Свойства: Мои документы.
  • Для перенаправления в домашнюю папку требуется клиент Windows XP Professional. Это средство недоступно для клиентов Windows 2000, Windows NT или Windows XP Home Edition.
  • При перенаправлении в домашнюю папку безопасность не проверяется, разрешения не изменяются. При перенаправлении папки предполагается, что безопасность папки настроена администратором должным образом. Такой подход к безопасности является причиной того, что перенаправление в домашнюю папку не рекомендуется использовать за исключением случаев, когда это необходимо для обратной совместимости.
  • При перенаправлении в домашнюю папку проверки владельца не выполняются. Как правило, перенаправление не удается выполнить, если пользователь не является владельцем папки, в которую выполняется перенаправление. Поскольку перенаправление в домашнюю папку предполагается использовать в устаревшем окружении, проверка владельца не производится.
  • Для пользователей должно быть должным образом настроено свойство домашней папки в их объектах службы каталогов Active Directory. Клиентские компьютеры извлекают путь к домашней папке пользователя из его объекта в Active Directory при входе пользователя в систему. Для пользователей, у которых задействована политика перенаправления папки, этот путь должен быть задан правильно, иначе перенаправление папки выполнить не удастся.
  • Не следует перенаправлять папку «Мои документы» в домашнюю папку, находящуюся в расположении, в котором используется шифрование на базе файловой системы EFS, поскольку в этом случае расшифровать ее сможет только выполнивший перенаправление и администратор домена. Пользователь, чья папка «Мои документы» была перенаправлена, расшифровать ее не сможет.

См. также


Перенаправление специальных папок в корневой каталог

Рисунок Microsoft Windows

Чтобы перенаправить специальные папки в корневой каталог

  1. Откройте объект групповой политики, связанный с сайтом, доменом или подразделением, содержащим пользователей, чьи специальные папки необходимо перенаправить.
  2. Чтобы отобразить особую папку, которую необходимо перенаправить, в дереве консоли дважды щелкните узел Перенаправление папки.

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Конфигурация Windows
    • Перенаправление папки
  3. Щелкните правой кнопкой мыши особую папку, которую требуется перенаправить (такую как Рабочий стол, Мои документы и так далее) и выберите в контекстном меню команду Свойства.
  4. На вкладке Размещение выберите в поле Политика значение
    Простое - перенаправлять папки всех пользователей в одно место.
  5. В области Размещение конечной папки выберите Создать папку для каждого пользователя на корневом пути.
  6. В поле Корневой путь введите путь в формате UNC, например \\имя_сервера\имя_ресурса, и нажмите кнопку OK.
  7. В диалоговом окне свойств особой папки нажмите кнопку OK.

Примечание

  • Имя пользователя и имя папки добавляются в путь UNC автоматически.

См. также


Перенаправление специальных папок в указанное расположение

Рисунок Microsoft Windows

Чтобы перенаправить специальные папки в указанное расположение

  1. Откройте объект групповой политики, связанный с сайтом, доменом или подразделением, содержащим пользователей, чьи специальные папки необходимо перенаправить.
  2. Чтобы отобразить особую папку, которую необходимо перенаправить, в дереве консоли дважды щелкните узел Перенаправление папки.

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Конфигурация Windows
    • Перенаправление папки
  3. Щелкните правой кнопкой мыши особую папку, которую требуется перенаправить (такую как Рабочий стол, Мои документы и так далее) и выберите в контекстном меню команду Свойства.
  4. На вкладке Размещение выберите в поле Политика значение
    Простое - перенаправлять папки всех пользователей в одно место.
  5. В области Размещение конечной папки выберите Перенаправлять в следующее место.
  6. В поле Корневой путь введите путь в формате UNC (например, \\имя_сервера\имя_ресурса) или введите допустимый путь к локальному расположению (например, C:\somefolder), а затем нажмите кнопку OK.

Примечание

  • В большинстве случаев вместо описанного в данном разделе перенаправления в указанное расположение используется перенаправление в корневой каталог. Дополнительные сведения см. в разделе Перенаправление специальных папок в корневой каталог.

См. также


Перенаправление специальных папок в расположение локального профиля

Рисунок Microsoft Windows

Чтобы перенаправить специальные папки в расположение локального профиля

  1. Откройте объект групповой политики, связанный с сайтом, доменом или подразделением, содержащим пользователей, чьи специальные папки необходимо перенаправить.
  2. Чтобы отобразить особую папку, которую необходимо перенаправить, в дереве консоли дважды щелкните узел Перенаправление папки.

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Конфигурация Windows
    • Перенаправление папки
  3. Щелкните правой кнопкой мыши особую папку, которую требуется перенаправить (такую как Рабочий стол, Мои документы и так далее) и выберите в контекстном меню команду Свойства.
  4. На вкладке Размещение выберите в поле Политика значение
    Простое - перенаправлять папки всех пользователей в одно место.
  5. В области Размещение конечной папки выберите Перенаправлять в место, определяемое локальным профилем и нажмите кнопку OK.

Примечания

  • Данная процедура используется для возврата перенаправленной папки в исходное расположение по умолчанию.
  • Изменение значения параметра на Не указывать политику на вкладке Размещение диалогового окна свойств особой папки не вызывает перенаправления особой папки в ее стандартное расположение.

См. также


Перенаправление специальных папок в расположения размещения в соответствии с членством в группе безопасности

Рисунок Microsoft Windows

Перенаправление специальных папок в различные расположения в соответствии с членством в группе безопасности

  • Перенаправление папки «Мои документы» в основной каталог в соответствии с членством в группе безопасности
  • Перенаправление специальных папок в корневой каталог в соответствии с членством в группе безопасности
  • Перенаправление специальных папок по указанному пути в соответствии с членством в группе безопасности
  • Перенаправление специальных папок в расположение локального профиля в соответствии с членством в группе безопасности


Перенаправление папки «Мои документы» в основной каталог в соответствии с членством в группе безопасности

Рисунок Microsoft Windows

Чтобы перенаправить папку «Мои документы» в основной каталог в соответствии с членством в группе безопасности

  1. Откройте объект групповой политики, связанный с сайтом, доменом или подразделением, содержащим пользователей, чьи папки «Мои документы» необходимо перенаправить.
  2. В дереве консоли дважды щелкните узел Перенаправление папки, чтобы открыть папку «Мои документы».

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Конфигурация Windows
    • Перенаправление папки
    • Мои документы
  3. Щелкните правой кнопкой параметр Мои документы и выберите команду Свойства.
  4. На вкладке Размещение выберите в поле Политика значение
    Расширенное - указать различные места для разных групп пользователей.
  5. Нажмите кнопку Добавить, чтобы открыть диалоговое окно Выбор группы и размещения.
  6. В группе Членство в группе безопасности введите имя группы безопасности или нажмите кнопку Обзор, чтобы найти эту группу.
  7. В области Размещение конечной папки выберите Перенаправить на домашнюю папку пользователя и нажмите кнопку OK.
  8. В диалоговом окне Свойства: Мои документы нажмите кнопку OK.

Примечания

  • Эта возможность предназначена только для организаций, которые уже развернули домашние папки, и теперь требуется обеспечить совместимость с существующей средой домашних папок.
  • Если перенаправить папку «Мои документы» в домашнюю папку, администраторы домена будут иметь полный контроль над папкой пользователя «Мои документы». Это будет иметь место даже при установленном флажке Предоставить права монопольного доступа к «Мои документы» на вкладке Параметры диалогового окна Свойства: Мои документы.
  • Для перенаправления в домашнюю папку требуется клиент Windows XP Professional. Это средство недоступно для клиентов Windows 2000, Windows NT или Windows XP Home Edition.
  • При перенаправлении в домашнюю папку безопасность не проверяется и разрешения не изменяются. При перенаправлении папки предполагается, что безопасность папки настроена администратором должным образом. Такой подход к безопасности является причиной того, что перенаправление в домашнюю папку не рекомендуется использовать за исключением случаев, когда это необходимо для обратной совместимости.
  • При перенаправлении в домашнюю папку проверки владельца не выполняются. Как правило, перенаправление не удается выполнить, если пользователь не является владельцем папки, в которую выполняется перенаправление. Поскольку перенаправление в домашнюю папку предполагается использовать в устаревшем окружении, проверка владельца не производится.
  • Для пользователей должно быть должным образом настроено свойство домашней папки в их объектах службы каталогов Active Directory. Клиентские компьютеры извлекают путь к домашней папке пользователя из его объекта в Active Directory при входе пользователя в систему. Для пользователей, у которых задействована политика перенаправления папки, этот путь должен быть задан правильно, иначе перенаправление папки выполнить не удастся.
  • Не следует перенаправлять папку «Мои документы» в домашнюю папку, находящуюся в расположении, в котором используется шифрование на базе файловой системы EFS, поскольку в этом случае расшифровать ее сможет только выполнивший перенаправление и администратор домена. Пользователь, чья папка «Мои документы» была перенаправлена, расшифровать ее не сможет.

См. также


Перенаправление специальных папок в корневой каталог в соответствии с членством в группе безопасности

Рисунок Microsoft Windows

Чтобы перенаправить специальные папки в корневой каталог в соответствии с членством в группе безопасности

  1. Откройте объект групповой политики, связанный с сайтом, доменом или подразделением, содержащим пользователей, чьи специальные папки необходимо перенаправить.
  2. Чтобы отобразить особую папку, которую необходимо перенаправить, в дереве консоли дважды щелкните узел Перенаправление папки.

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Конфигурация Windows
    • Перенаправление папки
  3. Щелкните правой кнопкой мыши особую папку, которую требуется перенаправить (такую как Рабочий стол, Мои документы и так далее) и выберите в контекстном меню команду Свойства.
  4. На вкладке Размещение выберите в поле Политика значение
    Расширенное - указать различные места для разных групп пользователей.
  5. Нажмите кнопку Добавить, чтобы открыть диалоговое окно Выбор группы и размещения.
  6. В группе Членство в группе безопасности введите имя группы безопасности или нажмите кнопку Обзор, чтобы найти эту группу.
  7. В области Размещение конечной папки выберите Создать папку для каждого пользователя на корневом пути.
  8. В поле Корневой путь введите путь в формате UNC, например \\имя_сервера\имя_ресурса, и нажмите кнопку OK.
  9. В диалоговом окне свойств особой папки нажмите кнопку OK.

Примечание

  • Имя пользователя и имя папки добавляются в путь UNC автоматически.

См. также


Перенаправление специальных папок в указанное расположение в соответствии с членством в группе безопасности

Рисунок Microsoft Windows

Чтобы перенаправить специальные папки в указанное расположение в соответствии с членством в группе безопасности

  1. Откройте объект групповой политики, связанный с сайтом, доменом или подразделением, содержащим пользователей, чьи специальные папки необходимо перенаправить.
  2. Чтобы отобразить особую папку, которую необходимо перенаправить, в дереве консоли дважды щелкните узел Перенаправление папки.

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Конфигурация Windows
    • Перенаправление папки
  3. Щелкните правой кнопкой мыши особую папку, которую требуется перенаправить (такую как Рабочий стол, Мои документы и так далее) и выберите в контекстном меню команду Свойства.
  4. На вкладке Размещение выберите в поле Политика значение
    Расширенное - указать различные места для разных групп пользователей.
  5. Нажмите кнопку Добавить, чтобы открыть диалоговое окно Выбор группы и размещения.
  6. В группе Членство в группе безопасности введите имя группы безопасности или нажмите кнопку Обзор, чтобы найти эту группу.
  7. В области Размещение конечной папки выберите Перенаправлять в следующее место.
  8. В поле Корневой путь введите путь в формате UNC, например \\имя_сервера\имя_ресурса, и нажмите кнопку OK.
  9. В диалоговом окне свойств особой папки нажмите кнопку OK.

Примечание

  • В большинстве случаев вместо описанного в данном разделе перенаправления в указанное расположение используется перенаправление в корневой каталог. Дополнительные сведения см. в разделе Перенаправление специальных папок в корневой каталог.

См. также


Перенаправление специальных папок в расположение локального профиля в соответствии с членством в группе безопасности

Рисунок Microsoft Windows

Чтобы перенаправить специальные папки в расположение локального профиля в соответствии с членством в группе безопасности

  1. Откройте объект групповой политики, связанный с сайтом, доменом или подразделением, содержащим пользователей, чьи специальные папки необходимо перенаправить.
  2. Чтобы отобразить особую папку, которую необходимо перенаправить, в дереве консоли дважды щелкните узел Перенаправление папки.

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Конфигурация Windows
    • Перенаправление папки
  3. Щелкните правой кнопкой мыши особую папку, которую требуется перенаправить (такую как Рабочий стол, Мои документы и так далее) и выберите в контекстном меню команду Свойства.
  4. На вкладке Размещение выберите в поле Политика значение
    Расширенное - указать различные места для разных групп пользователей.
  5. Нажмите кнопку Добавить, чтобы открыть диалоговое окно Выбор группы и размещения.
  6. В группе Членство в группе безопасности введите имя группы безопасности или нажмите кнопку Обзор, чтобы найти эту группу.
  7. В области Размещение конечной папки выберите Перенаправлять в место, определяемое локальным профилем и нажмите кнопку OK.
  8. В диалоговом окне свойств особой папки нажмите кнопку OK.

Примечания

  • Данная процедура используется для возврата перенаправленной папки в исходное расположение по умолчанию.
  • Изменение значения параметра на Не указывать политику на вкладке Размещение диалогового окна свойств особой папки не вызывает перенаправления особой папки в ее стандартное расположение.

См. также


Настройка групповой политики

  • Расширение возможностей групповой политики
  • Немедленное обновление групповой политики
  • Установка разрешений на объект групповой политики
  • Задание частоты обновления групповой политики для компьютеров
  • Установка других политик для оснастки «Групповая политика»


Расширение возможностей оснастки «Групповая политика»

Рисунок Microsoft Windows

Чтобы расширить возможности оснастки «Групповая политика»

  1. Откройте оснастку «Групповая политика» как автономную оснастку консоли управления MMC.
  2. В меню Консоль выберите команду Добавить или удалить оснастку.
  3. На вкладке Расширения выберите расширяемую оснастку и необходимое расширение, а затем нажмите кнопку OK.

Примечание

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».

См. также


Немедленное обновление групповой политики

Рисунок Microsoft Windows

Чтобы обновить групповую политику немедленно

  1. Нажмите кнопку Пуск и выберите команду Выполнить.
  2. В поле Открыть введите gpupdate и нажмите кнопку OK.

Примечание

  • Для получения дополнительных сведений о средствах gpupdate, gpresult и других средствах командной строки щелкните ссылку «См. также».

См. также


Установка разрешений на объект групповой политики

Рисунок Microsoft Windows

Чтобы установить разрешения на объект групповой политики

  1. Откройте оснастку «Групповая политика».
  2. В дереве консоли щелкните правой кнопкой значок или имя объекта групповой политики, который выглядит следующим образом:
    Политика имя_объекта_групповой_политики [имя_домена],
    и выберите команду Свойства.
  3. Перейдите на вкладку Безопасность, выберите нужные параметры (описанные ниже) и нажмите кнопку OK.

    4. Добавить. Открывает диалоговое окно Выбор: Пользователи, Компьютеры или Группы, в котором следует указать пользователей и группы, для которых назначаются разрешения.

    Удалить. Удаление из списка Группы или пользователи выбранных пользователей и группы, а также их разрешений на объект.

    Разрешения для: Прошедшие проверку. Отображает список стандартных разрешений, которые можно назначить или запретить пользователю, например «Полный доступ», «Чтение», «Запись» и так далее.

    Дополнительно. Используется для просмотра и задания особых разрешений, правил аудита и прав владельца для данного объекта.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • Разрешения могут быть заданы только для нелокального объекта групповой политики.

См. также


Задание частоты обновления групповой политики для компьютеров

Рисунок Microsoft Windows

Чтобы задать частоту обновления групповой политики для компьютеров

  1. Откройте оснастку «Групповая политика».
  2. В дереве консоли щелкните узел Групповая политика.

    3. Расположение

    • Политика имя_политики
    • Конфигурация компьютера
    • Административные шаблоны
    • Система
    • Групповая политика
  3. В области сведений дважды щелкните значок Интервал обновления групповой политики для компьютеров.
  4. На вкладке Параметр установите значение Включен.
  5. В полях Минут введите или выберите количество минут для интервала обновления и случайного смещения, а затем нажмите кнопку OK.
  6. В области сведений дважды щелкните параметр Отключить фоновое обновление групповой политики.
  7. На вкладке Параметр выберите Отключен и нажмите кнопку OK.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • По умолчанию файл System.adm установлен в узле Computer Configuration\Administrative Templates, где имеется возможность просмотреть данные параметры. Если файл System.adm не установлен, щелкните ссылку «См. также» для получения сведений о добавлении и удалении файлов административных шаблонов.
  • Компьютеры-клиенты запрашивают политику с контроллера домена при возникновении одного из следующих событий:
    • запуск компьютера;
    • вход пользователя в систему;
    • запрос приложением обновления с помощью функции API RefreshPolicy();
    • запрос пользователем немедленного обновления;
    • включен и задан один из интервалов обновления групповой политики.

    Политика не применяется контроллером домена, а запрашивается к компьютером-клиентом.

  • При минимальном значении параметра «Интервал обновления групповой политики» (ноль минут) фактическое время между запросом и обновлением составит около семи секунд. Установка минимального интервала времени обновления не используется в рабочем окружении, кроме случаев тестирования.
  • Политика обновлений не оказывает влияние на расширения «Установка программного обеспечения» и «Перенаправление папки».

См. также


Установка других политик в оснастке «Групповая политика»

Рисунок Microsoft Windows

Чтобы установить другие политики в оснастке «Групповая политика»

  1. Откройте оснастку «Групповая политика» с установленным файлом System.adm.
  2. Для изменения политики компьютера в дереве консоли щелкните Групповая политика.

    3. Расположение

    • Политика имя_политики
    • Конфигурация компьютера
    • Административные шаблоны
    • Система
    • Групповая политика

    Для изменения политики пользователя в дереве консоли щелкните Групповая политика.

    Расположение

    • Политика имя_политики
    • Конфигурация пользователя
    • Административные шаблоны
    • Система
    • Групповая политика
  3. В области сведений дважды щелкните значок или имя политики, которую необходимо задать.
  4. На вкладке Параметр задайте нужные значения и нажмите кнопку OK.

Примечания

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».
  • Файл System.adm установлен по умолчанию.

См. также


Делегирование управления групповой политикой

  • Делегирование изменения объекта групповой политики
  • Делегирование создания объектов групповой политики
  • Делегирование связывания объектов групповой политики


Делегирование изменения объекта групповой политики

Рисунок Microsoft Windows

Чтобы делегировать изменение объекта групповой политики

  1. Откройте оснастку «Групповая политика».
  2. В дереве консоли щелкните правой кнопкой значок или имя объекта групповой политики, который выглядит следующим образом:
    Политика имя_объекта_групповой_политики [имя_домена],
    и выберите команду Свойства.
  3. Чтобы добавить пользователя или группу пользователей, перейдите на вкладку Безопасность и нажмите кнопку Добавить. Введите имя пользователя или группы, затем нажмите кнопку OK.

    Чтобы предоставить пользователю или пользователям разрешения на чтение и запись, в области Разрешения для: Прошедшие проверку установите флажок Разрешить для чтения и записи. По окончании нажмите кнопку OK.

    Если нет необходимости применять политику для пользователя или группы пользователей, в области Разрешения для: Прошедшие проверку снимите флажок Разрешено, относящийся к применению групповой политики. По окончании нажмите кнопку OK.

Примечание

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».

См. также


Делегирование создания объектов групповой политики

Рисунок Microsoft Windows

Чтобы делегировать создание объектов групповой политики

  1. Откройте оснастку Active Directory — пользователи и компьютеры.
  2. В дереве консоли щелкните папку Пользователи.
  3. В столбце Имя панели сведений дважды щелкните Владельцы-создатели групповой политики.
  4. В диалоговом окне Свойства: Владельцы-создатели групповой политики откройте вкладку Члены.
  5. Нажмите кнопку Добавить и дважды щелкните имя каждого пользователя или группы безопасности, которым необходимо делегировать права создания.
  6. Нажмите кнопку OK в диалоговом окне Выбор: Пользователи, Контакты или Компьютеры, а затем — кнопку OK в диалоговом окне Свойства: Владельцы-создатели групповой политики.

Примечания

  • Для запуска оснастки «Active Directory — пользователи и компьютеры» откройте подключение к удаленному рабочему столу контроллера домена Windows 2000 или рядового сервера, на котором установлены средства администрирования Windows 2000. Для выполнения данной процедуры необходимо войти в систему на сервере в качестве администратора домена.
  • По умолчанию права на создание объектов групповой политики имеют только администраторы домена, администраторы предприятия, владельцы-создатели групповой политики и операционная система. Если администратор считает необходимым предоставить права создания объектов групповой политики пользователям или группе, они могут быть добавлены в группу безопасности «Владельцы-создатели групповой политики». При создании пользователем, не являющимся администратором, но входящим в группу «Владельцы-создатели групповой политики» объекта групповой политики пользователь становится создателем и владельцем данного объекта, и, следовательно, имеет права на его изменение. Членство в группе «Владельцы-создатели групповой политики» дает пользователю полный контроль только над объектами, созданными пользователем или теми, на который ему явно делегированы права. Это не дает пользователям никаких дополнительных прав на другие объекты групповой политики в домене — они не имеют прав на объекты, которые созданы не ими.
  • При создании объекта групповой политики администратором создателем-владельцем данного объекта становится группа «Администраторы домена».
  • При делегировании этой задачи пользователям делегируется также возможность управлять связями для указанного подразделения. Причиной этого является то, что пользователи (не являющиеся администраторами) по умолчанию не могут управлять связями, а невозможность управлять связями влечет за собой невозможность использовать оснастку «Active Directory — пользователи и компьютеры» для объекта групповой политики.

См. также


Делегирование связывания объектов групповой политики

Рисунок Microsoft Windows

Чтобы делегировать связывание объекта групповой политики

  1. Откройте оснастку Active Directory — пользователи и компьютеры.
  2. Щелкните правой кнопкой мыши подразделение, которому необходимо делегировать право связывать объекты групповой политики, и нажмите кнопку Делегирование управления.
  3. Нажмите кнопку Далее, а затем — кнопку Добавить.
  4. В диалоговом окне Выбор: Пользователи, Компьютеры или Группы выберите имя пользователя или группы и нажмите кнопку Добавить.
  5. В диалоговом окне Выбор: Пользователи, Компьютеры или Группы нажмите кнопку OK, а затем — кнопку Далее.
  6. В списке Делегировать следующие обычные задачи установите флажок Управление ссылками на групповые политики и нажмите кнопку Далее.
  7. Нажмите кнопку Готово.

Примечание

  • Чтобы открыть оснастку «Групповая политика», щелкните ссылку «См. также».

См. также


Основные понятия

В данном разделе содержатся основные сведения о групповой политике, изменении и настройке технологий управления, использующих групповою политику.

  • Новые возможности
  • Обзор групповой политики
  • Общие сведения о групповой политике
  • Использование оснастки «Групповая политика»
  • Ресурсы


Новые возможности

Windows XP Professional по сравнению с Windows 2000 обладают усовершенствованными технологиями управления конфигурацией.

Результирующая политика

Результирующая политика (RSoP) — это новое средство, помогающее прогнозировать и устранять неполадки при использовании политик. Дополнительные сведения см. в разделе Результирующая политика.

Административные шаблоны

В файлы .adm добавлено новое ключевое слово Поддерживается, указывающее, какая версия Windows поддерживается в качестве клиента для параметра. Сведения о ключевом слове Поддерживается см. на веб-странице Реализация групповой политики с помощью реестра (http://www.microsoft.com/), расположенной на веб-узле корпорации Майкрософт;

Кроме того, добавлен способ просмотра папки «Административные шаблоны» в виде веб-страницы, при котором отображается ключевое слово Поддерживается, указывающее, какая версия Windows поддерживается в качестве клиента для выбранного параметра. Сведения об использовании просмотра в виде веб-страницы см. в разделе Использование вида папки «Административные шаблоны».

Теперь интерактивная справка по административным шаблонам включена в Windows. В следующей таблице приведены ссылки на разделы справки по файлам .adm.

Файл .adm | Параметры политики
System.adm | Откройте раздел справки Системные параметры.
Wmplayer.adm | Откройте раздел справки Параметры проигрывателя Windows Media
Inetres.adm | Откройте раздел справки Параметры Internet Explorer
Conf.adm | Откройте раздел справки Параметры NetMeeting

Возможность осуществлять фильтрацию параметров при просмотре для упрощения отображения параметров при использовании папки «Административные шаблоны». Сведения об использовании данной функции см. в разделе Использование фильтра при просмотре папки «Административные шаблоны».

Дополнительные сведения об административных шаблонах см. в разделе Административные шаблоны.

Средства командной строки для оснастки «Групповая политика»

Команда Windows 2000 secedit /refreshpolicy больше не используется, она заменена средством gpupdate.

Расширены возможности команды пакета Windows 2000 Resource Kit gpresult,которая теперь входит в поставку Windows XP Professional.

Перенаправление папки

Упрощено применение перенаправления папок. Больше нет необходимости использовать переменные типа %username% при вводе пути перенаправления. Дополнительные сведения об использовании перенаправления папки см. в разделах Перенаправление специальных папок в корневой каталог и Перенаправление специальных папок в корневой каталог в соответствии с членством в группе безопасности.

Добавлена новая функция — перенаправление папки «Мои документы» в домашнюю папку пользователя. Она предназначена для использования в организациях, где уже выполнено развертывание основных каталогов. Дополнительные сведения см. в разделе Перенаправление папки «Мои документы» в основной каталог и Перенаправление папки «Мои документы» в основной каталог в соответствии с членством в группе безопасности. Эти разделы также содержат важные замечания по использованию данной функции.

Установка программного обеспечения

Расширены возможности установки программного обеспечения, обеспечивающие доступность 32-разрядных программ на 64-разрядных компьютерах. Добавлены некоторые дополнительные функции, позволяющие публиковать сведения о классе OLE для пакета программного обеспечения. Подробные сведения см. в разделе Редактирование параметров установки приложений.

Дополнительные сведения см. в разделе Новые способы выполнения некоторых задач.


Общие сведения о групповой политике

Чтобы начать использование оснастки Групповая политика немедленно, см. раздел Способы открытия оснастки «Групповая политика».

Параметры групповой политики определяют различные компоненты окружения пользовательского рабочего стола, которыми управляет системный администратор (например, программы, доступные пользователям; программы, отображающиеся на пользовательском рабочем столе, и параметры меню Пуск). Чтобы создать конфигурацию рабочего стола для определенной группы пользователей используется оснастка «Групповая политика». Указанные параметры групповой политики содержатся в объекте групповой политики, который в свою очередь связан с выбранными объектами Active Directory — сайтами, доменами или подразделениями.

Групповая политика применяется не только к пользователям и компьютерам, но и к рядовым серверам, контроллерам доменов и другим компьютерам под управлением Windows 2000 в области управления. По умолчанию групповая политика, применяемая к домену (то есть применяемая на уровне домена, расположенным непосредственно над корневым узлом оснастки Active Directory — пользователи и компьютеры), влияет на все компьютеры и пользователей домена. Кроме того, в оснастке «Active Directory — пользователи и компьютеры» содержится встроенное подразделение «Контроллеры домена». Если учетные записи контроллеров домена хранятся в этом подразделении, имеется возможность использовать объект групповой политики «Политика по умолчанию для контроллеров домена» для управления контроллерами домена отдельно от других компьютеров.

Групповая политика включает параметры для конфигурации пользователя, влияющей на пользователей, и конфигурации компьютера, влияющей на компьютеры. Дополнительные сведения см. в разделах Конфигурация пользователя и Конфигурация компьютера.

Использование групповой политики и ее расширений предоставляет следующие возможности.

  • Управление политикой на основе реестра посредством административных шаблонов. Групповая политика создает файл, содержащий параметры реестра, записанные в область базы данных реестра пользователя и локального компьютера. Параметры профиля пользователя, индивидуальные для пользователя, входящего на этот сервер или рабочую станцию, записываются в раздел реестра HKEY_CURRENT_USER (HKCU), а параметры компьютера записываются в раздел HKEY_LOCAL_MACHINE (HKLM). Дополнительные сведения см. в разделе Использование административных шаблонов. Технические сведения см. на странице
    • Реализация групповой политики с помощью реестра (http://www.microsoft.com/), расположенной на веб-узле корпорации Майкрософт.
  • Назначение сценариев. Например, сценарии запуска и отключения, а также сценарии входа и выхода. Дополнительные сведения см. в разделе Использование сценариев.
  • Перенаправление папок. Возможность перенаправлять папки, такие как «Мои документы» и «Мои рисунки», из папки «Documents and Settings» локального компьютера в сетевые расположения. Дополнительные сведения о перенаправлении папок см. в разделе Использование оснастки «Перенаправление папки».
  • Управление приложениями. С помощью групповой политики имеется возможность назначать, публиковать и восстанавливать приложения, используя расширение «Установка программного обеспечения». Дополнительные сведения см. в разделе Использование оснастки «Установка программного обеспечения».
  • Задание параметров безопасности. Сведения о параметрах безопасности см. в разделе Параметры безопасности.

Существующие по умолчанию объекты групповой политики

Каждый компьютер под управлением Windows XP Professional или Windows 2000 имеет один объект групповой политики, хранящийся локально. Этот локальный объект групповой политики содержит набор параметров, доступных в нелокальных объектах групповой политики. Дополнительные сведения см. в разделе Политика локальной группы.

По умолчанию, если установлена служба Active Directory, создаются два нелокальных объекта групповой политики:

  • объект «Политика по умолчанию для контроллеров домена», связанный с доменом и влияющий на всех пользователей и компьютеры домена (включая контроллеры домена) посредством наследования политики. Дополнительные сведения см. в разделе Наследование политики;
  • объект «Политика по умолчанию для контроллеров домена», связанный с подразделением контроллеров домена и влияющий только на контроллеры, поскольку учетные записи компьютеров — контроллеров домена хранятся исключительно в этом подразделении.

Способы применения групповой политики.

Для просмотра подробной хронологии приложения политики обратитесь к разделу Порядок событий при запуске и входе в систему

Политика пользователя и компьютера

Политика пользователя (параметры которой расположены в узле «Конфигурация пользователя» оснастки «Групповая политика») начинает действовать при входе пользователя в систему. Параметры политики компьютера, расположенные в узле «Конфигурация компьютера», начинают действовать при запуске компьютера. Дополнительные сведения см. в разделах Конфигурация пользователя и Конфигурация компьютера.

Пользователи и компьютеры — это только типы объектов Active Directory, получающих политику. В частности, политика не применяется к группам безопасности. Вместо этого, для увеличения быстродействия группы безопасности используются для фильтрования политики путем установления записи управления доступом (ACE) «Применение групповой политики», для которой может быть установлено значение Разрешить, Запретить или не задано никакое значение Дополнительные сведения см. в разделе Применение фильтра к групповой политике в соответствии с членством в группе безопасности.

Порядок применения

Политики применяются в следующем порядке:

  1. уникальный локальный объект групповой политики;
  2. объекты групповой политики сайта
    3. (в порядке, определенном администраторами);
  3. объекты групповой политики домена
    4. (в порядке, определенном администраторами);
  4. объекты групповой политики подразделения, от наибольшего подразделения к наименьшему (в порядке, определенном администраторами на уровне каждого подразделения).

Дополнительные сведения см. в разделе Порядок обработки параметров.

По умолчанию политики, примененные позже, переопределяют ранее примененные политики, если они не согласованы. Однако, если они согласованы, то в действующей политике отражены все примененные политики. Дополнительные сведения см. в разделе Приоритет групповой политики.

Применение фильтра к групповой политике в соответствии с членством в группе безопасности

Группа безопасности ACE в объекте групповой политики может быть Не настроена (нет предпочтений), или установлена на Разрешить, или Запретить. Значение Запретить предпочтительнее значения Разрешить. Дополнительные сведения см. в разделе Применение фильтра к групповой политике в соответствии с членством в группе безопасности.

Блокирование наследования политики

Политики, которые могут быть, с одной стороны, наследованы с высшего сайта, домена или подразделения, могут быть заблокированы на уровне сайта, домена или подразделения. Дополнительные сведения см. в разделе Блокирование наследования политики.

Влияние вышестоящей политики

Политики, которые могут быть заменены политиками дочерних подразделений, могут быть установлены на Не перекрывать на уровне объекта групповой политики. Дополнительные сведения см. в разделе Запрет перекрывания объекта групповой политики.

Примечания

  • Политики, установленные на Не перекрывать, не могут быть блокированы.
  • Параметры Не перекрывать и Блокировать следует применять с осторожностью. Повсеместное применение этих дополнительных параметров затрудняет устранение неполадок. Дополнительные сведения см. в разделах Устранение неполадок и Советы и рекомендации.

В этом разделе рассмотрены следующие темы.

  • Конфигурация пользователя
  • Конфигурация компьютера
  • Административные шаблоны
  • Конфигурация программ
  • Конфигурация Windows
  • Установка программного обеспечения
  • Перенаправление папки
  • Сценарии


Конфигурация пользователя

Папка «Конфигурация пользователя» оснастки Групповая политика используется для задания политик, применяемых к пользователям независимо от того, какой компьютер используется для входа в систему.

Обычно узел «Конфигурация пользователя» содержит подпапки «Конфигурация программ», «Конфигурация Windows» и «Административные шаблоны», но поскольку оснастка «Групповая политика» имеет расширения, которые можно добавлять и удалять, то точный набор подпапок может различаться.

Дополнительные сведения см. в следующих разделах.

  • Конфигурация компьютера
  • Административные шаблоны
  • Конфигурация программ
  • Конфигурация Windows
  • Чтобы назначить сценарии входа пользователя в систему
  • Чтобы назначить сценарии выхода пользователя из системы
  • Чтобы отключить параметры конфигурации пользователя в объекте групповой политики


Конфигурация компьютера

С помощью узла «Конфигурация компьютера» в Групповой политике администраторы могут устанавливать политики, применяемые к компьютерам, вне зависимости от того, кто работает на них.

Узел «Конфигурация компьютера» обычно содержит подузлы «Конфигурация программ», «Конфигурация Windows» и «Административные шаблоны». Однако можно удалять и добавлять расширения групповой политики, поэтому подузлы могут отличаться от описанных выше.

Дополнительные сведения см. в следующих разделах.

  • Конфигурация пользователя
  • Конфигурация программ
  • Конфигурация Windows
  • Административные шаблоны
  • Чтобы отключить параметры конфигурации компьютера в объекте групповой политики
  • Чтобы назначить компьютеру сценарии автозагрузки
  • Чтобы назначить компьютеру сценарии завершения работы


Административные шаблоны

В Windows включен ряд файлов .adm. Эти текстовые файлы, называемые административными шаблонами, содержат сведения о политике для элементов, расположенных в папке «Административные шаблоны» в дереве консоли оснастки Групповая политика.

Расположение

  • имя объекта групповой политики
  • Конфигурация компьютера (или «Конфигурация пользователя»)
  • Административные шаблоны

Дополнительные сведения о файлах .adm см. в разделе Файлы .adm, включенные в Windows.

Файлы .adm

Файл .adm состоит из иерархии категорий и подкатегорий, которые вместе определяют отображение параметров политики. Кроме того, в файле содержатся следующие сведения:

  • размещение параметров реестра, соответствующих каждому параметру;
  • величина параметров или ограничений, связанных с каждым параметром;
  • значение по умолчанию для большинства параметров;
  • объяснение функции каждого параметра;
  • версии Windows, поддерживающие каждый параметр.

Узел групповой политики «Административные шаблоны» содержит все сведения о политике на основе реестра. Конфигурация пользователя сохраняется в разделе HKEY_CURRENT_USER (HKCU), а конфигурация компьютера — в разделе HKEY_LOCAL_MACHINE (HKLM). В обоих этих разделах данные реестра, относящиеся к групповой политике, содержатся в папке \Software\Policies или \Software\Microsoft\Windows\CurrentVersion\Policies. Следовательно, параметры групповой политики хранятся в реестре в четырех областях.

Новые возможности, предлагаемые административными шаблонами:

  • отображение описания каждого параметра политики, содержащегося в административных шаблонах, в интерактивной справке с возможностью поиска. В следующей таблице приведены ссылки на эти разделы справки.
    Административный шаблон | Описание | Справка по параметрам политики в административных шаблонах
    System.adm | Установлен в групповой политике по умолчанию для клиентов Windows 2000 и Windows XP | Параметры системы
    Inetres.adm | Установлен в групповой политике по умолчанию, в политике Internet Explorer — для клиентов Windows 2000 и Windows XP | Параметры обозревателя Internet Explorer
    Wmplayer.adm | Параметры Windows Media Player для клиентов Windows 2000 и Windows XP | Параметры проигрывателя Windows Media Player
    Conf.adm | Параметры программы NetMeeting для клиентов Windows 2000 и Windows XP | Параметры программы NetMeeting
  • ключевое слово supported в файлах .adm, указывающее, какие версии Windows поддерживаются в качестве клиентов для параметра. Сведения о ключевом слове supported см. на веб-узле корпорации Майкрософт Реализация групповой политики с помощью реестра (http://www.microsoft.com/).
  • веб-узел, на котором приведены объяснения для каждого параметра в стиле Windows 2000 и новые сведения. Сведения об использовании просмотра в виде веб-страницы см. в разделе Использование вида папки «Административные шаблоны»;
  • возможность фильтрации просматриваемых параметров для упрощения их отображения при использовании папки «Административные шаблоны». Сведения об использовании данной функции см. в разделе Использование фильтра при просмотре папки «Административные шаблоны».

Если планируется создавать записи для административных шаблонов, заполните пространство имен с помощью следующего соглашения об именах, которое также используется в реестре:
\название_компании\продукт\версия (или \название_компании\продукт&версия)
Например, параметрами операционной системы для Windows являются \Microsoft\Windows.

Сведения о добавлении файлов .adm см. в разделе Добавление или удаление административного шаблона (файла .adm).

Файлы Registry.pol

Расширение административных шаблонов групповой политики содержится в файлах Registry.pol. Эти файлы содержат настройки параметров реестра, которые были определены (с использованием групповой политики) для применения в области реестра пользователя или локального компьютера.

  • Один из файлов Registry.pol, хранящийся в папке GPT\Machine, содержит параметры реестра, применяемые в разделе HKEY_LOCAL_MACHINE.
  • Другой файл Registry.pol, хранящийся в папке GPT\User, содержит параметры реестра, применяемые в разделе HKEY_CURRENT_USER.

Дополнительные сведения см. в следующих разделах.

  • Чтобы использовать вид папки «Административные шаблоны»
  • Роль административных шаблонов


Конфигурация программ

Папка «Конфигурация программ» распложена как в узле «Конфигурация компьютера», так и в узле «Конфигурация пользователя».

Папка, расположенная в узле \Конфигурация компьютера\Конфигурация программ, содержит параметры программ, применяющиеся ко всем пользователям, входящим в систему на данном компьютере. Данная папка содержит подпапку Установка программного обеспечения, и, кроме того, может содержать другие подпапки, размещаемые программами независимых производителей.

Папка, расположенная в узле \Конфигурация пользователя\Конфигурация программ, содержит параметры приложений, применяющиеся к пользователям вне зависимости от того, с какого компьютера они входят в систему. Данная папка содержит подпапку Установка программного обеспечения, и, кроме того, может содержать другие подпапки, размещаемые программами независимых производителей.

Дополнительные сведения см. в следующих разделах.

  • Установка программного обеспечения
  • Конфигурация пользователя
  • Конфигурация компьютера


Конфигурация Windows

В оснастке Групповая политика имеется две папки «Конфигурация Windows».

Узел, расположенный в дереве \Конфигурация компьютера\Конфигурация Windows, содержит параметры, применяющиеся ко всем пользователям, входящим в систему на данном компьютере. Он включает две подпапки: «Параметры безопасности» и «Сценарии».

Узел, расположенный в дереве \Конфигурация пользователя\Конфигурация Windows, содержит параметры, применяющиеся к пользователям вне зависимости от того, с какого компьютера они входят в систему. Он включает три подпапки: «Перенаправление папки», «Параметры безопасности» и «Сценарии».

Дополнительные сведения см. в следующих разделах.

  • Конфигурация пользователя
  • Конфигурация компьютера
  • Параметры безопасности
  • Сценарии
  • Перенаправление папки


Установка программного обеспечения

Для того чтобы начать работу с оснасткой «Установка программного обеспечения» немедленно, см. раздел Чтобы открыть оснастку «Установка программного обеспечения».

Оснастка «Установка программного обеспечения» помогает определить способ установки и сопровождения программ в организации. С помощью оснастки «Установка программного обеспечения» можно управлять приложением внутри объекта групповой политики, который в свою очередь связан с конкретным контейнером Active Directory: с сайтом, доменом или организационным подразделением. Приложениями можно управлять в одном из двух режимов: в режиме назначения или в режиме публикации.

Приложение назначается, когда необходимо, чтобы оно было установлено на всех компьютерах. Например, требуется, чтобы на всех компьютерах сотрудников маркетингового отдела был установлен Microsoft Excel. Объект групповой политики управляет всеми пользователями в этом отделе. При назначении Microsoft Excel в объекте групповой политики маркетингового отдела он объявляется на всех компьютерах в этом отделе. При объявлении назначенного приложения оно фактически не устанавливается на компьютер. Устанавливаются только необходимые данные для создания ярлыка Microsoft Excel в меню Пуск и связывания расширения файлов (.xls) в реестре. Дополнительные сведения см. в разделе Чтобы назначить приложение.

При загрузке этими пользователями своих компьютеров Microsoft Excel появляется в меню Пуск. При первом выборе Microsoft Excel в меню Пуск это приложение устанавливается. Можно также установить объявленное приложение, открыв документ, который с ним связан (с помощью расширения или активации COM). Если пользователь, не запускавший Microsoft Excel из меню Пуск, выбирает электронную таблицу Microsoft Excel для работы с ней, приложение устанавливается и электронная таблица открывается.

Назначенное приложение можно удалить, но оно будет объявлено снова при следующем входе в систему. Если снова выбрать его в меню Пуск, оно будет установлено.

Приложение публикуется, когда необходимо сделать его доступным для тех пользователей, управляемых данным объектом групповой политики, кто хочет установить это приложение. При публикации приложения каждый пользователь может решить, устанавливать его или нет.

Например, если приложение Microsoft Image Composer публикуется для пользователей, управляемых маркетинговым объектом групповой политики, и они хотят его установить, им следует для этого открыть компонент «Установка и удаление программ» на панели управления и произвести установку. Если пользователи не установили Image Composer с помощью компонента «Установка и удаление программ» на панели управления и если файлы с расширением .jpg связаны с Image Composer, это приложение будет установлено при первой попытке открыть файл с таким расширением. Дополнительные сведения о публикации приложений см. в разделах Чтобы опубликовать приложение и Компонент панели управления «Установка и удаление программ».

Дополнительные сведения об оснастке «Установка программного обеспечения» см. в следующих разделах.

  • Использование оснастки «Установка программного обеспечения»
  • Общие сведения об оснастке «Установка программного обеспечения»
  • Чтобы обновить приложение
  • Чтобы удалить управляемое приложение
  • Оснастка «Установка программного обеспечения» с точки зрения администратора
  • Типы файлов, часто встречающиеся в оснастке «Установка программного обеспечения»


Перенаправление папки

Расширение перенаправления папки используется в групповой политике для перенаправления некоторых специальных папок в сеть. Специальные папки — это, например, «Мои документы» и «Мои рисунки», расположенные в папке «Documents and Settings».

Политика «Перенаправления папки» расположена в папке «Конфигурация пользователя» консоли «Групповая политика».

Расположение

  • Политика имя_политики
  • Конфигурация пользователя
  • Конфигурация Windows
  • Перенаправление папки

Параметры перенаправления папки

В следующих параграфах описаны базовые параметры перенаправления папки. Для каждого базового параметра имеется расширенный вариант. В расширенном варианте параметров доступна более тонкая настройка на основе членства в группах безопасности.

Создать папку для каждого пользователя на корневом пути

Вместо необходимости вводить путь в формате UNC (Universal Naming Convention), например, \\имя_сервера\имя_сетевого_ресурса\%имя_пользователя%\MyDocuments, администратор имеет возможность просто ввести путь к сетевому ресурсу (например \\имя_сервера\имя_сетевого_ресурса), а расширение «Перенаправление папки»автоматически добавит имя пользователя и имя папки при применении политики. Используя перенаправление папки, администратору не обязательно знать переменные окружения, кроме того, снижается вероятность ошибок ввода.

Дополнительные сведения см. в разделе Перенаправление специальных папок в корневой каталог и Перенаправление специальных папок в корневой каталог в соответствии с членством в группе безопасности.

Перенаправить на домашнюю папку пользователя (только «Мои документы»)

С помощью данного параметра администратор имеет возможность перенаправить папку пользователя «Мои документы» в основной каталог пользователя. Эта возможность предназначена для только организаций, уже выполнивших развертывание основных каталогов, которым необходимо обеспечить совместимость с существующей средой основных каталогов. Этот параметр следует использовать, когда в организации уже выполнено развертывание основных каталогов.

Дополнительные сведения см. в разделе Перенаправление папки «Мои документы» в основной каталог и Перенаправление папки «Мои документы» в основной каталог в соответствии с членством в группе безопасности.

Перенаправлять в следующее место

Данный параметр используется для перенаправления папок пользователя на другой локальный диск или раздел, либо для ввода нестандартных конфигураций, не поддерживаемых новым интерфейсом перенаправления папок. Действие данной настройки аналогично интерфейсу перенаправления папки в Windows 2000.

Дополнительные сведения см. в разделе Перенаправление специальных папок по указанному пути и Перенаправление специальных папок по указанному пути в соответствии с членством в группе безопасности.

Перенаправлять в место, определяемое локальным профилем

С помощью данного параметра администраторы имеют возможность перенаправлять выбранную папку в место, определяемое локальным профилем, например: %userprofile%\<имя_папки>.

Дополнительные сведения см. в разделе Перенаправление специальных папок в в место, определяемое локальным профилем и Перенаправление специальных папок в в место, определяемое локальным профилем, в соответствии с членством в группе безопасности.

Примечание

  • Изменение значения параметра на Не задана в диалоговом окне свойств особой папки не вызывает перенаправления особой папки в стандартное расположение. Значение не задана оставляет неизменным текущее расположение перенаправленной папки. Если необходимо перенаправить специальную папку в ее исходное расположение, заданное профилем пользователя по умолчанию, используйте одну из этих процедур.

Дополнительные сведения об использовании перенаправления папки см. в подразделе «Перенаправление папки » в разделе Советы и рекомендации.

В Windows возможны варианты перенаправления папок, описанные в следующей таблице.

Специальная папка | Примечания
Application Data | Параметры групповой политики управляют поведением папки «Application Data» при включении кэширования на стороне клиента. Эти параметры расположены в дереве консоли «Групповая политика»: Конфигурация пользователя\Административные шаблоны\Сеть\Автономные файлы.
Рабочий стол | Папка «Рабочий стол» может быть перенаправлена независимо от всех остальных специальных папок.
Мои документы | Дополнительные сведения см. в разделе Преимущества перенаправления папки «Мои документы».
Мои документы\ Мои рисунки | Папка «Мои рисунки» может быть перенаправлена независимо от папки «Мои документы» или совместно с ней, как это происходит по умолчанию (она останется подпапкой вне зависимости от перемещения папки «Мои документы»). Рекомендуется оставить поведение по умолчанию, если нет особых причин (таких как масштабируемость общего ресурса) для отделения папки «Мои рисунки» от папки «Мои документы». При их разделении в папку «Мои документы» будет помещен ярлык папки «Мои рисунки».
Главное меню | При перенаправлении папки «Главное меню» ее подпапки всегда перенаправляются вместе с ней.

Преимущества перенаправления папки «Мои документы»

Некоторые из следующих преимуществ относятся к перенаправлению любой папки, но перенаправление папки «Мои документы» может быть особенно удобным, поскольку со временем размер этой папки увеличивается.

  • При использовании перемещаемого профиля пользователя его частью является только сетевой путь к папке «Мои документы», но не сама папка. Поэтому ее содержимое не нужно копировать и перемещать между клиентом и сервером каждый раз при входе пользователя в систему или его выходе, что делает процессы входа и выхода быстрее по сравнению с Windows NT 4.0.
  • Даже если пользователь входит в сеть с различных компьютеров, все его документы всегда доступны.
  • Технология автономных файлов обеспечивает пользователям доступ к папке «Мои документы» даже при отсутствии подключения к сети. Это особенно полезно для пользователей, использующих переносные компьютеры. Дополнительные сведения см. в разделе Предоставление возможности автономной работы с файлом или папкой.
  • Имеется возможность архивировать данные, хранящиеся на сервере, при управлении перемещаемыми профилями. Это является более безопасным, поскольку не требуется вмешательство пользователя.
  • Системный администратор может устанавливать дисковые квоты с помощью групповой политики, ограничивая дисковое пространство, выделенное пользователю для специальных папок.
  • Данные пользователя могут быть перенаправлены на жесткий диск локального компьютера с другого жесткого диска, на котором хранятся системные файлы операционной системы. Это обезопасит пользовательские файлы, если необходимо будет переустановить операционную систему.

Дополнительные сведения см. в разделе Советы и рекомендации для перенаправления папки.

Предоставление исключительных прав на специальные папки

Вкладка Параметры диалогового окна свойств каждой папки содержит флажок Предоставить права монопольного доступа к папке «Мои документы». Если установить данный флажок, пользователь и локальная система получат полный контроль над папкой, и никто другой, включая администраторов, не будет иметь на нее никаких прав. Если этот параметр отключен, то разрешения для папки не изменяются. Используются разрешения, применяемые по умолчанию.

Вопросы удаления политики, связанные с перенаправлением папки

В следующей таблице объединены сведения о том, что произойдет с перенаправленными папками и их содержимым, если к ним больше не будет применяться объект групповой политики.

Параметр Перемещение содержимого специальной папки в новое место Параметр Удаление политики Результаты удаления политики
Включен После удаления политики перенаправить папку обратно в локальный профиль пользователя
  • Специальная папка вернется в размещение профиля пользователя.
  • Содержимое будет скопировано (не перемещено) обратно в размещение профиля пользователя.
  • Содержимое не будет удалено из размещения перенаправленной папки.
  • Пользователь будет иметь доступ к содержимому, но только на локальном компьютере.
Отключен После удаления политики перенаправить папку обратно в локальный профиль пользователя
  • Специальная папка вернется в размещение профиля пользователя.
  • Содержимое не будет скопировано или перемещено назад в размещение профиля пользователя.

    • Внимание!

  • Если содержимое папки не скопировано в размещение профиля пользователя, пользователь не сможет его просматривать.
Или Включен, или Отключен При удалении политики папка останется в новом размещении.
  • Специальная папка остается в перенаправленном размещении.
  • Ее содержимое остается в перенаправленном размещении.
  • Пользователь по прежнему имеет доступ к содержимому в перенаправленной папке.

Перенаправление папки и автономные файлы

Технология автономных файлов применяется к любым монтируемым или подключаемым дискам, содержащим документы или данные, которые могут понадобиться пользователю в автономном режиме. Автономные файлы не связаны с перенаправлением папок. Они устанавливаются и настраиваются на сетевых ресурсах отдельно от оснастки «Перенаправления папки». Технология автономных файлов позволяет пользователю работать, даже если он не подключен к сети, например, на портативном компьютере или при сбое маршрутизатора.

При использовании любого типа перенаправления папок рекомендуется настраивать автономные файлы в соответствии с описанием, приведенным в следующей таблице.

Специальная папка | Настройка автономных файлов
Мои документы | Автоматическое кэширование документов (или кэширование вручную, если необходимо предоставить пользователям возможность делать файлы и папки доступными для автономной работы вручную)
Мои рисунки | Автоматическое кэширование документов (или кэширование вручную, если необходимо предоставить пользователям возможность делать файлы и папки доступными для автономной работы вручную)
Application Data | Автоматическое кэширование программ
Рабочий стол | Автоматическое кэширование программ, если папка «Рабочий стол» доступна только для чтения
Главное меню | Автоматическое кэширование программ

Разрешения для перенаправления папки

Это дополнительная функция. Если для расширения «Перенаправление папки» разрешено создание папок (рекомендуется), необходимые разрешения задаются автоматически. Как правило, нет необходимости обращаться к этим разрешениям. Однако, есть две причины, по которым эти разрешения могут представлять интерес:

  • В некоторых случаях, несмотря на то, что это не рекомендуется, администраторы создают перенаправленные папки до того, как это будет сделано расширением «Перенаправление папки». В следующей таблице показано, какие разрешения необходимо задать для использования перенаправления папок.
  • Разрешения для папки «Мои документы» на основной каталог снижают уровень безопасности по сравнению со стандартным перенаправлением. В следующей таблице показан уровень безопасности в стандартном случае.

Для корневой папки необходимы разрешения NTFS
Учетная запись пользователя | Стандартная настройка перенаправления папки | Необходимые минимальные разрешения
Создатель-владелец | Полный доступ, эта папка, подпапки и файлы | Полный доступ, эта папка, подпапки и файлы
Локальный администратор | Полный доступ, эта папка, подпапки и файлы | Полный доступ, эта папка, подпапки и файлы
Все | Полный доступ, эта папка, подпапки и файлы | Содержание папки / Чтение данных, Создание файлов / Запись данных, Создание папок / Дозапись данных: Только для этой папки
Локальная система | Полный доступ, эта папка, подпапки и файлы | Полный доступ, эта папка, подпапки и файлы
Для корневой папки необходимы разрешения на общий доступ (SMB)
Учетная запись пользователя | Стандартная настройка перенаправления папки | Необходимые минимальные разрешения
Все | Полный доступ | Все: нет разрешений. Используйте группу безопасности, включающую пользователей, которым необходимо размещать данные в сетевом ресурсе.
Для каждой перенаправленной папки пользователя необходимы разрешения NTFS
Учетная запись пользователя | Стандартная настройка перенаправления папки | Необходимые минимальные разрешения
%имя_пользователя% | Полный доступ, владелец папки | Полный доступ, владелец папки
Локальная система | Полный доступ | Полный доступ
Все | Обзор папки, Чтение атрибутов, Чтение дополнительных атрибутов и Чтение разрешений | Все: нет разрешений

Дополнительные сведения см. в разделе Ресурсы.


Сценарии

Групповая политика включает в себя два расширения для развертывания сценариев:

  • Сценарии (запуск/завершение). Это расширение, расположенное в узле консоли групповой политики «Конфигурация компьютера\Конфигурация Windows», можно использовать для указания сценариев, которые будут выполняться при запуске и завершении работы компьютера. Эти сценарии выполняются с правами локальной системы.
  • Сценарии (вход/выход из системы). Это расширение, расположенное в узле консоли групповой политики «Конфигурация пользователя\Конфигурация Windows», можно использовать для указания сценариев, которые будут выполняться при входе и выходе пользователя из системы. Эти сценарии запускаются с правами пользователя, а не администратора.

Дополнительные сведения см. в разделе Использование сценариев.

Операционная система Windows ХР0 включает сервер сценариев Windows — не зависящий от языка сценариев сервер для 32-разрядных платформ Windows, включающих поддержку как сценариев Visual Basic Scripting Edition ((VBScript; файлы .vbs), так и сценариев и JScript (файлы .js). Сервер сценариев Windows может использоваться для запуска файлов сценария .vbs и .js непосредственно с рабочего стола или из командной строки, не вставляя их в документ HTML.

Дополнительные сведения о сервере сценариев Windows см. в разделе Общие сведения о сервере сценариев Windows. Сведения о сервере сценариев Windows, модели объектов и примеры сценариев см. на веб-странице сервера сценариев Windows, расположенной на веб-узле корпорации Майкрософт (http://www.microsoft.com/). Дополнительные сведения см. в разделе Ресурсы.


Общее представление о групповой политике

В этом разделе рассмотрены следующие темы.

  • Объекты групповой политики
  • Наследование политики
  • Хранилище объектов групповой политики
  • Приоритет групповой политики
  • Общее представление об оснастке «Установка программного обеспечения»


Объекты групповой политики

Параметры политики хранятся в объектах групповой политики. Оснастку Групповая политика можно рассматривать как приложение, для которого типом документов являются объекты групповой политики (как, например, текстовый редактор использует файлы .doc или .txt).

Локальные и нелокальные объекты групповой политики

Существует два типа объектов групповой политики. Нелокальные объекты групповой политики хранятся на контроллере домена и доступны только в среде Active Directory. Они применяются к пользователям или компьютерам в сайте, домене или подразделении, связанном с объектом групповой политики. Дополнительные сведения см. в разделе Хранилище объектов групповой политики.

Локальные объекты групповой политики хранятся на локальном компьютере. На компьютере существует только один локальный объект групповой политики, содержащий набор параметров, доступных в нелокальном объекте групповой политики. В случае конфликта, параметры локального объекта будут перезаписаны нелокальными параметрами или применены совместно. Дополнительные сведения см. в разделе Политика локальной группы.


Наследование политики

Как правило, групповая политика передается от родительских контейнеров к дочерним в домене, который можно просмотреть с помощью оснастки Active Directory — пользователи и компьютеры. Групповая политика не наследуется от родительских доменов к дочерним (например, от веб-узла wingtiptoys.com к узлу sales.wingtiptoys.com). Оснастка Active Directory — домены и доверие, используемая для управления отношениями такого типа, не связана с групповой политикой.

Если назначена определенная групповая политика на верхнем уровне родительского контейнера, то она применяется для всех контейнеров ниже родительского, включая объекты пользователей и компьютеров в каждом контейнере. Однако, при применении определенной групповой политики к дочернему контейнеру, эта политика будет иметь больший приоритет, чем наследуемая от родительского контейнера политика.

Если родительское подразделение имеет ненастроенные параметры политики, то они не наследуются дочерним подразделением. Отключенные параметры политики наследуются как отключенные. Кроме того, если параметр политики настроен (включен или отключен) для родительского подразделения и этот же параметр политики не настроен для дочернего, то дочернее подразделение наследует состояние этого параметра политики от родительского.

Если параметр политики, применяемый к родительскому подразделению, и параметр, применяемый к дочернему подразделению, совместимы, то дочернее подразделение наследует параметр родительской политики, а параметр дочерней политики по прежнему применяется.

Если параметр, настроенный для родительского подразделения, несовместим с тем же параметром, настроенным для дочернего подразделения (то есть параметр включен в одном случае и отключен в другом), то дочернее подразделение не наследует такой параметр политики от родительского. Применяется параметр дочерней политики.

Блокирование наследования

Блокирование наследования на уровне домена или подразделения выполняется путем открытия диалогового окна свойств домена или подразделения и установки флажка Блокировать наследование политики. Дополнительные сведения см. в разделе Чтобы блокировать наследование политики.

Принудительное наследование

Принудительное наследование выполняется путем задания параметра Не перекрывать для связи объекта групповой политики.

Если установлен флажок Не перекрывать, то это принуждает все дочерние контейнеры наследовать родительскую политику, даже если эти политики конфликтуют и в дочерних контейнерах установлен флажок Блокировать наследование политики.

Для установки флажка Не перекрывать для связи объекта групповой политики откройте диалоговое окно свойств сайта, домена или подразделения, и установите данный флажок. Дополнительные сведения см. в разделе Запрет перекрывания объекта групповой политики.

Примечания

  • Политики, для которых установлен флажок Не перекрывать, не могут быть блокированы.
  • Параметры Не перекрывать и Блокировать следует применять с осторожностью. Повсеместное применение этих дополнительных параметров затрудняет устранение неполадок. Дополнительные сведения см. в разделах Устранение неполадок и Советы и рекомендации.

Дополнительные сведения о групповой политике см. в следующих разделах.

  • Общие сведения о групповой политике
  • Общее представление о групповой политике
  • Использование оснастки «Групповая политика»
  • Ресурсы
  • Приоритет групповой политики


Хранилище объектов групповой политики

Хранение объектов групповой политики является вопросом внедрения и обычно не представляет интереса в текущей деятельности, однако в данном разделе приведены общие сведения по данному вопросу.

Дополнительные сведения см. в следующих разделах.

  • Объекты групповой политики
  • Ресурсы
  • Документация по групповой политике (http://www.microsoft.com/)

На каждом компьютере, работающем под управлением Windows ХР, имеется только один локальный объект групповой политики. Он хранится в каталоге %systemroot%System32\GroupPolicy.

Другие объекты групповой политики состоят из двух частей, хранящихся отдельно: контейнера групповой политики и шаблона групповой политики. Часто изменяющиеся или значительные по объему данные хранятся в в контейнере групповой политики, а небольшие и редко меняющиеся данные хранятся в шаблоне. Интерфейс групповой политики отображает эти части как единое целое.

Дополнительных сведения об объекте локальной групповой политике см. в разделе Политика локальной группы.

Контейнер групповой политики

Контейнер групповой политики представляет собой объект службы каталогов. Он состоит из субконтейнеров для хранения сведений о групповой политике пользователя и компьютера. Контейнер групповой политики содержит следующие данные.

  • Сведения о версии. Используется для синхронизации с данными из шаблона групповой политики.
  • Сведения о состоянии. Указывает, включен или отключен объект групповой политики для данного сайта, домена или подразделения.
  • Список компонентов. Отображает, какие расширения групповой политики имеют параметры в объекте групповой политики.

В контейнере групповой политики хранится информация для оснасток «Установка программного обеспечения» и «Перенаправление папки», которые являются расширениями групповой политики. Дополнительные сведения см. в разделах Установка программного обеспечения и Перенаправление папки.

Шаблон групповой политики

Шаблон групповой политики — это папка контроллеров домена для хранения домена объекта групповой политики. Обычно папка шаблона групповой политики имеет следующий вид:

systemroot\Sysvol\SYSVOL\Streetmarket.com\Policies\
{34975054-fd77-df75-54fe-074936850457}

Подпапки шаблона групповой политики

Папка шаблона групповой политики содержит подпапки, которые включают в себя следующие элементы (но не ограничиваются только ими):

  • adm. Содержит все файлы .adm для этого шаблона групповой политики.
  • Сценарии. Содержит все сценарии и связанные с ними файлы для этого шаблона групповой политики.
  • Пользователь. Включает файл Registry.pol, содержащий параметры реестра, применяемые к пользователям. При входе пользователя d cbcntve загружается файл Registry.pol и применяются все параметры, хранящиеся в разделе реестра HKEY_CURRENT_USER. Папка User содержит следующие подпапки.
  • @@User\Applications. Содержит файлы .aas (сценарии объявления приложений), используемые службой установки операционной системы. Эти файлы применяютмя для пользователей.
  • Компьютер. Включает файл Registry.pol, содержащий параметры реестра, применяемые к компьютерам.При запуске компьютера загружается файл Registry.pol и применяются все параметры, хранящиеся в разделе реестра HKEY_LOCAL_MACHINE. Папка Machine содержит следующие подпапки.
  • @@Machine\Applications. Содержит файлы .aas, используемые службой установки операционной системы. Эти файлы применяются к компьютерам.


Приоритет групповой политики

Групповая политика на базе Active Directory может быть применена путем связывания объектов групповой политики с объектами Active Directory (сайтами, доменами или подразделениями). Параметры групповой политики, расположенные в папке «Конфигурация пользователя», применяются к пользователям, а параметры в папке «Конфигурация компьютера» — к компьютерам. Расположение учетных записей пользователя и компьютера в Active Directory определяет применяемые объекты групповой политики. Следует отметить, что хотя некоторые параметры относятся к пользовательскому интерфейсу, например, фоновый рисунок или возможность использовать команду Выполнить в меню Пуск, они применяются и к компьютерам.

Групповая политика действует совокупно. Дочерние контейнеры службы каталогов наследуют политику от родительских и обработка групповой политики выполняется в следующем порядке: локальная, политика сайта, домена, а затем последовательно политики подразделений, от наивысшего подразделения (наиболее удаленного от учетной записи пользователя или компьютера) к низшему подразделению (непосредственно содержащему учетную запись пользователя или компьютера). Это означает, что если объект групповой политики связан с родительским контейнером верхнего уровня, то этот объект применяется для всех контейнеров ниже родительского, включая пользователей и компьютеры в каждом контейнере. Однако, если в явном виде включить или отключить некоторые параметры групповой политики в другом объекте, связанном с дочерним контейнером, параметры объекта дочернего контейнера переопределят параметры объекта родительского контейнера.

Имеется возможность принудительно задать групповую политику для дочерних контейнеров, установив флажок Не перекрывать для объекта групповой политики. Кроме того, можно запретить наследование групповой политики от родительских контейнеров путем включения параметра Блокировать наследование политики в домене или подразделении.

Важно!

  • Параметры Не перекрывать и Блокировать наследование политики — это дополнительные параметры, не рекомендованные для повсеместного применения, поскольку они изменяют поведение по умолчанию наследования политики (как описано в предыдущем параграфе) и затрудняют устранение неполадок.

Примечание

  • В случае конфликта с параметрами профиля групповая политика имеет приоритет.

В этом разделе рассмотрены следующие темы.

  • Порядок событий при запуске и входе в систему
  • Порядок обработки параметров
  • Роль приложений в приоритете групповой политики


Порядок событий при запуске и входе в систему

Следующая последовательность действий показывает порядок применения компьютерной и пользовательской политики при запуске и входе пользователя в систему.

  1. Запуск сети. Системная служба удаленного вызова процедур (RPCSS) и поставщик универсальных имен MUP запущены.
  2. Список порядка объектов групповой политики, полученный с компьютера. Список может зависеть от следующих факторов:
    • является ли компьютер частью домена и поэтому подчиняется групповой политике через Active Directory;
    • размещение компьютера в Active Directory;
    • изменен ли список объектов групповой политики. Если список объектов групповой политики не изменен, то процесс является незавершенным. Для изменения этой настройки можно использовать параметр политики.
  3. Применена компьютерная политика. Это параметры из собранного списка «Конфигурации компьютера». Применение происходит синхронно по умолчанию и в следующем порядке: локально, на сайте, в домене, подразделении, дочернем подразделении и т.д. При включении политик компьютера пользовательский интерфейс не отображается.

    Дополнительные сведения о порядке работы параметров при применении политики компьютера или пользователя см. в разделе Порядок работы параметров.

  4. Запущен сценарий автозагрузки. Это скрыто и синхронизировано по умолчанию; каждый сценарий должен быть завершен или прерван до запуска следующего. Таймаут по умолчанию 600 секунд. Для изменения этой настройки можно использовать некоторые параметры политики.
  5. Для входа в систему пользователь нажал клавиши CTRL-ALT-DEL.
  6. После проверки пользователя загружается профиль пользователя, управляемый включенными параметрами политики.
  7. Список порядка объектов групповой политики получен от пользователя. Список может зависеть от следующих факторов:
    • входит ли пользователь в домен и поэтому подчиняется групповой политике через Active Directory;
    • включено ли замыкание на себя и каково состояние параметра политики замыкания (Слияние или Замена);
    • размещение пользователя в Active Directory;
    • изменен ли список объектов групповой политики; если список объектов групповой политики не изменен, то процесс является незавершенным. Для изменения этой настройки можно использовать параметр политики.
  8. Применена пользовательская политика. Это параметры из собранного списка «Конфигурации пользователя». Это происходит синхронно по умолчанию и в следующем порядке: локально, на сайте, в домене, подразделении, дочернем подразделении и т. д. При включении политик пользователя пользовательский интерфейс не отображается.

    Дополнительные сведения о порядке работы параметров при применении политики компьютера или пользователя см. в разделе Порядок работы параметров.

  9. Запущены Сценарии входа. В отличии от сценариев Windows NT 4.0, сценарии входа на основе групповой политики по умолчанию запускаются в скрытом режиме и асинхронно. Сценарий объекта пользователя (который как и в Windows NT 4.0 запускается в обычном окне) запускается последним.
  10. Пользовательский интерфейс операционной системы назначается групповой политикой.

Важно!

  • Три специальных случая миграции заслуживают внимания.
    • Если объект учетной записи компьютера находиться в домене Windows NT 4.0 и объект учетной записи пользователя находиться в Active Directory, то только компьютерная (а не пользовательская) системная политика запускается при входе пользователя в систему. Затем запускается пользовательская (а не компьютерная) групповая политика.
    • Если объект учетной записи компьютера находиться в Active Directory и объект учетной записи пользователя находиться в домене Windows NT 4.0, то компьютерная (а не пользовательская) групповая политика запускается во время загрузки компьютера. При входе пользователя в систему запускается пользовательская (а не компьютерная) системная политика.
    • Если учетные записи компьютера и пользователя Windows XP являются членами домена Windows NT 4.0, то только системная политика (а не групповая политика) для компьютера и пользователя применяется при входе пользователя в систему.

Примечание

  • Можно изменить некоторые из следующих событий. Установите следующие политики:
    • замените параметры по умолчанию синхронного и асинхронного запуска сценариев и применения политики;
    • задайте тайм-аут для сценария. По умолчанию он составляет 600 секунд;
    • измените параметры запуска сценариев: скрытно, в свернутом окне, в обычном окне.


Порядок обработки параметров

В данном разделе содержаться сведения о порядке, в котором параметры групповой политики для пользователей и компьютеров обрабатываются в Windows XP. Сведения о том, где выполнение параметров политики подходит схеме запуска компьютера и входа пользователя в систему см. пункты 3 и 8 раздела Порядок событий при запуске и входе в систему.

Параметры групповой политики обрабатываются в следующем порядке.

  1. Локальный объект групповой политики. Для каждого компьютера, на котором установлена Windows XP, существует только один объект групповой политики, который сохранен локально.
  2. Сайт. Любые объекты групповой политики, связанные с сайтом, обрабатываются позже. Обработка происходит синхронно в порядке, определенном администратором.
  3. Домен. Несколько объектов групповой политики, связанных с доменом, обрабатываются синхронно в порядке, заданном администратором.
  4. Подразделения. Объекты групповой политики, связанные с наивысшим подразделением в иерархии Active Directory, обрабатываются первыми, затем обрабатываются объекты групповой политики, связанные с дочерним подразделением и так далее. В самом конце обрабатываются объекты групповой политики, связанные с подразделением, содержащим компьютер или пользователя.

    На уровне каждого подразделения в иерархии Active Directory могут быть связаны один, несколько или ни одного объекта групповой политики. Если несколько объектов связано с подразделением, то они обрабатываются синхронно в порядке, определенном администратором.

Этот порядок означает, что первыми обрабатываются объекты локальной политики группы, а объекты групповой политики, связанные с подразделением, членами которого являются компьютер или пользователь обрабатываются последними, перезаписывая объекты групповой политики, созданные ранее.

Исключения в порядке обработки по умолчанию

Порядок обработки параметров по умолчанию подчиняется следующим исключениям.

  • Для любого объекта групповой политики, связанного с сайтом, доменом или подразделением (не объект локальной политики группы) можно установить параметр Не перекрывать по отношению к сайту, домену или подразделению, так, что ни один из параметров политики не будет перезаписан. При установке более чем одному объекту групповой политики параметра Не перекрывать наивысший в иерархии Active Directory объект (или наивысший в иерархии заданной администратором на каждом определенном уровне в Active Directory) имеет приоритет.

    Необходимо отметить, что параметры Не перекрывать и Отключен устанавливаются связям объектов групповой политики, а не самим объектам. Можно задать связь объекта групповой политики с одним и тем же подразделением несколько раз и для каждой связи независимо настроить параметры Не перекрывать и Отключен. (Хотя несколько ссылок с одного объекта групповой политики на одно подразделения редко бывают полезными, но такая возможность иллюстрирует гибкость инфраструктуры групповой политики.)

    Для сведений об установке параметров связей на Не перекрывать и Отключен см. раздел Чтобы запретить перекрывание объекта групповой политики и Чтобы отключить ссылку на объект групповой политики.

  • Для наследования групповой политики любого сайта, домена или подразделение можно выборочно установить флажок Блокировать наследование политики. Ссылки на объекты групповой политики, установленные как Не перекрывать, всегда применимы, однако не могут быть блокированы.

    Параметр Блокировать наследование политики применим непосредственно к сайту, домену или подразделению. Он не применим ни к объектам групповой политики, ни к ссылкам объекта групповой политики. Параметр Блокировать наследование политики отражает все попытки параметров групповой политики достигнуть сайта, домена или подразделения с высшего иерархического уровня (путем установления связи с родительским документом в иерархии Active Directory), вне зависимости от того, где были установлены эти параметры объектов групповой политики. Однако параметр Блокировать наследование групповой политики не отражает параметры групповой политики из объекта групповой политики, которые непосредственно связаны с сайтом, доменом или подразделением для которых включен параметр Блокировать наследование политики.

  • Замыкание на себя. Дополнительный параметр групповой политики, который удобно использовать в условиях непосредственного управления компьютером, например в лабораториях, классных комнатах, киосках и приемных. Для получения описания этого параметра выберите вкладку Объяснение, дважды щелкнув элемент Режим обработки замыкания пользовательской групповой политики в области сведений консоли MMC (Microsoft Management Console).

    Где?

    • Имя объекта групповой политики
    • Конфигурация компьютера
    • Административные шаблоны
    • Система
    • Групповая политика

    Замыкание на себя является альтернативой методу по умолчанию для получения упорядоченного списка объектов групповой политики, чьи параметры конфигурации пользователя оказывают влияние на пользователя. По умолчанию пользовательские параметры берутся из списка объектов групповой политики, который зависит от размещения пользователя в Active Directory. Упорядоченный список начинается со связанных с сайтом, затем с доменом и, наконец, с подразделением объектов групповой политики (наследование определяется размещением пользователя в Active Directory и в порядке, определенном администратором для каждого уровня).

    Политика замыкания на себя, как и любая другая политика, может быть Не задана, Включена или Отключена. В состоянии Включена можно установить параметры Слияние или Замена.

    Замыкание на себя с заменой. В случае замыкания на себя с заменой список объектов групповой политики для пользователя будет полностью заменен списком объектов групповой политики, полученном для компьютера при его запуске (на шаге 2 в разделе Порядок событий при запуске и входе в систему). Параметры «Конфигурации пользователя» в этом списке применяются к пользователю.

    Замыкание на себя со слиянием. В случае замыкания на себя со слиянием список объектов групповой политики является конкатенацией. Список по умолчанию для компьютеров, образующийся на шаге 2 в разделе Порядок событий при запуске и входе в систему объединяется со списком для пользователей по умолчанию, образующемся на шаге 7, а затем пользователи получают параметры конфигурации пользователя из общего списка. Следует заметить, что список объектов групповой политики, полученный для компьютеров, применяется позже, и поэтому, при возникновении конфликтов с параметрами из пользовательского листа, имеет приоритет.

  • Компьютеры, являющиеся членами рабочей группы, обрабатывают только объект политики локальной группы.


Роль приложений в приоритете групповой политики

Инфраструктура Групповой политики не может заставить приложение использовать групповую политику. Например, приложение, которое искало записи реестра в определенном месте за пределами области деревьев реестра, одобренной групповой политикой, будет продолжать искать их там. Групповая политика не копирует параметры реестра из области групповой политики в область системной политики Windows NT 4.0, не копирует параметры системной политики Windows NT 4.0 в зарезервированную область групповой политики. Дополнительные сведения см. в разделе Системные политики Windows NT 4.0 и Сведения о миграции.

Справочные руководства для написания приложений с использованием возможности групповой политики доступны в пакете «Microsoft Platform SDK», выпускаемом разработчиками. Дополнительные сведения доступны на странице SDK платформы групповой политики (http://www.microsoft.com/) на веб-узле корпорации Майкрософт. Администраторы, которые предполагают настроить приложение, автором которого они не являются, должны знать о действиях правильно написанных приложений по получению необходимых данных из реестра.

Исходное состояние реестра

После запуска компьютера и входа пользователя в систему, область реестра групповой политики перезаписывается таким образом, чтобы поддерживать общие параметры групповой политики, определенные для локального объекта групповой политики и Active Directory. При включении системной политики Windows NT 4.0 (не рекомендуется для клиентов Windows XP и Windows 2000) другие области реестра также изменяются при входе пользователя в систему.

Последовательность событий

  1. Пользователь запускает приложение.
  2. Обычное пользовательское приложение ищет данные реестра в области HKEY_LOCAL_MACHINE\Software\Policies, зарезервированной для групповой политики. Если приложение находит необходимые данных, дальнейший поиск не производится.

    Однако приложение, изменяющее или заменяющее возможности на уровне операционной системы (такие как команда Выполнить) и поэтому оказывающее воздействие на другие приложения, может искать необходимые данные в следующем разделе реестра групповой политики:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies.
    Если приложение находит необходимые данных, дальнейший поиск не производится.

  3. Приложение ищет данные в разделе реестра HKEY_LOCAL_MACHINE вне зарезервированной области групповой политики и при нахождении необходимых данных не продолжает дальнейший поиск.
  4. Приложение ищет данные в разделе реестра HKEY_CURRENT_USER вне зарезервированной области групповой политики и при нахождении необходимых данных не продолжает дальнейший поиск.
  5. Приложение использует .ini файлы (не рекомендуется) или параметры по умолчанию.

Вновь созданные приложения только для Windows XP могут выполнять действия только первых трех пунктов. Приложения, использующие групповую политику в Windows XP, но являющиеся совместимыми с ранними версиями Windows, продолжают выполнять действия с шага четыре при запуске их в старой операционной системе. Приложения, которые предшествуют Windows 2000, никогда не выполняют действий шагов 2 и 3, а сразу переходят к шагу 4.

Порядок последовательности событий имеет следующий вид.

  • Для правильно написанных приложений, запущенных в клиентах Windows XP, групповая политика имеет приоритет над системной политикой Windows NT 4.0.
  • Старые версии приложений (которые не поддерживают Active Directory и групповую политику) выполняются на компьютерах, работающих под Windows XP также, как и под Windows NT 4.0.
  • Параметр HKEY_LOCAL_MACHINE имеет приоритет над параметром HKEY_CURRENT_USER также, как и в Windows NT 4.0.

Дополнительные сведения см. в следующих разделах.

  • Порядок событий при запуске и входе в систему
  • Порядок обработки параметров
  • Наследование политики
  • Документация по групповой политике (http://www.microsoft.com/) на веб-узле корпорации Майкрософт
  • Ресурсы


Общее представление об оснастке «Установка программного обеспечения»

Рисунок Microsoft Windows

Общие сведения об оснастке «Установка программного обеспечения»

Чтобы начать использование оснастки «Установка программного обеспечения» немедленно, см. раздел Чтобы открыть оснастку «Установка программного обеспечения».

Оснастка «Установка программного обеспечения» позволяет управлять программным обеспечением и является основным инструментом администраторов для управления программным обеспечением в организации. Дополнительные сведения об оснастке «Установка программного обеспечения» см. в разделе Установка программного обеспечения.

Установка программ взаимодействует с групповой политикой и Active Directory. Она является одним из трех компонентов установки и сопровождения программного обеспечения, описанных в следующей таблице.

Компонент | Роль
Расширение «Установка программного обеспечения» оснастки «Групповая политика» | Используется администраторами для управления программами.
Установщик Windows | Устанавливает программы, упакованные в файлы установщика Windows.
Компонент панели управления «Установка и удаление программ» Дополнительные сведения см. в разделе Компонент панели управления «Установка и удаление программ» | Используется пользователями для управления программным обеспечением собственных компьютеров.

Назначение программ пользователям

При назначении приложения пользователю, оно объявляется ему при его следующем входе в систему на рабочей станции. Объявление приложения пользователю происходит вне зависимости от того, какой компьютер он использует. Приложение устанавливается при первой попытке пользователя загрузить его с помощью меню Пуск или открыть связанный с ним документ.

Дополнительные сведения см. в разделе Чтобы назначить приложение.

Назначение программ компьютерам

При назначении приложения компьютеру оно объявляется и устанавливается, если это действие является безопасным. Обычно это происходит при запуске компьютера, когда на компьютере нет других запущенных процессов.

Дополнительные сведения см. в разделе Чтобы назначить приложение.

Публикация программ для пользователя

При публикации приложения для пользователя оно не устанавливается на компьютер пользователя. На рабочем столе и в меню Пуск отсутствуют ярлыки, изменения в локальный реестр пользовательских компьютер не вносятся. Вместо этого, опубликованное приложение хранит атрибуты объявления в Active Directory. Сведения, такие как имя приложения и сопоставления файлов, предоставляются пользователям в контейнере Active Directory. После этого приложение становится доступным для установки пользователем в окне «Установка и удаление программ» на панели управления или путем открытия файла, связанного с этим приложением (такого как файл .xls для Microsoft Excel).

Дополнительные сведения см. в разделе Чтобы опубликовать приложение.

Сценарии назначения приложения

Файлы сценариев назначения приложения часто встречаются в оснастке «Установка программного обеспечения». Для каждого назначенного или опубликованного приложения в определенном объекте групповой политики создается сценарий назначения приложения (файл .aas), который хранится в объекте групповой политики домена. Эти файлы сценария содержат сведения объявления о настройке приложения.

Дополнительные сведения см. в разделе Типы файлов, часто встречающихся в оснастке «Установка программного обеспечения».

Active Directory

Active Directory состоит из иерархического набора контейнеров и расширяемых схем. Контейнеры Active Directory состоят из сайтов, доменов, подразделений, пользователей, компьютеров и принтеров. Поскольку схема определяет свойства объектов Active Directory и может быть расширена для определения новых объектов Active Directory, то там могут храниться любые объекты.

Управление программами обеспечивается расширением схем объектов в Active Directory. Эти объекты хранят сведения, необходимые для отображения различных классов параметров для пакетов приложения, поддерживающих эти класса параметров.

Установка программ с точки зрения пользователя

На компьютере пользователя системные компоненты включают в себя Winlogon, оболочку, объекты OLE, клиент LDAP и локальный реестр, которые обеспечивают установку программ на стороне пользователя. Winlogon является привилегированным агентом, применяющим политику установки программ. Возможности оболочки и объектов OLE расширены, чтобы поддерживать взаимодействие с Active Directory и установщиком Windows для установки программ. Клиент LDAP обеспечивает возможность запроса и поиска в Active Directory.

Используя окно «Установка и удаление программ», пользователи могут выбрать и установить программы из Active Directory в управляемой среде или из локального окружения (в неуправляемой среде или, если разрешает политика, из локального окружения в управляемых средах).

В этом разделе рассмотрены следующие темы.

  • Установка программы с точки зрения администратора
  • Компонент панели управления «Установка и удаление программ»
  • Типы файлов, часто встречающихся в оснастке «Установка программного обеспечения»


Оснастка «Установка программного обеспечения» с точки зрения администратора

При управлении программным обеспечением в организации администраторам, как правило, приходится выполнять следующие этапы: подготовка, управление и удаление.

Подготовка

Перед использованием оснастки «Установка программного обеспечения» необходимо обеспечить наличие пакета установщика Windows для программы, которую необходимо установить. Такой пакет часто поставляется вместе с программой. Если у программы отсутствует пакет установщика Windows, то необходимо создать его. Доступны служебные программы для перекомпоновки устанавливаемой программы. Затем дальнейшей настройки пакета могут быть использованы преобразователи. Преобразования, имеющие расширение .mst, иногда называются «модификациями». Дополнительные сведения см. в разделе Работа с модификациями пакета и Типы файлов, часто встречающихся в оснастке «Установка программного обеспечения».

Следующим шагом будет создание общей сетевой папки, называемой точкой распространения программ, которая будет содержать пакеты (файлы .msi), файлы преобразователей (.mst), программные файлы и компоненты. Для упрощения процесса администрирования следует хранить программные файлы и пакеты вместе, хотя это не является обязательным. (Пакеты и преобразователи необходимо хранить вместе.) Кроме того, для управления этими точками распространения программ администраторами могут использоваться Администраторы распределенные файловые системы.

В итоге необходимо убедиться, что пользователи имеют возможность читать сведения из точки распространения программ и записывать их в конечное место установки, особенно если программа записывается на сетевой файловый сервер.

Управление

Для управления программами в организации используется оснастка «Установка программного обеспечения». Программа может быть назначена либо пользователям, либо компьютерам, либо опубликована для пользователей.

Назначение и публикация программ для пользователей содержит следующие этапы.

  • Тестирование. Для проверки программного обеспечения может потребоваться, чтобы новую программу сначала использовали только несколько пользователей. На данном этапе старой версией программы пользуется большинство пользователей и она является версией, устанавливаемой по умолчанию. Новые пользователи устанавливают назначенную или опубликованную версию. Этот этап часто называют «пилотным» использованием новой версии. Этот этап следует использовать для испытания функций установки программного обеспечения, таких как назначение и публикация приложения. Кроме того, имеется возможность опробовать функцию автоматической установки с тем, чтобы чтобы эта программа устанавливалась при открытии файла с расширением, связанным с данной программой. Также могут быть использованы параметры Простой или Полный в зависимости от того, какой интерфейс необходимо отображать пользователям, устанавливаемые с помощью процедуры Чтобы задать значения параметров по умолчанию в оснастке «Установка программного обеспечения». С помощью данных параметров управляется уровень отображаемых пользователю сведений при установке программы.

    • Дополнительные сведения см. в разделах Чтобы назначить приложение, Чтобы опубликовать приложение и Чтобы задать параметр автоматической установки для приложения.

  • Завершающий этап. На данном этапе новая программа становится доступной большему числу пользователей.Новая версия становиться версией по умолчанию, большинство пользователей начинают ее использовать. Новые пользователи могут устанавливать только новую программу. Если установка новой программы помешает работе некоторых пользователей, для них можно оставить старую версию.

Удаление

При удалении программы администратор имеет возможность выбрать один из следующих способов (эти способы являются взаимоисключающими).

  • Немедленное удаление. Этот способ требует, чтобы никто не использовал программу в данный момент. Те пользователи, у кого до сих пор установлена эта программа, получают объявление об ее удалении.
  • Запретить новую установку. Этот способ позволяет пользователям продолжать использовать уже установленную программу.
Дополнительные сведения см. в разделе Чтобы удалить управляемое приложение.

Удаление с сервера

После того, как администратор убедится, что старая версия программы больше не нужна организации, он может удалить пакет установщика Windows и все программные файлы и компоненты. До удаления файлов из точки распространения программ может возникнуть необходимость архивировать пакет и программные файлы и компоненты.

Дополнительные сведения см. в следующих разделах.
  • Установка программного обеспечения
  • Советы и рекомендации
  • Устранение неполадок
  • Ресурсы


Компонент панели управления «Установка и удаление программ»

Используя компонент панели управления «Установка и удаление программ» можно выполнять различные задачи, в основном, установку приложений из локального окружения (такого как компакт-диск, гибкий диск) или из определенного расположения Active Directory (для назначенных и публичных приложений в корпоративной сети), или же из сети Интернет. Компонент «Установка и удаление программ» может быть использован для удаления или изменения существующего приложения или восстановления поврежденного.

Кроме того, компонент «Установка и удаление программ» предоставляет пользователю следующие возможности:

  • единый интерфейс для управления и обслуживания программ;
  • интерфейс, удобный как для опытных пользователей Microsoft Windows, так и начинающих;
  • поддержка установки программ при наличии пакета программы (в локальном окружении) также как и установки программ либо из корпоративной сети, либо из Интернета;
  • предоставление компоненту установщика Windows поддержки других технологий установки.

Дополнительные сведения см. в разделе Использование компонента «Установка и удаление программ».


Типы файлов, часто встречающиеся в оснастке «Установка программного обеспечения»

Наряду с исполняемыми файлами Setup.exe и Install.exe администраторы, использующие оснастку «Установка программного обеспечения», обычно работают с типами файлов, перечисленными в следующей таблице.

Тип файла | Расширение имени файла | Описание
Пакеты установщика Windows | .msi | Эти файлы обычно поставляются производителем программного обеспечения и необходимы для установки определенного приложения. Для управления программами необходимо сохранить эти и другие необходимые файлы в точке распространения программного обеспечения
Преобразования | .mst | Эти файлы (также называемые «модификациями») выполняют настройку пакета установщика Windows во время назначения или публикации. Они могут, например, задать нужный набор приложений
Исправления .msp В этих файлах могут распространяться исправленные ошибки, пакеты обновления и другие подобные файлы.

Исправления не могут использоваться для важных изменений, их применение ограничено следующими возможностями:

  • они не могут удалять компоненты или функции;
  • они не могут изменять код продукта;
  • не могут удалять или изменять имена ярлыков, файлов или разделов реестра.
Файлы .zap .zap Эти файлы созданы с помощью текстового редактора, например «Блокнот». Они могут только быть опубликованы (но не назначены) и указывают на исполняемую программу установки, которая отображается в окне «Установка и удаление программ» на панели управления для пользователей с правами администратора на локальном компьютере.

Примечание

В фалах .zap могут возникать затруднения с использованием кавычек. Применяются следующие правила:

  • путь и имя исполняемого файла установки всегда заключаются в кавычки;
  • если отсутствуют аргументы командной строки, необходимо использовать двойные кавычки.

Пример синтаксиса при использовании абсолютного пути:
SetupCommand=""\\server\share\folder\setup.exe""
SetupCommand="\\server\share\folder\setup.exe" /аргумент

Пример синтаксиса при использовании относительного пути:
SetupCommand=""setup.exe""
SetupCommand="setup.exe" /аргумент
Сценарии назначения приложений | .aas | Эти файлы содержат инструкции по назначению или публикации пакета

Сведения о выполнении процедур установки программного обеспечения см. в разделе Использование оснастки «Установка программного обеспечения». Сведения общего характера об оснастке «Установка программного обеспечения» см. в разделе Общие сведения об оснастке «Установка программного обеспечения».


Использование оснастки «Групповая политика»

В этом разделе рассмотрены следующие темы.

  • Способы открытия оснастки «Групповая политика»
  • Политика локальной группы
  • Файлы .adm, включенные в Windows
  • Дополнительные возможности расширения групповой политики
  • Администрирование групповой политики
  • Сетевая инфраструктура и оснастка «Групповая политика»
  • Сведения о миграции
  • Средства командной строки для оснастки «Групповая политика»


Способы открытия оснастки «Групповая политика»

В зависимости от необходимых действий и планируемых объектов применения, оснастку Групповая политика можно открыть несколькими способами. Способы открытия оснастки «Групповая политика» перечислены в следующей таблице.

Применение групповой политики к | Выполните следующее действие
Локальный компьютер | В консоли групповой политики измените локальный объект групповой политики, как описано в разделе Редактирование объекта групповой политики.
Другой компьютер | Откройте локальный объект групповой политики, хранящийся на сетевом компьютере под управлением Windows ХР, как описано в разделе Открытие групповой политики как автономной оснастки MMC и перейдите к сетевому компьютеру. Для этого необходимо быть администратором сетевого компьютера.
Сайт | Откройте групповую политику, как описано в разделе Открытие групповой политики из оснастки «Active Directory — сайты и службы», и свяжите объект групповой политики с нужным сайтом.
Домен | Откройте групповую политику, как описано в разделе Открытие групповой политики из оснастки «Active Directory — пользователи и компьютеры», и свяжите объект групповой политики с нужным доменом.
Подразделение | Откройте групповую политику, как описано в разделе Открытие групповой политики из оснастки «Active Directory — пользователи и компьютеры», и свяжите объект групповой политики с нужным подразделением. Кроме того, имеется возможность связать объект групповой политики с подразделением, занимающим более высокое положение в иерархии Active Directory, таким образом, что подразделение сможет наследовать параметры групповой политики.
Любой существующий объект или набор объектов групповой политики | Создайте и сохраните собственную консоль управления MMC. Дополнительные сведения см. в разделе Консоль управления Microsoft.

Открытие групповой политики из командной строки

Иногда требуется открыть оснастку «Групповая политика» путем нажатия кнопки Пуск выбора команды Выполнить и ввода команды. Кроме того, запуск оснастки «Групповая политика» возможен из командной строки окна MS-DOS. В следующей таблице приведены несколько примеров команд для запуска оснастки «Групповая политика» при различных условиях.

Пример команды Описание
gpedit.msc /gpcomputer:"Имя_данного_компьютера"

Примечания

  • Кавычки обязательны.
  • После /gpcomputer: пробел отсутствует.
Используется для редактирования групповой политики локального компьютера..
gpedit.msc /gpcomputer:"Имя_данного_компьютера.WingTipToys.com"

Примечания

  • Кавычки обязательны.
  • После /gpcomputer: пробел отсутствует.
Используется для редактирования локального объекта групповой политики на локальном компьютере, при этом имя компьютера задано в формате DNS, а не в старом формате NetBIOS.
gpedit.msc /gpobject:"LDAP://CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=WingTipToys,DC=com"

Примечание

  • Код GUID для объекта групповой политики из предыдущего примера.
Можно редактировать объект групповой политики, основанный на Active Directory.

Сведения о других средствах командной строки см. в разделе Средства командной строки для оснастки «Групповая политика».


Политика локальной группы

На каждом компьютере, работающем под управлением Windows ХР или Windows 2000, имеется только один локальный объект групповой политики. В таких объектах параметры групповой политики хранятся на отдельных компьютерах, вне зависимости от того, являются ли они частью окружения Active Directory или сетевого окружения.

Локальные объекты групповой политики содержат некоторые параметры нелокальной групповой политики, обычно это параметры безопасности. В локальных объектах групповой политики не поддерживается политика перенаправления папок и установки программного обеспечения.

Дополнительные сведения см. в следующих разделах.

  • Параметры безопасности
  • Перенаправление папки
  • Установка программного обеспечения

Поскольку их параметры могут быть перезаписаны объектами групповой политики, связанными с сайтами, доменами и подразделениями, то локальные объекты групповой политики являются наименее значительной частью окружения Active Directory. При отсутствии сети (или в сети, не имеющей контроллера домена ) параметры локального объекта групповой политики более важны, так как они не перезаписываются другими объектами групповой политики.

Для редактирования локального объекта групповой политики, хранящегося на локальном компьютере, откройте оснастку «Групповая политика». Щелкните узел Групповая политика для открытия локального объекта.

Если необходимо редактировать локальный объект групповой политики, хранящийся на другом компьютере в сети, откройте групповую политику как автономную оснастку консоль управления MMC и выберите необходимый объект групповой политики. Дополнительные сведения см. в разделе Чтобы открыть групповую политику как изолированную оснастку MMC.

Локальный объект групповой политики расположен по адресу systemroot\System32\GroupPolicy.

Компьютеры под управлением Windows NT 4.0 или более ранних версий не имеют локального объекта групповой политики и не поддерживают нелокальную групповою политику. Дополнительные сведения см. в разделе Сведения о миграции.


Файлы .adm, включенные в Windows

В Windows XP Professional включено четыре файла административных шаблонов (.adm). В следующей таблице приведено краткое описание этих файлов. Дополнительные сведения о файлах .adm см. в разделе Административные шаблоны.

Административный шаблон | Описание | Справка по параметрам политики в административных шаблонах
System.adm | Установлен в групповой политике по умолчанию для клиентов Windows 2000 и Windows XP | Параметры системы
Inetres.adm | Установлен в групповой политике по умолчанию, в политиках Internet Explorer для клиентов Windows 2000 и Windows XP | Параметры обозревателя Internet Explorer
Wmplayer.adm | Параметры Windows Media Player для клиентов Windows 2000 и Windows XP | Параметры проигрывателя Windows Media Player
Conf.adm | Параметры программы NetMeeting для клиентов Windows 2000 и Windows XP | Параметры программы NetMeeting

Файлы System.adm, Inetres.adm,Wmplayer.adm и Conf.adm используют четыре зарезервированные области реестра групповой политики. Сведения о размещении этих областей см. в разделе Системные политики Windows NT 4.0.

Визуальное отображение параметров системной политики в консоли групповой политики

При добавлении файла .adm в групповую политику, как описано в разделеДобавление или удаление файла административного шаблона (.adm), по умолчанию в консоли отображаются только параметры, содержащиеся в исходных деревьях групповой политики (деревьях, связанных с зарезервированными для групповой политики областями реестра).

Если необходимо изменить данное поведение по умолчанию и отображать не только параметры групповой политики, но и параметры в прежнем формате, см. раздел Использование фильтра при просмотре папки «Административные шаблоны». Снимите флажок Показывать только управляемые параметры политики в соответствии с описанной процедурой. Возможность снимать данный флажок в диалоговом окне Фильтрация задается параметром групповой политики «Вывод пункта "Показывать только политики"».

Расположение

  • Политика Имя_объекта_групповой_политики [имя_контроллера_домена.имя_домена]
  • Конфигурация пользователя
  • Административные шаблоны
  • Система
  • Групповая политика

При включении отображения параметров системной политики в консоли групповой политики значки этих параметров становятся красного цвета. Значки параметров непосредственно групповой политики отображаются голубым цветом.

Важно!

  • Настоятельно рекомендуется не использовать файлы системной политики типа .adm файлов при управлении клиентами Windows XP или Windows 2000, поскольку это ведет к постоянному нежелательному изменению параметров реестра. Дополнительные сведения см. в разделе Сведения о миграции.
Сведения об оптимизации использования технологии групповой политики и административных шаблонов см. в разделеСоветы и рекомендации.


Дополнительные возможности расширения групповой политики

Для расширения функциональности групповой политики могут быть использованы следующие дополнительные возможности.

Метод Преимущества Недостатки
Дополнительная возможность для администраторов — создание файла .adm.
  • Проще, чем создание расширения для групповой политики.
  • Все необходимые средства включены в Windows ХР.
  • Файлы .adm являются текстовыми файлами и могут быть отредактированы в приложении «Блокнот».
  • Можно создать эти файлы из черновика или изменить существующий шаблон, чтобы он соответствовал нужной цели.
  • Применимо только для политик на основе реестра.
  • Ограничен интерфейс. Затруднительно найти, где нужно установить отдельные политики.
Возможность только для разработчиков программного обеспечения: создание расширения групповой политики.
  • Расширенный интерфейса.
  • Для разработчиков доступен полный интерфейс API для групповой политики.
  • Отсутствуют ограничения для политик на основе реестра.
  • Поскольку создание расширения занимает у разработчиков определенное время, то эта возможность не является необходимой, кроме случаев ее частого или повсеместного применения.
  • Необходимо иметь пакет для разработки программного обеспечения (SDK), не включенный в Windows ХР.

Создание собственных файлов .adm

Администраторы могут создавать свои файлы .adm, если шаблон System.adm не удовлетворяет необходимым целям. Однако, по возможности рекомендуется использовать поставляемый шаблон.

Административные шаблоны распространяют настройки реестра на большее число компьютеров, не требуя от администраторов детального знания реестра. Для установки политик на основе реестра в операционной системе Windows ХР0 используется оснастка «Групповая политика». Для установки системной политики в Windows NT 4.0 использовался редактор системной политики (Poledit.exe).

Дополнительные сведения см. на веб-странице Реализация групповой политики с помощью реестра (http://www.microsoft.com/), расположенной на веб-узле корпорации Майкрософт.

Создание расширений оснастки консоли управления ММС

Разработчики могут создавать расширения оснастки для консоли управления ММС с целью предоставления программного интерфейса управления групповой политикой. Дополнительные сведения см. на веб-страницах SDK платформы групповой политики (http://www.microsoft.com/) и Библиотека MSDN (http://www.microsoft.com/), расположенных на веб-узле корпорации Майкрософт. Другие источники сведений см. в разделе Ресурсы.


Администрирование групповой политики

Если необходимо делегировать задачи, связанные с политикой, другим лицам, см. раздел Делегирование управления групповой политикой.

Дополнительные сведения см. в разделе Настройка групповой политики.

В этом разделе рассмотрены следующие темы.

  • Разрешения, используемые по умолчанию
  • Политика консоли управления ММС


Разрешения, используемые по умолчанию

По умолчанию для объектов групповой политики используются следующие разрешения.

Группа безопасности | Параметры по умолчанию
Прошедшие проверку | Чтение, Применение групповой политики (AGP)
Локальная система | Полный доступ (включая AGP)
Администраторы домена | Чтение, Запись, Создание дочерних объектов, Удаление всех дочерних объектов, Применение групповой политики (AGP)
Администраторы | Чтение, Запись, Создание дочерних объектов, Применение групповой политики (AGP)

По умолчанию объект групповой политики «Политика по умолчанию для домена» не может быть удален никаким администратором. Это ограничение предотвращает удаление объекта групповой политики, содержащего важные и необходимые сведения для домена. Если объект «Политика по умолчанию для домена» по каким-либо причинам необходимо удалить, разрешение на его удаление должно быть задано соответствующей группе в явном виде. Это действие выполняется помощью записи управления доступом (ACE) для объекта групповой политики.

Подробные сведения о разрешениях на перенаправление папок см. в разделеПеренаправление папки. Дополнительные сведения см. в разделе Чтобы установить разрешения для оснастки «Установка программного обеспечения» и Ресурсы.


Политика консоли управления Microsoft

Несколько параметров Групповой политики содержаться в стандартном файле административных шаблонов System.adm, управляющем использованием консоли MMC (Microsoft Management Console). Можно делегировать административные права, сохранив предыдущую конфигурацию консоли. Параметры политики консоли MMC доступны в консоли «Групповая политика».

Где?

  • Имя объекта групповой политики
  • Конфигурация пользователя
  • Административные шаблоны
  • Компоненты Windows
  • Консоль управления Microsoft
  • Запрещенные или разрешенные оснастки
  • Групповая политика

Чтобы управлять использованием расширения в консоли MMC, дважды щелкните каждое расширение групповой политики для которого необходимо установить административный параметр групповой политики.

Дополнительные сведения см. в следующих разделах.

  • Делегирование управления групповой политикой
  • Консоль управления Microsoft
  • Администрирование оснастки «Групповая политика»
  • Настройка групповой политики
  • Ресурсы


Сетевая инфраструктура и оснастка «Групповая политика»

В этом разделе собраны сведения по следующим вопросам.

  • Групповая политика в реплицированных средах
  • Групповая политика для медленных подключений
  • Групповая политика сайтов


Групповая политика в реплицированных средах

В домене, состоящем из нескольких контроллеров, распространение сведений Active Directory от одного контроллера домена к другому занимает некоторое время. Этот раздел описывает механизм репликации по отношению к групповой политике.

По умолчанию объекты групповой политики создаются или редактируются на контроллере домена, который владеет маркером операций эмулятора основного контроллера домена. Для сохранения синхронизации контроллеров домена при репликации сведений Active Directory этот маркер при репликации перемещается от одного контроллера домена к другому.

До создания объекта групповой политики, связанного с подразделением, позволяющим применить параметры групповой политики, оно должно быть реплицировано на контроллер домена, который владеет маркером. Администратор может создать подразделение на любом контроллере домена, используя оснастку Active Directory — пользователи и компьютеры.

Если связи между доменами являются медленными, то эти сведения наиболее значимы.

Параметры управления выбором контроллера домена

При выборе имени объекта групповой политики в дереве консоли в консоль «Групповая политика» (Имя объекта групповой политики [имя_контроллера_домена.имя_домена] Политика), в меню Вид отображается команда Параметры контроллера домена. При выборе команды выводится диалоговое окно Параметры для выбора контроллера домена, в котором можно указать контроллер домена, который необходимо использовать для редактирования групповой политики. Далее представлены параметры, доступные в этом диалоговом окне.

  • Хозяин операции для эмулятора PDC. Этот параметр устанавливается по умолчанию и является предпочтительным и наиболее безопасным с точки зрения защиты данных.
  • Контроллер, используемый оснастками Active Directory. Этот параметр использует тот же контроллер домена, что и служба, из которой была запущена групповая политика, если политика была запущена таким способом.
  • Любой доступный контроллер домена. Этот параметр позволяет оснастке «Групповая политика» выбрать любой доступный контроллер домена.Это наименее безопасный параметр, поскольку разные администраторы, теоретически, могут одновременно редактировать объект групповой политики, в результате чего результат редактирования может оказаться непредсказуемым. С другой стороны, при выборе этого параметра наиболее вероятным контроллером будет контроллер домена в локальном узле. Если только один администратор управляет групповой политикой в большом домене с несколькими узлами, то выбор этого параметра будет наилучшим.

Установка контроллера домена при помощи оснастки «Групповая политика»

В дополнение к команде Параметры контролера домена также доступен параметр групповой политики для выбора контроллера домена. Параметр входит в файл административного шаблона System.adm, который загружается в консоль групповой политики по умолчанию.

Параметр групповой политики доступен в консоли групповой политики.

Где?

  • Имя объекта групповой политики
  • Конфигурация пользователя
  • Административные шаблоны
  • Система
  • Групповая политика
В области сведений дважды щелкните значок Выбор контроллера домена групповой политики, а затем в раскрывающемся списке выберите необходимый параметр.

Дополнительные сведения см. в разделах Групповая политика для медленных подключений, Групповая политика сайтов и Ресурсы.


Групповая политика для медленных подключений

К компьютеру, являющемуся членом домена, которому принадлежит или доверяет сервер маршрутизации и удаленного доступа, групповая политика может применяться удаленно. Это относится ко входу в систему посредством маршрутизации и удаленного доступа либо ко входу с использованием кэшированных учетных данных при подключении посредством маршрутизации и удаленного доступа.

Групповая политика не применяется к компьютерам, являющимся членами чужого домена (то есть домена, не содержащего данный компьютер и не находящегося в доверительных отношениях с компьютером домена) или членамирабочей группы. Хотя подключение может может быть установлено, доступ к ресурсам домена иметь неблагоприятные последствия из-за несоответствия IP-безопасности.

По умолчанию политики на основе реестра применяются всегда и их отключение невозможно. Параметры безопасности также применяются по умолчанию, но все другие политики не применяются. Для всех, кроме параметров реестра, имеется возможность указать, будут ли они применяться по умолчанию или нет.

Подключение удаленного доступа — это не обязательно медленные подключения, также как локальная сеть (LAN) не всегда является быстрым подключением. По умолчанию статус быстрого или медленного подключения присваивается на основании проверки подключения к серверу с помощью команды «ping». Если время отклика составляет менее 2000 миллисекунд (двух секунд), то данное подключение рассматривается как быстрое, в противном случае подключение рассматривается как медленное. Можно задать это значение с помощью параметра групповой политики «Таймаут для профилей пользователей для медленных сетевых подключений».

Расположение

  • Имя объекта групповой политики
  • Конфигурация компьютера
  • Административные шаблоны
  • Система
  • Профили пользователей

Некоторые другие параметры групповой политики, связанные с медленными подключениями, расположены там же. Кроме того, см. параметр групповой политики «Обнаружение медленных подключений для групповой политики».

Расположение

  • Имя объекта групповой политики
  • Конфигурация компьютера
  • Административные шаблоны
  • Система
  • Групповая политика

Дополнительные сведения см. в разделах Групповая политика в реплицируемых средах и Групповая политика для сайтов. Подробное описание алгоритма определения медленных подключений см. в документации по групповой политике (http://www.microsoft.com/), расположенном на веб-узле корпорации Майкрософт.


Групповая политика сайтов

Объекты групповой политики, применяемые к объектам сайта Active Directory, оказывают влияние на все компьютеры этого сайта. Сведения каталогов реплицируются среди всех контроллеров домена на сайте и доступны любому контроллеру домена на сайте, с которым установлена связь. Следовательно, любой объект групповой политики, связанный с сайтом, применяется ко всем компьютерам этого сайта, вне зависимости от того, какой домен (в лесу) содержит эти компьютеры.

Это позволяет нескольким доменам в лесу получать один объект групповой политики (включая политики), хотя объект групповой политики хранится только в одном домене и должен читаться с этого домена домена при извлечении клиентами связанной с сайтом групповой политики.

Если дочерние домены установлены на протяжении всей глобальной сети (WAN), то при установке сайта необходимо это учитывать. Если это не учтено, то компьютеры в дочернем домене будут доступны объектам групповой политики, связанной с сайтом, посредством глобальной сети WAN. Это увеличит время обработки групповой политики.

Дополнительные сведения см. в разделах Групповая политика в реплицируемых средах и Групповая политика для медленных подключений.

Примечание

  • Обычно групповая политика не применяется к сайту. Как правило, она применяется к доменам и подразделениям. Дополнительные сведения см. в разделе Способы открытия оснастки «Групповая политика».


Сведения о миграции

В этом разделе собраны сведения по следующим вопросам.

  • Клиентские операционные системы
  • Роль папки «Административные шаблоны»
  • Роль редактора системной политики
  • Системные политики Windows NT 4.0


Клиентские операционные системы

Этот раздел описывает некоторые вопросы операционных систем в отношении клиентской политики.

Windows 2000 Server

Компьютеры, работающие под управлением Windows 2000 Server, могут являться либо обычными выделенными серверами Active Directory, либо контроллерами домена. Групповая политика полностью поддерживает оба этих типа.

Windows XP Professional и Windows 2000 Professional

Групповая политика полностью поддерживает клиентские компьютеры поду управлением Windows XP Professional и Windows 2000 Professional.

Windows NT 4.0 Workstation и Windows NT 4.0 Server

Эти клиенты по прежнему полностью поддерживаются системной политикой Windows NT 4.0, для которой поставляется редактор системной политики (Poledit.exe). Администратор использует редактор Poledit.exe для создания файлов .adm в формате Windows NT 4.0.

Операционная система Windows NT 4.0 не использует Active Directory. Поскольку для компьютеров, работающих под управлением Windows NT 4.0, нет локальных объектов групповой политики, групповая политика не применяется. Дополнительные сведения см. в разделе Политика локальной группы.

Windows 95, Windows 98 и Windows ME

На компьютерах под управлением Windows 95, Windows 98 и Windows ME рекомендуется запускать редактор системной политики (Poledit.exe) локально. Это обеспечивает совместимость созданного файла Config.pol с данными операционными системами. Скопируйте готовый файл Config.pol в папку «SysVol» на контроллере домена.

Групповая политика не применяется.

Windows XP Home Edition, Windows NT 3.51, Windows 3.1 и MS-DOS

К этим операционным системам групповая политика не применяется.

Примечание

  • Только один объект групповой политики существует на каждом компьютере, работающем под управлением Windows XP Professional или Windows 2000. Параметры конфигурации пользователя одинаковы для каждого пользователя этого компьютера. Чтобы поддерживать несколько пользовательских конфигураций, используя политику на компьютере, работающем под управлением одной из этих операционных систем, то есть поддерживающим только один объект групповой политики, поскольку он не является частью домена (например, автономный компьютер), администратор может использовать системную политику посредством редактора системной политики (Poledit.exe). Для создания правильного формата файла .pol, редактор Poledit.exe необходимо запустить на локальном компьютере. Если не используется ни системная политика, ни групповая, индивидуальная настройка рабочего стола для каждого пользователя обеспечивается профилем пользователя.

Дополнительные сведения см. в следующих разделах.

  • Роль административных шаблонов
  • Роль редактора системной политики
  • Системные политики Windows NT 4.0


Роль административных шаблонов

Файлы административных шаблонов в Windows XP имеют то же расширение .adm, что и в Windows NT 4.0. Однако их роль в Windows XP несколько иная.

Роль административных шаблонов в предыдущих версиях Windows

В предыдущих версиях Windows административные шаблоны представляли собой файлы в кодировке ANSI. Они создавали пространство имен в редакторе системной политики для удобства редактирования реестра. Административные шаблоны обеспечивали дружественный интерфейс редактора реестра (Regedit.exe). Кроме того, они повышали безопасность, показывая только записи реестра, прямо упомянутые в файле .adm.

Роль административных шаблонов в Windows XP

В Windows XP включено несколько файлов с расширением .adm, перечисленных в разделе Файлы .adm, включенные в Windows. Можно создать и дополнительные файлы .adm. Новая версия языка файлов .adm является расширенной по отношению к предыдущей версии — старые шаблоны могут создавать пользовательский интерфейс в групповой политике, но новые шаблоны не могут создавать пользовательский интерфейс в редакторе системной политики. Дополнительные сведения о языке файлов .adm см. на веб-странице Реализация групповой политики с помощью реестра (http://www.microsoft.com/), расположенной на веб-узле корпорации Майкрософт.

Windows ХР поддерживает .adm файлы в формате Юникод.

Сведения предупреждающего характера об использовании файлов .adm из Windows NT 4.0 в среде Windows XP см. в разделе Системные политики Windows NT 4.0.


Роль редактора системной политики

Хотя редактор системной политики (Poledit.exe) в основном заменен групповой политикой, он все еще нужен при определенных обстоятельствах. Если производится обновление предыдущей версии Windows, см. раздел Сведения о миграции.

  • Управление компьютерами с операционными системами Windows 95 или Windows 98. Для создания файлов Config.pol, совместимых с локальной операционной системой, редактор системной политики должен быть запущен локально на компьютерах под управлением Windows 98 или Windows 95.
  • Управление компьютерами с операционными системами Windows NT 4.0 Workstation и Windows NT 4.0 Server. Для этих компьютеров необходим свой файл .pol (NTconfig.pol).
  • Управление автономными компьютерами. Компьютеры под управлением Windows 2000, не подключенные к домену, не подчиняются нелокальной групповой политике через Active Directory. Только локальная групповая политика, содержащая параметры для всех пользователей конкретного компьютера, применима на этом компьютере. Дополнительные сведения о локальной групповой политике см. в разделе Политика локальной группы. Чтобы распространить параметры для нескольких пользователей, используйте редактор системной политики для создания файла Registry.pol. Только редактор системной политики версии Windows 2000 совместим с Windows 2000.

Хотя ранние версии редактора системной политики работают только с файлами .adm в кодировке ASCII, версия Windows 2000 также поддерживает кодировку Юникод для файлов .adm.

Для клиентов Windows 2000 и Windows XP вместо этого следует использовать групповую политику. Дополнительные сведения см. в разделе Советы и рекомендации.


Системные политики Windows NT 4.0

При обновлении компьютера-клиента с Windows NT 4.0 до Windows XP на компьютере остается только групповая политика «Конфигурация компьютера», но не системная политика компьютера Windows NT 4.0. Политика, получаемая для входящего в систему пользователя, является групповой политикой «Конфигурация пользователя», если учетная запись пользователя находится в Active Directory. Если учетная запись пользователя находиться на контроллере домена, работающего под управлением Windows NT 4.0, то пользователь получает системную политику Windows NT 4.0.

Дополнительные сведения см. в разделах Конфигурация компьютера и Конфигурация пользователя.

Разделы реестра, используемые групповой политикой.

Политики, включенные в Windows XP или Windows 2000, устанавливают разделы реестра и значения в следующих четырех зарезервированных деревьях.

  • HKEY_LOCAL_MACHINE\Software\Policies
  • HKEY_CURRENT_USER\Software\Policies
  • HKEY_LOCAL_MACHINE\Software\Microsoft\
    Windows\CurrentVersion\Policies
  • HKEY_CURRENT_USER\Software\Microsoft\
    Windows\CurrentVersion\Policies

Первые два дерева являются основными. Все четыре дерева являются защищенными и могут быть изменены только администратором, но не пользователем.

При изменении групповой политики по какой-либо причине эти деревья очищаются и затем туда записываются новые политики.

Политики Windows NT 4.0 не имеют отношения к этим специальным деревьям и могут быть записаны ни в один раздел реестра. После применения такой политики она продолжает существовать, пока значение зарезервировано (путем редактирования реестра или путем запрета политики в формате Windows NT 4.0).

Внимание!

  • С помощью процедуры добавления или удаления файлов .adm в групповую политику могут быть добавлены административные шаблоны, которые изменяют параметры вне используемых групповой политикой Windows ХР деревьев, хотя Windows ХР не включает в себя такие файлы .adm. Установка файлов .adm, созданных для Windows NT 4.0, может привести к нежелательным изменениям параметров реестра.

    Дополнительные сведения см. в разделах Административные шаблоны и Чтобы добавить или удалить файл административного шаблона (.adm).

    • Если необходимо использовать данную процедуру, обратитесь к описанию параметра Показывать только управляемые параметры политики в разделе Чтобы использовать фильтр при просмотре папки «Административные шаблоны» и сведениям о параметре групповой политики Вывод пункта «Показывать только политики»в разделе Чтобы добавить или удалить файл административного шаблона (.adm).

Дополнительные сведения см. в следующих разделах.

  • Клиентские операционные системы
  • Роль административных шаблонов
  • Роль редактора системной политики
  • Файлы .adm, включенные в Windows
  • Советы и рекомендации
  • Ресурсы


Средства командной строки для оснастки «Групповая политика»

В этом разделе рассмотрены следующие темы.

  • Средство Gpresult. Это средство может использоваться для просмотра применяемой политики. Обычно средство Gpresult используется для устранения неполадок.
  • Средство Gpupdate. Данное средство вызывает немедленное обновление политики, позволяя указывать в командной строке некоторые параметры. Средство Gpupdate является удлучшенной заменой команды Windows 2000 secedit /refreshpolicy.
Для получения сведений о запуске консоли Групповая политика из командной строки см. раздел Способы открытия оснастки «Групповая политика».


Ресурсы

В этом разделе содержатся дополнительные сведения о групповой политике и соответствующих технологиях. Здесь можно найти следующие ссылки:

  • Общие сведения о Windows от корпорации Майкрософт
  • Пакет разработчика программного обеспечения (SDK) групповой политики
  • Документация от корпорации Майкрософт
  • Разделы интерактивной справки для средств Windows, относящихся к групповой политике, а также ярлыки для запуска этих средств
  • Сведения от других компаний

Общие сведения о Windows см. на веб-узле Microsoft Windows (http://www.microsoft.com/).

Сведения о поддержке продуктов см. на веб-узле центра технической поддержки корпорации Майкрософт. (http://support.microsoft.com)

Сведения, полезные для специалистов по информационным технологиям, см. на веб-узле Technet (http://www.microsoft.com/).

Для получения справки по устранению известных неполадок, выполните поиск по ключевым словам в базе знаний Майкрософт. (http://www.microsoft.com/)

Поиск сведений о интерфейсах программирования приложений (API) для групповой политики, службе каталогов Active Directory или других средствах, полезных для разработчиков, начните в библиотеке MSDN (http://www.microsoft.com/).

Техническая документация корпорации Майкрософт в Интернете

Выберите эти ссылки для доступа к документации и сведениям о пакетах разработчика (SDK).

SDK платформы групповой политики (http://www.microsoft.com/)

Документация по групповой политике (http://www.microsoft.com/)

Реализация типичных сценариев управления рабочим столом (http://www.microsoft.com/)

Реализация групповой политики с помощью реестра (http://www.microsoft.com/)

Руководства по ресурсам IntelliMirror (http://www.microsoft.com/)

Операции (http://www.microsoft.com/)

Планирование и развертывание (http://www.microsoft.com/)

Пошаговые руководства (http://www.microsoft.com/)

Миграция систем и взаимозаменяемость (http://www.microsoft.com/)

Указатель по технологиям (http://www.microsoft.com/)

Устранение неполадок групповой политики (http://www.microsoft.com/)

SDK платформы «Инструментарий управления Windows (WMI)» (http://www.microsoft.com/)

Web-узел партнера корпорации Майкрософт

Посетите веб-узел компании Full Armor; эта компания, являющаяся партнером корпорации Майкрософт, специализируется на средствах, относящихся к политике, таких как FAZAM.

Средства Windows и разделы интерактивной справки

При работе с технологиями IntelliMirror иногда может потребоваться быстрый просмотр справки по следующим средствам. Не все из них доступны в предыдущих версиях Windows. Из средств, доступных в данной версии Windows, не все являются подходящими для управления компьютерами с Windows. Подробнее см. в разделах справки этих средств.

Примечание

  • Обычно групповая политика не применяется к сайту. Дополнительные сведения см. в разделе Советы и рекомендации.

Административные шаблоны

Оснастка Административные шаблоны обеспечивает удобное для переходов дерево в папках административных шаблонов консоли групповой политики. Они содержат сотни параметров политик. Файлы административных шаблонов имеют расширение .adm.

Файл ADM | Параметры политики
System.adm | Откройте раздел справки Системные параметры.
WMplayer.adm | Откройте раздел справки Параметры проигрывателя Windows Media
inetres.adm | Откройте раздел справки Параметры Internet Explorer
conf.adm | Откройте раздел справки Параметры NetMeeting
В Windows включено четыре файла .adm.

Управление компьютером

Члены групп «Опытные пользователи» и «Администраторы» имеют возможность управлять компьютером локально с помощью оснастки «Управление компьютером». Эта оснастка не является средством управления Active Directory. Она полезна для управления отдельными компьютерами, но не для одновременного управления несколькими компьютерами.

Откройте оснастку Управление компьютером.

Откройте раздел справки Управление компьютером.

IP-безопасность

Оснастка доступна через оснастку «Параметры безопасности» групповой политики или через оснастку Локальная политика безопасности.

Откройте раздел справки IP-безопасность.

Консоль управления (ММС)

Консоль управления (ММС) является основным приложением для большинства средств администрирования Windows 2000 и Windows XP, включая оснастку «Групповая политика».

Откройте консоль управления (ММС).

Откройте раздел справки Консоль управления Microsoft.

Автономные файлы и папки (кэширование на стороне клиента)

Откройте раздел справки Автономные файлы и папки.

Редактор реестра

Настройки групповой политики включают изменения в реестре. Для просмотра и изменения параметров реестра используется редактор реестра.

Откройте редактор реестра.

Откройте раздел справки Редактор реестра.

Внимание!

  • Выполнять редактирование реестра рекомендуется только опытным пользователям. Если реестр поврежден, компьютер может перестать работать.

Результирующий набор политики (RSoP)

Откройте оснастку Результирующая политика.

Откройте раздел справки Результирующая политика.

Параметры безопасности

Параметры безопасности доступны с помощью оснастки «Групповая политика».

Откройте раздел справки Параметры безопасности.

Откройте раздел справки Описание параметров безопасности.

Политики ограниченного использования программ

Политики ограничения программ (SAFER) доступны через параметры безопасности в групповой политике.

Откройте раздел справки Параметры безопасности.

Установщик Windows

Установщик Windows не имеет собственного графического интерфейса пользователей для администраторов. Установщик Windows используется в оснастке «Установка программного обеспечения», в групповой политике и в компоненте панели управления «Установка и удаление программ».

Откройте раздел справки Установщик Windows.


Устранение неполадок

Важной частью устранения неполадок в групповой политике является рассмотрение зависимостей между ее компонентами. Например, установка программного обеспечения зависит от групповой политики, а та, в свою очередь, зависит от Active Directory. Active Directory основана на правильной конфигурации сетевых служб. При попытке устранения неполадок в одном компоненте необходимо убедиться, что все связанные с ним компоненты, службы и ресурсы работают правильно. Для нахождения неполадок, причиной которых может являться такой тип иерархической зависимости, служат журналы событий.

Основные проверки и сбор сведений.

Необходимо выяснить, какие параметры политики используются.

Средствами определения используемой политики являются Результирующая политика и gpresult.

Кроме того, имеется возможность получить отчет по политики при помощи центра справки и поддержки, выполнив следующие действия.

  1. Нажмите кнопку Пуск и выберите команду Справка и поддержка.
  2. Нажмите кнопку Поддержка.
  3. В списке См. также щелкните пункт Расширенные сведения о системе.
  4. В списке Расширенные сведения о системе щелкните ссылку Просмотр примененных параметров групповой политики.
Отчет включает сведения об имени пользователя и домене; имени компьютера и домене; даты последнего применения конфигурации пользователя и конфигурации компьютера; сведения о перенаправлении папок, сценариях входа, выхода, запуска и прекращения работы; установленном программном обеспечении и административных шаблонах. В отчете также содержатся сведения о параметрах безопасности, параметра соединения и прокси-сервера для обозревателя Internet Explorer.

Необходимо обновить политику.

Используйте средство gpupdate, вызывающее немедленное обновление политики, позволяя указывать в командной строке некоторые параметры. Средство Gpupdate является улучшенной заменой команды Windows 2000 secedit /refreshpolicy. Дополнительные сведения см. в разделе Чтобы обновить групповую политику немедленно.

Для применения некоторых элементов политики (например, назначенного компьютеру приложения) необходимо перезагрузить компьютер. Для применения назначенного пользователю приложения пользователь должен выйти из системы и вновь в нее войти.

Необходимо проверить основное сетевое подключение.

Попробуйте выполнить команду ping для контроллера домена.

Проверьте правильность работы DNS.

Сведения о сетевых подключениях см. в разделах Общие сведения о компоненте «Сетевые подключения», Настройка подключения и Общие сведения о подключении по локальной сети.

Сведения, связанные с протоколом TCP/IP, см. в разделах Проверка конфигурации TCP/IP с помощью команды ping, Проверка TCP/IP-соединений с помощью команд ping и net view и Трассировка маршрута с помощью программы tracert.

Необходимо включить запись журнала.

Имеется возможность задать раздел реестра, вызывающий запись данных диагностики групповой политики в файл «Userenv.log» на клиентском компьютере. См. раздел «Monitoring Group Policy with Log Files» на веб-странице Troubleshooting Group Policy (http://www.microsoft.com/) веб-узла корпорации Майкрософт.

Кроме того, имеется возможность задать раздел реестра, позволяющий вести запись в журнал событий с тем. чтобы их можно было просматривать с помощью средства «Просмотр событий». Дополнительные сведения см. в разделах Общие сведения о просмотре событий и «Verbose Logging to Event Log» на веб-странице Troubleshooting Group Policy (http://www.microsoft.com/) веб-узла корпорации Майкрософт.

Сведения об изменении значений реестра см. в разделе Редактор реестра.

Возникают ли проблемы при использовании оснастки «Групповая политика»?

Необходима справка по параметрам индивидуальной групповой политики, входящим в административные шаблоны.

Теперь эти сведения включены в интерактивную справку Windows.

Файл ADM | Параметры политики
System.adm | Откройте раздел справки Системные параметры.
Wmplayer.adm | Откройте раздел справки Параметры проигрывателя Windows Media
Inetres.adm | Откройте раздел справки Параметры Internet Explorer
Conf.adm | Откройте раздел справки Параметры NetMeeting

Невозможно открыть объект групповой политики в консоли, даже при наличии доступа на чтение.

Причина. Для открытия объекта групповой политики в консоли администратор должен иметь не только доступ на чтение, но и полный доступ к объекту.

Решение. Необходимо быть членом группы безопасности с полным доступом к объекту групповой политики. Например, администратор домена может управлять групповой политикой на основе Active Directory. Администратор компьютера может редактировать только локальный объект групповой политики этого компьютера.

При попытке редактировать объект групповой политики появляется сообщение об ошибке «Не удалось открыть объект групповой политики».

Причина. Это происходит при наличии проблем в сети, особенно проблем, связанных с настройкой DNS.

Решение. Убедитесь, что служба DNS работает правильно. Дополнительные сведения см. в разделе DNS.

При попытке редактировать объект групповой политики появляется сообщение об ошибке «Отсутствующий контейнер Active Directory».

Причина. Эта ошибка вызвана попыткой связать объект групповой политики с подразделением, которое не удается обнаружить. Подразделение может быть удалено или же находиться в другом контроллере домена и не быть реплицировано в используемый контроллер домена.

Решение. Ограничьте число администраторов, одновременно вносящих структурные изменения в Active Directory или изменяющих объект групповой политики. Дождитесь репликации внесенных изменений пере внесением новых изменений, влияющих на то же подразделение или объект групповой политики.

При попытке редактировать объект групповой политики появляется сообщение «Ошибка инициализации оснастки».

Причина. Возможно, это вызвано отсутствием файла framedyn.dll.

Решение. Если используются сценарии установки, убедитесь, что сценарий помещает каталог %windir%\system32\wbem в системный путь. Путь %windir%\system32\wbem уже находится в системном пути по умолчанию; следовательно, вероятность столкнуться с данной проблемой невелика, если сценарии установки не использовались.

Вступили ли в силу параметры групповой политики?

Групповая политика не применяется к пользователям и компьютерам в группе безопасности, состоящей из них, даже если объект групповой политики связан с подразделением, содержащим эту группу.

Причина. Такое поведение является правильным. Групповая политика оказывает действие только на пользователей и компьютеры, содержащиеся в сайтах, доменах и подразделениях. Объекты групповой политики не применяются к группам безопасности.

Решение. Свяжите объекты групповой политики только с сайтами, доменами или подразделениями. Помните, что расположение групп безопасности в Active Directory не зависит от того, применяется ли групповая политика к пользователям и компьютерам в этой группе безопасности.

Дополнительные сведения см. в разделе Применение фильтра к групповой политике в соответствии с членством в группе безопасности.

Групповая политика не оказывает воздействия на компьютеры и пользователей на сайте, домене или подразделении.

Причина. В некоторых случаях параметрам групповой политики может быть намеренно или случайно запрещено оказывать воздействие на пользователей и компьютеры. Объект групповой политики может быть отключен для пользователей, для компьютеров, или для тех и других. Необходимо также либо непосредственно связать его с подразделением, содержащим компьютеры и пользователей, либо связать его с родительским доменом или подразделением таким образом, что параметры групповой политики будут применяться путем наследования.

При применении нескольких объектов групповой политики они обрабатываются в следующем порядке: локальный компьютер, сайт, домен, подразделение. По умолчанию параметры, применяющиеся позже, имеют приоритет. Кроме того, групповая политика может быть блокирована на уровне любого подразделения или установлен параметр Не перекрывать для определенных связей объекта групповой политики.

И наконец, пользователь или компьютер должен входить в состав одной или нескольких групп безопасности с соответствующим набором разрешений.

Решение. Убедитесь, что применяемая политика не блокирована.

Убедитесь также, что флажок Не перекрывать не установлен на более высоком уровне Active Directory.

Если установлены оба флажка Блокировать и Не перекрывать, параметр Не перекрывать имеет приоритет. Дополнительные сведения см. в разделе Наследование политики.

Удостоверьтесь, что пользователь или компьютер не является членом группы безопасности, для которой запись ACE применения групповой политики установлена на Запретить.

Удостоверьтесь, что пользователь или компьютер является членом хотя бы одной группы безопасности, для которой запись ACE применения групповой политики установлена на Разрешить.

Удостоверьтесь, что пользователь или компьютер является членом хотя бы одной группы безопасности, для которой запись ACE доступа для чтения групповой политики установлена на Разрешить.

Дополнительные сведения см. в разделе Применение фильтра к групповой политике в соответствии с членством в группе безопасности.

Групповая политика не оказывает влияния на пользователей и компьютеры в контейнере Active Directory.

Причина. Объекты групповой политики не могут быть связаны с контейнерами Active Directory другим способом, кроме как через сайты, домены или подразделения.

Решение. Свяжите объект групповой политики с родительским подразделением контейнера Active Directory. Затем, по умолчанию эти параметры будут применены к пользователям и компьютерам в этом контейнере путем наследования.

Дополнительные сведения см. в разделе Применение фильтра к групповой политике в соответствии с членством в группе безопасности.

Групповая политика не оказывает воздействие на локальный компьютер.

Причина. Локальные политики являются наименее влиятельными. Любые политики на основе Active Directory могут их переопределять.

Решение. Проверьте, какие объекты групповой политики применяются через Active Directory и имеют ли эти объекты параметры, которые конфликтуют с локальными параметрами.

Возникают ли проблемы при использовании оснастки «Установка программного обеспечения»?

Приложение, назначенное компьютеру, недоступно на нем.

Причина Клиентский компьютер не был перезагружен.

Решение. Перезапустите клиентский компьютер.

Приложение, назначенное или опубликованное для пользователя, недоступно на компьютере пользователя.

Причина. Пользователь не выполнил выход и последующий вход в систему.

Решение. Пользователю необходимо выйти из системы и вновь войти.

Опубликованные приложения не отображаются в окне «Установка и удаление программ» на панели управления.

Причина. Есть несколько возможных причин:

  • групповая политика не была применена;
  • нет доступа к Active Directory;
  • в применяемом объекте групповой политики нет опубликованных для пользователя приложений;
  • клиент запускает сервер терминалов.

Решение. Рассмотрите каждую возможную причину неполадок. Следует отметить, что политика «Установка программного обеспечения» не поддерживает клиентов сервера терминалов.

При попытке открытия документа, связанного с опубликованным приложением, это приложение не устанавливается.

Причина. Администратор не установил параметр автоматической установки.

Решение. См. раздел Задание параметров автоматической установки для приложения.

Пользователь получает сообщение об ошибке «Не удается найти устанавливаемое средство в исходном каталоге».

Причина. Это может быть вызвано неполадками в сети или проблемами с разрешениями.

Решение. Убедитесь, что сеть работает правильно. Также см. раздел Чтобы установить разрешения для оснастки «Установка программного обеспечения»

Пользователь получает сообщение об ошибке «Этот продукт не установлен» или «Идентификатор функции не зарегистрирован».

Причина. Это может быть вызвано одновременным входом в систему с двух компьютеров пользователем с перемещаемым профилем, что не поддерживатеся перемещаемыми профилями.

Решение. Пользователю необходимо выйти из системы на одном компьютере перед входом с другого. Таким образом, на втором компьютере будут обновлены ярлыки приложений и эти сообщения об ошибках не будут выводиться.

После удаления приложения его ярлык по прежнему находится на рабочем столе пользователя.

Причина. Пользователь мог создать ярлык самостоятельно и установщик Windows не знает об этом.

Решение. Пользователь должен удалить ярлык самостоятельно.

Пользователь получает сообщение об ошибке «Уже запущена другая копия процесса установки».

Причина. Возможно, удаление происходило в фоновом режиме без отображения пользователю интерфейса, или пользователь неожиданно два процесса установки одновременно (что не поддерживается).

Решение. Пользователю необходимо повторить попытку позже.

При открытии уже установленного приложения был запущен установщик Windows.

Причина. Возможно, приложение подвергается автоматическому восстановлению или добавляется запрошенная пользователем функция.

Решение. Не требуется никаких дополнительных действий.

Пользователь получает сообщение «Active Directory не позволит развернуть пакет» или «Не удается подготовить пакет для развертывания».

Причина. Пакет может быть поврежден либо ошибка вызвана неполадками в сети.

Решение. Используйте неповрежденный пакет. Определите возможные неполадки в сети и предпримите необходимые действия.

При щелчке одного из значков «Установка программного обеспечения» в консоли групповой политики выводится сообщение «Ошибка инициализации оснастки».

Причина. Возможно, это вызвано отсутствием файла framedyn.dll.

Решение. Если используются сценарии установки, убедитесь, что сценарий помещает каталог %windir%\system32\wbem в системный путь. Путь %windir%\system32\wbem уже находится в системном пути по умолчанию; следовательно, вероятность столкнуться с данной проблемой невелика, если сценарии установки не использовались.

Ресурсы в сети Интернет, связанные с устранением неполадок

Для получения справки по устранению известных неполадок, выполните поиск по ключевым словам в базе знаний Майкрософт. (http://www.microsoft.com/)

См. веб-страницу Troubleshooting Group Policy (http://www.microsoft.com/), на которой также рассмотрены вопросы устранения неполадок установки программного обеспечения.

Ресурсы Windows Resource Kits содержат статьи, такие как Extending and Troubleshooting Group Policy (http://www.microsoft.com/)

Другие источники сведений см. в разделе Ресурсы.