Контрольный список: установка и настройка IPv6

Действие | Ссылка
Ознакомьтесь с основными понятиями IPv6, такими как основные протоколы, адресация и маршрутизация. | Общие сведения о протоколе IPv6
Повторите основные понятия о разрешении имен IPv6 (разрешении DNS-имен в IP-адреса) | Разрешение имен
Проверьте, установлен ли сетевой адаптер, и при необходимости установите его. | Установка устройств
Установите IPv6 на данный компьютер. | Установка IPv6
Настройте адрес IPv6 и параметры префикса. (Только настройка вручную.) | Настройка IPv6 с вводом адресов вручную
Проверьте правильность установки и работы протокола IPv6 с помощью команды ping6. | Проверка конфигурации IPv6 с помощью команды ping6
Проверьте возможность взаимодействия с другими узлами IPv6 с помощью команды ping6. | Проверка подключения IPv6 с помощью команды ping6

Важно!

  • XOX


Инструкции

Этот раздел содержит инструкции по установке и настройке протокола IPv6.

  • Установка и настройка протокола IPv6
  • Управление маршрутами
  • Диагностика соединений


Установка и настройка протокола IPv6

  • Установка протокола IPv6
  • Настройка протокола IPv6
  • Удаление протокола IPv6


Установка IPv6

Рисунок Microsoft Windows

Чтобы установить протокол IPv6, выполните следующие действия.

  1. Откройте окно Командная строка.
  2. В командной строке введите команду:

    ipv6 install

Важно!

  • XOX

Примечания

  • XOX
  • Протокол IPv6 устанавливается как сетевой протокол, но не отображается в списке компонентов в окне свойств подключения (компонент Сетевые подключения).

См. также


Настройка протокола IPv6

  • Настройка IPv6 с вводом адресов вручную
  • Настройка сетевых атрибутов


Настройка IPv6 с вводом адресов вручную

Рисунок Microsoft Windows

Чтобы настроить IPv6 с вводом адресов вручную

  1. Откройте окно Командная строка.
  2. Введите в командной строке команду

    ipv6 if

    чтобы получить индекс интерфейса, для которого выполняется добавление адреса вручную.

  3. Введите в командную строку команду

    ipv6 adu [ИндексИнтерфейса]/[Адрес]

    4. где ИндексИнтерфейса — номер интерфейса, а Адрес — адрес IPv6. Имеются дополнительные параметры командной строки.

Важно!

  • XOX

Примечание

  • XOX

См. также


Настройка атрибутов интерфейса

Рисунок Microsoft Windows

Чтобы настроить атрибуты интерфейса

  1. Откройте окно Командная строка.
  2. Введите в командной строке команду

    ipv6 if

    чтобы получить индекс интерфейса, для которого выполняется настройка атрибутов.

  3. Введите в командной строке команду

    ipv6 ifc ИндексИнтерфейса [Атрибут]

    4. где ИндексИнтерфейса — номер интерфейса, а Атрибут — один или несколько следующих атрибутов.

    • forwards

      • Включает пересылку пакетов, принимаемых на данный интерфейс.

    • -forwards

      • Отключает пересылку пакетов, принимаемых на данный интерфейс.

    • advertises

      • Включает отправку сообщений объявления маршрутизатора на данный интерфейс.

    • -advertises

      • Отключает отправку сообщений объявления маршрутизатора на данный интерфейс.

    • mtu Байт

      • Задает максимальный размер передаваемого блока данных для данной связи (в байтах), который отправляется как параметр MTU в сообщении объявления маршрутизатора.

    • site ИдентификаторУзла

      • Задает идентификатор для узла. Идентификатор узла используется для различения интерфейсов, относящихся к различным областям администрирования, использующим адресацию локального узла.

Важно!

  • XOX

Примечание

  • XOX

См. также


Удаление протокола IPv6

Рисунок Microsoft Windows

Чтобы удалить протокол IPv6, выполните следующие действия.

  1. Откройте окно Командная строка.
  2. В командной строке введите команду:

    ipv6 uninstall

Важно!

  • XOX

Примечания

  • XOX
  • Протокол IPv6 устанавливается как сетевой протокол, но не отображается в списке компонентов в окне свойств подключения (компонент Сетевые подключения).

См. также


Управление маршрутами

  • Просмотр таблицы маршрутов протокола IPv6
  • Добавление маршрута IPv6
  • Удаление маршрута IPv6
  • Включение перенаправления IPv6


Просмотр таблицы маршрутизации протокола IPv6

Рисунок Microsoft Windows

Чтобы просмотреть таблицу маршрутизации протокола IPv6, выполните следующие действия.

  1. Откройте окно Командная строка.
  2. В командной строке введите команду

    ipv6 rt

Важно!

  • XOX

Примечание

  • XOX

См. также


Добавление маршрута IPv6

Рисунок Microsoft Windows

Чтобы добавить маршрут IPv6, выполните следующие действия.

  1. Откройте окно Командная строка.
  2. В командной строке введите команду

    ipv6 if

    чтобы получить индекс интерфейса, через который доступны адреса префикса маршрута.

  3. В командной строке введите команду

    ipv6 rtu Префикс ИндексИнтерфейса/АдресСледующегоПерехода

    4. где:

    • Префикс является префиксом маршрута.
    • ИндексИнтерфейса является номером интерфейса.
    • АдресСледующегоПерехода является адресом локального маршрутизатора.

    Имеются дополнительные параметры командной строки.

Важно!

  • XOX

Примечания

  • XOX
  • Для префиксов прямой связи параметр /АдресСледующегоПерехода является необязательным.

См. также


Удаление маршрута IPv6

Рисунок Microsoft Windows

Чтобы удалить маршрут IPv6, выполните следующие действия.

  1. Откройте окно Командная строка.
  2. В командной строке введите команду

    ipv6 rt

    чтобы получить префикс маршрута и индекс интерфейса, через который доступны адреса префикса маршрута.

  3. В командной строке введите команду

    ipv6 rtu Префикс ИндексИнтерфейса life 0

    4. где Префикс является префиксом маршрута, а ИндексИнтерфейса — номером интерфейса, через который доступен данный префикс. При задании времени жизни маршрута 0 этот маршрут удаляется из таблицы маршрутизации.

Важно!

  • XOX

Примечание

  • XOX

См. также


Включение перенаправления IPv6

Рисунок Microsoft Windows

Чтобы включить перенаправление IPv6, выполните следующие действия.

  1. Откройте окно Командная строка.
  2. В командной строке введите команду

    ipv6 if

    чтобы получить индекс интерфейса, через который разрешено перенаправление полученных пакетов.

  3. В командной строке введите команду

    ipv6 ifc ИндексИнтерфейса forwards

    4. где ИндексИнтерфейса является номером требуемого интерфейса.

    Если кроме пакетов с компьютера также требуется отправлять сообщения объявления маршрутизатора, введите в командной строке

    ipv6 ifc ИндексИнтерфейса forwards advertises

  4. Повторите шаг 3 для всех интерфейсов, через которые разрешено перенаправление.

Важно!

  • XOX

Примечание

  • XOX

См. также


Диагностика соединений

  • Проверка конфигурации IPv6 с помощью команды ping6
  • Проверка подключения IPv6 с помощью команды ping6
  • Трассировка маршрута с помощью команды tracert6
  • Просмотр конфигурации интерфейса
  • Просмотр кэша окружения
  • Просмотр кэша маршрутов


Проверка конфигурации IPv6 с помощью команды ping6

Рисунок Microsoft Windows

Чтобы проверить конфигурацию протокола IPv6 с помощью команды ping6, выполните следующие действия.

  1. Чтобы получить информацию о конфигурации IPv6 на компьютере, откройте командную строку и введите ipv6 if. Если протокол IPv6 не установлен, щелкните ссылку «См. также».
  2. В командной строке обратитесь по адресу замыкания на себя; для этого выполните команду ping6 ::1.

    3. Если команда ping6 не будет выполнена должным образом, убедитесь, что адрес ::1 назначен интерфейсу «Псевдо-интерфейс замыкания на себя».

  3. Чтобы опросить адрес IPv6 уровня связи данного компьютера, воспользуйтесь следующей командой:

    4. ping6 Адрес%КодОбласти

    где Адрес является адресом локальной связи, а КодОбласти — индексом интерфейса, которому назначен адрес локальной связи. Адреса локальной связи всегда начинаются с FE80.

    Если команда ping6 не выполняется успешно, проверьте адрес и индекс интерфейса.

  4. Опросите адрес локальной связи другого узла данной связи (также называемой подсетью).

    5. ping6 Адрес%КодОбласти

    где Адрес является адресом локальной связи другого узла, а КодОбласти — индексом интерфейса, через который требуется отправлять пакеты ping6.

    Если команда ping6 не выполняется успешно, проверьте адрес локальной связи другого узла и код области.

Важно!

  • XOX

Примечание

  • XOX

См. также


Проверка подключения IPv6 с помощью команды ping6

Рисунок Microsoft Windows

Чтобы проверить подключение IPv6 с помощью команды ping6, выполните следующие действия.

  1. Чтобы получить информацию о конфигурации IPv6 на компьютере, откройте командную строку и введите ipv6 if. Если протокол IPv6 не установлен, щелкните ссылку «См. также».
  2. Для опроса другого узла IPv6 воспользуйтесь одной из следующих команд.
    • Чтобы опросить адрес локальной связи другого узла текущей связи (также называемой подсетью):

      • ping6 Адрес%КодОбласти

      где Адрес является адресом локальной связи другого узла, а КодОбласти — индексом интерфейса, через который требуется отправлять пакеты ping6. Индекс интерфейса можно узнать из результатов выполнения команды ipv6 if.

      Если команда ping6 не выполняется успешно, проверьте адрес локальной связи другого узла и код области.

    • Чтобы опросить адрес локального сайта другого узла:

      • ping6 Адрес%КодОбласти

      где Адрес является адресом локального сайта другого узла, а КодОбласти — идентификатором сайта, указанным в результатах выполнения команды ipv6 if. Если идентификаторы сайта не используются, параметр %КодОбласти задавать не требуется.

      Если команда ping6 не выполняется успешно, проверьте адрес локального сайта другого узла и код области.

    • Чтобы опросить глобальный адрес другого узла:

      • ping6 Адрес

      где Адрес является глобальным адресом другого узла.

      Если команда ping6 не выполняется успешно, проверьте глобальный адрес другого узла.

    • Чтобы опросить другой узел, указав его имя:

      • ping6 Имя

      где Имя является именем, которое можно разрешить в адрес IPv6, используя записи в локальном файле hosts либо записи ресурса AAAA, присутствующие в инфраструктуре DNS (Domain Name System).

      Если команда ping6 не выполняется успешно, убедитесь, что указанное имя можно разрешить в адрес IPv6.

    • Чтобы опросить IPv4-совместимый адрес другого узла:

      • ping6 ::АдресIPv4

      где АдресIPv4 является адресом IPv4 другого узла.

      Если команда ping6 не выполняется успешно, проверьте адрес IPv4 другого узла.

Важно!

  • XOX

Примечание

  • XOX

См. также


Трассировка маршрута с помощью команды tracert6

Рисунок Microsoft Windows

Чтобы выполнить трассировку маршрута с помощью команды tracert6

  • Откройте окно Командная строка и выполните следующую команду:

    tracert6 ИмяУзла

    либо выполните команду tracert6 АдресIPv6%КодОбласти

    • где:

    • ИмяУзла является именем узла удаленного компьютера.
    • АдресIPv6 является адресом IPv6 удаленного компьютера.
    • КодОбласти является кодом (ID) области конечного адреса. Код области для конечных адресов локальной связи представляет собой индекс интерфейса, через который требуется отправлять пакеты tracert6. Код области для адресов локального сайта представляет собой код сайта, указанный в результатах выполнения команды ipv6 if. Для глобальных адресов параметр %КодОбласти не является обязательным.

Важно!

  • XOX

Примечания

  • XOX
  • Команда tracert6 определяет путь, по которому пакеты IPv6 передаются с локального на удаленный компьютер. Команда tracert6 использует сообщения эхо-запроса ICMPv6 (подобно команде ping6) и выдает на экран сведения о каждом пройденном маршрутизаторе и о времени обмена данными (RTT) с каждым из них.
  • Если трассировка маршрута с помощью программы tracert6 окончилась неудачей, то на основании выводимых ею данных можно определить, какой промежуточный маршрутизатор не пересылает данные дальше или делает это слишком медленно.

См. также


Просмотр конфигурации интерфейса

Рисунок Microsoft Windows

Чтобы просмотреть конфигурацию интерфейса, выполните следующие действия.

  1. Откройте окно Командная строка.
  2. В командной строке введите команду:

    ipv6 if

Важно!

  • XOX

Примечание

  • XOX

См. также


Просмотр кэша окружения

Рисунок Microsoft Windows

Чтобы просмотреть кэш окружения, выполните следующие действия.

  1. Откройте окно Командная строка.
  2. В командной сроке введите команду:

    ipv6 nc

Важно!

  • XOX

Примечание

  • XOX

См. также


Просмотр кэша маршрутов

Рисунок Microsoft Windows

Чтобы просмотреть кэш маршрутов, выполните следующие действия.

  1. Откройте окно Командная строка.
  2. В командной строке введите команду:

    ipv6 rc

Важно!

  • XOX

Примечание

  • XOX

См. также


Основные понятия

Данный раздела содержит сведения общего характера о протоколе IPv6.

  • Обзор протокола IPv6
  • Общие сведения о протоколе IPv6
  • Проверка протокола IPv6
  • Ресурсы


Обзор протокола IPv6

В этом разделе собраны сведения по следующим вопросам.

  • Введение в протокол IPv6
  • Возможности протокола IPv6
  • Возможности протокола IPv6 для Windows XP
  • Средства безопасности


Введение в протокол IPv6

Текущая версия протокола IP (известная как IP версии 4 или IPv4) не претерпела значительных изменений со времени опубликования документа RFC 791 в 1981 году. Протокол IPv4 показал себя как надежный и удобный в применении; он прошел проверку на масштабируемость в объединенной сети, будучи использованным до сих пор в масштабах Интернета. Это является заслугой его дальновидных разработчиков.

Однако первоначальная спецификация этого протокола не предусматривала следующих ситуаций.

  • Экспоненциального роста Интернета, наблюдаемого в последнее время, и предстоящей нехватки адресного пространства протокола IPv4.

    • Адреса IPv4 становятся относительно дефицитными, что заставляет некоторые организации использовать преобразование сетевых адресов (NAT) для сопоставления нескольких локальных адресов одному глобальному IP-адресу. Хотя преобразование сетевых адресов позволяет повторно использовать пространство локальных адресов, оно не обеспечивает стандартные меры безопасности на уровне сети и правильное сопоставление всех протоколов более высокого уровня и, что может создавать трудности при сетевом взаимодействии двух организаций, использующих пространства локальных адресов.

    Кроме того, возрастающее количество устройств и аппаратов, подключающихся к Интернету, способствует скорейшей нехватке адресов в пространстве общедоступных адресов IPv4.

  • Роста Интернета и возможность магистральных маршрутизаторов управлять большими таблицами маршрутизации.

    • В соответствии с механизмом распределения сетевых адресов, действующим по настоящее время, в таблицах маршрутизации магистральных маршрутизаторов Интернета находится более 70 000 маршрутов. Текущая инфраструктура маршрутизации в Интернете по протоколу IPv4 является сочетанием плоской и иерархической маршрутизации.

  • Необходимости более простой настройки.

    • В настоящее время в большинстве случаев протоколы IPv4 настраиваются вручную или с помощью протокола настройки адресов с ведением базы данных, такого как DHCP. При возрастающем количестве компьютеров и устройств, использующих IP-адреса, необходим более простой и автоматизированный способ настройки адресов и других параметров конфигурации, не зависящий от администрирования инфраструктуры DHCP.

  • Необходимости обеспечения безопасности на уровне IP.

    • Конфиденциальное взаимодействие с помощью общедоступных средств, таких как Интернет, требует возможности шифрования, защищающего передаваемые данные от просмотра и изменения. Хотя существует стандарт обеспечения безопасности пакетов IPv4 (называемый безопасностью IP-протокола или IPsec), он не является обязательным; чаще используются иные решения.

  • Необходимости улучшенной поддержки доставки данных в реальном времени (также известной как QoS).

    • Хотя для протокола IPv4 определены стандарты QoS, поддержка передачи трафика в реальном времени зависит от поля типа службы (TOS) и типа полезных данных IPv4, для передачи которых обычно используется порт UDP или TCP. К сожалению, поле TOS протокола IPv4 имеет ограниченную функциональность и различные интерпретации. Кроме того, определение типа полезных данных, пересылаемых через порты TCP и UDP, при шифровании полезных данных пакетов IPv4 невозможно.

Чтобы учесть и обойти эти ограничения, организация IETF (Internet Engineering Task Force) разработала семейство протоколов и стандартов IPv6 (IP версии 6). В этой новой версии, ранее называвшейся IPng (IP-The Next Generation), реализовано множество идей по модернизации протокола IPv4. В протокол IPv6 специально не вносились кардинальные изменения, чтобы сохранить протоколы высших и низших уровней по возможности без изменений.


Возможности протокола IPv6

Далее приведены возможности протокола IPv6:

  • Новый формат заголовка
  • Большое пространство адресов
  • Эффективная и иерархическая адресация и инфраструктура маршрутизации
  • Конфигурация адресов с ведением базы данных или без нее
  • Встроенные средства обеспечения безопасности
  • Улучшенная поддержка качества службы (QoS)
  • Новый протокол взаимодействия соседних узлов
  • Возможность расширения

Это возможности подробно рассмотрены в следующих разделах.

Новый формат заголовка

Заголовок IPv6 имеет новый формат, призванный минимизировать наличие в нем дополнительных данных. Это достигается перемещением полей, не являющихся необходимыми, и дополнительных полей в расширенные заголовки, стоящие после заголовка IPv6. Модернизированный заголовок IPv6 обеспечивает более эффективную работу промежуточных маршрутизаторов.

Заголовки IPv4 и IPv6 не могут обрабатываться совместно, а протокол IPv6 не имеет обратной совместимости с протоколом IPv4. Для обработки заголовков обоих форматов узел или маршрутизатор должен поддерживать как протокол IPv4, так и IPv6. Новый заголовок IPv6 всего в 2 раза длиннее заголовка IPv4, хотя адреса IPv6 длиннее адресов IPv4 в 4 раза.

Дополнительные сведения см. в разделе Протокол IP версии 6 (IPv6).

Большое пространство адресов

Протокол IPv6 использует 128-битные (16-байтовые) исходные и конечные адреса. Хотя 128 бит обеспечивают 3,4×1038 сочетаний, большое пространство адресов IPv6 предназначено для реализации нескольких уровней подсетей и распределения адресов от опорной сети Интернета до отдельных подсетей в пределах организации.

Хотя в настоящее время для использования узлами выделена лишь малая доля возможных адресов, большинство адресов зарезервировано для использования в будущем. С гораздо большим количеством доступных адресов способы экономии адресов, такие как применение преобразования сетевых адресов, становятся ненужными.

Дополнительные сведения см. в разделе Адресация протокола IPv6.

Эффективная и иерархическая адресация и инфраструктура маршрутизации

Глобальные адреса IPv6, использующиеся в части Интернета на базе протокола IPv6, предназначены для построения эффективной, иерархической и объединенной инфраструктуры маршрутизации, подходящей для использования в ситуации с несколькими уровнями поставщиков услуг Интернета. В Интернете IPv6 магистральные маршрутизаторы используют намного меньшие таблицы маршрутизации. Дополнительные сведения см. в разделе Адреса IPv6 для одноадресной рассылки.

Конфигурация адресов с ведением базы данных или без нее

Для упрощения настройки узлов протокол IPv6 поддерживает как конфигурацию адресов без ведения базы данных, такую как конфигурацию с использованием DHCP-сервера, так и конфигурацию адресов с ведением базы данных (при отсутствии DHCP-сервера). При конфигурации адресов без ведения базы данных узлы в пределах связи автоматически настраиваются, используя адреса IPv6 связи (адреса локальной связи) и адреса, получаемые из префикса, объявляемого локальным маршрутизаторами. Даже при отсутствии маршрутизатора узлы в пределах связи могут автоматически настроиться, используя адреса локальной связи и взаимодействовать без настройки вручную.

Дополнительные сведения см. в разделе Автонастройка адреса IPv6.

Встроенные средства обеспечения безопасности

Поддержка IPSec является требованием семейства протоколов IPv6. Это требование обеспечивает стандартное решение для обеспечения безопасности сети и возможность взаимодействия разных реализаций IPv6.

Дополнительные сведения см. в разделе Средства безопасности.

Улучшенная поддержка качества службы (QoS)

Новые поля заголовка IPv6 определяют условия обработки и идентификации трафика. Идентификация трафика с использованием поля «Flow Label» заголовка IPv6 позволяет маршрутизаторам идентифицировать пакеты, относящиеся к потоку, и обрабатывать их специальным образом. Поток представляет собой набор пакетов, передаваемых с исходного узла на конечный. Поскольку трафик идентифицируется в заголовке IPv6, поддержку QoS можно легко реализовать даже при шифровании полезных данных с помощью IPSec.

Новый протокол взаимодействия соседних узлов

Протокол ND (Neighbor Discovery) для IPv6 представляет собой набор сообщений ICMPv6 (Internet Control Message Protocol for IPv6), управляющих взаимодействием соседних узлов (то есть узлов, находящихся в пределах одной связи). Он заменяет протокол ARP (Address Resolution Protocol), запрос Router Discovery ICMPv4 и сообщение Redirect ICMPv4 эффективными одноадресными и многоадресными сообщениями, а также обладает другими функциями.

Дополнительные сведения см. в разделе ND (Neighbor Discovery).

Возможность расширения

Протокол IPv6 может быть расширен для использования новых возможностей путем добавления расширенных заголовков после заголовка IPv6. В отличие от заголовка IPv4, поддерживающего только 40 байт дополнительных данных, размер расширенных заголовков IPv6 ограничивается только размером пакета IPv6.


Возможности протокола IPv6 для Windows XP

Протокол IPv6 для Windows XP включает следующие возможности:

  • туннелирование 6to4;
  • протокол ISATAP;
  • туннелирование 6over4;
  • анонимные адреса;
  • префиксы узла в объявлениях маршрутизатора;
  • поддержка DNS;
  • поддержка IPSec;
  • поддержка приложений;
  • поддержка RPC;
  • поддержка статических маршрутизаторов.

Это возможности подробно рассмотрены в следующих разделах.

Туннелирование 6to4

6to4 представляет собой способ туннелирования, рассмотренный в документе RFC 3056. Узлы 6to4 не требуют настройки вручную и создают адреса 6to4, используя стандартную автоматическую настройку. 6to4 использует глобальный префикс адресов 2002:WWXX:YYZZ::/48, где WWXX:YYZZ — это точечно-десятичное представление общедоступного адреса IPv4 (w.x.y.z), назначенного сайту или узлу. WWXX:YYZZ — это составляющая следующего уровня (Next Level Aggregator, NLA) адреса 6to4.

6to4 позволяет взаимодействовать узлам и компьютерам, поддерживающим протокол IPv6, используя IPv6 поверх инфраструктуры IPv4 (например Интернета). Узлы и компьютеры IPv6 могут использовать префикс адреса 6to4 и Интернет для взаимодействия без получения у поставщика услуг Интернета префикса глобального адреса IPv6 и подключения к сети 6bone (часть Интернета на базе протокола IPv6).

Дополнительные сведения см. в разделе Трафик IPv6 между узлами в различных сайтах через Интернет (6to4).

Протокол ISATAP

Протокол ISATAP представляет собой механизм назначения адресов и туннелирования для взаимодействия узлов IPv6/IPv4 в пределах сайта IPv4. Он описывается в проекте стандартов Интернета «Протокол ISATAP (Intra-Site Automatic Tunnel Addressing Protocol)» (draft-ietf-ngtrans-isatap-00.txt). Дополнительные сведения см. в разделе Трафик IPv6 между узлами в разных подсетях объединенной сети IPv4.

Туннелирование 6over4

Туннелирование 6over4, также называемое многоадресным туннелированием IPv4, представляет собой способ туннелирования, описанный в документе RFC 2529. Он позволяет узлам IPv6 и IPv4 взаимодействовать по протоколу IPv6 поверх инфраструктуры IPv4. Туннелирование 6over4 использует инфраструктуру IPv4 как связь, поддерживающую многоадресную рассылку. Для правильной работы 6over4 инфраструктура IPv4 должна поддерживать многоадресную рассылку IPv4.

Дополнительные сведения о настройке интерфейса 6over4 см. в разделе Служебные программы IPv6.

Анонимные адреса

Для обеспечения анонимности при доступе к ресурсам Интернета 64-битный идентификатор интерфейса глобального адреса IPv6 получается из анонимного глобального адреса, создаваемого на основе случайных чисел.

Дополнительные сведения см. в разделе Идентификаторы интерфейса IPv6.

Префиксы узла в объявлениях маршрутизатора

Опубликованные префиксы соединения можно настроить, используя длину префикса сайтов, как описано в проекте стандартов Интернета «Префиксы сайтов в запросе Neighbor Discovery» (draft-ietf-ipngwg-site-prefixes-0x.txt). Для использования длины префикса сайта в префиксе адреса можно воспользоваться командой ipv6 rtu. Дополнительные сведения см. в разделе Служебные программы IPv6.

При получении префикса, задающего префикс сайта, создается запись в таблице префиксов сайтов. Эту таблицу можно просмотреть с помощью команды ipv6 spt. Таблица префиксов сайтов используется для удаления несоответствующих адресов локального сайта, возвращаемых функцией сокетов Windows getaddrinfo().

Поддержка DNS

Поддерживается обработка записей узлов IPv6 DNS (называются также записями ресурса AAAA (четыре A)) распознавателем (клиентом) DNS в Windows XP и службой сервера DNS в Windows 2000. Это описано в документе RFC 1886 «Расширения DNS для поддержки протокола IP версии 6». Весь трафик DNS пересылается по сети IPv4.

Дополнительные сведения см. в разделе Разрешение имен.

Поддержка IPSec

Поддерживается обработка заголовка проверки подлинности (AH) с использованием хеша MD5 (Message Digest 5) и протокола ESP с использованием заголовка ESP NULL с хешем MD5. Шифрование данных ESP не поддерживается.

Пример настройки см. в разделе Использование IPSec между двумя узлами локальной связи.

Поддержка приложений

Приложения, поддерживающие протокол IPv6, входящий в состав Windows XP, включают Internet Explorer, клиент Telnet (Telnet.exe) и FTP-клиент (Ftp.exe).

Дополнительные сведения см. в разделе Приложения для протокола IPv6.

Поддержка RPC

Функции удаленного вызова процедур (RPC), использующиеся для пересылки вызовов функций приложения на удаленный компьютер в сети, могут использоваться поверх IPv6. Примером использования RPC является удаленное администрирование.

Поддержка статических маршрутизаторов

Компьютер, работающий под управлением Windows XP, может выступать в роли статического маршрутизатора IPv6, пересылающего пакеты IPv6 между интерфейсами в зависимости от содержимого таблицы маршрутизации IPv6. Настраивать статические маршрутизаторы можно с помощью команды ipv6 rtu. Протоколы маршрутизации IPv6 в настоящее время не поддерживаются.

Компьютер, работающий под управлением Windows XP, может отправлять объявления маршрутизатора. Содержимое объявлений маршрутизатора автоматически формируется на основе маршрутов, опубликованных в таблице маршрутизации. Неопубликованные маршруты используются для маршрутизации, но не отправляются в объявлениях маршрутизатора. Объявления маршрутизатора всегда содержат исходный адрес уровня связи и значение MTU. Значение MTU устанавливается равным значению MTU исходного интерфейса текущей связи. Это значение можно изменять с помощью команды ipv6 ifc mtu. Компьютер, работающий под управлением Windows XP, объявляет себя основным маршрутизатором (путем использования объявления маршрутизатора со временем жизни маршрутизатора больше нуля) только при наличии основного маршрута, настроенного для публикации.

Примеры см. в разделах Трафик IPv6 между узлами в разных подсетях объединенной сети IPv6 и Задачи тестовой лаборатории протокола IPv6.


Средства безопасности

Протокол IPv6 для Windows XP включает протокол IPSec, обеспечивающий защиту данных IPv6 при пересылке по сети. IPSec представляет собой набор стандартов Интернета, использующий криптографические службы для обеспечения следующих возможностей.

  • Конфиденциальность

    • Трафик IPSec зашифрован. Перехваченный трафик IPSec нельзя расшифровать, не зная ключа.

  • Проверка подлинности

    • Трафик IPSec подписывается цифровой подписью с общим ключом шифрования, поэтому получатель может удостовериться в подлинности отправителя.

  • Целостность данных

    • Трафик IPSec содержит криптографическую контрольную сумму, включающую ключ шифрования. Получатель может проверить, не был ли пакет изменен в процессе передачи.

Пример настройки IPSec для IPv6 см. в разделе Использование IPSec между двумя узлами локальной связи.

Протокол IPv6 для Windows XP также обеспечивает поддержку для анонимных адресов. Анонимные адреса обеспечивают анонимность при доступе к ресурсам Интернета. Дополнительные сведения см. в разделе Идентификаторы интерфейса анонимного адреса.

Важно!

  • XOX

Примечания

  • IPSec в IPv6 является отдельным протоколом и не взаимодействует с IPSec для протокола TCP/IP. Политики IPSec, настроенные с использованием оснасток «Политики безопасности IP» или «Групповая политика», не оказывают влияния на трафик IPv6. Дополнительные сведения о протоколе IPSec для TCP/IP см. в разделе Протокол IPSec (Internet Protocol security).
  • IPSec в протоколе IPv6 для Windows XP не поддерживает использование шифрования данных для обеспечения конфиденциальности данных.
  • IPSec в протоколе IPv6 для Windows XP не поддерживает использование обмена ключами в Интернете (IKE) для согласования безопасности (SA). Политики IPSec и SA должны быть настроены вручную.


Общие сведения о протоколе IPv6

В этом разделе собраны сведения по следующим вопросам.

  • Основные протоколы семейства IPv6
  • Адресация и маршрутизация протокола IPv6
  • Разрешение имен
  • Приложения для протокола IPv6 и сетевые приложения


Основные протоколы семейства IPv6

В этом разделе собраны сведения по следующим вопросам.

  • Протокол IP версии 6 (IPv6)
  • ICMPv6 (Internet Control Message Protocol для IPv6)
  • MLD (Multicast Listener Discovery)
  • ND (Neighbor Discovery)


Протокол IP версии 6 (IPv6)

Протокол IPv6 описан в документе RFC 2460 «Спецификация протокола IP версии 6 (IPv6)». IPv6 — это не ориентированный на установление соединения и ненадежный протокол, ответственный, главным образом, за адресацию и маршрутизацию пакетов между узлами.

Термин «не ориентированный на установление соединения» означает, что сеанс для обмена данными не устанавливается. Термин «ненадежный» означает, что доставка не гарантируется. IPv6 всегда делает все необходимое, чтобы доставить пакет. IPv6-пакет может быть потерян, доставлен вне очереди, дублирован или задержан. Протокол IPv6 не пытается исправить ошибки этих типов. Подтверждение получения пакетов и повторное обращение за потерянными пакетами входят в компетенцию протокола более высокого уровня, например TCP.

Пакет IPv6, также называемый датаграммой IPv6, состоит из заголовка IPv6 и используемых данных IPv6, как показано на следующем рисунке.

Пакет IPv6

Заголовок IPv6 содержит следующие поля, используемые для адресации и маршрутизации.

Поле заголовка IPv6 | Функция
Source Address (исходный адрес) | Адрес IPv6 исходного узла, отправившего пакет IPv6.
Destination Address (конечный адрес) | Адрес IPv6 промежуточного или конечного узла, на который отправлен пакет IPv6.
Hop Limit (максимальное количество переходов) | Количество сегментов сетей, через которые может пройти пакет, прежде чем он будет отклонен маршрутизатором. Это поле задается узлом-отправителем и служит для предотвращения бесконечного блуждания пакетов в объединенной сети IPv6. При пересылке пакета IPv6 маршрутизаторы IPv6 должны уменьшать значение этого поля на 1 и отклонять пакет IPv6, если это значение достигнет нуля.

Важно!

  • XOX

Примечание

  • Стандарт IPv6 быстро развивается. Возможно, указанные документы RFC устарели в результате появления новых документов RFC.


ICMPv6 (Internet Control Message Protocol для IPv6)

ICMPv6 (Internet Control Message Protocol for IPv6) является обязательным стандартом IPv6, описанным в документе RFC 2463 «Спецификация протокола ICMPv6 (Internet Control Message Protocol) для протокола IP версии 6 (IPv6)». С помощью протокола ICMPv6 узлы и маршрутизаторы, использующие протокол IPv6, могут сообщать об ошибках и отправлять простые эхо-сообщения.

Протокол ICMPv6 также является основой для следующих запросов.

  • MLD (Multicast Listener Discovery)

    • MLD является набором из трех сообщений ICMPv6 и заменяет версию 2 протокола IGMP (Internet Group Management Protocol) для IPv4, управляющего членством в многоадресных подсетях. Дополнительные сведения см. в разделе MLD (Multicast Listener Discovery).

  • ND (Neighbor Discovery)

    • ND является набором из пяти сообщений ICMPv6, управляющим взаимодействием узел-узел в пределах связи. Он заменяет протокол ARP (Address Resolution Protocol), запрос Router Discovery ICMPv4 и сообщение Redirect ICMPv4, а также обладает другими функциями. Дополнительные сведения см. в разделе ND (Neighbor Discovery).

Сообщения ICMPv6 обычно отправляются автоматически, если пакет IPv6 не может дойти до конечного адреса.

Сообщения ICMPv6 инкапсулируются и отправляются в виде полезных данных пакетов IPv6, как показано на следующем рисунке.

Инкапсуляция ICMPv6 в пакет IPv6

Типы сообщений ICMPv6 различаются по заголовку ICMPv6. Так как сообщения ICMPv6 переносятся пакетами IPv6, их доставка не гарантируется.

В следующей таблице приведены сообщения ICMPv6, не относящиеся к MLD и ND, и их описания.

Сообщение ICMPv6 | Описание
Destination Unreachable (конечный адрес недоступен) | Сообщение об ошибке, информирующее узел-отправитель о том, что пакет не доставлен.
Packet Too Big (слишком большой пакет) | Сообщение об ошибке, информирующее узел-отправитель о том, что пакет слишком велик для пересылки.
Time Exceeded (время истекло) | Сообщение об ошибке, информирующее узел-отправитель о том, что превышен предел количества переходов пакета IPv6.
Parameter Problem (ошибка в параметрах) | Сообщение об ошибке, информирующее узел-отправитель о том, что при обработке обычного заголовка или заголовка расширения IPv6 возникла ошибка.
Echo Request (эхо-запрос) | Информационное сообщение, используемое для определения доступности узла IPv6 в сети.
Echo Reply (эхо-ответ) | Информационное сообщение, используемое для ответа на эхо-запрос ICMPv6.

Для отправки эхо-запросов ICMPv6 и приема эхо-ответов ICMPv6 можно использовать команду ping6. Эти сообщения команды ping6 позволяют выявлять неполадки в работе сетей и узлов, а также устранять другие неполадки соединений по протоколу IPv6. Дополнительные сведения см. в разделе Проверка подключения IPv6 с помощью команды ping6.

Команда tracert6 позволяет отправлять сообщения с эхо-запросом ICMPv6 с постепенно увеличивающимся значением в поле Hop Limit (максимальное количество переходов). Команда tracert6 отслеживает и отображает путь, пройденный пакетами IPv6 от исходного до конечного узла, что позволяет выявлять и устранять общие неполадки в маршрутизации IPv6. Дополнительные сведения см. в разделе Трассировка маршрута с помощью команды tracert6.

Важно!

  • XOX

Примечание

  • Стандарт IPv6 быстро развивается. Возможно, указанные документы RFC устарели в результате появления новых документов RFC.


MLD (Multicast Listener Discovery)

Применение многоадресной IP-рассылки описано в стандарте TCP/IP — документе RFC 1112 «Протокол IGMP (Internet Group Management Protocol)». Этот документ RFC определяет расширения адреса и узла, позволяющие IP-осуществлять многоадресную рассылку. Стандартны, изначально разработанные для текущей версии протокола IP (IP версии 4 или сокращенно IPv4), также применимы и к протоколу IPv6.

Что такое многоадресная рассылка?

Многоадресный трафик направляется по одному адресу, но обрабатывается несколькими узлами. Многоадресная рассылка похожа на подписку на информационный бюллетень. Когда бюллетень выходит в свет, его получают только подписчики; аналогично, только узлы, входящие в группу многоадресной рассылки, получают и обрабатывают трафик, отправляемый на зарезервированный адрес группы. Набор узлов, принимающих трафик с данным многоадресным адресом, называется группой многоадресной рассылки.

Далее приведены другие важные характеристики многоадресной рассылки.

  • Членство в группах динамическое, что позволяет узлам присоединяться к группе и покидать ее в любое время.
  • Присоединение к группе многоадресной рассылки происходит путем отправки сообщений о членстве в группе. В протоколе IPv6 сообщения MLD (Multicast Listener Discovery) используются для определения членства в группе в пределах сегмента сети, также называемого связью или подсетью.
  • Группы не ограничены по размеру, и их члены могут быть разбросаны по различным сегментам сети (если маршрутизаторы, которыми соединены эти сети, поддерживают распространение многоадресного трафика и информации о членстве в группах).
  • Узел может отправлять трафик по адресу группы, не будучи членом этой группы.

Адресация многоадресной рассылки IPv6

Адреса многоадресной рассылки в протоколе IPv6 зарезервированы и имеют префикс формата 1111 1111 (0xFF). В следующей таблице приведен частичный список адресов многоадресной рассылки IPv6, зарезервированных для многоадресной рассылки по протоколу IPv6 и зарегистрированных в IANA (Internet Assigned Numbers Authority).

Адрес многоадресной рассылки IPv6 | Описание
FF02::1 | Адрес, включающий все узлы в пределах текущей связи.
FF02::2 | Адрес, включающий все маршрутизаторы в пределах текущей связи.
FF02::4 | Адрес, включающий все маршрутизаторы многоадресной рассылки DVMRP (Distance Vector Multicast Routing Protocol) в пределах текущей связи.
FF02::5 | Адрес, включающий все маршрутизаторы OSPF (Open Shortest Path First) в пределах текущей связи.
FF02::6 | Адрес, включающий все назначенные маршрутизаторы OSPF в пределах текущей связи.
FF02::1:FFXX:XXXX | Адрес запрашиваемого узла, используемый в процессе разрешения адреса для определения адреса IPv6 узла уровня связи по его адресу локальной связи. Последние 24 бита (XX:XXXX) запрашиваемого узла являются последними 24 битами адреса одноадресной рассылки IPv6.

Полный текущий список дополнительных адресов IPv6, зарезервированных для многоадресной рассылки, содержится на веб-узле Information Sciences Institute.

Один адрес многоадресной рассылки IPv6 определяет одну группу многоадресной рассылки. Зарезервированный адрес IPv6 каждой группы используется всеми входящими в группу узлами, которые получают все сообщения IPv6, отправляемые по адресу этой группы.

Адреса многоадресной рассылки IPv6 сопоставлены зарезервированному для многоадресной рассылки набору аппаратных адресов. Сведения о сопоставлении адресов IPv6 многоадресной рассылки MAC-адресам Ethernet см. в документе RFC 2464 «Передача пакетов IPv6 по сетям Ethernet».

Примечание

  • XOX

Сообщения MLD

Сообщения MLD служат для обмена информацией о членстве в группах между маршрутизаторами IPv6, поддерживающими многоадресную рассылку, и членами групп многоадресной рассылки. О членстве узлов в группах многоадресной рассылки сообщают сами узлы, а состояние членства периодически проверяется маршрутизаторами, поддерживающими многоадресную рассылку. Протокол MLD описан в документе RFC 2710 «Протокол MLD (Multicast Listener Discovery) для IPv6».

Типы сообщений MLD описаны в следующей таблице.

Тип сообщения MLD | Описание
Multicast Listener Query (запрос многоадресного прослушивания) | Отправляется маршрутизатором, поддерживающим многоадресную рассылку, для обнаружения в сегменте сети членов групп. Запросы могут быть общими (запрос членства во всех группах) или специальными (запрос членства в определенной группе).
Multicast Listener Report (отчет многоадресного прослушивания) | Отправляется узлом при его происоединении к группе многоадресной рассылки или в ответ на запрос MLD, отправленный маршрутизатором.
Multicast Listener Done (завершение многоадресного прослушивания) | Отправляется узлом, являющимся последним членом группы в данном сегменте сети и прекращающим свое членство в данной группе.

Сообщения MLD отправлятся как сообщения ICMPv6.

Важно!

  • XOX

Примечание

  • Стандарт IPv6 быстро развивается. Возможно, указанные документы RFC устарели в результате появления новых документов RFC.


ND (Neighbor Discovery)

Запрос ND (Neighbor Discovery) протокола IPv6 является набором сообщений и процессов, определяющих отношения между соседними узлами. Запрос ND заменяет протокол ARP (Address Resolution Protocol), сообщения ICMP (Internet Control Message Protocol) Router Discovery и ICMP Redirect, использовавшиеся в протоколе IPv4, а также имеет другие функции. Запрос ND описан в документе RFC 2461 «Запрос Neighbor Discovery для IP версии 6 (IPv6)».

Использование запроса ND позволяет компьютерам выполнять следующие задачи.

  • Обнаруживать соседние маршрутизаторы.
  • Определять адреса, префиксы адресов и другие параметры конфигурации.

Использование запроса ND позволяет маршрутизаторам выполнять следующие задачи.

  • Объявлять о своем присутствии, объявлять параметры конфигурации и префиксы прямой связи.
  • Информировать узлы об адресе более короткого следующего перехода для пересылки пакетов на определенный адрес.

Использование запроса ND позволяет узлам выполнять следующие задачи.

  • Определять адрес уровня связи соседнего узла, на который пересылается пакет IPv6, а также узнавать об изменении адреса уровня связи соседнего узла.
  • Определять, возможны ли отправка и получение пакетов IPv6 с соседнего узла.

В следующей таблице приведены процессы ND и их описания.

Процесс | Описание
Router discovery (обнаружение маршрутизатора) | Обнаружение компьютером локальных маршрутизаторов в назначенной связи (аналогичен процессу Router Discovery ICMPv4) и автоматическая настройка основного маршрутизатора (аналогичного основному шлюзу IPv4).
Prefix discovery (определение префикса) | Определение компьютером префикса сети для взаимодействия с локальными узлами.
Parameter discovery (определение параметра) | Определение компьютером дополнительных параметров работы, включающих наибольший размер передаваемых данных (MTU) связи и используемое по умолчанию максимальное количество переходов для исходящих пакетов.
Address autoconfiguration (автоматическая конфигурация адреса) | Настройка IP-адресов для интерфейсов при наличии или отсутствии сервера настройки адресов с ведением базы данных, такого как DHCPv6 (Dynamic Host Configuration Protocol version 6). Дополнительные сведения см. в разделе Автонастройка адреса IPv6.
Address resolution (разрешение адресов) | Определение узлом адреса уровня связи (аналогичного ARP в IPv4) соседнего узла по его адресу IPv6. Полученный адрес уровня связи становится записью в кэше окружения узла (аналогичного кэшу ARP в IPv4). Просмотреть содержимое кэша окружения на компьютере, работающем под управлением Windows XP, можно с помощью команды ipv6 nc. Кэш окружения показывает идентификатор интерфейса записи кэша окружения, адрес IPv6 соседнего узла, соответствующий ему адрес уровня связи и состояние этой записи кэша окружения. Дополнительные сведения содержатся в разделе Просмотр кэша окружения.
Next-hop determination (определение следующего перехода) | Определение узлом адреса IPv6 соседнего узла, на который пересылается пакет в зависимости от конечного адреса. Адресом пересылки (или следующего перехода) является или конечный адрес отправленного пакета, или адрес соседнего маршрутизатора. Определенный адрес следующего перехода становится записью в кэше назначения узла (также называемом кэшем маршрута). Просмотреть содержимое кэша маршрута на компьютере, работающем под управлением Windows XP, можно с помощью команды ipv6 rc. Кэш маршрута показывает конечный адрес, идентификатор интерфейса и адрес следующего перехода, исходные идентификатор интерфейса и адрес, использованные при отправке, а также путь MTU конечного адреса. Дополнительные сведения содержатся в разделе Просмотр кэша маршрута.
Neighbor unreachability detection (обнаружение недостижимости соседнего узла) | Обнаружение узлом ситуации, когда невозможны отправка и получение пакетов IPv6 от соседнего узла. После определения адреса уровня связи соседнего узла, начинается отслеживание состояния соответствующей записи в кэше окружения. Если соседний узел больше не получает и не отправляет пакеты, соответствующая запись в кэше окружения со временем удаляется. Этот процесс обеспечивает для протокола IPv6 механизм обнаружения ситуации, когда соседний компьютер или маршрутизатор перестает быть доступным в сегменте локальной сети.
Duplicate address detection (обнаружение дублирования адреса) | Проверка, подтверждающая, что адрес, назначенный узлу, не используется соседними узлами (аналогичная использованию предварительных запросов ARP в IPv4).
Redirect function (функция перенаправления) | Информирование маршрутизатором компьютера о наличии адреса IPv6 более быстрого первого перехода (аналогично функции сообщения ICMP Redirect в IPv4).

Важно!

  • XOX

Примечание

  • Стандарт IPv6 быстро развивается. Возможно, указанные документы RFC устарели в результате появления новых документов RFC.


Адресация и маршрутизация протокола IPv6

В этом разделе собраны сведения по следующим вопросам.

  • Адресация протокола IPv6
  • Автонастройка адреса IPv6
  • Маршрутизация протокола IPv6
  • Таблица маршрутизации протокола IPv6


Адресация протокола IPv6

В этом разделе собраны сведения по следующим вопросам.

  • Пространство адресов IPv6
  • Формат адресов IPv6
  • Адреса IPv6 для одноадресной рассылки
  • Адреса IPv6 для многоадресной рассылки
  • Адреса IPv6 для рассылки до первого получателя
  • Адреса серверов и маршрутизаторов
  • Идентификаторы интерфейса IPv6


Пространство адресов IPv6

Наиболее очевидным отличием IPv6 является использование значительно более длинных адресов. Размер адреса IPv6 составляет 128 бит, что в четыре раза превышает размер адреса в IPv4. 32-битное пространство адресов вмещает 232 или 4 294 967 296 возможных адресов. 128-битное пространство адресов вмещает 2128 или 340 282 366 920 938 463 463 374 607 431 768 211 456 (3,4 × 1038) возможных адресов.

В конце 1970-х, когда было разработано пространство адресов IPv4, невозможно было представить, что его можно исчерпать. Однако в связи с изменениями в технологии и практикой выдачи адресов, не предусматривавшей недавнего взрывного увеличения числа узлов в Интернете, использование пространства адресов IPv4 достигло такого уровня, что к 1992 году необходимость замены стала очевидной.

Возможность исчерпания пространства адресов IPv6 представить еще сложнее. Для наглядности: 128-битное пространство адресов обеспечивает 655 570 793 348 866 943 898 599 (6,5 × 1023) адресов на каждый квадратный метр поверхности Земли.

Важно отметить, что решение использовать в IPv6 адреса длиной в 128 бит было принято не с целью обеспечить 6,5 x 1023 адресов на каждый квадратный метр поверхности Земли. Этот относительно большой размер адреса IPv6 предназначен для деления на домены иерархической маршрутизации, отражающие топологию современного Интернета. Использование 128 бит обеспечивает множество уровней иерархии и гибкость в разработке иерархической адресации и маршрутизации, которой недостает в Интернете на базе протокола IPv4.

Архитектура адресации IPv6 описана в документе RFC 2373 «Архитектура адресации протокола IP версии 6».

Текущее разделение

Аналогично способу разделения пространства адресов IPv4, пространство адресов IPv6 делится по значениям битов высокого порядка в адресе. Биты высокого порядка и их фиксированные значения называют префиксом формата (Format Prefix, FP).

В следующей таблице показано разделение пространства адресов IPv6 по значениям FP.

Выделение | Префикс формата | Доля пространства адресов
Зарезервировано | 0000 0000 | 1/256
Зарезервировано для выделения NSAP | 0000 001 | 1/128
Комбинируемые адреса глобальной одноадресной рассылки | 001 | 1/8
Адреса одноадресной рассылки в пределах связи | 1111 1110 10 | 1/1024
Адреса одноадресной рассылки в пределах сайта | 1111 1110 11 | 1/1024
Адреса многоадресной рассылки | 1111 1111 | 1/256

Оставшаяся часть пространства адресов IPv6 не имеет назначения.

Текущий набор адресов одноадресной рассылки, доступный для использования узлами IPv6, составляют комбинируемые адреса глобальной одноадресной рассылки, адреса одноадресной рассылки в пределах связи и адреса одноадресной рассылки в пределах сайта. В совокупности это всего 15 процентов от всего пространства адресов IPv6. Дополнительные сведения см. в разделе Адреса IPv6 для одноадресной рассылки.

Важно!

  • XOX

Примечание

  • Стандарт IPv6 быстро развивается. Возможно, указанные документы RFC устарели после появления новых документов RFC.


Формат адресов IPv6

Для представления адресов IPv4 используется точечно-десятичный формат. Этот 32-битный адрес разделен на части по 8 бит. 8-битные части адреса преобразованы в десятичные эквиваленты и разделены точками. 128-битный адрес IPv6 разделяется на части по 16 бит, которые преобразуются в 4-значные шестнадцатеричные числа и разделяются двоеточиями. Получающаяся форма записи называется двухточечно-шестнадцатеричной.

Ниже показан адрес IPv6 в двоичной форме:

0010000111011010000000001101001100000000000000000010111100111011
0000001010101010000000001111111111111110001010001001110001011010

Тот же 128-битный адрес, разделенный на части по 16 бит, выглядит следующим образом:

0010000111011010   0000000011010011   0000000000000000   0010111100111011
0000001010101010   0000000011111111   1111111000101000   1001110001011010

Каждый 16-битный блок преобразуется в шестнадцатеричное число и отделяется двоеточием. Получается следующий адрес:

21DA:00D3:0000:2F3B:02AA:00FF:FE28:9C5A

Представление адресов IPv6 может быть еще более упрощено путем удаления начальных нулей в каждом 16-битном блоке. Однако каждый из блоков должен содержать не менее одного знака. При удалении начальных нулей адрес выглядит следующим образом:

21DA:D3:0:2F3B:2AA:FF:FE28:9C5A

Сокращение нулей

Некоторые типы адресов содержат длинные последовательности нулей. Для дальнейшего упрощения представления адресов IPv6 непрерывная последовательность 16-битных блоков, состоящая из нулей в двухточечно-шестнадцатеричном формате, может быть сжата до вида :: (называется двойным двоеточием).

Например, адрес локальной связи FE80:0:0:0:2AA:FF:FE9A:4CA2 можно сократить до FE80::2AA:FF:FE9A:4CA2. Групповой адрес FF02:0:0:0:0:0:0:2 может быть приведен к виду FF02::2. Сокращение нулей можно использовать для сжатия одной непрерывной последовательности 16-битных блоков, представленных в двухточечно-шестнадцатеричном формате. Использовать сокращение нулей для включения части 16-битного блока нельзя. Например, нельзя сократить адрес FF02:30:0:0:0:0:0:5 до FF02:3::5.

Чтобы определить число нулей, представленных как ::, можно сосчитать число блоков в сокращенном адресе, вычесть это число из 8, а полученную разность умножить на 16. Например, в адресе FF02::2 блоков два (блок FF02 и блок 2). Число бит, представленных как :: равно 96 (96 = (8 - 2) × 16).

Сокращение нулей в адресе можно использовать только один раз. В противном случае будет невозможно определить число нулей, представленных каждым двойным двоеточием (::).

Префиксы IPv6

Префикс — это часть адреса, указывающая биты, имеющие фиксированные значения или биты идентификатора сети. Префиксы для маршрутов IPv6 и идентификаторов подсети выражаются так же, как в нотации CIDR (Classless Inter-Domain Routing) для IPv4. Префикс IPv6 записывается в нотации адрес/длина_префикса. Например, 21DA:D3::/48 — это префикс маршрута, а 21DA:D3:0:2F3B::/64 — префикс подсети.

Важно!

  • XOX

Примечание

  • В реализациях IPv4 широко используется точечно-десятичное представление префикса сети, известное как маска подсети. В IPv6 маска подсети не используется. Поддерживается только нотация префикс/длина.


Адреса IPv6 для одноадресной рассылки

Адрес одноадресной рассылки определяет один интерфейс в пределах области адресов одноадресной рассылки. При соответствующей топологии одноадресной маршрутизации пакеты, отправляемые на адрес одноадресной рассылки, доставляются на один интерфейс. Адресами одноадресной рассылки IPv6 являются адреса следующих типов:

  • комбинируемые адреса глобальной одноадресной рассылки;
  • адреса локальной связи;
  • адреса локального сайта;
  • специальные адреса;
  • адреса совместимости;
  • адреса NSAP.

Комбинируемые адреса глобальной одноадресной рассылки

Комбинируемые адреса глобальной одноадресной рассылки, определяемые префиксом формата (Format Prefix, FP) 001, эквивалентны общедоступным адресам IPv4. Они пригодны для глобальной маршрутизации и доступны в части Интернета, использующей протокол IPv6. Эту часть Интернета называют 6bone (от IPv6 backbone). Комбинируемые адреса глобальной одноадресной рассылки также называют глобальными адресами.

Как видно из названия, комбинируемые адреса глобальной одноадресной рассылки комбинируются, или объединяются, для получения эффективной инфраструктуры маршрутизации. В отличие от нынешнего Интернета на базе протокола IPv4, использующего как простую, так и иерархическую маршрутизацию, Интернет на базе протокола IPv6 был с самого начала разработан для поддержки эффективной, иерархической адресации и маршрутизации. Областью действия комбинируемого адреса глобальной одноадресной рассылки (регионом объединенной сети IPv6, в котором этот адрес является уникальным) является весь Интернет на базе протокола IPv6.

Структура комбинируемого адреса глобальной одноадресной рассылки

Поля комбинируемого адреса глобальной одноадресной рассылки описаны ниже.

  • TLA ID

    • Поле TLA ID указывает составляющую верхнего уровня (Top Level Aggregator, TLA) для адреса. Максимальный размер этого поля составляет 13 бит. TLA указывает самый верхний уровень в иерархии маршрутизации. Администрирование TLA осуществляет IANA. TLA выделяются локальным реестрам Интернета, которые, в свою очередь, выделяют отдельные идентификаторы TLA крупным, глобальным поставщикам услуг Интернета. 13-битное поле позволяет создать 8 192 различных идентификатора TLA. У маршрутизаторов самого верхнего уровня в иерархии маршрутизации IPv6 (называемых маршрутизаторами без умолчаний) стандартный маршрут отсутствует — существуют только маршруты с 16-битными префиксами, которые связаны с выделенными TLA.

  • Поле Res зарезервировано для будущего использования при увеличении размера полей TLA ID или NLA ID.

    • Поле «Res» зарезервировано для будущего использования при увеличении размера полей TLA ID или NLA ID.

  • Размер этого поля составляет 8 бит.

    • Поле NLA ID указывает составляющую следующего уровня (Next Level Aggregator, NLA) для адреса. Поле NLA ID используется для указания сайта конкретного потребителя. Размер этого поля составляет 24 бита. Поле NLA ID позволяет поставщикам услуг Интернета создавать множественные уровни иерархии адресации для организации адресации и маршрутизации, а также для определения сайтов. Структура сети поставщика услуг Интернета не видна для маршрутизаторов без умолчаний.

  • SLA ID

    • Поле SLA ID указывает составляющую уровня сайта (Site Level Aggregator, SLA) для адреса. Поле SLA ID используется отдельными организациями для определения подсетей в пределах сайта. Размер этого поля составляет 16 бит. С помощью этих 16 бит организация может создать в своем сайте 65 536 подсетей или несколько уровней иерархии адресации и эффективную инфраструктуру маршрутизации. Назначение организации префикса глобальной одноадресной рассылки с 16 байтами для создания подсетей эквивалентно выделению этой организации идентификатора подсети класса А по протоколу IPv4 (исходя из того, что последний октет используется для определения узлов в подсетях). Структура сети организации не видна для маршрутизаторов без умолчаний.

  • Interface ID

    • Поле Interface ID указывает интерфейс узла в конкретной подсети. Размер этого поля составляет 64 бита.

На следующем рисунке показано использование полей комбинируемого адреса глобальной одноадресной рассылки для создания трехуровневой топологической структуры.

Трехуровневая структура комбинируемого адреса глобальной одноадресной рассылки

Общедоступная топология представляет собой совокупность крупных и более мелких поставщиков услуг Интернета, предоставляющих доступ к Интернету на базе протокола IPv6. Топология сайта — это совокупность подсетей в пределах сайта организации. Идентификатор интерфейса определяет конкретный интерфейс в подсети, расположенной в пределах сайта организации. Дополнительные сведения о комбинируемом адресе глобальной одноадресной рассылки см. в документе RFC 2374 «Формат комбинируемого адреса глобальной одноадресной рассылки для протокола IPv6».

Локальные адреса для одноадресной рассылки

Существует два типа локальных адресов одноадресной рассылки:

  1. Адреса локальной связи, используемые между соседями по связи и для процессов изучения окружения.
  2. Адреса локального сайта, используемые между узлами, обменивающимися данными с другими узлами в том же сайте.

Адреса локальной связи

Адреса локальной связи, определяемые префиксом формата 1111 1110 10, используются узлами при обмене данными с соседними узлами на той же связи. Например, в сети IPv6 с единой связью, без маршрутизаторов, адреса локальной связи используются для обмена данными между узлами, подключенными к этой связи. Адреса локальной связи эквивалентны адресам APIPA (Automatic Private IP Addressing) в IPv4 (использующим префикс 169.254.0.0/16). Областью адреса локальной связи является соответствующая локальная связь. Адрес локальной связи необходим для процессов изучения окружения и всегда настраивается автоматически, даже при отсутствии всех прочих адресов одноадресной рассылки. Дополнительные сведения о процессе автоматической настройки адресов локальной связи см. в разделе Автонастройка адреса IPv6.

Адреса локальной связи всегда начинаются с FE80. Используя 64-битный идентификатор интерфейса, префикс для адреса локальной связи будет всегда выглядеть следующим образом: FE80::/64. Маршрутизатор IPv6 никогда не направляет трафик локальной связи за пределы канала связи.

Дополнительные сведения об использовании адресов локальной связи см. в разделе Подсеть с адресами локальной связи.

Адреса локального сайта

Адреса локального сайта, определяемые префиксом формата 1111 1110 11, эквивалентны частному пространству адресов (10.0.0.0/8, 172.16.0.0/12 и 192.168.0.0/16) в IPv4. Например, частные интрасети, не имеющие непосредственного маршрутизированного подключения к Интернету на базе протокола IPv6, могут использовать адреса локального сайта без конфликтов с комбинируемыми адресами глобальной одноадресной рассылки. Адреса локального сайта недоступны из других сайтов, и маршрутизаторы не должны пересылать трафик локального сайта за пределы этого сайта. Адреса локального сайта могут использоваться наряду с комбинируемыми адресами глобальной одноадресной рассылки. Областью адреса локального сайта является соответствующий сайт (объединенная сеть организации).

В отличие от адресов локальной связи, адреса локального сайта не настраиваются автоматически и должны быть назначены при помощи процесса настройки адресов с ведением или без ведения базы данных. Дополнительные сведения см. в разделе Автонастройка адреса IPv6.

Первые 48 бит всегда закреплены за адресами локального сайта, начиная с FEC0::/48. После 48 фиксированных битов следует 16-битный идентификатор подсети (поле Subnet ID), с помощью которого можно создавать подсети внутри организации. Эти 16 бит позволяют создать до 65 536 подсетей в простой структуре подсетей. Кроме того, можно отделить биты высокого порядка в поле Subnet ID для создания иерархической и комбинируемой инфраструктуры маршрутизации. За полем Subnet ID следует 64-битное поле Interface ID, определяющее конкретный интерфейс в подсети.

За исключением первых 48 байт комбинируемый адрес глобальной одноадресной рассылки и адрес локального сайта используют одинаковую структуру. В комбинируемых адресах глобальной одноадресной рассылки подсеть в пределах организации определяется полем SLA ID. Для адресов локального сайта эту функцию выполняет поле Subnet ID. Таким образом, назначив конкретный номер подсети, можно определить подсеть, используемую как для адресов локального сайта, так и для комбинируемых адресов глобальной одноадресной рассылки.

Специальные адреса

Специальными являются следующие адреса IPv6.

  • Неопределенный адрес

    • Неопределенный адрес (0:0:0:0:0:0:0:0 или ::) используется исключительно для обозначения отсутствия адреса. Является эквивалентом неопределенного адреса IPv4 (0.0.0.0). Неопределенный адрес обычно используется как адрес источника пакетов, отправляемых для проверки уникальности пробного адреса. Неопределенный адрес никогда не назначается интерфейсу и не используется как адрес назначения.

  • Адрес замыкания на себя

    • Адрес замыкания на себя (0:0:0:0:0:0:0:1 или ::1) используется для определения интерфейса замыкания на себя, который позволяет узлу отправлять пакеты самому себе. Является эквивалентом адреса замыкания на себя в IPv4 (127.0.0.1). Пакеты, отправленные на адрес замыкания на себя, никогда не отправляются на связь и не пересылаются маршрутизаторами IPv6.

Адреса совместимости

Следующие адреса определены для облегчения перехода от IPv4 к IPv6 и обеспечения сосуществования обоих типов узлов.

  • IPv4-совместимый адрес

    • IPv4-совместимый адрес, 0:0:0:0:0:0:w.x.y.z или ::w.x.y.z (где w.x.y.z — точечно-десятичное представление адреса IPv4), используется узлами с двумя стеками, которые используют для обмена данными инфраструктуру IPv6 поверх IPv4. Узлами с двумя стеками называют узлы, использующие оба протокола: IPv4 и IPv6. Когда в качестве адреса назначения IPv6 используется IPv4-совместимый адрес, трафик IPv6 автоматически инкапсулируется в заголовок IPv4 и отправляется по адресу назначения с использованием инфраструктуры IPv4.

  • IPv4-сопоставленный адрес

    • IPv4-сопоставленный адрес, 0:0:0:0:0:FFFF:w.x.y.z или ::FFFF:w.x.y.z, используется для представления узла, работающего только по протоколу IPv4, узлу IPv6. Такие адреса используются только для внутреннего представления. IPv4-сопоставленный адрес никогда не используется в качестве адреса источника или назначения для пакетов IPv6. Протокол IPv6 для Windows XP не поддерживает использование IPv4-сопоставленных адресов.

  • Адрес 6to4

    • Адрес 6to4 используется для обмена данными между двумя узлами, применяющими как инфраструктуру маршрутизации IPv4, так и инфраструктуру маршрутизации IPv6 поверх IPv4. Адрес 6to4 формируется путем объединения префикса 2002::/16 с 32-битным общедоступным адресом узла по протоколу IPv4, в результате чего получается 48-битный префикс. Например, для IPv4-адреса 131.107.0.1 префиксом адреса 6to4 является 2002:836B:1::/48. Дополнительные сведения об адресе 6to4 см. в разделеТрафик IPv6 между узлами в различных сайтах через Интернет (6to4).

Адреса NSAP

Для сопоставления адресов NSAP (Network Service Access Point) адресам IPv6 адреса NSAP используется префикс формата 0000001, а последние 121 бит адреса IPv6 сопоставляются адресу NSAP. Дополнительные сведения о четырех типах сопоставления адресов NSAP см. в документе RFC 1888 «NSAP адресов OSI и IPv6».

Важно!

  • XOX

Примечание

  • Стандарт IPv6 быстро развивается. Возможно, указанные документы RFC устарели после появления новых документов RFC.


Адреса IPv6 для многоадресной рассылки

Адрес многоадресной рассылки указывает множество интерфейсов. При соответствующей топологии многоадресной маршрутизации пакеты, отправляемые на адрес многоадресной рассылки, доставляются на все интерфейсы, указанные адресом.

Адреса IPv6 для многоадресной рассылки имеют префикс формата (FP) вида 1111 1111. Адрес IPv6 очень просто классифицировать как адрес для многоадресной рассылки, потому что он всегда начинается с FF. Адреса многоадресной рассылки нельзя использовать в качестве адресов источников.

После префикса формата в адресах многоадресной рассылки следует дополнительная структура, определяющая их флаги, область и группу многоадресной рассылки, как показано на следующем рисунке.

Структура адреса IPv6 для многоадресной рассылки

Поля адреса многоадресной рассылки описаны ниже.

  • Flags

    • Поле Flags указывает флаги, заданные для адреса многоадресной рассылки. Размер этого поля составляет 4 бита. Согласно документу RFC 2373, определен только флаг T (Transient — временный). Флаг T использует бит низкого порядка в поле Flags. Нулевое значение флага T указывает на то, что адрес многоадресной рассылки является постоянно назначенным (известным) адресом многоадресной рассылки, выделенным IANA (Internet Assigned Numbers Authority). Значение 1 флага T указывает на то, что адрес многоадресной рассылки является временным (назначенным не постоянно).

  • Scope

    • Поле Scope указывает область объединенной сети IPv6, для которой предназначен многоадресный трафик. Размер этого поля составляет 4 бита. Маршрутизаторы используют область многоадресной рассылки как дополнение к сведениям, предоставляемым протоколами многоадресной маршрутизации, для определения допустимых пределов рассылки многоадресного трафика.

    В документе RFC 2373 определены следующие области.

    Значение поля Scope | Область
1 | В пределах узла
2 | В пределах связи
5 | В пределах сайта
8 | В пределах организации
E | Не ограничена

    Например, область трафика с адресом многоадресной рассылки FF02::2 ограничена пределами связи. Маршрутизаторы IPv6 никогда не перешлют этот трафик за пределы локальной связи.

  • Group ID

    • Поле Group ID указывает идентификатор группы многоадресной рассылки, являющийся уникальным в пределах области. Размер этого поля составляет 112 бит. Постоянно назначенные идентификаторы групп независимы от области. Временные идентификаторы групп относятся только к конкретной области. Адреса многоадресной рассылки в диапазоне от FF01:: до FF0F:: зарезервированы и являются известными адресами.

Для указания всех узлов в областях локального узла и локальной связи определены следующие адреса многоадресной рассылки:

  • FF01::1 (адрес всех узлов локального узла);
  • FF02::1 (адрес всех узлов локальной связи).

Для указания всех маршрутизаторов в областях локального узла, локальной связи и локального сайта определены следующие адреса многоадресной рассылки:

  • FF01::2 (адрес всех маршрутизаторов локального узла);
  • FF02::2 (адрес всех маршрутизаторов локальной связи);
  • FF05::2 (адрес всех маршрутизаторов локального сайта).

С помощью 112 бит в поле Group ID можно составить 2112 идентификаторов групп. Тем не менее, из-за способа сопоставления адресов IPv6 многоадресной рассылки MAC-адресам Ethernet многоадресной рассылки, в документе RFC 2373 рекомендуется назначать поле Group ID из младших 32 битов адреса IPv6 многоадресной рассылки, а оставшимся битам исходного идентификатора поля присваивать значение 0. Использование младших 32 битов в идентификаторе группы позволяет сопоставить каждый идентификатор уникальному MAC-адресу Ethernet многоадресной рассылки.

Адрес запроса узлов

Адрес запроса узлов позволяет эффективно опрашивать узлы сети при разрешении адреса. В IPv4 отправляется широковещательный ARP-запрос на MAC-уровне, достигающий все узлы в сегменте сети, в том числе не использующие протокол IPv4. В IPv6 для разрешения адреса используется сообщение запроса окружения (Neighbor Solicitation). Однако вместо использования адреса всех узлов локальной связи в качестве места назначения сообщения запроса окружения (что повлияет на все узлы IPv6 локальной связи) используется адрес запроса узлов. Адрес запроса узлов состоит из префикса FF02::1:FF00:0/104 и последних 24 битов разрешенного адреса IPv6.

Например, узлу с адресом IPv6 локальной связи FE80::2AA:FF:FE28:9C5A соответствует адрес запроса узлов FF02::1:FF28:9C5A. Для разрешения адреса FE80::2AA:FF:FE28:9C5A в адрес уровня связи узел отправляет сообщение запроса окружения на адрес запроса узлов FF02::1:FF28:9C5A. Узел, использующий адрес FE80::2AA:FF:FE28:9C5A, прослушивает многоадресный трафик по адресу запроса узлов, а на его сетевом адаптере зарегистрирован соответствующий адрес многоадресной рассылки для интерфейсов, соответствующих физическому сетевому адаптеру.

Благодаря использованию адреса запроса узлов, для разрешение адреса, которое обычно происходит в пределах связи, не требуется беспокоить все узлы сети. Фактически в процесс разрешения адреса вовлекается очень небольшое число узлов. На практике, благодаря связи между MAC-адресом Ethernet, идентификатором интерфейса IPv6 и адресом запроса узлов, адрес запроса узлов действует как псевдо-одноадресный адрес, обеспечивающий очень эффективное разрешение адресов.


Адреса IPv6 для рассылки до первого получателя

Адрес рассылки до первого получателя указывает множество интерфейсов. При соответствующей топологии маршрутизации пакеты, отправляемые на адрес рассылки до первого получателя, доставляются на один интерфейс (ближайший из указанных адресом). Ближайший интерфейс определяется длиной маршрута. Многоадресные адреса используются для обмена данными по схеме «один-многие», с доставкой на множество интерфейсов. Адрес рассылки до первого получателя используется для обмена данными по схеме «один - один из многих», с доставкой на один интерфейс.

Для обеспечения доставки ближайшему члену группы рассылки до первого получателя инфраструктура маршрутизации должна знать интерфейсы, которым назначены адреса рассылки до первого получателя и их удаленность в терминах метрик маршрутизации. В настоящее время адреса рассылки до первого получателя используются только в качестве адресов назначения и назначаются только маршрутизаторам. Адреса рассылки до первого получателя назначаются из пространства адресов одноадресной рассылки. Областью адреса рассылки до первого получателя является область того типа адресов одноадресной рассылки, к которому относится назначенный адрес рассылки до первого получателя.

Адрес рассылки до первого получателя для маршрутизатора подсети

Адрес рассылки до первого получателя для маршрутизатора подсети является предопределенным и обязательным. Он создается на основе префикса данного интерфейса. Чтобы создать адрес рассылки до первого получателя, биты в префиксе подсети фиксируются на соответствующих значениях, а оставшимся битам присваивается значение 0. Все интерфейсы маршрутизатора, присоединенные к подсети, получают адрес рассылки до первого получателя для этой подсети. Адрес рассылки до первого получателя для маршрутизатора подсети используется для обмена данными с одним из нескольких маршрутизаторов, подключенных к удаленной подсети.


Адреса узлов и маршрутизаторов

Узел IPv4 с одним сетевым адаптером обычно имеет один адрес IPv4, назначенный этому адаптеру. Узел же IPv6 обычно имеет несколько адресов IPv6, даже при наличии только одного интерфейса.

Узлу IPv6 назначаются следующие адреса одноадресной рассылки:

  • адрес локальной связи для каждого интерфейса;
  • адреса одноадресной рассылки для каждого интерфейса (это может быть адрес локального сайта и один или несколько глобальных адресов);
  • адрес замыкания на себя (::1) для интерфейса замыкания на себя.

Обычно узлы IPv6 логически подключены к нескольким сетям, поскольку имеют как минимум два адреса, на которые могут принимать пакеты. Каждый узел имеет адрес локальной связи для трафика локальной связи, а также маршрутизируемый адрес локального сайта или глобальный адрес.

Кроме того, каждый узел прослушивает трафик на следующих адресах многоадресной рассылки:

  • адрес всех узлов в области локального узла (FF01::1);
  • адрес всех узлов в области локальной связи (FF02::1);
  • адрес запроса узла для каждого адреса одноадресной рассылки на каждом интерфейсе;
  • адреса многоадресной рассылки для групп, присоединенных к каждому интерфейсу.

Маршрутизатору IPv6 назначаются следующие адреса одноадресной рассылки:

  • адрес локальной связи для каждого интерфейса;
  • адреса одноадресной рассылки для каждого интерфейса (это может быть адрес локального сайта и один или несколько комбинируемых адресов глобальной одноадресной рассылки);
  • адрес замыкания на себя (::1) для интерфейса замыкания на себя.

Маршрутизатору IPv6 назначаются следующие адреса рассылки до первого получателя:

  • адрес рассылки до первого получателя для каждой подсети;
  • дополнительные адреса рассылки до первого получателя (необязательно).

Кроме того, каждый маршрутизатор прослушивает трафик на следующих адресах многоадресной рассылки:

  • адрес всех узлов в области локального узла (FF01::1);
  • адрес всех маршрутизаторов в области локального узла (FF01::2);
  • адрес всех узлов в области локальной связи (FF02::1);
  • адрес всех маршрутизаторов в области локальной связи (FF02::2);
  • адрес всех маршрутизаторов в области локального сайта (FF05::2);
  • адрес запроса узла для каждого адреса одноадресной рассылки на каждом интерфейсе;
  • адреса групп, присоединенных к каждому интерфейсу.


Идентификаторы интерфейса IPv6

Последние 64 бита адреса IPv6 представляют собой идентификатор интерфейса, уникальный для 64-битного префикса адреса IPv6. Идентификатор интерфейса определяется следующими способами:

  • согласно документу RFC 2373, все адреса одноадресной рассылки, использующие префиксы с 001 по 111, должны также использовать 64-битный идентификатор интерфейса, образованный из адреса EUI-64 (Extended Unique Identifier);
  • документ RFC 3041 описывает генерируемый случайным образом идентификатор интерфейса, изменяющийся со временем для обеспечения определенного уровня анонимности;
  • идентификатор интерфейса, назначаемый при автоматической настройке адреса с ведением базы данных (например, по протоколу DHCPv6). Стандарты DHCPv6 в настоящее время находятся на стадии определения. Протокол IPv6 для Windows XP не поддерживает настройку адресов с ведением базы данных или по протоколу DHCPv6.

Идентификаторы интерфейса на основе адресов EUI-64

64-разрядный адрес EUI-64 определен IEEE (Electrical and Electronic Engineers). Адреса EUI-64 либо назначаются сетевому адаптеру, либо выводятся из адресов IEEE 802.

Адреса IEEE 802

Традиционные идентификаторы интерфейсов для сетевых адаптеров используют 48-битный адрес, называемый адресом IEEE 802. Этот адрес состоит из 24-битного идентификатора компании (также называемого идентификатором изготовителя) и 24-битного идентификатора расширения (также называемого идентификатором платы). Сочетание уникального идентификатора компании, назначаемого каждому изготовителю сетевых адаптеров, и уникального идентификатора платы, назначаемого каждому сетевому адаптеру на этапе сборки, образует уникальный 48-битный адрес. Этот 48-битный адрес также называют физическим, аппаратным или MAC-адресом (Media Access Control).

Структура 48-битного адреса IEEE 802

В адресе IEEE 802 определены следующие биты.

  • Бит глобальности/локальности (U/L)

    • Бит U/L является седьмым в первом байте и используется для определения способа администрирования данного адреса (глобально или локально). Если бит U/L имеет значение 0, администрирование данного адреса осуществляет IEEE путем назначения идентификатора компании. Если бит U/L имеет значение 1, администрирование адреса осуществляется локально. Сетевой администратор переопределяет адрес, заданный изготовителем, и указывает другой адрес.

  • Бит отдельности/принадлежности к группе (I/G)

    • Бит I/G является битом низкого порядка в первом байте и используется для определения типа адреса: является ли он адресом одного узла (одноадресная рассылка) или адресом группы (многоадресная рассылка). Значение 0 указывает на то, что адрес используется для одноадресной рассылки. Значение 1 указывает на то, что адрес используется для многоадресной рассылки.

Для типичного адреса сетевого адаптера 802.x биты U/L и I/G имеют значение 0, что соответствует глобально администрируемому MAC-адресу одноадресной рассылки.

Адреса IEEE EUI-64

Адреса IEEE EUI-64 представляют новый стандарт адресации сетевых интерфейсов. Длина идентификатора компании по-прежнему составляет 24 бита, но идентификатор расширения имеет длину в 40 бит, что создает гораздо большее пространство адресов для изготовителей сетевых адаптеров. Адрес EUI-64 использует биты U/L и I/G точно так же, как адрес IEEE 802.

Структура адреса EUI-64

Сопоставление адресов IEEE 802 с адресами EUI-64

Для создания адреса EUI-64 из адреса IEEE 802 16 битов вида 11111111 11111110 (0xFFFE) вставляются в адрес IEEE 802 между идентификатором компании и идентификатором расширения. На следующем рисунке представлено преобразование адреса IEEE 802 в адрес EUI-64.

Преобразование адреса IEEE 802 в адрес EUI-64

Сопоставление адресов EUI-64 с идентификаторами интерфейсов IPv6

64-битный идентификатор интерфейса для адресов одноадресной рассылки IPv6 создается путем инвертирования бита U/L в адресе EUI-64 (значение 1 обращается в 0; значение 0 обращается в 1). На следующем рисунке показано преобразование глобально администрируемого адреса одноадресной рассылки EUI-64.

Преобразование глобально администрируемого адреса одноадресной рассылки EUI-64 в идентификатор интерфейса IPv6

Для получения идентификатора интерфейса IPv6 из адреса IEEE 802 необходимо сначала сопоставить этот адрес IEEE 802 с адресом EUI-64, а затем инвертировать бит U/L. На следующем рисунке показан процесс преобразования глобально администрируемого адреса одноадресной рассылки IEEE 802.

Преобразование глобально администрируемого адреса одноадресной рассылки IEEE 802 в идентификатор интерфейса IPv6

Пример преобразования адреса IEEE 802

Узел A имеет MAC-адрес Ethernet 00-AA-00-3F-2A-1C. Сначала этот адрес преобразуется в формат EUI-64 путем вставки разрядов FF-FE между третьим и четвертым байтами: 00-AA-00-FF-FE-3F-2A-1C. Затем инвертируется бит U/L (седьмой бит в первом байте). Первый байт в двоичном формате выглядит как 00000000. После выполнения операции дополнения седьмого бита первый байт принимает вид 00000010 (0x02). Конечный результат, 02-AA-00-FF-FE-3F-2A-1C, после преобразования в двоеточечно-шестнадцатеричную нотацию становится идентификатором интерфейса: 2AA:FF:FE3F:2A1C. Таким образом, сетевому адаптеру с MAC-адресом 00-AA-00-3F-2A-1C соответствует адрес локальной связи FE80::2AA:FF:FE3F:2A1C.

Примечание

  • При инвертировании бита U/L добавьте к первому байту 0x2, если администрирование адреса EUI-64 осуществляется глобально, и вычтите из первого байта 0x2, если администрирование адреса EUI-64 осуществляется локально.

Идентификаторы интерфейса анонимного адреса

В современном Интернете на базе протокола IPv4, обычный пользователь Интернета подключается к поставщику услуг Интернета и получает адрес IPv4 с использованием протоколов PPP (Point-to-Point Protocol) и IPCP (Internet Protocol Control Protocol). Адрес IPv4 может изменяться при каждом подключении данного пользователя. В связи с этим сложно отследить трафик пользователя в Интернете по IP-адресу.

При подключении удаленного доступа на базе протокола IPv6 после установки соединения пользователю назначается 64-битный префикс (путем обнаружения маршрутизатора и автонастройки адреса). Если идентификатор интерфейса всегда основан на адресе EUI-64 (полученном из статического адреса IEEE 802), то существует возможность определения трафика конкретного узла, независимо от его префикса, что облегчает отслеживание конкретных пользователей и использование ими Интернета. С учетом этого для обеспечения определенного уровня анонимности в документе RFC 3041описан альтернативный идентификатор интерфейса IPv6, генерируемый случайным образом и сменяемый с течением времени.

Исходный идентификатор интерфейса генерируется с использованием случайных чисел. Для систем IPv6, не способных хранить протокольные сведения для создания будущих значений идентификатора интерфейса, при каждой инициализации протокола IPv6 генерируется новый случайный идентификатор интерфейса. Для систем IPv6, имеющих возможность хранения протокольных сведений, при инициализации протокола IPv6 новый идентификатор интерфейса создается следующим образом:

  1. Загружается значение из хранилища протокольных сведений и добавляется к идентификатору интерфейса, основанному на адресе EUI-64 адаптера.
  2. Для величины, полученной на шаге 1, вычисляется хеш однопроходного шифрования MD5 (Message Digest-5).
  3. Последние 64 бита хеша MD5, вычисленного на шаге 2, сохраняются для вычисления следующего идентификатора интерфейса.
  4. Для седьмого из первых 64 бит хеша MD5, вычисленного на шаге 2, задается значение 0. Седьмым является бит U/L, нулевое значение которого задает локальное администрирование идентификатора интерфейса. Результат представляет собой идентификатор интерфейса.

Итоговый адрес IPv6, основанный на таком случайном идентификаторе интерфейса, называют анонимным адресом. Анонимные адреса создаются для префиксов общедоступных адресов, использующих автонастройку адресов без ведения базы данных. Анонимные адреса используются для меньшего из следующих значений срока жизни действительного и основного состояний адреса:

  • значения времени жизни, указанные в параметре «Prefix Information» полученного сообщения объявления маршрутизатора;
  • локальные значения времени жизни по умолчанию (1 неделя для действительного состояния и 1 день для основного состояния).

По истечении времени жизни действительного состояния генерируются новые идентификатор интерфейса и анонимный адрес.

Протокол IPv6 для Windows XP создает анонимные адреса для префиксов глобальных адресов по умолчанию. Этот режим можно изменить с помощью команды ipv6 gpu UseAnonymousAddresses. Дополнительные сведения см. в разделе Служебные программы IPv6.


Автонастройка адреса IPv6

Важным качеством протокола IPv6 является его способность настраиваться автоматически, без использования протокола настройки, ведущего базу данных, такого как DHCPv6 (Dynamic Host Configuration Protocol для IPv6). По умолчанию узел IPv6 может настраивать адреса локальной связи для каждого интерфейса. С помощью обнаружения маршрутизатора узел также может определять адреса маршрутизаторов, дополнительные адреса и другие параметры конфигурации. Сообщение объявления маршрутизатора содержит указание о том, следует ли использовать протокол настройки адресов с ведением базы данных.

Автонастройка адресов может выполняться только на интерфейсах, поддерживающих многоадресную рассылку. Автонастройка адресов описана в документе RFC 2462 «Автонастройка адресов IPv6 без ведения базы данных».

Состояния автонастраиваемых адресов

Автонастраиваемые адреса могут иметь одно или несколько из следующих состояний.

  • Пробный

    • Адрес находится в процессе проверки на уникальность. Проверка выполняется путем обнаружения дублирования адреса.

  • Основной

    • Адрес, уникальность которого подтверждена. Узел может использовать основной адрес для отправки и получения одноадресного трафика. Продолжительность времени, в течение которого адрес может оставаться пробным или основным, задается сообщением объявления маршрутизатора.

  • Устаревший

    • Адрес, остающийся действительным, но запрещенный для использования при создании новой связи. Существующие сеансы связи могут продолжать использование устаревшего адреса. Узел может использовать устаревший адрес для отправки и получения одноадресного трафика.

  • Действительный

    • Адрес, который может использоваться для отправки и приема одноадресного трафика. Действительными являются основные и устаревшие адреса. Продолжительность времени, в течение которого адрес может оставаться в пробном и действительном состояниях, задается сообщением объявления маршрутизатора. Время жизни действительного состояния адреса должно быть больше или равно времени жизни основного состояния адреса.

  • Недействительный

    • Адрес, который не может больше использоваться для отправки или получения одноадресного трафика. Адрес становится недействительным по завершении времени жизни действительного состояния.

Отношения между состояниями автонастраиваемого адреса, а также между временем жизни основного и действительного состояний показаны на следующем рисунке.

Состояния автонастраиваемого адреса и время их жизни

Примечание

  • За исключением адресов локальной связи, автонастройка адресов задается только для узлов, не являющихся маршрутизаторами. Настройка адресов и других параметров маршрутизаторов должна быть выполнена другими средствами (например, вручную).

Типы автонастройки

Существует три типа автонастройки.

  1. Без ведения базы данных

    2. Настройка адресов основана на получении сообщений объявления маршрутизатора. Эти сообщения содержат префиксы адресов и требуют, чтобы узлы не использовали специальный протокол настройки адресов.

  2. С ведением базы данных

    3. Для получения адресов и других параметров настройки используется протокол настройки адресов с ведением базы данных, такой как DHCPv6. Узел использует настройку адресов с ведением базы данных при получении сообщений объявления маршрутизатора, не содержащих префиксов адресов и требующих, чтобы узел использовал протокол настройки адресов с ведением базы данных. При отсутствии маршрутизаторов на локальной связи узел также будет использовать протокол настройки адресов с ведением базы данных.

  3. Смешанный

    4. Настройка основана на получении сообщений объявления маршрутизатора. Эти сообщения содержат префиксы адресов и предписывают узлам использовать протокол настройки адресов с ведением базы данных.

Адреса локальной связи настраиваются всегда при использовании всех типов автонастройки.

Процесс автонастройки

Процесс автонастройки адреса для узла IPv6 выглядит следующим образом.

  1. Выполняется получение пробного адреса на основе префикса пределов связи FE80::/64 и 64-разрядного идентификатора интерфейса.
  2. Выполняется обнаружение дублирования адреса для проверки уникальности пробного адреса локальной связи.
  3. В случае обнаружения дублирования адреса настройку узла необходимо выполнить вручную.
  4. Если дублирование адреса не будет обнаружено, пробный адрес локальной связи считается уникальным и действительным. В этом случае адрес локальной связи инициализируется для данного интерфейса. Сетевой адаптер регистрирует адрес уровня связи соответствующего запрашиваемого узла, используемый для многоадресной рассылки.

Для узла IPv6, не являющегося маршрутизатором, автонастройка адреса выполняется следующим образом.

  1. Узел отправляет сообщение запроса маршрутизатора.
  2. Если сообщение объявления маршрутизатора не получено, узел использует для получения адреса и других параметров протокол настройки адресов с ведением базы данных. Протокол IPv6 для Windows XP не поддерживает использование протокола настройки адресов с ведением базы данных.
  3. В случае получения сообщения объявления маршрутизатора на узле устанавливаются параметры, включенные в это сообщение.
  4. Для каждого включенного префикса адреса при автонастройке без ведения базы данных выполняются следующие действия.
    • Префикс адреса и соответствующий 64-разрядный идентификатор интерфейса используются для получения пробного адреса.
    • Выполняется обнаружение дублирования адреса для проверки уникальности пробного адреса.
      • Если пробный адрес используется, он не инициализируется для интерфейса.
      • Если пробный адрес не используется, он инициализируется. Это подразумевает задание времени жизни действительного и основного состояний на основе сведений, включенных в сообщение объявления маршрутизатора.
  5. Если сообщение объявления маршрутизатора содержит соответствующее указание, то для получения дополнительных адресов или параметров настройки узел использует протокол настройки адресов с ведением базы данных.

Важно!

  • XOX

Примечания

  • Стандарт IPv6 быстро развивается. Возможно, указанные документы RFC устарели после появления новых документов RFC.
  • Стандарты настройки адресов с ведением базы данных для IPv6 находятся в разработке. Протокол IPv6 для Windows XP не поддерживает настройку адресов с ведением базы данных или по протоколу DHCPv6.


Маршрутизация протокола IPv6

Маршрутизация — это процесс передачи пакетов между соединенными сегментами сети. Для сетей на базе протокола IPv6 маршрутизация представляет собой часть IPv6, обеспечивающую возможности пересылки пакетов между узлами, расположенными в разных сегментах крупной сети на базе протокола IPv6.

IPv6 служит средством сортировки и доставки данных для протокола более высокого уровня. Каждый входящий или исходящий пакет называется пакетом IPv6. Пакет IPv6 содержит адрес источника (отправляющего узла) и адрес назначения (принимающего узла). В отличие от адресов уровня связи, адреса IPv6 в заголовке IPv6 при перемещении пакета через сеть IPv6 обычно остаются неизменными.

Маршрутизация является основной функцией IPv6. Обмен пакетами IPv6 и их обработка на каждом узле выполняются протоколом IPv6, работающим на межсетевом уровне.

Над уровнем IPv6 транспортные службы узла-источника передают данные уровню IPv6 в виде TCP-сегментов или UDP-сообщений. Уровень IPv6 создает пакеты IPv6 со сведениями адресах источника и назначения, которые используются для маршрутизации данных в сети. Затем уровень IPv6 передает пакеты уровню связи, где пакеты IPv6 преобразуются в кадры для передачи по физическим носителям сети. На узле назначения эти действия выполняются в обратном порядке.

Службы уровня IPv6 на каждом узле анализируют адрес назначения каждого пакета, ищут этот адрес в локальной таблице маршрутизации и выбирают действие по ее дальнейшему перенаправлению. Маршрутизаторы IPv6 подключаются к двум или нескольким сегментам сети IPv6, между которыми требуется обеспечить перенаправление пакетов.

Маршрутизаторы IPv6

Сегменты сети IPv6, также называемые связями или подсетями, соединяются при помощи маршрутизаторов IPv6 — устройств, передающие пакеты IPv6 из одного сегмента сети в другой. Этот процесс, называемый маршрутизацией IPv6, показан на следующем рисунке.

Маршрутизация IPv6

Маршрутизаторы IPv6 предоставляют основные средства объединения нескольких физически раздельных сегментов сети IPv6. Все маршрутизаторы IPv6 имеют следующие характеристики.

  • Маршрутизаторы IPv6 являются узлами с несколькими сетевыми интерфейсами.

    Узел с несколькими сетевыми интерфейсами — это узел сети, использующий два или более сетевых интерфейсов для подключения к физически раздельным сегментам сети.

  • Маршрутизаторы IPv6 обеспечивают перенаправление пакетов для других узлов IPv6.

    Маршрутизаторы IPv6 отличаются от других узлов, использующих несколько сетевых интерфейсов. Маршрутизатор IPv6 должен уметь перенаправлять между сетями данные, передаваемые по протоколу IPv6 другими узлами IPv6.

Для внедрения маршрутизаторов IPv6 можно использовать различные аппаратные и программные продукты, в том числе компьютеры под управлением Windows XP с протоколом IPv6. Часто применяются специализированные аппаратные устройства, использующие специальное программное обеспечение. Независимо от типа задействованных маршрутизаторов IPv6, система маршрутизации IPv6 основана на использовании таблиц маршрутизации для связи между сегментами сети.

Таблицы маршрутизации

Узлы IPv6 используют таблицу маршрутизации, содержащую сведения о других сетях IPv6 и узлах IPv6. Сегменты сети определяются с помощью префикса сети IPv6 и длины префикса. Кроме того, таблицы маршрутизации предоставляют каждому локальному узлу важные сведения о том, как связаться с удаленными сетями и узлами.

Для любого компьютера в сети IPv6 можно создать и поддерживать таблицу маршрутизации, содержащую сведения обо всех остальных компьютерах и сетях, с которыми он поддерживает связь. Обычно такой подход не используется, а вместо него применяется маршрутизатор по умолчанию (основной маршрутизатор).

Перед отправкой пакета IPv6 компьютер вставляет в заголовок IPv6 адреса его источника и назначения (для получателя). Затем компьютер анализирует адрес назначения IPv6, ищет его в локальной таблице маршрутизации IPv6 и на основе результатов этого поиска выполняет соответствующее действие. На этом этапе выполняется одно из трех возможных действий:

  • передает пакет уровню протоколов локального узла, расположенному над уровнем IPv6;
  • пересылает пакет через один из подключенных сетевых интерфейсов;
  • отбрасывает пакет.

Протокол IPv6 просматривает таблицу маршрутизации в поисках маршрута, наиболее близкого к адресу назначения IPv6. По степени точности маршруты располагаются в следующем порядке (от наиболее точного к наименее точному):

  1. маршрут, совпадающий с адресом назначения IPv6 (маршрут к узлу со 128-битным префиксом);
  2. маршрут, совпадающий с назначением с наибольшей длиной префикса;
  3. маршрут по умолчанию (префикс сети ::/0).

Если совпадающий маршрут не найден, адрес назначения определяется в пределах локальной связи.

Дополнительные сведения см. в разделе Таблица маршрутизации IPv6.


Таблица маршрутизации протокола IPv6

Каждый компьютер, использующий протокол IPv6, определяет порядок пересылки пакетов по содержимому таблицы маршрутизации IPv6. Чтобы отобразить таблицу маршрутизации IPv6 на компьютере, работающем под управлением Windows XP, введите команду ipv6 rt в командной строке.

Записи в таблице маршрутизации IPv6 состоят из следующих элементов:

  • префикс адреса;
  • интерфейс, через который отправляются пакеты, соответствующие префиксу адреса;
  • адрес пересылки или следующего перехода;
  • значение предпочтения, используемое для выбора между несколькими маршрутами с одинаковым префиксом;
  • время жизни маршрута;
  • указание на то, является ли маршрут публикуемым (включается ли в сообщение объявления маршрутизатора);
  • указание на порядок устаревания маршрута;
  • тип маршрута.

Таблица маршрутизации IPv6 создается автоматически, на основании текущей конфигурации протокола IPv6 данного компьютера. При пересылке пакетов IPv6 компьютер выполняет в таблице маршрутизации поиск записи, наиболее точно соответствующей адресу назначения IPv6. Маршрут для префикса локальной связи (FE80::/64) не отображается.

Маршрут по умолчанию (маршрут с префиксом ::/0) обычно используется для пересылки пакетов IPv6 на маршрутизатор по умолчанию в локальной связи. Поскольку маршрутизатор, соответствующий маршрутизатору по умолчанию, содержит сведения о префиксах сети других подсетей IPv6 в крупной объединенной сети IPv6, он пересылает пакет на другие маршрутизаторы до тех пор, пока пакет не будет доставлен по назначению.

Сведения об управлении маршрутами IPv6 см. в разделе Управление маршрутами.


Разрешение имен

Протокол IPv6 работает с 128-битными адресами IPv6 узла-источника и узла-приемника, а компьютеры используются людьми, которым трудно запоминать цифровые адреса IPv6. Вместо них можно использовать легко запоминаемые имена.

Если имя служит псевдонимом адреса IPv6, необходимо обеспечить уникальность этого имени и правильно сопоставить с ним соответствующий адрес IPv6. Протокол IPv6, встроенный в Windows XP, может использовать имена компьютеров для сопоставления их с адресами IPv6. Имена компьютеров используются программами, работающими по стандарту Windows Sockets.

Разрешение имени компьютера — это процесс определения адреса IPv6 компьютера по его имени. Имя компьютера является псевдонимом, назначенным узлу IPv6, идентифицирующему компьютер IPv6. Имя компьютера может иметь длину до 255 знаков и содержать буквы, цифры, дефисы и точки. Одному компьютеру можно присвоить несколько имен.

Программы Windows Sockets (Winsock) могут использовать одно из двух значений для конечного компьютера, к которому требуется подключиться: адрес IPv6 или имя компьютера. Если используется адрес IPv6, необходимость в разрешении имени отпадает. Если же указывается имя компьютера, то для установления соединения с ним по протоколу IPv6 необходимо сначала определить по имени компьютера его адрес IPv6.

Имена компьютеров могут иметь различные формы. Две наиболее популярные формы — понятное имя и доменное имя. Понятное имя — это псевдоним адреса IPv6, который могут назначать и использовать отдельные пользователи. Доменное имя — это структурированное имя в иерархическом пространстве имен, называемом системой доменных имен (Domain Name System — DNS). Примером доменного имени может служить www.microsoft.com.

Понятные имена и доменные имена разрешаются с помощью записей в файле , который хранится в папке «системный_корневой_каталог\System32\Drivers\Etc». В записях, служащих для определения адреса IPv6 по имени, адреса IPv6 написаны в стандартном двухточечно-шестнадцатеричном формате. Дополнительные сведения см. в разделах Формат адресов IPv6 и Файлы базы данных TCP/IP.

Доменные имена разрешаются путем отправки запросов имен DNS на настроенный DNS-сервер, который представляет собой компьютер, хранящий записи сопоставления доменных имен и адресов IPv6 или записи других DNS-серверов. DNS-сервер разрешает доменное имя в адрес IPv6 и возвращает результат этого разрешения. DNS-клиент Windows XP поддерживает обработку записей ресурсов AAAA (четыре A). Все запросы и ответы DNS-серверов отправляются в формате протокола IPv4. Из-за этого в параметрах протокола Интернета (TCP/IP) необходимо задать IP-адрес (адрес IPv4) DNS-сервера. Также поддерживается регрессия полных доменных имен. Дополнительные сведения см. в разделе Настройка параметров клиента.

Дополнительные сведения см. в разделе Вводные сведения о DNS.


Приложения для протокола IPv6 и сетевые приложения

В этом разделе собраны сведения по следующим вопросам.

  • Поддержка Windows Sockets
  • Приложения для протокола IPv6


Поддержка Windows Sockets

Изменения в существующих функциях Windows Sockets для протокола IPv6 содержатся в документе RFC 2553 «Основные расширения интерфейса сокетов для IPv6». Протокол IPv6, встроенный в Windows XP, поддерживает RFC 2553 со следующими исключениями.

  • В Windows XP не поддерживаются файлы заголовка, описанные в RFC. В Windows XP используются файлы заголовка Winsock2.h и Ws2tcpip.h.
  • Структура сокета Windows XP не включает член sa_len. Такие образом, раздел 3.3 применим, а раздел 3.4 — нет.
  • Не поддерживаются адреса, сопоставленные IPv4, как описано в разделе 3.7.
  • Не поддерживаются функции идентификации интерфейса, описанные в разделе 4.
  • Разделы с 6.1 по 6.3 и 6.6 не поддерживаются, так как они будут исключены силами IETF (Internet Engineering Task Force).

Средства разработки приложений, поддерживающих протокол IPv6

Для разработки приложений, поддерживающих Winsock IPv6, требуются следующие средства.

  • SDK платформы Microsoft (январь 2000 или более поздняя версия)
  • Microsoft Visual C++ 6.0
  • Протокол IPv6 для Windows XP


Приложения для протокола IPv6

Windows XP включает следующие приложения, поддерживающие протокол IPv6.

  • Клиент FTP

    • Клиент FTP (ftp.exe) служит для установки сеансов FTP с FTP-серверами по протоколу IPv4 или IPv6.

  • Клиент Telnet

    • Клиент Telnet (telnet.exe) служит для установки сеансов Telnet с серверами Telnet по протоколу IPv4 или IPv6.

  • Internet Explorer

    • Новая библиотека Интернет-расширений wininet.dll позволяет веб-обозревателям обращаться к веб-серверам по протоколу IPv6. Например, библиотека wininet.dll используется обозревателем Microsoft Internet Explorer для подключения к веб-серверу для просмотра веб-страниц. Internet Explorer использует протокол IPv6 для загрузки веб-страниц, когда запрос к DNS (Domain Name System) по имени веб-сервера из адреса URL возвращает адрес IPv6.

    Адреса URL, которые используют формат литеральных адресов IPv6, описанный в документе RFC 2732 «Формат литеральных адресов IPv6 в адресах URL», не поддерживаются в версии обозревателя Internet Explorer, поставляемого с Windows XP.

    Список веб-узлов, поддерживающих только протокол IPv6, содержится на веб-узле IPv6. Для доступа к веб-узлам, поддерживающим только протокол IPv6, необходимо, чтобы с локального компьютера можно было подключаться к сети 6bone, являющейся сегментом Интернета, в котором используется протокол IPv6. Дополнительные сведения о подключении к 6bone см. в разделе Подключение к 6bone.

Кроме того, протокол IPv6 поддерживают компоненты удаленного вызова процедур (RPC) Windows XP, а версии сетевого монитора, входящие в состав Windows 2000 и Systems Management Server 2.0, поддерживают обработку заголовков IPv6.

Важно!

  • XOX

Примечания

  • XOX
  • Если Internet Explorer настроен на использование прокси-сервера, просмотр веб-узлов IPv6 с помощью него будет невозможен. Если Internet Explorer настроен на использование прокси-сервера, все запросы разрешения имен веб-узлов направляются на прокси-сервер. Если прокси-сервер не поддерживает протокол IPv6, проходящие через него запросы локальных или удаленных веб-страниц IPv6 удовлетворяться не будут. Сведения о настроке Internet Explorer для работы без использования прокси-сервера см. в справке Internet Explorer.


Проверка протокола IPv6

В этом разделе собраны сведения по следующим вопросам.

  • Элементы конфигурации протокола IPv6
  • Методы настройки конфигурации протокола IPv6
  • Конфигурации протокола IPv6
  • Настройка тестовой лаборатории для протокола IPv6


Элементы конфигурации протокола IPv6

Протокол IPv6 для Windows XP допускает настройку следующих элементов:

  • адрес IPv6;
  • маршрутизатор по умолчанию.

Для разрешения имен узлов в адреса IPv6 необходимо добавить в инфраструктуру DNS записи ресурсов AAAA (четыре A) и указать в окне Свойства: Протокол Интернета (TCP/IP) IP-адрес по крайней мере одного DNS-сервера.

Адрес IPv6

По умолчанию для каждого интерфейса на каждом узле IPv6 (включая маршрутизаторы) автоматически настраиваются уникальные адреса локальной связи IPv6. Для обмена данными с узлами IPv6, находящихся за пределами локальной связи, узел должен иметь дополнительный адрес локального сайта или глобальный адрес одноадресной рассылки. Дополнительные адреса для узлов либо создаются на основе рассылаемых маршрутизатором объявлений маршрутизатора, либо назначаются вручную. Дополнительные адреса для маршрутизаторов необходимо назначать вручную.

Дополнительные сведения см. в разделах Адреса IPv6 для одноадресной рассылки, Настройка IPv6 с вводом адресов вручную и Автонастройка адреса IPv6.

Маршрутизатор по умолчанию

Для обмена данными с узлами IPv6 в других сегментах сети протокол IPv6 должен использовать маршрутизатор по умолчанию. Маршрутизатор по умолчанию назначается автоматически при получении объявления маршрутизатора. Другим способом является добавление маршрута по умолчанию в таблицу маршрутизации IPv6. Для сетей, состоящих только из одного сегмента, задавать адрес маршрутизатора по умолчанию не требуется.

Дополнительные сведения см. в разделах Автонастройка адреса IPv6 и Добавление маршрута IPv6.

DNS-сервер

DNS-сервер разрешает имена узлов в адреса IPv6. Когда на узле IPv6 задан адрес DNS-сервера, узел IPv6 отправляет запросы на разрешение имен DNS указанному DNS-серверу. Сопоставление имен узлов адресам IPv6 обеспечивается с помощью записей ресурсов AAAA (четыре A), хранящихся на DNS-серверах.

Протокол IPv6 для Windows XP использует для отправки всего трафика запросов и ответов DNS протокол IPv4, даже при разрешении адресов IPv6. Адреса DNS-серверов задаются в свойствах протокола Протокол Интернета (TCP/IP) в компоненте «Сетевые подключения». Сопоставления имен узлов с адресами IPv6 также можно поместить в файл Hosts.

Дополнительные сведения см. в разделах Разрешение имен и Настройка TCP/IP на использование DNS.

В качестве DNS-сервера, хранящего записи AAAA, можно настроить компьютер с операционной системой Windows 2000 Server. Дополнительные сведения см. в разделе DNS (Domain Name System).


Методы настройки конфигурации протокола IPv6

Протокол IPv6 для Windows XP предусматривает следующие методы настройки.

  • Автоматическая настройка адресов без ведения базы данных
  • Настройка вручную

Автоматическая настройка

Протокол IPv6 для Windows XP поддерживает автонастройку адреса без ведения базы данных, как это описано в документе RFC 2462 «Автонастройка адресов IPv6 без ведения базы данных». Узлы IPv6 (включая маршрутизаторы) автоматически создают уникальные адреса локальной связи для всех интерфейсов локальной сети, являющихся интерфейсами Ethernet. Сообщения объявлений маршрутизатора используются узлами IPv6 для автоматической настройки следующих параметров.

  • Основного маршрутизатора.
  • Значения для использования по умолчанию в поле Hop Limit (максимальное количество переходов) заголовка IPv6.
  • Режима настройки адресов без ведения базы данных с использованием протокола DHCPv6 (DHCP для IPv6) или с ведением базы данных. Протокол IPv6 для Windows XP не поддерживает настройку адресов с ведением базы данных или по протоколу DHCPv6.
  • Таймеров, используемых в процессе изучения окружения (Neighbor Discovery).
  • Максимального размера блока данных (MTU) локальной связи.
  • Списка префиксов сети, определенных для данной связи. Каждый префикс сети содержит как префикс сети IPv6, так и его время жизни действительного и основного состояний. Если указано, из префикса сети и идентификатора интерфейса создается адрес IPv6 получающего интерфейса без ведения базы данных. Префикс сети также определяет диапазон адресов для узлов в локальной связи.

Дополнительные сведения см. в разделе Автонастройка адреса IPv6.

Кроме того, протокол IPv6 для Windows XP позволяет автоматически настраивать следующие параметры.

  • IPv4-совместимые адреса в автоматическом туннельном интерфейсе.
  • Адреса 6to4 в туннельном интерфейсе 6to4 для всех общедоступных адресов IPv4, назначенных компьютеру.
  • Адреса ISATAP (Automatic Tunnel Addressing Protocol) автоматического интерфейса для всех адресов IPv4, назначенных компьютеру.
  • Маршруты к префиксам удаленной связи (если префикс адреса удаленной связи объявлен маршрутизатором, работающим под управлением Windows XP).

Настройка вручную

Адреса и маршруты IPv6 можно настраивать вручную, используя средство командной строки Ipv6.exe. Конфигурация вручную может требоваться в сети, включающей несколько сегментов IPv6, маршрутизаторы IPv6 в которых не настроены на отправку объявлений маршрутизаторов.

Дополнительные сведения см. в разделах Настройка IPv6 с вводом адресов вручную и Добавление маршрута IPv6.


Конфигурации протокола IPv6

В этом разделе собраны сведения по следующим вопросам.

  • Подсеть с адресами локальной связи
  • Использование IPSec между двумя узлами локальной связи
  • Трафик IPv6 между узлами в разных подсетях объединенной сети IPv6
  • Трафик IPv6 между узлами в разных подсетях объединенной сети IPv4
  • Трафик IPv6 между узлами в различных сайтах через Интернет (6to4)
  • Подключение к сети 6bone


Подсеть с адресами локальной связи

Данная конфигурация требует установки протокола IPv6 по крайней мере на два узла в одном сегменте сети (также называемом связью или подсетью) без промежуточных маршрутизаторов.

Настройка адресов локальной связи на двух узлах одной подсети показана на следующем рисунке.

Использование адресов локальной связи двумя узлами одной подсети

По умолчанию протокол IPv6 для Windows XP настраивает адреса локальной связи для каждого интерфейса, соответствующего установленным сетевым адаптерам Ethernet. У адресов локальной связи префикс имеет вид FE80::/64. Последние 64 бита адреса IPv6 называются идентификатором интерфейса. Он создается на основе 48-битного MAC-адреса сетевого адаптера. Дополнительные сведения см. в разделе Идентификаторы интерфейса IPv6.

Для создания идентификатора интерфейса IPv6 из 48-битного (6-байтного) MAC-адреса Ethernet:

  • между третьим и четвертым байтами MAC-адреса вставляются шестнадцатеричные разряды 0xFF-FE;
  • инвертируется бит глобальности/локальности (второй бит низкого порядка в первом байте MAC-адреса). Значение 1 обращается в 0, а значение 0 — в 1.

Например, для MAC-адреса 00-60-08-52-F9-D8:

  • между 0x08 (третий байт) и 0x52 (четвертый байт) MAC-адреса вставляются шестнадцатеричные разряды 0xFF-FE, образуя 64-битный адрес 00-60-08-FF-FE-52-F9-D8;
  • в первом байте (0x00) MAC-адреса инвертируется бит глобальности/локальности (второй бит низкого порядка). Второй младший бит байта 0x00 равен 0, а после операции дополнения становится равным 1. В результате первый байт 0x00 превращается в 0x02.

Таким образом, идентификатор интерфейса IPv6, соответствующий MAC-адресу Ethernet 00-60-08-52-F9-D8, имеет значение 02-60-08-FF-FE-52-F9-D8.

Адрес локальной связи узла представляет собой сочетание префикса FE80::/64 и 64-разрядного идентификатора интерфейса в двухточечно-шестнадцатеричной нотации. В данном примере адрес локальной связи узла с префиксом FE80::/64 и идентификатором интерфейса 02-60-08-FF-FE-52-F9-D8 имеет вид FE80::260:8FF:FE52:F9D8.

Адрес локальной связи можно просмотреть с помощью команды ipv6 if, как показано в следующем примере.

интерфейс 4: Ethernet: Подключение по локальной сети
  используется поиск соседей
  адрес уровня связи: 00-b0-d0-23-47-33
    preferred link-local fe80::2b0:d0ff:fe23:4733, время жизни infinite
    многоадр. рассылка interface-local ff01::1, 1 ссылок, нет отчета
    многоадр. рассылка link-local ff02::1, 1 ссылок, нет отчета
    многоадр. рассылка link-local ff02::1:ff23:4733, 1 ссылок, последний отчет, 6 seconds until report
  MTU-связь 1500 (истинная MTU-связь 1500)
  текущий предел переходов 128
  достижимое время 36500мс (базовое 30000мс)
  интервал повтора передачи 1000мс
  DAD-передач 1
интерфейс 3: Псевдоинтерфейс 6to4-туннелирования
  не используется поиск соседей
    preferred global 2002:9d3c:89d9::9d3c:89d9, время жизни infinite
  MTU-связь 1280 (истинная MTU-связь 65515)
  текущий предел переходов 128
  достижимое время 0мс (базовое 0мс)
  интервал повтора передачи 0мс
  DAD-передач 0
интерфейс 2: Псевдоинтерфейс автоматического туннелирования
  не используется поиск соседей
    preferred link-local fe80::200:5efe:157.60.137.217, время жизни infinite
    preferred global ::157.60.137.217, время жизни infinite
  MTU-связь 1280 (истинная MTU-связь 65515)
  текущий предел переходов 128
  достижимое время 0мс (базовое 0мс)
  интервал повтора передачи 0мс
  DAD-передач 0
интерфейс 1: Псевдоинтерфейс замыкания на себя
  не используется поиск соседей
  адрес уровня связи:
    preferred link-local ::1, время жизни infinite
    preferred link-local fe80::1, время жизни infinite
  MTU-связь 1500 (истинная MTU-связь 1500)
  текущий предел переходов 128
  достижимое время 40500мс (базовое 30000мс)
  интервал повтора передачи 1000мс
  DAD-передач 1

Интерфейс Interface 4 соответствует установленному адаптеру Ethernet с адресом локальной связи FE80::2B0:D0FF:FE23:4733.

Проверка связи между двумя узлами локальной связи

Для простой проверки связи (обмена сообщениями эхо-запроса и эхо-ответа ICMPv6) между двумя узлами локальной связи по протоколу IPv6 выполните следующие действия.

  1. Для установки протокола IPv6 на двух узлах с операционной системой Windows XP (узлы A и Б), подключенных к одной связи (подсети), выполните в командной строке команду ipv6 install.
  2. Выполните на узле A команду ipv6 if для получения адреса локальной связи и идентификатора интерфейса для интерфейса Ethernet.

    3. Например, адрес локальной связи узла A — FE80::210:5AFF:FEAA:20A2, идентификатор интерфейса Ethernet — 4.

  3. Выполните на узле Б команду ipv6 if для получения адреса локальной связи и идентификатора интерфейса для интерфейса Ethernet.

    4. Например, адрес локальной связи узла Б — FE80::260:97FF:FE02:6EA5, идентификатор интерфейса Ethernet — 3.

  4. Воспользуйтесь командой Ping6.exe на узле A для проверки связи с узлом Б.

    5. Например: ping6 FE80::260:97FF:FE02:6EA5%4

При указании адреса локальной связи или локального сайта в качестве адреса назначения следует указать идентификатор области, чтобы обозначить область (часть сети) для трафика.

  • Например, на компьютере с несколькими адаптерами Ethernet, подключенными к различным связям, адреса локальной связи назначаются каждому из адаптеров Ethernet. Конечный адрес локальной связи при такой конфигурации будет неоднозначным, поскольку конкретный адрес локальной связи может быть назначен нескольким узлам, расположенным на связях, доступных со всех установленных адаптеров Ethernet. Для определения области сети, в которой находится адрес назначения, используется идентификатор области, указывающий адаптер Ethernet, через который отправляется и принимается трафик. В протоколе IPv6 для Windows XP идентификатором области является идентификатор интерфейса, отображаемый с помощью команды ipv6 if. Идентификатор интерфейса определяется локально на каждом узле IPv6. В связи с этим идентификатор интерфейса, используемый узлом А для достижения узла Б, и идентификатор интерфейса, используемый узлом Б для достижения узла А, могут различаться.
  • При использовании адресов локальной связи имеется возможность подключения к нескольким сайтам. В этом случае каждому сайту назначается идентификатор сайта. Для определения области сети, в которой находится адрес назначения, используется идентификатор области, указывающий идентификатор сайта. В протоколе IPv6 для Windows XP идентификатором области является идентификатор сайта, отображаемый с помощью команды ipv6 if. При подключении только к одному сайту используется идентификатор сайта по умолчанию (1), а указывать идентификатор области не требуется. Идентификатор сайта определяется локально на каждом узле IPv6. В связи с этим идентификатор сайта, используемый узлом А для достижения узла, Б и идентификатор сайта, используемый узлом Б для достижения узла А, могут различаться.

Для указания идентификатора области в адресе используется следующая форма: Адрес%Идентификатор области.

Дополнительные сведения о конфигурациях см. в разделе Конфигурации протокола IPv6.

Сведения об использовании протокола IPv6 в тестовой лаборатории см. в разделе Настройка тестовой лаборатории для протокола IPv6.


Использование IPSec между двумя узлами локальной связи

Эта конфигурация создает сопоставление безопасности (SA) IPSec между двумя узлами одной подсети. SA выполняет проверку подлинности, используя заголовок проверки подлинности (AH) и алгоритм хеширования MD5 (Message Digest 5). В данном примере создается конфигурация, защищающая весь трафик между двумя соседними узлами. Узел 1 имеет адрес локальной связи FE80::2AA:FF:FE53:A92C, а узел 2 — адрес локальной связи FE80::2AA:FF:FE92:D0F1.

  1. С помощью команды ipsec6 s создайте на узле 1 пустые файлы сопоставления безопасности (.sad) и политики безопасности (.spd). В этом примере команда ipsec6.exe имеет вид ipsec6 s test. Она создает два файла с пустыми записями для настройки сопоставлений безопасности (Test.sad) и политик безопасности (Test.spd) вручную.
  2. На узле 1 измените SPD-файл, добавив политику безопасности, защищающую весь трафик между узлом 1 и узлом 2.

    3. В следующей таблице показана запись политики безопасности, которая добавляется в файл Test.spd перед первой записью (первая запись в Test.spd не изменяется).

    Имя поля в SPD-файле | Пример значения
Policy | 2
RemoteIPAddr | - FE80::2AA:FF:FE92:D0F1
LocalIPAddr | - *
Protocol | - *
RemotePort | - *
LocalPort | - *
IPSecProtocol | AH
IPSecMode | TRANSPORT
RemoteGWIPAddr | *
SABundleIndex | NONE
Direction | BIDIRECT
Action | APPLY
InterfaceIndex | 0

    Введите точку с запятой в конце записи, настраивающей данную политику безопасности. Записи политики должны быть расположены в порядке убывания цифровой последовательности.

  3. Измените SPD-файл на узле 1, добавив записи SA для защиты всего трафика между узлами 1 и 2. Необходимо создать два сопоставления безопасности: по одному для входящего и исходящего трафика узла 2.

    4. В следующей таблице показана запись первого сопоставления безопасности, добавляемая в файл Test.sad (для входящего трафика на узел 2).

    Имя поля в SAD-файле | Пример значения
SAEntry | 2
SPI | 3001
SADestIPAddr | FE80::2AA:FF:FE92:D0F1
DestIPAddr | POLICY
SrcIPAddr | POLICY
Protocol | POLICY
DestPort | POLICY
SrcPort | POLICY
AuthAlg | HMAC-MD5
KeyFile | Test.key
Direction | OUTBOUND
SecPolicyIndex | 2

    В конце записи, настраивающей данное сопоставления безопасности, введите точку с запятой.

    В следующей таблице показана запись второго сопоставления безопасности, добавляемая в файл Test.sad (для исходящего трафика с узла 2).

    Имя поля в SAD-файле | Пример значения
SAEntry | 1
SPI | 3000
SADestIPAddr | FE80::2AA:FF:FE53:A92C
DestIPAddr | POLICY
SrcIPAddr | POLICY
Protocol | POLICY
DestPort | POLICY
SrcPort | POLICY
AuthAlg | HMAC-MD5
KeyFile | Test.key
Direction | INBOUND
SecPolicyIndex | 2

    В конце записи, настраивающей данное сопоставления безопасности, введите точку с запятой. Записи сопоставлений безопасности должны располагаться в порядке убывания номеров.

  4. На узле 1 создайте файл, который содержит данные, используемые для создания и проверки созданного на основе ключей хеша MD5 для каждого пакета, защищенного IPSec, который передается на узел 2. В этом примере используется текстовый файл. Создается файл test.key, содержащий текст This is a test. Лишние символы, пробелы или строки отсутствуют.

    5. Протокол IPv6 для Windows XP поддерживает для сопоставлений безопасности быстрого режима (также называемых сопоставлениями безопасности IPSec или этапа II) только ключи, настроенные вручную, поскольку согласование основного режима посредством обмена ключами в Интернете (Internet Key Exchange, IKE) не выполняется. Настройка ключей вручную выполняется путем создания файлов, содержащих текст или двоичные данные ключа. В данном примере для сопоставлений безопасности в обоих направлениях используется один и тот же ключ. Для обоих сопоставлений безопасности (входящего и исходящего) можно использовать различные ключи. Для этого следует создать различные файлы ключа и указать их в поле KeyFile SAD-файла.

  5. С помощью команды ipsec6 s создайте на узле 2 пустые файлы сопоставления безопасности (.sad) и политики безопасности (.spd). В этом примере команда ipsec6.exe имеет вид ipsec6 s test. Она создает два файла с пустыми записями для настройки сопоставлений безопасности (Test.sad) и политик безопасности (Test.spd) вручную.

    6. Чтобы упростить этот пример, на узле 2 для SAD- и SPD-файлов используются те же самые имена. На каждом узле можно использовать различные имена файлов.

  6. На узле 2 измените SPD-файл, добавив политику безопасности, защищающую весь трафик между узлом 2 и узлом 1.

    7. В следующей таблице показана запись политики безопасности, которая добавляется в файл Test.spd перед первой записью (первая запись в Test.spd не изменяется).

    Имя поля в SPD-файле | Пример значения
Policy | 2
RemoteIPAddr | - FE80::2AA:FF:FE53:A92C
LocalIPAddr | - *
Protocol | - *
RemotePort | - *
LocalPort | - *
IPSecProtocol | AH
IPSecMode | TRANSPORT
RemoteGWIPAddr | *
SABundleIndex | NONE
Direction | BIDIRECT
Action | APPLY
InterfaceIndex | 0

    Введите точку с запятой в конце записи, настраивающей данную политику безопасности. Записи политики должны быть расположены в порядке убывания цифровой последовательности.

  7. Измените SPD-файл на узле 2, добавив записи SA для защиты всего трафика между узлами 1 и 2. Необходимо создать два сопоставления безопасности: по одному для входящего и исходящего трафика узла 1.

    8. В следующей таблице показана запись первого сопоставления безопасности, добавляемая в файл Test.sad (для входящего трафика на узел 1).

    Имя поля в SAD-файле | Пример значения
SAEntry | 2
SPI | 3001
SADestIPAddr | FE80::2AA:FF:FE53:A92C
DestIPAddr | POLICY
SrcIPAddr | POLICY
Protocol | POLICY
DestPort | POLICY
SrcPort | POLICY
AuthAlg | HMAC-MD5
KeyFile | Test.key
Direction | OUTBOUND
SecPolicyIndex | 2

    В конце записи, настраивающей данное сопоставления безопасности, введите точку с запятой.

    В следующей таблице показана запись второго сопоставления безопасности, добавляемая в файл Test.sad (для исходящего трафика с узла 1).

    Имя поля в SAD-файле | Пример значения
SAEntry | 1
SPI | 3000
SADestIPAddr | FE80::2AA:FF:FE92:D0F1
DestIPAddr | POLICY
SrcIPAddr | POLICY
Protocol | POLICY
DestPort | POLICY
SrcPort | POLICY
AuthAlg | HMAC-MD5
KeyFile | Test.key
Direction | INBOUND
SecPolicyIndex | 2

    В конце записи, настраивающей данное сопоставления безопасности, введите точку с запятой. Записи сопоставлений безопасности должны располагаться в порядке убывания номеров.

  8. На узле 2 создайте текстовый файл, который содержит строку текста, используемую для проверки подлинности сопоставлений безопасности, созданных на узле 1. В этом примере создается файл Test.key со строкой This is a test. Лишние символы, пробелы или строки отсутствуют.
  9. На узле 1 воспользуйтесь командой ipsec6 l для добавления настроенных политик безопасности и сопоставлений безопасности из SPD- и SAD-файлов. В данном примере команда ipsec6 l test выполняется на узле 1.
  10. На узле 2 воспользуйтесь командой ipsec6 l для добавления настроенных политик безопасности и сопоставлений безопасности из SPD- и SAD-файлов. В данном примере команда ipsec6 l test выполняется на узле 2.
  11. Выполните на узле 2 команду ping6 для проверки связи с узлом 1.

    12. При использовании сетевого монитора для записи трафика можно наблюдать обмен сообщениями эхо-запроса и эхо-ответа ICMPv6 с заголовком проверки подлинности AH (Authentication Header) между заголовком IPv6 и заголовком ICMPv6.

Дополнительные сведения о конфигурациях см. в разделе Конфигурации протокола IPv6.

Сведения об использовании протокола IPv6 в тестовой лаборатории см. в разделе Настройка тестовой лаборатории для протокола IPv6.


Трафик IPv6 между узлами в разных подсетях объединенной сети IPv6

Для данной конфигурации требуются три компьютера (двух узла и один маршрутизатор) и дополнительная настройка маршрутизатора (помимо установки протокола IPv6). Она предусматривает два отдельных сегмента сети (также называемые связями или подсетями) и IPv6-совместимый маршрутизатор, пересылающий пакеты IPv6 между узлами в этих сегментах.

На следующем рисунке показана конфигурация из двух узлов в отдельных сегментах сети, соединенных маршрутизатором.

Два узла в отдельных сегментах сети, соединенных маршрутизатором

По умолчанию протокол IPv6 для Windows XP настраивает адреса локальной связи для каждого интерфейса, соответствующего установленным сетевым адаптерам Ethernet. У адресов локальной связи префикс имеет вид FE80::/64. Последние 64 бита адреса IPv6 называются идентификатором интерфейса и получены из 48-битного MAC-адреса сетевого адаптера. Дополнительные сведения см. в разделе Идентификаторы интерфейса IPv6. Используя адреса локальной связи, узлы A и Б могут обмениваться данными с маршрутизатором, но не друг с другом.

В данной конфигурации маршрутизатор объявляет дополнительные префиксы локального сайта. Префиксы локального сайта используются узлами A и Б для автоматической настройки адресов локального сайта, получаемых из 48-битного MAC адреса сетевого адаптера. После получения адресов локального сайта узлы A и Б могут обмениваться данными друг с другом.

На компьютере маршрутизатора введите команду ipv6 if для получения номеров индекса интерфейса двух сетевых адаптеров Ethernet. Подсеть 1 — это сегмент сети, к которому подключен узел A. Подсеть 2 — это сегмент сети, к которому подключен узел Б.

После получения номеров индекса интерфейса введите на компьютере маршрутизатора следующие команды:

ipv6 ifc ИндексИнтерфейсаПодсети1 forwards advertises

ipv6 ifc ИндексИнтерфейсаПодсети2 forwards advertises

ipv6 rtu FEC0:0:0:1::/64 ИндексИнтерфейсаПодсети1 publish

ipv6 rtu FEC0:0:0:2::/64 ИндексИнтерфейсаПодсети2 publish

где:

  • ИндексИнтерфейсаПодсети1 — индекс интерфейса адаптера маршрутизатора, подключенного к подсети 1;
  • ИндексИнтерфейсаПодсети2 — индекс интерфейса адаптера маршрутизатора, подключенного к подсети 2.

Например, если индексы интерфейсов подсети 1 и подсети 2 на маршрутизаторе равны 4 и 3 соответственно, используются команды

ipv6 ifc 4 forwards advertises

ipv6 ifc 3 forwards advertises

ipv6 rtu FEC0:0:0:1::/64 4 publish

ipv6 rtu FEC0:0:0:2::/64 3 publish

Следует подождать около 30 секунд, пока маршрутизатор объявит новые префиксы локального сайта в подсетях 1 и 2, а адреса локального сайта для узлов A и Б будут автоматически настроены с использованием этих префиксов.

В узле A введите команду ipv6 if, чтобы проверить наличие нового адреса IPv6 для адаптера Ethernet, который основан на префиксе локального сайта вида FEC0:0:0:1::/64. В узле Б введите команду ipv6 if, чтобы проверить наличие нового адреса IPv6 для адаптера Ethernet, который основан на префиксе локального сайта вида FEC0:0:0:2::/64.

На узле A используйте команду ping6 и адрес локального сайта узла Б для проверки узла Б. Например, если адрес локального узла Б имеет вид FEC0::2:260:97FF:FE02:6EA5, команда будет выглядеть так: ping6 FEC0::2:260:97FF:FE02:6EA5.

Дополнительные сведения о конфигурациях см. в разделе Конфигурации протокола IPv6.

Сведения об использовании протокола IPv6 в тестовой лаборатории см. в разделе Настройка тестовой лаборатории для протокола IPv6.


Трафик IPv6 между узлами в разных подсетях объединенной сети IPv4

Протокол IPv6 для Windows XP предоставляет следующие методы обмена данными между узлами IPv6 в разных подсетях объединенной сети IPv4.

  • Использование IPv4-совместимых адресов
  • Использование адресов ISATAP
  • Использование 6over4

    • 6over4 требует, чтобы объединенная сеть IPv4 поддерживала многоадресную рассылку. Поскольку большинство сетей IPv4 не поддерживает многоадресную рассылку, 6over4 используется редко. Дополнительные сведения о 6over4 см. в разделе Возможности протокола IPv6 для Windows XP и документе RFC 2529.

  • Использование 6to4

    • Хотя основным назначением 6to4 является обеспечение обмена данными между отдельными сайтами 6to4, поддерживающими IPv6, узлы 6to4, использующие протокол IPv6 для Windows XP, также могут использовать адреса 6to4 и туннелирование 6to4 для обмена данными через интрасеть IPv4 или Интернет. Дополнительные сведения см. в разделе Трафик IPv6 между узлами в различных сайтах через Интернет (6to4).

Во всех перечисленных случаях трафик IPv6 передается в качестве полезных данных пакетов IPv4 (инфраструктура IPv4 используется как уровень связи IPv6), но все же остается трафиком IPv6. Приложения, использующие адреса, связанные с этими методами, используют те же функции Windows Sockets, что и при использовании глобальных адресов IPv6 и инфраструктуры IPv6. Эти методы можно использовать для проверки функциональности IPv6 для приложений без развертывания маршрутизаторов IPv6 в организации.

Использование IPv4-совместимых адресов

IPv4-совместимые адреса, получаемые из общедоступных адресов IPv4, обеспечивают метод для подключения узлов или сайтов IPv6 с использованием существующей инфраструктуры Интернета на базе IPv4. Трафик IPv6 при использовании IPv4-совместимых адресов не требует добавления маршрутизаторов IPv6. Трафик IPv6 инкапсулируется в заголовки IPv4.

На следующем рисунке показана конфигурация из двух узлов в разных подсетях, использующих IPv4-совместимые адреса для обмена данными через маршрутизатор IPv4.

Использование IPv4-совместимых адресов для обмена данными через маршрутизатор IPv4

По умолчанию протокол IPv6 для Windows XP автоматически настраивает IPv4-совместимые адреса для общедоступных адресов IPv4 на автоматическом туннельном псевдоинтерфейсе (идентификатор интерфейса 2). IPv4-совместимый адрес имеет вид ::w.x.y.z, где w.x.y.z — это общедоступный адрес IPv4, назначенный интерфейсу компьютера. В качестве примера см. образец результатов выполнения команды ipv6 if см. в разделе Подсеть с адресами локальной связи. Протокол IPv6 для Windows XP также автоматически создает маршрут ::/96, пересылающий трафик на IPv4-совместимые адреса с помощью автоматического туннельного псевдоинтерфейса (идентификатор интерфейса 2). Весь трафик, пересылаемый данным узлом на IPv4-совместимые адреса назначения, инкапсулируется в заголовки IPv4.

Отправка трафика на IPv4-совместимый адрес выполняется с IPv4-совместимого адреса с инкапсуляцией трафика в заголовки IPv4. Для поля Protocol в заголовке IPv4 задается значение 41, указывающее на то, что полезные данные представляют собой пакет IPv6. Заголовок IPv4 позволяет передать трафик через инфраструктуру IPv4. Адреса IPv4, внедренные в IPv4-совместимые адреса источника и назначения заголовка IPv6, становятся адресами источника и назначения IPv4 в заголовке IPv4.

Например, ниже показаны адреса источника и назначения для заголовков IPv4 и IPv6 при использовании IPv4-совместимых адресов узлом A (с адресом IPv4 131.107.41.17) для отправки трафика IPv6 на узел Б (с адресом IPv4 157.60.15.93).

Поле | Значение
Адрес источника в заголовке IPv6 | ::131.107.41.17
Адрес назначения в заголовке IPv6 | ::157.60.15.93
Адрес источника в заголовке IPv4 | 131.107.41.17
Адрес назначения в заголовке IPv4 | 157.60.15.93

Инфраструктура маршрутизации IPv4 пересылает пакет с узла A на узел Б, используя адрес назначения IPv4 157.60.15.93. После получения пакета IPv4 на узле Б полезные данные (пакет IPv6) передается в протокол IPv6.

Для проверки связи используйте команду ping6. Например, узел A для проверки связи с узлом Б по его IPv4-совместимому адресу использует команду

ping6 ::157.60.15.93

Использование адресов ISATAP

Другой механизм назначения адресов и туннелирования, который может использоваться для связи между узлами IPv6/IPv4 в сети IPv4, описывается в проекте стандартов Интернета под названием «Протокол ISATAP (Intra-Site Automatic Tunnel Addressing Protocol)» (draft-ietf-ngtrans-isatap-00.txt). Эти адреса называют адресами ISATAP (Intrasite Automatic Tunnel Addressing Protocol). Они имеют вид 64БитныйПрефикс:200:5EFE:w.x.y.z.

  • 64БитныйПрефикс — это любой 64-битный префикс, допустимый для адресов одноадресной рассылки IPv6. В том числе префикс локальной связи (FE80::/64), префиксы локального сайта и глобальные префиксы.
  • 200:5EFE — это глобально уникальный 64-битный идентификатор интерфейса, образуемый сочетанием идентификатора организационного подразделения (OUI), назначенного IANA (00-00-5E) и типа, обозначающего внедренный адрес IPv4 (FE).
  • w.x.y.z — любой адрес одноадресной рассылки IPv4 (общедоступный или частный).

Как и IPv4-совместимые адреса 6over4 и 6to4, адреса ISATAP содержат внедренный адрес IPv4, используемый для определения источника или назначения IPv4 в заголовке IPv4 при пересылке трафика IPv6 с адресом ISATAP через сеть IPv4.

По умолчанию протокол IPv6 для Windows XP автоматически настраивает адрес ISATAP FE80::200:5EFE:w.x.y.z на автоматическом туннельном псевдоинтерфейсе для каждого назначенного узлу адреса IPv4. Используя эти адреса локальной связи ISATAP, узлы могут обмениваться данными через сеть IPv4.

Например, узел A имеет адрес IPv4 10.40.1.29, а узел Б имеет адрес IPv4 192.168.41.30. При запуске протокола IPv6 для Windows XP на узле A автоматически настраивается адрес ISATAP FE80::200:5EFE:10.40.1.29, а на узле Б автоматически настраивается адрес ISATAP FE80::200:5EFE:192.168.41.30. В следующей таблице показаны адреса источника и назначения для заголовков IPv4 и IPv6 при отправке трафика IPv6 с узла A на узел Б при помощи адреса ISATAP узла Б.

Поле | Значение
Адрес источника в заголовке IPv6 | FE80::200:5EFE:10.40.1.29
Адрес назначения в заголовке IPv6 | FE80::200:5EFE:192.168.41.30
Адрес источника в заголовке IPv4 | 10.40.1.29
Адрес назначения в заголовке IPv4 | 192.168.41.30

Для проверки связи используйте команду ping6. Например, узел A для проверки связи с узлом Б по его адресу ISATAP использует команду

ping6 FE80::200:5EFE:192.168.41.30%2

Часть %ИдентификаторОбласти данной команды используется для указания индекса интерфейса, с которого отправляется трафик. В данном случае указан интерфейс 2 (%2), то есть идентификатор интерфейса, назначенный автоматическому туннельному псевдоинтерфейсу на узле A.

Использование адресов локальной связи ISATAP позволяет узлам IPv6/IPv4 в интрасети IPv4 обмениваться данными друг с другом, но не с другими узлами IPv6 за пределами данного сайта. Для обмена данными с узлами за пределами данного сайта требуется следующая дополнительная настройка.

  • Узел должен получить от граничного маршрутизатора сайта объявление маршрутизатора, содержащее глобальный префикс адреса. Граничный маршрутизатор сайта — это маршрутизатор между интрасетью и Интернетом или сетью 6bone. Чаще всего граничный маршрутизатор сайта представляет собой маршрутизатор 6to4, подключенный к Интернету. По получении объявления маршрутизатора автоматически добавляются дополнительные адреса ISATAP, основанные на глобальном префиксе.

    • Например, если сайт подключен к 6bone и узел A получает в объявлении маршрутизатора глобальный префикс 3000::/64, автоматически настраивается адрес ISATAP 3000::200:5EFE:10.40.1.29. Без глобального префикса и подключения к 6bone сайт может использовать глобальный префикс адреса 6to4 и подключаться к другим сайтам 6to4, узлам 6to4 и сети 6bone с использованием Интернета на базе протокола IPv4. Если сайт использует префикс адреса 6to4 2002:836B:1:5::/64 (созданный из общедоступного адреса 131.107.0.1 и идентификатора уровня сайта, равного 5), то автоматически настраивается адрес ISATAP 2002:836B:1:5:200:5EFE:10.40.1.29.

    Однако в настоящее время отсутствует механизм распространения объявления маршрутизатора с граничного маршрутизатора сайта на узлы ISATAP через сеть IPv4.

    Протокол IPv6 для Windows XP требует настройки глобального адреса ISATAP на автоматическом туннельном псевдоинтерфейсе (идентификатор интерфейса 2) вручную с помощью команды ipv6 adu. При использовании префикса 6to4 из приведенного примера данная команда для узла A имеет вид ipv6 adu 2/2002:836B:1:5:200:5EFE:10.40.1.29. Дополнительные сведения см. в разделе Настройка IPv6 с вводом адресов вручную. 64-битный глобальный префикс, использующий автоматический туннельный интерфейс (идентификатор интерфейса 2), должен быть вручную добавлен в таблицу маршрутизации IPv6 с помощью команды ipv6 rtu. При использовании префикса 6to4 из приведенного примера данная команда для узла A имеет вид ipv6 rtu 2002:836B:1:5::/64 2. Дополнительные сведения см. в разделе Добавление маршрута IPv6.

  • Узел должен иметь маршрут по умолчанию, указывающий адрес ISATAP, соответствующий интерфейсу интрасети на граничном маршрутизаторе сайта.

    • Например, если для интерфейса интрасети на граничном маршрутизаторе сайта настроен адрес IPv4 172.16.0.1, на узле A необходимо настроить маршрут по умолчанию (::/0), использующий в качестве адреса следующего перехода адрес ISATAP FE80::200:5EFE:172.16.0.1. В результате весь трафик IPv6, для которого данный маршрут по умолчанию является наиболее близким, будет инкапсулироваться и пересылаться на граничный маршрутизатор сайта. Граничный маршрутизатор сайта пересылает трафик дальше. Если граничный маршрутизатор сайта является маршрутизатором 6to4, он инкапсулирует трафик IPv6 и пересылает его в Интернет.

    Протокол IPv6 для Windows XP необходимо настроить вручную, указав с помощью команды ipv6 rtu маршрут по умолчанию (::/0), использующий автоматический туннельный псевдоинтерфейс (идентификатор интерфейса 2) и адрес ISATAP, соответствующий интерфейсу интрасети на граничном маршрутизаторе сайта, в качестве адреса следующего перехода. В приведенном примере данная команда для узла A имеет вид ipv6 rtu ::/0 2/FE80::200:5EFE:172.16.0.1. Дополнительные сведения см. в разделе Добавление маршрута IPv6.

Дополнительные сведения о конфигурациях см. в разделе Конфигурации протокола IPv6.

Сведения об использовании протокола IPv6 в тестовой лаборатории см. в разделе Настройка тестовой лаборатории для протокола IPv6.


Трафик IPv6 между узлами в различных сайтах через Интернет (6to4)

6to4 — техника туннелирования, которая описана в документе RFC 3056. При использовании 6to4 перед отправкой по сетевому комплексу IPv4 (например, через Интернет) трафик IPv6 инкапсулируется с заголовком IPv4.

6to4 использует глобальный префикс адресов 2002:WWXX:YYZZ::/48, где WWXX:YYZZ — это составляющая следующего уровня (Next Level Aggregator, NLA) глобального адреса и точечно-десятичное представление общедоступного адреса IPv4 (w.x.y.z), назначенного сайту или узлу. Полный адрес узла 6to4 имеет вид 2002:WWXX:YYZZ:[Идентификатор локального сайта]:[Идентификатор интерфейса].

Документ RFC 3056 определяет следующие термины.

  • Узел 6to4

    • Узел IPv6, для которого настроен по крайней мере один адрес 6to4.

  • Маршрутизатор 6to4

    • Маршрутизатор IPv4/IPv6, пересылающий трафик с адресами 6to4 между узлами 6to4 в пределах сайта и другими маршрутизаторами 6to4 или ретранслирующими маршрутизаторами 6to4 в объединенной сети IPv4, такой как Интернет.

  • Ретранслирующий маршрутизатор 6to4

    • Маршрутизатор IPv4/IPv6, пересылающий трафик с адресами 6to4 между маршрутизаторами 6to4 в Интернете и узлами в сети 6bone.

При использовании узлов 6to4, инфраструктуры маршрутизации IPv6 в пределах сайтов 6to4, а также маршрутизаторов 6to4 на границах сайтов и ретранслирующего маршрутизатора 6to4 возможны следующие типы обмена данными.

  1. Между двумя узлами 6to4 в пределах одного сайта.

    2. Для этого типа обмена данными используется инфраструктура маршрутизации IPv6, обеспечивающая возможность доступа ко всем узлам в пределах сайта.

  2. Между узлом 6to4 и узлами 6to4 в других сайтах через Интернет на базе протокола IPv4.

    3. Этот тип обмена данными имеет место при пересылке узлом 6to4 трафика IPv6, предназначенного для узла 6to4 в другом сайте, на маршрутизатор 6to4 локального сайта. Маршрутизатор 6to4 локального сайта инкапсулирует трафик IPv6 в заголовки IPv4 и отправляет через Интернет на маршрутизатор 6to4 в сайте назначения. Маршрутизатор 6to4 в сайте назначения удаляет заголовок IPv4 и пересылает пакет IPv6 соответствующему узлу 6to4 с использованием инфраструктуры маршрутизации IPv6 в сайте назначения.

  3. Между узлом 6to4 и узлами в сети 6bone.

    4. Этот тип обмена данными имеет место при пересылке узлом 6to4 трафика IPv6, предназначенного для узла 6bone, на маршрутизатор 6to4 локального сайта. Маршрутизатор 6to4 локального сайта инкапсулирует трафик IPv6 в заголовки IPv4 и отправляет на ретранслирующий маршрутизатор 6to4, подключенный как к Интернету, так и к 6bone. Ретранслирующий маршрутизатор 6to4 удаляет заголовок IPv4 и пересылает пакет IPv6 соответствующему узлу 6bone с использованием инфраструктуры маршрутизации IPv6 сети 6bone.

Все описанные типы обмена данными используют трафик IPv6 без необходимости получения от поставщика услуг Интернета непосредственного подключения к 6bone или префикса глобального адреса IPv6.

Служба 6to4, включенная в протокол IPv6 для Windows XP, обеспечивает поддержку узлов и маршрутизаторов 6to4. Служба 6to4 выполняет следующие действия.

  • Автоматически настраивает адреса 6to4 на интерфейсе, обозначенном как псевдоинтерфейс туннелирования 6to4 (идентификатор интерфейса 3), для всех общедоступных адресов IPv4, назначенных интерфейсам данного компьютера. В качестве примера см. образец результатов выполнения команды ipv6 if см. в разделе Подсеть с адресами локальной связи.
  • Автоматически создает маршрут 2002::/16, пересылающий весь трафик 6to4 с использованием псевдоинтерфейса туннелирования 6to4 (идентификатор интерфейса 3). Весь трафик, пересылаемый данным узлом на адреса назначения 6to4, инкапсулируются в заголовки IPv4.
  • Автоматически выполняет запрос DNS (Domain Name System) для имени 6to4.ipv6.microsoft.com, чтобы получить адрес IPv4 ретранслирующего маршрутизатора Microsoft 6to4 в Интернете. Для указания запрашиваемого DNS-имени используется команда netsh interface ipv6 6to4 set relay. Дополнительные сведения см. в разделе Служебные программы IPv6.

С помощью автоматической настройки службы 6to4 любой узел, использующий протокол IPv6 для Windows XP и имеющий общедоступный адрес IPv4, автоматически настраивается как узел 6to4. Узел 6to4 может самостоятельно выполнять туннелирование для доступа к узлам 6to4 в других сайтах или в сети 6bone.

Дополнительные сведения о подключении к 6bone см. в разделе Подключение к 6bone.

Если на интерфейсе, которому назначен общедоступный адрес IPv4, включен общий доступ к подключению Интернета, служба 6to4:

  • обеспечивает маршрутизацию на частном интерфейсе;
  • отправляет объявления маршрутизатора, содержащие префиксы адресов 6to4 , основанные на общедоступных адресах IPv4 общего интерфейса. В качестве идентификатора уровня сайта (SLA ID) в префиксе адреса 6to4 указывается идентификатор интерфейса, на который отправляются объявления.

Включив общий доступ к подключению Интернета, можно использовать компьютер, применяющий протокол IPv6 для Windows XP, в качестве маршрутизатора 6to4, способного инкапсулировать и пересылать трафик 6to4 другим узлам или сайтам 6to4 в Интернете, а также пересылать трафик 6bone на ретранслирующий маршрутизатор 6to4 в Интернете.

На следующем рисунке показано использование службы 6to4 для обмена данными между двумя сайтами 6to4.

Использование 6to4 для обмена данными между двумя сайтами 6to4

Каждый из сайтов использует для создания маршрутизатора 6to4 компьютер с Windows XP, на общем интерфейсе которого включен общий доступ к подключению Интернета. Узлы с операционной системой Windows XP в сегментах частной сети получают от маршрутизатора 6to4 их сайта объявления маршрутизатора, содержащие префиксы адресов 6to4. В результате два узла 6to4 могут обмениваться данными через Интернет с использованием адресов 6to4.

Дополнительные сведения о конфигурациях см. в разделе Конфигурации протокола IPv6.

Сведения об использовании протокола IPv6 в тестовой лаборатории см. в разделе Настройка тестовой лаборатории для протокола IPv6.


Подключение к сети 6bone

Самым простым способом подключения к 6bone является использование службы 6to4, включенной в протокол IPv6 для Windows XP. Службу 6to4 можно использовать как узел 6to4 или как маршрутизатор 6to4, включив общий доступ к подключению Интернета на компьютере, подключенном к Интернету. Служба 6to4 автоматически настраивает для себя соответствующие адреса 6to4 и использует конкретный ретранслирующий маршрутизатор 6to4 в Интернете. Дополнительные сведения см. в разделе Трафик IPv6 между узлами в различных сайтах через Интернет (6to4). На следующем рисунке показана конфигурация узла, использующего 6to4 для обмена данными с 6bone через ретранслирующий маршрутизатор 6to4.

Использование ретранслирующего маршрутизатор 6to4 для обмена данными с 6bone

При помощи 6to4 можно проверять связь с другими компьютеры в сети 6bone (например, ping6 ipv6.research.microsoft.com). На веб-узле IPv6 доступен список серверов 6bone, доступных по протоколу IPv6. Кроме того, имена компьютеров 6bone содержатся в реестре 6bone.

Некоторые сайты 6bone могут быть недоступны. Также возможны затруднения с установкой связи. В любом из этих случаев может помочь команда tracert6 -d Адрес. Параметр -d предотвращает обратный просмотр DNS для адресов промежуточных маршрутизаторов. Дополнительные сведения о 6bone см. на веб-узле 6bone.

Дополнительные сведения о конфигурациях см. в разделе Конфигурации протокола IPv6.

Сведения об использовании протокола IPv6 в тестовой лаборатории см. в разделе Настройка тестовой лаборатории для протокола IPv6.

Важно!

  • XOX

Примечание


Настройка тестовой лаборатории для протокола IPv6

В этом разделе приведены инструкции по созданию тестовой лаборатории из пяти компьютеров для настройки и проверки протокола IPv6 Windows XP. Эти инструкции состоят из последовательности задач, дающих общее представление о протоколе IPv6 и его возможностях. Кроме выполнения задач эти инструкции также позволяют создать функционирующую конфигурацию, использующую протокол IPv6. Эту конфигурацию можно использовать для ознакомления и экспериментов с возможностями и функциями IPv6, помощи в разработке приложений для протокола IPv6 или переноса существующих приложений для протокола IPv4.

В этом разделе собраны сведения по следующим вопросам.

  • Настройка инфраструктуры
  • Задачи тестовой лаборатории протокола IPv6

Важно!

  • XOX

Примечание


Настройка инфраструктуры

Инфраструктура сети тестовой лаборатории IPv6 состоит из пяти компьютеров, выполняющих следующие роли.

  • Компьютер, работающий под управлением Windows 2000 Server, выступает в роли DNS-сервера. Имя компьютера DNS1.
  • Компьютер, работающий под управлением Windows XP Home Edition или Windows XP Professional, выступает в роли клиента. Имя компьютера CLIENT1.
  • Компьютер, работающий под управлением Windows XP Home Edition или Windows XP Professional, выступает в роли маршрутизатора. Имя компьютера ROUTER1.
  • Компьютер, работающий под управлением Windows XP Home Edition или Windows XP Professional, выступает в роли маршрутизатора. Имя компьютера ROUTER2.
  • Компьютер, работающий под управлением Windows XP Home Edition или Windows XP Professional, выступает в роли клиента. Имя компьютера CLIENT2.

На следующем рисунке показана конфигурация тестовой лаборатории IPv6.

Конфигурация тестовой лаборатории IPv6

Сеть включает три сегмента.

  • Сегмент сети с именем Subnet 1, использующий код частной IP-сети 10.0.1.0/24 и подсеть локального сайта FEC0:0:0:1::/64.
  • Сегмент сети с именем Subnet 2, использующий код частной IP-сети 10.0.2.0/24 и подсеть локального сайта FEC0:0:0:2::/64.
  • Сегмент сети с именем Subnet 3, использующий код частной IP-сети 10.0.3.0/24 и подсеть локального сайта FEC0:0:0:3::/64.

Все компьютеры в каждой подсети подключены к отдельному общему концентратору или коммутатору второго уровня. В двух компьютерах-маршрутизаторах (ROUTER1 и ROUTER2) установлены два сетевых адаптера.

Для протокола IPv4 на каждом компьютере вручную настроены соответствующий IP-адрес, маска подсети, основной шлюз и IP-адрес DNS-сервера. Протокол DHCP (Dynamic Host Configuration Protocol) и серверы WINS (Windows Internet Name Service) не используются. Для протокола IPv6 изначально используются адреса локальной связи.

В следующих разделах описана настройка каждого компьютера тестовой лаборатории. Чтобы воспроизвести конфигурацию тестовой лаборатории, настройте компьютеры в указанном порядке.

Примечание

  • XOX

DNS1

DNS1 — это компьютер, работающий под управлением Windows 2000 Server. Он обеспечивает работу службы DNS-сервера для домена DNS testlab.microsoft.com. Чтобы настроить компьютер DNS1 для этой службы, выполните следующие шаги.

  1. Установите Windows 2000 Server как изолированный сервер. Задайте пароль администратора
  2. После перезагрузки войдите в систему как администратор.
  3. Установите протокол IPv6. Дополнительные сведения см. в разделе Установка протокола IPv6.
  4. Установите службу «DNS-сервер». Дополнительные сведения см. в разделе Установка DNS-сервера.
  5. Задайте для протокола TCP/IP IP-адрес 10.0.1.2, маску подсети 255.255.255.0 и основной шлюз 10.0.1.1. Дополнительные сведения см. в разделе Настройка TCP/IP на статическую адресацию.

CLIENT1

CLIENT1 — это компьютер, работающий под управлением Windows XP Home Edition или Windows XP Home Edition и выступающий в роли клиента. Чтобы настроить CLIENT1 как компьютер-клиент, выполните следующие шаги.

  1. Установите на компьютер CLIENT1 Windows XP Home Edition или Windows XP Professional в режиме рабочей группы. Задайте пароль администратора
  2. После перезагрузки войдите в систему как администратор.
  3. Установите протокол IPv6. Дополнительные сведения см. в разделе Установка протокола IPv6.
  4. Задайте для протокола TCP/IP IP-адрес 10.0.1.3, маску подсети 255.255.255.0, основной шлюз 10.0.1.1 и IP-адрес DNS-сервера 10.0.1.2. Дополнительные сведения см. в разделах Настройка TCP/IP на статическую адресацию и Настройка TCP/IP на использование DNS.

ROUTER1

ROUTER1 — это компьютер, работающий под управлением Windows XP Home Edition или Windows XP Professional и используемый как маршрутизатор между подсетями Subnet 1 и Subnet 2. Чтобы настроить компьютер ROUTER1 как маршрутизатор, выполните следующие шаги.

  1. Установите на компьютер ROUTER1 Windows XP Home Edition или Windows XP Professional в режиме рабочей группы. Задайте пароль администратора
  2. После перезагрузки войдите в систему как администратор.
  3. Установите протокол IPv6. Дополнительные сведения см. в разделе Установка протокола IPv6.
  4. Для интерфейса подсети Subnet 1 задайте в конфигурации протокола TCP/IP IP-адрес 10.0.1.1, маску подсети 255.255.255.0 и IP-адрес DNS-сервера 10.0.1.2. Дополнительные сведения см. в разделах Настройка TCP/IP на статическую адресацию и Настройка TCP/IP на использование DNS.
  5. Для интерфейса подсети Subnet 2 задайте в конфигурации протокола TCP/IP IP-адрес 10.0.2.1, маску подсети 255.255.255.0 и основной шлюз 10.0.2.2. Дополнительные сведения см. в разделе Настройка TCP/IP на статическую адресацию.
  6. Включите перенаправление IP-датаграмм.

ROUTER2

ROUTER2 — это компьютер, работающий под управлением Windows XP Home Edition или Windows XP Professional и используемый как маршрутизатор между подсетями Subnet 2 и Subnet 3. Чтобы настроить компьютер ROUTER2 как маршрутизатор, выполните следующие шаги.

  1. Установите на компьютер ROUTER2 Windows XP Home Edition или Windows XP Professional в режиме рабочей группы. Задайте пароль администратора
  2. После перезагрузки войдите в систему как администратор.
  3. Установите протокол IPv6. Дополнительные сведения см. в разделе Установка протокола IPv6.
  4. Для интерфейса подсети Subnet 2 задайте в конфигурации протокола TCP/IP IP-адрес 10.0.2.2, маску подсети 255.255.255.0 и основной шлюз 10.0.2.1. Дополнительные сведения см. в разделе Настройка TCP/IP на статическую адресацию.
  5. Для интерфейса подсети Subnet 3 задайте в конфигурации протокола TCP/IP IP-адрес 10.0.3.1 и маску подсети 255.255.255.0. Дополнительные сведения см. в разделе Настройка TCP/IP на статическую адресацию.
  6. Включите перенаправление IP-датаграмм.

CLIENT2

CLIENT2 — это компьютер, работающий под управлением Windows XP Home Edition или Windows XP Home Edition и выступающий в роли клиента. Чтобы настроить CLIENT2 как компьютер-клиент, выполните следующие шаги.

  1. Установите на компьютер CLIENT2 Windows XP Home Edition или Windows XP Professional в режиме рабочей группы. Задайте пароль администратора
  2. После перезагрузки войдите в систему как администратор.
  3. Установите протокол IPv6. Дополнительные сведения см. в разделе Установка протокола IPv6.
  4. Задайте для протокола TCP/IP IP-адрес 10.0.3.2, маску подсети 255.255.255.0 и основной шлюз 10.0.3.1. Дополнительные сведения см. в разделе Настройка TCP/IP на статическую адресацию.
  5. Проверьте целостность инфраструктуры маршрутизации IPv4, обратившись с компьютера CLIENT2 по адресу 10.0.1.3 с помощью команды ping.


Задачи тестовой лаборатории протокола IPv6

Следующие задачи выполняются при общей настройке IPv6 в Windows XP с использованием инфраструктуры тестовой лаборатории, конфигурация которой описана в разделе Настройка инфраструктуры.

  • Проверка локальной связи
  • Создание инфраструктуры статической маршрутизации
  • Использование разрешения имен
  • Использование анонимных адресов

Примечание

  • XOX

Проверка локальной связи

Чтобы проверить связь с узлом при помощи адресов локальной связи и просмотреть записи, созданные в кэшах окружения и маршрутов, выполните следующие действия.

  1. На сервере DNS1 введите команду ipv6 if, чтобы получить адрес локальной связи интерфейса с именем Подключение по локальной сети.
  2. На компьютере КЛИЕНТ1 введите команду ipv6 if, чтобы получить адрес локальной связи и идентификатор интерфейса с именем Local Area Connection.
  3. На компьютере КЛИЕНТ1 введите следующую команду для проверки связи с адресом локальной связи сервера DNS1:

    4. ping6 АдресЛокальнойСвязиDNS1%ИдентификаторИнтерфейса

    Например, если сервер DNS1 имеет адрес локальной связи FE80::2AA:FF:FE9D:10C5, а идентификатор интерфейса Local Area Connection на компьютере КЛИЕНТ1 равен 3, команда имеет вид:

    ping6 FE80::2AA:FF:FE9D:10C5%3

  4. На компьютере КЛИЕНТ1 введите команду

    5. ipv6 nc

    чтобы просмотреть в кэше окружения компьютера КЛИЕНТ1 запись для сервера DNS1. Дополнительные сведения см. в разделе ND (Neighbor Discovery).

  5. На компьютере КЛИЕНТ1 введите команду

    6. ipv6 rc

    чтобы просмотреть в кэше маршрутов компьютера КЛИЕНТ1 запись для сервера DNS1. Дополнительные сведения см. в разделе ND (Neighbor Discovery).

  6. На компьютере КЛИЕНТ1 введите команду

    7. ipv6 rt

    чтобы просмотреть записи в таблице маршрутизации компьютера КЛИЕНТ1. Дополнительные сведения см. в разделе Таблица маршрутизации IPv6.

Создание инфраструктуры статической маршрутизации

Чтобы настроить инфраструктуру статической маршрутизации для обеспечения доступа ко всем компьютерам тестовой лаборатории при использовании трафика IPv6, выполните следующие действия.

  1. На компьютере МАРШРУТИЗАТОР1 введите команду ipv6 if, чтобы получить адреса локальной связи и номера идентификаторов интерфейса для подсетей 1 и 2.
  2. На компьютере МАРШРУТИЗАТОР1 введите следующие команды:

    3. ipv6 ifc ИндексИнтерфейсаПодсети1 forwards advertises

    ipv6 ifc ИндексИнтерфейсаПодсети2 forwards advertises

    ipv6 rtu FEC0:0:0:1::/64 ИндексИнтерфейсаПодсети1 publish

    ipv6 rtu FEC0:0:0:2::/64 ИндексИнтерфейсаПодсети2 publish

    ipv6 rtu ::/0 ИндексИнтерфейсаПодсети2/АдресМАРШРУТИЗАТОРА2ВПодсети2 publish

    где:

    • ИндексИнтерфейсаПодсети1 — индекс интерфейса компьютера МАРШРУТИЗАТОР1 в подсети 1;
    • ИндексИнтерфейсаПодсети2 — индекс интерфейса компьютера МАРШРУТИЗАТОР1 в подсети 2;
    • АдресМАРШРУТИЗАТОРА2ВПодсети2 — адрес локальной связи интерфейса МАРШРУТИЗАТОР2 в подсети 2.

    Например, если индекс интерфейса подсети 1 равен 4, индекс интерфейса подсети 2 равен 3, а интерфейс подсети 2 на компьютере МАРШРУТИЗАТОР2 имеет адрес локальной связи FE80::2AA:FF:FE87:4D5C, следует ввести следующие команды:

    ipv6 ifc 4 forwards advertises

    ipv6 ifc 3 forwards advertises

    ipv6 rtu FEC0:0:0:1::/64 4 publish

    ipv6 rtu FEC0:0:0:2::/64 3 publish

    ipv6 rtu ::/0 3/FE80::2AA:FF:FE87:4D5C publish

  3. На компьютере МАРШРУТИЗАТОР2 введите команду ipv6 if, чтобы получить адреса локальной связи и номера идентификаторов интерфейса для подсетей 2 и 3.
  4. На компьютере МАРШРУТИЗАТОР2 введите следующие команды:

    5. ipv6 ifc ИндексИнтерфейсаПодсети2 forwards advertises

    ipv6 ifc ИндексИнтерфейсаПодсети3 forwards advertises

    ipv6 rtu FEC0:0:0:2::/64 ИндексИнтерфейсаПодсети2 publish

    ipv6 rtu FEC0:0:0:3::/64 ИндексИнтерфейсаПодсети3 publish

    ipv6 rtu ::/0 ИндексИнтерфейсаПодсети2/АдресМАРШРУТИЗАТОРА1ВПодсети2 publish

    Например, если индекс интерфейса подсети 2 равен 4, индекс интерфейса подсети 3 равен 3, а интерфейс подсети 2 на компьютере МАРШРУТИЗАТОР1 имеет адрес локальной связи FE80::2AA:FF:FE9A:203F, следует ввести следующие команды:

    ipv6 ifc 4 forwards advertises

    ipv6 ifc 3 forwards advertises

    ipv6 rtu FEC0:0:0:2::/64 4 publish

    ipv6 rtu FEC0:0:0:3::/64 3 publish

    ipv6 rtu ::/0 4/FE80::2AA:FF:FE9A:203F publish

  5. На компьютере КЛИЕНТ1 введите команду ipv6 if для просмотра нового адреса интерфейса ЛВС, созданного на основе префикса локального сайта FEC0:0:0:1::/64.
  6. На компьютере КЛИЕНТ1 введите команду ipv6 rt, чтобы просмотреть новые маршруты для FEC0:0:0:1::/64, FEC0:0:0:2::/64 и ::/0.
  7. На компьютере КЛИЕНТ2 введите команду ipv6 if для просмотра нового адреса интерфейса ЛВС, созданного на основе префикса локального сайта FEC0:00:00:03::/64.
  8. На компьютере КЛИЕНТ2 введите команду ipv6 rt, чтобы просмотреть новые маршруты для FEC0:0:0:2::/64, FEC0:0:0:3::/64 и ::/0.
  9. На компьютере КЛИЕНТ1 введите следующую команду для проверки связи с адресом локальной связи компьютера КЛИЕНТ2:

    10. ping6 АдресЛокальногоСайтаКЛИЕНТ2

  10. На компьютере КЛИЕНТ1 введите команду tracert6 с параметром -d для трассировки маршрута между компьютерами КЛИЕНТ1 и КЛИЕНТ2:

    11. tracert6 -d АдресЛокальногоСайтаКЛИЕНТ2

    В сведениях, отображаемых командой tracert6, можно просмотреть адрес локальной связи интерфейса подсети 1 для компьютера МАРШРУТИЗАТОР1 и адрес локальной связи интерфейса подсети 2 для компьютера МАРШРУТИЗАТОР2.

  11. На компьютере МАРШРУТИЗАТОР1 введите следующие команды:

    12. ipv6 nc

    чтобы просмотреть в кэше окружения компьютера МАРШРУТИЗАТОР1 запись для компьютеров КЛИЕНТ1 и МАРШРУТИЗАТОР2.

    ipv6 rc

    чтобы просмотреть в кэше окружения компьютера МАРШРУТИЗАТОР1 запись для компьютеров DNS1 и МАРШРУТИЗАТОР2.

Примечание

  • Протокол IPv6 для Windows XP в настоящее время объявляет в сообщениях объявления маршрутизатора префиксы удаленной связи. Префиксы удаленной связи в поле Prefix Information становятся маршрутами в таблице маршрутизации узла-получателя.

Использование разрешения имен

Чтобы настроить DNS и локальный файл Hosts для разрешения имен в адреса IPv6, выполните следующие действия.

  1. На сервере DNS1 создайте зону с именем testlab.microsoft.com. Дополнительные сведения см. в разделе Добавление зоны прямого просмотра.
  2. Создайте запись ресурса AAAA (четыре A) для компьютера КЛИЕНТ2 с DNS-именем client2.testlab.microsoft.com для его адреса локального сайта IPv6. Дополнительные сведения см. в разделе Добавление записи ресурса в зону.

    3. Например, для адреса локального сайта компьютера КЛИЕНТ2 FEC0::3:260:8FF:FE52:F9D8 запись ресурса AAAA будет иметь вид:

    Имя: client2.testlab.microsoft.com

    Адрес: FEC0::3:260:8FF:FE52:F9D8

  3. На компьютере КЛИЕНТ1 введите следующую команду:

    4. ping6 client2.testlab.microsoft.com

    Будет выполнено разрешение имени client2.testlab.microsoft.com в адрес локального сайта путем отправки запроса DNS на сервер DNS1.

  4. На компьютере КЛИЕНТ2 создайте следующую запись в файле Hosts (в папке СистемныйКорневойКаталог\System32\Drivers\Etc):

    5. client1.testlab.microsoft.com АдресЛокальногоСайтаКЛИЕНТ1

  5. На компьютере КЛИЕНТ2 введите следующую команду:

    6. ping6 client1.testlab.microsoft.com

    Будет выполнено разрешение имени client1.testlab.microsoft.com в адрес локального сайта с помощью локального файла Hosts.

Использование анонимных адресов

Чтобы использовать анонимные адреса для глобальных префиксов адреса, выполните следующие действия.

  1. На компьютере МАРШРУТИЗАТОР1 введите команду

    2. ipv6 rtu 3000:0:0:1::/64 ИндексИнтерфейсаПодсети1 publish

    где ИндексИнтерфейсаПодсети1 — индекс интерфейса компьютера МАРШРУТИЗАТОР1 в подсети 1.

    Например, если индекс интерфейса подсети 1 равен 4, команда имеет вид:

    ipv6 rtu 3000:0:0:1::/64 4 publish

  2. На компьютере КЛИЕНТ1 введите команду ipv6 if для просмотра нового адреса интерфейса ЛВС, созданного на основе глобального префикса 3000:0:0:1::/64.

    3. Должно отображаться два адреса с префиксом 3000:0:0:1::/64. Один адрес использует идентификатор интерфейса, основанный на адресе EUI-64 этого интерфейса. Другой адрес является анонимным адресом, на основе которого случайным образом генерируется идентификатор интерфейса. Дополнительные сведения см. в разделе Идентификаторы интерфейса IPv6.

  3. На компьютере МАРШРУТИЗАТОР1 введите команду

    4. ipv6 rtu 3000:0:0:1::/64 ИндексИнтерфейсаПодсети1 life 0

    где ИндексИнтерфейсаПодсети1 — индекс интерфейса компьютера МАРШРУТИЗАТОР1 в подсети 1.

    Например, если индекс интерфейса подсети 1 равен 4, команда имеет вид:

    ipv6 rtu 3000:0:0:1::/64 4 life 0

    Эта команда удаляет глобальный префикс из таблицы маршрутизации компьютера МАРШРУТИЗАТОР1 и запрещает компьютеру МАРШРУТИЗАТОР1 объявлять этот префикс на своих интерфейсах.


Ресурсы

В этом разделе собраны сведения по следующим вопросам.

  • Документы RFC и проекты стандартов Интернета по IPv6
  • Справочники по протоколу IPv6
  • Служебные программы IPv6


Документы RFC и проекты стандартов Интернета по IPv6

В следующей таблице показаны документы RFC и проекты стандартов Интернета, внедренные в реализации протокола IPv6 для Windows XP.

Номер документа RFC или проект стандарта Интернета | Заголовок
1752 | Рекомендации для протокола IP нового поколения
1828 | Проверка подлинности IP с помощью MD5 на основе ключей
1886 | Расширения DNS для поддержки протокола IP версии 6
1933 | Механизмы переходов для узлов и маршрутизаторов IPv6
1981 | Опредение MTU маршрута для протокола IP версии 6
2185 | Аспекты маршрутизации переходного процесса IPv6
2373 | Архитектура адресации протокола IP версии 6
2374 | Формат комбинируемого адреса глобальной одноадресной рассылки для протокола IPv6
2401 | Архитектура безопасности для IP-протокола
2402 | Заголовок проверки подлинности (AH) IP
2403 | Использование HMAC-MD5-96 с ESP и AH (реализовано только для AH)
2404 | Использование HMAC-SHA-1-96 с ESP и AH (реализовано только для AH)
2406 | ESP (Encapsulating Security Payload) IP
2428 | Расширения FTP для IPv6 и NAT
2460 | Спецификация протокола IP версии 6 (IPv6)
2461 | Запрос Neighbor Discovery для IP версии 6 (IPv6)
2462 | Автонастройка адресов IPv6 без ведения базы данных
2463 | Спецификация протокола ICMPv6 (Internet Control Message Protocol) для протокола IP версии 6 (IPv6)
2464 | Передача пакетов IPv6 по сетям Ethernet
2467 | Передача пакетов IPv6 по сетям FDDI
2526 | Зарезервированные альтернативные адреса IPv6 подсети
2529 | Передача пакетов IPv6 через домены IPv4 без использования явных туннелей
2553 | Основные расширения интерфейса сокетов для IPv6
2710 | Протокол MLD (Multicast Listener Discovery) для IPv6 (реализован только для узлов)
2711 | Функция оповещения маршрутизатора IPv6 (реализована только для узлов)
2732 | Формат литеральных адресов IPv6 в адресах URL
3041 | Расширения, поддерживающие конфиденциальность при автонастройке адресов IPv6 без ведения базы данных
3056 | Подключение доменов IPv6 через «облака» IPv4
Проект стандартов Интернета | Расширение формата для диапазона адресов IPv6
Проект стандартов Интернета | Протокол ISATAP (Intra-Site Automatic Tunnel Addressing Protocol)
Проект стандартов Интернета | Автоматический выбор адресов для протокола IPv6
Проект стандартов Интернета | Архитектура адресации протокола IP версии 6
Проект стандартов Интернета | Архитектура диапазона адресов протокола IP версии 6
Проект стандартов Интернета | Поддержка мобильных устройств в протоколе IPv6 (только для узлов)
Проект стандартов Интернета | Маршрутизация диапазона узлов в протоколе IP версии 6 (IPv6)
Проект стандартов Интернета | Префиксы узлов в запросе Neighbor Discovery
Проект стандартов Интернета | Упрощенный протокол UDP

Получение документов RFC и проектов стандартов Интернета

Документы RFC и проекты стандартов Интернета доступны на веб-узле рабочей группы IETF (Internet Engineering Task Force).

Важно!

  • XOX

Примечание


Справочники по протоколу IPv6

Дополнительные сведения о наборе протоколов IPv6 можно найти в следующих книгах.

  • Huitema, C. IPv6: The New Internet Protocol. Второе издание. Upper Saddle River, NJ: издательство Prentice Hall, 1998 г.
  • Miller, M. Implementing IPv6: Supporting the Next Generation of Protocols. Второе издание. Foster City, CA: издательство M&T Books, 2000 г.


Служебные программы IPv6

Изменения конфигурации не являются постоянными и утрачиваются при перезагрузке или перезапуске компьютера. Для сохранения изменений конфигурации следует записать их как команды в файле сценария командной строки (.cmd), который можно выполнить после перезапуска компьютера или протокола IPv6. Для автоматического внесения изменений конфигурации после перезагрузки компьютера настройте компонент «Назначенные задания» на панели управления на выполнение файла CMD-файла при загрузке компьютера.

Ipv6.exe

Настройка для протокола IPv6 выполняется с помощью программы ipv6.exe, которая используется для запроса и настройки интерфейсов, адресов, кэша и маршрутов.

Программа ipv6.exe имеет множество команд, для каждой из которых предусмотрен собственный набор параметров.

  • ipv6 install

    • Установка протокола IPv6 в качестве сетевого протокола для подключений по локальной сети. После установки этот протокол не отображается в списке компонентов в окне свойств подключения (компонент «Сетевые подключения»). Чтобы определить, установлен ли протокол IPv6, введите в командной строке команду ipv6 if.

  • ipv6 uninstall

    • Удаление протокола IPv6 в качестве сетевого протокола для подключений по локальной сети.

  • ipv6 [-v] if [ИндексИнтерфейса]

    • Вывод сведений об интерфейсах. Если указан номер индекса интерфейса, выводятся сведения только о соответствующем интерфейсе. В противном случае выводятся сведения обо всех интерфейсах. В частности, отображаются адреса уровня связи интерфейса и список адресов IPv6, назначенных этому интерфейсу. Также выводится текущее значение MTU и максимальное (истинное) значение MTU, которое поддерживает данный интерфейс. Параметр -v служит для вывода дополнительных сведений об интерфейсе.

    Интерфейс 1 представляет собой псевдоинтерфейс, используемый для замыкания на себя (так называемый интерфейс замыкания на себя). Интерфейс 2 представляет собой псевдоинтерфейс, используемый для автоматического туннелирования (так называемый автоматический туннельный интерфейс). Интерфейс 3 представляет собой псевдоинтерфейс, используемый для туннелирования 6to4 (так называемый туннельный псевдоинтерфейс 6to4). Другие интерфейсы нумеруются последовательно в порядке их создания. На разных компьютерах этот порядок может различаться.

    Если адрес уровня связи имеет вид aa-bb-cc-dd-ee-ff, он относится к интерфейсу FDDI (Fiber Distributed Data Interface) или Ethernet.

    Псевдоинтерфейсы замыкания на себя, автоматического туннелирования и туннелирования 6to4 не используют изучение окружения IPv6.

  • ipv6 ifcr v6v4 АдресИсточникаV4 АдресНазначения_V4 [nd] [pmld]

    • Создание настроенного туннельного интерфейса IPv6 поверх IPv4 с указанными адресами источника и назначения IPv4. Параметр nd включает изучение окружения для туннеля, что позволяет отправлять и принимать сообщения объявления маршрутизатора. Параметр pmld включает периодические сообщения MLD (Multicast Listener Discovery) в том случае, если узел на конце туннеля использует туннель как связь с нешироковещательным множественным доступом (Nonbroadcast Multiple Access, NBMA).

  • ipv6 ifcr 6over4 АдресИсточникаV4

    • Создание интерфейса для применения протокола IPv6 поверх IPv4 (6over4) с использованием указанного адреса источника IPv4. Дополнительные сведения по 6over4 см. в документе RFC 2529.

  • ipv6 ifc ИндексИнтерфейса {[forwards] | [-forwards]} {[advertises] | [-advertises]} [mtu ЧислоБайт] [site ИдентификаторСайта]

    • Управление атрибутами интерфейса. Интерфейс может быть пересылающим; в этом случае он пересылает пакеты, адрес назначения которых не назначен данному интерфейсу. Интерфейс может быть объявляющим; в этом случае он отправляет объявления маршрутизатора. Управление этими атрибутами может осуществляться независимо. Интерфейс либо отправляет запросы маршрутизатора и принимает объявления маршрутизатора, либо принимает запросы маршрутизатора и отправляет объявления маршрутизатора.

    Поскольку псевдоинтерфейсы замыкания на себе и автоматического туннелирования не используют изучение окружения, они не могут быть настроены на отправку объявлений маршрутизатора.

    Параметр forwards можно сократить до forw, а advertises — до adv.

    Предоставляется возможность задать для интерфейса наибольший размер передаваемого блока данных (Maximum Transmission Unit, MTU). Новое значение MTU не должно превышать максимальное (истинное) значение MTU (отображаемое по команде ipv6 if) и не должно быть меньше минимального значения MTU для IPv6 (1280 байт).

    Также можно изменить идентификатор сайта для интерфейса. Идентификаторы сайта используются в поле sin6_scope_id для адресов локального сайта.

  • ipv6 ifd ИндексИнтерфейса

    • Удаление интерфейса. Удаление псевдоинтерфейсов замыкания на себе и автоматического туннелирования невозможно.

  • ipv6 adu ИндексИнтерфейса/Адрес [life ВремяЖизниДейств[/ВремяЖизниОсн]] [anycast] [unicast]

    • Добавление на интерфейсе или удаление с него назначения адреса для одноадресной рассылки или рассылки до первого получателя. Если не указана рассылка до первого получателя, по умолчанию используется одноадресная рассылка.

    Если время жизни не задано, оно не ограничивается. Если задано только время жизни действительного состояния адреса, то для времени жизни основного состояния адреса задается такое же значение. Время жизни можно либо не ограничивать, либо задать в секундах. Время жизни основного состояния адреса не должно превышать времени жизни действительного состояния адреса. Задание нулевого времени жизни приводит к удалению адреса.

    Параметр lifetime можно сократить до life.

    Время жизни действительного состояния для адресов рассылки до первого получателя может быть только нулевым либо неограниченным.

  • ipv6 nc [ИндексИнтерфейса [Адрес]]

    • Отображение содержимого кэша окружения. Если указан номер интерфейса, отображается содержимое кэша окружения только указанного интерфейса. В противном случае отображается содержимое кэша окружения всех интерфейсов. Если интерфейс указан, можно указать адрес IPv6 для отображения только одной записи кэша окружения.

    Для каждой записи кэша окружения отображаются интерфейс, адрес IPv6, адрес уровня связи и состояние возможности доступа.

  • ipv6 ncf [ИндексИнтерфейса [Адрес]]

    • Удаление указанных записей кэша окружения. Удаляются только записи кэша окружения без ссылок. Поскольку записи кэша маршрутов содержат ссылки на записи кэша окружения, рекомендуется сначала выполнить команду ipv6 rcf. Записи таблицы маршрутизации также могут содержать ссылки на записи кэша окружения.

  • ipv6 rc [ИндексИнтерфейса [Адрес]]

    • Отображение содержимого кэша маршрутов. Кэшем маршрутов в реализации протокола IPv6 для Windows XP называется кэш назначения. Если указан интерфейс и адрес, отображается запись кэша маршрутов, используемая для достижения адреса через данный интерфейс. В противном случае отображаются все записи кэша маршрутов.

    Для каждой записи кэша маршрутов отображаются адрес IPv6, а также интерфейс текущего следующего перехода и адрес соседа. Также отображаются адрес источника, предпочтительный для использования с данным конечным адресом, MTU текущего пути для достижения этого конечного адреса через данный интерфейс и указание на то, относится ли данная запись кэша маршрутов к конкретному интерфейсу. Если для конечного адреса задан замещающий адрес (care-of address), он также отображается.

    Адрес назначения может иметь несколько записей кэша маршрутов — по одной для каждого исходящего интерфейса. Однако адрес назначения может иметь не более одной записи кэша маршрутов, не связанной с конкретным интерфейсом. Запись кэша маршрутов, связанная с конкретным интерфейсом, используется только в том случае, если этот исходящий интерфейс указан приложением.

  • ipv6 rcf [ИндексИнтерфейса [Адрес]]

    • Удаление указанных записей кэша маршрутов.

  • ipv6 bc

    • Отображение содержимого кэша привязки, который содержит сведения о привязках домашних и замещающих адресов мобильных узлов IPv6.

    Для каждой привязки отображаются домашний адрес, замещающий адрес и порядковый номер привязки.

  • ipv6 [-v] rt

    • Отображение текущего содержимого таблицы маршрутизации.

    Для каждой записи таблицы маршрутизации отображаются префикс маршрута, интерфейс связи или следующий сосед на интерфейсе, значение предпочтения (чем меньше значение, тем выше приоритет) и время жизни в секундах. Для просмотра дополнительных записей системной таблицы маршрутизации используйте параметр -v.

    Записи таблицы маршрутизации могут также иметь атрибуты публикации и устаревания. По умолчанию они устаревают (отсчитывается время жизни) и не публикуются (не используются при создании объявлений маршрутизатора).

    На узлах, не являющихся маршрутизаторами, записи обычно настраиваются автоматически на основе объявлений маршрутизаторов.

    Дополнительные сведения см. в разделе Таблица маршрутизации IPv6.

  • ipv6 rtu Префикс ИндексИнтерфейса[/АдресСледПерехода] [life Действ[/Осн]] [preference Предп] [publish] [age] [spl ДлинаПрефиксаУзла]

    • Добавление или удаление маршрута в таблице маршрутизации. Префикс маршрута является обязательным. Префиксы прямой связи требуют указания интерфейса. Префиксы удаленной связи требуют указания интерфейса и адреса следующего перехода. Маршрут может иметь время жизни в секундах (по умолчанию — неограниченное) и уровень предпочтения (по умолчанию — ноль, самый высокий). Задание нулевого времени жизни приводит к удалению маршрута.

    Маршрут, указанный как публикуемый (используемый при составлении объявлений маршрутизатора), по умолчанию не устаревает. Время жизни такого маршрута не отсчитывается, то есть, фактически, является неограниченным. При включении маршрута в сообщения объявления маршрута используется время жизни. При желании можно определить публикуемый маршрут как устаревающий. Непубликуемые маршруты по умолчанию устаревают всегда.

    Параметр spl может использоваться для задания длины префикса сайта, связанной с маршрутом. Длина префикса сайта используется только при отправке объявлений маршрута.

    Параметр lifetime можно сократить до life, preference — до pref, а publish — до pub.

  • ipv6 spt

    • Отображение содержимого таблицы префиксов сайтов.

    Для каждого префикса сайта отображается сам префикс, интерфейс, к которому он применяется, а также время жизни префикса (в секундах).

    Префиксы сайта обычно настраиваются автоматически на основе объявлений маршрутизаторов. Они используются функцией getaddrinfo() для отсева неподходящих адресов локального сайта.

  • ipv6 spu Префикс ИндексИнтерфейса [life СрокЖизни]

    • Добавление, удаление или обновление префикса в таблице префиксов сайтов.

    Префикс и номер интерфейса являются обязательными. Время жизни префикса сайта (задается в секундах) по умолчанию не ограничено. Задание нулевого времени жизни приводит к удалению префикса сайта.

    Данная команда не требуется для стандартной настройки узлов или маршрутизаторов.

  • ipv6 gp

    • Отображение значений глобальных параметров для протокола IPv6.

  • ipv6 [-p] gpu DefaultCurHopLimit ЧислоПрыжков

    • Задание значения поля «Hop Limit» в заголовке IPv6 для пакетов, отправляемых данным узлом. Значение по умолчанию равно 128. Это значение можно изменить с помощью сообщений или приложений объявления маршрутизатора. Параметр -p задает сохранение данного значения в реестре.

  • ipv6 [-p] gpu UseAnonymousAddresses [yes|no|always|Счетчик]

    • Выбор режима использования анонимных адресов. По умолчанию используется значение yes. Параметр -p задает сохранение данного значения в реестре.

  • ipv6 [-p] gpu MaxAnonDADAttempts Число

    • Задание числа проверок анонимного адреса на анонимность. По умолчанию число попыток равно 5. Параметр -p задает сохранение данного значения в реестре.

  • ipv6 [-p] gpu MaxAnonLifetime Действительный[/Основной]

    • Задание времени жизни действительного и основного состояний анонимных адресов. Срок жизни действительного состояния по умолчанию составляет 7 дней. Срок жизни основного состояния по умолчанию составляет 1 день. Параметр -p задает сохранение этих значений в реестре.

  • ipv6 [-p] gpu AnonRegenerateTime Время

    • Задание периода времени (в секундах), в течение которого следует создать следующий анонимный адрес. По умолчанию задается период в 5 секунд. Параметр -p задает сохранение данного значения в реестре.

  • ipv6 [-p] gpu MaxAnonRandomTime Время

    • Задание максимальной продолжительности случайного срока действия анонимного адреса (в минутах). Случайный срок действия анонимного адреса — это период времени, истекающий до завершения промежутка времени, в течение которого анонимный адрес может создать новый анонимный адрес. Протокол IPv6 для Windows XP выбирает это значение случайным образом из интервала между значениями AnonRandomTime и MaxAnonRandomTime. Выбор случайного времени смены анонимного адреса выполняется для предотвращения нежелательных воздействий на сетевой трафик при одновременном прекращении срока действия большого числа анонимных адресов. Значение по умолчанию равно 10 минутам. Параметр -p задает сохранение данного значения в реестре.

  • ipv6 [-p] gpu AnonRandomTime Время

    • Задание минимальной продолжительности случайного срока действия анонимного адреса (в секундах). По умолчанию задается период в 0 секунд. Параметр -p задает сохранение данного значения в реестре.

  • ipv6 [-p] gpu NeighborCacheLimit Число

    • Задание максимального числа записей в кэше окружения для каждого интерфейса. По умолчанию значение равно 8. Параметр -p задает сохранение данного значения в реестре.

  • ipv6 [-p] gpu RouteCacheLimit Число

    • Задание максимального числа записей в кэше маршрутов для каждого интерфейса. По умолчанию значение равно 32. Параметр -p задает сохранение данного значения в реестре.

  • ipv6 ppt

    • Отображение таблицы префиксов политики. Таблица префиксов политики используется для указания политик выбора адресов источника и назначения.

  • ipv6 ppu Префикс precedence ЗначениеПредпочтения srclabel ЗначениеМеткиИсточника [dstlabel ЗначениеМеткиНазначения]

    • Обновление таблицы префиксов политики путем добавления политики, задающей уровень предпочтения, значение метки источника (ЗначениеМеткиИсточника) и значение метки назначения (ЗначениеМеткиНазначения). Записи в таблице префиксов политики могут изменять порядок выбора адресов источника и назначения. Дополнительные сведения см. в проекте стандартов Интернета под названием «Автоматический выбор адресов для протокола IPv6».

  • ipv6 renew [ИндексИнтерфейса]

    • Обновление конфигурации IPv6 для всех интерфейсов. Если указан номер индекса интерфейса, обновляется конфигурация только этого интерфейса. Узлы выполняют обновление автонастраиваемых адресов путем отправки сообщений запроса маршрутизаторов на соответствующие интерфейсы. Адреса настраиваются заново на основе полученных сообщений объявления маршрутизатора. Маршрутизаторы отправляют многоадресные сообщения объявления маршрутизатора на все соответствующие интерфейсы

Ipsec6.exe

Программа ipsec6.exe используется для настройки политик и сопоставлений безопасности IPSec.

Программа ipsec6.exe имеет несколько команд, для каждой из которых предусмотрен собственный набор параметров.

  • ipsec6 sp [Интерфейс]

    • Отображение активных политик безопасности. При указании интерфейса отображаются активные политики для данного интерфейса.

  • ipsec6 sa

    • Отображение активных сопоставлений безопасности.

  • ipsec6 l ИмяФайлаБезРасширения

    • Загрузка политик безопасности из файла ИмяФайла.spd и сопоставлений безопасности из файла ИмяФайла.sad.

  • ipsec6 s ИмяФайлаБезРасширения

    • Сохранение текущих политик безопасности в файл ИмяФайла.spd и текущих сопоставлений безопасности в файл ИмяФайла.sad. С помощью данной команды можно создать файлы, используемые для настройки политики и сопоставлений безопасности. При отсутствии политик безопасности или сопоставлений безопасности данная команда создает файл ИмяФайла.spd для политик безопасности и файл ИмяФайла.sad для сопоставлений безопасности. Эти файлы можно использовать как шаблоны для настройки нужных политик безопасности или сопоставлений безопасности, изменяя их в текстовом редакторе.

  • ipsec6 d [sp | sa] [Индекс]

    • Удаление указанных индексом политик безопасности (с использованием параметра sp) или сопоставлений безопасности (с использованием параметра sa) из списка активных политик безопасности и сопоставлений безопасности. Для просмотра индекса можно воспользоваться командой ipsec6 sp или ipsec6 sa.

  • ipsec6 m [on | off]

    • Определение состояния режима защиты обновления привязки, используемых для мобильных подключений IPv6, с помощью IPSec. По умолчанию этот режим включен.

Ping6.exe

Программа ping6.exe используется для отправки сообщений эхо-запросов ICMPv6, используемых для диагностики сети и проверки возможности доступа к конкретному адресу назначения.

Программа ping6.exe имеет следующий синтаксис:

ping6 [-t] [-a] [-n Число] [-l Размер] [-w Время ожидания] [-s АдресИсточника] [-r] {Имя|АдресНазначения[%КодОбласти]}

где:

  • -t — отправка пакетов на указанный узел до команды прерывания;
  • -a — разрешение адресов в имена компьютеров;
  • -n — отправка эхо-запросов, количество которых определяется параметром Число. По умолчанию количество равно 4.
  • -l — отправка эхо-запросов с объемом данных, определяемым параметром Длина. По умолчанию — 32 байта, максимум — 65527 байт.
  • -w — промежуток времени ожидания (в миллисекундах). По умолчанию — 4000.
  • -s — определение адреса источника в эхо-запросах. Требуется для адреса назначения локальной связи.
  • -r — задает использование заголовка расширения маршрутизации IPv6 для отправки эхо-запроса на локальный узел с использованием адреса назначения в качестве промежуточного назначения;
  • Имя — указывает имя назначения;
  • АдресНазначения — указывает адрес назначения;
  • КодОбласти — указывает область или зону назначения для эхо-запросов. Для адресов локальной связи КодОбласти равен индексу интерфейса, который отображается с помощью команды ipv6 if. Для адресов локального сайта КодОбласти равен номеру сайта, который отображается с помощью команды ipv6 if. Если используется один сайт, код области для адресов локального сайта не требуется. КодОбласти не требуется, когда адрес назначения является глобальным адресом.

Tracert6.exe

С помощью программы tracert6.exe можно отправлять эхо-запросы ICMPv6 для обнаружения и отображения пути между отправляющим узлом и узлом назначения.

Программа tracert6.exe имеет следующий синтаксис:

tracert6 [-d] [-h МаксимальноеЧислоПереходов] [-w ВремяОжидания] [-s АдресИсточника] [-r] {Имя|АдресНазначения[%КодОбласти]}

где:

  • -d — предотвращение выполнения обратных запросов DNS для каждого адреса промежуточного маршрутизатора;
  • -h — задает максимальное число переходов для пакетов tracert на пути к адресу назначения;
  • -w — промежуток времени ожидания (в миллисекундах). По умолчанию — 4000.
  • -s — указывает адрес источника в сообщениях с эхо-запросом;
  • -r — задает использование заголовка расширения маршрутизации IPv6 для отправки эхо-запроса на локальный узел с использованием адреса назначения в качестве промежуточного назначения;
  • Имя — указывает имя назначения;
  • АдресНазначения — указывает адрес назначения;
  • КодОбласти — указывает область или зону назначения для эхо-запросов. Для адресов локальной связи КодОбласти равен индексу интерфейса, который отображается с помощью команды ipv6 if. Для адресов локального сайта КодОбласти равен номеру сайта, который отображается с помощью команды ipv6 if. Если используется один сайт, код области для адресов локального сайта не требуется. КодОбласти не требуется, когда адрес назначения является глобальным адресом.

Netsh interface IPv6 6to4

В контексте netsh interface IPv6 6to4 можно использовать следующие команды для настройки или отображения параметров службы 6to4 на узле или маршрутизаторе 6to4. Дополнительные сведения об использовании службы 6to4 см. в разделе Трафик IPv6 между узлами в различных сайтах через Интернет (6to4).

Дополнительные сведения о команде Netsh см. в разделе Использование команды Netsh.

set interface

Настройка службы 6to4 на интерфейсе.

Синтаксис

set interface [name=] ИмяИнтерфейса [[routing=] enabled|disabled|default]

Параметры

name = ИмяИнтерфейса
Обязательный параметр. Указывает имя интерфейса, для которого требуется задать конфигурацию службы 6to4. Параметр ИмяИнтерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если ИмяИнтерфейса содержит пробелы, оно должно быть заключено в кавычки.
routing= enabled|disabled|default
Указывает состояние режима пересылки принятых пакетов 6to4 на данном интерфейсе: включен, отключен или по умолчанию.
/?
Отображает справку в командной строке.

Примечания

  • Данная команда включает, отключает или задает режим по умолчанию для службы 6to4 на указанном интерфейсе.
  • По умолчанию для параметра routing= задано значение enabled, включающее маршрутизацию на частных интерфейсах при использовании общего доступа к подключению Интернета (Internet Connection Sharing, ICS).

show interface

Отображение конфигурации службы 6to4 на всех интерфейсах или на указанном интерфейсе.

Синтаксис

show interface [[name=] ИмяИнтерфейса]

Параметры

name = ИмяИнтерфейса
Указывает имя интерфейса, для которого требуется отобразить конфигурацию службы 6to4. Параметр ИмяИнтерфейса должен совпадать с именем интерфейса, указанным в окне «Сетевые подключения». Если ИмяИнтерфейса содержит пробелы, оно должно быть заключено в кавычки.
/?
Отображает справку в командной строке.

Примечания

  • Если имя интерфейса не указано, отображается конфигурация 6to4 для всех интерфейсов.

set relay

Настройка имени 6to4 ретранслирующего маршрутизатора для службы 6to4. Кроме того, позволяет задать частоту разрешения имен и состояние ретранслирующего компонента для службы 6to4.

Синтаксис

set relay [[name=] DNS-ИмяРетранслятора|default] [[state=] enabled|disabled|automatic|default] [[interval=] ИнтервалРазрешения|default]

Параметры

name= DNS-ИмяРетранслятора|default
Указывает либо полное доменное имя (FQDN) ретранслирующего маршрутизатора 6to4 в Интернете по протоколу IPv4 (DNS-ИмяРетранслятора), либо задает для ретранслятора используемое по умолчанию имя 6to4.ipv6.microsoft.com (default).
state= enabled|disabled|automatic|default
Задает состояние ретранслирующего компонента для службы 6to4: включено, отключено, автоматически включено при использовании общего адреса IPv4 или по умолчанию.
interval= ИнтервалРазрешения|default
Задает интервал разрешения имени ретранслирующего маршрутизатора либо в минутах (ИнтервалРазрешения), либо по умолчанию в 1440 минут (default).
/?
Отображает справку в командной строке.

Примечания

  • Ретранслирующий маршрутизатор 6to4 служит точкой доступа между Интернетом по протоколу IPv4 и 6bone (часть Интернета, изначально использующая протокол IPv6). Для доступа к ресурсам 6bone с маршрутизатора 6to4 этот маршрутизатор инкапсулирует трафик 6to4 в заголовок IPv4 и отправляет его на адрес IPv4 ретранслирующего маршрутизатора 6to4. Ретранслирующий маршрутизатор 6to4 удаляет заголовок IPv4 и пересылает этот трафик в сеть 6bone. Для ответного трафика ретранслирующий маршрутизатор 6to4 инкапсулирует трафик IPv6 и отправляет его на маршрутизатор 6to4 в сайте узла 6to4.
  • По умолчанию для ретранслирующего маршрутизатора 6to4 задается имя 6to4.ipv6.microsoft.com.
  • По умолчанию задано состояние automatic, включающее пересылку исходного трафика IPv6 на ретранслирующий маршрутизатор в случае, когда любому из интерфейсов назначен адрес IPv4.
  • Интервал разрешения по умолчанию составляет 1440 минут (раз в день).

show relay

Отображение конфигурации ретранслирующего маршрутизатора для службы 6to4.

Синтаксис

show relay

set routing

Задает состояние маршрутизации и добавление префиксов адреса локального сайта в сообщения объявления маршрутизатора, отправляемые маршрутизатором 6to4.

Синтаксис

set routing [[routing=] enabled|disabled|automatic|default] [[sitelocals=] enabled|disabled|default]

Параметры

routing= enabled|disabled|automatic|default
Задает состояние маршрутизации на маршрутизаторе 6to4: включено, отключено, автоматически включено при использовании общего доступа к подключению Интернета или по умолчанию.
sitelocals= enabled|disabled|default
Задает режим включения в сообщения объявления маршрутизатора префиксов адреса локального сайта (помимо префиксов адреса 6to4): включено, отключено или по умолчанию.
/?
Отображает справку в командной строке.

Примечания

  • По умолчанию для параметра routing= задано значение automatic, включающее маршрутизацию на частных интерфейсах при использовании ICS.
  • По умолчанию для параметра sitelocals= задано значение enabled, включающее объявление префиксов локального сайта в том случае, если на частных интерфейсах настроены адреса локального сайта.

show routing

Отображение конфигурации маршрутизации для службы 6to4.

Синтаксис

show routing

set state

Отображение состояния маршрутизации для службы 6to4.

Синтаксис

set state [[state=] enabled|disabled|default] [[undoonstop=] enabled|disabled|default] [[6over4=] enabled|disabled|default]

Параметры

state= enabled|disabled|default
Задает состояние службы 6to4: включена, отключена или по умолчанию.
undoonstop= enabled|disabled|default
Задает режим реверсирования всех параметров, автоматически настраиваемых службой 6to4, при остановке этой службы: включено, отключено или по умолчанию.
6over4= enabled|disabled|default
Задает режим создания интерфейсов 6over4 для каждого настраиваемого адреса IPv4: включено, отключено или по умолчанию.
/?
Отображает справку в командной строке.

Примечания

  • По умолчанию для параметра state= задано значение enabled, включающее службу 6to4.
  • По умолчанию для параметра undoonstop= задано значение enabled, включающее реверсирование всех параметров, автоматически настраиваемых службой 6to4, при остановке этой службы.
  • По умолчанию для параметра 6over4= задано значение disabled, не разрешающее создание интерфейсов 6over4, соответствующих настроенным адресам IPv4.

show state

Отображение состояния службы 6to4.

Синтаксис

show state

reset

Сброс службы 6to4.

Синтаксис

reset


Устранение неполадок

Установите вид неполадки.

IPv6 не отображается в списке установленных протоколов.

Причина. Установка протокола IPv6 происходит без использования стандартной процедуры установки протокола в папке Сетевые подключения. Поэтому протокол IPv6 не отображается в списке установленных протоколов.

Решение. Отсутствует. Это не является неполадкой.

См. также: Установка протокола IPv6; Служебные программы IPv6

Невозможно определить, установлен протокол IPv6 или нет.

Причина. Протокол IPv6 не отображается в списке установленных протоколов в папке Сетевые подключения.

Решение. Введите в командной строке команду ipv6 if. Если протокол IPv6 установлен, на экран будет выведен список интерфейсов IPv6 и их конфигураций. В противном случае командой ipv6 будет выведено сообщение о том, что протокол IPv6 не установлен.

См. также: Установка протокола IPv6; Служебные программы IPv6

Маршрутизатор не объявляет себя основным маршрутизатором.

Причина. Компьютер с Windows XP, используемый как маршрутизатор IPv6, не объявляет себя основным маршрутизатором, если только он не использует основной маршрут (::/0), настроенный на публикацию.

Решение. Добавьте основной маршрут на маршрутизатор и укажите в настройке его публикацию с помощью команды ipv6 rtu.

См. также: Добавление маршрута IPv6; Служебные программы IPv6; Настройка тестовой лаборатории для протокола IPv6

На узле отсутствует основной маршрут.

Причина. Компьютер с Windows XP, используемый как маршрутизатор IPv6, не объявляет себя основным маршрутизатором, если только он не использует основной маршрут (::/0), настроенный на публикацию.

Решение. Добавьте основной маршрут на маршрутизатор и укажите в настройке его публикацию с помощью команды ipv6 rtu.

См. также: Добавление маршрута IPv6; Служебные программы IPv6; Настройка тестовой лаборатории для протокола IPv6

Адрес обладает неизвестным идентификатором интерфейса.

Причина. Локальный маршрутизатор настроен на объявление глобального префикса. По умолчанию анонимный адрес на основе глобального префикса настраивается автоматически.

Решение: Используйте команду ipv6 gpu UseTemporaryAddresses no для отключения анонимных адресов.

См. также: Идентификаторы интерфейса IPv6; Служебные программы IPv6

Обозревателю Internet Explorer не удается подключиться, если в адресе URL явно задан адрес IPv6.

Причина: Версия обозревателя Internet Explorer, поставляемая с Windows XP, не поддерживает формат литеральных адресов IPv6 в адресах URL, который описан в документе RFC 2732 «Формат литеральных адресов IPv6 в адресах URL».

Решение. Создайте запись DNS для ресурса AAAA, разрешающую имена веб-серверов в адрес IPv6, а затем используйте эти имена в адресах URL для обращения к соответствующим веб-серверам.

См. также: Приложения для протокола IPv6; Определение адресов по именам

В таблице маршрутизации присутствуют маршруты удаленной связи.

Причина. Когда маршрутизатор, работающий под управлением Windows XP, объявляет префиксы удаленной связи, он устанавливает зарезервированный бит данных префикса сообщения объявления маршрутизатора. Если узловой компьютер, работающий под управлением Windows XP, получает префикс удаленной связи с таким установленным битом, он добавляет в свою таблицу маршрутизации маршрут для объявленного префикса с адресом пересылки объявляющего маршрутизатора.

Решение. Отсутствует. Это не является неполадкой.

См. также: Маршрутизация протокола IPv6

При указании адреса локальной связи ping6 не удается отправить сообщения с эхо-запросом.

Причина. Не указан код области.

Решение. Эта обычная неполадка, возникающая при использовании адреса локальной связи. Обычно адреса локальной связи настраиваются автоматически для нескольких интерфейсов. Чтобы явно задать интерфейс для отправки сообщений с эхо-запросом, используйте синтаксис ping6 Адрес%КодОбласти, где КодОбласти является идентификатором интерфейса для отправки пакетов ping6.

См. также: Подсеть с адресами локальной связи; Служебные программы IPv6

Трафик IPSec не зашифрован.

Причина. Протокол IPv6 для Windows XP не поддерживает использование шифрования IPSec ESP. Однако поддерживается использование ESP с шифрованием NULL. Хотя способ шифрования NULL использует заголовок ESP, он обеспечивает только проверку подлинности и целостности данных.

Решение. Отсутствует. Это является текущим ограничением протокола IPv6 для Windows XP.

См. также: Средства безопасности; Использование политики IPSec между двумя узлами локальной связи

IPSec в IPv6 не работает из-за ограничений локальной политики IPSec или политики IPSec домена.

Причина. Поддержка IPSec для трафика IPv4 отличается от поддержки IPSec для трафика IPv6. Локальная политика IPSec и политика IPSec домена, определенные с помощью оснастки «Политика безопасности IP» или «Групповая политика», относятся только к трафику IPv4. Эти политики не оказывают влияния на трафик IPv6.

Решение. Отсутствует. Это является текущим ограничением протокола IPv6 для Windows XP.

См. также: Средства безопасности; Использование политики IPSec между двумя узлами локальной связи

Туннелированный трафик не доходит до конечного адреса.

Причина. Маршрутизаторы или брандмауэры отклоняют трафик IPv4, имеющий в поле IP Protocol значение 41.

Решение. Весь трафик IPv6, который инкапсулируется (туннелируется) внутри заголовка IPv4, имеет в заголовке значение 41 для поля IPv4 Protocol. Туннелирование трафика IPv6 включает трафик с IPv4-совместимыми адресами, адресами 6over4 и 6to4. Чтобы разрешить пересылку туннелированного трафика IPv6, настройте маршрутизаторы и брандмауэры так, чтобы они передавали трафик IPv4 со значением 41 в поле Protocol.

См. также: Средства безопасности; Использование политики IPSec между двумя узлами локальной связи

В программе netstat не отображается статистика для трафика IPv6.

Причина. Команда netstat не поддерживает трафик IPv6.

Решение. Отсутствует. Это является текущим ограничением команды netstat.

Для автоматического туннельного псевдоинтерфейса IPv4-совместимый адрес не настраивается автоматически.

Причина. Не одному из локальный интерфейсов не назначен общедоступный адрес IPv4.

Решение. Поскольку IPv4-совместимый адрес имеет глобальную область действия и является в ней уникальным, существование IPv4-совместимых адресов, производных от личных адресов, не допускается. Частные адреса для протокола IPv6 в Windows XP определены в следующем диапазоне: 10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16 и 169.254.0.0/16. Настройте общедоступный адрес IPv4 для одного из интерфейсов.

Не удается подключиться к другим узлам 6to4 или к 6bone через маршрутизатор 6to4.

Причина. Брандмауэр или маршрутизаторы в Интернете отклоняют трафик IPv4, имеющий в поле IP Protocol значение 41.

Решение. Весь трафик IPv6, который инкапсулируется (туннелируется) внутри заголовка IPv4, имеет в заголовке значение 41 для поля IPv4 Protocol. Туннелирование трафика IPv6 включает трафик с IPv4-совместимыми адресами, адресами 6over4 и 6to4. Чтобы разрешить пересылку туннелированного трафика IPv6, настройте маршрутизаторы и брандмауэры так, чтобы они передавали трафик IPv4 со значением 41 в поле Protocol.

Причина. Не удается определить адрес для DNS-имени 6to4.ipv6.microsoft.com.

Решение. По умолчанию служба 6to4 пытается определить по имени 6to4.ipv6.microsoft.com адрес IPv4, а затем выбрать соответствующий маршрутизатор. Если по имени 6to4.ipv6.microsoft.com не удается определить адрес, маршрутизатор выбран не будет, а сеть 6bone также не будет доступна. Введите ping 6to4.ipv6.microsoft.com, чтобы узнать, возможно ли определение адреса по имени 6to4.ipv6.microsoft.com.

Причина. Отсутствует правильный маршрут.

Решение. Просмотрите сведения, выводимые командой ipv6 rt. Обратите внимание на маршрут 2002::/16 -> 3. Этот маршрут задает передачу всего трафика 6to4 по туннельному интерфейсу 6to4.

Причина. Отсутствует правильный адрес.

Решение. Прежде чем обращаться к другим узлам, проверьте, назначен ли данному узлу адрес 6to4. Например, при отсутствии адреса 6to4 для обращения к глобальным адресам 6to4 может использоваться адрес локальной связи. Чтобы узнать конфигурацию локальных адресов, выполните команду ipv6 if.


IP версии 6

IP версии 6 (IPv6) представляет собой набор протоколов стандартных протоколов, являющихся следующим поколением протоколов сетевого уровня для Интернета.

  • Перед тем как приступить к использованию IPv6 на компьютере, ознакомьтесь с разделом Контрольный список: установка и настройка IPv6.
  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Общие сведения содержатся в разделе Основные понятия.
  • Инструкции по устранению неполадок содержатся в разделе Устранение неполадок.