Обзор программы "Удаленный рабочий стол"

При помощи удаленного рабочего стола можно получить доступ к сеансу Windows на своем компьютере, находясь при этом за другим компьютером. Это значит, что можно подключиться к рабочему компьютеру из домашнего компьютера и получить доступ ко всем программам, файлам и сетевым ресурсам (как если бы вы работали за рабочим компьютером).. Можно оставить программы выполняющимися на рабочем компьютере и дома продолжить работу с теми же программами, окна которых будут отображаться на экране домашнего компьютера.

При подключении к рабочему компьютеру программа "Удаленный рабочий стол" автоматически блокирует этот компьютер, чтобы другие пользователи не могли получить доступ к вашим приложениям и файлам. Отменить блокировку рабочего компьютера для продолжения работы на нем можно при помощи сочетания клавиш CTRL+ALT+DEL.

Вы можете оставить ваши программы работающими и сохранить состояние вашего сеанса Windows на время работы другого пользователя. Когда этот пользователь завершит сеанс, вы сможете возобновить подключение к вашему текущему сеансу.

С помощью быстрого переключения пользователей можно легко переключать пользователей на одном и том же компьютере. Допустим, при работе на домашнем компьютере необходимо войти в систему рабочего компьютера, чтобы обновить отчет о расходах. В это время одному из членов семьи необходимо проверить важное сообщение электронной почты. Можно отключить удаленный рабочий стол, чтобы другой пользователь вошел в систему и проверил электронную почту, а затем снова подключиться к рабочему компьютеру. При этом отчет о расходах будет отображен на экране в том виде, в каком он был в момент отключения. Быстрое переключение пользователей доступно на отдельных компьютерах и компьютерах, входящих в рабочую группу.

Удаленный рабочий стол можно использовать во множестве ситуаций, среди которых:

  • Работа дома. Доступ к рабочему компьютеру с домашнего компьютера, включая полный доступ к локальным и удаленным устройствам.
  • Совместная работа. Возможность открыть свой рабочий стол из офиса коллеги, чтобы работать вместе над проектами (например, над обновлением слайд-презентации или корректурой документа).
  • Общий доступ к консоли. Поддержка на одном компьютере сеансов нескольких пользователей с разными приложениями и параметрами (например, для продавцов или банковских служащих).

Для работы с удаленным рабочим столом требуются:

  • Компьютер ("главный" компьютер) под управлением Windows XP Professional с пакетом обновления 2 или Windows Server 2003 с пакетом обновления 2 ("удаленный" компьютер) с подключением к локальной сети или Интернету.
  • Второй компьютер ("клиентский" компьютер) с доступом к локальной сети через сетевое подключение, модем или виртуальную частную сеть (VPN). На этом компьютере должна быть установлена программа "Подключение к удаленному рабочему столу".
  • Соответствующие учетные записи пользователей и разрешения.


Лучшие решения по обеспечению безопасности

  • Добавьте себя в группу пользователей удаленного рабочего стола на своем компьютере. После этого не будет необходимости входить в систему с учетной записью администратора при удаленном доступе к компьютеру. Не следует добавлять себя в группу "Администраторы". Рекомендуется работать на компьютере с учетной записью администратора только при выполнении задач, для которых требуются права администратора. Для наилучшей работы входите в систему с учетной записью члена группы "Пользователи" и "Опытные пользователи". Если необходимо выполнить какое-либо действие, доступное только для администраторов, войдите в систему как администратор, выполните необходимые действия, а затем завершите сеанс. Дополнительные сведения см. в разделе Почему не следует работать на компьютере с учетной записью администратора.
  • Всем пользователям удаленного рабочего стола рекомендуется входить в систему, используя надежный пароль. Это особенно важно, если компьютер подключен к Интернету с помощью кабельного модема или подключение DSL. Дополнительные сведения см. в разделе Создание надежных паролей.


Различия между удаленным рабочим столом и удаленным помощником

Удаленный рабочий стол и удаленный помощник используют одинаковую технологию, однако в их работе есть различия.

При помощи удаленного рабочего стола можно получить доступ к сеансу Windows на своем компьютере, находясь при этом за другим компьютером. Например, с помощью удаленного рабочего стола можно подключиться к рабочему компьютеру из дома и получить доступ к программам, файлам и сетевым ресурсам, как если бы вы работали за своим рабочим компьютером.

Удаленный помощник позволяет помощнику — например, коллеге — воспользоваться Интернет-соединением для доступа к вашему компьютеру для оказания помощи. Помощник может видеть экран вашего компьютера и общаться с вами через окно разговора. При наличии соответствующего разрешения помощник может использовать удаленное управление компьютером для устранения возникших неполадок.


Настройка данного компьютера на использование удаленного рабочего стола

Рисунок Microsoft Windows

Настройка данного компьютера на использование удаленного рабочего стола

  1. Щелкните значок Система на панели управления.
  2. На вкладке Удаленное использование в разделе Дистанционное управление рабочим столом выберите Разрешить удаленный доступ к этому компьютеру.
  3. Нажмите кнопку Выбрать удаленных пользователей. Если вы являетесь администратором компьютера, ваша текущая учетная запись пользователя будет автоматически добавлена в список удаленных пользователей. В этом случае можно пропустить два следующих шага.
  4. В диалоговом окне Пользователи удаленного рабочего стола нажмите кнопку Добавить.
  5. В диалоговом окне Выбрать пользователей выполните следующие действия:
    • Чтобы указать местоположение поиска, нажмите кнопку Размещение, выберите папку, в которой нужно выполнить поиск, и нажмите кнопку OK.
    • В поле Введите имена выбираемых объектов введите имя пользователя, которого нужно добавить, и нажмите кнопку OK.

    Имя появится в списке пользователей в диалоговом окне "Пользователи удаленного рабочего стола".

Примечание

  • Для включения функции удаленного рабочего стола необходимо войти в систему с учетной записью администратора или быть членом группы "Администраторы".


Настройка домашнего компьютера для использования удаленного рабочего стола

Настройка домашнего компьютера для использования удаленного рабочего стола

На рабочем компьютере

Перед началом работы убедитесь, что у вас есть необходимые разрешения на использование удаленного рабочего стола. Для этого необходимо быть администратором или входить в группу пользователей удаленного рабочего стола. Если вы не уверены в наличии необходимых разрешений, обратитесь к администратору.

  1. Активируйте подключение к удаленному рабочему столу на вашем офисном компьютере.
    1. Щелкните значок Система на панели управления.
    2. На вкладке Удаленное использование в разделе Дистанционное управление рабочим столом выберите Разрешить удаленный доступ к этому компьютеру.
    3. Нажмите кнопку Выбрать удаленных пользователей. Если вы имеете права администратора на данном компьютере, текущая учетная запись пользователя будет автоматически добавлена в список удаленных пользователей. В этом случае следующие два шага можно пропустить.
    4. В диалоговом окне Пользователи удаленного рабочего стола нажмите кнопку Добавить.
    5. В диалоговом окне Выбрать пользователей выполните следующие действия:
      • Чтобы указать местоположение поиска, нажмите кнопку Размещение, выберите папку, в которой нужно выполнить поиск, и нажмите кнопку OK.
      • В поле Введите имена выбираемых объектов введите имя пользователя, которого нужно добавить, и нажмите кнопку OK.

      Имя появится в списке пользователей в диалоговом окне "Пользователи удаленного рабочего стола".

  2. Запишите имя офисного компьютера.

    Чтобы узнать имя офисного компьютера, в панели управления щелкните значок Система и выберите вкладку Имя компьютера. Имя вашего компьютера указано после надписи Полное имя компьютера (имя компьютера — это последовательность знаков до первой точки).

  3. Оставьте офисный компьютер включенным.
  4. Распечатайте этот раздел и выполните эти инструкции на вашем домашнем компьютере. Чтобы распечатать раздел, щелкните правой кнопкой мыши в любом месте раздела, после чего щелкните Печать.

На домашнем компьютере

  1. Подключитесь к вашей рабочей сети при помощи виртуальной частной сети (VPN), локального сетевого подключения (LAN) или модема.
  2. Откройте программу Подключение к удаленному рабочему столу, нажав кнопку Пуск и выбрав пункт Программы или Все программы, а затем Стандартные и Подключение к удаленному рабочему столу.
  3. Введите имя офисного компьютера и нажмите кнопку Подключить.


Получение программного обеспечения клиента удаленного рабочего стола

Получение программного обеспечения клиента удаленного рабочего стола

  • На компьютере под управлением Windows XP с пакетом обновления 2 (SP2) загрузите с веб-узла Центра обновления Майкрософт и установите пакет подключения к удаленному рабочему столу.


Установка программы "Подключение к удаленному рабочему столу" (32-разрядные компьютеры)

Установка программы "Подключение к удаленному рабочему столу" (32-разрядные компьютеры)

  • На компьютере под управлением Windows XP с пакетом обновления 2 (SP2) загрузите с веб-узла Центра обновления Майкрософт и установите пакет подключения к удаленному рабочему столу.


Установка клиента служб терминалов (16-разрядные компьютеры)

Установка клиента служб терминалов (16-разрядные компьютеры)

Содержимое данного раздела удалено, поскольку оно недействительно для данной версии программы "Подключение к удаленному рабочему столу".


Установка клиента служб терминалов (компьютеры Windows NT 3.51)

Установка клиента служб терминалов (компьютеры Windows NT 3.51)

Содержимое данного раздела удалено, поскольку оно недействительно для данной версии программы "Подключение к удаленному рабочему столу".


Использование программы "Интернет-подключение к удаленному рабочему столу"

В данном разделе содержатся общие сведения о программе "Интернет-подключение к удаленному рабочему столу".

  • О программе "Интернет-подключение к удаленному рабочему столу"
  • Настройка программы "Интернет-подключение к удаленному рабочему столу"
  • Установка программы "Интернет-подключение к удаленному рабочему столу"
  • Подключение к другому компьютеру с помощью программы "Интернет-подключение к удаленному рабочему столу"


О программе "Интернет-подключение к удаленному рабочему столу"

Можно подключиться к удаленному компьютеру через Интернет с помощью программы "Интернет-подключение к удаленному рабочему столу". Для этого на удаленном компьютере должна быть установлена ОС Windows и программа "Интернет-подключение к удаленному рабочему столу".

Для подключения к удаленному компьютеру с помощью программы "Интернет-подключение к удаленному рабочему столу" требуется только подключение к Интернету. Эта программа использует Интернет для подключения к веб-странице, после чего подключается к удаленному компьютеру по протоколу RDP. Преимущество этой программы заключается в том, что она позволяет администратору использовать одну конфигурацию для всех удаленных сеансов, не требуя публикации RDP-файлов или открытия к ним совместного доступа.

Сначала администратор должен настроить удаленный (главный) компьютер, чтобы он принимал входящие подключения. Администратором может быть пользователь (вы или сетевой администратор), обладающий возможностью разрешить входящие подключения на удаленном компьютере.

Инструкции по использованию программы "Интернет-подключение к удаленному рабочему столу" см. в разделе Подключение к другому компьютеру с помощью программы "Интернет-подключение к удаленному рабочему столу".


Настройка Интернет-подключения к удаленному рабочему столу

Программа "Интернет-подключение к удаленному рабочему столу" состоит из двух частей — программного обеспечения веб-сервера и клиентского подключения к веб-серверу.

Программное обеспечение веб-сервера для Интернет-подключения к удаленному рабочему столу не устанавливается по умолчанию. Установка этого приложения выполняется при помощи компонента "Установка и удаление программ". Инструкции по установке см. в разделе Установка программы "Интернет-подключение к удаленному рабочему столу". (Этот процесс также устанавливает IIS (Internet Information Services).)

При установке программного обеспечения веб-сервера для Интернет-подключения к удаленному рабочему столу по умолчанию файлы копируются в папку веб-сервера %SYSTEMROOT%\Web\Tsweb.

Чтобы подключиться к веб-серверу, на котором запущена программа "Интернет-подключение к удаленному рабочему столу", клиентский компьютер должен обладать подключением к Интернету или сети по протоколу TCP/IP и на нем должен быть запущен обозреватель Internet Explorer.

Дополнительные сведения см. в следующих разделах.

  • Подключение к другому компьютеру с помощью программы "Интернет-подключение к удаленному рабочему столу"


Установка программы "Интернет-подключение к удаленному рабочему столу"

Установка программы "Интернет-подключение к удаленному рабочему столу"

  1. На панели управления откройте компонент Установка и удаление программ.
  2. Нажмите кнопку Установка компонентов Windows.
  3. Выберите компонент Internet Information Services (IIS) и нажмите кнопку Состав.
  4. В списке Internet Information Services - состав выберите элемент Служба WWW и нажмите кнопку Состав.
  5. В списке Служба WWW - состав установите флажок Интернет-подключение к удаленному рабочему столу, нажмите кнопку OK, после чего снова нажмите кнопку OK еще раз.
  6. В окне мастера компонентов Windows нажмите кнопку Далее.

Примечания

  • XOX
  • IIS не устанавливается по умолчанию в Windows XP Professional.
  • Для выполнения этой процедуры необходимо войти в систему с учетной записью администратора. Если ваш компьютер подключен к сети, параметры сетевой политики могут запретить выполнение данной процедуры.
  • XOX
  • Сведения об использовании программы "Интернет-подключение к удаленному рабочему столу" с клиентского компьютера см. в разделе Подключение к другому компьютеру с помощью программы "Интернет-подключение к удаленному рабочему столу".

См. также


Подключение к другому компьютеру с помощью программы "Интернет-подключение к удаленному рабочему столу"

Подключение к другому компьютеру с помощью программы "Интернет-подключение к удаленному рабочему столу"

С помощью программы "Интернет-подключение к удаленному рабочему столу" можно подключиться к удаленному компьютеру через Интернет. Для этого на удаленном компьютере должна быть установлена ОС Windows и программа "Интернет-подключение к удаленному рабочему столу". Подключение к удаленному компьютеру через Интернет:

  1. Откройте Internet Explorer или другой веб-обозреватель и введите URL-адрес (имя или IP-адрес удаленного компьютера и за ним /tsweb/). Например:
    • Для имени компьютера "MyComputer" следует ввести http://mycomputer/tsweb/.
    • Для IP-адреса компьютера 192.168.1.120 нужно ввести http://192.168.1.120/tsweb/.
  2. В окне регистрации Интернет-подключения к удаленному рабочему столу введите имя сервера (имя удаленного компьютера), а затем нажмите кнопку Подключить.
  3. Введите имя пользователя и пароль, после чего нажмите кнопку OK.

Чтобы отключиться, завершите сеанс, после чего закройте свой веб-обозреватель.

Примечание

  • Если используется брандмауэр и не удается подключиться к удаленному компьютеру, откройте TCP-порт 80. Инструкции по открытию портов см. в документации брандмауэра.


Отключение удаленного управления рабочим столом

Отключение удаленного управления рабочим столом

  1. Щелкните значок Система на панели управления.
  2. На вкладке Удаленное использование в разделе Дистанционное управление рабочим столом установите флажок Не разрешать подключения к этому компьютеру и нажмите кнопку OK.

Примечания

  • Чтобы отключить удаленное управление рабочим столом, необходимо войти в систему как администратор или член группы "Администраторы".
  • XOX


Разрешение подключения других пользователей к компьютеру

Разрешение подключения других пользователей к компьютеру

  1. Щелкните значок Система на панели управления.
  2. На вкладке Удаленное использование в разделе Дистанционное управление рабочим столом выберите Разрешить удаленный доступ к этому компьютеру.
  3. Нажмите кнопку Выбрать удаленных пользователей. Если вы имеете права администратора на данном компьютере, текущая учетная запись пользователя будет автоматически добавлена в список удаленных пользователей. В этом случае следующие два шага можно пропустить.
  4. В диалоговом окне Пользователи удаленного рабочего стола нажмите кнопку Добавить.
  5. В диалоговом окне Выбрать пользователей выполните следующие действия:
    • Чтобы указать местоположение поиска, нажмите кнопку Размещение, выберите папку, в которой нужно выполнить поиск, и нажмите кнопку OK.
    • В поле Введите имена выбираемых объектов введите имя пользователя, которого нужно добавить, и нажмите кнопку OK.

    Имя появится в списке пользователей в диалоговом окне "Пользователи удаленного рабочего стола".

Примечание

  • Необходимо иметь учетную запись администратора компьютера или входить в группу "Администраторы", чтобы добавлять пользователей в группу удаленных пользователей.

См. также


Изменение значка ярлыка файла подключения.

Изменение значка ярлыка файла подключения

  1. Откройте папку, где расположен RDP-файл.
  2. Щелкните файл правой кнопкой мыши и выберите пункт Создать ярлык.
  3. Щелкните ярлык правой кнопкой мыши, выберите команду Свойства и нажмите кнопку Изменить значок.
  4. В диалоговом окне Смена значка щелкните значок и нажмите кнопку OK.
  5. В диалоговом окне Свойства ярлыка нажмите кнопку OK.

Примечания

  • Чтобы создать RDP-файл, откройте окно подключения к удаленному рабочему столу, нажав кнопку Пуск и выбрав пункты Программы или Все программы, Стандартные, а затем Подключение к удаленному рабочему столу. Щелкните Параметры, измените настройки и щелкните Сохранить или Сохранить как.
  • По умолчанию RDP-файлы сохраняются в папке "Мои документы". Используемый по умолчанию RDP-файл (default.rdp) сохраняется как скрытый файл.


Устранение неполадок

  • Устранение неполадок при появлении сообщений об общих ошибках
  • Устранение неполадок при появлении сообщений об ошибках лицензирования
  • Устранение отдельных неполадок


Совместное использование папки установки клиента

Совместное использование папки установки клиента

Содержимое данного раздела удалено, поскольку оно недействительно для данной версии программы "Подключение к удаленному рабочему столу".