Общие сведения о модемах

Телефонные линии, используемые в обычных телефонных системах, предназначены для передачи человеческой речи с помощью аналоговых сигналов. Аналоговые сигналы постоянно изменяются, подобно волнам, на протяжении всего своего пути. Компьютеры сохраняют и обрабатывают данные в цифровом виде; как внутри компьютеров, так и между ними данные передаются в виде двоичных чисел.

Когда два компьютера соединены друг с другом по обычной телефонной линии, модем преобразует двоичные данные, передаваемую компьютером-отправителем, в аналоговый сигнал, который может передаваться по телефонной линии. На другом конце другой модем преобразует аналоговый сигнал обратно в цифровой формат, который может воспринимать компьютер-получатель. Преобразование сигнала из цифрового в аналоговый формат называется модуляцией, а обратное преобразование из аналогового формата в цифровой — демодуляцией. Термином модем (сокращение от слов модулятор/демодулятор) обозначаются устройства, выполняющие эти преобразования.

Такие преобразования выполняют как обычные модемы, так и факс-модемы. Существуют также модемы ISDN, DSL и кабельные модемы, которые обеспечивают цифровое взаимодействие. Эти модемы не выполняют преобразования цифровых и аналоговых сигналов. Они позволяют компьютерам обмениваться данными в цифровом формате без преобразования. Для связи по аналоговым телефонным линиям необходимы обычные модемы.

Скорость, с которой модемы передают данные, называется пропускной способностью. Скорость измеряется в битах в секунду (бит/c).

Преобразование цифровых сигналов в аналоговые и наоборот выполняется в соответствии с патентованными и международными стандартами, называемыми модемными протоколами. Улучшение протоколов позволило достичь более высокой пропускной способности. Кроме более эффективного использования доступной полосы пропускания, протоколы реализуют сжатие данных, обеспечивающее более высокие скорости передачи, и контроль ошибок для большей надежности. Протоколы для модемов, работающих на скорости 56 килобит в секунду (Кбит/с, Kbps), теперь позволяют принимать данные от поставщика услуг Интернета, подключенного к цифровой линии, а отправлять данные — с помощью стандартного цифро-аналогового преобразования.

Windows поддерживает много разных модемов. В XOX Microsoft эти модемы тестировались с компонентом Сетевые подключения. Если модема нет в этом списке, он, вероятно, будет все же нормально работать в Windows, особенно если его изготовитель предоставляет установочный диск или INF-файл для Windows. Некоторые модемы совместимы с поддерживаемыми модемами и могут быть установлены с использованием сведений о них. Более подробные сведения см. в документации по имеющемуся модему. Установочные файлы и другие полезные сведения часто можно загрузить с веб-узла изготовителя модема.

См. также


Общие сведения об установке модемов

Чтобы установить модем на компьютер, ознакомьтесь с его документацией. В большинстве случаев будут полезны следующие инструкции.

  • Если модем внутренний и имеет перемычки, установите перемычки в режим Plug and Play для XOX или, если этот режим недоступен, для Windows 95, Windows 98, Windows NT, Windows 2000 или Windows Millennium Edition. Инструкции по установке перемычек см. в документации модема.
  • Вставьте внутренний модем в свободное гнездо. Подключите внешний последовательный модем к неиспользуемому коммуникационному порту.
  • Если модем является внешним, то перед включением компьютера и запуском Windows убедитесь, что модем подключен к компьютеру и включен.
  • Убедитесь, что модем правильно подключен к телефонной линии и к компьютеру.

Большинство современных модемов совместимо со стандартом Plug and Play и устанавливается автоматически после подключения к компьютеру. Однако старые модемы и внешние модемы с последовательным интерфейсом могут не обнаруживаться. Если модем не был установлен автоматически, установите его вручную с помощью компонента панели управления «Телефон и модем». XOX


Установка модема

Рисунок Microsoft Windows

Чтобы установить модем

XOX

  1. Откройте окно Телефон и модем в панели управления.

    При появлении запроса сведений о местоположении введите параметры набора номера для текущего местоположения и нажмите кнопку OK.

  2. На вкладке Модемы нажмите кнопку Добавить.
  3. Следуйте инструкциям мастера установки модема.

Примечания

  • XOX
  • Если мастер установки модема не обнаружил модем или если модем отсутствует в списке, щелкните ссылку См также для получения инструкций по установке неподдерживаемого модема.
  • Если в комплекте поставки внешнего модема отсутствует кабель, обратитесь к документации по модему, чтобы выяснить, кабель какого типа требуется. Для подключения годится большинство обычных кабелей, но в некоторых кабелях используются не все контакты. Не используйте переходники с 9 на 25 контактов, которые часто поставляются в комплекте с мышью, т. к. некоторые из них не подходят для модемов. XOX


Установка неподдерживаемого модема

Чтобы установить неподдерживаемый модем

XOX

  1. Откройте окно Телефон и модем в панели управления.

    При появлении запроса сведений о местоположении введите параметры набора номера для текущего местоположения и нажмите кнопку OK.

  2. На вкладке Модемы нажмите кнопку Добавить.
  3. В мастере установки модема установите флажок Не определять тип модема (выбор из списка) и нажмите кнопку Далее.
  4. Выполните одно из следующих действий.
    Если | Выполните следующее действие
    в списке есть модем, совместимый с имеющимся модемом | выберите в списке изготовителя и модель модема, который лучше всего подходит для имеющегося модема, и нажмите кнопку Далее.
    модема нет в списке и есть установочный диск или INF-файл, предоставленный изготовителем | нажмите кнопку Установить с диска и укажите местоположение диска или INF-файла.
  5. Следуйте дальнейшим инструкциям мастера установки модема.

Примечания

  • XOX
  • Если это возможно, получите у изготовителя самый новый установочный диск или INF-файл для модема, предназначенный для XOX. Необходимые файлы часто можно загрузить с веб-узла изготовителя. Если установочные файлы XOX недоступны, можно попробовать воспользоваться установочным диском или INF-файлом для Windows 95, Windows 98, Windows NT, Windows 2000 или Windows Millennium Edition. Он может подойти и для XOX.
  • Если для модема нет установочных файлов, то в инструкциях изготовителя, поставляемых вместе с модемом, могут быть указаны совместимые с ним модели. В противном случае выберите строку (Стандартный модем) в списке Изготовители и выберите стандартный модем, скорость которого совпадает со скоростью имеющегося модема.
  • Если в комплекте поставки внешнего модема отсутствует кабель, обратитесь к документации по модему, чтобы выяснить, кабель какого типа требуется. Для подключения модема подходят многие, но не все, кабели. В некоторых кабелях используются не все контакты. Не используйте переходники с 9 на 25 контактов, которые часто поставляются в комплекте с мышью, т. к. некоторые из них не подходят для модемов.


Настройка установленного модема

Чтобы настроить установленный модем

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить, и нажмите кнопку Свойства.
  3. Внесите любые из следующих изменений.
    Чтобы | Выполните следующее действие
    Изменить громкость динамика, максимальную скорость порта или включить/отключить ожидание гудка в линии. | Откройте вкладку Модем.
    Просмотреть диагностические сведения, включая поддерживаемые модемом команды, или просмотреть журнал операций модема. | Откройте вкладку Диагностика.
    Добавить дополнительные команды инициализации. | Откройте вкладку Дополнительные параметры связи.
    Изменить параметры вызова (отключение и режим ручного набора номера) или параметры подключения (скорость порта, протокол передачи данных, сжатие и управление потоком). | Откройте вкладку Дополнительные параметры связи и нажмите кнопку Изменить умолчания.
    Изменить параметры настройки оборудования (биты данных, четность, стоповые биты или модуляция). | Откройте вкладку Дополнительные параметры связи, нажмите кнопку Изменить умолчания и откройте вкладку Дополнительные параметры связи.

Примечание

  • XOX


Смена COM-порта для модема

Чтобы сменить COM-порт для модема

XOX

  1. Откройте окно Телефон и модем на панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить, и нажмите кнопку Свойства.
  3. На вкладке Дополнительные параметры связи нажмите кнопку Дополнительная настройка порта.

    Отсутствие этой кнопки означает, что модем не поддерживает смену назначенного COM-порта.

  4. В списке Номер COM-порта выберите порт, который требуется использовать.

Примечания

  • XOX
  • Не изменяйте данный параметр, если это не требуется для конфигурации системы. При установке модема коммуникационный порт в подавляющем большинстве случаев назначается правильно.
  • Дополнительная настройка COM-порта доступна только для некоторых моделей модемов. Если имеющийся модем не входит в их число, то для смены назначенного COM-порта нужно будет переустановить модем и выбрать требуемый COM-порт.


Физическое подключение оборудования

Модем должен быть подключен к телефонной системе и к источнику питания.

Телефонные подключения

И внутренние, и внешние модемы используют телефонный кабель с разъемами RJ-11. Обычно этот кабель поставляется в комплекте с модемом. Если в помещении используются старые, четырехконтактные, розетки, для подключения модема может потребоваться специальный адаптер.

Если офис оборудован цифровыми, многоканальными телефонами или внутренней АТС, модем нельзя будет подключить напрямую к телефонной системе. Нужно будет либо провести обычную телефонную линию, либо установить устройство для подключения модема к одной из этих систем. Обратитесь за помощью к поставщику компьютера или телефонной системы.

Питание

Внутренние модемы питаются от шины компьютера. Внешние модемы обычно поставляются с адаптером питания, но некоторые из них используют питание компьютера. Многие портативные модемы для переносных компьютеров используют батареи, хотя часто в комплекте с ними поставляются и адаптеры. Некоторые используют питание компьютера. Модемы используют различные виды адаптеров, поэтому в случае утери адаптера необходимо будет приобрести у изготовителя модема или компьютера новый адаптер. Дополнительные сведения о требованиях к питанию компьютера см. в его документации.

Последовательные кабели

Внешние модемы с последовательным интерфейсом подключаются к компьютеру при помощи последовательного кабеля, называемого также кабелем RS-232. Если в комплекте поставки модема кабель отсутствует, убедитесь, что используемый вами кабель подходит и для последовательного порта компьютера, и для порта модема.


Подключение с помощью модема

Поддерживается использование модема для выполнения следующих действий.

Действие | Раздел
Подключение к Интернету | Создание подключения к Интернету
Установление прямого соединения с другим компьютером. | Прямые подключения
Отправка и прием факсов (при наличии факс-модема). | Использование клиента службы факсов
Вход в сеть или подключение к другому компьютеру. | Подключения удаленного доступа

Примечание

  • Можно также установить коммуникационные программы других разработчиков. Они могут предоставлять дополнительные функции или служить для определенных целей, например для подключения к интерактивной службе.


Дублирование установки модема на несколько портов

Чтобы дублировать установку модема на несколько портов

XOX

  1. Установите модем, который требуется дублировать, хотя бы на один порт.

    Если модем еще не установлен, щелкните ссылку См. также.

  2. Откройте окно Телефон и модем в панели управления.
  3. На вкладке Модемы щелкните правой кнопкой мыши модем, который требуется дублировать на другие порты.
  4. Выберите команду Дублировать.
  5. Выберите способ дублирования модема: на все порты в списке или только на выбранные порты.
    • Выберите переключатель Все порты, чтобы продублировать установку модема на все порты, присутствующие в списке.
    • Выберите переключатель Выбранные порты и выберите порты, на которые требуется продублировать установку модема.

Примечания

  • XOX
  • С помощью этой процедуры можно быстро продублировать установку модема при установке модемов одной и той же модели и одного и того же изготовителя на несколько портов.


Копирование свойств модема модемам на других портах

Чтобы скопировать свойства модема модемам на других портах

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы щелкните правой кнопкой мыши модем, свойства которого требуется скопировать.
  3. Выберите команду Копировать свойства.
  4. Щелкните правой кнопкой мыши модем, которому требуется скопировать свойства, а затем выберите команду Применить свойства.

Примечания

  • XOX
  • Используйте эту процедуру для быстрого копирования изменений в свойствах модема модемам на других портах.


Удаление модема

Чтобы удалить модем

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется удалить.
  3. Нажмите кнопку Удалить.

Примечание

  • XOX


Проверка модема

Чтобы выполнить проверку модема

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется проверить.
  3. Нажмите кнопку Свойства, откройте вкладку Диагностика, а затем нажмите кнопку Опросить модем.

Примечания

  • XOX
  • Эта процедура посылает модему стандартные AT-команды и выводит ответы модема, содержащие сведения о поддерживаемых им возможностях.


Ведение и просмотр журнала команд модема

Чтобы включить ведение журнала команд модема или просмотреть журнал команд

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, для которого требуется вести журнал команд.
  3. Нажмите кнопку Свойства, а затем откройте вкладку Диагностика.
  4. В группе Ведение журнала установите флажок Добавить в журнал (в XOX Professional) или Вести журнал (в Windows 2000 Server).

Примечания

  • XOX
  • Чтобы просмотреть файл журнала, нажмите кнопку Просмотр журнала. Этот файл идентифицирует модем и содержит сведения о его работе.
  • Команды, отправляемые модему, сохраняются в файле

    СистемныйКорневойКаталог\System32\ModemLog_модель.txt.

    Обычно используется путь C:\Windows\System32\. Модель представляет имя модема в том виде, в котором оно присутствует в списке установленных модемов на вкладке Модемы диалогового окна «Телефон и модем».


Общие сведения о диагностике модема

Проверить правильность работы модема можно с помощью диагностического средства, предоставляемого компонентом «Телефон и модем» панели управления. XOX

Про опросе модема XOX пытается отправить ему следующие команды и выводит результаты их выполнения.

Команда | Ответ
ATQ0V1E0 | Инициализация запроса.
AT+GMM | Модель (рекомендацию ITU V.250 поддерживают не все модемы).
AT+FCLASS=? | Факс-классы, поддерживаемые модемом.
AT#CLS=? | Показывает, поддерживает ли модем набор голосовых команд Rockwell.
ATIn | Вывод сведений изготовителя для n = 1 до 7. В их число входит скорость порта, результат проверки контрольной суммы и информация о модели. Результаты, которые должны выводиться при выполнении этой команды, описаны в документации по данному модему.

Можно также вести журнал команд, посылаемых модему коммуникационными программами или операционной системой.


Устранение неполадок с модемами

Вид неполадки

Диагностика модема указывает, что внешний последовательный модем не получает команды.

Причина. Если диагностика показывает, что модем не получает команды, причиной может быть повреждение кабеля.

Решение. Попробуйте подключить модем другим кабелем.

Кабель модема в порядке, но модем все равно не получает команды.

Причина. Модем установлен неправильно.

Решение. Обратитесь к документации по модему, чтобы обеспечить правильность его установки.

Модем установлен правильно, но диагностика указывает, что он неправильно реагирует.

Причина. При установке модема в Windows были неправильно указаны изготовитель или модель, либо для установки использовался устаревший INF-файл.

Решение. Проверьте документацию по модему, чтобы узнать изготовителя и модель данного модема или совместимого с ним, и переустановите модем. Выясните у изготовителя, нет ли более новых установочных файлов для установки этого модема.

Согласно диагностике, модем работает, но он все еще не может установить подключение.

Причина. Модем неправильно подключен к телефонной линии или неисправна сама телефонная линия.

Решение. Проверьте подключение к телефонной линии. Если модем подключен правильно, необходимо проверить телефонную линию.

Невозможно установить подключение или возникают проблемы при подключении к другому компьютеру или к поставщику интерактивных служб.

Причина. Параметры подключения (см. раздел Параметры оборудования) двух модемов не совпадают. Чтобы два модема могли успешно установить связь, параметры подключения обоих модемов должны совпадать.

Решение. Проверьте параметры оборудования модемов на обоих компьютерах. Обычно используются следующие параметры: восемь битов данных, без четности, один стоповый бит.

При подключении к поставщику интерактивных услуг прочитайте документацию, предоставленную этим поставщиком, чтобы выяснить правильные параметры. Здесь обычно используются такие же параметры: восемь битов данных, без четности, один стоповый бит. Их используют электронные доски объявлений и большинство поставщиков услуг. Если эти параметры не подходят, попробуйте следующий набор: семь битов данных, проверка на четность, один стоповый бит. С такими параметрами работают некоторые поставщики интерактивных услуг. Другие значения этого набора параметров встречаются крайне редко.

После установки в компьютер платы PCMCIA-модема она не обнаруживается автоматически.

Причина. Встроенный COM-порт платы не настроен.

Решение. Настройте встроенный COM-порт платы с помощью компонента панели управления Установка оборудования. Затем можно установить PCMCIA-модем с помощью компонента панели управления Телефон и модем (см. раздел Установка модема).

Последовательное устройство с интерфейсом RS-232 работает плохо или совсем не работает.

Причина. В настоящее время некоторые последовательные устройства RS-232 поддерживают скорости, превышающие 115,2 килобита в секунду (Кбит/с), которую имеют стандартные последовательные порты, установленные на большинстве компьютеров. (Например, некоторые последовательные устройства поддерживают скорость в 230 Кбит/с.)

Решение. Если значение в поле Скорость порта в группе параметров подключения превышает 115,2 Кбит/с, попробуйте уменьшить скорость до 115,2 Кбит/с. Значение в поле Скорость порта для модема на вкладке Общие окна свойств модема можно оставить максимальным. Если последовательный порт компьютера поддерживает скорости более 115,2 Кбит/с, выберите в поле Скорость порта то из двух значений, которое меньше: скорость последовательного порта или скорость устройства.

В окне «Сетевые подключения» выводится сообщение, что порт подключения занят или не настроен для удаленного доступа.

Причина. Есть несколько возможных причин.

  • При запуске Windows модем Plug and Play был отсоединен или выключен, поэтому он не был правильно обнаружен.
  • Порт используется другой программой, такой как «Факс» или «Телефон».
  • Подключение могло быть не обновлено для учета изменений в коммуникационном оборудовании, таких как добавление последовательных портов или модемов.

Решение. Используйте одно из следующих решений.

  • Если модем был отсоединен или выключен, подсоедините или включите его и либо перезапустите Windows, либо выполните поиск нового оборудования с помощью диспетчера устройств.
  • Если коммуникационный порт уже используется другим подключением, прервите его или смените используемый подключением порт.
  • Если конфигурация оборудования была изменена (например, добавлен последовательный порт или модем), необходимо перенастроить подключение.

См. также. Настройка подключения; Переустановка устройства Plug and Play.

Примечания

  • Сведения по диагностике и устранению неполадок модема с помощью интерактивного средства диагностики неполадок см. в разделеДиагностика неполадок с модемами. Сведения о диагностике модема см. в разделе Проверка модема. Список команд, поддерживаемых модемом, и его ответов можно найти в документации к нему или получить в службе поддержки.
  • Рекомендуется записывать вносимые изменения параметров и переключателей модема. Это позволит при необходимости вернуть модем в предыдущее состояние.
  • При возникновении неполадок модема может потребоваться обратиться к системному администратору, изготовителю модема или поставщику. В свой запрос включите журнал модема, в который заносится информация о попытках подключения к другим системам. Сведения о создании журнала модема см. в разделе Ведение и просмотр журнала команд модема.


Повышение скорости работы модема

Если при наличии модема на 33,6 Кбит/с (протокол V.34) подключение постоянно осуществляется на скоростях 26 Кбит/с или выше либо если при наличии модема на 56 Кбит/с (протоколы V.90, K56flex и X2) прием данных от поставщиков услуг Интернета или интерактивных услуг происходит на скоростях 40000 бит/с и выше, то повысить скорость работы довольно сложно. Большинство телефонных линий не позволяет передавать данные с более высокой скоростью. Указанные скорости достигаются, если качество соединения близко к идеальному.

Если подключение постоянно происходит на меньших скоростях (24 Кбит/с или меньше для модема на 33,6 Кбит/с или меньше 40 Кбит/с для модема на 56 Кбит/с), можно попробовать выполнить следующие действия.

  • Проверьте, что в компоненте панели управления «Телефон и модем» перечислены соответствующие изготовитель и модель модема. Если указан не тот модем, выполните шаги, описанные в разделе Установка неподдерживаемого модема, чтобы правильно установить модем.
  • Выясните, не предлагает ли изготовитель модема обновленный установочный диск или файл .inf. Эти файлы часто можно найти на веб-узле или электронной доске объявлений изготовителя.
  • Для модемов на 33,6 Кбит/с убедитесь, что в поле Скорость порта для модема выбрано значение 38 400 бит/с или выше (рекомендуется 57 600). Для модемов на 56 Кбит/с должно быть установлено значение 115 200 бит/с. Инструкции см. в разделе Изменение максимальной скорости порта модема.
  • Убедитесь, что модем работает в нормальных температурных условиях. Многие модемы работают лучше, если температура не слишком высока и не чересчур низка. Не создавайте препятствий для воздушного потока: не кладите различные предметы на модем или компьютер, под них или за ними.
  • Попробуйте установить подключение по телефонным номерам, заведомо поддерживающим данную скорость. Это позволяет выяснить, где находится проблемный участок: у вас или на другом конце соединения.
  • Убедитесь, что по местному номеру действительно выполняется местный звонок. Многие поставщики интерактивных услуг перенаправляют местные вызовы в удаленные точки, обеспечивая тем самым службу местных вызовов. Это хорошо работает на скорости 14 400 бит/с, но может ухудшить сигнал и сделать использование более высоких скоростей невозможным.
  • Если на телефонной линии используется устройство подавления помех, попробуйте использовать модем без него. Учтите, однако, что при этом ваше оборудование лишится защиты, обеспечиваемой этим устройством.
  • Попросите специалиста проверить телефонную проводку, ведущую к компьютеру. Неисправная проводка, паяные соединения, длинные соединительные кабели, другое оборудование (телефоны, факс-аппараты и даже другие модемы) могут вызвать ухудшение сигнала. Чтобы отличить проблемы проводки от проблем линии, проверьте качество голосовых вызовов как при подключенной локальной проводке, так и напрямую в телефонной линии при отключенной локальной проводке. Многие телефонные компании теперь подключают внешнюю линию с помощью разъема, который пользователь может самостоятельно отключить для выполнении этой проверки.

Телефонные компании обычно не гарантируют возможность передачи данных на определенной скорости. В ответ на просьбу к телефонной компании исправить зашумленную линию можно услышать, что необходимо использовать специальную линию передачи данных или защищенную от помех линию. Подобное решение обычно является довольно дорогим. Модемы могут хорошо работать на голосовых линиях хорошего качества. В идеале следовало бы проверить линию связи не стандартным прибором, а с помощью хорошей аппаратуры (устройства для измерения ошибок в канале связи или специальной аппаратуры для проверки линии передачи данных). Можно также попросить телефонную компанию подключить к вашему дому другую пару проводов, ведущих из центрального офиса. Иногда проблему удается устранить, поменяв телефонный номер.


Сведения об особенностях некоторых модемов

В этом разделе приведены сведения об особенностях некоторых модемов, поддерживаемых компонентом «Сетевые подключения». XOX

Особенности некоторых модемов

Модемы, поддерживаемые компонентом Сетевые подключения, не обязательно способны работать во всех режимах с другими модемами, присутствующими в списке совместимого оборудования Microsoft Windows.

Например, некоторые модемы V.32bis не работают со скоростью порта 14400 бит/с, хотя они поддерживают эту скорость для передачи данных между модемами. Если имеющийся модем V.32bis не работает на начальной скорости 14400 бит/с, следует изменить скорость на 19200 бит/с.

Внутренние модемы

Некоторые внутренние модемы, такие как Digicom Scout Plus, не определяются автоматически. Такие модемы нужно устанавливать вручную с помощью панели управления.

Ответный звонок

Модемы, поддерживаемые в качестве серверных, могут не поддерживать функцию ответного звонка при использовании в качестве клиентских модемов.


Ввод команд инициализации

Чтобы ввести команды инициализации

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить.
  3. Нажмите кнопку Свойства, а затем откройте вкладку Дополнительно.
  4. В поле Дополнительные команды инициализации введите команды, которые должны отправляться модему во время его инициализации.

Примечания

  • XOX
  • Вводите команды в точности так, как они должны отправляться, без каких-либо дополнительных пробелов или символов. Префикс AT использовать не обязательно.
  • Введенные здесь команды будут отправлены после стандартных команд инициализации выбранного модема. Это позволяет настроить работу и конфигурацию модема в соответствии с требованиями, предъявляемыми используемой коммуникационной программой или поставщиком услуг. Дополнительные сведения о командах, поддерживаемых модемом, можно найти в документации по модему или на веб-узле его изготовителя.


Выбор страны или региона

Чтобы выбрать страну или регион

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить.
  3. Нажмите кнопку Свойства, а затем откройте вкладку Дополнительно.
  4. В группе Выбор страны или региона выберите страну или регион, из которых выполняется набор номера.

Примечания

  • XOX
  • Возможность настройки модема для использования телефонных сетей различных стран и регионов может отсутствовать. Если требуется настроить модем для различных стран и регионов, но группа Выбор страны и региона не отображается, обратитесь к изготовителю модема за обновлением.


Ожидание гудка в линии перед набором номера

Чтобы включить ожидание гудка в линии перед набором номера

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить, и нажмите кнопку Свойства.
  3. На вкладке Модем установите флажок Дождаться сигнала "Линия свободна".

Примечания

  • XOX
  • Если флажок Дождаться сигнала "Линия свободна" снят, модем будет набирать номер, не ожидая гудка в линии. Это может быть необходимо, если телефонной линии не используется стандартный гудок.


Регулировка громкости динамика модема

Чтобы отрегулировать громкость динамика модема

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить, и нажмите кнопку Свойства.
  3. На вкладке Модем перетащите ползунок Громкость динамика влево или вправо, чтобы установить нужную громкость.

Примечания

  • XOX
  • Некоторые модемы не позволяют регулировать громкость динамика.


Задание времени ожидания перед отключением

Чтобы задать время ожидания перед отключением

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить, и нажмите кнопку Свойства.
  3. Откройте вкладку Дополнительные параметры связи и нажмите кнопку Изменить умолчания.
  4. На вкладке Общие в группе Параметры вызова можно выполнять следующие действия.
    5. Чтобы | Выполните следующее действие
Выполнять автоматическое отключение, если соединение не используется в течение определенного времени. | Установите флажок Отключение при простое более и введите число минут, в течение которого модем будет поддерживать неиспользуемое соединение перед отключением.
Изменить время, отводимое на установление нового соединения. | Введите в поле Отмена вызова при отсутствии связи нужное число секунд.

Примечания

  • XOX
  • Учтите, что эти значения используются по умолчанию. Если соответствующие параметры задаются и в прикладной программе, то параметры программы будут иметь преимущество.
  • Если используется подключение по сети, то время ожидания перед отключением определяется параметрами сетевого подключения, а не значением, указанным в свойствах модема. Для получения сведений о настройке подключения щелкните ссылку См. также.


Изменение максимальной скорости порта модема

Чтобы изменить максимальную скорость порта модема

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить, и нажмите кнопку Свойства.
  3. На вкладке Модем выберите нужную скорость в списке Скорость порта для модема.

Примечания

  • XOX
  • При установке модема это значение обычно устанавливается надлежащим образом.
  • Это значение определяет максимальную скорость, с которой программам разрешено передавать данные модемам; оно обычно превышает номинальную скорость модема. Например, для модемов V.34 со скоростью 33,6 Кбит/с часто устанавливается скорость 57600 бит/с.
  • При изменении этого значения также устанавливается текущая скорость модема. Для просмотра описания процедуры изменения параметров подключения, позволяющей задать другое значение текущей скорости, щелкните ссылку См. также.


Повышение скорости передачи данных

Параметры скорости модема обычно задаются надлежащим образом при установке. В окне «Телефон и модем» устанавливаются две разные скорости: Скорость порта для модема в общих свойствах модема и Скорость порта в параметрах, используемых по умолчанию. Оба этих параметра определяют скорость, с которой коммуникационные программы отправляют данные модему, а не скорость передачи данных между локальным и удаленным модемами.

Параметр Скорость порта для модема задает максимальную скорость, с которой программам разрешается отправлять данные модему. Большинство программ устанавливает собственные скорости передачи данных, а этот параметр задает их верхний предел. Параметр Скорость порта представляет текущую скорость порта для модема. Значения этих двух параметров обычно совпадают, но встречаются ситуации, когда одно из них нужно изменить. Не изменяйте эти скорости только для того, чтобы привести их в соответствие с номинальной скоростью модема.

Измерение скорости модема

Скорость соединения определяют несколько отдельных компонентов. Когда программа или устройство сообщает о скорости передачи, нужно понимать, о какой скорости идет речь. Например, если модем на V.34 со скоростью 33,6 килобит в секунду (Кбит/с) сообщает о скорости соединения в 38,4 Кбит/с или даже больше, имеется в виду скорость порта, с которой данные передаются от компьютера модему, а не скорость передачи данных между модемами.

На практике часто нужно знать реальную пропускную способность соединения, то есть скорость, с которой данные передаются между коммуникационной программой на локальном компьютере и программой на удаленном компьютере. Коммуникационные программы обычно сообщают реальную скорость передачи данных между ними; эта скорость часто выражается либо в битах в секунду (бит/с, bps), либо в символах в секунду (симв/c, cps). Для последовательных соединений скорость в битах в секунду приблизительно в 10 раз больше скорости в символах в секунду.

Установив сеанс связи с удаленным компьютером, проверьте пропускную способность. Начальная скорость передачи не обязательно дает правильное представление о скорости передачи в дальнейшем. После установления соединения модемы могут повышать или понижать скорость обмена данными. Это зависит от качества соединения и от некоторых других факторов.

Скорости передачи для прямых последовательных соединений

При создании прямого последовательного соединения с другим компьютером или устройством, может потребоваться настроить максимальную скорость порта для этого соединения. Начальная скорость для прямых соединений устанавливается в 19,2 Кбит/с. Для устройств Windows CE или других устройств, поддерживающих более высокие скорости передачи, можно изменить соответствующим образом максимальную скорость порта. Сведения о скорости передачи, поддерживаемой таким устройством, см. в его документации.


Достижение высоких скоростей при работе с модемом на 56 Кбит/с

Чтобы модемное соединение поддерживало скорости передачи в 56 килобит в секунду (Кбит/с) (такие соединения еще называются соединениями V.90), должны выполняться три условия.

  • Обслуживающий сервер должен использовать цифровое подключение к сети. Поставщик услуг Интернета может сообщить, поддерживает ли он услуги по подключению на скорости 56 Кбит/с.
  • На обоих концах соединения должен поддерживаться один и тот же протокол — стандарт V.90 или один из его предшественников, K56flex или 3COM/USR X2. Например, если поставщик услуг Интернета использует устройства V.90, модем также должен поддерживать протокол V.90.
  • Между модемом и обслуживающим компьютером может быть только одно аналоговое соединение. Телефонные линии, имеющиеся в большинстве домов, являются аналоговыми линиями.

Если хотя бы одно из этих требований не выполняется, модем будет использовать самый быстрый протокол из числа пригодных для соединения. Например, модем V.90 на 56 Кбит/с может выполнить откат до протокола V.34 на скорости 33,6 Кбит/с при невозможности установления соединения V.90. Но даже если эти три требования выполняются, другие факторы могут снизить скорость передачи или вероятность установления соединения на максимальной скорости. Например, старые линии или линии, подверженные помехам, могут уменьшить скорость передачи данных. В таком случае не следует удивляться, если максимальная скорость передачи будет составлять не более 26 Кбит/с.

Устройства, улучшающие качество голосовой телефонной связи, также могут негативно влиять на модемные соединения V.90 на скорости 56 Кбит/с. Нагрузочные катушки, размещаемые на проводах большой длины для улучшения качества голосовой связи, обычно не препятствуют соединениям V.90, но могут снизить скорость передачи. Цифровые компенсаторы, выполняющие балансировку громкости голосовой связи, обычно не препятствуют соединениям V.90, но тоже могут снизить скорость передачи. Аналоговые компенсаторы делают невозможными соединения по протоколу V.90, так как они преобразовывают цифровые данные в аналоговые, чтобы сбалансировать громкость, а затем — обратно в цифровые. Тем самым на линии добавляется еще один аналоговый участок.

На практике скорость в 56 Кбит/с, поддерживаемая протоколом V.90 и другими протоколами, недостижима. Установленные правительством США правила, регулирующие безопасность общественных телефонных систем, в настоящее время ограничивают скорость передачи значением 53 Кбит/с. Шумы в телефонной линии и другие ограничения обычно удерживают среднюю скорость передачи в диапазоне от 40 до 50 Кбит/с.


Изменение параметров подключения

Чтобы изменить параметры подключения

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить, нажмите кнопку Свойства, откройте вкладку Дополнительные параметры связи и нажмите кнопку Изменить умолчания.
  3. На вкладке Общие в группе Параметры подключения линии данных выберите новые значения в полях Скорость порта, Протокол, Сжатие и Управление потоком.

Примечания

  • XOX
  • При установке модема эти значения обычно устанавливаются надлежащим образом.


Общие сведения о протоколах и стандартах

Стандарты модуляции публикуются сектором телекоммуникационных стандартов международного телекоммуникационного союза (ITU-T). Эти стандарты ITU-T обычно называются V-стандартами (V-series), так как их обозначения имеют префикс V (например, V.34). Суффиксы bis и terbo, которые имеют некоторые из этих стандартов, обозначают вторую и третью редакцию.

Частные компании, например Bell Systems, Western Electric и AT&T, также установили стандарты, которые прежде находили широкую поддержку. Сейчас они в большинстве своем либо устарели, либо используются совместно со стандартами ITU-T. В частности, стандарты Bell когда-то широко использовались в США и по-прежнему поддерживаются многими модемами для обеспечения совместимости со старыми устройствами.

Более новые протоколы обычно предназначены для более высоких скоростей связи. Чтобы два модема могли взаимодействовать друг с другом, они должны поддерживать один и тот же протокол. Набор микросхем модема определяет поддерживаемые модемом протоколы и скорости, на которых он может передавать данные. Драйвер, установленный на компьютере, выполняет те же функции для программных модемов.

Совместимость и скорость

Модемы различных изготовителей и даже различные модели одного изготовителя могут быть несовместимы по некоторым параметрам и режимам. Даже модемы, для которых утверждается, что они поддерживают набор AT-команд Hayes, иногда не могут установить связь с другими Hayes-совместимыми модемами.

Поскольку высокая скорость передачи данных достигается различными разработчиками модемов разными путями, проблема совместимости становится еще более актуальной для высокоскоростных модемов. Даже те модемы, которые удовлетворяют стандартам модуляции, сжатия и исправления ошибок, иногда не могут устанавливать связь друг с другом на высоких скоростях. Поэтому быстрые протоколы имеют возможность отката до уровня более медленных протоколов.

При соединении двух модемов вызывающий модем посылает смодулированный определенным образом сигнал. Если отвечающий модем поддерживает эту модуляцию, устанавливается соединение. В противном случае модемы пытаются выбрать другой, менее производительный, тип модуляции, и этот процесс продолжается до тех пор, пока они не найдут модуляцию, поддерживаемую ими обоими. Модемы обычно производят откат по стандартным модуляциям ITU-T. Модем V.90 выполняет откат до V.34, а модем V.34 — до V.32bis, а затем до V.32.

Даже после установки соединения с использованием определенной модуляции два модема могут также выполнить откат до более медленной скорости, если они не в состоянии поддерживать надежное соединение. Например, соединения по протоколам V.32bis и V.34 могут устанавливаться на следующих скоростях.

Модуляция | Скорости соединения (бит/с)
V.32bis | 14,400, 12,000, 9600, 7000
V.34 | 33 600, 31 200, 28 800, ..., 2400

Так как модем может либо выполнить откат до более медленного протокола, либо просто снизить скорость, не меняя протокола, то более низкие скорости передачи не обязательно свидетельствуют о неполадке линии или модема.


Общие сведения о протоколе модуляции V.90

Windows поддерживает модемы, имеющие скорость передачи 56 килобит в секунду (Кбит/с). Международным стандартом для модемов на 56 Кбит/с является протокол V.90. Этот протокол разработан для соединений поставщик услуг Интернета (ISP)-клиент. Протокол V.90, как и предшествовавшие ему патентованные протоколы K56flex и X2, отличается от предыдущих протоколов тем, что реализует разные скорости передачи данных в направлениях обслуживающий компьютер - клиент и клиент - обслуживающий компьютер. Протокол V.90 обеспечивает скорости передачи до 56 Кбит/с от обслуживающего компьютера поставщика услуг клиенту и до 33,6 Кбит/с от клиента обслуживающему компьютеру.

Технология модемов на 56 Кбит/с использует преимущества цифрового подключения к обычной телефонной сети, используемого в настоящее время большинством поставщиком услуг Интернета и поставщиками других интерактивных услуг. Так как при передаче данных с обслуживающего компьютера преобразование аналогового сигнала в цифровой не выполняется, она может вестись на более высоких скоростях.

При отправке данных клиент должен по-прежнему выполнять аналого-цифровое преобразование. Поэтому данные от клиента обслуживающему компьютеру передаются по протоколу V.34, позволяющему передавать данные со скоростью не выше 33,6 Кбит/с. На самом деле это не такое уж значительное ограничение, так как насыщенные графикой веб-страницы, аудио- и видеофайлы загружаются от поставщика услуг на скорости, близкой к скорости ISDN. От клиента обслуживающему компьютеру передаются, в основном, нажатия клавиш и щелчки мыши, для чего не требуется особенно быстрой передачи.

Стандарт V.90 совместим с предыдущими коммуникационными стандартами, такими как V.34. Когда модем V.90 подключается к удаленному компьютеру, на котором поддерживается протокол V.90, он проверяет линию, чтобы определить, выполняет ли обслуживающий компьютер при передаче данных аналогово-цифровые преобразования. Если такие преобразования обнаруживаются, модем переключается на использование протокола V.34. Модем V.90 также пытается использовать протокол V.34, если удаленный компьютер не поддерживает протокол V.90.


Скорость передачи данных

При создании подключения удаленного доступа его скорость определяют три различных компонента.

  • Скорость локального интерфейса — скорость соединения между компьютером и подключенным к нему модемом, также называемая скоростью DTE (Data Terminal Equipment).
  • Скорость соединения — скорость, с которой данные передаются между модемами по линиям связи, также называемая скоростью DCE (Data Communications Equipment).
  • Скорость удаленного интерфейса — скорость, с которой данный передаются между принимающим модемом и компьютером.

Реальная скорость передачи данных между компьютерами зависит от всех трех этих факторов. Для продаваемых модемов их изготовители обычно указывают максимальную скорость соединения. Максимальная скорость порта, которую можно задать в компоненте Телефон и модем панели управления, представляет максимальную скорость локального интерфейса, которую могут использовать коммуникационные программы для отправки данных модему. Скорость удаленного интерфейса может также ограничить скорости передачи данных. Например, для достижения максимальной скорости обмена данными интерактивная служба должна поддерживать именно тот протокол 56 Кбит/с, который используется вашим модемом.

Многие современные высокоскоростные модемы фиксируют определенное значение скорости своего локального интерфейса, а не подстраивают ее под скорость соединения. Поэтому скорость локального интерфейса обычно бывает выше, чем реальная скорость передачи данных по телефонной линии. Например, у модема V.34, поддерживающего скорость 33,6 Кбит/с, скорость порта может быть установлена в значение 115,2 Кбит/с.

Это различие, называемое буфером скорости, позволяет модему казаться быстрее, чем реальная скорость соединения. Модем может сжимать данные и отправлять их меньшим числом битов. Так как для передачи сжатых данных требуется меньшее число битов, сжатые данные передаются быстрее, чем несжатые. Модем V.34 может достигать скорости передачи данных 33,6 Кбит/с, даже если линия физически способна передавать меньшее число битов.


Управление потоком

Во взамодействие вовлечено шесть различных каналов связи: от компьютера-отправителя к модему-отправителю, от модема-отправителя к модему-приемнику, от модема-приемника к его компьютеру, а также обратный поток данных по этим трем каналам. Во всех каналах скорости передачи данных могут быть различными. Если модем-приемник временно не может принять данные, ему нужно каким-то образом сообщить модему-отправителю о необходимости замедлить или приостановить передачу данных. Управление потоком и является способом, позволяющим модему управлять скоростью передачи данных модемами-отправителями.

Если управление потоком настроено неправильно, то подключение к удаленной системе может оказаться невозможным, скорость передачи может быть существенно снижена, а соединение может постоянно разрываться. Если при загрузке файлов возникает множество ошибок или повторов передачи данных, проверьте параметры управления потоком как для модема, так и в коммуникационной программе. Параметры управления потоком, используемые и коммуникационной программой, и модемом, должны совпадать. Многие коммуникационные программы устанавливают их автоматически на основании параметров модема, но некоторые программы требуют отдельной настройки.

Аппаратное управление потоком

При аппаратном управлении потоком (RTS/CTS) поток данных контролирует модем. Его следует применять для всех высокоскоростных модемов или модемов, выполняющих сжатие данных.

Программное управление потоком

Программное управление потоком (также называемое XON/XOFF или CTRL+S/CTRL+Q) для сообщения о необходимости приостановки или возобновления передачи информации использует специальные символы. Это позволяет модему путем отправки управляющего символа сигнализировать модему-отправителю о необходимости прекращения передачи.

Программное управление потоком работает медленнее, чем аппаратное, и использовать его, обычно, менее желательно. Программное управление потоком следует применять только для передачи текста. Его нельзя использовать при передаче двоичной информации, так как в ней наверняка встретятся символы, используемые в качестве кодов управления потоком.


Сжатие данных

Сжатие данных позволяет передавать информацию со скоростью, превышающей реальную скорость соединения. Данные, особенно текст и графика, обычно содержат повторяющиеся последовательности. Принцип сжатия данных состоит в замене часто повторяющихся последовательностей символов меньшим числом символов и передаче только одной копии повторяющихся последовательностей данных.

Наиболее часто используемыми методами сжатия данных являются MNP 3, MNP 4, MNP 5 и V.42bis.

Эффективность сжатия зависит от данных. Текст и графика часто сжимаются довольно существенно. Сжатие уже сжатых данных, скорее всего, будет гораздо менее эффективным. Протокол V.42bis обеспечивает лучшее сжатие данных по сравнению с другими протоколами.

Чтобы протоколы исправления ошибок и сжатия данных работали, их должны поддерживать модемы на обоих концах соединения. После соединения двух модемов они автоматически выполняют согласование, чтобы определить лучший протокол, поддерживаемый ими обоими. Например, если протокол V.42bis не подходит, резервом служит протокол MNP 5, а если не подходит и этот протокол, то резервом служит параметр «без сжатия».

Для достижения максимальных скоростей передачи данных требуется аппаратное управление потоком, а максимальная скорость порта должна в два-четыре раза превышать номинальную скорость модема. При установке модема эти параметры обычно устанавливаются надлежащим образом. Если известно, какой тип сжатия поддерживается имеющимся модемом, можно вычислить скорость передачи данных, умножив скорость модема на приведенный выше коэффициент. Например, для модема на 14,4 Кбит/с с протоколом сжатия V.42bis следует выполнить следующие вычисления.

14,4 Кбит/с x 4 = 57,6 Кбит/с

Полученное значение является максимальной скоростью передачи данных модемом. Реальная же пропускная способность зависит от данных.

Программное сжатие данных

Коммуникационное программное обеспечение, например Сетевые подключения, может поддерживать сжатие данных. Например, используя модем на 56 Кбит/с с протоколом V.90, можно включить программное сжатие данных и добиться средней скорости передачи данных около 44 Кбит/с. Тесты показывают, что программное сжатие данных может обеспечивать более высокую скорость передачи данных, чем аппаратное.

Если используется программное сжатие, то, вероятно, нужно будет изменить параметры модема. Для достижения лучших результатов выполните следующие действия.

  • Включите режим исправления ошибок, выбрав в поле Протокол значение Стандартный EC или Форсированный EC.
  • Отключите аппаратное сжатие, выбрав в поле Сжатие значение Отключено.
  • Включите программное сжатие в коммуникационной программе.


Включение аппаратного или программного сжатия

Чтобы включить аппаратное или программное сжатие

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить.
  3. Нажмите кнопку Свойства.
  4. Откройте вкладку Дополнительные параметры связи.
  5. Нажмите кнопку Изменить умолчания.
  6. В группе Параметры подключения линии данных выберите в поле Сжатие значение Включено или Отключено.

Примечания

  • XOX
  • Некоторые коммуникационные программы обеспечивают эффективное программное сжатие. Если используется такая программа, отключение аппаратного сжатия часто позволяет повысить скорость передачи данных.


Общие сведения о настройке оборудования

Параметры подключения модема включают настройки оборудования, определяющие порядок отправки и получения данных модемами.

Биты данных

Параметр «Биты данных» обозначает число битов в слове. Большинство систем в настоящее время использует для представления символов данных восемь битов (расширенный ASCII). В редких случаях некоторые старые системы по-прежнему используют семь битов.

Четность

Параметр «Четность» определяет способ, который модем использует для обнаружения ошибок. Возникающие в линии шумы могут добавлять или изменять биты данных, передаваемых по телефонной сети. В старых методах модуляции четность использовалась для выявления таких ошибок. Когда проверка четности включена, передающий модем добавляет к пакету данных бит четности таким образом, чтобы число единичных битов пакета стало четным или нечетным. Принимающий модем подсчитывает число единичных битов в принятых данных и принимает или отклоняет пакет в зависимости от того, четной или нечетной является полученная сумма.

Доступно несколько вариантов настройки четности.

Значение | Описание
Чет | Установка бита четности в 0 или 1 так, чтобы общее число единичных битов было четным.
Нечет | Установка бита четности в 0 или 1 так, чтобы общее число единичных битов было нечетным.
Нет | Бит четности не отправляется.
Маркер (1) | Бит четности всегда имеет значение 1.
Пробел (0) | Бит четности всегда имеет значение 0.

Большинство модемных соединений в настоящее время использует более надежные и сложные способы обнаружения ошибок, поэтому этот параметр обычно устанавливают в значение Не проверяется.

Стоповые биты

Стоповые биты обрамляют пакеты данных в асинхронной связи. Они служат для уведомления принимающего модема о посылке байта данных. Современные асинхронные протоколы не используют больше одного стопового бита.

Модуляция

В параметрах оборудования модуляция задает протокол, используемый модемом для преобразования цифровых данных в звуковые сигналы, передаваемые по обычной телефонной линии. Это обязательное условие правильной передачи данных.

Для обеспечения совместимости с сигналами модема на компьютере, с которым устанавливается соединение, можно переключить тип модуляции. Большинство модемов поддерживают стандартный тип модуляции, но если не удается установить связь, попробуйте использовать нестандартный тип модуляции. В число таких типов входят протоколы Bell для старых модемов и патентованные протоколы, например HST компании US Robotics.


Изменение параметров настройки оборудования

Чтобы изменить параметры настройки оборудования

XOX

  1. Откройте окно Телефон и модем в панели управления.
  2. На вкладке Модемы выберите модем, который требуется настроить, и нажмите кнопку Свойства.
  3. Откройте вкладку Дополнительные параметры связи.
  4. Нажмите кнопку Изменить умолчания.
  5. Откройте вкладку Дополнительные параметры связи.
  6. В группе Параметры настройки оборудования выберите нужные значения в полях Биты данных, Четность, Стоповые биты и Модуляция.

Примечания

  • XOX
  • При установке модема эти значения обычно устанавливаются надлежащим образом.


Дата компиляции

Дата компиляции: 2003-12-03