Очередь сообщений

Очередь сообщений (Message Queueing, MSMQ) — это инфраструктура передачи сообщениями и средство разработки распределенных приложений обмена сообщениями для операционных систем Microsoft Windows. Такие приложения могут производить передачу данными в неоднородных сетях, а также управлять обменом сообщений между компьютерами, которые временно не способны установить соединение друг с другом. Очередь сообщений обеспечивает гарантированную доставку сообщений, эффективную маршрутизацию, безопасность, поддержку передачи сообщений в рамках транзакций и обработку сообщений на основе приоритетов.

Особый интерес очередь сообщений представляет для системных администраторов (занимающихся установкой инфраструктуры и управлением ее работой) и для разработчиков программного обеспечения (создающих приложения обмена сообщениями). Настоящая документация адресована системным администраторам и потому затрагивает лишь вопросы управления инфраструктурой, образуемой службой очереди сообщений, но не вопросы разработки приложений. Дополнительные сведения о разработке приложений очереди сообщений см. в материалах пакета Message Queuing Software Development Kit (SDK), который входит в пакет Microsoft Platform SDK, содержащийся в библиотеке Microsoft Developer Network (MSDN) Library. Дополнительные сведения о доступе к пакету Message Queuing SDK см. в материалах Microsoft Platform Software Development Kit.

  • Прежде чем проводить установку или обновление очереди сообщений, изучите Контрольный список: Установка клиентов очереди сообщений.
  • Список возможностей, перенесенных на платформу Windows XP, см. в разделе Новые способы выполнения некоторых задач.
  • Советы по использованию очереди сообщений содержатся в разделе Советы и рекомендации.
  • За помощью при выполнении конкретных задач обращайтесь к разделам Инструкции.
  • Сведения общего характера см. в разделе Основные понятия.
  • Указания по устранению возникающих проблем см. в разделе Устранение неполадок.

© Корпорация Майкрософт (Microsoft Corporation), 1997-2001.
Все права защищены.


Контрольный список: Установка клиентов очереди сообщений

Данный контрольный список используется при установке клиентов очереди сообщений на компьютеры, работающие под управлением Windows XP, на которых не установлена предыдущая версия очереди сообщений. По умолчанию в составе Windows XP очередь сообщений не устанавливается.

Действие | Ссылка
Ознакомьтесь с основными понятиями и сформулируйте требования к клиенту. | Компьютеры с очередями сообщений
Ознакомьтесь с предварительными требованиями к системе. | Установка очереди сообщений: обзор
Обзор и устранение сложностей, которые могут возникнуть во время установки. | Устранение неполадок при установке очереди сообщений
Войдите в систему с разрешениями локального администратора (как член локальной группы «Администраторы»). | Разрешения, необходимые для установки в разделе «Установка очереди сообщений: обзор».
Для зависимого клиента необходим сервер очереди сообщений с функциями независимого клиента, при этом желательно, чтобы он был расположен в том же сайте в который производится установка. Любой такой сервер, функционирующий в режмие домена, может служить поддерживающим сервером. | Установка зависимого клиента
Запустите Мастер компонентов Windows и выберите подкомпоненты, обеспечивающие соответствующие требования клиента. | Установка независимых клиентов; Установка зависимых клиентов
Убедитесь, что служба «Очередь сообщений» запущена. | Запуск и остановка служб очереди сообщений
Отправьте тестовое сообщение. | Отправка тестовых сообщений

Примечания

  • Новые возможности очереди сообщений Windows XP, такие как транспорт HTTP, триггеры очередей сообщений и рассылка сообщений нескольким получателям недоступны зависимым клиентам. Таким образом, поддержка списков рассылки, многоэлементных имен форматов и многоадресных сообщений для зависимых клиентов отсутствует.
  • Зависимые клиенты не будут поддерживаться в последующих версиях очереди сообщений.


Новые способы выполнения некоторых задач

В следующей таблице перечислены некоторые общие задачи, связанные с очередью сообщений, которые выполняются с помощью различных пользовательских интерфейсов в Windows XP и Windows NT 4.0.

Таблица различий в архитектуре и терминологии между данной версией очереди сообщений и ее предыдущими версиями содержится в разделе Обновление очереди сообщений: обзор.

Операция | В Windows NT 4.0 используйте | В Windows XP
Задание прав доступа, аудита доступа или смена владельца очереди сообщений | MSMQ Explorer | Откройте оснастку Active Directory – пользователи и компьютеры. Дополнительные сведения содержатся в разделе Безопасность очереди сообщений: обзор.
Смена учетной записи службы очереди сообщений | Компонент Службы на панели управления | Откройте компонент Управление компьютером. Дополнительные сведения содержатся в разделе Смена учетной записи службы очереди сообщений.
Настройка маршрутных ссылок | MSMQ Explorer | Откройте оснастку Active Directory – сайты и службы. Дополнительные сведения содержатся в разделе Администрирование сети, в которой используется очередь сообщений.
Создание инородных сайтов и добавление инородных компьютеров | MSMQ Explorer | Откройте оснастку Active Directory – сайты и службы. Дополнительные сведения содержатся в разделе Администрирование сети, в которой используется очередь сообщений.
Настройка компьютеров и свойств очереди сообщений, задание квот и свойств компьютеров | MSMQ Explorer | Откройте оснастку Active Directory – пользователи и компьютеры. Дополнительные сведения содержатся в разделе Администрирование компьютеров с очередями сообщений.
Установка свойств DNS для компьютеров с очередями сообщений | Компонент Сеть панели управления. | На панели управления откройте компонент Сетевые подключения. Дополнительные сведения содержатся в разделе Задание свойств DNS на компьютерах, использующих очередь сообщений.
Создание, удаление и настройка очередей, задание квот и свойств очередей | MSMQ Explorer | Откройте окно Управление компьютером или Active Directory - пользователи и компьютеры. Дополнительные сведения содержатся в разделе Администрирование очередей в очередях сообщений.
Просмотр и удаление сообщений, просмотр свойств сообщения | MSMQ Explorer | Откройте окно Управление компьютером или Active Directory - пользователи и компьютеры. Дополнительные сведения содержатся в разделе Администрирование сообщений в очередях сообщений.

В следующей таблице перечислены некоторые общие задачи, связанные с очередью сообщений, которые выполняются с помощью различных пользовательских интерфейсов в Windows XP и Windows 2000.

Операция | В Windows 2000 используйте | В Windows XP
Указание нового сайта для мобильных компьютеров | Значок Очередь сообщений на панели управления | Откройте компонент Управление компьютером. Дополнительные сведения содержатся в разделе Указание нового сайта для мобильных компьютеров.
Смена поддерживающего сервера для зависимого клиента | Значок Очередь сообщений на панели управления | Откройте компонент Управление компьютером. Дополнительные сведения содержатся в разделе Смена поддерживающего сервера для зависимого клиента.
Укажите диски и папки для хранения файлов сообщений, журналов сообщений и журналов транзакций. | Значок Очередь сообщений на панели управления | Откройте компонент Управление компьютером. Дополнительные сведения содержатся в разделе Хранение сообщений на нескольких дисковых устройствах.
Изменение, регистрация, просмотр и удаление сертификатов. | Значок Очередь сообщений на панели управления | Откройте компонент Управление компьютером. Дополнительные сведения содержатся в разделе Проверка подлинности в очереди сообщений.
Проверка подлинности серверов контроллеров MSMQ 1.0 | Значок Очередь сообщений на панели управления | Откройте компонент Управление компьютером. Дополнительные сведения содержатся в разделе Проверка подлинности серверов контроллеров MSMQ 1.0.
Обновление криптографических ключей для очереди сообщений | Значок Очередь сообщений на панели управления | Откройте компонент Управление компьютером. Дополнительные сведения содержатся в разделе Обновление криптографических ключей для очереди сообщений.

Примечания

  • Оснастки «Active Directory – Пользователи и компьютеры» и «Active Directory – Сайты и службы» не входят в состав Windows XP Professional и не могут быть установлены на компьютер, работающий под управлением Windows XP Professional, при установке средств администрирования Windows 2000. Эти оснастки необходимы для администрирования сети очереди сообщений, использующей домены, а также для доступа к содержимому Active Directory и его отображения. Указанные оснастки можно запустить, открыв подключение к удаленному рабочему столу на компьютере Windows XP Professional для доступа к службе терминалов на контроллере домена Windows 2000 или рядовом сервере, на котором установлены эти оснастки. Таким образом можно выполнять административные процедуры в доменной среде и обращаться к службе Active Directory с компьютера очереди сообщений, работающего под управлением Windows XP Professional. Дополнительные сведения содержатся в разделе Средства администрирования.
  • В среде со смешанным режимом основной контроллер предприятия (PEC) Windows NT 4.0 обновлен до контроллера домена Windows 2000, настроенного в качестве сервера глобального каталога и сервера очереди сообщений, а отстальные серверы включают по крайней мере один сервер MQIS Windows NT 4.0 и любое количество компьютеров, работающих под управлением Windows 2000. Такая среда существует до завершения процесса миграции и обновления всех серверов MQIS Windows NT 4.0 предприятия. Если клиент очереди сообщений, запущенный на компьютере с установленной ОС Windows XP, подключается к серверу MQIS Windows NT 4.0 в такой среде, оснастки консоли управления могут использоваться на компьютере, работающем под управлением Windows XP, для доступа к информации, относящейся к конфигурации MSMQ, хранящейся на сервере MQIS Windows NT 4.0, а также для просмотра свойств всех объектов MSMQ на этом компьютере. Однако в данном случае оснастка «Active Directory – пользователи и компьютеры» не покажет на странице безопасности разрешения, связанные с этими объектами. Эти разрешения можно просмотреть из оснастки «Управление компьютером» или локально на сервере MSMQ 1.0 с помощью программы MSMQ Explorer.
  • Программа MSMQ Explorer не запускается на компьютерах с установленными операционными системами Windows XP или Windows 2000.
  • Не существует средств, позволяющих управлять предприятием MSMQ 1.0 с компьютеров, работающих под управлением Windows XP или Windows 2000.


Советы и рекомендации

Приведенный ниже список содержит некоторые рекомендации по работе с очередями сообщений. Следует, по возможности, придерживаться этих рекомендаций.

  • Прежде чем устанавливать или обновлять очередь сообщений, убедитесь, что выполняются все требования.

    Имеются определенные требования, которые должны выполняться, и разрешения, которыми необходимо обладать для успешной установки очереди сообщений на данном предприятии. Дополнительные сведения содержатся в разделе Установка очереди сообщений: обзор.

    Для успешного обновления MSMQ 1.0 до очереди сообщений на данном предприятии требуется выполнение некоторых дополнительных требований и решение некоторых дополнительных вопросов. Например, серверы контроллеров MSMQ 1.0 следует обновлять в определенном порядке. Дополнительные сведения содержатся в разделе Требования и указания по обновлению очереди сообщений.

  • Установите серверы очереди сообщений в каждом сайте Windows 2000 site.

    В каждом сайте Windows 2000 в составе данного леса следует установить хотя бы один сервер очереди сообщений с поддержкой маршрутизации. Это необходимо для гарантии следующего.

    • Все сообщения будут достигать пункта назначения за пределами сайта.
    • Широковещательный запрос, генерируемый независимым клиентом в ходе автоматического распознавания сайта, будет обработан.

    Кроме того, чтобы клиент MSMQ 1.0, запущенный на компьютерах, работающих под управлением Windows NT 4.0, Windows 98 или Windows 95 мог взаимодействовать с серверами очереди сообщений, необходим хотя бы один контроллер домена с очередью сообщений версии 2.0, который настроен в качестве сервера глобального каталога из домена каждого такого клиента в сайте Windows 2000, содержащем таких клиентов.

    Первый контроллер домена в составе леса Windows 2000 автоматически назначается сервером глобального каталога.

  • Не устанавливайте на контроллере домена сервер очереди сообщений с поддержкой маршрутизации.

    Если требуются серверы очереди сообщений, поддерживающие маршрутизацию сообщений и предоставляющие доступ к Active Directory (например, в среде со смешанным режимом), установите их на других компьютерах. Например, сервер очереди сообщений с поддержкой маршрутизации установите на компьютере, не являющемся контроллером домена, а другой сервер очереди сообщений для предоставления доступа к объектам очереди сообщений в Active Directory установите на контроллер домена Windows 2000.

  • Установите серверы очереди сообщений на нескольких контроллерах домена.

    Для обеспечения высокой отказоустойчивости, производительности и масштабируемости следует установить серверы очереди сообщений на нескольких контроллерах домена Windows 2000 в каждом домене Windows 2000.

  • Для подключения ко всем сайтам используйте маршрутные ссылки.

    Все сайты должны сообщаться с другими сайтами посредством маршрутных ссылок. Маршрутная ссылка может иметь любое количество шлюзов сайта, являющихся серверами очереди сообщений, настроенными для маршрутизации сообщений между сайтами, или не иметь ни одного шлюза сайта.

    Дополнительные сведения содержатся в разделе Межсайтовая маршрутизация.

    В каждом новом сайте Windows 2000 необходимо создать маршрутную ссылку.

  • Установите в сайте несколько серверов входящей и исходящей маршрутизации.

    Настройте клиенты очереди сообщений для маршрутизации сообщений через серверы входящей и исходящей маршрутизации. Серверы входящей и исходящей маршрутизации являются серверами очереди сообщений, назначенными для маршрутизации сообщений внутри одного сайта.

    Поскольку клиенты очереди сообщений зависят от серверов входящей и исходящей маршрутизации, каждый клиент следует настроить для использования нескольких серверов. Каждому клиенту в качестве серверов входящей и исходящей маршрутизации может быть назначено до трех серверов очереди сообщений. Дополнительные сведения содержатся в разделе Внутрисайтовая маршрутизация.

    • В этом контексте клиент очереди сообщений представляет собой независимых клиентов, а серверы очереди сообщений не поддерживают маршрутизацию. Зависимые клиенты не могут использовать серверы входящей и исходящей маршрутизации.

  • Используйте сервер удаленного доступа для удаленных клиентов.

    Для снижения эксплуатационных расходов и увеличения производительности следует установить сервер удаленного доступа хотя бы на одном сервере очереди сообщений в каждом сайте. Хотя возможна настройка клиентов очереди сообщений для подключения к данной сети через сервер удаленного доступа в любом сайте, такой вариант обладает меньшими преимуществами. Кроме того, такие клиенты при удаленном доступе к сети должны использовать протокол NetBEUI. Дополнительные сведения содержатся в разделе Использование удаленного доступа клиентами.

  • Избегайте использования зависимых клиентов.

    Из-за некоторых ограничений в использовании зависимых клиентов рекомендуется по возможности использовать вместо них независимые клиенты. Дополнительные сведения содержатся в разделе Рассмотрение зависимых клиентов.

    Если необходимо использовать зависимые клиенты, поддерживающий сервер очереди сообщений должен находиться в том же сайте, что и зависимый клиент. Это увеличит скорость обработки сообщений зависимых клиентов.

  • Регулярно архивируйте сообщения и файлы журналов.

    Для повышения надежности выполняйте архивацию папок, в которых хранятся сообщения, с помощью служебной программы архивации и восстановления, входящей в состав очереди сообщений. Это позволит восстановить файлы сообщений в случае сбоя жесткого диска. Дополнительные сведения содержатся в разделе Архивация и восстановление сообщений.

  • Не останавливайте службу очереди сообщений.

    Не останавливайте службу, если можно обойтись без этого. В противном случае будут утеряны все срочные сообщения. Кроме того, в среде со смешанным режимом, где основной контроллер предприятия (PEC) Windows NT 4.0 был обновлен до контроллера домена Windows 2000, настроенного в качестве сервера глобального каталога с запущенной очередью сообщений, но остается хотя бы один сервер контроллера MSMQ 1.0, обновленные контроллеры PEC требуют, чтобы эта служба, так же как и служба репликации очереди сообщений, работала постоянно для возможности репликации сведений на серверы контроллеров MSMQ 1.0.

  • Храните файлы сообщений на разных высокопроизводительных дисках.

    Для увеличения скорости обработки сообщений следует хранить различные файлы, используемые при обмене сообщениями, на разных физических дисках. Для повышения производительности серверов очереди сообщений разместите файлы сообщений (*.mq), файлы журнала сообщений и файлы журнала транзакций, относящиеся к очередям сообщений, на разных физических дисках. Дополнительные сведения содержатся в разделе Число дисков.

    Для достижения наилучшей производительности используйте высокопроизводительные диски, использующие аппаратное чередование, и контроллеры дисков со сквозной записью. Дополнительные сведения содержатся в разделе Тип диска.

    • Кроме того, поскольку файловая система NTFS Windows 2000 обладает развитой системой восстановления файлов после сбоя питания или аварии системы, рекомендуется использовать ее на серверах очереди сообщений.

  • Не включайте ведение журнала, если это не требуется.

    Ведение журнала занимает много места на диске. Если необходимо вести журнал, для увеличения скорости обработки сообщений следует часто очищать журналы и очереди недоставленных сообщений. Инструкции по выполнению этой задачи содержатся в разделе Очистка очереди от всех сообщений.

  • Желательно чтобы объем хранимых сообщений не превышал 80-90% теоретического максимального объема всех хранимых на одном компьютере сообщений.

    Теоретически максимальный объем хранимых на компьютере сообщений ограничивается объемом оперативной памяти, общим объемом доступного дискового пространства, числом хранящихся в данный момент на компьютере сообщений, а также версией очереди сообщений, работающей на компьютере. Компьютер, объем оперативной памяти которого превышает 512 Мбайт и на котором работает текущая версия очереди сообщений, может хранить около 5 миллионов сообщений. В то же время, для хранения одного сообщения выделяется не более 4 Мбайт дискового пространства. Теоретически максимальное число байт, которые могут храниться на одном компьютере, может превышать 1 терабайт. Тем не менее, при использовании очереди сообщений возникает перерасход дискового пространства который тоже следует брать в расчет. Поэтому рекомендуется чтобы объем хранимых на компьютере сообщений не превышал 80-90% теоретического максимального объема всех сообщений.

  • Не храните сообщений больше, чем может вместить физическая оперативная память компьютера.

    Для снижения активности использования файла подкачки Windows XP и, таким образом, повышения скорости обработки сообщений не храните на компьютере больше срочных сообщений, чем может вместить его физическая оперативная память.

    Дополнительные сведения содержатся в разделе Аспекты выбора памяти.

  • Не изменяйте учетную запись службы очереди сообщений.

    По умолчанию служба «Очередь сообщений» использует учетную запись «Локальный компьютер». Не следует изменять ее, если это не является совершенно необходимым. Дополнительные сведения содержатся в разделе Значение учетной записи службы очереди сообщений.

  • Регулярно обновляйте криптографические ключи.

    Для обеспечения лучшей безопасности следует регулярно (не реже раза в год) обновлять используемые криптографические ключи. Также следует обновлять криптографические ключи в случаях, когда их надежность попадает под сомнение. Инструкции по выполнению этой задачи содержатся в разделе Обновление криптографических ключей для очереди сообщений.


Инструкции

  • Установка очереди сообщений
  • Администрирование сети, в которой используется очередь сообщений
  • Администрирование компьютеров с очередями сообщений
  • Администрирование безопасности в очередях сообщений
  • Администрирование очередей в очередях сообщений
  • Администрирование списков рассылки в очередях сообщений
  • Администрирование сообщений в очередях сообщений
  • Администрирование триггеров в очередях сообщений
  • Тестирование очереди сообщений и наблюдение за ней


Установка службы очередей сообщений

  • Настройка контроллера домена как сервера глобального каталога
  • Наделение контроллера домена правами для делегирования
  • Задание разрешений на установку MSMQ 1.0
  • Установка независимых клиентов
  • Установка зависимых клиентов
  • Удаление службы очередей сообщений


Настройка контроллера домена как сервера глобального каталога

Рисунок Microsoft Windows

Настройка контроллера домена как сервера глобального каталога

  1. Откройте оснастку Active Directory – сайты и службы.
  2. В дереве консоли щелкните правой кнопкой мыши раздел NTDS Settings.

      3. Где?

      • Active Directory – сайты и службы
      • Сайты
      • Соответствующий сайт
      • Серверы
      • Соответствующий сервер
      • NTDS Settings
  3. Нажмите кнопку Свойства.
  4. На странице Общие установите флажок Глобальный каталог.

Примечания

  • Оснастку «Active Directory - сайты и службы» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к серверу терминалов на контроллере домена Windows 2000 или на рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - сайты и службы» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Каждый сайт Windows 2000, содержащий клиентов MSMQ 1.0, запущенных на компьютерах, работающих под управлением Windows NT 4.0, Windows 98 или Windows 95, должен содержать хотя бы один контроллер домена Windows 2000, на котором запущен сервер очереди сообщений и который настроен в качестве сервера глобального каталога из домена каждого такого клиента. Это необходимо для того, чтобы такие клиенты могли отправлять очереди программно приложением на серверы очереди сообщений.
  • При миграции основного контроллера предприятия (PEC) Windows NT 4.0 или основного контроллера сайта (PSC), он автоматически становится контроллером домена, назначенным сервером глобального каталога.

См. также


Наделение контроллера домена правами для делегирования

Чтобы сделать контроллер домена доверенным для делегирования

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой мыши соответствующий контроллер домена.

      Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Контроллеры домена
      • Контроллер домена
  4. Нажмите кнопку Свойства.
  5. На вкладке Общие установите флажок Доверять компьютеру права представителя (если это необходимо).

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Если это свойство недоступно на контроллере домена, работа службы очереди сообщений невозможна.

См. также


Задание разрешений на установку MSMQ 1.0

Чтобы задать разрешения на установку MSMQ 1.0

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. В дереве консоли щелкните правой кнопкой мыши объект Computers (или другого подразделения).

      3. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
  3. Нажмите кнопку Делегирование управления, чтобы запустить мастера делегирования управления, а затем нажмите кнопку Далее.
  4. На странице выбора пользователей и групп нажмите кнопку Добавить.
  5. В окне Выбор: Пользователи, компьютеры или группы выполните следующие действия.
    • Чтобы разрешить установку очереди сообщений пользователям, прошедшим проверку, в поле Имя введите:

      Прошедшие проверку

      и нажмите кнопку ОК.
    • Чтобы разрешить установку очереди сообщений всем пользователям, в поле Имя введите:

      Все

      и нажмите кнопку ОК.
  6. На странице Пользователи или группы нажмите кнопку Далее.
  7. На странице Тип объекта Active Directory выберите вариант Только следующими объектами в этой папке, установите флажок Объекты компьютеров и нажмите кнопку Далее.
  8. На странице Разрешения в группе Отображать следующие разрешения снимите флажок Общие и установите флажок Разрешения для создания или удаления дочерних объектов.
  9. В списке Разрешения установите флажки Создание объектов Настройка MSMQ и Удаление объектов Настройка MSMQ, нажмите кнопку Далее а затем нажмите кнопку Готово.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Используйте мастер делегирования управления для наделения требуемыми разрешениями пользователей, которым требуется установить MSMQ 1.0 на компьютере, входящем в домен Windows 2000.
  • На странице Безопасность диалогового окна Свойства флажки разрешений, предоставленных с использованием мастера делегирования управления или с помощью унаследованных разрешений, закрашены серым цветом.
  • Для возможности удаления очереди сообщений необходимо разрешение «Удаление объектов Настройка MSMQ».

См. также


Установка независимых клиентов

Чтобы установить независимые клиенты

  1. Откройте пункт Установка и удаление программ на панели управления.
  2. Нажмите кнопку Добавление и удаление компонентов Windows.
  3. В мастере компонентов Windows установите флажок Очередь сообщений.
  4. Если какие-либо из необязательных подкомпонентов, устанавливаемых по умолчанию, не нужны, выполните следующие действия.
    • Нажмите кнопку Состав... для открытия страницы Очередь сообщений.
    • Если компьютер входит в состав домена и требуется, чтобы он функционировал в режиме рабочей группы, снимите флажок Интеграция с Active Directory.
    • Если установка триггеров очередей сообщений не требуется, снимите флажок Триггеры.
    • Если отправка сообщений по транспорту HTTP не требуется, снимите флажок Поддержка протокола MSMQ HTTP.
    • Нажмите кнопку ОК.
  5. Нажмите кнопку Далее.
  6. Если появится соответствующий запрос, введите имя DNS или имя NetBIOS контроллера домена Windows 2000 либо MSMQ 1.0 PEC или PSC в локальном сайте.
  7. Далее следуйте инструкциям мастера.
  8. Если появится запрос на перезапуск компьютера, нажмите кнопку Да для завершения установки.

Примечания

  • Чтобы открыть окно установки и удаления программ, нажмите кнопку Пуск, выделите команду Настройка, выберите команду Панель управления и дважды щелкните значок Установка и удаление программ.
  • Следующие подкомпоненты выбираются по умолчанию для 32-разрядных систем. Ядро, локальное хранилище, интеграция с Active Directory, триггеры и поддержка протокола MSMQ HTTP. При создании зависимого клиента устанавливается только подкомпонент Ядро.
  • На компьютерах, работающих под управлением Windows XP Professional, могут устанавливаться только независимые клиенты.
  • Если контроллер домена не существует в локальном сайте или соседнем сайте или к нему не удается получить доступ, можно установить независимого клиента, перезапусив программу установки и сняв флажок Интеграция с Active Directory. Очередь сообщений будет установлена в режиме работы, при котором невозможен доступ к общим очередям и требуется прямое подключение к компьютеру для отправки сообщений. В контексте очереди сообщений любой режим работы с запретом доступа к службе каталогов называется режимом рабочей группы, даже если соответствующий компьютер входит в состав домена .
  • Независимый клиент может также быть установлен в режиме рабочей группы, если компьютер входит в рабочую группу Windows 2000. В этом случае для отправки сообщений необходимо прямое подключение. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Не пытайтесь использовать файлы очереди сообщений версии 3.0 для создания независимого клиента на компьютере, работающем не под управлением Windows XP.
  • Информацию по брандмауэру Windows для очереди сообщений см. в разделе Брандмауэр Windows и очередь сообщений.

См. также


Установка зависимых клиентов

Чтобы установить зависимых клиентов

  1. Откройте объект Установка и удаление программ на панели управления.
  2. Нажмите кнопку Установка компонентов Windows.
  3. В Мастере компонентов Windows установите флажок Очередь сообщений и нажмите кнопку Состав....
  4. На странице Очередь сообщений снимите флажки Интеграция с Active Directory, Триггеры и Поддержка протокола MSMQ HTTP , установите флажок Общие и нажмите кнопку Состав.
  5. Снимите флажок Локальное хранилище, нажмите кнопку ОК, нажмите ОК снова, а затем нажмите кнопку Далее >.
  6. Если появится соответствующий запрос, введите имя DNS или NetBIOS поддерживающего сервера в локальном сайте.
  7. Когда появится запрос на перезапуск компьютера, нажмите кнопку Да для завершения установки.

Примечания

  • Чтобы открыть окно установки и удаления программ, нажмите кнопку Пуск, выберите команды Настройка и Панель управления и дважды щелкните значок Установка и удаление программ.
  • Следующие подкомпоненты выбираются по умолчанию для 32-разрядных систем. Ядро, локальное хранилище, интеграция с Active Directory, триггеры и поддержка протокола MSMQ HTTP. При создании зависимого клиента устанавливается только подкомпонент Ядро.
  • Любой сервер очереди сообщений, функционирующий в режиме домена с функциями независимого клиента может служить поддерживающим сервером для зависимого клиента. Программа установки пытается автоматически обнаружить такой сервер очереди сообщений в том же сайте или соседнем сайте. Если обнаружить сервер не удается, пользователю будет предложено указать имя такого сервера. Если сервер очереди сообщений в локальном сайте недоступен, появится сообщение об этом. Можно либо задать другой сервер, либо нажать кнопку Отмена. Если нажать кнопку Отмена, установка также будет успешно завершена. Эта возможность позволяет установить зависимый клиент до установки его поддерживающего сервера очереди сообщений.
  • Включение сервера очереди сообщений на контроллере домена Windows 2000 для его задействования в качестве поддерживающего сервера зависимого клиента осуществляется с помощью следующих действий, изменяющих настройки безопасности координатора распределенных транзакций Microsoft (MS DTC).
    1. Остановите все службы очереди сообщений.
    2. Откройте Службы компонентов.
    3. В дереве консоли щелкните узел Службы компонентов.
    4. На панели инструментов нажмите кнопку Настройка компьютера.
    5. В диалоговом окне Мой компьютер щелкните вкладку MSDTC.
    6. Чтобы остановить координатор распределенных транзакций Microsoft (MS DTC), в диалоговом окне MSDTC щелкните кнопку Остановить, а затем щелкните кнопку Настройка безопасности.
    7. В диалоговом окне Настройка безопасности установите флажок Сетевой доступ к DTC, а затем флажок Сетевые транзакции, после чего нажмите кнопку ОК.
    8. В диалоговом окне Мой компьютер нажмите кнопку Запустить, чтобы перезапустить DTC, а затем нажмите OK.
    9. Перезапустите службу очередей сообщений, остановленные на шаге 1.
  • Зависимые клиенты не могут быть установлены на компьютеры в режиме рабочей группы или на 64-разрядные системы.
  • Новые возможности очереди сообщений Windows XP, такие как транспорт HTTP, триггеры очереди сообщений и рассылка сообщений нескольким получателям, недоступны зависимым клиентам. Таким образом списки рассылки, многоэлементные списки имен форматов и многоадресные сообщения для зависимых клиентов не поддерживаются.
  • Зависимые клиенты не будут поддерживаться в последующих версиях очереди сообщений.

См. также


Удаление очереди сообщений

Чтобы удалить службы очереди сообщений

  1. Откройте пункт Установка и удаление программ на панели управления.
  2. Нажмите кнопку Добавление и удаление компонентов Windows.
  3. В мастере компонентов Windows снимите флажок Очередь сообщений и нажмите кнопку Далее.
  4. В ответ на приглашение подтвердить удаление очередей и сообщений, созданных очередью сообщений, нажмите кнопку Да.

Примечания

  • Чтобы открыть окно установки и удаления программ, нажмите кнопку Пуск, выделите команду Настройка, выберите команду Панель управления и дважды щелкните значок Установка и удаление программ.
  • При удалении очереди сообщений в многодоменной среде необходимо дождаться репликации Active Directory и убедиться, что объект msmq для соответствующего компьютера был удален, прежде чем пытаться переустанавливать эту службу на данном компьютере.
  • При удалении очереди сообщений файлы очереди сообщений из папок \Windows\System32 и \Windows\System32\Drivers не удаляются.
  • Информацию по выбору брандмауэра Windows для очереди сообщений см. в разделе Брандмауэр Windows и очередь сообщений.

См. также


Администрирование сети, использующей очередь сообщений

Администрирование сети, в которой используется очередь сообщений

  • Создание маршрутных ссылок
  • Изменение цены маршрутной ссылки
  • Смена шлюзов сайта для маршрутной ссылки
  • Создание инородных сайтов
  • Добавление инородных компьютеров в сайт


Создание маршрутных ссылок

Создание маршрутных ссылок

  1. Откройте оснастку Active Directory – сайты и службы.
  2. В меню Вид выберите команду Показать узел служб.
  3. В дереве консоли щелкните правой кнопкой раздел MsmqServices.

      4. Где?

      • Active Directory – сайты и службы
      • Службы
      • MsmqServices
  4. Выберите команды Создать и Маршрутная ссылка .
  5. В диалоговом окне Новый объект - маршрутная ссылка из списков Сайт 1 и Сайт 2 выберите два сайта, между которыми требуется создать маршрут.
  6. В поле Цена ссылки измените цену, если требуется.
  7. В поле Описание введите описательное имя маршрутной ссылки.

Примечания

  • Оснастку «Active Directory - сайты и службы» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к серверу терминалов на контроллере домена Windows 2000 или на рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - сайты и службы» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Маршрутная ссылка определяет маршрут для связи между двумя сайтами. Для получения дополнительных сведений о маршрутных ссылках, шлюзах сайта и их использовании для передачи сообщений щелкните ссылку «См. также».
  • По умолчанию всем маршрутным ссылкам назначена цена 1. Это значение следует изменять только при наличии нескольких маршрутов, если требуется поднять приоритет использования одного маршрута относительно другого с использованием цены ссылки. В этом случае можно назначать цены, отражающие разницу в стоимости подключений.
  • Цена может изменяться от 1 до 999999.
  • По умолчанию в среде нескольких доменов одной организации только члены группы «Администраторы предприятия» могут создавать и изменять маршрутные ссылки. Для возможности создания и изменения маршрутных ссылок членами группы «Администраторы домена» они должны быть наделены разрешением «Создание всех дочерних объектов» для объекта «MsmqServices». Для получения инструкций по заданию разрешений на действия с маршрутными ссылками щелкните ссылку «См. также».

См. также


Изменение цены маршрутной ссылки

Изменение цены маршрутной ссылки

  1. Откройте оснастку Active Directory – сайты и службы.
  2. В меню Вид выберите команду Показать узел служб.
  3. В дереве консоли щелкните раздел MsmqServices.

      4. Где?

      • Active Directory – сайты и службы
      • Службы
      • MsmqServices
  4. В области сведений щелкните правой кнопкой мыши маршрутную ссылку и выберите команду Свойства.
  5. На странице Общие задайте новую цену в поле Цена ссылки.

Примечания

  • Оснастку «Active Directory - сайты и службы» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к серверу терминалов на контроллере домена Windows 2000 или на рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - сайты и службы» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Маршрутная ссылка определяет маршрут для связи между двумя сайтами. Для получения дополнительных сведений о маршрутных ссылках, шлюзах сайта и их использовании для передачи сообщений щелкните ссылку «См. также».
  • По умолчанию всем маршрутным ссылкам назначена цена 1. Это значение следует изменять только при наличии нескольких маршрутов, если требуется поднять приоритет использования одного маршрута относительно другого с использованием цены ссылки. В этом случае можно назначать цены, отражающие разницу в стоимости подключений.
  • Цена может изменяться от 1 до 999999.
  • По умолчанию в среде нескольких доменов одной организации только члены группы «Администраторы предприятия» могут создавать и изменять маршрутные ссылки. Для возможности создания и изменения маршрутных ссылок членами группы «Администраторы домена» они должны быть наделены разрешением «Создание всех дочерних объектов» для объекта «MsmqServices». Для получения инструкций по заданию разрешений на действия с маршрутными ссылками щелкните ссылку «См. также».

См. также


Смена шлюзов сайта для маршрутной ссылки

Чтобы сменить шлюзы сайта для маршрутной ссылки

  1. Откройте оснастку Active Directory – сайты и службы.
  2. В меню Вид выберите команду Показать узел служб.
  3. В дереве консоли щелкните раздел MsmqServices.

      4. Где?

      • Active Directory – сайты и службы
      • Службы
      • MsmqServices
  4. В области сведений щелкните правой кнопкой мыши маршрутную ссылку и выберите команду Свойства.
  5. На странице Шлюзы сайта выполните одно из следующих действий.
    • Чтобы добавить в маршрутную ссылку сервер очереди сообщений в качестве шлюза сайта, выберите его из списка Доступные серверы и нажмите кнопку Добавить.
    • Чтобы удалить из маршрутной ссылки сервер маршрутизации очереди сообщений, выберите его из списка Шлюзы сайта и нажмите кнопку Удалить.
  6. При необходимости повторите шаг 5.

Примечания

  • Оснастку «Active Directory - сайты и службы» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к серверу терминалов на контроллере домена Windows 2000 или на рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - сайты и службы» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Маршрутная ссылка определяет маршрут для связи между двумя сайтами, а шлюз сайта является сервером маршрутизации очереди сообщений или одним из нескольких таких серверов, через которые проходит трафик сообщения между двумя сайтами. Для получения дополнительных сведений о маршрутных ссылках, шлюзах сайта и их использовании для передачи сообщений щелкните ссылку «См. также».
  • Шлюз сайта может принадлежать обоим сайтам, соединенным маршрутной ссылкой, или одному из них. Маршрутная ссылка может иметь любое количество шлюзов сайта или вообще не иметь шлюза сайта.
  • По умолчанию в среде нескольких доменов одной организации только члены группы «Администраторы предприятия» могут создавать и изменять маршрутные ссылки. Для возможности создания и изменения маршрутных ссылок членами группы «Администраторы домена» они должны быть наделены разрешением «Создание всех дочерних объектов» для объекта «MsmqServices». Для получения инструкций по заданию разрешений на действия с маршрутными ссылками щелкните ссылку «См. также».

См. также


Создание инородных сайтов

Чтобы создать инородные сайты

  1. Откройте оснастку Active Directory – сайты и службы.
  2. В меню Вид выберите команду Показать узел служб.
  3. В дереве консоли щелкните правой кнопкой раздел MsmqServices.

      4. Где?

      • Active Directory – сайты и службы
      • Службы
      • MsmqServices
  4. Выберите команду Новый инородный сайт.
  5. В диалоговом окне Новый объект – инородный сайт введите имя нового сайта в поле Имя инородного сайта.

Примечания

  • Оснастку «Active Directory - сайты и службы» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к серверу терминалов на контроллере домена Windows 2000 или на рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - сайты и службы» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Данная процедура может быть выполнена только пользователями, обладающими административными разрешениями для домена.
  • Маршрутная ссылка определяет маршрут для связи между любыми двумя сайтами, включая инородный и неинородный сайт, а шлюз сайта является сервером маршрутизации очереди сообщений или одним из нескольких таких серверов, через которые проходит трафик сообщения между двумя сайтами (для получения дополнительных сведений щелкните ссылку «См. также»). Чтобы установить подключение к инородному сайту, необходимо выполнить следующие действия.
    1. Создайте маршрутную ссылку между инородным сайтом и сайтом очереди сообщений Windows 2000, содержащим сервер очереди сообщений, использующий приложение-подключатель (для получения дополнительных сведений щелкните ссылку «См. также»).
    2. Определите сервер очереди сообщений в качестве шлюза сайта для маршрутной ссылки (для получения дополнительных сведений щелкните ссылку «См. также»).
    3. Откройте оснастку Active Directory – пользователи и компьютеры.
    4. В дереве консоли щелкните правой кнопкой мыши объект msmq компьютера, на котором работает приложение-подключатель.
    5. Нажмите кнопку Свойства.
    6. На странице Сайты выберите инородный сайт из списка Все сайты и щелкните кнопку Добавить для добавления этого сайта в список сайтов в котором находится данный сервер – таким образом, он будет добавлен к инородному сайту.
  • Чтобы удалить инородный сайт, в дереве консоли «Active Directory – сайты и службы» щелкните правой кнопкой мыши имя инородного сайта в списке Сайты, а затем выберите команду Удалить. Перед удалением инородного сайта следует обновить список сайтов. Для этого щелкните правой кнопкой мыши список Сайты, а затем выберите команду Обновить.

См. также


Добавление инородных компьютеров в сайт

Добавление инородных компьютеров в сайт

  1. Откройте окно Active Directory – сайты и службы.
  2. В меню Вид выберите команду Показать узел служб.
  3. В дереве консоли щелкните правой кнопкой раздел MsmqServices.

      4. Где?

      • Active Directory – сайты и службы
      • Службы
      • MsmqServices
  4. Щелкните кнопку Новый инородный компьютер для открытия диалогового окна Новый объект - инородный компьютер.
  5. В поле Имя компьютера введите имя инородного компьютера, из списка Инородный сайт выберите имя инородного сайта, к которому будет добавлен компьютер.

Примечания

  • Оснастки «Active Directory - сайты и службы» и «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлены эти оснастки. Оснастки «Active Directory - сайты и службы» и «Active Directory - пользователи и компьютеры» не входят в состав Windows XP Professional и не могут быть установлены на компьютер, работающий под управлением Windows XP Professional при установке средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Данная процедура создает два объекта в Active Directory для инородного компьютера. Первый - это объект компьютера в контейнере «Computers». Этот объект подобен обычнному объекту компьютера. Второй - объект конфигурации MSMQ, который создается под объектом компьютера и содержит указатель на инородный сайт в атрибуте MSMQ-Sites.
  • Инородный сайт следует сначала создать, а уже затем добавлять в него инородные компьютеры. Для получения инструкций по созданию инородного сайта щелкните ссылку «См. также».
  • Ввод имени инородного компьютера в диалоговое окно Новый инородный компьютер не гарантирует возможности отправки сообщений на него.
  • Маршрутная ссылка определяет маршрут для связи между двумя сайтами, а шлюз сайта является сервером маршрутизации очереди сообщений или одним из нескольких таких серверов, через которые проходит трафик сообщения между двумя сайтами. Для получения дополнительных сведений о маршрутных ссылках, шлюзах сайта и их использовании для передачи сообщений щелкните ссылку «См. также».
  • Сервер маршрутизации очередей сообщений, на котором работает приложение-подключатель и который сконфигурирован как шлюз сайта для маршрутной ссылки между своим и инородным сайтом, также должен быть добавлен к инородному сайту. Чтобы сделать это, выполните следующие действия.
    1. Откройте оснастку Active Directory – пользователи и компьютеры.
    2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
    3. В дереве консоли щелкните правой кнопкой раздел msmq.

        4. Где?

        • Active Directory – пользователи и компьютеры
        • Домен
        • Контроллеры домена
        • Сервер
        • msmq
    4. Нажмите кнопку Свойства.
    5. На странице Сайты выберите инородный сайт из списка Все сайты и щелкните кнопку Добавить для добавления этого сайта в список сайтов в котором находится данный сервер – таким образом, он будет добавлен к инородному сайту.
  • Сообщения не могут быть посланы по транспорту HTTP на инородные компьютеры.

См. также


Администрирование компьютеров с очередями сообщений

  • Присоединение к домену из рабочей группы
  • Добавление сайтов в список сайтов сервера очереди сообщений
  • Удаление сайтов из списка сайтов сервера очереди сообщений
  • Указание нового сайта для мобильных компьютеров
  • Назначение серверов входящей или исходящей маршрутизации
  • Смена поддерживающего сервера для зависимого клиента
  • Просмотр списка зависимых клиентов сервера
  • Ограничение размера банка сообщений для компьютеров
  • Задание ограничения размера хранилища журнала для компьютеров
  • Хранение сообщений на нескольких дисковых устройствах
  • Установка свойств DNS для очереди сообщений
  • Запуск и остановка служб очереди сообщений
  • Удаление объектов очереди сообщений из Active Directory


Присоединение к домену из рабочей группы

Присоединение к домену из рабочей группы

  1. На панели управления откройте компонент Система .
  2. На вкладке Имя компьютера щелкните кнопку Изменить.
  3. В группе Является членом выберите вариант домена, введите имя домена и нажмите кнопку ОК.
  4. По запросу введите имя и пароль существующего пользователя.
  5. Когда будет предложено, перезапустите компьютер, чтобы изменения вступили в силу.

Примечания

  • Чтобы открыть объект «Система», нажмите кнопку Пуск и выберите команды Настройка и Панель управления.
  • Эта процедура предназначена для компьютеров, работающих с очередью сообщений в рабочей группе, которые требуется присоединить (или повторно присоединить) к домену. После подключения к домену данному компьютеру станут доступны общие очереди, присутствующие в Active Directory.
  • Дополнительные сведения о данной процедуре содержатся в разделе Присоединение к домену справки операционной системы.
  • Для выполнения этой процедуры в процессе установки должны быть выбраны подкомпоненты интеграции с Active Directory. Если подкомпоненты интеграции с Active Directory не установлены, очередь сообщений может работать только в режиме рабочей группы.
  • Эту процедуру также можно использовать для присоединения к рабочей группе из домена. В этом случае следует выбрать в группе Является членом вариант рабочей группы и ввести в соответствующее поле имя рабочей группы. Компьютер будет исключен из домена.
  • Данную процедуру можно использовать для перемещения компьютера из одного домена в другой в пределах данного леса. В случае, если объект конфигурации MSMQ оставлен в старом домене, компьютер продолжит использовать этот объект. В противном случае в новом домене будет создан новый объект MSMQ.
  • После присоеденения к домену из рабочей группы или иного домена потребуется некоторое время (около 20-30 минут) для репликации изменений в Active Directory.


Добавление сайтов в список сайтов сервера очереди сообщений

Чтобы добавить сайты в список сайтов сервера очереди сообщений

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
  4. Нажмите кнопку Свойства.
  5. Перейдите на вкладку Сайты, выберите в списке Все сайты сайт, для добавления его в список сайтов в котором находится данный сервер, и нажмите кнопку Добавить.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • В большинстве случаев очередь сообщений автоматически определяет сайт, в котором находятся серверы. Данная процедура необходима, если добавление сайтов в список сайтов в котором находится сервер производится вручную. Соответствующие серверы являются серверами очереди сообщений с поддержкой маршрутизации, называемыми также серверами маршрутизации. Любой сервер маршрутизации, находящийся в определенном сайте, может являться сервером входящей и исходящей маршрутизации для компьютеров, находящихся в данном сайте. Кроме того, такие серверы маршрутизации могут являться шлюзами сайта в маршрутных ссылках на этот сайт. Сервер маршрутизации может находиться в нескольких сайтах, его можно настроить в качестве сервера входящей и исходящей маршрутизации или шлюза сайта независимо в каждом сайте в котором он находится.

См. также


Удаление сайтов из списка сайтов сервера очереди сообщений

Чтобы удалить сайты из списка сайтов сервера очереди сообщений

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
  4. Нажмите кнопку Свойства.
  5. Перейдите на вкладку Сайты, выберите в списке Имя_компьютера Сайты сайт, для удаления его из списка сайтов в котором находится данный сервер, и нажмите кнопку Удалить.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • В большинстве случаев очередь сообщений автоматически определяет сайт, в котором находятся серверы. Данная процедура необходима, если удаление сайтов из списка сайтов, в котором находится сервер, производится вручную. Соответствующие серверы являются серверами очереди сообщений с поддержкой маршрутизации, называемыми также серверами маршрутизации. Любой сервер маршрутизации, находящийся в определенном сайте, может являться сервером входящей и исходящей маршрутизации для компьютеров, находящихся в данном сайте. Кроме того, такие серверы маршрутизации могут являться шлюзами сайта в маршрутных ссылках на этот сайт. Сервер маршрутизации может находиться в нескольких сайтах, его можно настроить в качестве сервера входящей и исходящей маршрутизации или шлюза сайта независимо в каждом сайте в котором он находится.

См. также


Указание нового сайта для мобильных компьютеров

Указание нового сайта для мобильных компьютеров

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Очередь сообщений.

      Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
  3. Выберите команду Свойства.
  4. В диалоговом окне Свойства службы очередей откройте вкладку Мобильный, и в списке Новый сайт выберите сайт, в который будет перемещен мобильный компьютер.
  5. Когда будет выдан запрос на перезагрузку Windows, нажмите кнопку Перезагрузить Windows.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Эта задача применима только к компьютерам, работающим под управлением Windows XP в сети предприятия Windows NT 4.0, которые могут подключаться к серверам контроллеров MSMQ 1.0 для доступа к базе данных MQIS. Таким образом, вкладка Мобильный появляется в диалоговом окне Свойства службы очередей только на этих компьютерах. В иных случаях компьютеры с очередями сообщений обычно могут автоматически определить сайт, в котором они находятся. Дополнительные сведения содержатся в разделе Перемещение мобильных компьютеров в новый сайт.
  • Выбор нового сайта (в среде Windows NT 4.0) позволяет компьютеру подключаться к ближайшему серверу контроллера и, таким образом, оптимизировать доступ к базе данных MQIS. Можно выбрать новый сайт как перед отключением компьютера от сети, так и после подключения. к ней. Если новый сайт выбран перед отключением от сети, сообщения маршрутизируются в новый сайт при выполнении маршрутизации компьтера.
  • Если верный сайт не выбран (в среде Windows NT 4.0), служба очереди сообщений попытается получить доступ к серверу контроллера в исходном сайте и при наличии подключения будет функционировать по прежнему.

См. также


Назначение серверов входящей или исходящей маршрутизации

Чтобы изменить сервер входящей или исходящей маршрутизации

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Computers» или «Domain Controllers»)
      • Компьютер
      • msmq
  4. Нажмите кнопку Свойства.
  5. Перейдите на вкладку Маршрутизация.
  6. Чтобы сменить используемый сервер входящей маршрутизации, выберите в списке Серверы входящей маршрутизации новый сервер очереди сообщений, либо выберите пункт нет, чтобы прекратить использование определенного сервера очереди сообщений в качестве сервера входящей маршрутизации.
  7. Чтобы сменить используемый сервер исходящей маршрутизации, выберите в списке Серверы исходящей маршрутизации новый сервер очереди сообщений, либо выберите пункт нет, чтобы прекратить использование определенного сервера очереди сообщений в качестве сервера исходящей маршрутизации.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Эта задача применима только для независимых клиентов и серверов очереди сообщений с отключенной маршрутизацией, установленных не на контроллере домена, но может выполняться на любом компьютере с соответствующими правами.
  • Можно установить сервер очереди сообщений с поддержкой маршрутизации на контроллер домена, однако это может привести к снижению производительности.
  • При перемещении клиента в другой сайт данные параметры маршрутизации отключаются, пока этот клиент не вернется в исходный сайт.
  • Серверы очереди сообщений, выполняющие входящую и исходящую маршрутизацию, должны находиться в том же сайте, что и клиент. Клиент может использовать один компьютер в качестве сервера как входящей, так и исходящей маршрутизации.
  • Рекомендуется назначать каждому клиенту несколько серверов входящей и исходящей маршрутизации. Это позволяет равномерно распределить нагрузку и повысить устойчивость к сбоям.

См. также


Смена поддерживающего сервера для зависимого клиента

Чтобы сменить поддерживающий сервер для зависимого клиента

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Очередь сообщений.

      Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
  3. Нажмите кнопку Свойства.
  4. На странице Клиент очереди сообщений в диалоговом окне Свойства службы очередей сообщений введите имя поддерживающего сервера очереди сообщений.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Выполнение этой задачи возможно только на зависимых клиентах.
  • Любой сервер очереди сообщений, функционирующий в режиме домена с функциями независимого клиента (предпочтительно в локальном сайте, но также возможно и в соседнем сайте), может служить в качестве поддерживающего сервера для зависимого клиента.
  • Включение сервера очереди сообщений на контроллере домена Windows 2000 для его задействования в качестве поддерживающего сервера зависимого клиента осуществляется с помощью следующих действий, изменяющих настройки безопасности координатора распределенных транзакций Microsoft (MS DTC).
    1. Остановите все службы очереди сообщений.
    2. Откройте Службы компонентов.
    3. В дереве консоли щелкните узел Службы компонентов.
    4. На панели инструментов нажмите кнопку Настройка компьютера.
    5. В диалоговом окне Мой компьютер щелкните вкладку MSDTC.
    6. Чтобы остановить координатор распределенных транзакций Microsoft (MS DTC), в диалоговом окне MSDTC щелкните кнопку Остановить, а затем щелкните кнопку Настройка безопасности.
    7. В диалоговом окне Настройка безопасности установите флажок Сетевой доступ к DTC и флажок Сетевые транзакции, щелкните кнопку ОК, чтобы вернуться в диалоговое окно Мой компьютер, затем щелкните кнопку Запустить для перезапуска MS DTC, после чего щелкните кнопку ОК.
    8. Перезапустите службы очереди сообщений, остановленные на шаге 1.
  • Если для предыдущей версии зависимого клиента, работающего под управлением Windows NT 4.0 требуется сменить поддерживающий сервер на сервер очереди сообщений Windows 2000, на зависимый клиент необходимо предварительно установить пакет обновления 4 или более поздних версий для Windows NT.
  • Новые возможности очереди сообщений Windows XP, такие как транспорт HTTP, триггеры очереди сообщений и рассылка сообщений нескольким получателям, недоступны зависимым клиентам. Таким образом списки рассылки, многоэлементные списки имен форматов и многоадресные сообщения для зависимых клиентов не поддерживаются.
  • Зависимые клиенты не будут поддерживаться в последующих версиях очереди сообщений.

См. также


Просмотр списка зависимых клиентов сервера

Чтобы просмотреть список зависимых клиентов сервера

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
  4. Нажмите кнопку Свойства.
  5. На вкладке Зависимые клиенты нажмите кнопку Обновить, чтобы убедиться, что список является текущим.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Возможен просмотр только активных текущих зависимых клиентов (отправляющих сообщения в данный момент); их может быть меньше общего числа зависимых клиентов в данной организации.
  • Для получения инструкций по смене сервера очереди сообщений для зависимого клиента щелкните ссылку «См. также».

См. также


Ограничение размера банка сообщений для компьютеров

Ограничение размера банка сообщений для компьютеров

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
  4. Нажмите кнопку Свойства.
  5. На вкладке Общие установите в группе Ограничения хранилища флажок Предел хранения сообщений (КБ) и введите общий размер (в килобайтах) всех сообщений, которые могут храниться во всех очередях сообщений на выбранном компьютере.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Данная процедура не применима к компьютерам, функционирующим в режиме рабочей группы или виртуальным серверам в кластерах. Можно установить квоту компьютера рабочей группы с помощью параметра реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache\MachineQuota. Для изменения квоты виртуального сервера необходмо изменить аналогичный параметр реестра кластерных серверов.
  • По достижении этого размера сообщения нельзя будет отправить ни в какие очереди сообщений на компьютере, пока общий размер сообщений во всех очередях не станет меньше указанного предела.
  • Для получения инструкций по заданию максимального размера хранилища журналов (или квоты) для компьютера щелкните ссылку «См. также».

См. также


Задание ограничения размера хранилища журнала для компьютеров

Задание ограничения размера хранилища журнала для компьютеров

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
  4. Нажмите кнопку Свойства.
  5. На вкладке Общие установите в группе Ограничения хранилища флажок Предел хранения журнала (КБ) и введите общий размер (в килобайтах) всех сообщений журнала, которые могут храниться во всех очередях журналов на выбранном компьютере.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Данная процедура не применима к компьютерам, функционирующим в режиме рабочей группы или виртуальным серверам в кластерах. Можно установить квоту компьютера рабочей группы с помощью параметра реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters\MachineCache\MachineJournalQuota. Для изменения квоты виртуального сервера необходмо изменить аналогичный параметр реестра кластерных серверов.
  • Автоматически созданные папки, использующиеся для хранения копий сообщений, называются журналами. Сообщения, хранящиеся в журналах, называются сообщениями журнала. По достижении предельного размера журнала дополнительные сообщения нельзя будет отправить ни в какие журналы на компьютере, пока общий размер сообщений журнала во всех журналах на данном компьютере не станет меньше указанного предела.
  • Сообщения журнала, хранящиеся в источнике, или журналы компьютера могут включать любые исходящие нетранзактные сообщения. Сообщения журнала, хранящиеся в месте назначения, или очереди журнала могут включать любые входящие сообщения, в том числе транзактные сообщения.
  • Для получения инструкций по заданию ограничения размера хранилища сообщений (или квоты) для компьютера щелкните ссылку «См. также».

См. также


Хранение сообщений на нескольких дисковых устройствах

Хранение сообщений на нескольких дисковых устройствах

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Очередь сообщений.

      Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
  3. Нажмите кнопку Свойства.
  4. На вкладке Хранилище измените букву диска и путь в поле Папка файлов сообщений, Папка журнала сообщений или Папка журнала транзакций.
  5. Если будет предложено остановить службу очереди сообщений, нажмите кнопку Да.
  6. Если будет выдан запрос на перезагрузку Windows, нажмите кнопку Перезагрузить Windows.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • По умолчанию все файлы сообщений, файлы журналов и файлы журналов трассировки службы очереди сообщений хранятся в папке \Windows\System32\Msmq\Storage на диске, где установлена служба очереди сообщений.
  • Для получения сведений об использовании системного монитора для определения того, может ли добавление дополнительных дисковых устройств повысить скорость обработки сообщений, щелкните ссылку «См. также».

См. также


Установка свойств DNS для очереди сообщений

Установка свойств DNS для очереди сообщений

  1. На панели управления откройте компонент Сетевые подключения.
  2. Щелкните правой кнопкой мыши значок Подключение по локальной сети и выберите команду Свойства.
  3. В диалоговом окне Свойства: Подключение по локальной сети выберите в списке компонентов пункт Протокол Интернета (TCP/IP).
  4. Нажмите кнопку Свойства.
  5. На вкладке Общие выполните следующие действия:
    • Для автоматического указания DNS-сервера на вкладке Общие выберите параметр Получить адрес DNS-сервера автоматически.
    • Для указания одного или двух DNS-серверов на вкладке Общие выберите параметр Использовать следующие адреса DNS-серверов:. Затем в поле Предпочитаемый DNS-сервер: введите IP-адрес предпочитаемого DNS-сервера, а в поле Альтернативный DNS-сервер: введите IP-адрес дополнительного альтернативного DNS-сервера.
    • Для указания более двух DNS-серверов на вкладке Общие нажмите кнопку Дополнительно. На странице Дополнительные параметры TCP/IP выберите вкладку DNS. Нажмите кнопку Добавить... под списком Адреса DNS-серверов, в порядке использования:, в поле DNS-сервер введите адрес DNS-сервера и нажмите кнопку Добавить. Повторите описанные действия для каждого DNS-сервера который требуется указать. С помощью кнопок Вверх и Вниз можно изменять порядок DNS-серверов в списке. Нажатие кнопки Изменить... позволяет изменить адрес выделенного в списке DNS-сервера; при нажатии кнопки Удалить DNS-сервер будет удален.

Примечания

  • Чтобы открыть окно настройки очереди сообщений, нажмите кнопку Пуск, выберите команды Настройка и Панель управления а затем дважды щелкните значок Сетевые подключения.
  • Эту задачу следует выполнять только при работе в чистой среде DNS (в которой отсутствует сервер WINS). Служба очереди сообщений требует наличия настроенной системы DNS для правильного разрешения имен компьютеров.


Запуск и остановка служб очереди сообщений

Запуск и остановка служб очереди сообщений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните узел Службы.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Службы
  3. В области сведений щелкните правой кнопкой мыши соответствующую службу, после чего выполните одно из следующих действий, если это необходимо (необязательные параметры отображаются серым цветом).
    • Чтобы запустить службу, выберите команду Пуск.
    • Чтобы остановить службу, выберите команду Стоп.
    • Чтобы приостановить службу, выберите команду Пауза.
    • Чтобы возобновить работу приостановленной службы, выберите команду Продолжить.
    • Чтобы перезапустить службу, выберите команду Перезапустить.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Текущее состояние службы отображается в столбце Состояние в области сведений.
  • Данная процедура прменима к службе очередей сообщений, службе репликации очереди сообщений и службе триггеров очередей сообщений.
См. также


Удаление объектов очереди сообщений из Active Directory

Чтобы удалить объекты очереди сообщений из Active Directory

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
  4. Выберите команду Удалить. В ответ на запрос нажмите кнопку Да.
  5. Откройте оснастку Active Directory – сайты и службы.
  6. В области сведений щелкните правой кнопкой мыши объект Параметры MSMQ.

      7. Где?

      • Active Directory – сайты и службы
      • Сайты
      • Данный сайт
      • Серверы
      • Данный сервер
      • Параметры MSMQ
  7. Выберите команду Удалить. В ответ на запрос нажмите кнопку Да.

Примечания

  • Оснастки «Active Directory - пользователи и компьютеры» и «Active Directory - сайты и службы» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлены эти оснастки. Оснастки «Active Directory - пользователи и компьютеры» и «Active Directory - сайты и службы» не входят в состав Windows XP Professional и не могут быть установлены на компьютер, работающий под управлением Windows XP Professional при установке средств администрирования Windows 2000. Дополнительные сведения содержатся в разделе Средства администрирования.
  • Лучшим способом удаления объектов очереди сообщений из Active Directory является удаление служб очереди сообщений с данного компьютера. Описанную выше процедуру следует выполнять, только если не удается удалить с компьютера службу очереди сообщений, например из-за аппаратного сбоя, если отсутствует физический доступ к компьютеру, либо если произошла ошибка установки очереди сообщений. Для получения инструкций по удалению службы очереди сообщений с компьютера щелкните ссылку «См. также».
  • При удалении объектов очереди сообщений из Active Directory также удаляются все очереди и сообщения. Однако файлы, необходимые для работы очереди сообщений, включая параметры реестра и файлы хранилища, остаются на компьютере.
  • При удалении объектов сервера входящей или исходящей маршрутизации этот сервер также будет удален из списков маршрутизации всех использующих его клиентов.
  • При удалении объектов шлюза сайта данный сервер также будет удален из соответствующей маршрутной ссылки.

См. также


Администрирование безопасности в очередях сообщений

  • Задание разрешений для объектов компьютеров и очередей
  • Задание разрешений для объектов маршрутных ссылок
  • Задание разрешений для объектов параметров MSMQ
  • Задание разрешений для файлов очередей сообщений
  • Задание разрешений для списков рассылки
  • Смена владельца объектов компьютеров и очередей
  • Смена учетной записи службы очереди сообщений
  • Аудит доступа к объектам компьютеров и очередей
  • Аудит доступа к объектам маршрутных ссылок
  • Проверка подлинности серверов контроллеров MSMQ 1.0
  • Регистрация сертификатов для очереди сообщений
  • Удаление сертификатов для очереди сообщений
  • Просмотр сертификатов для очереди сообщений
  • Обновление сертификатов для очереди сообщений
  • Обновление криптографических ключей для очереди сообщений
  • Ослабление безопасности с использованием программы «ADSI Edit»
  • Изменение параметров безопасности для информационных служб Интернета


Задание разрешений для объектов компьютеров и очередей

Чтобы задать разрешения для объектов компьютеров и очередей

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. Чтобы наделить компьютер (объект msmq) определенными разрешениями доступа к очереди сообщений, в дереве консоли щелкните правой кнопкой мыши объект msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq

    Или, чтобы наделить очередь определенными разрешениями доступа к очереди сообщений, щелкните правой кнопкой мыши соответствующую очередь.

      Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
      • Папка очереди («Частные очереди» для частной очереди)
      • Очередь
  4. Нажмите кнопку Свойства.
  5. На странице Безопасность установите разрешения на доступ к объекту, рассмотренные в шаге 3, если требуется.
    • Для предоставления разрешений для этого объекта группе или пользователю, отображаемым в поле Группы или пользователи, выберите соответствующую группу или пользователя, а затем в группе Разрешения дляГруппа_или_пользователь в столбце Разрешить установите флажки соответствующих разрешений.
    • Для отмены разрешений группы или пользователя для этого объекта, в поле Группы или пользователи выберите соответствующую группу или пользователя, а затем в группе Разрешения дляГруппа_или_пользователь в столбце Запретить установите флажки соответствующих разрешений.
    • Для предоставления доступа новому пользователю или группе нажмите кнопку Добавить. В поле Имя выберите пользователя или группу, нажмите кнопку Добавить, затем нажмите ОК. Затем установите для добавленного пользователя или группы флажки, соответствующие требуемому разрешению.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Объекты очереди для очередей, находящихся на определенном компьютере, являются дочерними объектами объекта msmq соответствующего компьютера. Например, для создания очереди необходимо наличие разрешения «Создание всех дочерних объектов» для объекта msmq, который используется для создания очереди.
  • Можно предоставлять или отменять разрешения для объекта даже группе «Администраторы».
  • Данная процедура не может использоваться для задания разрешений для частной очереди на удаленном компьютере.

См. также


Задание разрешений для объектов маршрутных ссылок

Задание разрешений для объектов маршрутных ссылок

  1. Откройте оснастку Active Directory – сайты и службы.
  2. В дереве консоли щелкните правой кнопкой раздел MsmqServices.

      3. Где?

      • Active Directory – сайты и службы
      • Службы
      • MsmqServices
  3. Щелкните правой кнопкой мыши службу MsmqServices и выберите команду Свойства.
  4. На странице Безопасность установите требуемые разрешения.
    • Для предоставления разрешений для этого объекта группе или пользователю, отображаемым в поле Группы или пользователи, выберите соответствующую группу или пользователя, а затем в группе Разрешения дляГруппа_или_пользователь в столбце Разрешить установите флажки Создание всех дочерних объектов и Удаление всех дочерних объектов.
    • Для отмены разрешений группы или пользователя для данного объекта выберите соответствующую группу или пользователя в поле Группы или пользователи, а затем в столбце Запретить установите флажки Создание всех дочерних объектов и Удаление всех дочерних объектов.
    • Для предоставления доступа новому пользователю или группе нажмите кнопку Добавить. В поле Имя выберите пользователя или группу, нажмите кнопку Добавить, затем нажмите ОК. Затем установите для добавленного пользователя или группы флажки, соответствующие требуемому разрешению.

Примечания

  • Оснастку «Active Directory - сайты и службы» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к серверу терминалов на контроллере домена Windows 2000 или на рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - сайты и службы» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Каждый объект маршрутной ссылки является дочерним объектом объекта MsmqServices. Для создания, изменения и удаления маршрутных ссылок необходимо наличие разрешений «Создание всех дочерних объектов» и «Удаление всех дочерних объектов» для объектов MsmqServices. По умолчанию только группа «Администраторы предприятия» имеет оба эти разрешения.

См. также


Задание разрешений для объектов параметров MSMQ

Задание разрешений для объектов параметров MSMQ

  1. Откройте окно Active Directory – сайты и службы.
  2. В дереве консоли щелкните правой кнопкой мыши объект «MSMQ Settings» для соответствующего сервера.

      3. Где?

      • Active Directory – сайты и службы
      • Сайты
      • Объект «сайт»
      • Серверы
      • Объект «сервер»
      • Параметры MSMQ
  3. Нажмите кнопку Свойства.
  4. На странице Безопасность установите требуемые разрешения.
    • Для предоставления разрешений для этого объекта группе или пользователю, отображаемым в поле Группы или пользователи, выберите соответствующую группу или пользователя, а затем в группе Разрешения дляГруппа_или_пользователь в столбце Разрешить установите флажки Создание всех дочерних объектов и Удаление всех дочерних объектов.
    • Для отмены разрешений группы или пользователя для данного объекта выберите соответствующую группу или пользователя в поле Группы или пользователи, а затем в столбце Запретить установите флажки Создание всех дочерних объектов и Удаление всех дочерних объектов.
    • Для предоставления доступа новому пользователю или группе нажмите кнопку Добавить. В поле Имя выберите пользователя или группу, нажмите кнопку Добавить, затем нажмите ОК.

      Затем установите для добавленного пользователя или группы флажки, соответствующие требуемому разрешению.

Примечания

  • Оснастку «Active Directory - сайты и службы» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к серверу терминалов на контроллере домена Windows 2000 или на рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - сайты и службы» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Задание разрешений для файлов очередей сообщений

Чтобы задать разрешение для файлов очередей сообщений

  1. На рабочем столе щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Проводник.
  2. Найдите и щелкните правой кнопкой мыши папку, используемую для хранения файлов сообщений, журналов и журналов транзакций (обычно это папка Storage в папке \Windows\System32\Msmq), и выберите команду Свойства.
  3. На странице Безопасность в группе Группы или пользователи выберите элемент Администраторы.
  4. В списке Разрешения для администраторов установите в столбце Разрешить флажок Полный доступ.
  5. В списке Группы или пользователи выберите пользователя или группу, включая группу «Администраторы», не требующих непосредственного доступа к файлам очереди сообщений, и нажмите кнопку Удалить. Повторите этот шаг, если требуется.

Примечания

  • Разрешения на доступ на уровне файлов и папок можно устанавливать только на дисках, использующих файловую систему NTFS. Задание разрешений на доступ на уровне папки на дисках, использующих файловую систему FAT, невозможно. (Вкладка Безопасность недоступна для папок на дисках, использующих файловую систему FAT.)
  • По умолчанию только члены локальной группы «Администраторы» имеют разрешения для папок, использующихся для хранения файлов сообщений, файлов журнала и файлов журнала транзакций.


Задание разрешений для списков рассылки

Чтобы задать разрешения для списков рассылки

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. Чтобы назначить разрешения для списка рассылки, в дереве консоли щелкните правой кнопкой мыши соответствующий список (группу) рассылки.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Пользователи
      • список (группа) рассылки
  4. На странице Безопасность установите разрешения на доступ к объекту, рассмотренные в шаге 3, если требуется.
    • Для предоставления разрешений для этого объекта группе или пользователю, отображаемым в поле Группы или пользователи, выберите соответствующую группу или пользователя, а затем в группе Разрешения для Группа_или_пользователь в столбце Разрешить установите флажки соответствующих разрешений.
    • Для отмены разрешений группы или пользователя для этого объекта, в поле Группы или пользователи выберите соответствующую группу или пользователя, а затем в столбце Запретить установите флажки соответствующих разрешений.
    • Для предоставления доступа новому пользователю или группе нажмите кнопку Добавить. В диалоговом окне Выбор: Пользователь, Компьютер или Группа нажмите кнопку Что искать, установите соответствующие флажки Группа и/или Пользователи, снимите остальные флажки и нажмите кнопку ОК. В поле Имя введите имя группы или пользователя или имена нескольких групп или пользователей, разделяя их точкой с запятой, нажмите кнопку ОК, после чего нажмите кнопку ОК снова. Либо нажмите кнопку Дополнительно для поиска групп или пользователей, введите соответствующие параметры и нажмите кнопку Найти, выберите нужную группу или пользователя, нажмите кнопку OK, нажмите кнопку ОК вновь, после чего нажмите кнопку OK в третий раз.

      Затем установите для добавленного пользователя или группы флажки, соответствующие требуемому разрешению.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на компьютере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Списки рассылки службы очередей сообщений являются объектами группы распространения в Active Directory.

См. также


Смена владельца объектов компьютеров и очередей

Чтобы сменить владельца объекта компьютера или очереди

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. Чтобы сменить владельца компьютера (объекта msmq) в дереви консоли щелкните правой кнопкой мыши элемент msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq

    Или, чтобы сменить владельца очереди, щелкните правой кнопкой мыши соответствующую очередь.

      Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
      • Папка очереди («Частные очереди» для частной очереди)
      • Очередь
  4. Нажмите кнопку Свойства.
  5. На странице Безопасность нажмите кнопку Дополнительно.
  6. На странице Владелец в списке Изменить владельца на выберите нового пользователя или группу и нажмите кнопку ОК.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • По умолчанию владельцем объекта msmq является компьютер. Эта процедура служит для смены владельца объекта msmq или очереди.
  • Если локальный пользователь (не вошедший в домен Windows 2000) создает объект, группа Все приобретает разрешение Полный доступ на доступ к этому объекту.
  • Для каждого компьютера или очереди сообщений возможно наличие только одного владельца.
  • Данная процедура не может использоваться для смены владельца частной очереди на удаленном компьютере.

См. также


Смена учетной записи службы очереди сообщений

Чтобы сменить учетную запись службы очереди сообщений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните узел Службы.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Службы
  3. В области сведений дважды щелкните службу Очередь сообщений.
  4. На странице Вход в систему выберите вариант С учетной записью и нажмите кнопку Обзор. В поле Имя введите имя учетной записи пользователя и нажмите кнопку ОК.
  5. В поле Пароль введите пароль этой учетной записи.
  6. В поле Подтверждение еще раз введите пароль учетной записи.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • По умолчанию служба «Очередь сообщений» использует учетную запись «Локальный компьютер». Если административная политика запрещает работу служб с использованием учетной записи «Локальный компьютер», следует задать для службы «Очередь сообщений» другую учетную запись.
  • Данная процедура также применима к службе триггеров очереди сообщений. В этом случае на шаге 3 дважды щелкните элемент Триггеры очереди сообщений в панели сведений.
См. также


Аудит доступа к объектам компьютеров и очередей

Для выполнения аудита доступа к объектам компьютеров и очередей

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. Для выполнения аудита доступа к компьютеру (объекту msmq) в дереви консоли щелкните правой кнопкой мыши элемент msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq

    Или, чтобы включить аудит доступа к очереди, щелкните правой кнопкой мыши соответствующую очередь.

      Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
      • Папка очереди («Частные очереди» для частной очереди)
      • Очередь
  4. Нажмите кнопку Свойства
    5. .
  5. На странице Безопасность нажмите кнопку Дополнительно.
  6. На странице Аудит диалогового окна Дополнительные параметры безопасности нажмите кнопку Добавить.
  7. В списке Имя диалогового окна Выбор: Пользователь, Компьютер или Группа выберите имя пользователя или группы для аудита доступа и нажмите кнопку OK.
  8. В диалоговом окне Элемент аудита выберите в списке Применять объекты для аудита доступа к ним, а затем в списке Доступ установите флажки, соответствующие типам доступа, и нажмите кнопку ОК. Или, чтобы очистить все элементы аудита, нажмите кнопку Очистить все а затем нажмите кнопку ОК.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Данные аудита хранятся в журнале безопасности. Для получения инструкций по просмотру событий журнала безопасности щелкните ссылку «См. также».
  • Данная процедура не может использоваться для аудита доступа к частной очереди на удаленном компьютере.
  • Прежде чем выполнять эту задачу, необходимо включить аудит доступа, настроив политику аудита для локального компьютера.

См. также


Аудит доступа к объектам маршрутных ссылок

Для выполнения аудита доступа к объектам маршрутных ссылок

  1. Откройте оснастку Active Directory – сайты и службы.
  2. В меню Вид выберите команду Показать узел служб.
  3. В дереве консоли щелкните раздел MsmqServices.

      4. Где?

      • Active Directory – сайты и службы
      • Службы
      • MsmqServices
  4. В области сведений щелкните правой кнопкой мыши маршрутную ссылку и выберите команду Свойства.
  5. На странице Безопасность нажмите кнопку Дополнительно.
  6. На странице Аудит диалогового окна Дополнительные параметры безопасности нажмите кнопку Добавить.
  7. В списке Имя диалогового окна Выбор: Пользователь, Компьютер или Группа выберите имя пользователя или группы для аудита доступа и нажмите кнопку OK.
  8. В диалоговом окне Элемент аудита выберите в списке Применять объекты для аудита доступа к ним, а затем в списке Доступ установите флажки, соответствующие типам доступа, и нажмите кнопку ОК. Или, чтобы очистить все элементы аудита, нажмите кнопку Очистить все а затем нажмите кнопку ОК.

Примечания

  • Оснастку «Active Directory - сайты и службы» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к серверу терминалов на контроллере домена Windows 2000 или на рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - сайты и службы» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Данные аудита хранятся в журнале безопасности. Для получения инструкций по просмотру событий журнала безопасности щелкните ссылку «См. также».
  • Данную процедуру можно использовать для аудита доступа ко всем объектам очереди безопасности на уровне объекта MsmqServices и ниже.
  • Прежде чем выполнять эту задачу, необходимо включить аудит доступа, настроив политику аудита для локального компьютера.

См. также


Проверка подлинности серверов контроллеров MSMQ 1.0

Проверка подлинности сервера контроллера MSMQ 1.0

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Очередь сообщений.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
  3. Нажмите кнопку Свойства.
  4. На странице Безопасность службы диалогового окна Свойства службы очередей выберите элемент Использовать защищенные подключения при связи с контроллером MSMQ с системой Windows NT 4.0 а затем элемент Центры сертификации.
  5. В диалоговом окне Центры сертификации нажмите кнопку Системные сертификаты.
  6. В ответ на запрос нажмите кнопку Да.
  7. Снимите флажки, соответствующие центрам сертификации, которые не требуется использовать или которым не следует доверять при установке безопасных подключений, и нажмите кнопку OK.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Данная процедура применима только к клиентам, работающим под управлением Windows 2000, которые подключаются к серверам контроллеров MSMQ 1.0, работающим под управлением Windows NT 4.0.

См. также


Регистрация сертификатов для очереди сообщений

Чтобы зарегистрировать сертификат для очереди сообщений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Очередь сообщений.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
  3. Нажмите кнопку Свойства.
  4. В диалоговом окне Свойства службы очередей сообщений выберите вкладку Сертификат пользователя а затем в группе Сертификаты пользователей нажмите кнопку Регистрация.
  5. В диалоговом окне Личные сертификаты выберите сертификат и нажмите кнопку Регистрация.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Для выполнения данной задачи компьютер должен иметь доступ к Active Directory.
  • В ходе установки автоматически создается внутренний сертификат пользователя локального компьютера, который затем регистрируется в Active Directory при первом входе в систему в домене, если при этом компьютер может взаимодействовать с контроллером домена.
  • В случае отсутствия внутреннего сертификата, например, если он удален, данная процедура создает новый внутренний сертификат который можно зарегистрировать. Эта процедура также позволяет зарегистрировать внешний сертификат после его импорта.
  • Если сертификат, зарегистрированный на локальном компьютере, удален с использованием удаленного компьютера, он будет удален из Active Directory, но останется на локальном компьютере.

См. также


Удаление сертификатов для очереди сообщений

Удаление сертификатов для очереди сообщений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Очередь сообщений.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
  3. Нажмите кнопку Свойства.
  4. В диалоговом окне Свойства службы очередей сообщений выберите вкладку Сертификат пользователя а затем в группе Сертификаты пользователей нажмите кнопку Удалить.
  5. В диалоговом окне Личные сертификаты выберите сертификат пользователя и нажмите кнопку Удалить.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Можно удалить любой из показанных сертификатов пользователя, однако если при удалении зарегистрированного на компьютере сертификата используется другой компьютер, этот сертификат будет удален из Active Directory, но останется на локальном компьютере.

См. также


Просмотр сертификатов для очереди сообщений

Просмотр сертификатов для очереди сообщений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Очередь сообщений.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
  3. Нажмите кнопку Свойства.
  4. В диалоговом окне Свойства службы очередей сообщений выберите вкладку Сертификат пользователя а затем в группе Сертификаты пользователей нажмите кнопку Просмотр.
  5. В диалоговом окне Личные сертификаты выберите сертификат и нажмите кнопку Просмотр сертификата.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Можно просмотреть все сертификаты пользователей, зарегистрированные в Active Directory.

См. также


Обновление сертификатов для очереди сообщений

Обновление сертификатов для очереди сообщений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Очередь сообщений.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
  3. Нажмите кнопку Свойства.
  4. В диалоговом окне Свойства службы очередей сообщений выберите вкладку Сертификаты пользователей а затем в группе Внутренний сертификат нажмите кнопку Обновить.

    Появится предупреждение о том, что проверенные сообщения, отправленные с использованием текущего внутреннего сертификата, будут отклонены как не прошедшие проверку.

  5. Если отклонение таких сообщений допустимо, нажмите кнопку Да. В противном случае нажмите кнопку Нет и обновите внутренний сертификат позже.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Только пользователь, установивший очередь сообщений, может обновить внутренний сертификат Если очередь сообщений была установлена в режиме рабочей группы а компьютер впоследствии был присоединен к домену, только администратор домена может обновить внутренний сертификат.
  • После успешного обновления внутреннего сертификата появляется сообщение, предупреждающее об успешном обновлении внутреннего сертификата и его регистрации в Active Directory.

См. также


Обновление криптографических ключей для очереди сообщений

Обновление криптографических ключей для очереди сообщений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Очередь сообщений.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
  3. Нажмите кнопку Свойства.
  4. В диалоговом окне Свойства службы очередей сообщений выберите вкладку Безопасность службы а затем в группе Ключи шифрования нажмите кнопку Обновить.

    Появится предупреждение о том, что входящие сообщения могут быть зашифрованы с использованием криптографического ключа, отличающегося от имеющегося на данном компьютере. Такие сообщения нельзя будет прочесть.

  5. Если невозможность прочтения таких сообщений допустима, нажмите кнопку Да. В противном случае нажмите кнопку Нет и обновите криптографический ключ позже.
  6. Когда будет выдан запрос на перезагрузку Windows, нажмите кнопку Перезагрузить Windows.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Только пользователь, установивший очередь сообщений, имеет разрешения необходимые для обновления криптографических ключей. Если очередь сообщений установлена в режиме рабочей группы а компьютер присоединен к домену, только администратор домена может обновить криптографические ключи.
  • Эта задача неприменима к зависимым клиентам.

См. также


Ослабление безопасности с использованием программы «ADSI Edit»

Чтобы ослабить безопасность, используя программу «ADSI Edit»

  1. Нажмите кнопку Пуск и выберите команды Все программы, Программы поддержки Windows XP, Tools и ADSI Edit.
  2. В дереве консоли щелкните правой кнопкой мыши объект CN=MsmqServices.

      3. Где?

      • Configuration Container
      • CN=Configuration,...
      • CN=Services
      • CN=MsmqServices
  3. Нажмите кнопку Свойства.
  4. На странице Attributes выберите в списке Select a property to view атрибут MSMQNameStyle.
  5. В поле Edit Attribute введите TRUE, чтобы ослабить безопасность. Либо введите FALSE, чтобы усилить ее.
  6. Нажмите кнопку Set, а затем — кнопку OK.

Примечания

  • Перед использованием ADSI Edit должны быть установлены программы поддержки Windows XP, находящиеся на компакт-диске Windows XP. Для установки этих средств выполните следующие действия.
    1. Вставьте компакт-диск Windows XP в CD-ROM дисковод.
    2. Откройте папку «Support» а затем –папку «Tools».
    3. Дважды щелкните файл Setup.
    4. Следуйте инструкциям мастера установки программ поддержки Windows XP.
  • Эта процедура служит для снижения безопасности Active Directory для обеспечения поддержки пользователей MSMQ 1.0, клиентов очереди сообщений 2.0, входящих в систему с использованием локальной учетной записи, и определенных рабочих конфигураций.
  • Запуск зависимых клиентов под учетной записью локального пользователя невозможен. Любой компьютер, отправляющий запросы об объектах очереди соообщений к Active Directory непосредственно на контроллер домена, а не через службу каталогов очереди сообщений, не сможет получить доступ к Active Directory при входе в систему под локальной учетной записью пользователя, даже если безопасность Active Directory ослаблена.
  • После выполнения этой процедуры для того, чтобы изменения вступили в силу, необходимо перезапустить все серверы очереди сообщений, работающие на контроллерах домена Windows 2000.

См. также


Изменение параметров безопасности для информационных служб Интернета

Изменение параметров безопасности для информационных служб Интернета

  1. Нажмите кнопку Пуск, выберите команду Выполнить, введите

    mmc

    и нажмите кнопку ОК.
  2. В меню Консоль выберите команду Добавить или удалить оснастку.
  3. В диалоговом окне Добавить/Удалить оснастку нажмите кнопку Добавить, выберите оснастку Internet Information Services, нажмите кнопку Добавить, а затем нажмите кнопки Закрыть и ОК.
  4. В дереве консоли щелкните правой кнопкой мыши раздел Веб-узел по умолчанию.

      5. Где?

      • Корень консоли
      • Информационные службы Интернета
      • Компьютер
      • Веб-узел по умолчанию
  5. Нажмите кнопку Свойства и выберите вкладку Безопасность каталога.
  6. В группе Анонимный доступ и проверка подлинности нажмите кнопку Изменить.
  7. Снимите флажок Анонимный доступ. Или, в группе Учетная запись анонимного доступа нажмите кнопку Изменить, введите имя пользователя домена и нажмите кнопку ОК.
  8. Нажмите кнопку ОК, затем нажмите кнопку OK еще раз.
  9. Нажмите кнопку Пуск, выберите команду Выполнить, введите

    net stop iisadmin

    и нажмите клавишу ENTER.
  10. Нажмите кнопку Пуск, выберите команду Выполнить, введите

    net start smtpsvc

    и нажмите клавишу ENTER.
  11. Введите:

    y

    и нажмите клавишу ENTER.
  12. Нажмите кнопку Пуск, выберите команду Выполнить, введите

    net start w3svc

    и нажмите клавишу ENTER.
  13. Откройте оснастку Active Directory – пользователи и компьютеры.
  14. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  15. В дереве консоли щелкните правой кнопкой мыши имя данного компьютера.

      16. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Компьютеры
      • Компьютер
  16. Нажмите кнопку Свойства.
  17. На вкладке Общие установите флажок Доверять компьютеру права представителя и нажмите кнопку ОК.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • По умолчанию информационные службы Интернета (IIS) используют локальную учетную запись пользователя, которая другими компьютерами в сети воспринимается как учетная запись анонимного пользователя. Приложения и сценарии страниц ASP запускаются в среде IIS и потому их запросы к Active Directory рассматриваются как обращения анонимного пользователя. Поскольку анонимный пользователь в Windows XP не входит в группу «Все», эти запросы не выполняются, и приложениям и сценариям страниц ASP не удается обнаружить, создать или удалить очереди. Данная процедура запускает информационные службы Интернета (IIS), используя учетную запись пользователя, вошедшего в систему с работающими информационными службами Интернета (IIS), или с помощью определенной учетной записи пользователя домена.
  • Для того чтобы изменения вступили в силу, необходимо остановить а затем запустить административную службу IIS. Остановка данной службы также повлечет остановку зависящих от нее служб World Wide Web Publishing и Simple Mail Transport Protocol (SMTP). При запуске служб World Wide Web Publishing и Simple Mail Transport Protocol (SMTP) автоматически запускается административная служба IIS.
  • Наделение компьютера правами представителя позволяет нескольким прыжкам взаимодействовать с контроллером домена.

См. также


Администрирование очередей в очередях сообщений

  • Создание очередей
  • Поиск очередей
  • Удаление очередей
  • Отключение очередей исходящих сообщений
  • Приостановка и возобновление работы очереди исходящих сообщений
  • Изменение метки очереди
  • Изменение кода типа очереди
  • Изменение базового приоритета очереди
  • Включение и отключение ведения журнала назначений
  • Задание ограничения размера хранилища журнала для очередей
  • Задание ограничения размера банка сообщений для очередей
  • Помещение в очередь только сообщений, прошедших проверку
  • Изменение уровня секретности очередей
  • Указание или просмотр адресов многоадресной рассылки очереди и портов
  • Управление очередями и сообщениями на других компьютерах
  • Управление очередями и сообщениями с использованием оснастки «Active Directory - пользователи и компьютеры»


Создание очередей

Чтобы создать очередь

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши папку очереди.

    Где?

    • Управление компьютером
    • Службы и приложения
    • Очередь сообщений
    • Папка очереди (такая как «Общие очереди» или «Частные очереди»)
  3. Выберите команды Создать и Общая очередь (или Частная очередь) для открытия диалогового окна Новый объект - общая очередь (или диалогового окна Новая частная очередь).
  4. В поле Имя очереди введите имя новой очереди. Или, если требуется создать очередь для приема транзактных сообщений, введите имя и установите флажок Проведенной.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».
  • Очереди нельзя создавать в папках «Исходящие очереди» и «Системные очереди». Эти очереди создаются автоматически.
  • Объекты очереди для очередей, находящихся на определенном компьютере, являются дочерними объектами объекта msmq соответствующего компьютера. Таким образом, для создания очереди необходимо наличие разрешения «Создание всех дочерних объектов» для объекта msmq, который используется для создания очереди.
  • Для создания свойств общих очередей на удаленных компьютерах с помощью оснастки «Active Directory - пользователи и компьютеры» необходимо обладать разрешениями администратора домена и войти в систему с использованием учетной записи пользователя домена.
  • При создании очереди пользователю предлагается указать минимум необходимых сведениий. Каждая очередь имеет множество дополнительных настраиваемых свойств (атрибутов). После создания очереди значения многих дополнительных атрибутов можно просмотреть и изменить. Для получения дополнительных инструкций щелкните ссылку «См. также».

См. также


Поиск очередей

Чтобы выполнить поиск очередей

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой мыши любую папку или объект.
  4. Выберите команду Найти.
  5. В списке Найти выберите вариант Очередь сообщений.
  6. На странице Найти очередь сообщений введите в поле Метка или Код типа соответствующие сведения и нажмите кнопку Найти.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Если оставить поля Метка и Код типа пустыми, будет показан список всех очередей. Если ввести сведения и в поле Метка, и в поле Код типа, будут показаны только очереди, соответствующие обоим заданным условиям.

См. также


Удаление очередей

Удаление очередей

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди (такая как «Общие очереди» или «Частные очереди»)
      • Очередь
  3. Выберите команду Удалить.
  4. В ответ на запрос нажмите кнопку Да, чтобы удалить очередь.

Важно!

  • При удалении очереди из нее также удаляются все сообщения.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Нельзя удалять очереди из папок «Исходящие очереди» и «Системные очереди».
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Отключение очередей исходящих сообщений

Отключение очередей исходящих сообщений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Очередь сообщений.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
  3. Выберите команду Все задачи и выполните одно из следующих действий.
    • Чтобы отключить очередь сообщений от сети, выберите команду Отключить очередь сообщений....
    • Чтобы снова подключить очередь сообщений к сети, выберите команду Подключить очередь сообщений....
  4. В ответ на запрос нажмите кнопку Да.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • При отключении очереди сообщений от сети обработка всех исходящих сообщений на локальном компьютере приостанавливается. Это полезно, если при медленном и дорогостоящем доступе к сети требуется отложить доставку исходящих сообщений из всех очередей компьютера на более позднее время.
  • Также можно приостановить обработку отдельной очереди исходящих сообщений. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Выполнение этой задачи возможно только в оснастке «Управление компьютером».
См. также


Приостановка и возобновление работы очереди исходящих сообщений

Приостановка и возобновление работы очереди исходящих сообщений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Исходящие очереди
      • Данная исходящая очередь
  3. Выберите команду Все задачи.
  4. Выберите команду Пауза. Или, чтобы возобновить работу очереди, выберите команду Продолжить.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Приостановка работы очереди исходящих сообщений откладывает отправку сообщений из данной очереди в соответствующую конечную очередь. В этом случае все ожидающие сообщения будут отправлены в конечную очередь позже.
  • Отправку всех исходящих сообщений также можно отложить, отключив очередь сообщений от сети. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Значки исходящих очередей, отключенных от сети, помечены знаком «X» на красном фоне в дереве консоли «Управление компьютером».
  • Выполнение этой задачи возможно только в оснастке «Управление компьютером».
См. также


Изменение метки очереди

Чтобы изменить метку очереди

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди («Общие очереди» или «Частные очереди»)
      • Очередь
  3. Нажмите кнопку Свойства.
  4. На странице Общие введите в поле Метка новое название очереди.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Метка очереди используется для идентификации очереди и представляет собой строку длиной до 124 символов Юникода. Например, все очереди, принимающие сообщения, отправленные определенным приложением, могут иметь метку «Сообщения из приложения».
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Изменение кода типа очереди

Чтобы изменить код типа очереди

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди («Общие очереди» или «Частные очереди»)
      • Очередь
  3. Нажмите кнопку Свойства.
  4. На странице Общие введите в поле Код типа код типа новой очереди.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Код типа очереди указывает на функцию или тип услуг, предоставляемых очередью. Код типа очереди должен являться кодом GUID в виде {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}, где x - это шестнадцатеричый текстовый знак. Использование кода типа очереди необязательно и зависит от отребований приложения очереди сообщения.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Изменение базового приоритета очереди

Изменение базового приоритета очереди

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши общую очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Общие очереди
      • Очередь
  3. Нажмите кнопку Свойства.
  4. На странице Общие введите в поле Базовый приоритет новое значение или выберите его с помощью стрелок ВВЕРХ и ВНИЗ.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Диапазон значений базового приоритета можно установить от -32768 до 32767. По умолчанию используется значение 0.
  • Базовый приоритет (называемый также приоритетом очереди) можно установить только для общих очередей. Частные очереди не поддерживают базовый приоритет.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Включение и отключение ведения журнала назначений

Включение или отключение ведения журнала назначений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди («Общие очереди» или «Частные очереди»)
      • Очередь
  3. Нажмите кнопку Свойства.
  4. На странице Общие в группе Журнал установите флажок Включен. Или, чтобы отключить ведение журнала очереди, снимите флажок Включен.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Ведение журнала назначений настроено на работу с очередями.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Задание ограничения размера хранилища журнала для очередей

Задание ограничения размера хранилища журнала для компьютеров

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди («Общие очереди» или «Частные очереди»)
      • Очередь
  3. Нажмите кнопку Свойства.
  4. На странице Общие установите в группе Журнал флажок Предел хранения журнала (КБ) и введите общий размер (в килобайтах) всех сообщений журнала, которые могут храниться в очереди.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Ограничение размера хранилища журнала (или квота) для очереди определяет максимальный общий размер всех сообщений, содержащихся в соответствующем журнале очереди. Квота может являться любым целым числом между 0 и 4,294,967,294.
  • Ограничение размера хранилища журнала доступно только если настроено ведение журнала назначений.
  • По достижении этого размера дополнительные сообщения нельзя будет отправить в очередь журнала, пока общий размер сообщений журнала в очереди журнала не станет меньше указанного предела.
  • Если снять флажок Предел хранения журнала (КБ), размер журнала будет ограничен только квотой локального компьютера.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Задание ограничения размера банка сообщений для очередей

Задание ограничения размера банка сообщений для очередей

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди (такая как «Общие очереди» или «Частные очереди»)
      • Очередь
  3. Нажмите кнопку Свойства.
  4. Установите флажок Предел хранения сообщений (КБ) и введите общий размер (в килобайтах) всех сообщений, которые могут храниться в данной очереди.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Ограничение размера банка сообщений (или квота) для очереди определяет максимальный общий размер всех сообщений, содержащихся в соответствующей очереди. Квота может являться любым целым числом между 0 и 4,294,967,294.
  • По достижении предельного размера сообщения нельзя будет отправить ни в какие очереди, пока общий размер сообщений в очередях не станет меньше указанного предела.
  • Если снять флажок Предел хранения сообщений (КБ), размер сообщений будет ограничен только доступным дисковым пространством на локальном компьютере.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Помещение в очередь только сообщений, прошедших проверку

Помещение в очередь только сообщений, прошедших проверку

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди (такая как «Общие очереди» или «Частные очереди»)
      • Очередь
  3. Нажмите кнопку Свойства.
  4. На странице Общие установите флажок Проверенных. Или, чтобы в очередь помещались любые сообщения, снимите флажок Проверенных.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Если установлен флажок Проверенных, в очередь будут помещаться только проверенные сообщения.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Изменение уровня секретности очередей

Изменение уровеня секретности очередей

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди (такая как «Общие очереди» или «Частные очереди»)
      • Очередь
  3. Нажмите кнопку Свойства.
  4. На странице Общие выберите в списке Приватность требуемый уровень секретности.
    • Чтобы в очередь помещались как зашифрованные, так и незашифрованные сообщения, выберите вариант Не обязательно (используется по умолчанию).
    • Чтобы в очередь помещались только зашифрованные сообщения, выберите вариант Тела сообщения.
    • Чтобы в очередь помещались только незашифрованные сообщения, выберите вариант Нет.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Указание или просмотр адресов многоадресной рассылки очереди и портов

Указание или просмотр адресов многоадресной рассылки очереди и портов

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши очередь.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди (такая как «Общие очереди» или «Частные очереди»)
      • Очередь
  3. Нажмите кнопку Свойства и выберите вкладку Многоадресный.
  4. В поле Адрес многоадресной рассылки введите адрес многоадресной рассылки и номер порта, используя следующий синтаксис IP_адрес:Номер_порта.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Адрес многоадресной рассылки и номер порта могут быть связаны с любой частной или общей очередью. Тем не менее, в режиме рабочей группы адреса многоадресной рассылки могут быть связаны только с частными очредями. В режиме домена для связывания адресов многоадресной рассылки с общими очередями должен быть доступен контроллер домена, поддерживающий адреса многоадресной рассылки в Active Directory.
  • При указании адресов многоадресной рассылки пробелы и начальные нули не вводятся.
  • IP-адреса многоадресной рассылки должны состоять из четырех байт и находиться в диапазоне класса «D» со значениями от 224.0.0.0 до 239.255.255.255. Тем не менее, только определенные диапазоны адресов в этом диапазоне доступны для отправки многоадресных сообщений. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Указать или просмотреть адреса многоадресной рассылки и номера порта очереди также можно с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Управление очередями и сообщениями на других компьютерах

Управление очередями и сообщениями на других компьютерах

  1. Откройте окно Управление компьютером.
  2. Щелкните правой кнопкой мыши раздел Управление компьютером и выберите команду Подключиться к другому компьютеру.
  3. В диалоговом окне Выбор: Компьютер выберите компьютер для управления его очередями и сообщениями и нажмите кнопку ОК.
  4. Выполните требуемые задачи так же, как и для локального компьютера.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Для управления общими очередями необходимо наличие доступа к Active Directory.
  • Управление частными очередями, расположенными на удаленном компьютере, невозможно.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».
См. также


Управление очередями и сообщениями с использованием оснастки «Active Directory - пользователи и компьютеры»

Управление очередями и сообщениями с использованием оснастки «Active Directory - пользователи и компьютеры»

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой мыши очередь или сообщение.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
      • Папка очереди (такая как «Частные очереди» для частной очереди)
      • Очередь
      • Сообщение
  4. Выполните требуемую задачу с помощью оснастки «Управление компьютером».

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Для создания, удаления и изменения свойств общих очередей на удаленных компьютерах с помощью оснастки «Active Directory - пользователи и компьютеры» необходимо обладать разрешениями администратора домена и войти в систему с использованием учетной записи пользователя домена.
См. также


Администрирование списков рассылки в очередях сообщений

  • Создание списков рассылки
  • Просмотр, добавление и удаление элементов списка рассылки
  • Просмотр и изменение свойств списков рассылки
  • Получение перечня списков рассылки, содержащих заданный элемент
  • Удаление списков рассылки


Создание списков рассылки

Чтобы создать список рассылки

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Выберите в меню Вид команду Пользователи, группы и компьютеры как контейнеры, а затем в меню Вид выберите команду Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел Пользователи.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Пользователи
  4. Выберите команды Создать и Группа.
  5. В диалоговое окно Новый объект – группа введите имя списка рассылки под списком Имя группы, выберите элемент Глобальная или Локальная в домене и установите переключатель Группа распространения.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на компьютере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Списки рассылки службы очередей сообщений являются объектами группы распространения в Active Directory.
  • При создании списка (группы) рассылки в Active Directory пользователю предлагается указать минимум сведений, необходимый для установления объекта в Active Directory. Каждый список (группа) рассылки имеет множество дополнительных настраиваемых свойств (атрибутов). После создания списка (группы) рассылки значения многих дополнительных атрибутов можно просмотреть и изменить. Для получения дополнительных инструкций щелкните ссылку «См. также».
  • Для получения дополнительных сведений о добавлении или удалении членов списков (групп) рассылки щелкните ссылку «См. также».

См. также


Просмотр, добавление и удаление элементов списка рассылки

Чтобы просмотреть, добавить или удалить элементы списка рассылки

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Выберите в меню Вид команду Пользователи, группы и компьютеры как контейнеры, а затем в меню Вид выберите команду Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой мыши список (группу) рассылки.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Пользователи
      • список (группа) рассылки
  4. Нажмите кнопку Свойства.
  5. На странице Члены можно просмотреть список членов выбранного списка (группы) рассылки. Явные участники списка рассылки могут являться общими очередями, псевдонимами очереди и другими списками рассылки. Кроме того, можно удалить элементы (членов) из списка (группы) рассылки, выбрав соответствующий элемент (член), нажав кнопку Удалить, а затем ОК.
  6. Для добавления общей очереди в список (группу) рассылки выполните следующие действия.
    • В дереве консоли щелкните правой кнопкой мыши очередь.

        • Где?

        • Active Directory – пользователи и компьютеры
        • Домен
        • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
        • Компьютер
        • msmq
        • Общая очередь
    • Нажмите кнопку Свойства.
    • На странице Является членом нажмите кнопку Добавить.
    • В диалоговом окне Выбор групп в поле Имя введите имя списка (группы) рассылки или имена нескольких списков (групп) рассылки, разделяя их точкой с запятой, после чего нажмите кнопкуОК а затем нажмите OK снова. Либо нажмите кнопку Дополнительно для поиска списка (группы) рассылки, введите соответствующие параметры и нажмите кнопку Найти, выберите нужные списки (группы) рассылки, нажмите кнопку OK, нажмите ОК вновь, после чего нажмите кнопку OK в третий раз.
  7. Для добавления общих очередей или очередей с именами URL в список (группу) рассылки выполните следующие действия.
    • Создайте псевдоним для каждой частной очереди или очереди с именем URL, которую требуется добавить в список (группу) рассылки. Для получения сведений о создании псевдонима для частной очереди или очереди с именем URL щелкните ссылку «См. также».
    • В дереве консоли щелкните правой кнопкой мыши список (группу) рассылки, к которому требуется добавить псевдоним очереди или псевдонимы очереди.

        • Где?

        • Active Directory – пользователи и компьютеры
        • Домен
        • Пользователи
        • список (группа) рассылки
    • Нажмите кнопку Свойства.
    • На странице Является членом нажмите кнопку Добавить. В диалоговом окне Выбор групп нажмите кнопку Что искать, установите флажок Другие объекты, снимите остальные флажки и нажмите кнопку ОК. В поле Имя введите имя псевдонима очереди или имена нескольких псевдонимов очереди разделяя их точкой с запятой, нажмите кнопку ОК, после чего нажмите кнопку ОК снова. Либо нажмите кнопку Дополнительно для поиска списка (группы) рассылки, введите соответствующие параметры и нажмите кнопку Найти, выберите псевдоним очереди, нажмите кнопку OK, нажмите ОК вновь, после чего нажмите кнопку OK в третий раз.
  8. Для добавления псевдонима очереди в один или несколько списков (групп) рассылки выполните следующие действия.
    • В дереве консоли щелкните правой кнопкой мыши соответствующий псевдоним очереди.

        • Где?

        • Active Directory – пользователи и компьютеры
        • Домен
        • Организационая единица (такая как «Computers» или «Domain Controllers»)
        • Псевдоним
    • Нажмите кнопку Свойства.
    • На странице Является членом нажмите кнопку Добавить.
    • В диалоговом окне Выбор групп в поле Имя введите имя списка (группы) рассылки или имена нескольких списков (групп) рассылки, разделяя их точкой с запятой, после чего нажмите кнопкуОК а затем нажмите OK снова. Либо нажмите кнопку Дополнительно для поиска списка (группы) рассылки, введите соответствующие параметры и нажмите кнопку Найти, выберите нужные списки (группы) рассылки, нажмите кнопку OK, нажмите ОК вновь, после чего нажмите кнопку OK в третий раз.
  9. Для добавления списка (группы) рассылки в качестве члена другого списка (группы) рассылки выполните следующие действия.
    • В дереве консоли щелкните правой кнопкой мыши список (группу) рассылки, который требуется сделать новым членом другого списка (группы) рассылки.

        • Где?

        • Active Directory – пользователи и компьютеры
        • Домен
        • Пользователи
        • список (группа) рассылки
    • Нажмите кнопку Свойства.
    • На странице Является членом нажмите кнопку Добавить.
    • В диалоговом окне Выбор групп в поле Имя введите имя списка (группы) рассылки или имена нескольких списков (групп) рассылки, разделяя их точкой с запятой, после чего нажмите кнопкуОК а затем нажмите OK снова. Либо нажмите кнопку Дополнительно для поиска списка (группы) рассылки, введите соответствующие параметры и нажмите кнопку Найти, выберите нужные списки (группы) рассылки, нажмите кнопку OK, нажмите ОК вновь, после чего нажмите кнопку OK в третий раз.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на компьютере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Списки рассылки службы очередей сообщений являются объектами группы распространения в Active Directory.
  • Явные участники списков рассылки могут являться общими очередями, псевдонимами очередей и другими списками рассылки, но не частными очередями или очередями с именами URL. Частные очереди и очереди с именами URL могут быть включены в список рассылки с помощью псевдонимов очереди. Для получения сведений о создании псевдонима для частной очереди или очереди с именем URL щелкните ссылку «См. также».

См. также


Просмотр и изменение свойств списков рассылки

Чтобы просмотреть или изменить свойства списков рассылки

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Выберите в меню Вид команду Пользователи, группы и компьютеры как контейнеры, а затем в меню Вид выберите команду Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой мыши список (группу) рассылки.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Пользователи
      • список (группа) рассылки
  4. Нажмите кнопку Свойства.
  5. Просмотр и изменение свойств списка (группы) рассылки по мере необходимости.
    6. Свойство | Вкладка
Имя группы | Общие
Описание | Общие
Область действия группы | Общие
Тип группы | Общие
Элементы (члены) списка (группы) рассылки | Члены
Папки, содержащие членов в Active Directory | Члены
Списки (группы) рассылки, членом которых является соответствующий список (группа) рассылки | Член групп
Административные разрешения | Безопасность

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на компьютере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Списки рассылки службы очередей сообщений являются объектами группы распространения в Active Directory.
  • Явные участники списков рассылки могут являться общими очередями, псевдонимами очередей и другими списками рассылки, но не частными очередями или очередями с именами URL. Частные очереди и очереди с именами URL могут быть включены в список рассылки с помощью псевдонимов очереди.
  • Типом группы для списка рассылки должен быть тип «Группа распространения».
  • Областью действия группы для списка рассылки может быть «Глобальная» или «Локальная в домене».

См. также


Получение перечня списков рассылки, содержащих заданный элемент

Чтобы получить перечень списков рассылки, содержащих заданный элемент

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Выберите в меню Вид команду Пользователи, группы и компьютеры как контейнеры, а затем в меню Вид выберите команду Дополнительные функции.
  3. В дереве консоли выполните следующие дейсвия.
    • Щелкните правой кнопкой мыши соответствующий список (группу) рассылки.

        • Где?

        • Active Directory – пользователи и компьютеры
        • Домен
        • Пользователи
        • список (группа) рассылки
    • Щелкните правой кнопкой мыши соответствующую общую очередь.

        • Где?

        • Active Directory – пользователи и компьютеры
        • Домен
        • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
        • Компьютер
        • msmq
        • Общая очередь
    • Щелкните правой кнопкой мыши соответствующий псевдоним очереди.

        • Где?

        • Active Directory – пользователи и компьютеры
        • Домен
        • Контейнер псевдонимов
        • Псевдоним
  4. Нажмите кнопку Свойства.
  5. На странице Членство в группах можно просмотреть перечень списков (групп) рассылки, членом которых является соответствующий объект. Для получения дополнительных сведений о добавлении объекта в другой список (группу) рассылки щелкните ссылку «См. также». Можно удалить соответствующий объект из списка (группы) рассылки, членом которого он является, выделив имя основного списка (группы) рассылки, а затем нажав кнопку Удалить.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на компьютере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Списки рассылки службы очередей сообщений являются объектами группы распространения в Active Directory.
  • Явные участники списков рассылки могут являться общими очередями, псевдонимами очередей и другими списками рассылки, но не частными очередями или очередями с именами URL. Частные очереди и очереди с именами URL могут быть включены в список рассылки с помощью псевдонимов очереди.

См. также


Удаление списков рассылки

Чтобы удалить список рассылки

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Выберите в меню Вид команду Пользователи, группы и компьютеры как контейнеры, а затем в меню Вид выберите команду Дополнительные функции.
  3. В дереве консоли щелкните узел Пользователи.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • данный_домен
      • Пользователи
  4. В области сведений щелкните правой кнопкой мыши соответствующий список (группу) рассылки и выберите в меню команду Удалить. Кроме того, можно выделить соответствующий список (группу) рассылки, а затем нажать кнопку Удалить.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на компьютере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Списки рассылки службы очередей сообщений являются объектами группы распространения в Active Directory.
  • При удалении списка рассылки он также автоматически удаляется из всех списков рассылки, членом которых является.

См. также


Администрирование сообщений в очередях сообщений

  • Просмотр свойств сообщения
  • Выбор отображаемых столбцов свойств сообщения
  • Очистка очереди от всех сообщений
  • Задание используемого по умолчанию времени жизни сообщений


Просмотр свойств сообщения

Просмотр свойств сообщения

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Сообщения очереди (или Сообщения журнала).

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди (такая как «Общие очереди» или «Частные очереди»)
      • Очередь
      • Сообщения очереди
        Сообщения журнала
  3. В области сведений щелкните правой кнопкой мыши сообщение и выберите команду Свойства.
  4. Просмотрите на вкладках свойства сообщения и дополнительные сведения.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Выбор отображаемых столбцов свойств сообщения

Выбор отображаемых столбцов свойств сообщения

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Сообщения очереди (или Сообщения журнала).

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди (такая как «Частные очереди» для частной очереди)
      • Очередь
      • Сообщения очереди
        Сообщения журнала
  3. В меню Вид выберите команду Добавить или удалить столбцы.
  4. В диалоговом окне Добавление или удаление столбцов внесите требуемые изменения.
    • Чтобы добавить столбец свойств сообщения, выберите его в списке Доступные столбцы и нажмите кнопку Добавить->.
    • Чтобы удалить столбец свойств сообщения, выберите его в списке Отображаемые столбцы и нажмите кнопку <-Удалить.
    • Чтобы изменить порядок отображения столбцов свойств сообщения, выберите свойство в списке Отображаемые столбцы и переместите его влево или вправо, нажимая кнопку Вверх или Вниз.
  5. Повторите шаг 4 для всех остальных столбцов, которые требуется изменить.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Результаты выполнения этой процедуры отображаются в области сведений. Сообщения также можно сортировать по определенному свойству, если щелкнуть заголовок соответствующего столбца. Чтобы отсортировать сообщения в обратном порядке повторно щелкните заголовок столбца.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Очистка очереди от всех сообщений

Очистка очереди от всех сообщений

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Сообщения очереди (или Сообщения журнала).

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Папка очереди (такая как «Общие очереди» или «Частные очереди»)
      • Очередь
      • Сообщения очереди
        Сообщения журнала
  3. Выберите команды Все задачи и Очистить.
  4. В ответ на запрос нажмите кнопку Да.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Очередь нельзя очистить от отдельных сообщений.
  • Для повышения производительности следует регулярно очищать от сообщений очереди недоставленных сообщений и журналы.
  • Эту задачу также можно выполнить с помощью оснастки «Active Directory - пользователи и компьютеры». Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Задание используемого по умолчанию времени жизни сообщений

Задание используемого по умолчанию времени жизни сообщений

  1. Откройте оснастку Active Directory – сайты и службы.
  2. В меню Вид выберите команду Показать узел служб.
  3. В дереве консоли щелкните правой кнопкой раздел MsmqServices.

      4. Где?

      • Active Directory – сайты и службы
      • Службы
      • MsmqServices
  4. Нажмите кнопку Свойства.
  5. На странице Общие введите новое значение и выберите новые единицы измерения, если требуется.

Примечания

  • Оснастку «Active Directory - сайты и службы» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к серверу терминалов на контроллере домена Windows 2000 или на рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - сайты и службы» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Используемое по умолчанию время жизни сообщения также называется сроком поступления в очередь (TTRQ).

См. также


Администрирование триггеров в очередях сообщений

  • Создание триггеров
  • Создание правил и подключение их к триггерам
  • Просмотр и изменение свойств триггеров и правил для триггеров
  • Удаление триггеров и правил для триггеров
  • Изменение используемых по умолчанию значений конфигурации


Создание триггеров

Создание триггеров

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой раздел Триггеры.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Триггеры очереди сообщений
      • Триггеры
  3. Выберите команды Создать и Триггеры.
  4. В поле Имя триггера на первой странице диалогового окнаНовый триггер введите имя нового триггера.
  5. Если требуется определить пользовательскую очередь как очередь триггера, в поле Путь очереди введите путь очереди с которой будет связан триггер, используя синтаксис Имя_компьютера\Имя_очереди или синтаксис .\Имя_очереди для локального компьютера. (Не используйте формат имен.) В противном случае выделите имя автоматически созданной на данном компьютере очереди.
  6. Для определения типа обработки сообщений нажмите кнопку Просмотр, Извлечение, или Транзактное извлечение.
  7. Установите соответствующий флажок для включнения или отключения триггера.
  8. Установите соответствующий флажок для назначения триггеру последовательного или непоследовательного статуса и нажмите кнопку Далее.
  9. На второй странице диалогового окна Новый триггер нажмите кнопку Существующие правила, если требуется добавить существующее правило к новому триггеру. В диалоговом окне Существующие правила в списке Список правил выберите существующее правило или правила, которые требуется добавить, нажмите кнопку Вложить для каждого выделенного правила и нажмите кнопку Закрыть чтобы вернуться на вторую страницу диалогового окна Новый триггер. С помощью кнопок Вверх и Вниз можно изменять порядок испытания правил, кнопка Отсоединить используется для удаления выбранного правила из триггера. Для завершения процесса создания списка добавленных правил нажмите кнопку Готово.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Данная процедура также может быть выполнена при открытии диалогового окна Новый триггер из папки «Triggers» в любой очереди триггера в дереве консоли. Для этого щелкните правой кнопкой мыши элемент Триггеры, выберите команды Создать и Триггер. В этом случае очередь автоматически становится очередью триггера.
  • Независимо от места создания триггера все триггеры, созданные на локальном компьютере, называемом набором триггеров, указаны в области сведений оснастки «Управление компьютером», когда элемент Триггеры выбран в дереве консоли в папке «Триггеры очереди сообщений». По умолчанию область сведений для каждого триггера отображает имя очереди триггера и количество правил, связанных с ним, а также включен ли триггер и назначен ли ему последовательный статус.
  • Перед созданием триггера убедитесь, что учетная запись, с использованием которой запущена служба «Триггеры очереди сообщений», имеет разрешение «Считывание сообщения» для всех существующих очередей, которые будут связаны с триггерами, а также разрешение «Получение сообщения» для всех существующих очередей которые будут связаны с триггерами, имеющими тип обработки «извлечение» или «транзактное извлечение». Для получения дополнительных сведений щелкните ссылку «См. также».
  • Существование очереди проверяется после указания в поле Путь очереди имени очереди пользователя, с которой будет связан триггер. Если очередь с указанным именем найти невозможно, появляется сообщение об ошибке.
  • Триггеры могут быть последовательными или непоследовательными. Последовательные триггеры испытывают условия всех связанных с ними правил на каждом сообщении, и выполняют все соответствующие действия перед переходом к следующему сообщению в порядке прибытия сообщений, тем не менее, их производительность ниже, чем у непоследовательных триггеров, поскольку сообщения обрабатываются поочередно. Непоследовательные триггеры обеспечивают большую производительность, но не всегда могут выполнить заданную операцию с сообщениями в порядке их прибытия. Такое может произойти, например, если несколько сообщений обрабатываются одновременно. Если при создании нескольких триггеров для определенной очереди хотя бы один из них является последовательным, все триггеры будут действовать как последовательные, даже если они не определены в качестве таковых. Триггеры с типом обработки «транзактное извлечение» могут быть только последовательными. Рекомендуется использовать только один триггер с последовательным параметром, поскольку триггеры запускаются в произвольном порядке в сответствии с их кодами GUID.
  • После создания триггера к нему можно добавить правило. Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Создание правил и подключение их к триггерам

Создание правил и подключение их к триггерам

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой раздел Правила.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Триггеры очереди сообщений
      • Правила
  3. Выберите команды Создать и Правило.
  4. На первой странице диалогового окна Новое правило в поле Имя правила укажите имя нового правила, а в поле Описание праила введите дополнительное описание.
  5. Нажмите кнопку Далее >.
  6. В поле Создание условия на второй странице диалогового окна Новое правило укажите условие. Для этого выберите начальную строку из списка, введите соответствующую конечную строку в расположенное снизу поле и нажмите кнопку Добавить. После этого новое условие появится в Списке условий. Можно создать дополнительные условия, повторив указанную операцию.
  7. По окончании создания требуемого условия нажмите кнопку Далее.
  8. В группе Действие правила на третьей странице диалогового окна Новое правило, нажав соответствующую кнопку укажите, будет ли триггер вызывать отдельную программу или компонент COM (по умолчанию).
  9. Для компонента COM в поле Код ProgID компонента укажите код компонента COM, а в поле Название метода введите название метода.
  10. Для отдельного приложения в поле Путь к исполняемому файлу укажите полный путь исполняемого файла и установите флажок Взаимодействовать с рабочим столом для отображения окна консоли приложения.
  11. Чтобы добавить параметры компоненту COM или отдельному приложению нажмите кнопку Параметры. В диалоговом окне Параметры вызова выберите параметр из списка Параметр. Если параметр является численным или строковым литералом, укажите его значение в поле Литерал. Нажмите кнопку Добавить. Повторите указанные действия для каждого параметра который требуется добавить, используйте кнопки Вверх и Вниз для изменения порядка передачи параметров в программу. Затем нажмите кнопку OK чтобы вернуться на третью страницу диалогового окна Новое правило, после чего нажмите кнопку Готово.
  12. Для присоединения существующих правил к триггеру выполните следующие действия.
    • В дереве консоли щелкните элемент Триггеры раздела Триггеры очереди сообщений.

        • Где?

        • Управление компьютером
        • Службы и приложения
        • Очередь сообщений
        • Триггеры очереди сообщений
        • Триггеры

      Или выполните команду Триггеры в соответствующей очереди триггера.

        Где?

        • Управление компьютером
        • Службы и приложения
        • Очередь сообщений
        • Папка очереди («Общие очереди», «Частные очереди» или «Системные очереди»)
        • Очередь триггера
        • Триггеры
    • В области сведений щелкните правой кнопкой мыши соответствующий триггер и выберите команду Свойства. Откройте вкладку Присоединенные правила и нажмите кнопку Существующие правила. На странице Существующие правила для каждого правила которое требуется добавить выберите правило в списке Список правил и нажмите кнопку Вложить. Затем нажмите кнопку Закрыть чтобы вернуться на страницу Присоединенные правила после чего нажмите кнопку ОК.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Все правила, созданные на локальном компьютере, называемом набором правил, указаны в области сведений оснастки «Управление компьютером» когда элемент Правила выбран в дереве консоли. По умолчанию, для каждого правила панель сведений отображает имя правила и его описание а также показывает, установлен ли флажок Взаимодействовать с рабочим столом.
  • Правило формируется из одного или нескольких условий и выполняется если условия верны. Каждое условие применяется к сообщению, когда оно достигает очереди триггера, при этом возможно два результата: «истина» и «ложь». После создания, условия, применяемые к определенному правилу, указываются в Списке условий на второй странице диалогового окна Новое правило, а также на странице Условия диалогового окна Свойства данного правила. Условие можно удалить из списка, выделив его и нажав кнопку Удалить. Несколько условий должны иметь значение «истина» чтобы действие могло быть выполнено. Если не определено ни одного условия, всегда будет возвращаться значение «истина». Это полезно, если требуется чтобы триггер безусловно действовал каждый раз при поступлении сообщения в очередь триггера.
  • Действия, выполняемые если условие имеет значение «истина», выражаются либо в форме исполняемого файла и параметров (аргументов) или в форме компонента COM , метода и параметров. Также можно вызвать другие типы файлов, делая их параметрами EXE-файла. Например, можно вызвать MSC-файл, указав mmc.exe в качестве выполняемого файла и включив полный путь MSC-файла как параметр вызова типа строкового литерала. Можно указать один или несколько параметров, выполняемых за действие. Поддерживаемые параметры перечислены в списке диалогового окна Параметры вызова.
  • Триггеру можно добавить несколько правил. В таком случае правила выполняются в порядке их отображения на странице Присоединенные правила диалогового окна Свойства данного правила. Можно изменять приоритет (порядок выполнения) правил в списке. Для этого, используя кнопки Вверх и Вниз на данной странице, измените порядок выполнения каждого правила, устанавливая для него высокий или низкий приоритет. Кроме того, правила на этой странице можно отключить , выбрав определенные правила и нажав кнопку Отключить. Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Просмотр и изменение свойств триггеров и правил для триггеров

Просмотр и изменение свойств триггеров и правил для триггеров

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните элемент Триггеры или Правила.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Триггеры очереди сообщений
      • Триггеры (или правила)
  3. В области сведений щелкните правой кнопкой мыши соответствующий триггер или правило и выберите команду Свойства.
  4. Просмотрите или измените свойства триггеров.
    5. Свойство триггера | Вкладка или диалоговое окно
Имя триггера | Общие
Очередь триггера (путь очереди пользователя) | Общие
Тип обработки сообщения | Общие
Включение или отключение | Общие
Последовательный или непоследовательный | Общие
Правила, добавленные к триггеру | Добавленные правила
Правила, доступные для триггера | Существующие правила

    Или, просмотрите или измените свойства триггеров.

    Свойство правила | Вкладка или диалоговое окно
Имя правила | Общие
Описание правила | Общие
Условия, применимые к правилу | Условия
Независимо от того, запускает ли правило отдельное приложение или компонент COM | Действие
Путь отдельного приложения | Действие
Код ProgID компонента | Действие
Метод, выбранный для компонента COM | Действие
Взаимодействие с рабочим столом | Действие
Используемые свойства сообщения и их порядок | Параметры вызова

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Диалоговое окно Свойства определенного триггера имеет вкладки Общие и Присоединенные правила. Кроме того, на странице Присоединенные правила можно получить доступ к диалоговому окну Существующие правила. Диалоговое окно Свойства определенного правила имеет вкладки Условия и Действие. Кроме того, на странице Действие можно получить доступ к диалоговому окну Параметры вызова.
  • Очередь триггера существующего триггера изменить невозможно.
  • Правило состоит из одного или нескольких условий и выполняется если условия имеют значение «истина». Каждое условие применяется к сообщению, когда оно достигает очереди триггера, при этом возможно два результата: «истина» и «ложь». Условия, применяемые к определенному правилу, указываются в Списке условий на странице Условия диалогового окна Свойства данного правила. Условие можно удалить из списка, выделив его и нажав кнопку Удалить. Новые условия формирутся при выборе поддерживаемой начальной строки в списке Новое условие и указании заключительной строки в расположенном ниже поле. Несколько условий должны иметь значение «истина» чтобы действие могло быть выполнено. Если не определено ни одного условия, всегда будет возвращаться значение «истина». Это полезно, если требуется чтобы триггер безусловно действовал каждый раз при поступлении сообщения в очередь триггера.
  • Действия, выполняемые если условия имеют значение «истина», выражаются либо в форме исполняемого файла и параметров (аргументов) или в форме компонента COM, метода и параметров. Можно указать один или несколько аргументов, выполняемых за действие. Поддерживаемые параметры перечислены в соответствующем списке диалогового окна Параметры вызова, которое можно открыть, щелкнув кнопку Параметры на странице Действие диалогового окна Свойства определенного правила.
  • Правила, отображаемые на странице Существующие правила по умолчанию отключены. Добавление этих правил к триггеру позволить включить их. Триггеру можно добавить несколько правил. В таком случае правила выполняются в порядке их отображения на странице Присоединенные правила. Можно изменять приоритет (порядок выполнения) правил в списке. Для этого, используя кнопки Вверх и Вниз на данной странице, измените порядок выполнения каждого правила, устанавливая для него высокий или низкий приоритет. Кроме того, правила на этой странице можно отключить , выбрав определенные правила и нажав кнопку Отключить. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Все триггеры и правила для триггеров, созданные на локальном компьютере, отображаются в области сведений оснастки «Управление компьютером» когда соответствующая папка выбрана в дереве консоли.

См. также


Удаление триггеров и правил для триггеров

Удаление триггеров и правил для триггеров

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните элемент Триггеры или Правила.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Триггеры очереди сообщений
      • Триггеры (или правила)
  3. В области сведений щелкните правой кнопкой мыши соответствующий триггер или правило и выберите команду Удалить. Кроме того, можно выделить соответствующий триггер или правило а затем нажать клавишу DELETE.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Все триггеры и правила для триггеров, созданные на локальном компьютере, отображаются в оснастке «Управление компьютером».
  • Для отсоединения правила от триггера без его удаления щелкните правой кнопкой мыши соответствующий триггер в области сведений и выберите команду Свойства. Выберите вкладку Присоединенные правила, затем выделите правила, которые требуется отсоединить, и нажмите кнопку Отсоединить. Для получения дополнительных сведений щелкните ссылку «См. также».

См. также


Изменение используемых по умолчанию значений конфигурации триггеров

Изменение используемых по умолчанию значений конфигурации триггеров

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните правой кнопкой мыши раздел Триггеры очереди сообщений.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Очередь сообщений
      • Триггеры очереди сообщений
  3. Выберите команду Свойства а затем измените значения в полях Начальное число потоков, Предельное число потоков и Размер текста основного сообщения по умолчанию.

Примечания

  • Чтобы открыть окно управления компьютером, щелкните правой кнопкой мыши значок Мой компьютер и выберите команду Управление.
  • Все сведения о конфигурации а также описания триггеров и правил хранятся в реестре локального компьютера.
  • Значение Размер текста основного сообщения по умолчанию определяет объем буфера, который служба триггеров очереди сообщений будет отводить для входящего сообщения. Данное значение должно равняться размеру, позволяющему разместить 90% всех сообщений, которые должны прибыть в очереди триггера. Если это значение слишком мало, служба будет перераспределять буфер для каждого сообщения. Если значение слишком велико, будет зарезервирован чрезмерный объем памяти.

См. также


Тестирование узла очереди сообщений и наблюдение за ним

Тестирование очереди сообщений и наблюдение за ней

  • Просмотр событий очереди сообщений
  • Просмотр внешних транзакций
  • Просмотр производительности компьютера
  • Просмотр производительности очереди
  • Отправка тестовых сообщений
  • Включение слежения за маршрутом сообщения
  • Проверка подключения с использованием MQPing


Просмотр событий очереди сообщений

Чтобы просмотреть события очереди сообщений

  1. Откройте окно Просмотр событий.
  2. В дереве консоли выберите раздел Журнал приложений.
  3. В области сведений выделите столбец Источник для слияния источников «MSMQ» и «Триггеры MSMQ ».
  4. Прокручивайте список, пока не появятся события с источниками «MSMQ» и «Триггеры MSMQ ».

Примечания

  • Чтобы открыть программу просмотра событий, в меню Пуск выберите команду Выполнить, введите

    eventvwr

    и нажмите кнопку ОК.
  • Данные в окне просмотра событий можно сортировать, фильтровать, а также искать записи событий по свойствам.
См. также


Просмотр внешних транзакций

Чтобы просмотреть внешние транзакции

  1. Откройте Службы компонентов.
  2. В дереве консоли дважды щелкните раздел Службы компонентов, дважды щелкните раздел Компьютеры, затем дважды щелкните раздел Мой компьютер после чего дважды щелкните раздел Координатор распределенных транзакций.
  3. Для просмотра состояния внешних транзакций выберите элемент Список транзакций.
  4. Для просмотра статистики внешних транзакций выберите элемент Статистика транзакций.

Примечания

  • Чтобы открыть оснастку «Службы компонентов» в меню Пуск выберите команду Выполнить и введите следующую строку:

    dcomcnfg

    Затем нажмите кнопку ОК.

  • Для выполнения внешних транзакций должна быть запущена служба «Координатор распределенных транзакций Microsoft (MS DTC)».
  • На компьютере, работающем под управлением Windows NT 4,0, наблюдение за внешними транзакциями осуществляется при помощи консоли администрирования MS DTC. Чтобы открыть консоль администрирования MS DTC на компьютере с установленной ОС Windows NT 4.0 нажмите кнопку Пуск, выберите команду Выполнить, введите:

    dac.exe

    и нажмите клавишу ENTER. Состояние внешних транзакций можно просмотреть на странице Транзакция, а их статистику – на странице Статистика.

См. также


Просмотр данных о производительности компьютера

Чтобы просмотреть данные о производительности компьютера

  1. Откройте окно Производительность.
  2. В области сведений нажмите на панели инструментов кнопку Добавить (+).
  3. В диалоговом окне Добавить счетчики выберите вариант Использовать локальные счетчики для просмотра счетчиков данного компьютера. Или, чтобы просмотреть счетчики другого компьютера, выберите вариант Выбрать счетчики с компьютера, а затем выберите требуемый компьютер.
  4. В списке Объект выберите вариант Служба очередей сообщений.
  5. Выберите вариант Все счетчики. Либо выберите вариант Выбрать счетчики из списка, а затем выберите счетчики для наблюдения.
  6. Выберите вариант Все вхождения. Либо выберите вариант Выбрать вхождения из списка, а затем выберите экземпляры для наблюдения.
  7. Нажмите кнопку Добавить.
  8. Чтобы просмотреть описание выбранного счетчика, нажмите кнопку Объяснение.
  9. Нажмите кнопку Закрыть.

    В области сведений появятся диаграммы.

Примечания

  • Чтобы открыть системный монитор, в меню Пуск выберите команду Выполнить, введите

    perfmon

    и нажмите кнопку ОК.
  • Данные производительности в окне «Производительность» можно просматривать в виде диаграммы, отчета или гистограммы, а также сохранять в файле. Дополнительные сведения об окне «Производительность» содержатся в разделе «Системный монитор: обзор» справки операционной системы Windows 2000 Server.
  • Для получения дополнительных сведений о наблюдении за службой очереди щелкните ссылку «См. также».

См. также


Просмотр данных о производительности очереди

Чтобы просмотреть данные о производительности очереди

  1. Откройте окно Производительность.
  2. В области сведений нажмите на панели инструментов кнопку Добавить (+).
  3. В диалоговом окне Добавить счетчики выберите вариант Использовать локальные счетчики для просмотра счетчиков данного компьютера. Или, чтобы просмотреть счетчики другого компьютера, выберите вариант Выбрать счетчики с компьютера, а затем выберите требуемый компьютер.
  4. В списке Объект выберите вариант Очередь сообщений.
  5. Выберите вариант Все счетчики. Либо выберите вариант Выбрать счетчики из списка, а затем выберите счетчики для наблюдения.
  6. Выберите вариант Все вхождения. Либо выберите вариант Выбрать вхождения из списка, а затем выберите экземпляры для наблюдения.
  7. Нажмите кнопку Добавить.
  8. Чтобы просмотреть описание выбранного счетчика, нажмите кнопку Объяснение.
  9. Нажмите кнопку Закрыть.

    В области сведений появится диаграмма.

Примечания

  • Чтобы открыть системный монитор, в меню Пуск выберите команду Выполнить, введите:

    perfmon

    и нажмите кнопку ОК.
  • Данные производительности в окне «Производительность» можно просматривать в виде диаграммы, отчета или гистограммы, а также сохранять в файле. Дополнительные сведения об окне «Производительность» содержатся в разделе «Системный монитор: обзор» справки операционной системы Windows 2000 Server.
  • Для получения дополнительных сведений о наблюдении за службой очереди щелкните ссылку «См. также».

См. также


Отправка тестовых сообщений

Чтобы отправить тестовое сообщение

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел msmq.

      Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Исходный компьютер
      • msmq
  4. Нажмите кнопку Свойства.
  5. На странице Диагностика нажмите кнопку Послать.
  6. В списке Очередь местоназначения выберите очередь для проверки и нажмите кнопку Отправить. Или, чтобы создать очередь для отправки в нее сообщений, нажмите кнопку Новая очередь, введите полный полный путь к очереди (например, конечный_компьютер\конечная_очередь), нажмите кнопку OK, а затем – кнопку Отправить.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Компьютер, объект msmq которого выбран, является исходным компьютером, с которого отправляются тестовые сообщения.
  • Тестовые сообщения можно отправлять только в тестовые очереди. Все тестовые очереди являются общими очередями и имеют код типа очереди {55EE8F33-CCE9-11CF-B108-0020AFD61CE9}.
  • Транзактная очередь не может использоваться в качестве тестовой. В транзактные очереди можно отправлять только транзактные сообщения, которыми тестовые сообщения не являются. Аналогично нельзя изменять код типа очереди, требующей для этого проверки подлинности, на код типа тестовой очереди и отправлять тестовые сообщения в эту очередь, так как они не будут отправлены (если только эта очередь не расположена на исходном компьютере).
  • Поскольку все тестовые сообщения отправляются с установленным флагом слежения за маршрутом, если на исходном компьютере включено слежение за маршрутом а тестовая очередь находится на другом компьютере, маршрут таких тестовых сообщений отслеживается и сообщения отчетов отправляются в очередь отчетов на исходном компьютере. Для получения сведений об отслеживании маршрута щелкните ссылку «См. также».
  • Можно проверить доставку отправленных тестовых сообщений в конечную очередь, просмотрев свойства сообщений в конечной очереди, или, если включено слежение за маршрутом, просмотрев содержимое очереди отчета на исходном компьютере. Для получения инструкций по просмотру свойств сообщений в конкретной очереди щелкните ссылку «См. также».

См. также


Включение слежения за маршрутом сообщения

Включение слежения за маршрутом сообщения

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
  4. Нажмите кнопку Свойства.
  5. На вкладке Диагностика нажмите кнопку Слежение.

    Откроется диалоговое окно Слежение за маршрутом сообщения.

  6. В списке Путь к очереди отчетов выберите очередь отчетов. Или, чтобы создать новую очередь для сообщений отчетов, нажмите кнопку Создать и введите путь к очереди (например MyComputer\MyQueue).
  7. Выберите вариант Следить за всеми сообщениями или Следить только за тестовыми сообщениями.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Любая общая очередь может использоваться как очередь отчетов. Для получения инструкций по созданию очередей для сообщений отчетов перед выполненим данной процедуры щелкните ссылку «См. также».
  • Если выбран вариант Следить за всеми сообщениями, исходное приложение установило флаг слежения за маршрутом, а конечная очередь расположена на другом компьютере, для всех сообщений, отправленных таким приложением с исходного компьютера, будут отслежены маршруты. Все сообщения отчетов, отправленные по маршруту каждого сообщения, затем отправляются в очередь отчетов на исходном компьютере. Слежение выполняется как для сообщений, отправленных исходным компьютером, так и для сообщений, отправленных через сервер очереди сообщений с включенной маршрутизацией.
  • Если выбран вариант Следить только за тестовыми сообщениями, сообщения отчетов будут отправлены только для тестовых сообщений. Для получения инструкций по отправке тестового сообщения щелкните ссылку «См. также».
  • Сообщения, отправленные локально в очередь на том же компьютере, не отслеживаются.
  • Сообщения, отправленные по транспорту HTTP/HTTPS и сообщения, отправленные нескольким получателям с помощью IP-рассылки, списков рассылки или многоэлементных имен форматов невозможно отследить в текущей версии очереди сообщений.

См. также


Проверка подключения с использованием MQPing

Чтобы проверить подключение с использованием MQPing

  1. Откройте оснастку Active Directory – пользователи и компьютеры.
  2. Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем – флажок Дополнительные функции.
  3. В дереве консоли щелкните правой кнопкой раздел msmq.

      4. Где?

      • Active Directory – пользователи и компьютеры
      • Домен
      • Организационая единица (такая как «Компьютеры» или «Контроллеры домена»)
      • Компьютер
      • msmq
  4. Выберите команду Отправка сообщения MQPing.

Примечания

  • Оснастку «Active Directory - пользователи и компьютеры» можно запустить, открыв подключение к удаленному рабочему столу на компьютере с Windows XP Professional для доступа к службам терминала на контроллере домена Windows 2000 или рядовом сервере, на котором установлена эта оснастка. Оснастка «Active Directory - пользователи и компьютеры» не входит в состав Windows XP Professional и не может быть установлена на компьютер Windows XP Professional путем установки средств администрирования Windows 2000. Для получения дополнительных сведений щелкните ссылку «См. также».
  • Сообщение MQPing также можно отправить, щелкнув правой кнопкой объект msmq, выбрав команду Свойства, перейдя на вкладку Диагностика и нажав кнопку MQPing.
  • При отправке сообщения MQPing на какой-либо компьютер очередь сообщения ожидает от него ответ в течение 45 секунд. Появляется сообщение, информирующее о результатах проверки MQPing. Для определения наличия подключения к компьютеру может потребоваться отправка нескольких сообщений MQPing.

См. также


Основные понятия

Этот раздел содержит общие фундаментальные сведения об очереди сообщений.

  • Очередь сообщений: обзор
  • Общие сведения об очереди сообщений
  • Работа с очередью сообщений
  • Ресурсы


Очередь сообщений: обзор

Очередь сообщений (также известна как MSMQ) представляет собой инфраструктуру обмена сообщениями и средство разработки распределенных приложений обмена сообщениями для операционных систем Microsoft Windows. Приложения, разработанные для работы с очередью сообщений, отправляют сообщения в очереди, являющиеся временными хранилищами, из которых сообщения доставляются по назначению. Такие приложения могут производить обмен данными в неоднородных сетях а также обмениваться сообщениями между компьютерами, которые временно не могут установить соединение друг с другом. Очередь сообщений обеспечивает гарантированную доставку сообщений, эффективную маршрутизацию, безопасность, поддержку обмена транзактными сообщениями и обработку сообщений на основе приоритетов. Программные продукты с такими возможностями часто упоминаются как приложения очереди сообщений, приложения хранения и пересылки соощений или приложения, ориентированные на работу с сообщениями.

Очередь сообщений позволяет конечным пользователям общаться через сеть с использованием компьютеров, которые могут быть отключены от сети, независимо от текущего состояния сети и компьютеров. Системные администраторы могут использовать очереди сообщений для эффективного управления большими и сложными сетями, включающими компьютеры и очереди сообщений. Используя очереди сообщений, разработчики готовых решений получают более надежные способы подключения и могут более эффективно использовать сетевые ресурсы. Разработчики могут уделить больше внимания основным рабочим задачам, не отвлекаясь на вопросы, связанные с сетью, так как очередь сообщений обеспечивает эффективные и надежные сетевые подключения.

Очередь сообщений представляет определенный интерес для сетевых администраторов (установка и управление инфраструктурой) и разработчиков программного обеспечения (создание приложений обмена сообщениями). Данная документация предназначена для системных администраторов, поэтому в ней описаны только инфраструктура и возможности пользовательского интерфейса и средств администрирования очереди сообщений, а инструкции по разработке приложений отсутствуют. Более подробные сведения о разработке приложений, использующих очередь сообщений, содержатся в пакете «Message Queuing Software Development Kit (SDK)», входящем в состав пакета «Microsoft Platform SDK» библиотеки Microsoft Developer Network (MSDN). Дополнительные сведения о пакете «Message Queuing SDK» содержатся в разделе Microsoft Platform Software Development Kit.

В документации четко описаны различия между возможностями, предоставляемыми пользовательским интерфейсом и средствами администрирования очереди сообщений, и возможностями, получаемыми программным путем при использовании очереди сообщений.

По сравнения с предыдущими версиями, в текущей версии очереди сообщений присутствуют изменения в администрировании и терминологии. Список изменений, с которыми следует ознакомиться при обновлении с предыдущей версии, содержится в разделе Обновление очереди сообщений: обзор.

Примечания

  • Предыдущие версии очереди сообщений (для Windows NT 4.0, Windows 95 и Windows 98) назывались Microsoft Message Queuing Server или MSMQ 1.0. Текущая версия очереди сообщений, основанная на исходной концепции и технологиях MSMQ и дополненная многими новыми функциями, официально называется Очередь сообщений 3.0.
  • В данной документации текущее официальное название Очередь сообщений используется в качестве общего названия всех версий. Это вовсе не предполагает отказа от использования ставшего привычным термина MSMQ. Термин «MSMQ» широко используется опытными пользователями а также во внешних источниках, поэтому пользователям рекомендуется знать оба этих определения.
  • Аналогично, версия для Windows 2000 официально называется Очередь сообщений 2.0, но во внешних источниках и литературе часто именутся MSMQ 2.0.

Общие сведения о возможностях

Ниже рассмотрены основные возможности очереди сообщений, разделенные на новые, присутствующие только в Windows XP, и старые, сохранившиеся из предыдущих версий.

Новые возможности

  • Триггеры.Триггеры очереди сообщений теперь являются компонентом основного продукта а не дополнением. Триггеры содержат механизм, позволяющий связывать прибытие каждого входящего сообщения в очереди с ответом, зависящим от содержимого сообщения, и могут вызывать компонент COM или отдельное приложение. Рабочие правила могут быть определены и введены в ответ на такие сообщения без дополнительного программирования. Дополнительные сведения об этой возможности содержатся в разделе Триггеры очереди сообщений.
  • Отправка сообщений нескольким получателям. Клиенты могут отправлять одно сообщение нескольким получателям. Список конечных очередей может быть задан явно посредством объектов группы рассылки (списков рассылки) в Active Directory, а также в форме многоэлементных имен формата. Поддерживается проверка доставки в очередь на компьютеры с более ранними чем Windows XP версиями Windows сообщений, отправленных в списки рассылки и многоэлементные имена формата. Кроме того, поддерживается доставка сообщений по адресам IP-рассылки рассылки с помощью протокола PGM. Дополнительные сведения об этой возможности содержатся в разделе Отправка сообщений нескольким получателям.
  • Доставка сообщений по транспорту HTTP.Основанный на XML протокол отправки сообщений SRMP (SOAP Reliable Messaging Protocol) был разработан для доставки сообщений high-QoS (качество обслуживания). Общие и частные имена очередей администрирования или очередей ответов а также их имена прямого формата могут быть помещены в сообщения, отправляемые по транспорту HTTP. Аналогично, имена очередей администрирования или очередей ответов в формате HTTP могут быть помещены в сообщения, отправляемые по обычному (не HTTP) транспорту. Дополнительные сведения об этой возможности содержатся в разделе Доставка сообщений по транспорту HTTP. Дополнительные сведения о формате имен содержатся в разделе Формат имен.
  • Интеграция с Active Directory. Интеграция и расширение Active Directory для хранения всех сведений о конфигураци, настройках безопасности и состоянии. Теперь клиенты очереди сообщений используют протокол LDAP для доступа к контроллерам домена и серверам глобального каталога для получения специальной информации очереди сообщений в Active Directory напрямую, без помощи сервера очереди сообщений на контроллере домена.
  • Поддержка консоли управления Microsoft (MMC). Более полное администрирование очереди сообщений осуществляется с использованием оснасток, работающих в консоли управления (MMC). Административные задачи, ранее выполнявшиеся в панели управления, теперь выполняются в оснастках. Дополнительные сведения содержатся в разделе Новые способы выполнения некоторых задач.
  • Поиск сообщения. Теперь очередь сообщений позволяет просматривать определенные сообщения или извлекать их, не используя курсоры для навигации в очереди с целью обнаружения искомого сообщения. Эта возможность основана на 64-разрядном коде поиска, который назначается каждому сообщению при его помещении в конечную очередь. Дополнительные сведения содержатся в разделе Поиск сообщения.

Старые возможности

  • Работа в смешанном режиме. Очередь сообщений может работать в доменах, поддерживающих смешанный режим, то есть содержащих взаимодействующие серверы контроллеров MSMQ 1.0, работающие в Windows NT 4.0, и серверы очереди сообщений, работающие в Windows 2000.
  • Интеграция с механизмами безопасности Windows. Служба сообщений поддерживает секретность и безопасность, используя управление доступом, аудит доступа, шифрование и проверку подлинности сообщений. Для проверки подлинности сервера она также использует новые средства безопасности, впервые появившиеся в Windows 2000, такие как протокол безопасности Kerberos V5. Кроме того, американская версия очереди сообщений поддерживает шифрование как со 128-разрядным, так и с 40-разрядным ключами. Создание очередей доступно только пользователям, обладающим соответствующими разрешениями и работающими с приложениями очереди сообщений локально. Дополнительные сведения о безопасности содержатся в разделе Безопасность очереди сообщений: обзор.
  • Поддержка рабочих групп. Очередь сообщений может быть установлена и запущена на компьютере, входящем как в домен, так и в рабочую группу Windows XP. Кроме того, компьютер, входящий в рабочую группу и на который установлена очередь сообщений, может позже присоединиться к домену, а затем снова выйти из него. Дополнительные сведения о компьютерах, входящих в состав рабочей группы или домена, содержатся в разделах Топология сети в очереди сообщений и Присоединение к домену из рабочей группы.
  • Поддержка симметричного режима работы в кластере. Очередь сообщений полностью поддерживает симметричную работу в кластере серверов, что означает одновременную работу на всех узлах кластера.
  • Поддержка Windows CE. Специальная версия клиента очереди сообщений устанавливается на карманные и наладонные компьютеры, работающие под управлением Windows CE версии 3.0 (или более поздней), в составе ОС.
  • Архивация и восстановление сообщений. Файлы хранилищ сообщений, журналов, журналов транзакций и параметров реестра можно архивировать и восстанавливать на случай сбоя компьютера. Дополнительные сведения содержатся в разделе Архивация и восстановление сообщений.
  • Обработка сообщений в зависимости от их приоритета. Эта возможность позволяет отправлять срочные и важные сообщения раньше, чем менее важные сообщения, чтобы обеспечить требуемое время ответа от более важных сообщений за счет менее важных сообщений. Дополнительные сведения об отправке сообщений с различным приоритетом содержатся в разделе Приоритет сообщения.
  • Гарантированная доставка сообщений. Для гарантии доставки сообщения могут храниться в очереди на диске и позже пересылаться по назначению.
  • Отправка транзактных сообщений. Используя возможности транзакций, можно проводить несколько связанных действий в виде одной транзакции, обеспечивая доставку сообщений в заданном порядке, предотвращая их дублирование и проверяя, были ли они успешно получены из конечной очереди. Дополнительные сведения об отправке транзактных сообщений содержатся в разделе Обмен транзактными сообщениями.
  • Динамическое создание очередей. Можно создавать очереди и изменять их свойства «на лету», никак не влияя на приложения обмена сообщениями.
  • Маршрутизация сообщений. Очередь сообщений предоставляет возможности маршрутизации сообщений в зависимости от физической топологии сети, потребности в концентрации сеансов и транспорта. Концентрация сеансов позволяет эффективно использовать связи с малой скоростью передачи данных. Дополнительные сведения содержатся в разделе Маршрутизация сообщений.
  • Интеграция с различными платформами. Служба сообщений может использоваться на множестве аппаратных платформ, использующих средства подключения, предоставленные другими поставщиками. Дополнительные сведения об обмене сообщениями на различных платформах содержатся в разделе Поддержка различных платформ и подключение к инородным компьютерам.

Все эти возможности делают очередь сообщений идеальным средством для реализации полуавтономных систем клиент-сервер (таких как приложения учета, ведения учетных записей и инвентаризации), пакетной обработки, систем клиент-сервер на основе очереди (с последовательной обработкой запросов из очереди) и миграции с устаревших систем.

Очереди сообщений и электронная почта

Очередь сообщений не является приложением электронной почты и играет в организации совсем другую роль. Очередь сообщений доставляет данные между приложениями, используя систему очередей, распределенных по разным компьютерам. В отличие от нее, электронная почта является средством обмена данными между людьми, осуществляемого при помощи центрального почтового отделения и почтовых папок.

Однако очередь сообщений может дополнять приложения электронной почты, позволяя различным клиентам общаться друг с другом.

У этой системы имеются некоторые ключевые сходства с электронной почтой.

  • Ни одна из этих систем не требует присутствия получателя на рабочем месте во время отправки ему сообщения. Обе системы хранят сообщения и пересылают их , когда получатель будет доступен.
  • Сообщения обоих типов хранят адреса отправителя и получателя.

У этой системы имеются некоторые ключевые отличия от электронной почты.

  • Как отправителем сообщения в очередь сообщений, так и его получателем является приложение, тогда как и отправителем, и получателем сообщения электронной почты обычно является человек.
  • Содержимым сообщения из очереди сообщений обычно являются двоичные данные, понятные только приложениям, отправляющим и получающим такие сообщения. Содержимым сообщения электронной почты обычно является форматированный текст, понятный любому прочитавшему его человеку.
  • Приложение очереди сообщений не требует подключения компьютера для отправки сообщений. Для отправки сообщений электронной почты обычно необходима установка подключения к серверу или почтовому отделению.
  • Очередь сообщений оптимизирована для предоставления гораздо более быстрого способа передачи данных по сравнению с электронной почтой.
  • Очередь сообщений обрабатывает сообщения в зависимости от их приоритета, гарантирует доставку сообщений и возврат уведомлений об их получении.
  • Очередь сообщений позволяет настраивать доставку сообщений с преимущественным использованием памяти, диска или транзакций.


Общие сведения об очереди сообщений

В данной главе вводятся ключевые понятия и термины, с которыми необходимо ознакомиться перед тем, как приступать к установке и администрированию очереди сообщений.

  • Топология сети очереди сообщений
  • Компьютеры очереди сообщений
  • Типы очередей
  • Имена очередей
  • Типы сообщений и их доставка
  • Отправка сообщений нескольким получателям
  • Маршрутизация сообщений
  • Хранилище сообщений
  • Объекты очереди сообщений в Active Directory
  • Доставка сообщений по транспорту HTTP
  • Триггеры очереди сообщений
  • Рабочие сценарии для очереди сообщений


Топология сети очереди сообщений

Топология сети в очереди сообщений

Очередь сообщений (Message Queuing, MSMQ) – это инфраструктура передачи сообщений, которая состоит из компьютеров, выполняющих различные функции и объединенных в сеть Windows. Эта сеть может включать компьютеры, работающие как под управлением Windows XP, так и под управлением предыдущих версий Windows. В данном разделе рассказывается, каким образом компьютеры, использующие очередь сообщений, соединяются в подобную. сеть.

Очередь сообщений может использоваться либо в среде домена, либо в среде рабочей группы. В контексте очереди сообщений среда домена включает контроллеры домена, поддерживающие службу каталогов, например, Active Directory, тогда как среда рабочей группы не оснащена такой службой каталогов. Компьютер очереди сообщений, принадлежащий домену, можно настроить так, чтобы он не имел доступа к службе каталогов. О таком компьютере, равно как и о компьютере очереди сообщений, принадлежащем рабочей группе, говорят, что он функционирует в режиме рабочей группы. Возможны и другие ситуации, в которых компьютеры очереди сообщений, принадлежащие домену, будут лишены доступа к Active Directory. Подобные ситуации возникают, когда сервер очереди сообщений отключен от сети или когда от сети отключены все контроллеры домена в его сайте. Тогда говорят, что такой компьютер работает в автономном режиме.

Среда домена

В среде домена Windows 2000 компьютеры Windows XP, на которых работает служба очереди сообщений, может прямо обращаться к объектам очереди сообщений, расположенным в службе каталогов Active Directory. С другой стороны, компьютер Windows 2000, на котором работает очередь сообщений, требует присутствия контроллера домена Windows 2000, на котором находится сервер очереди сообщений, и его домена для доступа к таким объектам в Active Directory. Кроме того, для компьютера, работающего под управлением Windows NT 4.0, Windows 98 или Windows 95 с запущенной службой MSMQ 1.0, необходимо настроить контроллер домена в качестве сервера глобального каталога. Совокупность всех доменов в сети Windows 2000 называется лесом.

Очередь сообщений может работать и в домене со смешанным режимом, то есть в домене, где серверы контроллеров MSMQ 1.0, работающие в Windows NT 4.0, и серверы очереди сообщений, работающие в Windows 2000, могут осуществлять связь друг с другом.

Сайты

В среде домена сеть очереди сообщений может быть разделена на сайты Windows 2000, связанные с помощью маршрутных ссылок. Сайты отображают физическую структуру сети, тогда как домены, вообще говоря, представляют логическую структуру данной организации. Логическая и физическая структуры независимы друг от друга, поэтому в одном сайте может быть несколько доменов, равно как в одном домене — несколько сайтов.

В контексте очереди сообщений сайт включает в себя следующие объекты.

  • Контроллеры доменов Windows 2000, которые хранят данные о конфигурации и состоянии в службе каталогов Active Directory и реплицируют эти данные между сайтами с помощью связей сайтов. Active Directory использует так называемую "модель с несколькими главными контроллерами домена", то есть любой контроллер домена Windows 2000 может читать и записывать данные в объекты, которые хранятся в Active Directory.
  • Компьютеры Windows 2000, использующие один сетевой протокол (обычно IP). Любые два компьютера в пределах сайта, использующие один сетевой протокол, имеют непосредственную связь друг с другом. Такие средства подключения обеспечивают быструю и эффективную связь;
  • наборы связанных подсетей, каждой из которых соответствует один IP-адрес подсети.

Когда клиент очереди сообщений подключается к серверу очереди сообщений, он направляет запрос заранее заданному серверу в том же сайте, если он доступен.

Дополнительные сведения о факторах, определяющих структуру сайтов в сети, см. в разделе Роль сайтов.

Примечания

  • В контексте очереди сообщений более не предусмотрено специальное определение сайта, подобное имевшемуся в MSMQ 1.0. При обновлении MSMQ 1.0 каждый сайт MSMQ 1.0 отображается на сайт Windows 2000, a каждая инородная подключенная сеть – на инородный сайт. Если вы производите обновление с MSMQ 1.0, то список изменений можно найти в разделе Обновление очереди сообщений: обзор.

Дополнительные сведения о маршрутных ссылках см. в разделе Межсайтовая маршрутизация.

Режим рабочей группы

Службу очереди сообщений можно запустить в среде, не являющейся частью домена, например, в рабочей группе, или на компьютере, с которого запрещено отправлять в Active Directory запросы относительно объектов очереди сообщений. Если очередь сообщений работает на компьютере, входящем в рабочую группу, этот компьютер может позже присоединиться к домену Windows 2000. И наоборот, компьютер, использующий очередь сообщений и входящий в домен, может присоединиться к рабочей группе. Этот же компьютер позже может опять присоединиться к тому же домену.

При использовании очереди сообщений в режиме рабочей группы действуют следующие ограничения.

  • Сообщения, отправляемые такими компьютерами, не могут передаваться через серверы входящей маршрутизации, серверы исходящей маршрутизации и шлюзы сайтов. Необходимо иметь прямое подключение к конечному компьютеру.
  • Отсутствует доступ к Active Directory. Пользователь может создавать частные очереди и управлять ими, но только на локальном компьютере, а также просматривать свойства очередей на другом компьютере (но не создавать и не изменять их) с помощью оснастки «Управление компьютером» (дополнительные сведения об управлении очередями на удаленных компьютерах см. в разделе Управление очередями и сообщениями на других компьютерах). Просмотр и управление общими очередями, а также доступ к любым другим сведениям Active Directory невозможны. Впрочем, при наличии прямого подключения разрешается отправлять сообщения в частные очереди и получать их оттуда.
  • Внутренние сертификаты нельзя использовать для отправки проверенных сообщений. Вместо них следует использовать внешние сертификаты. Дополнительные сведения о сертификатах пользователей содержатся в разделе Сертификаты пользователей.
  • Сообщения нельзя шифровать. Дополнительные сведения о шифровании см. в разделе Шифрование в очереди сообщений.
  • Зависимые клиенты не поддерживаются. Дополнительные сведения об ограничениях на развертывание зависимых клиентов см. в разделе Планирование зависимых клиентов.
  • Сообщения нельзя отправлять в инородные очереди и приложения-подключатели.

Автономный режим

Службу очереди сообщений можно запустить на компьютере, который входит в домен и имеет доступ к Active Directory, но временно не может поддерживать связь с контроллером домена. Это случается, когда компьютер сам отключен от сети или все контроллеры домена в его сайте отключены от сети. Похожая ситуация возникает при попытке доступа к удаленному компьютеру (например, для просмотра файлов), который в данный момент времени не имеет возможности запрашивать проверку подлинности на контроллере домена. Во всех этих случаях в реестре сохраняется конфигурация компьютера как члена домена, и как только контроллер домена станет доступен, домен возобновит работу в обычном режиме.

В автономном режиме сообщения можно отправлять непосредственно, используя прямые имена форматов. Если используются другие форматы имен, сообщения хранятся на локальном компьютере и отправляются, как только контроллер домена становится доступен. Дополнительные сведения о различных типах имен форматов см. в разделе Имена форматов.

Поддержка различных платформ и связь с инородными компьютерами

Клиенты очереди сообщений могут общаться с инородными компьютерами при помощи приложения-подключателя. Инородные компьютеры — это компьютеры, которые работают под управлением операционных систем, не поддерживающих очередь сообщений или использующих иные системы обмена сообщениями. Приложения-подключатели работают на серверах очереди сообщений и позволяют инородным компьютерам взаимодействовать с клиентами очереди сообщений. Сервер очереди сообщений, на котором работает приложение-подключатель, обычно содержит две дополнительные очереди, называемые очередями подключателя: одна из них предназначена для транзактных сообщений, а другая — для нетранзактных (определение транзактных сообщений см. в разделе Обмен транзактными сообщениями). Когда клиент очереди сообщений отправляет сообщение инородному компьютеру, это сообщение сначала пересылается в очередь подключателя на сервере очереди сообщений, а затем передается на инородный компьютер.

Примером приложений-подключателей являются Microsoft MSMQ-MQSeries Bridge для взаимодействия с компьютерными платформами, работающими с IBM MQSeries, и Message Queuing Connector (MQC) для связи с компьютерами других платформ, на которых работает очередь сообщений.

Компонент Microsoft MSMQ-MQSeries Bridge расширяет функции очереди сообщений для обеспечения полной транзакционной совместимости с платформами IBM MQSeries версий 2 и 5. В настоящее время Microsoft MSMQ-MQSeries Bridge поставляется как часть сервера Microsoft Host Integration Server 2000. Дополнительные сведения о Microsoft Host Integration Server 2000 см. на веб-узле Microsoft Host Integration Server (http://www.Microsoft.com/hiserver/).

Приложение Message Queuing Connector (MQC) позволяет расширить возможности очереди сообщений, обеспечивая взаимодействие с другими операционными системами, включая UNIX, AS/400, Tandem, Digital VMS, CICS/MVS и Unisys ClearPath HMP. MQC входит в установочные комплекты серверов семейства Windows 2000. Но чтобы отправить сообщение на инородный компьютер, работающий не под ОС Windows, необходимо сначала приобрести и установить на этом компьютере дополнительное клиентское программное обеспечение Level 8 Systems и тем самым обеспечить комплексное решение. Дополнительные сведения о продуктах Level 8 Systems можно получить в компании Level 8 Systems или на веб-узле Level 8 Systems (http://www.level8.com/index.cfm?handle=gmq).

Эта продукты также можно использовать друг с другом в разных сочетаниях для установки подключений в масштабах предприятия. Например, можно обмениваться сообщениями между очередью сообщений на компьютере UNIX и IBM MQSeries на компьютере AS/4000.

Дополнительные сведения об использовании систем передачи сообщений с участием инородных компьютеров см. в разделе Настройка инородных сайтов и инородных компьютеров.


Компьютеры очереди сообщений

Компьютеры очереди сообщений, объединенные в сеть, могут выполнять различные функции, в зависимости от того, какие программные компоненты на них установлены. В этом разделе рассматриваются компоненты программного обеспечения очереди сообщений в контексте типов компьютеров очереди сообщений, создаваемых в результате установки компонентов. Дополнительные сведения о всех компонентах очереди сообщений и их установке см. в разделе Установка очереди сообщений: обзор.

Серверы очереди сообщений

Серверы очереди сообщений образуют основную магистраль передачи данных в сети компьютеров очереди сообщений. На всех серверах очереди сообщений по умолчанию запущена служба очереди сообщений, размещены основные очереди и осуществляются отправка и прием сообщений с последующим их локальным хранением.

Сведения о планировании развертывания серверов очереди сообщений в сети содержатся в разделе Выбор оборудования для сервера очереди сообщений.

Серверы очереди сообщений могут также обеспечивать доступ к службе каталогов для клиентов версий Windows, предшествовавших Windows XP, и функции маршрутизации. Эти дополнительные услуги обсуждаются в двух следующих разделах.

Доступ к каталогу

Серверы очереди сообщений, устанавливаемые на контроллерах доменов Windows 2000, по умолчанию предоставляют клиентам версий более ранних, чем Windows XP, возможность просмотра и изменения данных, содержащихся в каталоге Active Directory. Клиенты Windows XP могут обращаться к Active Directory напрямую, без посредничества сервера очереди сообщений.

Общие сведения о контроллерах доменов Windows 2000 см. в разделе «Контроллеры доменов» справки Windows 2000 Server.

Службы маршрутизации

Серверы очереди сообщений со службами маршрутизации выполняют маршрутизацию сообщений и временное хранение пересылаемых сообщений. Такие серверы могут выполнять маршрутизацию сообщений внутри сайта или между различными сайтами, если между клиентскими компьютерами нет прямой связи. Серверы очереди сообщений, выполняющие функции маршрутизации сообщений в пределах одного сайта, называются серверами входящей маршрутизации (InRS) или серверами исходящей маршрутизации (OutRS). Связь между сайтами определяется с помощью маршрутной ссылки. Трафик сообщений, передаваемых между двумя сайтами, связанными маршрутной ссылкой, можно направить через некоторый сервер; такой сервер называется шлюзом сайта. Шлюз сайта может принадлежать обоим сайтам, соединенным маршрутной ссылкой, или одному из них. На маршрутной ссылке можно установить любое число шлюзов сайтов, в том числе ни одного.

Хотя внутри сайта между клиентами, использующими один сетевой протокол, предполагается наличие прямой связи, использование серверов входящей и исходящей маршрутизации для маршрутизации сообщений внутри сайта может снизить потребности в ресурсах пропускной способности данной сети. Клиенты можно настроить на использование серверов входящей и исходящей маршрутизации при необходимости. В этом случае все сообщения, отправляемые или получаемые клиентом, передаются через такой сервер очереди сообщений. Термин «клиент» здесь означает любой компьютер очереди сообщений, который сам не может выполнять маршрутизацию сообщений, например, независимый клиент или сервер очереди сообщений с отключенной маршрутизацией. Данная возможность недоступна для зависимых клиентов. Зависимым клиентам для отправки и получения сообщений от их имени требуется поддерживающий сервер. Именно этот поддерживающий сервер с отключенной маршрутизацией, а не его зависимые клиенты, должен настраиваться на использование серверов входящей и исходящей маршрутизации.

Если для маршрутизации сообщений между сайтами используются шлюзы сайтов, то межсайтовую маршрутизацию могут выполнять только эти специально назначенные серверы очереди сообщений.

Компьютеры очереди сообщений в составе кластеров

Служба очереди сообщений, а также триггеры очереди сообщений могут быть установлены в кластерах. Кластер — это группа компьютеров, называемых узлами, которые выполняют те или иные функции, работая совместно как единое целое. Во всех кластерах обеспечивается балансировка нагрузки, повышенные показатели доступности и возможности масштабирования, однако следует отличать кластеры, создаваемые службой кластеров — они называются кластерами серверов и предлагают дополнительную возможность поддержки отказоустойчивости в виде функции переключения узлов при сбое, — от кластеров, создаваемых службой балансировки нагрузки сети (NLB), известных как кластеры NLB и не поддерживающих переключение при сбое.

Кластеры NLB и очередь сообщений

Второй тип кластера, в котором можно установить службу очереди сообщений, — это кластер службы балансировки нагрузки (NLB). Кластеры NLB распределяют клиентские подключения по нескольким серверам, что обеспечивает масштабируемость и высокие показатели доступности для клиентов, запрашивающих доступ к службам и приложениям, однако эти кластеры не поддерживают функцию переключения при сбое. В наиболее типичном варианте реализации служба NLB распределяет входящий трафик TCP/IP между несколькими серверами информационных служб Интернета (IIS), составляющими веб-ферму. NLB может объединить в один кластер балансировки нагрузки до 32 серверов, работающих под управлением Windows 2000 Advanced Server или Windows 2000 Datacenter Server. В кластер можно добавлять новые серверы, не прерывая его работу.

Основу NLB образует драйвер WLBS, который загружается на каждый сервер (узел) кластера. Этот драйвер содержит алгоритм статистического сопоставления, совместно используемый узлами кластера для того, чтобы определить, кто из них должен обрабатывать очередной входящий запрос.

Если в кластере этого типа какой-либо узел даст сбой или будет отключен, NLB автоматически изменит конфигурацию кластера так, чтобы последующие клиентские запросы направлялись в другие узлы кластера, остающиеся работоспособными. Все клиентские подключения, которые были открыты в момент сбоя или отключения узла, закрываются. При повторной попытке подключения клиент попадает на другой работающий узел. Время бездействия клиентских подключений не превышает 10 секунд.

NLB позволяет адресовать все компьютеры кластера с помощью одного набора IP-адресов кластера; при этом их старые индивидуальные IP-адреса также сохраняются. В результате клиентские запросы на основании виртуальных IP-адресов прозрачным образом распределяются по узлам кластера. Чтобы любой запрос мог быть обработан любым узлом, на каждом из них необходимо запустить IIS 5.0 или иную службу TCP/IP, причем все узлы должны обслуживать одно и то же содержимое. Обновленные страницы можно копировать на локальные диски узлов; кроме того, для обновления можно использовать коммерческие программы репликации файлов. NLB позволяет задать обработку всех подключений, инициируемых с одного клиентского IP-адреса, на определенном сервере (разумеется, кроме тех случаев, когда на сервере возникает сбой). Кроме того, можно направлять на один сервер все запросы, поступающие с адресов некоторого диапазона класса C.

При создании веб-фермы с помощью NLB каждый сервер постоянно поддерживает связь с остальными серверами. Они обмениваются статистическими данными о производительности и сообща несут ответственность за обработку входящих запросов. Каждый входящий запрос виден всем серверам фермы, и NLB с помощью специального алгоритма выбирает тот из них, который должен будет обрабатывать запрос.

Когда сообщения, используя транспорт HTTP, направляются в очередь по «виртуальному» URL-адресу, устанавливается сеанс TCP с одним из узлов кластера. Сообщения можно отправлять только в пункты назначения, заданные прямыми именами форматов. В случае срочных и восстанавливаемых сообщений от получателя не требуется поддерживать какое-либо определенное внутреннее состояние; очередь сообщений не гарантирует однократную доставку сообщения через веб-ферму, хотя для этого предпринимается все возможное, с привлечением механизма удаления случайных дубликатов.

Если сеанс между клиентом и узлом прерывается и в следующем сеансе клиент переключается на другой узел, сообщения, доставка которых не была подтверждена, заново отправляются клиентом и принимаются новым узлом; так могут образовываться дубликаты.

В узлах кластера NLB можно развертывать приложения очереди сообщений, которые будут получать и обрабатывать сообщения, отправляемые в кластер.

Аналогичные веб-фермы можно также реализовать на базе механизма циклического распределения адресов DNS, средства Cisco LocalDirector или службы преобразования сетевых адресов (NAT).

Циклическое распределение адресов DNS

Сервер Microsoft DNS поддерживает так называемую процедуру циклического распределения — стандартное средство балансировки нагрузки на базе сеансов, которое рассредоточивает клиентов, подключающихся к некоторому узлу Интернета, по серверам, обслуживающим этот узел. Циклическое распределение описано в спецификации RFC 1794. При использовании этого процесса одному логическому имени DNS (например, www.Microsoft.com) сопоставляется несколько IP-адресов. Когда поступает запрос на разрешение этого имени DNS, сервер DNS возвращает один из адресов из списка. При ответе на следующие запросы, касающиеся того же имени DNS, сервер DNS проходит список по кругу и в итоге распределяет пользователей по нескольким имеющимся серверам. Таким образом, разные пользователи, запрашивающие одно и то же имя DNS, получают различные IP-адреса, что обеспечивает равномерность нагрузки.

Данный алгоритм позволяет равномерно распределять поступающие запросы по имеющимся IP-адресам, но он не обеспечивает полную балансировку нагрузки, поскольку не является интерактивным. Дело в том, что сервер DNS не отслеживает нагрузку на каждом IP-адресе и не проверяет, работает ли в данный момент тот или иной сервер. Тем не менее циклическое распределение может послужить отправной точкой при построении более сложного решения или недорогой альтернативой для небольшой группы серверов. При использовании этого метода необходимо вести постоянный мониторинг серверов, чтобы в случае сбоя на каком-либо компьютере быстро исключить его из списка.

LocalDirector

LocalDirector — это разработанное компанией Cisco Systems аппаратное решение со встроенной операционной системой, которая поддерживает равномерное распределение входящих запросов HTTP. LocalDirector прослушивает сеть в ожидании входящих запросов на доступ по определенному виртуальному IP-адресу и может перенаправлять их в набор серверов IIS. Каждому физическому серверу в составе веб-фермы назначается уникальный IP-адрес. Однако, в отличие от ранее рассмотренных методов балансировки нагрузки, здесь IP-адреса физических серверов скрыты от пользователей. Процедура балансировки нагрузки выполняется всякий раз, когда поступает запрос по данному виртуальному IP-адресу. Такой метод называется балансировкой нагрузки на базе запросов.

В функциональном отношении NLB и LocalDirector имеют множество различий, однако результаты их работы одинаковы. Пользователь делает запрос по виртуальному IP-адресу, и это запрос передается на один из нескольких серверов веб-фермы. И NLB, и LocalDirector обеспечивают эффективную балансировку нагрузки на базе запросов, которая обладает многими преимуществами по сравнению с алгоритмами, основанными на сеансах. Балансировка нагрузки на базе запросов обеспечивает более детализированную обработку, поскольку соответствующая процедура выполняется гораздо чаще. Это приводит к более равномерному распределению запросов по серверам.

Балансировка нагрузки на базе запросов также гарантирует более высокие уровни отказоустойчивости. При использовании NLB или LocalDirector для отключения сервера достаточно выдать одну команду. Это позволяет проводить работы по техническому обслуживанию или обновлению любого сервера веб-фермы, не прерывая ход службы. Оба решения также позволяют выявлять сбои на серверах и принимать необходимые меры к тому, чтобы по недоступному IP-адресу запросы больше не направлялись.

Преобразование сетевых адресов

NAT (Network Address Translation — преобразование сетевых адресов) — это протокол, который позволяет из сети с частными адресами производить доступ к содержимому Интернета, используя процесс преобразования IP-адресов. NAT можно использовать для настройки небольшой сети на доступ в Интернет по одному общему подключению.

Независимые клиенты

На независимых клиентах по умолчанию запущена служба очереди сообщений, размещены основные очереди и осуществляются отправка и прием сообщений, причем эти клиенты по умолчанию могут работать и при отключении от сети. Для отправки и получения сообщений независимые клиенты не требуют синхронного доступа к серверу очереди сообщений. Основным различием между независимыми клиентами и серверами очереди сообщений является то, что независимые клиенты не обладают доступом к Active Directory и возможностью маршрутизации сообщений, которую поддерживают серверы очереди сообщений с включенной маршрутизацией.

Независимый клиент и сервер очереди сообщений, не поддерживающий маршрутизацию, обладают почти одинаковыми функциональными возможностями. Единственное различие между ними состоит в том, что независимые клиенты могут работать под управлением Windows XP Professional, а серверы очереди сообщений — только на платформах семейства Windows 2000 Server. В данном разделе независимый клиент и сервер очереди сообщений без включенной маршрутизации (если он установлен не на контроллере домена) будут считаться функционально эквивалентными.

Если независимый клиент (или эквивалентный ему сервер очереди сообщений) отключен от сети, он может продолжать генерировать сообщения, адресованные другим компьютерам. Независимый клиент хранит эти сообщения локально и автоматически отправляет их, как только сетевое подключение восстанавливается.

Мобильные клиенты

Мобильные независимые клиенты, например, устанавливаемые на переносных компьютерах, могут отправлять и получать сообщения во время перемещения. Когда независимый клиент подключается к новому сайту Windows 2000, он автоматически находит контроллеры своего нового домена и опрашивает службу каталогов с целью определить новый сайт, в котором он теперь располагается. После того, как новый сайт установлен, все сообщения, которые были посланы клиенту в период, когда он был отключен от сети, автоматически пересылаются из предыдущего сайта в новый.

Компьютер Message Queuing 3.0, принадлежащий сети предприятия Windows NT 4.0 и имеющий возможность подключаться к серверам контроллеров MSMQ 1.0, не в состоянии автоматически обнаруживать свой новый сайт. В этом случае пользователь может задать имя нового сайта до отключения компьютера от сети или после повторного подключения. Выбрав новый сайт, компьютер может подключиться к ближайшему серверу контроллера, благодаря чему доступ к базе данных MQIS заметно оптимизируется. Если задать новый сайт до отключения, сообщения, направляемые на компьютер в то время, когда он отключен, пересылаются непосредственно в новый сайт, пока компьютер еще находится в пути.

Как уже отмечалось, клиенты могут быть настроены на использование серверов очереди сообщений для внутрисайтовой маршрутизации (они называются серверами входящей и исходящей маршрутизации). Когда такой клиент перемещается в другой сайт, его серверы входящей и исходящей маршрутизации уже не будут использоваться в новом сайте для маршрутизации сообщений. Когда независимый клиент возвращается в исходный сайт, эти серверы очереди сообщений снова начинают использоваться для маршрутизации сообщений.

Если независимый клиент очереди сообщений работает в среде домена смешанного режима, в котором он должен поддерживать связь с сервером контроллера MSMQ 1.0, работающим под управлением Windows NT, то действует следующее правило: когда независимый клиент перемещается в другой сайт, он может автоматически определить, в каком сайте находится. Вновь подключившись к сети, клиент отправляет широковещательное сообщение и собирает все ответы на него. Если клиенту ответит какой-либо сервер очереди сообщений (отличный от того, который был закреплен за ним в старом сайте) и если этот новый сервер имеет связь с сервером исходного сайта, клиент подключается к новому сайту и начинает работать в нем. Если один из ответивших серверов является назначенным этому клиенту сервером в его исходном сайте, независимый клиент не будет подключаться к новому сайту.

Клиенты Windows CE

Существует специальная версия независимого клиента, предназначенная для карманных компьютеров, работающих под управлением системы Windows CE 3.0 и последующих версий. В силу особых требований к вычислительным ресурсам и отсутствия поддержки RPC, в отношении независимого клиента версии Windows CE действуют следующие ограничения.

  • Отсутствует поддержка Active Directory. Независимые клиенты Windows CE не могут опрашивать серверы очереди сообщений, работающие на контроллерах доменов Windows 2000.
  • Ограничена поддержка маршрутизации сообщений.
  • Ограничена поддержка общих очередей.
  • Отсутствуют проверка подлинности и шифрование сообщений. Все сообщения, отправляемые или получаемые другими компьютерами очереди сообщений, передаются как неформатированный текст.
  • Не поддерживается извлечение сообщений в удаленном режиме. Сообщения, хранящиеся на другом компьютере очереди сообщений, нельзя извлечь с компьютера независимого клиента Windows CE.
  • Нет поддержки транзакций с передачей нескольких сообщений.
  • Нет поддержки различных платформ. Не поддерживаются отправка и прием сообщений компьютерами, на которых работают другие системы обмена сообщениями.

Зависимые клиенты

Зависимые клиенты для выполнения любых функций обмена сообщениями должны обращаться в режиме синхронного доступа на специальный сервер очереди сообщений, называемый поддерживающим сервером. Им может быть любой сервер очереди сообщений, работающий в режиме домена и обладающий по крайней мере функциональными возможностями независимого клиента, желательно в локальном сайте, но можно и в соседнем. Поддерживающий сервер зависимого клиента выполняет от его имени все функции передачи сообщений, такие как размещение очередей, хранение сообщений, отправка и прием сообщений. Если поддерживающий сервер перейдет в автономное состояние, зависимый клиент не сможет отправлять и получать сообщения.

Новые возможности очереди сообщений Windows XP, такие как транспорт HTTP, триггеры очереди сообщений и рассылка сообщений нескольким получателям, недоступны зависимым клиентам. В частности, для них не поддерживаются списки рассылки и многоэлементные имена формата.

Зависимые клиенты не будут поддерживаться в последующих версиях очереди сообщений.

Из-за этих и других ограничений рекомендуется по возможности использовать в своей организации независимые клиенты вместо зависимых. Дополнительные сведения содержатся в разделе Планирование зависимых клиентов.

Поставщик транспорта MSMQ RPC

В предыдущих версиях службы очереди сообщений для Windows NT 4.0 и Windows 2000 поддерживался поставщик транспорта MSMQ RPC (remote procedure call — удаленный вызов процедур). В Windows XP он больше не поддерживается.

Приложение-подключатель MSMQ Exchange

В предыдущих версиях службы очереди сообщений для Windows NT 4.0 и Windows 2000 поддерживался подключатель MSMQ Exchange. В Windows XP он больше не поддерживается.


Типы очередей

Очереди, в контексте очереди сообщений, представляют собой временные хранилища для сообщений различных типов. В следующих разделах описываются различные типы очередей сообщений и их назначение. Дополнительные сведения об именах форматов, используемых для этих типов очередей, см. в разделе Имена очередей.

Общие очереди

В среде домена общие очереди представляют собой очереди, публикуемые в службе Active Directory и затем реплицируемые по всему лесу Windows 2000. Следует заметить, что реплицируются только свойства этих очередей, но не сами очереди и не их содержимое. Доступ к данным об общих очередях возможен с любого компьютера леса, при условии, что у пользователя имеются надлежащие разрешения на доступ к соответствующим объектам очередей. Вообще говоря, любой пользователь леса, имеющий доступ к Active Directory и обладающий разрешением уровня «Отправка» для данной общей очереди, может отправлять в нее сообщения.

В среде рабочей группы общие очереди недоступны.

Частные очереди

Частные очереди представляют собой очереди, не публикуемые в Active Directory и отображаемые только на содержащем их локальном компьютере. Частные очереди доступны только приложениям очереди сообщений, которым известен полный путь или имя формата очереди сообщений. Внутренние частные очереди не отображаются в папке «Частные очереди»; любые сведения об этих очередях и их содержимое можно получить только программным способом.

Журналы

Процесс сохранения копий сообщений называется ведением журнала. Эти копии, называемые сообщениями журнала, хранятся в очередях особого типа — журналах. Это может быть журнал компьютера, если речь идет о ведении журнала источников, или журналы очередей, связанные с ведением журналов назначений.

Ведение журнала источников

Ведение журнала источников — это процесс сохранения копий исходящих нетранзактных сообщений на исходном компьютере. Настройка этого процесса производится для каждого сообщения в отдельности; возможность ведения журнала источников устанавливается в приложении очереди сообщений программным способом. По умолчанию ведение журнала источников отключено.

Если ведение журнала источников включено для нетранзактного сообщения, копия исходящего сообщения помещается в единственный журнал исходного компьютера, показанный в виде очереди Сообщения журнала в папке «Системные очереди» в оснастках «Управление компьютером» и «Active Directory – пользователи и компьютеры». Это происходит, когда сообщение поступает на компьютер, содержащий очередь назначения, или на сервер маршрутизации очереди сообщений, который находится на один прыжок ближе к конечному компьютеру. Сервер очереди сообщений, выполняющий маршрутизацию сообщений для клиентов, не сохраняет копии этих сообщений в своем журнале компьютера.

Исходящие сообщения, отправляемые зависимыми клиентами, помещаются в журнал компьютера на поддерживающем сервере очереди сообщений.

Ведение журнала назначений

Ведение журнала назначений — это процесс сохранения копий входящих сообщений на компьютере, содержащем соответствующую очередь назначения. Этот процесс настраивается для каждой очереди в отдельности. Если ведение журнала назначений включено, то копия каждого сообщения, попадающего в конкретную очередь, будет передаваться в соответствующий журнал очереди, когда сообщение будет получено (удалено приложением очереди сообщений).

Однако нельзя гарантировать, что все входящие сообщения после получения будут помещаться в журнал очереди. Например, если превышена квота журнала очереди (предельный размер области хранения), то после успешного извлечения (удаления) лишних сообщений из соответствующей очереди их копии не останутся в журнале очереди и будут навсегда утеряны.

Журнал очереди создается автоматически для каждой очереди. Он показан в виде списка Сообщения журнала под соответствующей очередью в оснастках «Управление компьютером» и «Active Directory – пользователи и компьютеры». По умолчанию ведение журнала назначений отключено. О том, как включить ведение журнала назначений, см. в разделе Включение и отключение ведения журнала назначений.

Очереди недоставленных сообщений

Нетранзактные сообщения, которые не удалось доставить или у которых истек срок действия, хранятся в нетранзактных очередях недоставленных сообщений. Транзактные сообщения, которые не удалось доставить или у которых истек срок действия, хранятся в транзактных очередях недоставленных сообщений. Такие сообщения содержатся в соответствующих очередях на том компьютере, на котором истек срок их действия (или на которых их не удалось доставить или переслать). Это может быть исходный компьютер, конечный компьютер или промежуточный сервер очереди сообщений.

На каждом сервере очереди сообщений и у каждого независимого клиента имеется одна нетранзактная очередь недоставленных сообщений и одна транзактная очередь недоставленных сообщений. Эти очереди создаются автоматически и отображаются в папке «Системные очереди» соответствующего компьютера в оснастках MMC.

Сообщения считаются недоставленными в следующих случаях.

  • Конечная очередь неизвестна отправителю.
  • Достигнуто максимально допустимое для сообщения число прыжков.
  • Достигнут предельный размер области хранения, или квота.
  • Нетранзактное сообщение отправлено в очередь транзактных сообщений, или наоборот.
  • Транзакция отправки или приема не выполнена (для транзактных сообщений). Впрочем, если не выполнена транзакция приема, эти сообщения не помещаются в транзактную очередь недоставленных сообщений.

Срок действия сообщений считается истекшим в следующих случаях.

  • Истекло время жизни сообщения в сети, или срок поступления в очередь (TTRQ). (Оно может быть задано программным способом в приложении очереди сообщений.)
  • Истек срок приема сообщения (TTBR). (Он всегда задается программным способом в приложении очереди сообщений.)

Если приложение-отправитель не может отправлять сообщения в некоторую очередь из-за отсутствия необходимых прав доступа, эти сообщения не сохраняются в очередях недоставленных сообщений. Однако при соответствующей настройке исходных сообщений в таких случаях могут генерироваться отрицательные подтверждающие сообщения.

Сообщения, содержащиеся в нетранзактной и транзактной очередях недоставленных сообщений, всегда записываются на диск и потому могут быть восстановлены.

Дополнительные сведения о транзактных сообщениях см. в разделе Обмен транзактными сообщениями.

Очереди администрирования

В очередях администрирования хранятся подтверждающие сообщения; эти очереди задаются приложением-отправителем программным способом в исходных сообщениях. В качестве очереди администрирования может быть задана любая доступная нетранзактная очередь. Можно указать несколько очередей администрирования, используя списки рассылки, многоэлементные имена формата и адреса многоадресной IP-рассылки.

Очереди администрирования не содержат административных сообщений — они хранятся во внутренних частных очередях.

Дополнительные сведения о подтверждающих сообщениях см. в разделе Типы сообщений.

Очередь ответов

Очереди ответов содержат ответные сообщения, которые приложение-получатель возвращает в приложение-отправитель. Очереди ответов задаются программным способом в приложении-отправителе при отправке сообщения. В качестве очереди ответов может быть задана любая доступная очередь.

Если требуется одновременно использовать очередь ответов и очередь администрирования, их функции могут быть совмещены в одной очереди. Однако, поскольку все очереди администрирования должны быть нетранзактными, эта комбинированная очередь сможет принимать только нетранзактные сообщения.

Ответные сообщения следует отличать от административных ответных сообщений, которые хранятся во внутренней частной очереди.

Очереди отчетов

Очереди отчетов содержат сообщения-отчеты, в которых указывается маршрут некоторого сообщения на пути к месту назначения на удаленном компьютере, или маршрут тестового сообщения на пути к тестовой очереди на удаленном компьютере. На каждом компьютере может быть только одна очередь отчетов. Сообщения-отчеты направляются в очередь отчетов только в том случае, если слежение за маршрутами сообщений включено на главном компьютере и установлен флаг слежения за маршрутами сообщений.

Внутренние частные очереди

Служба очереди сообщений может использовать до семи дополнительных внутренних частных очередей, которые играют роль промежуточных очередей для временного хранения сообщений на их пути к очереди назначения. Эти очереди, будучи частными, не публикуются в Active Directory. Кроме того, они не включаются в состав папки «Частные очереди» в оснастках MMC, и любые сведения об этих очередях и их содержимом можно получить только программным способом. Внутренние частные очереди нельзя удалять.

В следующей таблице перечислены стандартные внутренние частные очереди и указывается, как они используются.

Внутренняя частная очередь | Назначение
admin_queue$ | Хранение административных сообщений.
msmqadminresp | Хранение административных ответных сообщений (кроме сообщений MQPing).
mqis_queue$ | Хранение возвращенных сообщений MQPing и ответов на запросы записи, сделанные службой репликации очереди сообщений или службой каталогов очереди сообщений на компьютерах, не оснащенных службой репликации и работающих в среде смешанного режима.
msmqtriggersnotifications | Хранение сообщений, которые оповещают службу триггеров (mqtgsvc.exe) о создании или изменении триггеров или правил программой mqtrig.dll. Сообщения, хранящиеся в этой очереди, после обработки удаляются.
notify_queue$ | Хранение сообщений-уведомлений. В этих сообщениях перечислены изменения свойств компьютера и очередей, включая создание и удаление очередей.
nt5pec_mqis_queue$ | Хранение ответов на запросы записи, сделанные службой каталогов очереди сообщений на компьютерах, использующих службу репликации очереди сообщений, таких как бывший основной контроллер предприятия (PEC), в среде смешанного режима.
order_queue$ | Отслеживание транзактных сообщений, которые требуется доставлять в определенном порядке.

Исходящие очереди

Исходящие очереди — это локальные внутренние очереди, которые используются для хранения сообщений, отправленных в удаленные очереди. Сообщения могут храниться в исходящих очередях в автономном состоянии, а после восстановления подключения направляться в очереди назначения на удаленные компьютеры Исходящие очереди показаны в папке «Исходящие очереди». Они генерируются автоматически и не могут быть созданы или удалены вручную.

Очереди подключателей

Очереди подключателей принимают сообщения, отправляемые на инородные компьютеры. Такие очереди располагаются на серверах очереди сообщений, на которых запущено приложение-подключатель, позволяющее инородным компьютерам общаться с другими компьютерами очереди сообщений в сети. На таких серверах обычно имеется две очереди подключателя: одна используется для транзактных сообщений, а другая — для нетранзактных. Когда клиент очереди сообщений отправляет сообщение на инородный компьютер, оно сначала попадает в очередь подключателя. Затем приложение-подключатель извлекает его, преобразует и направляет на инородный компьютер.

Очереди подключателей создаются неявным образом. Они не публикуются в Active Directory и являются прозрачными для приложений очереди сообщений, отправляющих сообщения в инородную очередь. С точки зрения приложения отправка сообщения в инородную очередь идентична отправке сообщения в собственную очередь сообщений. Инородная очередь является частью инородной системы передачи сообщений, но доступна в среде службы очереди сообщений.

Дополнительные сведения о взаимодействии с инородными компьютерами см. в разделе Поддержка различных платформ и связь с инородными компьютерами.


Имена очереди

В следующем разделе описаны различные способы определения очередей очереди сообщений. Очереди задаются с помощью путей и имен формата. Более подробные сведения о типах рассматриваемых очередей содержатся в разделе Тип очереди.

Пути

Путь очереди содержит имя компьютера, на котором расположена очередь, и ее имя, разделенные косой чертой в форме Имя_компьютера\Имя_очереди, или .\Имя_очереди для общей очереди, расположенной на локальном компьютере. Именам частных очередей предшествует строка private$, отделенная косой чертой. Таким образом, путь частной очереди имеет следующую форму: Имя_компьютера\private$\Имя_очереди или .\private$\Имя_очереди для частной очереди, расположенной на локальном компьютере.

Имена формата

Имена формата используются преимущественно приложениями очереди сообщений для программного выполнения задач. Тем не менее, он также используется в некоторых задачах администрирования, например, при создании многоэлементного имени формата, поэтому для успешной работы администраторам следует иметь представление об имени формата. В следующих разделах описывается большинство типов имен формата, используемых в очереди сообщений.

Прямое имя формата

Прямое имя формата используется для ссылок на общие или частные очереди без доступа к службе каталогов. Очередь сообщений может использовать сведения, предоставляемые прямым именем формата, для отправки сообщений непосредственно до места назначения. Таким образом, прямое имя формата может использоваться для отправки и получения сообщений в режиме рабочей группы и для отправки сообщений на компьютеры в Интернете, а также для отправки сообщений непосредственно на компьютер.

Прямое имя формата содержит строку DIRECT=, которая следует после указания расположения очереди и ее названия. Ниже представлен общий формат прямого имени формата для общих, частных и системных очередей, а также очередей с именами URL.

DIRECT=Адрес_компьютера\Имя_общей_очереди
DIRECT=Адрес_компьютера\PRIVATE$\Имя_очереди
DIRECT=Адрес_компьютера\SYSTEM$;Имя_системной_очереди
DIRECT=HTTP://Адрес_URL\msmq\Имя_общей_очереди
DIRECT=HTTPS://Адрес_URL\msmq\Имя_общей_очереди
DIRECT=HTTPS://Адрес_URL\msmq\private$\Имя_частной_очереди

Адрес компьютера может быть задан в двух формах: как сетевой адрес конечного компьютера (включая сетевой протокол TCP) или как любое имя конечного компьютера, изначально поддерживаемого основной операционной системой (ОС используется для указания собственного протокола компьютера, который нужно использовать). Ниже приведены примеры двух этих форм.

DIRECT=TCP:157.18.3.1\Общая_очередь
DIRECT=OS:elvisp.ms.com\Общая_очередь

В очереди с именем URL перед именем очереди находится строка msmq, отделенная косой чертой. Имя формата HTTP может использовать косую черту и обратную косую черту для разделения компонентов (другие имена формата используют только обратную косую черту). Например, следующие два имени формата могут использоваться для ссылки «Общая_очередь».

DIRECT=HTTP://Адрес_URL/msmq/Общая_очередь
DIRECT=HTTP://Адрес_URL\msmq\Общая_очередь

Общее имя формата

Общее имя формата используется для ссылки на общие очереди. Для ссылок на общие очереди также может использоваться прямое имя формата. При использовании общего имени формата, очередь сообщений использует свой внутренний алгоритм маршрутизации для определения маршрута к конечной очереди. При использовании прямого имени формата сообщение отправляется непосредственно в конечную очередь.

Когда очередь сообщений обнаруживает общее имя формата, она запрашивает у службы каталога информацию, необходимую для определения компьютера, на котором в данный момент находится очередь, используемого этим компьютером протокола а также любые другие сведения, требующиеся для доставки сообщения в очередь.

Общее имя формата содержит строку PUBLIC=, которая следует после идентификатора, назначенного очереди при ее создании. Этот идентификатор представляет собой код GUID, указанный для объекта очереди в Active Directory. Ниже представлен общий формат, используемый для ссылки на общую очередь и связанный журнал очереди.

PUBLIC=Код_GUID_очереди
PUBLIC=Код_GUID_очереди;JOURNAL

Общее имя формата строго эквивалентно идентификатору очереди за исключением того, что общее имя формата отформатировано как строка, а не как двоичные данные. Ниже приведен пример строки общего имени формата (следует иметь в виду, что строка имени формата является строкой в кодировке Юникод с нулем на конце).

PUBLIC=308FB580-1EB2-11CA-923B-08002B1075A7

Имейте в виду, что расположение общей очереди (определенный компьютер на котором находится очередь) не является частью общего имени формата. За счет этого становится возможным успешное выполнение операций с сообщениями при использовании общего имени формата независимо от расположения очереди; общая очередь может быть перемещена на другой компьютер, при этом имя формата остается в силе. Имена, связанные с определенным расположением, не являются именами прямого формата.

Частное имя формата

Частное имя формата используется для ссылки на частные очереди. Для ссылок на частные очереди также может использоваться прямое имя формата. При использовании частного имени формата, очередь сообщений использует свой внутренний алгоритм маршрутизации для определения маршрута к конечной очереди. При использовании прямого имени формата сообщение отправляется непосредственно в конечную очередь.

Когда очередь сообщений обнаруживает частное имя формата, она не обращается к службе каталогов за сведениями об очереди. Тем не менее, она использует службу каталогов для поиска на компьютере сведений, требующихся для задач маршрутизации.

Частное имя формата содержит строку PRIVATE= которая следует после идентификатора компьютера, на котром зарегистрирована очередь, и шестнадцатеричное число, идентифицирующее очередь. Ниже представлен общий формат, используемый для ссылки на частную очередь и связанный журнал.

PRIVATE=Код_GUID_компьютера\Номер_очереди
PRIVATE=Код_GUID_компьютера\Номер_очереди;JOURNAL

Ниже приведен пример строки частного имени формата (следует иметь в виду, что строка имени формата является строкой в кодировке Юникод с нулем на конце).

PRIVATE=ae0c5671-f190-12ce-ae10-00dd0114290f\0000000d

Имя формата списка рассылки

Имена формата списка рассылки используются для ссылок на списки рассылки, хранящиеся в Active Directory. Идентификатором списка рассылки является код GUID, указанный для объекта списка (группы) рассылки в Active Directory.

Имя формата списка рассылки содержит строку DL=, которая следует после идентификатора списка рассылки. Этот идентификатор представляет собой код GUID, указанный для объекта группы списка рассылки в Active Directory. Ниже представлен общий формат, используемый для ссылки на список рассылки с дополнительным включением имени домена.

DL=Код_GUID_списка рассылки[@Имя_домена]

Ниже приведен пример строки имени формата списка рассылки (следует иметь в виду, что строка имени формата является строкой в кодировке Юникод с нулем на конце).

DL=ae0c5671-f190-12ce-ae10-00dd0114290f

Имя формата списка рассылки может являться элементом многоэлементного имени формата. В этом отношении сохранена аналогия с именем формата очереди.

Дополнительные сведения о списках рассылки содержатся в разделе Списки рассылки.

Многоэлементные имена формата

Многоэлементное имя формата формируется как конкатенация одного или нескольких общих или частных имен форматов, прямого имени формата или имени формата списка рассылки, разделенного запятыми. Таким образом, различные типы имен форматов, используемых в очереди сообщений, могут использоваться вместе как элементы многоэлементного имени формата. Следующий пример демонстрирует многоэлементное имя формата, содержащее имя прямого формата, общее имя формата и имя формата списка рассылки.

DIRECT=Адрес_компьютера\Имя_очереди,PUBLIC=Идентификатор_очереди,DL=Идентификатор_DL

Следует иметь в виду, что многоэлементное имя формата, содержащее элемент, указывающий на общую очередь или список рассылки, не может использоваться при отсутствии доступа к Active Directory.

Многоэлементные имена формата не могут содержать имена формата очередей, предназначенных только для чтения, таких как очереди журналов, журналы компьютера или очереди недоставленных сообщений. Если имя формата очереди, предназначенной только для чтения, включено в многоэлементное имя формата, будет возвращена ошибка.

Дополнительные сведения о многоэлементных именах формата содержатся в разделе Многоэлементные имена формата.

Дополнительные сведения об этих и других именах формата, таких как имена формата компьютера и подключателя, содержатся в пакете «Message Queuing Software Development Kit (SDK)». Сведения о пакете «Message Queuing SDK» содержатся в документации Microsoft Platform Software Development Kit.


Типы сообщений и их доставка

В контексте очереди сообщений предполагается, что сообщение состоит из тела и набора свойств. Тело сообщения может содержать текст или двоичные данные в любой форме; оно может быть зашифровано. Большинство свойств сообщения задаются программно приложением очереди сообщений. Некоторые свойства, такие как код безопасности (SID) отправителя, задаются очередью сообщений. Свойства сообщения не могут быть зашифрованы. Размер сообщения, включая его тело и свойства, не должен превышать 4 мегабайта.

Кроме шифрования сообщений, можно организовать проверку их подлинности. Дополнительные сведения о проверке подлинности сообщений содержатся в разделе Проверка подлинности сообщений. Сведения о шифровании сообщений содержатся в разделе Шифрование в очереди сообщений.

Сообщения различаются по типу, приоритету и способу доставки. Общее представление об этом дается в следующих разделах.

Тип сообщения

Тип сообщения, также называемый классом сообщения, указывает назначение или местоположение сообщения. Поддерживаются следующие типы сообщений.

  • Обычные сообщения. Все сообщения, создаваемые приложениями очереди сообщений, принадлежат категории обычных. Обычные сообщения можно направлять в общие, частные и недоставленные очереди, как транзактные, так и нетранзактные, а копии обычных сообщений, сами являющиеся также обычными сообщениями, можно помещать в журналы, когда включено ведение журналов источников или назначений. Обычные сообщения не содержат данных о состоянии; такие данные включаются в подтверждения, ответы и отчеты.
  • Подтверждающие сообщения. Подтверждающие сообщения информируют о состоянии обычных сообщений. Они представляют собой нетранзактные сообщения, которые направляются в очереди администрирования, задаваемые в исходных сообщениях приложением-отправителем. Подтверждения могут быть положительными или отрицательными. Положительное подтверждающее сообщение означает, что исходное сообщение прибыло в очередь назначения и/или было получено (удалено принимающим приложением). Отрицательное подтверждающее сообщение означает, что исходное сообщение не достигло очереди назначения до истечения срока поступления в очередь (TTRQ) либо не попало в очередь назначения по какой-то другой, указанной в подтверждении причине, или же сообщение не было получено до истечения срока приема (TTBR) либо не получено по указанной причине.
  • Сообщения-отчеты. Сообщения-отчеты информируют о маршруте, которым прошло сообщение с исходного компьютера, где была включена функция слежения, до места назначения на удаленном компьютере. Сообщения-отчеты направляются в очередь отчетов на исходный компьютер; они могут генерироваться для всех сообщений, отправленных с этого компьютера при установленном флаге отслеживания маршрутов сообщений, или только для тестовых сообщений этого компьютера.
  • Ответные сообщения. Ответные сообщения представляют собой сообщения, отправляемые приложением-получателем в очереди ответов, заданные приложением-отправителем.

Дополнительные сведения о различных типах очередей, в которые могут направляться эти сообщения, см. в разделе Типы очередей.

Дополнительные сведения о причинах, препятствующих доставке сообщений в очередь назначения или их получению, которые могут быть заданы в классе сообщения, см. в пакете разработчика Message Queuing Software Development Kit (SDK). Дополнительные сведения о доступе к пакету «Message Queuing SDK» содержатся в разделе Microsoft Platform Software Development Kit.

Приоритет сообщения

Порядок отправки сообщений в очередь на конечном компьютере определяется в первую очередь приоритетом очереди (или базовым приоритетом), а затем — приоритетом сообщения. Приоритет общей очереди, включенной в Active Directory, можно установить в диапазоне от -32768 до 32767. По умолчанию он равен 0. Приложения очереди сообщений устанавливают приоритет нетранзактного сообщения в диапазоне от 0 до 7 (7 — наивысший приоритет). У всех транзактных сообщений приоритет равен значению, принимаемому по умолчанию (0).

Сообщения отправляются в общие очереди в порядке, определяемом суммой приоритетов конечной очереди и данного сообщения. Сообщения с самыми высокими суммарными значениями приоритета отправляются первыми.

В частных очередях приоритет очереди не используется. При отправке в частную очередь учитывается только приоритет сообщений.

Доставка сообщений

Поддерживаются два основных метода доставки сообщений: срочная доставка и с возможностью восстановления. Выбор способа доставки в сущности означает выбор между высокой производительностью с минимальным использованием ресурсов (срочная доставка) и надежностью (доставка с возможностью восстановления). Способ доставки сообщения задается программно в приложении-отправителе. Восстанавливаемые сообщения делятся на транзактные и нетранзактные.

Срочная доставка сообщений

Срочная доставка сообщений означает, что в ходе маршрутизации и доставки сообщения хранятся в оперативной памяти, что дает очень высокую производительность, но не обеспечивает возможности восстановления, если на каком-либо компьютере, через который передается сообщение, произойдет сбой. Имейте в виду, что если служба очереди сообщений останавливается, срочные сообщения теряются.

Если в оперативной памяти скопится слишком много срочных сообщений, они могут быть вытеснены на диск, что приведет к снижению быстродействия. Поэтому не рекомендуется сохранять больше срочных сообщений, чем позволяет объем оперативной памяти.

Тем не менее срочные сообщения могут преодолевать сбои в сети. Например, если приложение очереди сообщений отправляет срочные сообщения через сервер очереди сообщений и сетевое соединение между этим сервером и конечным компьютером дает сбой, сообщения будут по-прежнему храниться в памяти сервера очереди сообщений. Однако если сбой произойдет и на сервере очереди сообщений, прежде чем удастся восстановить сетевое соединение, срочные сообщения будут утеряны.

Внимание!

  • Если служба очереди сообщений работает в кластере серверов, срочные сообщения будут теряться во время переключения на другой узел при сбое.

Доставка сообщений с возможностью восстановления

Доставка сообщения с возможностью восстановления означает, что сообщения во время маршрутизации и доставки записываются на диск, что несколько замедляет процедуру по сравнению со срочной доставкой, однако полностью себя окупает при возникновении неустранимых сбоев или выключении компьютеров, когда в очередях остаются сообщения (это особенно актуально для мобильных клиентов на портативных компьютерах). Если при отправке сообщения на компьютере произойдет сбой или завершение работы, сообщение будет сохранено на диске. После перезагрузки компьютера и перезапуска службы очереди сообщений процесс отправки будет возобновлен.

Все восстанавливаемые сообщения сохраняются на дисках в файлах, отображаемых в памяти. Наиболее ощутимый выигрыш в производительности достигается при использовании нескольких физических дисков для хранения восстанавливаемых сообщений. Дополнительные сведения содержатся в разделе Использование дисков.

Обмен транзактными сообщениями

Транзактные сообщения — это сообщения, отправляемые или получаемые в составе транзакций. Транзакция — это действие или последовательность действий, в результате которых система преобразуется из одного согласованного состояния в другое. Транзакции характеризуются рядом свойств, которые обозначаются аббревиатурой ACID (atomicity, consistency, isolation, durability — целостность, согласованность, изолированность, живучесть).

  • Целостность. Транзакция выполняется по принципу «все или ничего». Если транзакция состоит из нескольких действий, все они рассматриваются вместе как единая операция, которая либо завершается успешно, либо не выполняется вообще.
  • Согласованность. Транзакция преобразует систему из одного допустимого состояния в другое.
  • Изолированность. Если одновременно выполняются несколько транзакций, они никак не влияют друг на друга. С точки зрения любой транзакции, остальные транзакции выполняются либо до нее, либо после.
  • Живучесть. Возможные отказы в системе или сети никак не отражаются на результатах выполненной транзакции.

В службе очереди сообщений транзакция может включать в себя только одну единицу работы, например, отправку сообщений или прием сообщений. Это значит, что одно и то же сообщение нельзя отправить и получить в рамках одной транзакции.

Все транзакции очереди сообщений должны выполняться по протоколу двухэтапного завершения. Рассмотрим, например, простую транзакцию обмена сообщениями, в которую входят все действия, выполняемые обычным приложением при отправке одного сообщения в очередь назначения. На первом этапе очередь сообщений проверяет, все ли эти действия можно выполнить. Если все действия выполнимы, очередь сообщений завершает транзакцию и направляет сообщение в очередь. В противном случае, если какие-либо действия не могут быть выполнены, очередь сообщений прерывает транзакцию и отменяет все произведенные ею изменения. Когда транзакция завершена, сообщение ставится в очередь на доставку. В конечном итоге оно доставляется в очередь назначения ровно один раз.

Транзакция может также выполнять отправку нескольких сообщений. В этом случае либо все сообщения передаются в том порядке, в котором они были отправлены (если транзакция завершается), либо ни одно из них не передается (если транзакция прерывается). Если несколько сообщений отправляются в одну и ту же очередь, служба очереди сообщений гарантирует, что они будут доставлены в очередь только один раз и в том порядке, в котором они отправлялись в рамках транзакции.

Сообщения, которые должны быть доставлены в порядке их отправки, принадлежат одному потоку сообщений. Вместе с каждым сообщением потока передается его порядковый номер, обозначающий место сообщения в потоке, а также номер предыдущего сообщения этого потока. С первым сообщением потока всегда передается предыдущий номер, равный нулю.

Точно так же транзакция может состоять из операций удаления нескольких сообщений из очереди. Сообщения удаляются из очереди только в том случае, если транзакция завершается; в противном случае они возвращаются в очередь и могут быть впоследствии считаны в ходе другой транзакции.

Очередь сообщений гарантирует, что сообщения, отправленные в ходе нескольких последовательных транзакций с одного и того компьютера в одну и ту же очередь назначения, поступят в нее согласно порядку завершения транзакций. Кроме того, как и в остальных вариантах отправки транзактных сообщений, каждое сообщение, если оно достигает очереди назначения, доставляется ровно один раз.

Транзактные сообщения передаются медленнее, чем нетранзактные, поскольку сообщения приходится несколько раз записывать на диск, и для их обработки требуется больше ресурсов компьютера. Транзактные сообщения можно отправлять только в транзактные очереди на локальном или удаленном компьютере (нетранзактные сообщения нельзя отправлять в транзактные очереди). Когда сообщения принимаются в рамках транзакции, их можно извлекать только из локальной транзактной очереди. В ходе же нетранзактных операций сообщения можно извлекать из локальных и удаленных транзактных очередей.

В общем случае обмен транзактными сообщениями можно реализовать двумя способами.

  • С помощью внешних (двухэтапных) транзакций под управлением координатора распределенных транзакций (Microsoft DTC), который теперь входит в состав служб компонентов (бывший сервер транзакций). DTC автоматически устанавливается на каждом компьютере во время установки очереди сообщений.
  • Внутренние (одноэтапные) транзакции, координируемые очередью сообщений.

Внешние транзакции используются в случае, когда частью транзакции должны стать ресурсы, отличные от тех, которые может предложить очередь сообщений. При этом очередь сообщений играет роль диспетчера ресурсов, действующего под управлением DTC. Используя DTC в качестве диспетчера транзакций очереди сообщений, можно реализовать приложения, основанные на механизме транзакций, в которых будут выполняться либо все действия, либо ни одного. Например, в пределах одной транзакции приложение очереди сообщений может отправить сообщение и обновить базу данных. DTC гарантирует, что либо оба действия будут успешными (транзакция завершена), либо оба отменены (транзакция прервана).

Внешние транзакции можно использовать для отправки или получения сообщений, входящих в состав любой операции применительно к COM-совместимому ресурсу, а также для отправки или получения нескольких сообщений, входящих в одну транзакцию.

Поскольку внутренние транзакции меньше загружают систему, они выполняются гораздо быстрее, чем внешние транзакции, координируемые DTC. Внутренние транзакции следует использовать в случае, когда нет необходимости координировать операции очереди сообщений с операциями, привлекающими внешние ресурсы, которые требовали бы участия DTC. Очередь сообщений выполняет функции координатора транзакций, который обслуживает как диспетчер ресурсов только самого себя.

Внутренние транзакции можно использовать в следующих целях.

  • Обеспечение доставки каждого сообщения только в одном экземпляре (гарантированная однократная доставка).
  • Обеспечение доставки всех сообщений в порядке их отправки с одного компьютера на другой (упорядоченная доставка).
  • Проверка успешного выполнения транзакции (получения сообщений) с помощью подтверждающих сообщений. Кроме того, с помощью подтверждений можно удостоверять поступление сообщения в очередь назначения (или его извлечение из очереди).

Дополнительные сведения о Microsoft DTC см. в разделе Использование служб компонентов.

Когда транзактные сообщения передаются по транспорту HTTP из внутренней сети организации в Интернет, имя локальной очереди упорядочения отправителя должно быть отображено во внешнее имя, чтобы сообщения подтверждения порядка направлялись от получателей в нужное место назначения.


Отправка сообщений нескольким получателям

Модель обмена сообщениям «один ко многим» позволяет клиентам отправлять одно сообщение нескольким получателям. Очередь сообщений позволяет реализовать эту модель несколькими способами. Во-первых, объект группы рассылки Active Directory, изолирующий набор конечных очередей, может выступать в качестве списка рассылки в очереди сообщений. Во-вторых, сообщение может быть отправлено программно нескольким получателям, определенным в форме имени формата, которая называется многоэлементным именем формата и содержит список разделенных запятыми мест назначения. (Хотя многоэлементные имена формата являются типом списка рассылки, в контексте очереди сообщений термин список рассылки всегда является ссылкой на группу рассылки, опубликованную в Active Directory.) В-третьих, сообщения могут быть отправлены на IP-адрес одного получателя, а затем получены и обработаны несколькими IP-узлами, наблюдающими за определенным IP-адресом многоадресной рассылки, и получающими все отправленные ему пакеты.

Списки рассылки и многоэлементные имена форматов также могут использоваться для выполнения следующих задач.

  • Отправка транзактных и нетранзактных сообщений нескольким получателям.
  • Указание нескольких очередей администрирования для отправки сообщений подтверждений.
  • Указание нескольких очередей ответов для отправки сообщений ответов.

Списки рассылки

Списки рассылки являются общими списками, публикуемыми как объекты групп рассылки в Active Directory. Явные участники списков рассылки являются местами назначения, опубликованными в Active Directory, псевдонимами очередей и другими списками рассылки, но не частными очередями или очередями с именами URL.

Тем не менее, частные очереди и очереди с именами URL могут косвенно ссылаться на список рассылки через псевдонимы очереди. Псевдонимы очереди обладают дополнительными преимуществами при использовании в списках рассылки. При удалении объекта псевдонима очереди псевдоним автоматически удаляется из списков рассылки, на которые он ссылается. Для изменения очереди, ссылка на которую имеется в псевдониме очереди, не требуется изменять список рассылки, который ссылается на нее.

Списки рассылки могут иметь локальную в домене или глобальную область действия. Списки рассылки с локальной в домене областью действия могут иметь в качестве членов только очереди и другие списки рассылки из локального домена, и не могут быть перемещены в другой домен. Списки рассылки с глобальной областью действия дополнительно могут иметь очереди и другие глобальные списки рассылки из других доменов в лесе, кроме того, их можно переместить в другой домен.

И наоборот, поскольку списки рассылки являются объектами в Active Directory, они не могут использоваться в режиме рабочей группы или автономном режиме, когда отсутствует доступ к Active Directory. В этих режимах сообщения могут быть отправлены нескольким получателям с помощью многоэлементных имен форматов, описанных в следующем разделе, если они не содержат элементы, указывающие на общую очередь или список рассылки.

Оснастку «Active Directory - пользователи и компьютеры» можно использовать для создания и удаления списков рассылки как объектов групп рассылки, для добавления и удаления членов и для просмотра их свойств. Дополнительные сведения о выполнении этих задач содержатся в разделах Создание списков рассылки, Удаление списков рассылки и Просмотр, добавление и удаление элементов списка рассылки.

На списки рассылки можно ссылаться программно через имена формата списка рассылки. Дополнительных сведения об использовании имен формата списков рассылки и их синтаксисе содержатся в пакете «Message Queuing Software Development Kit (SDK)» Сведения о пакете «Message Queuing SDK» содержатся в разделе Microsoft Platform Software Development Kit.

При отправке сообщения в список рассылки происходит опрос Active Directory с целью определения его членов и для перевода всех псевдонимов очереди в очереди. Таким образом, список рассылки расширяется до списка целевых очередей. Членов списка рассылки можно динамически добавлять или удалять на протяжении процесса расширения. После этого копия сообщения с идентичным кодом сообщения отправляется каждой из этих очередей. Если список рассылки содержит несколько ссылок на одно место назначения, дублированные ссылки при открытии места назначения для отправки сообщений игнорируются. Например, если среди членов списка рассылки D1 имеется очередь Q1 и другой список рассылки D2, список D2 также может содержать очередь Q1 или список D1. В таком случае вторая ссылка на очередь Q1 или список D1 игнорируется. Таким образом прерываются рекурсивные циклы, возникающие в списке рассылке, содержащим другие списки рассылки.

Списки рассылки и многоэлементные имена формата, описание которых содержится в следующем основном разделе, также могут использоваться для задания нескольких административных очередей при запросе сообщений подтверждений, а также для задания нескольких очередей ответов при запросе сообщений ответов.

Списки рассылки и многоэлементные имена формата могут ссылаться на транзактные и нетранзактные целевые очереди. При отправке нетранзактного сообщения нескольким таким целям, это сообщение также можно отправить всем транзактным и нетранзактным целевым очередям на локальном или удаленном компьютере. Тем не менее, когда сообщение достигает транзактную очередь, оно отклоняется и преобразуется в очередь неотправленных нетранзактных сообщений на компьютере, хранящем транзактную очередь, а сообщение неподтверждения указывает что нетранзактное сообщение, которое было отправлено в транзактную очередь, отправлено в административную очередь, заданную в исходном сообщении.

При запросе подтверждающих сообщений отправителю следует ожидать по крайней мере n подтверждающих сообщений для сообщения, отправленного в список рассылки или многоэлементное имя формата с n окончательными получателями. Следует ожидать более n подтверждающих сообщений, если одно сообщение создает подтверждающие сообщения по прибытии их к месту назначения, а также подтверждающее или опровергающее сообщение о прочтении подтверждающего сообщения. Следует иметь в виду, что все списки рассылки и встроенные списки рассылки расширяются, а продублированные получатели устраняются перед отправкой любого сообщения.

Параметры безопасности для списков рассылки

Поскольку списки рассылки являются объектами в Active Directory, атрибуты безопасности могут использоваться для управления доступом к ним, а их параметры можно запросить в Active Directory. Кроме того, они, как и очереди сообщений, поддерживают шифрование. Каждая копия сообщения может быть зашифрована с помощью открытого ключа конечного компьютера этой копии.

Дескриптор безопасности назначается каждой очереди и списку рассылки. Дескриптор безопасности содержит список пользователей и групп, которым разрешен или запрещен доступ к очереди или списку рассылки, и определенные разрешения, назначенные этим пользователям и группам. Следующие разрешения связаны со списками рассылки.

  • Разрешение «Отправить» позволяет группе или пользователю отправлять сообщения соответствующему списку рассылки. По умолчанию этим разрешением обладает каждый пользователь.
  • Разрешение «Добавить или удалить самого себя как члена» для общей очереди или псевдонима очереди позволяет группе или пользователю добавлять или удалять соответствующую общую очередь или очередь как члена в списке рассылки. По умолчанию этим разрешением обладает каждый пользователь.
  • Разрешение «Добавить или удалить самого себя как члена» для списка рассылки позволяет группе или пользователю добавлять или удалять соответствующий список рассылки как члена в другом списке рассылки. Только владелец списка рассылки обладает для него разрешением «Добавить или удалить самого себя как члена».

При добавлении в список рассылки члена (очереди или списка рассылки), группа пользователей, обладающих разрешением «Отправка» для списка рассылки, содержащего нового члена, остается неизменной. Таким образом, при добавлении списка рассылки c большими ограничениями доступа к списку рассылки с меньшими ограничениями доступа, клиенты расширенного списка рассылки могут получить доступ к новому списку рассылки с большими ограничениями доступа. Безопасность при этом не ставится под угрозу, поскольку каждый список рассылки по-прежнему может контролировать группу пользователей, имеющих разрешение на добавление к нему членов.

Многоэлементные имена формата

Функциональные отличия списков рассылки и многоэлементных имен формата основаны на том, что списки рассылки являются общими списками, публикуемыми в Active Directory, в то время как многоэлементные имена формата являются частными списками, не хранящимися в Active Directory. Кроме того, они создаются и управляются на уровне приложений.

Многоэлементное имя формата формируется как конкатенация одного или нескольких общих или частных имен форматов, прямого имени формата или имени формата списка рассылки, разделенного запятыми (дополнительные сведения об именах формата содержатся в разделе Имена формата). Таким образом, различные типы имен формата, используемых в очереди сообщений, могут использоваться вместе как элементы многоэлементного имени формата. Следующий пример демонстрирует многоэлементное имя формата, содержащее прямое имя формата, общее имя формата и имя формата списка рассылки.

ПРЯМОЙ=Адрес_компьютера\Имя_очереди,ОБЩИЙ=Идентификатор_очереди,DL=Идентификатор_DL

Многоэлементные имена формата могут использоваться для отправки сообщений нескольким получателям даже в режиме рабочей группы или автономном режиме, если они не содержат элемент, указывающий на общую очередь или список рассылки. Например, если многоэлементное имя формата ссылается на частную очередь и список рассылки, сообщение не будет отправлено, если нет доступа к Active Directory.

Многоэлементные имена формата могут использоваться для ссылки на несколько административных очередей и очередей ответов. Тем не менее, они не могут содержать имена формата очередей, предназначенных только для чтения, таких как очереди журналов, журналы компьютера или очереди недоставленных сообщений. Если имя формата очереди, предназначенной только для чтения, включено в многоэлементное имя формата, будет возвращена ошибка.

Для включения совместимости с компьютерами, работающими под управлением более ранних чем Windows XP версий Windows, список явных мест назначения доставляется из каждого списка рассылки или многоэлементного имени формата, используемых для отправки сообщения на исходный компьютер, и эти сведения вместе со списком рассылки или многоэлементным именем формата помещаются в каждый отправляемый пакет сообщений. Например, при отправке сообщения в список рассылки D1, который ссылается на три очереди (Q1, Q2 и Q3), пакет сообщений отправляется на три компютера, содержащих явные места назначения Q1, Q2 и Q3, а также исходный список рассылки D1. Если на каком-либо из конечных компьютеров запущена очередь сообщений версии 2.0 или более ранней, будут использоваться явные места назначения Q1, Q2 или Q3. Любой компьютер, на котором запущена очередь сообщений версии 3.0, будет использовать D1 и игнорировать повторяющиеся места назначения.

Надежная многоадресная рассылка IP

Очередь сообщений содержит механизм, позволяющий отправлять и получать трафик многоадресной рассылки IP с помощью драйвера Pragmatic General Multicast (PGM), устанавливаемого и настраиваемого как часть подкомпонента Ядро во время каждой установки очереди сообщений. Сообщения могут быть отправлены на IP-адрес одного получателя, а затем получены и обработаны несколькими IP узлами. Узел наблюдает за определенным IP-адресом многоадресной рассылки и получает все отправленные ему пакеты. Совокупность узлов, наблюдающих за определенным IP-адресом многоадресной рассылки, называется группой узлов.

Служба очереди сообщений на определенном узле осуществляет наблюдение за всеми адресами многоадресной рассылки, с которыми связаны ее локальные очереди, направляет входящие сообщения в соответствующие очереди, дублирует сообщения, отправленные в несколько очередей и динамически начинает и прекращает наблюдение за адресами многоадресной рассылки по мере того как локальные очереди становятся связанными или несвязанными.

Ниже приведены некоторые возможности многоадресной рассылки сообщений IP.

  • Отправляется только копия сообщения, после чего ее получают и обрабатывают компьютеры или узлы, наоблюдающие за ней.
  • Узлы могут динамически присоединяться к группе узлов и отключаться от нее в любое время.
  • Не существует ограничений по размеру группы узлов.
  • Узел может отпралять сообщения на IP-адрес многоадресной рассылки даже если он не принадлежит соответствующей группе узлов.

Адрес многоадресной рассылки и номер порта в синтаксисе IP_адрес:Номер_порта могут быть связаны с любой частной или общей очередью. Эти сведения для общих очередей хранятся в Active Directory. Эти сведения для частной очереди хранятся на компьютере, содержащем сообщения, отправленные в очередь. Таким образом, в режиме рабочей группы адреса многоадресной рассылки могут быть связаны только с частными очредями, а в режиме домена для связывания адресов многоадресной рассылки с общими очередями должен быть доступен контроллер домена, поддерживающий адреса многоадресной рассылки в Active Directory.

IP-адреса многоадресной рассылки должны находиться в диапазоне класса «D» со значениями от 224.0.0.0 до 239.255.255.255, соответствующими настройкам первых четырех старших битов, равных 1110. Тем не менее, только определенные диапазоны адресов в этом диапазоне досупны для отправки многоадресных сообщений. Для получения последнего списка зарезервированных адресов многоадресной рассылки перейдите по ссылке на страницу Internet Assigned Number Authority (IANA) в Windows 2000 Resource Kits - Web Resources (http://www.Microsoft.com/Windows 2000/library/resources/reskit/WebResources/default.asp).

Cведения по указанию или просмотру адреса многоадресной рассылки и номера порта для определенной очереди содержатся в разделе Указание или просмотр адресов многоадресной рассылки очереди и портов.

Для многоадресной рассылки сообщений не предусмотрено никаких дополнительных механизмов безопасности. Безопасность достигается за счет авторизации и проверки подлинности, основанных на механизмах модели обмена сообщениям «один-к-одному». Каждая целевая очередь защищается проверкой подлинности, основанной на отправителе и доступом, основанном на отправителе/получателе. Шифрование и расшифровка не поддерживаются.

Отправка транзактных сообщений нескольким получателям

Как списки рассылки, так и многоэлементные имена формата поддерживают обмен транзактными сообщениями. При отправке транзактного сообщения по списку рассылки или многоэлементному имени формата копия сообщения отправляется каждой соответствующей исходящей очереди. Неудача при отправке сообщения в любую из исходящих очередей приведет к прерыванию целой транзакции.

Для подтверждения однократной доставки сообщений в порядке их отправки, отправитель вкладывает в каждое сообщение сведения, позволяющие получателю устранять дублированные и поврежденные сообщения. Все сообщения, имеющие между собой отношения порядка, сообщают что должны находиться в одном потоке сообщений. Каждое сообщение в потоке содержит порядковый номер, по которому оно идентифицируется в потоке, и предыдущий номер, по которому идентифицируется предыдущее сообщение в том же потоке сообщений. Первое сообщение в потоке всегда содержит предыдущий номер, равный нулю.

Каждый получатель отфильтровывает прибывающие сообщения и принимает только прибывшие в определенном порядке и недублированные сообщения. Для этого получатель использует порядковые и предыдущие номера, вложенные в сообщения. Получателю необходимо отслеживать порядковый номер последнего сообщения, принятого в каждом потоке сообщений. При этом не требуется создавать журнал сообщений или большую базу данных. Получатель подтверждает получение, отправляя порядковый номер последнего принятого сообщения обратно отправителю. Таким образом отправитель узнает что получатель принял все сообщения вплоть до сообщения подтверждения.

Списки рассылки или многоэлементные имена формата могут ссылаться на транзактные и нетранзактные целевые очереди. При отправке транзактного сообщения нескольким таким целям, это сообщение также можно отправить всем транзактным и нетранзактным целевым очередям на локальном или удаленном компьютере. Тем не менее, когда сообщение достигает нетранзактную очередь, оно отклоняется и преобразуется в очередь неотправленных транзактных сообщений на компьютере, хранящем нетранзактную очередь, а сообщение неподтверждения указывает что транзактное сообщение, которое было отправлено в нетранзактную очередь, отправлено в административную очередь, заданную в исходном сообщении.

В следующих параграфах описываются возможности отправки транзактных сообщений в списки рассылки и многоэлементные имена формата.

Дополнительные сведения об отправке транзактных сообщений содержатся в разделе Обмен транзактными сообщениями.

Отправка транзактных сообщений по спискам рассылки

Очередь сообщений гарантирует однократное прибытие всех транзактных сообщений в порядке их отправки. Очередь сообщений также гарантирует однократное прибытие всех сообщений, отправленных в последовательных транзакциях с компьютера в одну конечную очередь, в порядке их отправки. Это означает что сообщения, отправленные в первой транзакции, будут доставлены раньше чем сообщения, отправленные в последующей транзакции.

Семантика транзакций также поддерживается для списков рассылки. Транзактные сообщения, отправленные спискам рассылки, будут доставлены только один раз в порядке их отправки. Кроме того, сообщения, отправленные в нескольких транзакциях с одного компьютера по одному списку рассылки, будут доставлены только один раз в порядке их отправки. Таким образом, доставка транзактных сообщений в списки рассылки и очереди идентична.

Тем не менее, данное положение не распространяется на очереди, ссылки на которые имеются в списках рассылки. Не гарантируется доставка в определенном порядке в очередь транзактных сообщений, отправленных в различные списки рассылки, даже если они содержат одинаковые элементы (очереди). Рассмотрим случай с двумя списками рассылки D1 и D2, каждый из которых содержит очередь Q1 в качестве члена. Если сообщение M1 отправлено в список D1, а сообщение M2 отправлено в список D2 в пределах одной транзакции, сообщения могут прибыть в очередь Q1 не в порядке их отправки. Тем не менее, сообщения будут доставлены только один раз.

В случае сбоя доставки, очередь сообщений помещает исходное сообщение с указанием первого сбоя доставки в очередь неотправленных транзактных сообщений исходного компьютера.

Поскольку списки рассылки явялются динамическими, получатели могут быть добавлены во время пересылки транзактных сообщений. Такие новые получатели начнут получать транзактные сообщения со следующей подходящей границы транзакции. Новый член будет получать только сообщения, отправленные после соединения новой очереди с группой распространения.

Отправка транзактных сообщений многоэлементым именам формата

При отправке транзактного сообщения многоэлементному имени формата соответствующие сообщения об успехе или неудаче могут быть возвращены отправляющему приложению. Кроме того, очередь сообщений гарантирует однократное прибытие всех сообщений, отправленных в последовательных транзакциях, инициированных с одного компьютера в одну конечную очередь, в порядке выполнения транзакций независимо от способа адресации целевой очереди: либо в качестве элемента многоэлементного имени формата, либо в качестве отдельной очереди.

При отправке транзактного сообщения многоэлементному имени формата очередь сообщений логически создает отдельную транзакцию, состоящую из серий дискретных операций для отправки сообщений в каждую целевую очередь, содержащуюся в многоэлементном имени формата, а затем выполняет или прерывает целую транзакцию. Это означает, что отправка сообщения многоэлементному имени формата в транзакции семантически эквивалентна отправке серий сообщений в отдельные очереди в отдельной транзакции.

Рассмотрим, например, многоэлементное имя формата N1, содержащее две очереди Q1 и Q2, и второе многоэлементное имя формата N2, содержащее очереди Q2 и Q3. Теперь рассмотрим транзакцию, состоящую из трех следующих действий. 1) отправка сообщения M1 имени формата N1, 2) отправка сообщения M2 в имени формата N2 и 3) отправка сообщения M3 в очередь Q2. Сообщения M1, M2 и M3 будут доставлены в очередь Q2 только один раз в порядке их отправки.

Тем не менее, гарантированная единовременная доставка сообщений в порядке их отправки применима только к идентичным элементам верхнего уровня многоэлементных имен формата и не распространяется на очереди, являющиеся членами различных списков рассылки, ссылки на которые имеются в многоэлементном имени формата. Рассмотрим случай с двумя списками рассылки D1 и D2, каждый из которых содержит очередь Q1 в качестве члена, многоэлементное имя формата N1, содержащее список D1 и другую очередь Q2 в качестве элементов, а также другое многоэлементное имя формата N2, содержащее список D2 и очередь Q2 в качестве элементов. Если сообщение M1 отправлено имени формата N1, а сообщение M2 отправлено имени формата N2 в пределах одной транзакции, сообщения прибудут в очередь Q2 в порядке их отправки, однако в очередь Q1 они могут прибыть в ином порядке. Тем не менее, сообщения будут доставлены в обе очереди только один раз.


Маршрутизация сообщений

Клиент очереди сообщений всегда пытается установить прямое подключение к конечному компьютеру, или сеанс, используя базовый сетевой протокол IP. Если прямое подключение установить не удается или это запрещено делать, серверы очереди сообщений, на которых включена маршрутизация (серверы маршрутизации), могут временно хранить сообщения у себя и затем пересылать их на конечный компьютер или на другой сервер маршрутизации. Таким образом они формируют маршрут, по которому сообщения проходят от исходного компьютера к конечному. Итак, маршрутизация сообщений может выполняться при наличии хотя бы одного из следующих условий:

  • не удается установить сеанс связи между исходным и конечным компьютерами (например, когда конечный компьютер отключен от сети);
  • отдельные серверы маршрутизации очереди сообщений специально выделены для хранения и пересылки сообщений от имени исходного или конечного компьютера.

Серверы маршрутизации очереди сообщений поддерживают концентрацию сеансов, что позволяет сократить эксплуатационные расходы. Такие серверы дают возможность обходиться более низкой пропускной способностью внутри сайта и уменьшить число сеансов между разными сайтами. Маршрутизация сообщений внутри сайта считается сравнительно быстрой и экономичной процедурой, а маршрутизация между сайтами — слишком медленной и дорогостоящей.

Кроме того, когда серверы маршрутизации очереди сообщений доступны, независимые клиенты не накапливают сообщения из-за нехватки свободного места, но сообщения могут доставляться на сервер исходящей маршрутизации, где и хранятся до тех пор, пока конечный компьютер не станет доступен в сети.

Серверы маршрутизации очереди сообщений, выполняющие внутрисайтовую маршрутизацию, бывают двух видов — серверы входящей маршрутизации (InRS) и серверы исходящей маршрутизации (OutRS). Серверы маршрутизации очереди сообщений, которые обеспечивают маршрутизацию на маршрутной ссылке, связывающей разные сайты, называются шлюзами сайтов.

Относительная цена использования конкретного маршрута, ведущего к конечному компьютеру, обычно измеряется числом прыжков; под прыжком понимается доставка сообщения с одного компьютера на другой. Если для одного пункта назначения имеется несколько маршрутов, наилучшим среди них будет маршрут с минимальным числом прыжков.

Примечания

  • В среде рабочей группы маршрутизация сообщений не действует. Поэтому серверы входящей и исходящей маршрутизации и шлюзы сайтов использовать нельзя; для доставки сообщения с исходного компьютера по месту назначения требуется прямое подключение.

Внутрисайтовая маршрутизация

Маршрутизация сообщений в пределах сайта называется внутрисайтовой маршрутизацией. В простейшем случае исходный и конечный компьютеры не бывают настроены на использование серверов входящей или исходящей маршрутизации. В такой ситуации очередь сообщений сначала пытается доставить сообщение на конечный компьютер непосредственно (одним прыжком), а в случае неудачи сообщение передается на какой-либо случайно выбранный сервер маршрутизации очереди сообщений, находящийся в том же сайте (два прыжка).

Маршрутизация сообщений внутри сайта

На этой схеме показан один из вариантов маршрутизации сообщения при его передаче с одного компьютера на другой в пределах сайта. Общее число прыжков может варьироваться, однако в данном случае сообщение, посланное с одного компьютера на другой компьютер того же сайта, делает два прыжка: один, чтобы попасть на сервер маршрутизации очереди сообщений, и еще один для перехода на конечный компьютер. Поскольку каждый прыжок выполняется внутри сайта, дополнительная загрузка системы при выполнении каждого прыжка минимальна.

Серверы входящей и исходящей маршрутизации

В контексте внутрисайтовой маршрутизации независимые клиенты и серверы очереди сообщений, на которых не включена маршрутизация, функционально эквивалентны. Эти компьютеры можно настроить на использование серверов входящей маршрутизации (InRS) или серверов исходящей маршрутизации (OutRS), чтобы те сохраняли и пересылали сообщения от их имени. Зависимые клиенты нельзя настроить на использование серверов входящей или исходящей маршрутизации, поскольку все функции обмена сообщениями выполняются поддерживающим сервером. Дополнительные сведения о различных типах компьютеров очереди сообщений см. в разделе Компьютеры очереди сообщений.

Если независимый клиент или сервер очереди сообщений, не выполняющий маршрутизацию, настроен на использование сервера исходящей маршрутизации, каждое исходящее сообщение, отправленное таким компьютером, будет проходить через этот сервер. Аналогичным образом, если такой компьютер настроить на использование сервера входящей маршрутизации, каждое присылаемое ему сообщение будет проходить через сервер. Каждый такой компьютер может использовать один и тот же сервер маршрутизации очереди сообщений и как сервер входящей маршрутизации, и как сервер исходящей маршрутизации.

Серверы входящей и исходящей маршрутизации должны принадлежать тому же сайту, куда первоначально входит обслуживаемый ими компьютер. При перемещении мобильного клиента в другой сайт эти серверы не будут использоваться для маршрутизации сообщений, пока клиент не вернется в исходный сайт.

Пропускная способность сети

Внутрисайтовая маршрутизация позволяет снизить расход ресурсов сетевой полосы пропускания за счет так называемой концентрации сеансов. Например, если в сайте используется звездообразная топология и каждый независимый клиент обычно общается непосредственно со всеми остальными независимыми клиентами, потребление полосы пропускания можно сократить путем концентрации сеансов, настраивая каждый клиент на использование серверов входящей и исходящей маршрутизации.

Концентрация сеансов внутри сайта

На этом рисунке один и тот же сервер маршрутизации очереди сообщений играет роль сервера входящей маршрутизации и сервера исходящей маршрутизации для каждого клиента.

Межсайтовая маршрутизация

Маршрутизация сообщений, передаваемых между различными сайтами, называется межсайтовой маршрутизацией; для нее требуется наличие подключения между сайтами. Такие подключения могут определяться в терминах логических каналов связи, называемых маршрутными ссылками. Если трафик сообщений между двумя конкретными сайтами можно направить через определенный сервер маршрутизации очереди сообщений или через один из нескольких таких серверов, этот сервер называется шлюзом сайта. Маршрутные ссылки могут использовать шлюзы сайтов для маршрутизации сообщений между сайтами.

Каждой маршрутной ссылке назначается относительная цена, которая может отражать скорость соответствующего физического канала связи или стоимость его использования в денежном выражении. Цена по умолчанию равна 1 и может принимать значения в диапазоне от 1 до 999999. Цену маршрутной ссылки можно менять только в случаях, когда поверх существующих маршрутных ссылок прокладываются альтернативные межсайтовые маршруты и возникает необходимость форсировать использование какого-либо маршрута вместо другого, что и позволяет сделать механизм цен.

В среде домена, содержащей более одного сайта Windows 2000, нужно обязательно создавать маршрутные ссылки, чтобы гарантировать передачу сообщений между сайтами. (Если маршрутной ссылки нет, очередь сообщений обычно пытается установить прямое подключение к конечному компьютеру в сайте, с которым отсутствует связь.)

Примечания

  • Шлюз сайта может принадлежать обоим сайтам, соединенным маршрутной ссылкой, или одному из них. Маршрутную ссылку можно настроить так, чтобы она использовала любое число шлюзов сайтов, в том числе ни одного.
  • Не следует путать маршрутные ссылки со связями сайтов. Маршрутные ссылки используются серверами очереди сообщений для маршрутизации сообщений между сайтами. Связи сайтов используются контроллерами доменов для репликации содержимого Active Directory между сайтами.

Когда независимый клиент отправляет сообщение на компьютер в другом сайте, исходный компьютер сначала пытается напрямую подключиться к конечному компьютеру, и только в случае неудачи он доставляет сообщение на сервер маршрутизации в своем сайте, а тот, в свою очередь, пересылает сообщение в шлюз сайта. Этот процесс продолжается до тех пор, пока сообщение не достигнет конечного компьютера.

Рассмотрим, к примеру, маршрутную ссылку, соединяющую сайт А с сайтом Б и содержащую четыре шлюза сайтов (Ш1-Ш4). Если шлюзы Ш1 и Ш2 принадлежат сайту А, шлюз Ш3 принадлежит сайтам А и Б, а Ш4 принадлежит сайту Б, то сообщения могут направляться через один из шлюзов сайта А (Ш1, Ш2 или Ш3), а затем через один из шлюзов сайта Б (Ш3 or Ш4). Однако если сообщения направить через шлюз Ш3, принадлежащий обоим сайтам, то для доставки на конечный компьютер им понадобится на один прыжок меньше. Таким образом, сообщения проходят преимущественно через шлюз Ш3. В общем случае, если маршрутная ссылка связана только с двумя шлюзами сайтов, по одному в каждом сайте, то только эти серверы смогут выполнять маршрутизацию сообщений между данными сайтами на данной маршрутной ссылке.

Для маршрутизации сообщений между сайтами в сети можно использовать несколько маршрутных ссылок — в целях балансировки нагрузки или обеспечения избыточности. В этих случаях, если требуется повысить приоритет одного маршрута относительно другого (например, чтобы задать ссылку, которую следует использовать по умолчанию), можно изменить цены маршрутных ссылок, которые определяют выбираемый маршрут.

Например, если цена маршрутной ссылки А-Б установлена равной 3, а цены трех остальных маршрутных ссылок (Б-В, Б-Г и В-Г) равны 1, сообщения, направляемые из сайта А на сайт В, всегда проходят из А на сайт Б и затем на В. Однако если цена маршрутных ссылок А-Б и Б-В равна 3, а цена маршрутных ссылок В-Г и Б-Г равна 1, сообщения, направляемые из сайта А в сайт В, будут всегда проходить из сайта А в Б, затем в Г и потом в В.

Межсайтовая маршрутизация

Маршрут, выбираемый сообщением для перехода из сайта А в сайт В, зависит от цен маршрутных ссылок:

Маршрутная ссылка | Цена
А-Б | 3
Б-В | 1
Б-Г | 1
В-Г | 1

В этом случае сообщения, отправляемые из сайта А в сайт В, всегда будут пересылаться из сайта А в сайт Б, а затем — в сайт В.

Маршрутная ссылка | Цена
А-Б | 3
Б-В | 3
Б-Г | 1
В-Г | 1

В этом случае сообщения, отправляемые из сайта А в сайт В, всегда будут пересылаться из сайта А в сайт Б, затем в сайт Г, а затем — в сайт В.

Дополнительные сведения о том, как изменить цену имеющейся маршрутной ссылки, см. в разделе Изменение цены маршрутной ссылки.

Дополнительные сведения о создании и настройке маршрутных ссылок см. в разделе Настройка маршрутных ссылок.

Уменьшение числа сеансов

Межсайтовая маршрутизация обычно приводит к сокращению числа сеансов, создаваемых клиентами. На следующем рисунке видно, что маршрутизация вне сайта прозрачна для компьютеров, находящихся внутри сайта, за исключением шлюза сайта. Это упрощает маршрут сообщения и уменьшает число устанавливаемых между сайтами сеансов. Сеанс между различными сайтами может установить только назначенный для этого сервер очереди сообщений.

Концентрация межсайтовых сеансов

Маршрутизация сообщений между сетями

Очередь сообщений можно использовать для отправки сообщений во внешние сети и получения сообщений из этих сетей; это могут быть сети других организаций или другие леса Windows 2000. Компьютеры, работающие с очередью сообщений, могут использовать различные служебные порты для взаимодействия с внешними сетями через настроенные должным образом брандмауэры, позволяющие устанавливать подключения через эти порты. Дополнительные сведения содержатся в разделе Настройка брандмауэра.


Хранилище сообщений

Предельные размеры хранилищ сообщений, или квоты, определяют максимальный совокупный размер всех сообщений, содержащихся в конкретной очереди или на компьютере. Аналогично предельные размеры хранилищ журналов, или квоты, определяют максимальный совокупный размер всех журнальных сообщений, содержащихся в конкретном журнале некоторой очереди или на компьютере.

Поняв, как организовано локальное хранение сообщений, можно определить объем дискового пространства. используемого для хранения сообщений, и проверить свойства локальных очередей.

Общее представление об этом дается в следующих разделах.

Квоты для сообщений

Квоты для сообщений бывают двух типов: квоты компьютеров и квоты очередей. Эти квоты задают общий размер всех сообщений (включая сообщения журналов), содержащихся в конкретной очереди или на компьютере. Квоты очередей и квоты компьютеров могут задаваться независимо. Когда вся квота очереди исчерпана, сообщения больше нельзя будет отправлять в эту очередь до тех пор, пока из нее не будет извлечено (удалено приложением очереди сообщений) одно или несколько сообщений. Квоту очереди можно устанавливать для всех очередей. Квоты компьютеров не распространяются на внутренние частные очереди.

Сначала отслеживается квота компьютера, независимо от совокупного значения квот очередей. Например, если задать квоту в 10 Мбайт для каждой из шести очередей, созданных на компьютере, и квоту компьютера в 50 Мбайт, то очередь сообщений будет сначала проверять соблюдение квоты компьютера (50 Мбайт), и только потом — общую сумму всех квот очередей. Однако каждая квота очереди будет по-прежнему ограничивать объем хранящихся в ней сообщений величиной 10 Мбайт.

Квоты очереди и компьютера можно задавать только на серверах очереди сообщений и независимых клиентах. Квоты очереди и компьютера, заданные на сервере очереди сообщений, поддерживающем зависимых клиентов, применяются как к серверу, так и ко всем зависимым от него клиентам. Например, если квота компьютера для сервера равна 50 Мбайт и один зависимый клиент создал сообщений на 50 Мбайт, сервер и остальные зависимые клиенты, поддерживаемые им, не смогут отправлять сообщения, пока общий объем сообщений не снизится до границы, определенной квотой.

Серверы очереди сообщений и независимые клиенты могут сохранять сообщения только до тех пор, пока их число не превышает некий максимальный предел на каждом компьютере, зависящий от ряда факторов. Для серверов очереди сообщений, поддерживающих несколько зависимых клиентов, такое предельное значение применяется к серверу, поскольку зависимые клиенты не хранят сообщения локально. Таким образом, число сообщений, которые могут находиться на сервере очереди сообщений, поддерживающем несколько зависимых клиентов, не превышает максимального числа собственных сообщений этого сервера, деленного на число зависимых клиентов.

Примечания

  • Теоретический объем хранилища сообщений на компьютере ограничен емкостью оперативной памяти, общим объемом дискового пространства, числом сообщений, содержащихся на компьютере в данный момент, и версией службы очереди сообщений, работающей на компьютере. Предельное число сообщений, которые можно хранить на компьютере с текущей версией очереди сообщений и оперативной памятью объемом не менее 512 Мбайт, составляет около 5 млн. В то же время максимальный объем дискового пространства, выделяемый для одного сообщения, равен 4 Мбайт. Если умножить максимальное число размещаемых сообщений на максимальный объем области, занимаемой одним сообщением, получится, что теоретический максимум объема содержимого, которое можно сохранить на одном компьютере, может превысить 1 терабайт.

Дополнительные сведения об установке квот см. в разделах Задание квот компьютера для сообщений и Задание квот очередей для сообщений.

Локальное хранилище сообщений

Файлы, используемые для хранения сообщений, находятся в папках Msmq\Storage и Msmq\Storage\Lqs (под умолчанию создаваемых в папке \Windows\System32).

Сообщения хранятся в файлах, отображаемых в памяти (файлах .mq), на жестком диске исходного компьютера, конечного компьютера или промежуточного сервера очереди сообщений, на котором работают службы маршрутизации. Дисковое пространство выделяется для срочных и восстанавливаемых сообщений порциями по 4 Мбайт, по мере необходимости. Для каждого восстанавливаемого сообщения файл сообщений, отображенный в памяти, записывается на диск для гарантии возможности восстановления этого сообщения. Файлы со срочными сообщениями записываются на диск только в том случае, если ресурсов компьютера недостаточно для хранения сообщений в памяти.

Компьютер, отправляющий сообщение, создает файлы, отображенные в памяти. Серверы очереди сообщений, используемые для маршрутизации сообщений, также хранят сообщения в файлах, отображенных в памяти. Если ведется журнал источников, файлы, отображенные в памяти, располагаются на исходном компьютере. Если ведется журнал назначений, файлы, отображенные в памяти, располагаются на конечном компьютере. На серверах очереди сообщений хранятся все файлы сообщений зависимых клиентов, которых они поддерживают.

Чтобы оградить систему от внешних атак, каждая операция удаления, изменения или добавления файла в папке Msmq\Storage сопровождается созданием записи аудита в журнале безопасности.

Файлы, отображаемые в памяти, можно сохранять в любой файловой системе, поддерживаемой в Windows XP. Однако, поскольку файловая система NTFS для Windows XP предлагает более надежное восстановление файлов после сбоя питания или аварии системы, на серверах очереди сообщений рекомендуется использовать именно ее. Кроме того, в целях повышения отказоустойчивости следует архивировать папки, содержащие файлы хранилища сообщений. Если на жестком диске с файлами сообщений произойдет сбой и его содержимое не удастся восстановить с помощью какой-либо программы архивации или входящей в состав очереди сообщений служебной программы архивации и восстановления, сообщения будут утеряны. Сведения о служебной программе архивации и восстановления сообщений содержатся в разделе Архивация и восстановление сообщений.

Файлы в папке Msmq\Storage

Файлы с расширением имени .mq представляют собой отображаемые в памяти файлы, в которых хранятся сообщения. Перед расширением .mq ставится буква, обозначающая тип сообщений, хранящихся в данном файле:

  • r — срочные сообщения (обычно они хранятся не на диске, а в оперативной памяти; данный файл используется при нехватке оперативной памяти)
  • p — восстанавливаемые сообщения
  • j — сообщения журнала
  • l — файл журнала сообщений для интерпретации файлов восстанавливаемых и журнальных сообщений

Файл .mq не представляет какую-то одну конкретную очередь. Сообщения из нескольких очередей могут храниться в одном файле .mq, а сообщения из одной очереди могут храниться в нескольких файлах .mq. Однако одно сообщение не может занимать несколько файлов. Это связано с ограничением размера сообщения — не более 4 Мбайт.

Файл QMLog — это журнал, в который вносятся записи об обработке всех транзакций. Когда он заполняется, новые записи делаются поверх самых старых. Чтобы обеспечить такое непрерывное циклическое обновление файла QMLog, последовательность сообщений и состояние всех активных транзакций периодически сохраняются соответственно в следующих файлах:

  • MQInSeqs.lg1
  • MQInSeqs.lg2
  • MQTrans.lg1
  • MQTrans.lg2

Файлы MQInSeqs.* называются файлами журнала сообщений, а файлы MQTrans.* — файлами журнала транзакций.

Запись в файлы *.lg1 и *.lg2 ведется поочередно, чтобы, если какой-либо файл будет поврежден в процессе записи, другой файл соответствующей пары можно было восстановить.

Файлы в папке Msmq\Storage\Lqs

Файлы в папке Lqs (хранилище локальных очередей) являются текстовыми файлами, описывающими свойства локальных очередей.

Имена файлов, имеющие формат nnnnnnnn.hhhhhhhh, представляют частные очереди. Фрагмент nnnnnnnn указывает номер очереди (который включается в прямое имя формата данной очереди). Расширение hhhhhhhh представляет собой хеш-код пути к очереди и используется для быстрого поиска.

Имена файлов в формате aaaaaaaabbbbccccddddeeeeeeeeeeee.hhhhhhhh представляют локальные общие очереди. Стоящая слева часть имени из 32 символов — это глобальный уникальный идентификатор (GUID) очереди. Расширение hhhhhhhh представляет собой хеш пути к очереди.

Внимание!

  • Удаление файлов из папки Lqs приведет к разрушению внутренних частных очередей, в которых хранятся сообщения, необходимые для внутренних операций очереди сообщений, и без которых служба очереди сообщений не сможет начать работать. Посмотрите перечень событий очереди сообщений в программе просмотра событий. Наиболее характерными признаками потери этих очередей являются события с идентификаторами 2020 и 2052.


Объекты очереди сообщений в Active Directory

В среде домена в каталоге Active Directory при установке создается один или несколько объектов очереди сообщений — для всех типов компьютеров очереди сообщений, за исключением зависимых клиентов. Эти объекты хранят различные сведения, относящиеся к очереди сообщений. Доступ пользователей к объектам очереди сообщений контролируется путем назначения объектам дескрипторов безопасности. Дескриптор безопасности содержит список пользователей и групп, которым разрешен или запрещен доступ к объекту, а также перечень конкретных разрешений, предоставленных этим пользователям и группам. Дополнительные сведения о контроле доступа к объектам очереди см. в разделе Управление доступом в очереди сообщений.

При определенных условиях служба каталогов может изменить имя объекта. Это возможно, когда одновременно на разных контроллерах домена создается несколько объектов под одним именем. Сведения о том, как в Active Directory обрабатываются имена объектов и их конфликты, содержатся в разделе Имена объектов.

В следующей таблице перечислены объекты, которые по умолчанию создаются очередью сообщений для каждого типа компьютера очереди сообщений и отображаются в оснастках MMC. Общие сведения о консоли MMC и ее оснастках см. в разделе Консоль управления Microsoft.

Компьютер очереди сообщений | Имя объекта | Класс объекта
Сервер очереди сообщений без поддержки службы каталогов или служб маршрутизации на контроллере домена | msmq | Настройка MSMQ
Сервер очереди сообщений с поддержкой службы каталогов на контроллере домена | msmq; MSMQ-Settings | Настройка MSMQ; Параметры MSMQ
Сервер очереди сообщений с включенной маршрутизацией | msmq; MSMQ-Settings | Настройка MSMQ; Параметры MSMQ
Сервер очереди сообщений на компьютере, не являющемся контроллером домена | msmq | Настройка MSMQ
Независимый клиент | msmq | Настройка MSMQ
Зависимый клиент | нет | нет

Когда пользователь вручную создает объект в Active Directory, ему предлагается задать минимальный набор сведений, необходимых для установки объекта в Active Directory. У каждого объекта есть множество других свойств (атрибутов), помимо устанавливаемых. Создав объект, можно посмотреть и изменить значения этих дополнительных атрибутов в диалоговом окне Свойства.

Кроме того, некоторые сведения об очереди сообщений также хранятся в объектах Active Directory, не относящихся к очереди сообщений. Так, объект «Пользователь» содержит данные о сертификатах пользователя, соответствующий объект «компьютер» (включающий объект msmq) — сведения о сертификатах, объект «Сайты» — сведения об инородных сайтах, а объекты «группа рассылки» — содержимое списков рассылки.

Дополнительные сведения об атрибутах объектов см. в разделе «Active Directory» в пакете Microsoft Platform Software Development Kit (SDK). Чтобы открыть начальную страницу Active Directory в разделе «Platform SDK» библиотеки MSDN, выберите на вкладке Содержание раздел Active Directory.

    Где?

    • Библиотека MSDN
    • Platform SDK
    • Networking and Directory Services
    • Directory Services
    • Active Directory

Объект «MsmqServices»

Объект «MsmqServices» создается системой Windows 2000 при настройке конфигурации первого контроллера домена данного леса. В составе леса может существовать только один объект «MsmqServices». Он принадлежит классу «MSMQ-Enterprise». Объект «MsmqServices» содержит сведения о настройке очереди сообщений в масштабах предприятия.

Объект «MsmqServices» расположен в следующей позиции дерева консоли (обычно это левая область) оснастки «Active Directory – сайты и службы».

  • Active Directory – сайты и службы
  • Службы
  • MsmqServices

Объект «маршрутная ссылка»

Объект «маршрутная ссылка» с именем, определяемым пользователем, создается для каждой маршрутной ссылки, которая установлена между двумя сайтами очереди сообщений или между сайтом очереди сообщений и инородным сайтом, и содержит данные о подключении. Объекты «маршрутная ссылка» принадлежат классу «MSMQ-Routing-Link».

Объекты «маршрутная ссылка» расположены в объекте «MsmqServices» в области сведений оснастки «Active Directory – сайты и службы».

Объект «MSMQ Settings»

Объект «MSMQ Settings» создается для каждого сервера очереди сообщений, устанавливаемого в контроллере домена Windows 2000, и для каждого сервера очереди сообщений с включенной службой маршрутизации. Объект «MSMQ Settings» содержит сведения о конфигурации, например, об услугах, предоставляемых сервером очереди сообщений. Объект «MSMQ Settings» принадлежит классу «MSMQ-Settings».

Объект «MSMQ Settings» отображается в области сведений (обычно это правая область) оснастки «Active Directory – Сайты и службы», если выбрать соответствующий объект «сервер». Объекты «сервер» располагаются в следующей позиции:

  • Active Directory – сайты и службы
  • Сайты
  • Объект «сайт»
  • Серверы
  • Объект «сервер»

Объект «msmq»

Объект «msmq» создается для каждого независимого клиента и для каждого сервера очереди сообщений; он содержит сведения о конфигурации локального компьютера. Объект «msmq» принадлежит классу «Настройка MSMQ». Он является родительским объектом входящих в него объектов «очередь». Кроме того, объект «msmq» может выступать в качестве объекта «MSMQ Configuration», например, в именах конкретных разрешений для данного объекта и в мастере делегирования управления.

Объект «msmq» (вместе с дочерними объектами-контейнерами) отображается в дереве консоли оснастки «Active Directory – Пользователи и компьютеры» в следующей позиции:

  • Active Directory – пользователи и компьютеры
  • Объект «домен»
  • Объект «подразделение» (например, «Компьютеры» или «Контроллеры доменов»)
  • Объект «компьютер»
  • msmq
  • Папка очереди (например, «Частные очереди» и «Системные очереди»)
  • Объект «очередь»
  • Сообщения очереди
    Сообщения журнала

Объект «очередь»

Объект «очередь» с именем, определяемым пользователем, создается для каждой очереди и содержит относящиеся к ней данные. Объекты «очередь» принадлежат классу «Очередь MSMQ». Каждый объект «очередь» содержит папку «Сообщения очереди» и папку «Сообщения журнала».

Объекты «очередь» входят в объект «msmq» компьютера, на котором они располагаются (за исключением зависимых клиентов, чьи объекты «очередь» находятся в объекте «msmq» поддерживающего сервера).

Объект «группа рассылки»

Объект «группа рассылки» с именем, определяемым пользователем, создается для каждого списка рассылки, публикуемого в Active Directory, и содержит относящиеся к нему данные, например, перечень элементов, составляющих список, — ими могут быть общие очереди, псевдонимы очередей и другие списки рассылки. Объекты «группа рассылки» принадлежат классу «Группа».

Объекты «группа рассылки» отображаются в дереве консоли оснастки «Active Directory – Пользователи и компьютеры» в следующей позиции:

  • Active Directory – пользователи и компьютеры
  • Объект «домен»
  • Пользователи
  • Объект «группа рассылки»

Дополнительные сведения о списках рассылки см. в разделе Списки рассылки.

Объект подразделения «MSMQ Computers»

Данный объект подразделения создается только мастером обновления очереди сообщений в среде домена смешанного режима (где имеется по крайней мере один сервер контроллера MSMQ 1.0, работающий на компьютере Windows NT 4.0, и сервер очереди сообщений, работающий на компьютере Windows 2000) и используется в качестве контейнера объектов «компьютер» для компьютеров MSMQ 1.0, принадлежащих доменам Windows NT 4.0.

Объект подразделения «MSMQ Computers» отображается в следующей позиции дерева консоли оснастки «Active Directory – пользователи и компьютеры».

  • Active Directory – пользователи и компьютеры
  • Объект «домен»
  • MSMQ Computers

Объект подразделения «MSMQ Users»

Данный объект подразделения создается только мастером обновления очереди сообщений в среде домена смешанного режима (где имеется по крайней мере один сервер контроллера MSMQ 1.0, работающий на компьютере Windows NT 4.0, и сервер очереди сообщений, работающий на компьютере Windows 2000) и используется в качестве контейнеров для объектов «обновленный пользователь MSMQ».

Объект подразделения «MSMQ Users» отображается в следующей позиции дерева консоли оснастки «Active Directory – пользователи и компьютеры».

  • Active Directory – пользователи и компьютеры
  • Объект «домен»
  • MSMQ Users

Объект «обновленный пользователь MSMQ»

Объект «обновленный пользователь MSMQ» создается только мастером обновления очереди сообщений и содержит зарегистрированные сертификаты для бывших пользователей MSMQ 1.0, принадлежавших доменам Windows NT 4.0. Объект «обновленный пользователь MSMQ» принадлежит классу «MSMQ-Upgraded-User».

Объекты «обновленный пользователь MSMQ» приводятся в области сведений оснастки «Active Directory – Пользователи и компьютеры», когда в дереве консоли выбран объект «MSMQ Users».

    Где?

    • Active Directory – пользователи и компьютеры
    • Объект «домен»
    • MSMQ Users

Примечания

  • Когда пользователь из доверенного домена Windows NT 4.0 загружается на компьютере, на котором запущена какая-либо версия службы очереди сообщений и который принадлежит домену Windows 2000, даже не в смешанном режиме, служба очереди сообщений и для такого пользователя создает объект «обновленный пользователь MSMQ».


Доставка сообщений по транспорту HTTP

Очередь сообщений поддерживает доставку сообщений по транспорту HTTP. Таким образом, сообщения из очередей могут быть отправлены и получены по транспорту HTTP как и в обычной программной модели очереди сообщений. Очереди могут быть адресованы по именам URL как в интрасети, так и в Интернете. Отправитель и получатель могут находиться в различных лесах или организациях. Определен и разработан открытый, основанный на XML протокол SRMP (SOAP-Reliable Messaging Protocol). Асинхронный обмен сообщениями, включая асинхронный обмен сообщениями B2B, приспособлен для поддержки брандмауэров. Для обеспечения масштабируемости и доступности очередь собщений интегрируется с общим механизмом распределения нагрузки сети, а именно: балансировка нагрузки сети (NLB), NAT, Cisco LocalDirector и ротация DNS. Дополнительные сведения о балансировке нагрузки в веб-фермах содержатся в разделе Кластеры NLB и очередь сообщений.

Сообщение может быть отправлено по транспорту HTTP в очереди, находящиеся в Интернете или интрасети, с помощью прямого формата имен стиля URL описание которого содержится в следующем разделе. Для отправки сообщений очередью сообщений по транспорту HTTP должен быть установлен подкомпонент «Поддержка протокола MSMQ HTTP». Данный подкомпонент, не устанавливаемый по умолчанию в составе Windows XP Professional, устанавливает оснастку «Internet Information Services» (IIS) и создает IIS расширение для очереди сообщений.

Имена URL для очередей

Общие и частные имена очередей администрирования или очередей ответов а также их имена прямого формата могут быть помещены в сообщения, отправляемые по транспорту HTTP. И наоборот: имена очередей администрирования или очередей ответов в формате HTTP могут быть помещены в сообщения, отправляемые по обычному (не HTTP) транспорту. Тем не менее, использование списков рассылки и многоэлементных имен форматов для этих целей не поддерживается.

Имя узла и ресурс в заголовке HTTP преобразуются в формат UTF-8. Это позволяет отправлять сообщения HTTP на компьютеры и в очереди с неанглийскими именами в кодировке Юникод.

Дополнительные сведения об использовании прямого формата имен для очередей с именами URL содержатся в разделе Имена прямого формата.

Срочные сообщения и сообщения с возможностью восстановления, отправленные по транспорту HTTP.

Если сообщение отправлено по транспорту HTTP, получателю не требуется поддерживать внутреннее состояние, а очередь сообщений не гарантирует однократную доставку (EOD), хотя и пытается добиться ее с помощью механизма удаления повторных сообщений. Если сеанс связи между клиентом и одним из узлов завершен и клиент направлен в другой узел для следующего сеанса связи, сообщения, для которых не было отправлено сообщения подтверждения сеанса связи, повторно отправляются клиентом и принимаются новым узлом (во избежание возникновения копий). Тем не менее, поскольку EOD не предоставляет никаких гарантий, приложение, принимающее сообщения, может обрабатывать копии или игнорировать неполадку.

Имена прямого формата формы DIRECT=TCP:IP-адрес кластера\имя очереди используются для отправки сообщений на виртуальный сервер NLB.

Распространение очереди сообщений через сеть периметра (DMZ)

Большинство организаций подключаются к Интернету с помощью сетей периметра (также называемых DMZ), защищенных брандмауэрами с прокси-серверами. Прокси-сервер является связующим звеном между интрасетью и Интернетом. Он создает защищенный канал, по которому прохождят данные между частной сетью и Интернетом и осуществляет кэширование. Очередь сообщений использует прокси-сервер HTTP при подключении к веб-адресам для доставки сообщений HTTP. Таким образом, очередь сообщений должна знать имя прокси-сервера и соответствующий порт, к которому ей предстоит подключиться. В то же время, можно создать список целевых имен, веб-адресов, не нуждаются в доступе через прокси-сервер, для которых будет осуществляться прямое соединение в обход прокси. В таких случаях осуществляется попытка установления прямого соединения. Все данные, относящиеся к прокси-серверам, хранятся в реестре.

Для настройки прокси-сервера используется утилита «Настройка прокси-сервера». Для настройки прокси-сервера введите в командной строке следующую команду.

proxycfg.exe -p Имя_прокси_сервера:номер_порта Обходить_следующие_цели

Имейте в виду, что подстановочные знаки могут использоваться для определения списка целей, для которых осуществляется прямое соединение в обход прокси.

Отправка нового запроса до окончания чтения всех ответов из предыдущего запроса называется конвейеризацией. Поскольку прокси-серверы не всегда поддерживают конвейеризацию, а IIS HTTPS в настоящее время также его не поддерживает, режимы конвейерной доставки HTTP и HTTPS контролируются двумя параметрами реестра, которые называются HttpPipeLine и HttpsPipeline (типа DWORD), расположенными в записи ресстра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters. Если значения параметров равны 1, конвейеризация включена. По умолчанию, доставка HTTP функционирует в режиме конвейеризации, а доставка HTTPS - нет.

Внешние и внутренние имена очереди

При отправке сообщения по транспорту HTTP, имена компьютеров в сети организации и имена расположенных на них очередей могут быть закрыты для отправителей, находящихся вне организации. Внутренние имена очередей и несущих компьютеров могут сопоставляться с внешними именами и псевдонимами. Таким образом, сообщения, отправленные по транспорту HTTP к внешнему HTTP формату имени очереди, могут быть направлены к соответствующей очереди, расположенной на компьютере в организации.

Транзактные сообщения доставляются только один раз в порядке их отправки. При отправке транзактных сообщений по транспорту HTTP из внутренней сети организации в Интернет, внутреннее имя порядковой очереди отправителя должно быть преобразовано в имя внешней очереди с помощью сопоставления по порядку для направления сообщений подтверждений с компьютера получателя (расположенного вне организации отправителя) назад к порядковой очереди отправителя. Сообщение подтверждения порядка отправляется в конверте SRMP.

Сопоставление внутренних имен очередей именам внешней очереди производится вручную в файлах сопоставлений XML. Имена внутренней и внешней очереди должны быть записаны в формате имен HTTP. Например, внутреннее имя очереди упорядочения должно быть записано с внутренним сетевым именем локального узла (http://Локальный_узел\msmq\private$\очередь_упорядочения$). Обратите внимание на направление косых черт. Ниже приведен пример файла сопоставлений XML, в котором внутреннее имя очереди приложения, расположенной на компьютере в организации, сопоставлено с соответствующим именем внешней очереди, и внутреннее имя очереди упорядочения сопоставлено с именем внешней очереди.

<mapping host="localhost" xmlns="msmq-queue-mapping.xml">

   <queue>
       <name>http://внутреннее_имя_в_сети\msmq\внутренняя_очередь</name>
       <name>http://внешнее_имя_в_сети\msmq\внешняя_очередь</name>
   </queue>

    <queue>
        <name>http://внутреннее_имя_в_сети\msmq\private$\очередь_упорядочения$</name>
        <alias>http://внешнее_имя_в_сети\msmq\private$\очередь_упорядочения$</alias>
    </queue>

</mapping>

Данные файлы сопоставлений XML должны храниться в папке «\Windows\System32\Msmq\Mapping».

Сообщения HTTPS

При отправке сообщений по транспорту HTTPS между отправителем и получателем должно быть установлено соединение по протоколу SSL. Отравитель всегда считается клиентом SSL а получатель – сервером SSL, независимо от того, запущен ли на компьютере сервер очереди сообщений или клиентское программное обеспечение.

Перед установлением защищенного соединения SSL для отправки сообщений, сервер IIS на компьютере получателя должен отправить, для проверки подлинности, отправителю сертификат сервера получателя. Сертификат сервера, содержащий подпись центра сертификации, открытый ключ отправителя, дополнительную информацию получателя и срок действия, должен быть из центра сертификации с которым у отправителя установлены доверительные отношения. Если у компьютера установлены доверительные отношения с конкретным сервером сертификации, он обладает сертификатом центра сертификации, содержащим подпись центра сертификации и открытый ключ, и хранящимся в банке сообщений Доверенные корневые центры сертитфикации компонента Сертификаты (локальный компьютер) оснастки «Сертификаты». Сертификат сервера должен находиться в хранилище Личные компонента Сертификаты (локальный компьютер) оснастки «Сертификаты» на компьютере получателя. Для проверки подлинности компьютера получателя отправитель проверяет, установлены ли у него доверительные отношения с центром сертификации, и подтверждает подпись в сертификате сервера получателя.

Более подробные сведения о получении и установке сертификата сервера из центра сертификации находятся в разделе Получение серверного сертификата документации по серверу IIS 6.0.

Для сеансов SSL может потребоваться дополнительный компонент безопасности, если сервер IIS на компьютере получателя запрашивает клиентский сертификат отправителя для проверки подлинности. Клиентские сертификаты можно получить из центра сертификации с которым установлены доверительные отношения. Клиентские сертификаты хранятся в хранилище MSMQ\Личные компонента Сертификаты - служба (Очереди сообщений) на локальном компьютере оснастки «Сертификаты» на компьютере отправителя.

Для использования клиентcкого сертификата необходимо выполнить следующую процедуру на компьютерах отправителя и получателя.

  • На компьютере отправителя выполните следующие действия.
    1. В веб-обозревателе откройте форму запроса сертификата из центра сертификации.
    2. Щелкните ссылку Запрос сертификата, затем выберите ссылку Дополнительные запросы сертификатов, после чего щелкните ссылкуСоздать и выдать запрос к этому ЦС.
    3. Введите необходимые данные и в группе Тип требуемого сертификата выберите элемент Сертификат проверки подлинности клиента.
    4. Установите флажки Использовать локальное хранилище компьютера и Пометить ключ как экспортируемый, нажмите кнопку Отправить а затем – кнопку Установить.
    5. Откройте оснастку «Сертификаты». Для этого нажмите кнопку Пуск, выберите команду Выполнить, введите mmc и нажмите нопку ОК.
    6. В меню Консоль выберите команду Добавить или удалить оснастку.
    7. В диалоговом окне Добавить/Удалить оснастку нажмите кнопку Добавить, выберите оснастку Сертификаты и снова нажмите кнопку Добавить.
    8. Выберите элемент учетной записи компьютера, нажмите кнопку Далее >, а затем нажмите кнопку Готово.
    9. В диалоговом окне Добавить/Удалить оснастку нажмите кнопку Добавить, выберите оснастку Учетная запись службы, нажмите кнопку Далее >, затем нажмите кнопку Далее > вновь.
    10. В группе учетной записи службы выберите элемент Очередь сообщений, нажмите кнопку Готово, затем нажмитке кнопку Закрыть, после чего нажмите кнопку ОК.
    11. Расположите автоматически установленный клиентский сертификат в хранилище Личные.

      12. Где?

      • Корень консоли
      • Сертификаты (локальный компьютер)
      • Личные
      • Сертификаты
    12. Удерживая нажатой левую кнопку мыши, перетащите сертификат в хранилище MSMQ\Личные компонента Сертификаты - служба (Очереди сообщений) на локальном компьютере оснастки «Сертификаты».

      13. Где?

      • Корень консоли
      • Сертификаты - служба (Очереди сообщений) на локальном компьютере
      • MSMQ\Личные
      • Сертификаты
  • На компьютере получателя выполните следующие действия.
    1. Откройте компонент Управление компьютером.
    2. В дереве консоли щелкните правой кнопкой мыши раздел Веб-узел по умолчанию.

      3. Где?

      • Управление компьютером
      • Службы и приложения
      • Internet Information Services
      • Веб-узлы
      • Веб-узел по умолчанию
    3. Нажмите кнопку Свойства.
    4. На странице Безопасность каталога в разделе Безопасные подключения нажмите кнопку Изменить.
    5. В диалоговом окне Безопасные подключения выберите элемент Принимать клиентские сертификаты.

Если все условия, налагаемые сервером IIS выполнены, отправитель и получатель создают ключи сессии SSL и обмениваются ими. Эти ключи используются для шифрования всех пакетов, посылаемых по соединению SSL. Дополнительные сведения о сертификатах и подключениях SSL см. в документации по IIS 6.0.

Сертификат сервера, полученный из центра сертификации, может быть выдан на имя Netbios или полное DNS-имя компьютера. Тем не менее, при отправке сообщений HTTPS, место назначения, указанное в сообщении, должно быть идентично имени компьютера в сертификате сервера получателя. Таким образом, когда для отправки сообщений в пределах того же леса в интрасети на компьютер, сертификат сервера которого содержит полное имя DNS, используется только имя Netbios места назначения (например, с именем формы прямого формата «DIRECT=HTTPS://msmqserv/msmq/private$/q1») проверка подлинности не выполняется. Следовательно, когда очередь сообщений пытается создать сессию SSL, она получает предупреждение, сообщающее что имя в сертификате не соответствует имени назначения, а сообщения, отправленные таким способом, накапливаются в очереди исходящих сообщений.

В контексте очереди сообщений сервер IIS может проверять подлинность компьютера отправителя, но не отдельного пользователя, отправляющего сообщения. В следующем разделе содержатся сведения о том, как может быть осуществлена проверка подлинности пользователей, отправляющих по транспорту HTTP/HTTPS прошедшие проверку подлинности сообщения.

Проверка подлинности сообщений HTTP/HTTPS.

При отправке прошедших проверку подлинности сообщений по транспорту HTTP/HTTPS отправитель вкладывает в них цифровую подпись XML и сертификат пользователя, содержащий имя пользователя, его открытый ключ и подпись поставщика. Пользователь может получить внешний сертификат пользователя из центра сертификации (ЦС), такого как VeriSign или Microsoft Certificate Services, или же использовать внутренний сертификат, который создается на локальном компьютере во время установки и автоматически регистрируется при первом входе в систему. Если внешний сертификат используется, пользователь должен зарегистрировать его в Active Directory в локальном лесе с помощью пользовательский интерфейс службы очередей сообщений.

При отправке сообщения, требующего проверки подлинности, в пределах одного леса, получатель расшифровывает цифровую подпись, подтверждает ее с помощью открытого ключа отправителя и пытается обнаружить сертификат пользователя в Active Directory в соответствии с его кодом GUID. Если сертификат пользователя найден, подпись поставщика (ЦС) проверяется с помощью его открытого ключа, хранящегося на любом компьютере, с которым поставщик установил доверительные отношения. Тем не менее, если сертификат пользователя не найден в Active Directory, очередь сообщений проверяет сертификат, чтобы определить, не является ли он (внутренний сертификат пользователя) самоподписанным. Если это так, сообщение отклоняется. Если сертификат пользователя не найден в Active Directory и не является самоподписанным, отправитель считается анонимным пользователем и ему предоставляется соответствующий доступ к конечной очереди.

При отправке сообщений по транспорту HTTP/HTTPS из различных лесов получатель не может осуществлять поиск сертификата в Active Directory в лесе отправителя. Чтобы устранить эту проблему и использовать один сертификат пользователя для проверки сообщений, отправленных из различных лесов, выполните следующие действия.

  1. Экспортируйте пользовательский сертификат отправителя в файл.
  2. Отправьте файл в лес получателя.
  3. В лесе получателя создайте виртуального пользователя, представляющего отправителя или группу отправителя.
  4. Импортируйте сертификат в персональное хранилище сертификатов виртуального пользователя.
  5. С помощью пользовательского интерфейса службы очередей сообщений зарегистрируйте для виртуального пользователя сертификат в Active Directory.
  6. Предоставьте виртуальному пользователю разрешения для записи в очереди сообщений.

Теперь получатель сможет, запрашивая Active Directory в локальном лесе, проверять сообщения, отправленные из различных лесов как и сообщения, отправленных по транспорту HTTP/HTTPS в пределах одного леса.

Инструкции по регистрации сертификата пользователя содержатся в разделе Регистрация сертификатов для очереди сообщений.


Триггеры очереди сообщений

Триггеры очереди сообщений являются службой, позволяющей связывать прибытие каждого входящего сообщения в очередь с ответом, зависящим от содержимого сообщения, и могут вызывать компонент COM или отдельное приложение. Триггеры очереди сообщений можно использовать для определения рабочих правил, которые могут быть введены в ответы на такие сообщения без какого-либо дополнительного программирования. Обычно, для обеспечения возможности обработки сообщений, разработчики сообщений должны создать получающее приложение, определенным образом обрабатывающее каждое сообщение. С помощью триггеров очереди сообщений определенные действия могут выполняться на уровне очереди. Разработчикам приложения больше не требуется писать код инфраструктуры для обеспечения возможности обработки сообщений.

Триггеры очереди сообщений являются неотъемлемой частью очереди сообщений версии 3.0. Предыдущая отдельная версия, известная как «Триггеры MSMQ », может быть установена на компьютеры, работающие под управлением Windows 2000 с очередью сообщений версии 2.0, а также на компьютеры, работающие под управлением Windows NT 4.0 с очередью сообщений версии 1.0.

Элементы триггера

Каждый триггер связан с определенной очередью триггера на локальном компьютере, и вызывается службой триггеров очереди сообщений для каждого сообщения очереди сообщений, прибывающего в эту очередь. Триггер настроен на подчинение одному или нескольким правилам. Правило определеяется одним или несколькими условиями и действием в форме исполняемого файла или компонента COM, и выполняется если все условия, связанные с парвилом, верны.

Триггер является автоматическим механизмом выполнения определенных действий в ответ на событие сообщения. В контексте триггеров очереди сообщений события определяются как набор из одного или нескольких условий, которым может удовлетворять сообщение, прибывающее в очередь. Совокупность триггеров на определенном компьютере называется набором триггеров.

Условие является критерием, применяемым к сообщению при его прибтии в очередь триггера. Условие может испытываться только для свойства сообщения. Каждое условие или набор нескольких условий связаны с действием.

Действие – это исполняемое поведение, которое применяется, если условие или набор нескольких условий имеют значение «истина». Действие может быть выражено как исполняемый файл и список аргументов или компонент COM, метод и список параметров. Также можно вызвать другие типы файлов, изменяя параметры EXE-файла. Например, можно вызвать MSC-файл, указав mmc.exe в качестве выполняемого файла и полный путь MSC-файла в качестве параметра.

Правило состоит из условия и действия. Правило определяет действие, выполняемое когда определенное условие или набор условий имеют значение «истина». Совокупность всех правил для всех триггеров на определенном компьютере называется набором правил.

Примечания

  • Триггеры могут быть связаны с очередями, расположенными на локальном компьютере и удаленном компьютере.

Тип обработки сообщения

Тип обработки сообщения задается для каждого триггера. Доступными типами обработки сообщений являются «просмотр», «извлечение» и «транзактное извлечение».

Если в качестве типа обработки сообщений для данного триггера выбран «просмотр» и запущена служба триггеров очереди сообщений, она просматривает каждое сообщение, прибывающее в очередь триггера, испытывает его по условиям всех связанных с очередью правил, выполняет все соответствующие действия но не удаляет сообщение из очереди.

Если в качестве типа обработки сообщений выбрано «извлечение», служба триггеров очереди сообщений просматривает каждое сообщение, прибывающее в очередь триггера, испытывает его по условиям всех связанных с очередью правил, выполняет все соответствующие действия но не удаляет сообщение из очереди.

Тип обработки сообщений «транзактное извлечение» подобен простому извлечению, однако при нем сообщение возвращается в очередь, если какое-либо из действий, связанных с получением сообщения, не может быть выполнено и транзакция извлечения отменяется.

Когда в транзактную очередь прибывает сообщение, очередь сообщений не ограничивает доступ службы триггеров очереди сообщений к этим сообщениям. Таким образом, другие приложения очереди сообщений могут открыть очередь и удалить сооообщения перед тем как службе триггеров очереди сообщений удастся обработать эти сообщения.

Последовательные и непоследовательные триггеры

Триггеры очереди сообщений могут быть последовательными или непоследовательными. Задание типа триггеров для определенной очереди влияет на обработку входящих сообщений службой триггеров очереди сообщений. Если при создании нескольких триггеров для определенной очереди хотя бы один из них является последовательным, все триггеры будут действовать как последовательные, даже если они не определены в качестве таковых. Триггеры с типом обработки «транзактное извлечение» могут быть только последовательными.

Последовательные триггеры обрабатывают сообщения в порядке их прибытия, испытывают условия всех связанных с ними правил на каждом сообщении, и выполняют все соответствующие действия перед переходом к следующему сообщению. Если определены последовательные триггеры, производительность службы триггеров очереди сообщений ниже чем при использовании непоследовательных триггеров, поскольку единовременно обрабатывается только одно сообщение а службы должны ожидать завершения всех действий, выполняемых над каждым сообщением.

Непоследовательные триггеры обрабатывают сообщения быстрее, но при этом сообщения могут обрабатываться не в порядке прибытия. Непоследовательные триггеры обеспечивают большую производительность, поскольку служба триггеров очереди сообщений перед началом обработки следующего сообщения не ожидает завершения всех действий, выполняемых над каждым сообщением. Рекомендуется использовать только один триггер с последовательным параметром, поскольку триггеры запускаются в произвольном порядке в сответствии с их кодами GUID.

Обработка сообщений

Служба триггеров очереди сообщений начинает обрабатывать сообщения в очереди сразу после запуска. Обработка начинается с начала очереди, при этом обрабатываются все сообщения в очереди. После обработки всех существующих сообщений служба ожидает новые сообщения в конце очереди. (При остановке и перезапуске службы все сообщения, находящиеся в очереди, будут обработаны вновь.)

Обработка сообщений с одинаковым приоритетом

Если все сообщения, отправленные в очередь триггера, имеют одинаковый приоритет, новые сообщения помещаются в конец очереди. После завершения обработки всех сообщений в очереди, служба триггеров очереди сообщений будет включать триггер при каждом прибытии сообщения в конец очереди. Если очередь контролируется триггером с типом обработки сообщений «просмотр», служба триггеров очереди сообщений после завершения обработки сообщений в очереди будет продолжать просмотр дополнительных сообщений, прибывающих в конец очереди, не обрабатывая при этом просмотренные ранее сообщения.

Обработка сообщений с различным приоритетом

По прибытии сообщений с различным приоритетом в очередь, новое сообщение может быть помещено в любое место в очереди. Например, если в очередь помещается сообщение с высоким приоритетом, служба триггеров очереди сообщений начинает обрабатывать его независимо от того, где именно оно находится, а затем продолжает обработку находящихся в очереди сообщений с низким приоритетом.

Когда триггер с типом обработки сообщений «просмотр» назначается очереди, содержащей два сообщения с приоритетом 1 (сообщение 1 и сообщение 2) и два сообщения с приоритетом 2 (сообщение 3 и сообщение 4), служба триггеров очереди сообщений обрабатывает очередь, просматривая сообщение 1, сообщение 2, сообщение 3 и сообщение 4. Затем, по прибытии в очередь сообщения 5 (нового сообщения с приоритетом 1) оно помещается между сообщением 2 и сообщением 3. Служба просматривает сообщение 5 а затем продолжает просмотр сообщения 3 и сообщения 4.

Следует иметь в виду, что в этом случае триггер включается дважды для сообщения 3 и дважды для сообщения 4. Повторного чтения сообщений можно избежать, используя транзактную очередь (все сообщения в которой имеют приоритет 0). Дополнительные сведения о транзактных очередях содержатся в разделе Обмен транзактными сообщениями.

Обработка транзактных сообщений.

При получении транзактного сообщения очередь сообщений не производит откат курсора если транзакция отменяется. Например, имеется очередь с двумя сообщениями: сообщением 1 и сообщением 2. При удалении транзактного сообщения 1 очередь сообщений переместит курсор на сообщение 2. Тем не менее, если по какой-либо причине транзакция отменяется, сообщение 1 помещается обратно в очередь, но курсор остается на сообщении 2.

Интересная ситуация возникает при типе обработки сообщений «просмотр» в очереди, содержащей одно сообщение, когда компонент COM, вызванный правилом триггера, получает сообщение, вызывающее его, и этот же компонент COM настроен в качестве части внешней транзакции. Если какое-либо действие в транзакции выполнить невозможно, транзакция отменяется а сообщение возвращается в очередь. После этого, если используется последовательный триггер, служба триггеров ожидает завершения процессов, выполняемых компонентом COM, перед началом повторной обработки сообщения. В этом случае курсор очереди перемещается и ожидает следующее сообщение, а триггер не вызывает повторно компонент COM для того же сообщения. Тем не менее, если используется непоследовательный триггер, сразу после завершения просмотра сообщения служба триггеров отправляет запрос на просмотр следующего сообщения и ожидает его появления в очереди. Следовательно, при вызове транзактного компонента COM в системе уже имеется незавершенное действие просмотра. Если сообщение возвращается в пустую очередь в невыполненной транзакции, оно прибывает в то место очереди, на которое указывает курсор. В этом случае возвращенное сообщение обрабатывается вновь, компонент COM вызывается для того же сообщения, а бессррочный цикл выполняется до прибытия нового сообщения или выполнения всех операций в транзакции.

Образец реализации триггеров очереди сообщений

Предположим, создан новый триггер, который называется «Частный триггер», связанный с частной очередью «Компьютер\Очередь» и имеющий два добавленных правила: Правило1 и Правило2.

Каждое из правил определяет условие (например «Метка сообщения содержит слово «marketing») и действие, выполняемые, если условие имеет значение «истина» (например "открыть Pbrush.exe" c параметром «Метка сообщения»).

Служба триггеров очереди сообщений извещается о прибытии сообщения в Компьютер\Очередь. Далее, для триггера «Частный триггер», заданного для данной очереди, выполняются подключенные правила Правило1 и Правило2. После этого, если все условия для правил имеют значение «истина», запускается приложение Microsoft Paint.

Дополнительные сведения о выполнении службы триггеров очереди сообщений содержатся в разделе Установка и запуск триггеров очереди сообщений.


Рабочие сценарии для очереди сообщений

Следующие сценарии показывают, как использование очереди сообщений может быть полезно в различных ситуациях. Они также могут использоваться в качестве общих образцов применения различных функций, доступных при использовании очереди сообщений.

Поскольку различия между использованием серверов и клиентов очереди сообщений проявляются в особенностях реализации, но не в самих сценариях, эти сценарии были максимально упрощены. Разработчики приложений могут найти типичные примеры приложений очереди сообщений в пакете «Message Queuing SDK».

Сценарий автоматизации работы производственного цеха

Типичный сценарий автоматизации работы производственного цеха

Очередь сообщений можно использовать для управления автоматизированным процессом производства любого продукта, который выпускается на оборудовании с числовым программным управлением, контролируемом с помощью компьютера. В примере, который иллюстрируется на рисунке, очередь сообщений используется для сбора запросов на выполнение технологических операций и управления потоком информации в процессе производства.

Для автоматизации работы производственного цеха важное значение имеют следующие возможности очереди сообщений.

  • Гарантированная доставка сообщений. Гарантия доставки каждого сообщения и обеспечение надежности системы обмена сообщениями.
  • Обработка сообщений в зависимости от их приоритета. Эффективная маршрутизация сообщений. Например, хотя сообщения контроля качества тоже требуют обязательной доставки, они не должны препятствовать эффективной доставке срочных сообщений.
  • Обмен сообщениями без установки подключений. Возможность взаимодействия всех компьютеров и производственного оборудования как единой системы.
  • Поддержка различных платформ. Интеграция персональных компьютеров и больших ЭВМ. Например, в системе MVS на мэйнфрейме IBM можно установить пакет бухгалтерских программ, который через подключатель Microsoft MSMQ-MQSeries Bridge будет взаимодействовать с приложениями очереди сообщений, размещенными на персональных компьютерах. Дополнительные сведения см. в разделе Поддержка различных платформ и связь с инородными компьютерами.
  • Производительность. Поскольку сообщения могут доставляться очень быстро, это позволяет в режиме реального времени контролировать нужные характеристики производственных процессов, например, температуру термообработки.
  • Асинхронная доставка. Быстродействующие устройства могут продолжать работать, не дожидаясь ответа от более медленных устройств.

Сценарий продажи билетов

Типичный сценарий продажи билетов

На рисунке показано, как несколько клиентов могут через Интернет обращаться на веб-сервер продажи билетов. Клиенты просматривают веб-страницы, на которых приводятся данные о наличии билетов, расценки и схемы расположения мест.

Компания, продающая билеты на различные мероприятия, могут усовершенствовать свою систему продажи, используя следующие возможности очереди сообщений.

  • Подключение к Интернету. Заявки принимаются через Интернет с помощью приложения очереди сообщений и компонентов COM, действующих совместно со страницами Active Server Pages (ASP) и информационными службами Интернета (IIS). Для заявок используются веб-формы, которые обеспечивают безопасность и поддерживают нескольких платформ. Поскольку IIS и очередь сообщений недоступны в версии Windows XP Home Edition, на компьютерах с этой платформой указанной возможностью воспользоваться нельзя.
  • Обмен сообщениями без установки подключений. Асинхронный режим обновления счетов и доставки билетов.
  • Поддержка различных платформ. Интеграция персональных компьютеров и больших ЭВМ. Например, сервер продажи билетов может работать под управлением ОС UNIX. Дополнительные сведения см. в разделе Поддержка различных платформ и связь с инородными компьютерами.

Сценарий публикации и подписки

Очередь сообщений можно использовать для упрощения разработки типичных программ публикации и подписки, таких как агентства новостей и службы подписки на финансовые данные. Хотя серверная программа должна постоянно отправлять обновляемые данные клиентам определенной категории, передачу данных не обязательно повторять, если клиент оказался отключен или недоступен.

Типичный сценарий публикации и подписки

На рисунке показан сценарий публикации и подписки, который обеспечивает информирование мобильных агентов по продажам о текущем состоянии наличных запасов товаров. Еще одно приложение очереди сообщений можно использовать для приема заявок, причем возможна интеграция двух систем. Однако для простоты в этом примере рассмотрено только оперативное распространение данных.

Как видно из рисунка, мобильные клиенты получают данные прямо по месту своего пребывания. Региональные серверы извлекают с головного сервера данные тех типов, на которые подписаны клиенты. Каждый клиент получает только те данные, на которые он подписан. Это снижает расходы на межсайтовую и мобильную связь.

В данном сценарии региональные серверы и центр данных располагаются в разных сайтах. Сообщения передаются из центра данных в другие сайты по маршрутным ссылкам, причем головной сервер центра данных и региональные серверы настраиваются в качестве шлюзов сайтов.

Для надежной работы стандартных программ публикации и подписки важное значение имеют следующие возможности очереди сообщений.

  • Обмен сообщениями в зависимости от их приоритетов и без установки подключений. Бремя ответственности за доставку сообщений возлагается на очередь сообщений. Пользователю нет необходимости заботиться о сведениях, срок действия которых истек (и которые поэтому уже не нужны) или которые не удалось своевременно доставить.
  • Безопасность. Гарантируется доставка сведений соответствующему клиенту, а также оплата всех услуг.

Сценарий организации банковского дела

Типичный сценарий организации банковского дела

Финансовые операции требуют программирования с использованием транзакций и поддержкой безопасности. Транзакции банковских автоматов также требуют обмена сообщениями без установки подключений. Как видно из рисунка, у каждого банкомата имеется своя местная база данных. Даже если местная, региональная или главная база данных будет временно недоступна, банкомат будет продолжать обработку транзакций.

Данный сценарий предусматривает создание региональных центров данных, каждый из которых напрямую подключен к нескольким местным центрам данных, имеющим, в свою очередь, прямую связь с несколькими банкоматами; все региональные центры находятся в разных сайтах. Сообщения передаются между головным центром данных и сайтами по маршрутным ссылкам, причем сервер головного центра данных и серверы региональных центров настроены в качестве шлюзов сайтов.

В этом сценарии использованы следующие возможности очереди сообщений.

  • Обмен сообщениями без установки подключений. Взаимодействие между банкоматами и региональными центрами.
  • Обмен транзактными сообщениями. Отправка сообщений осуществляется синхронно с обновлением финансовых баз данных. Сообщения доставляются только один раз.
  • Безопасность. Гарантия целостности системы. Потенциальные мошенники не смогут обмануть банкомат, а наблюдение за транзакциями с целью кражи номеров счетов и PIN-кодов невозможно.

Сценарий работы брокеров фондовой биржи

Типичный сценарий работы биржевых брокеров

В данном примере клиенты звонят по телефону брокерам, которые отправляют запросы на совершение сделки от их имени. Сервер торгов выполняет свои функции в следующем порядке.

  1. Запрашивает сервер учета для проверки возможности выполнения транзакции.
  2. Проверяет транзакцию на сервере управления рисками.
  3. Размещает запрос на сервере фондовой биржи.

Сервер фондовой биржи выполняет биржевую транзакцию и асинхронно обновляет счет клиента и данные на сервере управления рисками.

В этом сценарии биржевых транзакций используются следующие возможности очереди сообщений.

  • Безопасность. Проверка подлинности сообщений, их шифрование и аудит доступа обеспечивают надежно защищенную среду.
  • Поддержка различных платформ. Интеграция персональных компьютеров и больших ЭВМ. Дополнительные сведения см. в разделе Поддержка различных платформ и связь с инородными компьютерами.
  • Транзакции (однократная доставка). Гарантированная доставка сообщений, обеспечивающая правильное ведение учета.
  • Обмен сообщениями без установки подключений. Асинхронное выполнение обновления счетов и оценки рисков.


Работа с очередью сообщений

В данном разделе содержатся сведения о требованиях, предъявляемых при планировании, установке и обновлении очереди сообщений, а также рассматриваются вопросы безопасности и администрирования.

  • Планирование очереди сообщений
  • Установка, обновление и удаление очереди сообщений
  • Безопасность очереди сообщений
  • Администрирование очереди сообщений


Планирование очереди сообщений

В данной главе рассматриваются вопросы планирования и развертывания очереди сообщений в организации. Для успешного использования очереди сообщений необходимо правильно установить и настроить серверы, клиенты и приложения очереди сообщений.

  • Планирование сети очереди сообщений
  • Выбор оборудования для сервера очереди сообщений
  • Разработка приложений очереди сообщений
  • Развертывание очереди сообщений


Планирование сети очереди сообщений

Первым шагом при развертывании приложений и инфраструктуры очереди сообщений должна стать оценка требований, выдвигаемых по мере роста организации, и соответствующее планирование сети.

При дальнейшем расширении использования очереди сообщений в организации трафик, создаваемый сообщениями, также увеличивается. Для маршрутизации сообщений по каналам связи с большей пропускной способностью следует запланировать установку серверов очереди сообщений. Все сайты должны быть связаны с другими сайтами с помощью маршрутных ссылок. Чтобы обеспечить избыточность связей, следует по мере возможности использовать несколько маршрутных ссылок для межсайтовой маршрутизации.

Планирование сайтов

Все сайты определяются на этапе планирования и установки системы Windows 2000 Server в организации. Отдельная топология сайтов, как в предыдущих версиях очереди сообщений, не предусмотрена. Это упрощает планирование сайтов.

Тем не менее, при планировании следует принять во внимание ряд факторов, которые перечислены в следующей таблице.

Аспект планирования сайта | Требование или рекомендация
Канал связи | Канал связи между сайтами должен быть постоянным.
Доступная пропускная способность сети | Пропускная способность сети должна обеспечивать передачу всех сообщений внутри сайта.
Производительность | Число контроллеров доменов в каждом сайте отражается на производительности. Каждый контроллер домена в сайте порождает дополнительный трафик сообщений, связанный с репликацией содержимого Active Directory в этом сайте. Необходимо соизмерять преимущества избыточности с повышением системной нагрузки, вызванной репликацией.
Организация | Для повышения общей производительности системы, сокращения сетевого трафика и снижения интенсивности использования ресурсов следует группировать вместе пользователей, работающих в одном сайте.

Планирование маршрутных ссылок

Если в организации имеется более одного сайта Windows 2000, необходимо создать маршрутные ссылки, чтобы гарантировать успешную маршрутизацию сообщений между различными сайтами Windows 2000. Маршрут, выбираемый сообщениями при прохождении между сайтами, может быть определен на основе цен маршрутных ссылок. По умолчанию всем маршрутным ссылкам назначается цена, равная 1. Эти цены следует менять только в том случае, когда на существующих маршрутных ссылках могут формироваться альтернативные маршруты и возникает необходимость форсировать использование какого-либо маршрута вместо другого, варьируя цены отдельных ссылок.

С помощью цен ссылок можно выбирать наилучший маршрут сообщений между сайтами; цены могут отражать скорость соответствующего физического канала связи или стоимость его использования в денежном выражении. Определив число сайтов Windows 2000 в структуре леса, следует решить, нужно ли задавать другие цены для маршрутных ссылок. О том, как изменять цены маршрутных ссылок, см. в разделе Изменение цены маршрутной ссылки.

Дополнительные сведения о сайтах см. в разделе Сайты.

Планирование серверов очереди сообщений

Число серверов очереди сообщений с включенной маршрутизацией (серверов маршрутизации), которые развертываются в организации, может зависеть от следующих факторов.

  • Между сколькими сайтами предстоит выполнять маршрутизацию сообщений.
  • Как часто клиентские компьютеры отключаются от сети. Когда исходный или конечный компьютер отключен от сети, для передачи сообщений с промежуточным хранением необходимо наличие серверов очереди сообщений с включенной маршрутизацией.

Для обеспечения надлежащей производительности и масштабируемости следует установить серверы маршрутизации очереди сообщений на нескольких компьютерах в каждом сайте Windows 2000.

Кроме того, поскольку серверы маршрутизации очереди сообщений отвечают на широковещательные запросы, выдаваемые клиентами во время автоматического обнаружения сайтов, необходимо установить по крайней мере один сервер маршрутизации очереди сообщений в каждом сайте Windows 2000, входящем в лес.

Для мобильных клиентов, которые большую часть времени проводят в отключенном состоянии или подключаются к сети через сервер удаленного доступа, необходимо настроить серверы входящей и исходящей маршрутизации.

На установку серверов маршрутизации очереди сообщений на контроллерах доменов не накладывается никаких технических ограничений. Однако, поскольку в число основных обязанностей контроллера домена входит проверка подлинности пользователей, обработка запросов к Active Directory и обеспечение безопасности домена, необходимо понять, не повлияет ли установка серверов маршрутизации на контроллерах доменов на их производительность и безопасность.

Наконец, каждому зависимому клиенту в сети нужен поддерживающий сервер; его роль может играть любой сервер очереди сообщений, даже без включенной маршрутизации.

Сведения об аспектах выбора оборудования сервера содержатся в разделе Выбор оборудования для сервера очереди сообщений.

Планирование независимых клиентов

Развертывание независимых клиентов в сети организации дает следующие преимущества.

  • Эти клиенты отправляют и получают сообщения независимо от сервера очереди сообщений и не требуют синхронной связи с сервером очереди сообщений.
  • Вся нагрузка по обработке сообщений может быть распределена между несколькими серверами очереди сообщений путем настройки независимых клиентов на использование определенных серверов очереди сообщений (серверов входящей и исходящей маршрутизации).
  • Поддержка мобильности — независимые клиенты могут перемещаться из сайта в сайт.
  • Мобильные пользователи, отключенные от сети, могут продолжать получать сообщения с назначенных им серверов входящей маршрутизации. Однако из-за того, что такие настройки маршрутизации не учитываются, когда независимые клиенты подключаются к новому сайту, данную конфигурацию лучше использовать, когда независимые клиенты не подключаются к сети в других сайтах.

Примечания

  • Мобильные пользователи, использующие приложения очереди сообщений при отсутствии подключения к сети, могут дополнительно загружать сеть. Это происходит в то время, когда они, снова подключившись к сети, отправляют или получают большой объем сообщений. Для предотвращения падения производительности эту временную нагрузку можно переложить на дополнительные серверы очереди сообщений.

Планирование зависимых клиентов

Решите, требуется ли в данной организации развертывание зависимых клиентов. Использование зависимых клиентов дает следующие преимущества.

  • Для хранения сообщений используется дисковое пространство сервера. В случае необходимости для повышения производительности очереди сообщений достаточно будет обновить только ресурсы сервера (такие, как память и жесткий диск), оставляя клиентские компьютеры без изменений.
  • Уменьшается число компонентов, требующих администрирования; администратору придется архивировать содержимое меньшего числа компьютеров и отслеживать меньше журналов и очередей недоставленных сообщений.
  • Если зависимый клиент обычно отключен от сети, а сервер — нет, используется меньше ресурсов.

Зависимые клиенты также обладают следующими недостатками.

  • Поскольку служба очереди сообщений работает на поддерживающем сервере, шифрованные сообщения, отправляемые и получаемые зависимыми клиентами, передаются между клиентом и сервером открытым текстом.
  • Время доступа к очереди для зависимого клиента больше, чем для независимого. Это вызвано тем, что доступ к очереди происходит с использованием подключения на основе удаленного вызова процедур.
  • При одновременном подключении нескольких зависимых клиентов к своим поддерживающим серверам для отправки или получения сообщений возможно снижение производительности.
  • Очереди зависимых клиентов расположены на их поддерживающих серверах, и нет четких различий, какие очереди принадлежат каким клиентам.
  • При удалении программного обеспечения зависимого клиента его очереди не удаляются автоматически с поддерживающего сервера.
  • Сообщения от зависимого клиента проходят через поддерживающий сервер, поэтому если канал связи с сервером медленный или дорогой (такой, как между двумя сайтами), то все передачи зависимого клиента также будут медленными или дорогими.
  • Запуск зависимых клиентов под учетной записью локального пользователя невозможен.
  • Новые возможности очереди сообщений Windows XP, такие как транспорт HTTP, триггеры очереди сообщений и рассылка сообщений нескольким получателям, недоступны зависимым клиентам. В частности, для них не поддерживаются списки рассылки и многоэлементные имена формата.
  • Зависимые клиенты не могут устанавливаться на компьютерах рабочей группы и на 64-разрядных компьютерах.
  • Зависимые клиенты не будут поддерживаться в последующих версиях очереди сообщений.

Из-за этих ограничений рекомендуется по возможности использовать независимые клиенты вместо зависимых.

Вопросы лицензирования

Приложения очереди сообщений могут взаимодействовать с большим числом серверов, чем обычные сетевые приложения. Поэтому для компьютеров, использующих очередь сообщений, лицензирование в режиме «на рабочее место» может оказаться более выгодным.

Очередь сообщений подсчитывает число клиентских лицензий на Windows 2000 Server. Если таких лицензий нет, приложения очереди сообщений не смогут отправлять сообщения и открывать любые очереди. Очередь сообщений подсчитывает число таких лицензий по следующим правилам.

  • Независимый клиент, работающий под управлением Windows XP Professional, может установить одновременно не более 10 сеансов очереди сообщений и сеансов удаленного чтения с другими независимыми клиентами, работающими под управлением Windows XP Professional.
  • Зависимый клиент не подсчитывает число клиентских лицензий, но его поддерживающий сервер подсчитывает все сеансы и очереди, открытые от имени зависимого клиента. Считаются все сеансы очереди сообщений, сеансы удаленного чтения и очереди, открытые зависимыми клиентами. Число поддерживаемых зависимых клиентов ограничено числом клиентских лицензий, зарегистрированных на сервере.
  • Все сеансы, открываемые компьютером очереди сообщений, считаются только один раз. Например, если компьютер, работающий под управлением Windows XP Professional, установил сеанс очереди сообщений и сеанс удаленного чтения с компьютером, работающим под управлением Windows 2000 Server, сервер сосчитает оба сеанса как один случай использования клиентской лицензии.
  • Компьютеры, работающие под управлением Windows XP Professional, не считают сеансы связи с компьютерами, работающими под управлением Windows 2000 Server; однако компьютеры, работающие под управлением Windows 2000 Server, считают сеансы связи с компьютерами Windows XP Professional.

Дополнительные сведения о лицензиях для Windows 2000 Server см. в разделе Режимы лицензирования.

Развертывание в Интернете

Если в сети предполагается отправлять или получать сообщения через Интернет, необходимо продумать решение следующих проблем.

  • Балансировка нагрузки в сети.Для улучшения показателей масштабируемости и доступности в очередь сообщений интегрированы стандартные механизмы балансировки сетевой нагрузки, а именно NLB (Network Load Balancing — балансировка сетевой нагрузки), NAT, Cisco LocalDirector и циклическое распределение адресов DNS. Дополнительные сведения о балансировке нагрузки в веб-фермах содержатся в разделе Кластеры NLB и очередь сообщений.
  • Обмен сообщениями через сети периметра.Большинство организаций подключается к Интернету, используя прокси-сервер и сеть периметра (также называемую зоной DMZ), защищенную брандмауэрами. Прокси-сервер служит посредником между интрасетью организации и Интернетом. Он выполняет кэширование и дезинтеграцию данных. Очередь сообщений использует прокси-сервер HTTP при подключении к веб-адресам для доставки сообщений HTTP. Таким образом, очередь сообщений должна знать имя прокси-сервера и соответствующий порт, к которому ей предстоит подключиться. В то же время можно составить список веб-адресов, подключение к которым осуществляется в обход прокси-сервера. В таких случаях осуществляется попытка установления прямого соединения. Все данные, относящиеся к прокси-серверам, хранятся в реестре.


Выбор оборудования для сервера очереди сообщений

Выбор оборудования для сервера влияет на производительность сети. При выборе оборудования для серверов учтите потенциальные потребности на будущее, чтобы серверные компьютеры можно было легко модернизировать и наращивать их ресурсы. Таким образом, при увеличении числа пользователей в организации можно будет обновлять имеющееся оборудование вместо покупки новых компьютеров. Чтобы имеющееся серверное оборудование для очереди сообщений использовалось на полную мощность, примите следующие меры.

  • Увеличьте объем системной памяти на каждом сервере.
  • Обновите используемый процессор или добавьте дополнительные процессоры.
  • Увеличьте число, скорость или объем дисков.
  • Замените дисководы и наборы томов чередующимися дисковыми массивами.
  • Ограничьте число других служб, выполняющихся на компьютере, переместив несущественное программное обеспечение на другие компьютеры. Для нормальной работы дополнительных служб серверу требуется больше аппаратных ресурсов, чем обычно. При отсутствии этих дополнительных ресурсов, таких как дисковое пространство и память, сервер сможет поддерживать меньше зависимых клиентов.

Заблаговременное планирование позволяет выбрать оборудование, легко поддающееся обновлению. Если после развертывания возникнут проблемы с производительностью, можно будет обновить имеющееся оборудование вместо того, чтобы приобретать новые компьютеры или менять структуру сайта.

Выбор дисковой подсистемы

Следует обратить внимание на следующие аспекты дисковой подсистемы сервера, связанные с числом, объемом и типами дисков.

Число дисков

Поскольку система Windows 2000 и очередь сообщений могут выполнять множество дисковых операций одновременно, использование отдельных физических дисков (вместо одного диска с несколькими разделами) позволяет повысить быстродействие большинства приложений очереди сообщений. Приложения, использующие восстанавливаемые или транзактные сообщения, станут работать гораздо быстрее, так как эти сообщения постоянно записываются на диски и извлекаются оттуда.

Производительность обработки сообщений серверами очереди сообщений и независимыми клиентами можно увеличить, если хранить различные файлы службы очереди сообщений на нескольких физических дисках. Для хранения этих файлов можно использовать до трех дисков. Для повышения производительности серверов очереди сообщений разместите файлы сообщений (*.mq), файлы журнала сообщений и файлы журнала транзакций на разных физических дисках. Дополнительные сведения о хранении файлов сообщений и журналов содержатся в разделе Локальное хранилище сообщений.

Максимум производительности достигается при размещении файлов сообщений и журналов на пяти различных физических дисках:

  • Файлы сообщений
  • Файлы журнала сообщений
  • Файлы журнала транзакций
  • Файлы подкачки Windows
  • Файлы данных приложения

В случаях, когда установка пяти дисков на компьютере невозможна, наибольший прирост производительности обычно получается при установке трех дисков. Так, производительность в конфигурации из трех дисков в среднем в два-три раза выше, чем в конфигурации с одним диском. Система с пятью дисками обычно работает на 50% быстрее, чем система с тремя дисками. Если в системе только два диска, поместите файлы сообщений на один диск, а журналы сообщений и транзакций — на другой.

Для достижения наилучшей производительности транзакций разместите файлы данных и журналов приложения, используемого для обмена транзактными сообщениями, на двух или более различных дисках. Если имеется дополнительный диск, целесообразно поместить на него файл журнала диспетчера транзакций Microsoft Distributed Transaction Coordinator (DTC).

Добавление дисководов гарантирует, что доступ к диску будет минимально влиять на производительность системы обмена сообщениями. Однако если загрузка процессора близка к 100%, добавление дисководов не повысит производительность системы обмена сообщениями. Чтобы определить, нехватку каких ресурсов испытывает компьютер — в дисковой подсистеме или в процессорах, — откройте системный монитор и проследите за счетчиком % загруженности процессора (находящемся в объекте «Процессор») и за счетчиком Средняя длина очереди диска (в объекте «Физический диск»). Если установившееся значение счетчика % загруженности процессора во время отправки сообщений поднимается выше 75%, добавление ресурсов процессора может повысить производительность системы сообщений. Если значение счетчика Средняя длина очереди диска для какого-либо устройства превышает 0,6 во время отправки сообщений, производительность обмена сообщениями может повыситься в результате добавления дисков. Дополнительные сведения о наблюдении за производительностью очереди сообщений содержатся в разделе Наблюдение за производительностью.

Размер диска

Определяя минимальный размер диска для серверов, примите во внимание следующие показатели:

  • общее число сообщений, обычно хранящихся на сервере в произвольный момент времени, и общий размер этих сообщений;
  • объем дискового пространства, используемого для хранения файлов системы обмена сообщениями, а также файлов программ очереди сообщений.

Поскольку сообщения могут храниться на конечном компьютере, исходном компьютере или любом промежуточном сервере очереди сообщений, трудно бывает предугадать, сколько места потребуется для хранения сообщений. Однако если предполагается использовать серверы очереди сообщений для концентрации сеансов внутри сайта (серверы входящей и исходящей маршрутизации) или на маршрутных ссылках (шлюзы сайтов), необходимо предусмотреть на этих серверах дополнительное пространство для размещения сообщений. Кроме того, дополнительное место на дисках может понадобиться серверам, поддерживающим зависимых клиентов.

Объем дискового пространства, используемого для обработки сообщений, зависит от типа доставки сообщений (восстанавливаемые, транзактные или срочные), размера сообщений и тома, используемого для обмена сообщениями. Очередь сообщений выделяет на диске для одного сообщения не более 4 Мбайт.

Восстанавливаемые и транзактные сообщения записываются на диск 512-байтными блоками. В этих сообщениях примерно по 150 байт отводится на заголовок сообщения (в зависимости от отправленных свойств сообщения).

Поскольку срочные сообщения также записываются на диск, когда для их хранения недостаточно оперативной памяти, необходимо выделять для этого дополнительное дисковое пространство. Срочные сообщения хранятся блоками по 64 байта, поэтому если размер сообщения мал, дисковое пространство можно использовать более эффективно.

Сообщения журнала хранятся до тех пор, пока не будут удалены вручную или пока приложение очереди сообщений не прочитает журнал, поэтому необходимо также предусмотреть дополнительное место на диске для хранения сообщений журналов.

Впрочем, выбор способа доставки сообщений, как правило, зависит не от объема дискового пространства, а от текущих потребностей бизнеса. Дополнительные сведения о возможных способах доставки сообщений содержатся в разделе Доставка сообщений.

Примечания

  • Если на диске сервера очереди сообщений (или независимого клиента) закончится свободное место, он не сможет отправлять и получать сообщения, а также создавать на диске новые очереди.

Тип диска

Не все жесткие диски обладают одинаковой производительностью. Так, существуют высокопроизводительные диски, использующие аппаратные средства чередования и контроллеры дисков со сквозной записью и аккумуляторным питанием, которые откладывают операции записи до тех пор, пока они не смогут быть выполнены более эффективно. Такие диски значительно повышают производительность системы обмена сообщениями, особенно при отправке и получении восстанавливаемых и транзактных сообщений. В то время как производительность различных дисков различается в зависимости от производителя и других факторов, тома с аппаратным чередованием на трех дисках и с контроллером 2 Мбайт на аккумуляторах, в отличие от обычных дисков SCSI класса II, могут в десять раз увеличить скорость обработки сообщений.

Поскольку файловая система NTFS для Windows XP предлагает более надежное восстановление файлов после сбоя питания или аварии системы, на серверах очереди сообщений рекомендуется использовать именно ее. Установив три или более дисков формата NTFS, можно использовать поддержку RAID (Redundant Array of Independent Disks — массив независимых дисков с избыточностью), обеспечивающую отказоустойчивость в системе Windows 2000 Server.

Выбор памяти

Для достижения оптимальной производительности серверы очереди сообщений должны быть оснащены достаточными ресурсами физической оперативной памяти, чтобы избежать интенсивного использования файла подкачки Windows. Поскольку доступ к файлу подкачки происходит гораздо медленнее, чем доступ к физической памяти, увеличение объема физической памяти может значительно повысить скорость обработки сообщений. Однако общую производительность системы могут ограничивать другие аппаратные ресурсы, такие как подсистемы процессора и ввода-вывода.

Для максимального увеличения скорости обработки сообщений на компьютере должно быть достаточно памяти для хранения всех сообщений, которые могут содержаться во всех очередях в обычном режиме работы. Сообщения могут накапливаться на исходном компьютере (если конечный компьютер недоступен), на конечном компьютере (если приложение-получатель не запущено или не справляется с наплывом сообщений) или на промежуточном сервере очереди сообщений.

При расчете объема оперативной памяти, необходимого для хранения всех сообщений, необходимо понимать, из чего складывается размер сообщения. Размер сообщения представляет собой сумму размера тела сообщения и размера данных, хранящихся в заголовке сообщения. Обычно заголовки сообщений содержат примерно 150 байт данных, хотя реальный размер конкретного заголовка зависит от числа свойств, использованных приложением очереди сообщений. Следовательно, если будет отправляться 20 тыс. сообщений размером примерно в 1 Кбайт каждый со стандартными заголовками, необходимо обеспечить наличие не менее 23 Мбайт оперативной памяти (20000 1 Кбайт + 20000 150 байт), в дополнение к обычным системным требованиям.

Примечания

  • Эта рекомендация применима только в случаях, когда все сообщения действительно накапливаются на компьютере. Если сообщения обычно извлекаются (удаляются из очереди) сразу же, как только доставляются, оперативной памяти потребуется значительно меньше.

Кроме того, существуют квоты, определяющие совокупный предельный объем для всех сообщений (включая сообщения журналов) на компьютере или в отдельной очереди. Квоты для компьютера и для очередей рассчитываются исходя из размера сообщений и могут устанавливаться независимо друг от друга. Теоретический объем хранилища сообщений для серверов очереди сообщений и независимых клиентов ограничен емкостью оперативной памяти, общим объемом дискового пространства, числом сообщений, скопившихся к данному моменту на компьютере, и используемой версией службы очереди сообщений. Предельное число сообщений, которые можно хранить на компьютере с текущей версией очереди сообщений и оперативной памятью объемом не менее 512 Мбайт, составляет около 5 млн. В то же время одному сообщению может быть выделено не более 4 Мбайт памяти. Если умножить максимально допустимое число сообщений на максимальный объем области, занимаемой одним сообщением, получится, что теоретический максимум объема содержимого, которое можно сохранить на одном компьютере, может превысить 1 терабайт. Дополнительные сведения о квотах содержатся в разделе Квоты для сообщений.

Выбор процессора

Если серверная подсистема ввода-вывода работает быстро и не является единственным фактором сдерживания производительности, и если на сервере достаточно оперативной памяти, позволяющей обрабатывать сообщения без чрезмерно интенсивного использования файла подкачки Windows, установка более быстродействующего процессора может повысить производительность. На сервер очереди сообщений можно добавить дополнительные процессоры. Поддерживаются только компьютеры с процессорами Intel.

Выбор сетевой платы

Высокоскоростные сетевые платы и драйверы помогают оптимизировать быстродействие системы обмена сообщениями путем повышения пропускной способности при низкой загруженности процессора.

Так как к серверу очереди сообщений могут одновременно обращаться множество клиентов, следует установить одну или несколько высокопроизводительных сетевых плат для высокоскоростной шины, такой как PCI или EISA. Установка нескольких сетевых плат на многопроцессорном компьютере означает, что один компьютер сможет обрабатывать больше запросов от клиентов, так как каждой плате можно выделить для обслуживания отдельный сегмент сети или сетевой протокол.

Количественные аспекты

Для серверов очереди сообщений можно использовать оборудование различных категорий — от компьютеров с одним процессором Pentium до самых мощных многопроцессорных конфигураций, поддерживаемых системами Windows 2000 Advanced Server и Datacenter Server. Так, в организации, насчитывающей 10 тыс. клиентов, можно установить 100 серверов, обслуживающих по 100 пользователей каждый, или 20 серверов по 500 клиентов на каждый. Конкретное решение зависит от требований и бюджета организации.

В следующей таблице перечислены преимущества и недостатки использования большего числа менее мощных компьютеров.

Преимущества | Недостатки
Меньшая стоимость повышения производительности | Поддержка большего количества оборудования
Больше вариантов конфигурации оборудования | Небольшое увеличение числа пользователей или нагрузки требует больше оборудования
Большая близость к пользователям и соответствующее уменьшение трафика при взаимодействии клиента и сервера |

В следующей таблице перечислены преимущества и недостатки использования меньшего числа более мощных компьютеров.

Преимущества | Недостатки
Система лучше приспособлена к обновлению | Сетевые платы на каждом сервере должны обрабатывать больше трафика
Ниже требования к ресурсам хранилища |
Требуется меньше репликаций данных |


Разработка приложений очереди сообщений

Для отправки и получения сообщений с использованием очереди сообщений необходимо вначале спроектировать, разработать и установить соответствующее приложение очереди сообщений.

Поскольку данная документация предназначена для системных администраторов, занимающихся установкой и управлением инфраструктурой очереди сообщений, в ней не рассматриваются вопросы разработки приложений. В пакете Message Queuing Software Development Kit (SDK), входящем в состав Microsoft Platform SDK, приводятся сведения, необходимые разработчикам программного обеспечения для создания приложений очереди сообщений. Подробнее о пакете Message Queuing SDK см. Microsoft Platform Software Development Kit.


Развертывание очереди сообщений

В этом разделе описывается процесс развертывания службы очереди сообщений в организации средних или крупных размеров. Следует выбрать план, соответствующий конкретным потребностям.

Процесс развертывания может включать в себя следующие этапы.

  • Определение политики администрирования.
  • Проведение лабораторных испытаний.
  • Одно или несколько пробных развертываний.
  • Окончательное развертывание.

Определение политики администрирования

Политика администрирования является рабочим документом. Ее реализация может зависеть от других используемых политик. Необходимо выполнить следующие действия.

  • Установить правила управления доступом в организации.
  • Распределить административные обязанности.
  • Организовать документирование рабочего процесса.
  • Подготовиться к возможным экстренным ситуациям.
  • Составить расписание регулярного архивирования.

Также следует установить административные политики для обработки экстренных ситуаций, таких как повреждение, удаление или уничтожение сервера. Наличие плана действий в экстренной ситуации позволяет уменьшить негативные последствия.

Проведение лабораторных испытаний

Лабораторные испытания позволяют определить, насколько сильно очередь сообщений загружает серверы, а также проверить работоспособность используемых приложений очереди сообщений. Подготовка сайта и оборудования к испытанию включает следующие задачи.

  • Проверка всех компьютеров на соответствие минимальным требованиям для запуска очереди сообщений.
  • Проверка работоспособности приложений очереди сообщений.

Пробное развертывание

В результате лабораторных испытаний очередь сообщений уже готова к развертыванию в ограниченной среде. Пробное развертывание должно выполняться в небольшом масштабе, например для 15–50 пользователей. Используя данные пробной эксплуатации, перед окончательным развертыванием можно внести необходимые изменения в политику администрирования и приложения очереди сообщений. Если перед окончательным развертыванием были внесены значительные изменения, следует провести еще одно пробное развертывание.

Окончательное развертывание

После анализа результатов пробного развертывания можно приступать к полномасштабному развертыванию очереди сообщений во всей организации. План окончательного развертывания является расширением плана пробного развертывания, в который добавляются этапы документирования, составления бюджета и выполнения работ по материально-техническому обеспечению.


Установка, обновление и удаление очереди сообщений

В этом разделе описываются требования, предъявляемые при установке и обновлении программного обеспечения очереди сообщений на компьютерах, работающих под управлением Windows XP. Здесь также объясняется, как устанавливать новое программное обеспечение очереди сообщений в удаленном режиме с помощью сценария.

  • Установка очереди сообщений: обзор
  • Брандмауэр Windows и очередь сообщений
  • Установка новых клиентов очереди сообщений
  • Установка и запуск триггеров очереди сообщений
  • Автоматическая установка очереди сообщений
  • Обновление очереди сообщений
  • Удаление очереди сообщений


Установка очереди сообщений: обзор

Очередь сообщений не устанавливается по умолчанию в ходе установки Windows XP, однако во время этой процедуры на компьютер копируются все файлы, необходимые для установки очереди сообщений и всех ее компонентов. Очередь сообщений можно установить на компьютер, используя следующие способы.

  • Установите флажок Очередь сообщений и выберите необходимые компоненты очереди сообщений во время установки Windows XP. Установка очереди сообщений, инициируемая в ходе установки Windows XP, проходит в два этапа. На первом этапе, который выполняется при установке любой версии Windows XP, кроме Windows XP Home Edition, требуемые файлы программ копируются на локальный диск. На втором этапе, который выполняется после установки Windows XP и входа в систему, процесс установки очереди сообщений завершается.
  • Выберите значок Установка и удаление программ на панели управления после того, как установка Windows XP завершится. В этом случае процедура установки выполнится полностью автоматически, и окно мастера настройки сервера появляться не будет.

В обоих случаях требуемые компоненты очереди сообщений могут быть выбраны с помощью мастера компонентов Windows: установите флажок Очередь сообщений, нажмите кнопку Сведения и установите или сбросьте соответствующие флажки компонентов. Если выбрано сочетание компонентов, образующих независимый клиент, то можно будет также установить несколько дополнительных, необязательных компонентов.

Второй метод позволяет в любое время устанавливать на компьютерах новое программное обеспечение очереди сообщений. С помощью этого же метода позднее можно, используя мастер компонентов Windows, установить дополнительные компоненты или удалить любые компоненты, соблюдая некоторые ограничения (см. раздел Ограничения установки).

Когда на компьютере устанавливается очередь сообщений, по умолчанию также устанавливается диспетчер Microsoft Distributed Transaction Coordinator (DTC). Он необходим для обмена транзактными сообщениями и для создания ресурса DTC на одном виртуальном сервере в составе кластера серверов.

Поскольку файлы очереди сообщений всегда копируются на компьютер во время установки Windows Setup, даже если сама очередь сообщений при этом не устанавливается, для ее установки не требуется дополнительного места на диске.

Устанавливаемые компоненты очереди сообщений

В следующей таблице перечислены компоненты очереди сообщений, которые могут быть установлены в 32-разрядной системе Windows XP, указаны их связи с другими компонентами и их имена, включенные в файл .inf.

Название компонента | Описание и порядок установки | Зависит от | Имя в файле .inf
Очередь сообщений | родительских компонент для всех остальных компонентов | DTC | msmq
Общие | выполняет общие задачи установки: родительский компонент для компонентов «Ядро» и «Локальное хранилище» | нет | msmq_Common
Ядро | выполняет наиболее важные операции установки: создает и устанавливает разделы реестра и предоставляет функциональные возможности зависимого клиента | нет | msmq_Core
Локальное хранилище | создает и устанавливает службу сообщений и предоставляет функциональные возможности независимого клиента | Ядро | msmq_LocalStorage
Интеграция с Active Directory | создает в каталоге Active Directory объект «msmq» и (если необходимо) объект «Параметры MSMQ» и тем самым обеспечивает интеграцию с Active Directory в случаях, когда компьютер принадлежит домену | Локальное хранилище | msmq_ADIntegrated
Триггеры | устанавливает службу триггеров очереди сообщений | Локальное хранилище | msmq_TriggersService
Поддержка протокола MSMQ HTTP | создает расширение IIS для очереди сообщений (под названием MSMQ) | Локальное хранилище, IIS (служба публикации в Вебе) | msmq_HTTPSupport

Дерево компонентов очереди сообщений имеет следующий вид:

Очередь сообщений
Общие
Ядро
Локальное хранилище
Интеграция с Active Directory
Триггеры
Поддержка MSMQ HTTP

Примечания

  • На 64-разрядной платформе компоненты «Ядро» и «Локальное хранилище» объединяются в один компонент под названием «Ядро», который в данном случае обеспечивает функциональные возможности независимого клиента.

Установка по умолчанию

Если в мастере компонентов Windows на компьютере, работающем под управлением Windows XP Professional, выбрать «Очередь сообщений», то по умолчанию для установки будут выбраны следующие компоненты:

  • Ядро
  • Локальное хранилище
  • Интеграция с Active Directory
  • Триггеры

Это означает, что на компьютере, работающем под управлением Windows XP Professional, по умолчанию будет установлен независимый клиент, допускающий интеграцию с Active Directory (если компьютер принадлежит домену), а также установлена и запущена служба триггеров очереди сообщений.

Если компьютер принадлежит рабочей группе (работая на платформе Windows XP Professional или на любой из платформ Windows XP Server), по умолчанию выбирается компонент «Интеграция с Active Directory». В режиме рабочей группы присутствие этого компонента означает, что при каждом запуске службы очереди сообщений компьютеру будет предоставляться возможность присоединиться к домену и интегрироваться с Active Directory (т.е. он будет пытаться создать объект «msmq» в службе Active Directory и т.д.). Пока компьютер остается в режиме рабочей группы, объект «msmq» в Active Directory создаваться не будет; можно будет только отправлять прямые сообщения, а также создавать и удалять частные очереди.

Компьютеры, работающие на 64-разрядных платформах

На компьютере, работающем под управлением 64-разрядной системы Windows XP, не может быть установлен зависимый клиент Поэтому список компонентов очереди сообщений для 64-разрядных компьютеров можно упростить, объединив «Ядро» и «Локальное хранилище» в один компонент «Общие», и в этом случае два уровня компонентов не понадобятся. Дерево компонентов для 64-разрядных компьютеров примет следующий вид.

Очередь сообщений
Ядро
Интеграция с Active Directory
Триггеры
Поддержка MSMQ HTTP

В следующей таблице показаны отношения зависимости между компонентами на 64-разрядных компьютерах.

Имя компонента | Зависит от | Комментарии
Очередь сообщений | DTC | родительский компонент
Ядро |  |
Интеграция с Active Directory | Ядро |
Триггеры | Ядро |
Поддержка MSMQ HTTP | Ядро, IIS (служба публикации в Вебе) |

Разделы реестра

В папке HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Setup создается раздел реестра для каждого установленного компонента, и для него устанавливается значение 0x1. Оно означает, что соответствующий компонент успешно установлен на компьютере. Отсутствие какого-либо раздела означает, что данный компонент не установлен. Ниже перечислены имена этих разделов реестра.

  • msmq_Core
  • msmq_LocalStorage
  • msmq_ADIntegrated
  • msmq_TriggersService
  • msmq_HTTPSupport
  • msmq_RoutingSupport
  • msmq_MQDSService

Режим доступа

При установке очереди сообщений в конфигурации, выбираемой по умолчанию, на компьютере, входящем в рабочую группу Windows XP, будет установлен независимый клиент, работающий в режиме рабочей группы, а также установлена и запущена служба триггеров очереди сообщений. Режим рабочей группы означает, что компьютер не имеет доступа к Active Directory. Хотя в этой конфигурации также устанавливается компонент «Интеграция с Active Directory», компьютер не получит доступа к Active Directory и продолжит пребывать в режиме рабочей группы до тех пор, пока не присоединится к домену. Как только такой компьютер присоединится к домену, после очередной его перезагрузки или после перезапуска службы очереди сообщений последняя автоматически попытается обратиться к Active Directory через контроллер локального домена и создать объект «msmq».

Если очередь сообщений устанавливается на компьютере, входящем в домен Windows 2000, можно тем не менее задать, в каком режиме будет работать компьютер — в режиме домена (для этого задается установка компонента «Интеграция с Active Directory») или в режиме рабочей группы (если запретить установку компонента «Интеграция с Active Directory»). В контексте очереди сообщений любой режим работы, при котором невозможен доступ к службе каталогов, называется режимом рабочей группы, даже если соответствующий компьютер входит в состав домена . Для отправки сообщений в режиме рабочей группы необходимо иметь прямое подключение.

Если очередь сообщений устанавливается на компьютере, принадлежащем домену, и при этом выбирается установка компонента «Интеграция с Active Directory» (как в конфигурации, принимаемой по умолчанию), программа установки попытается установить связь с контроллером домена Windows 2000 в локальном или соседнем сайте. В случае успеха компьютер будет работать в режиме домена, т.е. ему будет разрешен доступ к службе Active Directory и в ней будет создан объект «msmq». В противном случае будет предложено ввести имя для контроллера домена Windows 2000 или контроллера PEC или PSC для MSMQ 1.0 (в предприятии Windows NT 4.0) в локальном сайте. Если и после этого связь с компьютером не наладится, нужно будет отменить установку и установить очередь сообщений без компонента «Интеграция с Active Directory». В таком случае очередь сообщения будет установлена в режиме рабочей группы.

Если не устанавливать компонент «Интеграция с Active Directory», компьютер будет работать в режиме рабочей группы, т.е. доступ к Active Directory будет запрещен. Режим рабочей группы можно выбрать, если контроллеры домена на данный момент недоступны или еще не установлены в организации. Однако такой компьютер никогда не предпримет попытку обратиться к службе каталогов или перейти в режим домена. И наоборот, если компьютер является членом домена и компонент «Интеграция с Active Directory» установлен, но компьютер в какой-то момент после установки временно лишится доступа к контроллеру домена, он продолжит работу в автономном режиме. Однако при очередной перезагрузке этого компьютера или перезапуске службы очереди сообщений последняя автоматически попытается обратиться к контроллеру локального домена. Если контроллер домена доступен и контакт установлен, компьютер возобновит работу в режиме домена. Дополнительные сведения о характеристиках режима рабочей группы, режима домена и автономного режима см. в разделе Топология сети.

Предварительные требования к системе

Независимо от того, выполняется ли новая установка очереди сообщений или обновление предыдущей версии, для успешной установки очереди сообщений на компьютере, работающем под управлением Windows XP, должны быть соблюдены следующие требования.

  • Необходимо войти в систему с административными разрешениями, достаточными для установки или обновления очереди сообщений на данном компьютере. Дополнительные сведения о разрешениях, необходимых для установки, содержатся в разделе Разрешения, необходимые для установки.
  • Чтобы установить или обновить очередь сообщений на компьютере, входящем в домен Windows 2000, необходимо иметь подключение к сети.
  • Прежде чем устанавливать или обновлять очередь сообщений на компьютере, входящем в домен Windows 2000 и работающем под управлением версии более ранней, чем Windows XP, необходимо установить сервер Message Queuing 2.0 на контроллере локального домена Windows 2000. Это требование не применяется в случае установки или обновления очереди сообщений на компьютере, который является членом домена Windows NT 4.0, содержащего серверы контроллеров MSMQ 1.0, такие как PEC или PSC.
  • Если контроллер домена в локальном или соседнем сайте недоступен или не существует, процесс установки можно будет продолжить при условии, что не был выбран компонент «Интеграция с Active Directory». Очередь сообщений будет установлена в режиме рабочей группы, даже если компьютер, на котором устанавливается очередь сообщений, принадлежит домену.

Ограничения установки

Для успешной установки или обновления очереди сообщений необходимо соблюдать следующие ограничения.

  • Не устанавливайте Message Queuing 2.0 одновременно на нескольких контроллерах домена Windows 2000. В Active Directory одновременное создание объектов с одинаковым именем на нескольких контроллерах домена может повлечь изменение имен этих объектов. Это может произойти из-за того, что репликация данных между контроллерами домена занимает некоторое время.
  • Не создавайте объекты очереди сообщений (такие, как «msmq») в Active Directory вручную прежде, чем очередь сообщений будет установлена или обновлена.

Кроме того, существует ряд ограничений в отношении конкретных конфигураций компонентов.

  • Зависимый клиент не может быть установлен в режиме рабочей группы. Таким образом, компонент «Ядро» нельзя устанавливать в режиме рабочей группы без компонента «Локальное хранилище».
  • После того, как очередь сообщений установлена, компонент «Локальное хранилище» нельзя добавлять или удалять.
  • После того, как компонент «Локальное хранилище» установлен, его нельзя удалять.
  • Контроллер домена, с которым независимый клиент будет пытаться связаться в ходе установки, нельзя определить заранее в ходе установки, производимой вручную. Если требуется задать контроллер домена, нужно запустить установку в автоматическом режиме и включить в раздел [msmq] строку ControllerServer.
  • Для зависимого клиента нельзя устанавливать никакие дополнительные компоненты. Если требуется добавить какой-либо компонент, сначала удалите очередь сообщений и затем установите ее заново как независимый клиент.

Наконец, определенные ограничения могут накладываться на создание очередей на компьютерах, заданных в ходе установки очереди сообщений. Дополнительные сведения содержатся в разделе Дескрипторы безопасности объектов msmq.

Совместимые платформы

В следующей таблице показано, на каких платформах Windows можно создавать компьютеры очереди сообщений тех или иных типов.

Тип компьютера очереди сообщений | Платформа Windows
Сервер очереди сообщений | семейство Windows 2000 Server
Независимый клиент | 32- и 64-разрядные платформы Windows XP Professional, кроме Windows XP Home Edition
Зависимый клиент | 32-разрядная платформа Windows XP Professional, кроме Windows XP Home Edition

Примечания

  • На компьютере, работающем под управлением Windows XP Professional, могут быть установлены только независимый клиент, компоненты «Интеграция с Active Directory», «Триггеры» и «Поддержка MSMQ HTTP».
  • На компьютере, работающем в режиме рабочей группы, и на 64-разрядном компьютере нельзя установить зависимый клиент.

Разрешения, необходимые для установки

Пользователь, устанавливающий независимый или зависимый клиент на компьютере Windows XP, должен обладать локальными административными разрешениями (или являться членом локальной группы «Администраторы»). По умолчанию, если войти в систему с использованием учетной записи, имеющей такие разрешения, это позволит в ходе установки очереди сообщений создавать в Active Directory соответствующие объекты очереди сообщений.

Дополнительные сведения об административных группах в Windows XP см. в разделе Встроенные и предварительно определяемые группы.

Если нежелательно предоставлять пользователям слишком широкие полномочия для установки очереди сообщений, можно назначить им разрешения только на создание конкретных объектов, необходимых для создания различных компьютеров очереди сообщений. В следующей таблице перечислены дочерние объекты службы Active Directory, на создание которых необходимо иметь разрешение для успешной установки очереди сообщений.

Компьютер очереди сообщений | Требуемое разрешение | Объект
Независимый клиент | Создание объектов «Настройка MSMQ» | соответствующий объект «компьютер» в оснастке «Active Directory – пользователи и компьютеры»
Зависимый клиент | нет | нет

Эти разрешения можно предоставлять конкретным пользователям или всем пользователям домена с помощью мастера делегирования управления.

Дополнительные сведения об объектах очереди сообщений и о месте их создания и хранения в Active Directory содержатся в разделе Объекты очереди сообщений в Active Directory.

Дополнительные сведения о разрешениях на доступ к объектам см. в разделе Управление доступом в очереди сообщений.

Пример использования мастера делегирования управления для предоставления разрешений см. в разделе Задание разрешений на установку MSMQ 1.0.

Примечания

  • Для установки очереди сообщений может также потребоваться разрешение на удаление объектов «Настройка MSMQ», так как если программа установки обнаружит в Active Directory объект msmq («Настройка MSMQ»), она должна будет удалить его, прежде чем сможет создать новый.
  • Для удаления очереди сообщений необходимо обладать разрешением на удаление объектов «Настройка MSMQ».

Сценарии установки

Ниже описываются некоторые возможные сценарии установки.

Неудачная попытка установки

Если попытка установить очередь сообщений по какой-то причине окажется неудачной, программа установки попытается удалить объект msmq («Настройка MSMQ») и все остальные сопутствующие объекты в Active Directory, чтобы иметь возможность установить новые в ходе повторной установки. Однако иногда возникает необходимость вручную удалить нужные объекты перед тем, как повторно запускать процесс установки. Если этого не сделать, то в Active Directory будут созданы объекты под теми же именами, что может привести к непредсказуемым результатам. Дополнительные сведения об объектах очереди сообщений и о месте их создания и хранения в Active Directory содержатся в разделе Объекты очереди сообщений в Active Directory.

Дополнительные сведения о том, как удалять объекты очереди сообщений из Active Directory, см. в разделе Удаление объектов очереди сообщений из Active Directory.

Примечания

  • Объект «MsmqServices» не следует удалять, пока очередь сообщений не будет удалена со всех компьютеров в данной организации. Этот объект очереди сообщений относится к типу «MSMQ предприятия».

Установка очереди сообщений с помощью учетной записи пользователя Windows NT 4.0

Если пользователь устанавливает очередь сообщений на компьютере Windows XP, войдя в систему с помощью учетной записи пользователя домена Windows NT 4.0, необходимо иметь по крайней мере один сервер очереди сообщений, работающий на контроллере того же домена Windows 2000, в котором производится установка. В противном случае во время установки будет предложено ввести имя основного контроллера сайта (PSC) в домене Windows NT 4.0.

Установка MSMQ 1.0 в домене Windows 2000

При установке MSMQ 1.0 на компьютере, работающем под управлением Windows NT 4.0, Windows 98 или Windows 95 в домене Windows 2000, необходимо учитывать следующее.

Когда в ходе установки будет запрошено имя основного контроллера сайта (PSC), следует ввести вместо него имя контроллера домена. На этом контроллере домена Windows 2000 должен работать сервер очереди сообщений, он должен быть настроен в качестве сервера глобального каталога и находиться в том же сайте и том же домене, где производится установка MSMQ 1.0.

Если планируется установка MSMQ 1.0 на компьютерах, работающих под управлением Windows NT 4.0 в новом домене Windows 2000, необходимо установить сервер очереди сообщений на первом контроллере этого домена. Если MSMQ 1.0 устанавливается на компьютерах, работающих под управлением Windows NT 4.0 в уже существующем домене Windows 2000, следует убедиться, что группа «Все» добавлена в группу «Пред-Windows 2000 доступ» этого домена. Для этого откройте оснастку «Active Directory – пользователи и компьютеры». В дереве консоли дважды щелкните Встроенные, щелкните правой кнопкой мыши Пред-Windows 2000 доступ, выберите команду Свойства и на странице Члены группы проверьте, есть ли в списке группа «Все». Если ее нет, нажмите кнопку Добавить и затем выберите Все.

Кроме того, у зависимых клиентов, работающих под управлением Windows NT 4.0, должен быть установлен пакет обновления 4 (SP4) для Windows NT или более поздняя версия. Это необходимо для обмена транзактными сообщениями.

Наконец, если установка производится на компьютерах, работающих под управлением Windows 98 или Windows 95, необходимо обладать разрешением на создание объектов «компьютер» в объекте-контейнере «Компьютеры» службы Active Directory, поскольку для таких компьютеров объекты «компьютер» в Active Directory изначально не существуют.

Чтобы разрешить пользователям устанавливать MSMQ 1.0 в домене Windows 2000, необходимо с помощью мастера делегирования управления предоставить соответствующие разрешения всем пользователям домена. Дополнительные сведения см. в разделе Задание разрешений на установку MSMQ 1.0.


Брандмауэр Windows и очередь сообщений

Брандмауэр Windows – это брандмауэр экспертного уровня, который отбрасывает весь незапрошенный входящий трафик, т.е. трафик, не являющийся ответом на запрос компьютера (запрошенный трафик) или разрешенным незапрошенным трафиком. Таким образом, брандмауэр Windows обеспечивает уровень защиты от злоумышленников и программ, использующих незапрошенный входной траффик для атак на компьютер.

В Windows XP и Windows XP Service Pack 1 (SP1) брандмауэр Windows по умолчанию отключен для всех подключений, пока вы не включите его сами с помощью мастера настройки сети или мастера подключения к Интернету. В Windows XP Service Pack 2 (SP2) брандмауэр Windows по умолчанию включен для всех подключений. Это означает, что по умолчанию для всех подключений компьютера, работающего под Windows XP SP2, брандмауэр Windows включен, включая подключения через ЛВС (проводные и беспроводные), коммутируемые подключения и подключения через виртуальные частные сети (VPN). Для новых подключений брандмауэр Windows также по умолчанию включен. Хотя такой способ обеспечивает более надежную защиту для компьютеров, работающих в Windows XP, он может ухудшить качество связи и повлиять на приложения, например на очередь сообщений. Чтобы устранить эту проблему, администраторы Windows XP SP2 могут задать список приложений-исключений, указав путь к программному файлу.

По умолчанию во время установки очереди сообщений или при обновлении ее в Windows XP SP2 программа установки автоматически включает очередь сообщений в список приложений-исключений для брандмауэра Windows. Для компьютеров с Windows XP SP2, подключенных к домену, можно настроить брандмауэр Windows с помощью службы каталогов Active Directory. Для Windows 2000 или Windows Server 2003 можно задать новые настройки брандмауэра в групповой политике конфигурации компьютера. Инструкции по настройке групповой политики для брандмауэра Windows см. в технической статье по установке настроек брандмауэра Windows для Microsoft® Windows® XP с Service Pack 2 на веб-странице http://go.microsoft.com/fwlink/?LinkId=24283. Политика домена преобладает над местными настройками брандмауэра Windows.

Настроить очередь сообщений для брандмауэра Windows можно также с помощью сценариев. Удалить очередь сообщений из списка приложений-исключений брандмауэра Windows можно с помощью следующей команды:

netsh firewall delete allowedprogram program=%windir%\system32\mqsvc.exe profile=all

Для включения очереди сообщений в список исключенных приложений брандмауэра Windows выполните следующую команду:

netsh firewall add allowedprogram program=%windir%\system32\mqsvc.exe name=msmq mode=enable scope=all profile=all

Для просмотра списка приложений-исключений брандмауэра Windows и отключенных приложений выполните следующую команду:

netsh firewall show allowedprogram mode=all

По умолчанию брандмауэр Windows блокирует все удаленные вызовы процедур (RPC), получаемые по сети. Чтобы использовать функции очереди сообщений в среде Distributed COM, необходимо настроить брандмауэр Windows так, чтобы он позволял получать удаленные запросы RPC на компьютере, где установлена очередь сообщений. Сделать это можно с помощью следующей команды:

netsh firewall add allowedprogram program=%windir%\system32\mqsvc.exe name=msmq mode=enable scope=all profile=all

При установке MSMQ HTTP Support автоматически устанавливается IIS (служба публикации в Интернете ) и создается расширение IIS для очереди сообщений (называемое MSMQ). Подробности о настройке IIS для брандмауэра Windows см. в документации по IIS.


Установка новых клиентов очереди сообщений

В этом разделе описана установка клиентского программного обеспечения очереди сообщений на компьютеры, не имеющие программного обеспечения MSMQ 1.0. Возможна установка независимых клиентов или зависимых клиентов. По возможности рекомендуется устанавливать независимые клиенты. Сведения об обновлении клиентского программного обеспечения MSMQ 1.0 содержатся в разделе Обновление очереди сообщений: обзор.

Чтобы на компьютере можно было установить клиентское программное обеспечение очереди сообщений, должны выполняться следующие требования.

  • Если планируется установка клиента очереди сообщений на компьютере, работающем в режиме домена, необходимо установить сетевое подключение и иметь возможность связаться с контроллером домена Windows 2000 в локальном или соседнем сайте (или с контроллером PEC или PSC службы MSMQ 1.0 в локальном сайте).
  • Необходимо войти в систему с разрешениями локального администратора (в качестве члена локальной группы «Администраторы»).
  • Для установки очереди сообщений может также потребоваться разрешение на удаление объектов «Настройка MSMQ», потому что если программа установки обнаружит в Active Directory объект msmq («Настройка MSMQ»), она должна будет удалить его, чтобы можно было создать новый объект.
  • Для удаления очереди сообщений пользователь должен обладать разрешением на удаление объектов «Настройка MSMQ».

Дополнительные сведения о разрешениях, необходимых для установки, содержатся в разделе Разрешения, необходимые для установки.

Установка независимого клиента

Программное обеспечение независимого клиента можно установить на компьютере, работающем под управлением Windows XP Professional, но не на компьютере, работающем под управлением Windows XP Home Edition.

Программа установки автоматически пытается найти контроллер домена Windows 2000 в том же или соседнем сайте. Если найти его не удается, нужно будет, получив соответствующий запрос, ввести DNS-имя или NetBIOS-имя такого контроллера домена или контроллера PEC или PSC службы MSMQ 1.0. Если с указанным компьютером связаться не удастся, можно отменить процесс установки и затем инициировать его заново, установив очередь сообщений без доступа к Active Directory, — для этого достаточно сбросить флажок Интеграция с Active Directory. В контексте очереди сообщений любой режим работы с запретом доступа к службе каталогов называется режимом рабочей группы, даже если соответствующий компьютер входит в состав домена . В этом режиме для отправки сообщений необходима установка прямого подключения. Дополнительные сведения об установке очереди сообщений без доступа к Active Directory см. в разделе Режим доступа.

Можно также задать установку независимого клиента в среде рабочей группы (или любой другой среде, не поддерживающей службу каталогов, такую как Active Directory). В этом случае для отправки сообщений также понадобится прямое подключение.

Дополнительные сведения об установке независимого клиента в условиях, когда все требования соблюдены, см. в разделе Установка независимых клиентов.

Установка зависимого клиента

Программное обеспечение зависимого клиента можно устанавливать на компьютерах, работающих под управлением 32-разрядной системы Windows XP Professional, но не на 64-разрядных компьютерах и не на компьютерах, работающих в режиме рабочей группы.

Сервер очереди сообщений, который поддерживает зависимого клиента (размещая у себя его очереди и сообщения), называется поддерживающим сервером. Его роль может играть любой сервер очереди сообщений, работающий в режиме домена и обладающий по крайней мере функциональными возможностями независимого клиента. Программа установки пытается автоматически обнаружить такой сервер очереди сообщений в том же сайте или соседнем сайте. Если такой сервер не удается найти, будет выдано сообщение о том, что сервер недоступен. В таком случае можно вручную задать сервер очереди сообщений или нажать кнопку Отмена. Если нажать кнопку Отмена, установка также будет успешно завершена. Эта возможность позволяет установить зависимый клиент до установки его поддерживающего сервера очереди сообщений.

Если на роль поддерживающего сервера требуется назначить контроллер домена Windows 2000, необходимо изменить настройку параметров безопасности диспетчера транзакций Microsoft Distributed Transaction Coordinator (DTC). Дополнительные сведения об этом см. в разделе Установка зависимых клиентов.

Зависимые клиенты не обязательно должны располагаться в одном сайте со своим поддерживающим сервером. Но поскольку связь с зависимыми клиентами осуществляется через поддерживающий сервер очереди сообщений, то если этот канал связи клиента с сервера окажется медленным или дорогим, то и связь со всеми клиентами также будут медленной или дорогой.

Дополнительные сведения об установке зависимого клиента в условиях, когда все требования соблюдены, см. в разделе Установка зависимых клиентов.

Примечания

  • Если для зависимого клиента MSMQ 1.0, работающего под управлением Windows NT 4.0, требуется заменить поддерживающий сервер на сервер очереди сообщений, работающий под управлением Windows 2000, на компьютере зависимого клиента должен быть установлен пакет обновления 4 для Windows NT или более поздняя версия, иначе не будет действовать обмен транзактными сообщениями.


Установка и запуск триггеров очереди сообщений

Триггеры очереди сообщений являются неотъемлемой частью очереди сообщений. Их можно установить в ходе настройки очереди сообщений, выбрав подкомпонент «Триггеры». Триггеры и правила определяются и управляются с помощью оснастки «Управление компьютером». Диагностические данные службы триггеров очереди сообщений записываются в Журнал приложений и их можно просмотреть в окне просмотра событий.

Установка

Поддержка триггеров очереди сообщений может быть установлена в составе очереди сообщений в ходе установки независимого клиента на компьютеры, работающие под управлением Windows XP Professional. Триггеры очереди сообщений нельзя установить на зависимого клиента.

Для установки триггеров очереди сообщений выберите подкомпонент «Триггеры» очереди сообщений в ходе установки сервера очереди сообщений на независимого клиента. Если флажок для данного подкомпонента установлен, служба триггеров устанавливается и запускается автоматически. Если данный флажок не установлен, службу триггеров можно будет установить позднее, открыв объект Установка и удаление программ и установив флажок Триггеры в Мастере компонентов Windows.

Файл ответов для автоматической установки может содержать запись msmq_TriggersService = ON, соответствующую флажку Триггеры страницы Очередь сообщений Мастера компонентов Windows.

Программе установки для службы триггеров требуется пять файлов в папке \Windows\System32 folder: mqtrig.dll, mqtrig.tlb, mqtgsvc.exe, mqgentr.dll и mqtgclus.dll.

По умолчанию служба «Триггеры очереди сообщений» использует учетную запись «Локальный компьютер». Кроме того, она может использовать учетную запись администратора домена. Служба считывает и записывает параметры реестра и, по умолчанию, каждый пользователь домена обладает соответствующими правами. Учетная запись пользователя должна иметь доступ к очереди с которой связаны триггеры. В частности, учетная запись должна обладать разрешениями «Вход в качестве службы» и «Просмотр сообщения» для всех соответствующих очередей. Если типом обработки сообщений триггера является «извлечение» или «транзактное тизвлечение», пользователь должен обладать разрешением «Получение сообщения» для данной очереди. При изменении настроек безопасности очереди для включения триггера, осуществляющего наблюдение за очередью, необходимо остановить а затем возобновить работу триггеров, чтобы обновить конфигурацию службы перед началом работы триггера. Инструкции по заданию разрешений для объектов очереди сообщений содержатся в разделе Задание разрешений для объектов компьютеров и очередей.

Триггеры очереди сообщений устанавливаются с набором используемых по умолчанию значений конфигурации, которые хранятся в реестре. Эти значения можно изменить с помощью оснастки «Управление компьютером». Дополнительные сведения об изменении используемых по умолчанию значений конфигурации содержатся в разделе Изменение используемых по умолчанию значений конфигурации триггеров.

Создание триггеров

Для создания триггеров на локальном компьютере в папке «Триггеры очереди сообщений» в дереве консоли оснастки «Управление компьютером» или в любой очереди триггера щелкните правой кнопкой мыши элемент Триггеры, а затем выберите команды Создать и Триггер. В этом случае выбранная очередь автоматически становится очередью триггера. На первой странице диалогового окнаНовый триггер введите имя нового триггера в поле Имя триггера. Очередь триггера может быть пользовательской очередью, зарегистрированной в Active Directory, путь к которой указывается в поле Путь очереди или одной из автоматически созданных очередей на локальном компьютере, выбираемых при нажатии соответствующей кнопки. Независимо от места создания триггера каждый триггер, созданный на локальном компьютере, отображается в оснастке «Управление компьютером» в разделе Триггеры и в соответствующей очереди триггера. Затем выберите тип обработки сообщения и укажите, будет ли триггер включен и является ли он последовательным. Дополнительные сведения о типах обработки сообщений, а также включенных и последовательных триггерах содержатся в разделе Триггеры очереди сообщений .

Можно добавить существующее правило к новому триггеру, нажав кнопку Существующие правила на второй странице диалогового окна Новый триггер. Затем из Списка правил диалогового окна Существующие правила следует выбрать существующее правило или несколько правил для добавления к триггеру, а затем связать их с триггером, нажав кнопку Вложить. Порядок испытания правил (приоритет) можно изменить с помощью кнопок Вверх и Вниз. Дополнительные сведения о создании триггеров содержатся в разделе Создание триггеров.

Перед созданием триггера следует убедиться, что учетная запись, с использованием которой запущена служба «Триггеры очереди сообщений», имеет разрешение «Просмотр сообщения» для всех существующих очередей, которые будут связаны с триггерами. Дополнительные сведения содержатся в разделе Задание разрешений для объектов компьютеров и очередей.

Правила управления для триггеров

Все правила, созданные на локальном компьютере, отображаются в оснастке «Управление компьютером». Одному триггеру можно добавить несколько правил. В этом случае правила выполняются в порядке их отображения в списке Присоединенные правила на второй странице диалогового окна Новый триггер или на странице Присоединенные правила диалогового окна Свойстватриггера. Можно изменять приоритет (порядок выполнения) правил в списке, выбирая правило и нажимая соответствующую кнопку. Правила, отображаемые в диалоговом окне Существующие правила, по умолчанию отключены. Чтобы использовать правило с триггером его необходимо добавить к соответствующему триггеру. Дополнительные сведения содержатся в разделе Просмотр и изменение свойств триггеров и правил для триггеров.

Правило формируется из одного или нескольких условий и выполняется если условия верны. Каждое условие применяется к каждому сообщению, прибывающему в очередь триггера, при этом возможно два результата: «истина» и «ложь». Несколько условий должны иметь значение «истина» чтобы действие могло быть выполнено. Если не определено ни одного условия, всегда будет возвращаться значение «истина». Это полезно, если требуется чтобы триггер безусловно действовал каждый раз при поступлении сообщения в очередь триггера. Условия, применяемые к определенному правилу, указываются в Списке условий на странице Условия диалогового окна Свойства данного правила. Новые правила формируются при выборе поддерживаемой начальной строки в списке Новое условие и указании заключительной строки в расположенном ниже поле. Список этих условий приведен в следующей таблице.

Условие | Описание
Метка сообщения содержит/не содержит | Проверяет, содержит ли метка прибывшего сообщения указанную строку. Эта строка чувствительна к регистру.
Сообщение содержит/не содержит | Данное условие применимо только к сообщениям строкового типа. В противном случае условие всегда будет неверно.
Приоритет сообщения равен/не равен/больше чем/меньше чем | Проверяет, удовлетворяет ли заданному математическому выражению приоритет прибывшего сообщения.
Номер сообщения, определяемый приложением (AppSpecific) равен/не равен/больше чем/меньше чем | Проверяет, удовлетворяет ли заданному математическому выражению номер сообщения, определяемый приложением.
Код компьютера источника сообщения (SourceMachineGuid) равен/не равен | Проверяет, удовлетворяет ли заданному значению код GUID компьютера источника сообщения.

Действия, выполняемые если условие или набор условий имеют значение «истина», выражаются либо в форме отдельного исполняемого файла и параметров (аргументов) или в форме компонента COM , метода и параметров. Можно указать один или несколько аргументов, выполняемых за действие.

Поддерживаются следующие параметры:

  • Код сообщения (как variant)
  • Метка сообщения (как строка)
  • Основной текст сообщения (как variant)
  • Основной текст сообщения (как строка)
  • Приоритет сообщения (как число)
  • Время отправки сообщения (как date variant)
  • Время прибытия сообщения (как date variant)
  • Код корреляции сообщения (как variant)
  • Код подстановки сообщения (как variant)
  • Путь очереди (как строка)
  • Имя формата очереди (как строка)
  • Имя формата очереди ответов (как строка)
  • Имя формата очереди администрирования (как строка)
  • Номер сообщения, определяемый приложением (AppSpecific как дл. целое)
  • Имя триггера (как строка)
  • Код триггера (как строка)
  • Код компьютера источника сообщения (SourceMachineGuid как строка)
  • Строковый литерал
  • Численный литерал

Эти параметры перечислены в списке в группе Параметр диалогового окна Параметры вызова, доступ к которому можно получить, нажав кнопку Параметры на третьей странице диалогового окна Новое правило, а также на странице Действие диалогового окна Свойства конкретного правила. Если правило вызывает компонент COM, следует убедиться, что он может быть успешно вызван из контекста безопасности с помощью службы триггеров, правильно зарегистрирован и имеет соответствующие зависимости.

Триггеры и правила создаются и изменяются динамической библиотекой mqtrig.dll, однако служба реализуется исполняемым файлом mqtgsvc.exe. Следовательно, сведения о состоянии любого нового или измененного триггера или правила должны вноситься перед запуском службы. Это осуществляется при помощи отправки сообщения уведомления во внутреннюю частную очередь msmqtriggersnotifications. Служба читает каждое сообщение, отправленное в эту очередь, соответствующим образом обновляет его внутренние данные, после чего удаляет сообщение.

Дополнительные сведения о создании правил содержатся в разделе Создание и подключение правил для триггеров.

Изменение используемых по умолчанию значений конфигурации

Служба триггеров очереди сообщений имеет набор используемых по умолчанию значений конфигурации. После установки службы эти значения можно изменить с помощью оснастки «Управление компьютером».

Сведения о конфигурации, а также описания триггеров и правил хранятся в реестре локального компьютера.

Любые из следующих настроек конфигурации можно изменить.

  • Начальное число потоков - по умолчанию используется значение 5.
  • Наибольшее число потоков - по умолчанию используется значение 20.
  • Размер текста основного сообщения по умолчанию - по умолчанию используется значение 2048. Данный параметр задает размер буфера, который триггеры очереди сообщений выделяют для входящего сообщения. Значение данного параметра должно равняться размеру буфера, позволяющему разместить 90% всех сообщений, которые должны прибыть в очередь триггера. Если значение слишком мало, служба будет перераспределять буфер для каждого прибывающего сообщения большего размера. Слишком большое значение приведет к чрезмерному использованию системных ресурсов.

При изменении настроек конфигурации необходимо остановить и перезапустить службу чтобы изменения вступили в силу. Дополнительные сведения об изменении настроек конфигурации содержатся в разделе Изменение используемых по умолчанию значений конфигурации триггеров.


Автоматическая установка очереди сообщений

С помощью процедуры автоматической установки Windows можно установить программное обеспечение очереди сообщений, используя файл ответов в удаленном режиме. Этот файл должен быть размещен либо в папке установки очереди сообщений на исходном компьютере, с которого запускается автоматическая установка, либо в системной папке Windows (обычно это папка C:\Windows) на конечном компьютере, на котором устанавливается очередь сообщений.

В ходе автоматической установки очереди сообщений не отображается никаких сообщений и не открывается никаких окон. Ошибки записываются в файл Msmqinst.log, расположенный в системной папке Windows (обычно C:\Windows) конечного компьютера.

Поскольку в некоторых вариантах установки требуется задавать имя подключенного сервера очереди сообщений, проще всего создать и запускать отдельные сценарии автоматической установки для компьютеров каждого сайта Windows 2000. Один файл сценария можно использовать для установки в нескольких сайтах, но при этом необходимо создать в этом файле отдельные записи для каждого компьютера, не входящего в указанный (используемый по умолчанию) сайт.

Чтобы запустить автоматическую установку очереди сообщений, введите в командной строке в системной папке Windows следующую команду:

sysocmgr.exe /i:sysoc.inf /u:путь и имя файла ответов

Записи файла ответов

В файле ответов задаются различные параметры установки. Ниже описываются параметры, относящиеся к очереди сообщений.

Программа установки просматривает раздел [Components] (Компоненты), чтобы определить, что следует делать с каждым из компонентов очереди сообщений. Значение ON в записи этого раздела означает, что компонент должен быть установлен, а OFF — удален; отсутствие же записи означает, что состояние компонента не изменится. В строках этого раздела используются следующие параметры.

msmq_Core

Запись msmq_Core = ON задает установку компонента «Ядро», который выполняет наиболее фундаментальные подготовительные задачи: создает и устанавливает разделы реестра, а также обеспечивает функциональные возможности зависимого клиента. Это компонент обязателен для установки очереди сообщений. Для установки зависимого клиента необходимо задать поддерживающий сервер. Им может быть любой сервер очереди сообщений, работающий в режиме домена и обладающий функциональными возможностями по крайней мере независимого клиента, желательно в локальном сайте, но можно и в соседнем. Задайте его имя, используя параметр SupportingServer в разделе [msmq]. Никакие другие компоненты для зависимого клиента установлены быть не могут. Чтобы выполнить автоматическое удаление программного обеспечения очереди сообщений, включите в файл запись msmq_Core = OFF. В результате будут удалены все файлы сообщений и журналов. Однако из папок \Windows\System32 и \Windows\System32\Drivers никакие файлы очереди сообщений не удаляются.

msmq_LocalStorage

Запись msmq_LocalStorage = ON задает установку компонента «Локальное хранилище», который устанавливает службу очереди сообщений и обеспечивает функциональные возможности независимого клиента. Эта запись является обязательной, если одновременно устанавливаются еще какие-то компоненты. «Локальное хранилище» нельзя установить без компонента «Ядро». Поэтому, если устанавливается «Локальное хранилище», можно не включать запись msmq_Core = ON: «Ядро» будет установлено автоматически. После того, как компонент «Локальное хранилище» установлен, его нельзя удалять, только если при этом не удаляется вся очередь сообщений.

msmq_ADIntegrated

Запись msmq_ADIntegrated = ON задает установку компонента «Интеграция с Active Directory», который создает в Active Directory объект «msmq» и (если необходимо) объект «Параметры MSMQ», тем самым обеспечивая интеграцию с Active Directory для компьютеров, принадлежащих доменам. Если нужно использовать конкретный контроллер домена, его следует задать с помощью параметра ControllerServer в разделе [msmq]. Компонент «Интеграция с Active Directory» не может быть установлен без компонентов «Ядро» и «Локальное хранилище». Поэтому, если устанавливается компонент «Интеграция с Active Directory», то включать записи msmq_Core = ON и msmq_LocalStorage = ON необязательно. Эти компоненты будут установлены автоматически.

Если очередь сообщений устанавливается в среде рабочей группы или любой другой среде, в которой нет доступа к Active Directory, можно включить запись msmq_ADIntegrated = ON. В этом случае параметр ControllerServer игнорируется, и компьютер никогда не предпримет попытки подключиться к контроллеру домена для доступа к Active Directory. Для отправки и получения сообщений таким компьютером требуется его прямое подключение к другим компьютерам. Данная запись действует только при установке системы с функциями независимого клиента на компьютере, не являющемся контроллером домена.

msmq_TriggersService

Данный параметр задает установку службы триггеров очереди сообщений. Если включить в файл запись msmq_TriggersService = ON, служба устанавливается. Если включить запись msmq_TriggersService = OFF, служба удаляется. Установка для этого параметра значения ON равносильна выбору компонента «Триггеры» во время установки очереди сообщений с функциями независимого клиента. Поэтому если устанавливается компонент «Триггеры», то нет необходимости включать записи msmq_Core = ON и msmq_LocalStorage = ON. Эти компоненты будут установлены автоматически.

msmq_HTTPSupport

Данный параметр задает установку компонента «Поддержка MSMQ HTTP», который устанавливает информационные службы Интернета (IIS) и создает расширение IIS для службы очереди сообщений (MSMQ). Если в файл ответов включена запись msmq_HTTPSupport = ON, расширение IIS будет создано. Если включить запись msmq_HTTPSupport = OFF, это расширение будет удалено. «Поддержка MSMQ HTTP» не может быть установлена без компонентов «Ядро» и «Локальное хранилище». Поэтому если устанавливается «Поддержка MSMQ HTTP», то записи msmq_Core = ON и msmq_LocalStorage = ON можно не включать. Соответствующие компоненты будут установлены автоматически.

В строках раздела [msmq] используются следующие параметры.

ControllerServer

В качестве значения этого параметра устанавливается NetBIOS-имя или DNS-имя контроллера домена Windows XP или Windows 2000, с которым должен связаться независимый клиент или сервер маршрутизации, устанавливаемый на компьютере домена в указанном сайте, при условии, что значение msmq_ADIntegrated равно ON. Эту запись иногда можно не задавать. Программа установки попытается автоматически найти подходящий контроллер домена в списке AD.lib. Однако если это ей не удастся, автоматическая установка не сможет продолжиться. Если запись в файле задана, процедура автоматической установки воспользуется ее значением и не будет пытаться искать компьютер самостоятельно.

Не включайте в файл запись с этим параметром, если очередь сообщений устанавливается на контроллере домена.

SupportingServer

В качестве значения этого параметра устанавливается NetBIOS-имя или DNS-имя сервера очереди сообщений, который будет использоваться для обслуживания устанавливаемого зависимого клиента. Данная запись необходима в случае, когда создается зависимый клиент.

ServerAuthenticationOnly

В качестве значения этого параметра устанавливается TRUE или FALSE (по умолчанию FALSE). Запись ServerAuthenticationOnly = TRUE следует включать только для клиентов, которые будут взаимодействовать с серверами контроллеров MSMQ 1.0, работающими под управлением Windows NT 4.0, и которым понадобится проверять подлинность этих серверов. Данный параметр не действует, когда очередь сообщений устанавливается на контроллере домена.

Site

Строка с этим параметром должна быть включена в файл при установке сервера маршрутизации очереди сообщений. Программа установки может не суметь автоматически найти нужный сайт, если конфигурация подсетей в сети настроена неправильно. В таком случае данная запись становится обязательной. Задайте в ней имя используемого по умолчанию сайта Active Directory, содержащего контроллер домена, с которым данный сервер будет взаимодействовать.

Пример файла ответов

В качестве шаблона можно использовать следующий файл ответов. Внесите в него необходимые изменения, воспользовавшись текстовым редактором.

Примечания

  • При автоматической установке не учитываются записи, начинающиеся с точки с запятой (;). Таким способом можно добавлять в файл ответов комментарии.

  [Version]
  Signature = "$Windows NT$"

  [Global]
  FreshMode = Custom
  MaintenanceMode = RemoveAll
  UpgradeMode =  UpgradeOnly

  [Components]
  msmq_Core = ON | OFF
  msmq_LocalStorage = ON | OFF
  msmq_ADIntegrated = ON | OFF
  msmq_TriggersService = ON | OFF
  msmq_HTTPSupport = ON | OFF

  [Msmq]
  ControllerServer = используемый_контроллер_домена
  SupportingServer = используемый_контроллер_домена_или_сервер_маршрутизации
  ServerAuthenticationOnly = FALSE | TRUE
  Site = имя_первого_сайта_по_умолчанию

Перед использованием сценария автоматической установки его следует протестировать.


Обновление очереди сообщений

В данном разделе описываются требования, предъявляемые при обновлении предыдущих версий программного обеспечения очереди сообщений (MSMQ 1.0 и 2.0) на компьютерах, которые обновляются до операционной системы Windows XP из предыдущих версий Windows.

  • Обновление очереди сообщений: обзор
  • Требования и указания по обновлению очереди сообщений
  • Обновление компьютеров MSMQ 1.0


Обновление очереди сообщений: обзор

В этом разделе дается обзор обновления службы MSMQ 1.0, работающей на платформах Windows NT 4.0, Windows 98 и Windows 95, а также службы Message Queuing 2.0, работающей в Windows 2000, до версии Message Queuing 3.0.

Программное обеспечение очереди сообщений на всех компьютерах Windows 95, Windows 98 и Windows NT 4.0, за исключением серверов контроллера MSMQ 1.0, и на клиентах Windows 2000 и Windows Me автоматически обновляется во время установки Windows XP. Основной контроллер предприятия (PEC) и основные контроллеры сайтов (PSC) в MSMQ 1.0 обновляются с помощью мастера обновления очереди сообщений, который автоматически запускается после завершения установки Windows 2000 Server с помощью мастера настройки сервера.

Важно!

  • Прежде чем пользоваться услугами мастера обновления очереди сообщений, следует сначала ознакомиться с предварительными требованиями и другими аспектами процедуры обновления. В частности, необходимо сначала прочитать раздел Требования и указания по обновлению очереди сообщений и затем раздел Использование мастера обновления очереди сообщений.

Служба Message Queuing 3.0, как и Message Queuing 2.0, совместима с MSMQ 1.0. Если после обновления PEC в домене одновременно работают серверы контроллеров MSMQ 1.0 и более новые версии серверного программного обеспечения, такой режим работы называется смешанным. Процесс обновления всех серверов контроллеров MSMQ 1.0 (PEC, PSC и резервных контроллеров сайтов BSC) в организации до уровня серверов очереди сообщений называется миграцией.

Для некоторых элементов MSMQ 1.0 имеются аналоги в Message Queuing 2.0 и 3.0, но под другими именами. Эти элементы, с указанием эквивалентных элементов в текущей версии очереди сообщений, перечислены в следующей таблице.

Версия для Windows NT 4.0 | Текущая версия | Пояснения
Microsoft Message Queue Server (MSMQ) или MSMQ 1.0 | Message Queuing 3.0 | Message Queuing 3.0 в материалах других фирм и других внешних источниках может фигурировать под названием MSMQ 3.0.
Предприятие MSMQ | Лес Windows 2000 | В один лес Windows 2000 нельзя перенести более одного предприятия MSMQ 1.0.
Сайт MSMQ | сайт Windows 2000 | Сайтов, относящихся именно к MSMQ, больше не существует.
Связь сайтов MSMQ | Маршрутная ссылка | Маршрутная ссылка определяет маршрут для связи между двумя сайтами.
MQIS | Active Directory | Очередь сообщений отныне полностью интегрирована вместе с Active Directory.
Связанная сеть | нет | Связанные сети больше не используются.
Инородная связанная сеть | Инородный сайт | В Windows 2000 инородная связанная сеть обновляется до уровня инородного сайта.
Сервер контроллера MSMQ (или MQIS) | Сервер очереди сообщений с включенной маршрутизацией, или сервер маршрутизации | В число серверов контроллеров MSMQ, предлагавших услуги маршрутизации и доступа к каталогу, входили основной контроллер предприятия (PEC), основные контроллеры сайтов (PSC) и резервные контроллеры сайтов (BSC). Чтобы обеспечить поддержку служб каталогов для объектов очереди сообщений на компьютерах, использующих MSMQ 1.0 и 2.0, необходимо, чтобы сервер очереди сообщений работал на контроллере домене Windows 2000.
Сервер маршрутизации MSMQ | Сервер очереди сообщений с включенной маршрутизацией, или сервер маршрутизации | Серверы маршрутизации могут быть настроены как серверы входящей маршрутизации или серверы исходящей маршрутизации, а также как шлюзы сайтов.
Независимый клиент MSMQ (работающий на платформе Windows NT 4.0 Server) | Сервер очереди сообщений без включенной маршрутизации | Сервер очереди сообщений без включенной маршрутизации на контроллере, не принадлежащем домену, обладает теми же функциями, что и независимый клиент MSMQ на платформе Windows NT 4.0 Server.
Независимый клиент MSMQ (на платформе Windows NT 4.0 Workstation, Windows 95 или Windows 98) | Независимый клиент | На компьютерах, работающих под управлением Windows XP Professional, возможна установка только независимых клиентов.
Зависимый клиент MSMQ | Зависимый клиент | Для зависимых клиентов недоступны новые возможности, появившиеся в текущей версии: транспорт HTTP, триггеры очереди сообщений и отправка сообщений нескольким адресатам.
MSMQ Explorer | Оснастка консоли управления Microsoft Management Console (MMC) | Для администрирования очереди сообщений используются оснастки «Управление компьютером», «Active Directory – Пользователи и компьютеры» и «Active Directory – Сайты и службы».

Дополнительные сведения о терминах и понятиях, используемых в MSMQ 1.0, содержатся в руководстве администратора сервера очереди сообщений Microsoft.

Примечание.

  • Информацию по выбору брандмауэра Windows для очереди сообщений см. в разделе Брандмауэр Windows и очередь сообщений.


Требования и указания по обновлению очереди сообщений

В данном разделе перечисляются предварительные требования и рассматриваются другие аспекты, которые следует принимать во внимание при обновлении службы MSMQ 1.0, работающей под управлением Windows NT 4.0, Windows 98 или Windows 95, или службы Message Queuing 2.0, работающей под управлением Windows 2000.

Программное обеспечение очереди сообщений на всех компьютерах Windows 95, Windows 98 и Windows NT 4.0, за исключением серверов контроллеров MSMQ 1.0, а также на компьютерах клиентов Windows 2000 и Windows Me обновляется автоматически во время установки Windows XP.

Обновление компонентов

При любом обновлении программа установки пытается воспроизвести набор функциональных возможностей очереди сообщений исходного компьютера, устанавливая соответствующие компоненты. В следующей таблице перечислены компоненты очереди сообщений, которые устанавливаются автоматически при обновлении компьютеров Windows NT 4.0 и Windows 2000 до уровня Windows XP Professional:

Имя компонента | Описание | Типы компьютеров, на которых компонент устанавливается при обновлении Windows NT 4.0 | Типы компьютеров, на которых компонент устанавливается при обновлении Windows 2000
Ядро | выполняет наиболее важные операции установки: создает и устанавливает разделы реестра и предоставляет функциональные возможности зависимого клиента | любой компьютер с установленной службой MSMQ 1.0 | любой компьютер с установленной службой Message Queuing 2.0
Локальное хранилище | устанавливает службу очереди сообщений и предоставляет функциональные возможности независимого клиента | любой независимый клиент MSMQ 1.0 | любой независимый клиент Message Queuing 2.0
Интеграция с Active Directory | создает в каталоге Active Directory объект «msmq» и (если необходимо) объект «Параметры MSMQ» и тем самым обеспечивает интеграцию с Active Directory в случаях, когда компьютер принадлежит домену | любой компьютер с установленной службой MSMQ 1.0 | любой компьютер, на котором параметр реестра AlwaysWithoutDS равен 0 или не существует
Триггеры | устанавливает службу триггеров очереди сообщений | нет | нет
Поддержка протокола MSMQ HTTP | создает расширение IIS для очереди сообщений (MSMQ) | нет | нет

Примечания

  • Программное обеспечение очереди сообщений не обновляется при обновлении до Windows XP Home Edition.
  • Параметр AlwaysWithoutDS хранится в разделе реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters\Setup.
  • Дополнительный модуль «Триггеры очереди сообщений» во время обновления не удаляется. Его можно удалить после обновления, а затем установить компонент «Триггеры» с помощью функции Установка и удаление программ, выбрав Триггеры в окне мастера компонентов Windows.

После обновления до Windows XP можно удалить отдельные компоненты и установить другие, воспользовавшись функцией Установка и удаление программ и сбросив или установив флажки соответствующих компонентов в окне мастера компонентов Windows. Дополнительные сведения о компонентах очереди сообщений см. в разделе Устанавливаемые компоненты очереди сообщений.

Ограничения обновления

Помимо ограничений на установку, обсуждавшихся в обзорном разделе, необходимо учитывать следующие дополнительные ограничения.

  • Нельзя создавать сайты MSMQ, если в каком-либо узле леса работает сервер очереди сообщений.
  • Нельзя создавать стандартные связанные сети, если в каком-либо узле леса работает сервер очереди сообщений. Тем не менее остается возможность создания инородных связанных сетей.

Использование службы каталогов

В MSMQ 1.0 использовалась так называемая база данных MQIS, создаваемая на основе Microsoft SQL Server; в ней хранились данные о конфигурации компьютеров, очередей и пользователей MSMQ. В каждом сервере контроллера MSMQ 1.0 имелась своя копия базы данных MQIS, которая полностью реплицировалась по всем серверам контроллеров с помощью специального алгоритма.

Теперь очередь сообщений хранит конфигурационные данные в службе каталогов Active Directory и не может пользоваться базой данных MQIS. При обновлении сервера контроллера MSMQ 1.0 содержимое базы данных MQIS автоматически преобразуется и записывается в Active Directory.

В среде смешанного режима, где остается по крайней мере один сервер контроллера MSMQ 1.0 и имеется по крайней мере один контроллер домена Windows 2000, настроенный в качестве сервера глобального каталога и содержащий сервер очереди сообщений, репликация данных производится в обоих направлениях между серверами контроллеров MSMQ 1.0 и серверами очереди сообщений, независимо от того, где было инициировано изменение конфигурации.

Мастер восстановления MSMQ MQIS (входящий в Windows NT, пакет обновления 4) позволяет восстановить базу данных MQIS для сервера контроллера MSMQ 1.0, на котором произошел сбой. Базу данных MQIS можно восстановить только с другого контроллера PSC или с контроллера BSC в сайте, в котором имеется PSC. Базу данных MQIS нельзя восстановить с обновленного сервера контроллера MSMQ 1.0 (уже использующего Active Directory). При работе в среде смешанного режима рекомендуется создать по крайней мере два сервера контроллеров, каждый из которых мог бы служить источником для восстановления базы данных на другом сервере. Если это уже невозможно, следует обновить все оставшиеся контроллеры PSC.

Администрирование очереди сообщений теперь осуществляется с помощью оснасток консоли управления Microsoft (MMC). Однако контроллер PSC службы MSMQ 1.0, остающийся в среде смешанного режима, будет сам производить все изменения в принадлежащих ему объектах, независимо от того, кем эти изменения инициированы. Так, если объект сайта MSMQ 1.0 создан или изменен с помощью оснасток MMC, нужно будет, чтобы эти изменения выполнил контроллер PSC службы MSMQ 1.0, являющийся владельцем объекта. Это означает, что соответствующий PSC должен быть подключен к сети в момент попытки изменить объект в какой-либо оснастке, если клиентский компьютер, использующий эту оснастку, поддерживает связь с контроллером домена Windows 2000 или другим сервером MQIS в Windows NT 4.0. Изменения затем реплицируются по всему лесу Windows 2000.

Связанные сети

MSMQ 1.0 использует концепцию связанных сетей, в которых любые два компьютера могут взаимодействовать непосредственно. Прогресс в области сетей связи, появление виртуальных частных сетей и широкое распространение протоколов Интернета способствуют моральному старению связанных сетей. Поэтому очередь сообщений больше не поддерживает связанные сети.

Если в организации не установлены прямые подключения между всеми клиентскими компьютерами и раньше в ней использовались связанные сети, то в процессе миграции и по его окончании может возникнуть необходимость в настройке конфигурации сети. Определение маршрутных ссылок между сайтами предоставляет те же возможности для взаимодействия, что ранее предоставляли связанные сети. Это гарантирует, что все сообщения будут доставлены до пункта назначения.

О том, как создавать маршрутные ссылки, см. в разделе Создание маршрутных ссылок.

Ниже приведены описания некоторых часто встречающихся конфигураций связанных сетей с указаниями по настройке сети после миграции.

  • Все компьютеры в организации используют и протокол IP, и протокол IPX. Дополнительная настройка не требуется. Маршрутизация сообщений будет осуществляться по протоколу IP.
  • Некоторые компьютеры в организации используют только протокол IPX, а некоторые — только протокол IP.Служба очереди сообщений больше не поддерживает протокол IPX. Поэтому необходимо добавить протокол IP на все серверы, использующие только протокол IPX.
  • В организации используется несколько отключенных IP-сетей.Чтобы подключить их, добавьте маршрутизаторы или воспользуйтесь удаленным доступом. Можно также настроить отключенные IP-сети как отдельные сайты Windows 2000.
  • В организации для обмена сообщениями используются инородные компьютеры. Инородные компьютеры обычно настраиваются для пересылки сообщений на сервер очереди сообщений, который находится не в инородном сайте и на котором запущено приложение-подключатель. Такой сервер очереди сообщений также может использоваться в сайте как сервер входящей/исходящей маршрутизации для инородных компьютеров. Целесообразно разместить такие серверы очереди сообщений и все инородные компьютеры в одном инородном сайте, а затем создать маршрутные ссылки к этому сайту.

Средства администрирования

Для управления объектами MSMQ на компьютерах MSMQ 1.0 использовалась административная программа MSMQ Explorer; некоторые задачи администрирования в Windows 2000 позволяла выполнять служебная программа «Очередь сообщений» на панели управления. Эти средства больше не используются, и программу MSMQ Explorer на компьютере Windows XP запустить нельзя. Теперь для администрирования очереди сообщений применяются оснастки консоли MMC: «Управление компьютером», «Active Directory – Пользователи и компьютеры» и «Active Directory – Сайты и службы».

В среде смешанного режима основной контроллер предприятия (PEC) Windows NT 4.0 обновляется до контроллера домена Windows 2000, настроенного в качестве сервера глобального каталога, а остальные серверы образуют группу, включающую по крайней мере один сервер MQIS, работающий под управлением Windows NT 4.0, и произвольное число компьютеров Windows 2000. Такая среда будет существовать до тех пор, пока не завершится весь процесс миграции и не будут обновлены все серверы MQIS платформы Windows NT 4.0, входящие в предприятие. Если клиент очереди сообщений, работающий под управлением Windows XP, взаимодействует в такой среде с сервером MQIS платформы Windows NT 4.0, то с помощью оснастки MMC на компьютере Windows XP можно получить доступ к данным о конфигурации MSMQ, хранящимся на сервере MQIS Windows NT 4.0, и посмотреть свойства всех объектов MSMQ на этом компьютере. Однако в данном случае оснастка «Active Directory – Пользователи и компьютеры» не покажет на странице безопасности разрешения, связанные с этими объектами. Эти разрешения можно посмотреть либо в оснастке «Управление компьютером», либо локально на сервере MSMQ 1.0, используя MSMQ Explorer.

Клиент MSMQ 1.0, оставшийся работать в среде смешанного режима или в среде Windows 2000, использует MSMQ Explorer для управления своими объектами и для просмотра объектов на других компьютерах.

Примечания

  • Не существует средств, позволяющих управлять предприятием MSMQ 1.0 с компьютера Windows XP.


Обновление компьютеров MSMQ 1.0

Основной контроллер предприятия (PEC) и каждый из основных контроллеров сайтов (PSC) в структуре предприятия Windows NT 4.0 обновляются с помощью мастера обновления очереди сообщений, который запускается после установки Windows 2000 Server из мастера настройки сервера. Остальные компоненты программного обеспечения MSMQ 1.0 автоматически обновляются из Windows NT 4.0 в ходе установки Windows 2000.

Обновление серверов контроллеров MSMQ 1.0 должно производиться в следующем порядке:

  1. обновите основной контроллер предприятия (PEC);
  2. обновите все резервные контроллеры одного сайта (BSC);
  3. обновите основной контроллер того же сайта (PSC);
  4. повторите пункты 2 и3 для каждого сайта, пока не будут обновлены все серверы контроллеров.

Нет необходимости полностью завершать процесс обновления компьютеров в одном сайте, прежде чем приступать к обновлению компьютеров в другом сайте. Можно обновлять одновременно несколько сайтов, при условии, что все резервные контроллеры в одном сайте обновляются раньше, чем основной контроллер того же сайта.

Использование мастера обновления очереди сообщений

В этом разделе рассматриваются вопросы использования мастера обновления очереди сообщений для обновления PEC и всех контроллеров PSC в организации. Прежде чем пользоваться этим мастером, следует сначала ознакомиться с разделом Требования и указания по обновлению очереди сообщений.

Важно!

  • Для запуска мастера обновления очереди сообщений необходимо иметь права администратора предприятия или принадлежать группе «Администраторы предприятия».

После того, как все предварительные требования соблюдены, сервер контроллера MSMQ преобразован в контроллер домена Windows 2000, настроенный в качестве сервера глобального каталога, и пользователь вошел в систему как член группы «Администраторы предприятия», он может запускать мастер обновления очереди сообщений. Этот мастер передает сведения из базы данных MQIS в Active Directory. По окончании работы мастера на обновленном компьютере запускается служба очереди сообщений.

Сначала мастер проверяет базу данных MQIS на наличие ошибок и несоответствий и сохраняет результаты в файле журнала для проверки пользователем. Затем выполняется импорт базы данных MQIS в Active Directory. Рекомендуется по запросу мастера выбрать вариант сканирования базы данных, а затем выбрать тип ведения журнала. Это позволяет проверить файл журнала и продолжить или прервать работу мастера на этом этапе.

Примечания

  • Если возникнет необходимость вторично запустить мастер на компьютере, нужно перед этим сначала остановить службу сообщений и службу репликации очереди сообщений и отключить эти службы. Когда мастер закончит работу, можно будет снова запустить службу очереди сообщений.

Обновление основного контроллера предприятия MSMQ

Основной контроллер предприятия (PEC) — это первый компьютер, обновляемый мастером обновления очереди сообщений. Этот компьютер сначала нужно сделать контроллером домена Windows 2000, настроенным в качестве сервера глобального каталога, а затем сделать его доверенным для делегирования.

О том, как настроить компьютер в качестве контроллера домена Windows 2000, см. раздел «Контрольный список: Установка контроллера домена» в справке Windows 2000 Server. О том, как настроить контроллер домена в качестве сервера глобального каталога, см. раздел Настройка контроллера домена как сервера глобального каталога. О том, как установить отношение доверия для делегирования полномочий, см. раздел Наделение компьютера домена правами для делегирования.

Служба репликации очереди сообщений, которая синхронизирует данные между Active Directory и базой данных MQIS на всех остальных серверах контроллеров MSMQ 1.0, запускается только на обновленном компьютере PEC. Чтобы репликация действовала, на обновленном компьютере PEC также должна работать служба очереди сообщений. По умолчанию репликация выполняется каждые 15 минут. Во время работы службы репликации с этого компьютера нельзя удалять службу очереди сообщений. (Некоторые PSC или BSC еще не обновлены.) После того, как будет обновлен последний сервер контроллера в организации, служба репликации очереди сообщений автоматически остановится.

Если организация состоит из нескольких доменов Windows, службу репликации очереди сообщений необходимо запускать от имени учетной записи администратора предприятия (или пользователя, принадлежащего группе «Администраторы предприятия»). О том, как заменить учетную запись для запуска службы, см. раздел Смена учетной записи службы очереди сообщений. Будьте внимательны — в области сведений нужно дважды щелкнуть службу Репликация очереди сообщений (а не Очередь сообщений).

Для поддержки компьютеров MSMQ 1.0 в среде смешанного режима, где остается по крайней мере один сервер контроллера Windows NT 4.0 и имеется по крайней мере один контроллер домена Windows 2000, настроенный в качестве сервера глобального каталога и содержащий сервер очереди сообщений, мастер обновления очереди сообщений автоматически ослабляет требования безопасности для Active Directory на обновленном компьютере PEC. Дополнительные сведения содержатся в разделе Необходимость в ослабленной безопасности.

Обновление резервных контроллеров сайта MSMQ

В каждом сайте до обновления контроллера PSC необходимо обновить резервные контроллеры BSC (это не относится к сайтам, в которых PEC также выполняет функции PSC).

Резервные контроллеры сайта (BSC) во время установки Windows 2000 Server автоматически, без какого-либо вмешательства со стороны пользователя обновляются до серверов очереди сообщений с включенной маршрутизацией. Если в ходе обновления операционной системы компьютер был настроен в качестве контроллера домена Windows 2000, обновленный сервер также сможет предоставлять доступ к Active Directory. В этом случае компьютер также должен быть доверен для делегирования, как описано выше.

Обновление основных контроллеров сайтов MSMQ

В каждом сайте до обновления контроллера PSC необходимо обновить резервные контроллеры BSC (это не относится к сайтам, в которых PEC также выполняет функции PSC). Каждый компьютер PSC сначала необходимо настроить в качестве контроллера домена Windows 2000, доверенного для делегирования; кроме того, возможно, его потребуется настроить и как сервер глобального каталога (если в локальном сайте нет другого сервера очереди сообщений, который работал бы на контроллере домена, уже настроенном в качестве сервера глобального каталога).

Мастер обновления очереди сообщений сравнивает содержимое базы данных MQIS на контроллере PSC с содержимым Active Directory и исправляет все найденные несоответствия. Если будут обнаружены какие-либо несоответствия между MQIS на контроллере PSC и Active Directory, данные Active Directory будут приведены в соответствие содержимому MQIS на контроллере PSC. Таким образом, важно синхронизировать все серверы контроллеров MSMQ 1.0 до начала обновления.

Обновление серверов маршрутизации MSMQ 1.0 и клиентов MSMQ 1.0

Серверы маршрутизации MSMQ 1.0, независимые клиенты MSMQ 1.0 и зависимые клиенты MSMQ 1.0 автоматически обновляются в ходе установки Windows 2000 без какого-либо вмешательства со стороны пользователя. При поступлении запроса во время установки введите имя контроллера домена Windows 2000 (или поддерживающего сервера в случае зависимого клиента) в локальном сайте.

Порядок обновления этих компьютеров не имеет значения.

Подключатель MSMQ Exchange в Windows XP больше не поддерживается


Удаление очереди сообщений

Для удаления с компьютера программного обеспечения очереди сообщений необходимо обладать разрешением «Удаление объектов Настройка MSMQ». Дополнительные сведения о разрешениях на установку содержатся в разделе Разрешения, необходимые для установки.

Запуск программы установки очереди сообщений

Удаление очереди сообщений производится с помощью функции Установка и удаление программ на панели управления. При удалении очереди сообщений с компьютера программа установки очереди сообщений удаляет с него и из Active Directory все очереди (в том числе частные) и сообщения, направлявшиеся на этот компьютер. Однако файлы очереди сообщений, содержащиеся в папках \Windows\System32 и \Windows\System32\Drivers, не удаляются.

При удалении сервера очереди сообщений все соответствующие объекты компьютера («Настройка MSMQ» и «Параметры MSMQ») также удаляются, а имя сервера исключается из списков маршрутизации сообщений на клиентских компьютерах, обслуживавшихся этим сервером.

Дополнительные сведения об удалении программного обеспечения очереди сообщений см. в разделе Удаление очереди сообщений.

Можно также удалять отдельные компоненты очереди сообщений: выберите Установка и удаление программ и сбросьте флажки нужных компонентов в мастере компонентов Windows. Дополнительные сведения о компонентах очереди сообщений см. в разделе Устанавливаемые компоненты очереди сообщений.

Удаление объектов очереди сообщений из Active Directory

Если с компьютера не удается удалить программное обеспечение очереди сообщений, например из-за неполадок оборудования или отсутствия физического доступа к компьютеру, можно удалить объекты очереди сообщений этого компьютера из Active Directory. При удалении объектов очереди сообщений из Active Directory удаляются также все очереди и сообщения, находящиеся на локальном компьютере.

Дополнительные сведения об объектах очереди сообщений и о месте их создания и хранения в Active Directory содержатся в разделе Объекты очереди сообщений в Active Directory.

Дополнительные сведения об удалении объектов очереди сообщений из Active Directory см. в разделе Удаление объектов очереди сообщений из Active Directory.

Примечания

  • Объект «MsmqServices» не следует удалять, пока очередь сообщений не будет удалена со всех компьютеров в данной организации. Этот объект очереди сообщений относится к типу «MSMQ предприятия».


Безопасность очереди сообщений

В данном разделе рассматриваются вопросы безопасности, которые необходимо принимать во внимание при установке и использовании очереди сообщений в организации.

  • Безопасность очереди сообщений: обзор
  • Управление доступом в очереди сообщений
  • Проверка подлинности в очереди сообщений
  • Шифрование в очереди сообщений
  • Аудит доступа в очереди сообщений


Безопасность очереди сообщений: обзор

Очередь сообщений использует различные средства безопасности, встроенные в операционную систему Windows XP. К числу этих средств относятся управление доступом, проверка подлинности сообщений, шифрование и аудит доступа. Те же средства обеспечения безопасности используются и в MSMQ 1.0. Однако вдобавок к 40-разрядному шифрованию теперь еще поддерживается и 128-разрядное.

Средства управления доступом служат для ограничения доступа пользователей к объектам очереди сообщений, хранящимся в Active Directory; для этого объектам присваиваются дескрипторы безопасности. К объектам очереди сообщений относятся «MsmqServices», «msmq», «Очередь», «маршрутная ссылка» и «Параметры MSMQ». (Объект «msmq» для локального компьютера также известен как объект «Настройка MSMQ»; так он обозначается, например, в именах конкретных разрешений для этого объекта и в мастере делегирования управления.) В дескрипторе безопасности перечисляются пользователи и группы, которым предоставляется или запрещается доступ к объекту, а также назначенные им конкретные разрешения.

В Active Directory и другие службы каталогов могут выдаваться запросы системы безопасности, посредством которых клиент и сервер, подключенные к сети, общаются друг с другом; эти запросы производятся по протоколам безопасности Kerberos V5 (между компьютерами Windows 2000) и Windows NTLM (для совместимости со службой MSMQ 1.0, работающей под управлением Windows NT 4.0). Итак, Kerberos V5 и NTLM используются клиентами для проверки подлинности серверов очереди сообщений.

Kerberos V5 также обеспечивает делегирование запросов с одного контроллера домена на другой в случае, когда в радиусе одного прыжка нет подходящих контроллеров домена. И обратно, если запрос, сделанный компьютером с помощью NTLM, не доходит до контроллера того же домена за один прыжок, сеанс прекращается.

Подлинность отправителя сообщения удостоверяется на компьютере-получателе с помощью сертификатов. Проверка подлинности сообщений производится асинхронно, без обмена данными между отправителем и получателем.

Шифрование реализовано в виде алгоритмов, основанных на использовании как открытых (асимметричных), так и секретных (симметричных) ключей. С помощью этих алгоритмов приложения очереди сообщений шифруют сообщения, которыми обмениваются компьютеры очереди сообщений.

Аудит доступа применяется для записи сведений о пользователях, пытающихся обратиться к объектам очереди сообщений в Active Directory. В дескрипторе безопасности объекта указано, какие события доступа к этому объекту подлежат аудиту.

Управляя свойствами безопасности объектов, администраторы могут устанавливать разрешения, назначать владельцев и отслеживать доступ пользователей.

Прежде чем настраивать систему безопасности в сети очереди сообщений, необходимо рассмотреть ряд вопросов, обсуждаемых в следующих разделах.

Необходимость в ослабленной безопасности

Серверы очереди сообщений, установленные на контроллерах доменов Windows 2000, могут работать в условиях пониженных требований к безопасности в отношении Active Directory. Ослабленная безопасность может быть включена во время установки первого сервера очереди сообщений на контроллере домена Windows 2000 в составе леса. Затем этот режим реплицируется на остальные контроллеры доменов во все домены леса. Ослабленная безопасность должна использоваться, если в данной организации используется одна из следующих конфигураций.

  • Среда домена смешанного режима, в которой пользователи службы MSMQ 1.0 (работающей под управлением Windows NT 4.0, Windows 98 или Windows 95) обращаются к серверам очереди сообщений, работающим на контроллерах доменов Windows 2000, для доступа к службе каталогов. (Сюда также включаются случаи, когда такие пользователи входят в систему с помощью учетной записи домена Windows 2000.)
  • Домен Windows 2000, в который пользователи очереди сообщений (работающей под управлением Windows XP или Windows 2000) входят с помощью учетной записи домена Windows NT 4.0.
  • Среда, в которую пользователи Message Queuing 2.0 входят с помощью учетной записи локального пользователя. (Однако зависимые клиенты не могут запущены от имени учетной записи локального пользователя, и любой компьютер, который направляет запросы об объектах очереди сообщений в службу Active Directory на контроллере домена непосредственно, а не через сервер очереди сообщений, не получит доступа к этим объектам в Active Directory, если он зарегистрирован под учетной записью локального пользователя, даже в условиях ослабленной безопасности для Active Directory.)

Если включена ослабленная безопасность, сервер очереди сообщений, работающий на контроллере домена Windows 2000, будет осуществлять доступ к Active Directory на соответствующем контроллере домена в рамках своего собственного контекста безопасности, используя учетную запись LocalSystem. Это позволит просматривать свойства объектов Active Directory, в частности, объектов «msmq» («Настройка MSMQ») и объектов «очередь», а также проверять параметры безопасности для клиентов версий более ранних, чем Windows XP, однако все ограничения на создание объектов или установку их параметров безопасности по-прежнему остаются в силе.

В случае MSMQ 1.0, когда служба MSMQ инициирует вызов RPC на сервер очереди сообщений, работающий на контроллере домена Windows 2000, этот вызов в контексте безопасности, используемом по умолчанию, представляется как анонимный вход в систему. Чтобы разрешить доступ таких анонимных пользователей к Active Directory, безопасность домена ослабляется, разрешая не олицетворять этот вызов. Поэтому все запросы на доступ к объектам очереди сообщений в Active Directory принимаются серверами очереди сообщений Windows 2000. Это означает, что можно будет только просматривать свойства объектов очереди сообщений, но не означает, что сообщения удастся извлекать (удалять) из общих очередей.

Воспользовавшись после окончания установки программой ADSI Edit, можно проверить настройку очереди сообщений и в случае необходимости изменить ее. О том, как это сделать, см. раздел Ослабление безопасности с использованием программы ADSI Edit.

Можно также обеспечить поддержку пользователей MSMQ 1.0 (и всех остальных обсуждавшихся конфигураций) без ослабления безопасности. Для этого необходимо назначить группе «Все» разрешение «Список содержимого» на всех объектах «компьютер» во всех доменах. Впрочем, при этом безопасность домена подвергается серьезному риску.

Выбор учетной записи службы очереди сообщений

В отличие от других программ, выполняемых участником системы безопасности (пользователем или компьютером), службы выполняются в своем собственном контексте безопасности. Чтобы установить контекст безопасности, служба должна зарегистрироваться в системе, подобно участникам системы безопасности. Служба очереди сообщений может быть запущена на компьютере от имени учетной записи LocalSystem или учетной записи конкретного пользователя. LocalSystem — это стандартная, прошедшая проверку подлинности учетная запись пользователя домена в системе Windows 2000. По умолчанию служба очереди сообщений использует именно учетную запись LocalSystem. Учетную запись, используемую службой, можно заменить. Это может быть полезно, если необходимо предоставить для службы конкретные разрешения.

Использование учетной записи LocalSystem для запуска службы сообщений дает следующие преимущества:

  • эта учетная запись входит в локальную группу «Администраторы»;
  • эта учетная запись уже обладает правами, необходимыми для запуска службы;
  • эта учетная запись уже обладает полномочиями на создание записей аудита безопасности.

Если служба очереди сообщений запускается с помощью учетной записи LocalSystem на всех компьютерах предприятия, членам группы «Проверенные пользователи» по умолчанию предоставляется разрешение на чтение любых объектов очереди сообщений в Active Directory. Это разрешение позволяет таким пользователям читать атрибуты объектов очереди сообщений, находящихся в Active Directory, но не контролирует их права на получение (и удаление) сообщений из очередей. Учетную запись, от имени которой запускается служба очереди сообщений, следует менять только в том случае, если нежелательно предоставлять разрешение на чтение всем членам группы «Проверенные пользователи». Чтобы запустить службу очереди сообщений от имени учетной записи конкретного пользователя, необходимо сделать следующее.

  • Предоставьте данной учетной записи пользователя разрешение на чтение всех объектов очереди сообщений в Active Directory.
  • Включите учетную запись пользователя в локальную группу «Администраторы».

Если требуется обеспечить дополнительные возможности, можно предоставить учетной записи пользователя следующие полномочия:

  • Вход в систему в качестве службы
  • Работа в режиме операционной системы
  • Замена маркера уровня процесса
  • Увеличение квот
  • Создание записей аудита безопасности

Кроме того, если с помощью учетной записи пользователя запускать приложения очереди сообщений для независимых клиентов Windows 2000, эти клиенты не смогут проверять подлинность серверов очереди сообщений, работающих на контроллерах доменов. Такие контроллеры доменов предоставляют доступ к Active Directory. Если проверка подлинности этих серверов очереди сообщений является обязательным требованием, следует использовать учетную запись пользователя домена.

О том, как заменить учетную запись для запуска службы очереди сообщений, см. в разделе Замена учетной записи службы очереди сообщений.

Другие вопросы безопасности

Очередь сообщений гарантирует безопасность всех сообщений, отправляемых с исходного компьютера на конечный. Для обеспечения полной безопасности приложение-получатель и конечная очередь должны располагаться на одном компьютере. Это обусловлено тем, что в конечной очереди сообщения хранятся в незашифрованном виде. Операция доступа к содержимому очереди с того же компьютера, на котором находится эта очередь, называется локальным чтением. Операция доступа к содержимому очереди с другого компьютера называется удаленным чтением. При удаленном чтении сообщения не шифруются, а их подлинность не проверяется. Тем не менее очередь сообщений гарантирует неприкосновенность сообщений.

По умолчанию информационные службы Интернета (IIS) используют локальную учетную запись пользователя, которая другими компьютерами в сети воспринимается как учетная запись анонимного пользователя. Приложения и сценарии страниц ASP запускаются в среде IIS и потому их запросы к Active Directory рассматриваются как обращения анонимного пользователя. Поскольку анонимные пользователи в системе Windows XP больше не входят в группу «Все», эти запросы удовлетворены не будут; приложения и сценарии ASP не смогут искать, создавать и удалять очереди, а сообщения, посланные с помощью таких сценариев, не будут доходить до очередей назначения. Для выхода из положения запустите IIS от имени учетной записи пользователя домена, вошедшего в систему на компьютере, на котором работает IIS, или от имени какой-либо другой учетной записи пользователя домена.

В этом случае компьютер должен быть доверенным для делегирования, чтобы разрешить соединение с контроллером домена, включающее несколько прыжков.

Дополнительные сведения об изменении параметров безопасности IIS см. в разделе Изменение параметров безопасности для информационных служб Интернета.


Управление доступом в очереди сообщений

Средства управления доступом позволяют ограничивать доступ пользователей к объектам очереди сообщений, находящимся в Active Directory, и могут быть реализованы путем назначения объектам дескрипторов безопасности. В дескрипторе безопасности перечисляются пользователи и группы, которым предоставляется или запрещается доступ к данному объекту, и указываются конкретные разрешения, назначенные этим пользователям и группам. Эта часть дескриптора безопасности называется избирательной таблицей управления доступом (DACL). Задавая разрешения на доступ к объекту, его владелец определяет, какие можно выполнять действия над объектом. В число объектов очереди сообщений входят объекты «компьютер» (msmq), «очередь», «маршрутная ссылка» и «Параметры MSMQ». Дополнительные сведения об объектах очереди сообщений и о месте их создания и хранения в Active Directory содержатся в разделе Объекты очереди сообщений в Active Directory.

С помощью разрешений также можно ограничить возможности отправки сообщений пользователями в определенную очередь на компьютере, или получения сообщений из определенной очереди. Хотя сообщения не представлены объектами в Active Directory, они защищены дескриптором безопасности объекта «очередь».

Поскольку очередь сообщений реализует асинхронный обмен сообщениями, одновременного подключения к сети исходного и конечного компьютеров не требуется. Управление доступом отключенных пользователей к очереди сообщений осуществляется с использованием кодов безопасности (SID) отправителей. Например, очередь может ограничить доступ к своему содержимому, поэтому приложение-отправитель должно присоединять свой код безопасности к каждому сообщению, направляемому в такую очередь. Служба очереди сообщений на конечном компьютере проверит этот код, чтобы убедиться в том, что у отправителя есть разрешения на доступ к очереди.

Примечания

  • Для установки и удаления очереди сообщений также необходимо обладать определенными разрешениями. Дополнительные сведения содержатся в разделе Разрешения, необходимые для установки.

Дополнительные сведения об управлении доступом в системе Windows XP Professional см. в разделе «Управление доступом» справки Windows 2000 Server.

Использование административных групп

Администрирование управления доступом можно упростить, используя одну или несколько административных групп пользователей с соответствующими разрешениями для каждой группы. В этом случае требуется всего лишь добавлять пользователей в группу, чтобы наделять их соответствующими разрешениями. Например, можно создать группу «Администраторы сайта» в каждом сайте леса Windows 2000. Затем можно назначить группе «Администраторы сайта» права администратора домена на каждом сервере очереди сообщений в этом сайте.

Дополнительные сведения об административных группах в системе Windows XP Professional см. в разделе «Встроенные и предварительно определяемые группы» справки Windows 2000 Server.

Дескрипторы безопасности объектов msmq

Объект msmq — это родительский объект всех очередей на компьютере. Чтобы создать очередь, пользователь должен иметь разрешение «Создание всех дочерних объектов» для объекта msmq, в котором будет создан объект «очередь» в Active Directory. Таким образом, круг пользователей, которым разрешено создавать очереди на компьютере, определяется дескриптором безопасности объекта msmq соответствующего компьютера, который, в свою очередь, определяется в ходе установки очереди сообщений, как описано ниже.

Когда в структуре леса Windows 2000 устанавливается независимый клиент или сервер очереди сообщений без маршрутизации (на компьютере, не являющемся контроллером домена) в режиме рабочей группы или режиме домена, дескриптор безопасности для объекта msmq по умолчанию разрешает создавать очереди по следующим правилам:

  • пользователи, обладающие правами администратора домена или предприятия, могут создавать очереди на этом компьютере;
  • пользователь, выполнявший установку очереди сообщений, может создавать очереди на этом компьютере;
  • все пользователи могут создавать очереди на инородном компьютере.

Если во время установки независимого клиента или сервера очереди сообщений без маршрутизации (на компьютере, не являющемся контроллером домена) задать имя сервера контроллера MSMQ 1.0 (работающего под управлением Windows NT 4.0), дескриптор безопасности для объекта msmq по умолчанию разрешает всем создавать очереди на таком компьютере.

При установке MSMQ 1.0 на компьютере в домене Windows 2000 дескриптор безопасности для объекта msmq по умолчанию разрешает всем создавать очереди на этом компьютере.

Приложения, работающие на компьютере Windows XP в составе леса Windows 2000, могут создавать на этом компьютере очереди при условии, что он может поддерживать связь с контроллером домена Windows 2000. Приложения, работающие на компьютере с версией более ранней, чем Windows XP, могут создавать очереди только в том случае, если у компьютера есть связь с контроллером домена Windows 2000, на котором размещен сервер очереди сообщений. В предприятии Windows NT 4.0 клиентский компьютер должен иметь возможность связаться с сервером контроллера MSMQ 1.0.

Задание разрешений на доступ к объектам msmq

В оснастке «Active Directory – Пользователи и компьютеры» объект msmq является дочерним для соответствующего объекта «компьютер». Таким образом, объект msmq может быть создан или удален только пользователем, обладающим соответственно разрешением «Создание всех дочерних объектов» или «Удаление всех дочерних объектов» для родительского объекта «компьютер». Объект msmq также иногда обозначается как объект «Настройка MSMQ», например, в именах конкретных разрешений для этого объекта и в мастере делегирования управления.

Разрешения на доступ к объекту msmq, предоставляемые службой Active Directory по умолчанию, можно изменять; также можно устанавливать дополнительные разрешения, связанные с очередью сообщений. По умолчанию группа «Все» имеет общее разрешение на чтение содержимого объекта msmq, т.е. члены группы могут просматривать его свойства и дескрипторы безопасности. По умолчанию же группе «Все» предоставляются общие разрешения «Создание всех дочерних объектов» и «Удаление всех дочерних объектов» для объекта msmq, необходимые соответственно для создания и для удаления очередей.

В следующей таблице сведены относящиеся к очереди сообщений разрешения, которые можно просматривать и устанавливать для объекта msmq. Эти разрешения можно предоставлять отдельным пользователям или, с помощью мастера делегирования управления, группам пользователей в домене, таким как «Проверенные пользователи».

Разрешение очереди сообщений | Пользователю или группе разрешается...
Просмотр журнала компьютера | Просматривать содержимое журнала компьютера и хранящиеся в нем сообщения.
Просмотр недоставленных сообщений | Просматривать содержимое очереди недоставленных сообщений на компьютере и хранящиеся в ней сообщения.
Получение журнала компьютера | Читать (удалять) сообщения из журнала компьютера.
Получение недоставленных сообщений | Читать (удалять) сообщения из очереди недоставленных сообщений компьютера.

Если пользователю или группе предоставлено разрешение «Получение погибшего сообщения» или «Получение журнала компьютера», этой группе или пользователю также автоматически предоставляется разрешение «Просмотр сообщения». (Разрешения «Получение погибшего сообщения» и «Получение журнала компьютера» без разрешения «Просмотр журнала» бессмысленны.)

Дополнительные сведения об установке разрешений для объекта msmq см. в разделе Задание разрешений для объектов компьютеров и очередей.

О том, как сменить владельца объекта msmq, см. в разделе Смена владельца объектов компьютеров и очередей.

Задание разрешений на доступ к объектам очередей

В оснастке «Active Directory – Пользователи и компьютеры» объекты «очередь» являются дочерними объектами объекта msmq.

Разрешения на доступ к объекту «очередь», предоставляемые службой Active Directory по умолчанию, можно изменять; также можно устанавливать для них дополнительные разрешения, связанные с очередью сообщений.

По умолчанию создателю очереди предоставляется общее разрешение «Полный доступ», а членам группы «Все» — общее разрешение на запись в объект «очередь». Пользователи, обладающие разрешением на запись в очередь, могут отправлять в нее сообщения.

Общее разрешение на чтение очереди позволяет только просматривать ее свойства и дескриптор безопасности.

В следующей таблице сведены относящиеся к очереди сообщений разрешения, которые можно просматривать и устанавливать для объекта «очередь». Эти разрешения можно предоставлять отдельным пользователям или, с помощью мастера делегирования управления, группам пользователей в домене, таким как «Проверенные пользователи».

Разрешение очереди сообщений | Пользователю или группе разрешается...
Просмотр сообщения | Просматривать содержимое очереди и ее журнала и хранящиеся там сообщения.
Получение журнала | Читать (удалять) сообщения из журнала очереди.
Получение сообщения | Читать (удалять) обычные сообщения из очереди.

Если пользователю или группе предоставлено разрешение «Получение сообщения» или «Получение журнала», этой группе или пользователю также автоматически предоставляется разрешение «Просмотр сообщения». (Без него разрешения «Получение сообщения» и «Получение журнала» бессмысленны.)

Дополнительные сведения об установке разрешений для объекта «очередь» см. в разделе Задание разрешений для объектов компьютеров и очередей.

О том, как сменить владельца объекта «очередь», см. в разделе Смена владельца объектов компьютеров и очередей.

Примечания

  • Для отправки сообщений в очереди с ограниченным доступом необходимы доверительные отношения между доменами. Если пользователь отправляет сообщение в очередь, принимающую сообщения не от всех пользователей, компьютер, на котором находится эта очередь, должен входить в тот же домен, что и отправитель, либо между их доменами должны быть установлены доверительные отношения. В противном случае сообщение отвергается, а доступ к очереди не предоставляется. Общие сведения о доменах см. в разделе «Домены» справки Windows 2000 Server.

Задание разрешений для списков рассылки

Списки рассылки — это списки общего пользования, публикуемыми в Active Directory в виде объектов «группа рассылки». Явными членами списка рассылки должны быть пункты назначения, публикуемые в Active Directory, т.е. общие очереди, псевдонимы очередей и другие списки рассылки.

Каждому списку рассылки назначается список DACL очереди сообщений. Ниже приводится перечень разрешений, относящихся к спискам рассылки. Эти разрешения можно предоставлять отдельным пользователям или, с помощью мастера делегирования управления, группам пользователей в домене.

Разрешение | Группе или пользователю разрешается...
Отправка | Отправлять сообщения в соответствующий список рассылки.
Добавление/удаление себя как члена (для общей очереди или псевдонима очереди) | Добавлять соответствующую общую очередь или псевдоним очереди в список рассылки или удалять из списка.
Добавление/удаление элемента списка (для списка рассылки) | Добавлять соответствующий список рассылки в другой список рассылки или удалять его оттуда.

По умолчанию разрешения «Отправка» и «Добавление/удаление элемента списка» (для общей очереди или псевдонима очереди) предоставляются всем, а разрешение «Добавление/удаление элемента списка» для списка рассылки — только владельцу этого списка. Кроме того, все пользователи по умолчанию могут создавать списки рассылки.

Сообщения нельзя читать непосредственно из списков рассылки. Таким образом, доступ по чтению контролируется только на уровне конечных очередей.

Задание разрешений для объектов маршрутных ссылок

В оснастке «Active Directory – Сайты и службы» каждый объект «маршрутная ссылка» является дочерним объектом объекта MsmqServices. Следовательно, установка разрешений для объекта «маршрутная ссылка» означает предоставление разрешений на создание и удаление дочерних объектов («Создание всех дочерних объектов» и «Удаление всех дочерних объектов») пользователям родительского объекта MsmqServices.

По умолчанию обоими этими разрешениями обладают только пользователи с полномочиями администратора предприятия (принадлежащие группе «Администраторы предприятия»); они могут создавать, изменять и удалять маршрутные ссылки, если в организации имеется несколько доменов. Чтобы пользователи, входящие в группу «Администраторы домена», также могли изменять или удалять маршрутные ссылки, им нужно предоставить разрешение «Удаление всех дочерних объектов» для объекта MsmqServices.

Для объекта «маршрутная ссылка» можно изменять только разрешения, предоставляемые службой Active Directory по умолчанию. Специальные разрешения очереди сообщений для этого объекта отсутствуют.

Дополнительные сведения об установке разрешений для объектов «маршрутная ссылка» см. в разделе Задание разрешений для объектов маршрутных ссылок.

Задание разрешений для объектов «Параметры MSMQ»

Задание разрешений для объекта «Параметры MSMQ» означает предоставление разрешений на создание или удаление дочерних объектов родительского объекта «сервер». В оснастке «Active Directory – Сайты и службы» объект «Параметры MSMQ» является дочерним объектом объекта «сервер».

Для объекта «Параметры MSMQ» можно изменять только разрешения, предоставляемые службой Active Directory по умолчанию. Специальные разрешения очереди сообщений для этого объекта отсутствуют.

Дополнительные сведения об установке разрешений для объектов «Параметры MSMQ» см. в разделе Задание разрешений для объектов «Параметры MSMQ».

Задание разрешений для файлов сообщений

По умолчанию только члены локальной группы «Администраторы» имеют полный доступ к локальным файлам сообщений, файлам журналов и файлам локального хранилища очередей. Другие пользователи не имеют доступа к этим файлам.

По умолчанию в папках Storage и Lqs действует механизм доступа на уровне файлов. Каждый раз, когда в какую-либо из этих папок записывается новый файл, этот файл наследует параметры безопасности соответствующей папки. Однако если переместить файл сообщения в другую папку, используя оснастку Управление компьютером, параметры безопасности из исходной папки не будут скопированы в новую папку. Для файлов, перемещаемых из этих стандартных папок в другие папки, останутся действительными лишь их собственные параметры безопасности, принимаемые по умолчанию (но не параметры безопасности папок Storage и Lqs).

Дополнительные сведения об установке разрешений для локальных файлов сообщений и журналов см. в разделе Задание разрешений для файлов очереди сообщений.

Примечания

  • Доступ на уровне папок и на уровне файлов возможен только на дисках формата NTFS. На дисках, использующих файловую систему FAT, возможен только доступ на уровне папок.


Проверка подлинности в очереди сообщений

В Active Directory и другие службы каталогов могут выдаваться запросы системы безопасности, посредством которых клиент и сервер, подключенные к сети, общаются друг с другом; эти запросы производятся по протоколам безопасности Kerberos V5 (между компьютерами Windows XP и/или Windows 2000) и Windows NTLM (для совместимости со службой MSMQ 1.0, работающей под управлением Windows NT 4.0). Итак, Kerberos V5 и NTLM используются клиентами для проверки подлинности серверов очереди сообщений.

Проверка подлинности сообщения удостоверяет, что сообщение не было изменено в процессе доставки, и позволяет получателю сообщения установить подлинность его отправителя; такая проверка реализуется с использованием сертификатов. Сообщения проверяются асинхронно, без обмена данными между отправителем и получателем.

Проверка подлинности сообщений не является обязательной. При отправке и получении сообщений приложения очереди сообщений необязательно должны использовать проверку подлинности. Следует иметь в виду, что проверка подлинности сообщений замедляет их передачу. Если приложения очереди сообщений все же отправляют или получают сообщения с проверкой подлинности, то должен использоваться поставщик службы криптографии, устанавливаемый по умолчанию вместе с Windows XP; он необходим как для проверки подлинности, так и для шифрования сообщений. Дополнительные сведения о шифровании сообщений содержатся в разделе Шифрование в очереди сообщений.

Дополнительные сведения о проверке подлинности в Windows XP Professional см. в разделе «Проверка подлинности» справки Windows 2000 Server.

Дополнительные сведения о сертификатах для Windows XP Professional см. в разделе «Обзор сертификатов» справки Windows 2000 Server.

Проверка подлинности сообщений

Проверка подлинности сообщения — это процедура, в ходе которой требуется установить, что сообщение не было изменено во время доставки. Кроме того, этот процесс используется для удостоверения личности пользователя, отправившего сообщение.

Сообщение, подвергающееся проверке, отправляется с цифровой подписью и сертификатом. Цифровые подписи создаются и проверяются с помощью процедуры шифрования, использующей общий (асимметричный) ключ. В очереди сообщений отправитель, используя закрытый ключ, создает цифровую подпись, а затем получатель с помощью открытого ключа, который содержится в сертификате, вложенном в сообщение, проверяет достоверность цифровой подписи.

Поскольку очередь сообщений реализует асинхронный обмен сообщениями, одновременного подключения исходного и конечного компьютеров к сети и друг к другу не требуется.

Проверить подлинность отправителя сообщения не всегда представляется возможным. Например, прежде чем можно будет проверить подлинность отправителя сообщения, передаваемого между компьютерами одного леса с доступом к Active Directory, необходимо, что сертификат пользователя был зарегистрирован в Active Directory. В результате регистрации в Active Directory сертификату сопоставляется код безопасности (SID) его владельца. Можно также использовать внутренний сертификат пользователя, создаваемый на локальном компьютере в ходе установки; он регистрируется автоматически при первом входе в систему с этого компьютера.

При передаче сообщения приложение очереди сообщений на исходном компьютере создает цифровую подпись для сообщения, вкладывает в него эту цифровую подпись, а также код безопасности и соответствующий сертификат, и затем отправляет сообщение. На конечном компьютере служба очереди сообщений проверяет достоверность цифровой подписи и выдает запрос в службу каталогов для проверки регистрации пары «код безопасности/сертификат». Если эта пара зарегистрирована, подлинность сообщения считается установленной, и он помещается в очередь назначения.

Говоря более конкретно, на исходном компьютере приложение очереди сообщений выполняет следующие действия:

  1. вычисляет хеш-код для фиксированного ограниченного фрагмента сообщения, используя алгоритм хеширования;
  2. шифрует хеш-код, используя закрытый криптографический ключ, и создает цифровую подпись;
  3. вкладывает в сообщение цифровую подпись, код безопасности (SID), имя алгоритма хеширования и цифровой сертификат с открытым криптографическим ключом исходного компьютера.

На конечном компьютере служба очереди сообщений выполняет следующие действия:

  1. вычисляет хеш-код для фиксированного ограниченного фрагмента сообщения, используя тот же алгоритм хеширования, что и исходный компьютер;
  2. расшифровывает цифровую подпись, вложенную в сообщение, используя открытый криптографический ключ из цифрового сертификата, и получает второй хеш-код;
  3. сравнивает два хеш-кода, чтобы убедиться, что сообщение доставлено в нетронутом виде;
  4. в случае совпадения хеш-кодов ищет в Active Directory сертификат пользователя и проверяет, соответствует ли имя пользователя, зарегистрировавшего сертификат, отправителю (коду SID), указанному в сообщении.

В данном случае цифровой сертификат однозначно определяет пользователя, пославшего сообщение, а также само сообщение. Поскольку ни один пользователь не может подписать сообщение цифровой подписью другого пользователя, никто не сможет отрицать свою причастность к отправке сообщения, если в нем будет содержаться действительный цифровой сертификат, который может быть идентифицирован с конкретным отправителем.

Данный метод проверки подлинности требует доступа к Active Directory и потому не может быть использован для проверки сообщений в случаях, когда компьютер-получатель находится в режиме рабочей группы или автономном режиме.

Дополнительные сведения о криптографических ключах, используемых очередью сообщений, содержатся в разделе Криптографические ключи.

Проверенные сообщения также можно отправлять на инородные компьютеры. Промежуточный сервер очереди сообщений (на котором работает приложение-подключатель) может подтверждать подлинность проверенных сообщений.

Очередь можно настроить так, чтобы она принимала только проверенные сообщения. Дополнительные сведения см. в разделе Помещение в очередь только сообщений, прошедших проверку.

Следующие разделы посвящены подробному рассмотрению сертификатов пользователей.

Сертификаты пользователей

Очередь сообщений может использовать два типа сертификатов пользователей, или сертификатов с открытым ключом: внутренние сертификаты и внешние сертификаты. Внутренние сертификаты автоматически создаются в ходе установки очереди сообщений и могут использоваться всеми. Внешние сертификаты содержат данные, предоставляемые центром сертификации (CA). Содержимое данного раздела во всех случаях, кроме специально оговоренных, распространяется на сертификаты обоих типов.

Управление сертификатами пользователей компьютера очереди сообщений осуществляется с помощью диалогового окна Свойства: Очередь сообщений в оснастке «Управление компьютером». О том, как посмотреть все сертификаты пользователей, зарегистрированные в Active Directory, см. в разделе Просмотр сертификатов для очереди сообщений. Все сертификаты обладают определенным сроком действия. По истечении срока действия сертификат больше не считается действительным удостоверением личности. Кроме того, если установить очередь сообщений на компьютере, работающем в режиме рабочей группы, а затем этот компьютер присоединится к домену, нужно будет вручную обновить внутренний сертификат. Дополнительные сведения об обновлении внутренних сертификатов пользователей см. в разделе Обновление сертификатов для очереди сообщений.

Сертификаты пользователей можно хранить в Active Directory. Если система Windows XP установлена на компьютере заново (а не в результате обновления предыдущей версии), необходимо удалить предыдущий (устаревший) сертификат пользователя. Дополнительные сведения об удалении сертификата пользователя см. в разделе Удаление сертификатов для очереди сообщений. Далее необходимо вручную зарегистрировать новый сертификат. Инструкции по регистрации сертификата пользователя содержатся в разделе Регистрация сертификатов для очереди сообщений.

Примечания

  • Если управление доступом к очередям осуществляется с использованием разрешений, сертификаты пользователей должны быть зарегистрированы в Active Directory, чтобы очередь сообщений могла сопоставлять их соответствующим кодам SID пользователей. Хотя в очереди с ограниченным доступом могут отправляться и непроверенные сообщения, это рискованно с точки зрения безопасности, так как содержимое таких сообщений может быть изменено или прочитано в ходе доставки.
  • В случае кластера пользовательский профиль, необходимый для сохранения сертификата пользователя в реестре, не будет создан для пользователя, учетная запись которого используется только для службы кластеров, до тех пор, пока он хотя бы однажды не войдет в какой-либо узел кластера. После того, как профиль будет создан, пользователь должен будет вручную зарегистрировать свой сертификат для очереди сообщений.

Внешние сертификаты

Внешние сертификаты пользователей содержат не код SID, а данные, предоставляемые центром сертификации (CA) и необходимые для удостоверения личности отправителя. Достоверность содержимого сертификата гарантирует выдавший его центр сертификации. Служба очереди сообщений на конечном компьютере при получении сообщения проверяет достоверность цифровой подписи, но не самого внешнего сертификата. Ответственность за проверку внешнего сертификата, выполняемую перед обработкой сообщения, ложится на приложение-получатель. Дополнительные сведения о центрах сертификации см. в разделе «Центры сертификации» в справке Windows 2000 Server.

Внешний сертификат можно зарегистрировать в Active Directory и затем использовать для проверки подлинности кода SID отправителя при передаче сообщений на другие компьютеры того же леса; это происходит точно так же, как в случае внутреннего сертификата, но, возможно, обеспечивает более высокий уровень безопасности.

Если зарегистрировать внешний сертификат в Active Directory и тем самым сопоставить ему код SID, можно будет отправлять сообщения в очереди ограниченного доступа. Это связано с тем, что служба очереди сообщений проверяет код SID отправителя. Таким образом, регистрация внешнего сертификата обеспечивает дополнительную (хотя и необязательную) проверку подлинности, что может быть использовано приложением-получателем.

Внешние сертификаты необходимы при отправке сообщений в среды, отличные от Windows 2000. Кроме того, внешний сертификат можно использовать в следующих случаях.

  • Требуется проконтролировать состав пользователей, которые смогут отправлять сообщения с проверкой подлинности. (Внутренние сертификаты создаются автоматически во время установки очереди сообщений и могут использоваться кем угодно.)
  • Требуется отправлять сообщения кому-либо, не имеющему доступа к Active Directory.
  • Пользователь входит в рабочую группу, а не в домен.

Если коды SID не могут быть использованы для проверки подлинности отправителя, как, например, в случае сообщения, передаваемого между компьютерами рабочей группы, проверку сообщения можно произвести с помощью внешнего сертификата. В таких случаях при отправке сообщения, подлежащего проверке, приложение очереди сообщения на исходном компьютере создает цифровую подпись для сообщения, вкладывает в него эту подпись вместе с соответствующим внешним сертификатом и отправляет сообщение. Служба очереди сообщений на конечном компьютере проверяет достоверность цифровой подписи.

Говоря более конкретно, на исходном компьютере приложение очереди сообщений выполняет следующие действия:

  1. вычисляет хеш-код для фиксированного ограниченного фрагмента сообщения, используя алгоритм хеширования;
  2. шифрует хеш-код, используя закрытый криптографический ключ отправителя, и создает цифровую подпись;
  3. вкладывает в сообщение цифровую подпись, имя алгоритма хеширования и цифровой сертификат с открытым криптографическим ключом отправителя.

На конечном компьютере служба очереди сообщений выполняет следующие действия:

  1. вычисляет хеш-код для фиксированного ограниченного фрагмента сообщения, используя тот же алгоритм хеширования, что и исходный компьютер;
  2. расшифровывает цифровую подпись, вложенную в сообщение, используя открытый криптографический ключ из цифрового сертификата, и получает второй хеш-код;
  3. сравнивает два хеш-кода, чтобы убедиться, что сообщение доставлено в нетронутом виде;
  4. в случае совпадения хеш-кодов проверяет достоверность внешнего сертификата (необязательное действие).

Одним из способов получения внешнего сертификата является использование Internet Explorer 5 или более поздней версии для запроса сертификата из центра сертификации. Например, можно обратиться в один из следующих центров сертификации:

  • AT&T
  • InternetMCI Mail
  • Keywitness Canada
  • VeriSign Commercial Software Publishers

Вообще говоря, центры сертификации могут выдавать внешние сертификаты различных уровней. Некоторые внешние сертификаты не удостоверяют личность пользователя. Они лишь гарантируют, что все его сообщения отправляет одно и то же лицо. Этого достаточно для систем, действующих по подписке. Внешние сертификаты других уровней подтверждают, что пользователь действительно является тем, за кого себя выдает.

Проверка подлинности сервера

Проверка подлинности сервера используется клиентами для проверки запросов, отправляемых на контроллеры доменов и серверы очереди сообщений. Клиент может проверить, не были ли результаты запросов изменены в ходе доставки и возвращены ли они именно тем контроллером домена или сервером очереди сообщений, которым следует. В режиме домена смешанного режима, где клиент очереди сообщений может взаимодействовать с сервером контроллера MSMQ 1.0 или, наоборот, клиент MSMQ 1.0 — с сервером очереди сообщений, выбор клиентом метода проверки подлинности сервера зависит от версии очереди сообщений (и, следовательно, операционной системы), используемой сервером и клиентом. В следующей таблице показано, какие методы применяются в каждой из возможных ситуаций.

Клиент | Сервер | Метод проверки подлинности сервера
Клиент очереди сообщений, работающий под управлением Windows XP | Контроллер домена Windows 2000 | Kerberos V5
Клиент очереди сообщений, работающий под управлением Windows 2000 | Сервер очереди сообщений, работающий под управлением Windows 2000 | Kerberos V5
Клиент очереди сообщений, работающий под управлением Windows XP or Windows 2000 | Сервер контроллера MSMQ 1.0, работающий под управлением Windows NT 4.0 | Windows NTLM (с использованием сертификата сервера)
Клиент MSMQ 1.0, работающий под управлением Windows NT 4.0, Windows 98 или Windows 95 | Сервер очереди сообщений, работающий под управлением Windows 2000 | Windows NTLM (с использованием сертификата сервера)

Сертификаты серверов используются для проверки подлинности некоторых серверов очереди сообщений. Создавать и регистрировать сертификат сервера необходимо только для тех серверов очереди сообщений, которые отвечают на запросы Active Directory, поступающие от клиентов MSMQ 1.0, работающих под управлением Windows NT 4.0, Windows 98 или Windows 95. Клиенты очереди сообщений, работающие под управлением Windows XP или Windows 2000, проверяют подлинность серверов Windows 2000 по протоколу Kerberos V5.

Если какой-либо клиент очереди сообщений (работающий под управлением Windows XP) взаимодействует с сервером контроллера MSMQ 1.0 (работающим под управлением Windows NT 4.0) и требуется проверить подлинность этого сервера, это придется сделать вручную. Дополнительные сведения о настройке таких клиентов для проверки подлинности серверов контроллеров MSMQ 1.0 с помощью сертификатов серверов см. в разделе Проверка подлинности серверов контроллеров MSMQ 1.0.

Сертификаты серверов, используемые для проверки подлинности серверов очереди сообщений, должны устанавливаться отдельно от любых сертификатов пользователей (клиентов), которые могут быть установлены для проверки подлинности сообщений. Однако при правильной настройке один сертификат может использоваться как очередью сообщений для проверки подлинности серверов, так и информационными службами Интернета (IIS) для установки безопасных подключений к Web (по протоколу HTTP-S).

Проверка подлинности сообщений HTTP

Когда проверяется подлинность сообщений, передаваемых с помощью транспорта HTTP, отправитель вкладывает в сообщение цифровую подпись XML и внешний или внутренний сертификат пользователя, содержащий имя пользователя, его открытый ключ и подпись издателя. В отличие от сообщений, передаваемых обычным транспортом, здесь код SID отправителя не используется для проверки подлинности, и получателю для проверки цифровой подписи приходится прибегать к другим методам, например, привлекать внешние сертификаты из доверенных центров сертификации. Это касается как сообщений, передаваемых в рамках одного леса, так и сообщений, отправляемых в другой лес. Когда сообщения передаются по транспорту HTTPS, необходимо соблюсти дополнительные меры безопасности, прежде чем можно будет установить сеанс SSL между отправителем и получателем.

Дополнительные сведения о получении внешних сертификатов из центров сертификации и о проверке цифровых подписей в сообщениях, передаваемых по транспорту HTTP в пределах леса или между разными лесами, см. в разделе Проверка подлинности сообщений HTTP/HTTPS.

Дополнительные сведения о передаче сообщений в рамках сеансов SSL с помощью транспорта HTTPS см. в разделе Сообщения HTTPS.


Шифрование в очереди сообщений

В контексте очереди сообщений шифрование представляет собой процесс кодирования и декодирования сообщений, гарантирующий, что они не смогут быть прочитаны или использованы лицами, не имеющими на то полномочий. Шифрование в очереди сообщений реализовано с помощью алгоритмов, использующих симметричные и асимметричные (открытые/закрытые) ключи. Используемые методы шифрования основаны на интерфейсе Microsoft Cryptographic Application Program Interface CryptoAPI, для которого, в свою очередь, используется поставщик службы криптографии (CSP), установленный на компьютере.

Шифрование сообщений не является обязательным. При отправке и получении сообщений приложения очереди сообщений необязательно должны использовать шифрование. Следует иметь в виду, что шифрование сообщений замедляет их передачу. Если приложения очереди сообщений все же отправляют или получают сообщения с шифрованием, то должен использоваться поставщик службы криптографии (CSP), устанавливаемый по умолчанию вместе с Windows XP; он необходим как для шифрования сообщений, так и для проверки их подлинности. Дополнительные сведения о проверке подлинности сообщений содержатся в разделе Проверка подлинности в очереди сообщений.

Хотя для шифрования данных, не относящихся к очереди сообщений, могут быть использованы другие поставщики CSP, тот, который входит в комплект Windows XP, должен обязательно использоваться любым приложением очереди сообщений, отправляющим и получающим шифрованные сообщения. Приложения, не работающие с очередью сообщений, могут продолжать использовать других поставщиков службы криптографии.

Примечания

  • Американская версия Windows 2000 поддерживает 128-разрядное шифрование в дополнение к 40-разрядному, но остальные версии Windows 2000 не поддерживают 128-разрядное шифрование. В американской версии поставщик CSP для 128-разрядного шифрования называется Microsoft Enhanced Cryptographic Service Provider (Усовершенствованный поставщик службы криптографии Майкрософт).

Механизм шифрования сообщений

Сообщения шифруются службой очереди сообщений на исходном компьютере и дешифруются службой очереди сообщений на конечном компьютере. Расшифрованные сообщения хранятся в конечной очереди в виде открытого текста. Поскольку для доступа к конечному компьютеру и его очереди пользователю нужны соответствующие разрешения, сообщения, хранящиеся на конечном компьютере открытым текстом, не составляют предмета внимания для системы безопасности. Шифрование сообщений направлено на предотвращение несанкционированного просмотра передаваемых сообщений.

Использование шифрования сообщений приводит к снижению быстродействия, хотя и не в такой степени, как при проверке подлинности сообщений. Наиболее заметное снижение быстродействия наблюдается при отправке зашифрованных сообщений на множество разных компьютеров. Однако при отправке нескольких сообщений на один конечный компьютер только отправка первого сообщения занимает больше времени, чем обычно.

Чтобы выяснить причину снижения пропускной способности, важно понять, как работает механизм шифрования, используемый в очереди сообщений. На исходном компьютере служба очереди сообщений выполняет следующие действия:

  1. создает секретный ключ;
  2. шифрует тело сообщения с помощью секретного ключа;
  3. шифрует секретный ключ, используя открытый ключ конечного компьютера;
  4. вкладывает зашифрованный секретный ключ в зашифрованное сообщение.

На конечном компьютере служба очереди сообщений выполняет следующие действия:

  1. расшифровывает секретный ключ, используя свой закрытый ключ (из имеющейся пары ключей);
  2. расшифровывает тело сообщения с использованием секретного ключа.

Секретные ключи могут использоваться как для шифрования, так и для расшифровки, поэтому они и называются симметричными. Открытые ключи могут использоваться только для шифрования, а закрытые — только для расшифровки.

Шифрование с использованием асимметричного ключа сильнее загружает систему, чем шифрование с использованием симметричного ключа. Отправка первого сообщения занимает больше времени из-за шифрования секретного ключа с использованием открытого ключа конечного компьютера. По умолчанию очередь сообщений хранит зашифрованный секретный ключ на исходном компьютере 10 минут. При отправке дополнительных сообщений на тот же компьютер в течение 10 минут после отправки первого сообщения используется тот же секретный ключ. В результате для каждого следующего сообщения задержка будет определяться только временем, необходимым для шифрования тела сообщения с использованием секретного ключа. В этом случае очереди сообщений не нужно будет каждый раз заново шифровать секретный ключ, используя открытый ключ конечного компьютера. Такая же ситуация с производительностью наблюдается и на конечном компьютере. Получив первое сообщение, служба очереди сообщений расшифровывает секретный ключ с помощью своего собственного закрытого ключа. Затем расшифрованный ключ сохраняется и позже может повторно использоваться при обработке следующих сообщений, позволяя избежать дополнительной нагрузки.

Уровень конфиденциальности очереди определяет, какие в нее могут помещаться сообщения: зашифрованные, незашифрованные или и те и другие. Если выбран уровень конфиденциальности Нет, в очередь будут помещаться только незашифрованные сообщения. Если выбран уровень конфиденциальности Тело сообщения, в очередь будут помещаться только зашифрованные сообщения. Если выбран уровень конфиденциальности Необязательно, в очередь будут помещаться как незашифрованные, так и зашифрованные сообщения. Чтобы проверить, зашифровано сообщение, отправленное в очередь, или нет, можно воспользоваться оснасткой «Active Directory – Пользователи и компьютеры» (или в программе — проверить значение свойства сообщения PROPID_M_PRIV_LEVEL).

Дополнительные сведения об установке уровня конфиденциальности очереди см. в разделе Изменение уровня конфиденциальности очереди.

Примечания

  • Зашифрованные сообщения, отправленные на инородные компьютеры, остаются зашифрованными на промежуточном сервере очереди сообщений, на котором установлено приложение-подключатель. Подключатель может пересылать зашифрованные сообщения на инородный компьютер либо предварительно расшифровывать их перед отправкой.
  • Поскольку для шифрования требуется доступ к Active Directory, его нельзя использовать в режиме рабочей группы и в автономном режиме.

Криптографические ключи

Пары криптографических ключей компьютера, состоящие из открытого и закрытого ключей, создаются во время установки очереди сообщений и могут быть обновлены в диалоговом окне Свойства: Очередь сообщений, открываемом из оснастки «Управление компьютером». Все компьютеры очереди сообщений, кроме зависимых клиентов, используют криптографические ключи.

Дополнительные сведения о криптографических ключах для Windows XP Professional см. в разделе «Создание криптографических ключей и запросов сертификатов» в справке Windows 2000 Server.

Обновление криптографического ключа — это одна из возможностей системы безопасности очереди сообщений. Криптографические ключи рекомендуется обновлять периодически, например, раз в год. Кроме того, ключи следует обновлять всякий раз, когда вы подозреваете, что кто-то получил к ним доступ. Таким образом можно уменьшить вероятность несанкционированного использования закрытого ключа.

После обновления криптографических ключей для компьютера очереди сообщений нельзя будет расшифровать сообщения, которые были зашифрованы с помощью старых открытых ключей. Это будет происходить только до тех пор, пока новые открытые ключи не будут реплицированы в Active Directory на все серверы очереди сообщений, а исходный компьютер не начнет использовать эти ключи.

О том, как обновлять криптографические ключи, см. раздел Обновление криптографических ключей для очереди сообщений.


Аудит доступа в очереди сообщений

С помощью средств аудита доступа можно записывать, какие пользователи предпринимают попытки доступа к объектам очереди сообщений, операции какого типа они пытаются выполнять и насколько успешными оказываются эти попытки. В дескрипторе безопасности объекта указано, какие события доступа для этого объекта подлежат аудиту. Эта часть дескриптора безопасности называется системной таблицей управления доступом (SACL). В таблице SACL указываются следующие сведения.

  • Пользователи или группы, подлежащие аудиту при осуществлении доступа к объекту.
  • События доступа, подлежащие аудиту для каждой группы или пользователя.
  • Атрибут «Успех» или «Неудача» для каждого события доступа, в зависимости от разрешений, предоставленных каждой группе или пользователю в избирательной таблице управления доступом (DACL) данного объекта.

Дополнительные сведения об аудите в системе Windows XP Professional см. в разделе «Аудит событий безопасности» справки Windows 2000 Server.

В журнал безопасности записываются сообщения аудита о контролируемых операциях; их можно просматривать с помощью программы просмотра событий. Дополнительные сведения о программе просмотра событий содержатся в разделе Просмотр событий.

Настройка аудита доступа

Прежде чем приступать к реализации аудита доступа, необходимо сначала установить политику аудита. Политика аудита определяет категории событий, связанных с безопасностью, которые необходимо отслеживать. При установке политики аудита для сервера очереди сообщений необходимо, чтобы ему было предоставлено разрешение Управление аудитом и журналом безопасности. Дополнительные сведения об установке политики аудита см. в разделе «Установка политики аудита» в справке Windows 2000 Server.

Затем следует выбрать категорию доступа к объектам и задать параметры аудита для отдельных объектов. При выборе категории доступа можно использовать страницу Свойства для конкретных объектов очереди сообщений, задавая на ней, следует ли вести аудит успешных или неудачных попыток доступа в свете разрешений, предоставленных каждой группе или пользователю. Дополнительные сведения об установке параметров аудита для объектов «компьютер» (msmq) и «очередь» см. в разделе Аудит доступа к объектам компьютеров и очередей. Дополнительные сведения об установке параметров аудита для объекта «маршрутная ссылка» см. в разделе Аудит доступа к объектам маршрутных ссылок.

Если задать параметры аудита для объекта очереди сообщений, не установив политику аудита на сервере очереди сообщений, выполняющем соответствующую операцию, сообщение аудита не будет создано.

Примечания

  • Может быть выдано сообщение об ошибке, в котором говорится, что аудит доступа не включен. Такое сообщение означает, что на используемом компьютере аудит доступа отключен или не установлена политика аудита; это не значит, что аудит доступа не включен на компьютере, для которого предполагалось вести аудит.

Сообщения аудита

Сообщения аудита создаются в журнале безопасности на компьютере, выполняющем контролируемую операцию; этим компьютером не обязательно должен быть владелец объекта. Поэтому сообщения аудита для одного объекта очереди сообщений могут быть рассредоточены по всей сети. Например, на данном рисунке, если тестовая очередь, расположенная на клиентском компьютере 1 в сайте в Сан-Франциско, удалена клиентом 2, расположенным в сайте в Сиэтле, сообщение аудита будет создано на сервере 2 в сайте в Сиэтле.

Создание сообщений аудита

При доступе к очереди сообщение аудита для этой операции всегда создается на компьютере, на котором расположена очередь,. Поскольку все операции с очередями, кроме получения и просмотра сообщений, выполняются сервером очереди сообщений, сообщения аудита создаются на сервере очереди сообщений, выполняющем соответствующую операцию. Сообщения аудита создаются только при доступе к очереди, но не при получении или отправлении каждого сообщения.

Для каждого сообщения аудита в журнале безопасности создается запись Открытие и запись Закрытие. Если обращение к очереди выполняется для операции получения или просмотра сообщения, запись Закрытие заносится в журнал непосредственно после записи Открытие.


Администрирование очереди сообщений

В данном разделе рассматриваются вопросы администрирования и наблюдения за компьютерами, очередями и другими объектами, используемыми очередью сообщений. Этот раздел рекомендуется прочитать после установки очереди сообщений и настройки соответствующих параметров безопасности.

  • Администрирование очереди сообщений: обзор
  • Администрирование сети очереди сообщений
  • Администрирование компьютеров очереди сообщений
  • Администрирование очередей в службе очереди сообщений
  • Администрирование сообщений в службе очереди сообщений
  • Наблюдение за очередью сообщений

В данном разделе не рассказывается об установке параметров безопасности. Дополнительные сведения о защите данных очереди сообщений см. в разделе Очередь сообщений и безопасность.


Администрирование очереди сообщений: обзор

Администрирование сети и компьютеров, использующих очередь сообщений, выполняется преимущественно с помощью оснасток, отображаемых в консоли управления (MMC). Для выполнения некоторых задач администрирования служит диалоговое окно Свойства службы очередей, которое может быть открыто с помощью оснастки «Управление компьютером». В следующей таблице показаны средства администрирования, используемые для управления очередью сообщений.

Средство администрирования | Тип средства | Выполняемые задачи
Управление компьютером | оснастка консоли управления | большинство задач при работе в режиме рабочей группы; управление очередями и сообщениями, некоторые локальные задачи; управление сертификатами пользователей и криптографическими ключами
Active Directory – пользователи и компьютеры | оснастка консоли управления | большинство задач при работе в режиме домена; управление компьютерами, очередями и сообщениями
Active Directory – сайты и службы | оснастка консоли управления | некоторые задачи при работе в режиме домена; управление маршрутными ссылками и инородными сайтами

Общие сведения о консоли управления и ее оснастках содержатся в разделе Консоль управления Microsoft.

Для администрирования объектов MSMQ на компьютерах с MSMQ 1.0 использовалась программа MSMQ Explorer, но она не работает на компьютерах с Windows XP или Windows 2000. В Windows XP для администрирования очереди сообщений служат оснастки консоли управления (MMC) «Управление компьютером», «Active Directory - пользователи и компьютеры» и «Active Directory - сайты и службы». Сведения о доступе к информации на сервере контроллера MSMQ 1.0 с помощью клиента очереди сообщений, запущенного на компьютере, работающем под управлением Windows XP или Windows 2000 в среде со смешанным режимом, содержатся в разделе Роль средства администрирования.

Примечания

  • В этом разделе не рассматривается администрирование безопасности очереди сообщений. Сведения о безопасности в очереди сообщений содержатся в разделе Безопасность очереди сообщений: обзор.

Администрирование очереди сообщений с использованием оснасток

Для администрирования очереди сообщений служат три оснастки. Оснастка «Управление компьютером» предоставляет доступ к локальным очередям и сообщениям. Оснастки «Active Directory - пользователи и компьютеры» и «Active Directory - сайты и службы» предоставляют доступ к сведениям Active Directory о маршрутизации, компьютерах, очередях и других объектах очереди сообщений в составе данного леса Windows 2000. Дополнительные сведения об объектах, связанных с очередью сообщений, содержатся в разделе Объекты очереди сообщений в Active Directory.

Большинство объектов очереди сообщений отображаются в дереве консоли (обычно это левая область) окна, отображающего оснастки. Когда требуется просмотреть свойства какого-либо объекта очереди сообщений, следует щелкнуть его в дереве консоли правой кнопкой мыши и выбрать команду Свойства. В области сведений (обычно это правая область) окна консоли управления обычно отображаются (в столбцах) имя, тип и свойства объектов очереди сообщений.

Репликация Active Directory может задерживать обновление отображаемых сведений, поэтому изменения, вносимые в оснастке, не отображаются, пока не будет выполнена их репликация. Например, при добавлении очереди на компьютер в сайте В с компьютера в сайте Б изменения в соответствующей оснастке не отображаются, пока они не будут реплицированы с сайта В в сайт Б. Для обновления сведений, отображаемых в оснастке, после внесения изменений нажмите клавишу F5.

Важно!

  • Оснастки «Active Directory – Пользователи и компьютеры» и «Active Directory – Сайты и службы» не входят в состав Windows XP Professional и не могут быть установлены на компьютер, работающий под управлением Windows XP Professional, при установке средств администрирования Windows 2000. Эти оснастки необходимы для администрирования сети очереди сообщений, использующей домены, а также для доступа к содержимому Active Directory и его отображения. Указанные оснастки можно запустить, открыв подключение к удаленному рабочему столу на компьютере Windows XP Professional для доступа к службе терминалов на контроллере домена Windows 2000 или рядовом сервере, на котором установлены эти оснастки. Таким образом можно выполнять административные процедуры в доменной среде и обращаться к службе Active Directory с компьютера очереди сообщений, работающего под управлением Windows XP Professional. Дополнительные сведения содержатся в разделе Средства администрирования.

Оснастка «Управление компьютером»

Оснастка «Управление компьютером» позволяет выполнять множество повседневных задач администрирования применительно к очередям и сообщениям. По сути, это единственная оснастка, предназначенная для управления очередью сообщений в среде рабочей группы (при отсутствии домена Windows 2000).

Оснастка «Управление компьютером» служит для выполнения следующих задач.

  • Создание и просмотр частных очередей и задание свойств очередей.
  • Просмотр кэшированных общих очередей (если локальный компьютер ранее входил в состав домена и имел доступ к Active Directory).
  • Приостановка и возобновление работы какой-либо исходящей очереди.
  • Приостановка и возобновление работы всех исходящих очередей компьютера.
  • Просмотр свойств сообщений и очистка исходящих очередей от сообщений.
  • Управление очередями и сообщениями на других компьютерах.

Кроме того, диалоговое окно Свойства службы очередей, которое можно открыть с помощью оснастки «Управление компьютером», можно использовать для выполнения следующих локальных задач администрирования очереди сообщений.

  • Задание локальных дисковых устройств и папок для хранения сообщений и файлов журнала.
  • Регистрация, удаление, обновление и просмотр сертификатов пользователей.
  • Смена и просмотр сертификата сервера.
  • Обновление криптографических ключей.
  • Настройка проверки подлинности сервера при взаимодействии с серверами контроллеров MSMQ 1.0.
  • Указание нового сайта, на который будут пересылаться сообщения для мобильных компьютеров (это относится только к компьютерам очереди сообщений версии 3.0, работающим в сети предприятия Windows NT 4.0, которые могут подключаться к серверам контроллеров MSMQ 1.0 для доступа к базе данных MQIS).

Исходящие очереди отображаются только при использовании оснастки «Управление компьютером». Они не отображаются ни в какой другой оснастке.

Оснастка «Управление компьютером» позволяет управлять очередями и сообщениями на других компьютерах (при наличии административных разрешений для этих компьютеров). Дополнительные инструкции по управлению очередями и сообщениями на других компьютерах содержатся в разделе Управление очередями и сообщениями на других компьютерах.

Для управления очередями и сообщениями на всех компьютерах в рабочей группе (или домене) можно создать файл консоли MMC (.msc), отображающий все требуемые компьютеры. Сведения о создании файлов консоли содержатся в разделе «Создание консолей» справки Windows 2000 Server.

Примечания

  • Только оснастка «Управление компьютером» позволяет управлять очередью сообщений в контексте виртуального сервера в кластере. В этом случае отображается объект группы кластера, обладающий ресурсом типа «Сетевое имя» виртуального сервера. Ниже этого объекта в дереве отображаются объекты очереди сообщений.

Оснастка «Active Directory – пользователи и компьютеры»

Оснастка «Active Directory - пользователи и компьютеры» служит для выполнения следующих задач администрирования очереди сообщений, включая Active Directory, в среде домена.

  • Просмотр всех компьютеров очереди сообщений и задание свойств отдельных компьютеров.
  • Создание, просмотр, удаление и поиск всех общих очередей и задание свойств очередей.
  • Создание, просмотр и удаление локальных частных очередей и задание свойств очередей.
  • Просмотр свойств сообщений и очистка очередей от сообщений.
  • Отправка сообщений MQPing, тестовых сообщений и настройка слежения за маршрутом сообщений.
  • Создание и удаление псевдонимов очереди, а также просмотр и изменение их свойств

Ссылка, использованная в шаге 1 некоторых процедур для открытия оснастки «Active Directory - пользователи и компьютеры» открывает консоль управления в авторском режиме. Данная консоль должна быть первоначально открыта в авторском режиме, что позволяет выбрать требуемые параметры просмотра для отображения всех объектов очереди сообщений в Active Directory. В процедурах присутствует следующий шаг:

"Установите в меню Вид флажок Пользователи, группы и компьютеры как контейнеры, а затем — флажок Дополнительные функции."

Эти изменения можно сохранить, чтобы текущий режим всегда включался по умолчанию, путем создания файла .msc для этой оснастки. В этом случае сначала нужно открыть ранее созданный файл .msc, в меню Файл выбрать команду Параметры, а затем выбрать одну из трех записей пользовательских режимов в группе Режим консоли. Теперь консоль будет открываться в выбранном пользовательском режиме с текущими настройками. Открытие консоли оснастки в одном из пользовательских режимов (а не в авторском режиме) более безопасно с точки зрения администратора, так как никто больше не сможет изменять режим работы и внешний вид этой оснастки.

Оснастка «Active Directory – сайты и службы»

Оснастка «Active Directory - сайты и службы » служит для выполнения следующих задач администрирования очереди сообщений, включая Active Directory, в среде домена.

  • Создание и удаление маршрутных ссылок, а также просмотр и задание их свойств (включая шлюзы сайта).
  • Создание инородных сайтов и инородных компьютеров, а также просмотр и задание их свойств.
  • Задание времени жизни сообщений в сети (называемое сроком поступления в очередь)

Ссылка, использованная в шаге 1 некоторых процедур для открытия оснастки «Active Directory - сайты и службы » открывает консоль управления в авторском режиме. Данная консоль должна быть первоначально открыта в авторском режиме, что позволяет выбрать требуемый режим просмотра для отображения всех объектов очереди сообщений в Active Directory. В процедурах присутствует следующий шаг:

"В меню Вид выберите команду Показать узел служб."

Эти изменения также можно сохранить, чтобы текущий режим всегда включался по умолчанию, путем создания файла .msc для этой оснастки, как было описано выше.


Администрирование сети очереди сообщений

В этом разделе приведены инструкции по настройке свойств очереди сообщений, относящихся к среде домена на уровне сети, таких как маршрутные ссылки и инородные сайты. Для выполнения задач администрирования на уровне сети служит оснастка «Active Directory - сайты и службы». Здесь также приведены инструкции по настройке брандмауэра для возможности взаимодействия компьютеров, использующих очередь сообщений, в локальной сети и во внешних сетях.

Настройка маршрутных ссылок

Для маршрутизации сообщений между очередями сообщений используются маршрутные ссылки. При создании сайта Windows 2000 следует создать и соответствующую маршрутную ссылку, чтобы обеспечить доставку сообщений на другие сайты. Тем не менее, запрос на создание маршрутной ссылки при создании сайта не выдается. Для распределения нагрузки и обеспечения надежности можно создать несколько маршрутных ссылок.

Инструкции по созданию маршрутных ссылок содержатся в разделе Создание маршрутной ссылки.

Примечания

  • По умолчанию в среде нескольких доменов одной организации только пользователи, имеющие разрешения администратора предприятия (или члены группы «Администраторы предприятия»), могут создавать и изменять маршрутные ссылки. Для возможности создания и изменения маршрутных ссылок членами группы «Администраторы домена» они должны быть наделены разрешением «Создание всех дочерних объектов» для объекта «MsmqServices». Инструкции по заданию разрешений на действия с маршрутными ссылками содержатся в разделе Задание разрешений для объектов маршрутных ссылок.

По умолчанию всем маршрутным ссылкам назначена цена 1. Это значение следует изменять только при наличии нескольких маршрутов, если требуется поднять приоритет использования одного маршрута относительно другого с использованием цены ссылки. В этом случае можно назначить цены, отражающие разницу в стоимости подключений между различными ссылками. Цена может изменяться от 1 до 999999.

Например, между двумя сайтами в одном городе, А и Б, имеется связь по высокоскоростной линии, а удаленный сайт В подключен к сайту Б по низкоскоростной линии. В этом случае следует установить цену ссылки между сайтами А и Б 1, а между сайтами Б и В – 2. Инструкции по изменению цены маршрутной ссылки см. в разделе Изменение цены маршрутной ссылки.

Для передачи сообщений между двумя сайтами по маршрутной ссылке могут использоваться серверы очереди сообщений с поддержкой маршрутизации, называемые шлюзами сайта. Маршрутная ссылка может иметь любое количество шлюзов сайта или вообще не иметь шлюз сайта, а каждый шлюз сайта может принадлежать одному или обоим сайтам, соединенным маршрутной ссылкой. Если маршрутная ссылка связана с парой шлюзов сайтов, для передачи сообщений от имени одного из клиентов по данной маршрутной ссылке будут использоваться только эти серверы. С помощью маршрутных ссылок должны быть связаны все сайты в рамках организации.

Инструкции по смене серверов очереди сообщений, используемых маршрутными ссылками, содержатся в разделе Смена шлюзов сайта для маршрутной ссылки.

Дополнительные общие сведения о маршрутных ссылках и шлюзах сайта содержатся в разделе Межсайтовая маршрутизация.

Настройка инородных сайтов и инородных компьютеров

Для взаимодействия с инородными компьютерами необходимо сначала создать инородный сайт, добавить в него инородные компьютеры, а затем создать очереди на инородных компьютерах. Все они являются объектами очереди сообщений в Active Directory, существование которых в материальном мире не существенно. Затем следует создать маршрутную ссылку между инородным сайтом и сайтом очереди сообщений Windows 2000 (неинородным), содержащим сервер очереди сообщений с приложением-подключателем, задать этот сервер очереди сообщений в качестве шлюза сайта для маршрутной ссылки и добавить этот сайт в список сайтов, в котором находится данный компьютер.

Если все инородные компьютеры обслуживаются одним приложением-подключателем, их можно поместить в один инородный сайт. Приложения-подключатели работают на серверах очереди сообщений и позволяют инородным компьютерам взаимодействовать с клиентами очереди сообщений в локальной сети. Хорошими примерами приложений-подключателей очереди сообщений являются Microsoft MSMQ-MQSeries Bridge и Message Queuing Connector (MQC). Когда компьютер с очередью сообщений отправляет сообщение инородному компьютеру, это сообщение пересылается на сервер очереди сообщений на котором работает приложение-подключатель в инородном сайте, поскольку этот сервер также является шлюзом сайта в маршрутной ссылке, подключающейся к инородному сайту. Когда сервер распознает местоназначение сообщения как очередь на инородном компьютере, он помещает его в очередь подключателя. Впоследствии сообщение обрабатывается приложением-подключателем, взаимодействующим с инородным компьютером.

Необходимо создать маршрутные ссылки между инородным сайтом и каждым сайтом Windows 2000, который будет с ним взаимодействовать. Сервер очереди сообщений в инородном сайте, на котором работает приложение-подключатель, также должен выступать в роли шлюза сайта в каждой маршрутной ссылке, подключающейся к инородному сайту. Более того, если шлюз в маршрутной ссылке на инородный сайт станет недоступен, шлюзы в других сайтах, взаимодействующие с этим инородным сайтом, не смогут отправлять сообщения в соответствующую очередь подключателя для передачи на компьютеры в инородном сайте. Шлюзы сайта всегда назначены определенной маршрутной ссылке. Поэтому по возможности рекомендуется создавать несколько маршрутных ссылок на инородный сайт.

Инструкции по созданию инородных сайтов содержатся в разделе Создание инородных сайтов.

Сведения о добавлении инородных компьютеров и сервера очереди сообщений, на котором работает приложение-подключатель, в инородный сайт содержатся в разделе Добавление инородных компьютеров в сайт.

Инструкции по созданию и настройке маршрутных ссылок содержатся в разделе Настройка маршрутных ссылок.

Использование Microsoft MSMQ-MQSeries Bridge

Microsoft MSMQ-MQSeries Bridge – это приложение-подключатель, обеспечивающее интерфейс между компьютерами, на которых работают приложения очереди сообщений, и компьютерами, на которых работают приложения IBM MQSeries. Для отправки сообщения с компьютера, использующего очередь сообщений, на компьютер, использующий MQSeries, на инородном компьютере (MQSeries) должна существовать конечная очередь. Дополнительные сведения о настройке приложения Microsoft MSMQ-MQSeries Bridge и инородных компьютеров, использующих IBM MQSeries, содержатся в документации по Microsoft MSMQ-MQSeries Bridge.

В настоящее время Microsoft MSMQ-MQSeries Bridge поставляется как часть сервера Microsoft Host Integration Server 2000. Дополнительные сведения о Microsoft Host Integration Server 2000 см. на веб-узле Microsoft Host Integration Server (http://www.Microsoft.com/hiserver/).

Работа с Message Queuing Connector

Message Queuing Connector (MQC) – это приложение-подключатель, обеспечивающее связь между компьютерами, работающими с приложениями очереди сообщений в операционных системах Windows, и компьютерами, работающими с приложениями очереди сообщений в других операционных системах. Приложение MQC включено в установочные диски Windows 2000 Server и может быть установлено на компьютере, где находится сервер очереди сообщений. Чтобы отправить сообщение на инородный компьютер, работающий не под управлением ОС Windows, сначала необходимо приобрести и установить клиентское программное обеспечение, предоставляемое компанией Level 8 Systems. Некоторые инородные компьютеры работают так же, как зависимые клиенты, поэтому сервер очереди сообщений, на котором установлено приложение MQC, должен быть поддерживающим их сервером. Дополнительные сведения о приложении MQC содержится в документации по нему. MQC находится на установочных дисках Windows 2000 Server в папке Valueadd\3rdparty\Level8\Mqc.que.

Дополнительные сведения о клиентском программном обеспечении, которое необходимо в этом случае, можно найти в документации, поставляемой с продуктами Level 8 Systems, или на веб-узле Level 8 Systems (http://www.level8.com/index.cfm?handle=gmq).

Для связи в пределах организации можно совместно использовать очередь сообщений, Microsoft MSMQ-MQSeries Bridge и MQC. Например, можно обмениваться сообщениями между очередью сообщений на компьютерах UNIX и IBM MQSeries на компьютерах AS/400.

Настройка брандмауэра

Брандмауэр данной организации можно настроить так, чтобы обеспечить связь компьютеров, находящихся по разные его стороны. Это включает возможность подключения компьютеров, использующих очередь сообщений и находящихся во внешней сети, к компьютерам, использующим очередь сообщений и находящимся во внутренней сети, через Интернет. Это достигается открытием в брандмауэре следующих портов.

TCP | 1801
RPC | 135, 2101, 2103, 2105
UDP | 3527, 1801

Важно!

  • Если компьютеры, использующие очередь сообщений и находящиеся во внешней сети, требуют доступа к Active Directory, рекомендуется настроить подключение к частной виртуальной сети (VPN) по протоколу PPTP; в противном случае пострадает безопасность сети. Дополнительные сведения о подключении к VPN и протоколе PPTP содержатся в разделе Протокол PPTP (Point-to-Point Tunneling Protocol).

Примечания

  • При использовании прямого формата имен необходимо открыть только порт TCP. Он обеспечивает двустороннюю отправку но только локальное чтение. Чтобы получить возможность чтения из удаленных очередей или обращения к Active Directory для получения сведений, относящихся к общим очередям или другим объектам очереди сообщений, необходимо дополнительно открыть порты RPC.
  • Если при запуске службы очередей сообщений исходные порты службы PRC заняты, их номера 2103 и 2105 будут увеличены на 11. Для поиска портов 2xxx служба очередей сообщений отправляет запрос в порт RPC 135.
  • MQPing работает по протоколу UDP через порт 3527.

Следующая настройка брандмауэра поддерживает три различных режима работы удаленных компьютеров, использующих очередь сообщений и расположенных во внешних сетях.

Только отправка сообщений

Для возможности отправки сообщений удаленными клиентами необходимо разрешить им доступ через брандмауэр по протоколу TCP к порту 1801.

В этом случае для удаленных клиентов будут недоступны каталог Active Directory и маршрутизация сообщений через серверы очереди сообщений внутренней сети. Это значит, что удаленные клиенты должны обладать возможностью непосредственного подключения к конечному компьютеру во внутренней сети через этот порт. Теперь удаленные клиенты смогут отправлять сообщения в конечные очереди, используя прямое имя формата.

Это не относится к зависимым клиентам.

Отправка сообщений с использованием доступа к Active Directory

Вдобавок к открытию порта 1801 для протокола TCP, разрешение доступа к портам RPC 135 и 2101 позволяет удаленным клиентам обращаться к Active Directory. Порт RPC 135 используется для синхронизации удаленного клиента и сервера очереди сообщений. Серверы очереди сообщений также используют порт RPC 2101 для взаимодействия друг с другом.

Если передача сетевых пакетов многоадресной рассылки через брандмауэр разрешена, разрешение доступа к порту UDP 1801 также позволит удаленным клиентам отправлять широковещательные сообщения для определения их сайта.

Это не относится к зависимым клиентам.

Отправка и получение сообщений с использованием доступа к Active Directory

Вдобавок к открытию порта 1801 для протокола TCP и портов RPC 135 и 2101, разрешение доступа к портам RPC 2103 и 2105 также позволит удаленным пользователям обращаться к очередям и получать сообщения с компьютеров, использующих очереди сообщений, во внутренней сети.

Доступ к портам RPC 2103 и 2105 позволит также удаленным зависимым клиентам отправлять и получать сообщения с помощью сервера, поддерживающего их в вашей сети.


Администрирование компьютеров с очередями сообщений

В этом разделе приведены инструкции по настройке и управлению компьютерами, использующими очереди сообщений, в локальной сети. Для выполнения задач администрирования на уровне компьютеров служат оснастки «Управление компьютером» и «Active Directory - пользователи и компьютеры».

Присоединение к домену из рабочей группы

Очередь сообщений можно использовать в среде, не являющейся доменом Windows 2000, такой как компьютер, входящий в рабочую группу Windows XP. Если очередь сообщений работает на компьютере, входящем в рабочую группу, этот компьютер может позже присоединиться к домену. И наоборот, компьютер, использующий очередь сообщений и входящий в домен, может присоединиться к рабочей группе. Этот же компьютер позже может опять присоединиться к тому же или новому домену. Компьютер с очередью сообщений, работающий под управлением Windows XP, может присоединяться к любому новому домену Windows 2000. Чтобы компьютер с очередью сообщений, работающий под управлением Windows XP, смог присоединиться к новому домену должен быть доступен контроллер домена. Рекомендуется также, чтобы контроллер домена был назначен сервером глобального каталога. Кроме того, компьютеры, использующие очередь сообщений, могут входить только в домены Windows 2000. Инструкции по присоединению к домену из рабочей группы содержатся в разделе Присоединение к домену из рабочей группы.

В Windows 2000 возможности службы каталогов настраиваются пользователем. Если сервер очереди сообщений использует возможности службы каталогов, эти возможности будут доступны всякий раз, когда компьютер будет становиться контроллером домена.

Сведения об ограничениях в работе очереди сообщений в среде рабочей группы содержатся в разделе Режим рабочей группы.

Назначение серверов входящей и исходящей маршрутизации

Для маршрутизации сообщений внутри сайта можно использовать серверы очереди сообщений, называемые серверами входящей и исходящей маршрутизации. Каждый независимый клиент (или сервер очереди сообщений без поддержки маршрутизации) можно настроить для использования до трех серверов входящей и исходящей маршрутизации для пересылки сообщений от их имени.

Мобильные клиенты, обычно отключенные от сети или подключающиеся к ней через сервер удаленного доступа, должны использовать серверы входящей и исходящей маршрутизации.

Один сервер очереди сообщений может быть как сервером входящей, так и сервером исходящей маршрутизации. Однако все эти серверы должны находиться в исходном сайте клиента (в сайте, где установлен этот клиент). При перемещении мобильного клиента в другой сайт эти серверы не будут использоваться для маршрутизации сообщений, пока клиент не вернется в исходный сайт.

Для обеспечения надежности рекомендуется настроить клиентов на использование нескольких серверов входящей и исходящей маршрутизации.

Инструкции по выбору и смене серверов входящей и исходящей маршрутизации содержатся в разделе Смена серверов входящей или исходящей маршрутизации.

Добавление и удаление сайтов из списка сайтов, в котором находится сервер маршрутизации

В большинстве случаев очередь сообщений автоматически определяет сайт, в котором находятся серверы. Очередь сообщений также позволяет вручную добавлять или удалять сайты из списка сайтов, в котором находится сервер очереди сообщений с поддержкой маршрутизации, также называемый «сервер маршрутизации». Любой сервер маршрутизации, находящийся в определенном сайте, может являться сервером входящей и исходящей маршрутизации для компьютеров, находящихся в данном сайте. Кроме того, такие серверы маршрутизации могут являться шлюзами сайта в маршрутных ссылках на этот сайт. Сервер маршрутизации может находиться в нескольких сайтах, его можно настроить в качестве сервера входящей и исходящей маршрутизации или шлюза сайта независимо в каждом сайте в котором он находится.

Сведения о добавлении сайтов в список сайтов, в котором находится сервер очереди сообщений с поддержкой маршрутизации, содержатся в разделе Добавление сайтов в список сайтов сервера очереди сообщений.

Сведения об удалении сайтов из списка сайтов, в котором находится сервер очереди сообщений с поддержкой маршрутизации, содержатся в разделе Удаление сайтов из списка сайтов сервера очереди сообщений.

Перемещение мобильных компьютеров в новый сайт

Компьютеры с Windows XP можно переместить в другие сайты Windows 2000. При перемещении компьютера в новый сайт очередь сообщений автоматически обнаруживает контроллер домена в новом сайте и использует его для информационных служб. Затем в службу каталогов добавляются сведения о новом сайте в котором расположен компьютер. После установки нового сайта все сообщения, отправленные на компьютер, пока он был отключен, пересылаются из предыдущего сайта в новый. После того как компьютер подключится к новому сайту, все новые сообщения сразу будут маршрутизироваться ему в этот сайт. Если компьютер является сервером маршрутизации очереди сообщений, все его возможности автоматически восстанавливаются в новом сайте.

Компьютеры с Windows XP, использующие контроллер сайта MSMQ 1.0 в качестве информационного сервера, не способны автоматически обнаружить новый сайт. В этом случае можно указать имя нового сайта как перед отключением компьютера от сети, так и после подключения к ней. Выбор нового сайта позволяет компьютеру подключаться к ближайшему серверу контроллера и, таким образом, оптимизировать доступ к базе данных MQIS. Если новый сайт указан до отключения от сети, все сообщения, отправляемые компьютеру пока он отключен, сразу будут направляться в новый сайт. Если новый сайт компьютера не указан, очередь сообщений будет пытаться использовать контроллер сайта в предыдущем сайте. Все сообщения, отправляемые этому компьютеру, будут пересылаться в его предыдущий сайт. Это относится только к независимым клиентам очереди сообщений и серверам очереди сообщений, не поддерживающим маршрутизацию. Серверы очереди сообщений, поддерживающие маршрутизацию (обеспечивающие маршрутизацию сообщений клиентов), не поддерживаются в среде контроллеров сайта MSMQ 1.0.

Инструкции по указанию нового сайта для мобильных компьютеров содержатся в разделе Указание нового сайта для мобильных клиентов.

Использование удаленного доступа клиентами

Удаленные пользователи очереди сообщений могут подключаться к сети через компьютер, настроенный как сервер удаленного доступа. Чтобы сократить затраты на междугородные звонки и гарантировать подключение удаленных клиентов к одному и тому же сайту, следует настроить сервер удаленного доступа в каждом сайте. Хотя возможна настройка клиентов для подключения к данной сети через сервер удаленного доступа в любом сайте, такой вариант обладает меньшими преимуществами.

Сервер удаленного доступа должен использовать только один IP-адрес. Если этот компьютер будет использовать несколько IP-адресов, автоматическое распознавание сайта некоторыми клиентами будет невозможно. В результате этого клиенты, подключающиеся к данной сети с использованием удаленного доступа, получат низкую производительность либо вообще не смогут отправлять и получать сообщения.

При настройке удаленного доступа для использования клиентами имейте в виду следующее.

  • Клиенты при удаленном доступе к сети должны использовать протокол NetBEUI. Если клиент будет использовать протокол NetBEUI, его имя будет разрешаться, исходя из IP-адреса сервера, а не клиентского компьютера. По умолчанию поддержка протокола NetBEUI отключена.
  • Нельзя последовательно подключаться к двум разных сайтам через линию удаленного доступа без остановки и перезапуска службы очереди сообщений на клиенте.

Дополнительные сведения о серверах удаленного доступа содержатся в разделе «Удаленный доступ» справочной системы Windows 2000 Server.

Смена поддерживающего сервера для зависимого клиента

Зависимые клиенты требуют синхронного доступа к серверу очереди сообщений, называемому поддерживающим сервером. Любой сервер очереди сообщений, функционирующий в режиме домена с функциями независимого клиента (предпочтительно в локальном сайте, но также и в соседнем сайте), может служить в качестве поддерживающего сервера для зависимого клиента. При установке зависимого клиента запрашивается поддерживающий его сервер. Позже можно выбрать другой поддерживающий сервер.

Инструкции по смене поддерживающего сервера для зависимого клиента содержатся в разделе Смена поддерживающего сервера для зависимого клиента.

Инструкции по просмотру списка зависимых клиентов, поддерживаемых сервером очереди сообщений, содержатся в разделе Просмотр списка зависимых клиентов сервера.

Примечания

  • Если для предыдущей версии зависимого клиента, работающего под управлением Windows NT 4.0 требуется сменить поддерживающий сервер на сервер очереди сообщений Windows 2000, на зависимый клиент необходимо установить пакет обновления 4 или более поздний для Windows NT.

Задание квот компьютера для сообщений

Квоты компьютера задают ограничение совокупного размера всех сообщений, хранящихся во всех очередях на компьютере. Если квота компьютера исчерпана, данный компьютер больше не сможет получать сообщения до тех пор, пока из очередей на данном компьютере не будут удалены (прочитаны) одно или несколько сообщений.

Квоты компьютера задаются для серверов очереди сообщений и независимых клиентов. Квоты компьютера, заданные на серверах очереди сообщений, поддерживающих зависимых клиентов, применяются как к серверу, так и ко всем зависимым от него клиентам.

Общие сведения о квотах содержатся в разделе Квоты для сообщений.

Инструкции по заданию квот компьютера для обычных сообщений содержатся в разделе Задание размера банка сообщений для компьютеров.

Инструкции по заданию квот компьютера для сообщений журнала содержатся в разделе Задание ограничения размера хранилища журнала для компьютеров.

Хранение файлов сообщений на нескольких дисках

Производительность обработки сообщений серверами очереди сообщений и независимыми клиентами можно увеличить, храня различные файлы сообщений на разных физических дисках. Для обработки сообщений очередью сообщений может использоваться до трех дисков. Для повышения производительности серверов очереди сообщений разместите файлы сообщений (*.mq), файлы журнала сообщений и файлы журнала транзакций на разных физических дисках.

Дополнительные сведения об определении оптимального числа дисков для использования содержатся в разделе Число дисков.

Инструкции по хранению файлов сообщений на нескольких дисках содержатся в разделе Хранение сообщений на нескольких дисковых устройствах.

Настройка параметров DNS

При работе в среде, требующей разрешения DNS-имен доменов, такой как среда, в которой очереди отправляются в Active Directory, параметры DNS (например, адреса DNS-сервера) должны быть правильно настроены на каждом компьютере для правильного разрешения имен компьютеров в очереди сообщений.

Кроме того, следует убедиться, что каждый компьютер обладает полным именем DNS; в противном случае выполнение некоторых операций очереди сообщений будет невозможно. Это свойство обычно устанавливается автоматически службой «Сетевой вход в систему» на каждом компьютере в домене Windows 2000. Чтобы проверить значение этого свойства, откройте оснастку «Active Directory - пользователи и компьютеры». В дереве консоли щелкните правой кнопкой мыши соответствующий объект компьютера, выберите команду Свойства и на странице Общие проверьте параметр DNS-имя.

Инструкции по настройке свойств DNS для очереди сообщений содержатся в разделе Установка свойств DNS для очереди сообщений.

Проверка досягаемости компьютера

Очередь сообщений поддерживает команду MQPing, аналогичную команде ping протокола TCP/IP. Команду MQPing можно использовать для обнаружения службы очереди сообщений на испытываемом компьютере, а также для проверки его подключения к сети. Когда компьютер, использующий очередь сообщений, получает запрос MQPing, он возвращает ответное сообщение в очередь сообщений на компьютере, отправившем запрос MQPing. Таким образом, в отличие от команды ping, команда MQPing не проверяет, установлено ли прямое IP-подключение между двумя компьютерами, но проверяет, могут ли они отправлять друг другу сообщения с возможностью маршрутизации.

Инструкции по использованию MQPing содержатся в разделе Проверка подключения с использованием MQPing.


Администрирование очередей в очередях сообщений

В этом разделе приведены инструкции по управлению и настройке очередей сообщений. Для администрирования очередей служат оснастки «Управление компьютером» и «Active Directory - пользователи и компьютеры». Дополнительные сведения содержатся в разделе Администрирование очереди сообщений: обзор.

Создание, поиск и удаление очередей

Существуют некоторые ограничения на создание очередей на компьютерах, определенных в ходе настройки очереди сообщений. Дополнительные сведения содержатся в разделе Дескрипторы безопасности объектов msmq.

Инструкции по созданию, удалению и поиску очереди содержатся в разделах Создание очередей, Удаление очередей и Поиск очередей.

Просмотр очередей

Операция просмотра содержимого очереди с того же компьютера, на котором она находится, называется локальным чтением. Операция доступа к содержимому очереди с другого компьютера называется удаленным чтением.

Просмотр очередей возможен только при наличии достаточных разрешений для открытия этих очередей. Таким образом, возможно существование общих очередей, содержимое которых недоступно для оснасток. Дополнительные сведения содержатся в разделе Задание разрешений для объектов очередей.

Имеются некоторые внутренние частные очереди, используемые только для внутренних операций. Они включают промежуточные очереди, которые хранят и пересылают сообщения в конечную очередь. Оснастки «Управление компьютером» и «Active Directory - пользователи и компьютеры» не отображают внутренние частные очереди. В результате, если сообщение находится во временной очереди, оно не отображается в этих оснастках.

Примечания

  • После запуска нескольких приложений очереди сообщений (или нескольких экземпляров одного приложения), получающих сообщения из удаленной очереди, может появиться сообщение о недостатке ресурсов. Инструкции по разрешению этой ошибки приведены в разделе Устранение неполадок администрирования очереди сообщений.
  • При использовании оснастки «Управление компьютером» просмотр транзактных сообщений в исходящих очередях невозможен.

Изменение свойств очереди

Сообщения отправляются в общие очереди в порядке, определяемом суммой приоритетов данного сообщения и конечной очереди, или значением базового приоритета. Сообщения с наибольшими суммарными значениями приоритета отправляются первыми. Сообщения отправляются сначала с учетом базового приоритета, а затем — с учетом приоритета сообщения. В частных очередях базовый приоритет не поддерживается, поэтому сообщения отправляются только исходя из приоритета сообщения.

Инструкции по изменению базового приоритета очереди содержатся в разделе Изменение базового приоритета очереди.

Код типа очереди указывает тип предоставляемых очередью услуг. Код типа очереди должен являться кодом GUID в виде {дддддддд-дддд-дддд-дддд-дддддддддддд}, где d это шестнадцатеричный текстовый знак. Код типа очереди можно использовать для поиска, открытия или удаления очередей определенного типа. Использование кода типа очереди не является обязательным.

Инструкции по смене кода типа очереди содержатся в разделе Изменение кода типа очереди.

Каждая очередь может иметь метку, которая используется для идентификации очереди и представляет собой строку длиной до 124 символов Юникода. Например, все очереди, принимающие сообщения, отправленные определенным приложением, могут иметь метку «Сообщения из приложения». Инструкции по изменению метки очереди содержатся в разделе Изменение метки очереди.

Уровень секретности очереди определяет, какие сообщения могут помещаться в очередь: зашифрованные, незашифрованные или и те, и другие. Если выбран уровень секретности Нет, в очередь будут помещаться только незашифрованные сообщения. Если выбран уровень секретности Тело, в очередь будут помещаться только зашифрованные сообщения. Если выбран уровень секретности Дополнительно, в очередь будут помещаться как незашифрованные, так и зашифрованные сообщения. Проверить, зашифровано сообщение, отправленное в очередь сообщений, или нет, можно проверить с помощью оснастки «Active Directory - пользователи и компьютеры» (или программно по значению свойства сообщения PROPID_M_PRIV_LEVEL).

Инструкции по заданию уровня секретности очереди содержатся в разделе Изменение уровня секретности очередей. Общие сведения о шифровании сообщений содержатся в разделе Шифрование в очереди сообщений.

Также можно разрешить постановку в очередь только сообщений, прошедших проверку подлинности. Дополнительные сведения об использовании данной возможности содержатся в разделе Помещение в очередь только сообщений, прошедших проверку. Общие сведения о шифровании сообщений содержатся в разделе Проверка подлинности сообщений.

Задание квот очередей для сообщений

Квоты очередей задают ограничение совокупного размера сообщений, хранящихся в определенной очереди. Если квота очереди исчерпана, постановка сообщений в данную очередь будет невозможна до тех пор, пока из нее не будут удалены (прочитаны) одно или несколько сообщений.

Квоты очереди можно задавать только на серверах очереди сообщений и независимых клиентах. Квоты очереди, заданные на серверах очереди сообщений, поддерживающих зависимых клиентов, применяются как к серверу, так и ко всем зависимым от него клиентам.

Общие сведения о квотах содержатся в разделе Квоты для сообщений.

Инструкции по заданию квот очереди для обычных сообщений содержатся в разделе Задание ограничения размера банка сообщений для очередей.

Инструкции по заданию квот очереди для сообщений журнала содержатся в разделе Задание ограничения размера хранилища журнала для очередей.

Ведение журнала назначений

Ведение журнала назначений настроено на работу с очередями. Если оно включено, копия каждого входящего сообщения помещается в соответствующую очередь журнала, когда сообщение удаляется (читается) из конечной очереди.

Инструкции по включению ведения журнала назначений очереди содержатся в разделе Включение и отключение ведения журнала назначений.

Приостановка и возобновление работы исходящей очереди

Исходящие очереди на компьютере используются для временного хранения сообщений до того, как они будут отправлены по назначению. Исходящие очереди отображаются только в оснастке «Управление компьютером».

Работу локальной исходящей очереди можно приостановить и возобновить позже, тем самым откладывая отправку сообщений из этой очереди в соответствующую конечную очередь. В этом случае все ожидающие сообщения будут отправлены в конечную очередь позже. Инструкции по приостановке и возобновлению работы исходящей очереди содержатся в разделе Приостановка и возобновление работы очереди исходящих сообщений.

Очередь сообщений также можно отключить от сети. При отключении очереди сообщений от сети обработка всех исходящих сообщений на локальном компьютере приостанавливается. Эту возможность следует использовать, если при медленном и дорогостоящем доступе к сети требуется отложить доставку исходящих сообщений из всех очередей компьютера на более позднее время. Инструкции по отключению очереди сообщений от сети содержатся в разделе Отключение очередей исходящих сообщений.

Отправка сообщения в очередь тестовых сообщений

Тестовым сообщением называется сообщение, созданное службой очереди сообщений на определенном исходном компьютере и отправленное в конечную очередь на определенный конечный компьютер. Исходный компьютер может быть независимым клиентом или сервером очереди сообщений, а определенный конечный компьютер, на котором расположена конечная очередь, может быть любым другим независимым клиентом или сервером очереди сообщений в том же лесе. Конечная очередь должна быть тестовой очередью, то есть, нетранзактной общей очередью с кодом типа очереди, равным {55EE8F33-CCE9-11CF-B108-0020AFD61CE9}.

Тестовое сообщение проверяет отправку сообщения с исходного компьютера и его доставку в общие очереди на определенном конечном компьютере и, если включено слежение за маршрутом сообщения, отслеживает маршрут сообщений, отправленных с исходного компьютера в общие очереди на конечном компьютере. Дополнительные сведения об отслеживании маршрута сообщений содержатся в разделе Отслеживание сообщений.

Можно создать новую тестовую очередь или преобразовать имеющуюся общую очередь в тестовую очередь. Большинство имеющихся общих очередей можно преобразовать в тестовые, изменив их код типа на приведенный выше. Тем не менее, бесполезно изменять код типа транзактной очереди или очереди, требующей проверки подлинности сообщения, чтобы преобразовать их в тестовую очередь, поскольку нетранзактные и не требующие проверки подлинности тестовые сообщения, не будут доставлены в транзактную очередь или в очередь, требующую проверки подлинности сообщения (если только эта очередь не расположена на исходном компьютере).

Инструкции по отправке тестовых сообщений содержатся в разделе Отправка тестового сообщения.


Администрирование сообщений в очередях сообщений

В этом разделе приведены инструкции по администрированию сообщений в очередях сообщений, включая просмотр и удаление сообщений, задание времени жизни сообщений для использования по умолчанию, а также просмотр и изменение свойств сообщений.

Для администрирования сообщений служат оснастки «Управление компьютером» и «Active Directory - пользователи и компьютеры». Дополнительные сведения содержатся в разделе Администрирование очереди сообщений: обзор.

Сведения о наблюдении за транзактными сообщениями содержатся в разделе Наблюдение за транзактными сообщениями.

Чтение сообщений

Сообщение может содержать текстовые или двоичные данные. Если сообщение содержит текстовые данные, они отображаются. Если сообщение содержит двоичные данные, они отображаются в шестнадцатеричном виде наряду со своим символьным представлением. Содержимое сообщения можно просмотреть в диалоговом окне Тело сообщения.

Для извлечения сообщений из очереди необходимо обладать разрешением «Получение сообщения» для этой очереди. Разрешения на чтение для этой очереди недостаточно. Инструкции по заданию разрешений для очередей содержатся в разделе Задание разрешений для объектов очередей.

Поиск сообщения

Можно создать приложения, позволяющие просматривать или извлекать определенные сообщения без перемещения в очереди с целью их поиска. Эта возможность основана на 64-разрядном коде поиска, который назначается каждому сообщению при его помещении в конечную очередь. Сообщение в очереди имеет уникальный код поиска, значение которого всегда больше значения кода поиска предыдущего сообщения и меньше значения кода поиска следующего сообщения.

Код поиска имеют сообщения, отправляемые приложениями, и сообщения, отправляемые очередью сообщений. Диспетчер локальной очереди создает код поиска и задает свойства кода поиска сообщения (PROPID_M_LOOKUPID и MSMQMessage.LookupId) всякий раз при помещении сообщения в очередь. Очередь сообщений создает код поиска для сообщений, размещенных в очередях, созданных пользователями и приложениями, таких как конечные очереди, административные очереди, очереди ответов и очереди отчетов, а также для копий сообщений, размещенных в генерируемых системой журналах, очередях недоставленных сообщений и очередях подключателя. Если сообщение отправлено в несколько конечных очередей, или если копия сообщения хранится в журнале компьютера или в очереди журнала, каждой копии сообщения при помещении в соответствующую очередь будет присвоен уникальный код поиска.

Очередь сообщений обладает функцией и методами API объекта MSMQQueue, позволяющими приложениям программно выполнять следующие задачи без использования курсоров.

  • Просмотр первого сообщения в очереди.
  • Просмотр сообщения, которое предшествует сообщению, определенному кодом поиска.
  • Просмотр сообщения, определенного поставляемым кодом поиска.
  • Просмотр сообщения, которое следует за сообщением, определенным кодом поиска.
  • Просмотр последнего сообщения в очереди.
  • Извлечение первого сообщения в очереди.
  • Извлечение сообщения, которое предшествует сообщению, определенному кодом поиска.
  • Извлечение сообщения, определенного поставляемым кодом поиска.
  • Извлечение сообщения, которое следует за сообщением, определенным кодом поиска.
  • Извлечение последнего сообщения в очереди.

Если произведен вызов функции API для просмотра и извлечения сообщений, они могут быть обработаны синхронно, асинхронно или в пределах одной транзакции. Тем не менее, метод вызывает синхронную обработку сообщений.

Получающее приложение может использовать код поиска сообщения для перехода непосредственно к определенному сообщению, а затем продолжить перемещение в очереди из этого места к началу или концу очереди. В этом отношении коды поиска отличаются от курсоров. При использовании курсора приложение должно начать обработку в начале очереди и перемещаться к концу очереди.

Очистка очередей от сообщений

От сообщений можно очищать все очереди, кроме системных и частных. Очередь нельзя очистить от отдельных сообщений.

Инструкции по очистке очередей от всех сообщений содержатся в разделе Очистка очереди от всех сообщений.

Изменение свойств сообщений

Возможно задание времени жизни сообщений в сети, также называемое сроком поступления в очередь (TTRQ). По достижении значения TTRQ сообщения считаются устаревшими. Инструкции по заданию времени жизни сообщений в сети содержатся в разделе Задание времени жизни сообщений для использования по умолчанию.

Возможен просмотр различных свойств сообщений. Инструкции по просмотру свойств сообщений содержатся в разделе Просмотр свойств сообщения.

Также можно выбрать столбцы свойств и их порядок для отображения по умолчанию в области сведений (обычно это правая область) оснастки. Инструкции по выбору отображаемых свойств сообщения содержатся в разделе Выбор отображаемых столбцов свойств сообщения.

Отслеживание сообщений

С помощью отправки тестовых сообщений можно отслеживать отправку и прибытие сообщений с исходного компьютера в конечную очередь, кроме того, можно отслеживать маршрут в сети тестовых сообщений или всех сообщений, отправленных с исходного компьютера в тестовые очереди на удаленных компьютерах, включив отслеживание маршрута сообщений.

Отправка тестового сообщения

Тестовое сообщение можно отправить с независимого клиента или сервера очереди сообщений в очередь тестовых сообщений на любом другом независимом клиенте или сервере очереди сообщений в составе того же леса Windows. Для этого необходимо сначала создать на конечном компьютере очередь тестовых сообщений или изменить код типа имеющейся очереди, чтобы в нее можно было отправлять тестовые сообщения. Дополнительные сведения содержатся в разделе Отправка сообщения в очередь тестовых сообщений.

Сообщения отчетов, отслеживающие маршрут сообщений в сети, всегда отправляются в очередь отчетов, задаваемую исходным компьютером для тестовых сообщений, если на нем включено слежение за маршрутом.

Инструкции по отправке тестовых сообщений содержатся в разделе Отправка тестового сообщения.

Слежение за маршрутом сообщения

Данная возможность позволяет отслеживать маршрут сообщений в сети. Если выполнены все условия слежения за маршрутом, сообщение отчета отправляется в очередь отчетов исходного компьютера при отправке сообщения с исходного компьютера, при его прибытии на конечный компьютер, и всякий раз, когда сообщение прибывает на сервер очереди сообщений с включенной маршрутизацией или отправляется с него.

Для использования слежения за маршрутом сообщений необходимо соблюдение двух основных условий. Во-первых, необходимо включить слежение за маршрутом сообщений и создать или указать очередь отчетов на исходном компьютере. Во-вторых, флаг слежения за маршрутом в сообщении должен быть установлен программно отправляющим приложением. Кроме того, отслеживаются только сообщения, отправленные на конечный компьютер, а сообщения, отправленные по транспорту HTTP/HTTPS, а также сообщения, отправленные нескольким получателям с помощью IP-рассылки, списков рассылки или многоэлементных имен формата в текущей версии очереди сообщений отследить невозможно.

Инструкции по включению отслеживания маршрута сообщений содержатся в разделе Включение слежения за маршрутом сообщения. Сведения о пакете «Message Queuing SDK» (для программного задания свойств) содержатся в разделе Microsoft Platform Software Development Kit.

В заголовке сообщения только одна очередь может быть определена в качестве очереди отчетов данного сообщения. Если сообщение, маршрут которого отслеживается и в заголовке которого определена очередь ответов, проходит через сервер очереди сообщений с поддержкой маршрутизации и отслеживания маршрутов сообщений, очередь сообщений отправляет сообщение о конфликте отчетов в очередь отчетов данного сервера после отправки с него этого сообщения.

Предположим, что имеются три компьютера: А, Б и В. На компьютере А включено отслеживание маршрутов сообщений. В таком случае, приложение очереди сообщений на компьютере А отправляет сообщение на компьютер В через сервер исходящей маршрутизации Б. Если очередь отчетов компьютера А называется ОА, сообщение отчета будет отправлено в эту очередь в следующих случаях:

  • сообщение отправляется с компьютера А;
  • сообщение поступает на сервер исходящей маршрутизации Б;
  • сообщение отправляется с сервера исходящей маршрутизации Б;
  • сообщение поступает на компьютер В.

Если на сервере исходящей маршрутизации Б также включено отслеживание маршрутов сообщений с отправкой сообщений отчетов в очередь ОБ, во время отправки сообщения с сервера исходящей маршрутизации Б в данную очередь будет отправлено сообщение о конфликте очередей отчетов. В исходную очередь ОА будут продолжать поступать обычные сообщения отчетов.

Возможна и другая ситуация: на компьютере А не включено отслеживание маршрутов сообщений, однако оно включено на компьютерах Б и В. В этом случае, сведения о перемещении сообщения начнут поступать после того как оно будет отправлено с сервера исходящей маршрутизации Б. Всего в ОБ будет отправлено два сообщения отчета (первое – при отправке сообщения с компьютера Б, и второе – по прибытии сообщения на компьютер C), и ни одного сообщения о конфликте очередей отчетов.

Наконец, можно смоделировать следующий пример: ни на компьютере А, ни на компьютере Б не включено отслеживание маршрутов сообщений, однако оно включено на компьютере В. В этом случае, не будет отправлено ни одного сообщения отчета, пока сообщение не достигнет конечного компьютера. По прибытии сообщения на место назначения одно сообщение отчета будет отправлено в ОВ. Не будет отправлено ни одного сообщения о конфликте очередей отчетов.

Сообщения отчетов состоят из метки и тела. Метка сообщения имеет следующий формат.

гггг:вввв:пп отправлено от <компьютер> к <адрес> в <время>
гггг:вввв:пп получено <компьютер> к <адрес> в <время>

где гггг — первые четыре шестнадцатеричных знака кода GUID исходной очереди, вввв — внутренний код сообщения, а пп — число переходов.

Внутренний код сообщения является порядковым номером сообщения, входящим в состав его полного кода. Код сообщения не используется не используется, так как он неудобен для чтения из-за большого размера (16 байт кода GUID плюс 4 байта порядкового номера.)

Если отправлены сообщения о конфликте очередей отчетов, метки содержат строку «Report Message Conflict».

Тело обычного сообщения отчета содержит код сообщения, сведения о конечной очереди, расположении следующего перехода и числе переходов в формате XML. Например, тело сообщения отчета, которое в первом примере было отправленного в ОА после отправки сообщения с сервера исходящей маршрутизации, имеет следующую форму:

<КОД СООБЩЕНИЯ>код_сообщения</КОД СООБЩЕНИЯ>
<КОНЕЧНАЯ ОЧЕРЕДЬ>формат_имени_конечной_очереди_на_компьютере_В</КОНЕЧНАЯ ОЧЕРЕДЬ>
<СЛЕДУЮЩИЙ ПЕРЕХОД>IP-адрес_компьютера_В</СЛЕДУЮЩИЙ ПЕРЕХОД>
<ЧИСЛО ПЕРЕХОДОВ>1</ЧИСЛО ПЕРЕХОДОВ>

Тело сообщения о конфликте отчетов содержит дополнительную строку, содержащую исходную очередь. Например, тело сообщения «Конфликт сообщений отчета», которое в первом примере было отправлено в ОБ сразу после отправки описанного сообщения отчета в ОА, имеет следующую форму:

<ИСХОДНАЯ ОЧЕРЕДЬ>формат_имени_ОА</ИСХОДНАЯ ОЧЕРЕДЬ>
<КОД СООБЩЕНИЯ>код_сообщения</КОД СООБЩЕНИЯ>
<КОНЕЧНАЯ ОЧЕРЕДЬ>формат_имени_конечной_очереди_на_компьютере_В</КОНЕЧНАЯ ОЧЕРЕДЬ>
<СЛЕДУЮЩИЙ ПЕРЕХОД>IP-адрес_компьютера_C</СЛЕДУЮЩИЙ ПЕРЕХОД>

Архивация и восстановление сообщений

Служебная программа архивации и восстановления сообщений для командной строки Mqbkup, входящая в состав системы очередей сообщений, служит для защиты файлов хранилища, файлов журнала, файлов журнала транзакций и параметров реестра от сбоев оборудования. Прежде чем пользоваться этой программой, следует создать папку для архивации. Чтобы запустить эту служебную программу, в командной строке введите mqbkup.

Синтаксис запуска этой программы:

mqbkup {-b путь_к_папке | -r путь_к_папке | -?}

где:

-b путь_к_папке — архивация файлов в указанную папку

-r путь_к_папке — восстановление файлов из указанной папки

-?-? — вывод справки по этой команде

Прежде чем восстанавливать сообщения, необходимо закрыть панель управления и все приложения очереди сообщений.

Эта программа не архивирует сертификаты и криптографические ключи.

После выполнения восстановления необходимо зарегистрировать новый сертификат пользователя. Инструкции по регистрации сертификата содержатся в разделе Регистрация сертификатов для очереди сообщений.

Эта программа останавливает и перезапускает службу очереди сообщений.


Наблюдение за очередью сообщений

В этом разделе описаны возможности наблюдения за событиями очереди сообщений в окне «Просмотр событий», производительностью очереди сообщений в окне «Производительность» и выполнением транзакций очереди сообщений с использованием оснастки «Службы компонентов» при запущенном координаторе распределенных транзакций Microsoft (MS DTC).

Наблюдение за событиями

Журналы очереди сообщений передают сведения о работе службы очередей сообщений в журналы событий Windows XP. Событиям очереди сообщений соответствуют записи со значением «Очередь сообщений» в столбце «Источник». Большая часть событий заносится в журнал безопасности. События, относящиеся к безопасности, заносятся в журнал безопасности.

Инструкции по просмотру событий очереди сообщений содержатся в разделе Просмотр событий очереди сообщений.

Дополнительные сведения об окне просмотра событий содержатся в разделе Просмотр событий.

В журнале приложений Windows XP могут храниться записи о событиях приложений очереди сообщений трех типов:

  • Уведомления. Редкие важные сообщения, уведомляющие об успешном исходе операций.
  • Предупреждения. События, необязательно являющиеся важными, но означающие наличие потенциальных неполадок.
  • Ошибки. События, означающие наличие важных неполадок.

Некоторые события заносятся в журнал приложений не при каждом возникновении. Например, если серверу очереди сообщений не удается установить сеанс с удаленным компьютером, это событие будет занесено в журнал только в первый раз, а следующее событие будет занесено, когда сеанс удастся установить.

В журнале безопасности могут храниться записи о событиях, связанных с безопасностью очереди сообщений, двух типов:

  • Аудит успехов. Создается при успешном доступе к требуемому объекту.
  • Аудит отказов. Создается при отсутствии доступа к требуемому объекту.

Дополнительные сведения об аудите доступа содержатся в разделе Аудит доступа к очереди сообщений.

Наблюдение за производительностью

Для наблюдения за производительностью очереди сообщений служат определенные счетчики безопасности. Значения этих счетчиков производительности можно просматривать в окне «Производительность». Стандартные счетчики производительности сгруппированы в следующие объекты.

  • Служба MSMQ
  • Очередь MSMQ
  • Сеанс MSMQ
  • Входящий трафик HTTP MSMQ
  • Исходящие сеансы HTTP MSMQ
  • Входящие многоадресные сеансы MSMQ
  • Исходящие многоадресные сеансы MSMQ
  • Служба репликации MSMQ

Дополнительные сведения об окне «Производительность» содержатся в разделе «Системный монитор: обзор» справки операционной системы Windows 2000 Server.

Примечание.

  • Счетчики производительности недоступны для нескольких экземпляров очереди сообщений, используемых в кластере серверов.

Объект производительности «Служба MSMQ»

Объект производительности «Служба MSMQ» присутствует на серверах очереди сообщений и независимых клиентах. Объект «Служба MSMQ» включает счетчики производительности, служащие для сбора статистики очереди сообщений для выбранного компьютера. Счетчики, отображающие общее число байт в сообщениях, подсчитывают все без исключения байты в сообщениях.

Значения, показывающие использование памяти, включают объем памяти, занятый всеми сообщениями в локальных очередях компьютера. Поскольку сообщения с возможностью восстановления хранятся на диске, этот объем памяти архивируется на диск с использованием файлов, отраженных в памяти, а не пула файлов подкачки Windows XP. Дополнительные сведения о хранении сообщений содержатся в разделе Локальное хранилище сообщений.

Объект производительности «Очередь MSMQ»

Объект производительности «Очередь MSMQ» включает счетчики производительности, служащие для сбора статистики сообщений для выбранной очереди. Компьютер, на котором находится очередь, может содержать экземпляр объекта для каждой открытой очереди и для каждой очереди, содержащей сообщения. Количество экземпляров на компьютере ограничивается заданным максимальным числом. Кроме того, компьютер, на котором находится исходящая очередь, может содержать экземпляр объекта для каждой исходящей очереди, открытой для каждой конечной очереди. Количество экземпляров на компьютере ограничивается заданным максимальным числом. Данное имя счетчика очереди является именем формата очереди. Если на компьютере работает приложение-подключатель, также доступен счетчик для очереди подключателя; его имя отображается как foreign=GUID.

В списке экземпляров отображаются только первые 97 очередей, созданных на данном компьютере, включая частные очереди. Счетчики очередей для определенного компьютера отображаются для каждого экземпляра. Экземпляр Computer Queues представляет журнал источников или журнала компьютера, а также недоставленные сообщения данного компьютера. Счетчики Байт в очереди и Сообщений в очереди отражают состояние очереди недоставленных сообщений данного компьютера. Счетчики Байт в журнале и Сообщений в журнале отражают состояние журнала компьютера (сообщения журнала в папке «Системные очереди»).

Исходящая очередь отличается тем, что имя компьютера, приведенное в экземпляре счетчика, не совпадает с именем компьютера, на котором расположена соответствующая конечная очередь.

Объект производительности «Сеанс MSMQ»

Объект производительности «Сеанс MSMQ» отображается, только когда данный компьютер устанавливает сеанс с другим компьютером, использующим очередь сообщений. Этот объект содержит счетчики, которые можно использовать для сбора статистики сеансов между компьютерами, использующими очередь сообщений. Могут присутствовать несколько экземпляров этого объекта, по одному на каждый сеанс. На обоих компьютерах, включенных в каждый сеанс, может быть экземпляр данного объекта. Количество экземпляров на компьютере ограничивается заданным максимальным числом. Экземпляры отражают IP-адреса компьютера, с которым установлен сеанс.

Объекты производительности сообщений HTTP

Объекты производительности «Входящий трафик HTTP MSMQ» и «Исходящие сеансы HTTP MSMQ» включают счетчики, отражающие состояние сообщений, посланных по транспорту HTTP. Эти объекты содержат счетчики, используемые для сбора статистики входящих сообщений HTTP, контролирующие скорость прибытия сообщений и байт сообщений на компьютер во входящем соединении HTTP, подсчитывающие общее число сообщений HTTP, прибывших во время соединения, общее число байт сообщений, прибывших во время соединения, а также счетчики, собирающие статистику об активных исходящих сеансах HTTP между двумя компьютерами, контролирующие скорость отправки сообщений и байт сообщений с компьютера в определенном исходящем сеансе, подсчитывающие общее число сообщений HTTP, отправленных во время сеанса и общее число байт сообщений, отправленных во время сеанса.

Объекты производительности многоадресной рассылки

Объекты производительности «Входящие многоадресные сеансы MSMQ» и «Исходящие многоадресные сеансы MSMQ» содержат счетчики, отражающие состояние сообщений, отправленных в многоадресных сеансах. Эти объекты содержат счетчики, используемые для сбора статистики входящих многоадресных сеансов, контролирующие скорость прибытия сообщений и байт сообщений на компьютер во время определенного входящего многоадресного сеанса, подсчитывающие общее число многоадресных сообщений, прибывших во время сеанса, общее число байт сообщений, прибывших во время сеанса, а также счетчики, собирающие статистику об активных исходящих многоадресных сеансах между двумя компьютерами, контролирующие скорость отправки сообщений и байт сообщений с компьютера в определенном исходящем сеансе, подсчитывающие общее число многоадресных сообщений, отправленных во время сеанса и общее число байт сообщений, отправленных во время сеанса.

Объект производительности «Служба репликации MSMQ»

Объект производительности «Служба репликации MSMQ» отображается только в средах со смешанным режимом, когда основной контроллер предприятия (PEC) MSMQ 1.0 обновлен до сервера очереди сообщений, работающего под управлением Windows 2000 и использующего службу репликации очереди сообщений. Счетчики, входящие в этот объект, собирают статистику по различным аспектам производительности при репликации данных на сервере контроллера MSMQ 1.0, работающего под управлением Windows NT 4.0.

Повышение скорости обработки сообщений

Если доступные ресурсы процессора не ограничивают скорость обработки сообщений, ее можно повысить, если хранить различные файлы сообщений и файлы журналов на серверах очереди сообщений и независимых клиентах на разных физических дисках.

Чтобы определить, ограничена производительность компьютеров скоростью доступа к диску или мощностью процессора, понаблюдайте в системном мониторе за значениями счетчиков % загруженности процессора (в объекте «Процессор») и Средняя длина очереди диска (в объекте «Физический диск»). Если устоявшееся значение счетчика % загруженности процессора во время отправки сообщений поднимается выше 75%, добавление ресурсов процессора может повысить производительность системы сообщений. Если во время отправки сообщений значение счетчика Средняя длина очереди диска для любого диска превышает 0,6, дополнительные диски могут повысить производительность системы обмена сообщениями.

Рекомендации по хранению сообщений и файлов журнала содержатся в разделе Хранение сообщений на нескольких дисковых устройствах.

Дополнительные сведения по определению числа дисков, требуемых для оптимальной работы серверов, содержатся в разделе Число дисков.

Наблюдение за транзактными сообщениями

Для выполнения внешних транзакций в очереди сообщений используется координатор распределенных транзакций Microsoft (MS DTC), входящий в состав Windows XP. Для сбора статистики транзактных сообщений, отправленных или полученных во внешних транзакциях, а также для сбора статистики всех транзакций, координируемых MS DTC, используется оснастка «Службы компонентов». Дополнительные сведения содержатся в разделе Просмотр внешних транзакций.

При наблюдении за внешними, или двухэтапными, транзакциями, на панели сведений, которая открывается при выборе элемента Статистика транзакций в дереве консоли оснастки «Служба компонентов», отображаются полезные сведения о количестве активных, завершенных и невыполненных транзакций. Для возможности обработки внешних транзактных сообщений должна быть запущена служба MS DTC.

Дополнительные сведения о транзактных сообщениях содержатся в разделе Обмен транзактными сообщениями.

Дополнительные сведения о координаторе распределенных транзакций Microsoft содержатся в разделе Работа со службами компонентов.


Ресурсы

В этом разделе приведены источники дополнительных сведений об очередях сообщений и ссылки на другое программное обеспечение, работающее с очередями сообщений.

Пакет Microsoft Platform Software Development Kit

Пакет Message Queuing Software Development Kit (SDK) входит в пакет Microsoft Platform SDK библиотеки Microsoft Developer Network (MSDN). Пакет «Message Queuing SDK» включает основные фундаментальные сведения по разработке приложений, использующих очередь сообщений, и справочник с подробными описаниями функций, свойств, структур и компонентов COM, поддерживаемых и используемых очередью сообщений. Пакет «Message Queuing SDK» также включает примеры и файлы программ для самых популярных типов приложений.

Пакет Microsoft Platform SDK периодически выпускается в составе библиотеки MSDN, которая доступна как на компакт-дисках, так и в Интернете. Для открытия вводной темы очереди сообщений в разделе «Platform SDK» библиотеки MSDN в Содержании выберите элемент Очередь сообщений.

    Где?

    • Библиотека MSDN
    • Platform SDK
    • Networking and Directory Services
    • Networking and Directory Services\Network Communication
    • Oчередь сообщений

Доступ к пакету Message Queuing SDK в Интернете можно получить на веб-узле MSDN (http://msdn.Microsoft.com/library/default.asp).

Веб-узлы

  • Самые последние сведения об очередях сообщений содержатся на веб-странице Message Queuing (http://www.Microsoft.com/msmq/).
  • Последняя версия списка часто задаваемых вопросов (FAQ) по очередям сообщений содержится на веб-странице Message Queuing FAQ (http://www.microsoft.com/windows2000/technologies/communications/msmq/wp_msmqfaq.asp).
  • Сведения об очереди сообщений, имеющиеся в службе технической поддержки Microsoft, можно найти на домашней странице службы технический поддержки Microsoft (http://support.Microsoft.com/directory/default.asp).
  • Сведения об обучающих компьютерных системах компании Integrity eLearning Inc., также известной как Integrity Training Inc., содержатся на веб-узле Integrity eLearning (http://www.ielearning.com).
  • Дополнительную информацию о решениях Level 8 Systems по взаимодействию с другими платформами можно найти на веб-узле Level 8 Systems (http://www.level8.com/index.cfm?handle=gmq).
  • Дополнительная информация о программном обеспечении очереди сообщений содержится на веб-узле MessageQ.Com (http://www.messageq.com).

Примечания

  • Веб-адреса могут изменяться, поэтому доступность некоторых описанных выше веб-узлов по указанным адресам не гарантирована.

Группы новостей Интернета

Следуя инструкциям веб-обозревателя или программы чтения новостей для подключения к серверу новостей Интернета, можно подписаться на следующие группы новостей.

  • Microsoft.public.msmq.deployment
  • Microsoft.public.msmq.interop
  • Microsoft.public.msmq.networking
  • Microsoft.public.msmq.performance
  • Microsoft.public.msmq.programming
  • Microsoft.public.msmq.security
  • Microsoft.public.msmq.setup

Книги

Ниже представлен список книг, которые могут быть интересны разработчикам приложений, использующих очередь сообщений.

  • Dickman, Alan. Designing Applications With MSMQ: Message Queuing for Developers. Addison-Wesley Publishing Co., 1998.
  • Homer, Alex and Sussman, David. Professional MTS and MSMQ Programming with VB and ASP. Wrox Press Inc., 1998.
  • Sessions, Roger. COM and DCOM: Microsoft's Vision for Distributed Objects. John Wiley & Sons, 1998, глава 11.


Устранение неполадок

В данном разделе рассматриваются вопросы устранения неполадок, которые могут возникать при установке, обновлении и администрировании очереди сообщений.

  • Устранение неполадок при установке очереди сообщений
  • Устранение неполадок при обновлении очереди сообщений
  • Устранение неполадок при администрировании очереди сообщений
  • Устранение неполадок, связанных с триггерами очереди сообщений


Устранение неполадок при установке очереди сообщений

В этом разделе приведены инструкции по устранению неполадок, связанных с установкой нового программного обеспечения очереди сообщений и настройкой очереди сообщений.

При возникновении неполадок в ходе установки сначала следует просмотреть файлы журналов установки. Это особенно важно при выполнении автоматической установки, поскольку в этом случае иначе никак нельзя установить, все ли идет по плану. Файл журнала установки очереди сообщений (Msmqinst.log) находится в папке Windows (обычно это папка C:\Windows). Если содержимое этого файла не поможет выявить источник неполадок, тогда просмотрите файл журнала установки Windows XP, Setuperr.log, который расположен в системной папке (обычно это C:\Windows\System32).

Вид неполадки

Установка Windows XP выполнена, но очереди сообщений нигде нет

Причина. Очередь сообщений не устанавливается по умолчанию вместе с Windows XP.

Решение. Установите очередь сообщений после завершения установки Windows XP, используя функцию Установка и удаление программ на панели управления.

См. также: Установка очереди сообщений: обзор

Очередь сообщений не устанавливается, или выдается сообщение об ошибке «Отказано в доступе»

Причина. Для установки клиентов очереди сообщений необходимо войти в систему с разрешениями локального администратора компьютера, на котором должна быть выполнена установка.

Решение. Убедитесь, что вход в систему выполнен с использованием учетной записи, обладающей соответствующими разрешениями для компьютера, на котором требуется установить очередь сообщений.

Решение. Дайте возможность выполниться репликации Active Directory и затем повторите попытку.

См. также: Разрешения, необходимые для установки

В ходе установки очереди сообщений в предприятии Windows 2000 запрошено имя сервера

Причина. В случае компьютера Windows XP программа установки не смогла автоматически найти контроллер домена Windows 2000 в локальном или соседнем сайте. В случае компьютера с версией более ранней, чем Windows XP, программа установки не смогла автоматически найти подходящий контроллер домена Windows 2000, управляющий работой очереди сообщений в локальном сайте. Такой контроллер домена должен присутствовать в сайте до установки очереди сообщений на других компьютерах этого сайта, использующих версии более ранние, чем Windows XP.

Решение. Выполните следующие действия.

  1. Проверьте, подключены ли к сети компьютер, выполняющий установку очереди сообщений, и контроллер домена.
  2. В случае компьютера с версией более ранней, чем Windows XP, проверьте, запущена ли на контроллере домена служба очереди сообщений.
  3. В случае компьютера с версией более ранней, чем Windows XP, задайте DNS-имя или NetBIOS-имя контроллера домена Windows 2000, на котором размещен сервер очереди сообщений в локальном сайте. Если такой контроллер домена отсутствует, вместо него можно задать имя сервера контроллера MSMQ 1.0.

См. также: Установка очереди сообщений: обзор

При удалении очереди сообщений получено сообщение об ошибке «Работает приложение очереди сообщений»

Причина. В данный момент еще работает какое-то приложение очереди сообщений.

Решение. Закройте все приложения очереди сообщений.

См. также: Запуск и остановка служб очереди сообщений


Устранение неполадок при обновлении очереди сообщений

В этом разделе приводятся указания по устранению неполадок, связанных с обновлением серверов контроллеров MSMQ 1.0 или работой мастера обновления очереди сообщений.

При возникновении неполадок в ходе установки сначала следует просмотреть файлы журналов установки. Это особенно важно при выполнении автоматической установки, поскольку в этом случае иначе никак нельзя установить, все ли идет по плану. Файл журнала установки очереди сообщений (Msmqinst.log) находится в папке Windows (обычно это папка C:\Windows). Если содержимое этого файла не поможет выявить источник неполадок, тогда посмотрите файл журнала установки Windows XP, Setuperr.log, который расположен в системной папке (обычно это C:\Windows\System32).

Вид неполадки

Не запускается мастер обновления очереди сообщений

Причина. Для запуска мастера необходимо обладать правами администратора предприятия или принадлежать группе «Администраторы предприятия».

Решение. Добавьте свою учетную запись в группу «Администраторы предприятия».

Причина. В сайте, в котором запускается мастер, нет сервера глобального каталога.

Решение. Настройте контроллер домена Windows 2000 в локальном сайте как сервер глобального каталога. Кроме того, в каждом домене, в котором запускается мастер обновления очереди сообщений, должен иметься по крайней мере один контроллер домена, работающий под управлением Windows NT 4.0 в подключенном режиме.

Причина. На компьютере не запущен сервер Microsoft SQL Server.

Решение. Запустите службы SQL Server.

Причина. Возможно, в момент вторичного запуска мастер на компьютере (например, после того, как он обнаружил ошибки или несоответствия в базе данных MQIS) работает служба очереди сообщений.

Решение. Остановите службу очереди сообщений и снова запустите мастер обновления очереди сообщений.

См. также: Требования и указания по обновлению очереди сообщений; Обновление компьютеров MSMQ 1.0

Мастер обновления очереди сообщений не смог успешно импортировать базу данных MQIS

Причина. Прежде чем импортировать базу данных MQIS в Active Directory, мастер проверяет ее на наличие ошибок. Возможно, в ней обнаружились ошибки или несоответствия, которые мастер не смог устранить.

Решение. Выполните следующие действия.

  1. Запустите мастер еще раз и по запросу выберите вариант только сканирование базы данных и запись результатов.
  2. Просмотрите файл журнала и исправьте все ошибки.

См. также: Обновление компьютеров MSMQ 1.0


Устранение неполадок при администрировании очереди сообщений

В этом разделе приводятся указания по устранению неполадок, связанных с просмотром и настройкой свойств, доступом к объектам в Active Directory и использованием оснасток для очереди сообщений.

Вид неполадки

Не удается найти никаких средств администрирования и ярлыков меню для очереди сообщений

Причина. Администрирование очереди сообщений осуществляется с помощью расширений оснасток «Управление компьютером», «Active Directory – Пользователи и компьютеры» и «Active Directory – Сайты и службы» на консолях MMC.

Решение. Откройте оснастку «Управление компьютером», «Active Directory – Пользователи и компьютеры» или «Active Directory – Сайты и службы».

Для управления зависимым клиентом следует перейти на поддерживающий сервер.

Решение. В системе Windows XP Professional по умолчанию устанавливается только оснастка «Управление компьютером». Оснастки «Active Directory – пользователи и компьютеры» и «Active Directory – сайты и службы» не входят в состав Windows XP Professional и не могут быть установлены на компьютер, работающий под управлением Windows XP Professional, при установке средств администрирования Windows 2000. Эти оснастки необходимы для администрирования сети очереди сообщений, использующей домены, а также для доступа к содержимому Active Directory и его отображения. Указанные оснастки можно запустить, открыв подключение к удаленному рабочему столу на компьютере Windows XP Professional для доступа к службе терминалов на контроллере домена Windows 2000 или рядовом сервере, на котором установлены эти оснастки. Таким образом можно выполнять административные процедуры в доменной среде и обращаться к службе Active Directory с компьютера очереди сообщений, работающего под управлением Windows XP Professional.

См. также: Администрирование очереди сообщений: обзор; Средства администрирования

Очередь сообщений отсутствует в папке Службы и приложения оснастки «Управление компьютером»

Причина. Служба очереди сообщений не работает.

Решение. В дереве консоли «Управление компьютером» в папке Службы и приложения щелкните Службы. В окне сведений в списке Имя щелкните правой кнопкой мыши Очередь сообщений и выберите команду Запустить. После этого заново откройте оснастку «Управление компьютером».

Не удается найти в Active Directory объекты, относящиеся к очереди сообщений

Причина. Для этих оснасток не были выбраны необходимые параметры представлений.

Решение. В оснастке «Active Directory – Пользователи и компьютеры» выберите в меню Вид команду Пользователи, группы и компьютеры как контейнеры и затем щелкните Дополнительные функции. Объекты очереди сообщений обычно находятся в контейнере «Компьютеры» или «Контроллеры доменов».

Если очередь сообщений работает в автономном режиме, нужно иметь возможность просматривать общие очереди, но не сообщения, свойства очередей, частные очереди, системные очереди и триггеры.

Решение. В оснастке «Active Directory – Сайты и службы» в меню Вид выберите команду Показать узел служб. Объекты очереди сообщений расположены в объектах «Серверы» и «Службы».

Внесенные изменения можно сохранить, чтобы эти представления всегда включались по умолчанию; для этого создайте свой файл .msc для данных оснасток. При первом открытии созданного файла .msc выберите в меню Файл команду Параметры и затем в списке Режим консоли выберите один из трех пользовательских режимов. Теперь консоль будет открываться в этом пользовательском режиме, в котором уже будут включены все требуемые представления. Открытие консоли оснастки в одном из пользовательских режимов (а не в авторском режиме) более безопасно с точки зрения администратора, так как никто больше не сможет изменять режим работы и внешний вид этой оснастки.

См. также: Оснастка «Active Directory – Пользователи и компьютеры»; Оснастка «Active Directory – Сайты и службы»; Объекты очереди сообщений в Active Directory

Доступ к любым объектам очереди сообщений в Active Directory запрещен

Причина. Возможно, изменена учетная запись, используемая для запуска службы очереди сообщений. Чтобы клиенты версий более ранних, чем Windows XP, имели доступ к объектам в Active Directory, эта служба должна запускаться на контроллерах доменов Windows 2000 с учетной записью LocalSystem.

Решение. Убедитесь, что служба очереди сообщений запущена на соответствующем сервере очереди сообщений с использованием учетной записи LocalSystem.

Не удается подключиться к Active Directory

Причина. Возможно, сервер очереди сообщений, с которым поддерживается связь, отключен или служба очереди сообщений остановлена.

Решение. Проверьте, подключен ли к сети сервер очереди сообщений, с которым осуществляется взаимодействие, и работает ли служба очереди сообщений.

Причина. Возможно, данный компьютер отключен, сетевой адаптер неисправен или компьютеру не назначен IP-адрес (или назначен IP-адрес 0.0.0.0).

Решение. Убедитесь, что компьютер подключен, сетевой адаптер работает и протокол TCP/IP настроен правильно.

Причина. Сервер DNS отключен или настроен неправильно, либо IP-адрес сервера очереди сообщений недавно изменился и еще не был реплицирован на сервер DNS.

Решение. Убедитесь, что сервер DNS подключен и настроен правильно.

Причина. В данном сайте нет сервера очереди сообщений, который работал бы на контроллере домена Windows 2000, настроенном в качестве сервера глобального каталога, или сертификат сервера просрочен либо не существует. Это относится к пользователям MSMQ 1.0, работающим в системе Windows NT 4.0, и всем пользователям, вошедшим в систему с помощью учетной записи локального пользователя.

Решение. Убедитесь, что соответствующий сервер очереди сообщений правильно настроен и обладает действительным сертификатом сервера.

Причина. Возможно, имеющихся разрешений недостаточно для доступа к Active Directory.

Решение. Предоставьте себе разрешения, достаточные для выполнения этой операции.

Внесенные изменения не отображаются в Active Directory

Причина. Из-за репликации содержимое оснастки может обновляться с задержкой, так что внесенные изменения будут отображены только по завершении репликации.

Решение. Нажмите клавишу F5 после внесения изменений или подождите по крайней мере 15 минут.

См. также: разделы «Репликация» и «Настройка репликации» в справке Windows 2000 Server.

Клиенты и локальные пользователи Windows NT 4.0 не имеют доступа к Active Directory

Причина. Во время установки сервера очереди сообщений на контроллере домена Windows 2000, входящем в данный лес, не была выбрана ослабленная безопасность. Для эффективной поддержки клиентов MSMQ 1.0, работающих под управлением Windows NT 4.0, и пользователей, вошедших в систему с помощью учетной записи локального пользователя, требования безопасности доступа к Active Directory должны быть ослаблены. (Зависимые клиенты не смогут запускаться с помощью учетной записи локального пользователя, и любой компьютер, направляющий запросы относительно объектов очереди сообщений в Active Directory на контроллер домена непосредственно, а не через сервер очереди сообщений, не получит доступа к Active Directory, если он вошел в сеть с помощью учетной записи локального пользователя, даже в условиях ослабленной безопасности для Active Directory.)

Решение. Используя программу ADSI Editor, входящую в пакет Windows XP Resource Kit, установите ослабленную безопасность.

См. также: Необходимость в ослабленной безопасности

Доступ к содержимому определенной очереди запрещен

Причина. Отсутствуют разрешения, необходимые для просмотра этой очереди. По умолчанию служба очереди сообщений отображает все очереди, предлагаемые для просмотра. Однако пользователь может просматривать только те очереди, которые ему разрешено открывать. Таким образом, могут существовать общие очереди, содержимое которых недоступно для просмотра в оснастках.

Решение. Предоставьте себе разрешения на просмотр сообщений и чтение содержимого очереди. Для просмотра содержимого журнала очереди необходимо обладать разрешением «Просмотр журнала» для этой очереди.

См. также: Просмотр очередей

Создавать очереди запрещено

Причина. Возможно, имеющихся разрешений недостаточно для выполнения этой операции.

Решение. Предоставьте себе разрешения, достаточные для выполнения этой операции.

См. также: Задание разрешений на доступ к объектам msmq

Не удается отправить сообщения в другой сайт

Причина. Возможно, между двумя сайтами не определена маршрутная ссылка, или назначенный шлюз сайтов недоступен. В результате, хотя приложение и может отправлять сообщения, они не в состоянии покинуть исходящую очередь.

Решение. Создайте маршрутную ссылку между двумя сайтами и определите для нее шлюзы сайтов. Для надежности рекомендуется создать несколько маршрутных ссылок между всеми сайтами.

См. также: Настройка маршрутных ссылок

Не удается отправить или получить сообщения с проверкой подлинности

Причина. Возможно, сертификат пользователя для этого компьютера удален, просрочен или не зарегистрирован в Active Directory. Сертификат пользователя необходим для отправки сообщений, проходящих проверку подлинности. Сертификат пользователя устанавливается в ходе установки очереди сообщений и регистрируется в Active Directory при первом входе в систему.

Решение. Откройте диалоговое окно Свойства: Очередь сообщений в оснастке «Управление компьютером» и обновите сертификат, а затем зарегистрируйте его.

Причина. Поставщик службы криптографии Microsoft Base CSP, входящий в комплект Windows XP, не используется приложениями очереди сообщений. Поставщик Microsoft Base CSP необходим для всех приложений очереди сообщений, отправляющих или получающих сообщения с проверкой подлинности.

Решение. Проверьте, используется ли приложениями очереди сообщений поставщик Microsoft Base CSP (или Enhanced CSP) при отправке или получении сообщений.

См. также: Сертификаты пользователей, Проверка подлинности в очереди сообщений

Все сообщения, отправляемые в очередь, отвергаются

Причина. Возможно, доступ к очереди ограничен.

Решение. Убедитесь, что очередь расположена в том же домене, что и компьютер, отправивший сообщение, либо в доверенном домене.

См. также. Задание разрешений для объектов очередей

Не удается извлечь сообщения из очереди

Причина. Для извлечения сообщений из очереди необходимо обладать разрешением «Получение сообщений» для этой очереди. Разрешения на чтение для этой очереди недостаточно.

Решение. Предоставьте себе разрешение на получение сообщений для этой очереди.

См. также: Чтение сообщений

Сообщения больше не отправляются на определенный компьютер или в определенную очередь

Причина. Превышена квота компьютера или очереди на соответствующем компьютере.

Проверить это можно двумя способами:

  1. запросите сообщения с отрицательными подтверждениями и проверьте их класс (этот способ применим в случае квот очередей, но не квот компьютеров);
  2. используя счетчики производительности, сравните квоту очереди или компьютера с фактическим объемом сообщений.

Решение. Обработайте и удалите сообщения из соответствующих очередей или увеличьте соответствующее значение квоты.

См. также: Задание квот компьютера для сообщений; Задание квот очередей для сообщений

Потеряны срочные сообщения

Причина. Недоставленные срочные сообщения теряются, когда служба очереди сообщений останавливается на компьютере, на котором эти сообщения хранятся в энергозависимой памяти, а также при завершении работы компьютера или в случае сбоя.

Решение. Пользуйтесь восстанавливаемыми или транзактными сообщениями (только транзактные сообщения полностью защищены от потерь данных).

См. также: Архивирование и восстановление сообщений

Зависимые клиенты не могут работать с транзактными сообщениями

Причина. Возможно, на компьютерах зависимых клиентов MSMQ 1.0, которые работают под управлением Windows NT 4.0 и обслуживаются поддерживающим сервером, работающим под управлением Windows 2000, не установлен пакет обновления 4 (SP4) для Windows NT. Он необходим для обработки транзактных сообщений.

Решение. Установите для этих зависимых клиентов пакет обновления Windows NT SP4 или более позднюю версию.

Причина. Не запущен координатор транзакций Microsoft Distributed Transaction Coordinator (DTC). Его наличие обязательно для обработки внешних транзакций.

Решение. Запустите DTC.

Не удается отправить тестовое сообщение в определенную очередь

Причина. Тестовые сообщения можно отправлять из оснастки MMC только в тестовые очереди, у которых код типа очереди равен {55EE8F33-CCE9-11CF-B108-0020AFD61CE9}.

Решение. Проверьте правильность кода типа очереди, в которую собираетесь послать тестовое сообщение. Нельзя заменять транзактную очередь или очередь, требующую проверки подлинности, на тестовую очередь, потому что в такую очередь тестовые сообщения доставляться не будут. Следует иметь в виду, что программным способом тестовые сообщения можно отправлять в очереди с любым кодом типа.

См. также: Отправка тестового сообщения в очередь

Файлы сообщений на локальном диске недоступны

Причина. По умолчанию только члены группы «Администраторы» локального компьютера имеют полный доступ ко всем локально хранящимся файлам сообщений, журналам и файлам LQS (локальным хранилищам очередей).

Решение. Предоставьте себе административные права на данном компьютере, или включите себя в локальную группу «Администраторы».

См. также: Задание разрешений для файлов сообщений

Не удается найти сообщения аудита для определенной операции

Причина. Сообщения аудита хранятся в журнале безопасности на сервере очереди сообщений, выполняющем эту операцию, но этот сервер может не быть владельцем объекта. Кроме того, сообщения аудита создаются в журнале безопасности только тогда, когда очередь открывается, а не для каждого полученного или отправленного сообщения.

Решение. С помощью программы просмотра событий изучите содержимое журнала безопасности соответствующего компьютера.

См. также: Аудит доступа в очереди сообщений.

Ошибки при взаимодействии с компьютерами, использующими протокол IPX

Причина. Служба очереди сообщений больше не поддерживает протокол IPX.

Решение. Включите протокол IP в конфигурацию компьютеров, использующих только протокол IPX.

Клиентам MSMQ 1.0 не удается проверить подлинность сервера очереди сообщений

Причина. Работая в среде смешанного режима, клиенты MSMQ 1.0 проверяют подлинность серверов очереди сообщений с помощью сертификатов серверов. Возможно, у данного сервера нет сертификата или его сертификат не зарегистрирован в Active Directory.

Решение. Создайте и зарегистрируйте сертификат сервера для каждого сервера очереди сообщений, отвечающего на запросы клиентов MSMQ 1.0.

См. также: Проверка подлинности сервера.

На зависимых клиентах не удается запустить приложения очереди сообщений

Причина. Для входа в систему была использована учетная запись локального пользователя или иная учетная запись, не прошедшая проверку подлинности. Учетные записи, не прошедшие проверку, не смогут запускать приложения очереди сообщений.

Решение. Войдите в систему с использованием учетной записи пользователя домена, подлинность которой проверяется автоматически.

Во время работы нескольких приложений, извлекающих сообщения из удаленной очереди, выдается сообщение о нехватке ресурсов

Причина. Когда приложение очереди сообщений извлекает сообщение из удаленной очереди, на локальном компьютере (на котором запущено это приложение) создается поток. Для этих целей на сервере очереди сообщений может создаваться по умолчанию до 64 потоков, а на независимом клиенте — до 16.

Решение. С помощью редактора реестра увеличьте значение параметра MaxRRThreads до требуемой величины. Этот параметр отображается в реестре только в том случае, если он впервые был добавлен в него с помощью редактора реестра либо изменен позднее. Чтобы увеличить значение этого параметра, выполните следующие действия.

  1. Чтобы открыть редактор реестра, нажмите кнопку Пуск, выберите команду Выполнить и введите regedt32.exe.
  2. Выберите раздел реестра Parameters.

    Где?

    • HKEY_LOCAL_MACHINE;
    • SOFTWARE
    • Microsoft
    • MSMQ
    • Parameters
  • В меню Правка выберите команду Добавить параметр.
  • В диалоговом окне Добавление параметра в поле Параметр введите MaxRRThreads; в поле Тип данных щелкните стрелку, открывающую список, выберите REG_DWORD и нажмите кнопку ОК.
  • В диалоговом окне Редактор двойных слов в поле Данные введите новое (десятичное) значение; в списке Представление щелкните Десятичное и нажмите кнопку ОК.

    • Внимание!

    • Ошибка при изменении реестра может серьезно повредить систему. Перед изменением реестра создайте резервную копию всех важных данных.

    Примечания

    • Эти потоки создаются по запросу и существуют в течение всего времени работы службы очереди сообщений на локальном компьютере.

    Превышен таймаут ожидания ресурсов очереди сообщений в кластере серверов

    Причина. По умолчанию таймаут подключения ресурсов в кластере серверов составляет три минуты. Очереди сообщений может потребоваться больше трех минут, в зависимости от сценариев восстановления и количества хранящихся сообщений.

    Решение. Увеличьте значение таймаута для ресурсов очереди сообщений, используемое по умолчанию.

    См. также:раздел «Ресурсы кластера» в справке Windows 2000 Server.


Устранение неполадок, связанных с триггерами очереди сообщений

В этом разделе обсуждаются наиболее распространенные неполадки, которые могут возникнуть при использовании триггеров очереди сообщений.

Вид неполадки

Служба триггеров очереди сообщений не запускается

Причина. Служба триггеров очереди сообщений настроена для запуска с использованием учетной записи пользователя домена, у которого нет надлежащих административных полномочий.

Решение. Настройте службу триггеров очереди сообщений для запуска с помощью стандартной учетной записи LocalSystem, обладающей всеми требуемыми разрешениями, или предоставьте себе необходимые разрешения.

Причина. Служба триггеров очереди сообщений завершилась аварийно. В инициируемых во время ее работы внутрипроцессных компонентах модели COM (Component Object Model) иногда могут возникать аварийные сбои, что вызывает аварийное завершение службы триггеров очереди сообщений.

Решение. Устраните условие, вызывающее аварийный сбой компонента COM, и затем заново запустите службу триггеров очереди сообщений.

Причина. Служба триггеров очереди сообщений перестала реагировать на запросы. Это может произойти в случае, если вызываемое действие (и соответствующий компонент EXE или COM) блокированы.

Решение. Подождите, пока заблокированный компонент сможет продолжить работу.

Триггер определен, но не срабатывает

Причина. Триггер в данный момент отключен.

Решение. Проверьте, включен ли триггер.

См. также: Просмотр и изменение свойств триггеров и правил триггеров

Причина. Учетная запись, использованная для запуска службы триггеров очереди сообщений, не обладает разрешением «Просмотр сообщения» для контролируемой очереди, или, если в триггере в качестве типа обработки сообщения задано «извлечение» или «транзактное извлечение», учетной записи не предоставлено разрешение «Получение сообщения» для этой очереди.

Решение. Измените разрешения для очередей и затем заново запустите службу триггеров очереди сообщений.

См. также: Задание разрешений для объектов компьютеров и очередей

Причина. Служба триггеров очереди сообщений не работает.

Решение. Проверьте, была ли запущена эта служба.

Причина. Служба триггеров очереди сообщений приостановлена.

Решение. Проверьте, не находится ли служба в приостановленном состоянии.

Причина. Первое правило, созданное и назначенное первому триггеру для очереди, применяется к сообщениям, уже содержавшимся до этого в очереди, а не к сообщениям, попавшим в нее после назначения правила.

Решение. Проверьте, какие сообщения обрабатывает служба триггеров очереди сообщений.

Причина. Удовлетворены не все условия триггера. Если вычисление какого-либо из условий дает значение «ложь», триггер не сработает.

Решение. Проверьте, все ли условия правила выполнены.

Обработка сообщений службой триггеров очереди сообщений резко замедляется при увеличении числа сообщений в контролируемой очереди.

Такая реакция обычна в условиях высокой нагрузки на службу триггеров очереди сообщений. Это происходит из-за достижения максимально допустимого числа потоков. Обработку сообщений можно ускорить, увеличив максимальное число разрешенных потоков.


Невозможно запустить программу.

Операционной системе не удается запустить программу. Возможны следующие решения:

Если компьютер подключен к локальной сети, следует обратиться к администратору сети.

Если компьютер находится под управлением системного администратора, причину, по которой невозможно запустить программу, следует выяснить у него. Возможно, администратор удалил данную программу или запретил пользователю ее запуск.

Установите необходимое оборудование.

Установка некоторых программ происходит автоматически после установки связанного с ними оборудования. Чтобы установить новое оборудование, нажмите кнопку Пуск, выберите команды Настройка и Панель управления и дважды щелкните значок Установка оборудования.

Установите необходимое программное обеспечение.

Возможно, программа не установлена на компьютере, по следующим причинам:

  • Данная программа является дополнительным компонентом. Чтобы установить дополнительные программы, нажмите кнопку Пуск, выберите команды Настройка и Панель управления и дважды щелкните значок Установка и удаление программ.
  • Не установлено оборудование, использующее данную программу. Чтобы установить новое оборудование, нажмите кнопку Пуск, выберите команды Настройка и Панель управления и дважды щелкните значок Установка оборудования.
  • Если компьютер подключен к локальной сети, администратор мог удалить данную программу или запретить пользователю ее запуск.

Переустановите файл программы.

Возможно, файл программы был случайно удален или поврежден. Если известно имя пропавшего файла, можно скопировать на жесткий диск его сжатую версию с установочного компакт-диска операционной системы, и затем востановить его, выполнив следующие действия.

  1. Вставьте установочный компакт-диск в устройство для чтения компакт-дисков.
  2. Щелкните кнопкуОбзор компакт-диска.
  3. В списке папок откройте папку «Alpha» или «I386».
  4. Найдите имя пропавшего файла.

    ПРИМЕЧАНИЕ. Последняя буква в расширении имени файла заменена знаком подчеркивания, поскольку это сжатая версия файла. Например, notepad.exe на установочном компакт-диске называется notepad.ex_.

  5. Скопируйте сжатый файл в папку systemroot\System32 на жестком диске.
  6. В меню Пуск выберите команды Программы и Командная строка.
  7. В командной строке введите:
    expand %systemroot%\system32\имя_файла.ex_ %systemroot%\system32\имя_файла.exe
    и нажмите клавишу Enter.


Сведения об авторском праве

В содержание настоящего документа, в том числе в URL-адреса и другие ссылки на веб-узлы в Интернете, могут быть внесены изменения без предварительного уведомления. Если не указано иное, все предприятия, организации, продукты, имена доменов, адреса электронной почты, эмблемы, лица, места и события, используемые в качестве примеров, являются вымышленными. Любое сходство с реально существующими предприятиями, организациями, продуктами, именами доменов, адресами электронной почты, эмблемами, лицами, местами и событиями случайно. Ответственность за соблюдение всех применимых в данном случае законов об авторских правах возлагается на пользователя. Без ущерба для авторских прав никакая часть настоящего документа не может быть воспроизведена, сохранена или представлена в информационно-поисковой системе, передана в какой-либо форме и какими-либо средствами (электронными, механическими, фотокопировальными, записывающими или другими) и в каких-либо целях без явного письменного разрешения корпорации Майкрософт.

Корпорация Майкрософт может быть обладателем патентов, патентных заявок, товарных знаков, авторских прав, а также других прав интеллектуальной собственности, имеющих отношение к содержанию данного документа. Предоставление вам данного документа не означает передачи каких-либо прав на эти патенты, товарные знаки, объекты авторского права или иную интеллектуальную собственность, за исключением случаев, явно указанных в лицензионном соглашении с корпорацией Майкрософт.

© Корпорация Майкрософт (Microsoft Corporation), 2004. Все права защищены.

Microsoft, MS-DOS, Windows, Windows NT, Windows Server, Active Directory, Microsoft Press, MSDN, Visual Basic и Visual C++ являются зарегистрированными товарными знаками или товарными знаками корпорации Microsoft в США и других странах и регионах.

Названия прочих упомянутых здесь организаций и изделий могут являться товарными знаками соответствующих владельцев.


О данном файле справки

Разделы данного файла справки включены в компонент «Справка и поддержка». Для просмотра разделов выберите в меню Пуск команду Справка и поддержка.


Настройка серверов хранения и пересылки

Настройка серверов хранения и пересылки

Эта документация недоступна в данном предварительном выпуске.