Общие сведения о назначенных заданиях

С помощью планировщика заданий можно назначить выполнение сценария, запуск программы или открытие документа на наиболее удобное время. Планировщик заданий запускается при каждом запуске XOX и выполняется в фоновом режиме.

Планировщик заданий позволяет:

  • назначать задание к выполнению ежедневно, еженедельно, ежемесячно или в определенные моменты (например, при запуске системы);
  • изменять расписание для задания;
  • прекращать выполнение назначенного задания;
  • настраивать режим запуска задания в назначенное время.

См. также


Общие задачи: назначенные задания

Рисунок Microsoft Windows

Решение задач

Планируя выполнение заданий на компьютере, часто приходится выполнять следующие задачи. Чтобы найти конкретное слово или фразу, перейдите на вкладку Указатель или Поиск.

Создание назначенного задания

Прежде чем планировать задание к выполнению, необходимо создать одно или несколько заданий.

Пошаговые инструкции

Изменение назначенного задания

Создав назначенные задания, можно их изменять. Допускается изменение программы, расписания и отдельных свойств задания.

Пошаговые инструкции

Удаление назначенного задания

Назначенные задания, которые больше не нужны, можно удалять.

Пошаговые инструкции

Прекращение выполнения назначенного задания

Если назначенное задание начинает выполняться, пользователь, работающий в это время на компьютере, может остановить задание, а позже запустить снова.

Пошаговые инструкции

Временное отключение всех назначенных заданий

Все назначенные задания можно на время выключить или приостановить, а позже включить снова.

Пошаговые инструкции


Назначение нового задания

Чтобы назначить новое задание

  1. Откройте папку Назначенные задания.
  2. Дважды щелкните значок Добавить задание.
  3. Следуйте указаниям мастера планирования заданий.

Примечания

  • XOX
  • Если необходимо настроить дополнительные параметры задания, установите флажок Установить дополнительные параметры после нажатия кнопки «Готово» на последней странице мастера.
  • Проверьте правильность системной даты и времени на компьютере, так как планировщик заданий использует эти сведения для запуска назначенных заданий. Для проверки или изменения системной даты и времени дважды щелкните значение времени на панели задач.
  • Если пароль остается пустым и требуется задать выполнение задания при входе пользователя, откройте соответствующее задание. На вкладке Задание установите флажок Выполнять только при выполненном входе в систему. Задание будет выполняться в назначенное время после входа в систему пользователя, создавшего данное задание.


Изменение назначенного задания

Чтобы изменить назначенное задание

  1. Откройте папку Назначенные задания.
  2. Щелкните правой кнопкой мыши задание, которое требуется изменить, и выберите команду Свойства.
  3. Выполните одно или несколько действий из следующего списка.
    • Чтобы заменить программу, которую необходимо запустить, введите путь новой программы в поле Выполнить.
    • Чтобы изменить расписание задания, откройте вкладку Расписание.
    • Чтобы настроить параметры задания, например максимальное время выполнения, допустимое время простоя или параметры управления электропитанием, откройте вкладку Параметры.
    • Чтобы установить параметры безопасности задания, откройте вкладку Безопасность.

Примечания

  • XOX
  • При замене учетной записи пользователя или выполняемой программы необходимо указать пароль учетной записи пользователя.
  • Если программе требуется передать параметры командной строки, введите их после пути в поле Выполнить.
  • Если полный путь к программе включает пробелы, заключите его в прямые кавычки (""). Например:

    • "C:\Program Files\Windows Media Player\Mplayer2.exe"

  • Проверьте правильность системной даты и времени на компьютере, так как планировщик заданий использует эти сведения для запуска назначенных заданий. Для проверки или изменения системной даты и времени дважды щелкните значение времени на панели задач.


Удаление назначенного задания

Чтобы удалить назначенное задание

  1. Откройте папку Назначенные задания.
  2. Щелкните правой кнопкой мыши задание, которое требуется удалить, и выберите команду Удалить.

Примечания

  • XOX
  • При удалении назначенного задания удаляется только задание из расписания. Файл программы, запускаемый этим заданием, не удаляется с жесткого диска.
  • Для удаления назначенного задания можно также выбрать его и нажать клавишу DEL.


Остановка выполнения запущенного назначенного задания

Чтобы остановить выполнение запущенного назначенного задания

  1. Откройте папку Назначенные задания.
  2. Щелкните правой кнопкой мыши задание, которое требуется остановить, и выберите команду Завершить.

Примечания

  • XOX
  • Если назначенное задание запущено и затем остановлено, команда Завершить не прекратит выполнение всех других программ, которые могли быть запущены этим заданием.
  • Если остановить выполняемое задание, оно может быть завершено с некоторой задержкой (до трех минут).
  • Чтобы снова запустить остановленное задание, щелкните его значок правой кнопкой мыши и выберите команду Выполнить.


Немедленный запуск назначенного задания

Чтобы немедленно запустить назначенное задание

  1. Откройте папку Назначенные задания.
  2. Щелкните правой кнопкой мыши задание, которое требуется выполнить, и выберите команду Выполнить.

Примечания

  • XOX
  • Для остановки задания выберите команду Завершить в меню Файл.
  • Если задание не запускается, выберите команду Просмотр журнала в меню Дополнительно и изучите содержимое журнала для выяснения причины неполадок.


Включение режима получения уведомлений о пропущенных заданиях

Чтобы включить режим получения уведомлений о пропущенных заданиях

Для установки этого параметра необходимо быть членом группы администраторов.

  1. Откройте папку Назначенные задания.
  2. В меню Дополнительно выберите команду Уведомлять о пропущенных заданиях.

Примечания

  • XOX
  • Галочка перед командой Уведомлять о пропущенных заданиях означает, что служба уведомлений включена. Для остановки службы выберите команду Уведомлять о пропущенных заданиях еще раз, при этом галочка перед командой исчезнет.


Назначенные задания и команда AT

В предыдущих версиях Windows команда at использовалась для планирования запуска команды, сценария либо программы в указанные день и время. В XOX команда at выполняется с помощью служебной программы с графическим интерфейсом «Планировщик заданий», что предоставляет дополнительные возможности.

Для доступа к новым возможностям планировщика заданий используйте папку «Назначенные задания». Задание, назначенное с помощью команды at, появляется в папке «Назначенные задания» и получает имя следующего образца:

At3478

Теперь задание можно просматривать и изменять. Однако если изменить задание, оно превращается в обычное назначенное задание. Задание становится недоступным для команды at, и учетная запись команды at больше к нему не относится. Нужно будет явно указать для задания учетную запись пользователя и пароль.

Все задания, созданные с помощью команды at, должны выполняться с использованием той же учетной записи пользователя, как в более ранних версиях Windows. В то же время любое задание, созданное в папке «Назначенные задания», можно выполнить от имени другой учетной записи пользователя.

В более ранних версиях Windows задания назначались командой at с использованием той же учетной записи пользователя, что и для службы расписаний (также известной, как служба "at"). Эту учетную запись можно было настроить как локальную системную учетную запись или как учетную запись произвольного пользователя.

В XOX служба расписаний должна запускаться с системными правами доступа на локальном компьютере. Однако для запуска заданий, созданных командой at, можно установить другую учетную запись. Для этого воспользуйтесь меню Дополнительно в папке «Назначенные задания».

В папке «Назначенные задания» можно просматривать и изменять параметры задания, созданного с использованием команды at. Однако если изменить в этой папке задание, созданное командой at, оно превращается в обычное назначенное задание. Задание становится недоступным для команды at, и учетная запись команды at больше к нему не относится. Нужно будет явно указать для задания учетную запись пользователя и пароль.


Просмотр журнала выполнения назначенных заданий

Чтобы просмотреть журнал выполнения назначенных заданий

  1. Откройте папку Назначенные задания.
  2. В меню Дополнительно выберите команду Просмотр журнала.

Примечания

  • XOX
  • Используемый по умолчанию в планировщике заданий файл журнала храниться в папке \Windows и называется SchedLgU.txt.
  • По умолчанию файл журнала имеет размер 32 КБ.
  • Когда файл журнала достигнет максимального размера, новые сведения станут автоматически записываться в начало файла, поверх старого содержимого.


Просмотр назначенных заданий на удаленном компьютере

Чтобы просмотреть назначенные задания на удаленном компьютере

  1. Откройте окно Мое сетевое окружение.
  2. Выполните одно из следующих действий.
    • Если локальный компьютер принадлежит домену, выполните поиск удаленного компьютера, выбрав вариант Вся сеть в списке Другие места, а затем дважды щелкните пункт Сеть Microsoft Windows.
    • Если локальный компьютер не принадлежит домену, выполните поиск удаленного компьютера, выбрав вариант Обзор компьютеров в рабочей группе в списке Сетевые задачи.
  3. Дважды щелкните значок удаленного компьютера, на котором требуется просмотреть назначенные задания.
  4. Дважды щелкните значок Назначенные задания.

Примечания

  • XOX
  • Просматривать задания на удаленном компьютере с операционной системой Windows может только пользователь, имеющий права администратора на удаленном компьютере.
  • Изменять задания на удаленном компьютере с операционной системой Windows 95, Windows 98, Windows NT 4.0, Windows 2000 или XOX можно только в том случае, если на удаленном компьютере установлено программное обеспечение общего доступа к файлам и назначен общий ресурс x$, где x представляет жесткий диск, на котором находится папка "Назначенные задания".


Просмотр скрытых задач

Чтобы просмотреть скрытые задачи:

XOX

  1. Откройте планировщик заданий.
  2. В меню Дополнительно выберите команду Просмотреть скрытые задания.

Примечания

  • XOX
  • Задания можно создавать и скрывать с помощью интерфейса прикладных программ (API). Средство просмотра скрытых задач позволяет администраторам просматривать все имеющиеся на компьютере задания, включая скрытые.


Удаленный доступ к назначенным заданиям

Администраторы сети могут создавать файлы заданий и добавлять их на компьютеры пользователей по мере необходимости. Предусмотрен обмен файлами заданий, как и любыми другими файлами (например, посредством сообщений электронной почты). Кроме того, можно открыть общий доступ к папке назначенных заданий локального компьютера (обычно это c:\Windows\Tasks) так, чтобы к ней можно было обращаться в удаленном режиме с помощью окна «Мое сетевое окружение».

Примечания

  • Разрешается создавать назначенное задание на локальном компьютере и затем перетаскивать его на другой удаленный компьютер.
  • Необходимо предоставить пароль для учетной записи, в соответствии с которой требуется выполнить назначенное задание. Пароль не может быть пустым.


Приостановка выполнения назначенных заданий

Чтобы приостановить выполнение назначенных заданий

  1. Откройте папку Назначенные задания.

  2. В меню Дополнительно выберите команду Приостановить планировщик.

Примечания

  • XOX
  • Команда Приостановить планировщик полезна в случаях, когда требуется отменить выполнение назначенного задания во время установки программного продукта или во время работы другой программы (например, игровой).
  • Задания, которые не были выполнены из-за паузы в работе планировщика заданий, будут запущены в следующий раз согласно своему расписанию.
  • Чтобы возобновить действие расписания заданий, выберите в меню Дополнительно команду Возобновить работу планировщика.


Остановка выполнения назначенных заданий

Чтобы остановить выполнение назначенных заданий

  1. Откройте папку Назначенные задания.
  2. В меню Дополнительно выберите команду Остановить планировщик.

Примечания

  • XOX
  • По окончании работы с планировщиком заданий запуск назначенных сценариев, программ или документов не выполняется; при следующем входе в XOX планировщик заданий автоматически не загружается.


Настройка учетной записи службы AT

Чтобы настроить учетную запись службы AT

XOX

  1. Откройте папку Назначенные задания.
  2. В меню Дополнительно выберите команду Учетная запись службы AT.
  3. Выберите параметр Учетная запись, затем введите учетную запись пользователя, которая будет применяться для запуска заданий, назначенных с помощью команды at.
  4. В полях Пароль и Подтверждение введите правильный пароль для данной учетной записи.

Примечания

  • XOX
  • Указанная учетная запись пользователя должна обладать соответствующими разрешениями для выполнения любого задания, назначенного с помощью команды at. Например, если планируется запуск программ, которые могут выполняться только администраторами, необходимо задать учетную запись администратора.
  • Вместо параметра Учетная запись можно выбрать вариант Системная учетная запись. Если для команды at выбран параметр Системная учетная запись, назначенные задания будут выполняться с использованием учетной записи LocalSystem.


Запуск назначенного задания во время простоя компьютера

Чтобы запустить назначенное задание во время простоя компьютера

  1. Откройте папку Назначенные задания.
  2. Щелкните правой кнопкой мыши задание, которое следует выполнить во время простоя компьютера, и выберите команду Свойства.
  3. На вкладке Настройка в группе Время простоя установите флажок Запускать задание, только когда компьютер уже простаивает.
  4. Укажите интервал времени (в минутах), в течение которого компьютер должен простаивать перед запуском задания.

Примечания

  • XOX
  • Компьютер простаивает, когда не производятся операции с мышью или клавиатурой.
  • Можно указать интервал времени (в минутах), в течение которого будет проверяться состояние компьютера для запуска назначенного задания.
  • Чтобы при возобновлении активности компьютера выполнение задания прекращалось, установите флажок Останавливать задание, когда прекращается простаивание.


Установка параметров управления электропитанием для назначенного задания

Чтобы установить параметры управления электропитанием для назначенного задания

  1. Откройте папку Назначенные задания.
  2. Щелкните правой кнопкой мыши задание, для которого нужно задать параметры управления электропитанием, и выберите команду Свойства.
  3. На вкладке Настройка в группе Управление электропитанием выполните одно или несколько действий из следующего списка.
    • Чтобы экономно расходовать заряд батарей компьютера, установите флажок Не выполнять задание, если компьютер работает от батарей.
    • Чтобы выполнение задания прекращалось при переходе компьютера на автономное питание, установите флажок Остановить задание при переключении на питание от батарей.
    • Чтобы активизировать питаемый от батарей компьютер для запуска задания, установите флажок Разбудить компьютер для запуска этого задания. (Данный параметр доступен только на компьютерах, поддерживающих эту возможность.)

Примечания

  • XOX
  • По умолчанию управление электропитанием настроено таким образом, чтобы назначенные задания не выполнялись при питании компьютера от батарей. Если необходимо запустить назначенное задание на переносном компьютере, работающем от батарей, снимите флажки, установленные по умолчанию.
  • В случае сбоя электропитания или отказа батареи выполняемое задание может быть не завершено.


Назначенные задания и безопасность

При назначении нового задания можно установить разрешения, позволяющие другим пользователям выполнять то же самое задание.
  • Настройка учетных данных пользователя
  • Задание разрешений
  • Установка дополнительных параметров безопасности
  • Сброс паролей


Устранение неполадок назначенных заданий

Если запланированное задание не запускается в назначенное время, щелкните правой кнопкой мыши значок задания и выберите команду Свойства. Убедитесь, что на вкладке Задание установлен флажок Включено (задание будет выполняться в заданное время). На вкладке Расписание проверьте, правильно ли составлено расписание.

Если программа задания выполняется неверно, проверьте, указаны ли для нее все необходимые параметры командной строки. Для получения дополнительных сведений о конкретной программе и ее параметрах командной строки выполните одно из следующих действий.

  • При наличии справки по программе ознакомьтесь с ней.
  • В командной строке введите следующую команду (где программа представляет имя программы, которую следует запустить): программа /?

Также можно проверить столбец Состояние в окне «Назначенные задания». Возможные состояния заданий перечислены в следующей таблице.

Состояние | Описание
Пусто | Задание не выполняется, либо уже успешно выполнено
Запущено | Задание выполняется
Пропущено | Одна или несколько попыток выполнить задание были пропущены
Запуск не удался | Последняя попытка запуска задания была неудачной

Дополнительные сведения о состоянии назначенного задания можно найти в файле журнала SchedLgU.txt. Этот файл журнала планировщика заданий храниться в папке Windows и используется для записи выполнения назначенных заданий. С помощью журнала можно определить причину остановки задания или проверить его состояние.

Примечания

  • Если на компьютере, подключенном к домену, не удается запустить ни одно из назначенных заданий, обратитесь к системному администратору, чтобы проверить, включена ли служба планировщика заданий.
  • Если пользователь не вошел в систему к моменту запланированного запуска задания, задание начнет выполняться, но останется скрытым.
  • Для проверки состояния назначенного задания выберите в меню Вид команду Таблица, затем прокрутите список, чтобы был виден столбец Состояние.


Установка дополнительных параметров безопасности

Можно установить дополнительные разрешения для файлов и папок, предоставляющие пользователю возможность просмотра или редактирования назначенного задания, либо запрещающие какие-либо операции.

Примечания

  • Чтобы просмотреть параметры безопасности для назначенного задания, щелкните значок задания правой кнопкой мыши, выберите команду Свойства и затем перейдите на вкладку Безопасность.
  • Для просмотра или изменений дополнительных установок безопасности на вкладке Безопасность нажмите кнопку Дополнительно. На вкладке Разрешения выберите пользователя, для которого требуется задать просмотр или изменение разрешения, нажмите кнопку Изменить.


Дата компиляции

Дата компиляции: 2003-12-03


Сброс паролей

В XOX пароль имеет определенный срок действия. По назначении заданий, повторяющихся неограниченное количество раз, необходимо учитывать срок действия паролей. При истечении срока действия пароля компьютера необходимо сбросить пароли назначенных заданий.

Примечание

  • Чтобы изменить или задать новый пароль, откройте соответствующее задание. На вкладке Задачи нажмите кнопку Задать пароль.


Настройка учетных данных пользователя

При создании задания выводится запрос имени пользователя и пароля. Это обпеспечивает более безопасный способ управления заданиями, выполняющимися на локальном компьютере. Несколько пользователей компьютера могут иметь собственные назначенные задания.

После установки имени пользователя другой пользователь не может отменить или удалить задание при отсутствии соответствующих прав.

Примечания

  • Чтобы завершить планирование задания, необходимо ввести имя пользователя в окне мастера планирования заданий.
  • Если пароль не введен, в последнем окне мастера появляется сообщение об ошибке, оповещающее о возможности невыполнения задания. Если пароль остается пустым и требуется задать выполнение задания при входе пользователя, откройте соответствующее задание. На вкладке Задание установите флажок Выполнять только при выполненном входе в систему. Задание будет выполняться в назначенное время после входа в систему пользователя, создавшего данное задание.
  • Пароль можно изменить, установив флажок Установить дополнительные параметры после нажатия кнопки «Готово» на последней странице мастера.


Задание разрешений

В XOX назначение и выполнение заданий основано на стандартных разрешениях безопасности XOX. Задания можно настраивать с помощью дескрипторов безопасности файловой системы NTFS, которые позволяют устанавливать разрешения для конкретных пользователей или групп, дающие право на просмотр, удаление, изменение или использование задания. Кроме того, выполнение отдельных элементов в составе задания (сценариев, программ, документов) контролируется дескрипторами безопасности, соответствующими этим элементам.

Для настройки параметров безопасности назначенного задания следует добавить либо удалить пользователя на вкладке Безопасность. После добавления имени пользователя в назначенное задание можно устанавливать разрешения на доступ пользователя к этому заданию.

Для назначенного задания можно устанавливать следующие разрешения.

Разрешение | Разрешаемые действия
Полный доступ | Просмотр, запуск, изменение, удаление, смена владельца
Изменение | Просмотр, запуск, изменение, удаление
Чтение и выполнение | Просмотр и запуск
Чтение | Просмотр
Запись | Просмотр, запуск, изменение, удаление

Примечания

  • Чтобы просмотреть параметры безопасности для назначенного задания, щелкните значок задания правой кнопкой мыши, выберите команду Свойства и затем перейдите на вкладку Безопасность.
  • Для просмотра или изменения дополнительных параметров безопасности нажмите кнопку Дополнительно на вкладке Безопасность.