Компонент «Сетевые подключения»

Компонент «Сетевые подключения» обеспечивает связь локального компьютера с Интернетом, локальной сетью или другим компьютером. Это средство позволяет получать доступ к ресурсам и функциональным возможностям сети независимо от того, как пользователь подключен к сети — напрямую или с помощью служб удаленного доступа. Операции создания, настройки, сохранения подключений и наблюдения за ними выполняются в папке «Сетевые подключения».

Специальный мастер нового подключения помогает создавать подключения к Интернету с использованием модема удаленного доступа, адаптера ISDN, линии DSL или кабельного модема. С помощью этого мастера можно создавать входящие подключения, прямые подключения и подключения виртуальной частной сети (VPN). Если на компьютере установлен сетевой адаптер, автоматически создается подключение по локальной сети.

Каждое подключение в папке «Сетевые подключения» поддерживает определенный набор возможностей, используемых для связи между локальным компьютером и другим компьютером или сетью. Для установки соединения с сетью исходящие подключения обращаются к серверу удаленного доступа с помощью определенного метода доступа (через локальную сеть, модем, линию ISDN, DSL, кабельный модем и т. п.). Входящие подключения, наоборот, позволяют другим компьютерам подключаться к компьютеру под управлением XOX, XOX или к изолированному компьютеру под управлением Windows 2000 Server. Это означает, что такой компьютер может выступать в качестве сервера удаленного доступа. Независимо от способа подключения — через локальную сеть, в удаленном режиме (по телефонной линии, ISDN и т. п.) или обоими этими способами, — любое подключение можно настроить на выполнение необходимых сетевых операций. К таким операциям относится печать на сетевых принтерах, работа с сетевыми дисками и файлами, просмотр других сетей и доступ к Интернету.

Все службы и методы связи настраиваются в рамках конкретного подключения, поэтому для настройки подключения не требуются внешние средства управления. Например, параметры подключения удаленного доступа определяют возможности, которые задействуются до, во время и после процесса подключения. В частности, они задают модем, выполняющий набор номера, вид шифрования пароля, который должен применяться в процессе подключения, и сетевые протоколы, которые будут использоваться после установления связи. Состояние подключения, в том числе сведения о его продолжительности и скорости, можно просмотреть средствами самого подключения; нет необходимости пользоваться какими-либо внешними средствами наблюдения за состоянием. Сведения о настройке параметров подключения см. в разделе Чтобы настроить подключение.

Средства безопасности доменов и процедуры входа в сеть, поддержка защитных узлов, шифрование данных, проверка подлинности и функция ответного вызова обеспечивают безопасный доступ к сети для сетевых подключений и подключений удаленного доступа. Дополнительные сведения о безопасности см. в разделе Средства безопасности в компоненте «Сетевые подключения».

См. также


Оборудование, необходимое для сетевых подключений

В зависимости от конфигурации системы может потребоваться все нижеперечисленное оборудование или часть этого списка.

  • Сетевой адаптер с драйвером, соответствующим стандарту NDIS (Network Driver Interface Specification), для подключения к локальной сети.
  • Один или несколько совместимых модемов и свободный COM-порт.
  • Модем с быстродействием 28,8 или 56 Кбит/с или адаптер ISDN (если используется линия ISDN).
  • Модем DSL. Если это внешний модем DSL, он обычно подключается к адаптеру сети Ethernet.
  • Кабельный модем. Если это внешний кабельный модем, он обычно подключается к адаптеру сети Ethernet.
  • Плата X.25 или устройство PAD (если используется сеть X.25).
  • Аналоговая телефонная линия.
  • Если компьютер настроен на прием входящих подключений, многопортовый адаптер позволит повысить производительность при работе с несколькими подключениями.

XOX

Сведения о настройке параметров подключения см. в разделе Чтобы настроить подключение.


Контрольный список: настройка сетевых подключений

Действие | Справочные сведения
Знакомство с основными понятиями | Компонент «Сетевые подключения»
Подключение к локальной сети | Чтобы создать подключение по локальной сети
Подключение к сети по телефонной линии | Чтобы создать подключение удаленного доступа по телефонной линии
Подключение к поставщику услуг Интернета | Чтобы создать подключение к Интернету
Подключение к частной сети через Интернет (виртуальная частная сеть) | Чтобы создать подключение к виртуальной частной сети (VPN)
Прямое подключение к другому компьютеру | Чтобы создать прямое сетевое подключение
Предоставление доступа к данному компьютеру с других компьютеров | Чтобы создать входящее сетевое подключение
Наблюдение за подключением | Чтобы выбрать режим наблюдения за подключением


Переименование и создание сетевых подключений

Ниже приведены практические рекомендации по переименованию сетевых подключений и созданию нескольких копий подключений.

  • Если используется несколько сетевых адаптеров, переименуйте все подключения по локальной сети.

    • Операционная система обнаруживает установленные сетевые адаптеры и автоматически создает в папке «Сетевые подключения» для каждого из них подключение по локальной сети. Если на компьютере установлено несколько сетевых адаптеров, во избежание путаницы сразу же переименуйте все подключения по локальным сетям, присвоив каждому из них имя, отражающее тип соответствующей сети. Например, предположим, что на компьютере имеется сетевой адаптер, который подсоединен к внешнему модему DSL или кабельному модему, обеспечивающему подключение к Интернету. Переименуйте это подключение, выбрав какое-нибудь простое имя, чтобы его было легко найти в папке «Сетевые подключения».

    Для каждого подключения нужно добавить или включить необходимые ему сетевые службы, клиенты и протоколы. При этом клиенты, службы и протоколы будут добавляться или включаться и для всех остальных сетевых подключений и подключений удаленного доступа.

  • Создайте несколько подключений удаленного доступа или подключений VPN, скопировав их в папке «Сетевые подключения».

    • Когда подключения будут скопированы, можно переименовать их и изменить их параметры. Этот способ позволяет быстро создать несколько подключений для работы с различными модемами, поставщиками услуг Интернета, профилями набора номера и т. д.

    Дополнительные сведения см. в разделе Чтобы скопировать сетевое подключение.


Новые способы выполнения типичных задач

В следующей таблице перечислены некоторые стандартные задачи, связанные с сетевыми подключениями. Пользовательский интерфейс для выполнения этих задач в XOX отличается от того, который применяется в Windows NT версии 4.0. В эту таблицу не вошли различия между операционными системами Windows 2000 и XOX.

Интерфейс для создания сетевых подключений в XOX отличается от того, который применяется в Windows 2000. Мастер новых подключений заменил мастера сетевого подключения и мастера подключения к Интернету, использовавшихся в Windows 2000. Этот мастер моздает сетевые подключеняи всех типов, в том числе подключения к Интернету, входящие подключения, подключения удаленного доступа, подключения VPN и прямые подключения. Используя следующую таблицу, можно узнать, как с помощью мастера нового подключения создается подключение каждого из этих типов.

Задача | Используемый компонент Windows NT 4.0 | Используемый компонент XOX
Подключение к сети с помощью модема или по линии ISDN | Удаленный доступ к сети в папке «Мой компьютер» (щелкните значок Создать) | Сетевые подключения. Дополнительные сведения см. в разделе Чтобы создать подключение удаленного доступа по телефонной линии
Подключение к сети при помощи виртуальной частной сети (VPN) | Удаленный доступ к сети в папке «Мой компьютер» (щелкните значок Создать) | Сетевые подключения. Дополнительные сведения см. в разделе Чтобы создать подключение к виртуальной частной сети (VPN)
Настройка компьютера на прием входящих подключений | Сеть на панели управления | Сетевые подключения. Дополнительные сведения см. в разделе Чтобы создать входящее сетевое подключение
Настройка протокола TCP/IP | Сеть на панели управления | Сетевые подключения. Дополнительные сведения см. в разделе Чтобы настроить параметры TCP/IP
Настройка подключения | Удаленный доступ к сети в папке «Мой компьютер» (нажмите кнопку Дополнительно) | Сетевые подключения. Дополнительные сведения см. в разделе Чтобы настроить подключение
Добавление клиента или службы | Сеть на панели управления | Сетевые подключения. Дополнительные сведения см. в разделе Чтобы добавить сетевой компонент
Добавление протокола | Сеть на панели управления | Сетевые подключения. Дополнительные сведения см. в разделе Чтобы добавить сетевой компонент
Добавление дополнительных сетевых компонентов | Сеть на панели управления | Сетевые подключения. Дополнительные сведения см. в разделе Чтобы добавить дополнительные сетевые компоненты
Наблюдение за входящими или исходящими подключениями | Монитор удаленного доступа к сети на панели управления | Сетевые подключения. Дополнительные сведения см. в разделе Чтобы выбрать режим наблюдения за подключением


Типы сетевых подключений

Существует пять типов сетевых подключений и подключений удаленного доступа. В следующей таблице показаны все типы подключений, описаны используемые ими способы связи и приведены примеры этих подключений. XOX

Тип подключения | Способ связи | Пример
Подключения удаленного доступа | Модем, ISDN, X.25 | Подключение к сети предприятия или к Интернету средствами удаленного доступа
Подключения по локальной сети | Ethernet, Token Ring, кабельный модем, DSL, FDDI, IP поверх ATM, IrDA, беспроводная связь, технологии глобальных сетей (T1, Frame Relay) | Обычный пользователь сети предприятия. Подключение к Интернету через кабельный модем или линию DSL. С помощью адаптеров Ethernet, IrDA, HPNA и беспроводных адаптеров можно построить домашнюю или небольшую офисную сеть.
Подключения виртуальной частной сети (VPN) | Виртуальная частная сеть (VPN) с использованием туннеля PPTP или L2TP в корпоративной сети или в Интернете | Безопасное подключение к корпоративной сети через Интернет
Прямые подключения | Последовательный кабель, инфракрасная связь, кабель DirectParallel | Синхронизация данных между карманным компьютером Windows CE и настольным компьютером
Входящие подключения | Подключения удаленного доступа, подключения VPN или прямые подключения | Вызов для установки связи с сервером удаленного доступа в домашней или небольшой офисной сети

См. также


Настройка сетевого подключения

Конфигурация любого сетевого подключения или подключения удаленного доступа задается набором параметров. Для каждого подключения определяются такие параметры, как номер телефона, число попыток повторного набора номера и т. п. Эти параметры, применяющиеся до или после установки подключения, не влияют на настройку других подключений. Например, если один из серверов часто оказывается занят, то подключение к нему можно настроить на десятикратное повторение набора номера. Для другого сервера, менее загруженного, можно задать подключение удаленного доступа с тремя попытками установить связь. Параметры повторного набора номера первого подключения никак не повлияют на число попыток набора номера для второго подключения — их никогда не будет больше трех. Для настройки подключения удаленного доступа не нужно изменять никакие параметры, не относящиеся к данному подключению.

Изменение некоторых сетевых параметров подключения может повлиять на другие подключения. Например, если добавить в список доступных сетевых компонентов какого-либо подключения протокол IPX/SPX, то этот протокол хотя и не будет включен, но станет доступен другим подключениям, установленным на этом же компьютере.

Параметры можно изменять и для активных подключений. Разрешается также переименовывать активные подключения. Однако для сохранения изменений может потребоваться повторное подключение. В таком случае соединение разрывается, измененные параметры сохраняются, после чего подключение сразу же восстанавливается.

Для каждого подключения задается минимальный набор необходимых для успешного соединения параметров. Эти параметры расположены на вкладке Общие. Например, для подключений по локальной сети на этой вкладке достаточно указать лишь сетевой адаптер. Для подключений удаленного доступа вкладка Общие содержит такие необходимые сведения, как устройство для подключения, номер телефона и коды города и страны.

Для исходящих подключений на вкладках Параметры, Безопасность, Сеть и Доступ можно задать дополнительные параметры конфигурации. Для входящих подключений дополнительные параметры задаются на вкладках Пользователи и Сеть.

Другие дополнительные параметры настраиваются в диалоговом окне, вызываемом командой Дополнительные параметры меню Дополнительно папки «Сетевые подключения». Изменив надлежащим образом эти параметры, можно добиться повышения производительности. Например, порядок обращения к службам доступа к сети и сетевым протоколам определяется в диалоговом окне Дополнительные параметры. Если подключение локальной сети обеспечивает доступ к сетям NetWare и Microsoft Windows, использующим протоколы TCP/IP и IPX, но используется главным образом для работы в сети Microsoft Windows с протоколом TCP/IP, то можно переместить элемент Сеть Microsoft Windows в начало списка Службы доступа к сети на вкладке Порядок служб доступа, а элемент Протокол Интернета (TCP/IP) — в начало списка привязки для узла Служба доступа к файлам и принтерам сетей Microsoft на вкладке Адаптеры и привязки. Изменение порядка служб доступа к сети и порядка привязки протоколов позволит повысить производительность.

XOX

См. также


Изменение параметров подключения

Рисунок Microsoft Windows

Чтобы измененить параметры подключения

  1. Откройте компонент Сетевые подключения.
  2. Чтобы настроить подключение удаленного доступа или изменить его параметры, щелкните подключение, которое требуется настроить, а затем в группе Сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. Выполните одно или несколько действий из следующего списка.
    • Чтобы настроить устройства набора номера, которые используются компьютером для установления подключения (например, модем), телефонные номера, адреса узлов, коды страны или региона или правила набора номера, выберите вкладку Общие.
    • Чтобы настроить параметры набора номера, повторного набора номера или параметры X.25, откройте вкладку Параметры.
    • Чтобы настроить параметры проверки подлинности пользователя, которые помогают проверить подлинность компьютера пользователя при установлении подключения, шифрование (с помощью этой функции можно закодировать содержание таким образом, что оно вряд ли сможет быть прочитано кем-то, кроме указанного получателя), окно терминала или параметры сценариев, откройте вкладку Безопасность.
    • Чтобы настроить сервер удаленного доступа, к которому требуется подключиться, и протоколы подключения (формат, который компьютер пользователя использует для связи с другими компьютерами), откройте вкладку Сеть.
    • Чтобы включить или выключить общий доступ к подключению к Интернету или настроить компьютер для автоматического установления подключения, откройте вкладку Дополнительно.

Примечания

  • XOX
  • В зависимости от используемого типа подключения параметры и вкладки в диалоговом окне Свойства могут различаться. Если отсутствует какой-то конкретный параметр, это означает, что он не используется для данного настраиваемого подключения.
  • Для всех сетей и подключений к Интернету автоматически включается брандмауэр Windows. Для получения дополнительных сведений щелкните ссылку См. также.

См. также


Копирование сетевого подключения

Рисунок Microsoft Windows

Чтобы скопировать сетевое подключение

  1. Откройте компонент Сетевые подключения.
  2. Щелкните правой кнопкой мыши подключение удаленного доступа, подключение VPN или прямое подключение и выберите команду Создать копию.

Примечания

  • XOX
  • Нельзя копировать подключения по локальной сети и входящие подключения.
  • Можно создать несколько подключений удаленного доступа, подключений к виртуальным частным сетям (VPN) или прямых подключений, скопировав их в папке «Сетевые подключения». Затем можно переименовать подключения и изменить их параметры. Этот способ позволяет быстро создать несколько подключений для работы с различными модемами, поставщиками услуг Интернета, профилями набора номера и т. д.

См. также


Восстановление подключения по локальной сети или высокоскоростного подключения к Интернету

Рисунок Microsoft Windows

Чтобы восстановить подключение по локальной сети или высокоскоростное подключение к Интернету

XOX

  1. Откройте компонент Сетевые подключения.
  2. В списке ЛВС или высокоскоростной Интернет выберите подключение, которое требуется восстановить, и затем в группе Типичные сетевые задачи щелкните ссылку Восстановление отдельного подключения.
  3. Если после этого подключение не восстановится, выполните следующие действия.
    • Посмотрите на световые индикаторы состояния на модеме DSL или кабельном модеме; они показывают, функционирует ли подключение к поставщику услуг Интернета.
    • Выключите модем DSL или кабельный модем и затем включите снова.
    • Если и это не восстановит работоспособность подключения к Интернету, обратитесь к своему поставщику услуг Интернета.

Примечания

  • XOX
  • Если на компьютере установлено несколько сетевых адаптеров, рекомендуется переименовать подключение к Интернету, чтобы его было легче опознать. Например, присвойте ему имя «Подключение к Интернету» или имя поставщика услуг Интернета.

См. также


Отключение от сети

Рисунок Microsoft Windows

Чтобы отключиться от сети

  1. Откройте компонент Сетевые подключения.
  2. Щелкните правой кнопкой мыши нужное подключение и выполните одно из следующих действий.
    • Если это подключение удаленного доступа, подключение VPN или входящее подключение, нажмите кнопку Отключить.
    • Если это подключение по локальной сети, также нажмите кнопку Отключить.

Примечания

  • XOX
  • При разрыве подключения по локальной сети работа драйвера сетевого адаптера приостанавливается до тех пор, пока подключение не будет возобновлено.

См. также


Общие сведения о подключениях по локальной сети

При создании домашней или малой офисной сети компьютеры под управлением XOX или XOX подключены к локальной сети (LAN). При установке XOX обнаруживается сетевой адаптер и создается подключение по локальной сети. Как и подключения других типов, оно показано в папке «Сетевые подключения». По умолчанию подключение по локальной сети всегда активно. Только подключения этого типа создаются и активизируются автоматически.

Если разорвать подключение по локальной сети, оно больше не будет автоматически активизироваться. Сведения об этом сохраняются в профиле оборудования, поэтому профиль позволяет учитывать потребности мобильных пользователей, меняющих свое местоположение. Например, во время командировки в другой город можно использовать другой профиль оборудования, который не активизирует подключение по локальной сети, поэтому не придется тратить время на ожидание соединения с недоступной сетью. Сетевой адаптер даже не будет пытаться выполнить подключение.

Если на компьютере установлено несколько сетевых адаптеров, в папке «Сетевые подключения» для каждого из них будет создан значок подключения по локальной сети.

Локальные сети можно строить с помощью адаптеров Ethernet, беспроводных адаптеров, адаптеров домашней сети на базе телефонной линии (HPNA), кабельных модемов, линий DSL, средств инфракрасной связи (IrDA), а также технологий Token Ring, FDDI, IP поверх ATM и средств эмуляции на базе ATM. Эмулируемые сети строятся на основе драйверов виртуальных адаптеров, таких как LAN Emulation Protocol (протокол эмуляции локальной сети).

Если в сеть вносятся изменения, измените соответствующим образом параметры существующего подключения по локальной сети. Сведения об изменении параметров подключения см. в разделе Чтобы настроить подключение. Команда Состояние папки «Сетевые подключения» позволяет просматривать такие сведения о подключении, как длительность соединения, его скорость, объем принятых и отправленных данных, а также средства диагностики, доступные для данного подключения. Сведения об использовании команды Состояние см. в разделе Чтобы просмотреть состояние подключения по локальной сети.

Если на компьютере установлен новый сетевой адаптер, то при очередной загрузке компьютера в папке «Сетевые подключения» появится значок нового подключения по локальной сети. Средства Plug and Play обнаруживают сетевой адаптер и создают для него подключение по локальной сети. Устройства PC Card можно устанавливать прямо на включенный компьютер без его последующей перезагрузки. Значок подключения по локальной сети будет сразу же добавлен в папку. Вручную добавить значок подключения по локальной сети в папку «Сетевые подключения» нельзя.

Команда Дополнительные параметры позволяет настраивать параметры нескольких сетевых адаптеров. Можно изменить порядок адаптеров, используемых подключением, и связанные с каждым адаптером службы, клиенты и протоколы. Можно также изменить порядок служб доступа к сети, в соответствии с которым данное подключение получает доступ к ресурсам, таким как сети и принтеры.

Настройка устройства, которое используется подключением, и всех связанных с ним клиентов, служб и протоколов выполняется с помощью команды Свойства. Клиенты определяют параметры доступа к компьютерам и файлам сети для данного подключения. Службы предоставляют такие возможности, как общий доступ к файлам и принтерам. Протоколы, такие как TCP/IP, определяют язык, на котором компьютер общается с другими компьютерами сети.

При изменении состояния подключения по локальной сети внешний вид значка в папке «Сетевые подключения» меняется; кроме того, в области уведомлений может появиться еще один значок. Если компьютер не обнаруживает сетевой адаптер, значок подключения по локальной сети в папке «Сетевые подключения» не отображается. В следующей таблице описаны различные значки подключений по локальной сети.

Значок | Описание | Местонахождение
Активное подключение по локальной сети | Подключение по локальной сети активно | Папка «Сетевые подключения»
Подключение по локальной сети, физически отключенное от среды передачи (значок папки) | Среда передачи отключена | Папка «Сетевые подключения»
Подключение по локальной сети, физически отключенное от среды передачи (значок панели задач) | Среда передачи отключена | Область уведомлений
Подключение по локальной сети, отключенное драйвером | Драйвер отключен | Папка «Сетевые подключения»

См. также


Создание подключения по локальной сети

Рисунок Microsoft Windows

Чтобы создать подключение по локальной сети

  • Если на компьютере установлен сетевой адаптер и создана домашняя или небольшая офисная сеть, значит, компьютер подключен к локальной сети. Компьютер под управлением XOX также подключен к локальной сети, если он является частью корпоративной сети. При запуске компьютера операционная система обнаруживает сетевой адаптер и автоматически начинает устанавливать подключение по локальной сети. В отличие от остальных типов подключений, подключение по локальной сети создается автоматически; для его запуска не нужно специально выбирать этот вид подключения.

Примечания

  • Подключение по локальной сети создается автоматически для каждого обнаруженного сетевого адаптера.
  • Если на компьютере установлено несколько сетевых адаптеров, во избежание путаницы сразу же переименуйте все подключения по локальным сетям, присвоив каждому из них имя, отражающее тип соответствующей сети.
  • Если на компьютере установлен только один сетевой адаптер, но с его помощью требуется подключаться к различным сетям (например, при командировках в региональные представительства компании), нужно будет при каждой смене сети включать и отключать соответствующие сетевые компоненты подключения по локальной сети.
  • Если установлено несколько сетевых адаптеров, нужно будет добавить или включить сетевые клиенты, службы и протоколы, которые необходимы для каждого подключения по локальной сети. При этом каждый клиент, служба или протокол будет добавляться или включаться и для всех остальных сетевых подключений и подключений удаленного доступа.

См. также


Дополнительные сетевые компоненты

В конфигурацию можно добавлять или удалять из нее дополнительные сетевые компоненты. Такие компоненты предназначаются для поддержки тех или иных видов сетевых операций и не устанавливаются по умолчанию. Примерами дополнительных компонентов являются cлужба RLS (Route Listening Service), «Простые службы TCP/IP», «Службы SNMP» и «Службы печати для UNIX».

Сведения об установке дополнительных сетевых компонентов см. в разделе Чтобы добавить дополнительные сетевые компоненты.


Добавление дополнительных сетевых компонентов

Рисунок Microsoft Windows

Чтобы добавить дополнительные сетевые компоненты

  1. Откройте компонент Сетевые подключения.
  2. В меню Дополнительно выберите команду Дополнительные сетевые компоненты.
  3. Выполните одно из следующих действий.
    • Чтобы установить все дополнительные сетевые компоненты, установите флажки Средства управления и наблюдения, Сетевые службы и Другие службы доступа к файлам и принтерам в сети и нажмите кнопку Далее.
    • Чтобы установить лишь некоторые из дополнительных сетевых компонентов, установите соответствующий флажок и нажмите кнопку Состав.

      В списке компонент - состав установите флажки необходимых компонентов и нажмите кнопку ОК.

Примечания

  • XOX
  • Примерами дополнительных сетевых компонентов являются протокол SNMP (Simple Network Management Protocol), простые службы TCP/IP и службы печати для Unix.

См. также


Подключения удаленного доступа

Подключение удаленного доступа позволяет установить связь с сетью или Интернетом с помощью устройства, передающего данные по телефонной сети. Таким устройством может быть модем, использующий обычную телефонную линию, плата ISDN-адаптера, подключаемая к высокоскоростной линии ISDN, или сеть X.25.

Простым пользователям обычно доступно одно или два подключения удаленного доступа — для выхода в Интернет и для подключения к сети своей организации. В более сложных конфигурациях серверной среды может использоваться больше подключений удаленного доступа — они необходимы для расширенной маршрутизации.

Можно создать несколько подключений удаленного доступа, скопировав их в папке «Сетевые подключения». Затем можно переименовать подключения и изменить их параметры. Этот способ позволяет быстро устанавливать подключения для работы сразу с несколькими модемами, профилями набора номера и т. д.

См. также


Учетные данные для удаленного доступа

Для успешного подключения к Интернету с помощью средств удаленного доступа нужно иметь учетные данные, к которым относятся имя пользователя и пароль. При установке подключения удаленного доступа пользователю, в зависимости от его профиля, предлагается на выбор два или три варианта сохранения его учетных данных. В профиле пользователя указан вид его учетной записи — с полномочиями администратора или с полномочиями обычного пользователя. Если у пользователя имеются учетные записи обоих типов, ему будут доступны полномочия той учетной записи, с которой он вошел в систему.

Если вход в систему осуществлен по учетной записи с полномочиями пользователя, то разрешается устанавливать только индивидуальные пользовательские подключения удаленного доступа. Индивидуальные подключения будут действовать только для данного пользователя и будут недоступны для остальных пользователей. В случае индивидуальных подключений у пользователя есть два варианта — сохранить свои учетные данные только для личного пользования или не сохранять учетные данные. Если выбрать сохранение учетных данных для личного пользования, они будут автоматически предоставляться при установке подключения удаленного доступа, но только при условии, что при входе в систему использовалась та же учетная запись, что и при сохранении учетных данных. Если отказаться от сохранения учетных данных, то при установке подключения каждый раз будет открываться диалоговое окно, в котором нужно будет вводить учетные данные.

Если вход в систему осуществлен по учетной записи с полномочиями администратора, то разрешается устанавливать либо глобальные, либо индивидуальные пользовательские подключения удаленного доступа. Глобальные подключения видны всем пользователям, работающим на главном компьютере общего доступа в Интернет, однако успех попытки установить подключение зависит от того, как были сохранены учетные данные. В случае глобальных подключений можно сохранить свои учетные данные для всеобщего пользования, сохранить их только для личного пользования или не сохранять все. Если учетные данные сохранены для всеобщего пользования, они будут автоматически предоставляться любому пользователю при попытке подключиться к Интернету с помощью значка подключения удаленного доступа или путем вызова по требованию. Если выбрать сохранение учетных данных для личного пользования, они будут автоматически предоставляться при установке подключения удаленного доступа, но только для данного пользователя. Остальные пользователи увидят диалоговое окно, предлагающее им задать имя пользователя и пароль, однако если эти учетные данные будут введены неправильно, подключение к Интернету установить не удастся. Если отказаться от сохранения учетных данных, то при установке подключения к Интернету будет открываться диалоговое окно, в котором пользователь должен будет ввести учетные данные.

Ниже дана сводка возможностей пользователя, входящего в систему с учетной записью пользователя с ограниченными правами, и сводка возможностей пользователя, входящего с учетной записью администратора.

Профиль входа в систему с учетной записью пользователя

Тип подключения Вариант сохранения учетных данных Доступ к локальному компьютеру
Только индивидуальные пользовательские подключения
  • Для личного пользования
  • Не сохранять
 Только данный пользователь может автоматически выполнить индивидуальное подключение к Интернету. Так как доступ к вкладке Дополнительно для включения ICS или настройки брандмауэра Windows может получить только администратор, то, если требуется включить ICS или брандмауэр Windows, при создании подключения удаленного доступа необходимо войти в систему с учетной записью администратора. Если требуется включить ICS или брандмауэр Windows для подключения удаленного доступа, которое было создано пользователями с учетными записями с ограниченными правами, необходимо повысить учетную запись пользователя с ограниченными правами до учетной записи администратора.
Клиентский доступ в Интернет через индивидуальные пользовательские подключения на основе ICS
Попытка создания клиентом ICS индивидуального пользовательского подключения к Интернету с использованием значка удаленного доступа или вызова по требованию будет успешна только в следующих случаях:
  • пользователь вошел в систему на главном компьютере ICS и предварительно сохранил свои учетные данные;
  • учетные данные не были сохранены, но на главном компьютере ICS работает другой пользователь, который может задать учетные данные пользователя клиентского компьютера в соответствующем диалоговом окне.

Профиль входа в систему с учетной записью администратора

Тип подключения Вариант сохранения учетных данных Доступ к локальному компьютеру
Индивидуальные пользовательские подключения
  • Для личного пользования
  • Не сохранять
 Только данный пользователь может автоматически выполнить индивидуальное подключение к Интернету. Так как доступ к вкладке Дополнительно для включения ICS или настройки брандмауэра Windows может получить только администратор, то, если требуется включить ICS или брандмауэр Windows, при создании подключения удаленного доступа необходимо войти в систему с учетной записью администратора. Если требуется включить ICS или брандмауэр Windows для подключения удаленного доступа, которое было создано пользователями с учетными записями с ограниченными правами, необходимо повысить учетную запись пользователя с ограниченными правами до учетной записи администратора.
Глобальные подключения
  • Все пользователи
  • Для личного пользования
  • Не сохранять
 Подключение к Интернету видно всем пользователям. Если учетные данные сохранены для всеобщего пользования, к Интернету сможет подключиться любой пользователь, вошедший в систему на этом компьютере. Если учетные данные сохранены только для личного пользования, подключение будет осуществлено автоматически, если войти в систему с учетной записью администратора или пользователя, сохранившего учетные данные. Если учетные данные не были сохранены, при попытке подключения к Интернету нужно будет ввести учетные данные. Администратор может использовать вкладку Дополнительные параметры для включения службы ICS.
Клиентский доступ в Интернет через глобальные подключения на основе ICS
Попытка создания клиентом ICS глобального общего подключения к Интернету с использованием значка удаленного доступа или вызова по требованию будет успешна только в следующих случаях:
  • учетные данные были сохранены для всеобщего пользования (это приведет к успеху независимо от того, вошел пользователь на сервер ICS или нет);
  • пользователь вошел в систему на главном компьютере ICS и предварительно сохранил свои учетные данные только для личного пользования;
  • учетные данные не были сохранены, но на главный компьютер ICS вошел другой пользователь. Ему будет предложено ввести в специальном диалоговом окне учетные данные, необходимые для успешного подключения клиентского компьютера к поставщику услуг Интернета.

Для автоматического инициирования подключений удаленного доступа к поставщику услуг Интернета необходимо включить поддержку вызова по требованию. Дополнительные сведения см. в разделе Чтобы включить вызов по требованию.

Чтобы можно было пользоваться общим подключением к Интернету, необходимо включить службу ICS на компьютерах сети. Дополнительные сведения см. в разделе Общий доступ к подключению Интернета.

Для управления общим подключением к Интернету необходимо включить функцию обнаружения и контроля ICS для клиентов сети. Дополнительные сведения см. в разделе Использование общего доступа к подключению к Интернету с функцией обнаружения и управления устройствами шлюза Интернета.

Примечания

  • Подключения удаленного доступа, созданные членами рабочей группы в XOX или XOX, будут доступны для всех пользователей.


Использование телефонных линий и модемов

Подключения удаленного доступа, как правило, устанавливаются с использованием обычной аналоговой телефонной линии и модема. Такие телефонные линии широко распространены во всем мире и удовлетворяют большинству требований, предъявляемых мобильными пользователями. Обычные аналоговые телефонные линии также часто обозначают терминами PSTN (Public Switched Telephone Network — коммутируемая телефонная сеть общего доступа) или POTS (Plain-Old Telephone Service — обычная старая телефонная служба).

С операционной системой XOX совместимо множество модемов. Практически все модемы, отвечающие отраслевым стандартам, должны успешно взаимодействовать с системой. Несовместимый модем нередко оказывается причиной проблем, с трудом поддающихся выявлению. XOX

Модемы распознаются системой автоматически. Это особенно удобно, если пользователь не уверен в том, что модем (например, внутренний) установлен. Для подключений удаленного доступа можно использовать общие модемные пулы. Большинство модемов поддерживают сжатие данных и контроль ошибок. Однако программное сжатие данных часто дает более эффективные результаты, чем аппаратное.

См. также


Создание подключения удаленного доступа к рабочему месту по телефонной линии

Рисунок Microsoft Windows

Чтобы создать подключение удаленного доступа к рабочему месту по телефонной линии

  1. Откройте компонент Сетевые подключения.
  2. В группе Сетевые задачи щелкните ссылку Создать новое подключение и затем нажмите кнопку Далее.
  3. Выберите вариант Подключить к сети на рабочем месте и нажмите кнопку Далее.
  4. Установите переключатель в положение Подключение удаленного доступа, нажмите кнопку Далее и следуйте указаниям мастера нового подключения.

Примечание

  • XOX

См. также


Настройка модема для подключения удаленного доступа

Рисунок Microsoft Windows

Чтобы настроить модем для подключения удаленного доступа

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение удаленного доступа, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Модемы в списке Подключаться через выберите модем, который требуется настроить, и нажмите кнопку Настроить.
  4. В группе Параметры оборудования установите флажки для тех параметров, которые нужно включить.
  5. Чтобы включить динамик модема, установите флажок Включить динамик модема.

Примечания

  • XOX

  • Для обеспечения полной совместимости необходимо использовать модем того же типа, что и на сервере удаленного доступа, выбрать ту же начальную скорость связи и включить те же возможности. Если не удается использовать модем той же модели, выберите по крайней мере модем того же стандарта ITU-T, что и модем сервера.

  • Если выбрать функцию, не поддерживаемую данным модемом, это никак не отразится на его производительности.

  • Компонент «Сетевые подключения» автоматически настраивает подключения в соответствии с используемыми устройствами. Например, в офисе переносной компьютер можно использовать со стыковочным узлом, настроив подключение на работу с установленным в этом узле модемом. Если пользователь работает на таком компьютере в пути и модем стыковочного узла недоступен, подключение автоматически настраивается на использование модема PCMCIA, установленного на компьютере. Когда пользователь вернется в офис и снова подключит переносной компьютер к стыковочному узлу, компонент «Сетевые подключения» обнаружит, что модем стыковочного узла вновь стал доступен, и автоматически настроит подключение на использование этого модема.

См. также


Запуск диспетчера автоподключений удаленного доступа

Рисунок Microsoft Windows

Чтобы запустить диспетчер автоподключений удаленного доступа

  1. Откройте окно Управление компьютером.
  2. В дереве консоли щелкните узел Службы.

    Где?

    • Управление компьютером
    • Службы и приложения
    • Службы
  3. В правой панели щелкните правой кнопкой мыши службу Диспетчер авто-подключений удаленного доступа и выберите команду Запустить.

    4. В столбце Состояние появится пометка Работает.

Примечания

  • XOX
  • Диспетчер автоподключений удаленного доступа по умолчанию включен на компьютерах с XOX, которые не являются членами домена, а на компьютерах с XOX.

См. также


Настройка параметров удаленного доступа

Существует много возможностей, позволяющих упростить процесс подключения удаленного доступа. Для получения инструкций по настройке конкретной возможности щелкните соответствующую ссылку в следующей таблице.

Возможность | Функция
Настройка ответного вызова | Уменьшает расходы на оплату телефонной связи, предписывая серверу удаленного доступа выполнить ответный вызов клиента после того, как тот подключится к серверу
Настройка модификаторов телефонного номера | Позволяет вставить символы, управляющие набором номера (задающие паузу, приостанавливающие набор номера до ввода данных и т. п.)
Настройка параметров повторного набора номера | Задает число попыток повторного автоматического набора номера для подключения к серверу удаленного доступа. Эта возможность также позволяет автоматически восстанавливать подключение после принудительного отключения простаивающей линии
Назначение нескольких телефонных номеров одному подключению | Назначает подключению удаленного доступа несколько телефонных номеров. В этом может возникнуть необходимость, если имеется пул телефонных номеров для подключения
Включение режима набора номера через оператора или вручную | Позволяет пользователю участвовать в процессе установки удаленного подключения. Это бывает необходимо, например, при подключении через ручной коммутатор.

Примечание

  • С помощью компонента панели управления «Телефон и модем» можно настраивать параметры удаленного доступа, относящиеся ко всем подключениям, которые устанавливаются из данного места (например, набор цифры 9 для выхода на внешнюю линию, отключение режима оповещения, использование импульсного набора номера вместо тонового и т. д.).

См. также


Ответный вызов

Функция ответного вызова предписывает серверу удаленного доступа отключиться после получения вызова клиента и выполнить ответный вызов. Такая возможность позволяет снизить расходы и обеспечивает дополнительную защиту сети. Поскольку сразу после вызова клиента соединение разрывается и ответный вызов выполняет сервер, расходы пользователя на оплату услуг телефонной связи уменьшаются. Требование ответного вызова укрепляет безопасность сети, так как доступ к серверу становится возможным только для пользователей, находящихся в определенном месте. Разрыв связи и незамедлительный ответный вызов по заранее определенному номеру позволяет предотвратить большинство попыток несанкционированного доступа с использованием чужих учетных данных.

Если администратор включил функцию ответного вызова как обязательное средство, то после получения вызова от клиента сервером удаленного доступа происходит следующее.

  1. Сервер проверяет правильность имени пользователя и пароля.
  2. Если они правильны, сервер отключается и выполняет ответный вызов.

Если ответный вызов разрешен администратором и настроен на клиентском компьютере с помощью команды меню Параметры удаленного доступа, то после получения вызова сервером удаленного доступа происходит следующее.

  1. Сервер проверяет правильность имени пользователя и пароля.
  2. Если они правильны, на локальном компьютере открывается диалоговое окно Ответный вызов.
  3. Пользователь вводит в этом окне номер для ответного вызова и ожидает, пока сервер отключится и выполнит ответный вызов.

    Если нужно отменить ответный вызов и сохранить подключение к серверу, нажмите клавишу ESC.

Дополнительные сведения о настройке параметров ответного вызова см. в разделе Чтобы настроить ответный вызов.

Примечания

  • Полномочия пользователей в отношении ответного вызова определяются системным администратором. Администратор может запретить использование ответного вызова, разрешить ответный вызов с параметрами, задаваемыми пользователем, или потребовать обязательного выполнения ответного вызова по заданному номеру. Чтобы получить сведения о доступных возможностях ответного вызова, обратитесь к системному администратору.
  • Если компьютер настроен на прием входящих подключений, можно включить на нем принудительное использование ответного вызова. Дополнительные сведения см. в разделе Чтобы настроить ответный вызов для входящих подключений.


Настройка ответного вызова

Рисунок Microsoft Windows

Чтобы настроить ответный вызов

  1. Откройте компонент Сетевые подключения.
  2. В меню Дополнительно выберите команду Параметры удаленного доступа.
  3. На вкладке Ответный вызов выполните одно из следующих действий.
    • Если ответный вызов выполнять не требуется, установите переключатель в положение Ответный вызов не выполняется.
    • Если решение о необходимости ответного вызова требуется принимать в момент подключения, установите переключатель в положение Иногда. Выдавать запрос при подключении к серверу.
    • Если ответный вызов нужно выполнять всегда, установите переключатель в положение Всегда выполнять ответный вызов по указанным номерам и выберите модем или устройство, куда должен поступать ответный вызов.
      • Если столбец Номер телефона для выбранного устройства пуст, нажмите кнопку Изменить и введите номер.
      • Чтобы удалить модем или устройство из списка устройств, принимающих ответные вызовы, выберите этот модем или устройство и нажмите кнопку Удалить.

Примечания

  • XOX
  • Привилегии ответного вызова определяются системным администратором и имеют преимущество перед параметрами ответного вызова, настраиваемыми в этом диалоговом окне. Задавая свойства сервера, администратор может запретить использование ответных вызовов, позволить пользователям настраивать параметры ответного вызова или потребовать выполнения ответного вызова по определенному номеру. Сведения о действующих параметрах ответного вызова можно получить у системного администратора.
  • Ответный вызов можно использовать только в том случае, если включены расширения протокола LCP (Link Control Protocol).

См. также


Настройка вызова с использованием нескольких устройств

Компонент «Сетевые подключения» позволяет устанавливать многоканальные подключения по протоколу PPP с использованием нескольких линий ISDN, X.25 или модемных линий. Эта возможность позволяет объединять несколько физических каналов в одну логическую связку с целью расширения полосы пропускания подключения. Для выполнения вызова с использованием нескольких устройств необходимо включить функцию многоканального подключения как на локальном компьютере, так и на сервере удаленного доступа.

Компонент «Сетевые подключения» может динамически управлять использованием линий для многоканального подключения. Линии выделяются только тогда, когда в них возникает необходимость, что позволяет избежать чрезмерного расширения полосы пропускания и добиться более высокой эффективности. Условия, при которых подключаются дополнительные линии и отключаются простаивающие, задаются в окне «Сетевые подключения».

Функция многоканального подключения в XOX и XOX включена автоматически.

Примечание

  • Если многоканальное подключение выполняется для доступа к серверу, требующему ответного вызова, то ответный вызов может быть направлен только на одно из устройств, использовавшихся при подключении. Это объясняется тем, что в учетной записи пользователя может храниться только один номер. Поэтому подключиться сможет только одно устройство и возможность многоканального подключения будет недоступна.
    • Этой проблемы можно избежать в следующих случаях:
    • если запись телефонной книги для многоканального подключения предусматривает стандартную конфигурацию модема, а сервер удаленного доступа, к которому выполняется подключение, использует несколько линий для одного номера;
    • если запись телефонной книги для многоканального подключения задает подключение по линии ISDN с двумя каналами, имеющими один и тот же телефонный номер.


Настройка модификаторов телефонного номера

Рисунок Microsoft Windows

Чтобы настроить модификаторы телефонного номера

XOX

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение удаленного доступа, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменение настроек отдельного подключения.
  3. На вкладке Общие измените номер телефона, используя один или нескольких символов, приведенных в следующей таблице.
Символ | Функция
, (запятая) | Пауза перед продолжением набора номера (для большинства модемов — две секунды)
P | Переключение из тонового режима набора в импульсный
T | Переключение из импульсного режима набора в тоновый
$ | Ожидание запроса на ввод номера телефонной карточки

Например, при звонке из номера отеля для выхода на внешнюю линию иногда требуется сначала набрать цифру 9. В таком случае необходимо задать номер примерно следующего вида:

9,555-0100

Запятая после цифры 9 обеспечивает паузу перед набором основного номера, достаточно длинную для выхода на внешнюю линию.

Примечания

  • XOX
  • Установив флажок Использовать правила набора номера и нажав кнопку Правила, можно настроить параметры места вызова, для которого автоматически будут применяться определенные правила набора номера. Например, если подключаться часто приходится из дома и потому требуется отменить режим оповещения, создайте специальное место для вызова из дома, при котором перед установкой соединения автоматически набирался бы код отключения режима оповещения.
  • Если перед номером набираются какие-то неизвестные цифры, убедитесь, что флажок Использовать правила набора номера снят. Если он установлен, то, возможно, для данного места вызова действует правило набора номера, которое на самом деле не требуется. Например, может быть выбрано место вызова, в котором всегда набирается цифра 8 для междугородных звонков.

См. также


Параметры повторного набора номера

Параметры повторного набора номера позволяют задать число попыток повторного набора, автоматически предпринимаемых в случае неудачи при подключении к серверу удаленного доступа. Повторный набор номера также выполняется при непредвиденном разрыве связи.

По умолчанию подключение удаленного доступа настраивается на троекратный повторный набор номера (с интервалом в одну минуту) в случае, если попытки установления связи с сервером удаленного доступа оканчиваются неудачей. Также по умолчанию считается, что подключение не будет пытаться восстановить связь в случае ее непредвиденного разрыва.

См. также


Настройка параметров повторного набора номера

Рисунок Microsoft Windows

Чтобы настроить параметры повторного набора номера

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение удаленного доступа, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Параметры в поле Число повторений набора номера укажите, сколько раз следует повторно набрать номер на подключении удаленного доступа в случае, если первая попытка оказывается неудачной.
  4. В поле Интервал между повторениями с помощью кнопок со стрелками установите интервал ожидания между окончанием одной попытки и началом следующей.
  5. В поле Время простоя до разъединения с помощью кнопок со стрелками установите допустимый интервал времени простоя, по истечении которого клиент должен будет разрывать связь.
  6. Если при разрыве связи требуется автоматически набирать номер повторно, установите флажок Перезвонить при разрыве связи.

Примечания

  • XOX
  • Пауза, задаваемая параметром Интервал между повторениями, позволяет устройству заново выполнить инициализацию перед повторным набором номера. По умолчанию этот интервал равен одной минуте. Если этого времени недостаточно, увеличьте значение данного параметра. Можно попробовать использовать и более короткий интервал, но если пауза будет слишком мала, устройству может не хватить времени для повторной инициализации.
  • Помните, что сервер удаленного доступа также имеет таймер разъединения. Если для параметра Время простоя до разъединения задано большое значение, нельзя гарантировать, что подключение не будет разорвано до истечения этого срока. Сервер может отключиться до окончания указанного периода простоя.
  • Если используется обозреватель Internet Explorer, то его параметры для подключений удаленного доступа могут противоречить описанным здесь параметрам повторного набора номера.

См. также


Назначение нескольких телефонных номеров одному подключению удаленного доступа

Рисунок Microsoft Windows

Чтобы назначить несколько телефонных номеров одному подключению удаленного доступа

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение, которому нужно назначить несколько телефонных номеров, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Общие нажмите кнопку Другие и затем выполните одно из следующих действий.
    • Если требуется, чтобы в случае неудачной попытки подключения по первому номеру из списка использовался другой номер, установите флажок При сбое пытаться соединиться по следующему номеру.
    • Чтобы перенести первый номер, по которому удалось установить подключение, в начало списка Номера телефонов и использовать его первым при следующей попытке подключения, установите флажок Переносить успешно набранный номер в начало списка.
    • Чтобы добавить в список новый телефонный номер, нажмите кнопку Добавить и введите новый номер в поле Номер телефона.
    • Чтобы изменить порядок телефонных номеров в списке Номера телефонов, выберите соответствующий номер и с помощью кнопок со стрелками переместите его в нужную позицию.
    • Чтобы удалить номер телефона из списка Номера телефонов, выделите этот номер и нажмите кнопку Удалить.
  4. Если нужно, чтобы подключение использовало код города и правила набора номера, установите на вкладке Общие флажок Использовать правила набора номера.
  5. Закончив ввод сведений о новом телефонном номере, нажмите кнопку ОК.

Примечания

  • XOX
  • Если для подключения задано несколько номеров телефонов, то при установлении подключения пользователь получает возможность выбрать нужный номер из списка.


Включение режима набора номера через оператора или вручную

Рисунок Microsoft Windows

Чтобы включить режим набора номера через оператора или вручную

  1. Откройте компонент Сетевые подключения.
  2. В меню Дополнительно выберите команду Набор номера через оператора.
  3. Дважды щелкните подключение, которое нужно использовать.
  4. Поднимите трубку и наберите номер или попросите это сделать оператора.

    5. Для справки в диалоговом окне выводится номер, назначенный данному подключению.

  5. Сразу после окончания набора номера нажмите кнопку Вызов.
  6. Повесьте трубку только после того, как модем примет управление линией; обычно об этом свидетельствует щелчок, после которого наступает тишина.

    7. Трубку можно уже класть, когда служба сетевых подключений начинает проверять имя пользователя и пароль. Об этом напоминает соответствующее сообщение в строке состояния.

Примечания

  • XOX
  • При включении режима вызова через оператора рядом с командой Набор номера через оператора в меню Дополнительно появится галочка.


Автоматизация сетевого подключения

Средство автонабора номера позволяет автоматизировать процесс установки сетевого подключения или подключения удаленного доступа. Когда данная возможность включена, сетевые адреса сопоставляются с конечными пунктами удаленных подключений, что позволяет автоматически устанавливать подключение при обращении к удаленному ресурсу.

Процесс подключения для любого клиента Microsoft можно также автоматизировать с помощью простого пакетного файла и команды rasdial, либо с помощью специального приложения Windows NT или Windows 2000, которое поддерживает удаленный доступ.

См. также


Автоматический набор номера

Средство автоматического набора номера сопоставляет сетевые адреса с удаленными ресурсами, что позволяет автоматически устанавливать удаленные подключения при обращении к этим ресурсам из приложения или из командной строки. Сетевой адрес может быть именем узла Интернета, IP-адресом или NetBIOS-именем сервера. Автонабор выполняется на подключении к Интернету, используемом по умолчанию, если только не существует другого подключения к Интернету, настроенного на автонабор номера.

В следующем примере описано, как работает функция автонабора номера.

  1. Пользователь, не имеющий в данный момент подключения к поставщику услуг Интернета, щелкает адрес Интернета, вставленный в документ текстового редактора.
  2. При наличии подключения к Интернету, помеченного как используемое по умолчанию, на нем выполняется автонабор номера, и пользователь получает доступ к этому адресу Интернета.
  3. Если подключение по умолчанию не определено, пользователю предлагается выбрать подключение для связи с поставщиком услуг Интернета. На выбранном подключении набирается номер, и пользователь получает доступ к адресу Интернета.
  4. Когда пользователь в следующий раз щелкнет адрес Интернета в документе текстового редактора, не имея подключения к поставщику услуг Интернета, повторится аналогичный процесс. Если на шаге 3 было выбрано конкретное подключение, будет установлена связь по этому подключению. В противном случае используется подключение, устанавливаемое по умолчанию.

Средство автонабора номера сопоставляет адреса ресурсам, необходимым для первоначального подключения, но не выполняет сопоставление после того, как подключение установлено.

При попытке автоматического набора номера возможны два варианта.

  • Если подключение к сети отсутствует, функция автонабора будет пытаться установить его при каждом обращении приложения по какому-либо удаленному адресу.

  • Если компьютер подключен к сети, функция автонабора номера будет пытаться установить подключение только для тех адресов, которые ей уже известны. Если имя сервера или узла Интернета введено неправильно, попытка автоматического набора номера предприниматься не будет.

Дополнительные сведения см. в разделе Чтобы настроить автонабор номера.


Настройка автонабора номера

Рисунок Microsoft Windows

Чтобы настроить автонабор номера

  1. Откройте компонент Сетевые подключения.
  2. В меню Дополнительно выберите команду Параметры удаленного доступа.
  3. На вкладке Автонабор номера установите флажок места подключения, для которого нужно включить автонабор номера, и нажмите кнопку ОК.

Примечания

  • XOX
  • По умолчанию в XOX автонабор включен. Для поддержки этой возможности по умолчанию запускается служба автоподключений удаленного доступа. XOX
  • Средство автонабора номера сопоставляет адреса с ресурсами, необходимым для первоначального подключения, но не выполняет сопоставление после того, как подключение установлено.

См. также


Команда rasdial

Процесс подключения любого клиента Microsoft можно автоматизировать с помощью простого пакетного файла и команды rasdial. Команда rasdial выполняет запуск сетевого подключения, используя указанные параметры.

Синтаксис

rasdial имя_подключения [имя_пользователя [пароль | *]] [/domain:домен] [/phone:номер_телефона] [/callback:номер_для_ответного_вызова] [/phonebook:путь_к_телефонной_книге] [/prefixsuffix]

Чтобы отключить установленное сетевое подключение, выполните команду rasdial со следующими параметрами:

rasdial [имя_подключения] /disconnect

Параметры

Нет
Команда rasdial, выполненная без параметров, показывает состояние текущих подключений.
имя_подключения
Запись текущего pbk-файла, расположенного в папке системный_корневой_каталог\System32\Ras. Если имя подключения содержит пробелы или специальные символы, заключите его в кавычки (").

По умолчанию используется файл Rasphone.pbk, если не выбран параметр Личная телефоная книга. Если выбрана личная телефонная книга, используется файл имя_пользователя.pbk. Имя подключения показано в заголовке окна программы Rasphone, если выбран параметр Личная телефонная книга/p. В случае конфликта имен к ним добавляются цифры.

имя_пользователя [пароль | *]
Имя пользователя и пароль для подключения. Если используется символ звездочки, пользователю выдается запрос на ввод пароля, но вводимые символы не отображаются.
/domain:домен
Домен, в котором находится учетная запись пользователя.

Если этот параметр отсутствует, используется последнее значение поля Домен диалогового окна Подключение.

/phone:номер_телефона
Номер телефона, который заменяет номер для данного подключения, указанный в телефонной книге Rasphone.pbk.
/callback:номер_для_ответного вызова
Номер телефона, который заменяет номер ответного вызова для данного подключения, указанный в телефонной книге Rasphone.pbk.
/disconnect
Разрывает указанное подключение.
/phonebook:путь_к_телефонной_книге
Путь к файлу телефонной книги. По умолчанию используется путь системный_корневой_каталог\System32\Ras\имя_пользователя.pbk. Можно указать полный путь к файлу.
/prefixsuffix
Применяет к набираемому номеру телефона параметры текущего места вызова TAPI. Эти параметры задаются с помощью компонента панели управления «Телефония». По умолчанию данный режим отключен.

Примеры использования команды rasdial

Чтобы подключиться с использованием записи «OFFICE» телефонной книги Rasphone.pbk, выполните команду:

rasdial office

Чтобы подключиться с использованием записи «OFFICE 2» телефонной книги Rasphone.pbk, указав номер для ответного вызова, выполните команду:

rasdial "office 2" /callback:555-0100

Чтобы разорвать подключение «EAST OFFICE», выполните команду:

rasdial "EAST OFFICE" /d

Примечание

Команда rasdial не поддерживает следующие функции программы Rasphone.exe:

  • подключения, требующие ввода данных в режиме терминала в процессе набора номера;
  • набор номера через оператора или вручную.


Использование команды rasdial

Для установки сетевого подключения удаленного доступа можно создать простой пакетный файл, содержащий команду rasdial. Кроме того, с помощью команды rasdial можно подключаться к сети и отключаться от нее из командной строки. В отличие от функции автонабора номера, команда rasdial не выполняет автоматическую проверку состояния сетевого подключения перед набором номера и действует независимо от диспетчера автоподключений удаленного доступа.

Например, предположим, что нужно организовать автоматическую установку подключения удаленного доступа во время периодов пониженной нагрузки в сети для передачи больших файлов данных. Можно создать пакетный файл или группу пакетных файлов для автоматизации этого процесса. Для установки и завершения подключения удаленного доступа воспользуйтесь командой rasdial. Вместе с ней можно задать ряд дополнительных параметров, например, определить номер набираемого телефона и указать, следует ли использовать ответный вызов.

Дополнительные сведения об использовании команды rasdial см. в разделе Команда rasdial. Дополнительные сведения о пакетных файлах см. в разделе Пакетные файлы.


Общие сведения о подключениях к Интернету

Компонент «Сетевые подключения» позволяет легко подключаться к Интернету. Например, для создания подключения удаленного доступа к Интернету используются следующие средства:

  • протокол TCP/IP, включенный для данного сетевого подключения;
  • модем или другое устройство для связи с поставщиком услуг Интернета;
  • учетная запись от поставщика услуг Интернета.

Подключение к Интернету устанавливает связь с поставщиком услуг Интернета и выполняет вход в систему. Последовательность действий при входе в систему зависит от требований поставщика услуг, к которому выполняется подключение. PPP-подключения часто устанавливаются полностью автоматически. SLIP-подключения могут требовать входа в систему с использованием окна терминала, что иногда не позволяет автоматизировать процесс входа с помощью сценариев в файле Switch.inf.

Дополнительные сведения см. в следующих разделах:

  • Общие сведения о протоколе TCP/IP
  • Способы подключения к поставщикам услуг Интернета
  • Поставщики услуг Интернета
  • Использование протокола PPP для подключения к Интернету
  • Чтобы создать подключение к Интернету

Примечание

  • Перед созданием подключения к Интернету выясните у своего поставщика услуг Интернета необходимые параметры этого подключения. Для подключения к поставщику могут потребоваться следующие параметры:
    • учетная запись, выданная поставщиком услуг Интернета, со сведениями о настройке;
    • телефонный номер поставщика услуг Интернета;
    • назначенный IP-адрес;
    • IP-адрес основного шлюза;
    • адреса DNS и имена доменов.


Поставщики услуг Интернета

Поставщик услуг Интернета — это организация, предоставляющая доступ в Интернет. Такие организации существуют в большом количестве по всему миру. Для подключения к Интернету нужно набрать определенный телефонный номер и войти в удаленную систему. Установив подключение, пользователь получает доступ к Интернету и ко всем другим службам, предлагаемым поставщиком, в частности, к электронной почте. Обычно эти услуги платные.

Получить учетную запись Интернета у поставщика услуг Интернета можно несколькими способами. К числу таких способов относятся следующие.

  • Найдите в телефонном справочнике список поставщиков услуг Интернета.
  • На компьютере уже могут быть установлены программы для доступа к известным поставщикам услуг Интернета, таким как MSN.
  • В комплект компьютера может входить один или несколько компакт-дисков с информацией о поставщиках услуг Интернета. Чтобы подключиться к одному из них, вставьте компакт-диск в дисковод и следуйте указаниям, появляющимся на экране.
  • Для поиска поставщика используйте справочную службу XOX.

Если учетная запись Интернета установлена на другом компьютере, то с него можно подключиться к Интернету с теми же параметрами, используя один из следующих методов.

  • Позвоните своему поставщику услуг Интернета и выясните, какие параметры необходимы для подключения к нему.
  • Посетите веб-страницу своего поставщика услуг Интернета и получите необходимые сведения о параметрах.
  • Запустите мастер переноса файлов и параметров. Следуя его указаниям, перенесите нужные файлы со старого компьютера на новый.

Примечание

  • XOX

См. также


Способы подключения к поставщикам услуг Интернета

Подключение к поставщику услуг Интернета можно установить через модем и телефонную линию, через адаптер ISDN и линию ISDN, через кабельный модем, через линию DSL (Digital Subscriber Line) или через сеть X.25.

При использовании модема желательно добиться наивысшей скорости соединения, чтобы быстрее загружать данные из Интернета. Рекомендуется использовать модем со скоростью 28,8 Кбит/с или выше. Дополнительные сведения о модемах см. в разделе Общие сведения о модемах.

Подключение к Интернету устанавливает связь с поставщиком услуг Интернета и выполняет вход в систему. Последовательность действий при входе в систему зависит от требований поставщика услуг Интернета, к которому выполняется подключение.

При подключении по линии DSL или через кабельный модем поставщик услуг Интернета может либо предложить постоянно действующее подключение, либо требовать каждый раз выполнения процедуры входа в сеть. Постоянно действующее подключение означает, что можно будет обойтись без этой процедуры входа при каждой попытке обращения в Интернет. Если же от пользователя линии DSL или кабельного модема требуется выполнять вход в сеть, он должен предъявить имя пользователя и пароль.

Дополнительные сведения см. в следующих разделах:

  • Чтобы создать подключение к Интернету.
  • Общие сведения о протоколе TCP/IP
  • Поставщики услуг Интернета
  • Использование протокола PPP для подключения к Интернету

Примечание

  • Перед созданием подключения к Интернету выясните у своего поставщика услуг Интернета необходимые параметры этого подключения. Для подключения к поставщику услуг Интернета могут потребоваться следующие параметры:
    • назначенный IP-адрес;
    • адреса DNS и имена доменов.


Создание подключения к Интернету

Рисунок Microsoft Windows

Чтобы создать подключение к Интернету

  1. Откройте компонент Сетевые подключения.
  2. В группе Типичные сетевые задачи щелкните ссылку Создать новое подключение и затем нажмите кнопку Далее.
  3. Выберите вариант Подключить к Интернету и нажмите кнопку Далее.
  4. Воспользуйтесь одним из следующих методов.
    • Если уже имеется учетная запись, назначенная поставщиком услуг Интернета, выберите вариант Установить подключение вручную и нажмите кнопку Далее.
    • Если поставщик услуг Интернета предоставил компакт-диск, выберите вариант Использовать компакт-диск поставщика услуг Интернета и нажмите кнопку Далее.
    • Если учетная запись Интернета еще не назначена, выберите вариант Выбрать из списка поставщиков услуг Интернета и нажмите кнопку Далее.
  5. Для получения дальнейших указаний щелкните ссылку на выбранный в предыдущем пункте вариант.

    6. Установить подключение вручную

    • Если подключение к поставщику услуг Интернета производится с помощью обычного модема с быстродействием 28,8 Кбит/с или 56 Кбит/с или модема ISDN, выберите вариант Подключаться, используя удаленный доступ, нажмите кнопку Далее и следуйте указаниям мастера.
    • Если для подключения к ISP с помощью DSL или кабельного модема требуется имя пользователя и пароль, выберите вариант Подключаться, используя высокоскоростное подключение с указанием имени пользователя и пароля, нажмите кнопку Далее и следуйте инструкциям мастера.
    • Если подключение к поставщику услуг Интернета через линию DSL или кабельный модем всегда включено и не требует ввода имени пользователя и пароля, выберите вариант Подключаться, используя всегда включенное высокоскоростное подключение, нажмите кнопку Далее и затем кнопку Готово.

    Использовать компакт-диск поставщика услуг Интернета

    • Нажмите кнопку Далее, а затем кнопку Готово. Вставьте в дисковод компакт-диск, предоставленный поставщиком услуг Интернета, и следуйте дальнейшим указаниям мастера.

    Выбрать поставщика услуг Интернета из списка

    • Чтобы создать учетную запись Интернета с помощью обозревателя MSN Explorer, выберите вариант Подключиться к Интернету через MSN и нажмите кнопку Готово. Следуйте указаниям программы MSN Explorer.
    • Чтобы выбрать поставщика, выберите вариант Выбрать другого поставщика из списка, нажмите кнопку Готово и два раза щелкните вариант Дополнительный список поставщиков услуг Интернета. Следуйте инструкциям мастера.

Примечания

  • XOX
  • Если используемый модем DSL или кабельный модем всегда подключен к Интернету и поставщик услуг Интернета не требует каждый раз вводить имя пользователя и пароль, услуги мастера нового подключения не нужны. Для имеющегося широкополосного подключения не потребуется дополнительная настройка.
  • Перед созданием подключения к Интернету выясните у своего поставщика услуг Интернета необходимые параметры этого подключения. Для подключения к поставщику услуг Интернета могут потребоваться следующие параметры:
    • назначенный IP-адрес;
    • адреса DNS и имена доменов;
    • параметры POP3 для входящей электронной почты;
    • параметры SMTP для исходящей электронной почты.

См. также


Создание широкополосного подключения с помощью протокола PPPoE

Рисунок Microsoft Windows

Чтобы создать широкополосное подключение с помощью протокола PPPoE (Point-to-Point Protocol over Ethernet)

  1. Откройте компонент Сетевые подключения.
  2. В группе Сетевые задачи щелкните ссылку Создать новое подключение и затем нажмите кнопку Далее.
  3. Выберите вариант Подключить к Интернету и нажмите кнопку Далее.
  4. Выберите вариант Установить подключение вручную и нажмите кнопку Далее.
  5. Установите переключатель в положение Подключаться, используя высокоскоростное подключение с указанием имени пользователя и пароля.
  6. Введите данные для поставщика услуг Интернета, следуя указаниям мастера нового подключения.

Примечание

  • XOX

См. также


Общий доступ к подключению Интернета

Служба общего доступа к подключению Интернета (Internet Connection Sharing, ICS) позволяет компьютерам домашней или небольшой офисной сети входить в Интернет, используя только одно общее подключение. Например, предположим, что в сети есть компьютер, который подключается к Интернету с помощью подключения удаленного доступа. Если на этом компьютере включить ICS (он в таком случае будет называться главным компьютером ICS), остальные компьютеры сети смогут получать доступ в Интернет по этому же подключению.

При создании домашней или малой офисной сети для включения общего доступа к подключению к Интернету в XOX рекомендуется использовать мастер настройки сети. Мастер автоматически предоставляет для настройки все параметры сети, необходимые для совместного использования одного подключения к Интернету всеми компьютерами сети.

Примечание

  • XOX

Включив ICS и убедившись, что все компьютеры могут обмениваться данными друг с другом и имеют доступ в Интернет, можно пользоваться программами Internet Explorer, Outlook Express и др. так, как будто они непосредственно подключены к поставщику услуг Интернета. При отправке запроса в Интернет главный компьютер ICS подключается к поставщику услуг Интернета и создает подключение, позволяющее другим компьютерам получить доступ по указанному веб-адресу или загрузить электронную почту. Чтобы протестировать работу сетевых соединений и подключение к Интернету, проверьте, доступны ли на компьютерах файлы других компьютеров сети и все ли они могут подключиться к данному веб-адресу.

Служба общего доступа к подключению Интернета предназначена для использования в сети, в которой один компьютер выделяется для управления сетевыми соединениями между остальными компьютерами и Интернетом. Предполагается, что в домашней или небольшой офисной сети главный компьютер ICS имеет только одно подключение к Интернету. На других компьютерах сети также могут быть установлены модемы для доступа в Интернет, но основным для них является подключение через главный компьютер ICS.

Для нормальной работы в Интернете может потребоваться дополнительная настройка компьютера с общим подключением. Предоставляемые службы должны быть настроены так, чтобы к ним могли обращаться пользователи Интернета. Например, если в домашней или небольшой офисной сети размещается веб-сервер и нужно обеспечить доступ к нему для пользователей Интернета, необходимо настроить на главном компьютере ICS службу веб-сервера. Дополнительные сведения см. в разделе Открытие портов в брандмауэре Windows.

Службу ICS необходимо включить на общедоступном подключении домашней или небольшой офисной сети. Если на компьютере установлено несколько сетевых адаптеров, следует выбрать подключение по локальной сети, которое свяжет этот компьютер с остальными компьютерами домашней или небольшой офисной сети. Такое подключение также называется частным сетевым подключением. Если имеется более одного подключения по локальной сети, то при включении ICS необходимо выполнить одно из следующих действий.

  • Выберите одно подключение для связи с остальными компьютерами сети. Сведения о выборе частного соединения см. в разделе Общедоступные и частные сетевые подключения.
  • Если установлено два или более подключений по локальной сети, и все они обеспечивают связь с остальными компьютерами сети, объедините эти подключения в мост, прежде чем выбирать подключение к домашней или небольшой офисной сети. Если создать мост, содержащий все подключения по локальной сети, этот мост автоматически будет выбран при включении ICS. Если создать мост, содержащий лишь некоторые подключения по локальной сети для данной домашней сети, то и в этом случае мост можно выбрать в качестве частного подключения. Сведения о включении ICS см. в разделе Разрешение общего доступа к подключению к Интернету по сети. Сведения о создании моста см. в разделе Объединение подключений в мост.

Сведения о протоколах, службах, интерфейсах и маршрутах, которые настраиваются при разрешении общего доступа к подключению Интернета, см. в разделе Параметры общего доступа к подключению Интернета.

Важно!

  • Данную возможность не следует использовать в сети, где имеются другие контроллеры доменов Windows 2000 Server, серверы DNS, шлюзы, серверы DHCP или системы со статическими IP-адресами.
  • На главном компьютере ICS нужно установить два сетевых подключения. Подключение по локальной сети, автоматически создаваемое в результате установки сетевого адаптера, обеспечивает соединение с компьютерами домашней или небольшой офисной сети. Второе подключение (использующее модем с пропускной способностью 56 Kбит/с, линию ISDN, DSL или кабельный модем) связывает эту сеть с Интернетом. Необходимо убедиться, что служба ICS включена на втором подключении, обеспечивающем выход в Интернет. Таким образом общее подключение соединит домашнюю или небольшую офисную сеть с Интернетом, а пользователи, находящиеся вне этой сети, могут не опасаться, что получат из нее неправильные адреса.
  • После активизации службы общего доступа к подключению Интернета сетевому адаптеру, подключенному к домашней или небольшой офисной сети, присваивается новый статический IP-адрес. Как следствие, все подключения TCP/IP между компьютерами сети и главным компьютером ICS, которые уже были установлены к моменту включения ICS, будут разорваны и потребуют повторной установки.

Примечание

  • Если на главном компьютере ICS создать подключение VPN и включить на нем общий доступ к подключению Интернета, весь трафик из Интернета будет направляться в корпоративную сеть и все компьютеры домашней или небольшой офисной сети получат доступ к корпоративной сети. Если служба ICS не включена на подключении VPN, то при активизации этого подключения на главном компьютере ICS другие компьютеры потеряют доступ к Интернету или корпоративной сети. Дополнительные сведения о создании подключения виртуальной частной сети (VPN) см. в разделе Чтобы создать подключение к виртуальной частной сети (VPN).

См. также


Параметры общего доступа к подключению Интернета

Рисунок Microsoft Windows

Параметры общего доступа к подключению к Интернету

При запуске мастера настройки сети и включении общего доступа к подключению к Интернету некоторые протоколы, службы, интерфейсы и маршрутизаторы настраиваются автоматически. Эти автоматически настраиваемые элементы приведены в следующей таблице.

Элемент | Действие
IP-адрес 192.168.0.1 | Присваивается с маской подсети 255.255.255.0 сетевому адаптеру, подключенному к домашней или небольшой офисной сети
Функция автонабора номера | Включается
Статический IP-маршрут, выбираемый по умолчанию | Создается при установке подключения удаленного доступа
Служба общего доступа к подключению Интернета | Запускается
Распределитель DHCP | Включается с диапазоном по умолчанию 192.168.0.1 и маской подсети 255.255.255.0. Частным сетевым клиентам выделяются уникальные адреса из диапазона 192.168.0.2–192.168.0.254
Прокси-сервер DNS | Включается

Интернет-игры по сети

Чтобы играть в Интернет-игры, используя компьютер в локальной сети и компьютер в Интернете, необходимо убедиться, что сетевые подключения для игры перенаправляются сетевыми устройствами между локальной сетью и Интернетом. Приведем два примера.

  • Если сетевое устройство между сетью и Интернетом — компьютер под управлением XOX, использующий общий доступ к подключению к Интернету, то для приема сетевых подключений для игры необходимо настроить параметры общего доступа к подключению. Дополнительные сведения о добавлении определений служб для общего доступа к подключению к Интернету см. в разделе Добавление определений служб для общего доступа к подключению к Интернету и Использование средства обнаружения и управления устройствами шлюза Интернета. Чтобы включить средство обнаружения и управления устройствами шлюза Интернета, выберите на странице свойств подключения вкладку Дополнительно, а затем установите флажок Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету.
  • Если сетевое устройство — брандмауэр или шлюз безопасности, для приема сетевых подключений для игры необходимо настроить устройство. В этом случае обратитесь к администратору сети, который определит конкретный тип подключений, используемых Интернет-игрой и настроит брандмауэр для перенаправления этих подключений.
Если не выполнить такую настройку, компьютеры в локальной сети не смогут подключиться к игровым серверам в Интернете, а игроки в Интернете не смогут подключиться к игровым серверам Интернета в локальной сети.

Примечания

  • Чтобы включить общий доступ к подключению к Интернету для подключения локальной сети (LAN), необходимо настроить протокол TCP/IP для подключений LAN к Интернету с использованием шлюза по умолчанию. В этом случае TCP/IP-адресация может быть как статической, так и динамической с использованием DHCP.
  • XOX

См. также


Разрешение общего доступа к подключению Интернета по сети

Рисунок Microsoft Windows

Чтобы разрешить общий доступ к подключению Интернета по сети

XOX

  • Для настройки общего доступа к подключению к Интернету запуститемастер настройки сети.

Важно!

  • Не следует использовать общий доступ к подключению к Интернету в сети, где есть другие контроллеры домена, DNS-серверы, шлюзы, DHCP-серверы или системы со статическими IP-адресами.
  • Когда общий доступ к подключению к Интернету разрешен, сетевому адаптеру, подключенному к домашней или небольшой офисной сети, присваивается новый статический IP-адрес. Существующие TCP/IP-подключения на компьютере, использующем ICS, будут разорваны и потребуют повторной установки. Например, если обозреватель Internet Explorer был подключен к веб-узлу при включении ICS, необходимо обновить страницу, чтобы обозреватель восстановил подключение.
  • Для использования ICS пользователи в домашней или малой офисной сети должны настроить протокол TCP/IP для подключения по локальной сети на автоматическое получение IP-адреса. Пользователи домашней или малой офисной сети должны также настроить параметры Интернета для ICS. Дополнительные сведения см. в разделе Чтобы настроить параметры Интернета для общего доступа к подключению Интернета.

Примечания

  • XOX
  • Для получения сведений об автоматически настраиваемых протоколах, службах, интерфейсах и маршрутах щелкните ссылку См. также.
  • Общий доступ к подключению к Интернету доступен только в том случае, когда на компьютере установлено более одного сетевого адаптера.

См. также


Настройка параметров Интернета для службы общего доступа к подключению Интернета

Рисунок Microsoft Windows

Чтобы настроить параметры Интернета для службы общего доступа к подключению Интернета

  1. Откройте обозреватель Internet Explorer.
  2. В меню Сервис выберите команду Свойства обозревателя.
  3. На вкладке Подключения установите переключатель в положение Никогда не использовать и нажмите кнопку Настройка сети.
  4. В группе Автоматическая настройка снимите флажки Автоматическое определение параметров и Использовать сценарий автоматической настройки.
  5. В группе Прокси-сервер снимите флажок Использовать прокси-сервер.

Примечания

  • XOX
  • Если подключение к Интернету до этого не устанавливалось, начнет работать мастер нового подключения. Для получения дополнительных сведений о подключении к Интернету щелкните ссылку См. также.

См. также


Использование подключаемых модулей общего доступа к подключению к Интернету и брандмауэра Windows

Поставщики программного обеспечения могут предоставлять определенный тип подключаемого модуля для исправления проблем с подключением, которые могут возникнуть при использовани программ, работающих через Интернет, если при этом используются общий доступ к подключению к Инернету (ICS), брандмауэр Windows или оба этих средства одновременно. Такой тип модуля подключения называется подключаемым модулем общего доступа к подключению к Интернету и брандмауэра Windows. Этот подключаемый модуль является исполняемым файлом, который доступен в двух форматах.

  1. Во время установки новой программы может появиться возможность установить подключаемый модуль — при этом появляется сообщение, которое показывает, что устанавливаемая программа попытается установить подключаемый модуль ICS и брандмауэра Windows.
  2. Если программа уже установлена ранее, дополнительный модуль можно попробовать поискать на веб-узле производителя этой программы. Если дополнительный модуль имеется, его можно загрузить из Интернета и установить.

При установке нового подключаемого модуля ICS и брандмауэра Windows существует возможность, что ранее установленный подключаемый модуль будет изменен и перестанет работать правильно. Для восстановления предыдущих модулей попробуйте удалить новый модуль. Удаление подключаемого модуля приводит к возвращению ICS и брандмауэра Windows в их прежнее состояние. Для удаления модуля можно воспользоваться компонентом панели управления Установка и удаление программ. Дополнительные сведения см. в разделе Чтобы заменить или удалить программу.

Так как подключаемый модуль ICS и брандмауэра Windows может изменить брандмауэр и поэтому потенциально сделать сеть уязвимой для угроз безопасности, необходимо устанавливать такой подключаемый модуль только в том случае, если он поступил из надежного источника.

Примечания

  • XOX


Просмотр состояния общего подключения к Интернету

Рисунок Microsoft Windows

Чтобы просмотреть состояние общего подключения к Интернету

  1. Откройте компонент Сетевые подключения.
  2. Щелкните правой кнопкой мыши значок общего подключения к Интернету и выберите команду Состояние.

Примечания

  • XOX
  • Если для общего подключения к Интернету установлен флажок При подключении вывести значок в области уведомлений, можно щелкнуть значок общего подключения для открытия окна состояния.
  • Если включен брандмауэр Windows, для работы средства обнаружения и управления устройства шлюза Интернета необходимо установить флажок UPnP-структура на вкладке Исключения.

См. также


Что такое брандмауэр Windows?

Брандмауэр помогает повысить безопасность компьютера. Он ограничивает информацию, поступающую на компьютер с других компьютеров, позволяя лучше контролировать данные на компьютере и обеспечивая линию обороны компьютера от людей или программ (включая вирусы и «черви»), которые несанкционированно пытаются подключиться к компьютеру.

Можно считать брандмауэр пограничным постом, на котором проверяется информация (часто называемая трафик), приходящая из Интернета или локальной сети. В ходе этой проверки брандмауэр отклоняет или пропускает информацию на компьютер в соответствии с установленными параметрами. См. следующую иллюстрацию.

Иллюстрация брандмауэра, блокирующего одни подключения и пропускающего другие

В XOX брандмауэр Windows включен по умолчанию. (Однако некоторые производители компьютеров и администраторы сети могут выключить его.) Необязательно использовать именно брандмауэр Windows — можно установить и включить любой брандмауэр по выбору. Оцените возможности других брандмауэров, а затем решите, какой из брандмауэров подходит лучше всего. При желании установить и включить другой брандмауэр отключите брандмауэр Windows.

Как работает брандмауэр?

Когда к компьютеру пытается подключиться кто-то из Интернета или локальной сети, такие попытки называют «непредусмотренными запросами». Когда на компьютер поступает непредусмотренный запрос, брандмауэр Windows блокирует подключение. Если на компьютере используются такие программы, как программа передачи мгновенных сообщений или сетевые игры, которым требуется принимать информацию из Интернета или локальной сети, брандмауэр запрашивает пользователя о блокировании или разрешении подключения. Если пользователь разрешает подключение, брандмауэр Windows создает исключение, чтобы в будущем не тревожить пользователя запросами по поводу поступления информации для этой программы.

Если идет обмен мгновенными сообщениями с собеседником, который собирается прислать файл (например фотографию), брандмауэр Windows запросит подтверждения о снятии блокировки подключения и разрешении передачи фотографии на компьютер. А при желании участвовать в сетевой игре через Интернет с друзьями пользователь может добавить эту игру как исключение, чтобы брандмауэр пропускал игровую информацию на компьютер.

Хотя имеется возможность отключать брандмауэр Windows для отдельных подключений к Интернету или локальной сети, это повышает вероятность нарушения безопасности компьютера.

Что может и чего не может брандмауэр Windows

Он может: | Он не может:
Блокировать компьютерным вирусам и «червям» доступ на компьютер. | Обнаружить или обезвредить компьютерных вирусов и «червей», если они уже попали на компьютер. По этой причине необходимо также установить антивирусное программное обеспечение и своевременно обновлять его, чтобы предотвратить повреждение компьютера вирусами, «червями» и другими опасными объектами, а также не допустить использования данного компьютера для распространения вирусов на другие компьютеры.
Запросить пользователя о выборе блокировки или разрешения для определенных запросов на подключение . | Запретить пользователю открывать сообщения электронной почты с опасными вложениями. Не открывайте вложения в сообщениях электронной почты от незнакомых отправителей. Следует проявлять осторожность, даже если источник сообщения электронной почты известен и заслуживает доверия. При получении от знакомого пользователя электронного письма с вложением внимательно прочтите тему сообщения перед тем, как открыть его. Если тема сообщения представляет собой беспорядочный набор знаков или не имеет смысла, не открывайте письмо, пока не свяжетесь с отправителем для получения подтверждения.
Вести учет (журнал безопасности) — по желанию пользователя — записывая разрешенные и заблокированные попытки подключения к компьютеру. Этот журнал может оказаться полезным для диагностики неполадок. Если требуется, чтобы брандмауэр Windows создавал журнал безопаности, см. раздел Включение параметров ведения журнала безопасности. | Блокировать спам или несанкционированные почтовые рассылки, чтобы они не поступали в папку входящих сообщений. Однако некоторые программы электронной почты способны делать это. Ознакомьтесь с документацией своей почтовой программы, чтобы выяснить ее возможности.

См. также


Почему следует использовать только один брандмауэр

Если на компьютере установлено более одного брандмауэра, не следует включать их одновременно. Одновременное включение двух брандмауэров может вызвать проблемы совместимости, в результате которых некоторые программы перестанут работать правильно.

Чтобы защитить компьютер от вирусов и других опасностей, работать всегда следует с включенным брандмауэром. Windows оснащен брандмауэром, который включен по умолчанию. (Однако некоторые производители компьютеров или сетевые администраторы могут выключить его.) При желании установить и включить другой брандмауэр отключите брандмауэр Windows.

Рекомендации по отключению брандмауэра Windows см. в разделе Включение и отключение брандмауэра Windows.

См. также


Для чего служат параметры настройки брандмауэра Windows?

Работа брандмауэра Windows определяется тремя параметрами: Включить, Включить, но не разрешать исключения и Выключить.

Включить. По умолчанию брандмауэр Windows включен, и лучше оставить его в таком состоянии. При использовании этого параметра брандмауэр Windows будет блокировать все непредусмотренные запросы на подключение к компьютеру за исключением тех, которые предназначены для программ или служб, выбранных на вкладке Исключения.

Включить, но не разрешать исключения: При установке флажка Не разрешать исключения брандмауэр Windows блокирует все непредусмотренные запросы на подключение к компьютеру, в том числе и те, которые предназначены для программ или служб, выбранных на вкладке Исключения. Этот параметр служит для максимальной защиты компьютера, например при подключении к общедоступной сети в отеле или аэропорту или в периоды распространения через Интернет особо опасных вирусов или червей. Нет необходимости все время использовать флажок Не разрешать исключения, поскольку при этом некоторые программы могут перестать работать правильно, а кроме того будут блокироваться непредусмотренные запросы к следующим службам:

  • Служба доступа к файлам и принтерам
  • Средства «Удаленный помощник» и «Дистанционное управление рабочим столом»
  • Обнаружение сетевых устройств
  • Заранее настроенные программы и службы в списке «Исключения»
  • Дополнительные объекты, которые были добавлены в список «Исключения»

Если установлен флажок Не разрешать исключения, можно по-прежнему отправлять и получать электронную почту, использовать программу передачи мгновенных сообщений или просматривать большинство веб-страниц.

Выключить. Этот параметр отключает брандмауэр Windows. При использовании этого параметра компьютер гораздо более уязвим к атакам злоумышленников или вирусов, исходящим из Интернета. Этот параметр следует использовать только опытным пользователям в целях администрирования компьютера или при наличии защиты компьютера другим брандмауэром.

Примечание

  • Параметры настройки, заданные для случая, когда компьютер присоединен к домену, сохраняются отдельно от параметров для работы компьютера не в составе домена. Эти отдельные группы параметров настройки называются профили.

См. также


Возможность для программы связываться через брандмауэр Windows

Помогая обеспечить защиту компьютера, брандмауэр Windows блокирует непредусмотренные запросы на подключение к вашему компьютеру. Поскольку брандмауэр ограничивает обмен данными между компьютером и Интернетом, может потребоваться регулировка параметров для некоторых программ, которым требуется свободное подключение к Интернету. Для этих программ можно сделать исключение, чтобы они могли связываться через брандмауэр.

Риск при создании исключений

Каждое исключение, дающее программе возможность связываться через брандмауэр Windows, делает компьютер более уязвимым. Создание исключения равносильно пробиванию бреши в брандмауэре. Если таких брешей окажется слишком много, брандмауэр уже не будет прочной преградой. Обычно взломщики используют специальные программы для поиска в Интернете компьютеров с незащищенными подключениями. Если создать много исключений и открыть много портов, компьютер может оказаться жертвой таких взломщиков.

Чтобы уменьшить потенциальный риск при создании исключений:

  • Создавайте исключение, только когда оно действительно необходимо.
  • Никогда не создавайте исключений для программы, которую плохо знаете.
  • Удаляйте исключения, когда необходимость в них отпадает.

Создание исключений несмотря на риск

Иногда требуется открыть кому-то возможность связи с вашим компьютером, несмотря на риск—например, когда ожидается получение файла, посланного через программу передачи мгновенных сообщений, или когда хочется принять участие в сетевой игре через Интернет.

Если идет обмен мгновенными сообщениями с собеседником, который собирается прислать файл (например фотографию), брандмауэр Windows запросит подтверждения о снятии блокировки подключения и разрешении передачи фотографии на ваш компьютер. А при желании участвовать в сетевой игре через Интернет с друзьями вы можете добавить эту игру как исключение, чтобы брандмауэр пропускал игровую информацию на ваш компьютер.

Чтобы разрешить непредусмотренные подключения к программе на своем компьютере, используйте вкладку Исключения в брандмауэере Windows. Если программа или служба, для которой требуется создать исключение, отсутствует в списке на вкладке Исключения, можно добавить ее с помощью кнопки Добавить программу. Если программа отсутствует в списке программ, которые можно добавить, нажмите кнопку Обзор, чтобы найти ее.

Чтобы добавить программу в список исключений

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Исключения в группе Программы и службы установите флажок для программы или службы, которую требуется разрешить, а затем нажмите кнопку OK.

Если программа или служба, которую требуется разрешить, отсутствует в списке, выполните следующие действия.

  1. Нажмите кнопку Добавить программу.
  2. В диалоговом окне Добавление программы выберите программу, которую требуется добавить, и нажмите кнопку OK. Эта программа появится (с установленным флажком) на вкладке Исключения в группе Программы и службы.
  3. Нажмите кнопку OK.

Если программа или служба, которую требуется разрешить, не перечислена в диалоговом окне Добавление программы, выполните следующие действия.

  1. В диалоговом окне Добавление программы нажмите кнопку Обзор, найдите программу, которую требуется добавить, и дважды щелкните ее. (Программы обычно хранятся на компьютере в папке «Program Files».) Программа появится в группе Программы в диалоговом окне Добавление программы.
  2. Нажмите кнопку OK. Эта программа появится (с установленным флажком) на вкладке Исключения в группе Программы и службы.
  3. Нажмите кнопку OK.

Если программу по-прежнему не удалось найти, можно открыть порт. Порт подобен маленькой дверце в брандмауэре, через которую разрешается взаимодействовать. Чтобы определить, какой порт нужно открыть, на вкладке Исключения нажмите кнопку Добавить порт. (Открыв порт, не забудьте снова закрыть его, когда перестанете использовать.)

Добавление исключения более предпочтительно, чем открытие порта, по следующим причинам:

  • Проще сделать.
  • Нет необходимости выяснять номер используемого порта.
  • Добавление исключения помогает поддерживать безопасность, так как брандмауэр открыт только в то время, когда программа ожидает подключения к ней.

Дополнительные параметры

Опытные пользователи могут открывать порты и настраивать их для отдельных подключений, чтобы свести к минимуму возможности злоумышленников в получении доступа к компьютеру или к сети. Для этого откройте брандмауэр Windows, откройте вкладку Дополнительно и используйте параметры в группе Параметры сетевого подключения.

См. также


Общее представление о случаях блокирования программ

Если при включенном брандмауэре Windows программа на компьютере пытается выполнить подключение к Интернету или сети, брандмауэр блокирует действия программы и отображает сообщение с возможностью разблокировать эту программу.

Например, предположим, на компьютере имеется игра, для которой настроен многопользовательский режим работы через Интернет. Брандмауэр заблокирует подключение игры к Интернету, и будет невозможно получать сведения от других игроков, которые необходимы для правильной работы игры. Будет отображен запрос с вариантами возможных действий.

При получении этого запроса пользователь может выбрать варианты действий:

  • Блокировать — программа не сможет выполнять подключения без разрешения пользователя.
  • Разблокировать — этот вариант можно выбрать для доверенной программы и только если известно, зачем программе требуется подключение к сети. (В приведенном ранее примере с игрой подходит именно этот вариант.)
  • Сделать выбор позднее, если пользователь решил отложить решение о блокировании или разрешении подключения программы. В этом случае программа остается заблокированной (для большей надежности), а при следующем запуске программы пользователь снова получит запрос о выборе решения.

Если программа была разблокирована, брандмауэр Windows создаст исключение для этой программы, чтобы обеспечить взаимодействие через брандмауэр. При следующий подключениях этой программы к сети оповещения брандмауэра отображаться не будут. После закрытия программы временный проход через брандмауэр будет также закрыт.

Примечания

  • Сделанный выбор применяется к каждому пользователю, имеющему учетную запись на данном компьютере.
  • Для некоторых игр (игр DirectX) сообщение может быть скрыто за окном программы. Чтобы просмотреть сообщение, сверните или закройте программу.
  • Эти сообщения могут быть отключены с помощью брандмауэра Windows, программы netsh.exe или групповой политики. Чтобы отключить эти сообщения в брандмауэре Windows на вкладке Исключения снимите флажок Отображать уведомление, когда брандмауэр блокирует программу. Однако рекомендуется не отключать эти сообщения, так как они используются для наблюдения за безопасностью компьютера.
  • Если на вкладке Общие установлен флажок Не разрешать исключения, сообщения не будут отображаться, так как брандмауэр будет блокировать все подключения, не зависимо от значений других параметров.

См. также


Включение и выключение брандмауэра Windows

Рисунок Microsoft Windows

Чтобы включить или выключить брандмауэр Windows

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Общие выберите один из следующих параметров.

    • Включить (рекомендуется). Обычно используется этот параметр.

      Можно также установить флажок Не разрешать исключения. Когда установлен этот флажок, брандмауэр блокирует все непредусмотренные запросы на подключение к компьютеру, в том числе запросы к программам или службам, выбранным на вкладке Исключения. Этот параметр служит для максимальной защиты компьютера, например при подключении к общедоступной сети в отеле или аэропорту или в периоды распространения через Интернет особо опасных вирусов или червей.

    • Выключить (не рекомендуется). Отключение брандмауэра Windows может привести к тому, что компьютер (и сеть, если она есть) может стать более уязвимым для атак со стороны вирусов или неизвестных злоумышленников.

Внимание!

  • Если на вкладке «Дополнительно» брандмауэр Windows был отключен для одного или нескольких подключений, центр обеспечения безопасности Windows отобразит сообщение о том, что брандмауэр отключен (даже если брандмауэр включен для других подключений). На вкладке «Общие» будет отображаться, что брандмауэр Windows включен.

Примечания

  • XOX
  • Для всех подключений к Интернету и локальной сети брандмауэр Windows по умолчанию включен. Однако некоторые производители компьютеров или сетевые администраторы могут выключить его.
  • Поскольку брандмауэр Windows по умолчанию включен, некоторыми возможностями ряда программ можно будет воспользоваться только после включения программы в список на вкладке Исключения брандмауэра Windows. В частности, нельзя послать фотографии через программу передачи мгновенных сообщений, пока эта программа не добавлена в список исключений.

См. также


Включение брандмауэра Windows без исключений

Рисунок Microsoft Windows

Чтобы включить брандмауэр Windows без исключений

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Общие выберите вариант Включить.
  3. Установите флажок Не разрешать исключения и нажмите кнопку OK.

Примечания

  • XOX
  • При установке флажка Не разрешать исключения брандмауэр Windows блокирует все непредусмотренные запросы на подключение к компьютеру, в том числе запросы к программам или службам, выбранным на вкладке Исключения. Этот параметр служит для максимальной защиты компьютера, например при подключении к общедоступной сети в отеле или аэропорту или в периоды распространения через Интернет особо опасных вирусов или червей.
  • Когда установлен флажок Не разрешать исключения, брандмауэр блокирует также непредусмотренные запросы на доступ к общим файлам и принтерам и обнаружение сетевых устройств.
  • Когда установлен флажок Не разрешать исключения, можно по-прежнему просматривать большинство веб-страниц, отправлять и получать электронную почту, а также использовать программу передачи мгновенных сообщений.

См. также


Включение и отключение общего доступа к файлам и принтерам

Рисунок Microsoft Windows

Чтобы включить или отключить общий доступ к файлам и принтерам

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Исключения выполните одно из следующих действий.
    • Чтобы включить общий доступ к файлам и принтерам, установите флажок Общий доступ к файлам и принтерам.
    • Чтобы отключить общий доступ к файлам и принтерам, снимите флажок Общий доступ к файлам и принтерам.

Примечание

  • XOX
  • Опытные пользователи могут корректировать настройки службы общего доступа к файлам и принтерам, включая или отключая отдельные порты и настраивая требуемый диапазон портов.

См. также


Включение и отключение структуры UPnP

Рисунок Microsoft Windows

Чтобы включить или отключить структуру UPnP

XOX

  1. Откройте брандмауэр Windows.
  2. Выполните одно из следующих действий.
    • Чтобы включить технологию UPnP, на вкладке Исключения установите флажок UPnP-структура.
    • Чтобы выключить технологию UPnP, на вкладке Исключения снимите флажок UPnP-структура.

Примечания

  • XOX
  • Опытные пользователи могут редактировать службу для структуры UPnP, включая или отключая отдельные порты и настраивая требуемый диапазон портов.

См. также


Влияние брандмауэра Windows на печать и сканирование

Большинство принтеров будет работать так же, как они работали до установки XOX. Однако возможны некоторые отличия:

  • Клиентский компьютер не будет получать уведомлений от принтера — таких как «задание печати выполнено» или «принтер не заправлен бумагой».
  • Если на сервере печати (компьютере, к которому подключен принтер) включен брандмауэр Windows, а порты общего доступа к файлам и принтерам не открыты, то другие компьютеры локальной сети не смогут использовать принтер.
  • Обычно около каждого значка принтера в папке «Принтеры и факсы» панели управления выводятся сведения о текущем состоянии устройства — такие как «Готово» или «Пауза». Если включен брандмауэр Windows, эти сведения будут выводиться с некоторой задержкой.

Если после установки XOX сетевой принтер перестает работать или другой компьютер локальной сети — не тот, который служит сервером печати — не может использовать принтер, откройте в панели управления окно брандмауэра Windows и установите флажок Служба доступа к файлам и принтерам на вкладке Исключения. Это устранит большую часть проблем общего доступа к принтеру.

Сетевые принтеры и сканеры

Если на сервере печати включен брандмауэр Windows, а компьютеры локальной сети используют для печати протокол IPP (Internet printing protocol), то для успешного общего доступа к принтерам необходимо открыть на сервере печати специальный порт. Обычно для серверов печати с протоколом IPP используется порт 80.

При включенном брандмауэре Windows сканирование с помощью сетевого сканера может оказаться невозможным. Если сканер не работает, обратитесь за рекомендациями к изготовителю сканера.

Примечание

  • XOX

См. также


Влияние брандмауэра Windows на уведомления

Так как брандмауэр Windows проверяет все входящие подключения, поведение некоторых программ, особенно почтовых программ, при включенном брандмауэре может измениться.

Outlook Express, например, при наличии новой почты отправляет пользователю уведомление. Брандмауэр Windows не повлияет на поведение этой программы, так как уведомления о получении новой почты исходят от локального компьютера.

Однако когда Microsoft Office Outlook 2000, Outlook 2002 или Outlook 2003 отправляют уведомления о наличии новой почты, эти уведомления приходят с сервера в Интернете, поэтому брандмауэр Windows блокирует уведомления, и они не попадают на компьютер пользователя. С помощью приложения Office Outlook можно отправлять и получать сообщения электронной почты, однако необходимо вручную проверять наличие новых сообщений.


Восстановление параметров по умолчанию для брандмауэра Windows

Рисунок Microsoft Windows

Чтобы восстановить параметры по умолчанию для брандмауэра Windows

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно нажмите кнопку Восстановить умолчания.

Примечание

  • XOX

См. также


Открытие портов в брандмауэре Windows

Чтобы обеспечить безопасность компьютера, необходимо держать брандмауэр Windows (или другой брандмауэр по выбору) включенным, чтобы он блокировал любые непредусмотренные запросы на подключение к компьютеру. Для возможности подключения такого типа необходимо разрешить исключение или открыть порт для конкретной программы или службы.

Порт — это проход в ваш компьютер, через который может передаваться информация. Если идет обмен мгновенными сообщениями с собеседником, который собирается прислать файл (например фотографию), брандмауэр Windows запросит подтверждения о снятии блокировки подключения и разрешении передачи фотографии на ваш компьютер. А при желании участвовать в сетевой игре через Интернет с друзьями вы можете добавить эту игру как исключение, чтобы брандмауэр пропускал игровую информацию на ваш компьютер.

Риск при открытии портов

Каждое исключение или открытый порт, дающие программе возможность связываться через брандмауэр Windows, делают компьютер более уязвимым. Открытие порта равносильно пробиванию бреши в брандмауэре. Если таких брешей окажется слишком много, брандмауэр уже не будет прочной преградой. Обычно взломщики используют специальные программы для поиска в Интернете компьютеров с незащищенными подключениями. Если открыть много портов, компьютер может оказаться жертвой таких взломщиков.

Чтобы уменьшить потенциальный риск при открытии портов:

  • Открывайте порт, только когда он действительно необходим.
  • Никогда не открывайте порт для программы, которую плохо знаете.
  • Закрывайте порт, когда необходимость в нем отпадает.

Как работают порты

У каждого порта есть номер, который играет роль адреса. Многие программы и службы имеют «постоянные адреса», то есть для них заранее определены номера портов. Номера портов, необходимых для программы или службы, можно найти в документации производителя или на соответствующем веб-узле. Дополнительные сведения см. в документе Как открыть порты в брандмауэре Windows на веб-узле корпорации Майкрософт (http://www.microsoft.com/).

Для некоторых программ (например для некоторых игр) номера портов не определены заранее. Эти программы открывают порты автоматически при необходимости. Чтобы такие программы могли соединиться с вашим компьютером, брандмауэр Windows должен позволить программе открыть нужный порт. Для правильной работы таких программ их необходимо внести в список на вкладке Исключения брандмауэра Windows.

При добавлении или изменении параметров настройки для службы или программы, например для игры, следует выбрать условие открытия порта: для любого компьютера или только для компьютеров локальной сети. Если выбран вариант Любой компьютер, то к данному компьютеру сможет подключиться любой компьютер из Интернета или из локальной сети. Если выбран вариант Только локальная сеть, к данному компьютеру смогут подключиться компьютеры только из локальной сети. При желании можно выбрать вариант Особые и ввести в список IP-адреса и подсети, которым будет разрешен доступ.

См. также


Включение и выключение брандмауэра Windows для отдельных подключений

Рисунок Microsoft Windows

Чтобы включить или выключить брандмауэр Windows для отдельных подключений

XOX

  1. Откройте брандмауэр Windows.
  2. Выполните одно из следующих действий.
    • Чтобы включить брандмауэр Windows для подключения, установите флажок для подключения на вкладке Дополнительно в списке Параметры сетевого подключения.
    • Чтобы отключить брандмауэр Windows для подключения, снимите флажок этого подключения на вкладке Дополнительно в списке Параметры сетевого подключения.

Примечания

  • XOX
  • Если выключить брандмауэр Windows на компьютере, он (или сеть, если она есть) может стать уязвимым для злоумышленников.
  • Эти параметры применяются только если брандмауэр включен (на вкладке Общие).
  • Если установить флажок Не разрешать исключения на вкладке Общие, будут заблокированы все непредусмотренные подключения, вне зависимости от флажка, установленного для отдельных подключений.

См. также


Открытие или закрытие портов

Рисунок Microsoft Windows

Чтобы открыть или закрыть порты

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Исключения выберите один из следующих параметров.
    • Чтобы открыть порт для программы или услуги, установите для них флажок.
    • Чтобы закрыть порт для программы или услуги, снимите установленный флажок.

Примечания

  • XOX
  • Заранее настроенные на вкладке Исключения программы и службы не могут быть удалены.
  • Опытные пользователи могут открыть порты для отдельного подключения, используя раздел Параметры сетевого подключения на вкладке Дополнительно.

См. также


Добавление порта

Рисунок Microsoft Windows

Чтобы добавить порт

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Исключения нажмите кнопку Добавить порт.
  3. В поле Номер порта введите номер нужного порта.
  4. Выберите TCP или UDP.
  5. В поле Имя введите короткое имя порта, чтобы запомнить, для чего он используется.
  6. Чтобы определить, какие компьютеры могут использовать этот порт, нажмите кнопку Изменить область.
  7. Выполните одно из следующих действий.
    • Чтобы разрешить подключения от любого компьютера, включая компьютеры из Интернета, выберите вариант Любой компьютер (включая из Интернета) и нажмите кнопку OK.
    • Чтобы разрешить подключения только из локальной подсети, выберите вариант Только локальная сеть (подсеть), а затем нажмите кнопку OK.
    • Чтобы определить особый список, выберите вариант Особый список и введите список, состоящий из IP-адресов и (или) подсетей, разделенных запятыми.

Примечания

  • XOX
  • Если нет уверенности в том, какой номер порта или какой тип порта (TCP или UDP) выбрать, обратитесь к документации или к веб-узлу программы или службы, для которой добавляется порт.

См. также


Изменение порта или параметров программы

Рисунок Microsoft Windows

Чтобы изменить порт или параметры программы

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Исключения выберите программу или службу, для которой требуется изменить параметры порта, и нажмите кнопку Изменить.
  3. В диалоговом окне Изменение порта или Изменение программы выберите параметры, которые требуется изменить.

Примечания

  • XOX
  • Для получения дополнительных сведений обратитесь к документации по службе или программе, для которой требуется настроить порт, или на соответствующий веб-узел.

См. также


Удаление порта или программы

Рисунок Microsoft Windows

Чтобы удалить порт или программу

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Исключения выберите порт или программу, которую требуется удалить, и нажмите кнопку Удалить.

Примечания

  • XOX
  • Заранее настроенные на вкладке Исключения программы и службы не могут быть удалены.

См. также


Добавление определения службы для отдельного подключения

Рисунок Microsoft Windows

Чтобы добавить определение службы для отдельного подключения

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно в списке Параметры сетевого подключения выберите подключение, котороые требуется изменить, и нажмите кнопку Параметры.
  3. На вкладке Службы нажмите кнопку Добавить и введите следующие данные:
    • В поле Описание службы введите имя службы; используйте легко узнаваемые имена.
    • В поле Имя или IP-адрес компьютера вашей сети, на котором располагается эта служба введите имя или IP-адрес компьютера сети, на котором установлена данная служба.
    • В поле Номер внешнего порта службы введите номер порта, который должен будет использоваться внешними компьютерами для доступа к службе.
    • В поле Номер внутреннего порта службы введите номер порта, используемого службой в сети. (Как правило, этот номер совпадает с номером, указанным на предыдущем шаге.)
    • Выберите тип порта — TCP или UDP.

Примечания

  • XOX
  • Правильные значения номеров портов TCP или UDP можно узнать в документации по данной службе или на ее веб-узле.

См. также


Изменение определения службы для отдельного подключения

Рисунок Microsoft Windows

Чтобы изменить определение службы для отдельного подключения

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно в списке Параметры сетевого подключения выберите подключение, которое требуется изменить, и нажмите кнопку Параметры.
  3. На вкладке Службы выберите службу, которую требуется изменить, нажмите кнопку Изменить и измените следующие параметры:
    • В поле Имя или IP-адрес компьютера вашей сети, на котором располагается эта служба введите имя или IP-адрес такого компьютера.
    • В поле Номер внешнего порта службы введите номер порта, который должен будет использоваться внешними компьютерами для доступа к службе.
    • В поле Номер внутреннего порта службы введите номер порта, используемого службой в сети. (Как правило, этот номер совпадает с номером, указанным на предыдущем шаге.)
    • Выберите тип порта — TCP или UDP.

Примечания

  • XOX
  • Для заранее настроенных определений служб можно изменить только поле под названием Имя или IP-адрес компьютера вашей сети, на котором располагается эта служба.
  • Правильные значения номеров портов TCP или UDP можно узнать в документации по данной службе или на ее веб-узле.
  • Никакие два определения служб не могут одновременно использовать одни и те же номера портов.

См. также


Удаление определения службы для отдельного подключения

Рисунок Microsoft Windows

Чтобы удалить определение службы для отдельного подключения

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно в списке Параметры сетевого подключения выберите подключение, которое требуется удалить, и нажмите кнопку Параметры.
  3. На вкладке Службы выберите службу, которую нужно удалить, и нажмите кнопку Удалить.

Примечания

  • XOX
  • Удалять можно только службы, добавленные пользователем. Нельзя удалять определения служб, устанавливаемые по умолчанию.
  • Удаление службы для одного подключения приведет к ее удалению для всех подключений.

См. также


Ведение журнала безопасности брандмауэра Windows

Если брандмауэр Windows включен, можно вести журнал (или запись) безопасности, в который записываются успешные подключения, которые осуществляются через брандмауэр, и подключения, которые блокируются (потерянные пакеты).

Если журнал настроен на запись потерянных пакетов, собираются сведения о каждой попытке преодоления брандмауэра, которая обнаруживается и блокируется брандмауэром Windows. Например, если параметры протокола ICMP (Internet Control Message Protocol) не разрешают входящие эхо-запросы, например такие, которые посылаются командами Ping и Tracert, и подобный эхо-запрос получен из внешней сети, этот запрос отклоняется и сведения об этом записываются в журнал.

Если журнал настроен на запись успешных подключений, собираются сведения о каждом успешном подключении, которое осуществляется через брандмауэр. Например, когда компьютер успешно подключается к веб-узлу с помощью веб-обозревателя, это подключение записывается в журнал.

Сведения о просмотре журнала безопасности брандмауэра Windows см. в разделе Просмотр файла журнала безопасности. Сведения о сохранении журнала брандмауэра в определенной папке и о присвоении ему требуемого имени см. в разделе Изменение пути и имени файла журнала безопасности.

Журнал безопасности состоит из двух разделов.

  • В заголовке отображаются сведения о версии журнала безопасности и о полях, которые доступны для ввода данных, куда можно добавлять сведения.
  • В теле журнала содержится полный отчет со всей собранной и записанной информацией о трафике или попытках подключения через брандмауэр. Тело журнала безопасности представляет собой динамический список, а новые записи данных отображаются в нижней части журнала. Сведения о настройке журнала безопасности см. в разделе Включение параметров ведения журнала безопасности.

В следующих таблицах описываются сведения, которые записываются в журнал безопасности.

Заголовок журнала

Элемент

Описание

Пример
#Version: Версия установленного журнала безопасности брандмауэера Windows. 1.5
#Software: Имя журнала безопасности. Брандмауэр Microsoft Windows
#Time: Задает использование местного времени при записи в журнал отметок времени Местное
#Fields: Статический список полей, доступных для записей журнала безопасности при наличии данных. Эти поля приведены ниже в таблице, относящейся к телу журнала. src-ip

Тело журнала

Поле

Описание

Пример
Дата Год, месяц и день, когда произошла записанная транзакция. Дата представляется в следующем формате:
ГГГГ-ММ-ДД
где ГГГГ — год, ММ — месяц и ДД — день. 		2001-01-27
Время Часы, минуты и секунды, когда произошла записанная транзакция. Время записывается в следующем формате:
ЧЧ:ММ:СС
где ЧЧ — часы в 24-часовом формате, ММ — количество минут, а СС — количество секунд. 		21:36:59
Действие | Операция, которая была обнаружена брандмауэром. Могут записываться следующие действия: OPEN (открытие), CLOSE (закрытие), DROP (отклонение) и INFO-EVENTS-LOST (потерянные события). Действие INFO-EVENTS-LOST показывает количество событий, которые произошли, но не были записаны в журнал. | OPEN
Протокол | Протокол, использованный для подключения. Если протокол отличен от TCP, UDP и ICMP, в этом поле указывается число пакетов | TCP
src-ip | IP-адрес источника (IP-адрес компьютера, который попытался установить подключения). | 192.168.0.1
dst-ip | IP-адрес назначения попытки подключения. | 192.168.0.1
src-port | Номер порта источника — компьютера-отправителя. Правильная запись src-port отображается только для протоколов TCP и UDP. Для всех остальных протоколов запись src-port отображается в виде «-». | 4039
dst-port | Номер порта конечного компьютера. Правильная запись dst-port отображается только для протоколов TCP и UDP. Для всех остальных протоколов запись dst-port отображается в виде «-». | 53
size | Размер пакета в байтах. | 60
tcpflags Флаги управления TCP, найденные в заголовках TCP пакета IP:
  • Ack Acknowledgment field significant (Включение поля подтверждения)
  • Fin No more data from sender (Конец массива данных отправителя)
  • Push function (Функция Push)
  • Rst Reset the connection (Сброс подключения)
  • Syn Synchronize sequence numbers (Синхронизация порядковых номеров)
  • Urg Urgent Pointer field significant (Включение поля указателя срочных данных)
Флаги записываются прописными буквами. 		FAP
tcpsyn | Последовательность портов TCP в пакете. | 1315819770
tcpack | Номер подтверждения TCP в пакете. | 2515999782
tcpwin | Размер окна TCP в байтах в пакете. | 64240
icmptype | Число, которое представляет поле Type сообщения ICMP. | 8
icmpcode | Число, которое представляет поле Code сообщения ICMP. | 0
info | Запись данных, которая зависит от типа случившегося действия. Например, действие INFO-EVENTS-LOST приведет к появлению записи с числом событий, произошедших, но не записанных в журнал с момента последнего наступления данного типа события. | 23

Примечания

  • Ведение журнала безопасности брандмауэра Windows по умолчанию отключено. Чтобы включить ведение журнала безопасности, см. раздел Включение параметров ведения журнала безопасности.
  • Ведение журнала доступно только для подключений, для которых включен брандмауэр Windows.

См. также


Просмотр файла журнала безопасности

Рисунок Microsoft Windows

Чтобы просмотреть файл журнала безопасности

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно в группе Ведение журнала безопасности нажмите кнопку Параметры.
  3. Нажмите кнопку Обзор.
  4. Щелкните правой кнопкой мыши файл pfirewall.log, а затем нажмите кнопку Открыть.

Примечания

  • XOX
  • По умолчанию журнал безопасности имеет имя pfirewall.log и расположен в папке Windows.
  • Чтобы файл pfirewall.log появился в папке Windows, необходимо установить флажок Записывать пропущенные пакеты или Записывать успешные подключения.
  • Если превышен максимально допустимый размер журнала pfirewall.log (4096 килобайт), сведения, содержащиеся в файле, передаются в другой файл, который сохраняется с именем pfirewall.log.old. Новые сведения сохраняются в первом созданном файле с именем pfirewall.log.

См. также


Включение параметров ведения журнала безопасности

Рисунок Microsoft Windows

Чтобы включить параметры ведения журнала безопасности

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно в группе Ведение журнала безопасности нажмите кнопку Параметры.
  3. Выберите один из следующих параметров.
    • Чтобы включить регистрацию неудачных попыток установления входящего подключения, установите флажок Записывать пропущенные пакеты.
    • Чтобы включить регистрацию успешных исходящих подключений, установите флажок Записывать успешные подключения.

Примечания

  • XOX
  • Ведение журнала безопасности не включено по умолчанию, если брандмауэр Windows включен, однако брандмауэр работает независимо от того, включено ведение журнала безопасности или отключено.
  • Ведение журнала доступно только для подключений, для которых включен брандмауэр Windows.
  • Для получения сведений об открытии и чтении журнала безопасности щелкните ссылку См. также.

См. также


Отключение параметров ведения журнала безопасности

Рисунок Microsoft Windows

Чтобы отключить параметры ведения журнала безопасности

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно в группе Ведение журнала безопасности нажмите кнопку Параметры.
  3. Выполните одно или оба следующих действия.
    • Чтобы отключить регистрацию неудачных попыток установления входящего подключения, снимите флажок Записывать пропущенные пакеты.
    • Чтобы отключить регистрацию успешных исходящих подключений, снимите флажок Записывать успешные подключения.

Примечания

  • XOX
  • Брандмауэр Windows действует независимо от того, включено ведение журнала безопасности или отключено.

См. также


Изменение размера файла журнала безопасности

Рисунок Microsoft Windows

Чтобы изменить размер файла журнала безопасности

XOX Также необходимо включить брандмауэр Windows.

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно в группе Ведение журнала безопасности нажмите кнопку Параметры.
  3. В поле Предельный размер файла журнала: введите новый размер файла или используйте клавиши со стрелками для его задания.

Примечания

  • XOX
  • По умолчанию предельный размер журнала безопасности равен 4096 КБ. Максимальный размер файла журнала составляет 32 767 КБ.
  • При превышении допустимого размера файла pfirewall.log сведения, хранившиеся в этом файле, сохраняются в файл с именем pfirewall.log.old. Новые сведения сохраняются в файле с именем pfirewall.log.

См. также


Изменение пути и имени файла журнала безопасности

Рисунок Microsoft Windows

Чтобы изменить путь и имя файла журнала безопасности

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно в группе Ведение журнала безопасности нажмите кнопку Параметры.
  3. Нажмите кнопку Сохранить как и перейдите в папку, в которую требуется сохранить файл журнала.
  4. В поле Имя файла введите новое имя файла журнала (или оставьте поле пустым, чтобы принять имя журнала по умолчанию — pfirewall.log), а затем нажмите кнопку Сохранить.

Примечания

  • XOX
  • При превышении допустимого размера файла pfirewall.log сведения, хранившиеся в этом файле, сохраняются в файл с именем pfirewall.log.old, новые сведения сохраняются в файле с именем pfirewall.log.

См. также


Дополнительные параметры брандмауэра Windows

Опытные пользователи могут настроить параметры брандмауэра Windows для отдельных подключений. Для этого в окне брандмауэра Windows откройте вкладку Дополнительно, а затем в группе Параметры сетевого подключения настройте Параметры.

Для устранения неполадок с брандмауэром Windows на клиентских компьютерах администратор может использовать средство дистанционного управления рабочим столом. Однако если служба брандмауэра Windows не запущена, администратор не сможет провести удаленную диагностику неполадок, так как все порты будут закрыты, включая порт, который используется средством дистанционного управления рабочим столом.

Используя протокол Internet Control Message Protocol (ICMP), можно выбрать различные параметры брандмауэра, например Разрешить запрос входящего эха, Разрешить входящий запрос штампа времени, Разрешить входящий запрос маршрутизатора и Разрешить перенаправление. Для настройки этих параметров и ознакомления с их кратким описанием откройте вкладку Дополнительно и в группе ICMP выберите Параметры. Дополнительные сведения о протоколе ICMP см. в разделе Протокол ICMP (Internet Control Message Protocol).

Администраторы могут использовать для настройки брандмауэра Windows средство netsh командной строки. Дополнительные сведения см. в разделе Настройка брандмауэра Windows с помощью командной строки.


Определение активных параметров брандмауэра Windows

Сочетание параметров на вкладке Исключения и любые дополнительные параметры в разделе Параметры сетевого подключения на вкладке Дополнительно называются «результирующим набором» параметров брандмауэра Windows.

Для каждого подключения результирующий набор параметров может быть различным. Параметры, открывающие порт для определенного подключения, имеют более высокий приоритет по сравнению с глобальными параметрами, которые могут запрещать открытие этого порта. В следующей таблице приведены несколько примеров.

Глобальный параметр | Параметр для подключения | Результирующий набор
Отключено | Отключено | Отключено
Включено (подсеть) | Отключено | Включено (подсеть)
Включено (глобально) | Отключено | Включено (глобально)
Отключено | Включено | Включено
Включено (подсеть) | Включено | Включено (глобально)
Включено (глобально) | Включено | Включено (глобально)

При одновременном использовании глобальных и отдельных параметров определить результирующий набор будет трудно.


Параметры групповой политики для брандмауэра Windows

С помощью брандмауэра Windows администратор может защитить общее подключение небольшой сети или одиночного компьютера к Интернету. Дополнительные сведения о брандмауэре Windows см. в разделе Общие сведения о брандмауэре Windows. Параметры групповой политики определяют различные компоненты пользовательской системы, которыми управляет системный администратор. Дополнительные сведения о групповой политике см. в разделе Общие сведения о групповой политике.

В XOX доступны следующие параметры групповой политики:

  • Брандмауэр Windows: Разрешать обход для прошедших проверку IPSec
  • Брандмауэр Windows: Разрешать исключения для общего доступа к файлам и принтерам
  • Брандмауэр Windows: Разрешать исключения ICMP
  • Брандмауэр Windows: Разрешать локальные исключения для портов
  • Брандмауэр Windows: Разрешать локальные исключения для программ
  • Брандмауэр Windows: Разрешать ведение журнала
  • Брандмауэр Windows: Разрешать исключения для удаленного управления
  • Брандмауэр Windows: Разрешать исключения для удаленного рабочего стола
  • Брандмауэр Windows: Разрешать исключения для UPnP-инфраструктуры
  • Брандмауэр Windows: Задать исключения для программ
  • Брандмауэр Windows: Задать исключения портов
  • Брандмауэр Windows: Не разрешать исключения
  • Брандмауэр Windows: Защитить все сетевые подключения
  • Брандмауэр Windows: Запретить уведомления
  • Брандмауэр Windows: Запретить одноадресные ответы на многоадресные или широковещательные запросы

Дополнительные сведения об этих параметрах см. в документе Документация Windows XP SP2 для профессионалов в области информационных технологий (http://www.microsoft.com/technet/winxpsp2/).


Настройка брандмауэра Windows с помощью командной строки

Опытные пользователи могут использовать для настройки брандмауэра Windows командную строку. Для этого можно применять средство netsh командной строки.

Команды netsh, приведенные в таблице, доступны для XOX. Введите команду и « /?», чтобы получить справочные сведения для этой команды.

Группа | Команда | Описание
Добавление | netsh firewall add allowedprogram | Добавление разрешенной конфигурации программы в брандмауэр Windows
 | netsh firewall add portopening | Добавление конфигурации порта в брандмауэр Windows
Удаление | netsh firewall delete allowedprogram | Удаление разрешенной конфигурации программы из брандмауэра Windows
 | netsh firewall delete portopening | Удаление конфигурации порта из брандмауэра Windows
Сброс | netsh firewall reset | Сброс конфигурации брандмауэра Windows до конфигурации по умолчанию
Задание | netsh firewall set allowedprogram | Изменение разрешенной конфигурации программы в брандмауэре Windows
 | netsh firewall set icmpsettings | Изменение конфигурации ICMP в брандмауэре Windows
 | netsh firewall set logging | Изменение конфигурации ведения журнала в брандмауэре Windows
 | netsh firewall set notifications | Изменение конфигурации уведомлений в брандмауэре Windows
 | netsh firewall set opmode | Изменение рабочей конфигурации в брандмауэре Windows
 | netsh firewall set portopening | Изменение конфигурации портов в брандмауэре Windows
 | netsh firewall set service | Изменение конфигурации служб в брандмауэре Windows
Отображение | netsh firewall show allowedprogram | Показ разрешенной конфигурации программы в брандмауэре Windows
 | netsh firewall show config | Показ конфигурации брандмауэра Windows
 | netsh firewall show currentprofile | Показ текущего профиля брандмауэра Windows
 | netsh firewall show icmpsettings | Показ конфигурации ICMP в брандмауэре Windows
 | netsh firewall show logging | Показ конфигурации ведения журнала в брандмауэре Windows
 | netsh firewall show notifications | Показ конфигурации уведомлений в брандмауэре Windows
 | netsh firewall show opmode | Показ рабочей конфигурации в брандмауэре Windows
 | netsh firewall show portopening | Показ конфигурации портов в брандмауэре Windows
 | netsh firewall show service | Показ конфигурации служб в брандмауэре Windows
 | netsh firewall show state | Показ текущего состояния брандмауэра Windows

Примечания

  • Команды Set machine, Set online, Set offline и Dump в брандмауэре Windows не поддерживаются. Эти команды не выполняют никаких действий.
  • С помощью команды Show обычно отображаются локально настроенные параметры. Параметры групповой политики не отображаются ни в каком другом состоянии, кроме состояния «Отображение».


Включение протокола ICMP

Рисунок Microsoft Windows

Чтобы включить протокол ICMP

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно в списке ICMP нажмите кнопку Параметры.
  3. В диалоговом окне ICMP установите флажок рядом с каждым типом сообщения протокола ICMP (Internet Control Message Protocol), который требуется включить.

Примечания

  • XOX
  • По умолчанию все параметры ICMP отключены. При включении параметров ICMP компьютер может стать доступным любому человеку из локальной сети или из Интернета.
  • При выборе параметра в списке его описание появляется в поле внизу.

См. также


Отключение протокола ICMP

Рисунок Microsoft Windows

Чтобы отключить протокол ICMP

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Дополнительно в списке ICMP нажмите кнопку Параметры.
  3. В диалоговом окне ICMP снимите флажок рядом с каждым типом сообщения протокола ICMP (Internet Control Message Protocol), который требуется отключить.

Примечания

  • XOX
  • По умолчанию все параметры ICMP отключены.

См. также


Использование общего доступа к подключению к Интернету с функцией обнаружения и управления устройствами шлюза Интернета

По умолчанию открытым ICS-подключением к Интернету можно управлять с помощью средства обнаружения и управления устройствами шлюза Интернета.

С помощью средства обнаружения и управления устройствами шлюза Интернета пользователи ICS-компьютеров в сети могут выполнять следующие действия.

  • Просматривать статистические данные о общем подключении к Интернету.
  • наблюдать за состоянием общего подключения;
  • Осуществлять удаленное подключение к общему подключению к Интернету или отключаться от него.
  • использовать значок, содержащийся в области уведомлений на панели задач, для наблюдения за общим подключением к Интернету и управления его работой.
  • Настраивать сопоставления служб.

Дополнительные сведения о средстве обнаружения и управления устройствами шлюза Интернета см. в разделе Использование средства обнаружения и управления устройствами шлюза Интернета.

Администратор компьютера, который напрямую подключается к Интернету, может отключить параметры, указанные выше, для пользователей компьютеров, которые находятся в домашней или малой офисной сети. Дополнительные сведения см. в разделах Установка разрешения на управление общим подключением к Интернету и Управление общим подключением к Интернету.

Примечания

  • Чтобы использовать общий доступ к подключению к Интернету (ICS) со средством обнаружения и управления устройствами шлюза Интернета на компьютере под управлением Windows 98, Windows 98 Second Edition или Windows Millennium Edition, запустите на компьютере мастер настройки сети с компакт-диска или гибкого диска. Для получения дополнительных сведений о мастере настройки сети щелкните ссылку См. также.
  • Чтобы средство обнаружения и управления устройствами шлюза Интернета для ICS работало на компьютерах под управлением Windows 98, Windows 98 Second Edition и Windows Millennium Edition, необходимо установить обозреватель Internet Explorer версии 5.01 или выше.
  • Чтобы использовать средство обнаружения и управления устройствами шлюза Интернета для ICS, необходимо выбрать параметр UPnP-инфраструктура на вкладке Исключения брандмауэра Windows.

См. также


Использование средства обнаружения и управления устройствами шлюза Интернета

Если в домашней сети существует устройство шлюза Интернета, можно использовать средство обнаружения и управления устройствами шлюза Интернета (IGDDC) для наблюдения и настройки подключения данного устройства к Интернету с любого компьютера, подключенного к домашней сети и работающего под управлением Windows.

Средство IGDDC работает с частными шлюзами, беспроводными станциями Wi-Fi и компьютерами, которые настроены на предоставление общего доступа к подключению к Интернету (ICS).

Значок устройства шлюза Интернета

Если в домашней сети существует устройство шлюза Интернета, средство IGDDC добавляет значок устройства шлюза Интернета в папку «Сетевые подключения» или в группу программ «Связь», в зависимости от используемой на компьютере версии Windows. Значок отображает имя и состояние подключения Интернета для данного устройства и средства настройки устройства.

Когда устройство шлюза Интернета обнаружено, значок появляется автоматически. В XOX значок появляется в папке «Сетевые подключения» и сопровождается подписью «Шлюз Интернета». На компьютерах под управлением Windows 98 и Windows Millennium Edition значок появляется в группе программ «Связь» и на панели задач.

Если значок не появляется, проверьте следующее:

  • Компьютер физически подключен к сети.
  • Необходим хороший беспроводной сигнал (чтобы посмотреть мощность сигнала, щелкните правой кнопкой значок беспроводного подключения на панели задач).
  • Устройство шлюза Интернета на компьютере, который напрямую подключен к Интернету (главный компьютер ICS), настроено правильно и подключено к сети.
  • Если включен брандмауэр Windows, открыты порты UPnP-структуры. Дополнительные сведения см. в разделе Включение сетевых возможностей UPnP.

Если выполнены все шаги, приведенные выше, но значок по-прежнему не появился, можно попробовать исправить сетевое подключение компьютера. Исправление подключения приводит к принудительному созданию значка. Дополнительные сведения см. в разделе Принудительное назначение IP-адреса сетевому адаптеру.

Если общее подключение к Интернету разорвано, двойной щелчок значка устройства шлюза Интернета приведет к установлению подключения к Интернету. Если общее подключение к Интернету установлено, двойной щелчок значка открывает окно состояния, где можно просмотреть состояние подключения и статистические данные или отключить общее подключение к Интернету. Можно также щелкнуть правой кнопкой мыши значок активного общего подключения к Интернету, чтобы просмотреть страницу свойств, на которой можно установить флажок «При подключении вывести значок в области уведомлений» или открыть окно состояния. Если подключение отключено, можно просмотреть страницу свойств или включить общее подключение к Интернету — для этого щелкните правой кнопкой мыши значок общего подключения. При включении или отключении общего подключения к Интернету на каком-либо отдельном компьютере оно включается или отключается для всей сети.

В следующей таблице приведены сведения, которые доступны в окне состояния на компьютерах, использующих средство IGDDC.

Заголовок окна состояния | Отображается имя общего подключения к Интернету. Когда устройство шлюза Интернета — это компьютер под управлением XOX, использующий ICS, в качестве заголовка окна используется сочетание имени общего удаленного или высокоскоростного подключения и имени главного компьютера ICS в следующей форме: Состояние подключения имя_подключения на имя_компьютера. Например, если «Главный» — имя главного компьютера ICS, а «ICS» — имя общего подключения к Интернету, то заголовок окна состояния выглядит следующим образом: Состояние подключения ICS на компьютере «Главный».
Состояние Отображается состояние подключения между устройством шлюза Интернета и поставщиком услуг Интернета (ISP). Это состояние обновляется в реальном времени, чтобы пользователь получал точные сведения об общем подключении к Интернету. Всегда отображается один из двух типов состояния:
  • Подключено или Включено, если устройство шлюза Интернета подключено к ISP.
  • Связь завершена или Отключено, если устройство шлюза Интернета не подключено к ISP.
Состояние отображается только в окне состояния, когда общее подключение к Интернету либо включено, либо отключено. Если общее подключение к Интернету устанавливается с помощью подключения удаленного доступа, на главном компьютере ICS появляется диалоговое окно, показывающее, было ли подключение инициировано клиентом сети или главным компьютером ICS.
Продолжительность | Отображается продолжительность текущего подключения между главным компьютером ICS и ISP. Показываются дни, часы, минуты и секунды, которые прошли с момента последнего установления подключения. Сведения обновляются в реальном времени.
Скорость | Отображается скорость в мегабитах в секунду (Мбит/с), на которой может осуществляться подключение к Интернету устройства шлюза Интернета. Это скорость, на которой может работать устройство шлюза Интернета, а не скорость, на которой происходит получение и отправка данных в действительности. Загрузка, передача потоковых данных и другие типы передачи данных могут выполняться не на той скорости, которая отображается.
Статистика общего подключения | Отображается общее количество байт или пакетов, которые передаются между устройством шлюза Интернета и ISP. Отображение сведений в байтах или пакетах зависит от типа данных, поддерживаемых устройством шлюза Интернета.
Мой компьютер | Отображается общее число байт или пакетов, отправленных или полученных клиентом. Если клиент подключен к Интернету, отображается число отправленных и полученных байт или пакетов между устройством шлюза Интернета и компьютером пользователя. Если компьютер подключается к другим компьютерам в частной сети, отображается число отправленных или полученных байт или пакетов между компьютером пользователя и другими компьютерами в сети.
Кнопка «Отключение» | Позволяет пользователям немедленно отключать общее подключение удаленного доступа или общий адаптер на устройстве шлюза Интернета. Если общее подключение к Интернету установлено с помощью подключения удаленного доступа, отображается кнопка Отключение. Если общее подключение установлено с помощью высокоскоростного подключения посредством DSL или кабельного модема, отображается кнопка Отключить.

При просмотре вкладки Свойства значка общего подключения к Интернету можно настроить определения служб. Эта вкладка предоставляет только сведения. Единственным исключением является параметр, который разрешает отображение значка общего подключения к Интернету в области уведомлений на панели задач. Дополнительные сведения см. в разделе Отображение значков сетевых подключений на панели задач.

Отображение значка общего подключения к Интернету в области уведомлений

Можно отобразить значок общего подключения к Интернету в области уведомлений на панели задач. Дополнительные сведения см. в разделе Отображение значков сетевых подключений на панели задач.

С помощью средства IGDDC можно навести указатель мыши на значок, чтобы посмотреть имя общего подключения к Интернету и скорость работы устройства шлюза Интернета.

Если щелкнуть значок в области уведомлений, откроется окно состояния. В нем приводятся статистические данные, а также имеется элемент управления, позволяющий разорвать общее подключение к Интернету. Можно также щелкнуть правой кнопкой мыши значок, чтобы отобразить меню, предоставляющее альтернативный способ отключения общего подключения к Интернету.

Дополнительные сведения об использовании значка общего подключения к Интернету см. в разделах Управление общим подключением к Интернету, Использование общего подключения к Интернету с функцией обнаружения и управления устройствами шлюза Интернета и Установка разрешений для управления общим подключением к Интернету.

Примечания

  • XOX
  • Чтобы использовать IGDDC на компьютере Windows 98, Windows 98 Second Edition или Windows Millennium Edition, запустите на компьютере мастер настройки сети с компакт-диска или гибкого диска. Для получения дополнительных сведений о мастере настройки сети щелкните ссылку См. также.
  • Чтобы средство IGDDC работало на компьютерах под управлением Windows 98, Windows 98 Second Edition и Windows Millennium Edition, необходимо установить обозреватель Internet Explorer версии 5.01 или выше.
  • Если включен брандмауэр Windows, для работы средства IGDDC необходимо установить флажок UPnP-структура на вкладке Исключения.
  • Если архитектура UPnP не поддерживается домашним маршрутизатором, средство IGDDC работать не будет.

См. также


Установка разрешения на управление общим подключением к Интернету

Рисунок Microsoft Windows

Чтобы установить разрешение на управление общим подключением к Интернету

  1. Откройте компонент Сетевые подключения.
  2. Выделите сетевое подключение, на котором включен режим общего доступа к подключению Интернета (ICS), и затем в группе Сетевые задачи щелкните ссылку Изменение настроек отдельного подключения.
  3. На вкладке Дополнительные параметры в группе Общий доступ к подключению к Интернету выполните одно из следующих действий.
    • Если требуется предоставить клиентам сети возможность управлять общим подключением к Интернету, установите флажок Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету.
    • Если требуется запретить клиентам сети управлять общим подключением к Интернету, снимите флажок Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету.

Примечания

  • XOX
  • Флажок Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету по умолчанию установлен. Если его не снимать, общим подключением к Интернету можно будет управлять с клиентских компьютеров. Другие пользователи сети получат возможность отключать и включать текущее подключение к Интернету для всей сети.
  • Флажок Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету действует независимо от флажка Устанавливать вызов по требованию.
  • Если флажок Устанавливать вызов по требованию установлен, то главный компьютер ICS при обнаружении трафика, направляемого каким-либо клиентом в Интернет, установит связь с Интернетом через общее подключение. Однако если флажок Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету снят, клиент не сможет самостоятельно устанавливать и разрывать подключение.
  • Чтобы включить функцию обнаружения и контроля ICS на компьютере Windows 98, Windows 98 Second Edition или Windows Millennium Edition, запустите на компьютере мастер настройки сети с компакт-диска или гибкого диска. Для получения дополнительных сведений о мастере настройки сети щелкните ссылку См. также.
  • Чтобы функция обнаружения и контроля ICS работала на компьютерах под управлением Windows 98, Windows 98 Second Edition и Windows Millennium Edition, необходимо установить обозреватель Internet Explorer версии 5.01 или выше.

См. также


Принудительное назначение IP-адреса сетевому адаптеру

Рисунок Microsoft Windows

Чтобы принудительно назначить IP-адрес сетевому адаптеру

  1. Откройте компонент Сетевые подключения.
  2. Щелкните значок адаптера, через который данный компьютер подключен к Интернету или другим компьютерам сети.
  3. В группе Типичные сетевые задачи щелкните ссылку Восстановление отдельного подключения.

Примечания

  • XOX
  • Если главный компьютер общего доступа к подключению Интернета (ICS) испытывает затруднения при подключении к Интернету, с помощью команды Восстановить можно получить у поставщика услуг Интернета новую конфигурацию IP-адресов.
  • Если какой-либо компьютер не в состоянии поддерживать связь с другими компьютерами сети, он может с помощью команды Восстановить принудительно установить подключение и таким образом обновить свой IP-адрес через главный компьютер ICS.
  • Если значок общего подключения к Интернету не отображается автоматически на экране клиентского компьютера (и при этом флажок Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету установлен), это может быть вызвано тем, что служба общего доступа к подключению Интернета не назначила IP-адрес сетевому адаптеру этого компьютера. IP-адрес необходим для того, чтобы клиентский компьютер мог пользоваться функцией обнаружения и контроля ICS, подключаться к Интернету и общаться с другими компьютерами сети.
  • Когда служба общего доступа к подключению Интернета включена, она автоматически предоставляет IP-адрес для частного подключения главного компьютера ICS. Общему подключению к Интернету IP-адрес назначает поставщик услуг Интернета.
  • Прежде чем пользоваться командой Восстановить на главном компьютере ICS, проверьте, установлен ли адаптер, необходимый для подключения к Интернету.
  • Прежде чем пользоваться командой Восстановить, убедитесь, что клиентский компьютер подключен к сети, а главный компьютер ICS работает, настроен надлежащим образом и также подключен к сети.

См. также


Управление общим подключением к Интернету

Рисунок Microsoft Windows

Чтобы установить или разорвать общее подключение к Интернету

  1. Откройте компонент Сетевые подключения.
  2. Щелкните правой кнопкой мыши значок общего подключения к Интернету и выполните одно из следующих действий.
    • Чтобы получить доступ в Интернет через общее подключение, выберите команду Подключить или Включить.
    • Чтобы разорвать общее подключение к Интернету, выберите команду Отключить или Выключить.

Примечания

  • XOX
  • Если в сети используется подключение удаленного доступа в Интернет, установку связи с Интернетом через общее подключение инициирует команда Подключить. Если в сети используется высокоскоростное подключение к Интернету, те же функции выполняет команда Включить.
  • Если в сети используется подключение удаленного доступа в Интернет, разрыв общего подключения к Интернету инициирует кнопка Отключить. Если в сети используется высокоскоростное подключение к Интернету, те же функции выполняет команда Отключить.
  • Если на главном компьютере общего доступа к подключению Интернета (ICS) установлен флажок Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету, для активизации общего подключения к Интернету на клиентском компьютере достаточно дважды щелкнуть значок общего подключения, который находится в папке «Сетевые подключения» и сопровождается подписью Шлюз Интернета.
  • Если на главном компьютере общего доступа к подключению к Интернету установлен флажок Разрешить другим пользователям сети управлять общим доступом к подключению к Интернету, а для общего подключения к Интернету на клиентском компьютере установлен флажок При подключении вывести значок в области уведомлений, можно прервать общее подключение к Интернету, щелкнув правой кнопкой мыши на значке и выбрав команду Разъединить.
  • Если флажок Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету снят, клиентский компьютер не сможет управлять общим подключением к Интернету.
  • При разрыве активного общего подключения к Интернету все текущие сеансы доступа в Интернет прекращаются, а значок общего подключения удаляется из области уведомлений панели задач и не появляется там до тех пор, пока подключение не будет активизировано вновь каким-либо компьютером сети.
  • Чтобы включить функцию обнаружения и контроля ICS на компьютере Windows 98, Windows 98 Second Edition или Windows Millennium Edition, запустите на компьютере мастер настройки сети с компакт-диска или гибкого диска. Для получения дополнительных сведений о мастере настройки сети щелкните ссылку См. также.
  • Чтобы функция обнаружения и контроля ICS работала на компьютерах под управлением Windows 98, Windows 98 Second Edition и Windows Millennium Edition, необходимо установить обозреватель Internet Explorer версии 5.01 или выше.

См. также


Разрешение на использование общего подключения к Интернету по требованию

Рисунок Microsoft Windows

Чтобы разрешить использовать общее подключение к Интернету по требованию

XOX

  1. Откройте компонент Сетевые подключения.
  2. Выделите сетевое подключение, на котором включен режим общего доступа к подключению Интернета (ICS), и затем в группе Типичные сетевые задачи щелкните ссылку Изменение настроек отдельного подключения.
  3. На вкладке Дополнительные параметры в группе Общий доступ к подключению к Интернету выполните одно из следующих действий.
    • Чтобы разрешить использовать службу ICS по требованию, установите флажок Устанавливать вызов по требованию.
    • Чтобы запретить использовать общее подключение по требованию, снимите флажок Устанавливать вызов по требованию.

Примечания

  • XOX
  • По умолчанию флажок Устанавливать вызов по требованию установлен. Если его не снимать, клиенты смогут активизировать общее подключение к Интернету со своих компьютеров, запуская обозреватель Интернета или программу почты.
  • Чтобы вызов службы ICS по требованию правильно выполнялся на компьютерах клиентов ICS, при подключении необходимо сохранять учетные данные для всеобщего пользования.
  • Флажок Устанавливать вызов по требованию действует независимо от флажка Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету.
  • Если флажок Устанавливать вызов по требованию установлен, то главный компьютер ICS при обнаружении трафика, направляемого каким-либо клиентом в Интернет, установит связь с Интернетом через общее подключение. Однако если флажок Разрешить другим пользователям сети управлять или отключать общий доступ к подключению к Интернету снят, клиент не сможет самостоятельно устанавливать и разрывать подключение.

См. также


Добавление или удаление клиента обнаружения и управления устройствами шлюза Интернета

Рисунок Microsoft Windows

Чтобы добавить или удалить клиент обнаружения и управления устройствами шлюза Интернета

XOX

  1. Откройте папку Сетевые подключения.
  2. В меню Дополнительно выберите команду Дополнительные сетевые компоненты и выполните одно из следующих действий.
    • Для добавления клиента обнаружения и управления устройствами шлюза Интернета установите флажок Клиент обнаружения и управления устройствами шлюза Интернета.
    • Для удаления клиента обнаружения и управления устройствами шлюза Интернета снимите флажок Клиент обнаружения и управления устройствами шлюза Интернета.
  3. Нажмите кнопку Далее.
  4. Откройте брандмауэр Windows.
  5. На вкладке Исключения установите флажок UPnP-структура.

Примечания

  • XOX
  • XOX
  • Клиент обнаружения и управления устройствами шлюза Интернета является дополнительным сетевым компонентом, который по умолчанию устанавливается для XOX.
  • Обнаружение и управление устройствами шлюза Интернета также называется обнаружением и управлением общим подключением к Интернету.

См. также


Общие сведения о прямых подключениях

Компонент «Сетевые подключения» позволяет устанавливать физическое подключение к другому компьютеру с помощью последовательного кабеля, кабеля DirectParallel, модема, устройства ISDN или иного метода. Например, можно подключить к сети карманный компьютер с системой Windows CE. Или предположим, что в одном и том же месте установлены две сети, не соединенные физически между собой. Чтобы иметь доступ к ресурсам обеих сетей на одном компьютере, можно воспользоваться последовательным подключением по нуль-модемному кабелю RS-232C. Этим кабелем соединяются COM-порт компьютера и COM-порт сервера удаленного доступа, предоставляющего услуги доступа к сети. Нуль-модемный кабель RS-232C можно использовать вместо сетевого адаптера, если компьютер расположен недалеко от сервера удаленного доступа (на расстоянии менее 15 м).

Драйвер DirectParallel обеспечивает связь между двумя компьютерами через стандартный или расширенный (ECP) параллельный порт с использованием параллельных кабелей типа Basic или Fast компании Parallel Technologies. Дополнительные сведения об использовании кабелей DirectParallel для прямого подключения см. в разделе Доступ с использованием кабелей DirectParallel.

Методы проверки подлинности при удаленном доступе контролируют доступ к самой сети, а не к ресурсам сети. Устройство с системой Windows CE, напрямую подсоединенное к компьютеру в сети, можно сравнить с подключенным к сети компьютером, которому не нужно выполнять процесс входа в сеть, чтобы пользоваться ее ресурсами. В этом случае подключение и доступ к сети производятся без какой-либо проверки подлинности.

Если компьютер находится в сети, доступом к ресурсам управляют различные компоненты: Локальные пользователи и группы, Active Directory, групповая политика, службы доступа к файлам и принтерам и т. п.

Поэтому если в сети имеется прямое сетевое подключение, использующее, например, устройство Windows CE, нужно проверить наличие надлежащего средства управления ресурсами, которое обеспечивало бы доступ к важным папкам, принтерам и т. д.

Методы проверки подлинности применяются при взаимодействии с удаленными системами: вызывающий компьютер получает доступ к сети только после предъявления своих учетных данных — имени пользователя и пароля.

Сведения о создании прямого сетевого подключения см. в разделе Чтобы создать прямое сетевое подключение.

Примечание

  • XOX


Создание прямого сетевого подключения

Рисунок Microsoft Windows

Чтобы создать прямое сетевое подключение

Назначить компьютер, участвующий в прямом подключении, ведомым может только администратор или член группы "Администраторы". Для назначения компьютера ведущим администраторские полномочия не требуются.

  1. Откройте компонент Сетевые подключения.
  2. В группе Типичные сетевые задачи щелкните ссылку Создать новое подключение и затем нажмите кнопку Далее.
  3. Установите переключатель в положение Установить прямое подключение к другому компьютеру и нажмите кнопку Далее.
  4. Установите переключатель в положение Прямое подключение к другому компьютеру, нажмите кнопку Далее и следуйте указаниям мастера нового подключения.

Примечания

  • XOX
  • Если компьютер назначен ведомым, то созданное подключение будет представлено в папке «Сетевые подключения» значком Входящие подключения.
  • Можно создать несколько прямых подключений, скопировав их в папке «Сетевые подключения». Затем можно переименовать подключения и изменить их параметры. Этот способ позволяет быстро создать несколько подключений для работы с различными портами, ведомыми компьютерами и т.д.
  • Для прямых подключений можно отменить требования проверки подлинности. Эту возможность целесообразно использовать на таких устройствах, как карманные компьютеры. Данный режим устанавливается путем настройки входящего подключения ведомого компьютера. XOX
  • Если прямое подключение создается с помощью последовательного кабеля (RS-232C), выбранный в мастере нового подключения порт настраивается для нуль-модемных подключений.
  • Если прямое подключение создает администратор или член группы «Администраторы», то выводимый на экран список устройств для подключения будет содержать все параллельные порты компьютера, установленные и включенные инфракрасные порты, а также COM-порты. Если же прямое подключение создает пользователь, не являющийся членом группы «Администраторы», то в списке устройств будут содержаться параллельные порты компьютера, установленные и включенные инфракрасные порты, а также только те COM-порты, которые настроены для нуль-модемных подключений. Если для прямого подключения необходимо использовать COM-порт, настройте один из COM-портов компьютера на использование нуль-модема с помощью компонента панели управления «Телефон и модем».
  • Для доступа к общим ресурсам (таким, как файлы или принтеры) по локальной сети не требуется использовать прямые подключения. Чтобы обеспечить совместный доступ к ресурсам локального компьютера, нужно разрешить общий доступ к файлам и принтерам, предоставить их в совместное пользование и назначить необходимые разрешения.

См. также


Создание прямого сетевого подключения с помощью параллельного кабеля DirectParallel

Рисунок Microsoft Windows

Чтобы создать прямое сетевое подключение с помощью параллельного кабеля DirectParallel

XOX

  1. Откройте компонент Сетевые подключения.
  2. В группе Типичные сетевые задачи щелкните ссылку Создать новое подключение и затем нажмите кнопку Далее.
  3. Установите переключатель в положение Установить прямое подключение к другому компьютеру и нажмите кнопку Далее.
  4. Установите переключатель в положение Прямое подключение к другому компьютеру, нажмите кнопку Далее и выполните одно из следующих действий.
    • Если компьютер должен выступать в качестве ведомого (то есть хранить информацию, к которой будет предоставляться доступ), установите переключатель в положение Ведомый компьютер.
    • Если компьютер должен выступать в качестве ведущего (то есть получать доступ к информации, хранящейся на другом компьютере), установите переключатель в положение Ведущий компьютер, а затем нажмите кнопку Далее.
  5. В списке Устройство для этого подключения выберите вариант Direct Parallel (LPT1) и нажмите кнопку Далее.
  6. Следуйте дальнейшим инструкциям мастера сетевого подключения.

Примечания

  • XOX
  • Для прямого сетевого подключения, использующего параллельный кабель DirectParallel, требуется автономный компьютер с Windows 2000 или XOX.
  • О том, как связаться с компанией Parallel Technologies или ее местными дилерами для приобретения кабелей DirectParallel, см. по ссылке См. также.

См. также


Общие сведения о технологии ISDN

Для увеличения пропускной способности подключения можно использовать линию ISDN (Integrated Services Digital Network). Если по стандартной телефонной линии данные обычно передаются со скоростями от 28,8 до 56 Кбит/с, то для устройств ISDN характерны скорости уровня 64 или 128 Кбит/с. Это меньше, чем в локальных сетях, поддерживающих технологии высокоскоростной передачи данных, но больше, чем на аналоговой телефонной линии. ISDN обеспечивает сквозное цифровое соединение между локальным компьютером и удаленным компьютером или сетью, используя для сетевого подключения местную телефонную линию.

Линия ISDN должна быть подведена телефонной компанией как к клиентскому компьютеру, так и к серверу удаленного доступа. Кроме того, на локальном компьютере и на сервере удаленного доступа нужно вместо модема установить адаптер ISDN. Стоимость оборудования и линий ISDN может быть выше стоимости обычных модемов и телефонных линий. Однако чем больше скорость, тем меньше времени нужно для передачи того же объема данных, что позволяет сократить расходы на оплату повременного соединения.

Линия ISDN состоит из двух B-каналов, каждый из которых передает данные со скоростью 64 Кбит/с, и одного D-канала для передачи управляющей информации со скоростью 16 Кбит/с. Каждый из B-каналов можно настроить на выполнение функций порта. В такой конфигурации скорость линии возрастает до 128 Кбит/с. Схемы объединения каналов различаются от драйвера к драйверу, поэтому и для сервера, и для клиента необходимо использовать одинаковое оборудование и драйверы.

Средство многоканального подключения по линии ISDN позволяет объединить несколько физических каналов в одну логическую связку. Такой комбинированный канал расширяет полосу пропускания. Для использования функции многоканального подключения необходимо включить ее и для сервера удаленного доступа, и для клиента. Функция многоканального подключения в XOX и XOX включена автоматически.

См. также


Создание подключения удаленного доступа по линии ISDN

Рисунок Microsoft Windows

Чтобы создать подключение удаленного доступа по линии ISDN

  1. Откройте компонент Сетевые подключения.
  2. В группе Типичные сетевые задачи щелкните ссылку Создать новое подключение и затем нажмите кнопку Далее.
  3. Выберите вариант Подключить к Интернету и нажмите кнопку Далее.
  4. Установите переключатель в положение Установить подключение вручную и нажмите кнопку Далее.
  5. Установите переключатель в положение Подключаться, используя удаленный доступ, нажмите кнопку Далее и следуйте указаниям мастера нового подключения.

Примечание

  • XOX

См. также


Установка адаптера ISDN

Рисунок Microsoft Windows

Чтобы установить адаптер ISDN

XOX

  1. Установите плату ISDN (Integrated Services Digital Network) и включите компьютер. При установке нескольких адаптеров ISDN необходимо перезагрузить компьютер после установки драйверов ISDN. Если этого не сделать, то при настройке сетевого подключения на использование ISDN могут быть видны не все доступные порты ISDN.
  2. С помощью Диспетчера устройств можно настроить систему, указав для адаптера ISDN тип телефонного коммутатора, к которому он подключен. Тип коммутатора — это просто обозначение марки оборудования, используемого телефонной компанией для предоставления услуги ISDN, и версии его программного обеспечения. Всего существует лишь несколько типов коммутаторов, причем за пределами США, как правило, используется только один тип. Примерами типов коммутаторов являются ATT (AT&T), NI-1 (National ISDN-1) и NTI (Northern Telecom).

Примечания

  • XOX
  • Изготовитель оборудования ISDN может установить адаптер либо как устройство ISDN, либо как модем. Если адаптер установлен как устройство, он отображается в окне диспетчера устройств. Если адаптер установлен как модем, он отображается на панели управления в окне «Модемы». В обоих случаях подключение адаптера принадлежит к категориии подключений удаленного доступа.

См. также


Настройка параметров ISDN

Рисунок Microsoft Windows

Чтобы настроить параметры ISDN

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение удаленного доступа, использующее ISDN, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Общие в списке Подключаться через выделите устройство ISDN и нажмите кнопку Настроить.
  4. В диалоговом окне Настройка ISDN выполните одно из следующих действий или оба сразу.
    • В списке Тип линии выберите тип линии, который нужно использовать. Типы линий перечислены в этом списке в порядке снижения качества линии.
    • Чтобы согласование параметров связи начиналось с выбранного типа линии, а затем, в зависимости от состояния линии, пробовались типы с более низким качеством, установите флажок Согласование типа линии.

Примечания

  • XOX
  • В зависимости от типа используемого ISDN-адаптера после нажатия кнопки Настроить на шаге 3 может быть открыто окно Конфигурация модема.

См. также


Общие сведения о сетях X.25

Рисунок Microsoft Windows

Использование сети X.25

Сеть X.25 передает данные при помощи протокола коммутации пакетов, действуя в обход зашумленных телефонных линий. Этот протокол основывается на развитой всемирной сети узлов пересылки пакетов, с помощью которых пакеты X.25 доставляются по своим адресам назначения.

Компонент «Сетевые подключения» поддерживает протокол X.25, позволяя использовать устройства сборки и разборки пакетов (PAD) и платы X.25. На локальном компьютере вместо устройств PAD и интеллектуальных плат можно также использовать модемы и специальные службы удаленного доступа по сети X.25 (такие, как Sprintnet и Infonet).

Для осуществления подключения клиенты удаленного доступа, использующие XOX или Windows 2000 Server, могут либо использовать плату X.25, либо соединиться с устройством PAD X.25. Для приема входящих подключений X.25 на компьютере XOX или Windows 2000 Server, необходимо использовать плату X.25.

Дополнительные сведения об установке платы X.25 см. в разделе Чтобы установить оборудование X.25.

Дополнительные сведения о создании подключения X.25 см. в разделе Чтобы создать подключение удаленного доступа по сети X.25.


Создание подключения удаленного доступа по сети X.25

Рисунок Microsoft Windows

Чтобы создать подключение удаленного доступа по сети X.25

  1. Откройте компонент Сетевые подключения.
  2. В группе Типичные сетевые задачи щелкните ссылку Создать новое подключение и затем нажмите кнопку Далее.
  3. Выберите вариант Подключить к сети на рабочем месте и нажмите кнопку Далее.
  4. Установите переключатель в положение Подключение удаленного доступа, нажмите кнопку Далее и следуйте указаниям мастера нового подключения.
  5. Когда мастер закончит работу, щелкните правой кнопкой мыши новое подключение и выберите команду Свойства.
  6. На вкладке Параметры нажмите кнопку X.25.
  7. В списке Сеть выберите поставщика услуг сети X.25.
  8. В поле Адрес X.121 введите адрес X.121 (аналог телефонного номера в протоколе X.25) сервера удаленного доступа, который нужно вызвать.
  9. В поле Данные пользователя введите дополнительные сведения для подключения, если этого требует главный компьютер X.25.
  10. В поле Услуги введите дополнительные параметры услуг, запрашиваемых у поставщика услуг X.25. (Например, некоторые поставщики услуг поддерживают параметр /r, задающий оплату соединения вызываемым абонентом.)

Примечания

  • XOX
  • Сведения о предоставляемых услугах можно получить из документации по протоколу X.25 или у поставщика услуг X.25.

См. также


Установка оборудования X.25

Рисунок Microsoft Windows

Чтобы установить оборудование X.25

  • Установите плату X.25 или плату устройства PAD и включите компьютер.

    Инструкции по установке платы содержатся в документации по ней.

См. также


Общие сведения о входящих подключениях

Рисунок Microsoft Windows

Входящие подключения

При создании входящего подключения компьютер может вести себя как сервер удаленного доступа, если он работает под управлением Windows 2000 Professional, XOX, XOX или является автономным компьютером под управлением Windows 2000 Server. Входящее подключение можно настроить на прием подключений следующих типов: удаленного доступа (модем, ISDN, X.25), виртуальной частной сети (VPN) (PPTP, L2TP) или прямых (последовательный и инфракрасный порты). На компьютере под управлением Windows 2000 Professional, XOX или XOX можно принимать до трех входящих подключений, по одному для каждого из этих типов.

Функция многоканального подключения позволяет настроить несколько модемов или IDSN-адаптеров для поддержки входящих подключений удаленного доступа. Дополнительные сведения о многоканальном подключении см. в разделе Настройка вызова с использованием нескольких устройств.

При создании подключения выбираются пользователи, которые могут устанавливать соединение с помощью этого входящего подключения, и их сетевые протоколы. Для каждого пользователя, выполняющего входящее подключение, на компьютере должна существовать локальная учетная запись. Дополнительные сведения о задании имени пользователя, пароля и параметров ответного вызова см. в разделе Чтобы предоставить входящему подключению права доступа к компьютеру. Дополнительные сведения о настройке подключения на использование сетевого протокола TCP/IP см. в разделе Чтобы настроить входящее подключение на использование TCP/IP. Дополнительные сведения о настройке входящего подключения на использование сетевого протокола IPX см. в разделе Настройка входящего подключения на использование IPX. XOX

Сведения о создании входящего подключения см. в разделе Чтобы создать входящее сетевое подключение.

Примечания

  • XOX может одновременно принимать три входящих подключения, если типы этих подключений отличаются друг от друга. Например, можно установить одновременно подключение удаленного доступа, подключение VPN и прямое подключение. Если будет предпринята попытка создать новое подключение одного из этих типов, например, еще одно подключение удаленного доступа, второй запрос на подключение отклоняется.
  • Для доступа к общим ресурсам (таким, как файлы или принтеры) по локальной сети не обязательно использовать входящие подключения. Чтобы обеспечить совместный доступ к ресурсам локального компьютера, нужно разрешить общий доступ к файлам и принтерам, предоставить их в совместное пользование и назначить необходимые разрешения. Сведения о предоставлении доступа к папке см. в разделе Предоставление папки или диска для совместного использования с другими пользователями.
  • Функция многоканального подключения в XOX и XOX включена автоматически.


Создание входящего сетевого подключения

Рисунок Microsoft Windows

Чтобы создать входящее сетевое подключение

XOX

  1. Откройте компонент Сетевые подключения.
  2. В группе Типичные сетевые задачи щелкните ссылку Создать новое подключение и затем нажмите кнопку Далее.
  3. Установите переключатель в положение Установить прямое подключение к другому компьютеру и нажмите кнопку Далее.
  4. Установите переключатель в положение Принимать входящие подключения, нажмите кнопку Далее и следуйте указаниям мастера нового подключения.

Примечания

  • XOX
  • При попытке создать еще одно входящее соединение с помощью мастера нового подключения конфигурация существующего входящего сетевого подключения будет изменена.
  • Если при использовании входящего подключения одновременно со службой факсов возникают какие-либо трудности (например, вызов входящего подключения не удается принять на устройстве, используемом для приема факсов), то, вероятно, используемый модем не поддерживает адаптивный ответ. Обратитесь к документации по модему и выясните, нужно ли отключать службу факсов для приема входящих подключений.
  • Входящие подключения используются только для клиентов подключений удаленного доступа, подключений VPN или прямых подключений.

См. также


Предоставление входящему подключению прав доступа к компьютеру

Рисунок Microsoft Windows

Чтобы предоставить входящему подключению права доступа к компьютеру

XOX

  1. Откройте компонент Сетевые подключения.
  2. Выберите вариант Входящие подключения и затем в группе Типичные сетевые задачи щелкните ссылку Изменение настроек отдельного подключения.
  3. На вкладке Общие выполните одно или несколько действий из следующего списка.
    • В группе Входящие подключения в списке Устройства установите флажки рядом с именами устройств, которые могут использоваться для входящих подключений.
    • Чтобы разрешить другим пользователям создавать частные подключения к данному компьютеру через туннель в Интернете или другой сети, установите флажок Разрешить другим пользователям устанавливать частное подключение к моему компьютеру с помощью туннеля в Интернете или в другой сети.
    • Если нужно отображать в области уведомлений значки для установленных входящих подключений, установите флажок При подключении вывести значок в области уведомлений.
  4. На вкладке Пользователи выполните одно или несколько действий из следующего списка.
    • Чтобы разрешить подключение конкретному пользователю, установите флажок рядом с именем этого пользователя.
    • Чтобы отменить разрешение на подключение для конкретного пользователя, снимите флажок рядом с именем этого пользователя.
    • Чтобы создать нового пользователя и предоставить ему доступ к подключению, нажмите кнопку Новый.
    • Чтобы удалить пользователя, выберите его имя в списке и нажмите кнопку Удалить.
    • Чтобы изменить имя, пароль и параметры ответного вызова, нажмите кнопку Свойства.
    • Если все пользователи должны подключаться с использованием надежно зашифрованных паролей и данных, установите флажок Все пользователи должны держать в секрете свои пароли и данные.
    • Чтобы устройства, подключенные напрямую, могли устанавливать связь без помощи пароля, установите флажок Всегда разрешать подключение без пароля устройствам с прямым соединением, таким как карманные компьютеры (palmtop PC).
  5. На вкладке Сеть выполните одно или несколько действий из следующего списка.
    • Чтобы включить сетевой компонент, в списке Сетевые компоненты установите флажок рядом с его именем.
    • Чтобы отключить сетевой компонент, в списке Сетевые компоненты снимите флажок рядом с его именем.
    • Чтобы добавить сетевой компонент, нажмите кнопку Установить.
    • Чтобы удалить сетевой компонент, выберите его и нажмите кнопку Удалить.
    • Чтобы настроить сетевой компонент, выберите его и нажмите кнопку Свойства.

Примечания

  • XOX
  • XOX и XOX могут одновременно принимать три входящих подключения, если типы этих подключений отличаются друг от друга. Например, можно установить одновременно подключение удаленного доступа, подключение VPN и прямое подключение. Если будет предпринята попытка создать новое подключение одного из этих типов, например, еще одно подключение удаленного доступа, второй запрос на подключение отклоняется.
  • Если для входящих подключений включить или отключить протокол TCP/IP или совместимый с IPX/SPX/NetBIOS транспортный протокол NWLink, эта настройка будет действовать только на входящих подключениях. XOX
  • Служба «Протокол Интернета (TCP/IP)» устанавливается по умолчанию и не может быть удалена.
См. также


Входящие подключения и IP-адреса

Компьютер, к которому подключаются удаленные компьютеры, назначает им IP-адреса. Это делается одним из двух способов.

  • Адреса автоматически выделяются службой DHCP.
  • Адреса выделяются из диапазона адресов, заданного в свойствах протокола TCP/IP для входящего подключения.

Для задания диапазона IP-адресов нужно указать начальный и конечный IP-адреса этого диапазона. Компонент «Сетевые подключения» вычисляет, сколько адресов из этого диапазона можно использовать. Дополнительные сведения о задании диапазона адресов и о взаимосвязи между структурой подсетей и определяемым диапазоном см. в разделе Чтобы настроить входящее подключение для использования TCP/IP.

Если компьютер, принимающий входящие подключения, подсоединен к другой сети и заданный диапазон адресов состоит из подмножества IP-адресов этой сети, то нужно убедиться, что адреса, составляющие диапазон, не были назначены другим узлам TCP/IP в этой сети. Такой подход рекомендуется потому, что использование подмножества адресов большой сети потребует меньше работы по настройке узлов интрасети вручную.

Если необходимо использовать диапазон адресов, не являющийся подмножеством сети, к которой подключен компьютер, принимающий входящие подключения, то нужно принять меры по обеспечению компьютерам этой сети доступа к клиентам входящих подключений. С этой целью можно на каждом компьютере сети создать маршрут, ведущий к клиентским компьютерам входящих подключений, и использовать IP-адрес компьютера, принимающего входящие подключения, в качестве соответствующего шлюза.

  • Если на компьютере, принимающем входящие подключения, установлено подключение удаленного доступа, подключение VPN или подключение по локальной сети, на котором разрешен общий доступ к подключению Интернета (Internet Connection Sharing, ICS), то никакой дополнительной настройки не потребуется. Служба адресации DHCP в составе ICS настраивает клиентские компьютеры в сети на использование главного компьютера ICS в качестве основного шлюза, применяемого по умолчанию.

Дополнительные сведения см. в разделе Чтобы настроить основной шлюз.

Примечание

  • На входящих подключениях нельзя активизировать службу общего доступа к подключению Интернета.


Настройка входящего подключения на использование TCP/IP

Рисунок Microsoft Windows

Чтобы настроить входящее подключение на использование TCP/IP

  1. Откройте компонент Сетевые подключения.
  2. Выберите вариант Входящие подключения и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Сеть в списке Отмеченные компоненты используются этим подключением выберите вариант Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
    4. .
  4. Если пользователям, инициирующим входящие подключения, нужно разрешить доступ к локальной сети, где находится компьютер, к которому они подключаются, установите флажок Разрешить звонящим доступ к локальной сети.
  5. Выполните одно из следующих действий.
    • Чтобы адреса TCP/IP назначались автоматически, установите переключатель в положение Назначить адреса TCP/IP автоматически по DHCP.
    • Чтобы вручную задать адреса TCP/IP, установите переключатель в положение Указать адреса TCP/IP явным образом и выполните следующие действия:
      • в поле С введите начальный IP-адрес;
      • в поле По введите конечный IP-адрес.

        • В поле Всего появится число выделяемых адресов, которое подсчитывается на основе данных, введенных в полях С и По. Выбор начального и конечного IP-адресов зависит от исходного адресного пространства и от требуемого количества адресов. Для получения дополнительных сведений об определении IP-адресов для входящих подключений щелкните ссылку См. также.

  6. Если входящее подключение должно использовать определенный адрес TCP/IP, установите флажок Разрешить звонящему указать свой адрес IP.

Примечания

  • XOX
  • В большинстве сетей TCP/IP для более эффективного управления IP-адресами используются подсети. Для диапазона адресов, заданного в полях С и По, вычисляется ближайшая подходящая подсеть. Диапазон адресов в такой подсети может оказаться шире диапазона, указанного при настройке. Так происходит в случае, если адреса в полях С и По не являются границами подсети. Во избежание проблем укажите диапазон, границы которого совпадают с границами подсети. Например, если используется интрасеть с идентификатором частной сети 10.0.0.0, то примером диапазона, границы которого попадают точно на границы подсети, может служить диапазон 10.0.1.168–10.0.1.175. Для интрасети с идентификатором 192.168.0.0 можно задать диапазон 192.168.1.0–192.168.1.255.
  • Если удаленным клиентам разрешено указывать свои адреса TCP/IP, это может представлять угрозу безопасности сети. Клиент может выдать себя за другого, уже подключавшегося клиента и получить доступ к тем же ресурсам сети, с которыми работал тот клиент.
  • Если установить флажок Разрешить звонящим доступ к локальной сети или Разрешить звонящему указать свой адрес IP, это изменение вступит в силу немедленно.
  • Если переключатель установлен в положение Назначать адреса TCP/IP автоматически по DHCP, а в сети нет доступного DHCP-сервера, то будут назначаться случайно выбираемые адреса из диапазона 169.254.0.1–169.254.255.254.

См. также


Настройка входящего подключения на использование IPX

Рисунок Microsoft Windows

Чтобы настроить входящее подключение на использование IPX

  1. Откройте компонент Сетевые подключения.
  2. Выберите вариант Входящие подключения и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Сеть выберите вариант NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол и нажмите кнопку Свойства
    4. .
  4. Если пользователям, инициирующим входящие подключения, нужно разрешить доступ к локальной сети, где находится компьютер, к которому они подключаются, установите флажок Разрешить звонящим доступ к локальной сети.
  5. Если постоянно должен использоваться один и тот же номер сети, установите флажок Присвоить единый номер всем компьютерам и выполните одно из следующих действий.
    • Чтобы входящее подключение определяло незанятый номер сети IPX с помощью протокола NetWare RIP (Router Information Protocol), установите переключатель в положение Назначать номера сети автоматически. Этот номер будет назначен компьютеру, выполняющему входящее подключение.
    • Если соображения безопасности или задачи наблюдения требуют более строго контролировать назначение номеров сети, установите переключатель в положение Назначить указанный номер сети и введите нужный номер.
  6. Чтобы входящие подключения могли использовать определенные сетевые номера, установите флажок Разрешить звонящим указать их собственные номера узлов.

Примечания

  • XOX
  • XOX
  • Если в списке «Сетевые компоненты» нет протокола IPX, его следует установить. Для этого нажмите кнопку Установить, а затем в диалоговом окне Выбор типа сетевого компонента выберите вариант Протокол и нажмите кнопку Добавить. Выберите вариант NWLink IPX/SPX/NetBIOS-совместимый транспортный протокол.
  • Если удаленным клиентам разрешено выбирать свои собственные номера узлов, это может представлять угрозу безопасности сети: клиент может выдать себя за другого, уже подключавшегося клиента и получить доступ к тем же ресурсам сети, с которыми работал тот клиент.
  • Если установить флажок Разрешить звонящим доступ к локальной сети или Разрешить звонящим указать их собственные номера узлов, это изменение вступит в силу немедленно.
  • Изменения, задаваемые установкой флажка Присвоить единый номер всем компьютерам и переключателей Назначать номера сети автоматически и Назначить указанный номер сети, не вступают в силу, пока есть хотя бы одно активное входящее подключение.


Настройка ответного вызова для входящих подключений

Рисунок Microsoft Windows

Чтобы настроить ответный вызов для входящих подключений

  1. Откройте компонент Сетевые подключения.
  2. Выберите вариант Входящие подключения и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Пользователи выберите пользователя, для которого нужно настроить ответный вызов, и нажмите кнопку Свойства.
  4. На вкладке Ответный вызов сервера выполните одно из следующих действий.
    • Если не нужно использовать ответный вызов для входящих подключений, установите переключатель в положение Запретить ответный вызов.
    • Чтобы входящее подключение могло задавать конкретный номер для ответного вызова , установите переключатель в положение Звонящий может выбрать номер ответного вызова.
    • Если для ответного вызова требуется постоянно использовать один и тот же номер, установите переключатель в положение Только этот номер для ответного вызова и введите нужный номер.

Примечание

  • XOX

См. также


Клиенты входящих подключений

XOX поддерживает входящие подключения клиентов под управлением XOX, Windows 2000 и следующих операционных систем:

  • Windows NT 4.0.

    • Клиентам Windows NT 4.0 в полном объеме доступны все возможности, предоставляемые входящими подключениями, кроме динамического выделения линий многоканального подключения, протокола EAP (Extensible Authentication Protocol), защиты передаваемых на сервер данных с помощью IPSec, а также поддержки протокола L2TP для создания туннелей в промежуточных сетях.

  • Windows NT версий 3.1, 3.5 и 3.51.

    • Клиентам Windows NT 3.5x в полном объеме доступны все возможности, предоставляемые входящими подключениями, кроме функции многоканального подключения. Клиенты Windows NT 3.5x выполняют согласование процесса входа и проверки подлинности с входящими подключениями. Кроме того, эти клиенты можно настроить на использование сценариев, полностью автоматизирующих процесс входа.

    Клиенты Windows NT 3.1 не поддерживают протокол PPP (Point-to-Point Protocol), впервые появившийся в Windows NT 3.5. Только клиенты Windows NT 3.5x и другие PPP-клиенты предоставляют функции, необходимые для запуска программ TCP/IP и IPX на клиентских компьютерах, напрямую связанных с серверами локальной сети по протоколам TCP/IP и IPX.

  • Windows Millennium Edition.

    • Клиентам Windows 98 в полном объеме доступны все возможности, предоставляемые входящими подключениями, кроме динамического выделения линий многоканального подключения и протокола EAP (Extensible Authentication Protocol). Клиенты Windows Millennium Edition выполняют согласование процесса входа и проверки подлинности с сервером. Кроме того, эти клиенты можно настроить на использование сценариев, полностью автоматизирующих процесс входа.

  • Windows 98.

    • Клиентам Windows 98 в полном объеме доступны все возможности, предоставляемые входящими подключениями, кроме динамического выделения линий многоканального подключения и протокола EAP (Extensible Authentication Protocol). Клиенты Windows 98 выполняют согласование процесса входа и проверки подлинности с сервером. Кроме того, эти клиенты можно настроить на использование сценариев, полностью автоматизирующих процесс входа.

  • Windows 95.

    • Клиентам Windows 95 в полном объеме доступны все возможности, предоставляемые входящими подключениями, кроме многоканального подключения, динамического выделения линий многоканального подключения и протокола EAP (Extensible Authentication Protocol). Клиенты Windows 95 выполняют согласование процесса входа и проверки подлинности с сервером. Кроме того, эти клиенты можно настроить на использование сценариев, полностью автоматизирующих процесс входа.

  • Windows для рабочих групп, MS-DOS и LAN Manager.

    • Windows 2000 Server и более поздние версии обеспечивают возможности удаленного доступа с помощью клиентской программы Microsoft Network Client 3.0 для MS-DOS и клиента Windows для рабочих групп. Приобретаемые отдельно клиенты Windows для рабочих групп и клиенты сетевых подключений LAN Manager также могут работать с входящими подключениями.

    Программа Microsoft Network Client 3.0 для MS-DOS должна быть настроена на использование полного перенаправления (full redirector) (такая настройка действует по умолчанию). Если выбрано базовое перенаправление (basic redirector), программу удаленного доступа Rasphone запустить не удастся и входящее подключение будет недоступно.

    Клиенты Windows для рабочих групп, MS-DOS и LAN Manager могут использовать шлюз удаленного доступа NetBIOS для доступа к серверам NetBIOS, поддерживающим протоколы TCP/IP или IPX, но эти клиенты не могут запускать программы, для работы которых необходимо наличие TCP/IP или IPX на клиентском компьютере.

    Эти клиенты также не поддерживают протокол PPP, впервые появившийся в Windows NT 3.5.

  • Клиенты PPP.

    • PPP-клиенты независимых разработчиков, которые используют протокол TCP/IP или IPX, могут работать с входящими подключениями. На входящем подключении автоматически проводится согласование проверки подлинности с PPP-клиентами; клиенты независимых разработчиков не требуют никакой особой настройки.

    Дополнительные сведения о клиенте PPP можно найти в документации по соответствующему клиенскому программному обеспечению.

XOX

См. также


Общие сведения о подключениях виртуальной частной сети (VPN)

С помощью протокола PPTP (Point-to-Point Tunneling Protocol) или протокола L2TP (Layer Two Tunneling Protocol), которые автоматически устанавливаются на компьютере, можно обеспечить безопасный доступ к ресурсам сети, используя подключение к серверу удаленного доступа через Интернет или другую сеть. Сетевая структура, использующая частные и общедоступные сети для создания сетевого подключения, называется виртуальной частной сетью (VPN). В следующей таблице описаны преимущества подключений VPN.

Преимущество | Пример
Выигрыш в стоимости | Вместо дорогостоящих служб междугородной и международной телефонной связи и других платных служб используется Интернет. Все необходимое коммуникационное оборудование, такое как модемы и ISDN-адаптеры, предоставляет поставщик услуг Интернета, поэтому для локальной сети придется приобретать и поддерживать меньшее число устройств.
Распределение обслуживания в сетях удаленного доступа | Пользователь соединяется с местным телефонным узлом или поставщиком услуг Интернета, который подключает его к серверу удаленного доступа и корпоративной сети. Модемами и телефонными линиями, необходимыми для удаленного доступа, заведует телефонная компания или поставщик услуг Интернета. Так как поддержкой сложных конфигураций коммуникационного оборудования занимается поставщик услуг Интернета, сетевой администратор может сосредоточиться на централизованном управлении учетными записями пользователей на сервере удаленного доступа.
Повышенная безопасность | Передача данных по подключению через Интернет осуществляется с шифрованием и полностью безопасна. Сервер удаленного доступа использует новые протоколы проверки подлинности и шифрования. Секретные данные будут скрыты от пользователей Интернета, но определенные пользователи могут получить безопасный доступ к ним через сеть VPN.
Поддержка сетевых протоколов | Благодаря поддержке большинства популярных сетевых протоколов (включая TCP/IP и IPX) можно запускать в удаленном режиме любые приложения, рассчитанные на работу с этими протоколами. XOX
Безопасность IP-адресов | Передаваемые через VPN данные зашифрованы, так что используемые адреса защищены, и в Интернете виден только внешний IP-адрес. Для организаций, внутренние IP-адреса которых не согласованы с InterNIC, это очень существенно, так как позволяет избежать административных расходов, связанных с изменением IP-адресов для удаленного доступа через Интернет.

VPN-подключение можно создать двумя способами: удаленным подключением к поставщику услуг Интернета или прямым подключением к Интернету, как показано в следующих примерах.

В первом примере сначала выполняется вызов поставщика услуг Интернета. После того как подключение будет установлено, выполняется вызов сервера удаленного доступа, в результате чего создается туннель PPTP или L2TP. После проверки подлинности пользователь может обращаться в корпоративную сеть, как показано на рисунке.

Подключение VPN, устанавливаемое через поставщика услуг Интернета

Во втором примере пользователь, уже подключенный к Интернету, использует подключение VPN для связи с сервером удаленного доступа. Это может быть пользователь, компьютер которого подключен к локальной сети, пользователь кабельного модема или абонент службы, подобной ADSL, которая устанавливает IP-соединение сразу после включения пользовательского компьютера. Драйвер PPTP или L2TP создает туннель в Интернете и подключается к серверу удаленного доступа, поддерживающему PPTP или L2TP. После проверки подлинности пользователь получает доступ к корпоративной сети с теми же возможностями, что и в предыдущем примере.

Подключение VPN, устанавливаемое с помощью существующего подключения к Интернету

Примечания

  • Прямое подключение к Интернету означает прямой доступ по протоколу IP без участия поставщика услуг Интернета. (Например, клиенты некоторых отелей могут использовать для доступа в Интернет кабель Ethernet.)
  • При наличии активного клиента Winsock Proxy создать сеть VPN нельзя. Клиент Winsock Proxy сразу же перенаправляет данные на указанный прокси-сервер, не позволяя обработать их так, как это требуется для VPN. Чтобы создать сеть VPN, следует отключить клиент Winsock Proxy.

См. также


Создание подключения виртуальной частной сети (VPN)

Рисунок Microsoft Windows

Чтобы создать подключение виртуальной частной сети (VPN)

  1. Откройте компонент Сетевые подключения.
  2. В группе Типичные сетевые задачи щелкните ссылку Создать новое подключение и затем нажмите кнопку Далее.
  3. Выберите вариант Подключить к сети на рабочем месте и нажмите кнопку Далее.
  4. Установите переключатель в положение Подключение к виртуальной частной сети, нажмите кнопку Далее и следуйте указаниям мастера.

Примечания

  • XOX
  • Можно создать несколько подключений VPN, скопировав их в папке «Сетевые подключения». Затем можно переименовать подключения и изменить их параметры. Этот способ позволяет легко и быстро создавать различные подключения для работы с несколькими узлами, параметрами безопасности и т. д.

См. также


Преимущества VPN с точки зрения стоимости

Виртуальные частные сети (VPN) позволяют пользователям, работающим в пути и дома, подключаться к локальным сетям своих организаций через Интернет, неся при этом значительно меньше расходов, чем в случае традиционных решений удаленного доступа. Очевидно, что выгоднее пользоваться коммутатором телефонной компании, чем протягивать собственные телефонные линии и приобретать персональный коммутатор; точно так же при вызове сервера удаленного доступа, поддерживающего PPTP, по IP-адресу или DNS-имени задействуются уже имеющиеся маршрутизаторы Интернета, коммутаторы ATM и цифровые и аналоговые линии, причем без ущерба для безопасности.

Подключиться к виртуальной частной сети можно с помощью сетевого адаптера, аналогично тому, как к обычному удаленному серверу подключаются через модем. Сети VPN избавляют организации от расходов на приобретение и обслуживание таких компонентов, как банки модемов и выделенные аналоговые телефонные линии. Модемы и связанная с ними инфраструктура сосредоточены у поставщика услуг Интернета, что никак не отражается на уровне безопасности и не ограничивает возможности управления удаленными подключениями. Безопасный доступ по сети VPN к частным данным обеспечивается за счет дополнительной проверки подлинности, шифрования и сжатия данных пользователей.

См. также


Повышенная безопасность сетей VPN

Для проверки подлинности подключений виртуальных частных сетей (VPN), поддерживающих протокол PPTP или L2TP, применяются методы проверки на уровне пользователей, основанные на протоколе PPP. К этим методам относятся протоколы Password Authentication Protocol (PAP), Challenge Handshake Authentication Protocol (CHAP), Shiva Password Authentication Protocol (SPAP), Microsoft Challenge Authentication Protocol (MS-CHAP) и (как необязательное средство) Extensible Authentication Protocol (EAP).

Благодаря новым возможностям, предлагаемым протоколами EAP (Extensible Authentication Protocol) и IPSec (Internet Protocol security), виртуальные частные сети обеспечивают повышенную безопасность для удаленных пользователей. Например, если сервер удаленного доступа настроен на проверку по протоколу EAP, то на подключениях удаленного доступа и подключениях VPN к этому серверу будет использоваться высший уровень проверки подлинности. Системный администратор может пользоваться средствами проверки подлинности и шифрования, предоставляемыми протоколом PPP (Point-to-Point Protocol), применять фильтрацию PPTP на сервере удаленного доступа и настраивать серверы удаленного доступа в Интернете на обслуживание только клиентов PPTP, прошедших проверку подлинности и использующих шифрование данных; в результате усиливается безопасность данных и заметно повышается эффективность управления удаленными пользователями.

В некоторых средах используются настолько секретные данные, что их приходится физически изолировать и скрывать от большинства пользователей организации. Примерами таких данных являются сведения финансового характера и данные о персонале предприятия. Организации могут использовать подключения VPN, проходящие через сервер VPN, для физического изолирования серверов с особо секретными данными, в то же время предоставляя отдельным сотрудникам безопасный доступ к этим данным. Пользователь корпоративной интрасети, имеющий соответствующие разрешения, может установить удаленное клиентское подключение VPN к серверу VPN и работать с защищенными ресурсами закрытой части сети. Кроме того, для обеспечения конфиденциальности данных весь трафик, передаваемый по виртуальной частной сети, шифруется. Для пользователей, не обладающих разрешениями на установку подключения VPN к серверу VPN, этот сервер останется скрытым.

См. также


Поддержка сетевых протоколов в VPN

Так как виртуальные частные сети (VPN) поддерживают большинство общераспространенных сетевых протоколов, клиенты сетей Ethernet, TCP/IP и IPX могут легко использовать подключения VPN. Все сетевые протоколы, поддерживаемые службой удаленного доступа, соответственно поддерживаются и сетью VPN. Это означает, что пользователи могут запускать в удаленном режиме программы, работающие с конкретными сетевыми протоколами. В результате снижаются затраты на настройку и сопровождение подключений VPN.

XOX

См. также


Безопасность IP-адресов

В локальной сети могут использоваться незарегистрированные IP-адреса (или адреса, зарезервированные в InterNIC для частных сетей, например, в диапазоне 10.x.y.z), а для поддержания связи через Интернет необходим действительный общий IP-адрес. Внутри конверта, пересылаемого по виртуальной частной сети, содержатся пользовательские пакеты, в которых указан адрес отправителя и адрес в частной сети назначения. Так как пакеты шифруются, адресные данные удаленной частной сети будут защищены. В Интернете виден лишь общий IP-адрес. Для организаций, внутренние IP-адреса которых не согласованы с InterNIC, это очень существенно, так как позволяет избежать административных расходов, связанных с изменением IP-адресов для удаленного доступа через Интернет.

См. также


Администрирование сети VPN

Используя политики доступа в сети, обслуживаемой сервером удаленного доступа, системный администратор может настроить параметры пользователя виртуальной частной сети (VPN) так, чтобы укрепить безопасность сетевой среды, например повысить требуемые уровни проверки подлинности и шифрования данных и паролей. Эти требования будут распространяться либо на отдельных пользователей, либо на группу (или профиль) пользователей. Например, системный администратор может настроить параметры удаленного доступа для профиля группы таким образом, чтобы проверка подлинности всех пользователей этой группы производилась по протоколу EAP (Extensible Authentication Protocol), а их данные шифровались с использованием 128-разрядного ключа. Такие меры безопасности будут автоматически вводиться при подключении любого пользователя данного профиля к серверу удаленного доступа.

Подключение VPN следует настроить в соответствии с политиками, установленными администратором сети. Дополнительные сведения о настройке подключений см. в разделе Чтобы настроить подключение.


Общие сведения о сетевом мосте

Сетевой мост предлагает простой способ соединения сегментов локальной сети. Сегмент локальной сети — это часть сетевой среды передачи, связывающая между собой группу компьютеров. Предположим, что имеется три компьютера: омпьютер A, компьютер B и компьютер C. На компьютере A установлено два сетевых адаптера Ethernet, а на компьютерах B и C — по одному адаптеру Ethernet. Кабель Ethernet, подключающий A к B, образует один сегмент локальной сети. Кабель Ethernet, подключающий A к C, образует другой сегмент локальной сети.

Обычно для создания нескольких сегментов в сети используется один из двух методов: маршрутизация или мостовые соединения. IP-маршрутизация — наиболее распространенный способ соединения сетевых сегментов. Однако для его реализации приходится либо приобретать аппаратные маршрутизаторы, либо устанавливать в местах перехода между сегментами дополнительные компьютеры, играющие роль маршрутизаторов. P-маршрутизация требует сложной настройки IP-адресов для каждого компьютера в каждом сетевом сегменте, и каждый сегмент необходимо настроить как отдельную подсеть. IP-маршрутизация хорошо подходит для больших сетей, где важное значение имеет масштабируемость и где имеются квалифицированные специалисты по настройке и сопровождению сети. Мостовое оборудование не требует такой сложной настройки, но в этом случае понадобится дополнительное оборудование для мостов. Если речь идет о домашней или небольшой офисной сети, или если на покупку дорогостоящего мостового оборудования нет средств или отсутствуют опытные специалисты по администрированию сети с IP-маршрутизацией, то ни один из этих двух вариантов сегментации нельзя признать вполне подходящим.

Если использовать сетевой мост, то для соединения сетевых сегментов достаточно выбрать значки соответствующих сетевых подключений и выполнить команду Подключения типа мост. Сравнительно просто можно включить мост и добавлять в него другие подключения. Сетевой мост управляет сетевыми сегментами и создает одну подсеть для всей сети. Не требуется никакой настройки, не нужно приобретать дополнительное оборудование, такое как мосты или маршрутизаторы. Если IP-сеть состоит из одной подсети, существенно упрощается IP-адресация, распределение адресов и разрешение имен.

Сетевой мост может создавать подключения между сетевыми средами разных типов. Чтобы в традиционной сети можно было использовать несколько видов среды передачи данных, необходимо создать свою подсеть для каждой такой среды и организовать пересылку пакетов между всеми этими подсетями. Пересылка пакетов требуется потому, что в разных сетевых средах действуют разные протоколы. Сетевой мост автоматизирует настройку конфигурации, необходимой для передачи данных из среды одного типа в среду другого типа.

На компьютере под управлением XOX может существовать только один сетевой мост, но можно использовать его для объединения такого количества различных сетевых подключений, которое компьютер физически способен поддержать. Сведения о создании сетевого моста см. в разделе Объединение подключений в мост.

Алгоритм связующего дерева

Для построения топологии пересылки пакетов, исключающей зацикливание, сетевой мост использует алгоритм связующего дерева (spanning tree algorithm, STA), разработанный институтом IEEE. Если в сети с мостовыми подключениями имеется несколько путей, могут образоваться циклические маршруты и следование простым правилам пересылки данных через мост приведет к тому, что один и тот же пакет будет бесконечно передаваться с одного сегмента сети через мост на другой сегмент сети. Алгоритм связующего дерева позволяет по мере необходимости автоматически отключать передачу через мост в отдельных портах, чтобы предотвратить зацикливание в топологии маршрутов пересылки пакетов. Для использования алгоритма связующего дерева в сетевом мосте никакой дополнительной настройки не требуется.

См. также


Объединение подключений в мост

Рисунок Microsoft Windows

Чтобы объединить подключения в мост

XOX

  1. Откройте компонент Сетевые подключения.
  2. В списке ЛВС или высокоскоростной Интернет удерживайте клавишу CTRL и выберите каждое из частных сетевых подключений, которые требуется добавить в мост.
  3. Щелкните правой кнопкой мыши одно из выделенных сетевых подключений и выберите команду Подключения типа мост.

Примечания

  • XOX
  • Для создания моста необходимо выбрать по меньшей мере два созданных сетевых подключения.
  • В сетевой мост могут входить только адаптеры Ethernet, адаптеры IEEE-1394 и Ethernet-совместимые адаптеры, такие как беспроводные адаптеры и адаптеры для домашней сети на базе телефонной линии (HPNA).
  • Адаптеры, для которых включен ICS, не могут входить в состав сетевого моста и не отображаются в контрольном списке «Сетевой мост». Аналогично, параметр Добавить к мосту доступен только для тех адаптеров, которые могут быть добавлены в качестве подключений к сетевому мосту.
  • Не следует создавать мост между общим подключением к Интернету и частным сетевым подключением, а также добавлять общее подключение в состав существующего сетевого моста. Это привело бы к образованию незащищенного канала связи между сетью и Интернетом и сделало бы сеть уязвимой для проникновения извне.
  • На компьютере можно создать только один сетевой мост, но в его состав может входить любое число сетевых подключений.
  • Мостовое соединение нельзя создать на компьютере, работающем под управлением Windows 2000 или более ранних версий Windows.
  • Сетевые адаптеры, входившие ранее в список ЛВС или высокоскоростной Интернет, после добавления в качестве подключений моста появляются в списке Сетевой мост. Сетевые адаптеры, обеспечивающие связь с Интернетом, такие как адаптеры DSL и кабельные модемы, не могут использоваться для создания моста и все время остаются в списке ЛВС или высокоскоростной Интернет.

См. также


Добавление подключения к сетевому мосту

Рисунок Microsoft Windows

Чтобы добавить подключение к сетевому мосту

XOX

  1. Откройте компонент Сетевые подключения.
  2. В списке Сетевой мост щелкните правой кнопкой вариант Сетевой мост и выберите команду Свойства.
  3. На вкладке Общие в разделе Адаптеры установите флажок для каждого адаптера, который требуется добавить к мосту, а затем нажмите кнопку OK.

Примечания

  • XOX
  • Не добавляйте общедоступное подключение к Интернету к существующему сетевому мосту, потому что таким образом создается незащищенная связь между сетью и Интернетом, что может привести к тому, что сеть станет уязвимой для проникновений.
  • Сетевые адаптеры, входившие ранее в список ЛВС или высокоскоростной Интернет, после добавления в качестве подключений моста появляются в списке Сетевой мост. Сетевые адаптеры, обеспечивающие связь с Интернетом, такие как адаптеры DSL и кабельные модемы, не могут использоваться для создания моста и все время остаются в списке ЛВС или высокоскоростной Интернет.

См. также


Удаление подключения из сетевого моста

Рисунок Microsoft Windows

Чтобы удалить подключение из сетевого моста

XOX

  1. Откройте компонент Сетевые подключения.
  2. В списке Сетевой мост щелкните правой кнопкой вариант Сетевой мост и выберите команду Свойства.
  3. На вкладке Общие в группе Адаптеры установите флажок для каждого из удаляемых адаптеров и затем нажмите кнопку OK.

Примечания

  • XOX
  • Если брандмауэр Windows включен, при удалении адаптера из сетевого моста он будет по-прежнему защищен брандмауэром.
  • Если после удаления сетевых адаптеров из сетевого моста в нем остается менее двух адаптеров, мост не сможет выполнять свои функции, но будет по-прежнему использовать системные ресурсы.

См. также


Включение и отключение сетевого моста

Рисунок Microsoft Windows

Чтобы включить или выключить сетевой мост

XOX

  1. Откройте компонент Сетевые подключения.
  2. В списке Сетевой мост щелкните правой кнопкой мыши вариант Сетевой мост и выполните следующие действия:
    • Включить для включения сетевого моста;
    • Отключить для отключения сетевого моста.

Примечания

  • XOX
  • Перед включением сетевого моста используйте команду Подключения типа мост, чтобы создать его.
  • Если удалить сетевой мост, компьютер сети не сможет поддерживать связь с компьютерами, расположенными в других сегментах сети. Кроме того, некоторые компьютеры сети могут лишиться доступа в Интернет.

См. также


Удаление сетевого моста

Рисунок Microsoft Windows

Чтобы удалить сетевой мост

XOX

  1. Откройте компонент Сетевые подключения.
  2. В списке Сетевой мост щелкните правой кнопкой вариант Сетевой мост и выберите команду Удалить.

Примечания

  • XOX
  • Если брандмауэр Windows включен, при удалении адаптеров из сетевого моста брандмауэр останется для них включенным.
  • Если удалить сетевой мост, некоторые компьютеры в сети не смогут поддерживать связь с компьютерами, расположенными в других сегментах сети. Кроме того, некоторые компьютеры сети могут лишиться доступа в Интернет.

См. также


Включение сетевых возможностей UPnP

Рисунок Microsoft Windows

Чтобы включить сетевые возможности UPnP

Брандмауэр Windows включается в XOX по умолчанию, что позволяет обеспечить безопасность компьютера. Как следствие, брандмауэр блокирует порты 1900 и 2869 — порты, которые структура UPnP в Windows использует для сетевых подключений. Чтобы открыть эти порты, выполните следующие действия.

XOX

  1. Откройте брандмауэр Windows.
  2. На вкладке Общие нажмите кнопку Включить (рекомендуется). (Если установлен флажок Не разрешать исключения, порты UPnP останутся закрытыми, даже если выполнить все остальные действия этой процедуры.)
  3. Перейдите на вкладку Исключения.
  4. Установите флажок UPnP-структура и нажмите кнопку OK.

Примечания

  • XOX
  • По умолчанию с помощью этих действий можно настроить порты 1900 и 2869 таким образом, чтобы они принимали подключения из домашней или малой офисной сети. Чтобы получать подключения от всех IP-адресов, установите флажок UPnP-структура, а затем нажмите кнопку Изменить.
  • Когда порты 1900 и 2869 заблокированы, сообщения UPnP через сеть не передаются. Таким образом, программа контрольной точки UPnP, такая как клиент обнаружения и управления устройствами шлюза Интернета, не сможет обнаружить устройства UPnP, подключенные к сети, и управлять ими. Пользователь также не сможет увидеть изменения в окне состояния сетевых UPnP-устройств (например, когда изменяется состояние включения устройства), потому что брандмауэр Windows блокирует входящие сообщения о событиях.

См. также


Групповая политика для сетевого моста

Параметр Запретить установку, настройку и использование сетевых мостов в вашей сети DNS-доменов определяет, может ли пользователь компьютера, имеющий административные полномочия, создать сетевой мост в сети с доменами DNS.

Создавая сетевой мост, администратор компьютера объединяет два или более сетевых подключений так, чтобы сетевой трафик мог проходить по всем этим подключениям, как если бы они принадлежали одной и той же подсети. Дополнительные сведения о сетевом мосте см. в разделе Общие сведения о сетевом мосте. Параметры групповой политики определяют, какими компонентами рабочего стола пользователя должен управлять системный администратор. Дополнительные сведения о групповой политике см. в разделе Общие сведения о групповой политике.

Важно!

Команда меню сетевого моста Подключения типа мост доступна только в том случае, когда на компьютере установлено более одного сетевого адаптера. По умолчанию сетевой мост отключен, но администратор может включить его с помощью контекстного меню группы значков сетевых подключений. Если установить параметр Запретить установку, настройку и использование сетевых мостов в вашей сети DNS-доменов, запрещающий использовать сетевой мост в сети с доменами, то команда Подключения типа мост будет удалена из меню значков сетевых подключений. Пользователям компьютера, обладающим ограниченными правами, запрещается настраивать сетевой мост, независимо от значения данного параметра.

Если на компьютере сети уже был установлен сетевой мост до включения политики, он продолжит функционировать, поскольку упомянутый параметр привязан к месту действия. Он имеет силу только в том случае, если компьютер подключен к той же сети доменов DNS, к которой он был подключен в момент последнего обновления данного параметра. Если компьютер (например, переносной) подключен к некоторой сети с доменами DNS, однако данный параметр компьютера последний раз обновлялся в другой сети, в текущей сети он применяться к этому компьютеру не будет.


Наблюдение за сетевыми подключениями

Команда Состояние позволяет просматривать сведения об активном подключении.

С помощью команды Состояние могут быть получены следующие данные.
  • Продолжительность работы подключения.
  • Начальная скорость подключения.

    Для одноканального подключения и для отдельных составляющих многоканального подключения эта скорость согласовывается (и фиксируется) во время установки подключения или канала. Для многоканального подключения эта скорость равна сумме скоростей отдельных каналов. При добавлении или удалении каналов общая скорость меняется.

  • Для подключений по локальной сети — число байтов, переданных и принятых с момента установки соединения. Для подключений других типов — число байтов, переданных и принятых байтов с момента установки соединения, а также статистика сжатия данных и исправления ошибок.
  • Средства диагностики подключения (если таковые есть). Например, средство устранения неполадок сетей Windows, программа TCP/IP Autoping и программа настройки Windows IP для TCP/IP. Такие средства явно регистрируются в XOX их разработчиками (как в корпорации Майкрософт, так и в любой другой организации).

Дополнительные сведения см. в разделе Чтобы выбрать режим наблюдения за подключением.

Примечание

  • Если компьютер настроен на прием входящих подключений, то для каждого подключающегося пользователя в папку «Сетевые подключения» будет добавляться значок подключения с именем этого пользователя. Для получения сведений о конкретном входящем подключении щелкните его правой кнопкой мыши и выберите команду Состояние.


Наблюдение за подключением

Рисунок Microsoft Windows

Чтобы выбрать режим наблюдения за подключением

  1. Откройте компонент Сетевые подключения.
  2. Выполните одно из следующих действий.
    • Чтобы наблюдать за ходом текущего сеанса, щелкните правой кнопкой мыши соответствующее подключение и выберите команду Состояние.
    • Чтобы монитор состояния автоматически выводился на экран при каждой активизации подключения, щелкните подключение правой кнопкой мыши, выберите команду Свойства и установите флажок При подключении вывести значок в области уведомлений.
  3. Чтобы узнать, как прошло назначение IP-адреса, и посмотреть сам IP-адрес, маску подсети и основной шлюз, перейдите на вкладку Поддержка.

Примечания

  • XOX
  • Для получения дополнительных сведений о сетевом подключении нажмите на вкладке Поддержка кнопку Сведения.
  • Чтобы восстановить подключение и сбросить параметры IP, нажмите на вкладке Поддержка кнопку Восстановить.
  • Если компьютер настроен на прием входящих подключений, то для каждого подключающегося пользователя в папку «Сетевые подключения» будет добавляться значок подключения с именем этого пользователя. Для получения сведений о конкретном входящем подключении щелкните его правой кнопкой мыши и выберите команду Состояние.
  • Текущие сведения о подключении можно также просмотреть, выбрав команду Состояние в меню Файл или щелкнув значок состояния на панели задач.
  • Чтобы просмотреть общие сведения о состоянии всех подключений (Отключено или Подключено), выберите в меню Вид команду Таблица.
  • Чтобы разорвать подключение по локальной сети, нажмите кнопку Отключить в диалоговом окне Состояние. Чтобы разорвать подключение удаленного доступа, подключение VPN или входящее подключение, нажмите кнопку Отключить в диалоговом окне Состояние.
  • По умолчанию монитор состояния отключен для подключений по локальной сети и включен для всех остальных типов подключений.

См. также


Просмотр состояния подключения по локальной сети

Рисунок Microsoft Windows

Чтобы просмотреть состояние подключения по локальной сети

  1. Откройте компонент Сетевые подключения.
  2. Выполните одно из следующих действий.
    • Для просмотра данных о текущем сеансе щелкните нужное подключение правой кнопкой мыши и выберите команду Состояние.
    • Чтобы монитор состояния автоматически выводился на экран при каждой активизации подключения, щелкните значок подключения по локальной сети правой кнопкой мыши, выберите команду Свойства и установите флажок При подключении вывести значок в области уведомлений.

Примечания

  • XOX
  • Кнопка Свойства позволяет просматривать и изменять сетевые компоненты подключения по локальной сети, например параметры сетевых протоколов.
  • По умолчанию монитор состояния отключен для подключений по локальной сети и включен для всех остальных типов подключений.

См. также


Общие сведения о связи в сети

Связь между компьютером и сетью обеспечивается с помощью сетевых протоколов, методов доступа и серверных протоколов.

В зависимости от способа передачи данных с компьютера на сервер (например, по прямому подключению с помощью последовательного кабеля, или по безопасному подключению VPN через поставщика услуг Интернета к корпоративной сети), используются различные сочетания методов доступа и протоколов. Эти варианты перечислены в следующей таблице.

Сетевой протокол | Метод доступа | Серверный протокол
TCP/IP | Использование телефонных линий и модемов | PPP (Point-to-Point Protocol)
IPX | Доступ с использованием ISDN | SLIP
 | Доступ с использованием последовательного кабеля (RS-232) | L2TP (Layer Two Tunneling Protocol)
 | Доступ с использованием кабелей DirectParallel |

XOX


Общие сведения о протоколе TCP/IP

TCP/IP (Transmission Control Protocol/Internet Protocol) — самый популярный сетевой протокол, служащий основой Интернета. Предлагаемые им средства маршрутизации обеспечивают максимальную гибкость функционирования сетей предприятий. В XOX протокол TCP/IP установлен автоматически.

В сетях TCP/IP клиентам должны быть назначены IP-адреса. Кроме того, клиентам может потребоваться служба имен или алгоритм разрешения имен. В этом разделе рассказывается о том, какие методы IP-адресации и разрешения имен в сетях TCP/IP поддерживает компонент «Сетевые подключения». Здесь также описаны служебные программы FTP и Telnet, входящие в комплект протокола TCP/IP.

Назначение IP-адресов подключениям удаленного доступа и подключениям виртуальных частных сетей (VPN)

Каждому удаленному компьютеру, подключающемуся к серверу удаленного доступа в сети TCP/IP системы Windows, этот сервер присваивает IP-адрес.

Если нужно использовать фиксированный IP-адрес, сервер удаленного доступа должен быть настроен таким образом, чтобы разрешать пользователям запрашивать конкретный адрес.

Разрешение имен для сетевых подключений и подключений удаленного доступа

Помимо IP-адреса, для сетевых подключений и подключений удаленного доступа в сети TCP/IP может потребоваться средство сопоставления имен компьютеров с IP-адресами. Доступны четыре варианта разрешения имен: DNS, WINS, широковещательное разрешение имен и файлы Hosts и Lmhosts.

В небольших сетях, где IP-адреса не изменяются, сетевые подключения и подключения удаленного доступа могут пользоваться для разрешения имен файлами Hosts и Lmhosts. Эти файлы находятся на локальном диске, так что в этом случае не требуется передавать серверу WINS или DNS запросы на разрешение имен и ожидать от него ответа.

Служебные программы Интернета

В комплект протокола TCP/IP входят служебные программы FTP (File Transfer Protocol) и Telnet. FTP — это приложение с текстовым интерфейсом, позволяющее подключаться к FTP-серверам и передавать файлы. Telnet обладает графическим интерфейсом и позволяет входить на удаленный компьютер и выполнять команды так же, как если бы пользователь находился за клавиатурой этого компьютера. В Интернете можно найти различные версии FTP, Telnet и других программ, основанных на более ранних стандартах Интернета; они также имеются в продаже.

Сведения о настройке параметров подключения см. в разделе Чтобы настроить подключение. Сведения о настройке параметров протокола TCP/IP см. в разделе Чтобы настроить параметры TCP/IP.


Протокол IPX

Протокол IPX (Internet Packet Exchange) был разработан для сетевой операционной системы NetWare и широко используется во многих сетях Novell. В этом разделе рассказывается о том, как клиенты, пользующиеся компонентом «Сетевые подключения», интегрируются в IPX-сеть NetWare.

XOX

Поддержка NetWare

Чтобы увидеть сеть Novell NetWare с компьютера, необходимо запустить на нем средство перенаправления запросов NetWare. Этот перенаправитель называется «Клиент для сетей NetWare» (CSNW).

Сервер удаленного доступа также выполняет функции IPX-маршрутизатора и агента SAP (Service Advertising Protocol). Соответствующим образом настроенные серверы удаленного доступа обеспечивают для клиентов сетевых подключений Windows функционирование служб файлов и печати и поддержку приложений Windows Sockets по протоколу IPX в сети NetWare. Серверы удаленного доступа и их клиенты, использующие компонент «Сетевые подключения», настраивают линию удаленного доступа на поддержку IPX с помощью протокола PPP IPX Configuration Protocol (IPXCP), как описано в документе RFC 1552, «The PPP Internet Protocol Control Protocol (IPXCP)».

IPX-адресация удаленных клиентов

Клиенты службы сетевых подключений Windows всегда получают IPX-адрес на сервере удаленного доступа. Номер сети IPX либо создается сервером удаленного доступа автоматически, либо выбирается из статического пула номеров, специально выделенного серверу для компонента «Сетевые подключения».

При автоматическом создании номеров сетей IPX сервер удаленного доступа с помощью протокола NetWare Router Information Protocol (RIP) определяет номер, который не используется в IPX-сети. Найденный номер сервер присваивает подключению данного клиента.

Сведения о настройке параметров подключения см. в разделе Чтобы настроить подключение. Сведения о настройке IPX/SPX/NetBIOS-совместимого транспортного протокола NWLink, представляющего собой реализацию протокола IPX в XOX, см. в разделе Настройка протокола NWLink.

Сведения о настройке входящих подключений на использование протокола IPX см. в разделе Чтобы настроить входящее подключение на использование IPX.


Доступ с использованием ISDN

Для увеличения пропускной способности сети можно использовать линию ISDN (Integrated Services Digital Network). В то время как обычная телефонная линия способна передавать данные со скоростью до 56 Кбит/с, линии ISDN позволяют вести передачу со скоростью 64 или 128 Кбит/с.

Линии ISDN должны быть установлены телефонной компанией как на стороне сервера, так и в удаленном узле. Кроме того, для работы с ISDN необходимо установить на сервере и на самом компьютере платы ISDN-адаптеров. Стоимость оборудования и линий ISDN может оказаться выше стоимости стандартных модемов и телефонных линий. Однако чем больше скорость, тем меньше времени нужно для передачи того же объема данных, что позволяет сократить расходы на оплату повременного соединения.

Линия ISDN состоит из двух B-каналов, каждый из которых передает данные со скоростью 64 Кбит/с, и одного D-канала для передачи управляющей информации со скоростью 16 Кбит/с. Каждый из B-каналов можно настроить на выполнение функций порта. Некоторые драйверы ISDN позволяют объединять каналы. Это означает, что полосу пропускания можно расширить, настроив оба B-канала на функционирование в качестве единого порта. В такой конфигурации скорость линии возрастает до 128 Кбит/с.

Объединение каналов ISDN осуществляется с помощью функции многоканального подключения (Multilink). Она соединяет несколько физических каналов в одну логическую связку. Такой комбинированный канал увеличивает полосу пропускания подключения. Кроме того, каналы можно выделять динамически, т. е. линии ISDN будут использоваться только по мере необходимости. Это позволяет избежать чрезмерного расширения полосы пропускания, обеспечивая гораздо более эффективную работу пользователей. Условия, при которых подключаются дополнительные линии и отключаются простаивающие, задаются параметрами компонента «Сетевые подключения».

См. также


Доступ с использованием последовательного кабеля (RS-232)

Предположим, что две сети находятся в одном и том же месте, но физически не соединены между собой. Чтобы ресурсы обеих сетей стали доступны с одного компьютера, можно с помощью кабелей RS-232C и COM-портов создать нуль-модемные соединения. Пользователь с помощью кабеля RS-232C соединяет COM-порт своего компьютера с COM-портом каждого сервера удаленного доступа. Для серверов эти порты будут выглядеть как модемы. Доступ к сети обеспечивается средствами удаленного доступа сервера, предоставляемыми в составе службы маршрутизации и удаленного доступа.

См. также


Доступ с использованием кабелей DirectParallel

Технология DirectParallel обеспечивает связь между двумя компьютерами через стандартный или расширенный (ECP) параллельный порт с использованием параллельных кабелей типа Basic или Fast компании Parallel Technologies. Сведения о настройке прямого сетевого подключения по кабелю DirectParallel см. в разделе Чтобы создать прямое сетевое подключение с помощью кабеля DirectParallel. Кабели для прямого кабельного подключения можно приобрести несколькими способами. Можно, например, заказать кабели DirectParallel в компании Parallel Technologies или у ее местного дилера. Дополнительные сведения см. в разделе Чтобы связаться с компанией Parallel Technologies или ее местным дилером с целью приобретения кабелей для прямого подключения.


Протокол SLIP

SLIP (Serial Line Internet Protocol) — это старый стандарт удаленного доступа, используемый в основном серверами удаленного доступа на платформе UNIX. Компонент «Сетевые подключения» поддерживает протокол SLIP; с его помощью можно устанавливать подключения к любым серверам удаленного доступа.

При подключении к серверу SLIP открывается диалоговое окно Терминал Windows для проведения интерактивного сеанса входа на SLIP-сервер UNIX. При этом выполняется именно сеанс входа в систему UNIX, а не в службу удаленного доступа. После установки подключения удаленный доступ к сети становится открытым для пользователя.

Система удаленного доступа соответствует требованиям, изложенным в следующих документах RFC:

  • RFC 1144, «Compressing TCP/IP Headers for Low-Speed Serial Links»

  • RFC 1055, «A Nonstandard for Transmission of IP Datagrams Over Serial Lines: SLIP»

Сведения о настройке подключений удаленного доступа и сетевых подключений см. в разделе Чтобы настроить подключение.

Примечания

  • Компьютер, работающий под управлением XOX, не может выполнять функции SLIP-сервера. Обеспечивается лишь поддержка клиентов XOX, подключающихся к другим SLIP-серверам.
  • Для подключения к SLIP-серверу необходимо использовать протокол TCP/IP и последовательный COM-порт.


Настройка параметров TCP/IP

Рисунок Microsoft Windows

Чтобы настроить параметры TCP/IP

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. Выполните одно из следующих действий.
    • В случае подключения по локальной сети выберите в списке Отмеченные компоненты используются этим подключением вариант Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
    • В случае подключения удаленного доступа, входящего подключения или подключения VPN откройте вкладку Сеть. В списке Отмеченные компоненты используются этим подключением выберите вариант Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
  4. Выполните одно из следующих действий.
    • Чтобы параметры IP были назначены автоматически, установите переключатель в положение Получить IP-адрес автоматически и нажмите кнопку ОК.
    • Чтобы вручную указать IP-адрес или адрес сервера DNS, выполните следующие действия.
      • Установите переключатель в положение Использовать следующий IP-адрес и в поле IP-адрес введите соответствующий адрес.
      • Установите переключатель в положение Использовать следующие адреса DNS-серверов и введите в полях Предпочитаемый DNS-сервер и Альтернативный DNS-сервер адреса основного и дополнительного серверов DNS.
  5. Чтобы настроить параметры DNS, WINS и IP, нажмите кнопку Дополнительно.

Примечания

  • XOX
  • По возможности желательно использовать автоматическую настройку параметров IP (с помощью DHCP), что продиктовано следующими соображениями.
    • Служба DHCP включена по умолчанию.
    • При изменении местоположения компьютера не требуется вручную изменять параметры IP.
    • Автоматическое назначение параметров IP используется для всех подключений; при этом отпадает необходимость в настройке параметров DNS, WINS и т. п.

См. также


Добавление сетевого компонента

Рисунок Microsoft Windows

Чтобы добавить сетевой компонент

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение, для которого нужно добавить сетевой компонент, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. Выполните одно из следующих действий.
    • В случае подключения по локальной сети нажмите кнопку Установить.
    • В случае подключения удаленного доступа, входящего подключения или подключения VPN откройте вкладку Сеть и нажмите кнопку Установить.
  4. В диалоговом окне Выбор типа сетевого компонента выберите вариант Клиент, Служба или Протокол и нажмите кнопку Добавить.
  5. Выполните одно из следующих действий.
    • Если установочного диска для нужного компонента нет, выберите соответствующий клиент, службу или протокол и нажмите кнопку ОК.
    • При наличии установочного диска для компонента выберите соответствующий клиент, службу или протокол, нажмите кнопку Установить с диска, вставьте установочный диск в дисковод и нажмите кнопку ОК.

Примечания

  • XOX
  • По описанным ниже причинам следует устанавливать только те сетевые компоненты, которые необходимы.
    • Лишние протоколы и клиенты снижают производительность сети и увеличивают трафик.
    • Если при установке сетевого подключения или подключения удаленного доступа возникают трудности, компьютер пытается выполнить задачу, используя все установленные и включенные сетевые протоколы. Если на компьютере установлены и включены только необходимые протоколы, операционная система не будет пытаться воспользоваться заведомо недоступными ей протоколами и сможет быстрее возвращать данные о состоянии.
    • Чрезмерное число служб может уменьшить производительность локального компьютера.

См. также


Удаление сетевого компонента

Рисунок Microsoft Windows

Чтобы удалить сетевой компонент

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение, для которого нужно удалить сетевой компонент, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. Выполните одно из следующих действий.
    • В случае подключения по локальной сети на вкладке Общие в списке Отмеченные компоненты используются этим подключением выберите клиент, службу или протокол, который следует удалить, и нажмите кнопку Удалить.
    • В случае подключения удаленного доступа, подключения VPN или входящего подключения на вкладке Сеть в списке Отмеченные компоненты используются этим подключением выберите клиент, службу или протокол, который следует удалить, и нажмите кнопку Удалить.
  4. В диалоговом окне Удаление имя компонента нажмите кнопку Да.

Примечания

  • XOX
  • Служба «Протокол Интернета (TCP/IP)» устанавливается по умолчанию и не может быть удалена.

См. также


Включение сетевого компонента

Рисунок Microsoft Windows

Чтобы включить сетевой компонент

  1. Откройте компонент Сетевые подключения.
  2. Выделите нужное подключение и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. Выполните одно из следующих действий.
    • В случае подключения по локальной сети на вкладке Общие в списке Отмеченные компоненты используются этим подключением установите флажок, соответствующий клиенту, службе или протоколу, который нужно включить.
    • В случае подключения удаленного доступа, входящего подключения или подключения VPN откройте вкладку Сеть. В списке Отмеченные компоненты используются этим подключением установите флажок для клиента, службы или протокола, который требуется включить.

Примечания

  • XOX
  • По описанным ниже причинам следует включать только те сетевые компоненты, которые необходимы.
    • Лишние протоколы и клиенты снижают производительность сети и увеличивают трафик.
    • Если при установке сетевого подключения или подключения удаленного доступа возникают трудности, компьютер пытается выполнить задачу, используя все установленные и включенные сетевые протоколы. Если на компьютере установлены и включены только необходимые протоколы, операционная система не будет пытаться воспользоваться заведомо недоступными ей протоколами и сможет быстрее возвращать данные о состоянии.
    • Чрезмерное число служб может уменьшить производительность локального компьютера.

См. также


Отключение сетевого компонента

Рисунок Microsoft Windows

Чтобы отключить сетевой компонент

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение, для которого нужно отключить сетевой компонент, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. Выполните одно из следующих действий.
    • В случае подключения по локальной сети на вкладке Общие в списке Отмеченные компоненты используются этим подключением снимите флажок, соответствующий клиенту, службе или протоколу, который нужно отключить.
    • В случае подключения удаленного доступа, входящего подключения или подключения VPN откройте вкладку Сеть. В списке Отмеченные компоненты используются этим подключением снимите флажок для клиента, службы или протокола, который требуется отключить.

Примечание

  • XOX

См. также


Изменение порядка привязки протоколов

Рисунок Microsoft Windows

Чтобы изменить порядок привязки протоколов

XOX

  1. Откройте компонент Сетевые подключения.
  2. В меню Дополнительно выберите команду Дополнительные параметры.
  3. На вкладке Адаптеры и привязки в списке Connections выберите подключение, которое требуется изменить.
  4. В списке Привязки для подключения по локальной сети выберите протокол, который требуется переместить вверх или вниз по списку, и нажмите кнопку со стрелкой вверх или вниз.

Примечание

  • XOX

См. также


Изменение порядка служб доступа к сети

Рисунок Microsoft Windows

Чтобы изменить порядок служб доступа к сети

XOX

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение, которое нужно изменить, и выберите в меню Дополнительно команду Дополнительные параметры.
  3. На вкладке Порядок служб доступа в списке Службы доступа к сети выберите службу, которую требуется переместить вверх или вниз по списку, и нажмите кнопку Вверх или Вниз.

Примечания

  • XOX
  • Обращение к службам доступа к сети производится в том порядке, в котором они указаны в этом списке.

См. также


Клиент для сетей Microsoft

Компонент «Клиент для сетей Microsoft» позволяет компьютеру обращаться к ресурсам сети Microsoft.

Этот компонент устанавливается и включается автоматически. Его не требуется настраивать, если в сети не используется программное обеспечение компании The Open Group, например, клиент или сервер DCE (Distributed Computing Environment). Если же это программное обеспечение используется, узнайте у системного администратора правильный сетевой адрес службы каталогов ячеек DCE.

Компонент «Клиент для сетей Microsoft» является аналогом службы рабочей станции (Workstation) в системе Windows NT 4.0.

См. также


Настройка клиента для сетей Microsoft

Рисунок Microsoft Windows

Чтобы настроить клиент для сетей Microsoft

  1. Откройте компонент Сетевые подключения.
  2. Выделите нужное подключение и затем в группе Типичные сетевые задачи щелкните ссылку Изменение настроек отдельного подключения.
  3. Выполните одно из следующих действий.
    • В случае подключения по локальной сети выберите в списке Отмеченные компоненты используются этим подключением на вкладке Общие вариант Клиент для сетей Microsoft и нажмите кнопку Свойства.
    • В случае подключения VPN, подключения удаленного доступа или входящего подключения выберите в списке Отмеченные компоненты используются этим подключением на вкладке Сеть вариант Клиент для сетей Microsoft и нажмите кнопку Свойства.
  4. В списке Поставщик службы имен выберите поставщика для службы имен RPC.
  5. Если выбрана Служба каталогов ячеек DCE, в поле Сетевой адрес введите сетевой адрес поставщика службы имен.
  6. Если используется сетевое программное обеспечение Banyan Vines, установите флажок Включить поддержку RPC для Banyan.

Примечания

  • XOX
  • Изменять поставщика службы имен следует только по согласованию с системным администратором.
  • Поставщиком службы имен по умолчанию является «Локатор Windows».
  • Аналогом компонента «Клиент для сетей Microsoft» в Windows NT 4.0 является служба рабочей станции (Workstation).

См. также


Служба доступа к файлам и принтерам сетей Microsoft

Компонент «Служба доступа к файлам и принтерам сетей Microsoft» позволяет другим сетевым компьютерам обращаться к ресурсам данного компьютера по сети Microsoft.

Этот компонент устанавливается и включается автоматически. Он активизируется для каждого подключения с помощью протокола TCP/IP и необходим для обеспечения общего доступа к локальным папкам.

Компонент «Служба доступа к файлам и принтерам сетей Microsoft» является аналогом службы сервера (Server) в системе Windows NT 4.0.

См. также


Протокол PPP (Point-to-Point Protocol)

PPP (Point-to-Point Protocol) — это набор стандартных протоколов, позволяющих программам удаленного доступа различных разработчиков взаимодействовать друг с другом. Подключение PPP обеспечивает связь с удаленными сетями через стандартный PPP-сервер. Протокол PPP также позволяет серверу удаленного доступа принимать входящие вызовы от программ удаленного доступа других разработчиков, поддерживающих PPP, и обеспечивать сетевой доступ к таким программам.

Стандарты PPP предлагают дополнительные возможности, которые отсутствуют в более старых стандартах (таких, как SLIP). PPP поддерживает несколько методов проверки подлинности, а также сжатие и шифрование данных. Большинство реализаций PPP позволяют полностью автоматизировать весь процесс входа в сеть.

PPP поддерживает несколько протоколов локальных сетей. В качестве сетевого протокола можно использовать TCP/IP или IPX. XOX

PPP служит основой для протоколов PPTP и L2TP, используемых на безопасных подключениях виртуальных частных сетей (VPN).

Протокол PPP является основным стандартом для большинства систем удаленного доступа.

См. также


Принципы работы и протоколы подключения PPP

Подключения PPP (Point-to-Point Protocol) должны удовлетворять требованиям стандартов, которые изложены в спецификациях RFC по протоколу PPP. В данном разделе описывается работа подключения PPP и используемые им протоколы.

Порядок работы подключения PPP

После установления связи с удаленным PPP-сервером создается подключение PPP; при этом используются следующие средства согласования.

  • Протоколы управления связью (Link Control Protocol, LCP).

    • Используются для установки и настройки связи и параметров кадров, таких как максимальный размер кадра.

  • Протоколы проверки подлинности.

    • Используются для определения уровня безопасности, допустимого для сервера удаленного доступа, и требований этого сервера. Минимальный уровень безопасности соответствует проверке подлинности с использованием незашифрованного пароля (передаваемого открытым текстом), максимальный — проверке подлинности с шифрованием, использующей смарт-карты.

  • Протоколы управления сетью (NCP).

    • Используются для установки и настройки различных параметров сетевых протоколов IP и IPX. На этом этапе выполняется согласование сжатия заголовков протоколов и выбор протокола управления сжатием.

Установленное подключение остается активным, пока связь не будет прервана по одной из следующих причин:

  • сеанс связи прекращен пользователем;
  • превышено допустимое время простоя соединения;
  • сеанс связи прекращен администратором;
  • обнаружена неустранимая ошибка связи.

Протоколы управления связью

Протоколы управления связью (LCP) устанавливают и настраивают параметры формирования кадров PPP. Структура кадров PPP определяет схему инкапсуляции данных перед их передачей по глобальной сети. Использование стандартного формата кадров PPP позволяет любым программам удаленного доступа взаимодействовать с другими программами удаленного доступа, поддерживающими стандарты PPP, и распознавать отправляемые ими пакеты данных.

PPP и XOX используют для формирования кадров для последовательных подключений или подключений ISDN варианты протокола High-level Data Link Control (HDLC).

Протоколы проверки подлинности

Согласование протоколов проверки подлинности происходит сразу после определения качества связи и до согласования сетевого уровня.

Протоколы управления сетью

Протоколы управления сетью устанавливают и настраивают различные параметры для сетевых протоколов TCP/IP и IPX. Для подключения PPP используются протоколы управления сетью, описанные в следующей таблице.

XOX

Протокол управления сетью | Описание
IPCP (Internet Protocol Control Protocol) | Используется для настройки, включения и отключения модулей IP на обоих концах подключения PPP
IPXCP (Internetwork Packet Exchange Control Protocol) | Используется для настройки, включения и отключения модулей IPX на обоих концах подключения PPP. IPXCP широко применяется разработчиками средств PPP. Корпорацией Novell предложен альтернативный вариант — протокол IPX WAN. Он несовместим с IPXCP. XOX поддерживает протокол IPXCP, который реализован в большинстве программ удаленного доступа.


Материалы RFC по протоколу PPP

RFC (Request for Comments — рабочее предложение) — это постоянно пополняемое собрание рабочих материалов (технических отчетов, проектов протоколов и описаний стандартов протоколов), используемых разработчиками и пользователями Интернета. Стандарты маршрутизации определены в документах RFC, опубликованных группой IETF (Internet Engineering Task Force) и другими рабочими группами. В следующей таблице перечислены документы RFC, относящиеся к PPP.

Номер RFC | Название
1549 | PPP in HDLC Framing
1552 | The PPP Internetwork Packet Exchange Control Protocol (IPXCP)
1334 | PPP Authentication Protocols
1332 | The PPP Internet Protocol Control Protocol (IPCP)
1661 | Link Control Protocol (LCP)
1990 | PPP Multilink Protocol
2125 | The PPP Bandwidth Allocation Protocol (BAP), The PPP Bandwidth Allocation Control Protocol (BACP)
2097 | The PPP NetBIOS Frames Control Protocol (NBFCP)
1962 | The PPP Compression Control Protocol (CCP)
1570 | PPP LCP Extensions
2284 | PPP Extensible Authentication Protocol (EAP)

Получение документов RFC

XOX. Этот веб-узел в настоящее время поддерживается членами ISI (Information Sciences Institute), которые публикуют классифицированные списки документов RFC. Документы RFC классифицируются по следующим категориям: утвержденные стандарты Интернета, предложения по стандартам Интернета (в виде проектов), рекомендации по работе с Интернетом и информация (FYI).

Примечание

  • XOX


Использование протокола PPP для подключения к Интернету

Сетевые подключения, устанавливаемые по умолчанию, используют протокол PPP (Point-to-Point Protocol).

Если компьютер работает под управлением Windows 2000 Professional, XOX или является автономным компьютером под управлением Windows 2000 Server, который настроен на прием входящих подключений, для поддержки входящих вызовов PPP специальная настройка не требуется. Если подключения настроены правильно, согласование вызовов PPP происходит автоматически.

При соединении с удаленным сервером PPP обычно вполне подходящей оказывается конфигурация параметров, заданная по умолчанию, и никакой дополнительной настройки не требуется. Однако можно настроить параметры PPP для подключения, по которому устанавливается связь с сервером PPP.


Включение запросов расширений LCP для протокола PPP

Рисунок Microsoft Windows

Чтобы включить запросы расширений LCP для протокола PPP

  1. Отключитесь от удаленного сервера.
  2. Откройте компонент Сетевые подключения.
  3. Выделите подключение удаленного доступа или подключение VPN, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  4. На вкладке Сеть нажмите кнопку Настройка и установите флажок Включить расширения LCP.

Примечание

  • XOX

См. также


Отключение запросов расширений LCP для протокола PPP

Рисунок Microsoft Windows

Чтобы отключить запросы расширений LCP для протокола PPP

  1. Отключитесь от удаленного сервера.
  2. Откройте компонент Сетевые подключения.
  3. Выделите подключение удаленного доступа или подключение VPN, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  4. На вкладке Сеть нажмите кнопку Настройка и снимите флажок Включить расширения LCP.

Примечание

  • XOX

См. также


Отключение сжатия заголовков IP в протоколе PPP

Рисунок Microsoft Windows

Чтобы отключить сжатие заголовков IP в протоколе PPP

XOX

  1. Отключитесь от удаленного сервера.
  2. Откройте компонент Сетевые подключения.
  3. Выделите подключение удаленного доступа, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменение настроек отдельного подключения.
  4. На вкладке Сеть в списке Отмеченные компоненты используются этим подключением выберите вариант Протокол Интернета (TCP/IP) и нажмите кнопку Свойства.
  5. Нажмите кнопку Дополнительно и снимите флажок Использовать сжатие IP-заголовков.

Примечание

  • XOX

См. также


Отключение программного сжатия

Рисунок Microsoft Windows

Чтобы отключить программное сжатие

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение удаленного доступа, подключение VPN или входящее подключение, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Сеть нажмите кнопку Настройка и снимите флажок Использовать программное сжатие данных.

Примечание

  • XOX

См. также


Протоколы PPPoE (Point-to-Point Protocol over Ethernet)

С помощью протокола PPPoE (Point-to-Point Protocol over Ethernet) и широкополосного модема пользователи локальной сети могут получать доступ к высокоскоростным сетям данных с индивидуальной проверкой подлинности. Протокол PPPoE, соединяя возможности Ethernet с функциями протокола PPP (Point-to-Point Protocol), обеспечивает эффективный способ создания для пользователей персональных подключений к удаленному серверу. Выбор службы, доступ к ней и оплата услуг осуществляются для каждого пользователя в отдельности, а не для каждого рабочего места.

Матералы RCF по протоколу PPPoE

RFC (Request for Comments — рабочее предложение) — это постоянно пополняемое собрание рабочих материалов (технических отчетов, проектов протоколов и описаний стандартов протоколов), используемых разработчиками и пользователями Интернета. Стандарты маршрутизации определены в документах RFC, опубликованных группой IETF (Internet Engineering Task Force) и другими рабочими группами. В следующей таблице перечислены документы RFC, относящиеся к PPPoE.

Номер RFC | Название
2516 | A Method for Transmitting PPP Over Ethernet (PPPoE)

Получение документов RFC

XOX. Этот веб-узел в настоящее время поддерживается членами ISI (Information Sciences Institute), которые публикуют классифицированные списки документов RFC. Документы RFC классифицируются по следующим категориям: утвержденные стандарты Интернета, предложения по стандартам Интернета (в виде проектов), рекомендации по работе с Интернетом и информация (FYI).

Примечание

  • XOX

См. также


Протокол PPTP (Point-to-Point Tunneling Protocol)

Доступ к частной сети через Интернет или другую сеть общего пользования можно производить с помощью подключения виртуальной частной сети (VPN) по протоколу PPTP (Point-to-Point Tunneling Protocol).

PPTP обеспечивает безопасную передачу данных между удаленным компьютером и частным сервером путем создания виртуальной частной сети (VPN) в структуре сетей TCP/IP. PPTP позволяет создавать многопротокольные виртуальные частные сети на основе общедоступных сетей, таких как Интернет.

Протокол PPTP, разрабатывавшийся как расширение протокола PPP (Point-to-Point Protocol), образует дополнительный уровень безопасности и поддержки многопротокольной связи в среде Интернета. Благодаря использованию нового протокола EAP (Extensible Authentication Protocol) передача данных по виртуальной частной сети PPTP столь же безопасна, как и в локальной сети предприятия.

PPTP осуществляет туннелирование, или инкапсуляцию, протоколов IP и IPX внутри датаграмм PPP. Это означает, что пользователи могут запускать удаленные программы, работающие с конкретными сетевыми протоколами. Сервер туннеля выполняет все необходимые проверки, связанные с защитой, и обеспечивает шифрование данных, что делает передачу информации по открытым сетям гораздо более безопасной. Протокол PPTP можно также использовать для соединения частных локальных сетей.

XOX

Туннель PPTP

Для PPTP не требуется наличие подключения удаленного доступа. Необходимо лишь IP-соединение между компьютером и сервером. Если компьютер подключен непосредственно к локальной IP-сети и имеет доступ к серверу, то туннель PPTP можно создать и в этой сети. Однако если туннель создается в Интернете, а доступ к Интернету производится через подключение к поставщику услуг Интернета, то для создания туннеля нужно будет сначала установить подключение удаленного доступа к Интернету.

См. также


Протокол L2TP (Layer Two Tunneling Protocol)

Доступ к частной сети через Интернет или другую сеть общего пользования можно производить с помощью подключения виртуальной частной сети (VPN) по протоколу L2TP (Layer Two Tunneling Protocol). L2TP — стандартный протокол туннелирования в Интернете, обладающий примерно теми же возможностями, что и протокол PPTP (Point-to-Point Tunneling Protocol). Реализация L2TP в XOX предназначена для работы в IP-сетях. Эта реализация L2TP не поддерживает создание туннелей в сетях X.25, Frame Relay или ATM.

В соответствии со спецификациями L2F (Layer Two Forwarding) и PPTP (Point-to-Point Tunneling Protocol) протокол L2TP можно применять для создания туннелей в промежуточных сетях. L2TP, подобно PPTP, инкапсулирует кадры протокола PPP (Point-to-Point Protocol), который, в свою очередь, инкапсулирует протоколы IP или IPX, тем самым позволяя пользователям запускать удаленные программы, работающие с конкретными сетевыми протоколами.

XOX

Туннель L2TP

При использовании L2TP все проверки, связанные с безопасностью, выполняет компьютер, работающий под управлением Windows 2000 Server, с которого производится вход в сеть. L2TP также поддерживает шифрование данных, что существенно повышает надежность транспортировки данных через незащищенные сети. Благодаря использованию нового протокола проверки подлинности и шифрования IPSec (Internet Protocol security) передача данных по виртуальной частной сети L2TP столь же безопасна, как и в локальной сети предприятия.

См. также


Средства безопасности в компоненте «Сетевые подключения»

Для подключений удаленного доступа, подключений виртуальной частной сети (VPN) и прямых подключений можно применять различные уровни парольной проверки подлинности и шифрования данных. Существует множество методов проверки подлинности, начиная с передачи незашифрованных паролей и заканчивая специальными настраиваемыми механизмами, такими как протокол EAP (Extensible Authentication Protocol — протокол расширенной проверки подлинности). Протокол EAP обеспечивает гибкую поддержку большого числа способов проверки подлинности, включая смарт-карты, сертификаты, одноразовые пароли и открытые ключи. В зависимости от выбранного уровня парольной проверки подлинности (MS-CHAP, EAP, MS-CHAP v2 или EAP-TLS) можно также задать тип шифрования данных. И наконец, чтобы еще более повысить безопасность удаленного подключения, можно настроить параметры ответного вызова.

Учетные записи пользователей и домены обеспечивают безопасность с помощью процедур шифрованной проверки подлинности и шифрования данных.


Действия системы безопасности в процессе подключения

В этом разделе описаны действия, выполняемые в процессе вызова сервера удаленного доступа.

  1. Клиент удаленного доступа вызывает сервер удаленного доступа.
  2. В зависимости от выбранных методов проверки подлинности, выполняются следующие шаги.
    • Если используется протокол PAP или SPAP:
      • клиент отправляет серверу имя пользователя и пароль;
      • сервер сверяет данные учетной записи с базой данных пользователей.
    • Если используется протокол CHAP или MS-CHAP:
      • сервер отправляет запрос клиенту;
      • клиент отправляет зашифрованный ответ серверу;
      • сервер сверяет ответ с базой данных пользователей.
    • Если используется протокол MS-CHAP v2:
      • сервер отправляет запрос клиенту;
      • клиент отправляет зашифрованный ответ и запрос серверу;
      • сервер сверяет зашифрованный ответ клиента с базой данных пользователей и отправляет клиенту свой зашифрованный ответ;
      • клиент проверяет зашифрованный ответ сервера.
    • Если используется проверка подлинности с помощью сертификатов:
      • сервер отправляет клиенту свой сертификат компьютера;
      • если клиент настроен, он выполняет проверку сертификата сервера;.
      • клиент отправляет серверу свой сертификат пользователя;
      • сервер проверяет, действителен ли сертификат пользователя и не был ли он отозван.
  3. Если попытка подключения прошла проверку подлинности (учетные данные пользователя действительны, учетная запись пользователя включена и не заблокирована, а подключение выполняется в разрешенное время входа) и авторизована (учетная запись пользователя имеет разрешение на удаленный доступ для входящих подключений), то сервер принимает подключение удаленного доступа.

    4. Если включен режим ответного вызова, сервер осуществляет обратный вызов клиентского компьютера и повторяет шаги со второго по третий.

Примечания

  • Для службы маршрутизации и удаленного доступа авторизация подключения определяется свойствами входящих вызовов в учетной записи пользователя и политикой удаленного доступа. Политика удаленного доступа — это набор условий и параметров подключения, с помощью которых сетевые администраторы могут более гибко управлять разрешениями на удаленный доступ в систему. Если параметры попытки подключения не соответствуют ни одной из применяемых для подключения политик удаленного доступа, эта попытка подключения отклоняется вне зависимости от параметров входящих звонков учетной записи пользователя.
  • Методы проверки подлинности, поддерживаемые компонентом «Сетевые подключения», контролируют доступ к самой сети, а не к ресурсам сети. После подключения пользователя к сети управление его доступом к ресурсам осуществляется с помощью списков управления доступом различными компонентами: оснастка «Локальные пользователи и группы», служба Active Directory, оснастка «Групповая политика», служба общего доступа к файлам и принтерам и т. п.
  • Методы проверки подлинности предназначены для сред с использованием удаленного доступа, где вызывающий компьютер получает доступ к сети только после проверки его учетных данных, таких как имя пользователя и пароль.
  • Сведения о настройке таких средств защиты подключений, как протоколы проверки подлинности и шифрование данных, см. в разделе Средства безопасности в компоненте «Сетевые подключения».
  • Если служба RRAS запускается из командной строки, для правильной работы службы необходимо также настроить порты в брандмауэре Windows. Для этого на вкладке Исключения брандмауэра Windows нажмите кнопку Добавить порт и откройте следующие порты: порт 1723 для PPTP – TCP, порт 1701 для L2TP – UDP и порт 500 для IKE – UDP. Чтобы открыть эти порты только для конкретного подключения, используйте раздел Параметры сетевого подключения на вкладке Дополнительно.


Шифрование данных

Выполняя шифрование, вы как бы помещаете в сейф нечто ценное и запираете на ключ. Данные, зашифрованные с помощью соответствующего алгоритма, становятся нечитаемыми, если не знать ключ шифрования. Ключи для шифрования данных определяются во время подключения локального компьютера к удаленному. Использование шифрования данных может быть инициировано как локальным компьютером, так и сервером, к которому он подключается.

Сетевые подключения поддерживают два типа шифрования: метод Microsoft MPPE, использующий алгоритм шифрования RSA RC4, и метод IPSec, использующий алгоритмы шифрования DES (Data Encryption Standard) и Triple DES. И MPPE, и IPSec допускают несколько уровней шифрования, как показано в следующей таблице.

Метод шифрования
Стандартное шифрование MPPE (40- и 56-разрядные ключи)
Усиленное шифрование MPPE (128-разрядный ключ)
IPSec DES (56-разрядный ключ)
IPSec Triple DES (3DES, 168-разрядный ключ)

Примечания

  • Путем настройки сервера можно запретить использование шифрования, потребовать использования конкретного метода шифрования или позволить компьютеру самому выбрать метод шифрования. По умолчанию серверы, как правило, разрешают использование шифрования и позволяют клиентам выбирать методы шифрования. Это допустимо для большинства компьютеров. Требования к шифрованию устанавливаются системным администратором. Чтобы узнать, какие именно возможности доступны, обратитесь к системному администратору.
  • Чтобы включить шифрование данных с использованием MPPE на подключениях удаленного доступа или подключениях VPN, необходимо активизировать проверку подлинности по протоколу MS-CHAP, MS-CHAP v2 или EAP-TLS. Все эти методы проверки подлинности генерируют ключи, используемые в процессе шифрования.
  • Методы шифрования, используемые в виртуальных частных сетях (VPN), зависят от типа сервера, к которому они подключаются. Если подключение VPN настроено на связь через сервер PPTP, применяется шифрование MPPE. Если подключение VPN устанавливается через сервер L2TP, используются методы шифрования IPSec. Если подключение VPN настроено на автоматический выбор типа сервера (так происходит по умолчанию), то сначала предпринимается попытка использовать протокол L2TP и связанный с ним метод шифрования IPSec (при наличии сертификата у компьютера), а затем — PPTP и шифрование MPPE.

См. также


Протокол MPPE (Microsoft Point-to-Point Encryption)

Протокол MPPE (Microsoft Point-to-Point Encryption) шифрует данные, которые передаются через подключения удаленного доступа, установленные по протоколу PPP, и подключения VPN, использующие протокол PPTP. Поддерживаются две схемы шифрования MPPE — усиленная (с использованием 128-разрядного ключа) и стандартная (с 40-разрядным ключом). MPPE обеспечивает защиту данных, проходящих между локальным подключением PPTP и сервером туннеля.

Дополнительные сведения о настройке подключений см. в разделе Чтобы настроить подключение.

Примечание

  • MPPE требует использования общих ключей клиента и сервера, генерируемых протоколом проверки подлинности MS-CHAP или EAP.


Общие сведения о протоколе IPSec (Internet Protocol security)

IPSec — это набор служб защиты и протоколов безопасности, основанных на средствах криптографии; этот протокол представляет одно из наиболее перспективных направлений развития средств защиты сетей. Для его внедрения не требуется вносить какие-либо изменения в приложения или протоколы, поэтому IPSec легко развертывается в уже существующих сетях.

IPSec обеспечивает проверку подлинности на уровне компьютера и шифрование данных для подключений VPN, использующих протокол L2TP. Перед установкой подключения L2TP протокол IPSec выполняет согласование связи между компьютером и удаленным сервером туннеля, что позволяет защитить и пароли, и данные.

При взаимодействии с IPSec протокол L2TP использует стандартные методы проверки подлинности на базе PPP, такие как EAP, MS-CHAP, CHAP, SPAP и PAP.

Тип шифрования определяется так называемым сопоставлением безопасности IPSec. Сопоставление безопасности — это набор атрибутов, состоящий из адреса назначения, протокола безопасности и уникального идентификатора, называемого индексом параметров безопасности. Поддерживаются следующие алгоритмы шифрования:

  • DES (Data Encryption Standard), использующий 56-разрядный ключ;
  • 3DES (Triple DES), использующий два 56-разрядных ключа и предназначенный для среды с высоким уровнем безопасности, характерной для Северной Америки.

Дополнительные сведения о протоколе IPSec см. в разделе Протокол IPSec (Internet Protocol security).

Дополнительные сведения о настройке подключений см. в разделе Чтобы настроить подключение.


Использование промежуточного устройства

Компонент «Сетевые подключения» поддерживает промежуточные устройства различных типов, которые располагаются между клиентом и сервером удаленного доступа. В их число входят следующие устройства:

  • коммутаторы модемных пулов;
  • защитные узлы;
  • сети X.25.

Перед подключением к серверу удаленного доступа клиент проводит настройку каждого из промежуточных устройств, используя специальное диалоговое окно для ввода пользовательских данных и отображения ответов компьютера. Эти диалоговые окна бывают двух видов:

  • статическое диалоговое окно (никогда не изменяется и не требует, чтобы пользователь вводил какие-либо данные);
  • интерактивное диалоговое окно (каждый раз меняется и требует ввода данных пользователем).

Необходимо настроить подключение на работу с каждым промежуточным устройством.

Если требуется использовать как статическое, так и интерактивное диалоговые окна, выполните следующие действия.

  1. Напишите сценарий для статического диалогового окна. Дополнительные сведения см. в разделе Создание сценариев для промежуточных устройств.
  2. Включите режим терминала для интерактивного диалогового окна. Дополнительные сведения см. в разделе Чтобы войти на удаленный компьютер с помощью окна терминала.

Если планируется использовать только один из двух видов диалогового окна, достаточно выполнить лишь одно из этих действий. Например:

  • если клиенты подключаются только через одно промежуточное устройство со статическим диалоговым окном (например, через сеть X.25), пропустите шаг 2;
  • если клиенты подключаются через защитный узел, используя интерактивное диалоговое окно, пропустите шаг 1.


Защитные узлы

Защитный узел — это устройство проверки подлинности, которое проверяет, разрешено ли данное подключение к серверу удаленного доступа. Такая проверка дополняет средства безопасности, предоставляемые компонентом «Сетевые подключения» и системой Windows 2000 Server. Существует два типа защитных узлов.

  • Узлы, выполняющие проверку подлинности при модемных вызовах.

    Защитные узлы этого типа располагаются между клиентом и сервером удаленного доступа и выполняют свою проверку до проверки подлинности сервером удаленного доступа. Такие узлы обычно образуют дополнительный уровень защиты, требуя от клиента наличия некоторого аппаратного ключа. Только после проверки этого ключа может быть предоставлен доступ к серверу удаленного доступа. Подобная открытая архитектура позволяет системному администратору выбрать из списка нужный защитный узел, дополняющий средства безопасности компонента «Сетевые подключения», однако следует учесть, что проверка подлинности ограничена только модемными вызовами.

    Например, одна из таких систем безопасности состоит из двух аппаратных устройств: узла защиты и карточки безопасности. Узел защиты устанавливается между сервером удаленного доступа и его модемом. Карточка безопасности представляет собой небольшое устройство размером с кредитную карточку, похожее на карманный калькулятор без клавиш. Карточка безопасности показывает меняющийся каждую минуту код доступа. Этот код синхронизируется с аналогичным кодом, вычисляемым каждую минуту защитным узлом. При подключении пользователь передает на узел свой PIN-код и код, показываемый карточкой безопасности. Если указанные данные совпадают с кодом, вычисленным защитным узлом, последний разрешает подключение к серверу удаленного доступа.

    Другие защитные узлы того же типа запрашивают у клиента имя пользователя (которое может не совпадать с именем пользователя службы удаленного доступа) и пароль (отличающийся от пароля для удаленного доступа). Защитный узел должен быть настроен так, чтобы сервер удаленного доступа мог инициализировать модем до выполнения процедур системы безопасности. Кроме того, сервер удаленного доступа должен иметь возможность непосредственно инициализировать модем, подключенный к защитному узлу, не подвергаясь проверкам этого узла.

  • Узлы, вызываемые в процессе проверки подлинности.

    Узлы этого типа выполняют специальные виды проверки в процессе проверки подлинности службы удаленного доступа. Такая проверка может как дополнять, так и замещать стандартную проверку идентификационных данных пользователя сети XOX службой маршрутизации и удаленного доступа. Примерами защитных узлов такого типа являются серверы RADIUS, выполняющие проверку подлинности пользователей от имени службы маршрутизации и удаленного доступа. С появлением протокола Extensible Authentication Protocol (EAP) независимые разработчики получили возможность создавать интерфейсы между системой проверки подлинности при удаленном доступе и своими серверами. Такие серверы используются для проверки смарт-карт и других видов удостоверений.

Примечание

  • Чтобы с данным подключением могли работать и другие устройства безопасности, включите режим терминала для взаимодействия с защитным узлом. Дополнительные сведения см. в разделе Вход на удаленный компьютер с помощью окна терминала.
  • Если служба RRAS запускается из командной строки, для правильной работы службы необходимо также настроить порты в брандмауэре Windows. Для этого на вкладке Исключения брандмауэра Windows нажмите кнопку Добавить порт и откройте следующие порты: порт 1723 для PPTP – TCP, порт 1701 для L2TP – UDP и порт 500 для IKE – UDP. Чтобы открыть эти порты только для конкретного подключения, используйте раздел Параметры сетевого подключения на вкладке Дополнительно.


Настройка параметров проверки подлинности пользователя и шифрования данных для подключения удаленного доступа

Рисунок Microsoft Windows

Чтобы настроить параметры проверки подлинности пользователя и шифрования данных для подключения удаленного доступа

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение удаленного доступа, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Безопасность выполните одно из следующих действий.
    • Чтобы выбрать одну из готовых комбинаций методов проверки подлинности и требований шифрования данных, установите переключатель в положение Обычные (рекомендуемые параметры) и в списке При проверке используется выберите нужный метод проверки подлинности.

      В зависимости от того, какой метод выбран в списке При проверке используется, можно установить (включить) или снять (отключить) флажки Использовать автоматически имя входа и пароль из Windows (и имя домена, если существует) и Требуется шифрование данных (иначе отключаться). В следующей таблице показаны флажки, доступные для каждого из выбранных методов.

      Если флажок Требуется шифрование данных (иначе отключаться) снят, шифрование данных считается необязательным. Чтобы запретить шифрование, установите переключатель в положение Дополнительные (особые параметры) и нажмите кнопку Настройка. В списке Шифрование данных выберите вариант Не разрешено (отключиться, если требуется шифрование).

      • При проверке используется | Использовать автоматически имя входа и пароль из Windows (и имя домена, если существует) | Требуется шифрование данных (иначе отключаться)
Небезопасный пароль | Недоступен | Недоступен
Безопасный пароль | Доступен | Доступен
Смарт-карта | Недоступен | Доступен

    • Для включения, настройки или отключения отдельных методов проверки подлинности и требований шифрования данных установите переключатель в положение Дополнительные (особые параметры) и нажмите кнопку Настройка.

Важно!

  • Для изменения дополнительных параметров (вариант Дополнительные (особые параметры)) необходимо знать основы протоколов безопасности.

Примечание

  • XOX

См. также


Настройка параметров проверки подлинности пользователя и шифрования данных для подключения VPN

Рисунок Microsoft Windows

Чтобы настроить параметры проверки подлинности пользователя и шифрования данных для подключения VPN

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение VPN, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Безопасность выполните одно из следующих действий.
    • Чтобы выбрать одну из готовых комбинаций методов проверки подлинности и требований шифрования данных, установите переключатель в положение Обычные (рекомендуемые параметры) и в списке При проверке используется выберите нужный метод проверки подлинности.

      В зависимости от того, какой метод выбран в списке При проверке используется, можно установить (включить) или снять (отключить) флажки Использовать автоматически имя входа и пароль из Windows (и имя домена, если существует) и Требуется шифрование данных (иначе отключаться). В следующей таблице показаны флажки, доступные для каждого из выбранных методов.

      Если флажок Требуется шифрование данных (иначе отключаться) снят, шифрование данных считается необязательным. Чтобы запретить шифрование, установите переключатель в положение Дополнительные (особые параметры) и нажмите кнопку Настройка. В списке Шифрование данных выберите вариант Не разрешено (отключаться, если требуется шифрование).

      • При проверке используется | Использовать автоматически имя входа и пароль из Windows (и имя домена, если существует) | Требуется шифрование данных (иначе отключаться)
Безопасный пароль | Доступен | Доступен (установлен по умолчанию)
Смарт-карта | Недоступен | Доступен (установлен по умолчанию)

    • Для включения, настройки или отключения отдельных методов проверки подлинности и требований шифрования данных установите переключатель в положение Дополнительные (особые параметры) и нажмите кнопку Настройка.

Важно!

  • Для изменения дополнительных параметров (вариант Дополнительные (особые параметры)) необходимо знать основы протоколов безопасности.

Примечание

  • XOX

См. также


Процесс проверки подлинности при удаленном доступе

При подключении к Интернету проверка подлинности для удаленного доступа сводится к одной операции. Локальный компьютер предъявляет учетные данные (обычно это имя пользователя и пароль), которые принимаются и проверяются сервером удаленного доступа, установленным у поставщика услуг Интернета, и пользователю предоставляется доступ в Интернет.

При подключении к корпоративной сети, в которой имеется домен Windows, выполняется аналогичная процедура. Но в этом случае проверка подлинности удаленного доступа состоит из двух этапов. После того как пользователь подключился к сети, запрашиваемые им ресурсы (такие, как серверы обслуживания файлов и принтеров) при каждой попытке доступа к ним требуют, чтобы клиент представил учетные данные пользователя домена. Эти учетные данные могут отличаться от учетных данных, запрашиваемых сервером удаленного доступа.

Помимо этого, учетные данные требуются для доступа к компьютеру под управлением безопасной операционной системы, такой как XOX.

Это значит, что для удаленного доступа к компьютеру требуются три набора учетных данных: первый — для входа в систему компьютера; второй — для сервера удаленного доступа и третий — для доступа к сетевым ресурсам. Во всех трех случаях можно использовать один и тот же набор учетных данных, как описано ниже, но это могут быть и разные наборы.

Компьютеры защищенной корпоративной сети обычно являются членами домена. Применительно к XOX это означает, что до получения доступа к системе учетные данные, которые предоставляет пользователь при входе в систему, проверяются на контроллере домена. Таким образом, эти же учетные данные будут использоваться для удовлетворения запросов сетевых ресурсов. В целях упрощения удаленного доступа многие корпоративные сети устроены так, чтобы и сервер удаленного доступа признавал те же учетные данные пользователя домена. Тем самым для рядовых компьютеров домена обеспечивается единая, разовая процедура входа в сеть. Один и тот же набор учетных данных после установки подключения открывает доступ к компьютеру, обеспечивает удаленный доступ к корпоративной сети и разрешает обращаться к сетевым ресурсам.

Чтобы реализовать разовую процедуру входа на компьютерах, которые являются членами домена, сетевые подключения в XOX можно настроить таким образом, чтобы они предоставляли учетные данные пользователя, используемые для входа в систему, серверу удаленного доступа. Тем самым исключается необходимость предоставлять учетные данные серверу явным образом. Поскольку учетные данные входа в систему совпадают с учетными данными пользователя домена, они же позволят удовлетворять и запросы от сетевых ресурсов.

Однако компьютеры, установленные вне офиса (например, дома), обычно не являются членами домена, поэтому учетные данные входа пользователя в систему, открывающие доступ к компьютеру, не обеспечивают доступ к домену. Бывает также, что сервер удаленного доступа требует учетные данные, никак не связанные с учетными данными домена сети. В таком случае придется предоставлять три набора учетных данных — для входа в систему на компьютере, для подключения к удаленной сети и затем для доступа к ресурсам этой сети.

См. также


Проверка подлинности и шифрование данных для подключений удаленного доступа

Параметры безопасности, выбираемые с помощью переключателя Обычные (рекомендуемые параметры) на вкладке Безопасность, активизируют заранее определенный набор методов проверки подлинности и требований к шифрованию, которые согласовываются с сервером при установлении связи по протоколу PPP.

В следующей таблице приводятся методы проверки подлинности и шифрования данных, которые можно использовать при различных сочетаниях параметров При проверке используется и Требуется шифрование данных (иначе отключаться). Эти параметры можно также просмотреть, выбрав в группе Обычные (рекомендуемые параметры) нужные варианты проверки подлинности и шифрования данных, а затем установив переключатель в положение Дополнительные (выборочные параметры) и нажав кнопку Настройка.

Используя переключатель Дополнительные (выборочные параметры), можно включать, отключать и настраивать параметры безопасности по отдельности, но это требует знания протоколов безопасности.

Для получения дополнительных сведений о каком-либо конкретном методе проверки подлинности или шифрования данных щелкните этот метод в таблице. Сведения о настройке параметров подключения см. в разделе Чтобы настроить подключение.

При проверке используется | Требуется шифрование данных | Доступные методы проверки подлинности | Шифрование
Небезопасный пароль | Нет | PAP, CHAP, SPAP, MS-CHAP, MS-CHAP v2 | Optional encryption (connect even if no encryption)
Безопасный пароль | Нет | CHAP, MS-CHAP, MS-CHAP v2 | Необязательное (подключиться даже без шифрования)
Безопасный пароль | Да | MS-CHAP, MS-CHAP v2 | Обязательное (отключиться, если нет шифрования)
Смарт-карта | Нет | EAP/TLS | Необязательное (подключиться даже без шифрования)
Смарт-карта | Да | EAP/TLS | Обязательное (отключиться, если нет шифрования)

Примечания

  • Данные шифруются только в том случае, если согласовано использование одного из следующих протоколов проверки подлинности: MS-CHAP, MS-CHAP v2 или EAP/TLS. Только эти протоколы генерируют собственные начальные ключи шифрования, которые необходимы для операций шифрования.
  • Протокол MPPE (Microsoft Point-to-Point Encryption) шифрует данные на подключениях удаленного доступа, основанных на протоколе PPP. Поддерживаются две схемы шифрования MPPE — усиленная (с использованием 128-разрядного ключа) и стандартная (с 40-разрядным ключом).
  • MS-CHAP v2 и EAP — это протоколы взаимной проверки подлинности, при которой и клиент, и сервер должны предоставлять доказательства своей подлинности. Если подключение использует MS-CHAP v2 или EAP в качестве единственного метода проверки подлинности, а сервер, к которому выполняется подключение, не предоставляет доказательства своей подлинности, то подключиться к нему не удастся. Ранее серверам разрешалось принимать вызовы, избегая проверки подлинности. Данное изменение позволяет гарантировать подключение именно к нужному серверу.


Проверка подлинности и шифрование данных для подключений VPN

Параметры безопасности, выбираемые с помощью переключателя Обычные (рекомендуемые параметры) на вкладке Безопасность, активизируют заранее определенный набор методов проверки подлинности и требований к шифрованию, которые согласовываются с сервером при установлении связи по протоколу PPP.

В следующих таблицах приводятся методы проверки подлинности и шифрования данных, которые можно использовать при различных сочетаниях параметров При проверке используется и Требуется шифрование данных (иначе отключаться). Эти параметры можно также просмотреть, выбрав в группе Обычные (рекомендуемые параметры) нужные варианты проверки подлинности и шифрования данных, а затем установив переключатель в положение Дополнительные (выборочные параметры) и нажав кнопку Настройка.

Используя переключатель Дополнительные (выборочные параметры), можно включать, отключать и настраивать параметры безопасности по отдельности, но это требует знания протоколов безопасности.

Для получения дополнительных сведений о каком-либо конкретном методе проверки подлинности или шифрования данных щелкните этот метод в таблице. Сведения о настройке параметров подключения см. в разделе Чтобы настроить подключение.

Сервер удаленного доступа, использующий протокол PPTP (Point-to-Point Tunneling Protocol), или автоматический сервер удаленного доступа

При проверке используется | Требуется шифрование данных | Доступные методы проверки подлинности | Шифрование
Безопасный пароль | Нет | CHAP, MS-CHAP, MS-CHAP v2 | Необязательное (подключиться даже без шифрования)
Безопасный пароль | Да | MS-CHAP, MS-CHAP v2 | Обязательное (отключиться, если нет шифрования)
Смарт-карта | Нет | EAP/TLS | Необязательное (подключиться даже без шифрования)
Смарт-карта | Да | EAP/TLS | Обязательное (отключиться, если нет шифрования)

Сервер удаленного доступа, использующий протокол L2TP (Layer Two Tunneling Protocol)

При проверке используется | Требуется шифрование данных | Доступные методы проверки подлинности | Шифрование
Безопасный пароль | Нет | CHAP, MS-CHAP, MS-CHAP v2 | Необязательное (подключиться даже без шифрования)
Безопасный пароль | Да | CHAP, MS-CHAP, MS-CHAP v2 | Обязательное (отключиться, если нет шифрования)
Смарт-карта | Нет | EAP/TLS | Необязательное (подключиться даже без шифрования)
Смарт-карта | Да | EAP/TLS | Обязательное (отключиться, если нет шифрования)

Примечания

  • На подключениях VPN, использующих протокол L2TP, данные шифруются по протоколу IPSec (Internet Protocol security).
  • Протокол MPPE (Microsoft Point-to-Point Encryption) применяется для шифрования данных на подключениях VPN, использующих протокол PPP. Поддерживаются две схемы шифрования MPPE — усиленная (с использованием 128-разрядного ключа) и стандартная (с 40-разрядным ключом).
  • Данные шифруются по протоколу MPPE только в том случае, если согласовано использование одного из следующих протоколов проверки подлинности: MS-CHAP, MS-CHAP v2 или EAP/TLS. Это единственные протоколы проверки подлинности, генерирующие собственные начальные ключи шифрования. MPPE требует использования общих ключей клиента и сервера, создаваемых указанными алгоритмами проверки подлинности.
  • MS-CHAP v2 и EAP/TLS — это протоколы взаимной проверки подлинности, при которой и клиент, и сервер должны предоставлять доказательства своей подлинности. Если подключение использует MS-CHAP v2 или EAP/TLS в качестве единственного метода проверки подлинности, а сервер, к которому выполняется подключение, не предоставляет доказательства своей подлинности, то подключиться к нему не удастся. Ранее серверам разрешалось принимать вызовы, избегая проверки подлинности. Данное изменение позволяет гарантировать подключение именно к нужному серверу.


Протокол PAP (Password Authentication Protocol)

PAP (Password Authentication Protocol) — это протокол простой проверки подлинности, предусматривающий отправку имени пользователя и пароля на сервер удаленного доступа открытым текстом (без шифрования). Протокол PAP крайне ненадежен, поскольку пересылаемые пароли можно легко читать в пакетах PPP (Point-to-Point Protocol), которыми обмениваются стороны в ходе проверки подлинности. Обычно PAP используется только при подключении к старым серверам удаленного доступа на базе UNIX, которые не поддерживают никакие другие протоколы проверки подлинности.

Примечания

  • Если подлинность подключения проверяется по протоколу PAP, использовать алгоритм шифрования MPPE (Microsoft Point-to-Point Encryption) нельзя.
  • Если для подключения к серверу, на котором настроен только протокол PAP, требуется безопасный пароль, клиент удаленного доступа XOX разрывает подключение.

См. также


Протокол CHAP (Challenge Handshake Authentication Protocol)

CHAP (Challenge Handshake Authentication Protocol) — это широко распространенный алгоритм проверки подлинности, предусматривающий передачу не самого пароля пользователя, а косвенных сведений о нем. При использовании CHAP сервер удаленного доступа отправляет клиенту строку запроса. На основе этой строки и пароля пользователя клиент удаленного доступа вычисляет хеш-код MD5 (Message Digest-5). Хеш-функция является алгоритмом одностороннего (необратимого) шифрования, поскольку значение хеш-функции для блока данных вычислить легко, а определить исходный блок по хеш-коду с математической точки зрения невозможно. Хеш-код MD5 передается серверу удаленного доступа. Сервер, которому доступен пароль пользователя, выполняет те же самые вычисления и сравнивает результат с хеш-кодом, полученным от клиента. В случае совпадения учетные данные клиента удаленного доступа считаются подлинными.

Примечание

  • Если подлинность подключения проверяется по протоколу CHAP, использовать алгоритм шифрования MPPE (Microsoft Point-to-Point Encryption) нельзя.
  • Если протокол CHAP используется при подключении к серверу удаленного доступа, на котором работает операционная система Windows 2000 и служба маршрутизации и удаленного доступа, учетная запись пользователя, инициирующая подключение клиента, должна разрешать хранение пароля в обратимо зашифрованном виде. Дополнительные сведения содержатся в справке Windows 2000 Server.

См. также


Протокол SPAP (Shiva Password Authentication Protocol)

SPAP (Shiva Password Authentication Protocol) — это протокол простой проверки подлинности шифрованных паролей, поддерживаемый серверами удаленного доступа Shiva. С помощью SPAP клиент удаленного доступа отправляет зашифрованный пароль на сервер удаленного доступа. SPAP использует алгоритм двустороннего (обратимого) шифрования. Сервер удаленного доступа расшифровывает пароль и проверяет подлинность клиента по паролю, представленному открытым текстом.

Примечание

  • Если подлинность подключения проверяется по протоколу PAP, использовать алгоритм шифрования MPPE (Microsoft Point-to-Point Encryption) нельзя.

См. также


Протокол MS CHAP (Microsoft Challenge Handshake Authentication Protocol)

Корпорация Майкрософт разработала протокол MS-CHAP для выполнения процедур проверки подлинности удаленных рабочих станций Windows; он поддерживает функциональные возможности, привычные для пользователей локальных сетей, и интегрирует алгоритмы шифрования и хеширования, действующие в сетях Windows. Для проведения проверки подлинности без передачи пароля протокол MS-CHAP, как и CHAP, использует механизм «запрос-ответ».

Протокол MS-CHAP генерирует запрос и ответ с помощью алгоритма хеширования MD4 (Message Digest 4) и алгоритма шифрования DES (Data Encryption Standard); предусмотрены также механизмы возврата сообщений об ошибках подключения и возможности изменения пароля пользователя. Пакет ответа — это формат, разработанный специально для работы с сетевыми продуктами в операционных системах Windows 95, Windows 98, Windows Millennium Edition, Windows NT, Windows 2000 и XOX.

Примечания

  • Существует версия MS-CHAP, предназначенная специально для подключения к серверу Windows 95. Эту версию следует использовать, если подключение устанавливается с сервером, работающим под управлением Windows 95. Чтобы включить эту версию, установите флажок Разрешить старый протокол MS-CHAP для Windows 95 в диалоговом окне Дополнительные параметры безопасности.
  • В отличие от CHAP, MS-CHAP не требует, чтобы пароль учетной записи пользователя хранился в обратимо зашифрованном виде.
  • В процессе проверки подлинности по протоколу MS-CHAP генерируются общие секретные ключи шифрования для алгоритма MPPE (Microsoft Point-to-Point Encryption).

См. также


Протокол MS CHAP v2 (Microsoft Challenge Handshake Authentication Protocol версии 2)

XOX поддерживает протокол MS CHAP v2 (Microsoft Challenge Handshake Authentication Protocol версии 2). Он выполняет взаимную проверку подлинности и генерирует более надежные начальные ключи шифрования данных для протокола MPPE (Microsoft Point-to-Point Encryption), а также различные ключи шифрования для отправки и получения данных. Чтобы свести к минимуму риск раскрытия пароля во время обмена паролями, из протокола исключена поддержка старых методов обмена паролями MS-CHAP.

Поскольку версия MS-CHAP v2 обеспечивает более надежную защиту, чем MS-CHAP, при подключении сначала предлагается использовать именно ее (если она доступна), а затем уже MS-CHAP.

Протокол MS-CHAP v2 поддерживается на компьютерах под управлением XOX, Windows 2000, Windows 98, Windows Millennium Edition и Windows NT 4.0. На компьютерах, работающих под управлением Windows 95, протокол MS-CHAP v2 поддерживается только для подключений VPN, но не для подключений удаленного доступа.

Примечание

  • MS-CHAP v2 — это протокол взаимной проверки подлинности, при которой и клиент, и сервер должны доказать, что они знают пароль пользователя. Сначала доказательство затребует сервер удаленного доступа, отправляя запрос клиенту удаленного доступа. Затем наступает очередь клиента, который отправляет запрос серверу удаленного доступа. Если сервер не может правильно ответить на запрос клиента и таким образом оказывается не в состоянии доказать, что знает пароль пользователя, клиент разрывает подключение. Если бы проверка подлинности не была взаимной, клиент удаленного доступа не смог бы распознать подключение к серверу, выдающему себя за другого.

См. также


Протокол EAP (Extensible Authentication Protocol)

Протокол EAP (Extensible Authentication Protocol) является расширением протокола Point-to-Point Protocol (PPP); на нем основаны несколько методов проверки подлинности, предусматривающих обмен учетными данными и прочими сведениями произвольного объема. Протокол EAP был разработан с учетом растущей потребности в средствах проверки подлинности, использующих более широкий круг устройств системы безопасности; он предлагает стандартную архитектуру для поддержки дополнительных методов проверки подлинности в рамках PPP.

С помощью EAP можно реализовать поддержку нескольких алгоритмов проверки подлинности — так называемых типов EAP, к числу которых относятся генераторы кода доступа, одноразовые пароли, средства проверки подлинности на основе открытых ключей с использованием смарт-карт, сертификатов и др. Протокол EAP, в сочетании со строгими типами EAP, является ключевым компонентом технологии безопасных подключений виртуальных частных сетей (VPN). Строгие типы EAP, например основанные на сертификатах, обеспечивают более надежную защиту от попыток «грубого» взлома системы или подбора пароля, чем другие протоколы проверки подлинности, использующие пароли, такие как CHAP и MS-CHAP.

Чтобы узнать, используется ли в вашей организации какой-либо тип EAP, обратитесь к своему администратору сети.

В XOX существует поддержка двух типов EAP:

  • EAP-MD5 CHAP (аналог протокола проверки подлинности CHAP);
  • EAP-TLS (применяется для проверки подлинности на основе сертификатов пользователей).

EAP-TLS — это метод взаимной проверки подлинности, при котором и клиент, и сервер должны предоставлять доказательства своей подлинности. В ходе сеанса EAP-TLS клиент удаленного доступа отправляет свой сертификат пользователя, а сервер удаленного доступа — свой сертификат компьютера. Если хотя бы один из этих сертификатов не будет передан или окажется недействительным, подключение разрывается.

Примечания

  • В процессе проверки подлинности методом EAP-TLS генерируются общие секретные ключи шифрования для алгоритма MPPE (Microsoft Point-to-Point Encryption).

См. также


Проверка подлинности с помощью смарт-карт и других сертификатов

Если имеется сертификат, установленный в хранилище сертификатов на компьютере или расположенный на смарт-карте, и включен протокол EAP (Extensible Authentication Protocol), то при входе в сеть можно использовать проверку подлинности с помощью сертификатов.

Сертификат представляет собой набор зашифрованных данных, предназначенных для проверки. Сертификат содержит цифровую подпись центра сертификации, который его выдал. В процессе проверки подлинности с помощью сертификата компьютер предоставляет свой сертификат серверу, а сервер предоставляет свой сертификат компьютеру, т.е. осуществляется взаимная проверка. Проверка подлинности сертификата заключается в проверке цифровой подписи с помощью открытого ключа, который содержится в корневом сертификате доверенного центра сертификации, хранящемся на локальном компьютере. Корневые сертификаты служат основой проверки сертификатов и должны предоставляться только системным администратором. Существует несколько доверенных корневых сертификатов. Добавлять и удалять доверенные корневые сертификаты следует только по согласованию с системным администратором.

Сертификаты могут находиться либо в хранилище сертификатов на локальном компьютере, либо на смарт-картах. Смарт-карта — это устройство размером с кредитную карточку, вставляемое в считыватель смарт-карт, который устанавливается внутри компьютера или подключается к нему снаружи.

Настраивая параметры безопасности подключения, можно выбрать режим использование смарт-карты или другого сертификата и указать необходимые требования к их обработке. Например, можно задать проверку сертификата сервера и выбрать для сервера доверенный корневой центр сертификации.

Если создавать подключение с помощью мастера нового подключения на компьютере, на котором установлено устройство для чтения смарт-карт, операционная система обнаружит устройство и предложит использовать на данном подключении проверку подлинности с помощью смарт-карт. Можно отказаться от этого предложения во время установки подключения и включить проверку подлинности с помощью смарт-карт позднее. Дополнительные сведения см. в разделе Чтобы включить проверку подлинности с помощью смарт-карт или других сертификатов.

Сведения о том, как член домена Active Directory должен запрашивать сертификат, см. в разделе Запрос сертификата. Сведения о запросе сертификата пользователем, не являющимся членом домена Active Directory, и о запросе сертификата через Интернет см. в разделе Отправка запроса на сертификат пользователя через Интернет. Сведения о мобильных пользователях и сертификатах см. в разделе Мобильные пользователи и сертификаты.


Включение проверки подлинности с помощью смарт-карт или других сертификатов

Рисунок Microsoft Windows

Чтобы включить проверку подлинности с помощью смарт-карт или других сертификатов

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение удаленного доступа, подключение VPN или входящее подключение, для которого требуется проверять подлинность с помощью смарт-карты или других сертификатов, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. Если используются стандартные параметры смарт-карты, на вкладке Безопасность установите переключатель в положение Обычные (рекомендуемые параметры) и выберите в списке Производить проверку с использованием вариант Использовать смарт-карту.
  4. Если нужно включить, отключить или настроить отдельные методы проверки подлинности и требования к шифрованию, на вкладке Безопасность установите переключатель в положение Дополнительные (особые параметры), нажмите кнопку Настройка и выполните следующее.
    • Установите переключатель Безопасный вход в положение Расширяемый протокол идентификации (EAP), выберите в списке вариант Смарт-карта или иной сертификат (шифрование разрешено), нажмите кнопку Свойства и выполните следующие действия.
      1. Если нужно использовать сертификат, размещенный на смарт-карте, установите переключатель в положение использовать мою смарт-карту.
      2. Если нужно использовать сертификат, расположенный в хранилище сертификатов на компьютере, установите переключатель в положение использовать сертификат на этом компьютере.
      3. Если требуется проверить, не просрочен ли предоставленный компьютеру сертификат сервера, правильно ли он заверен и имеет ли он доверенный корневой центр сертификации, установите флажок Проверять сертификат сервера.
      4. Чтобы подключаться только к серверам определенного домена, установите флажок Подключаться только если имя сервера заканчивается на и введите имя домена.
      5. Чтобы потребовать принадлежности сертификата сервера определенному корневому центру сертификации, выберите нужный центр сертификации в списке Доверенный корневой центр сертификации.
      6. Чтобы использовать для подключения другое имя пользователя в случае, когда имя пользователя в смарт-карте или сертификате отличается от имени пользователя домена, в который выполняется вход, установите флажок Использовать для подключения другое имя пользователя.

Примечания

  • XOX
  • Если, например, требуется подключаться только к серверам, расположенным в домене Microsoft.com, введите Microsoft.com в поле Подключаться только если имя сервера заканчивается на.
  • Если, например, вы работаете в консультационной фирме и должны входить в домен компании, для которой ваша фирма выполняет работы, а ваша смарт-карта содержит имя пользователя, используемое в вашей фирме, установите флажок Использовать для подключения другое имя пользователя.
  • При установленном флажке Использовать для подключения другое имя пользователя сертификат экспортируется без закрытых ключей и отправляется системному администратору, чтобы тот явно сопоставил его с учетной записью пользователя домена. XOX
  • Если флажок Подключаться только если имя сервера заканчивается на установлен, а имя домена не введено, то при подключении будет предложено использовать имя домена из серверного сертификата.

См. также


Мобильные пользователи и сертификаты

Мобильные пользователи должны включать на своих компьютерах поддержку сертификатов. Если системный администратор перед выдачей компьютера пользователю не установил на нем сертификаты компьютера и пользователя, то пользователь должен сам подключиться к корпоративной сети, применяя обычные методы парольной проверки подлинности, и получить необходимые сертификаты. Подключившись, пользователь присоединяет свой компьютер к корпоративному домену, получает сертификаты и устанавливает политику сертификатов. При следующем подключении к корпоративной сети он сможет использовать методы проверки подлинности с помощью сертификатов, такие как протокол EAP.

Чтобы включить использование сертификатов на компьютере, выполните следующие действия.

  1. Войдите в корпоративную сеть, используя подключение удаленного доступа или сетевое подключение по протоколу PPTP, а также протокол проверки подлинности, такой как MS-CHAP или MS-CHAP v2. При этом компьютер будет включен в корпоративный домен и получит сертификаты компьютера.

  2. Запросите сертификат пользователя. Дополнительные сведения о запросе сертификатов см. в разделах Запрос сертификата, Отправка запроса на сертификат пользователя через Интернет и Запрос сертификатов.
  3. Создайте другое подключение, использующее проверку подлинности с помощью сертификатов. Подключитесь снова, используя такие методы проверки подлинности, как EAP или IPSec. Дополнительные сведения о включении режима использования смарт-карты или других сертификатов см. в разделе Чтобы включить проверку подлинности с помощью смарт-карт или других сертификатов.

Системный администратор может избавить пользователя от необходимости выполнять эти операции, установив сертификаты компьютера и пользователя на переносной компьютер перед выдачей его пользователю.

Примечание

  • Для автоматического получения сертификатов компьютера необходимо установить политику открытых ключей (с помощью оснастки «Групповая политика»), которая автоматически регистрирует компьютеры, нуждающиеся в сертификатах. Если процесс получения сертификатов компьютера не автоматизирован, необходимо войти на компьютер с учетной записью администратора, установить службы сертификации и запросить сертификат компьютера. Дополнительные сведения см. в разделах Управление сертификатами компьютера и Управление сертификатами учетной записи пользователя.


Общие сведения об окне терминала и сценариях входа

При подключении к серверу удаленного доступа, работающему под управлением операционной системы, отличной от Windows, иногда используется специальное окно терминала, в котором требуется ввести сведения, необходимые для входа в удаленную систему. Подключение должно быть для этого настроено соответствующим образом.

Для автоматизации процесса входа в удаленную систему с помощью терминала можно воспользоваться одним из двух методов: сценариями Switch.inf или сценариями Windows. Сценарии файла Switch.inf — это давно известный метод, применявшийся в предыдущих версиях Windows NT. Однако языком сценариев Windows 95 проще пользоваться, чем файлом Switch.inf.


Использование окна терминала в процессе удаленного входа

Если на сервере PPP или SLIP, к которому выполняется подключение, требуется входить в систему с помощью экрана эмуляции терминала, нужно настроить параметры сценария для данного сетевого подключения на использование окна терминала. В этом случае после установки соединения с удаленной системой появляется текстовое окно, в котором отображается последовательность операций входа в систему. Выполните в этом окне все действия, необходимые для входа на удаленный компьютер. Дополнительные сведения см. в разделе Чтобы войти на удаленный компьютер с помощью окна терминала. Можно также автоматизировать процесс входа в удаленную систему, как описано в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.

В некоторых коммерческих сетях перед процедурой входа на экран выводятся большие меню со списком предоставляемых услуг. При входе на серверы SLIP, обычно работающие под управлением UNIX, иногда приходится выполнять длинную последовательность команд, которые обновляют файлы, собирают данные о пользователе или настраивают подключение SLIP. Новые серверы PPP, как правило, запрашивают лишь имя пользователя и пароль.

Примечание

  • Если удаленный компьютер является сервером удаленного доступа, работающим под управлением Windows, то использовать окно терминала при входе не нужно. В этом случае процесс входа полностью автоматизирован.


Вход на удаленный компьютер с помощью окна терминала

Рисунок Microsoft Windows

Чтобы войти на удаленный компьютер с помощью окна терминала

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение удаленного доступа, для которого предполагается использовать окно терминала.
  3. В группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  4. На вкладке Безопасность в группе Интерактивная регистрация и сценарий установите флажок Вывести окно терминала.

Примечания

  • XOX
  • После установки подключения откроется окно «Терминал после набора номера», в котором появится приглашение на вход в систему удаленного компьютера. Выполните в этом окне все действия, необходимые для входа на удаленный компьютер. Когда процедура входа будет завершена, нажмите кнопку Готово. Сервер удаленного доступа начнет проверку подлинности.
  • Если последовательность действий для входа на удаленный компьютер не меняется, можно создать сценарий входа, который будет автоматически передавать запрашиваемые сведения удаленному компьютеру, что позволит полностью автоматизировать подключение.

См. также


Использование файлов команд устройств (inf-файлов)

Компонент «Сетевые подключения» использует файлы Switch.inf и Pad.inf для автоматизации процесса интерактивного входа на серверы и для инициализации модулей сборки и разборки пакетов (PAD) протокола X.25. Эти файлы команд устройств (inf-файлы), расположенные в папке системный_корневой_каталог\System32\Ras, используют одни и те же команды и синтаксис для автоматической связи с устройствами или компьютерами.

Switch.inf

Команды этого файла можно использовать при подключении к сети через защитный узел или удаленный сервер, на который требуется входить в интерактивном режиме (например, сервер UNIX). Чтобы создать сценарий, введите имя устройства в квадратных скобках, а затем добавьте одну или несколько команд. Активизируйте созданный сценарий (на вкладке Безопасность) для каждого подключения, которое должно его использовать. Сценарии могут использоваться до набора номера (например, для работы с модемным пулом) или после набора (например, при использовании защитных узлов или при входе непосредственно на удаленный сервер). Дополнительные сведения см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.

Pad.inf

Команды этого файла используются при подключении к сети с помощью устройства сборки и разборки пакетов (PAD) протокола X.25. Сценарии предусмотрены практически для всех поддерживаемых устройств PAD, и все они содержатся в файле Pad.inf. При необходимости можно создать сценарий самостоятельно, введя имя устройства в квадратных скобках и добавив одну или несколько команд. Активизируйте созданный сценарий (на вкладке Безопасность) для каждого подключения, которое должно его использовать.


Автоматизация процесса входа в удаленную систему с помощью сценариев Windows

Для автоматизации процесса входа в систему через подключение удаленного доступа можно использовать не только файл Switch.inf, но и язык сценариев Windows 95.

Для установления соединения многие поставщики услуг Интернета и интерактивные службы требуют вводить вручную такие данные, как имя пользователя и пароль. Благодаря тому, что компонент «Сетевые подключения» поддерживает сценарии, с их помощью этот процесс можно автоматизировать.

Сценарий — это текстовый файл, содержащий последовательность команд, параметров и выражений, которые необходимы для подключения к поставщику услуг Интернета или интерактивной службе и для получения доступа к предоставляемым ими ресурсам. Файл сценария можно создать в любом текстовом редакторе, например, в «Блокноте». Созданный файл сценария назначается конкретному подключению.

В папке системный_корневой_каталог\System32\Ras находятся следующие примеры сценариев.

Файл | Описание
Cis.scp | Подключение к Compuserve по протоколу PPP
Pppmenu.scp | Подключение по протоколу PPP к узлу, использующему систему меню
Slip.scp | Подключение к узлу по протоколу SLIP
Slipmenu.scp | Подключение по протоколу SLIP к узлу, использующему систему меню

Сведения об активизации сценария см. в разделе Чтобы активизировать сценарий входа в систему.

Дополнительные сведения об использовании языка сценариев Windows 95 содержатся в следующих разделах:

  • Основная структура сценария
  • Переменные
  • Системные переменные
  • Строковые литералы
  • Выражения
  • Комментарии
  • Ключевые слова
  • Команды
  • Зарезервированные слова


Основная структура сценария

Команды являются основными инструкциями, из которых состоит файл сценария. Некоторым командам требуются параметры, уточняющие их действие. Выражение представляет собой комбинацию операторов и аргументов, вычисление которых дает некий результат. В любой команде в качестве значений можно использовать выражения. Примерами выражений могут служить арифметическое выражение, операция сравнения и сцепление строк.

Общая структура сценария, используемого компонентом «Сетевые подключения», выглядит следующим образом.

;

; Комментарий начинается с точки с запятой и продолжается до

; конца строки.

;

proc main

; В сценарии можно использовать любое количество

; переменных и команд.

объявление переменных

блок команд

endproc

В сценарии обязательно должна быть процедура main, начинающаяся ключевым словом proc и завершающаяся ключевым словом endproc.

Переменные должны быть объявлены до блока команд. Сначала выполняется первая команда процедуры main, а затем — все последующие команды в том порядке, в котором они расположены в сценарии. Достигнув конца процедуры main, сценарий заканчивает работу.

Сведения об автоматизации процесса входа в систему при удаленном доступе с помощью языка сценариев Windows 95 см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Windows. Сведения об активизации сценария входа в систему см. в разделе Чтобы активизировать сценарий входа в систему.


Переменные

Сценарии могут содержать переменные. Имя переменной должно начинаться с буквы или символа подчеркивания (_) и может содержать любую последовательность прописных или строчных букв, цифр и символов подчеркивания. Использование зарезервированных слов в качестве имен переменных не допускается. Дополнительные сведения см. в разделе Зарезервированные слова.

Переменные должны быть объявлены до первого их использования в сценарии. При объявлении переменной нужно определить ее тип. Каждая переменная может содержать только значения того же типа. В следующей таблице описаны три поддерживаемые типа переменных.

Тип | Описание
integer (целый) | Отрицательное или положительное целое число, например, 7, -12 или 5698
string (строка) | Последовательность символов, заключенная в прямые кавычки. Например, "Hello world!" или "Enter password:"
boolean (логический) | Логическое значение: TRUE (истина) или FALSE (ложь)
Значения переменным присваиваются оператором присваивания:

переменная = выражение

Значением переменной будет результат вычисления выражения.

Например:

integer count = 5

integer timeout = (4 * 3)

integer i

boolean bDone = FALSE

string szIP = (getip 2)

set ipaddr szIP

Сведения об автоматизации процесса входа в систему при удаленном доступе с помощью языка сценариев Windows 95 см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Windows. Сведения об активизации сценария входа в систему см. в разделе Чтобы активизировать сценарий входа в систему.


Системные переменные

Системные переменные устанавливаются командами сценария или определяются данными, вводимыми при создании подключения. Системные переменные доступны только для чтения, т.е. их значения нельзя изменить в сценарии программным путем. Системные переменные описаны в следующей таблице.

Имя | Тип | Описание
$USERID | Строка | Идентификатор пользователя текущего подключения. Эта переменная содержит имя пользователя, указанное в диалоговом окне Подключение к
$PASSWORD | Строка | Пароль для текущего подключения. Эта переменная содержит пароль, указанный в диалоговом окне Подключение
$SUCCESS | Логический | Эта переменная устанавливается некоторыми командами и показывает, успешно ли была выполнена соответствующая команда. Значение этой переменной можно использовать для ветвления в сценарии
$FAILURE | Логический | Эта переменная устанавливается некоторыми командами и показывает, завершилась ли соответствующая команда неудачей. Значение этой переменной можно использовать для ветвления в сценарии

Эти переменные можно использовать везде, где допускаются выражения того же типа. Например:

transmit $USERID

Эта команда допустима, так как переменная $USERID принадлежит строковому типу.

Сведения об автоматизации процесса входа в систему при удаленном доступе с помощью языка сценариев Windows 95 см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Windows. Сведения об активизации сценария входа в систему см. в разделе Чтобы активизировать сценарий входа в систему.


Строковые литералы

В сценариях можно использовать управляющие последовательности и специальные символы, перечисленные в следующей таблице.

Строковый литерал | Описание
^символ Управляющий символ.

Если символ находится в интервале между '@' и '_', данная последовательность преобразуется в однобайтовое значение в диапазоне от 0 до 31. Например, последовательность ^M будет преобразована в символ возврата каретки.

Если символ является буквой из набора от 'a' до 'z', данная последовательность преобразуется в однобайтовое значение в диапазоне от 1 до 26.

Если же символ имеет какое-либо другое значение, эта последовательность преобразована не будет
<cr> | Возврат каретки
<lf> | Перевод строки
\" Кавычка
\^ Символ ^
\< Угловая скобка
\\ Обратная косая черта
Например:

transmit "^M"

transmit "Joe^M"

transmit "<cr><lf>"

waitfor "<cr><lf>"

Сведения об автоматизации процесса входа в систему при удаленном доступе с помощью языка сценариев Windows 95 см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Windows. Сведения об активизации сценария входа в систему см. в разделе Чтобы активизировать сценарий входа в систему.


Выражения

Выражение представляет собой комбинацию операторов и аргументов, задающую вычисление некоего результата. В любой команде в качестве значений можно использовать выражения.

Выражение может включать любое целое, строковое или логическое значение или переменную в сочетании с унарными и бинарными операторами, перечисленными в следующих таблицах. Все унарные операторы имеют наивысший приоритет. Бинарные операторы перечислены в таблице в порядке их приоритета.

В следующей таблице приводится список унарных операторов.

Оператор | Вид операции
- | Унарный минус
! | Дополнение до единицы

В следующей таблице приводится список бинарных операторов, упорядоченный в соответствии с их приоритетами. Операторы с более высоким приоритетом показаны первыми.

Оператор | Вид операции | Ограничения на тип
* / | Мультипликативная | Целые
+ - | Аддитивная | Целые, строковые (только для +)
<> <= >= | Отношение | Целые
== != | Равенство | Целые, строковые, логические
and | Логическое «И» | Логические
or | Логическое «ИЛИ» | Логические

Например:

count = 3 + 5 * 40

transmit "Hello" + "there"

delay 24 / (7 - 1)

Сведения об автоматизации процесса входа в систему при удаленном доступе с помощью языка сценариев Windows 95 см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Windows. Сведения об активизации сценария входа в систему см. в разделе Чтобы активизировать сценарий входа в систему.


Комментарии

Весь текст в строке после точки с запятой игнорируется. Например:

; это комментарий

transmit "hello" ; передача строки "hello"

Сведения об автоматизации процесса входа в систему при удаленном доступе с помощью языка сценариев Windows 95 см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Windows. Сведения об активизации сценария входа в систему см. в разделе Чтобы активизировать сценарий входа в систему.


Ключевые слова

Ключевые слова определяют структуру сценария. В отличие от команд они не выполняют никаких действий. Ключевые слова описаны в следующей таблице.

Ключевое слово | Описание
proc имя | Начало процедуры. Каждый сценарий должен включать в себя основную процедуру main (proc main). Выполнение сценария начинается с процедуры main и заканчивается по достижении ее конца.
endproc | Конец процедуры. Когда выполняющийся сценарий доходит до оператора endproc процедуры main, компонент «Сетевые подключения» запускает службу PPP или SLIP.
integer имя [ = значение ] | Объявление переменной целого типа. Для инициализации такой переменной можно использовать любое численное выражение или любую численную переменную.
string имя [ = значение ] | Объявление переменной строкового типа. Для инициализации такой переменной можно использовать любой строковый литерал или любую строковую переменную.
boolean имя [ = значение ] | Объявление переменной логического типа. Для инициализации такой переменной можно использовать любую логическую переменную или любое логическое выражение.

Сведения об автоматизации процесса входа в систему при удаленном доступе с помощью языка сценариев Windows 95 см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Windows. Сведения об активизации сценария входа в систему см. в разделе Чтобы активизировать сценарий входа в систему.


Команды

Все команды являются зарезервированными словами; это означает, что нельзя объявлять переменные, имена которых совпадают с именами этих команд. Команды описаны в следующей таблице.

Команда | Описание | Пример
delay nСекунд Пауза длительностью nСекунд перед выполнением следующей команды сценария delay 2 ; пауза в 2 секунды

delay x * 3 ; пауза в x * 3 секунд
getip значение Ожидание получения IP-адреса от удаленного компьютера. Если поставщик услуг Интернета возвращает в строке несколько IP-адресов, используйте параметр значение для указания порядкового номера нужного IP-адреса. ; получить второй IP-адрес

set ipaddr getip 2

; присвоить переменной первый

; полученный IP-адрес

szAddress = getip
goto метка Переход к строке сценария, помеченной меткой метка, и выполнение следующих за ней команд. waitfor "Prompt:" until 10

if !$SUCCESS then

goto BailOut ; переход на

;BailOut и выполнение

;следующих за ней команд

endif

transmit "bbs^M"

goto End

BailOut:

transmit "^M"

halt | Остановка выполнения сценария. Эта команда не закрывает окно терминала. Для подключения нужно будет нажать кнопку Продолжить. Повторно запустить сценарий нельзя.
if условие then

команды

endif

         Выполнение блока команд команды, если условие соблюдено (имеет значение TRUE). if $USERID == "John" then

transmit "Johnny^M"

endif
метка: Указание строки сценария, на которую может выполняться переход. Метка должна представлять собой уникальное имя и удовлетворять соглашению об именах переменных.
set port databits 5 | 6 | 7 | 8 | Изменение числа битов в байтах, передаваемых и принимаемых во время сеанса. Число битов указывается в диапазоне от 5 до 8. Если эта команда в сценарии отсутствует, будет использоваться значение, заданное в параметрах данного подключения. | set port databits 7
set port parity none | odd | even | mark | space | Изменение схемы контроля четности для порта во время сеанса. Если эта команда в сценарии отсутствует, будет использоваться значение, заданное в параметрах данного подключения. | set port parity even
set port stopbits 1 | 2 | Изменение числа стоповых битов для порта во время сеанса. Число стоповых битов может быть равно 1 или 2. Если эта команда в сценарии отсутствует, будет использоваться значение, заданное в параметрах данного подключения. | set port stopbits 2
set screen keyboard on | off | Разрешение или запрет ввода данных с клавиатуры в окно терминала во время работы сценария. | set screen keyboard on
set ipaddr строка IP-адрес рабочей станции для сеанса. Строка должна иметь формат IP-адреса. szIPAddress = "10.0.0.0"

set ipaddr szIPAddress

set ipaddr "10.0.0.0"

set ipaddr getip
transmit строка [ , raw ] Отправка на удаленный компьютер символов, заданных параметром строка.

Удаленный компьютер будет распознавать управляющие последовательности и специальные символы, если команда выполняется без модификатора raw. Модификатор raw можно использовать для передачи системных переменных $USERID и $PASSWORD, если имена или пароли пользователей содержат последовательности символов, которые без модификатора raw будут интерпретироваться как управляющие последовательности или символы.

 transmit "slip" + "^M"

transmit $USERID, raw
waitfor строка [ , matchcase ] [ then метка { , строка [ , matchcase ] then метка } ] [ until время ] Ожидание получения компьютером одной или нескольких указанных строк от удаленного компьютера. Регистр символов для параметра строка не учитывается, если не задан модификатор matchcase.

Если указанная строка получена и для нее задана конструкция then метка, то команда выполняет переход на строку файла сценария, обозначенную этой меткой.

Необязательная конструкция until время задает максимальное время в секундах, в течение которого компьютер будет ожидать получения строки, прежде чем перейдет к следующей команде. Без этой конструкции время ожидания ограничено не будет.

Если компьютер получает одну из указанных строк, для системной переменной $SUCCESS устанавливается значение TRUE. В противном случае она принимает значение FALSE по истечении числа секунд, заданных параметром время. 		waitfor "Login:"

waitfor "Password?", matchcase

waitfor "prompt:" until 10

waitfor

"Login:" then DoLogin,

"Password:" then DoPassword,

"BBS:" then DoBBS,

"Other:" then DoOther

until 10
while условие do

команды

endwhile

 Выполнение блока команд команды до тех пор, пока условие не перестанет соблюдаться (приняв значение FALSE) integer count = 0

while count < 4 do

transmit "^M"

waitfor "Login:" until 10

if $SUCCESS then

goto DoLogin

endif

count = count + 1

endwhile

...

Сведения об автоматизации процесса входа в систему при удаленном доступе с помощью языка сценариев Windows 95 см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Windows. Сведения об активизации сценария входа в систему см. в разделе Чтобы активизировать сценарий входа в систему.


Зарезервированные слова

Следующие слова являются зарезервированными и не могут использоваться в качестве имен переменных.

and | boolean | databits | delay
do | endif | endproc | endwhile
even | FALSE | getip | goto
halt | if | integer | ipaddr
keyboard | mark | matchcase | none
odd | off | on | or
parity | port | proc | raw
screen | set | space | stopbits
string | then | transmit | TRUE
until | waitfor | while

Сведения об автоматизации процесса входа в систему при удаленном доступе с помощью языка сценариев Windows 95 см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Windows. Сведения об активизации сценария входа в систему см. в разделе Чтобы активизировать сценарий входа в систему.


Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf

Для автоматизации процесса входа в удаленные системы можно использовать файл Switch.inf (или Pad.inf для сетей X.25) вместо того, чтобы вручную вводить данные в окно терминала, как это описано в разделе Использование окна терминала в процессе удаленного входа.

Сценарии автоматической обработки особенно удобны в тех случаях, когда требуется обеспечить постоянное подключение к удаленному компьютеру. Если сетевое подключение настроено на использование сценария, то при разрыве подключения к удаленной системе оно будет восстанавливаться автоматически. Если в удаленную систему приходится входить часто, сценарии существенно экономят время, избавляя от необходимости каждый раз вводить данные вручную.

Файл Switch.inf содержит типовой сценарий, который можно использовать в готовом виде либо после минимальных изменений. Сначала попробуйте воспользоваться файлом Switch.inf, не внося в него никаких изменений, а если он не будет работать как нужно, скопируйте файл и измените сценарий так, чтобы он отражал последовательность действий, которые требуется выполнять при входе на удаленный компьютер.

Язык сценариев также может использоваться для взаимодействия с другими устройствами, в частности, с модемами. Если вы еще не знакомы со сценариями для модемов, вам, возможно, будет трудно самому составлять их. Наверное, проще будет скопировать и затем изменить один из типовых сценариев-примеров.


Создание сценариев в файле Switch.inf для сетевых подключений и подключений удаленного доступа

Файл Switch.inf, расположенный в папке системный_корневой_каталог\System32\Ras, содержит несколько сценариев. Здесь имеются сценарии для всех промежуточных устройств и интерактивных служб, используемых подключением.

Сценарий файла Switch.inf состоит из элементов шести типов:

  • Заголовки разделов
  • Строки комментариев
  • Команды
  • Ответы
  • Ключевые слова ответов
  • Макросы

Сведения об активизации сценария файла Switch.inf см. в разделе Чтобы активизировать сценарий входа в систему. Дополнительные сведения о сценариях Switch.inf см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.


Заголовки разделов

Заголовки разделов разбивают файл Switch.inf на отдельные сценарии. Каждый заголовок раздела обозначает начало сценария какого-либо удаленного компьютера и содержит не более 31 символа. Текст заголовка появляется в окне «Сетевые подключения» при активизации сценария. Заголовок раздела заключается в квадратные скобки. Например:

[Route 66 Logon Process]

Сведения об активизации сценария файла Switch.inf см. в разделе Чтобы активизировать сценарий входа в систему. Дополнительные сведения о сценариях Switch.inf см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.


Строки комментариев

Строки комментариев должны содержать в первом столбце точку с запятой (;) и могут располагаться в любом месте файла. Содержимое этих строк предназначено для лиц, занимающих сопровождением файла Switch.inf. Например:

; Этот сценарий создан Ольгой Голубевой 29 сентября 1996 г.

Сведения об активизации сценария файла Switch.inf см. в разделе Чтобы активизировать сценарий входа в систему. Дополнительные сведения о сценариях Switch.inf см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.


Команды

Каждая строка сценария является либо командой локального компьютера, предназначенной для удаленного компьютера, либо ответом удаленного компьютера. Каждая команда или ответ представляет собой поток данных или текста. Например, следующая команда отправляет удаленному компьютеру имя пользователя (Martha) и управляющий символ возврата каретки (макрос <cr>):

COMMAND=Martha<cr>

Команды и ответы должны располагаться в файле именно в том порядке, в котором их ожидает удаленный компьютер. Команды ветвления, такие как GOTO и IF, не поддерживаются.

Каждому конкретному удаленному устройству соответствует определенная последовательность команд и ответов, которая должна быть описана в документации устройства, а в случае подключения к коммерческой службе должна предоставляться отделом технической поддержки этой службы. Если точная последовательность неизвестна, активизируйте типовой сценарий, предоставляемый компонентом «Сетевые подключения», и измените его таким образом, чтобы он соответствовал последовательности входа для удаленного компьютера, как описано в разделе Устранение неполадок, связанных со сценариями удаленного входа.

Оператор COMMAND= можно использовать еще двумя способами.

  • COMMAND= NoResponse

    Этот вариант применяется по умолчанию, он вызывает задержку примерно в две секунды. Такой способ используется в случае, когда промежуточному устройству необходима задержка.

  • COMMAND= строка

    В этом случае за параметром строка не следует макрос возврата каретки (<cr>). Такой способ используется в случае, когда данные для устройства должны вводиться медленно. Устройство не принимает сразу всю строку команды, а требует, чтобы она передавалась по символам.

Следующий пример демонстрирует сценарий для промежуточного устройства, которое настолько медленно, что может принимать и обрабатывать за один прием только один символ команды PPP:

COMMAND=P
NoResponse
COMMAND=P
NoResponse
COMMAND=P
NoResponse

Примечание

  • Сведения об активизации файла сценария см. в разделе Чтобы активизировать сценарий входа в систему.


Ответы

Ответ отправляется удаленным устройством или компьютером. Для создания автоматического сценария необходимо знать ответы, которые будут приниматься от удаленного устройства. Если между символами возникает задержка в две секунды или больше, полученный текст отправляется в качестве ответа. Этот промежуток является единственным признаком конца ответа. Дополнительные сведения см. в разделе Обработка двухсекундных задержек и больших блоков текста в сценарии файла Switch.inf.

Сведения об активизации сценария файла Switch.inf см. в разделе Чтобы активизировать сценарий входа в систему. Дополнительные сведения о сценариях Switch.inf см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.


Ключевые слова ответов

Ключевое слово в строке ответа указывает, что нужно делать с ответами, получаемыми от удаленного компьютера.

  • OK=ответ удаленного компьютера<макрос>

    При обнаружении макроса или ответа управление передается следующей строке сценария.

  • LOOP=ответ удаленного компьютера<макрос>

    При обнаружении макроса или ответа управление передается предыдущей строке сценария.

  • CONNECT=ответ удаленного компьютера<макрос>

    Вставляется в конце успешно выполненного сценария модема. Обычно в файле Switch.inf не используется.

  • ERROR=ответ удаленного компьютера<макрос>

    При обнаружении ответа выводится общее сообщение об ошибке. Таким образом можно оповещать пользователей в случаях, когда удаленный компьютер сообщает об определенной ошибке.

  • ERROR_DIAGNOSTICS=ответ удаленного компьютера<diagnostics>

    Отображение конкретной причины ошибки, возвращенной устройством. Не все устройства сообщают конкретные сведения об ошибках. Если устройство не сообщает сведений об ошибках, распознаваемых средствами диагностики сетевых подключений, используйте ключевое слово ERROR=.

  • NoResponse

    Используется при отсутствии ответа от удаленного устройства.

Подключение всегда предполагает наличие ответа от удаленного устройства и ожидает его получения, если только за строкой COMMAND= не следует оператор NoResponse. Если после строки COMMAND= нет такого оператора, строка COMMAND= выполняется, и затем сценарий останавливается в этой точке.

Сведения об активизации сценария файла Switch.inf см. в разделе Чтобы активизировать сценарий входа в систему. Дополнительные сведения о сценариях Switch.inf см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.


Макросы

Макросы заключаются в угловые скобки (<>) и выполняют различные специальные функции, как описано ниже.

  • <cr>

    Возврат каретки.

  • <lf>

    Перевод строки.

  • <match> "строка"

    Сообщает о найденном соответствии, если в ответе устройства обнаружена заключенная в кавычки строка. Сравнение производится с учетом регистра каждого символа строки. Таким образом, макрос <match> "Smith" считает подходящими строки "Jane Smith" и "John Smith III", но не "SMITH".

  • <?>

    Служит подстановочным знаком. Например, CO<?><?>2 соответствуют строки COOL2 и COAT2, но не COOL3.

  • <hXX>

    (XX — шестнадцатеричные цифры)

    Позволяет вставить в строку любой символ с шестнадцатеричным кодом, включая нулевой байт, <h00>.

  • <ignore>

    Пропуск оставшейся части ответа, следующей за макросом.

  • <diagnostics>

    Передача подробных данных об ошибках из устройства в систему удаленного доступа, которая сообщает о каждой ошибке пользователю. Если не использовать этот макрос, используется сообщение об ошибке общего вида.

Сведения об активизации сценария файла Switch.inf см. в разделе Чтобы активизировать сценарий входа в систему. Дополнительные сведения о сценариях Switch.inf см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.


Описание примера сценария в файле Switch.inf

В этом разделе описаны все элементы типового сценария входа, содержащегося в файле Switch.inf.

Каждый сценарий должен начинаться с команды, адресованной удаленному компьютеру, за которой следует одна или несколько строк ответа. Эта начальная команда может просто ожидать, пока удаленный компьютер пройдет инициализацию и пришлет свою заставку для входа в сеть. По умолчанию начальная команда задает двухсекундное ожидание заставки для входа. В файле Switch.inf эта команда выглядит следующим образом:

COMMAND=

Если удаленный компьютер отправляет следующий ответ (заставку для входа):

Welcome to Electronic, Inc. Net. Please enter your login:

то в файле Switch.inf должна присутствовать следующая строка:

OK=<match>"Введите имя пользователя:"

Если удаленный компьютер отправляет строку «Введите имя пользователя:», то это означает, что все работает так, как нужно. Затем следует команда, которая передает удаленному серверу имя пользователя и символ возврата каретки:

COMMAND=Martha<cr>

Если в ответ удаленный компьютер запрашивает пароль следующим образом:

Please enter your password:

то в файле Switch.inf должна присутствовать следующая строка:

OK=<match>"Введите пароль:"

Чтобы отправить пароль, используйте следующую команду:

COMMAND=mUs3naB<cr>

Этот сценарий выполняет автоматический вход в систему на многих компьютерах, использующих протокол PPP.

Сведения об активизации сценария файла Switch.inf см. в разделе Чтобы активизировать сценарий входа в систему. Дополнительные сведения о сценариях Switch.inf см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.


Обработка двухсекундных задержек и больших блоков текста в сценарии файла Switch.inf

Если в потоке данных ответа удаленного компьютера компьютеру, который выполняет подключение, возникает двухсекундная задержка, то сервер удаленного доступа будет считать, что эта задержка означает окончание ответа. Такие задержки могут возникать в любом месте потока, даже посреди слов, и распознаются средствами диагностики модема. Дополнительные сведения см. в разделе Ведение и просмотр журнала команд модема.

Если созданный сценарий не работает по причинам, на первый взгляд непонятным, включите диагностику модема, а затем изучите полученный файл системный_корневой_каталог\ModemLog_модель.txt и выясните, не оканчивается ли какой-либо ответ в середине слова. Модель — это имя модема в том виде, в котором оно фигурирует в списке установленных модемов в окне Свойства: Модем. Если ответ заканчивается посреди слова, в сценарии следует предусмотреть возможность двухсекундных задержек. Проще всего это сделать, вставив следующую команду:

COMMAND=<cr>

С помощью сценария можно пропускать большие фрагменты текста, содержащие многочисленные задержки; для этого используется ключевое слово LOOP= и сравнение текста в конце блока с образцом. Например:

COMMAND=<cr>

OK=<match>"Укажите службу для запуска:"

LOOP=<ignore>

В этом примере сетевое подключение отправляет пустую команду (означающую двухсекундное ожидание). Затем оно ожидает появления сообщения «Укажите службу для запуска:» . Если передается большой блок текста, эта строка найдена не будет. Затем управление передается команде LOOP. Команда LOOP выполняет возврат на предыдущую строку и подключение будет ожидать строку «Укажите службу для запуска:» во втором ответе. Таким образом можно с помощью цикла дожидаться нужного сообщения в больших блоках текста.

Сведения об активизации сценария файла Switch.inf см. в разделе Чтобы активизировать сценарий входа в систему. Дополнительные сведения о сценариях Switch.inf см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.


Использование команд и символов возврата каретки в файле Switch.inf

В сценариях файла Switch.inf обычно в конце команды нужно указывать макрос <cr>, обозначающий возврат каретки. Этот макрос заставляет удаленный компьютер немедленно приступить к обработке команды. Если макрос <cr> не будет включен в команду, удаленный компьютер может не распознать ее.

В некоторых случаях макрос <cr> использовать нельзя, так как удаленный компьютер может принимать команду без возврата каретки и ему может требоваться время на ее обработку. Подобные ситуации возникают главным образом при отправке серии команд без ожидания ответа.

Сведения об активизации сценария файла Switch.inf см. в разделе Чтобы активизировать сценарий входа в систему. Дополнительные сведения о сценариях Switch.inf см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf.


Устранение неполадок, связанных со сценариями удаленного входа

Все данные, передаваемые между сетевым подключением, модемом и удаленным устройством, в том числе сообщения об ошибках, обнаруженных удаленным устройством, можно заносить в журнал.

В журнале можно просматривать команды модема. Если включить ведение журнала, команды, адресуемые модему, будут записываться в файл системный_корневой_каталог\ModemLog_модель.txt. Модель — это имя модема в том виде, в котором оно фигурирует в списке установленных модемов. Сведения о журнале команд модема см. в разделе Ведение и просмотр журнала команд модема.


Активизация сценария входа в систему

Рисунок Microsoft Windows

Чтобы активизировать сценарий входа в систему

  1. Откройте компонент Сетевые подключения.
  2. Щелкните правой кнопкой мыши подключение, для которого должен выполняться сценарий, и выберите команду Свойства.
  3. На вкладке Безопасность установите флажок Сценарий.
  4. Чтобы использовать существующий файл сценария, нажмите кнопку Обзор.

    Чтобы использовать файл Switch.inf, нажмите кнопку Изменить.

Примечания

  • XOX
  • Кроме файла Switch.inf в XOX поддерживается также и язык сценариев Windows 95, который позволяет подключаться к компьютерам, использующим операционные системы других разработчиков. Однако языком сценариев Windows 95 проще пользоваться, чем файлом Switch.inf. XOX
  • Если нажать кнопку Изменить и загрузить файл Switch.inf в программу «Блокнот», следует сразу же сохранить этот файл под другим именем, чтобы оригинал остался в нетронутом виде.

См. также


Устранение неполадок сетевых подключений и подключений удаленного доступа

Выберите тип неполадки, которую требуется устранить.

Модем не работает.

Причина. Несовместимый модем.

Решение. Если доступен другой компьютер, подключенный к Интернету, просмотрите перечень поддерживаемых модемов. XOX

Причина. Модем неправильно подключен или его питание выключено.

Решение. Проверьте правильность подключения модема к соответствующему порту компьютера. Если модем внешний, убедитесь, что его питание включено.

См. также: Устранение неполадок с модемами.

Не удается подключиться к поставщику услуг Интернета (ISP).

Причина. Сервер поставщика услуг не работает.

Решение. Выясните у поставщика услуг, работает ли сервер удаленного доступа.

Причина. У пользователя отсутствует действующая учетная запись или разрешение на удаленный доступ.

Решение. Выясните у поставщика услуг, существует ли необходимая учетная запись и имеется ли у нее разрешение на удаленный доступ.

Причина. Набирается неправильный номер либо набирается правильный номер, но без необходимого кода выхода на внешнюю линию, например 9.

Решение. Проверьте правильность набираемого номера.

Причина. Модем не может согласовать передачу данных с модемом сервера.

Решение. Попробуйте использовать модем того же типа, что и на сервере.

Причина. Неподходящий или неисправный кабель модема.

Решение. Не используйте переходники с 9 на 25 контактов, которые часто входят в комплект поставки манипуляторов мышь, так как некоторые из них не способны передавать сигналы модемов. Необходимо использовать специально предназначенные для модемных сигналов переходники.

Причина. Телефонная линия (например, в номере отеля) не поддерживает скорость используемого модема.

Решение. Выберите меньшую скорость передачи данных (или попросите у управляющего отелем прямую линию).

См. также: Изменение максимальной скорости порта модема.

Причина. Линия является цифровой.

Решение. Большинство модемов работает только с аналоговыми телефонными линиями. Убедитесь, что используется аналоговая телефонная линия, либо, при наличии цифровой телефонной линии, что сервер и клиенты используют цифровые модемы.

При попытке подключения выдается сообщение о том, что сервер поставщика услуг Интернета не отвечает.

Причина.

  • На высоких скоростях передачи модем может быть не совместим с модемом сервера.
  • На линии много статического электричества, что препятствует подключению модемов на высокой скорости.
  • Между клиентом и сервером находится коммутатор, препятствующий согласованию передачи на высокой скорости.

Решение. Настройте модем на более низкую скорость.

См. также: Изменение максимальной скорости порта модема.

Причина. Сервер поставщика услуг не работает.

Решение. Попросите системного администратора проверить, работает ли сервер удаленного доступа.

Модем все время подключается на более низкой скорости, чем указано.

Причина. Модем и телефонная линия работают неправильно. Избыточное статическое электричество на телефонной линии приводит к разрыву связи.

Решение. Проверьте правильность работы модема с помощью средств диагностики.

См. также: Протоколирование и просмотр журнала команд модема.

Причина. Недостаточное качество исходящей линии.

Решение. Попросите телефонную компанию проверить качество линии.

Причина. На скорость влияет качество вызываемой линии.

Решение. Если к серверу поставщика услуг Интернета можно подключиться по нескольким номерам, попробуйте использовать другой номер.

Причина. Программное обеспечение модема требует обновления.

Решение. Выясните у изготовителя модема, нет ли для модема обновленного программного обеспечения.

Сеансы связи с поставщиком услуг Интернета постоянно разрываются.

Причина. Связь разрывается из-за оповещения о входящих звонках.

Решение. Проверьте, включен ли на линии режим оповещения. Если это так, отключите этот режим и снова попробуйте установить связь.

См. также: Изменение параметров набора номера для местоположения.

Причина. Сервер удаленного доступа отключил пользователя из-за простоя.

Решение. Попробуйте установить связь снова.

Причина. Во время сеанса связи кто-то поднял телефонную трубку. Поднятие трубки автоматически разрывает соединение.

Решение. Попробуйте установить связь снова.

Причина. Кабель модема неплотно вставлен в разъем.

Решение. Убедитесь, что кабель модема подключен надежно.

Причина. Программное обеспечение модема требует обновления.

Решение. Выясните у изготовителя модема, нет ли для модема обновленного программного обеспечения.

Решение. Необходимо изменить параметры модема, потому что изменились параметры сервера поставщика услуг Интернета.

Решение. Выясните правильные параметры модема у системного администратора поставщика услуг Интернета.

При попытке подключения связь разрывается.

Причина. Сервер поставщика услуг не работает.

Решение. Попросите системного администратора поставщика услуг Интернета проверить, работает ли сервер удаленного доступа.

Причина.

  • Модем не может согласовать передачу данных с модемом на сервере поставщика услуг Интернета.
  • Последовательный порт компьютера не поддерживает выбранную скорость передачи.

Решение. Попробуйте использовать более низкую начальную скорость порта.

См. также: Изменение максимальной скорости порта модема.

Причина. Программное обеспечение модема требует обновления.

Решение. Выясните у изготовителя модема, нет ли для модема обновленного программного обеспечения.

При попытке подключения выдается сообщение об аппаратной ошибке.

Причина. Модем выключен.

Решение. Убедитесь, что модем включен. Если он выключен, включите его и повторите набор номера.

Причина. Модем работает неправильно.

Решение. Включите ведение журнала команд модема, чтобы проверить подключение.

См. также: Протоколирование и просмотр журнала команд модема.

Причина. Несовместимый кабель.

Решение. Если модем работает в терминале, но не работает с подключениями из папки «Сетевые подключения», то, возможно, модем подключен к компьютеру неподходящим кабелем. Нужно использовать совместимый кабель.

Конфликтующие последовательные порты вызывают неполадки с подключением.

Причина. Последовательные порты конфликтуют.

Решение. Порты COM1 и COM3 совместно используют линию запроса на прерывание IRQ 4, порты COM2 и COM4 — IRQ 3. В результате, нельзя использовать для последовательных соединений одновременно порты COM1 и COM3 или порты COM2 и COM4. Например, нельзя одновременно использовать для подключения из папки «Сетевые подключения» порт COM1, а для терминала — порт COM3.

Это правило действует и при использовании мыши совместно с программами последовательной связи, такими как компонент «Сетевые подключения» или программа терминала Windows 2000. Это правило не распространяется на случай, когда используется интеллектуальный последовательный адаптер, такой как последовательный адаптер DigiBoard.

См. также: Чтобы настроить подключение; Чтобы изменить COM-порт для модема.

При попытке подключения по ISDN выдается сообщение об отсутствии ответа.

Причина. Сервер поставщика услуг Интернета не отвечает, так как он выключен или модем не подключен.

Решение. Обратитесь к системному администратору.

Причина. Линия занята.

Решение. Повторите попытку подключения позже или обратитесь к системному администратору.

Причина. Неполадки оборудования.

Решение. Проверьте правильность установки и настройки ISDN-адаптеров.

Причина. Телефонный номер настроен неправильно.

Решение. В одних случаях каждый B-канал линии ISDN имеет свой номер, а в других случаях оба B-канала используют один и тот же номер. Выясните у телефонной компании, сколько номеров использует данная линия ISDN.

Причина. Код профиля службы (SPID) настроен неправильно (для пользователей в США и Канаде). Код SPID обычно состоит из номера телефона, к которому добавлены (в начало, в конец или и в начало, и в конец) дополнительные цифры. Код SPID позволяет коммутатору распознать тип подключенного к линии оборудования и направлять вызовы на соответствующие устройства на линии. Если канал ISDN требует кода SPID, а тот введен неправильно, то устройство не сможет выполнять или принимать вызовы.

Решение. Проверьте правильность ввода кода SPID.

Причина. Плохое состояние линии (например, наличие статического электричества) препятствует установлению соединения.

Решение. Подождите несколько минут и повторите попытку.

Причина. Отключено согласование типа линии, или соединение нельзя установить по линии выбранного типа.

Решение. Включите согласование типа линии.

Причина. Коммутатор ISDN занят.

Решение. Повторите попытку подключения позже.

Причина. Используется устаревший адаптер DigiBoard.

Решение. Если используется устаревшая плата PCIMAC-ISA DigiBoard, с серийным номером, меньшим чем A14308, обратитесь в компанию Digi для ее замены.

Подключения по сети X.25 разрываются.

Причина. Устройство сборки/разборки пакетов (PAD), используемое для удаленного доступа, имеет неправильные параметры X.3 или неправильные параметры последовательной связи.

Решение. Если сервер удаленного доступа работает и к нему не удается подключиться напрямую через интеллектуальную плату X.25 или внешнее устройство PAD, измените параметры X.3 или последовательные параметры устройства PAD, используемого для удаленного доступа. Выясните у системного администратора правильные параметры.

См. также: Чтобы настроить подключение.

Причина. Недопустимые новые сведения в файле Pad.inf.

Решение. Просмотрите остальные элементы файла Pad.inf для прямых подключений и внешних устройств PAD, и прочитайте комментарии к ним. Для просмотра ответа от устройства PAD, возможно, потребуется анализатор линии или терминальная программа. Для устройства PAD, используемого для удаленного доступа, в качестве примера можно взять существующие данные из файла Pad.INF, обращая внимание на комментарии к ним.

Причина. Несовместимый модем.

Решение. Если модем подключается к устройству PAD, используемому для удаленного доступа, на меньшей скорости, чем должен, замените модем, установив совместимый.

См. также: Модем не работает с компонентом «Сетевые подключения»

Причина. Линия, к которой подключен сервер удаленного доступа, перегружена. Если подключение было осуществлено, но сетевые диски отключаются, а сеансы связи разрываются или возникают сетевые ошибки, то причиной этого может быть перегруженность выделенной серверу удаленного доступа линии.

Например, для четырех клиентов, подключающихся на скорости 9600 бит/с каждый (через PAD удаленного доступа), необходимо обеспечить полосу пропускания выделенной линии на стороне сервера не менее 38400 бит/с (четыре раза по 9600). Если выделенная линия не имеет необходимой пропускной способности, она может стать причиной задержек и снизить производительность работы подключенных клиентов. В данном примере подразумевается, что служба маршрутизации и удаленного доступа использует всю полосу пропускания. Если же служба маршрутизации и удаленного доступа совместно использует полосу пропускания еще с какими-либо службами или приложениями, то может быть осуществлено меньшее количество подключений.

Решение. Системный администратор должен проверить, может ли пропускная способность выделенной линии поддерживать все COM-порты на всех скоростях, на которых подключаются клиенты.

Не удается осуществить подключение с использованием протокола PPTP.

Причина. Неполадки соединения TCP/IP не позволяют подключиться к PPTP-серверу.

Решение. Проверьте возможность подключения к серверу с помощью служебных программ ipconfig и ping.

Причина. Активен клиент Winsock Proxy.

Решение. VPN-подключение не может нормально работать при активном клиенте Winsock Proxy. Winsock Proxy сразу же перенаправляет пакеты на прокси-сервер, не позволяя виртуальному частному подключению инкапсулировать их. Попросите системного администратора отключить клиента Winsock Proxy.

Причина. Отсутствуют необходимые разрешения на подключение к серверу удаленного доступа и вход в домен.

Решение. Обратитесь к системному администратору.

Причина. В TCP/IP-сети IP-адрес данной рабочей станции не уникален.

Решение. Обратитесь к системному администратору.

Причина. Неполадки с разрешением имен не позволяют преобразовывать имена в IP-адреса.

Решение. Используйте при подключении полные доменные имена и IP-адреса.

См. также: Чтобы настроить параметры TCP/IP.

Не удается установить связь с помощью протокола PPP или служебных программ TCP/IP.

Причина. Сервер не поддерживает расширения LCP.

Решение. Если не удается подключиться к серверу по протоколу PPP, или если удаленный компьютер разрывает соединение, то, вероятно, сервер не поддерживает расширения LCP. В папке «Сетевые подключения» снимите флажок Включить расширения LCP для данного подключения.

Причина. Сжатие заголовков IP мешает работе служебных программ TCP/IP. Если соединение с удаленным сервером по протоколу PPP установлено, но служебные программы TCP/IP не работают, то причиной может быть сжатие заголовков IP.

Решение. Отключите сжатие заголовков IP и повторите попытку.

См. также: Чтобы отключить запросы расширений LCP для протокола PPP; Чтобы отключить сжатие заголовков IP в протоколе PPP.

Конкретная программа испытывает проблемы с подключением к Интернету, когда включены общиий доступ к подключению к Интернету, брандмауэр Windows или оба приложения одновременно.

Причина. Брандмауэр Windows, общий доступ к подключению к Интернету или оба приложения препятствуют работе программы или запрещают ей успешно установить полноценное, двухстороннее подключение через Интернет.

Решение. Получите у производителя программы подключаемый модулем общего доступа к подключению к Интернету и брандмауэра Windows. Подключаемые модули общего доступа к подключению к Интернету и брандмауэра Windows разработаны для решения любых проблем с подключением к Интернету, которые могут возникнуть у программ при работе общего доступа к подключению к Интернету (ICS) или брандмауэра Windows. Подключаемые модули поставляются на диске или через Интернет в виде исполняемого файла. Так как подключаемые модули общего доступа к подключению к Интернету и брандмауэра Windows могут сделать сеть уязвимой для рисков безопасности, необходимо устанавливать их, только если они поступили из надежного источника. Дополнительные сведения см. в разделе Использование подключаемых модулей общего доступа к подключению к Интернету и брандмауэра Windows.

Не удается установить связь с помощью общего доступа к подключению к Интернету.

Причина. Общий доступ предоставлен не к тому сетевому адаптеру.

Решение. Компьютер, предоставляющий общий доступ к подключению к Интернету, должен иметь по крайней мере два подключения. Одно подключение (обычно через сетевой адаптер) соединяет этот компьютер с другими компьютерами домашней или малой офисной сети, а другое связывает локальную сеть с Интернетом. Для второго подключения должен быть разрешен общий доступ к подключению к Интернету.

Причина. Протокол TCP/IP не установлен на некоторых компьютерах домашней или малой офисной сети.

Решение. По умолчанию протокол TCP/IP устанавливается на компьютеры под управлением XOX, Windows 2000, Windows Millennium Edition, Windows 98 и Windows NT версии 4.0. Если пользователи домашней или малой офисной сети работают с другими операционными системами, проверьте, установлен ли на их компьютерах протокол TCP/IP.

Причина. Если пользователи локальной сети не могут получить доступ к Интернету, то на их компьютерах может быть неправильно настроен протокол TCP/IP.

Решение. Проверьте, что для подключений по локальной сети на этих компьютерах заданы следующие параметры TCP/IP.

  • IP-адрес: Получить IP-адрес автоматически (через DHCP)
  • DNS-сервер: Получить адрес DNS-сервера автоматически
  • Основной шлюз: не задан

В операционных системах Windows 95, Windows 98, Windows Millennium и Windows NT версии 4.0 параметры TCP/IP настраиваются с помощью компонента «Сеть» на панели управления.

Причина. Если пользователи домашней или малой офисной сети не могут получить доступ к Интернету, то на их компьютерах могут быть неправильно настроены параметры Интернета.

Решение. Для общего доступа к подключению к Интернету нужно настроить параметры Интернета. Дополнительные сведения см. в разделе Чтобы настроить параметры Интернета для общего доступа к подключению к Интернету.

Причина. Служба общего доступа к подключению Интернета не запущена.

Решение. С помощью программы «Просмотр событий» убедитесь, что служба общего доступа к подключению к Интернету запущена.

См. также Использование окна просмотра событий.

Причина. На компьютере, предоставляющем общий доступ к подключению к Интернету, неправильно настроено разрешение имен.

Решение. Возможно, на компьютере требуется настроить службы разрешения имен WINS или DNS. Если компьютеры в домашней или малой офисной сети не могут преобразовывать имена в IP-адреса, проверьте с помощью команды ipconfig конфигурацию разрешения имен на компьютере, предоставляющем общий доступ к подключению к Интернету. Поставщик услуг Интернета может настроить разрешение имен двумя способами.

  • Статически назначаемые серверы имен

    • Необходимо вручную указать в настройках протокола TCP/IP IP-адрес (или адреса) серверов имен поставщика услуг Интернета. При статическом назначении серверов имен можно в любой момент с помощью команды ipconfig получить IP-адреса указанных серверов имен.

  • Динамически назначаемые серверы имен

    • Ручной настройки не требуется. IP-адреса серверов имен поставщика услуг Интернета динамически выделяются при подключении к поставщику услуг. Если серверы имен назначаются динамически, выполнять команду ipconfig следует после установления подключения к поставщику услуг Интернета.

Причина. Если не удается поиграть в игру по Интернету, то, возможно, приложение использует нетранслируемый протокол.

Решение. Попробуйте запустить программу с компьютера, предоставляющего общий доступ к подключению к Интернету. Если программа работает на нем, но не работает на другом компьютере домашней или малой офисной сети, то, видимо, программа не рассчитана на работу в таком режиме.

Причина. Если не удается поиграть в игру по Интернету, то, возможно, программа не настроена на компьютере, предоставляющем общий доступ к подключению к Интернету.

Решение. Проверьте правильность настройки программы, включая номера портов.

See also: Общие сведения о программах и службах

Причина. Если пользователям Интернета не видны службы домашней или малой офисной сети, например веб-сервер, то эти службы настроены неправильно.

Решение. Проверьте правильность настройки этих служб, включая номера портов и адреса TCP/IP.

Причина. Если пользователи вашей сети не могут обращаться к узлам Интернета по понятным именам, значит, разрешение имен DNS настроено неправильно.

Решение. Попросите пользователей сети использовать полные доменные имена или IP-адреса при доступе к ресурсам Интернета.

См. также: Общие сведения об определениях служб; Общий доступ к подключению к Интернету; Чтобы настроить TCP/IP на использование WINS; Чтобы настроить TCP/IP на использование DNS; Чтобы проверить конфигурацию TCP/IP с помощью команды ping.

При использовании подключения по локальной сети отсутствует ответ.

Причина. Возможно, неполадки связаны с сетевым адаптером.

Решение. Попробуйте выполнить следующие действия:

  • Проверьте внешний вид значка подключения по локальной сети. В зависимости от состояния подключения по локальной сети значок в папке «Сетевые подключения» может выглядеть по-разному. Кроме того, при отключении адаптера от среды передачи (например, при отсоединении кабеля) в области уведомлений появляется значок состояния. Дополнительные сведения см. в разделе Подключения по локальной сети.
  • Проверьте правильность работы сетевого адаптера с помощью диспетчера устройств.

Причина. Кабель локальной сети может быть отсоединен от сетевого адаптера.

Решение. Убедитесь, что кабель локальной сети подключен к сетевому адаптеру.

При использовании переносного компьютера для подключения к поставщику услуг Интернета, некоторые или все программы работают неправильно.

Причина. Клиентское программное обеспечение WinSock Proxy Client может препятствовать правильной работе программ при подключении к поставщику услуг Интернета.

Решение. Если вы являетесь мобильным пользователем и используете свой переносной компьютер в сети организации, то для подключения с этого же компьютера к поставщику услуг Интернета или к другой удаленной сети вам потребуется отключить клиент Microsoft WinSock Proxy Client (клиент WSP в панели управления). Например, если переносной компьютер используется в офисе и он же служит для подключения к поставщику услуг Интернета или другой сети из дома, то при подключении из дома могут возникнуть сложности с работой приложений. (Например, программы не смогут найти необходимые ресурсы или серверы.) Если это так, то следует отключить Microsoft WinSock Proxy Client (Клиент WSP в панели управления), чтобы обеспечить нормальную работу программ, которые обычно используются в офисе.

Клиенты входящих подключений не могут видеть ресурсы, расположенные вне компьютера, принимающего входящие подключения.

Причина. Если адреса, назначаемые клиентам входящих подключений, не являются подмножеством адресов сети, к которой подключен компьютер, принимающий входящие подключения, то необходимо создать для клиентов входящих подключений маршрут к компьютерам интрасети.

Решение. Перенастройте диапазон IP-адресов, выделяемых клиентам входящих подключений так, чтобы он стал подмножеством адресов сети, к которой подключен компьютер, принимающий входящие подключения. Если сделать это нельзя, то задайте в качестве адреса основного шлюза для узлов интрасети IP-адрес компьютера, принимающего входящие подключения.

  • Если узлы интрасети настроены на автоматическое получение IP-адреса, а в интрасети работает DHCP-сервер, то можно настроить этот сервер на автоматическое назначение компьютерам основного шлюза.
  • Если узлы интрасети настроены на автоматическое получение IP-адреса, а сервер DHCP в интрасети отсутствует (то есть, используется средство автоматического назначения частных IP-адресов), то нужно будет вручную задать на всех узлах интрасети IP-адреса, маску подсети и адрес основного шлюза.

См. также: Чтобы настроить основной шлюз, Входящие подключения и IP-адреса.

Причина. Вычисленный диапазон адресов, выделяемых клиентам входящих подключений, шире, чем указанный вами диапазон.

Решение. Большинство сетей TCP/IP для более эффективного управления IP-адресами использует подсети. Для диапазона адресов, заданного в полях С и По, вычисляется ближайшая подходящая подсеть. Диапазон адресов в такой подсети может оказаться шире диапазона, указанного при настройке. Так происходит в случае, если адреса в полях С и По не являются границами подсети. Во избежание проблем укажите диапазон, границы которого совпадают с границами подсети. Например, если используется интрасеть с идентификатором частной сети 10.0.0.0, то примером диапазона, границы которого попадают точно на границы подсети, может служить диапазон 10.0.1.168–10.0.1.175. Для интрасети с идентификатором 192.168.0.0 можно задать диапазон 192.168.1.0–192.168.1.255.

См. также: Чтобы настроить входящее подключение на использование TCP/IP.


Сообщения об ошибках

При использовании компонента «Сетевые подключения» могут появляться сообщения об ошибках, перечисленные ниже. Для вывода на экран описания ошибки щелкните соответствующее сообщение в списке.

600 Начатая операция не закончена.

601 Обнаружен недопустимый дескриптор порта.

602 Указанный порт уже открыт.

603 Буфер вызывающего слишком мал.

604 Указаны недопустимые сведения.

605 Невозможно установить сведения о порте.

606 Указанный порт не подключен.

607 Обнаружено недопустимое событие.

608 Указано несуществующее устройство.

609 Указан несуществующий тип устройства.

610 Указан недопустимый буфер.

611 Указанный маршрут недоступен.

612 Указанный маршрут не распределен.

613 Указан недопустимый тип сжатия.

614 Недостаточно доступных буферов.

615 Указанный порт не найден.

616 Асинхронный запрос приостановлен.

617 Модем уже отключается.

618 Указанный порт не открыт.

619 Указанный порт не подключен.

620 Не удалось определить конечные точки.

621 Системе не удалось открыть файл телефонной книги.

622 Системе не удалось загрузить файл телефонной книги.

623 Системе не удалось найти запись телефонной книги для этого подключения.

624 Системе не удалось обновить файл телефонной книги.

625 Система обнаружила недопустимые данные в файле телефонной книги.

626 Не удалось загрузить строку.

627 Не удалось найти ключ.

628 Подключение было закрыто.

629 Подключение было закрыто удаленным компьютером.

630 Модем был отключен из-за ошибки оборудования.

631 Пользователь отключил модем.

632 Обнаружен неправильный размер структуры.

633 Модем уже используется или не настроен для исходящих подключений удаленного доступа.

634 Не удалось зарегистрировать компьютер в удаленной сети.

635 Произошла неизвестная ошибка.

636 Устройство, подключенное к порту, не соответствует ожидаемому.

637 Обнаружена строка, которую не удалось преобразовать (конвертировать).

638 Запрос просрочен.

639 Нет доступной асинхронной сети.

640 Произошла ошибка, затрагивающая NetBIOS.

641 Серверу не удалось выделить NetBIOS-ресурсы, необходимые для поддержки этого клиента.

642 Одно из компьютерных NetBIOS-имен уже зарегистрировано в удаленной сети.

643 Ошибка сетевого адаптера сервера.

644 Всплывающие сетевые сообщения получаться не будут.

645 Произошла внутренняя ошибка проверки подлинности.

646 Вход в это время дня для пользователя с данной учетной записью не разрешен.

647 Учетная запись отключена.

648 Срок действия пароля для учетной записи истек.

649 Учетная запись не имеет прав для дозвона.

650 Сервер удаленного доступа не отвечает.

651 Модем сообщил об ошибке.

652 Отклик от модема не распознан.

653 Макрос, требуемый модемом, не найден в INF-файле устройства.

654 Команда или отклик в секции INF-файла устройства ссылается на неопределенный макрос.

655 Макрос <сообщение> не найден в разделе файла «<устройство>.INF».

656 Макрос <defaultoff> в разделе файла «<устройство>.INF» содержит неопределенный макрос.

657 Не удалось открыть INF-файл устройства.

658 Слишком длинное имя устройства в INF-файле устройства или в INI-файле носителя.

659 INI-файл носителя ссылается на неизвестное имя устройства.

660 INF-файл устройства не содержит ответов для этой команды.

661 В INF-файле устройства отсутствует команда.

662 Произошла попытка установить макрос, отсутствующий в списке в секции INF-файла устройства.

663 INI-файл носителя ссылается на неизвестный тип устройства.

664 Недостаточно памяти.

665 Модем не настроен.

666 Модем не работает должным образом.

667 Системе не удалось прочесть INI-файл носителя.

668 Подключение было прервано.

669 Недопустимое использование параметра в INI-файле носителя.

670 Системе не удалось прочесть имя секции из INI-файла носителя.

671 Системе не удалось прочесть тип устройства из INI-файла носителя.

672 Системе не удалось прочесть имя устройства из INI-файла носителя.

673 Системе не удалось прочесть использование из INI-файла носителя.

674 Системе не удалось прочесть максимальную скорость подключения из INI-файла носителя.

675 Системе не удалось прочесть максимальную несущую скорости подключения из INI-файла носителя.

676 Телефонная линия занята.

677 Вместо модема ответил человек.

678 Ответ не получен.

679 Системе не удается определить несущую.

680 Отсутствует гудок.

681 Модем сообщает о возникновении общей ошибки.

691 Доступ запрещен, поскольку такое имя пользователя или пароль недопустимы в этом домене.

692 Произошла аппаратная ошибка модема.

695 Конечные автоматы не запущены.

696 Конечные автоматы уже запущены.

697 Цикл ответа не завершен.

699 Ответ модема вызвал переполнение буфера.

700 Развернутая команда в INF-файле устройства слишком длинна.

701 Установленная скорость подключения для модема не поддерживается этим COM-драйвером.

703 Подключению требуются некоторые данные от пользователя, но приложение не допускает взаимодействия с пользователем.

704 Недопустимый номер ответного вызова.

705 Недопустимое состояние авторизации.

707 Произошла ошибка, связанная с протоколом X.25.

708 Данная учетная запись просрочена.

709 Произошла ошибка при смене пароля домена. Возможно, пароль слишком короткий или совпадает с предыдущим.

710 При работе с этим модемом произошла последовательность ошибок переполнения.

711 Не удалось запустить диспетчер службы удаленного доступа. Дополнительная информация находится в журнале событий.

712 Инициализация двустороннего порта. Подождите несколько секунд и перезвоните.

713 Нет доступных линий ISDN.

714 Нет доступных ISDN-каналов для выполнения звонка.

715 Из-за низкого качества телефонной линии произошло слишком много ошибок.

716 IP-конфигурация службы удаленного доступа непригодна для использования.

717 Нет доступных IP-адресов в статическом пуле IP-адресов службы удаленного доступа.

718 Истекло время ожидания допустимого отклика с удаленного компьютера.

719 Подключение было прервано удаленным компьютером.

721 Удаленный компьютер не отвечает.

722 От удаленного компьютера получены недопустимые данные. Данные были проигнорированы.

723 Телефонный номер, включая префикс и суффикс, слишком длинный .

726 IPX-протокол не может быть использован для выполнения исходящих звонков на более чем одном модеме одновременно.

728 Системе не удается найти IP-адаптер.

729 Пока не будет установлен протокол IP, использовать протокол SLIP невозможно.

731 Протокол не настроен.

732 Этот компьютер и удаленный компьютер не смогли согласовать протоколы управления PPP.

733 Этот компьютер и удаленный компьютер не смогли согласовать протоколы управления PPP.

734 Протокол управления PPP-связью был прерван.

735 Запрошенный адрес был отвергнут сервером.

736 Удаленный компьютер завершил работу протокола управления.

737 Обнаружено замыкание на себя.

738 Сервер не назначил адрес.

739 Протокол проверки подлинности, требуемый удаленным сервером, не может использовать сохраненный пароль. Перезвоните и введите пароль явно.

740 Обнаружено недопустимое правило дозвона.

741 Локальный компьютер не поддерживает требуемый тип шифрования данных.

742 Удаленный компьютер не поддерживает требуемый тип шифрования данных.

743 Удаленному серверу требуется шифрование данных.

751 Номер обратного вызова содержит недопустимые символы. Допустимы только следующие символы: цифры (от 0 до 9), T, P, W, (, ), -, @ и символ пробела.

752 При обработке этого сценария была обнаружена синтаксическая ошибка.

753 Подключение не может быть разорвано, поскольку оно создано мультипротокольным маршрутизатором.

754 Системе не удается найти многоканальный пучок.

755 Система не может выполнить автоматический дозвон, поскольку это подключение имеет параметры для конкретного звонящего пользователя.

756 Это подключение уже выполнено.

757 Службы удаленного доступа не могут запускаться автоматически. Дополнительную информацию можно найти в журнале событий.

758 Для этого подключения уже разрешен общий доступ к подключению Интернета (ICS).

760 Произошла ошибка при разрешении маршрутизации.

761 Произошла ошибка при разрешении общего доступа к подключению Интернета.

763 Не удается разрешить общий доступ к подключению Интернета. Более чем одно подключение по локальной сети будет использовано совместно.

764 Считыватели смарт-карт не установлены.

765 Не удается разрешить общий доступ к подключению Интернета. Подключение по локальной сети уже настроено на использование IP-адреса, который распределяется автоматически.

767 Не удается разрешить общий доступ к подключению Интернета. Подключение локальной сети, выбранной в качестве частной, настроено на использование более одного IP-адреса. Измените параметры настройки подключения к локальной сети.

768 Ошибка шифрования данных при попытке подключения.

769 Указанное назначение недостижимо.

770 Удаленный компьютер отверг попытку подключения.

771 Попытка подключиться не удалась, поскольку сеть перегружена.

772 Аппаратура удаленного компьютера несовместима с типом запрашиваемого вызова.

773 Попытка подключиться не удалась из-за изменения адреса назначения.

774 Попытка подключиться не удалась из-за временной ошибки. Попробуйте подключиться снова.

775 Подключение было блокировано удаленным компьютером.

776 Подключиться не удалось, поскольку удаленный компьютер вошел в режим «Не беспокоить».

777 Попытка подключения не удалась, поскольку на удаленном компьютере не работает модем или другое устройство связи.

778 Невозможно проверить идентичность сервера.

780 Пробная функция недопустима для этого подключения.

783 Не удается разрешить общий доступ к подключению Интернета. Подключение локальной сети, выбранной в качестве частной, либо не существует, либо разорвано. Убедитесь, что подключен сетевой адаптер.

784 Невозможно использовать это подключение во время загрузки, поскольку оно использует имя пользователя, отличное от пользователя смарт-карты. Для использования его во время загрузки измените используемое имя на имя владельца смарт-карты.

785 Невозможно использовать это подключение во время загрузки, поскольку оно настроено на использование смарт-карты. Измените свойства этого подключения, чтобы использовались данные смарт-карты.

788 Попытка L2TP-подключения не удалась, поскольку на уровне безопасности не удалось согласовать параметры с удаленным компьютером.

789 Попытка L2TP-подключения не удалась из-за ошибки, произошедшей на уровне безопасности во время согласований с удаленным компьютером.

791 Попытка L2TP-подключения не удалась, поскольку не найдена политика безопасности.

792 Попытка L2TP-подключения не удалась, поскольку истекло время согласования режима безопасности.

793 Попытка L2TP-подключения не удалась из-за ошибки согласования режима безопасности.

794 Установленный RADIUS-атрибут «Кадрированный протокол» (Framed Protocol) для этого пользователя не имеет значение PPP.

795 Установленный RADIUS-атрибут «Тип туннеля» (Tunnel Type) для этого пользователя имеет некорректное значение.

796 Установленный RADIUS-атрибут «Тип службы» (Service Type) для этого пользователя не имеет значения ни «Кадрированный» (Framed), ни «Кадрированный для ответных вызовов» (Callback Framed).

797 Подключение к удаленному компьютеру не удалось установить из-за того, что модем не найден или занят.

799 Не удалось включить общий доступ к подключению Интернета (ICS) из-за конфликтов IP-адресов в сети. ICS требует, чтобы узел был настроен на использование адреса 192.168.0.1. Убедитесь, что никакой другой клиент сети не использует адрес 192.168.0.1.

800 Не удалось установить подключение к виртуальной частной сети. Недоступен сервер VPN или неправильно настроены параметры безопасности для данного подключения.


Модем не работает с компонентом «Сетевые подключения»

Если доступен другой компьютер, подключенный к Интернету, просмотрите перечень поддерживаемых модемов в списке совместимого оборудования Microsoft Windows. XOX

Если модем присутствует в этом списке, проверьте правильность его подключения к соответствующему порту компьютера. Если модем внешний, убедитесь, что его питание включено.

Дополнительные сведения об устранении неполадок с модемами см. в разделе Устранение неполадок с модемами.


Дата компиляции

Рисунок Microsoft Windows
Дата компиляции: 2003-12-03


Как работает брандмауэр Windows

 Иллюстрация брандмауэра, блокирующего одни подключения и пропускающего другие


Групповые политики для сетевых подключений

С помощью оснастки «Групповая политика» администратор может настроить параметры рабочего стола сразу для нескольких компьютеров. Некоторые параметры групповой политики относятся непосредственно к компоненту «Сетевые подключения», например, поддержка доступа пользователей к подключениям и возможность изменения свойств подключений. Эти параметры содержатся в папке «Административные шаблоны» оснастки «Групповая политика».

Где?

  • Имя_объекта_групповой_политики
  • Конфигурация компьютера (или Конфигурация пользователя)
  • Административные шаблоны
  • Сеть
  • Сетевые подключения

Примечание

  • Если у пользователя нет права доступа для записи в объект групповой политики, он не сможет увидеть параметры, содержащиеся в этом объекте.

См. также


Переименование значка сетевого подключения

Рисунок Microsoft Windows

Чтобы переименовать значок сетевого подключения

XOX

  1. Откройте компонент Сетевые подключения.
  2. Щелкните значок сетевого подключения, который следует переименовать.
  3. В группе Типичные сетевые задачи щелкните ссылку Переименование отдельного подключения.
  4. В выделенном поле под выбранным значком введите новое имя.

Примечания

  • XOX
  • Данная процедура позволяет присвоить значку сетевого подключения легко запоминаемое имя.
  • Не рекомендуется переименовывать значок общего подключения к Интернету, который автоматически устанавливается на клиентских компьютерах главным компьютером общего доступа к подключению Интернета (ICS). Имя общего подключения к Интернету, установленного на главном компьютере ICS, отображается на клиентском компьютере в нескольких местах.
    1. В папке «Сетевые подключения».
    2. Под значком подключения, который можно отобразить в области уведомлений на панели задач.
    3. В окне состояния общего подключения к Интернету.

См. также


Отображение значков сетевых подключений на панели задач

Рисунок Microsoft Windows

Чтобы включить отображение значка сетевого подключения на панели задач

  1. Откройте компонент Сетевые подключения.
  2. В группе ЛВС или высокоскоростной Интернет щелкните значок сетевого подключения, который требуется отображать на панели задач. Затем в группе Задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Общие установите флажок При подключении вывести значок в области уведомлений.

Примечания

  • XOX
  • Если значок сетевого подключения показан в области уведомлений на панели задач, то, установив на нем указатель мыши, можно вывести на экран основные сведения о подключении и статистические данные.
  • Если для общего подключения к Интернету установлен флажок При подключении вывести значок в области уведомлений, значок для этого подключения будет появляться в области уведомлений каждый раз при установке подключения. При разрыве общего подключения к Интернету его значок исчезает из области уведомлений.

См. также


Общие сведения об определениях служб для общего доступа к подключению к Интернету

Службы незаметно поддерживают другие программы. Примером службы является веб-сервер, работающий по протоколу HTTP, который поддерживает размещение веб-страниц из домашней или малой офисной сети. Если в сети включена служба веб-сервера HTTP, можно использовать эту службу для загрузки собственных веб-страниц в Интернет. Помимо использования веб-сервера можно использовать в сети службу FTP, которая разрешает пользователям загружать файлы через Интернет, почтовый сервер Интернета для хранения и перенаправления электронной почты и множество других служб.

Чтобы разрешить прохождение трафика через Интернет в компьютер, на котором размещена служба, необходимо добавить эту службу в список Службы. Для этого введите сведения о рабочих параметрах службы на вкладке Службы главного компьютера ICS. Набор рабочих параметров предоставляет параметры, которые требуются для того, чтобы брандмауэр Windows разрешил прохождение трафика из Интернета в сеть и чтобы компьютер ICS мог перенаправить этот трафик. Операционные параметры также называются «определением службы», потому что они определяют требуемую среду. К сведениям, которые необходимо ввести для добавления определения службы, относятся: описание службы, имя или IP-адрес компьютера, на котором размещена служба, а также номера портов TCP или UDP службы. Дополнительные сведения см. в разделе Добавление определения службы.

Некоторые службы определены для ICS заранее. FTP-сервер, почтовый сервер Интернета, безопасный веб-сервер, сервер Telnet и веб-сервер — примеры встроенных служб. Эти службы можно запустить на клиентских компьютерах ICS или на главном компьютере ICS. Чтобы добавить в сеть новую службу, установите программное обеспечение службы на одном из компьютеров сети и затем добавьте определение службы, чтобы при включении ICS доступ к службе из Интернета был разрешен. Для определения заранее настроенных служб требуется только имя или IP-адрес компьютера, на котором размещена служба. Для встроенных служб невозможно изменить такие сведения, как описание службы и номер портов TCP или UDP. Дополнительные сведения см. в разделе Изменение определения службы.


Обращение в компанию Parallel Technologies или к ее местному дилеру для приобретения кабелей прямого подключения

Рисунок Microsoft Windows

Чтобы связаться с компанией Parallel Technologies для приобретения кабелей прямого подключения

  • С этой компанией можно связаться одним из следующих способов.
    • По телефону

      В США и Канаде звоните +1 (800) 789-4784. (800) 789-4784

      В остальных странах звоните (425) 869-1119. (425) 869-1119

    • Через Интернет

      Веб-узел Direct Parallel

    • По электронной почте

      sales@lpt.com

      Электронная почта Compuserve 71612,3466

    • Справка по местным дилерам

      Звоните (425) 869-1119

Примечание

  • XOX


Настройка основного шлюза

Рисунок Microsoft Windows

Чтобы настроить основной шлюз

  1. Откройте компонент Сетевые подключения.
  2. Выделите подключение по локальной сети, которое требуется настроить, и затем в группе Типичные сетевые задачи щелкните ссылку Изменить параметры этого подключения.
  3. На вкладке Общие в списке Отмеченные компоненты используются этим подключением выберите вариант Протокол Интернета (TCP/IP) и нажмите кнопку Свойства
    4. .
  4. На вкладке Альтернативная конфигурация установите переключатель в положение Настраиваемый пользователем. Введите значения IP-адреса, маски подсети и адреса основного шлюза.

Примечания

  • XOX
  • Если протокол TCP/IP настроен на автоматическое получение IP-адреса, то для настройки основного шлюза необходимо вручную указать адрес TCP/IP и маску подсети.

См. также


Создание сценариев для промежуточных устройств

Каждому сценарию для статического диалогового окна отводится раздел файла Switch.inf. Для каждого промежуточного устройства в файл Switch.inf добавляется соответствующий сценарий. Примеры сценариев для сетей X.25 см. в файле Pad.inf, находящемся в папке системный_корневой_каталог\System32\Ras.

При подключении с использованием модемных пулов или защитных узлов необходимо вступить в диалог с устройством. Диалог может происходить как перед подключением, так и после него. Хотя оба эти диалога могут быть как статическими, так и интерактивными, обычно перед подключением используется статический диалог, а после подключения — интерактивный.

В стандартном файле Switch.inf содержится типовой сценарий, который, как правило, можно использовать при подключении к серверам PPP в готовом виде либо после внесения минимальных изменений. При подключении попробуйте сначала выполнить предлагаемый сценарий Switch.inf. Если он не работает, скопируйте и измените его таким образом, чтобы он соответствовал последовательности входа на удаленном компьютере, к которому выполняется подключение.

Дополнительные сведения о сценариях файла Switch.inf см. в разделе Автоматизация процесса входа в удаленную систему с помощью сценариев Switch.inf. Сведения о настройке подключения на использование сценария Switch.inf см. в разделе Чтобы активизировать сценарий входа в систему.