Отправка сообщения консоли

Команда «Отправка сообщения консоли» предназначена для отправки сообщений на компьютеры, имеющие открытые сеансы с управляемым компьютером. При этом можно отправить сообщение на конкретный компьютер или всем пользователям, подключенным к управляемому компьютеру.

  • Справка по выполнению конкретных задач содержится в разделе Инструкции.
  • Сведения общего характера см. в разделе Основные понятия.


Инструкции

  • Отправка сообщения консоли всем подключенным компьютерам
  • Отправка сообщения консоли управляемому компьютеру


Отправка сообщения консоли всем подключенным компьютерам

Рисунок Microsoft Windows

Чтобы отправить сообщение консоли всем подключенным компьютерам

Использование оснастки «Управление компьютером»

  1. XOX
  2. В дереве консоли щелкните правой кнопкой мыши узел Общие папки, укажите пункт Все задачи и выберите команду Отправка сообщения консоли.
  3. Введите текст, который требуется отправить, в поле Сообщение.
  4. Нажмите кнопку Добавить, введите имена компьютеров получателей в поле Получатели и нажмите кнопку OK.
  5. Нажмите кнопку Отправить.

Примечания

  • XOX
  • Если некоторые адресаты не получают сообщение, имена компьютеров остаются в списке Получатели диалогового окна Отправка сообщения консоли. Проверьте, что имена компьютеров записаны правильно и что компьютеры доступны, и повторите отправку сообщения.
  • При выполнении команды из корневого узла «Управление компьютером» список получателей содержит только имя управляемого компьютера. При выполнении команды из узлов «Общие папок» или «Службы» список получателей содержит имена всех компьютеров, которые имеют открытые в настоящий момент сеансы с управляемым компьютером.
  • Для получения дополнительных сведений об использовании оснастки «Управление компьютером» щелкните ссылку «См. также».

Использование командной строки

  • Откройте окно Командная строка.
  • Введите:

    net send /users сообщение

Аргумент | Описание
net send | Отправка сообщения другому пользователю, компьютеру или псевдониму, доступному в сети. Для получения сообщений на компьютере должна быть запущена служба сообщений.
/users | Отправка сообщения всем пользователям, подключенным к серверу.
сообщение | Сообщение, которое требуется отправить.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    net help send

Важно!

  • Будьте внимательны при отправке сообщения консоли всем подключенным компьютерам. Эта список рассылки может быть очень большим.

Примечания

  • Для получения сообщений консоли необходимо, чтобы на компьютере получателя была запущена служба сообщений.
  • Если на компьютере получателя включен брандмауэр Windows, сообщения консоли могут быть заблокированы.
  • Получатели идентифицируются по именам компьютеров. Если пользователь вошел в систему на нескольких компьютерах, сообщение получит компьютер, имя которого содержится в списке.
  • Отправляемые сообщения не сохраняются.

См. также


Отправка сообщения консоли управляемому компьютеру

Рисунок Microsoft Windows

Чтобы отправить сообщение консоли управляемому компьютеру

Использование оснастки «Управление компьютером»

  1. XOX
  2. Щелкните правой кнопкой мыши Управление компьютером имя_компьютера (или Управление компьютером (локальным) в случае управления локальным компьютером), укажите на пункт Все задачи, а затем выберите команду Отправить сообщение консоли.
  3. Введите текст, который требуется отправить, в поле Сообщение.
  4. Нажмите кнопку Добавить, введите имена компьютеров-получателей в поле Получатели и нажмите кнопку OK.
  5. Нажмите кнопку Отправить.

Примечания

  • XOX
  • По умолчанию в поле Получатели отображаются только имена управляемых компьютеров.
  • Если некоторые адресаты не получают сообщение, имена компьютеров остаются в списке Получатели диалогового окна Отправка сообщения консоли. Проверьте, что имена компьютеров записаны правильно и что компьютеры доступны, и повторите отправку сообщения.
  • При выполнении команды из корневого узла «Управление компьютером» список получателей содержит только имя управляемого компьютера. При выполнении команды из узла «Общие папки» или «Службы» список получателей содержит имена всех компьютеров, которые имеют открытые в настоящий момент сеансы с управляемым компьютером.
  • Для получения дополнительных сведений об использовании оснастки «Управление компьютером» щелкните ссылку «См. также».

Использование командной строки

  • Откройте окно Командная строка.
  • Введите:

    net send имя_компьютера сообщение

Аргумент | Описание
net send | Отправка сообщения другому пользователю, компьютеру или псевдониму, доступному в сети. Для получения сообщений на компьютере должна быть запущена служба сообщений.
имя_компьютера | Имя компьютера, на который необходимо отправить сообщение.
сообщение | Сообщение, которое требуется отправить.

Примечания

  • XOX
  • Чтобы просмотреть полный синтаксис этой команды, введите в командной строке:

    net help send

Примечания

  • Для получения сообщений консоли необходимо, чтобы на компьютере получателя была запущена служба сообщений.
  • Если на компьютере получателя включен брандмауэр Windows, сообщения консоли могут быть заблокированы.
  • Получатели идентифицируются по именам компьютеров. Если пользователь вошел в систему на нескольких компьютерах, сообщение получит компьютер, имя которого содержится в списке.
  • Отправляемые сообщения не сохраняются.

См. также


Основные понятия

В этом разделе представлена информация общего характера о команде «Отправка сообщения консоли».

  • Общие сведения о команде «Отправка сообщения консоли»
  • Отправка сообщения консоли из командной строки


Общие сведения о команде «Отправка сообщения консоли»

Команда «Отправка сообщения консоли» представляет собой расширение оснастки «Управление компьютером». С помощью команды «Отправка сообщения консоли» можно отправить сообщение некоторым или всем пользователям, подключенным к управляемому компьютеру. Например, если необходимо отключить или перезапустить управляемый компьютер, можно просто отправить сообщение, уведомляющее всех пользователей, которые подключены к общему тому, папке или принтеру, об отключении или перезапуске.

Команда отправки сообщений консоли доступна в узлах «Управление компьютером», «Общие папки» и «Службы». Работа команды «Отправка сообщения консоли» незначительно различается в зависимости от узла, из которого она запущена.

  • При выполнении команды из корневого узла «Управление компьютером» список получателей содержит только имя управляемого компьютера.
  • При выполнении команды из узлов «Общие папок» или «Службы» список получателей содержит имена всех компьютеров, которые имеют открытые в настоящий момент сеансы с управляемым компьютером.


Отправка сообщения консоли из командной строки

В дополнение к команде «Отправка сообщения консоли» оснастки управления компьютером можно работать с сообщениями в командной строке. С помощью команды Net send можно отправить сообщения другим пользователям, компьютерам или псевдонимам, доступным в сети.

Дополнительные сведения о других служебных программах командной строки см. в разделе Справочник по использованию командной строки. Дополнительные сведения о возможностях управления см. в разделе Управление и администрирование.