Службы

Оснастка «Службы» используется для управления службами на локальном или удаленном компьютерах.

  • Описание некоторых возможностей, изменившихся в Windows ХР, см. в разделе Новые способы выполнения некоторых задач.
  • Советы по использованию оснастки «Службы» находятся в разделе Советы и рекомендации.
  • Справочные сведения по выполнению конкретных задач см. в разделе Инструкции.
  • Сведения общего характера см. в разделе Основные понятия.


Новые способы выполнения типичных задач

В следующей таблице перечислены некоторые общие задачи, связанные с настройкой служб. Пользовательский интерфейс для выполнения этих задач отличается от того, который применяется в Windows NT версии 4.0.

Примечание

  • XOX
Задача | В Windows NT 4.0 используется | В Windows XP используется
Запуск, приостановка, остановка, возобновление и перезапуск службы на удаленном и локальном компьютерах | Панель управления | Откройте оснастку Службы. Дополнительные сведения см. в разделе Запуск, остановка, приостановка и возобновление работы службы


Советы и рекомендации

  • Соблюдайте осторожность при изменении стандартной настройки.

    Изменение стандартной настройки служб может привести к неправильной работе ключевых служб. Особенно важно соблюдать осторожность при изменении параметров «Тип запуска» и «Вход в систему» для служб, настроенных для автоматического запуска.

  • Перед изменением значения типа запуска проверьте, чтобы запуск служб осуществлялся без вмешательства пользователя.

    Если запуск системной службы выполняется автоматически, выполните соответствующую проверку, чтобы убедиться, что для запуска службы не требуется вмешательство пользователя.

  • Перед приостановкой или остановкой службы «Сервер» сообщите пользователям, подключенным к компьютеру.

    При остановке работы службы «Сервер» все пользователи, которые были связаны с этим компьютером через сеть, будут отключены. Удаленное администрирование данного компьютера невозможно, таким образом, службу «Сервер» необходимо запустить локально. Если приостановлена работа службы «Сервер», только члены групп «Администраторы» и «Операторы сервера» могут установить новую связь с этим компьютером.

    При остановке службы «Сервер» она автоматически запускается при перезагрузке компьютера. Чтобы отключить автоматический запуск, в поле Тип загрузки выберите Вручную или Отключено. Дополнительная информация о настройке службы запуска см. раздел Настройка запуска службы.


Инструкции

  • Настройка запуска службы
  • Запуск, остановка, приостановка, возобновление работы или перезапуск службы
  • Выбор учетной записи для выполнения службы
  • Включение или отключение службы для профиля оборудования
  • Установка действий по восстановлению, выполняемых при сбое службы
  • Просмотр зависимых служб
  • Запуск службы вторичного входа


Настройка запуска службы

Рисунок Microsoft Windows

Чтобы настроить запуск службы

  1. Откройте оснастку Службы.
  2. Щелкните правой кнопкой службу, которую требуется настроить, и выберите команду Свойства.
  3. На вкладке Общие в поле Тип запуска выберите Авто, Вручную или Отключено.
  4. Чтобы указать учетную запись пользователя, которую служба может использовать для входа в систему, выберите вкладку Вход в систему и выполните одно из следующих действий.
    • Чтобы указать использование службой учетной записи «Локальный компьютер», установите переключатель в положение С системной учетной записью.
    • Чтобы указать использование службой учетной записи «LocalService», установите переключатель в положение С учетной записью и введите NT AUTHORITY\LocalService.
    • Чтобы указать использование службой учетной записи «NetworkService», установите переключатель в положение С учетной записью и введите NT AUTHORITY\NetworkService.
    • Чтобы указать использование другой учетной записи, установите переключатель в положение С учетной записью, нажмите кнопку Обзор и укажите учетную запись пользователя в диалоговом окне Выбор пользователей. Для продолжения нажмите кнопку OK.
  5. Введите пароль для выбранной учетной записи в полях Пароль и Подтверждение и нажмите кнопку OK.

Важно!

  • Изменение стандартной настройки служб может привести к неправильной работе ключевых служб. Особенно важно соблюдать осторожность при изменении параметров «Тип запуска» и «Вход в систему» для служб, настроенных для автоматического запуска.

Примечания

  • XOX
  • XOX
  • Если служба включена или отключена и возникли неполадки при запуске компьютера, возможно удастся запустить компьютер в безопасном режиме. Затем можно изменить настройку службы или восстановить настройки по умолчанию. Для получения дополнительных сведений щелкните ссылку «См. также».
  • При установке флажка Разрешить взаимодействие с рабочим столом служба предоставляет пользователю интерфейс на рабочем столе. Эта возможность доступна только при установке переключателя в положение С системной учетной записью и только если служба настроена для взаимодействия с рабочим столом.
  • Дополнительная информация об учетных записях пользователя, которые служба использует для входа в систему см. по ссылке «См. также».

См. также


Запуск, остановка, приостановка, возобновление работы или перезапуск службы

Рисунок Microsoft Windows

Чтобы запустить, остановить, приостановить, возобновить работу или перезапустить службу

  1. Откройте оснастку Службы.
  2. В области сведений выполните следующие действия.
    • Выберите службу. В меню Действие выберите команды Пуск, Стоп, Остановка, Продолжение или Перезапуск.
    • Щелкните команду правой кнопкой мыши и выберите команды Пуск, Стоп, Остановка, Продолжение или Перезапуск.

Важно!

  • При остановке, запуске и перезапуске службы, оказывается влияние на любые зависимые от нее службы.
  • Изменение стандартной настройки служб может привести к неправильной работе ключевых служб. Особенно важно соблюдать осторожность при изменении параметров «Тип запуска» и «Вход в систему» для служб, настроенных для автоматического запуска.

Примечания

  • XOX
  • XOX
  • Для настройки параметров запуска службы щелкните службу правой кнопкой мыши, выберите команду Свойства и введите параметры в поле Параметры запуска перед нажатием кнопки Пуск. Эта настройка используется только один раз и не сохраняется. (Обратная косая черта (\) обрабатывается как управляющий знак, поэтому для каждого символа обратной косой черты в параметре следует ввести два таких символа.)

См. также


Выбор учетной записи для выполнения службы

Рисунок Microsoft Windows

Чтобы выбрать учетную запись для выполнения службы

  1. Откройте оснастку Службы.
  2. Щелкните правой кнопкой мыши службу, которой требуется назначить учетную запись пользователя или группы, и выберите из контекстного меню команду Свойства.
  3. Откройте вкладку Вход в систему и выполните одно из следующих действий.
    • Чтобы указать использование службой учетной записи «Локальный компьютер», установите переключатель в положение С системной учетной записью.
    • Чтобы указать использование службой учетной записи «LocalService», установите переключатель в положение С учетной записью и введите NT AUTHORITY\LocalService.
    • Чтобы указать использование службой учетной записи «NetworkService», установите переключатель в положение С учетной записью и введите NT AUTHORITY\NetworkService.
    • Чтобы указать использование другой учетной записи, установите переключатель в положение С учетной записью, нажмите кнопку Обзор и укажите учетную запись пользователя в диалоговом окне Выбор пользователей. Для продолжения нажмите кнопку OK.
  4. Введите пароль для выбранной учетной записи в полях Пароль и Подтверждение и нажмите кнопку OK.

Важно!

  • Изменение стандартных настроек служб может привести к неправильной работе ключевых служб. Особенно важно соблюдать осторожность при изменении параметров «Тип запуска» и «Вход в систему» для служб, настроенных для автоматического запуска.

Примечания

  • XOX
  • Необходимо настроить учетную запись пользователя специально для входа службы. Чтобы проверить правильность настройки учетной записи пользователя, щелкните правой кнопкой мышы учетную запись пользователя в оснастке «Пользователи и группы». В диалоговом окне Свойства на вкладке Общие должен быть установлен флажок Срок действия пароля не ограничен, на вкладке Членство в группах убедитесь, что пользователь является членом соответсвующих групп. Для получения дополнительных сведений об оснастке «Пользователи и группы» щелкните ссылку «См. также».
  • При выборе учетной записи пользователя, которая не имеет право выполнять вход в качестве службы, оснастка «Службы» автоматически выдает разрешения этой учетной записи на управляемом компьютере.

См. также


Включение или отключение службы для профиля оборудования

Рисунок Microsoft Windows

Чтобы включить или отключить службу для профиля оборудования

  1. Откройте оснастку Службы.
  2. Щелкните правой кнопкой мыши библиотеку, которую требуется включить или отключить, и выберите команду Свойства.
  3. На вкладке Вход в систему выберите профиль оборудования, который нужно настроить.
  4. В столбце «Служба» установите значение Включена или Отключено, а затем кнопку ОК.

Важно!

  • Изменение стандартных настроек служб может привести к неправильной работе ключевых служб. Особенно важно соблюдать осторожность при изменении параметров «Тип запуска» и «Вход в систему» для служб, настроенных для автоматического запуска.

Примечания

  • XOX
  • При отключении службы для конкретного профиля оборудования, настройка профиля оборудования переопределяет настройку «Тип запуска» для этой службы.
  • Используйте диалоговое окно «Свойства системы» для создания и управления профилями оборудования. Для получения дополнительных сведений о создании профилей оборудования щелкните ссылку «См. также».

См. также


Установка действий по восстановлению, выполняемых при сбое службы

Рисунок Microsoft Windows

Чтобы установить действия по восстановлению, выполняемые при сбое службы

  1. Откройте оснастку Службы.
  2. Щелкните правой кнопкой мыши службу, действия по восстановлению которой нужно установить, и выберите команду Свойства.
  3. На вкладке Восстановление выберите действие, которое необходимо предпринять, в полях Первый сбой, Второй сбой и Последующие сбои, и затем нажмите кнопку OK.

Примечания

  • XOX
  • Действия по восстановлению доступны только на компьютерах под управлением Windows 2000 или Windows XP.
  • Если выбрана возможность Выполнение программы, не указывайте программы или сценарии, требующие ввода данных пользователем.
  • Если выбрана возможность Перезагрузка компьютера, можно указать время ожидания перед перезагрузкой компьютера. Для этого нажмите кнопку Параметры перезагрузки компьютера. Также можно создать сообщение, выдаваемое удаленным пользователям до перезапуска компьютера.

См. также


Просмотр зависимых служб

Рисунок Microsoft Windows

Чтобы просмотреть зависимые службы

  1. Откройте оснастку Службы.
  2. Щелкните правой кнопкой службу, которую требуется настроить, и выберите команду Свойства.
  3. Выберите вкладку Зависимости.

Примечания

  • XOX
  • Верхний список на вкладке Зависимости показывает другие службы, которые должны работать для функционирования выбранной службы. Нижний список на вкладке Зависимости показывает службы, которые требуют запуска выбранной службы, чтобы они работали правильно.

См. также


Запуск службы вторичного входа

Рисунок Microsoft Windows

Чтобы запустить службу вторичного входа

  1. Откройте оснастку Службы.
  2. В колонке Имя щелкните Вторичный вход в систему.
  3. В меню Действие выберите команду Пуск.

Примечания

  • XOX
  • Служба «Вторичный вход в систему» позволяет открывать программы (файлы с расширением .ехе), сохраненные консоли ММС (файлы с расширением .msc) и компоненты панели управления от имени администратора, находясь в системе с учетной записью члена другой группы, например «Пользователи» или «Опытные пользователи».
  • По умолчанию служба «Вторичный вход в систему» автоматически начинает работать при включении компьютера. Для получения дополнительных сведений о настройке параметров запуска службы щелкните ссылку «См. также».
  • Команда runas позволяет запусить конкретные средств и программы с разрешениями, отличными от тех, которые предоставляет текущая учетная запись. Для получения дополнительных сведений об этой команде щелкните ссылку «См. также».

См. также


Основные понятия

Данный раздела содержит сведения общего характера об оснастке «Службы».

  • Общие сведения о службах
  • Разрешения служб
  • Стандартная настройка служб


Общие сведения о службах

Служба — это тип приложения, которое запускается в фоновом режиме и сходны с приложениями-процессами UNIX. Приложения служб обычно поддерживают приложения типа «клиент-сервер», веб-серверы, серверы баз данных и другие веб-приложения для локальных и удаленных пользователей.

Службы используются для следующих действий.

  • Запустить, приостановить, остановить, возобновить и отключить службы на удаленном и локальном компьютерах. Необходимо иметь соответствующие разрешения на запуск, приостановку, остановку, перезапуск и отключение служб.
  • Управление службами на локальном и удаленном компьютерах (удаленный компьютер должен быть только под управлением Windows XP, Windows 2000 или Windows NT 4.0).
  • Настраивать действия по аварийному восстановлению службы в случае сбоя, например автоматический перезапуск службы или компьютера (только на компьютерах с системой Windows XP или Windows 2000).
  • Включить или отключить службы для конкретного профиля оборудования.
  • Просмотреть состояние и описание каждой службы.


Разрешения служб

У каждой службы есть определенные разрешения, которые предоставляются или запрещаются для каждого пользователя или группы. Разрешения для отдельных служб можно установить используя средство «Шаболны безопасности». Дополнительные сведения по этому вопросу содержатся в разделе Локальные пользователи и группы.

Службы должны входить с учетной записью, чтобы получить доступ к ресурсам и объектам операционной системы. Некоторые службы по умолчанию настроены на вход в систему с локальной системной учетной записью, которая является самой мощной учетной записью и имеет полный доступ к системе. Если служба входит в локальную системную учетную запись на контроллере домена, у нее есть доступ ко всему домену. Другие службы настроены на вход в систему с учетными записями «LocalService» или «NetworkService», которые являются определенными встроенными записями, сходными с проверенными учетными записями пользователей. У этих записей уровень доступа к ресурсам и объектам такой же, как и у членов групп «Пользователи». Такой ограниченный доступ позволяет защитить систему, если нарушена работа отдельных служб или процессов.

Службы с учетной записью «LocalService» имеют доступ к сетевым ресурсам, как нулевой сеанс без учетных данных. Службы с учетной записью «NetworkService» имеют доступ к сетевым ресурсам с использованием учетных данных машины.

Дополнительные сведения о настройке службы, см. раздел Настройка запуска службы.

Внимание!

  • Перемена учетной записи, под которой выполняется служба, может привести к неправильной работе службы

В следующей таблице приведены разрешения служб, которые можно применять.

Разрешение | Описание
Полный доступ | Выполняет все действия. Это разрешение автоматически предоставляет пользователю все служебные разрешения
Запрос шаблона | Определяет настройку параметров, соответствующих объекту службы
Изменение шаблона | Изменение настройки службы
Запрос состояния | Предоставляется сведения о состоянии службы
Перечисление зависящих служб | Определяются все службы, которые зависят от выбранной службы.
Пуск | Запускает службу
Остановка | Останавливает работу службы
Приостановка и продолжение работы | Приостанавливает и продолжает работу службы
Опрос | Докладывает о текущем состоянии службы
Пользовательский элемент управления | Посылает запрос пользовательского элемента управления или запрос, что он указан в службе, этой службе.
Удаление | Удаляет службу
Чтение разрешений | Читает разрешения безопасности, назначенные службе
Смена разрешений | Меняет разрешения безопасности, назначенные службе
Смена владельца | Изменяет ключ безопасности или меняет разрешения для службы, которая не принадлежит пользователю


Стандартные настройки служб

При стандартной установке многие службы настраиваются как «автоматические» (т.е., запуск служб выполняется автоматически при запуске системы или при первом обращении к службе). Если для службы задан параметр «вручную», службу необходимо запускать вручную перед осуществлением ее загрузки операционной системой и предоставлением возможности ее использования. Если служба «отключена», ее нельзя запустить ни вручную, ни автоматически. Дополнительные сведения о настройке запуска службы, см. раздел Настройка запуска службы. Дополнительные сведения о запуске службы из командной строки находятся в разделе Net start.

В следующей таблице указаны стандартные службы при обычной установке Windows XP Porfessional вместе с настройкой запуска этих служб по умолчанию. Список служб может быть различным в зависимости от компонентов, выбранных при установке, и от дополнительно установленных программ.

Служба | Группа «Тип запуска» | Группа «Вход в систему как» | Дополнительные сведения
Оповещатель | Вручную | Локальная служба |
Application Layer Gateway | Вручную | Локальная служба |
Управление приложениями | Вручную | Локальная система |
Автоматическое обновление | Авто | Локальная система |
Background Intelligent Transfer Service | Вручную | Сетевая служба | Сведения об устранении неполадок, связанных с этой службой см. в разделе Время задержки неактивных заданий службы BITS (Background Intelligent Transfer Service).
Сервер папки обмена | Вручную | Локальная система |
Система событий СОМ+ | Вручную | Локальная система |
Приложения COM+ System | Вручную | Локальная система |
Обозреватель компьютеров | Авто | Локальная система |
Службы крипрографии | Авто | Локальная система |
DHCP-клиент | Авто | Локальная система |
Клиент отслеживания изменившихся связей | Авто | Локальная система |
Координатор распределенных транзакций | Вручную | Сетевая служба |
DNS-клиент | Авто | Сетевая служба |
Регистрация ошибок | Авто | Локальная система |
Журнал событий | Авто | Локальная система |
Быстрое переключение пользователей | Вручную | Локальная система |
Справка и поддержка | Авто | Локальная система |
Доступ к HID-устройствам | Отключено | Локальная система |
IMAPI CD-Burning COM | Вручную | Локальная система |
Служба индексирования | Вручную | Локальная система | Служба индексирования используется для индексирования документов и их свойств и сохранения информации о них в каталоге. Дополнительные сведения содержатся в разделе Служба индексирования.
Общий доступ к подключению Интернета | Вручную | Локальная система |
Службы IPSec | Авто | Локальная система |
Диспетчер логических дисков | Авто | Локальная система |
Служба администрирования диспетчера логических дисков | Вручную | Локальная система |
Служба сообщений | Авто | Локальная служба | Для получения оповещений данная служба должна быть запущена. Дополнительные сведения о наблюдении за производительностью см. в разделе Введение в наблюдение за производительностью. Эту службу необходимо запустить на компьютерах пользователей, чтобы можно было получать сообщения консоли. Дополнительные сведения о сообщениях консоли см. в разделе Отправка сообщения консоли.
MS Software Shadow Copy Provider | Вручную | Локальная система |
Сетевой вход в систему | Авто | Локальная система |
NetMeeting Remote Desktop Sharing | Вручную | Локальная система |
Сетевые подключения | Вручную | Локальная система |
Диспетчер сетевого DDE | Вручную | Локальная система |
Диспетчер сетевого DDE | Вручную | Локальная система |
Служба сетевого расположения (NLA) | Вручную | Локальная система |
Поставщик поддержки безопасности NT LM | Вручную | Локальная система |
Оповещения и журналы производительности | Вручную | Сетевая служба |
Plug and Play | Авто | Локальная система |
Portable media serial number | Авто | Локальная система |
Диспетчер очереди печати | Авто | Локальная система | Если принтер не отвечает, перезапустите эту службу. Отложенные задания печати отменяются.
Защищенное хранилище | Авто | Локальная система |
QoS RSVP | Вручную | Локальная система |
Диспетчер авто-подключений удаленного доступа | Вручную | Локальная система |
Диспетчер подключений удаленного доступа | Вручную | Локальная система |
Диспетчер сеанса справки для удаленного рабочего стола | Вручную | Локальная система |
Удаленный вызов процедур (RPC) | Авто | Локальная система |
Локатор удаленного вызова процедур (RPC) | Вручную | Сетевая служба |
Удаленный реестр | Авто | Локальная служба | Для повышения производительности, связанной с этой службой, см. раздел Устранение неполадок.
Съемные ЗУ | Вручную | Локальная система |
Маршрутизация и удаленный доступ | Вручную | Локальная система |
Вторичный вход в систему | Авто | Локальная система | Дополнительные сведения о службе «Вторичный вход в систему» находятся в разделе Запуск службы вторичного входа.
Диспетчер учетных записей безопасности | Авто | Локальная система |
Сервер | Авто | Локальная система | Остановка работы этой службы приводит к отключению всех открытых сеансов с удаленным компьютером.
Определение оборудования оболочки | Авто | Локальная система |
Смарт-карты | Вручную | Локальная служба |
Модуль поддержки смарт-карт | Вручную | Локальная служба |
Служба обнаружения SSDP | Вручную | Локальная служба |
Уведомление о системных событиях | Авто | Локальная система |
Служба восстановления системы | Авто | Локальная система |
Планировщик заданий | Авто | Локальная система |
Модуль поддержки NetBIOS через TCP/IP | Авто | Локальная служба |
Телефония | Вручную | Локальная система |
Telnet | Вручную | Локальная система |
Cлужбы терминалов | Вручную | Локальная система |
Темы | Авто | Локальная система |
Источник бесперебойного питания | Вручную | Локальная служба |
Узел устройства UPnP | Вручную | Локальная система |
Upload Manager | Авто | Локальная система |
Диспетчер служебных программ | Вручную | Локальная система |
Мгновенные снимки состояния томов | Вручную | Локальная система |
Веб-клиент | Авто | Локальная служба |
Windows Audio | Авто | Локальная система |
Брандмауэр Windows/Общий доступ к подключению Интернета | Авто | Локальная система |
Windows Image Acquisition (WIA) | Вручную | Локальная система |
Windows Installer | Вручную | Локальная система |
Windows Management Instrumentation | Авто | Локальная система |
Служба времени Windows | Авто | Локальная система |
Wireless Zero Configuration service | Авто | Локальная система |
Адаптер производиетльности WMI | Вручную | Локальная система |
Рабочая станция | Авто | Локальная система |