Общие сведения о средстве «Восстановление системы»

Рисунок Microsoft Windows

Общие сведения о средстве «Восстановлении системы»

Средство «Восстановление системы» — компонент системы Windows XP Professional, с помощью которого при возникновении проблем можно восстановить предыдущее состояние компьютера без потери личных файлов (таких, как документы Microsoft Word, перечень просмотренных страниц, рисунки, избранные файлы и сообщения электронной почты). Программа «Восстановление системы» ведет наблюдение за изменениями системы и некоторыми файлами приложений и автоматически создает легко идентифицируемые точки восстановления. Эти точки восстановления позволяют вернуть систему к состоянию на данный момент времени. Они создаются ежедневно, а также во время существенных системных событий (таких, как установка приложения или драйвера). Пользователь также имеет возможность в любое время создавать именованные точки восстановления.

Примечания

  • Восстановление никак не влияет и не изменяет личные файлы данных. Дополнительные сведения об архивации личных файлов данных см. в разделе Архивация файлов и папок.
  • Общие сведения о других возможностях восстановления, предоставленных Windows XP, см. в разделе Восстановление операционной системы.
  • Дополнительные сведения о системе восстановления см. в разделе Общее представление о средстве «Восстановление системы».


Общие сведения о средстве «Восстановление системы»

Программа «Восстановление системы» позволяет выполнять перечисленные далее задачи.

Восстановление предыдущего состояния компьютера

Программа «Восстановление системы» постоянно автоматически отслеживает изменения, произошедшие на компьютере, и с указанными интервалами создает точки восстановления перед осуществлением изменений. Точки восстановления представляют сохраненные состояния компьютера.

Также можно создать точки восстановления вручную перед внесением изменений в компьютер, чтобы сохранить состояние компьютера и параметров. Появляется возможность восстановить предыдущее состояние компьютера, выбирая по дате или времени точку восстановления, после которой были произведены изменения.

Например, если случайно были удалены или повреждены наблюдаемые программные файлы (такие, как файлы с расширением .exe или .dll), то можно восстановить состояние компьютера, предшествующее внесению изменений.

Программа «Восстановление системы» по умолчанию отслеживает и восстанавливает все разделы и диски на компьютере. Она также отслеживает настройку всех приложений и дисков, которые осуществляют пользователи с помощью CD-ROM или гибкого диска, сервера управления системой (SMS) или IntelliMirror.

В некоторых случаях при восстановлении системы восстанавливается папка, имя которой совпадает с именем существующей папки. Чтобы не переписывать существующие файлы, программа «Восстановление системы» переименовывает папку, добавляя к ее имени числовой суффикс.

Восстановление состояния компьютера без потери личных файлов

Восстановление системы не приводит к потере личных файлов или пароля. Такие элементы, как документы, сообщения электронной почты, перечень просмотренных страниц и последний пароль, сохраняются при восстановлении системы до более раннего состояния.

Программа «Восстановление системы» обеспечивает сохранение личных файлов, не выполняя восстановление файлов в папке Мои документы. Кроме того, данная программа не восстанавливает файлы данных с часто используемыми расширениями, такими как .doc и .xls. Если пользователь не уверен, что его личные файлы имеют часто используемые расширения имен файлов данных и необходимо их исключить из операции восстановления системы, то следует поместить их в папку «Мои документы».

Если программа была установлена после создания точки восстановления, то в процессе восстановления эта программа может быть удалена. Файлы данных, созданные программой, не теряются. Однако для открытия этих файлов необходимо будет переустановить соответствующую программу.

Сохранение прошлых точек восстановления с давностью от одной до трех недель

Фактическое число сохраненных точек восстановления зависит от активности использования компьютера, размера жесткого диска (или размера раздела, содержащего каталог Windows XP Professional) и количества места на жестком диске, выделенного для хранения сведений программой «Восстановления системы». См. раздел Изменение параметров восстановления системы.

Обнаружение дат, соответствующих точкам восстановления

При запуске программы восстановления системы появляется календарь, позволяющий пользователю найти даты, соответствующие точкам восстановления. Если компьютер используется не каждый день, то в течение нескольких дней может существовать только одна точка восстановления. Если компьютер используется ежедневно, то точка восстановления будет приходиться почти на каждый день, а некоторым датам может соответствовать несколько точек восстановления.

Убедитесь, что все восстановления обратимы

Если пользователю не нравится состояние компьютера после его восстановления, то можно отменить восстановление или выбрать другую точку восстановления. Все удачные операции восстановления обратимы. Все неудачные операции обновления автоматически отменяются программой восстановления системы.

Обеспечение несколько типов точек восстановления

В следующем списке представлены все типы точек восстановления и работа программы восстановления системы с каждым типом точки.

Контрольные точки исходной системы

Такие контрольные точки создаются при первом запуске компьютера после обновления системы на Windows XP Professional или при первом запуске нового компьютера. Выбор этой точки возвратит Windows XP Professional и программы в начальное состояние. Все файлы данных с известными расширениями (такими как .doc, .htm, .xls и так далее) и файлы в папке «Мои документы» не будут восстановлены.

Если средство восстановления системы должно удалить все старые точки восстановления, чтобы освободить место на диске для новых изменений, будет создана новая точка восстановления и далее создание этих точек будет идти в обычном порядке.

Контрольные точки системы

Средство восстановления системы регулярно создает точки восстановления, даже если в системе не было сделано никаких изменений. Средством «Восстановление системы» автоматически создаются следующие точки восстановления:

  • каждые 24 часа по календарному времени;

    или

  • каждые 24 часа при включенном компьютере.

Если компьютер был выключен более 24 часов, средство восстановления системы создаст точку восстановления при следующем включении компьютера. Для создания точки восстановления по расписанию необходимо, чтобы компьютер находился в состоянии простоя несколько минут.

Выбор этой точки возвратит Windows XP Professional и программы в начальное состояние. Все файлы данных с известными расширениями (такими как .doc, .htm, .xls и так далее) и файлы в папке «Мои документы» не будут восстановлены.

Точки восстановления установки имени программы

При установке программ с помощью последних программ установки, типа InstallShield и Windows XP Professional Installer, система восстановления создает точку восстановления. Такие точки восстановления используются для отслеживания изменений в системе или для восстановления состояния компьютера, в котором он находился до установки программы.

При выборе такой точки восстановления все установленные файлы будут удалены и исходные параметры реестра, все программы и системные файлы будут восстановлены в том виде, в котором они были до установки. Все файлы данных с известными расширениями (такими как .doc, .htm, .xls и так далее) и файлы в папке «Мои документы» не будут восстановлены.

Чтобы отменить изменения, внесенные программой, которая не использует один из указанных установщиков, выберите предшествующую точку восстановления, наиболее близкую к дате установки программы.

Точки восстановления для автоматического обновления Windows XP Professional

При использовании автоматического обновления Windows XP Professional для получения загруженных обновлений система восстановления создает точку восстановления до установки обновленного программного обеспечения. Если обновление загружено, но не установлено, то точка восстановления не создается. Точка восстановления создается только при начале установки компонентов. Эти точки используются для отслеживания изменений в системе и, в редких случаях, отслеживают конфликт этих обновлений с прочими программами, установленными на компьютере.

Точки восстановления, созданные вручную

Пользователь имеет возможность вручную создавать собственные точки восстановления с помощью мастера восстановления системы. Созданная точка восстановления отображается на экране Выберите контрольную точку восстановления с присвоенным ей именем и соответствующими значениями даты и времени ее создания. Точки восстановления можно создавать при настройке удачной конфигурации компьютера или перед внесением изменений, например перед установкой на компьютер программ, которые могут повлиять на его работу.

Точки восстановления операции восстановления

Каждый раз при выполнении восстановления в конфигурацию компьютера вносятся изменения. Для отслеживания этих изменений и обеспечения возможности их отмены средство восстановления создает точки восстановления операции восстановления. Чтобы отменить восстановление, выберите соответствующую точку восстановления операции восстановления на экране Выберите контрольную точку восстановления мастера восстановления системы.

Точки восстановления неподписанных драйверов устройств

Обнаружив установку нового драйвера, который не подписан и не сертифицирован организацией Windows Hardware Quality Labs (WHQL), система восстановления сразу же создает точку восстановления. Если установка драйвера привела к нежелательным изменениям, можно на экране мастера восстановления системы Выберите контрольную точку восстановления выбрать такую точку восстановления, чтобы отменить эти изменения и вернуть компьютер к состоянию до установки драйвера.

Точки восстановления программы Microsoft Windows

При выполнении восстановления с использованием программы Backup, программа «Восстановление системы» создает точки восстановления до начала архивации. Если после операции восстановления компьютер перешел в неверное состояние, можно на экране Выберите контрольную точку восстановления выбрать такие контрольные точки и вернуть компьютер к состоянию до выполнения восстановления по архивной копии.

Примечания

  • Если выбранная точка восстановления была создана до установки программы, эта программа не будет работать после восстановления. При необходимости использовать данную программу установите ее заново.
  • Средство восстановления системы не заменяет процесс отмены установки программы. Для полного удаления файлов, установленных программой, необходимо удалить программу, используя компонент Установка и удаления программ на панели управления или используя собственную программу отмены установки. XOX
  • Программа «Восстановление системы» не отслеживает и не восстанавливает перенаправленные папки и любые настройки, связанные с перемещаемыми профилями пользователей.
  • Программа «Восстановление системы» выполняет наблюдение и восстановление только дисков и разделов, указанных в ее конфигурации. Она не влияет на диски и разделы, которые были перенаправлены или исключены из наблюдения.
  • При наличии зашифрованных файлов (таких, которые имеют расширение .exe или .dll) они никогда не будут расшифрованы. Чтобы удостовериться в этом, выключите программу «Восстановления системы» до начала шифрования файлов или папок, а затем запустите ее снова, после окончания. Или, если зашифрованные файлы уже существуют, включите и выключите систему восстановления. При выключении программы «Восстановление системы» все точки восстановления удаляются. Точки восстановления, созданные после повторного запуска «Восстановления системы», не содержат сведения о времени расшифрования файлов. Как правило, шифруются только файлы данных, которые не могут быть изменены программой «Восстановление системы».
  • Антивирусные служебные программы могут возвращать систему к предыдущему состоянию. Если точка восстановления содержит зараженный файл из-за того, что служебная программа не очистила этот файл в точке восстановления, или если зараженный файл был удален из точки из-за невозможности его очистки, восстановление системы не вернет компьютер в данное или зараженное состояние. Если восстановление системы возвращает компьютер в предыдущее состояние, но сохраняется возможность наличия в точке восстановления нескольких зараженных файлов или файлов, удаленных антивирусными службами, можно удалить все точки восстановления из архива восстановления системы, выключив и запустив ее повторно.

Дополнительные сведения о восстановлении системы см. в разделе Общие сведения о восстановлении системы. Дополнительные сведения о программе «Мастер восстановления системы» см. в разделе Использование мастера восстановления системы.

Дополнительные сведения о файловой системе см. в разделе Шифрование файловой системы.


Использование мастера восстановления системы

Мастер восстановления системы дает пошаговые инструкции для каждой задачи системы восстановления.

При запуске мастера для восстановления предыдущего состояния компьютера отображаются следующие экраны.

Экран приветствия средства «Восстановление системы»

На этом экране предлагается параметр для восстановления более раннего состояния компьютера.

Выберите контрольную точку восстановления

Этот экран позволяет выбрать в календаре дату, а затем выбрать точку для восстановления предыдущего состояния компьютера.

Подтверждение выбора точки восстановления

Этот экран дает возможность отказаться от операции, а также сохранить все файлы и закрыть программы перед запуском операции восстановления. После подтвеждения сделанного выбора начнется процесс восстановления, компьютер перезапустится и появится экран входа пользователя.

Восстановление завершено

Этот экран показывает, что восстановление было выполнено успешно. Если восстановление выполнить не удастся, будет выведено экран Восстановление не завершено и состояние компьютера не изменяется.

Дополнительные сведения о восстановлении системы см. в разделе Общие сведения о средстве «Восстановление системы».


Создать точку восстановления

Чтобы создать точку восстановления

  1. Получите доступ к мастеру восстановления системы через центр справки и поддержки.
  2. Выберите Создание точки восстановления и нажмите кнопкуДалее.
  3. В поле Описание точки восстановления введите имя этой точки. Мастер восстановления системы автоматически добавит к имени точки восстановления дату и время ее создания.
    • Для завершения создания данной точки восстановления нажмите кнопку Создать.
    • Для отмены создания точки восстановления и возврата на экран приветствия средства Восстановление системы нажмите кнопку Назад.
    • Для отмены создания точки восстановления и выхода из программы «Мастер восстановления системы» нажмите кнопку Отмена.

Примечания

  • XOX
  • Создание собственной точки восстановления может оказаться полезным при внесении изменений, которые могут привести к нестабильной работе компьютера.
  • Для просмотра или возврата к точке восстановления из окна Восстановление системы мастера восстановления системы выберите Восстановление более раннего состояния системы. Далее укажите дату создания точки восстановления в календаре из окна Выберите точку восстановления. Все точки восстановления соответствующей даты создания отображаются в поле со списком в алфавитном порядке справа от календаря.

См. также


Отмена последнего восстановления

Чтобы отменить последнее восстановление

  1. Получите доступ к средству Восстановление системы через центр справки и поддержки.
  2. Выберите Отменить последнее восстановление. Сохраните все файлы и программы и нажмите кнопку Далее.

Примечания

  • XOX
  • Если необходимо отменить последнее восстановление, установите переключатель в положение Восстановление более раннего состояния компьютера в окне Восстановление системы, а затем выберите подобную операцию восстановления контрольной точки, указанную в мастере восстановления системы.

См. также


Изменение параметров средства «Восстановление системы»

Чтобы изменить параметры средства «Восстановление системы»

Возможны следующие изменения параметров средства «Восстановления системы».

  • Исключение наблюдения и восстановления для несистемного диска
  • Возобновление наблюдения средства «Восстановление системы»
  • Выделение большего объема на диске для восстановления системы
  • Отключение средства «Восстановление системы»
  • Включение средства «Восстановление системы»

Примечания

  • Восстановление системы начинает работу при первом запуске нового компьютера или после завершения установки операционной системы, вне зависимости от наличия 200 Мбайт свободного пространства на жестком диске (или в разделе, где находится каталог Windows System).

    При отсутствии достаточного свободного места на диске при установке Windows можно включить восстановление системы (используя вышеописанные действия) после освобождения достаточного дискового пространства.

  • При отсутствии свободного места на диске программа восстановления системы становится неактивной. При выделении достаточного места на диске программа восстановления системы будет автоматически запущена, но все точки восстановления будут утеряны.

  • Когда программа «Восстановление системы» отключается для диска или раздела, все точки восстановления, сохраненные для этого диска или раздела, будут удалены. Изменения, выполненные для исключенного диска или раздела, не будут отменены при восстановлении системы.


Исключение диска или раздела, не являющегося системным

Чтобы исключить диск или раздел, не являющийся системным

  1. Откройте компонент Свойства системы.
  2. Убедитесь, что флажок Отключить восстановление системы на этом диске в состоянии отключен.
  3. В поле со списком Параметры диска выберите несисетемный диск, который необходимо исключить, и нажмите кнопку Настройки.
  4. Убедитесь, что флажок Отключить восстановление системы на этом диске снят. Невозможно выполнить это действие, если был выбран системный диск или раздел.

Примечания

  • XOX В диалоговом окне Свойства системы выберите команду Восстановление системы.
  • Можно исключить наблюдение и восстановление для несистемного диска или раздела. Изменения, выполненные для исключенного диска или раздела, не будут отменены при восстановлении системы.

См. также


Возобновление наблюдения средства «Восстановление системы»

Чтобы возобновить наблюдение средства «Восстановление системы»

  1. Откройте компонент Свойства системы.
  2. Убедитесь, что флажок Отключить восстановление системы на этом диске в состоянии отключен.
  3. В группе Параметры дисков выберите несистемный диск или раздел и нажмите кнопку Параметры.
  4. Убедитесь, что флажок Отключить восстановление системы на этом диске снят.

Примечание

  • XOX
    • В диалоговом окне Свойства системы выберите вкладку Восстановление системы.

См. также


Выделение большего места на диске для архивирования точек восстановления

Чтобы выделить больше места на диске для архивирования точек восстановления

  1. Откройте компонент Свойства системы.
  2. Выберите диск из поля Доступные диски и затем нажмите кнопку Настройка. Если имеется только один диск или раздел, этот шаг можно пропустить.
  3. В поле Параметры диска (<диск:>) переместите ползунок Зарезервировано на диске, чтобы изменить объем места на диске для восстановления системы. Следует отметить, что нельзя выделить более 12 процентов доступного места на диске.

Примечания

  • XOX В диалоговом окне Свойства системы выберите команду Восстановление системы.

  • Для восстановления системы нужно не меньше 200 Мбайт дискового пространства (или места в разделе, содержащем папку Windows System). Наилучшую производительность и надежность обеспечивает выделение максимально возможного объема.

  • При установке средства «Восстановление системы» для архивирования точек восстановления по умолчанию выделяется 12 процентов доступного пространства жесткого диска.

См. также


Отключение средства «Восстановление системы»

Чтобы отключить средство «Восстановление системы»

  1. Откройте компонент Свойства системы.
  2. Убедитесь, что флажок Отключить восстановление системы на этом диске установлен.

Примечания

  • XOX В диалоговом окне Свойства системы выберите команду Восстановление системы.
  • Если не удается отключить восстановление системы, это может означать, что администратор домена включил восстановление системы в групповую политику административной системы. Обратитесь к системному администратору.

См. также


Включение средства «Восстановление системы»

Чтобы включить средство «Восстановление системы»

  1. Откройте компонент Свойства системы.
  2. Убедитесь, что флажок Отключить восстановление системы на этом диске в состоянии отключен.

Примечание

  • XOX В диалоговом окне Свойства системы выберите команду Восстановление системы.

См. также


Запуск средства «Восстановление системы» в безопасном режиме

Чтобы запустить средство «Восстановление системы» в безопасном режиме

  1. Получите доступ к средству Восстановление системы через центр справки и поддержки.
  2. Следуйте инструкциям, появляющимся на экране.

Примечания

  • XOX
  • При загрузке в безопасном режиме средство «Восстановление системы» не создает точки восстановления. Таким образом, невозможно отменить восстановление, выполненное, когда компьютер был в безопасном режиме.
  • В безопасном режиме можно выполнить восстановление системы по любой точке восстановления. Если нет возможности запустить компьютер в стандартном режиме, можно использовать систему восстановления для возврата к моменту времени, когда при запуске компьютера возникали ошибки.
  • Чтобы восстановить состояние на время, когда компьютер запускался без ошибок, выберите точку восстановления, максимально близкую к времени запуска компьютера без ошибок.
  • Если средство «Восстановление системы» приостановлена из-за отсутствия свободного места на диске, то, находясь в безопасном режиме, невозможно включить ее, освободив дополнительное дисковое пространство. Необходимо перезапустить компьютер в стандартном режиме и освободить больше дискового пространства.

См. также


Доступ к средству «Восстановления системы»

Доступ к средству «Восстановление системы»

Чтобы запустить программу «Мастер восстановления системы» и изменить парамеры восстановления системы, необходимо быть членом группы администраторов.

Если при наличии прав администратора невозможно запустить программу «Мастер восстановления системы» или просмотреть Параметры восстановления системы, возможно, администратор домена выключил систему восстановления, используя групповую политику системы. Для получения дополнительных сведений обратитесь к системному администратору.

Существует три способа доступа к возможностям средства «Восстановление системы».

  • Запустить программу «Мастер восстановления системы» с помощью кнопки Пуск. XOX
  • Получить доступ к средству Восстановление системы через панель управления. XOX
  • Получить доступ к средству Восстановление системы через центр справки и поддержки. XOX

Дополнительные сведения о восстановлении системы см. в разделе Общие сведения о средстве «Восстановление системы».


Вопросы дискового пространства

Для запуска программы восстановления системы нужно не меньше 200 Мбайт дискового пространства (или места в разделе, содержащем папку Windows System). Если отсутствует достаточное свободное место на диске, то при установке операционной системы программа восстановления системы устанавливается, но не запускается. Если на диске нет как минимум 200 Мбайт свободного дискового пространства, то данную программу запустить невозможно.

Когда программе «Восстановление системы» не хватает места на диске, наблюдение за всеми дисками будет приостановлено. Для всех дисков будет отображено состояние Отключено в столбце Состояние в группе «Параметры дисков» в окне Свойства системы. При остановке работы системы восстановления невозможно запустить программу «Мастер восстановления системы». При попытке запуска мастера появится диалоговое окно с сообщением об остановке работы средства «Восстановление системы». Наблюдение автоматически будет возобновлено после выделения на диске минимального необходимого объема в 200 Мбайт.

Чтобы освободить дисковое пространство выполните следующие действия.

  • Запустите программу Очистка диска. Программа «Очистка диска» используется для удаления ненужных файлов.
  • Откройте компонент Установка и удаление программ. С его помощью можно удалить ненужные программы и компоненты операционной системы.

Примечания

  • XOX
  • XOX

Дополнительные сведения см. в разделе Чтобы изменить параметры системы восстановления.