Доступ к предыдущим версиям общих файлов и папок

Возможность «Предыдущие версии» предоставляет доступ к предыдущим версиям общих файлов и папок сети.

  • Сведения общего характера см. в разделе Общие сведения.
  • Справочные сведения по выполнению конкретных задач см. в разделе Инструкции.
  • Сведения об устранении неполадок см. в разделе Устранение неполадок.


Общие сведения о доступе к предыдущим версиям

При работе с файлами в общих папках в локальной сети возможен доступ к предыдущим версиям файлов. Доступ к предыдущим версиям дает следующие возможности.

  • Восстановление случайно удаленных файлов. Если файл был удален по ошибке, можно открыть его предыдущую версию и скопировать ее в безопасное расположение.
  • Восстановление случайно перезаписанного файла. Если файл был перезаписан по ошибке, можно восстановить его предыдущую версию.
  • Сравнение версий файлов при работе. Предыдущие версии позволяют отслеживать различия между двумя версиями файла.

Чтобы сделать возможным доступ к предыдущим версиям файлов, администратор сервера должен включить теневые копии общих папок на файловом сервере. Теневыми называются копии файлов, расположенные на сервере и отображаемые как предыдущие версии. Для включения теневых копий общих папок обратитесь к администратору.

Примечания

  • Чтобы был возможен доступ к предыдущим версиям файлов, общие файлы должны быть размещены на компьютере, работающем под управлением операционной системы из семейства Microsoft® Windows® Server 2003 с включенными теневыми копиями общих папок.
  • Предыдущие версии доступны только для чтения. Внести изменения в предыдущую версию файла невозможно, так как она находится на сервере.
  • Предыдущие версии периодически удаляются и могут исчезать в любое время. Если предыдущая версия файла может понадобиться, рекомендуется скопировать ее в надежное место.
  • Чтобы узнать, в какое время создаются и удаляются предыдущие версии, обратитесь к администратору сервера.

Дополнительные сведения см. в разделе Инструкции.


Инструкции

  • Просмотр предыдущей версии файла
  • Копирование предыдущей версии файла в новое расположение
  • Восстановление предыдущей версии файла
  • Восстановление случайно удаленного файла


Просмотр предыдущей версии файла

Рисунок Microsoft Windows

Чтобы просмотреть предыдущую версию файла

  1. Найдите файл, предыдущую версию которого следует просмотреть (в сети), щелкните его правой кнопкой мыши и выберите команду Свойства. Будет открыто диалоговое окно Свойства.
  2. На вкладке Предыдущие версии выберите версию, которую следует просмотреть, и нажмите кнопку Показать.

Примечания

  • Если вкладка Предыдущие версии не отображается в диалоговом окне Свойства, возможно, на файловом сервере не включены теневые копии общих папок. Теневыми называются копии файлов, расположенные на сервере и отображаемые как предыдущие версии. Для получения дополнительных сведений обратитесь к администратору.
  • Если список предыдущих версий пуст, то файл не изменялся с момента создания самой старой копии.
  • Предыдущие версии доступны только для чтения. Внести изменения в предыдущую версию файла невозможно, так как она находится на сервере.

См. также


Копирование предыдущей версии файла в новое расположение

Чтобы скопировать предыдущую версию файла в новое расположение

  1. Найдите файл, который следует скопировать (в сети), щелкните его правой кнопкой мыши и выберите команду Свойства. Будет открыто диалоговое окно Свойства.
  2. На вкладке Предыдущие версии выберите версию файла, которую следует скопировать, и нажмите кнопку Копировать.
  3. В диалоговом окне Копирование элементов выберите новое расположение для файла и нажмите кнопку Копировать.

Примечания

  • Если вкладка Предыдущие версии не отображается в диалоговом окне Свойства, возможно, на файловом сервере не включены теневые копии общих папок. Теневыми называются копии файлов, расположенные на сервере и отображаемые как предыдущие версии. Для получения дополнительных сведений обратитесь к администратору.
  • Если список предыдущих версий пуст, то файл не изменялся с момента создания самой старой копии.
  • При использовании команды Копировать для файла устанавливаются разрешения по умолчанию того каталога, в который помещается копия.

См. также


Восстановление предыдущей версии файла

Чтобы восстановить предыдущую версию файла

  1. Найдите файл, который следует восстановить (в сети), щелкните его правой кнопкой мыши и выберите команду Свойства. Будет открыто диалоговое окно Свойства.
  2. На вкладке Предыдущие версии выберите версию файла, которую следует восстановить, и нажмите кнопку Восстановить. Появится предупреждение о восстановлении предыдущей версии. Для завершения процедуры нажмите кнопку Да.

Внимание!

  • Восстановление предыдущей версии удалит текущую версию. Если восстанавливается предыдущая версия папки, папка будет возвращена к состоянию, соответствующему выбранной дате и времени. Все изменения, сделанные в файлах этой папки после указанного момента, будут утрачены. Если удаление текущей версии файла или папки нежелательно, воспользуйтесь командой Копировать, чтобы скопировать предыдущую версию в другое расположение.

Примечания

  • Если вкладка Предыдущие версии не отображается в диалоговом окне Свойства, возможно, для этого общего ресурса не включены теневые копии общих папок. Теневыми называются копии файлов, расположенные на сервере и отображаемые как предыдущие версии. Для получения дополнительных сведений обратитесь к администратору.
  • Если список предыдущих версий пуст, то файл не изменялся с момента создания самой старой копии.
  • При восстановлении предыдущей версии папки файлы в текущей папке, которые отсутствовали в предыдущей версии, не удаляются.
  • При восстановлении файла его разрешения не изменяются — они останутся такими же, как до восстановления. При копировании предыдущей версии файла для нее устанавливаются разрешения по умолчанию того каталога, в который помещается копия.
  • Восстановление большого каталога создает большую нагрузку на файловый сервер и может привести к удалению предыдущих версий. По возможности следует восстанавливать отдельные файлы, а не весь каталог.

См. также


Восстановление случайно удаленного файла

Чтобы восстановить случайно удаленный файл

  1. Найдите папку, в которой был сохранен удаленный файл (в сети), щелкните ее правой кнопкой мыши и выберите команду Свойства. Будет открыто диалоговое окно Свойства.
  2. На вкладке Предыдущие версии дважды щелкните последнюю версию папки, содержащей восстанавливаемый файл. Появится список файлов, сохраненных в этой предыдущей версии.
  3. Щелкните правой кнопкой мыши файл, который был случайно удален, и выберите команду Копировать.
  4. Щелкните правой кнопкой мыши расположение, в которое следует поместить файл, и выберите команду Вставить.

Примечания

  • Если вкладка Предыдущие версии не отображается в диалоговом окне Свойства, возможно, для этого общего ресурса не включены теневые копии общих папок. Теневыми называются копии файлов, расположенные на сервере и отображаемые как предыдущие версии. Для получения дополнительных сведений обратитесь к администратору.
  • При копировании файла для него устанавливаются разрешения по умолчанию того каталога, в который помещается копия.
  • При восстановлении случайно удаленного файла выполняется копирование предыдущей версии. Все изменения, сделанные в файле после создания последней из предыдущих версий, будут утрачены.
  • Чтобы восстановить удаленную папку, откройте предыдущие версии родительской папки и выберите папку для копирования.

См. также


Устранение неполадок

В данном разделе содержатся рекомендации по устранению неполадок при доступе к предыдущим версиям файлов и папок.

Вид неполадки

В диалоговом окне Свойства отсутствует вкладка Предыдущие версии.

Причина. На файловом сервере не включены теневые версии общих папок.

Решение. Обратитесь к системному администратору с просьбой включить теневые копии общих папок на файловом сервере.

В диалоговом окне Свойства на вкладке Предыдущие версии не указано ни одного файла.

Причина. Файл не был изменен.

Решение. Для просмотра предыдущих версий файл должен быть изменен.

В диалоговом окне Свойства на вкладке Предыдущие версии больше нет предыдущей версии файла, которую я хочу просмотреть.

Причина. Предыдущие версии периодически удаляются в связи с ограничениями сервера на дисковое пространство.

Решение. Обратитесь к системному администратору с просьбой предоставить дисковое пространство для увеличения числа предыдущих версий на файловом сервере.

При просмотре предыдущей версии файла возникают затруднения.

Причина. Предыдущие версии доступны только для чтения. Некоторые приложения могут некорректно работать с такими файлами.

Решение. Воспользуйтесь командой Копировать, чтобы скопировать файл в другое расположение и оттуда открыть его для просмотра.

Невозможно найти предыдущие версии файлов, сохраненных в общей папке моего коллеги.

Причина. Общая папка должна быть размещена на компьютере, работающем под управлением операционной системы из семейства Windows Server 2003, на котором включены теневые копии.

Решение. Переместите файлы, используемые совместно с коллегой, в общую папку на компьютере, работающем под управлением операционной системы из семейства Windows Server 2003, на котором включены теневые копии.