Обслуживание обозревателя Internet Explorer

В данном разделе содержатся сведения об администрировании Microsoft Internet Explorer на компьютерах, работающих под управлением Windows 2000 и Windows XP, а также основные понятия, относящиеся к обслуживанию обозревателя.

  • Управление обозревателем Microsoft Internet Explorer
  • Основные понятия Internet Explorer 6


Управление обозревателем Microsoft Internet Explorer

Оснастку «Групповая политика» можно использовать для управления обозревателем Microsoft Internet Explorer и его настройки на компьютерах с Windows 2000 и Windows XP. Например, можно задать домашнюю страницу пользователя и настроить ссылки на избранные страницы.

Дополнительные сведения содержатся в следующих разделах:

  • Использование оснастки «Групповая политика» для управления обозревателем Internet Explorer
  • Экспорт параметров Internet Explorer с помощью оснастки «Групповая политика»
  • Основные понятия Internet Explorer 6

Для настройки обозревателя Internet Explorer перед развертыванием, а также для управления им на других операционных системах используется Диспетчер профилей. Диспетчер профилей является частью пакета IEAK, входящего в состав пакетов ресурсов Windows 2000 и Windows XP, а также доступного на веб-узле Microsoft Windows.

Оснастка «Групповая политика» позволяет управлять следующими параметрами.

Интерфейс обозревателя

Настройка интерфейса и представления обозревателя.

  • Заголовок обозревателя
  • Анимированная эмблема Internet Explorer
  • Настройка эмблем

Настройки соединения

Предустановка пользовательских настроек соединения (таких как подключения с помощью удаленного доступа и по локальной сети) и управление ими.

  • Настройки соединения
  • Автоматическая настройка
  • Параметры прокси
  • Строка обозревателя

Пользовательские адреса URL

Задание адресов URL, которые появятся в обозревателе пользователя (таких как страница поиска, домашняя страница) и в списке «Избранное».

  • Избранное и ссылки
  • Важные URL-адреса

Безопасность

Предустановка пользовательских настроек безопасности (таких как зоны безопасности и оценка содержимого) и управление ими.

  • Зоны безопасности и оценка содержимого
  • Параметры Authenticode

Связывание приложений

Указание программ Интернета, по умолчанию используемых для выполнения стандартных процедур, таких как чтение электронной почты или просмотр групп новостей.

  • Программы


Автоматическая настройка

Имеется возможность назначить адреса URL для файлов, которые будут автомавтически выполнять настройку Internet Explorer. Это средство полезно, если требуется централизованно контролировать настройки нескольких пользователей.

Настройка параметров осуществляется с помощью файлов .ins, которые называют профилями IEAK. С помощью файлов .ins можно включить стандартные настройки прокси. Можно также указать файлы сценариев в формате .js, .jvs или .pac, которые позволяют задавать и управлять дополнительными настройками прокси.

Сетевые серверы, использующие систему доменных имен DNS и протокол DHCP, могут автоматически определять и задавать настройки обозревателя при первом запуске обозревателя в сети. Дополнительные сведения см. в разделе Автоматическое определение и задание параметров обозревателя.

Для автоматического определения настроек обозревателя установите флажок Автоматически определять настройки конфигурации.

Если задаются адреса URL и для автоматической конфигурации, и для автоматического определения прокси (авто-прокси), то авто-прокси URL будет включен в файл .ins. Правильным форматом адреса URL является http://общий_ресурс/тест.ins.

Разрешить автоматическую конфигурацию
Установите этот флажок для включения автоматической конфигурации и задания интервала обновления.
Автоматически настраивать каждые xx минут
Задает в минутах интервал для средства автоматической конфигурации. Если ввести нулевое значение или не вводить значение, то автоматическая конфигурация будет выполняться только при перезагрузке компьютера пользователя.
Автоматическая настройка адреса URL (INS-файл)
Введите в это поле адрес URL для файла .ins.
Авто-прокси URL (JS, JVS или PAC-файл)
Введите в это поле адрес URL для сценария авто-прокси.

Дополнительные сведения о файлах сценариев автоматической настройки содержатся в разделе Файлы примеров автоматической настройки прокси JavaScript или JScript.


Заголовок обозревателя

Можно изменить представление текста, отображающегося в заголовках обозревателя Internet Explorer и почтового клиента Outlook Express. Обновление заголовка почтового клиента Outlook Express происходит независимо от того, включен ли он в пакет или уже установлен на компьютеры пользователей. Введите текст, который должен отображаться в заголовке. Он будет отображаться после слов "Microsoft Internet Explorer, предоставленный" или "Outlook Express, предоставленный".

Примечание

  • При выборе точечного рисунка убедитесь, что его цвета контрастируют с текстом. Таким образом будет повышена удобочитаемость текста.

Настройка заголовков

  1. Установите флажок Изменить заголовки окон.
  2. Введите текст в поле Текст заголовка.


Настройка панели инструментов

Имеется возможность изменить панель инструментов, которая выводится в обозревателе пользователя. Это позволяет добиться большей гибкости в работе и расширить возможности разработки. Можно изменить фон панели инструментов и значки стандартных кнопок, таких как Поиск и Журнал.

Кроме того, можно изменить вид и количество дополнительных кнопок. Дополнительные средства, выводящие возможности изменения панели инструментов на новый уровень, позволяют указать сценарии или программы, запускаемые кнопками панели инструментов. Эти средства входят в специальный пакет разработчика. Дополнительные сведения о разработке пользовательских программ см. на веб-узле разработчика MSDN Online Web Workshop.

Фон
Если изменять фон рисунка панели инструментов не требуется, выберите параметр Использовать стандартный рисунок панели инструментов Windows. Для изменения фона панели инструментов выберите параметр Выбрать фоновый рисунок панели инструментов и укажите имя и расположение файла рисунка.
Кнопки
При работе с пользовательскими кнопками панели инструментов можно добавлять на кнопки собственные значки, связывать с каждой кнопкой файлы сценариев и исполняемые файлы, а также указывать расположение файлов значков панели инструментов. После добавления кнопок можно в любое время вернуться на страницу мастера настройки панели инструментов и изменить или удалить их.
Удалить существующие кнопки на панели, если они есть
Установите этот флажок, чтобы удалить в обозревателе пользователя все существующие кнопки панели инструментов за исключением стандартных кнопок, устанавливаемых с Internet Explorer. Этот параметр доступен только для администраторов организаций.

Примечания

  • Фоновый рисунок должен иметь размеры, соответствующие размерам панели инструментов, и быть достаточно светлым, чтобы отображался черный текст.
  • Если включаются темы Windows, пользовательский фон панели инструментов игнорируется. Чтобы применить пользовательский фон панели инструментов, следует выбрать классическую тему Windows.
  • Установка флажка Удалить существующие кнопки на панели, если они есть приводит к удалению только тех кнопок, которые были добавлены вручную. Стандартные кнопки, устанавливаемые с Internet Explorer, остаются на панели.

Как добавить пользовательскую кнопку панели инструментов

  1. Нажмите кнопку Добавить.
  2. В поле Заголовок панели управления (необходимо указать) введите текст, который будет появляться при наведении указателя на кнопку панели инструментов. Необходимо указать подпись или надпись на кнопке. Рекомендуется длина не более 10 знаков.
  3. В поле Действие панели управления (указать сценарий или исполняемый файл) введите имя файла сценария или исполняемого файла либо нажмите кнопку Обзор для поиска файла. Необходимо указать файл сценария или исполняемый файл, который будет запускаться при нажатии кнопки пользователем.
  4. В поле Цветной значок панели управления (необходимо указать) введите имя файла, представляющего кнопку в активном состоянии, или нажмите кнопку Обзор для поиска файла. Необходимо указать цветной значок кнопки, которая будет выводиться на панели инструментов. Значок содержит точечные рисунки 20х20 для активного и неактивного состояния. Дополнительные сведения см. на веб-узле MSDN Online Web Workshop.
  5. В поле Черно-белый значок панели управления (необходимо указать) введите имя и расположение полутонового файла значка для отображения панели инструментов на черно-белых мониторах или нажмите кнопку Обзор для поиска файла. Необходимо указать полутоновый значок кнопки, которая будет выводиться на панели инструментов.
  6. Установите флажок Эта кнопка должна присутствовать на панели инструментов по умолчанию для отображения кнопки по умолчанию на панели инструментов в обозревателе пользователей.

Примечания

  • При указании расположения рисунков, сценариев и приложений необходимо указывать адрес и имя файла.
  • Дополнительные сведения о влиянии настройки на конечный вид обозревателя см. в справке пакета администрирования Internet Explorer.

Как изменить пользовательскую кнопку панели инструментов

  1. В списке пользовательских кнопок панели инструментов выберите нужную кнопку. Нажмите кнопку Изменить.
  2. Измените информацию о кнопке.

Как удалить пользовательскую кнопку панели инструментов

  1. В списке пользовательских кнопок панели инструментов выберите нужную кнопку.
  2. Нажмите кнопку Удалить. Кнопка будет немедленно удалена из списка. Когда пользователи будут устанавливать настроенный пакет Internet Explorer, эта кнопка будет недоступна.


Настройки соединения

Вы можете задать настройки соединения для пользователей, импортировав эти настройки с вашего компьютера.

Чтобы просмотреть импортируемые настройки, в меню Сервис обозревателя выберите команду Свойства обозревателя и перейдите на вкладку Подключения. Нажмите кнопку Настройка для просмотра настроек удаленного доступа или кнопку Настройка LAN для просмотра сетевых настроек. Адреса для автоматической конфигурации не импортируются.

Не изменять настройки соединения
Выберите этот параметр, если не требуется предустанавливать пользовательские настройки.
Импортировать текущие настройки соединения
Выберите этот параметр, если требуется предустановить в качестве пользовательских настроек параметры, импортированные с вашего компьютера. Если требуется именить импортируемые настройки, нажмите кнопку Изменить настройки.
Удалить существующие настройки соединения
Если вы являетесь администратором организации, установите этот флажок для очистки существующих настроек на компьютерах ваших пользователей.

Примечание

  • Администраторы организации могут также использовать системные политики и ограничения, чтобы указать, могут ли пользователи изменять свои настройки подключения. Политики и ограничения можно задать на стадии 5 мастера настройки Internet Explorer 6 или с помощью автоматической конфигурации.


Избранное и ссылки

Папку «Избранное» на панели ссылок можно изменить, добавив в нее ссылки на узлы, относящиеся к вашим компании или службам. Например, если ваша компания является поставщиком усгул Интернета, специализирующимся на развлечениях, можно добавить ссылки на развлекательные узлы.

Панель ссылок по умолчанию появляется в верхней части экрана пользователя и содержит исходный набор ссылок. Можно добавить ссылки в папки, используемые по умолчанию, или создать новые папки. По нажатии пользователем кнопки Избранное в левой части окна появляется список избранных ссылок.

Расположить избранное и ссылки во главе списка в указанном ниже порядке
Установите этот флажок, чтобы поместить папку «Избранное» и некоторые ссылки в начало пользовательского списка «Избранное». Это позволит быстро находить их. При установке этого флажка становятся доступными кнопки Вверх и Вниз.
Удалить существующее избранное и ссылки , если они есть
Корпоративные администраторы могут устанавливать этот флажок для удаления элементов из пользовательских списков ссылок и папок «Избранное». Этот параметр рекомендуется использовать с осторожностью, поскольку он удаляет добавленные пользователями ссылки и элементы папки «Избранное».
Удалить только созданное администратором избранное
Корпоративные администраторы могут устанавливать этот флажок для удаления собственных элементов из пользовательских списков ссылок и папок «Избранное».
Удалить существующие каналы, если они есть
Установив этот флажок, корпоративные администраторы могут удалять имеющиеся каналы с компьютеров пользователей.

Примечания

  • Чтобы проверить ссылку в списке, выберите эту ссылку и нажмите кнопку Проверить URL.
  • В папку «Избранное» можно добавить до 200 ссылок.
  • Чтобы удалить элемент из папки «Избранное» или с панели ссылок, выберите этот элемент и нажмите кнопку Удалить.
  • Наглядную демонстрацию добавленных ссылок в настроенном обозревателе см. в справке пакета администрирования Internet Explorer.

Как вручную добавить папку в список «Избранное» или на панель ссылок

  1. Выберите Избранное, Ссылки или папку в списке Избранное или Ссылки, а затем нажмите кнопку Добавить папку.
  2. В поле Имя введите имя папки. Имя должно быть понятным и явно описывающим содержимое папки.

Как импортировать папку со ссылками с локального компьютера в список «Избранное» или на панель ссылок

  1. Щелкните заголовок Избранное или Ссылки, а затем нажмите кнопку Импорт.
  2. В диалоговом окне Обзор папок найдите и щелкните папку с соответствующими ссылками на локальном компьютере. Чаще всего эти ссылки расположены в папке «\Windows\Favorites».

Как добавить веб-страницу в список «Избранное» или на панель ссылок

  1. Щелкните Избранное, Ссылки или папку в списке Избранное или Ссылки, а затем нажмите кнопку Добавить URL.
  2. В диалоговом окне Состав введите в поле Имя краткое описание этой веб-страницы. Оно должно быть понятным и явно описывающим ссылку.
  3. В поле URL-адрес введите адрес ссылки.
  4. Чтобы задать для этой ссылки специальный значок размером 16x16 пикселов, введите имя соответствующего BMP-файла в поле Значок или нажмите кнопку Обзор, чтобы найти его.
  5. Корпоративные администраторы могут сделать эту страницу доступной для пользователей, даже если они не подключены к Интернету, установив флажок Сделать доступной автономно. Этот параметр может быть полезным для пользователей портативных компьютеров.
  6. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Состав.


Важные URL-адреса

Возможно задание URL-адресов для домашней страницы, страницы поиска и страницы интерактивной поддержки.

URL-адрес домашней страницы
Домашняя страница, иногда называемая начальной страницей, открывается по нажатии кнопки Домой. В Internet Explorer по умолчанию открывается заранее заданная домашняя страница, но ее всегда можно сменить.

Если требуется задать другую домашнюю страницу, установите флажок Изменить. Введите в поле URL-адрес домашней страницы требуемый URL-адрес домашней страницы.

URL-адрес панели поиска
Панель поиска расположена возле левого края экрана. Панель поиска позволяет пользователям одновременно видеть и запрос, и результаты поиска. На ней также можно выбрать механизм поиска. Если требуется задать другой URL-адрес панели поиска, установите флажок Изменить. Затем введите в поле URL-адрес панели поиска требуемый URL-адрес.
URL-адрес страницы поддержки
В Internet Explorer сведения о поддержке отображаются при выборе в меню Справка команды Техническая поддержка. Рекомендуется создать соответствующую страницу поддержки и сделать ее доступной для пользователей.

Если требуется задать другую страницу поддержки, установите флажок Изменить. Затем введите в поле URL-адрес страницы поддержки URL-адрес страницы поддержки.


Пользовательские эмблемы и живые картинки

Эмблема Internet Explorer в правом верхнем углу окна обозревателя может отображаться в двух состояниях: в виде статической картинки, когда не выполняется никакое действие, и в виде «живой» картинки (анимации), когда работает обозреватель. Имеется возможность заменить точечные рисунки эмблемы на собственные анимированные или статические рисунки.

Настройка статической эмблемы

Если используется статический рисунок, он отображается и при выполнении, и при отсутствии действий обозревателя.

Для использования собственной статической эмблемы необходимо предварительно создать два точечных рисунка. Один должен иметь размеры 22х22 пикселей, а другой 38х38 пикселей. Затем укажите пути к файлам рисунков эмблем в полях Путь к файлу "живой" картинки маленького размера (22x22) и Путь к файлу "живой" картинки большого размера (38x38).

Настройка живой эмблемы

Если используются анимированные рисунки, то первый кадр отображается как статический рисунок, когда обозреватель не выполняет никакие действия. Остальные кадры образуют анимацию, когда используется обозреватель.

Для использования собственной живой эмблемы необходимо предварительно создать два анимированных рисунка. Один должен иметь размеры 22х22 пикселей, а другой 38х38 пикселей. Затем укажите пути к файлам рисунков эмблем в полях Путь к файлу "живой" картинки маленького размера (22x22) и Путь к файлу "живой" картинки большого размера (38x38).

Примеры анимированных рисунков можно найти в папке \<программная папка IEAK>\Toolkit\ пакета IEAK Toolkit.

Примечания

  • В IEAK включены две средства, помогающие создавать пользовательские анимации для обозревателя. Первое средство используется для создания последовательности кадров в описанных выше форматах, а второе для просмотра анимации.
  • Дополнительные сведения о влиянии настройки на конечный вид обозревателя см. в справке пакета администрирования Internet Explorer.


Программы

Параметры программ включают параметры, задающие программы для использования по умолчанию. При настройке большого количества программ импорт файлов с рабочего компьютера может сэкономить время и сделать параметры разных пользователей одинаковыми.

Не настраивать параметры программ
Отмена настройки параметров программ пользователей. Эти параметры включают используемые по умолчанию приложение электронной почты и HTML-редактор.
Импортировать текущие параметры программ
Копирование параметров программ с рабочего компьютера на компьютеры пользователей. Чтобы изменить импортируемые параметры, выберите вариант Импортировать текущие параметры программ и нажмите кнопку Изменить параметры.


Параметры прокси

Соответствующее окно служит для задания прокси-серверов, к которым подключаются пользователи.

Разрешить настройку прокси-сервера
Установите этот флажок, чтобы использовать прокси-серверы для всех перечисленных служб.
Адрес прокси-сервера
Адрес прокси-сервера, используемого службой.
Порт
Номер порта. В большинстве случаев используется порт 80.
Использовать один прокси-сервер для всех адресов
Установите этот флажок, чтобы использовать одинаковые параметры для всех служб.
Не использовать прокси-сервер для адресов, начинающихся с
В некоторых случаях, например в корпоративной интрасети, прокси-сервер использовать не требуется. Это поле служит для задания соответствующих адресов. Для разделения адресов используйте точку с запятой.
Не использовать прокси-сервер для локальных (внутрисетевых) адресов.
Установите этот флажок, чтобы не использовать прокси-серверы для всех адресов в интрасети.


Безопасность

Для лучшего обеспечения безопасности служат центры сертификации и Authenticode.

Центры сертификации служат для управления узлами, где пользователи могут загружать определенные компоненты, такие как элементы ActiveX и приложения Java. Сертификат узла является формой цифрового сертификата для узла интрасети. Основанный на технологии Authenticode, он показывает источник получения программ и проверяет их сохранность.

Не настраивать центры сертификации
Установите этот флажок, если настройка центров сертификации не требуется. Это не отменяет настройку безопасности Authenticode.

Параметры центров сертификации можно импортировать с локального компьютера. Если требуется изменить параметры, применяемые к компьютерам пользователей, выберите вариант Импортировать текущие центры сертификации, а затем нажмите кнопку Изменить параметры.

Затем для управления параметрами центров сертификации можно будет воспользоваться диспетчером сертификатов. Сертификаты применяются для проверки подлинности сетевых серверов, сетевых клиентов, безопасной электронной почты и опубликованных программ.

Не настраивать безопасность Authenticode
Установите этот флажок, если настройка безопасности Authenticode не требуется.

Authenticode позволяет указать, какие издатели программного обеспечения и центры сертификации заслуживают доверия. Эти параметры можно импортировать с локального компьютера. Если требуется изменить параметры, применяемые к компьютерам пользователей, выберите вариант Импортировать текущие сведения о безопасности Authenticode, а затем нажмите кнопку Изменить параметры.


Зоны безопасности и оценка содержимого

Зоны безопасности и оценка содержимого Internet Explorer служат для предотвращения просмотра пользователями страниц с неприятным содержимым. Оценка содержимого позволяет Internet Explorer контролировать содержание материалов, доступных для данного компьютера из Интернета. Изменять оценки содержимого для выбора приемлемого содержимого можно в четырех областях: обнажение тела, ненормативная лексика, насилие, секс.

Не настраивать зоны безопасности
Отмена настройки параметров каждой зоны безопасности.
Импортировать текущие параметры зон безопасности
Если требуется импортировать эти параметры с локального компьютера, выберите вариант Импортировать текущие параметры зон безопасности. Чтобы изменить импортируемые параметры, нажмите кнопку Изменить параметры. Системные политики и ограничения также позволяют задать, какие пользователи могут самостоятельно изменять собственные параметры безопасности.
Не настраивать оценку содержимого
Отмена настройки оценки содержимого в четырех областях: обнажение тела, ненормативная лексика, насилие, секс.
Импортировать текущие параметры оценки содержимого
Если требуется импортировать эти параметры с локального компьютера, выберите вариант Импортировать текущие параметры оценки содержимого. Чтобы изменить импортируемые параметры, нажмите кнопку Изменить параметры. Затем эти параметры можно будет изменить с помощью ограничения доступа.

Примечания

  • При ограничении доступа по умолчанию используются очень строгие ограничения. Эти настройки можно изменять в соответствии с определенными требованиями.
  • Не все содержимое в Интернете имеет оценки. Если вы выберете в настройках возможность просмотра узлов, не имеющих оценки, учтите, что некоторые из этих узлов могут содержать нежелательные для просмотра материалы.


Строка обозревателя

В некоторых компаниях отслеживается статистика посещения узлов, такая как количество просмотров веб-страниц и использовавшиеся для этого веб-обозреватели. Это осуществляется с использованием строки обозревателя, предоставляющей веб-серверу сведения о веб-обозревателях пользователей. В групповой политике можно задать часть этой строки обозревателя.

Строка, которая присоединяется к строке агента пользователя
Строка, введенная в это поле, добавляется к строке используемого обозревателя. Строку обозревателя не следует изменять, если только не требуется отслеживать использование настроенного обозревателя путем сбора статистики обозревателей с других веб-узлов. Имейте в виду, что компании, собирающие статистику с узлов, будут видеть эту строку.

Чтобы изменить строку обозревателя, можно добавить к ней какой-либо текст.

Новая строка будет отображаться в любой статистике, включающей строку обозревателя. Имейте в виду, что компании, собирающие статистику, будут видеть эту строку. Не добавляйте в строку обозревателя текст, имеющий конфиденциальный характер.

Пример строки обозревателя:

Mozilla/4.0(compatible; MSIE 5.0; Windows NT; ДобавленныйТекст)


Основные понятия Internet Explorer 6

В следующих разделах содержатся сведения об управлении обозревателем Internet Explorer, запущенным в операционной системе Windows 2000 и Windows XP.

  • Автоматическое определение настроек обозревателя
  • Настройка помощника по поиску
  • Разработка значков панели инструментов Internet Explorer 6
  • Безопасность Internet Explorer 6


Автоматическое определение настроек обозревателя

С помощью автоматического определения обозреватель может быть настроен при запуске, даже если до этого настройка не производилась. Например, если вместо установки настроенной версии обозревателя с корпоративного сервера, произведена загрузка ненастроенного обозревателя из Интернета, автоматическое определение может настроить обозреватель при запуске.

Автоматическое определение параметров обозревателя, основанное на автоматическом определении прокси (WPAD), поддерживается протоколом DHCP и DNS. Настроенные соответствующим образом серверы DHCP и DNS могут автоматически определять и настраивать параметры обозревателя.

Эта возможность основана на технологиях автоматической настройки, которые позволяют производить настройку обозревателя с помощью файла автоматической настройки (INS-файл) или файла настройки прокси Javascript (JS, JVS или PAC).

Включение автоматической настройки обозревателя

  1. Запустите оснастку «Групповая политика».
  2. Дважды щелкните элемент Подключение.
  3. Дважды щелкните элемент Автоматическая настройка обозревателя.
  4. Введите необходимые данные и нажмите кнопку ОК.
Автоматическое определение настроек
Установите данный флажок чтобы определить, отличаются ли настройки пользователя от установленных настроек.
Разрешить автоматическую настройку
Установите данный флажок для поддержки настроек обозревателя после запуска.
Automatically configure every xx minutes
Укажите, через сколько минут будет производиться обновление. Чтобы обновление производилось при каждом запуске Internet Explorer, не заполняйте данное поле.
URL автонастройки (INS-файл)
Введите путь к файлу .Ins, содержащему настройки обозревателя. Правильным форматом является http://общий_ресурс/тест.ins.
URL авто-прокси (JS, JVS или PAC-файл)
В данном поле укажите путь к файлу сценария автоматической настройки. Дополнительные сведения о файлах сценариев автоматической настройки содержатся в разделе Файлы примеров автоматической настройки прокси JavaScript или JScript.

Автоматическое определение настроек обозревателя для DHCP и DNS

Сервер DHCP позволяет администратору централизованно задавать глобальные и определенные для подсети параметры TCP/IP, а также параметры для клиентов с помощью зарезервированных адресов. При перемещении клиентского компьютера между подсетями изменение его настроек для TCP/IP происходит автоматически при запуске.

DNS является набором протоколов и служб в сети TCP/IP, позволяющим пользователям производить поиск других компьютеров, используя вместо числовых IP-адресов дружественные иерархические имена, называемые «узлами».

DHCP с автоматическим определением целесообразно использовать для клиентов локальных вычислительных сетей, в то время как DNS позволяет пользователям локальных вычислительных сетей и удаленного доступа определять их настройки. Хотя DNS может оперировать пользователями сети и удаленного доступа, DHCP предоставляет пользователям ЛВС более быстрый доступ и большую гибкость при определении конфигурационных файлов.

Для включения автоматического определения настроек обозревателя необходимо настроить определенные параметры DNS серверов и DHCP серверов.

Включение автоматического определения настроек обозревателя на DHCP

Для установки автоматического определения настроек обозревателя на сервере DHCP, необходимо создать новый тип параметра с кодовым номером 252.

Следующая процедура демонстрирует возможности использования Диспетчера DHCP, запущенного под Windows NT 4.0, для создания нового глобального или применимого к определенной области параметра DHCP. Если Диспетчер DHCP не установлен, обратитесь к документации Microsoft NT 4.0 для получения сведений о его установке.

Добавление нового типа параметра DHCP

  1. Выберите команду Умолчания в меню Параметры.
  2. В списке «Класс параметра» выделите класс, для которого требуется добавить новый тип параметра, а затем нажмите кнопку Создать.
  3. В поле Имя введите имя нового параметра.
  4. В списке Тип данных выберите элемент Строка.
  5. Для используемого по умолчанию значения строки введите URL-адрес файла настройки. Этот файл настройки может иметь расширение .pac, .jvs, .js или .ins.

    Примеры:

    • http://www.fabrikam.com/webproxy.pac
    • http://marketing/config.ins
    • http://###.#.###.#/account.pac
  6. В поле Идентификатор введите кодовый номер 252 чтобы связать его с этим типом параметра.
  7. В поле Комментарий введите описание.

Включение автоматического определения на DNS

Для включения автоматического определения настроек обозревателя на DNS, необходимо настроить главную запись либо запись CNAME в файле базы данных DNS.

Главная запись

Главная запись используется для статического связывания имен узлов (компьютеров) с IP-адресами в зоне. Главная запись содержит данные для всех узлов, требующих статического распределения, таких как рабочие станции, серверы и почтовые серверы.

Используется следующий синтаксис: <имя узла> IN A <ip-адрес узла>

Например:

Имя узла |  |  | Адрес узла
corserv | IN | A | 192.55.200.143
nameserver2 | IN | A | 192.55.200.2
mailserver1 | IN | A | 192.55.200.51

Запись CNAME

Данные записи также называются псевдонимами, но технически называются именами в "каноническом формате" (CNAME). Эти записи позволяют использовать несколько имен для указания одного узла. Использование имен в каноническом формате облегчает выполнение такой задачи, как создание и использование сервера FTP и веб-сервера на одном компьютере.

Настройка файла базы данных DNS для автоматического определения настроек обозревателя

  • В файл базы данных DNS введите главную запись wpad, указывающую на IP-адрес веб-сервера, содержащего файлы автоматической настройки с расширениями .pac, .jvs, .js или .ins.

    Или, введите псевдоним CNAME, который называется wpad, указывающий на имя (разрешенное имя, а не IP-адрес) сервера, содержащего файлы автоматической настройки с расширениями .pac, .jvs, .js или .ins.

Примечания

  • После добавления записи и помещения файла базы данных на сервер, имя DNS wpad.домен.com должно стать идентичным имени сервера, содержащего файл автоматической настройки.

  • При использовании DNS, Internet Explorer создает используемый по умолчанию шаблон URL, основанный на имени узла wpad. Например, http://wpad.domain.com/wpad.dat.

    Следовательно, на веб-сервере wpad необходимо установить файл или пункт перенаправления, который называется wpad.dat, доставляющий содержимое файла автоматической настройки.


Настройка помощника по поиску

Помощник по поиску Microsoft Windows позволяет пользователям выполнять различные типы поиска унифицированным методом. Помощник по поиску представляет собой контекстный инструмент поиска, позволяющий указать тип искомых сведений, вместо использования определенной поисковой системы. Помощник по поиску открывается на панели поиска в левой части обозревателя при нажатии кнопки Поиск.

Можно изменить панель поиска в соответствии с предъявляемыми требованиями. Для этого, определите адрес URL для панели поиска в разделе Internet Explorer оснастки «Групповая политика».

Панель поиска можно настроить, используя функциональные возможности, доступные в обозревателе Internet Explorer. Данные возможности включают язык JScript (совместимый со спецификацией ECMA 262), Visual Basic Scripting Edition (VBScript), элементы управления ActiveX , динамический HTML, наборы рамок, каскадные таблицы стилей (CSS) и так далее.

Результаты поиска отображаются в панели поиска. Возможность с легкостью пользоваться результатами поиска, выполненного любыми службами поиска, имеет первостепенную важность для пользователей. Функциональные возможности панели поиска можно использовать для загрузки подробных сведений, таких как аннотации к тексту, адреса URL или размер файла. Такие сведения содержатся во всплывающих подсказках, появляющихся при наведении указателя мыши на результаты поиска. Это позволяет наглядно отображать результаты поиска и при необходимости предоставлять более подробные сведения.

Далее в данном разделе приведены сведения о настройке помощника по поиску. Дополнительные сведения о сценариях и динамическом HTML содержатся на веб-узле MSDN Online.

Технология настройки помощника по поиску

Помощник по поиску можно настроить в соответствии с определенными требованиями. Например, дополнительные сведения о результатах поиска могут храниться во всплывающих подсказках, а результаты поиска могут отображаться на определенной веб-странице.

Выделение результатов поиска

Internet Explorer 6 облегчает создание настраиваемых руководств по поиску слов и предложений на веб-страницах. Новый метод NavigateAndFind позволяет загружать определенные веб-страницы и выполнять поиск соответствующих строк в документе. Если текст содержит соответствующую строку, она выделяется.

В приведенном ниже примере производится поиск слов "Corporation Microsoft" на веб-узле Microsoft.

window.external.NavigateAndFind("http://www.microsoft.com","Microsoft Corporation");

Всплывающие подсказки/аннотации

Для более эффективного использования пространства окна обозревателя, а также для повышения удобочитаемости результатов поиска, Internet Explorer позволяет включать определенные сведения о ссылках во всплывающие подсказки. Для этого необходимо определить атрибут TITLE= для тега.

В приведенном ниже примере ссылка содержит дополнительные сведения.

<A HREF="http://www.alpineskihouse.com/" TITLE="Последние новости о спорте и результаты соревнований, обновление производится каждый час. Интервью с победителями соревнований"> alpineskihouse - Последние новости о спорте</A>

Наведите указатель мыши на данную ссылку чтобы просмотреть, как должен выглядеть результат. Последние новости о спорте

Новые строки во всплывающих подсказках

Во всплывающей подсказке строки длиной более трех дюймов автоматически разбиваются. Всплывающая подсказка должна содержать один абзац текста, однако он может состоять не более чем из 1024 символов. Можно начать новую строку или расставить позиции табуляции, используя зарезервированные символы &#10 и &#13 для возврата каретки и перевода строки, а символ &#09 для расстановки позиций табуляции.

В приведенном ниже примере используется возврат каретки и перевод строки после строки 1 всплывающей подсказки:

<A HREF="http://www.microsoft.com" TITLE="Текст, отображаемый в строке1&#10;&#13; Текст, отображаемый в строке2&#10; &#09;Текст, отображаемый в строке3&#10; &#09;Текст, отображаемый в строке4"> Использование нескольких строк во всплывающих подсказках</A>

Наведите указатель мыши на данную ссылку чтобы просмотреть, как должен выглядеть результат. Использование нескольких строк во всплывающих подсказках


Разработка значков панели инструментов Internet Explorer 6

Для создания значка панели инструментов необходимо создать два варианта изображения разных размеров для двух состояний панели инструментов (черно-белый для неактивного состояния, в котором значок находится по умолчанию, и цветной для активного состояния, когда на значок наведен указатель мыши), с различной глубиной цвета. Ниже приведен список необходимых изображений.

  • Одно цветное изображение размером 20 на 20 точек (в 256-цветной палитре полутонов Windows)
  • Одно черно-белое изображение размером 20 на 20 точек (в 256-цветной палитре полутонов Windows)
  • Одно цветное изображение размером 20 на 20 точек (в 16-цветной палитре полутонов Windows)
  • Одно черно-белое изображение размером 20 на 20 точек (в 16-цветной палитре полутонов Windows)
  • Одно цветное изображение размером 16 на 16 точек (в 16-цветной палитре полутонов Windows)
  • Одно черно-белое изображение размером 16 на 16 точек (в 16-цветной палитре полутонов Windows)

Эти изображения должны быть похожи на приведенные ниже.

Изображения, необходимые для значков

Разработка значков панели инструментов

Ниже дано несколько советов, которые необходимо иметь ввиду при разработке значков панели инструментов.

  • Убедитесь, что визуальные переходы от неактивных изображений к активным происходят плавно. Для этого можно создать отдельные слои для неактивных и активных изображений в программе для работы с изображениями, а затем просмотреть изображения, наложив их друг на друга.
  • При создании 16-цветных значков следует использовать 16-цветную палитру Windows. Активное и неактивное изображения значка должны быть окружены черной границей. Исключением являются случаи, в которых черная граница может ухудшить удобочитаемость изображения, например, в значке стрелки или значке "X". Кроме того, изображения должны быть немного затенены.
  • При создании 256-цветных значков следует использовать палитру полутонов Windows. Как в неактивном, так и в активном состоянии значки должны иметь границы с серыми или цветными верхней и левой сторонами, а также черными нижней и правой сторонами. При создании значков можно использовать более 16 цветов, при этом источник света должен располагаться вверху слева, в соответствии с чем накладывается затенение.

Создание файлов с расширением .ico

Необходимо создать два файла .ico для одного значка.

  • Первый файл .ico содержит активные (цветные) изображения двух размеров с различной глубиной цвета.
  • Второй файл .ico содержит неактивные (черно-белые) изображения двух размеров с различной глубиной цвета.

Для создания значков следует использовать графическую программу, а для создания файлов .ico служит специальная среда разработки, например Microsoft Visual C++ Development Studio.

Два файла значков должны содержать следующую графику.

Создание изображений

  1. После создания изображений в графической программе поместите 16-цветное и 256-цветное изображения в отдельные файлы.
  2. Сопоставьте каждый файл с соответствующей палитрой, либо с 16-цветной палитрой или палитрой полутонов Windows.
  3. Сохраните каждый файл как точечное изображение (файл .bmp).

Создание файлов значков в Visual C++

  1. Откройте файл .bmp
  2. В меню File выберите команду New а затем команду Icon. По умолчанию на экране появится окно значка с изображением устройства размером 32 на 32 точки.
  3. В окне значка нажмите кнопку New Device Image. Нажмите кнопку Custom, а затем создайте данные изображения:
    • одно 16-цветное изображение размером 22 на 20 точек;
    • одно 256-цветное изображение размером 22 на 20 точек;
    • одно 16-цветное изображение размером 18 на 16 точек;

    Следует иметь в виду, что изображения устройства на две точки шире изображений, отражающих фактическую ширину кнопки. Расположите изображения по центру области изображения устройства.

  4. Удалите стандартное изображение устройства размером 32 на 32 точки.
  5. Скопируйте и вставьте цветные изображения из bmp-файлов в изображение устройства подходящего размера и соответствующей глубины цвета.
  6. Чтобы сделать фон прозрачным, выберите прозрачный цвет в палитре и залейте им фон изображения.
  7. Сохраните файл с расширением .ico.
  8. Чтобы создать неактивный (черно-белый) ico-файл, выполните те же действия.


Безопасность Internet Explorer 6

Internet Explorer 6 можно использовать для управления безопасностью издателей Authenticode и зон безопасности. Кроме того, можно установить оценку содержимого просматриваемых страниц.

О зонах безопасности

Параметры безопасности Internet Explorer 6 позволяют добавлять определенные веб-узлы в различные зоны безопасности в зависимости от их содержимого.

При установке Internet Explorer 6 устанавливаются следующие зоны безопасности:

  • зона «Интернет», по умолчанию содержащая все узлы Интернета;
  • зона «Местная интрасеть», содержащая веб-узлы, расположенные в интрасети;
  • зона «Надежные узлы», содержащая доверенные веб-узлы;
  • зона «Ограниченные узлы», содержащая веб-узлы, которые могут причинить вред компьютеру или данным;
  • зона «Мой компьютер», содержащая файлы, расположенные на локальном компьютере.

Примечание

  • Зону «Мой компьютер» можно настроить только с помощью оснастки «Групповая политика» или пакета IEAK, сделать это с помощью обозревателя невозможно. В большинстве случаев, если не требуется использовать особые параметры, рекомендуется сохранять уровень безопасности, установленный по умолчанию. Использование низкого уровня безопасности ставит под угрозу безопасность, в то время как использование высокого уровня безопасности снижает функциональность.

Стандартные настройки

Для этих зон могут быть установлены четыре стандартных уровня безопасности: Высокий, Средний, Ниже среднего и Низкий. Кроме того, для каждой зоны можно установить собственный уровень безопасности.

Чтобы просмотреть настройки безопасности, в панели управления откройте значок Свойства обозревателя, а затем выберите вкладку Безопасность.

Следует помнить, что безопасность работы в Интернете напрямую зависит от настроек безопасности обозревателя. Internet Explorer 6 предоставляет сведения и гибкие инструментальные средства, необходимые для установки подходящего уровня безопасности.

Можно не только настроить параметры безопасность, но и запретить пользователям самостоятельно изменять их. Если параметры безопасности не устанавливаются администратором сети, пользователи могут сделать это самостоятельно в соответствии с собственными требованиями.

Настройка зоны «Интернет»

Зона «Интернет» содержит все узлы, не помещенные в другие зоны. По умолчанию для этой зоны устанавливается Средний уровень безопасности. Если требуется повысить безопасность работы в Интернете, установите более высокий уровень безопасности. При установке более высокого уровня безопасности некоторые веб-узлы не смогут выполнять определенные потенциально опасные операции, что может привести к снижению функциональности и неправильному отображению некоторых страниц.

Если требуется, можно установить собственные параметры безопасности для зоны. Для этого, в панели управления откройте значок Свойства обозревателя, выберите вкладку Безопасность, а затем нажмите кнопку Другой.

Добавление узлов в зоны «Надежные узлы» и «Ограниченные узлы»

В эти две зоны можно добавлять веб-узлы, параметры безопасности для которых отличаются от параметров безопасности, установленных для зон «Интернет» и «Местная интрасеть». Чтобы добавить веб-узел в зону выделите ее и нажмите кнопку Узлы.

По умолчанию для зоны «Надежные узлы» установлен Низкий уровень безопасности. Эта зона предназначена для надежных узлов, таких как веб-узлы компаний-партнеров, также известные как "экстрасеть". При добавлении узла в зону «Надежные узлы» будет без предупреждения запускаться все его активное содержимое. Кроме того, Internet Explorer потребует подтверждения операции. В данную зону можно добавлять только веб-узлы с проверенным содержимым, которые не причинят вреда компьютеру. Для веб-узлов зоны «Надежные узлы» рекомендуется использовать протокол HTTPS: или иные средства, позволяющие устанавливать безопасное соединение.

По умолчанию для зоны «Ограниченные узлы» установлен Высокий уровень безопасности. При добавлении узла в зону «Ограниченные узлы» будут отключены все его небезопасные функции. Эта зона предназначена для узлов, которым нельзя доверять. При отключении небезопасных функций многие страницы могут отображаться неправильно.

Настройка зоны «Местная интрасеть» (для сетевых администраторов)

Для обеспечения безопасности зона «Местная интрасеть» должна быть установлена вместе с прокси-сервером и брандмауэром. Все узлы этой зоны должны находиться в брандмауэре, а прокси-серверы необходимо настроить таким образом, чтобы запретить внешним именам DNS доступ в данную зону. Настройка безопасности данной зоны требует хорошего знания конфигурации конкретной сети, прокси-серверов и брандмауэров. В противном случае следует обратиться к администратору сети.

По умолчанию зона «Местная интрасеть» состоит из локальных имен доменов и узлов, установленных на вкладке Подключение. Эти параметры можно изменить на экране Параметры подключения. Следует иметь в виду, что теперь для каждого пользователя можно настроить несколько параметров подключения. Администратор сети должен подтвердить, что эти настройки безопасны для установки или скорректировать их соответствующим образом.

При настройке зоны можно указать, какие категории адресов URL должны рассматриваться. В зону можно добавлять определенные узлы.

Помещение в зону определенных категорий адресов URL.

  1. В обозревателе Internet Explorer в меню Сервис выберите команду Свойства обозревателя и перейдите на вкладку Безопасность.
  2. Выберите зону Местная интрасеть и нажмите кнопку Узлы.
  3. Установите следующие флажки:

    Все узлы интрасети, не перечисленные в других зонах
    Все узлы, подключаемые минуя прокси-сервер
    Все сетевые пути (UNC)

Примечание

  • Чтобы добавить веб-узел в эту зону, нажмите кнопку Дополнительно, введите URL-адрес узла и нажмите кнопку Добавить. Для включения проверки серверов установите флажок Для всех узлов этой группы требуется проверка серверов (https:).

Параметры зоны «Местная интрасеть»

Следующие правила применимы к параметрам зоны «Местная интрасеть». Имейте в виду, что при добавлении веб-узлов в любую зону следует придерживаться следующих правил.

  • Включение всех локальных узлов (узлов интрасети), не входящих в другие зоны: Узлы интрасети имеют имена, не содержащие точек (например http://local). Такое имя узла как http://www.microsoft.com/ не является локальным, поскольку содержит точки. Этот узел должен быть добавлен в зону «Интернет». Правило имени локального узла применимо к URL-адресам, начинающимся с file: и http:.
  • Включение всех локальных узлов, подключаемых минуя прокси-сервер: Обычные конфигурации интрасети используют прокси-сервер для доступа в Интернет при помощи прямого соединения с серверами интрасети. Такой тип настойки позволяет отличать содержимое интрасети от содержимого Интернета и, соответственно, применять параметры, установленные для зон. Если прокси-сервер настроен иначе, следует снять данный флажок и использовать другие параметры для определения файлов, назначенных зоне «Местная интрасеть». В системах, не использующих прокси-сервер, данный параметр работать не будет.
  • Включение всех сетевых путей (UNC): Сетевые пути (например \\local\файл.txt) обычно используются для содержимого локальных сетей, которое должно входить в зону «Местная интрасеть». Если имеются сетевые пути которые не должны входить зону «Местная интрасеть», следует снять данный флажок и использовать другие параметры для указания фалов, относящихся к зоне «Местная интрасеть». Например, в определенных конфигурациях общей файловой системы Интернета (CIFS) сетевой путь может ссылаться на содержимое Интернета.

После подтверждения безопасности зоной «Местная интрасеть» следует изменить значение уровня безопасности на Ниже среднего или Низкий для отмены ограничений на выполнение веб-узлами потенциально опасных операций. Кроме того, персональные настройки безопасности можно регулировать в диалоговом окне «Особые параметры».

Если некоторые компьютеры в интрасети небезопасны или ненадежны, их можно исключить из этой зоны, добавив в зону «Ограниченные узлы».

Настройка параметров зоны «Местная интрасеть» производится с помощью оснастки «Групповая политика» или пакета IEAK, а также на вкладке Безопасность диалогового окна «Свойства: Интернет».

Работа с суффиксами имени домена

Для ссылки на веб-сервер с помощью его короткого адреса, не включающего домен, можно использовать суффикс имени домена. Например, на веб-сервер, называемый sample.microsoft.com можно сослаться как на sample; то есть, доступ к нему можно получить, введя http://sample.microsoft.com/ или http://sample.

Для этого необходимо добавить суффикс домена в свойства порядка просмотра доменных суффиксов TCP/IP, выполнив следующие шаги.

  1. Щелкните правой кнопкой мыши значок Мое сетевое окружение и выберите команду Свойства.
  2. Щелкните значок TCP/IP и выберите команду Свойства.
  3. Откройте вкладку DNS, а затем в область Порядок просмотра доменных суффиксов введите необходимые сведения.

Необходимо правильно настроить зоны безопасности для данной конфигурации. По умолчанию URL-адрес, не содержащий точек (http://sample), относится к зоне «Местная интрасеть», в то время как URL-адрес, содержащий точки (http://sample.microsoft.com), относится к зоне «Интернет». Следовательно, при использовании такой конфигурации, не содержащей узлов, минующих прокси-сервер для точного назначения содержимого соответствующей зоне, необходимо изменить настройки зоны безопасности.

В зависимости от того, относится ли содержимое, доступ к которому осуществляется с помощью суффикса домена, к интрасети или Интернету, URL-адрес узла необходимо добавить в соответствующую зону. Для добавления URL-адресов, таких как http://sample, в зону «Интернет», снимите флажок Все узлы интрасети, не перечисленные в других зонах для зоны «Местная интрасеть», и добавьте узел в список веб-узлов данной зоны.

Дополнительные сведения о безопасности, относящиеся ко всем зонам

Сослаться на веб-содержимое можно с помощью DNS-имени или по IP-адресу. Для узлов, использующих оба способа, должны быть настроены обе ссылки в одной зоне. В большинстве случаев, узлы зоны «Местная интрасеть» идентифицируются по локальным именам или IP-адресам в списке узлов, не использующих прокси-сервер. Все другие имена и IP-адреса должны отображаться в зоне «Интернет». Тем не менее, если имя узла добавлено в список веб-узлов зоны «Надежные узлы» или «Ограниченные узлы», а его IP-адрес не добавлен, узел рассматривается как часть зоны «Интернет», если доступ к нему осуществляется по IP-адресу.

Следует помнить, что пользователь может копировать содержимое из одной зоны в другую, тем самым понижая или повышая предполагаемый уровень безопасности содержимого.

Если автоматическая настройка обозревателей Internet Explorer 6 и Internet Explorer 4.0 производится с помощью одного и того же файла настройки, некоторые параметры безопасности, различающиеся в данных версиях обозревателя, в Internet Explorer 4.0 настроены не будут.


Файлы примеров авто-прокси JavaScript или JScript

Следующие сценарии содержат примеры использования файлов .pac для указания URL авто-прокси. Для использования этих возможностей необходимо изменить имена прокси, IP-адреса и номера портов.

Примечания

  • Функции isInNet(), isResolvable() и dnsResolve() запрашивают сервер DNS.
  • Ссылки на объекты, свойства или методы модели объектов не позволяют использовать файл авто-настройки прокси. Например, ссылки window.open(...), alert(...), password(...) приведут к сбою работы файла авто-настройки прокси в Internet Explorer.

Пример 1: Локальные узлы осуществляют прямое соединение, все остальные узлы подключаются через прокси

Следующая функция определяет, является ли узел локальным, и подключен ли он с помощью прямого соединения. Если узел не является локальным, соединение осуществляется через прокси (прокси).

функция FindProxyForURL(url, host)
  {
    if (isPlainHostName(host))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Функция isPlainHostName() проверяет наличие точек в имени узла. В случае их наличия возвращается значение «ложь», в противном случае возвращается значение «истина».

Пример 2: Узлы в брандмауэре осуществляют прямое соединение, узлы, находящиеся вне локальных серверов, подключаются через прокси

Следующая функция проверяет, является ли имя узла "простым" именем (т.е. не включающим в себя имя домена) или частью определенного домена (.company.com), но именем узла не является www или home.

функция FindProxyForURL(url, host)
  {
    if ((isPlainHostName(host) ||
       dnsDomainIs(host, ".company.com")) &&
      !localHostOrDomainIs(host, "www.company.com") &&
      !localHostOrDoaminIs(host, "home.company.com"))

      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Примечания

  • Функция localHostOrDomainIs() выполняется только для адресов URL в локальном домене.
  • Функция dnsDomainIs() возвращает значение «истина», если домен имени узла соответствует данному домену.

Пример 3: Если узел распознается, осуществляется прямое соединение, в остальных случаях подключение производится через прокси

Следующая функция опрашивает сервер DNS, пытаясь распознать имя вошедшего в него узла. Если удается распознать имя узла, осуществляется прямое соединение. В противном случае подключение производится через прокси. Данная возможность полезна при использовании внутреннего сервера DNS для распознавания всех внутренних имен узла.

функция FindProxyForURL(url, host)
  {
    if (isResolvable(host))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

См. примечание к описанию функции isResolvable() вверху страницы.

Пример 4: Если узел находится в определенной подсети, осуществляется прямое соединение, в остальных случаях подключение производится через прокси

Следующая функция сравнивает данный образец IP-адреса и маски с именем узла. Это удобно, если определенные узлы в подсети должны устанавливать прямое соединение, а остальные узлы должны устанавливать подключение через прокси.

функция FindProxyForURL(url, host)
  {
    if (isInNet(host, "999.99.9.9", "255.0.255.0"))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

См. примечание к описанию функции isInNet() вверху страницы.

Функция isInNet(host, pattern, mask) возвращает значение «истина» если IP-адрес узла соответствует определенному образцу. Маска указывает, какая часть IP-адреса соответствует образцу (255=соответствует, 0=пропускается).

Пример 5: Определение типа связи на основании домена узла

Следующая функция определяет прямое подключения, если узел является локальным. Если узел не является локальным, данная функция на основании домена узла определяет, какой прокси использовать. Это удобно, если доменное имя узла является одним критериев для отбора прокси.

функция FindProxyForURL(url, host)
  {
    if (isPlainHostName(host))
      return "DIRECT";
    else if (shExpMatch(host, "*.com"))
      return "PROXY comproxy:80";
    else if (shExpMatch(host, "*.edu"))
      return "PROXY eduproxy:80";
    else
      return "PROXY proxy";
  }

Функция shExpMatch(str, shexp) возвращает значение «истина», если str соответствует shexp с помощью бланков выражения оболочки.

Пример 6: Определение типа связи на основании используемого протокола

Следующая функция извлекает используемый протокол и в соответствии с ним выбирает прокси. Если сопоставить протокол не удается, устанавливается прямое соединение. Это удобно, если используемый протокол является одним критериев для отбора прокси.

функция FindProxyForURL(url, host)
  {
      if (url.substring(0, 5) == "http:") {
        return "PROXY proxy:80";
      }
      else if (url.substring(0, 4) == "ftp:") {
        return "PROXY fproxy:80";
      }
      else if (url.substring(0, 7) == "gopher:") {
        return "PROXY gproxy";
      }
      else if (url.substring(0, 6) == "https:") {
        return "PROXY secproxy:8080";
      }
      else {
        return "DIRECT";
      }
  }

Функция substring() извлекает определенное число символов из строки.

Пример 7: Определение настроек прокси с помощью проверки соответствия имени узла IP-адресу

Следующая функция производит выбор прокси, переводя имя узла в IP-адрес и сравнивая его с определенной строкой.

функция FindProxyForURL(url, host)
  {
      if (dnsResolve(host) == "999.99.99.999") { // = http://secproxy
        return "PROXY secproxy:8080";
      }
      else {
        return "PROXY proxy:80";
      }
  }

См. примечание к описанию функции dnsResolve() вверху страницы.

Пример 8: Если IP-адрес узла соответствует определенному IP-адресу, устанавливается подключение через прокси, в остальных случаях устанавливается прямое соединение

Следующая функция позволяет другим способом произвести выбор прокси, основываясь на определении IP-адреса. В данном примере, в отличие от примера 7, вызов функции используется для явного получения числового IP-адреса (в примере 7 используется функция dnsResolve(), переводящая имя узла в числовой IP-адрес).

функция FindProxyForURL(url, host)
  {
      if (myIpAddress() == "999.99.999.99") {
        return "PROXY proxy:80";
      }
      else {
        return "DIRECT";
      }
  }

Функция myIpAddress() возвращает IP-адрес (в формате целых, разделенных точками) узла, на котором запущен обозреватель.

Пример 9: Если в имени узла есть точки, устанавливается подключение через прокси, в остальных случаях устанавливается прямое соединение

Следующая функция проверяет, сколько точек содержит имя узла. Если в имени узла есть точки, устанавливается подключение через прокси. Если в имени узла нет точек, устанавливается прямое соединение. Это еще один способ, при помощи которого можно определить тип соединения на основании характеристик имени узла.

функция FindProxyForURL(url, host)
  {
      if (dnsDomainLevels(host) > 0) { // если количество точек в имени узла > 0
        return "PROXY proxy:80";
      }
        return "DIRECT";
  }

Функция dnsDomainLevels() возвращает целое число, равное количеству точек в имени узла.

Пример 10: Указание дней недели, по которым соединение устанавливается через прокси, и дней недели, по которым устанавливается прямое соединение

Следующая функция определяет тип соединения, указывая дни недели, по которым соединение устанавливается через прокси. По другим дням недели устанавливается прямое соединение. Данная функция может быть полезна, если в определенные дни недели, когда трафик высок, требуется использовать прокси, а в те дни, когда трафик низок, устанавливать прямое соединение.

функция FindProxyForURL(url, host)
  {
    if(weekdayRange("WED", "SAT", "GMT"))
     return "PROXY proxy:80";
    else
     return "DIRECT";
  }

Функция weekdayRange( <day1> [,<day2>] [,<fGMT>] ) проверяет, попадает ли текущее системное время в диапазон, заданный параметрами <day1>, <day2> и <fGMT>. Необходим только первый параметр. Параметр GMT устанавливает среднее время по Гринвичу, а не местное время.


Экспорт параметров Internet Explorer с помощью оснастки «Групповая политика»

Оснастку «Групповая политика» можно использовать для экспорта всех настроек обозревателя Internet Explorer в файл .ins, и при необходимости в cab-файл. Эти параметры можно использовать для автоматической настройки на компьютерах, работающих под управлением других операционных систем.

  1. В оснастке «Групповая политика» щелкните правой кнопкой мыши экран Internet Explorer, содержащий настройки, которые требуется экспортировать.
  2. Нажмите кнопку Экспорт параметров обозревателя.
  3. Введите имя ins-файла и, если необходимо, имена cab-файлов, в которые требуется экспортировать настройки обозревателя.
  4. Введите URL-адрес веб-сервера, на котором будут располагаться файлы.


Запуск оснастки «Групповая политика» для Internet Explorer

Оснастка «Групповая политика» позволяет управлять пользовательскими параметрами обозревателя Internet Explorer. Кроме того, эти параметры можно настроить с помощью пакета IEAK, при этом действия по настройке будут иными. При использовании пакета IEAK настройки помещаются в пользовательский пакет Internet Explorer, который затем можно развернуть. При использовании оснастки «Групповая политика» после настройки параметров обозревателя процесс развертывания можно пропустить. При запуске Internet Explorer функция автоматической настройки произведет обновление параметров обозревателя.

Запуск оснастки «Групповая политика» для Internet Explorer

  1. В меню Пуск выберите командуВыполнить.
  2. В поле Открыть введите gpedit.msc, а затем нажмите кнопку OK.
  3. Выберите элементы Конфигурация пользователя и Конфигурация Windows.
  4. Дважды щелкните компонент Настройка Internet Explorer.

См. также


Использование оснастки «Групповая политика» для управления обозревателем Internet Explorer

  1. В оснастке «Групповая политика» выделите элемент Конфигурация пользователя.
  2. Выберите элементы Конфигурация Windows и Настройки Internet Explorer.
  3. Дваждый щелкните значок, относящийся к параметрам, которые требуется изменить.
  4. Дважды щелкните название параметра, который требуется настроить.
  5. Измените настройки по своему усмотрению.

    Настройки вступят в силу сразу после нажатия кнопки OK. Настройки хранятся в объекте оснастки «Групповая политика».

Примечания

  • Дополнительные сведения об использовании оснастки «Групповая политика» содержатся в файле справки оснастки «Групповая политика».
  • Оснастку «Групповая политика» можно также использовать для экспорта всех настроек обозревателя Internet Explorer в файл .ins и при необходимости в cab-файл. Дополнительные сведения содержатся в разделе Экспорт параметров Internet Explorer с помощью оснастки «Групповая политика».


Служба технической поддержки корпорации Майкрософт в Интернете

Получение последних решений технических проблем через Интернет

Интерактивная поддержка пользователей службой технической поддержки Майкрософт

Если не удается найти ответ на возникший технический вопрос в справке Windows 2000 или Windows XP, обратитесь в службу технической поддержки корпорации Майкрософт в Интернете. На специальных узлах технической поддержки в базе данных технической информации службы поддержки продуктов корпорации Майкрософт, включающей статьи базы знаний Майкрософт, ответы на часто задаваемые вопросы и предложения по устранению неполадок, можно быстро найти точные ответы на возникающие вопросы. Интерактивная техническая поддержка подберет специальные материалы, в которых скорее всего будет содержаться ответ на заданный вопрос.

Чтобы начать поиск, перейдите на узел интерактивной поддержки.

Интерактивная техническая поддержка предоставит сведения о том, как связаться с корпорацией Майкрософт (эти сведения также содержатся в соответствующих разделах справки).