What Is SQL Server Client Network Utility?

Отзыв Программа сетевого клиента

Программа сетевого клиента SQL Server

Программа сетевого клиента SQL Server представляет собой графический инструмент, позволяющий выполнить следующее.

  • Создавать подключения по сетевым протоколам к заданным серверам и изменять используемый по умолчанию сетевой протокол.

  • Отображать сведения о сетевых библиотеках, установленных в данное время в системе.

  • Отображать версию библиотеки DB-Library, установленной в данное время в системе, и задавать используемые по умолчанию параметры для DB-Library.

Дополнительные сведения о программе сетевого клиента SQL Server содержатся в разделе по управлению клиентами (Managing Clients) в электронной документации SQL Server Books Online.

©Корпорация Майкрософт (Microsoft Corporation), 1988-2000. Все права защищены.


Вкладка «Общие»

В данном разделе перечислены функции параметров, доступных на вкладке Общие.

Параметры

Отключенные протоколы

Указываются доступные протоколы, в данное время выключенные на этом компьютере. Чтобы включить протокол, щелкните его и нажмите кнопку Включить.

Включенные протоколы по порядку

Указываются протоколы, в данное время включенные на этом компьютере. Протоколы записываются в том порядке, в котором система будет пытаться использовать их для подключений.

Включить

Включает протоколы, выделенные в данное время в списке Отключенные протоколы. Для выполнения той же операции достаточно дважды щелкнуть соответствующий протокол.

Отключить

Выключает протоколы, выделенные в данное время в списке Включенные протоколы по порядку. Для выполнения той же операции достаточно дважды щелкнуть соответствующий протокол.

Кнопки "вверх" и "вниз"

Перемещают выделенный протокол вверх и вниз по списку. Это позволяет изменить порядок, в котором сетевая библиотека будет пытаться использовать протоколы для подключений.

Свойства

Отображаются используемые по умолчанию свойства подключения для выделенного протокола.

Обязательное шифрование протокола

Включение шифрования протокола с помощью SSL (Secure Sockets Layer).

Разрешить общий протокол памяти

Включение общего протокола памяти для подключений одного и того же компьютера.

См. также

Добавление конфигурации сетевой библиотеки

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки

Проверка прослушивания AppleTalk сервером SQL Server


Named Pipes Protocol Default Value Setup

Установка значения по умолчанию для протокола именованных каналов

В разделе перечислены параметры и их значения, доступные в диалоговом окне Установка значения по умолчанию для сетевого протокола для протокола Именованные каналы.

Параметры

Именованный канал по умолчанию

Задает канал по умолчанию, который сетевая библиотека именованных каналов будет использовать при попытке подключиться к указанному экземпляру Microsoft® SQL Server™.

См. также

Добавление конфигурации сетевой библиотеки

Задание псевдонима клиента для альтернативного канала

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


TCP/IP Protocol Default Value Setup

Установка значения по умолчанию для протокола TCP/IP

В разделе перечислены параметры и их значения, доступные в диалоговом окне Установка значения по умолчанию для сетевого протокола для протокола TCP/IP.

Параметры

Порт по умолчанию

Задает порт, который сетевая библиотека TCP/IP будет использовать при попытке подключиться к указанному экземпляру Microsoft® SQL Server™. По умолчанию используется порт 1433.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования TCP/IP

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Multiprotocol Protocol Default Value Setup

Установка значения по умолчанию для протокола Multiprotocol

В разделе перечислены параметры и их значения, доступные в диалоговом окне Установка значения по умолчанию для сетевого протокола для протокола Multiprotocol.

Параметры

Протоколы RPC

Список протоколов, которые будет использовать сетевая библиотека Multiprotocol при попытке подключиться к указанному экземпляру Microsoft® SQL Server™. Сетевая библиотека Multiprotocol будет проверять каждый протокол в указанном порядке, пока не будет установлено соединение. Имена протоколов перечислены ниже. Они должны разделяться пробелами.

Протокол | Имя
Multiprotocol | nlrpc
Именованные каналы | nacn_np
TCP/IP | nacn_ip_tcp
IPX/SPX | nacn_spx

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования сетевой библиотеки Multiprotocol

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


NWLink IPX/SPX Protocol Default Value Setup

Установка значения по умолчанию для протокола NWLink IPX/SPX

В разделе перечислены параметры и их значения, доступные в диалоговом окне Установка значения по умолчанию для сетевого протокола для протокола NWLink IPX/SPX.

Параметры

Сеть по умолчанию

Указывает номер сети NetWare. По умолчанию задается значение 0.

Порт по умолчанию

Указывает номер соединителя. По умолчанию задается значение 33854.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования сетевой библиотеки NWLink IPX/SPX

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


AppleTalk Protocol Default Value Setup

Установка значения по умолчанию для протокола AppleTalk

В разделе перечислены параметры и их значения, доступные в диалоговом окне Установка значения по умолчанию для сетевого протокола для протокола AppleTalk.

Параметры

Зона по умолчанию

Указывает зону, используемую при регистрации службы.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования сетевой библиотеки AppleTalk

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Banyan VINES Protocol Default Value Setup

Установка значения по умолчанию для протокола Banyan VINES

В разделе перечислены параметры и их значения, доступные в диалоговом окне Установка значения по умолчанию для сетевого протокола для протокола Banyan VINES.

Параметры

Группа по умолчанию

Указывает группу, к которой принадлежит служба.

Организация по умолчанию

Указывает организацию, к которой принадлежит служба.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования сетевой библиотеки Banyan VINES

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


VIA Protocol Default Value Setup

Установка значения по умолчанию для протокола VIA

В разделе перечислены параметры и их значения, доступные в диалоговом окне Установка значения по умолчанию для сетевого протокола для протокола VIA.

Параметры

Продавец

Указывает продавца оборудования, которое будет использоваться протоколом VIA.

Порт сервера по умолчанию

Указывает порт сервера, используемый по умолчанию. По умолчанию задается значение 0:1433.

NIC клиента по умолчанию

Указывает используемую по умолчанию сетевую плату клиента. По умолчанию задается значение 0.

См. также

Добавление конфигурации сетевой библиотеки

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Alias Tab

Вкладка «Псевдоним»

В данном разделе перечислены функции параметров, доступных на вкладке Псевдоним.

Параметры

Настройка псевдонимов для сервера

Указывает сведения о псевдонимах сервера для компьютеров, к которым подключается клиент.

Псевдоним для сервера

Указывает псевдоним сервера для компьютера, к которому подключается клиент.

Сетевая библиотека

Указывает сетевую библиотеку клиента, используемую для настройки.

Параметры подключения

Указывает все параметры, связанные с адресом подключения для конфигурации сетевой библиотеки.

Добавить

Добавление конфигурации сетевой библиотеки.

Удалить

Удаление конфигурации сетевой библиотеки.

Изменить

Изменение конфигурации сетевой библиотеки.

См. также

Добавление конфигурации сетевой библиотеки

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки

Проверка прослушивания AppleTalk сервером SQL Server


Add (or Edit) Named Pipes Library Configuration

Добавление (или Изменение) конфигурации библиотеки именованных каналов

В разделе перечислены параметры и их значения, доступные в диалоговом окне Добавление (или изменение) конфигурации сетевой библиотеки для протокола именованных каналов.

Параметры

Псевдоним для сервера

Указывает уникальное имя для экземпляра Microsoft® SQL Server™, который осуществляет прослушивание с помощью сетевой библиотеки именованных каналов.

Сетевые библиотеки

Указывает сетевую библиотеку, которая будет использоваться для подключения к серверу. Выделено значение для именованных каналов.

Имя сервера

Указывает имя сервера указанного экземпляра SQL Server.

Имя канала

Задает канал, который сетевая библиотека именованных каналов будет использовать при попытке подключиться к указанному экземпляру SQL Server.

См. также

Добавление конфигурации сетевой библиотеки

Задание псевдонима клиента для альтернативного канала

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Add (or Edit) TCP/IP Library Configuration

Добавление (или Изменение) конфигурации библиотеки TCP/IP

В разделе перечислены параметры и их значения, доступные в диалоговом окне Добавление (или изменение) конфигурации сетевой библиотеки для протокола TCP/IP.

Параметры

Псевдоним для сервера

Указывает уникальное имя для экземпляра Microsoft® SQL Server™, который осуществляет прослушивание с помощью сетевой библиотеки соединителей TCP/IP.

Сетевые библиотеки

Указывает сетевую библиотеку, которая будет использоваться для подключения к серверу. Выделено значение TCP/IP.

Имя сервера

Укажите экземпляр SQL Server, который выполняет прослушивание клиентов соединителей TCP/IP.

Динамически определить порт

Указывается, что сетевая библиотека будет определять порт динамически. Порт, указанный в поле Номер порта, использоваться не будет.

Номер порта

Задает порт, который сетевая библиотека TCP/IP будет использовать при попытке подключиться к указанному экземпляру SQL Server. По умолчанию используется номер 1433, который сетевая библиотека соединителей Windows обычно использует для SQL Server. В большинстве случаев менять номер порта не потребуется. Это поле активно только в случает снятого флажка Динамически определить порт.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования TCP/IP

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Add (or Edit) Multiprotocol Library Configuration

Добавление (или Изменение) конфигурации библиотеки Multiprotocol

В разделе перечислены параметры и их значения, доступные в диалоговом окне Добавление (или изменение) конфигурации сетевой библиотеки для протокола Multiprotocol.

Параметры

Псевдоним для сервера

Указывает уникальное имя для сервера, на котором выполняется экземпляр Microsoft® SQL Server™, осуществляющий прослушивание с помощью сетевой библиотеки Multiprotocol.

Сетевые библиотеки

Указывает сетевую библиотеку, которая будет использоваться для подключения к серверу. Выделено значение Multiprotocol.

Имя сервера

Укажите экземпляр SQL Server, который выполняет прослушивание для клиентов Multiprotocol.

Дополнительные параметры

Указывает дополнительные параметры конфигурации для сетевой библиотеки Multiprotocol. Данные параметры не являются обязательными.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования сетевой библиотеки Multiprotocol

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Add (or Edit) NWLink IPX/SPX Library Configuration (Service Name)

Добавление (или Изменение) конфигурации библиотеки NWLink IPX/SPX (имя службы)

В разделе перечислены параметры и их значения, доступные в диалоговом окне Добавление (или изменение) конфигурации сетевой библиотеки для протокола NWLink IPX/SPX.

Параметры

Псевдоним для сервера

Указывает уникальное имя для экземпляра Microsoft® SQL Server™, который осуществляет прослушивание с помощью сетевой библиотеки NWLink IPX/SPX.

Сетевые библиотеки

Указывает сетевую библиотеку, которая будет использоваться для подключения к серверу. Выделено значение NWLink IPX/SPX.

Задание параметров

Указывает, как задаются параметры. Выделено значение Имя службы.

Имя службы

Указывает имя компьютера с системой Microsoft Windows NT® 4.0 или Windows® 2000, на котором работает экземпляр SQL Server. Эти сведения хранятся в системной базе данных сервера.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования сетевой библиотеки NWLink IPX/SPX

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Add (or Edit) NWLink IPX/SPX Library Configuration (Network Address)

Добавление (или Изменение) конфигурации библиотеки NWLink IPX/SPX (сетевой адрес)

В разделе перечислены параметры и их значения, доступные в диалоговом окне Добавление (или изменение) конфигурации сетевой библиотеки для протокола NWLink IPX/SPX.

Параметры

Псевдоним для сервера

Указывает уникальное имя для экземпляра Microsoft® SQL Server™, который осуществляет прослушивание с помощью сетевой библиотеки NWLink IPX/SPX.

Сетевые библиотеки

Указывает сетевую библиотеку, которая будет использоваться для подключения к серверу. Выделено значение NWLink IPX/SPX.

Задание параметров

Указывает, как задаются параметры. Выделено значение Сетевой адрес.

Адрес

Указывает адрес сетевой платы MAC.

Порт

Указывает номер соединителя. По умолчанию задается значение 33854.

Сеть

Указывает номер сети NetWare. По умолчанию задается значение 0.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования сетевой библиотеки NWLink IPX/SPX

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Add (or Edit) AppleTalk Library Configuration

Добавление (или Изменение) конфигурации библиотеки AppleTalk

В разделе перечислены параметры и их значения, доступные в диалоговом окне Добавление (или изменение) конфигурации сетевой библиотеки для протокола AppleTalk.

Параметры

Псевдоним для сервера

Указывает уникальное имя для сервера, на котором выполняется экземпляр Microsoft® SQL Server™, осуществляющий прослушивание с помощью сетевой библиотеки AppleTalk.

Сетевые библиотеки

Указывает сетевую библиотеку, которая будет использоваться для подключения к серверу. Выделяется значение AppleTalk.

Имя объекта

Указывает объект службы, назначенный системным администратором.

Зона

Указывает зону, используемую при регистрации службы.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования сетевой библиотеки AppleTalk

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Add (or Edit) Banyan VINES Library Configuration

Добавление (или Изменение) конфигурации библиотеки Banyan VINES

В разделе перечислены параметры и их значения, доступные в диалоговом окне Добавление (или изменение) конфигурации сетевой библиотеки для протокола Banyan VINES.

Параметры

Псевдоним для сервера

Указывает уникальное имя для сервера, на котором выполняется экземпляр Microsoft® SQL Server™, осуществляющий прослушивание с помощью сетевой библиотеки Banyan VINES.

Сетевые библиотеки

Указывает сетевую библиотеку, которая будет использоваться для подключения к серверу. Выделяется значение Banyan VINES.

Служба

Указывает имя службы (версии для ПК) StreetTalk, которая используется на сервере.

Группа

Указывает группу, к которой принадлежит служба.

Организация

Указывает организацию, к которой принадлежит служба.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования сетевой библиотеки Banyan VINES

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Add (or Edit) VIA Library Configuration

Добавление (или Изменение) конфигурации библиотеки VIA

В разделе перечислены параметры и их значения, доступные в диалоговом окне Добавление (или изменение) конфигурации сетевой библиотеки для протокола VIA.

Параметры

Псевдоним для сервера

Указывает уникальное имя для сервера, на котором выполняется экземпляр Microsoft® SQL Server™, осуществляющий прослушивание с помощью сетевой библиотеки VIA.

Сетевые библиотеки

Указывает сетевую библиотеку, которая будет использоваться для подключения к серверу. Выбрана библиотека VIA.

Имя сервера

Укажите экземпляр SQL Server, который выполняет прослушивание для клиентов VIA.

Номер порта сервера

Задает номер порта сервера для использования при подключении к экземпляру SQL Server. По умолчанию задается значение 0:1433.

См. также

Добавление конфигурации сетевой библиотеки

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


Add (or Edit) Other Library Configurations

Добавление (или Изменение) конфигураций других сетевых библиотек

В разделе перечислены параметры и их значения, доступные в диалоговом окне Добавление (или изменение) конфигурации сетевой библиотеки для других протоколов.

Параметры

Псевдоним для сервера

Указывает уникальное имя для сервера, на котором выполняется экземпляр Microsoft® SQL Server™ и который осуществляет прослушивание новой конфигурации сетевой библиотеки.

Сетевые библиотеки

Указывает сетевую библиотеку, которая будет использоваться для подключения к серверу. Выделяется значение Другое.

Имя файла

Указывает имя и местоположение файла DLL для сетевой библиотеки, предоставленной другим производителем.

Параметры

Указывает все необходимые параметры и их формат.

См. также

Добавление конфигурации сетевой библиотеки

Настройка клиента для использования нестандартной сетевой библиотеки

Удаление конфигурации сетевой библиотеки

Изменение конфигурации сетевой библиотеки


DB-Library Options Tab

Вкладка «Параметры DB-библиотеки»

В данном разделе перечислены функции параметров, доступных на вкладке Параметры DB-библиотеки.

Параметры

Имя файла

Указывает имя файла и местоположение библиотеки DB-Library, установленной на данном компьютере.

Версия

Указывает номер версии библиотеки DB-Library, установленной на данном компьютере.

Дата

Указывает дату установки на данный компьютер библиотеки DB-Library.

Размер

Указывает размер библиотеки DB-Library, установленной на данном компьютере.

Автоматическое преобразование ANSI -> OEM

Включение в библиотеке DB-Library функцию преобразования набора знаков из OEM в ANSI при передаче данных от клиента к Microsoft® SQL Server™ и из ANSI в OEM при передаче данных клиенту от SQL Server. Устанавливается по умолчанию.

Использовать национальные настройки

Позволяет библиотеке DB-Library извлекать форматы даты, времени и валюты из операционной системы вместо использования этих параметров из программы. Устанавливается по умолчанию для клиентов, выполняющихся в 32-разрядных операционных системах Microsoft Windows®.

См. также

Задание параметров преобразования DB-библиотеки


Network Libraries Tab

Вкладка «Сетевые библиотеки»

В данном разделе перечислены функции параметров, доступных на вкладке Сетевые библиотеки.

Параметры

Сетевая библиотека

Вывод списка сетевых библиотек клиента Microsoft® SQL Server™, установленных на данном компьютере.

Имя файла библиотеки

Отображение местоположения сетевых библиотек клиента SQL Server, установленных на данном компьютере.

Версия

Отображение списка номеров версий сетевых библиотек клиента SQL Server, установленных на данном компьютере.

Дата файла

Отображение списка дат установки на данный компьютер сетевых библиотек клиента SQL Server.

Размер

Отображение размеров сетевых библиотек клиента SQL Server, установленных на данном компьютере.

См. также

Отображение номеров версий библиотеки


Managing Clients

Управление клиентами

Клиент является приложением переднего плана (front-end), использующим службы, предоставляемые сервером. Компьютер, на котором находится приложение, называется клиентским. Программное обеспечение клиента позволяет компьютерам подключаться к экземпляру Microsoft® SQL Server™ в сети.

Клиенты SQL Server могут включать приложения разных типов, например такие как:

  • Потребители OLE DB.

    Эти приложения используют для подключения к экземплярам SQL Server и преобразования с помощью экземпляров SQL Server поставщик Microsoft OLE DB для SQL Server или для ODBC. Поставщики OLE DB служат в качестве промежуточного слоя между экземпляром SQL Server и клиентскими приложениями, которые используют данные SQL Server в качестве наборов строк OLE DB.

  • Приложения ODBC.

    Включают клиентские программы, установленные вместе с SQL Server, например, «SQL Server Enterprise Manager» и «SQL Query Analyzer», а также другие приложения, которые для подключения к экземпляру SQL Server и преобразования с помощью экземпляра SQL Server используют драйвер SQL Server ODBC.

  • Клиенты DB-Library, включая программу командной строки SQL Server isql и клиентов, написанных для DB-Library.

Независимо от типа приложения, управление клиентом состоит, главным образом, из настройки его соединений с серверными компонентами SQL Server. В зависимости от требований вашего узла, управление клиентом может меняться от ввода имени компьютера сервера до построения библиотеки выборочных записей настройки для адаптации разной многопользовательской среды.


How to start the Client Network Utility (Windows)

Запуск программы сетевого клиента (Windows)

Запуск программы сетевого клиента

  • В меню Пуск, выберите пункты и Программы и Microsoft SQL Server 7.0, а затем в меню выберите Программа сетевого клиента.


How to display the network library version numbers (Client Network Utility)

Отображение номеров версий библиотеки (программа сетевого клиента)

Чтобы отобразить номера версий библиотеки

  • Выберите вкладку Сетевые библиотеки.

    Отображаются сетевая библиотека, имя файла библиотеки, версия, дата и размер файла.


How to set DB-Library conversion preferences (Client Network Utility)

Задание параметров преобразования DB-библиотеки (программа сетевого клиента)

Примечание. Эта процедура применяется к клиентам 32-разрядной ОС Microsoft® Windows®.

Задание параметров преобразования DB-библиотеки

  1. Выберите вкладку Параметры библиотеки DB.

  2. Установите или удалите флажок Автоматическое преобразование ANSI -> OEM.

  3. Установите или снимите флажок Использовать национальные настройки.


How to add a network library configuration (Client Network Utility)

Добавление конфигурации сетевой библиотеки (программа сетевого клиента)

Чтобы добавить конфигурацию сетевой библиотеки

  1. Выберите вкладку Псевдоним и нажмите кнопку Добавить.

  2. В диалоговом окне Добавление конфигурации сетевой библиотеки выберите одну из сетевых библиотек в группе Сетевые библиотеки.

  3. Введите псевдоним сервера и требуемые параметры для выбранной сетевой библиотеки.


How to edit a network library configuration (Client Network Utility)

Изменение конфигурации сетевой библиотеки (программа сетевого клиента)

Чтобы изменить конфигурацию сетевой библиотеки

  1. На вкладке Псевдоним выберите конфигурацию сетевого протокола, которую требуется изменить.

  2. Нажмите кнопку Изменить.

  3. В диалоговом окне Изменение конфигурации сетевой библиотеки измените нужные сведения.


How to delete a network library configuration (Client Network Utility)

Удаление конфигурации сетевой библиотеки (программа сетевого клиента)

Чтобы удалить конфигурацию сетевой библиотеки

  1. На вкладке Псевдоним выберите конфигурацию сетевой библиотеки, которую требуется удалить.

  2. Нажмите кнопку Удалить.


How to alias a client to an alternate pipe (Client Network Utility)

Задание псевдонима клиента для другого канала (программа сетевого клиента)

Чтобы задать псевдоним клиента для другого канала

  1. Выберите вкладку Псевдоним и нажмите кнопку Добавить.

  2. В диалоговом окне Добавление конфигурации сетевой библиотеки, выберите Именованные каналы.

  3. В поле Псевдоним сервера введите псевдоним сервера.

  4. В группе Параметры подключения в поле Имя канала, введите имя альтернативного канала (например, \\myserver\pipe\altpipe).


How to configure a client to use the Multiprotocol Net-Library (Client Network Utility)

Настройка клиента для использования сетевой библиотеки Multiprotocol (программа сетевого клиента)

Примечание. Перед созданием конфигурации клиента Multiprotocol, убедитесь в том, что компьютер имеет по крайней мере один протокол IPC, загруженный для Multiprotocol на сервере (Именованные каналы, NWLink IPX/SPX, TCP/IP или Windows Sockets).

Чтобы настроить клиента для использования сетевой библиотеки Multiprotocol

  1. Выберите вкладку Псевдоним и нажмите кнопку Добавить.

  2. В диалоговом окне Добавление конфигурации сетевой библиотеки щелкните MultiProtocol.

  3. В поле Псевдоним для сервера введите имя компьютера, на котором выполняется экземпляр Microsoft® SQL Server™ и который осуществляет прослушивание сетевой библиотеки Multiprotocol.

  4. Оставьте поле Дополнительные пустым, если серверу не требуются специфические параметры. Перед вводом параметров посоветуйтесь со своим администратором сети.


How to configure a client to use TCP/IP (Client Network Utility)

Настройка клиента для использования TCP/IP (программа сетевого клиента)

Чтобы настроить клиента для использования сетевой библиотеки Multiprotocol TCP/IP

  1. Выберите вкладку Общие и нажмите кнопку Добавить.

  2. В диалоговом окне Добавление конфигурации сетевой библиотеки щелкните TCP/IP.

  3. В поле Псевдоним для сервера введите псевдоним экземпляра Microsoft® SQL Server™, который осуществляет прослушивание сетевой библиотеки Windows Sockets.

    При использовании TCP/IP вместо имени сервера может указываться его IP-адрес.

  4. Выполните одно из следующих действий:
    • Установите флажок Динамически определить порт, чтобы определить порт автоматически.

    • Снимите флажок Динамически определить порт, чтобы задать порт вручную, а затем в поле Номер порта, ввести номер порта.

Для других протоколов TCP/IP, поддерживающих Windows Sockets, см. Документацию по TCP/IP.


How to configure a client to use the NWLink IPX/SPX network library (Client Network Utility)

Настройка клиента для использования сетевой библиотеки NWLink IPX/SPX (программа сетевого клиента)

Чтобы настроить клиента для использования сетевой библиотеки NWLink IPX/SPX

  1. Выберите вкладку Псевдоним и нажмите кнопку Добавить.

  2. В диалоговом окне Добавление конфигурации сетевой библиотеки щелкните NWLink IPX/SPX.

  3. В поле Псевдоним для сервера введите псевдоним экземпляра Microsoft® SQL Server™, который осуществляет прослушивание сетевой библиотеки NWLink IPX/SPX.

  4. В группе Параметры подключения щелкните Имя службы или Сетевой адрес, а затем выполните одно из следующих действий:
    • Если было выбрано значение Имя службы, введите имя службы.

      Имя службы представляет собой имя компьютера с системой Microsoft Windows NT® 4.0 или Windows® 2000, на котором работает экземпляр SQL Server. Это имя хранятся в системной базе данных сервера.

    • Если было выбрано значение Сетевой адрес, введите адрес (адрес платы MAC), порт (номер соединителя) и сеть (номер сети NetWare).


How to configure a client to use the AppleTalk network library (Client Network Utility)

Настройка клиента для использования сетевой библиотеки AppleTalk (программа сетевого клиента)

Чтобы настроить клиента для использования сетевой библиотеки AppleTalk

  1. Выберите вкладку Псевдоним и нажмите кнопку Добавить.

  2. В диалоговом окне Добавление конфигурации сетевой библиотеки щелкните AppleTalk.

  3. В поле Псевдоним для сервера введите имя компьютера, на котором выполняется экземпляр Microsoft® SQL Server™ и который осуществляет прослушивание сетевой библиотеки AppleTalk.

  4. В группе Параметры подключения введите имя объекта AppleTalk и необязательные идентификаторы зоны.


How to configure a client to use the Banyan VINES network library (Client Network Utility)

Настройка клиента для использования сетевой библиотеки Banyan VINES (программа сетевого клиента)

Чтобы настроить клиента для использования сетевой библиотеки Banyan VINES

  1. Выберите вкладку Псевдоним и нажмите кнопку Добавить.

  2. В диалоговом окне Добавление конфигурации сетевой библиотеки щелкните Banyan VINES.

  3. В поле Псевдоним для сервера введите псевдоним экземпляра Microsoft® SQL Server™, который осуществляет прослушивание сетевой библиотеки Banyan VINES.

  4. В группе Параметры подключения введите службу и организацию VINES. Можно использовать значения по умолчанию MSSQL для группы.


How to configure a client to use the VIA network library (Client Network Utility)

Настройка клиента для использования сетевой библиотеки VIA (программа сетевого клиента)

Чтобы настроить клиента для использования сетевой библиотеки VIA

  1. Выберите вкладку Псевдоним и нажмите кнопку Добавить.

  2. В диалоговом окне Добавление конфигурации сетевой библиотеки щелкните VIA.

  3. В поле Псевдоним для сервера введите псевдоним экземпляра Microsoft® SQL Server™, который осуществляет прослушивание сетевой библиотеки VIA.

  4. В группе Параметры подключения введите имя сервера и номер порта сервера.


How to configure a client to use a nonstandard network library (Client Network Utility)

Настройка клиента для использования нестандартной сетевой библиотеки (программа сетевого клиента)

Чтобы настроить клиента для использования нестандартной сетевой библиотеки

  1. Выберите вкладку Псевдоним и нажмите кнопку Добавить.

  2. В диалоговом окне Добавление конфигурации сетевой библиотеки щелкните Другая.

  3. В поле Псевдоним для сервера введите псевдоним экземпляра Microsoft® SQL Server™, который осуществляет прослушивание устанавливаемой сетевой библиотеки.

  4. В группе Параметры подключения введите имя файла (файл должен являться библиотекой DLL) установленной сетевой библиотеки. Do not enter the DLL extension.

  5. При необходимости, введите любые дополнительные сведения (например имя пользователя и пароль) в поле Параметры. Параметры отделяются друг от друга запятыми.


How to verify that SQL Server is listening on AppleTalk and can accept a client connection (Client Network Utility)

Проверка того, что SQL Server прослушивает AppleTalk и может принять клиентское соединение (программа сетевого клиента)

Чтобы проверить, что SQL Server прослушивает AppleTalk и может принять клиентское соединение

  1. Скопируйте сетевую библиотеку AppleTalk клиента (Dbmsadsn.dll) из каталога сервера \WINNT\system32 в тот же каталог удаленного компьютера, на котором выполняется служба Microsoft® Windows NT® или Microsoft Windows® Windows 2000 для Macintosh.

  2. На удаленной рабочей станции запустите настройку клиента SQL Server.

  3. Если протокол AppleTalk содержится в списке Отключенные протоколы, выберите AppleTalk и нажмите кнопку Включить.

  4. В списке Включенные протоколы по порядку выберите AppleTalk, а затем нажимайте кнопку Вверх, пока AppleTalk не окажется в верхней части списка.

  5. Нажмите кнопку OK.

  6. Произведите попытку соединения с использованием имени объекта службы AppleTalk.

    Например, введите в командную строку:

    isql -Usa -P -Sимя_службы

    Если успешно устанавливается соединение с ISQL и запросы выполняются, это означает, что сервер правильно настроен и принимает соединения.

    Примечание. Клиентская сетевая библиотека Microsoft Win32® AppleTalk (ADSP) (файл Dbmsadsn.dll) включена для проверки соединений ADSP и устранения неполадок в соединениях между клиентами Macintosh и Microsoft SQL Server™. Данная сетевая библиотека предназначена только для проверки на удаленном клиенте соединения с экземпляром SQL Server. При попытке установления через сетевую библиотеку ADSP локальных соединений с сервером, на котором выполняется экземпляр SQL Server, прослушивающий протокол AppleTalk, произойдет следующая сетевая ошибка: Net-Library error 11: getsockopt().


How to check the ODBC SQL Server driver version (Windows)

Проверка версии драйвера ODBC SQL Server (Windows)

Примечание. Выполните следующие шаги только в операционной системе Microsoft® Windows NT® 4.0.

Чтобы проверить версию драйвера ODBC SQL Server (32-разрядный)

  1. На панели управления дважды щелкните значек Источники данных ODBC.

  2. Перейдите на вкладку Драйверы.

    Сведения о записи Microsoft SQL Server™ отображаются в столбце Версия.


Microsoft SQL Server 2000 Copyright and Disclaimer

Microsoft SQL Server 2000: авторские права и отказ от обязательств

Данный документ, включая упоминаемые в нем примеры приложений, предоставлен исключительно для ознакомления, и корпорация Майкрософт не предоставляет на него никаких гарантий -- ни явных, ни подразумеваемых. В содержание настоящего документа, в том числе в примеры, URL-адреса и другие ссылки на веб-узлы в Интернете, могут быть внесены изменения без предварительного уведомления. Пользователь принимает на себя весь риск, связанный с использованием настоящего документа.

Главной целью примера является иллюстрация понятия или обоснованного применения определенной инструкции или предложения. Большинство примеров не включают весь исходный текст завершенного приложения, так как из него удалены обработчики проверки целостности данных или ошибок, чтобы заострить внимание на определенном понятии или инструкции. Техническая поддержка для примеров или исходных текстов не предоставляется.

Если не оговорено обратное, названия организаций и изделий, а также имена, даты и события, используемые в качестве примеров, являются вымышленными. Возможное сходство с реально существующими предприятиями, организациями, изделиями, лицами и событиями следует рассматривать как случайное. На пользователе лежит ответственность за соблюдение всех применимых в данном случае законов об авторском праве. В рамках, предусмотренных законами об авторских правах, никакая часть настоящего документа не может быть воспроизведена, сохранена или представлена в какой-либо системе хранения данных или передана в какой бы то ни было форме, какими бы то ни было средствами (электронными, механическими, фотокопировальными, записывающими или другими) и в каких бы то ни было целях без специального письменного разрешения корпорации Майкрософт.

Корпорация Майкрософт может являться правообладателем патентов и заявок, поданных на получение патента, товарных знаков и объектов авторского права, которые имеют отношение к содержанию данного документа. Предоставление вам данного документа не означает передачи какой-либо лицензии на использование данных патентов, товарных знаков и объектов авторского права, за исключением использования, явно оговоренного в лицензионном соглашении корпорации Майкрософт.

©Корпорация Майкрософт (Microsoft Corporation), 1996-2000. Все права защищены.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, Microsoft SQL Server, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Visual Studio, Win32, Windows 2000, Windows и Windows NT являются охраняемыми товарными знаками корпорации Майкрософт в США и других странах.

Названия прочих организаций и изделий являются товарными знаками их владельцев.

Версия: 8.00.000


(Untitled)

Данный раздел содержится в электронной документации SQL Server Books Online

©Корпорация Майкрософт (Microsoft Corporation), 1988-2000. Все права защищены.